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About the HP Unified Functional Testing User
Guide

TheHP Unified Functional Testing User Guide describes how to use UFT to test your applications.
It provides step-by-step instructions to help you create, debug, and run tests, and report defects
detected during the testing process.

Prerequisite Background
This guide is intended for UFT users at all levels. Readers should already have some understanding
of functional testing concepts and processes, and know which aspects of their application they
want to test.

UFT Guides and References
The following tables provide a list of the UFT guides, online help and references:

Note: To check for recent updates of any of the guides below, visit the HP Software Product
Manuals Web site (http://h20230.www2.hp.com/selfsolve/manuals).

Getting started

Reference Description

What's
New?

Describes the newest features in the latest version of Unified Functional Testing.

You can also access theWhat’s New from theUnified Functional Testing Help
menu.

Product
Movies

Click the link or select Help > Product Feature Movies to view short movies that
demonstrate themain product features.

Readme Provides last-minute news and information about Unified Functional Testing.

For the latest readme file, go to the HP SoftwareManuals Web site (requires an
HP Passport) at http://support.openview.hp.com/selfsolve/manuals.

UFT PAM The Product Availability Matrix (PAM) provides current information about
technologies and integrations supported for this version of UFT.

GUI Testing
Tutorial

TheGUI Testing Tutorial is a self-paced printable guide, designed to lead you
through the process of creating GUI tests and familiarize you with the testing
environment. 

API Testing
Tutorial

The API Testing Tutorial is a self-paced printable guide, designed to lead you
through the process of creating API tests in theWindows environment. 

HP Unified Functional Testing (12.00) Page 53 of 2274

http://h20230.www2.hp.com/selfsolve/manuals
https://hpln.hp.com/page/uft-120-videos
http://support.openview.hp.com/selfsolve/manuals


PDF guides

Guide Description

UFT User
Guide

The HP Unified Functional Testing User Guide describes how
to use UFT to test your applications. It provides step-by-step
instructions to help you create, debug, and run tests, and
report defects detected during the testing process.

Run Results
Viewer

The HP RunResults Viewer User Guide explains how to use
the Run Results Viewer to interpret and use the test results
from your GUI or API tests.

UFT
Installation
Guide

The HP Unified Functional Testing Installation Guide
provides a complete, step-by-step instructions on how to
install and set up UFT on a standalone computer.

UFT
QuickStart

The UFT Installation QuickStart Sheet explains the steps to
perform a basic installation of UFT.

License Server
Installation
Guide

The Concurrent License Server Installation Guide provides
the information you need to install andmaintain the
HP Functional Testing Concurrent License Server.

UFT Add-ins
Guide

The HP Unified Functional Testing Add-ins Guide explains
how to set up support for UFT add-ins and standardWindows
testing support. Add-ins enable you to test any supported
environment using GUI tests and business components.

References

Links to the references are available from the UFT online help home page.

Reference Description

Object Model
Reference

TheObject Model Reference for GUI Testing includes a description, a list of
methods and properties, syntax, examples, and identification properties for
each UFT test object.

VBScript
Reference

Microsoft's Visual Basic Scripting documentation that describes objects,
methods, properties, functions, and other elements that can be used when
writing VBScript scripts.

Automation
Object Model
Reference

List the objects, methods, and properties that enable you to control UFT from
within another application.
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Reference Description

Object
Repository
Automation
Reference

Describes the objects that enable you tomanipulate UFT shared object
repositories and their contents from outside of UFT.

Run Results
Schema
Reference

Provides details about the structure of the Run Results XML schema, and
describes the elements and attributes used in the its XML reports.

Test Object
Schema
Reference

A reference describing the elements and attributes available for creating test
object configuration XML content, for use when creating UFT extensibility
projects.

Object
Repository
Schema
Reference

Describes the elements and complex types defined for the object repository
schema.

Additional Online Resources
The following additional online resources are available from the Unified Functional Testing Help
menu:

Resource Description

HP Software
Support Online

Opens the HP Software Support Web site. This site enables you to browse
the HP Software Self-solve knowledge base. You can also post to and
search user discussion forums, submit support requests, download patches
and updated documentation, andmore. ChooseHelp > HP Software
Support. The URL for this Web site www.hp.com/go/hpsoftwaresupport.

l Most of the support areas require that you register as an HP Passport
user and sign in. Many also require a support contract.

l To findmore information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp

l To register for an HP Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html
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Resource Description

Testing Forums Opens the testing forums for GUI Testing, API Testing, and BPT Testing
forums. where you can interact with other users of UFT and discuss topics
related to GUI Testing, API Testing, and BPT.

The URLs for these sites are:

l GUI Testing: http://h30499.www3.hp.com/t5/Unified-Functional-
Testing/bd-p/sws-Fun_TEST_SF

l API Testing: http://h30499.www3.hp.com/t5/Service-Test-Support-and-
News/bd-p/sws-Serv_TEST_SF

l BPT: http://h30499.www3.hp.com/t5/Business-Process-Validation/bd-
p/sws-BPT_SF

UFT Product
Page

Opens the HP Unified Functional Testing product page, with information and
related links about UFT.

Troubleshooting
& Knowledge
Base

Opens the Troubleshooting page on the HP Software Support Web site
where you can search the HP Software Self-solve knowledge base. Choose
Help > Knowledge Base orHelp > Troubleshooting. The URL for the
troubleshootingWeb site is
http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software
Community

Opens the HP IT Experts Community site, where you can interact with other
HP software users, read articles and blogs on HP software and access
downloads of other software products.

HP Manuals Site Opens the HP Software Product Manuals Web site, where you can search
for themost up-to-date documentation for a selected HP Software product.
The URL for this Web site is
http://support.openview.hp.com/selfsolve/manuals (requires an HP
Passport).

What's New Opens the UFTWhat's New Help, describing the new features and
enhancements in this version of UFT.

Product Movies Opens a page on HPLN (HP Live Networks) displaying a list of all product
movies.

HP Software
Web site

Opens the HP SoftwareWeb site. This site provides you with themost up-
to-date information on HP Software products. This includes new software
releases, seminars and trade shows, customer support, andmore. The URL
for this Web site is www.hp.com/go/software.

You can access the following sample applications from theStartmenu. These applications are the
basis for many examples in this guide:

User Guide
About the HP Unified Functional Testing User Guide

HP Unified Functional Testing (12.00) Page 56 of 2274

http://h30499.www3.hp.com/t5/Unified-Functional-Testing/bd-p/sws-Fun_TEST_SF
http://h30499.www3.hp.com/t5/Service-Test-Support-and-News/bd-p/sws-Serv_TEST_SF
http://h30499.www3.hp.com/t5/Business-Process-Validation/bd-p/sws-BPT_SF
http://h20230.www2.hp.com/troubleshooting.jsp
http://support.openview.hp.com/selfsolve/manuals
http://www.hp.com/go/software


l Mercury Tours sampleWeb site. The URL for this Web site is http://newtours.demoaut.com.

l Mercury Flight application. To access from the Start menu, select All Programs > HP
Software > HP Unified Functional Testing > Sample Applications > Flight API / Flight
GUI.
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Chapter 1: UFT Introduction
Relevant for: GUI testing and API testing

This chapter includes:

HP Unified Functional Testing Overview 61

UFT GUI Testing - Overview 62

GUI TestingWorkflow 63

Additional GUI Testing Capabilities and Tools 67

UFT API Testing - Overview 69

UFT Integrated Testing - Overview 70

Business Process Testing in UFT - Overview 72

UFT ProgramManagement 73

Licensing 73

Access Permissions 73

DemoApplication(s) 75
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HP Unified Functional Testing Overview
Relevant for: GUI testing and API testing

Welcome to HP Unified Functional Testing (UFT), the advanced solution for functional test and
regression test automation, combined with functional testing for headless systems.

UFT's combined solution for GUI and API (service) testing enables you to test functionality across
multiple application layers, such as the front-endGUI layer as well as back-end service layers.
Additionally, the integrated BPT features enable a wider range of both technical and non-technical
UFT users, maximizing your opportunity to create comprehensive automated tests.

UFT helps you to cut time-to-market by starting automated functional testing earlier in your
process. You can also streamline your tools, cutting costs on both training and licenses.

UFT provides you with an integrated system for the followingmain services:

l "UFT GUI Testing - Overview" on the next page

l "UFT API Testing - Overview" on page 69

l "Business Process Testing in UFT - Overview" on page 72

You can also integrate GUI testing and API testing in a single test, calling tests of one type from the
other, as described in "UFT Integrated Testing - Overview" on page 70.

Note: UFT supports creating andmanaging tests and components, for both GUI testing and
API testing. Some sections of this help are relevant only for certain types of UFT functionality,
such as tests, GUI tests and components, or actions. Each section of the help is marked with
the relevant area of functionality.

Accessibility
Many operations are performed using themouse. In accordance with Section 508 of theW3C
accessibility standards, UFT also recognizes operations performed using theMouseKeys option in
theWindows Accessibility Options utility. Additionally, you can perform many operations using
shortcut keys.

Unicode Compliancy

Unified Functional Testing is Unicode compliant according to the requirements of the
Unicode standard (http://www.unicode.org/standard/standard.html), enabling you to test
applications in many international languages. Unicode represents the required characters using 8-
bit or 16-bit code values. This allows processing and display of many diverse languages and
character sets. You can test non-English language applications, as long as the relevant Windows
language support is installed on the computer on which UFT is installed (Start > Settings >
Control Panel > Regional Options or similar). For additional information on Unicode andmulti-
lingual support issues, see the"Troubleshooting and Limitations - Multilingual Applications in GUI
Testing" section in the online Help.
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UFT GUI Testing - Overview
Relevant for: GUI tests and components

UFT's GUI testing solution deploys the concept of keyword-driven testing to enhance test creation
andmaintenance.

Keyword-driven testing is a technique that separates much of the programming work from the
actual test steps. This enables you to create test steps earlier, andmaintain them with only minor
updates, even when there are significant changes in your application or your testing needs.

l Using the keyword-driven approach, test automation experts have full access to the underlying
test and object properties, via an integrated scripting and debugging environment that is round-
trip synchronized with the Keyword View.

l Advanced testers who are familiar with VBScript can also use the Editor, which enables you to
add and update statements that enhance your test with programming. Use the Editor to increase
the test's power and flexibility.

l UFT also provides add-ins that enable you to test objects (controls) created in commonly used
development environments.

For more details about supported functionality for GUI tests, see "Additional GUI Testing
Capabilities and Tools" on page 67.

Basic GUI Test Structure

l A test is comprised of calls to actions. Actions help divide your test into logical units, such as
themain sections of aWeb site, or specific activities that you perform in your application. By
creating tests that call multiple actions, you can design tests that aremoremodular and
efficient.

l Each action is comprised of steps. As you add steps to an action, they are displayed in the UFT
window, either as part of the Keyword View or the Editor. In the Keyword View, every step
includes automatically generated documentation that provides a plain language textual
description of what the step does.

l When you perform a run session, UFT performs each action in your test. After the run session
ends, you can view a report detailing which steps were performed, and which ones succeeded or
failed.

Creating and Enhancing Your GUI Test

l While editing the actions in your test, you can insert a step that checks the properties of specific
objects in your application. For example, you can check that a specific text string is displayed in
a particular location in a dialog box, or you can check that a hypertext link on yourWeb page
goes to the correct URL address.

l You can also create function libraries and call their functions from your test. For example, you
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can define functions and use them as keywords in your test.

For details about the steps in the GUI testing process, see "GUI TestingWorkflow" below.

GUI Testing Workflow
Relevant for: GUI tests and components

This section describes the general workflow of the GUI testing process, which involves the
followingmain stages:

l "Stage 1: Analyzing Your Application" below

l "Stage 2: Preparing the Testing Infrastructure" below

l "Stage 3: Adding Steps to Your Actions" on the next page

l "Stage 4: Enhancing Your Test" on page 65

l "Stage 5: Running and Debugging Your Test" on page 65

l "Stage 6: Analyzing Run Results and Reporting Defects" on page 66

Stage 1: Analyzing Your Application
Before you begin creating a test, you need to analyze your application and determine your testing
needs. You need to:

l Determine the development environments in which your application controls were
developed. Development environments might includeWeb, Java, or .NET, and so on. You
must load the required UFT add-ins when you open UFT, and before creating your test.

l Determine the functionality that you want to test. To do this, you consider the various
activities that customers perform in your application to accomplish specific tasks. Which
objects and operations are relevant for the set of business processes that need to be tested?
Which operations require customized keywords to provide additional functionality?

l Decide how to divide these processes into smaller units that will be represented by
your test's actions. Each action should emulate an activity that a customermight perform
when using your application.

As you plan, try to keep the amount of steps you plan to include in each action to aminimum.
Creating small, modular actions helps make your tests easier to read, follow, andmaintain.

Stage 2: Preparing the Testing Infrastructure
To complete the infrastructure that is part of the planning process, you need to do the following:

l Build the set of resources to be used by your tests. Resources can include shared object
repositories containing test objects (which are representations of the objects in your application),
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function libraries containing functions that enhance testing functionality, and so on.

For details, see "Managing Test Objects in Object Repositories" on page 1198 and "User-
Defined Functions and Function Libraries" on page 1029.

l Configure UFT according to your testing needs. This can include setting up your global
testing preferences, your run session preferences, any test-specific preferences, and recovery
scenarios. You can also create automation scripts that automatically set the required
configurations (such as the add-ins to load) on the UFT client at the beginning of a run session.

For details, see "UFT Automation Scripts" on page 1155.

l Create one or more tests that serve as action repository tests. You can create an action
repository test to store reusable actions to be used in your tests. Generally, you create an action
repository test for each area of your application to be tested. Storing all of your actions in
specific tests enables you tomaintain your actions in a central location.

You then associate the shared object repositories with the relevant actions. This enables you to
insert steps into the actions using the objects stored in the object repositories.

When you create your tests, you insert calls to one or more of the actions stored in this
repository. When you update an action in the action repository, the update is reflected in all tests
that contain a call to that action. When you run a test, only the relevant action repository tests
are loaded.

Stage 3: Adding Steps to Your Actions
In this stage, you add steps to the actions in your action repository test.

Note: Before you begin adding steps, make sure that you associate your function libraries and
recovery scenarios with the repository test, so that you can insert steps using keywords.

You can create steps using the keyword-driven functionality available in the table-like, graphical
Keyword View—or you can use the Editor, if you prefer to program steps directly in VBScript. You
can also add steps to your test using the following additional methods:

l Drag objects. Drag objects from your object repository or from the Toolbox pane to add
keyword-driven steps in the Keyword View or Editor. The object repository and Toolbox pane
contain all of the objects that you want to test in your application.

When you drag an object into the Keyword View, a step is created in the action with the default
operation for that object. For example, if you drag a button object into the Keyword View, the
Click operation is automatically defined for the step. You can thenmodify the step as needed.
For more details, see "Keyword View" on page 919 and "Toolbox Pane User Interface (GUI
Testing)" on page 510.

Advanced users can also add steps using the Editor, as described in "Programming in GUI
Testing Documents in the Editor" on page 994.
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l Record on your application. As you navigate through your application during a recording
session, each step you perform is displayed as a row in the Keyword View. A step is something
that causes or makes a change in your application, such as clicking a link or image, or
submitting a data form. In the Editor, these steps are displayed as lines in a test script
(VBScript). The Documentation column of the Keyword View displays a description of each step
in easy-to-understand sentences. For more details, see "Keyword View" on page 919.

Stage 4: Enhancing Your Test
You can enhance the testing process by modifying your test with special testing options and/or with
programming statements. For example:

l Insert checkpoints and output values into your test. A checkpoint checks specific
properties or other characteristics of an object and enables you to identify whether or not your
application is functioning correctly. For details, see "Checkpoints Overview" on page 1396.

l Use output values to extract data from your test. An output value is a value retrieved during
the run session and entered into your data table or stored in a variable or a parameter. You can
subsequently use this output value as input data in your test. This enables you to use data
retrieved during a run session in other parts of the test. For details, see "Output Values
Overview" on page 1488.

l Replace fixed values with parameters to broaden the scope of your test.When you test
your application, you can parameterize your steps to check how your application performs the
same operations with different data. Youmay supply data in the data table, define environment
variables and values, define test or action parameters and values, or insert a step that generates
random numbers for current user and test data. For details, see "Parameterizing Object Values"
on page 1526.

l Add user-defined functions by creating function libraries and calling their functions
from your test. Function libraries contain VBScript functions, subroutines, statements, and so
on. You can call functions from your test, or use functions as operations in your test or
component. For details, see "User-Defined Functions and Function Libraries" on page 1029.

l For complex testing goals:Use other UFT features to enhance your test, and/or programming
statements. For details, see "Generated ProgrammingOperations" on page 968.

Stage 5: Running and Debugging Your Test
After you create your test, you can perform different types of runs to achieve different goals.

l Debug the test. You can control your run session to help you identify and eliminate defects in
your test, as follows:

n Use theStep Into, Step Over, andStep Out commands to run your test step by step.

n Begin your run session from a specific step in your test, or run the test until a specific step is
reached.

n Set breakpoints to pause your test at predetermined points. You can view or change the value
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of variables in your test each time it stops at a breakpoint in the Debug Viewer.

n Manually run VBScript commands in the Debug Viewer.

For more details, see "Debugging Tests and Components" on page 674.

l Test your application. The test starts running from the first line in your test and stops at the
end of the test.

While running, UFT connects to your application and performs each operation in your test,
including any checkpoints, such as checking text strings, objects, tables, and so forth.

If you parameterized your test with data table parameters, the test (or specific actions in your
test) repeats for each set of data values in the data table.

For more details, see "Running Tests and Components" on page 634.

l Update your test. If you know that your application has changed, run your test in one of the
followingmodes to update your test accordingly:

n Maintenance Run Mode. Use this mode if you expect that UFT will not be able to identify
the objects in your test. As your test runs, UFT opens a wizard for each object that cannot be
found in the application, to guide you through resolving each issue. When the object can be
identified and the issue is resolved, the run continues.

n Update Run Mode. Use this mode to update the any of the following:

o Property sets used for test object descriptions

o Expected checkpoint values

o Data available to retrieve in output values

o Active Screen images and values

For more details, see "Maintaining and Updating GUI Tests or Components " on page 1078.

Stage 6: Analyzing Run Results and Reporting Defects
After you run your test, you can view the results of the run in the Run Results Viewer, including both
a summary and a detailed report, and you can report defects detected during the run session.

l View still images or movies. If you captured still images or movies of your application during
the run, you can view these from the Screen Recorder tab of the Run Results Viewer.

l Local system monitoring. If you enabled local systemmonitoring for your test, you can view
the results in the SystemMonitor tab of the Run Results Viewer.

l Report defects in ALM. If you have access to ALM, the HP centralized quality solution, you
can report the defects you discover to the project database.
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l Report defects automatically or manually. You can add steps to your test that automatically
report each failed step in your test, or you can report themmanually from the Run Results
Viewer.

For details about run results, see theHP RunResults Viewer User Guide. For details about defect
reporting, see "ALM Integration" on page 707.

Additional GUI Testing Capabilities and Tools
Relevant for: GUI tests and components

The following sections describe additional UFT functionality for GUI tests:

l "Testing Objects from Different Environments" on the next page

l "Programming in the Editor " on the next page
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l "Functions and Function Libraries" below

Testing Objects from Different Environments
When you open UFT, you can load environment-specific UFT add-ins, such as Java, .NET, and
Web.

l Loading the relevant add-in enables UFT to recognize and learn the objects in your application so
that you can design automated tests that mirror your customer's operations and business
processes. You can then run these tests to check that your application works as expected.

l You load add-ins using the Add-in Manager dialog box described in "How to Start UFT" on page
114. For details on the on the Add-in Manager dialog box and each of the UFT add-in
environments, see theHP Unified Functional Testing Add-ins Guide.

Programming in the Editor
The Editor displays a text-based version of your action.

The test is composed of statements written in VBScript (Microsoft Visual Basic Scripting Edition)
that correspond to the steps and checks displayed in the Keyword View. You canmove between
the two views by selecting the Editor / Keyword View toggle button. For details, see "Programming
in GUI Testing Documents in the Editor" on page 994.

For more details on the test objects andmethods available for use in your test and how to program
using VBScript, see theHP UFT Object Model Reference for GUI Testing and theVBScript
Reference (select Help > HP Unified Functional Testing Help).

Functions and Function Libraries
If you have sets of steps that are repeated in several actions or tests, youmay want to consider
creating and using user-defined functions.

l A user-defined function encapsulates an activity (or a group of steps that require programming)
into a keyword, also called an operation. User-defined functions help shorten your tests, and
make them easier to design, read, andmaintain.

l You can use the built-in Editor view to create and edit user-defined functions during your
session. A function library is a Visual Basic script containing VBscript functions, subroutines,
modules, and so forth. You can also use the Function Definition Generator to assist you in
defining new functions.

l When you create a function, you can insert it directly in an action tomake it available only within
that action, or you can insert it in a function library to make it available to any test that is
associated with that function library. For details, see "User-Defined Functions and Function
Libraries" on page 1029.
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UFT API Testing - Overview
Relevant for: API tests

UFT's API (service) testing solution provides tools for the construction and execution of functional
tests for headless (GUI-less) systems. For example, you can use UFT to test standardWeb
Services, non-SOAPWeb Services, such as REST, and so on.

You create an API test by dragging and dropping activities from the UFT Toolbox pane into the test,
displayed in the canvas. The toolbox provides a collection of activities for functional testing in areas
such as REST, Web Services, JMS, and HTTP. You can addmore activities to the toolbox by
importingWSDLs or providing other contract definitions.

For more details about service (API) testing in UFT, including all of the optional steps included in
the testing workflow, see "API Test Creation Overview" on page 1589.
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UFT Integrated Testing - Overview
Relevant for: GUI testing and API testing

Integration for GUI and API Testing
You can integrate your GUI and service testing processes in a single test by including calls from
your GUI test to API tests, or from your API tests to GUI tests. When you insert a call to another
test, the call is displayed as nested under the relevant action in the canvas.

l You insert andmodify calls to API tests from GUI tests using the "Call to API Test/Action
Dialog Box" described on page 1075. For details, see "Integration with API Tests" on page 1067.

l You insert andmodify calls to GUI tests from API tests by dragging the Call GUI Action or Test
onto the canvas from the HP Automated Testing Tools node in the Toolbox pane. For more
details, see "How to Call External Tests or Actions" on page 1639.

Integration with ALM
You can also use UFT together with ALMtomanage the entire testing process. For example, you
can use ALM to:

l Create a project (central repository) of manual and automated tests

l Build test cycles

l Run tests

l Report and track defects

You can also create reports and graphs to help you review the progress of test planning, runs, and
defect tracking before a software release.

Tests and components created in UFT can be saved directly to your ALM project, and you can run
UFT tests and review andmanage the results in ALM. For details see "ALM Integration" on page
707, and theHP Application Lifecycle Management User Guide.

Note: Unless otherwise specified, references toApplication Lifecycle Management orALM
in this guide apply to all currently supported versions of ALM andQuality Center. Note that
some features and options may not be supported in the specific edition of ALM or Quality
Center that you are using.

For a list of the supported versions of ALM or Quality Center, see theHP Unified Functional
Testing Product Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD. Themost up-to-date product availability matrix is available from the
HP Software Product Manuals site, at http://h20230.www2.hp.com/selfsolve/manuals
(requires an HP Passport).
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For details on ALM or Quality Center editions, see theHP Application Lifecycle Management
User Guide or theHP Quality Center User Guide.
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Business Process Testing in UFT - Overview
Relevant for: business process tests and flows

Business Process Testing (BPT) works within UFT or ALM as a component-based testing
framework. Working with a testing framework provides many advantages to enterprises, including
streamlining the creation andmaintenance of bothmanual and automated tests, andmaximizing
efficiency for testing complete business processes.

Business components:

l Enable structured automated testing.

l Reduce the duplication of effort when combiningmanual tests with automatic tests.

l Enable component reusability to speed-up the automation process.

l Provide the ability to pass parameters from one step to another within your business process.
You can save the output of a step to a parameter and use it as an input value for subsequent
steps.

l Simplify on-going test maintenance.

l Minimizes time-to-test.

"Business Process Testing in UFT" on page 2062 describes how to use BPT in UFT, including how
tomaintain business process tests and flows, business components, and application areas in UFT.
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UFT Program Management
The following sections describe how you canmanage your UFT program, including available
licenses and access levels.

To check for software updates, patches, or service packs for UFT, visit the HP Software Support
Site. TheHP Update program does not provide updates for UFT.

Licensing
Working with UFT requires a license. When you install UFT, you select one of the following license
types:

l A permanent seat license that is specific to the computer on which it is installed (includes a 30-
day demo license)

l A network-based concurrent license that can be used by multiple UFT users

You can change your license type at any time (as long as you are logged in with administrator
permissions on your computer). For example, if you are currently working with a seat license, you
can choose to connect to a concurrent license server, if one is available on your network.

For information onmodifying your license information, see theHP Unified Functional Testing
Installation Guide.

Note: You can also open UFT using a legacy license, although the functionality will be limited
to the service that you are licensed to use. For example, you can open UFT using a legacy
QuickTest Professional or Service Test license and access GUI testing or API testing
functionality.

Access Permissions
Youmust make sure the following access permissions are set to run UFT or to work with ALM.

Permissions Required When Working with UFT
Youmust have the following file system permissions:

l Full read and write permissions to the Temp folder

l Read permissions to theWindows folder and to the System folder

l Full read and write permissions to the folder on which you are saving solutions, tests, or run
results

l Full read and write permissions to the <Program Files>\Common Files\Mercury Interactive
folder
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l If you are working on theWindows Vista, Windows 7, orWindows Server 2008 operating
systems: Full read and write permissions to the <Program Data>\HP folder

l Full read and write permissions to the User Profile folders

l Full read and write permissions to the <Windows>\mercury.ini file

l Full read and write permissions to the followingAppData folders:

n %userprofile%\AppData\Local\HP

n %appdata%\Hewlett-Packard\UFT

n %appdata%\HP\API Testing

Note: Read/write permissions to these folders should also enable permission to any
subfolders contained in the folders listed above. If not, the system administrator must
grant administrative permissions to the subfolders contained in these folders.

Youmust have the following registry key permissions:

l Full read and write permissions to the keys uderHKEY_CURRENT_
USER\Software\Mercury Interactive or [HKEY_LOCAL_
MACHINE\SOFTWARE\Wow6432Node\Hewlett-Packard]

l Full read and write permissions to all the keys underHKEY_CURRENT_
USER\SOFTWARE\Hewlett Packard

l Read andQuery Value permissions to all theHKEY_LOCAL_MACHINE andHKEY_
CLASSES_ROOT keys

Permissions Required When Working with ALM
Youmust have the following permissions to use UFT with ALM:

l Full read and write permissions to the ALM cache folder

l Full read and write permissions to the <Program Data>\HP folder

l Full read and write permissions to the UFT Add-in for ALM installation folder

l Administrative permissions for the first connection to ALM

Note: If you do not have administrative permissions, you can turn off the UAC for your user
account instead in order to perform the first connection to ALM.

Permissions Required When Working with BPT
The ALM Project Administrator can control access to a project by defining which users can log in to
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it and by specifying the types of tasks each user may perform. The ALM Project Administrator can
assign permissions for adding, modifying, and deleting folders, components, steps, and parameters
in the Business Components module of an ALM project.

You need tomake sure you have the required ALM permissions before working with business
components and application areas.

l Towork with component steps in ALM, youmust have the appropriateAdd Step,Modify Step,
orDelete Step permissions set. You do not needModify Component permission to work with
component steps. TheModify Component permission enables you to work with component
properties (the fields in the component Details tab).

l Towork with parameters in ALM or in a testing tool, youmust have all the parameter task
permissions set in ALM.

l Tomodify application areas, youmust have the separate permissions for resources required for
modifying components, and adding, modifying, and deleting steps. All four permissions are
required. If one of these permissions is not assigned, you can open application areas only in
read-only format.

For more information on setting user group permissions in the Business Components module, see
theHP Business Process Testing User Guide.

Demo Application(s)
Many examples in this guide use theMercury Tours sampleWeb site. The URL for this Web site is:
http://newtours.demoaut.com.

Note that youmust register a user name and password to use this site.

A sample Flight Windows-based application is also provided with the UFT installation. You can
access it from Start > Programs > HP Software > HP Unified Functional Testing > Sample
Applications > Flight API or Flight GUI.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" below.

Accessing UFT in Windows 8 Operating Systems
UFT applications and files that were accessible from theStartmenu in previous versions of
Windows are accessible inWindows 8 from theStart screen or theApps screen.

l Applications (.exe files). You can access UFT applications inWindows 8 directly from the
Start screen. For example, to start UFT, double-click theHP Unified Functional Testing

shortcut .
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Other examples of applications accessible from theStart screen include:

n The RunResults Viewer

n All UFT tools, such as the Password Encoder and the License Validation Utility

n The API testing sample Flight applications

l Non-program files. You can access documentation and the link to theMercury Tours Website
from theApps screen.

Note: By default, the Start and Apps screens onWindows 8 are set to open Internet Explorer in
MetroMode. However, if User Account Control is turned off on your computer, Windows 8 will
not open Internet Explorer in Metromode. Therefore, if you try to open an HTML shortcut from
the Start or Apps screen, such as the UFT Help or Readme file, an error will be displayed.

To solve this, you can change the default behavior of Internet Explorer so that it never opens in
Metromode. In the Internet Properties dialog box > Programs tab, select Always in Internet
Explorer on the desktop for the in theChoose how you open links option. For more
details, see http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-explorer-10-on-
windows-8.aspx.
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Chapter 2: UFT at a Glance
Relevant for: GUI tests and components and API testing
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Concepts

UFT at a Glance - Introduction
Relevant for: GUI tests and components and API testing

UFT provides a unified solution to test your application, combining the ability to test the user
interface of your application (throughGUI testing) and the non-GUI sections of your application
(through API testing).

You can create a test of your application from start to finish, or you can test sections of it through
the creation of individual actions or components to test each process in your application or
application sections. You can then combine the individual process testing scenarios into a test (for
actions) or a business process test or flow (for components).

UFT also works with ALM, HP's centralized quality control solution. You can save tests,
components, function libraries and application areas with your ALM project andmake them
available to multiple users and testing projects.

UFT Main Window Overview
Relevant for: GUI testing, API testing, and Business Process Testing

Themain window in UFT provides multiple areas to design, edit, debug, and run testing documents.
The following table introduces the key elements in the UFT window:

Element Description

"Start
Page"

Welcomes you to UFT. You can use the shortcut buttons to open new and existing
documents.

For details, see "Start Page" on page 121.

Document
Pane

Themain area to design and edit testing documents.

l Canvas. Visually displays the test flow as a series of actions (for GUI tests) or
steps (for API tests). For details, see "The Canvas" on page 209.

l Editor. Displays each test step as a line of code and enables you to create GUI
actions or function libraries with VBScript code or API user code using C# code.
For details, see "Editor at a Glance" on page 82.

l Keyword View (GUI testing only). Displays each step and the object
hierarchy in amodular, icon-based table and enables you to create test steps
using a keywordmethodology. For details, see "Keyword View Overview" on
page 921.

For details on the different types of documents used in UFT, see "Editor at a
Glance" on page 82.
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Element Description

"UFT
Panes at a
Glance"

Provide information and functionality about the current test, business component,
function library or application area.

For details, see "UFT Panes at a Glance" on page 94.

The image below shows the UFTmain window when aGUI test is open.
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The image below shows the UFTmain window when an API test is open.

For details about the key areas displayed in themain window, as well as details about other types
of UFT documents, see the Glance subsections in the remainder of this chapter.

Canvas at a Glance

Relevant for: GUI tests only and API testing

The canvas provides a visual representation of the test flow.

For GUI testing: The canvas displays a flow of the action calls found within a test, including calls
to copies of actions or calls to existing actions. You can double-click each action to open the action
as a separate, editable document tab.

For API testing: The canvas displays a flow of the steps found within a test, including parameter
links between steps. You add steps to the canvas by dragging them from the Toolbox pane.
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The image below shows the canvas for aGUI test.
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The image below shows the canvas for anAPI test.

For details on the canvas, see "The Canvas" on page 209.

Editor at a Glance

Relevant for: GUI tests, scripted GUI components, function libraries, and user code files

The Editor displays test steps as lines of code and enables you to add steps to a document or user
code file using VBScript code (for GUI tests and components) or C# code (for API tests and
components).

For GUI testing: In the Editor, UFT displays each operation performed on your application in the
form of a script, comprised of VBScript statements. For each object andmethod in an Editor
statement, a corresponding row exists in the Keyword View.

For API testing: The Editor enables you to write customized user code forAPI tests run during test
steps or to write custom code which defines the properties and behavior of different test steps.

The image below shows the Editor forGUI testing.
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The image below shows the Editor (open to an event handler) forAPI testing.

For details on using the Editor, see "Editing Text and Code Documents" on page 305.

Keyword View at a Glance

Relevant for: GUI tests and keyword GUI components

The Keyword View enables you to create and view the steps of your GUI test or component in a
keyword-driven, modular, table format. The Keyword View is comprised of a table-like view, in
which each step is a separate row in the table, and each column represents different parts of the
steps. You canmodify the columns displayed to suit your requirements.
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You create andmodify GUI tests or components by selecting items and operations in the Keyword
View and entering information as required. Each step is automatically documented as you complete
it, enabling you to view a description of your test steps in understandable English.

Each operation performed on your application during a recording session is recorded as a row in the
Keyword View.

For each row in the Keyword View, UFT displays a corresponding line of script in the Editor. If you
focus on a specific step in the Keyword View and switch to the Editor, the cursor is located in that
corresponding line of the test.

For details on using the Keyword View, see "Keyword View" on page 919.

UFT Testing Documents
Relevant for: GUI testing and API testing

In UFT, you can create, edit, debug, and run a variety of testing documents. The following
document types are available in UFT:

Document Description

GUI Test
(GUI
testing
only)

Tests your application's user interface using actions, steps, and resources.

For details, see "GUI Test Creation Overview" on page 812.

API Test Tests your application's non-GUI, service-based functions.

For details, see "UFT API Testing Overview" on page 1590.
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Document Description

Keyword
GUI
Component
(GUI
testing
only)

Tests sections of your application as a business component using keywords and
operations.

For details, see "Keyword GUI Components Overview" on page 2084.

Scripted
GUI
Component
(GUI
testing
only)

Tests a section of your application as business component using script
commands in the Editor or keywords in the Keyword View.

For details, see "Scripted GUI Components Overview" on page 2085.

API
Component

Creates a business component similar to an API test. Certain limitations apply to
API components.

For details about API testing, see"UFT API Testing Overview" on page 1590. For
details about exceptions when working with API components, see "Working with
API components" on page 2079.

Business
Process
Tests

Tests your application by combiningmultiple components into a test with an ALM
project.

For details, see "Business Process Testing in UFT - Overview" on page 2065.

Business
Process
Flows

Creates a test flow of multiple components to test a specific order of steps in your
application with an ALM project.

For details, see "Business Process Testing in UFT - Overview" on page 2065.

Application
Area
(GUI
testing
only)

Creates a resource area for your application by defining resources and settings for
the component testing a specific section of your application.

For details, see "Application Areas - Overview" on page 2096.

Function
Library
(GUI
testing
only)

Creates a document containing functions and subroutines to use with your GUI
test or component.

For details, see "Function Library Overview" on page 1030.

User Code
Files
(API testing
only)

Creates a document containing functions or classes to use with yourAPI test or
component.

For details, see "Writing Code for API Test Events - Overview" on page 1938.
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GUI Tests at a Glance

Relevant for: GUI tests only

GUI tests enable you to test user interface elements in your application. You can design tests with
a keyword-driven approach through the Keyword View or by writing VBScript test scripts in the
Editor. Each test is comprised of single or multiple calls to actions, which each contain individual
test steps. After building your test, UFT runs each step individually and reports which steps were
performed, as well as which steps succeeded or failed.

The image below shows aGUI test displaying the canvas tab. Each action is also displayed as its
own editable tab.

For details, see "Methodologies for Creating Tests" on page 813.

API Tests at a Glance

Relevant for: API tests

API tests enable you to test your GUI-less applications (also called headless applications) or the
sections of your application which lack user interface elements. You can use an API test to test a
connection to aWeb Service or database, the ability of your application to upload or download a
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specific file or string from the file system or information database, and similar application
background services. Using the Toolbox pane, you drag various API service activities onto the
canvas to create a test. After compiling the test, UFT runs each step individually and reports which
steps were performed as well as which steps succeeded or failed.

The image below shows an API test canvas.

For details, see "UFT API Testing Overview" on page 1590.

Business Process Tests at a Glance

Relevant for: business process tests

Business process tests enable you to create a scenario that contains a sequence of business
components or flows to test a specific business process in your application. You can group flows
and/or components together to run them for a specific number of iterations, and to use parameters
for an entire group.

Note: The first time that you open a business process test or flow from UFT, youmust connect
to ALM as a user with administrator privileges on the computer on which you are connecting.
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The image below shows a business process test, as well as the components and flows available to
the test, iteration data for the selected component in the test, and test properties.

For details, see "Business Process Testing in UFT" on page 2062.

Business Process Testing Flows at a Glance

Relevant for: business process flows

Business process flows enable you create a logical set of business components in a fixed
sequence to perform a specific business task, and can be added to business process tests to run
as a unit.

Note: The first time that you open a business process test or flow from UFT, youmust connect
to ALM as a user with administrator privileges on the computer on which you are connecting.

The image below shows a business process flow selected in the Solution Explorer and displayed in
the document pane, as well iteration data for the selected component in the test, and the flow's test
properties.
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For details, see "Business Process Testing in UFT" on page 2062.
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Keyword GUI Components at a Glance

Relevant for: Keyword GUI components only

Keyword GUI components enable you to test a specific area of your application using a keyword-
driven format in the Keyword View. Each component consists of steps divided in amodular format
that are automatically documented as they are completed. You can also add user-defined functions
to your keyword component to specify a specific function or operation to perform. Keyword GUI
components are saved with your ALM project, making them available for other testing projects and
resources.

For details, see "Keyword GUI Components Overview" on page 2084.

User Guide
Chapter 2: UFT at a Glance

HP Unified Functional Testing (12.00) Page 90 of 2274



Scripted GUI Components at a Glance

Relevant for: Scripted GUI components only

Scripted GUI components enable you to create components using the full functionality of both the
Keyword View and Editor and the tools associated with these views. Scripted GUI components
also enable you to usemore complex functionality into your component through the addition of
VBScript and other programming statement steps in addition to keyword-driven steps. Scripted GUI
components are saved with your ALM project, making them available for other testing projects and
resources.

For details, see "Scripted GUI Components Overview" on page 2085.
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Application Areas at a Glance

Relevant for: GUI components only

Each business component is based on an application area that provides it with settings and links to
specific resource files, such as function library files, shared object repositories (that contain the test
objects used by the application), and recovery scenario files. You definemost of these assets in the
application area. Associated add-ins and other general settings are defined in the Properties pane.

The application area contains a number of panes that are accessed by the buttons in the left
sidebar:

Pane Description

Function
Libraries

Displays the associated function libraries and enables you to associate
additional function libraries with this application area and to prioritize them.

Object
Repositories

Displays the associated object repositories and enables you to associate shared
object repositories with this application area and to prioritize them.

Keywords Enables you to set the keywords that are available to this application area and to
view their individual properties.

Additional
Settings

Enables you to specify settings for the applications used in designing an
application area, recovery scenarios for the application area, and log tracking and
systemmonitoring preferences.
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For details, see "Application Areas" on page 2095 and "General Properties Tab (Properties Pane for
Application Areas)" on page 391

Function Libraries at a Glance

Relevant for: GUI tests and components

Function libraries enable you to create user-defined functions that you can associate with and can
call in a test or component. Each function library is a separate document containing VBscript
functions, subroutines, classes, modules, and so on. Function libraries use the same editing and
debugging features that are available in the Editor.

For details, see "User-Defined Functions and Function Libraries" on page 1029.

User Code Files at a Glance

Relevant for: API testing only

User code files enable you to create user-defined events (in the TestUserCode.cs file) to run as part
of your test steps or user-defined classes that a test calls during a run session. The
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TestUserCode.cs file contains all events created as part of a test. Other user code files are
separate documents containing all the code needed during the test session.

For details, see "Writing Code for API Test Events - Overview" on page 1938.

UFT Panes at a Glance
Relevant for: GUI tests and components and API testing

The following sections describe the available UFT panes:

Active Screen Pane at a Glance 95

Bookmarks Pane at a Glance 95

Data Pane at a Glance 96

Errors Pane at a Glance 98

Debug Panes at a Glance 99

Output Pane at a Glance 102

Properties Pane at a Glance 103

Solution Explorer Pane at a Glance 106
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Search Results Pane at a Glance 108

Tasks Pane at a Glance 109

Toolbox Pane at a Glance 110

Active Screen Pane at a Glance

Relevant for: GUI tests and scripted GUI components

The Active Screen provides a snapshot of your application as it appeared when you performed a
certain step during a recording session. Additionally, depending on the Active Screen capture
options that you used while recording, the page displayed in the Active Screen can contain detailed
property information about each object displayed on the page.

To view the Active Screen, select View > Active Screen.

For details, see "Active Screen Pane" on page 193.

Bookmarks Pane at a Glance

Relevant for: GUI tests scripted GUI components, function libraries, and user code files

The Bookmarks pane displays all bookmarks inserted into your tests, component, function libraries,
or user code files. The pane enables you to create bookmarks, view the information about inserted
bookmarks, and navigate to the document containing the bookmark.

To view the Bookmarks pane, select View > Bookmarks.
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For details, see "Bookmarks Overview" on page 204.

Data Pane at a Glance

Relevant for: GUI tests and components, API testing, and business process testing

The Data pane displays the relevant data for your test or component, or business process testing
flow. It's a spreadsheet-like table with columns and rows representing the data applicable to your
document, and assists you in parameterizing that data.

For GUI testing: The Data displays aGlobal tab showing the data relevant to the entire test, and
separate tabs for each action contained within the test.

For API testing: The Data pane can display data from a local data table, an Excel spreadsheet, a
database connection, or an XML file.

For business process testing: The Data pane displays iteration data related to the selected
component, enables you to link iteration parameter data to other parameter values in your test or
flow, as well as promote component parameters to test or flow parameters.

To view the Data pane, select View > Data.

The image below shows the Data pane for GUI testing.
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The image below shows the Data pane for API testing.

The image below shows the Data pane for business process testing.

For details about the Data pane, see "Data PaneOverview" on page 222.
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Errors Pane at a Glance

Relevant for: GUI tests and components and API testing

The Errors pane provides a list of missing resources and coding syntax errors from your test. If the
pane is not currently displayed, UFT automatically opens it when an error is detected. You can
double-click an error to locate in the error in your test or component.

Missing resources are the resources that are specified in your test or component but cannot be
found. Information errors provide a list of coding syntax errors in your test or function library scripts.

For GUI testing: Missing resources for GUI tests or components can include calls to missing
actions, missing function libraries, missing recovery scenarios, missing environment variable XML
files, unmapped shared object repositories, and parameters that are connected to shared object
repositories. Each time you open your test, component, or application area, UFT automatically
checks that all specified resources are accessible. If it finds any resources that are not accessible,
UFT lists them in the Errors pane.

In addition, when you create VBScript for your test or components steps, UFT automatically
checks for VBScript syntax errors in your script, and shows them in the Errors pane.

For API testing: Missing resources listed in this pane aremissing resource files, such as
references called by the test during a run session or user functions or objects called by a test.

The pane also displays coding syntax errors or individual step property errors. If there is a coding
syntax error in a user code file or a property value error in a step, it is displayed in the Errors pane.

In addition, if a property value for a step is undefined, it is listed in the Errors pane as a test error.

To view the Errors pane, select View > Errors.

The image below shows the Errors pane for GUI testing
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The image below shows the Errors pane for API testing

For details, see "Errors Pane" on page 364.

Debug Panes at a Glance

Relevant for: GUI tests, scripted GUI components, function libraries and user code files

The Debug panes assist you in debugging your document or user code file, and contains the
following options:

Tab Description

Breakpoints Displays information about breakpoints inserted into tests, function libraries, or
user code files and allows you enable or disable the breakpoints.

For details, see " Breakpoints Pane" on page 277.

Call Stack Displays information about the function andmethod calls currently running in a
test, function library, or user code file.

For details, see "Call Stack Pane" on page 281.

Loaded
Modules
(API testing
only)

Displays information on the .dll files associated with the current run session.

For details, see "LoadedModules Pane (API Testing) " on page 285.

Threads
(API testing
only)

Displays information about all the threads running in the current context of the
test.

For details, see "Threads Pane (API Testing) " on page 287.

Local
Variables

Displays the current value and type of all variables that were recognized up to the
last step performed during the run session that you are debugging. You can also
set or modify the values of the variables that are displayed.

For details, see "Local Variables Pane" on page 288.
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Tab Description

Console Enables you to run lines of script to set or modify the current value of a variable,
code object, property, method, or function call in your test or function library.

For details, see "Console Pane" on page 292.

Watch Displays the current value and type of any variable or expression that you added
to theWatch pane.

For details, see "Watch Pane" on page 297.

To view the Debug panes, select View > Debug and select the specific Debug pane you want to
view.

This image below shows the Breakpoints pane for aGUI test visible with the other panes open as
individual tabs. You can display any Debug pane by clicking on the relevant tab.
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This image below shows the Threads pane for anAPI test visible with the other panes open as
individual tabs. You can display any debug pane by clicking on the relevant tab.

For details, see "Debug Panes" on page 271.

Output Pane at a Glance

Relevant for: GUI tests and components and API testing

For GUI tests: This pane enables you to view information that is sent using thePrintUtility
statement during the run session.

For API testing:This pane enables you to view theOutput log for the compilation and test run.

To view theOutput pane, select View > Output.
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The image below shows theOutput pane forGUI testing.

The image below shows theOutput pane for .API testing

For details, see "Output Pane" on page 379.

Properties Pane at a Glance

Relevant for: GUI tests and components, API testing, and business process testing

The Properties pane displays and enables you to edit properties and parameters for a selected test,
action, component, function library, or application area. The information displayed in this pane is
dependent upon the active document.

Additionally:

For GUI testing: The Properties pane enables you to view details about your test and specify input
or output parameters for an action or test in theParameters tab.

For API testing: The Properties pane enables you view and edit the property values, schemas,
and event handlers for the different activities in the test canvas. Using the Input/Checkpoints tab,
you can specify input and output values for the highlighted activity and set checkpoints for that
activity. Using theEvents tab, you can open the TestUserCode.cs file in the Editor, enabling you to
write event code to use during a particular test step. Using theData Sources tab (visible only when
the test flow is selected), you can select data sources to use with your test.

For BPT in UFT: The Properties pane enables you to specify parameters and other details for your
test, flow, or component.

To view the Properties pane, select View > Properties.
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The image below shows the Properties tab in the Properties pane forGUI testing. You can display
the other tabs by clicking on them.
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The image below shows the Input/Checkpoints view for an API test step. You can display the
other tabs by clicking on them.

The image below shows the Properties tab in the Properties pane when a business process test is
selected. You can display theComponent Parameters andComments tabs by selecting a
component or flow in your test.
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For details on theGUI testing Properties pane, see "Properties Pane User Interface (GUI Testing)"
on page 387.

For details on theAPI testing Properties pane, see "Properties Pane User Interface (API Testing) "
on page 402.

For details on theBPT Properties pane, see "Properties Pane User Interface (BPT in UFT)" on
page 438.

Solution Explorer Pane at a Glance

Relevant for: GUI tests and components and API testing

The Solution Explorer Pane displays all the resources associated with a test or component. You
can add, remove, andmanage all of the resources in your test or to view and open all of the
resources in your component through this pane. In addition, the Solution Explorer pane enables you
to combinemultiple types of tests, components, application areas, function libraries, and user code
files into a single solution.

For GUI testing: GUI tests and actions or components are associated with resources such as
function libraries, recovery scenarios, and object repositories (via an application area). The Solution
Explorer pane displays each action of a GUI test as a node of the test, with its associated object
repositories, application areas, function libraries, and recovery scenarios.

For API testing: APItest nodes can include numerous references, events, and actions. The
Solution Explorer pane displays all external references for a test, the event handler code file
(TestUserCode.cs), anyAPI-specific actions created as part of a test, and any user-defined code
files added to a test.

You can openmost associated resources and references from the Solution Explorer pane by
double-clicking on the name of the resource or reference.

To view the Solution Explorer pane, select View > Solution Explorer.
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The image below shows the Solution Explorer pane for GUI testing.
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The image below shows the Solution Explorer pane forAPI testing.

For details, see "Solution Explorer PaneOverview" on page 471.

Search Results Pane at a Glance

Relevant for: GUI tests and components and API testing

The Search Results pane displays the results of searches performed using the options in the
Search menu. Using this pane, you can browse the results of your search, locate a specific result,
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and perform recent searches in order to receive updated results.

To view the Search Results pane, select View > Search Results.

The image below shows the Search Results pane for GUI testing.

The image below shows the Search Results pane for API testing.

For details, see " Search Results PaneOverview" on page 463.

Tasks Pane at a Glance

Relevant for: GUI tests and components and API testing

The Tasks pane enables you to create, view, andmanage your TODO tasks. A TODO task is
anything that needs to be done in a test or component, such as providing information relevant for
handing over a testing document, or adding a reminder to yourself to add steps that test a new page
in your application. Your TODO tasks are saved with the test or component.

The Tasks pane also enables you to view the TODO comments that exist in an action, an open
function library (for example, instructions or notes adjacent to a step), or an open user code file and
navigate to the line in the test step or user code file containing the TODO comment.

To show or hide the Tasks pane, select View > Tasks.

User Guide
Chapter 2: UFT at a Glance

HP Unified Functional Testing (12.00) Page 109 of 2274



For details, see "Tasks Pane User Interface" on page 501.

Toolbox Pane at a Glance

Relevant for: GUI tests and components, API testing, and business process testing

For GUI testing: The Toolbox pane displays all the keywords and functions available to your test
or component. It enables you to drag and drop objects or calls to functions into your test or
component. When you drag and drop an object into your test or component, UFT inserts a step with
the default operation for that object. When you drag and drop a function into your test or component,
UFT inserts a call to that function.

For API testing: The Toolbox pane contains all the activities and flow control activities you can
use to create an API test. You can drag and drop activities from the Toolbox pane into the canvas to
create a test, or you can double-click activities to create a test flow. Custom activities (such as
Web services) are also added to the Toolbox pane, under the Local Activities node.

For BPT in UFT: The Toolbox pane displays all of the components and flows available to your
business process test or flow. Double-click an item to add it to your test or flow.

To view the Toolbox pane, select View > Toolbox.

The image below shows the Toolbox pane for GUI testing.
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The image below shows the Toolbox pane for API testing
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The image below shows the Toolbox pane for BPT:
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For details on theGUI testing Toolbox pane, see "Toolbox Pane User Interface (GUI Testing)" on
page 510.

For details on theAPI testing Toolbox pane, see "Toolbox Pane User Interface (API Testing) " on
page 514.

For details on theBPT Toolbox pane, see "Toolbox Pane User Interface (BPT in UFT)" on page
518.
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Tasks

How to Start UFT
Relevant for: GUI tests and components and API testing

1. From the Startmenu, select All Programs > HP Software > HP Unified Functional
Testing > HP Unified Functional Testing, or double-click theHP Unified Functional

Testing shortcut on your desktop.

Whenever you start UFT, the Add-in Manager dialog box opens, displaying the currently
installed add-ins—unless you specify otherwise. For a user interface description, see "Add-in
Manager Dialog Box" on page 118.

Note:

n For details on how to Start UFT from theWindows 8 Start screen, see "Accessing UFT
inWindows 8Operating Systems" on page 75.

n If you have not installed a license as part of the installation, youmust install a license
before opening UFT. For details on the LicenseWizard, see "Understanding the Unified
Functional Testing License InstallationWizard" on page 2184.

2. In the Add-in Manager dialog box, select the add-ins you want to load and click OK. The UFT
window opens, displaying the "Start Page". For details on the Start Page, see "Start Page" on
page 121.

Note: For details on installing, loading, and working with add-ins, see theHP Unified
Functional Testing Installation Guide and theHP Unified Functional Testing Add-ins
Guide.

3. If your installation of UFT integrates with ALM, connect to your ALM project, as described in
"How toWork with Tests and Components in ALM" on page 719.

4. Begin creating or editing your tests. For details on how tomanage testing documents, see
"How to Create andManage Documents" on page 136.

5. Set your global test options. For details on setting test options in the Options Dialog Box, see
"Global Options - Overview" on page 523.

6. For GUI testing:Set your individual test or component settings. For details on setting test or
component settings, see "Settings Overview" on page 581.
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Reference

About Unified Functional Testing Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to view information regarding the features and add-ins, installed on your
computer, as well as other basic information about your computer. This information is useful for
troubleshooting and when working with HP Software Support.

To access Select Help > About HP Unified Functional Testing.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Version
information

The version of UFT that is installed on your computer and its build number.
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UI Element Description

License
Type

Displays the license type installed on your computer: Seat orConcurrent.

Installed
Features

The list of installed add-ins that are installed on your computer. This window
displays the feature name and version number for each add-in.

Detailed
Info

Opens the "About Unified Functional Testing Detailed InformationWindow"
(described on page 117), which displays all information about the application
components installed on your computer.

System
Info

Opens theWindows system information window which displays information about
the hardware and software components running on your computer.

License Opens the License Summary dialog box detailing the installed license. Select
Modify License to change the type of license.
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About Unified Functional Testing Detailed Information
Window

Relevant for: GUI tests and components and API testing

This window displays detailed information on UFT components installed on your computer.

To access In the About UFT dialog box, click theDetailed info button.

See also "About Unified Functional Testing Dialog Box" on page 115

User interface elements are described below:

UI Elements Description

Product Name The name of the product.
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UI Elements Description

Version The version number of the product listed in this window.

Host Name The name of the computer hosting UFT and the operating system.

ALM Connectivity
Version

The version number of the ALM Connectivity Add-in.

Maintenance Number Themaintenance number for your software.

Installed Components The list of UFT components installed on your computer, including
version number.

Add-in Manager Dialog Box
Relevant for: GUI tests and components and business process tests and flows

This dialog box enables you to select the add-ins that you want UFT to load by selecting the check
boxes adjacent to required add-ins.
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To access By default, this dialog box opens when you start UFT.

To display the Add-in Manager if it does not open when you start UFT, select
Tools > Options > General tab > Startup options node and then select
Display Add-in Manager on startup.

Important
information

l If you select the check box of an add-in that contains a child add-in, the parent
add-in is selected automatically.

l If you clear the check box for a parent add-in, the check boxes for its children
are also cleared.

l UFT remembers which add-ins you selected so that the next time you open
UFT, the same add-ins are selected in the Add-in Manager dialog box.

Relevant
tasks

"How to Start UFT" on page 114

See also "About Unified Functional Testing Detailed InformationWindow" on page 117

User interface elements are described below:

UI Element Description

Add-in The names of the installed add-ins.

The list of add-ins might also include child nodes representing add-ins that you or a
third party developed to support additional environments or controls using add-in
extensibility. For details, see the relevant Add-in Extensibility Developer Guide,
available from the HP Unified Functional Testing Extensibility Documentation
program group (Start > All Programs > HP Software > HP Unified Functional
Testing > Extensibility > Documentation).

Note:

l If you plan to test your application in aWeb browser, selectWeb as well
as your required add-in.

l If you want to test .NETWindows Forms, select .NET and click OK. A
message is displayed stating that for full operation of the .NET Add-in you
must also load theWeb Add-in. If you want to test only .NETWindows
Forms (and not. NETWeb Forms), you can click Yes.

l For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75. 
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UI Element Description

License The license used by the add-in, if any, and the time remaining until a time-limited
license expires:

l Licensed. Applies to the add-ins that are provided with UFT. Add-ins use the
same license as UFT. Therefore, if UFT uses aPermanent license, the add-
ins use the samePermanent license; if UFT uses a Time-Limited license, the
add-ins use the same Time-Limited license.

l Not Licensed. Applies to an add-in that does not have an installed seat license
or access to a concurrent license (for example, if all concurrent licenses are
currently in use, or if the required add-in license is not installed on the
concurrent license server on your subnet). To load the add-in, you first need to
install or access a license.

l Time Remaining. Specifies the number of days and hours remaining until a
time-limited add-in license expires. (Displayed only when using a UFT seat
license—not a concurrent license.)

For details, see theHP Unified Functional Testing Installation Guide.

License
used
(concurrent
licenses
only)

The license used by UFT:

l Unified Functional Testing.Enables you to use all UFT features, including
the use of GUI testing and API testing features.

l QuickTest Professional. Enables you to open only GUI tests and
components. When using this license, API testing-related options are not
available.

l Service Test. Enables you to open only API tests and components. When
using this license, GUI testing-related options are not available.

l QuickTest and Service Test. Enables you to use UFT with a QuickTest
11.00 or earlier or a Service Test 11.20 or earlier license. When using this type
of license, business process testing features andGUI/API integration features
(like calls to a GUI test from an API test and vice versa are not available).

Click Change to modify the type of license used with a session of UFT.

Note:

l You can only choose the type of license when working with a concurrent
license. This menu is hidden when using a seat license.

l Towork with BPT in UFT, select Unified Functional Testing.
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UI Element Description

Show on
startup

Instructs UFT to display the Add-in Manager dialog box each time you open UFT.

When this check box is cleared, UFT opens and loads the same add-ins it loaded
in the previous session, without displaying the Add-in Manager.

Note: (for concurrent license users) If this check box was cleared in the
previous session, and the license type selected from the concurrent license
server in that session is not currently available, UFT tries to load an available
license that matches the selected add-ins.

To display the Add-in Manager again:

Select Tools > Options > General tab > Startup options node and select
Display Add-in Manager on startup.

Start Page
Relevant for: GUI tests and components and API testing

This page welcomes you to UFT and describes the new features in this release, including links to
more information about these features.

To access 1. Start UFT, as described in "How to Start UFT" on page 114.

2. If the Start Page window is not displayed, select View > Start Page.
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User interface elements are described below:

UI Elements Description

Recent
Tests/Components
Recent Solution

Enables you to create a test or component or a solution by clicking the
New orOpen buttons after selecting a test, component or solution name.

Options Options for viewing the start page.

You can select Display the Start Page on Startup to display the Start
Page immediately upon the launch of UFT. You can select Close Start
Page after test loads if you want to close the start page after loading a
test.

What's New area Click theWhat's New button to display information on the list of the
newest features, enhancements, and supported environments in the
latest version of UFT.

Community Area Click theCommunity button to open news about UFT, links to UFT in the
HP Software site, links to the GUI Testing Forum, the API Testing forum,
and the BPT Forum, or the UFT blog.

Links Area Click the Links button to open links to the UFT Help, theHP UFT Object
Model Reference for GUI Testing, and the tutorials for GUI Testing and
API Testing.

Support Area Click theSupport button to open links to UFT support, the Knowledge
Base, and Troubleshooting areas of the HP Software Support Web site.

UFT Program Folder Structure
Relevant for: GUI tests and components and API testing

After the UFT setup process is complete, the following items are added to your UFT program folder
(Start > All Programs > HP Software > HP Unified Functional Testing):

User Guide
Chapter 2: UFT at a Glance

HP Unified Functional Testing (12.00) Page 122 of 2274



l Documentation. Provides the following links to commonly used documentation files:

Option Description

HP Unified
Functional
Testing Code
Samples Plus

Opens the Unified Functional Testing Code Samples Plus Help, which
provides sample function libraries, code, and SDK samples with
accompanying explanations.

Note: These samples are relevant for GUI testing only.

HP UFT Help Opens the UFT Help, which displays links to commonly used topics and
movies that describe how to use UFT, as well as additional links to
HPSoftwareWebsites.

The UFT Help provides access to all guides available for UFT, such as
Getting Started guides, Helps, reference files, and links to printer-
friendly (PDF format) documentation. It contains various navigation
options to help you find the information you need.

TheWelcome to the UFT Help section describes how to navigate,
use, and get updates for the UFT Help.

Unified
Functional
Testing
Automation
Reference

Opens the Unified Functional Testing Automation Object Model
Reference for GUI Testing. The object model assists you in automating
GUI test management, by providing objects, methods and properties
that enable you to control UFT features and configurations. TheObject
Model Reference provides syntax, descriptive information, and
examples for the objects, methods, and properties. It also contains a
detailed overview to help you get started writing GUI test scripts.

UFT Tutorials Opens theGUI testing and API testing tutorials, which teach you basic
skills and shows you how to start testing your applications.

l Sample Applications. Contains the following links to sample applications that you can use to
practice testing with UFT:

Option Description

Flight
API

Opens aGUI-less flight service application, used in conjunction with an API test.

Note: Youmust have administrator privileges to use this application.

Flight
GUI

Opens a sample flight reservationWindows application. To access the
application, enter any username and the passwordmercury.
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Option Description

Mercury
Tours
Web site

Opens a sample flight reservationWeb application. This Web application is used
as a basis for the UFTGUI Testing tutorial. For details, see theHP Unified
Functional Testing Tutorial for GUI Testing.

l Tools. Contains the following utilities and tools that assist you with the testing process:

Note: The available tools depend on the installed UFT add-ins.

Option Description

Activity
Wizard

Opens the API Testing "Activity Wizard" (described on page 2049), which
enables you to create customAPI activities that will be visible in the Toolbox
pane.

Additional
Installation
Requirements

Opens the "Additional Installation Requirements Utility" (described on page
2181), which displays any prerequisite software that youmust install or
configure to work with UFT. For details, see the

Commuter
License Tool

Opens the Commuter Licensing utility, to check in or check out concurrent
licenses when working at a remote location.

HP Micro
Player

Opens the HP Micro Player, which enables you to view capturedmovies of
a run session without opening UFT. For details, click theHelp button in the
HP Micro Player window.

Java Add-in
JRE Support
Tool
(GUI testing
only)

Opens the Java Add-in JRE Support Tool, which adjusts the JVM Runtime
Parameters of your JRE to enable the Java Add-in to recognize Java
applets and the Java objects within them.

This tool is necessary only for certain operating systems, browsers, and
JRE versions. For details, see the Java section of theHP Unified
Functional Testing Add-ins Guide. This tool is only available when the Java
add-in is installed with UFT.

License
Validation
Utility

Opens the License Validation utility, which enables you to retrieve and
validate license information. For details, click theHelp button in the License
Validation Utility window.

Password
Encoder
(GUI testing
only)

Opens the Password Encoder tool, which enables you to encode
passwords. You can use the resulting strings as method arguments or Data
pane parameter values. For details, see "Password Encoder Tool" on page
965.
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Option Description

Register New
Browser
Control
(GUI testing
only)

Opens the Register Browser Control Utility, which enables you to register
your browser control application so that UFT recognizes yourWeb objects
when recording or running GUI tests. For details, see the section on
registering browser controls in the
HP Unified Functional Testing Add-ins Guide.

Remote
Agent

Activates the UFT Remote Agent, which enables you to configure how UFT
behaves when aGUI test or component is run by a remote application such
as ALM. For details, see "Remote Agent Settings Dialog Box" on page 745.

Silent Test
Runner
(GUI testing
only)

Opens the "Silent Test Runner" (described on page 2239). This enables you
to run a test in themanner in which it is run from LoadRunner or Business
Availability Center.

soapUI to API
Test
Converter
(API Testing
only)

Converts soapUI tests to a UFT API Test.

Stingray
Support
Configuration
Wizard
(GUI testing
only)

Opens the Stingray Support ConfigurationWizard which enables UFT to
recognize Stingray objects in your application.

This tool is only available when the Stingray add-in is installed with UFT.

Test Batch
Runner

Opens the Test Batch Runner application, which enables you to set up UFT
to run several tests in succession. For details, see "How to Create and Run
a Test Batch" on page 646.

l HP Unified Functional Testing Product Availability Matrix. Provides a complete list of all
environments, programs, and versions that are supported for UFT and its add-ins.

l HP Unified Functional Testing. Opens the UFT application.

l Readme. Opens theHP Unified Functional Testing Readme, which provides the latest news
and information on UFT and the UFT add-ins.

Note:

l If you uninstalled a previous version of UFT before installing this version, youmay have
additional (outdated) items in your UFT program folder. In addition, iIf you have UFT add-ins
or extensibility SDKs installed, youmay have items in your program folder that relate
specifically to these items.
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l For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing UFT
inWindows 8Operating Systems" on page 75.
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Chapter 3: UFT File Operations
Relevant for: GUI tests and components and API testing
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Concepts

Testing Documents Overview
Relevant for: GUI tests and components and API testing

A testing document is any file that enables you to test your application. You create, maintain, and
edit steps, parameters, functions, and other details in the document to enable the testing of your
application.

Testing documents can include:

l GUI testing documents:

n GUI tests

n GUI actions

n Function libraries

l API testing documents:

n API tests

n API actions

n C# files containing event handler code (TestUserCode.cs files)

n C# files containing user-generated code

l BPT documents:

n Business process tests

n Business process flows

n Business components, including API, keyword GUI, and scripted GUI components

n Application areas

You work with testing documents in the "Document Pane" (described in "Document Pane" on page
302). In UFT, you can perform standard file operations with testing documents, including creating,
opening, saving, and printingmultiple types of documents. You can also save a test with its
resources, save your test files in a .zip format, or import a test document that has been stored as a
.zip file.
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The document pane supports the following types of views and functionality:

l Canvas. Graphically displays and enables you to edit the flow of your test, action, or
component. For details, see "The Canvas" on page 209.

l Keyword View. Enables you to create and view the steps of your action or component in a
keyword-driven, modular, table format. For details, see "Keyword View User Interface" on page
942.

l Editor. Provides text and code editing features that facilitate the design of your text, script, and
code documents. For details, see "Editing Text and Code Documents" on page 305.

l Application area. Displays and enables you to edit the application area settings and resource
associations. For details, see "Application Area User Interface" on page 2101.

l BPT in UFT. Displays and enables you to create and edit business process tests and flows that
are stored in ALM. For details, see "Business Process Testing in UFT User Interface" on page
2074.

Relative Paths in UFT for GUI Testing
Relevant for: GUI tests and components

UFT enables you to define the path to a GUI testing resource stored in the file system or in ALM as
a relative or an absolute path.

If you specify a relative path, then during a run session, UFT searches for the resource file in the
folder for the current test or component, and then in the folders listed in the Folders pane of the
Options dialog box (Tools > Options > GUI Testing tab > Folders node). For details, see
"Folders Pane (Options Dialog Box > GUI Testing Tab)" on page 544.

Note:

l A path that starts with \.. is considered to be a full path, with the backslash representing the
root folder of the current drive.

l If you are working with the Resources and Dependencies model with Quality Center 10.00
or ALM, specify an absolute Quality Center or ALM path. For details, see "Relative Paths
and ALM" on page 758.

Example of When to Use Relative Paths

If your test's resources are stored in the file system and you want other users or HP products
to be able to run this test on other computers, you can set the file path to the resource as a
relative path. Any users who want to run this test should then specify the drive letter and folder
in which UFT should search for the relative path in the Folders pane of the Options dialog box
(Tools > Options > GUI Testing tab > Folders node).
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Entering a Path to a Resource

When you specify a path to a function library, shared object repository, recovery scenario, data
table file, or environment variable file, UFT checks if the path, or the initial part of the path, exists in
the Folders pane of the Options dialog box.

UFT then enables you to specify whether to convert the path to a relative path or store an absolute
path. One of the followingmessage boxes opens, depending on whether the path you specified, or a
part of the path, exists in the Folders pane.

Path Exists in the Folders Pane
If the resource path you specify matches an existing search path in the Folders pane, you are
prompted whether to define the path using only the relative part of the path.

l ClickingYes truncates the path to a relative path.

l ClickingNo defines the path to the resource as an absolute path.

In cases where a part of the path you enter matches more than one path in the Folders pane, the
closest match is applied. For example, if bothC:\Current_Version andC:\Current_Version\Libraries
are defined in the search path list, the latter is applied.
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Path Does Not Exist in the Folders Pane
If the resource path you specify does not match an existing search path in the Folders pane, you are
prompted whether to add the resource's location path to the Folders pane and define the path
relatively.

l ClickingYes adds the resource's location path to the Folders pane and truncates the path to a
relative path.

l ClickingNo defines the path to the resource as an absolute path.

Note:

n You can choose not to show one or both of thesemessage boxes when you enter a path
to a resource by selecting theDo not show this message again check box. To show
thesemessage boxes again, select theRemind me to use relative paths when
specifying a path to a resource check box in the Folders pane of the Options dialog
box (Tools > Options > GUI Testing tab > Folders node). This check box is selected
by default when you first start UFT.

n If you are connected to Quality Center 10.00 or ALM, thesemessage boxes are
displayed only if you select a path in the file system.

Understanding Absolute and Relative Paths

Relevant for: GUI tests and components

You can reference UFT GUI testing resources, such as shared object repositories, function
libraries, recovery scenarios or environments, using absolute or relative paths.

l An absolute path describes the full path to a specific file starting from a fixed location such as
the root folder, or the drive on which the file is located, and contains all the other subfolders in the
path. An absolute path always points to the specified file, regardless of the current folder.
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If you are working with the Resources and Dependencies model with Quality Center 10.00 or
ALM, youmust specify an absolute Quality Center or ALM path to enable your tests to access
your resource files.

l A relative path describes the path to a specific file starting from a given folder, and is generally
only a portion of the absolute path. A relative path therefore specifies the location of the file
relative to the given location in the file system.

Using relative paths means that the paths remain valid when files or folders containing files are
moved or copied to other locations or computers, provided that they aremoved within the same
folder structure. If you are not working with the Resources and Dependencies model with
Quality Center 10.00 or ALM, we recommend that you use relative paths when saving resources
in UFT.

Example

Consider a UFT GUI testing resource file named FunctionLibrary1.qfl located inC:\Current_
Version\Libraries. The absolute path to the file is C:\Current_
Version\Libraries\FunctionLibrary1.qfl. The relative path to the file from within the folder named
Libraries is specified using only the name of the file, FunctionLibrary1.qfl. Alternatively, the
relative path to the file from within another folder, such as C:\Current_
Version\Libraries\MyFiles, would be Libraries\FunctionLibrary1.qfl.

Using a relative path, you could copy the FunctionLibrary1.qfl file from C:\Current_
Version\Libraries to an updated version inC:\New_Version\Libraries, and the path used by
UFT would remain valid.

Portable Copies of Tests
Relevant for: GUI tests and API tests

When you work with a GUI test, the tests and their resource files are often stored on a network
drive or in ALM, as this enables the reuse of actions and other resources, and helps ease test
management. Therefore, youmay need to open or run a test when you do not have access to a
network drive or ALM. For example, youmay need to create a portable copy of a test for use when
traveling to other sites.

For API tests, some of the activities and reference files used with a test are stored locally in the
same location as the test. Therefore, when youmove the test to another computer, UFT cannot
locate the resources, and therefore not run the test.

For GUI tests
You can save a standalone copy of your GUI test and its resource files to a local drive or to another
storage device using the File > Save (Other) > Save with Resources command.

When you save a test in this manner, UFT creates a copy of the following and saves the files in the
location you specify:
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l Source test. UFT saves a copy of this test in the location you specify.

l Resource files. UFT saves a copy of all resource files associated with the source test, such as
function libraries and shared object repositories. UFT stores these files in sub-folders of the
copied test.

l Called actions. UFT saves a copy of any external actions called by the source test. For
example, if Test A calls actions that are stored in Test B, UFT creates a local copy of the
actions stored in Test B and stores them in a sub-folder of Test A. The sub-folder has the same
name as the test from which the called actions were copied. In this example, the sub-folder is
named Test_B. UFT also creates a copy of any resources associated directly with these
actions, such as its local shared object repositories and action sheets in the data table. UFT
does not, however, save the resource files associated with Test B, so youmust ensure that
these resources are associated with the source test, Test A.

This enables you tomodify or run the test without access to a network drive or ALM.

For API tests
You can save a standalone copy of your API test and its resources to a local drive or to another
storage device by saving the activity as a local activity. For details, see "Save a portable copy of an
API test" on page 139.

Tip: If you use UFT with a concurrent license but do not have access to the concurrent license
server (for example, during a business trip), you can install a commuter license. For more
details, see theHP Unified Functional Testing Installation Guide.

Opening and Saving Tests with Locked Resources
Relevant for: GUI tests and API tests

Resource files can be locked by UFT to protect the information in the file from being overwritten.

Resource files are locked in the following scenarios:

l The file is being used by another UFT user.

l The file is checked into an ALM version control database or any other version control software.

l The file is marked as read-only.

Note: External files that are associated with your test but cannot be edited within UFT (such
as environment variable files) are not affected by this lockingmechanism.
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UFT notifies you if a resource file that is associated with your test is locked when:

l Opening a test whose resource file is locked. For details, see "Open Test with Locked
Resources - Message Box" on page 163.

l Saving a test whose external resource files were not opened in read-write mode (because they
were locked when you opened the test) andmodified while editing the test. For details, see
"Save Test with Locked Resources - Message Box" on page 168.

Tip: To create a writable copy of a test with locked resources, use the Save As option from
the File menu and save the test under a new name.
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Tasks

How to Create and Manage Documents
Relevant for: GUI tests and components, API testing, and business process testing

The task describes how tomanage testing documents and includes the following steps:

l "Create a new standalone document" below

l "Create a new document within an existing solution" on the next page

l "Open an existing document" on the next page

l "Add an existing document to your solution" on page 138

l "Edit an open document" on page 138

l "Save the current document" on page 138

l "Save all open documents" on page 138

l "Save a portable copy of an API test" on page 139

l "Save a portable copy of a GUI test" on page 139

l "Close the current document" on page 139

l "Close all documents" on page 140

l "Switch between open documents" on page 140

l "Zip and unzip a test (GUI tests only)" on page 141

l "Delete a document" on page 141

Create a new standalone document

1. (Optional) If you are working with ALM, connect to the relevant ALM project. For details, see
"ALM Connection Dialog Box" on page 737.

2. Do one of the following:

n Select File > New and select the type of document to create.

n Click theNew button down arrow and select the type of document to create from
the drop-down list.
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A dialog box opens:

n If you are creating a test or component, see "New <Document> Dialog Box" on page 152.

This dialog box enables you to specify the type of test or component you want to create, the
location in which the new item is stored, and, optionally, the solution in which it is included.

n If you creating a function library, application area, or solution, see "Open/New
<Document>/<Resource> Dialog Box" on page 156.

This dialog box enables you to specify the location in which the new item is stored.

n If you are creating aGUI test from an XML file containing exported Sprinter steps and test
objects see "Sprinter Automated Test Data File Dialog Box" on page 150.

This dialog box enables you to specify the location of the XML file, the name of the test to
create, and the location in which to store it.

After you finish entering the information for your new document in the dialog box, a new
document is automatically saved and displayed as a tab in the document pane.

Create a new document within an existing solution
Do one of the following:

l Select File > Add or click theAdd down arrow to add a new document to your solution.

l In the "Solution Explorer Pane" (described on page 478) right-click the <solution name> node,
select Add > Add New and select the type of document to create.

A dialog box opens. For details, see: "Add Test/Component to Solution Dialog Box" on page 146,
or, if you are creating aGUI test from an XML file containing exported Sprinter steps and test
objects see "Sprinter Automated Test Data File Dialog Box" on page 150.

After you finish entering the information for your new document in the dialog box, a new document is
automatically saved and displayed as a tab in the document pane.

Open an existing document

1. If your document is stored in ALM, connect to the relevant ALM project. For details, see "ALM
Connection Dialog Box" on page 737.

2. Do one of the following:

n Select File > Open, click theOpen down arrow, or select the list of Recent files in
the Filemenu to open an existing document. In the "Open/New <Document>/<Resource>
Dialog Box" (described on page 156), browse to and select your document.

n If your document is part of a solution, in the "Solution Explorer Pane" (described on page 478)
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double-click the selected node for your document.

Note:Within a solution, different document types are located in different locations. For
details, see "Open an existing document from the current solution" on page 475.

If your GUI test has locked resources, see "Opening and Saving Tests with Locked Resources"
on page 134 and "Open Test with Locked Resources - Message Box" on page 163.

Add an existing document to your solution
Do one of the following:

l In the "Solution Explorer Pane" on page 470 (described on page 478), right-click the <solution
name> node and select Add > Add Existing <Document>, and select the type of document
to add.

l Select File > Add Existing or theAdd down arrow to add a document to your solution.

A dialog box opens. For details, see "Add <Existing Document> to Solution Dialog Box" on page
145.

Edit an open document
The features available for viewing and editing documents depend on the document type. For details,
see "Document PaneOverview" on page 303.

Save the current document
Do one of the following:

l Make sure that the document you want to save is the active tab (you can select the document's

tab to bring it into focus), and click theSave button .

l Right-click the tab of the document you want to save and select Save <document name> or
Save <document name> As.

UFT saves the document with your changes. If you are usingSave As, the "Save
<Resource>/Save <Document> As Dialog Box" (described on page 164) opens.

Note:When you edit a document, an asterisk (*) is displayed in the document tab (for
standalone documents like application areas, function libraries, or user code files) or the
canvas tab (if the document is part of a test) until the document is saved.

Save all open documents

Select File > Save All or click theSave All button .

Note:When you edit a document, an asterisk (*) is displayed in the document tab (for
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standalone documents like application areas, function libraries, or user code files) or the
canvas tab (if the document is part of a test) until the document is saved.

Save a portable copy of an API test

1. Prerequisites:

n If your test was last modified using Service Test 11.10 or later, or using UFT, make sure that
the test and its resources are upgraded to UFT. Open the test in UFT and save it (Save or
Save As). If the test contains calls to external actions (actions stored in other tests), open
and save those tests too.

Note: Tests last modified in Service Test 11.00 or earlier cannot be opened in UFT.

n Make sure that your resource file (such as WSDL or REST service) has at least one step in
the current test.

2. In the Toolbox pane, right-click on the service name and selectMove to > File System
Activities. The servicemoves to the File System Activities section of the Toolbox pane.

3. Select File > Save (Other) > Save with Resources. The "Save <Resource>/Save
<Document> As Dialog Box" (described on page 164) opens.

Save a portable copy of a GUI test

1. If your test was last modified using QuickTest 11.00 or earlier, make sure that the test and its
resources are upgraded to UFT. Open the test in UFT and save it (Save orSave As). If the test
contains calls to external actions (actions stored in other tests), open and save those tests too.

2. Select File > Save (Other) > Save with Resources. The "Save Test with Resources Dialog
Box" (described on page 169) opens

3. Select a name and location for the test and click Save.

For details about portable tests, see "Portable Copies of Tests" on page 133.

Close the current document
Do one of the following:

l Make sure that the document you want to close is the active document and select File > Close.

l To close all documents included in the current solution and the solution, select File > Close
solution.

l Right-click a document tab and select Close.
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Close all documents
Do one of the following:

l To close all open documents, right-click any document's tab and select Close All.

l To close all open documents except the active document, right-click on the document tab and
select Close All but This.

Switch between open documents

l To navigate to an open document, select the relevant tab.

Note: If some tabs are not visible due to a lack of space, click the document display arrow
in the upper-right hand corner to display a list of all open documents. Select the

document you want to view.

l To select your document from amenu of open documents, press and hold CTRL+TAB on your
keyboard. A window opens showing a list of all open documents and panes.
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Zip and unzip a test (GUI tests only)

l To zip a test, select File > Export Test and use the "Export to Zip File Dialog Box" (described
on page 151).

This enables you to save configuration, run-time, setup data, and Active Screen files together,
conserving space andmaking it easier to move a test.

l To unzip a test, select File > Import Test and use the "Import from Zip File Dialog Box"
(described on page 152).

Delete a document

l If the document is stored in the file system, select File > Open, File > New, or File > Save as
to open a file operation dialog box. Browse to the document, right-click and select Delete.

Caution:

n For GUI tests:Do not delete actions in this way. Delete them from within the test that
contains them.

n Before you delete a document, make sure that it is not used by or associated to any other
documents.

l If the document is stored in ALM, you delete it from within ALM, regardless of whether it was
created in UFT or in ALM. For details, seeHP Business Process Testing User Guide.

How to Define API Test Properties or User/System
Variables

Relevant for: API testing only

The following steps describe how to define test properties, user variables, and operating system
variables. These settings are optional.

l "Define test parameters" below

l "Define user variables" on the next page

l "Set user variable values " on the next page

l "Define user variable profiles " on page 143

l "Set OS variable values for the test - optional" on page 143

Define test parameters
This step applies if you want to define custom parameters that can be used by all steps in the test,
with the ability to assign data from a data source.
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1. Click in a blank area of the canvas. In the Properties pane, open the Test Input Parameters
view .

2. Click theAdd button to define a new input or output parameter.

3. In the "Add Input/Output Property/Parameter Dialog Box (API Testing)" (described on page
1775), specify a parameter name and data type. All types that were defined in any reference
file, are available.

4. Click in theDefault Value column and specify a value.

Define user variables
You can create user variables and set their values. You can definemultiple profiles for the variable
values. You select a profile to be active before the test run. For details, see "Set user variable
values " below.

1. Click in a blank area of the canvas. In the Properties pane, open the Test Variables tab .

2. Click theAdd User Variable button  to define a new user variable.

Set user variable values
You can set values for variables in one of the following ways:

l In the Properties pane's Test Variables view, click in theProfile column andmanually enter
values.

l Open the Toolbox pane and drag theSet Test Variable activity from theMiscellaneous
category into the Test Flow (or loop). In the Properties pane, define the variable key and value.
To obtain values, click the Link to a Data Source button in the row. In the "Select Link Source
Dialog Box (API Testing)" (described on page 1840), select the Test Variables option. Select a
name and value for theVariable key andVariable value.

l Open the Properties pane's Events view for the step or define a Custom Code activity. Edit the
event handler code and assign a value using the TestProfile object. The following example sets
the value of theRegion user variable to NE.

activity.Context.TestProfile.SetVariableValue("Region", "NE");

For details, see "Writing Event Handlers for API Test Steps" on page 1935.

Repeat this step for each variable for which you want to set values.
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Define user variable profiles
This step applies only if you created user variables as described in the above steps.

1. Define one or more user variables as described above.

2. Click theAdd New Profile button .

3. In the "New Test Profile Dialog Box" (described on page 172), specify a name and indicate the
profile (if any) from which to copy the properties. If you do not copy the properties from an
existing profile, UFT copies the user variables from the active profile without its values.

4. To rename or delete a profile, click theManage Profiles button . Click Remove or
Rename.

5. Click theCompare button to display the profiles side-by-side.

6. Only the active profile is accessed during the test run. Tomake a profile active, select it from
theActive Profile list.

For user interface details, see the "Test Variables Tab (Properties Pane - API Testing)" on page
432.

Set OS variable values for the test - optional
This step lets you set global operating system variables that will apply to all steps in the current test
run.

1. From the Toolbox pane and drag theSet OS Environment Variable activity from theSystem
category into the Test Flow or another custom loop.

2. In the Properties pane's Input/Checkpoints tab, define the variable key and value or click the
Link to Source button  to specify a data source.

Tip: To view a list of the test variables, click in a blank area of the canvas. In the Properties

pane, open the Test Variables tab . The System variables are listed in the lower pane.

How to Upgrade API Tests Using the Batch Upgrader
Relevant for: API testing only

UFT provides an upgrade tool for API tests, STBatchUpgrader.exe, located in the <Unified
Functional Testing installation>/bin folder. This tool lets you run a batch file to upgrade tests last
modified in version 11.10 or 11.20, making them compatible for UFT.

Note: The Batch Upgrader tool may not successfully upgrade tests stored in ALM11.00 when
working onWindows 2003.
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If you do not upgrade your tests with the batch upgrade tool, when you open a test last modified in
version 11.10 or 11.20, it prompts you to upgrade the test.

Tests last modified in Service Test 11.00must first be opened and saved in Service Test 11.10,
before you can upgrade them to UFT.

For the tool's options, see "Batch Upgrader Command Line Options" on page 174

The following steps describe how to use theSTBatchUpgrader tool.

l "Prerequisite" below

l "Locate the Batch Upgrader tool" below

l "Add command line options" below

l "Run the command" below

1. Prerequisite
Make sure that UFT is not running.

If you ran the upgrader tool once while UFT was running, the logs may become corrupted.
Backup and delete all of the existing logs in the <Unified Functional Testing
installation>\bin\logs folder before proceeding.

If desired, create a backup copy of the older tests.

2. Locate the Batch Upgrader tool
In the command line, enter the location of theSTBatchUpgrader.exe file in theUnified
Functional Testing/bin sub-folder.

3. Add command line options
Add the relevant options as described in "Batch Upgrader Command Line Options" on page
174, using the following syntax:

STBatchUpgrader.exe source [destination] [/ALM url domain project] [/login username pas
sword] [/log logfile] [/report reportfile]

For example, the following string runs the upgrade on all tests in theST_11_1 folder on the
ALM server, pumpkin, for the TEST1 project in the AUTOMATION domain. It places the report
in c:\logs\MyLogfile.log.

STBatchUpgrader.exe Subject\ST11_1 /ALM http://pumpkin:8080/qcbin AUTOMATION T
EST1 /login user password /log c:\logs\MyLogfile.log.

4. Run the command
Run the command. Verify the validity of the tests in the destination folder.
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Reference

Add <Existing Document> to Solution Dialog Box
Relevant for: GUI tests and components, API testing, and business process testing

This dialog box enables you to add existing documents to a solution.

This section describes the following dialog boxes:

l Add Test to Solution dialog box

l Add Business Component to Solution dialog box

l Add an Existing Application Area to Solution dialog box

To access Do one of the following:

l In the "Solution Explorer Pane" (described on page 478), right-click the solution
node and select Add Existing <Document>.

l Select File > Add Existing <Document>.

l Click theAdd button down arrow and select the type of document.
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Important
information

l Solutions are saved in your file system only and cannot be saved in an ALM
project.

l Using File > Add Existing <Document> enables you to openmultiple tests,
components, or application areas simultaneously instead of using File > Open
(which closes all open documents).

l If you try to open a document and there is an error with loading the test (such
as ALM connectivity problems or a changed document name), an error
describing the problem is displayed in the Errors pane.

Relevant
tasks

"How to Create andManage Documents" on page 136

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<sidebar> The location in which the document is stored, for example File System orALM Test
Plan.

Note: Youmay need to select a different location before browsing to your
document.

Look in The path for the document. You can use the down arrow to navigate to the required
folder, or you can double-click a folder in the file list area to navigate to the required
folder.

<file list
area>

The folders and/or documents stored in the current path.

File name The name of the documents selected in the <file list area>.

Files of
type

Filters a list of displayed files to show only the file types selected. If the current
folder contains other file types, they are hidden.

Add Test/Component to Solution Dialog Box
Relevant for: GUI tests and components, API testing, and business process testing

This dialog box enables you to add new tests or components to a solution.

This section describes the following dialog boxes:

l AddNew Test/Component to Solution dialog box

l Add Business Component to Solution dialog box

The image below shows the dialog box to add a new test to a solution (File > Add > New Test).
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The image below shows the dialog box to add a new component to a solution (File > Add > New
Business Component).
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To access Do one of the following:

l In the "Solution Explorer Pane" (described on page478), right-click the solution
node and select Add New <Document>.

l Select File > Add New <Document>.

l Click theAdd button down arrow and select the type of document.

Important
information

l When you add a document to a solution, it is added to the solution in the
Solution Explorer and it also opens as a new tab in the document pane.

l Solutions are saved in your file system only and cannot be saved in an ALM
project. For details, see "Solution Explorer PaneOverview" on page 471.

l You can use this command to keepmultiple tests, components, or application
areas open simultaneously instead of using File > New (which closes all open
documents).

l When you save a new document in the file system, UFT suggests a default
folder calledUnified Functional Testing. For all supported operating
systems prior toWindows Vista, this folder is located under your UFT
installation folder. ForWindows Vista and later operating systems, this folder
is located underMy Documents.

Relevant
tasks

"How to Create andManage Documents" on page 136

User interface elements are described below:
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UI Element Description

Select type A list of available tests or components.

For tests, you can select:

l GUI Test

l API Test

l API Test - Load Enabled

l Business Process Test

l Business Process Flow

For components, you can select:

l GUI Keyword Component

l GUI Scripted Component

l API Component

Note: The options available differ according to the license loaded and the
software installed on the UFT computer.

Name The name of the document. Use a descriptive name that helps you and others
identify the document easily.

Depending on the location you specify in the Location field, UFT suggests
possible names to avoid conflicts with existing documents.

Naming conventions:See "Troubleshooting - Naming Conventions" on page
2269.

Location The folder of the document in the file system or an ALM project.

Note: (for ALM users) The location of your test or component file is
prefaced by an ALM path, shown as: [ALM] Components/Subject \<folder
name>.

Application
Area
(GUI
components
only)

The folder location for the application area associated with your component.

Note: (for ALM users) The file system path for your application area file is
prefaced by an ALM path, shown as: [ALM\Resource] Resources\<folder
name>

User Guide
Chapter 3: UFT File Operations

HP Unified Functional Testing (12.00) Page 149 of 2274



Sprinter Automated Test Data File Dialog Box
Relevant for: GUI tests only

This dialog box enables you to create or add aGUI test from an XML file containing exported
Sprinter steps and test objects. UFT automatically adds this new test to the open solution.

This section describes the following dialog boxes:

l New Sprinter Automated Test Data File dialog box

l Add Sprinter Automated Test Data File (to Solution) dialog box

To
access

Select File > New > GUI Test from Sprinter Automated Test Data File or File >
Add > GUI Test from Sprinter Automated Test Data File.

See
also

Conceptual overview: "Creating Tests by Importing Steps from HP Sprinter" on page
815

User interface elements are described below:

UI Element Description

XML File
Location

The file system path of the XML file containing the captured user actions, test
objects, and comments.

GUI Test
Name

The name for the new test. You can enter a new name or accept the default
name.

GUI Test
Location

The file system path for the new test and its files. You can enter a new path or
accept the default path.
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Export to Zip File Dialog Box
Relevant for: GUI tests only

This dialog box enables you to zip your GUI tests together with configuration, run-time, setup data,
and (optionally) Active Screen files. Zipping these files together helps conserve space andmakes
tests easier to transfer.

To access Select File > Export Test.

Relevant tasks "How to Create andManage Documents" on page 136

User interface elements are described below:

UI
Element Description

Source
Path

The read-only current file system path of the test to be zipped.

Zip File The file system path at which to store the zipped file. You can enter a .zip file name
and path, or accept the default name and path.
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Import from Zip File Dialog Box
Relevant for: GUI tests only

This dialog box enables you to extract your zipped UFT tests when needed. When the extraction
process is complete, the test opens.

To access Select File > Import Test

User interface elements are described below:

UI
Element Description

Zip File The file path to the zipped file. You can enter a .zip file name and path, or accept the
default name and path.

Extract
to

The path at which to export the test and its files. You can enter the .zip file name and
path, or accept the default name and path.

New <Document> Dialog Box
Relevant for: GUI tests and components, API testing, and business process testing

This dialog box enables you to create a new testing document.

This section describes the following dialog boxes:

l New Test dialog box

l New Business Component dialog box

The image below shows the dialog box to create a new test (File > New > Test).
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The image below shows the dialog box to create a new component (File > New > Business
Component).
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To access 1. Prerequisite for ALM users:Connect to your ALM project if needed. For
details, see "ALM Connection Dialog Box" on page 737.

2. Do one of the following:

n Select File > New > Test (for tests only).

n Select File > New > Business Component (for components only).

n Click theNew down arrow and select the type of document you
want to create.

User Guide
Chapter 3: UFT File Operations

HP Unified Functional Testing (12.00) Page 154 of 2274



Important
information

l After you create the document, it is automatically saved to the specified
location.

l When you save a new document in the file system, UFT suggests a default
folder calledUnified Functional Testing. For all supported operating systems
prior toWindows Vista, this folder is located under your UFT installation folder.
ForWindows Vista and later operating systems, this folder is located underMy
Documents.

l In ALM, components are saved in the ALM Components module. You cannot
save a component directly in the root folder of this module. Create a sub-folder
within it, or select an existing sub-folder.

Relevant
tasks

"How to Create andManage Documents" on page 136

User interface elements are described below:

UI Element Description

Select type A list of available test or component types.

For tests, you can select:

l GUI Test

l API Test

l API Test - Load Enabled

l Business Process Test

l Business Process Flow

For components, you can select:

l GUI Keyword Component

l GUI Scripted Component

l API Component

Note: The options available differ depending on the license loaded and the
HP applications installed on the UFT computer.
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UI Element Description

Name The name of the document. Use a descriptive name that helps you and others
identify the document easily.

Depending on the location you specify in the Location field, UFT suggests
possible names to avoid conflicts with existing documents.

Naming conventions:See "Troubleshooting - Naming Conventions" on page
2269.

Location The folder of the document in the file system or an ALM project.

Note: (for ALM users) The location of your document file is prefaced by an
ALM path, shown as: [ALM] Components/Subject \<folder name>.

Application
Area
(GUI
components
only)

The folder location for the application area associated with your component.

Note: (for ALM users) The location of your application area file is prefaced
by an ALM path, shown as: [ALM\Resources] Resources\<folder name>.

Solution
Name

The name of the solution to create that contains your document. If you do not
specify a name for a solution, a generic solution calledSolution Untitled is
created in the Solution Explorer, and the document is associated with this default
solution.

Note: All new documents must be part of a solution.

Open/New <Document>/<Resource> Dialog Box
Relevant for: GUI tests and components, API testing, and business process testing

This dialog box enables you to open an existing document or resource from the file system or your
ALM project, if UFT is connected to an ALM project.

Additionally, this dialog box is used when you create a new solution, application area, or function
library, enabling you to specify the location for the new item.

This section describes the following dialog boxes:

l New Function Library dialog box

l New Application Area dialog box

l New Solution dialog box

l AddNew Application Area to Solution dialog box
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l Open Solution dialog box

l Open Test dialog box

l Open Business Component dialog box

l Open Function Library dialog box

l Open Application Area dialog box

l OpenData Table dialog box

l OpenRecovery Scenario dialog box

l Open SharedObject Repository dialog box

l Open XML File dialog box

l Open Environment Variable File dialog box

The image below shows a dialog box when opening a test. Similar options are available when
opening other types of documents or resources.

To access:
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Prerequisite for ALM Connect to your ALM project if needed. For details, see "ALM
Connection Dialog Box" on page 737.

New Function Library Click theNew down arrow and select Function Library.

New Application Area Click theNew down arrow and select Application Area.

New Solution Click theNew down arrow and select Solution.

Open Test/Business
Component/Application
Area

Click theOpen down arrow and select the type of
document to open.

Open Function Library Do one of the following:

l Click theOpen down arrow and select Function
Library.

l In an application area, click Function Libraries pane > Add

Function Library , then click the browse button.

Open Data Table dialog
box

Select File > Settings > Resources tab > Other location radio
button. Then click the browse button.

Open Recovery
Scenario dialog box

Do one of the following:

l Select File > Settings > Recovery node > Add button , then
click the browse button.

l Select Resources > Recovery Scenario Manager > Open
button.

l In an application area, click Additional Settings pane >
Recovery node > Add button , then click the browse button.

For details on recovery scenarios, see "Recovery Scenarios
Overview" on page 1112.

Open Shared Object
Repository window

Do one of the following:

l Select Resources > Associate Repositories > Add
Repository button .

l Select Resources > Object Repository Manager. Then, in the
Object Repository Manager window, select File > Open or click

Open .

l In an application area, click Object Repositories pane > Add

Object Repository , then click the browse button.

User Guide
Chapter 3: UFT File Operations

HP Unified Functional Testing (12.00) Page 158 of 2274



Open XML File dialog
box

Do one of the following:

l Select Design > Checkpoint > XML Checkpoint (From
Resource). Then, in the "XML Source Selection - Checkpoint /
Output Value Properties Dialog Box" (described on page 1482),
select Create checkpoint from XML file and click Browse.

l Select Design > Output Value > XML Output (From
Resource). Then, in the "XML Source Selection - Checkpoint /
Output Value Properties Dialog Box" (described on page 1482),
select Create output value step from XML file and click the
browse button.

Open Environment
Variable File dialog box

1. Select File > Settings > Environment node > User-defined
variable type.

2. Select the Load variables and values from external file
check box and click the browse button.
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Important
information

l When you create a new document in the file system, UFT suggests a default
folder. For all supported operating systems prior toWindows Vista, this folder
is located under your UFT installation folder. ForWindows Vista and later
operating systems, this folder is located underMy Documents.

l After you create the document, it is automatically saved in the specified
location.

l When you open a document in read-only mode, the title bar displays Read
Only and all tabs associated with that document (for example, actions in a
test) display a lock icon.

l Each time you open a document using File > Open, it replaces and closes any
documents or solutions currently in use.

l You can also open a recently used test or component by selecting from the
Recent files in the File menu. If you select a test or component when you are
not connected to an ALM project, or if you select a component that is stored in
a different ALM project, UFT displays amessage asking you if you want to
connect to that project.

l If you try to open a document and there is an error with loading the test (such
as ALM connectivity problems or a changed document name), an error
describing the problem is displayed in the Errors pane.

l If your GUI test has locked resources, see "Open Test with Locked Resources
- Message Box" on page 163.

l For BPT in UFT: The first time that you open a business process test or flow
from UFT, youmust connect as a user with administrator privileges on the
computer on which you are connecting.

l When trying to open a test saved in Service Test, version 11.10 or 11.20, UFT
prompts you to upgrade the test using the Batch Upgrader tool (described on
page 143). If the test or component was created in Service Test 11.00, you
must first open and save it in Service Test 11.10 before you can upgrade it
using the Batch Upgrader.

l If you try to open a test or component last saved in a version of QuickTest
earlier than 9.5, an error message is displayed in the UFT Error Pane. You
must first open it in QuickTest 10.00 or 11.00 to upgrade it. Assets last saved
in QuickTest 10.00 or later can be opened directly in UFT.

Relevant
tasks

"How to Create andManage Documents" on page 136
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<sidebar> The location in which the document is stored, for example File System, ALM Test
Plan, orALM Resources.

Note:

l Youmay need to select a different location before browsing to your
document.

l Tests stored in ALM are always stored in ALM Test Plan. Business
components are always stored inALM Components. Application areas are
always stored inALM Resources.

Look in The path for the document. You can use the down arrow to navigate to the required
folder, or you can double-click a folder in the file area to navigate to the required
folder.

<file list
area>

The folders and/or documents stored in the current path.

Note: (for ALM users) If the document is stored in an ALM project with
version control support, you can view version control information for the
document by clicking theViews down arrow and selectingDetails. For details,
see "Checking Assets Out of the Version Control Database" on page 797.

File name The name of the document selected in the file list area.

Files of
type

Filters the list of displayed folders or documents to display the selected file type. If
the current folder contains other file types, those files are hidden.
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UI
Element Description

Open in
read-only
mode

Opens the document in read-only mode. This option enables you to view the
document but not modify it.

Note: (for ALM users) A document also opens in read-only mode if:

l You opened a document that is currently checked in to the version control
database (for projects that support version control).

l You opened a document that is currently checked out to another user (for
projects that support version control).

l You opened a document from an earlier version of ALM and the document
has not yet been updated to the current format.

For details, see "Checking Assets Out of the Version Control Database" on page
797.

Open Opens the selected document.
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Open Test with Locked Resources - Message Box
Relevant for: GUI tests only and API tests

This message box opens when you try to open a document that is associated with a locked
resource file, such as a locked data table or object repository file.

To access Open a document with a locked resource file, such as a locked data table or
shared object repository.

Important
information

When you try to open a document with locked resource files, the locked resource
files open in read-only mode. You can open the document in "Read-Only" or
"Read-Write" mode.

See also "Opening and Saving Tests with Locked Resources" on page 134
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User interface elements are described below:

UI
Element Description

Read-
Only

Opens the document in read-only mode, enabling you to run it but not make any
changes to it. All editing options are disabled and you cannot edit the document.

Note: Even though the document itself cannot be saved, if you run the document
and choose to save the results, the results file is saved.

You can select theSave As option from the Filemenu, save the document under a
new name, and then edit the document. The same is true for a shared object
repository file opened in read-only mode.

Read-
Write

Opens the document in read-write mode, enabling you to run and edit it, and save any
changes youmake to it. However, any changes to referenced and locked UFT files
cannot be saved. Locked resource files are opened in read-only mode even if the
referencing document is opened in read-write mode.

Example: Suppose you open a test in read-write mode that has a locked data
table associated with it. When you edit the test, any changes to the data table are
not saved. If any of the data table values change as a result of editing the test,
and you save the changes to the test, the test may fail the next time it calls the
unmodified data table values.

It is therefore recommended to open the test in read-only mode or to close the test
without saving.

Save <Resource>/Save <Document> As Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to save a new resource, or save a copy of an existing document with
another name. You can save the document or resource in the file system or your ALM project, if
UFT is currently connected to an ALM project.

This section describes the following dialog boxes:

l Save Function Library dialog box

l Save SharedObject Repository dialog box

l Save Recovery Scenario dialog box

l Save Environment Variable File dialog box

l Save (Test/Business Component/Application Area/Function Library) As dialog box
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To access

Prerequisite for
ALM

Connect to your ALM project if needed. For details, see "ALM Connection
Dialog Box" on page 737.

Save Function
Library

In an application area sidebar, click Function Libraries and then click

Create Function Library .

Save Shared
Object
Repository

Do one of the following:

l In the Object Repository Manager, select File > Save/Save Aswhen
working with an object repository.

l In an application area sidebar, click Object Repositories and then click

Create Object Repository .

Save Recovery
Scenario

In the Recovery Scenario Manager, click theSave button after creating a
recovery scenario.

Save
Environment
Variable File

In the Test Settings dialog box, select an environmental variable and click
Export.
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Save As
(for tests, and
business
components,
application areas,
and function
libraries)

Do one of the following:

l In the document pane, right-click the document tab, and select Save
<document name> As.

l Select File > Save <document name> As.

l For API testing only: File > Save (Other) > Save <component name
> As Business Component.

l For GUI testing only: Select Save or click theSave button in the
resource dialog box

Important
information

l Youmust use theSave As option in UFT to save a document with
another name or create a copy of a document. You cannot copy a
document or change its name directly in the file system or in ALM.

l If changes aremade to an existing document, an asterisk (*) is
displayed in the title bar until the document is saved.

l For GUI components: If you want to associate a resource file with an
application area, and take advantage of the Resources and
Dependencies model, save the resource file to the ALM Test
Resources module in an ALM project. For details, see "Resources and
Dependencies Model Terminology" on page 759.

Relevant tasks "How to Create andManage Documents" on page 136

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<sidebar> The location in which to save the document or resource, for example, File
System orALM Test Plan.

Note: For business components the location is always ALM Components,
and for and application areas it is always ALM Resources. For business
process tests or flows, the location is always ALM Test Plan.

Look in The path for the folder in which to save the document or resource. You can use
the down arrow to navigate to the required folder, or you can double-click a folder
in the file area to navigate to the required folder.

Note: (for application areas only)Youmust save application areas in the
default location. If you need tomove the application area after saving it, you
can do that from within ALM, as described in theHP Application Lifecycle
Management User Guide.
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UI Element Description

<file list
area>

The folders and/or documents or resource files stored in the current path.

Note: (for ALM users) If the document is stored in an ALM project with
version control support, you can view version control information for the
document by clicking theViews down arrow and selectingDetails. For
details, see "Checking Assets Out of the Version Control Database" on
page 797.

File name The name of the document or resource. Use a descriptive name that helps you
and others identify the document or resource easily.

Naming conventions: See "Troubleshooting - Naming Conventions" on page
2269

Files of type Filters the file types displayed in the file list area. You can choose to display a
specific type of file or all file types.

Save Active
Screen files
(GUI tests
and scripted
GUI
components
only)

Saves the Active Screen files with your test or scripted component. If you clear
this check box, your Active Screen files will not be saved, and you will not be
able to edit your test or scripted component using the options that are normally
available from the Active Screen.

Tip:

l If you are using the test or scripted component only for run sessions, and
if you want to conserve disk space after you finish designing the test or
scripted component, clear theActive Screen files check box.

l If you had previously cleared the Save Active Screen files check box,
and now want to edit your test or scripted component using Active
Screen options, regenerate the Active Screen information by performing
anUpdate Run operation. For details, see "How to Update Test Object
Descriptions, Checkpoints, or Output Values, or Active Screen
Captures" on page 1088.

l To set Active Screen preferences, such as instructing UFT not to capture
Active Screen files while recording or to only capture Active Screen
information under certain conditions, you canmodify the options in the
Active Screen pane of the Options dialog box (Tools > Options > GUI
Testing tab > Active Screen node). For details, see "Active Screen
Pane (Options Dialog Box > GUI Testing Tab)" on page 547.

For details on the Active Screen and its uses, see "Active ScreenOverview" on
page 194.

User Guide
Chapter 3: UFT File Operations

HP Unified Functional Testing (12.00) Page 167 of 2274



UI Element Description

Save run
results
(GUI tests
only)

Saves any existing run results with your document.

Note: The check box is available only for documents that are saved in the
file system, and that ran at least once.

If you clear this check box, your run result files are not be saved, and you will not
be able to view them later.

Tip: To conserve disk space if you do not require the run results for later
analysis, or if you are saving an existing document under a new name and do
not need the run results, clear theSave run results check box.

For details on run results, see theHP RunResults Viewer User Guide.

Save Test with Locked Resources - Message Box
Relevant for: GUI tests and API tests

This message box opens when you save a read-write document with locked resource files, which
have changed since you opened the associated document.
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To access Save a document with a locked resource file that has beenmodified during the
current UFT session.

Important
information

It is recommend to avoid saving documents when locked resource fields have
beenmodified. If you do save the document, the next time you run the test or
component, the runmay fail because of unexpected resource file values.

See also "Opening and Saving Tests with Locked Resources" on page 134

Save Test with Resources Dialog Box
Relevant for: GUI tests

This dialog box enables you to save a fully portable copy of a test and its resource files to a local
drive or other storage device, eliminating the need for network or ALM connections.

To access Select File > Save (Other) > Save <test name> with Resources.
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Important
information

Before you create a copy of the test:

l Resolve any missing resources.

l Save the original test.

l Make sure that the test and its resources are all updated to the current UFT
version.

l Make sure that all files associated with the source test are editable.

l Make sure you have write permissions for the folder in which you want to
create a copy of the test.

After you make a copy of the test:

l A report is generated in HTML format, listing:

n The name of the test, the name of the user that saved this copy of the test,
and the date on which the test was copied.

n A record for each resource that was copied with the test, specifying:

o the name of the resource

o the type of resource (for example, function library, an external data
table, or shared object repository)

o the path from which the resource was copied-- the status of the copied
resource (for example, the resource was saved successfully)

o the current location of the copied resource

You can open the HTML report from the copied test's root folder.

l The copied test becomes the active test in the UFT window.

l All links to the source files are severed. Therefore, any modifications you
make to the copied test are applied only to the copied test.

l Any external actions associated with your test are saved as internal actions
when saving a test with resources.

Relevant
tasks

"How to Create andManage Documents" on page 136

See also "Portable Copies of Tests" on page 133
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

Name The name for the saved test.

Naming conventions: See "Troubleshooting - Naming Conventions" on page 2269

Save
Location

Specifies the root folder in which to save the test. By default, for any operating
system prior toWindows Vista, the root folder is <UFT installation folder>\Tests.

ForWindows Vista and later operating systems, the root folder
is:...\MyDocuments\HP\Unified Functional Testing. However, you can specify any
folder on a local, network, or portable drive.

Note: The folder you specify must not already contain a sub-folder with the
same name as the test.

Save
Active
Screen
files

Instructs UFT to save any existing Active Screen files with your test.

Clearing the Save Active Screen files check box can be especially useful for
conserving disk space if you have finished designing the test and are using the test
only for run sessions.

Note: If you clear this box, your Active Screen files are not copied over with the
test and its resources, and you are not able to edit your test using the options
that are normally available from the Active Screen.

Tip: If you clear the Save Active Screen files check box and later want to edit
your test using Active Screen options, you can regenerate the Active Screen
information by performing an Update Run operation. For details, see "How to
Update Test Object Descriptions, Checkpoints, or Output Values, or Active
Screen Captures" on page 1088.

Archive
test and
resource
files in a
.zip file

Creates a .zip file of the test and its resources, and stores the .zip file in the folder
you specified in the Save Location box.
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New Test Profile Dialog Box
Relevant for: API testing only

This dialog box enables you to create a new profile for your test with pre-defined user variables.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the Solution Explorer, select an API test or component.

2. Select theStart orEnd step in the canvas.

3. In the Properties pane, open theUser Variables view .

4. Click theAdd Profile button .

Relevant tasks "How to Define API Test Properties or User/System Variables" on page 141

User interface elements are described below:

UI Element Description

Name A name for the profile as it will appear in the profile list drop down list.

Copy properties from
existing profile

A drop down list of existing profiles.

Default:Do not copy properties, creates a new empty profile with the
user variables of the active profile, without values.

User Guide
Chapter 3: UFT File Operations

HP Unified Functional Testing (12.00) Page 172 of 2274



Manage Profiles Dialog Box
Relevant for: API testing only

This dialog box enables you to remove and rename user variable profiles.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the Solution Explorer, select an API test or component.

2. Select theStart orEnd step in the canvas.

3. In the Properties pane, open the Test Variables view .

4. Add additional profiles usingAdd Profile.

5. Click theManage Profiles button .

Relevant tasks "How to Define API Test Properties or User/System Variables" on page 141

User interface elements are described below:

UI Element Description

Profiles List A list of all the profiles defined for this test.

Rename Allows you to rename the selected profile.

Remove Deletes the selected profile.
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Batch Upgrader Command Line Options
Relevant for: API testing only

You operate the batch upgrade tool from the command line. For task details, see "How to Upgrade
API Tests Using the Batch Upgrader " on page 143. The following table describes the command
line options:

UI
Elements Description

/ALM Indicates that ALM connection information will follow.

/log Indicates that the log will be written to an alternate file. By default, log files are
store in the <UFT installation>\bin\logs folder.

/login Indicates that login information will follow.

/report Instructs the upgrader tool to generate a summary report.

destination l For tests on the File system: The full UNC path of the folder in which to store
the tests after the upgrade.

l For tests in ALM: a target folder path under the Test Planmodule, in which to
store the upgraded tests.

Note:

l The destination valuemust be a local or remote folder with the samewrite
access permissions as the source path.

l The destination folder should be an empty folder that does not include any
tests.

l If you do not specify a destination folder, the tests will be upgraded in the
source folder, overwriting the originals.

domain The name of an ALM domain in which the source tests are stored.

logfile The full path of the file to which the log will be written.

project The name of an ALM project in which the source tests are stored.

reportfile The full path of an existing folder, with the file name including an extension, to
where the summary report should be written. For example,
c:\logs\MySummary.txt.
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UI
Elements Description

source l For tests on the File system: The full UNC path of the folder containing the
tests to be upgraded.

l For tests in ALM: a source folder path under the Test Planmodule).

url The URL of an ALM instance to which to connect in the following form: http://
{instance_domain}:8080/qcbin

username,
password

For ALMmode, the username and password with which to log in to the ALM
project.

soapUI to API Test Converter
Relevant for: API testing only

Using the soapUI Converter tool, you can convert soapUI tests to UFTAPI tests.

To
access

Do one of the following:

l Select soapUI to API Test Converter from the product's Tools section under
theStartmenu.

l Run the soapUI2APITest.exe file from the product's bin folder.

User Guide
Chapter 3: UFT File Operations

HP Unified Functional Testing (12.00) Page 175 of 2274



User interface elements are described below:

UI Element Description

soapUI project The absolute path of the .xml file representing the soapUI project.

Destination folder The target folder in which to store the converted test.

Convert Begins the conversion process.

Command Line Syntax
You can also run the soapUI converter utility from the command line. Run the following command in
the command line:

soapUI2APITestCMD.exe /<source soapUI_file> /destination <destination directory>/
logs <log_directory>

Command line options are described below:

Command
Line Switch Description

/source The absolute path to the soapUI file with an .xml extension, to be converted.

/destination The absolute path of the folder to where the created API tests will be written.

/logs
(optional)

The absolute path of the folder in which to write the log file. If this option is
omitted, the log file is written to the destination folder.

-? or /? Show the parameters and their usage. For example: soapUI2APITestCMD.exe
-?
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Troubleshooting and Limitations - UFT Testing
Documents

Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitation for working with testing documents:

Troubleshooting and Limitations - Opening and Saving Tests 177

Troubleshooting and Limitations - Upgrading Service Test Tests 179

Troubleshooting and Limitations - Opening and Saving
Tests

Relevant for: GUI tests and components and API testing

This section describes general troubleshooting and limitation for creating, opening and saving
testing documents, as well as opening tests or components last modified in previous versions of
QuickTest or Service Test.

Folder names
It is not possible to create an API test in a path containing a '=' character.

Opening documents stored in ALM
Opening a document from the Recent Files.

You can open components from theRecent files list in the Filemenu. If you select a test located in
an ALM project, but UFT is not currently connected to the correct project, the Connect to ALM
Project dialog box opens and displays the correct server, project, and the name of the user who
most recently opened the test or component on this computer.

This dialog box also opens if you choose to open a test or component that was last edited on your
computer using a different ALM user name. You can either log in using the displayed name or you
can click Cancel to stay logged in with your current user name.

Opening a document that was last modified in an earlier version of QuickTest.

If a test is stored in ALM and was last modified using a version of QuickTest earlier than 9.5, it
opens in read-only mode. To edit the test, it must be upgraded to QuickTest 11.00 using the
QuickTest Asset Upgrade Tool for ALM (found on theQuickTest 11.00 installation DVD). After
upgrading the test to QuickTest 11.00, you can open it in UFT.

Opening a solution containing test documents stored in ALM.

Testing documents that are part of the same solution cannot be stored in different ALM projects,
domains, or servers.
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Opening documents stored in the file system
UFT does not support hidden files. If youmark a UFT test, or other UFT file as hidden (by selecting
theHidden attribute), UFT may behave unexpectedly.

Opening a document that was last modified in an earlier version of QuickTest.

l If you try to open a test or component last saved in a version of QuickTest earlier than 9.5, an
error message is displayed in the UFT Error Pane. Youmust first open it in QuickTest 10.00 or
11.00 to upgrade it. Assets last saved in QuickTest 10.00 or later can be opened directly in UFT.

l If the test contains objects in the local object repositories of one or more actions in the test, the
relevant add-in must be installed to convert the test to the current format. Otherwise, the test
opens in read-only format.

l If you choose to convert the test, it is updated to the current format and you canmodify it as
needed. If you save the converted test, it cannot be used with earlier versions of QuickTest.

l If you choose to view the test in read-only format, it appears as it did previously, using all of its
original settings, but you cannot modify it.

l If you havemany tests that need to be updated to the current format, you can create a script that
iterates through all of your tests to open and save each one in the new format. For details on
creating scripts, see "UFT Automation Object Model Overview" on page 1156.

To view a sample script that converts old tests to the current version, see theConvert a Set of
Tests from an Older QuickTest Version to the Current Version example in theHP UFT
Automation Object Model Reference (Help > HP UFT GUI Testing Advanced References
Help > HP UFT Automation Object Model Reference).

Opening a document that was last modified in an earlier version of Service Test.

When trying to open a test saved in Service Test, version 11.10 or 11.20, UFT prompts you to
upgrade the test using the Batch Upgrader tool (described on page 143). If the test or component
was created in Service Test 11.00, youmust first open and save it in Service Test 11.10 before you
can upgrade it using the Batch Upgrader.

Opening and saving tests with resources

l If a test has locked resource files, you can open the test in read-only mode or in read-write mode.
In all cases, the locked resource file opens in read-only mode.

For details, see "Opening and Saving Tests with Locked Resources" on page 134.

For a description of the displayedmessage boxes, see "Open Test with Locked Resources -
Message Box" on page 163 and "Save Test with Locked Resources - Message Box" on page
168.

Opening and saving documents in Windows 7

l The Libraries feature of Windows 7/Windows 8 is not supported. If you attempt to open a test
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from a library location or save a test to a library location, UFT may behave unexpectedly.

Workaround:Browse to your saved tests using standard file paths, even if they are included in
a library, such as the Documents library.

For example, to browse for a test that is stored in the default UFT folder, use:

Computer > C: > Program Files > HP Software > HP Unified Functional Testing> Tests > <Tes
tName>

Instead of:

Libraries > Documents > HP Unified Functional Testing > <TestName>

l If you work with UFT on aWindows Vista, Windows 7, orWindows 8 operating system with
User Account Control (UAC) enabled, and you open a test from a protected location (such as
Program Files), it is opened in read-only mode and amessage is displayed that you do not have
permissions to open it in read-write mode.

Unexpected read-only files
Documents that were saved in the file system in system folders like (%Windir% orProgram files)
while UAC was disabled can be opened only in read-only mode when the UAC is set to ON.

Workaround:Copy the asset to another location and open the files from the new location.

Multilingual support
Names and paths of tests and resources (for example, function libraries, object repositories, and
recovery scenarios) are not Unicode compliant and therefore should be specified in English or in the
language of the operating system.

Troubleshooting and Limitations - Upgrading Service
Test Tests

Relevant for: API testing only

This section describes limitations for opening tests last modified with earlier versions of Service
Test.

l When upgrading a test from version 11.00 (via 11.10), Service Test does not retain the Security
settings.

Workaround: In Service Test 11.00, save the Security Scenario to an .stss file. Import this file
for your service when you upgrade it. For details, see "Setting Security Overview" on page 1878.

l Tests last modified in Service Test 11.20 that contain aCall QuickTest Professional Test step,
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cannot be opened in UFT.

l In certain instances, if the upgrader was unable to upgrade the test, youmay need tomodify the
code tomake it compatible with the current version:

n The user code file is now titled TestUserCode.cs.

n The namespace at the beginning of the test is Script.

n The class definition is public class TestUserCode : TestEntities.

namespace Script
{
        using System;
        using System.Xml;
        using System.Xml.Schema;
        using HP.ST.Ext.BasicActivities;
        using HP.ST.Fwk.RunTimeFWK;
        using HP.ST.Fwk.RunTimeFWK.ActivityFWK;
        using HP.ST.Fwk.RunTimeFWK.Utilities;
        using HP.ST.Fwk.RunTimeFWK.CompositeActivities;
        using System.Windows.Forms;
        using HP.ST.Ext.FTPActivities;

[Serializable()]
        public class TestUserCode : TestEntities
        ...

n The args variable is no longer supported.

Workaround:Change the args variable name to the concrete Activity name as it appears at
the top of the Properties pane. For example, change args.Output.outStr = args.Input.inStr; to
CodeActivity8.Output.outStr=CodeActivity8.Input.inStr.

n The soapUI to API Test Converter tool does not support links between steps. If you convert a
soapUI test with linkedWeb service calls, the links will not be transferred to the API/Service
Test test.
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Chapter 4: UFT Window Layout
Relevant for: GUI tests and components and API testing

This chapter includes:

Concepts 183

UFTWindow Layout Customization - Overview 183

Tasks 184

How to Customize the UFTWindow 184

Reference 191

Tips and Considerations for Customizing the UFTWindow Layout 191

Troubleshooting and Limitations - UFTWindow Layout 192
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Concepts

UFT Window Layout Customization - Overview
Relevant for: GUI tests and components and API testing

You canmodify the layout of the UFT window. For example, you canmove and resize panes,
select to show or auto-hide panes, create tabbed panes, and select which toolbars to display. If
needed, you can also restore the default layout.

You can also resize the UFT window to suit your needs for each type of UFT session (view/edit,
record, and run sessions). For example, you can display UFT in full view when creating or editing a
test, component, or application area, andminimize the UFT window during a run session.

When you customize or restore the UFT window layout, UFT applies the changes to all document
types and session types.

UFT Window Layout Customization in Different Modes
UFT works in several different modes: view/edit, run, and record (for GUI testing only). Youmay
want to modify the UFT layout to match the functionality of amode. For example, when recording a
GUI test or component, it is often convenient to have UFT partially visible. This enables you to
watch steps being added as you record your test without viewing the Active Screen. In addition,
when running a test or component, it is often convenient to minimize UFT so that you can view your
application during the run session. When viewing or editing a test or component, it may be
convenient to maximize the UFT window, with all panes showing.

UFT remembers the size and location of its main window and all of its panes for eachmode. When
UFT enters amode, the layout reverts to themost recently used layout for that mode. This means
that themain UFT window and each of its panes aremaximized, minimized, or resized, based on
the previous layout of the current mode.
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Tasks

How to Customize the UFT Window
Relevant for: GUI tests and components and API testing

This section describes how to customize andmodify the UFT window layout and panes.

This task includes the following steps:

l "Move Panes" below

l "Show and Hide Panes" on page 188

l "Float and Dock Panes" on page 189

l "Set the UFT Layout for RecordMode" on page 190

l "Set the UFT Layout for RunMode" on page 190

l "Restore the Default Layout of the UFTWindow" on page 190

Move Panes
You canmove the UFT window panes to suit your own personal preferences. You can rearrange the
panes, and you can also change a pane to a tabbed pane, and vice versa.

1. In the UFT window, drag the title bar or tab of the pane you want to move. (If the required pane
is not displayed in the UFT window, you can select it from theViewmenu).

For example, you canmove the Data or Errors pane located at the bottom of the window to be a
new tabbed pane at the top right of the window. As you drag the pane, markers are displayed in
the active pane and on each edge of the UFT window.

2. Repeat this procedure for each pane you want to move.
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During themoving process, the followingmarkers are displayed:

Type Marker Description

Current
pane
markers

Enables you to:

n position the pane as a new pane in the top, bottom, left or right half,
or middle of the active pane, according to the arrow marker selected
when you release themouse button.

n position the pane as a new tabbed pane in the active window, by
releasing themouse button while selecting the center marker.

Note: The center marker is displayed only if you are dragging a
pane onto an existing pane (other than the document pane).

Window
pane
markers

Enables you to position the pane across the top of the UFT window.

Enables you to position the pane across the right side of the UFT
window.

Enables you to position the pane across the bottom of the UFT window.

Enables you to position the pane across the left side of the UFT
window.
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The following examples (from left to right) illustrate an example of the UFT window at the
beginning of themoving process, during themoving process, and after themoving process,
respectively.
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The following illustrates an example of the UFT window during themoving process.
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The following illustrates an example of the UFT window after themoving process.

Show and Hide Panes
After youmove the panes to their default positions, you can decide whether these panes should be
displayed at all times, or whether you want to auto-hide them, and only display them as required.
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To auto-hide panes, select the button option in the pane you want to auto-hide and display as a side-
tab on one of the edges of the UFT window. The following buttons may be displayed on the title bar:

Button Description

TheMenu button enables you to select any of the following:

l Float. Opens the pane on top of all the other windows and panes as a separate
window, with its own title bar.

l Show. Opens the pane in its default location if it is hidden.

l Dock as Tabbed Document. Changes the pane to a tab in the document pane.

l Auto-hide. Displays the pane as a side-tab either at the top or bottom of the UFT
window, or on one of the edges, according to its position in the UFT window.

l Hide. Closes the pane.

TheAuto Hide button hides the pane.

The pane is displayed as a side-tab either at the top or bottom of the UFT window, or on
one of the edges, according to its position in the UFT window.

To display the pane, hold the cursor over the side-tab. The button toggles to theDock
button, shown below.

TheDock button docks the pane to the UFT window.

The pane returns the position it was in before it was hidden, and the button toggles to
theAuto Hide button, shown above.

TheClose button closes the pane.

The pane is removed from the UFT window. To reopen the pane, select it from theView
menu.

Tip: You can also close a pane by right-clicking and choosingHide from the
context menu.

Float and Dock Panes
Docked panes are fixed in a set position relative to the rest of the application. For example, when
youmove a pane to a position indicated by amarker, the pane is docked in that position.

Floating panes are displayed on top of all other windows. They can be dragged to any position on
your screen, even outside the UFT window. Floating panes have their own title bars.

l To float a pane, right-click the title bar, and choose Float from the context menu. The pane
opens on top of all the other windows and panes, with its own title bar.
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l To dock a pane, double-click the title bar, or right-click the title bar and select Dock as Tabbed
Document. The pane returns to its previous position in the UFT window.

Set the UFT Layout for Record Mode

1. Open a new or existing GUI test or component.

2. Start a recording session.

3. Record one step.

4. Set all of your layout preferences for the recordingmode.

5. Stop the recording session.

Set the UFT Layout for Run Mode

1. Enter a breakpoint before the first step in the test. This enables you to arrange the layout during
the run session. For details on how to set a breakpoint, see "Breakpoints " on page 681.

2. Run your test or component.

3. When UFT reaches the breakpoint, set all of your layout preferences for the runmode.

4. Stop the run session.

Restore the Default Layout of the UFT Window
You can restore the default UFT window layout for all document types and panes at any time by
selectingView > Reset Window Layout.
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Reference

Tips and Considerations for Customizing the UFT
Window Layout

Relevant for: GUI tests and components and API testing

This section includes:

l "Moving Panes " below

l "Showing, Hiding, and Floating Panes " below

Moving Panes

l Tomove a dockable pane without snapping it into place, press CTRLwhile dragging it to the
required location.

l Tomove a single, tabbed pane, drag the tab label. When you start dragging the tabbed pane, the
tab is removed, and its title bar is displayed.

l Tomove all tabbed panes simultaneously, drag the title bar of the active tabbed pane.

Showing, Hiding, and Floating Panes

l To auto-hide all the tabbed panes, select the title bar of the active tabbed pane, right-click and
select Auto Hide. The tabbed panes are displayed as a group of side-tabs on the edge of the
UFT window, and each pane is displayed only when you hold the cursor over that side-tab.

l If you auto-hide the Errors pane, it is automatically displayed when syntax errors are detected in
a test script.

l You cannot auto-hide floating panes or individual tabbed panes.

l By default, auto-hidden panes open across the UFT window, according to their position in the
UFT window. For example, if the docked pane was positioned on the right side of the UFT
window, it is displayed as a side tab on the right edge of the UFT window, and opens across the
right side of the UFT window when selected.

l To float a pane, right-clicking the title bar and choosing Floating from the context menu. The
pane opens on top of all the other windows and panes, with its own title bar. To dock the pane,
double-click the title bar, or right-click the title bar and select Docking. The pane returns to its
previous position in the UFT window.
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Troubleshooting and Limitations - UFT Window Layout
Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for the UFT layout on your screen.

When UFT is displayed on a secondary monitor, some drop-down lists may appear on the primary
monitor.

Workaround: If you want to ensure that UFT is displayed on only onemonitor, display UFT on your
primary monitor.
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Chapter 5: Active Screen Pane
Relevant for: GUI tests and scripted GUI components

This chapter includes:

Concepts 194

Active ScreenOverview 194

Tasks 197

How to Use the Active Screen in Your Test 197

How toModify the Active Screen Settings 198

Reference 200

Active Screen Pane User Interface 200

Troubleshooting and Limitations - Active Screen Pane 202
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Concepts

Active Screen Overview
Relevant for: GUI tests and scripted GUI components

The Active Screen provides a view of your application as it appeared when you performed the
corresponding step during a recording or Update Run session.

ForWeb-based applications the Active Screen uses the actual HTML of the captured page. For
Windows-based applications, the Active Screen captures an 'active' snapshot of the page , which
includes images of the objects as well as object property data.

An Active Screen can be captured for every step. Additionally, depending on the Active Screen
capture options that were set at the time that you recorded or updated your test, the page displayed
in the Active Screen can contain detailed property information on each object displayed on the
page. For details on setting Active Screen recording options, see "Enhancing Your Tests" on page
815.

The Active Screen enables you to parameterize object values and insert checkpoints, methods,
and output values for almost any object in the page after you finish your recording session, even if
your application is not available or you do not have a step in your test corresponding to the selected
object.

If UFT captured object information while recording (or updating) your test, you can use the Active
Screen to add these objects to the local object repository.

This section includes:

l "Active Screen Capture Settings" below

l "Active Screen Settings for UFT Add-ins" on the next page

l "Active ScreenMaintenance" on page 196

l "Tips for Improving Active Screen Performance" on page 196

Active Screen Capture Settings

l You can specify the level at which UFT captures and stores information on objects for Active
Screen captures. For example, you can instruct UFT to capture all properties for all test objects
on the captured screen, or only the properties of the recorded objects and their parents.

l You can decide how much information you want to capture and save in the Active Screen. The
more information you capture, the easier it is to add steps to your test using themany Active
Screen options. However, more captured information also leads to slower recording and editing
times. Removing or decreasing Active Screen information can be especially useful for
conserving disk space after you have finished designing the test and you are using the test only
for test runs.
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l If you find that the information saved in the Active Screen after recording is not sufficient for your
test editing needs, or if you no longer need Active Screen information, and you want to decrease
the size of your test, you can change the amount of Active Screen information saved with your
test.

For details on configuring the Active Screen capture settings, see "Active Screen Pane (Options
Dialog Box > GUI Testing Tab)" on page 547.

Active Screen Settings for UFT Add-ins
Active Screen for Web-based Applications

l The Active Screen displays the captured HTML content using an Internet Explorer browser
control, even if you ran your steps on another browser. Additionally, depending on your settings,
the Active Screenmay capture your HTML page before or after various scripts ran on the page.
For these reasons, some pages may look slightly different in the Active Screen than they
appeared during your record or update run session, and some property values may be different or
may not be available, for example, if those properties are supported one browser, but not in
another.

The Active Screen also stores DOM information in Internet Explorer format. Therefore, if you
insert theObject property for aWeb object when only Active Screen object data is available (the
object is not displayed in an open application), then UFT's statement completion feature
displays the available native operations and properties for the Internet Explorer DOM, even if
you recorded the object in another browser.

UFT stores the URL path to images and other resources on the page, rather than downloading
and storing the images with your test. Therefore, youmay need to provide login information to
view password-protected resources. For details on accessing password-protected resources in
the Active Screen of aWeb-based application, see the section on accessing password-
protected resources in the active screen in theHP Unified Functional Testing Add-ins Guide.

l You can specify Active Screen display criteria for capturedWeb pages. For example, you can
specify whether UFT should load ActiveX controls or Java applets. For details, see "Active
Screen Pane (Options Dialog Box > GUI Testing Tab)" on page 547.

Active Screen Non-Web-based Applications

l Active Screen pages for non-Web-based applications are based on a single bitmap capture of
the visible part of the application window (or other top-level object), with context-sensitive areas
representing each object displayed in the Active Screen.

l You can choose whether or not to save the content of the Active Screen with your test. Saving
the content of the Active Screen with your test is especially useful if you want to be able to edit
the saved test directly from the Active Screen. Later, if you need to conserve disk space after
you finish editing the test, and you plan to use your test only for test runs, you can save the test
without the content of the Active Screen. (Tests without Active Screen files use significantly
less disk space.)
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Active Screen Maintenance
As the content of your application changes, you can continue to use the Active Screen from tests
that you recorded previously. To do this, you update the selected Active Screen display so that you
can use the Active Screen to add new steps to your test rather than re-recording steps on new or
modified objects.

Example:

Suppose that one of the pages in yourWeb site now includes a new object and you want to add
a checkpoint that checks this object. You can use theChange Active Screen command to
replace the page in your Active Screen pane and then proceed to create a checkpoint for this
object.

For more details, see "How toModify the Active Screen Settings" on page 198.

It is also possible to update all Active Screen captures saved with a test using the Update Run
Mode. For details, see "Update Options Tab (Update Run Dialog Box)" on page 1107.

Tips for Improving Active Screen Performance

l For Windows-based applications: You can choose to save all Active Screen information in
every step, save information only in certain steps, or to disable Active Screen captures entirely.
You set this preference in the Active Screen pane of the Options dialog box (Tools > Options >
GUI Testing tab > Active Screen node). The less information saved, the faster your recording
times will be. For more details, see "Active Screen Pane (Options Dialog Box > GUI Testing
Tab)" on page 547.

l For Web-based applications: You can disable the screen capture of all steps in the Active
Screen to improve recording time. For details, see "Active Screen Pane (Options Dialog Box >
GUI Testing Tab)" on page 547.

l If you are testing an application using a UFT add-in, see theHP Unified Functional Testing Add-
ins Guide to determine whether special Active Screen screen capture options exist for that
environment.

l Tests without Active Screen files use significantly less disk space. For more details, see "How
toModify the Active Screen Settings" on page 198.

User Guide
Chapter 5: Active Screen Pane

HP Unified Functional Testing (12.00) Page 196 of 2274



Tasks

How to Use the Active Screen in Your Test
Relevant for: GUI tests and scripted GUI components

This task describes the different operations you can perform in the Active Screen pane, and
includes the following steps:

l "View object information as it appeared during a recording session" below

l "Insert steps on objects in the application" below

l "Insert output values on objects in the application" below

l "Insert checkpoints on objects in the application" below

View object information as it appeared during a recording session

1. Right-click the object in the Active Screen, and select View/Add Object. TheObject Selection
dialog box opens. For details, see "Object Selection Dialog Box " on page 1195.

2. Select the object you want to view and click OK. TheObject Properties dialog box opens. For
details, see "Object Properties Dialog Box" on page 1271.

Insert steps on objects in the application

1. Right-click the object in the Active Screen, and select Step Generator. TheObject Selection
dialog box opens. For details, see "Object Selection Dialog Box " on page 1195.

2. Select the object you want to view and click OK. The StepGenerator dialog box opens. For
details, see "Step Generator Dialog Box" on page 983.

Insert output values on objects in the application

1. Right-click the object in the Active Screen, and select Insert Output Value. TheObject
Selection dialog box opens. For details, see "Object Selection Dialog Box " on page 1195.

2. Select the object you want to view and click OK. TheOutput Value Properties dialog box
opens. For details, see "Step Generator Dialog Box" on page 983.

Insert checkpoints on objects in the application

1. Right-click the object in the Active Screen, and select one of the following:

n Insert Standard Checkpoint

n Insert Bitmap Checkpoint
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n Insert Text Checkpoint

TheObject Selection dialog box opens. For details, see "Object Selection Dialog Box " on page
1195.

2. Select the object you want to view and click OK. The relevant Checkpoint Properties dialog
box opens. For details, see "How to Insert a Checkpoint in a GUI Test or Component" on page
1419.

For a user interface description, see "Active Screen Pane User Interface" on page 200.

How to Modify the Active Screen Settings
Relevant for: GUI tests and scripted GUI components

The following steps describe how tomodify different settings of the Active Screen:

l "Increase or decrease the Active Screen information saved with a test" below

l "Stop saving Active Screen information and reduce the disk space used by your test" on the
next page

l "Update a single Active Screen capture" on the next page

l "Disable Active Screen capture to improve recording time" on the next page

Increase or decrease the Active Screen information saved with a test

1. Modify the Active Screen capture preference in the Active Screen pane of the Options dialog
box (Tools > Options > GUI Testing tab > Active Screen node) to capture the amount of
information you need. For details, see "Active Screen Pane (Options Dialog Box > GUI Testing
Tab)" on page 547.

2. Perform one of the following:

n Update Run Mode.This operation enables you to save the required amount of information
in the Active Screen for all existing steps. For details on theUpdate Run Mode options,
see "Update Options Tab (Update Run Dialog Box)" on page 1107.

n Re-record the steps. This enables you to specify the objects you want to add to the Active
Screen by performing one of the following:

o Select the step after which you want to record your step, position your application to
match the selected location in your test, and then begin recording.

o Place a breakpoint in your test at the step before which you want to add a step and run
your test to the breakpoint. This brings your application to the point from which to record
the step. For details on setting breakpoints, see "Breakpoints " on page 681.
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Stop saving Active Screen information and reduce the disk space used by
your test

1. Open the relevant test.

2. Select File > Save As and clear theSave Active Screen files check box.

Note: If you clear this check box, your Active Screen files will not be saved, and you will
not be able to edit your test using the options that are normally available from the Active
Screen.

3. Click Save to apply your changes. For details, see "Save <Resource>/Save <Document> As
Dialog Box" on page 164.

Update a single Active Screen capture

1. Make sure that your application is displaying the window or page that you want to use to
replace what is currently displayed in the Active Screen pane.

2. In the Keyword View, click a step that you want to change. The window or page is displayed in
the Active Screen pane.

3. Select Tools > Change Active Screen. The UFT window is hidden and themouse pointer
becomes a pointing hand. For details on using the pointing hand feature, see "Tips for Using
the Pointing Hand" on page 1196.

4. Click the window or page displayed in your application.

5. When amessage prompts you to change your current Active Screen display, click Yes.

Disable Active Screen capture to improve recording time
Click Custom Level to open "Custom Active Screen Capture Settings Dialog Box" on page 551,
and select theDisable Active Screen Capture option.

For more details, see "Tips for Improving Active Screen Performance" on page 196.
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Reference

Active Screen Pane User Interface
Relevant for: GUI tests and scripted GUI components

This pane enables you to view snapshots of your application as it appeared during a step in a
recording session. It also enables you to parameterize object values and insert steps, checkpoints,
methods, and output values for almost any object in the page at any time after the recording
session.

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the solution explorer, select a GUI test or component node, or one of its
child nodes.

2. Select View > Active Screen.

Important
information

l You can increase or decrease the Active Screen information saved with your
test. For details, see "Active Screen Pane (Options Dialog Box > GUI Testing
Tab)" on page 547.

l Additional context menu options may be available depending on the test object
selected in the Active Screen.

Relevant
tasks

l "How toModify the Active Screen Settings" on page 198

l "Adding and Deleting Test Objects in a Local or SharedObject Repository" on
page 1199

See also l "Active ScreenOverview" on page 194

l "Custom Active Screen Capture Settings Dialog Box" on page 551
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User interface elements and context menu options are described below (unlabeled elements are
shown in angle brackets):

UI
Elements Description

<active
screen
area>

The snapshot of the application at the time of recording the selected step. The
object used in the step is highlighted.

Insert
Standard
Checkpoint

Inserts a standard checkpoint on the selected object. For details, see "How to
Insert a Checkpoint in a GUI Test or Component" on page 1419.

Insert
Output
Value

Inserts an output value on the selected object. For details, see "Output Values
Overview" on page 1488.

View / Add
Object

Opens theObject Properties dialog box, which enables you to view object
properties and add the selected object to your local object repository. For details,
see "Object Properties Dialog Box" on page 1271.

Step
Generator

Opens the StepGenerator dialog box, which enables you to create a step using
the selected object. For details, see "Step Generator Dialog Box" on page 983.

Insert
Bitmap
Checkpoint

Inserts a bitmap checkpoint on the selected object. For details, see the areas
relevant to bitmap checkpoints in the "Checkpoint Properties Dialog Box" on page
1432

Insert Text
Checkpoint

Inserts a text checkpoint on the selected object. For details, see the areas
relevant to text/text area checkpoints in the "Checkpoint Properties Dialog Box"
on page 1432.
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Troubleshooting and Limitations - Active Screen Pane
Relevant for: GUI tests and components

l For steps that contain Insight test objects, the Active Screen provides only a visual reference to
the application and the test object's context. The Active Screen displays the Insight test object
highlighted within a screen capture of its parent object.

You cannot use the Active Screen of an Insight step to view object properties, to insert
checkpoints or output values, or to add objects to the object repository.

l TheOCR text recognitionmechanism is not supported for objects in the Active Screen.

l When creating objects, checkpoints, or output values from the Active Screen for objects in a
modal dialog box within aWeb browser, they are created under the Browser object and not under
theWindow object.

Workaround:Add the object directly from the application, for example by using theAdd
Objects to Local button in the Object Repository window.
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Chapter 6: Bookmarks Pane
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This chapter includes:

Concepts 204

Bookmarks Overview 204

Reference 206

Bookmarks Pane User Interface 206
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Concepts

Bookmarks Overview
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

You can use bookmarks when editing actions, scripted components, function libraries, or user code
files in the Editor. Bookmarks enable you to navigate between sections of your document more
easily. The bookmarks are saved on your file system on a per-user basis.

When you assign a bookmark, an icon is added to the left of the selected line of your document.

GUI testing example
In the following example, bookmarks have been added to the reusable GUI action in the Editor:
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API testing example
In the following example, bookmarks have been added to anAPI event handler:

The Bookmarks pane displays a list of all bookmarks added in any document connected with the
open test. Using the Bookmarks pane, you can:

l Add a new bookmark.

l Navigate to the location of the bookmark in your document.

l Navigate between consecutive bookmarks in the pane.

l Delete an individual bookmark.

l Clear all bookmarks.

For task details, see "How to Use Bookmarks in the Editor" on page 321.
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Reference

Bookmarks Pane User Interface
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

The Bookmarks pane displays the location of bookmarks in your action, scripted component,
function library, or user code files and enables you to navigate to these bookmarks.

To access Select View > Bookmarks.

Important
information

l All bookmarks added to test actions, scripted components, function libraries,
or user code file included in a saved solution aremaintained after you close and
reopen the pane, document, or UFT.

l Bookmarks are saved per solution, even if multiple users are working on the
same documents.

l Whenworking with documents saved in ALM, bookmarks aremaintained until
you close UFT.

Relevant
tasks

"How to Use Bookmarks in the Editor" on page 321

See also "Bookmarks Overview" on page 204
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<bookmarks
list>

All bookmarks connected with the open solution are displayed in the Bookmarks
pane. Even if a test is not open in the document pane, its bookmarks are still
displayed in the Bookmarks pane. Bookmarks are removed from the pane when
the solution is closed.

Example:When you open a solution, bookmarks in any test's actions and
associated function libraries (for GUI tests) or any relevant user code files (for
API tests) are displayed.

For each bookmark in the list, UFT displays the location of the bookmark's
document, the file name, and the line location of the bookmark. For documents
stored on ALM, the location of the local temporary copy is displayed. Bookmarks
inserted in a document or user code document are kept with the document when
it is saved in an ALM project.

Note: You can double-click the bookmark line to navigate directly to the
relevant line in your document. If a bookmark's document is not open, UFT
opens the relevant document.

Insert/Remove Bookmark. Inserts a bookmark in the current document in the
line where the cursor is currently located.

Previous Bookmark. Navigates to previous bookmark in the pane.

Next Bookmark. Navigates to next bookmark in the pane.

Delete. Deletes the currently selected bookmark from the relevant document and
from the list displayed in the pane.

Clear All Bookmarks. Deletes all bookmarks you have added from all
documents and from the list displayed in the pane.
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Chapter 7: The Canvas
Relevant for: GUI tests and API testing

This chapter includes:

Concepts 209

The Canvas 209

Reference 212

Canvas User Interface (GUI Testing) 212

Canvas User Interface (API Testing) 217
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Concepts

The Canvas
Relevant for: GUI tests and API testing

The canvas provides a visual representation of the GUI or API test flow. It opens as a tab in the
document pane.

For a GUI test, the canvas shows the flow of your test actions. For an API test, the canvas shows
the steps included in your test.

Business process tests and flows are displayed only in a grid view, and are not shown in the
canvas at all. For details about viewing business process tests and flows in the document pane,
see "Business Process Testing in UFT User Interface" on page 2074. For details about application
areas, see "Application Area User Interface" on page 2101.

The canvas has the following features:

Test Action Management (GUI Testing only)
You can access the Action Properties, as well as the Action Call Properties from the action on the
canvas. Using these properties, you can set the settings and properties for how your action is used
in the test.

For details on the Action Properties, see "Action Properties Dialog Box" on page 900. For details on
the Action Call Properties, see "Action Call Properties Dialog Box" on page 895.

Test Runs from a Specific Action (GUI Testing only)
Using the action context menu, you can run the test from a specific action or debug the test from a
specific action. As a result, you do not need to run an entire test to check if the selected action runs
as expected.

For details on using these commands, see "Running to a Step and Debugging from a Step " on page
678.

Step Manipulation
The canvas enables you tomanipulate the steps in the following ways:

l Reorder. Drag a step (for API tests) or an action (for GUI tests) from one location to another.

l Move Up or Move Down. (GUI Tests only)You can change the order of actions using the
Move Up orMove Down commands from the action context menu.

l Copy and Paste. (API Tests only)Select a step and press CTRL+C to copy it to the clipboard.
Press CTRL+V to paste it into another location within the Test Flow or to another loop.

l Delete. (API Tests only)Select a step and press the keyboard's Delete button.
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Flow Control (API Testing only)
By default, the canvas includes a Test Flow area to serve as a container for test steps. However,
you can also add special test flow steps including:

l Loop. Themain Test Flow area provides a default loop for test steps. However, you can add
additional loops to the test. Using the Properties pane, you can specify the type of loop, number
of iterations, and conditions for the Test Flow or loop.

l Conditional steps. Adds a two-branched conditional node to the test. You then add the
activities as part of the conditional branches.

l Break.Moves the test run to the step after the loop.

l Continue.Moves the test run to the first step in the surrounding Test Flow or Loop and begins
the next test iteration.

Alerts (API Testing only)
Steps that require additional information in order to run, such as HTTP Request/Response or
SOAP Request, Custom Code, andWait post an alert in their top right corner. Clicking an alert
button displays themissing values for the step. If you click on the alert details, the Properties pane
opens to the required property to resolve the alert.

You can also view this information in the Errors pane by selectingView > Errors. For details about
the Errors pane, see "Errors Pane" on page 364.
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Step Input/Output Property Connections (API Testing only)
The canvas displays the relationship between output and input properties/parameters. An arrow
indicates the relationship between the linked properties/parameters.

For details, see the "Select Link Source Dialog Box (API Testing)" on page 1840.

For details about linkingmultiple steps to a single result, see "Outgoing Links" on page 1808.

Tests of Individual Steps (API Testing only)
TheRun Step utility lets you run a single test step without running the entire test. Using the
property values from the Properties pane, theRun Step operation invokes the step locally and
presents the results in theRun Step Results pane. The following example shows the results of an
FTP File Get Size step.

For more details about individual step runs, see the "Run Step Results Pane" on page 454.

For details about theRun Step utility, see the "Run Step Dialog Box" on page 459.
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Reference

Canvas User Interface (GUI Testing)
Relevant for: GUI tests and components

The canvas provides a visual representation of the actions in the test flow and enables you to:

l Manage actions and change their order in the test

l Run your test from a selected action or to a selected action

l Debug your test from a selected action

l Display actions in the Keyword View or the Editor

To access 1. Create or open aGUI test.

2. Click the test tab.
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Important
information

l The canvas is displayed by default when you create a new test.

l You can close the test canvas by right-clicking a canvas tab and selecting
Close. Action tabs included in the test canvas remain open.

l If you close a test canvas tab, the next time you open a test, the canvas tab
will not open. To open the canvas tab, do one of the following:

n Double-click the <test name> node in the Solution Explorer

n Select View > Reset Window Layout.

l Working with the canvas closed can improve UFT's performance when
creating or opening aGUI test.

l For details on working with actions in your test, see "Actions in GUI Testing"
on page 871.

Relevant
tasks

l "How to Display andModify Action-Related Information" on page 886

l "How toManage the Structure of Your GUI Test" on page 888

See also "The Canvas" on page 209

This pane includes the following icons and context menu options:

l "Main User Interface Elements" on the next page

l "Action Type Icons" on page 215

l "Context MenuOptions - Test Nodes" on page 215

l "Context MenuOptions - Action Nodes" on page 215

l "Context MenuOptions - API Test Nodes" on page 216
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Main User Interface Elements
User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<Zoom
slider>

Enables you to zoom in or out of the test flow.

Do one of the following:

l Click themagnifying glass with the plus sign to zoom in on (enlarge) the
test flow.

l Click themagnifying glass with theminus sign to zoom out of (shrink) the
test flow.

l Click and drag the zoom slider position handle left or right to zoom in or out of
the test flow.

<Return to default size button>. Restores the test flow to the default size and
moves the zoom slider position to the center.

Show
parameters

Enables you to select the types of parameter information shown in the test flow,
including:

l None. Shows only the number of input and output parameters adjacent to the
relevant action. Click the number to expand the parameter details.

l Links only. Shows links when parameters are defined as input from other
actions.

l Links and names. Shows links and parameter names, when parameters are
defined as input from other actions.

l All. Displays the names and types of each input and output parameter adjacent
to the relevant action. Click the number to collapse the parameter details.

l User defined. Shows only user-defined parameters and hides built-in
parameters.

<Minimap display button>. Located above the test flow on the right. Displays or
hides the test flow minimap in the lower left corner of the canvas. Click to show or
hide theminimap.

Theminimap display button is highlighted in grey when theminimap is displayed,
and is not highlighted when theminimap is hidden.
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UI Element Description

<test flow> Displays the actions in the test in a flow chart format, as well as any parameter
details available, as specified in theParameter presentation drop-down list.

For details, see "Action Type Icons" below and "Context MenuOptions - Test
Nodes" below.

<Minimap> A small, high-level view of the entire test flow, useful when using large flows
and/or small screens.

Note:When you zoom out of the canvas, the test flow in theminimap
becomes smaller because theminimap displays the entire test flow.

Action Type Icons

Icon Description

A call to a reusable or non-reusable action.

A call to an API test or action.

Context Menu Options - Test Nodes
Test node context menus are accessible by right-clicking theStart andEnd nodes in the test flow.

Command Description

Settings Opens the "Properties Pane (Test/Business Component Settings Dialog Box)" on
page 590, which enables you to view the test settings.

Context Menu Options - Action Nodes
Action node context menu items are accessible by right-clicking an action in the test flow.

Command Description

Action Call
Properties

Opens the "Action Call Properties Dialog Box" (described on page 895), which
enables you to view details of the selected action call.

Action
Properties

Opens the "Action Properties Dialog Box" (described on page 900), which
enables you to view details of the selected action.

Object
Repository

Opens the "Object Repository Window" (described on page 1274), which
displays a tree containing all objects in the current test.

Call to New
Action

Opens the "Insert Call to New Action Dialog Box (GUI Testing)" (described on
page 913), which enables you to insert a call to a new action.
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Command Description

Call to Copy
of Action

Opens the "Select Action Dialog Box " (described on page 915), which enables
you to select a copy of an action to insert into the test.

Call to
Existing
Action

Opens the "Select Action Dialog Box " (described on page 915), which enables
you to insert a call to a specific existing reusable action.

Delete Removes the selected action from your test. For details, see "How toManage
the Structure of Your GUI Test" on page 888.

Note: This option is disabled if your test contains only one action.

Run from
Action

Starts a run session from the beginning of the selected action.

Debug from
Action

Starts a debug session and pauses it at the beginning of the selected action.

Run to
Action

Runs the test until the beginning of the selected action and then pauses the run
session.

Move Up Moves a action (a direct child of the test) up the canvas tree.

Note: This option is disabled if you only have one action in your test.

Move Down Moves a top-level action (a direct child of the test) down the canvas tree.

Note: This option is disabled if you only have one action in your test.

Context Menu Options - API Test Nodes
API test node context menu items are accessible by right-clicking a call to an API test within a GUI
test action.

Command Description

Edit Call
to API
Test

Opens the "Call to API Test/Action Dialog Box" on page 1075 (described on page
1075), enabling you to view andmodify your API test parameters.

Note: To replace the current call with a different API test, youmust first delete
the current call and then insert a new one.

Delete Removes the selected API test call from your test.
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Canvas User Interface (API Testing)
Relevant for: API testing only

The canvas is displayed by default when you create a new test. It provides a visual representation
of the test flow and enables you to:

l Display test and action steps

l Manage steps and change their order

l Test individual steps using the Run Step command

l Openwizards and dialog boxes to resolve steps with missing information.

To access 1. Create or open an API test or component.

2. Click on the test tab.

See also "Activity Overview" on page 1612
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This pane includes the following icons and context menu options:

l "Main User Interface Elements" below

l "Context MenuOptions" on the next page

Main User Interface Elements
User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<Zoom
slider>

Enables you to zoom in or out of the test flow image.

Do one of the following:

l Click themagnifying glass with the plus sign to zoom in on (enlarge) the
test flow image.

l Click themagnifying glass with theminus sign to zoom out of (shrink) the
test flow image.

l Click and drag the zoom slider position handle left or right to zoom in or out of
the test flow image.

<Return to default size>. Returns the test flow image to the default size and the
zoom slider position to the center.

Show
parameters

Enables you to select the level of information shown in the canvas, including:

l None. Shows only the number of input and output properties, adjacent to each
step or action frame. Clicking the number shows the property names.

l All. Displays the names of all the input and output properties and their links,
with the total number of properties.

l Links only. Displays only the links to other steps in the flow, and the number
of properties. (API tests only)

Tip: Clicking the number displays the properties for the step.

l Links and names. Displays the links to other steps, the name of the linked
properties, and the number of properties. (API tests only)

l Custom. Indicates that theShow parameters settings for some of the steps
weremodifiedmanually and not via the drop down. This entry is not selectable.

User Guide
Chapter 7: The Canvas

HP Unified Functional Testing (12.00) Page 218 of 2274



UI Element Description

<Minimap display>. Located above the test flow image on the right, and displays
or hides the test flow minimap in the lower left corner of the canvas.

The toggle button is highlighted when theminimap is displayed.

<Test
flow>

Displays the test flow in a flow chart format, as well as any parameter details
available, as specified in theShow parameters drop-down list.

<Minimap> A small, high-level view of the entire test flow, useful when using large flows
and/or small screens.

Note:When you zoom out of the canvas, the area displayed in the canvas
becomes larger. This has the effect of shrinking the test flow image in the
minimap because theminimap displays the entire test flow.

Context Menu Options
Context menu items are accessible by right-clicking a step in a test or action.

Option Description

Cut Cuts the selected step and places it on the clipboard.

Copy Copies the selected step to the clipboard.

Delete Deletes the selected step.

Properties Opens the Properties Pane. For details, see "Properties Pane" on page 385.

Open Opens the selected action step in its own tab (for action steps inside the Test
Flow).

Paste Pastes the step currently on the clipboard to the location of the cursor.

Note:

l Available only after you add a step to the clipboard using eitherCut or
Copy.

l Only visible when clicking on the down arrow inside the Test Flow, Loop, or
Action frame.
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Option Description

Run Step Runs the current step using its properties from the Properties pane, and shows the
results in theRun Step Results pane. For details, see "Run Step Results Pane"
on page 454.

Note:

l This command is not available for all steps.

l If an input property was linked to an output property of a previous step, the
Run Step dialog box opens. This lets you set constant values for the step's
properties. For details, see "Run Step Dialog Box" on page 459.
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Chapter 8: Data Pane
Relevant for: GUI testing, API testing, and business process testing

This chapter includes:

Concepts 222

Data PaneOverview 222

Data Table Sheets for GUI Testing 225

Data Pane - SaveOptions for GUI Testing 227

Data Table Objects, Methods, and Properties for GUI Testing 228

Formulas in Data Tables for GUI Testing 228

Tasks 230

How to Define a Data Table in a GUI Test 230

How toManage Data Tables in a GUI Test 231

How to Insert Formulas into Data Tables for Use in Checkpoints in a GUI Test 232

How to Import Data Into a GUI Test UsingMicrosoft Query 233

How to Add Data Sources to an API Test 233

Reference 239

Data Pane User Interface (GUI Testing) 239

Data Pane User Interface (API Testing) 252

Data Pane User Interface (BPT in UFT) 265

Troubleshooting and Limitations - Data Pane 269
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Concepts

Data Pane Overview
Relevant for: GUI testing, API testing, and business process testing.

UFT enables you to insert and run steps that are driven by data in the Data pane.

This section includes:

l "For GUI testing" below

l "For API testing" below

l "For business process testing" on the next page

For GUI testing
The data your test uses is stored in a design-time data table, which is displayed in the Data pane
while you insert and edit steps.

The Data pane has the characteristics of aMicrosoft Excel spreadsheet, enabling you to store and
use data in its cells and also perform mathematical formulas within the cells.

You can use theGUI testing Data pane, or you can use any Microsoft Excel (.xls or .xlsx) file.

You can use theDataTable, DTSheet andDTParameter utility objects to manipulate the data in
any cell in the Data pane. For details on these objects, see theUtility Objects section of the
HP UFT Object Model Reference for GUI Testing.

You can insert data table parameters and output values into your test. Using data table parameters
and/or output values in a test enables you to create a data-driven test or action that runs several
times using the data you supply.

For more details, see "How UFT Uses Data Tables in GUI Testing" on the next page.

For API testing
You can designate an Excel spreadsheet, a local data table, an XML file, or results of a database
query as data to be used for your test.

HP Unified Functional Testing (12.00) Page 222 of 2274



Using the Properties pane, you can insert data in your test step's input and output values. Using
these parameters enables you to create a data-driven test.

Tip: If UFT is integrating with ALM, you can use the data awareness features to:

l use a different data resource for each run iteration

l use the same data resource in multiple tests

l perform other tasks

For details, see "Data Awareness in ALM" on page 715 and "How to Data Drive a Test Using
Data from ALM" on page 720.

For details about data handling for API tests, see "Data Usage in API Tests" on page 1800.

For business process testing
The Data pane enables you to view andmodify iteration data for a business component or group in
your test or flow, or for a specific flow in your test. You can add and delete iterations, populate
parameter values, link input parameter values to other parameters in your test or flow, and promote
component or flow parameters to the next level.

You can configure components, flows, and groups to run a specified number of iterations during a
single run. Each iteration can use different parameter values.

For each iteration, use the Data pane to configure with which data a component, flow, or group runs
in a test or flow.

For more details, see "Considerations for BPT Test Iterations and Parameters" on the next page.

Note: For task details on defining iterations for components, groups, and flows, see "Iterate
components and flows" on page 2072.

How UFT Uses Data Tables in GUI Testing

Relevant for: GUI tests and components

In each repetition, or iteration, of a run session, UFT uses a different value from the data table.

During the run session, UFT creates a run-time data table—a live version of the data table
associated with your test. During the run session, UFT displays the run-time data in the Data pane
so that you can see any changes to the data table as they occur.

When the run session ends, the run-time data table closes, and the Data pane again displays the
stored design-time data table. Data entered in the run-time data table during the run session is not
saved with the test. The final data from the run-time data table is displayed in theRun-Time Data
Table in the Run Results Viewer. For details on the run-time data table, see the section on the Run
Results Viewer Data Pane (described in theHP RunResults Viewer User Guide).
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Tip: If UFT is integrating with ALM, you can use the data awareness feature to:

l use a different data table for each run iteration

l use the same data table in multiple tests

l perform other tasks.

To use this feature, make sure to save your data table parameters in theGlobal sheet.

For details, see "How to Data Drive a Test Using Data from ALM" on page 720.

Parent Topic: "Data PaneOverview" on page 222

Considerations for BPT Test Iterations and Parameters

Whenworking with iterations and parameters for business process test, consider the following:

l "Match an application’s post-condition with the next iteration’s pre-condition" below

l "Link input parameter values to output parameters" below

l "Moving a group, or amember within a group, can cause a parameter reference to be removed"
on the next page

Match an application’s post-condition with the next iteration’s pre-
condition
For a business component to run iterations successfully, it is essential that the post-condition (the
state of the application after the last step in the component runs) match the pre-condition (the state
of the application before the first step in the component runs).

For group iterations to be successful, the state of the application at the end of the last item in the
groupmust match the state of the application before the first item in the group.

For example, if the first component in the group assumes that the Login dialog box in an application
is open, then at the point where the last component of the group ends, the Login dialog box must be
in an open state before the next iteration begins.

Note: Components or flows in a group with input parameters must have the same number of
iterations.

Link input parameter values to output parameters
Iterations in a business process test or flow can result in multiple output parameter values. By
linking parameters, each iteration can pass its output value as input to the corresponding target
component or flow.

When you use the output of a previous component as the value for an input component parameter,
the option applies to all component iterations for that input parameter.
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To link input parameters values to other test or component parameters, use the "Select Link Source
Dialog Box (BPT)" on page 2128 (described on page 2128).

Moving a group, or a member within a group, can cause a parameter
reference to be removed
When a group is moved to a position preceding the component that provides an input component
parameter needed by a parameter in the group, the parameter linkage is deleted, and the value for
the source parameter will be empty.

You can then either supply a value for the parameter or reinstate the link using the "Select Link
Source Dialog Box (BPT)" on page 2128.

Data Table Sheets for GUI Testing
Relevant for: GUI tests and scripted GUI components

Whenworking with tests, the data table has two types of data sheets—Global andAction. You
can access the different sheets by clicking the appropriate tabs below the data table.

l "Global Sheet". You store data in the Global tab when you want it to be available to all actions
in your test and you want the data to control the number of test iterations.

Youmust also store data in the Global tab if your test is stored in ALM, and you want to use the
data awareness feature. For details, see "Data Awareness in ALM" on page 715.

l "Action Sheets". You store data in the action's tab when you want to use the data in data table
parameters for that action only and you want the data to control the number of action iterations.

For example, suppose you are creating a test on the sampleMercury Tours Web site. Youmight
create one action for logging in, another for booking flights, and a third for logging out. Youmay want
to create a test in which the user logs onto the site once, and then books flights for five passengers.
The data about the passengers is relevant only to the second action, so it should be stored in the
action sheet corresponding to that action.
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Global Sheet

Relevant for: GUI tests and scripted GUI components

TheGlobal sheet contains the data that replaces parameters in each iteration of the test. If you
create a Global parameter called Arrivals, the Global sheet might look like this:

For details on creating global parameters, see "Parameterizing Object Values" on page 1526.

Action Sheets

Relevant for: GUI tests and scripted GUI components

Each time you add a new action to the test, a new action sheet is added to the Data pane. Action
sheets are automatically labeled with the exact name of the corresponding action. The data
contained in an action sheet is relevant for data table parameters in the corresponding action only.
For example, if a test had the data table below, your GUI test would use the data contained in the
Purchase sheet when running iterations on action parameter steps within thePurchase action.

For details on creating action parameters, see "Parameterizing Object Values" on page 1526.

Note: If UFT is integrating with ALM, make sure to save your data table parameters in the
"Global Sheet" (described on page 226). For details, see "Data Awareness in ALM" on page
715.
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Data Pane - Save Options for GUI Testing
Relevant for: GUI tests and scripted GUI components

The Data pane contains the values that UFT substitutes for data table parameters when you run a
test, as well as any other values or formulas you enter. Whenever you save your test, UFT
automatically saves its data table as an .xls or .xlsx file.

When working with tests, the data table is saved with your test by default. You can save the data
table in another location and instruct the test to use this data table when running a test. You specify
a name and location for the data table in the Resources pane of the Test Settings dialog box. For
details on the Test Settings dialog box, see "Settings for GUI Tests, GUI Business Components,
and Application Areas" on page 580.

When to save the data table in a different location

l If you want to run the same test with different sets of input values. For example, you can test the
localization capabilities of your application by running your test with a different data table file for
each language you want to test. You can also vary the user interface strings that you check in
each language by using a different environment parameter file each time you run the test. For
details, see "Parameterizing Object Values" on page 1526.

l If you need the same input information for different tests. For example, you can test aWeb
version and a standardWindows version of the same application using different tests, but the
same data table file.

When to save a run-time data table
If it is important for you to save the resulting data from the run-time data table, you can insert a
DataTable.Export statement to the end of your test to export the run-time data table to a file. You
can then import the data to the design-time data table using the data table's File > Import from
Filemenu. Alternatively you can add a DataTable.Import statement to the beginning of your test to
import the run-time data table that was exported at the end of the previous run session. For more
details on thesemethods, see theHP UFT Object Model Reference for GUI Testing.

Saving data tables in an ALM project
Whenworking with ALM, youmust save the data table file in the Test Resources module in your
ALM project before you specify the data table file in the Resources pane of the Test Settings dialog
box. For more details, see "Resources Pane (Test/Business Component Settings Dialog Box) " on
page 603.

You can add a new or existing data table file to your ALM project. Note that adding an existing data
table file from the file system to an ALM project creates a copy of the file. Thus, once you save the
file to the project, changes made to the ALM data table file will not affect the data table file in the file
system and vice versa.
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Data Table Objects, Methods, and Properties for
GUI Testing

Relevant for: GUI tests and scripted GUI components

GUI testing provides several data table methods that enable you to retrieve information on the run-
time data table and to set the value of cells in the run-time data table. You enter these statements
manually in the Editor. For details on working in the Editor, see "Programming in GUI Testing
Documents in the Editor" on page 994.

From a programming perspective, the data table is made up of three types of objects—DataTable,
DTSheet (sheet), andDTParameter (column). Each object has several methods and properties
that you can use to retrieve or set values.

For more details on the data table methods, see theHP UFT Object Model Reference for GUI
Testing.

Formulas in Data Tables for GUI Testing
Relevant for: GUI tests and scripted GUI components

You can useMicrosoft Excel formulas in your data table. This enables you to create contextually
relevant data during the run session. You can also use formulas as part of a checkpoint to check
that objects created on-the-fly (dynamically generated) or other variable objects in yourWeb page or
application have the values you expect for a given context.

When you use formulas in a data table to compare values (generally in a checkpoint), the values
you comparemust be of the same type, for example integers, strings, and so forth. When you
extract values from different places in your applications using different functions, the values may
not be of the same type. Although these values may look identical on the screen, a comparison of
them will fail, since, for example, 8.2 is not equal to "8.2".

For more details on using worksheet functions, see theMicrosoft Excel documentation.

Formulas in Data Tables for Use in Iterations
You can enter formulas rather than fixed values in the cells of a parameter column.

For example, suppose you want to parameterize the value for aWebEdit object that requires a date
value no earlier than today's date. You can set the cells in theDate column to the date format, and
enter the =NOW()Excel formula into the first row to set the value to today's date for the first
iteration.
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Then you can use another formula in the remaining rows to enter the above date plus one day, as
shown below. By using this formula you can run the test on any day and the dates will always be
valid.

TEXT or VALUE Functions Used to Convert Values from One Type to Another

l TEXT(value, format). Returns the textual equivalent of a numeric value in the specified format,
so that, for example the formula =TEXT(8.2, "0.00") is "8.20".

l VALUE(string). Returns the numeric value of a string, so that, for example, =VALUE("$8.20")
is 8.20.

For more details on using parameters, see "Parameterizing Object Values" on page 1526.

Formulas in Data Tables for Use in Checkpoints
You can use a formula in a checkpoint to confirm that an object created on-the-fly (dynamically
generated) or another variable object in yourWeb page or application contains the value it should for
a given context. For example, suppose a shopping cart Web site displays a price total. You can
create a text checkpoint on the displayed total value and use a data table formula to check whether
the site properly computes the total, based on the individual prices of the products selected for
purchase in each iteration.

When you use the data table formula option with a checkpoint, two columns are created in the data
table. The first column contains a default checkpoint formula. The second column contains the
value to be checked in the form of an output parameter. The result of the formula is Boolean—
TRUE or FALSE.

A FALSE result in the checkpoint column during a test run causes the test to fail.

After you finish adding the checkpoint, you canmodify the default formula in the first column to
perform the check you need.
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Tasks
For tasks related to BPT, see "How to Create, Maintain, and Run Business Process Testing Tests
and Flows in UFT" on page 2071.

How to Define a Data Table in a GUI Test
Relevant for: GUI tests and scripted GUI components

This task describes the different options for defining a new data table for your test.

This task includes:

l "Add an external data table file" below

l "Import data from a database" below

l "Manually enter or import information in the Data table" below

l "Add a data table file to your ALM project" on the next page

Add an external data table file
Configure the location of the data table in the Resources pane of the Test Settings dialog box (File
> Settings > Resources node). For details, see "Resources Pane (Test/Business Component
Settings Dialog Box) " on page 603.

If you select an external file as your data table, make sure that:

l The column names in the external data table match the parameter names in the test.

l The sheets in the external data table match the action names in the test.

Import data from a database
Import data into a data table sheet usingMicrosoft Query, or by specifying an SQL statement. For
details, see the "How to Import Data Into a GUI Test UsingMicrosoft Query" on page 233.

Manually enter or import information in the Data table
Edit information in the Data pane by typing directly into the table cells. You can also import data
saved inMicrosoft Excel, tabbed text file (.txt), or ASCII format.

To import an Excel file:

Right-click in the Data pane and select File > Import from File from the Data pane commands.

To import a single sheet or a tabbed text file:

Right-click in the Data pane and select Sheet > Import > From File from the Data pane
commands.

For more details on Data pane commands, see "Data Pane User Interface (GUI Testing)" on page
239.
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Add a data table file to your ALM project

1. Make sure you have an accessible Microsoft Excel file with an .xls or .xlsx extension.

2. In ALM, create a new data table resource and then upload the .xls or .xlsx file you created in
the previous step to the project's Test Resources module. For more details, see the
HP Application Lifecycle Management User Guide.

3. In UFT, in the Test Settings dialog box (File > Settings > Resources node), select Other
location and click the browse button to locate the data table file.

4. Create your test. When you save the test, UFT saves the data table file to the ALM project.

How to Manage Data Tables in a GUI Test
Relevant for: GUI tests and scripted GUI components

This task describes how tomanage the data table in your test.

This task includes:

l "Define the number of iterations for an action or test" below

l "Change a column name" below

l "Use an autofill list" on the next page

Define the number of iterations for an action or test

l For actions: Open theRun tab of theAction Call Properties dialog box (right-click an action in
the canvas and select Action Call Properties).

l For tests: Open theRun pane of theSettings dialog box (File > Settings > Run pane).

If you want to prevent UFT from running an iteration on a row when theRun on all rows option is
selected, youmust delete the entire row from the data table. To do this, do one of the following:

l Select the row, right-click in the table, and select Edit > Delete from the data table's context
menu (or use CTRL+K). This restores the bottom grid line from black to gray.

l Use the Clear option from the table's Editmenu (or CTRL+X).

l Select a cell and press Delete on the keyboard. The data is deleted from the cells, but the row is
not deleted and the black line remains. This means that UFT will run an iteration for this row
even though there is no data in it.

Change a column name
For details, see "Change Parameter NameDialog Box (GUI Testing Data Pane)" on page 248.
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Use an autofill list

1. Select the type of autofill list from the "AutoFill Lists Dialog Box (GUI Testing Data Pane)",
described on page 247.

2. Enter the first item into a cell in the table (item names are case-sensitive).

3. Fill the cells by doing one of the following:

n Drag the cursor, from the bottom right corner of the cell up or right to fill the next row or
column in the sheet.

n Highlight the item and press ENTER to automatically fill the next row of the sheet.

n Highlight the item and press TAB to automatically fill the next column of the sheet.

How to Insert Formulas into Data Tables for Use in
Checkpoints in a GUI Test

Relevant for: GUI tests and scripted GUI components

This task describes how to insert formulas into the data table for use in a checkpoint.

To use a formula in a checkpoint:

1. Select the object or text for which you want to create a checkpoint and open the Insert
Checkpoint dialog box as described in "How to Insert a Checkpoint in a GUI Test or
Component" on page 1419.

2. In theConfigure value area, click Parameter.

3. Set the parameter options, as described in the "Parameter Options Dialog Box" on page 1556.

4. Specify your other checkpoint setting preferences as described in the "Checkpoint Properties
Dialog Box" on page 1432.

5. Highlight the value in the first (formula) column to view the formula andmodify the formula to fit
your needs.

6. If you want to run several iterations, add the appropriate formula in subsequent rows of the
formula column for each iteration in the test or action.

Tip: You can encode passwords to use the resulting strings as method arguments or data
table parameter values. For details, see "Password Encoder Tool" on page 965.

You can also encrypt strings in data table cells using theEncrypt option in the Data pane
menu. For details, see "DataMenu (GUI Testing Data Pane)" on page 243.
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How to Import Data Into a GUI Test Using Microsoft
Query

Relevant for: GUI tests and scripted GUI components

You can useMicrosoft Query to choose a data source and define a query within the data source.
For details on supported versions of Microsoft Query, see theHP Unified Functional Testing
Product Availability Matrix, available from the UFT Help or the root folder of the Unified Functional
Testing DVD.

To choose a data source and define a query in Microsoft Query:

1. Open the "DatabaseQuery Wizard" (described on page 249) and select Create query using
Microsoft Query.

2. WhenMicrosoft Query opens, choose a new or an existing data source.

3. Define a query.

4. In the Finish screen of the Query Wizard, select one of the following:

n Exit and return to HP Unified Functional Testing > Finish to exit Microsoft Query.

n View data or edit query in Microsoft Query > Finish to view the data.

After viewing or editing the data, select File > Exit and return to HP Unified Functional
Testing to closeMicrosoft Query and return to UFT.

For details on working with Microsoft Query, see theMicrosoft Query documentation

How to Add Data Sources to an API Test
For details about data handling for GUI tests and theGUI testing Data Pane, see "Data Pane
Overview" on page 222.

Relevant for: API testing only

This task describes how to define data sources before selecting a test step. After creating a test
step, you link it to an existing data source. The following steps provide you with different options for
creating a data source. To create a data source for your properties, you only need to add data using
one of these options.

l "Add an Excel data source" on the next page

l "Add an XML data source" on the next page

l "Add a database data source" on page 235

l "Add a local data table" on page 238
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Add an Excel data source

1. Make sure the Data pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select Excel. The
"New/Change Excel Data Source Dialog Box" (described on page 255) opens.

3. Browse to the file and indicate if the first row is a header row.

4. Specify a name for the data source. If you do not provide a name, UFT sets it to the Excel file
name after you navigate to the file.

5. Select whether to link to the Excel in its original location or create a local copy. The advantage
of making a local copy is that it becomes portable with the test. However, any updates to the
data at its original location will not be not reflected in themigrated test.

6. Select Allow other tools to override the data option to enable integration with ALM's Data
Awareness. This allows you to overwrite the data from the imported Excel file with values from
an ALM Data Resource. For details, see "Data Awareness in ALM" on page 715.

In addition, if you call a test or action with data assigned to its steps, this option allows you to
edit the data in the called test or action. For details, see "Actions Using the Data Table" on
page 1791.

7. Click OK.

8. In the Data pane, select the data source under theExcel node. In the right pane, you can view
and edit the values.

Tip: You can replace an existing Excel data source with a new file. For user interface details,
see "New/Change Excel Data Source Dialog Box" on page 255.

Add an XML data source

1. Make sure the Data pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select XML. The "New
XMLData Source Dialog Box" (described on page 257) opens.

3. Provide aData Source name.

4. Select the entity upon which to base the data source:

n Schema file:Browse to an .xsd file.

n XML file:Browse to an .xml file.

n Use existing: Browse to an existing XML-based data source from another test.
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5. Click OK.

6. Select the data source's node in the Data pane.

7. Edit the XML data in the grid. Click theAdd rows button to add row values. For user
interface details, see "XMLData Source - Toolbar" on page 253.

8. To load XML values, click the Load data from an XML file button .

Add a database data source

1. Make sure the Data pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select Database. The
"Add New Database Data SourceWizard" (described on page 258) opens. TheSet Database
Connection page opens.

3. For anOleDB type connection:

a. Select OleDB as theConnection type.

b. Set the connection string in one of the following ways:

o Paste anOLE DB connection string into the text area.

o Select a previously defined connection string from the drop down.
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o Click theBuild Connection String button to useMicrosoft's Data Link Properties
dialog box. For details, click theHelp button in the Data Link Properties dialog box.

c. Click Test Connection to verify that the connection is valid.

d. Click Next. This button is only available for valid connections.

4. For anODBC type connection:

a. Select ODBC as theConnection type.

b. Click theBuild Connection String button to select a DSN type. For details, see
"Select Data Source NameDialog Box" on page 262.

c. Select a DSN type and provide the necessary credentials. To create or edit a DSN entry,
click theManage ODBC Data Sources button. For details, click theHelp button in the
ODBC Data Source Administrator dialog box. After you close the administrator dialog box,
click theReload DNS list button to refresh the list.

d. Test the connection. After the confirmation, click OK.
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5. In theSet SQL Statement page:

a. Provide a unique name for the data source, not used by another data source. If you do not
provide a name, the data source is automatically assigned the table name after you build
the query.

b. Provide an SQL statement in one of the following ways:

o Paste an existing statement into the text area.

o Select a previously defined statement from the drop down history.

o Click theBuild Query Statement button to open the "Query Designer Dialog Box"
(described on page 1724). TheQuery Designer allows you to create a basic SQL query,
with a single table or view. For complex queries, such as those using advanced SQL
features and calculations, create the query in your environment and paste it into the text
area.

c. If you are using theQuery Designer:

o Select a table or view. TheQuery Designer lists all of the rows in the pane below and
displays the corresponding SQL statement in the preview pane.

o EnableAuto execute to view the results of your query as youmake changes in the
upper pane.

o By default, the Query Designer selects all columns in the table. To remove a column
from the query, clear theOutput check box for that column.

o To set a sorting order, select Ascend orDescend from theSort column drop-down. If
you havemultiple rows that you are sorting, provide theSort Order beginning with 1.
TheQuery Designer adds anORDER BY clause to the preview pane.
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o To filter the returned results, enter the text to match in the Filter column.

o To add aGROUP BY orDISTINCT clause to your statements, select the appropriate
check box.

Click OK to accept the query and return to the wizard. Click theReset Query button

to discard the changes.

d. In the wizard's Set SQL Statement page, click theCheck SQL Statement button. A
Query Preview dialog box opens. Click Close to return to the wizard.

e. Click Finish. UFT shows the query details in the Properties pane's "Database Data
Source Properties Tab (Properties Pane - API Testing)" (described on page 408). By
default the Data pane shows the first ten rows of the query data. To change the number of
displayed rows, use the "General Pane (Options Dialog Box > API Testing Tab)"
(described on page 565).

f. To update the data at a later stage, click Refresh in the Data pane. The data is not
automatically refreshed—the displayed data is the result of the query when you created the
data source or the last time you clicked theRefresh button.

Add a local data table

1. Make sure theData pane is visible. If not, select View > Data.

2. In the Data pane, click theNew Data Source down arrow and select Local Table. The
"New Local Table Data Source Dialog Box" (described on page 264) opens.

3. Click theAdd button to create a column in the data table.

4. In the columns list, specify a column name and description. Select a data type from the drop
down list.

5. Repeat steps 3 and 4 for each column you want to create.

6. Use the arrows to reorder the columns as required .

7. Click theRemove button to delete an unwanted column from the data table.

8. Click OK.

9. In the Data pane, select the table's node in the left pane andmove within the table using the
keyboard arrows. Type within the cells to manually set values.
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Reference

Data Pane User Interface (GUI Testing)
For details about the API testing Data Pane interface, see "Data Pane User Interface (API Testing)
" on page 252. For details about the BPT Data pane interface, see "Data Pane User Interface (BPT
in UFT)" on page 265.

Relevant for: GUI tests and scripted GUI components

You use the Data pane in the sameway as aMicrosoft Excel spreadsheet, including inserting
formulas into cells.

To Access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node, or one of its
child nodes.

2. Do one of the following:

n Select View > Data.

n Click theData toolbar button.
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Important
information

l You access the Data panemenus and commands by right-clicking anywhere
in the Data pane.

l Each row in the table represents the set of values that UFT submits for the
parameterized arguments during a single iteration of the test or action.

l Each column in the table represents the list of values for a single
parameterized argument. The column header is the parameter name.

l Combo box and list cells, conditional formatting, and other special cell formats
are not supported in the Data pane.

l Special characters, machine-dependent characters, and platform-dependent
characters are not supported for use in Data Pane column names.

l You can also enter data and formulas in cells in the columns that are not
intended for use with data table parameters (the columns that do not have a
parameter name in the column header).

Relevant
tasks

l "How to Define a Data Table in a GUI Test" on page 230

l "How toManage Data Tables in a GUI Test" on page 231

l "How to Insert Formulas into Data Tables for Use in Checkpoints in a GUI
Test" on page 232

See also l "Data Table Parameters" on page 1533

l For details on supported versions of Microsoft Excel, see theHP Unified
Functional Testing Product Availability Matrix, available from theUFT Help or
the root folder of the Unified Functional Testing DVD.

The Data pane provides the following shortcut menu (right-click) commands:

l "General Commands (GUI Testing Data Pane)" on the next page

l "File Menu (GUI Testing Data Pane)" on the next page

l "Sheet Menu (GUI Testing Data Pane)" on page 242

l "Edit Menu (GUI Testing Data Pane)" on page 242

l "DataMenu (GUI Testing Data Pane)" on page 243

l "Format Menu (GUI Testing Data Pane)" on page 244
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This section also includes:

l "Data Pane Specifications (GUI Testing Data Pane)" on page 245

l "Guidelines forWorking with the GUI Testing Data Pane" on page 246

l "AutoFill Lists Dialog Box (GUI Testing Data Pane)" on page 247

l "Change Parameter NameDialog Box (GUI Testing Data Pane)" on page 248

General Commands (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

TheGeneral shortcut (right-click) menu includes the following commands:

Command Shortcut Key Description

Switch between Data
pane sheets

CTRL+PAGE
UP/PAGE DOWN

Switches through the Data pane sheets when the
Data pane is in focus.

File Menu (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

The File shortcut (right-click) menu includes the following commands:

Command Description

Import
From File

Imports an existingMicrosoft Excel into the Data pane. This commandwill import
all the sheets in the selectedMicrosoft Excel file. If you want to import only one
sheet from an existingMicrosoft Excel file or a tabbed text file, use theSheet >
Import > From File command described below.

Note:

l The table file you import replaces all data in all sheets of the table. The first
row in eachMicrosoft Excel sheet also replaces the column headers in the
corresponding Data pane sheet. It is therefore essential that the first row of
your Microsoft Excel sheet exactly matches the parameter names in your
test, and that the file contains at least the same number of sheets as the
current data table.

l If you import a Microsoft Excel table containing combo box or list cells,
conditional formatting, or other special cell formats, the formats are not
imported and the cells are displayed in the data table with a fixed value.

Export Exports the table to a specifiedMicrosoft Excel (.xls or .xlsx) file.

Print Prints the entire table or the selected sheet.
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Sheet Menu (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

TheSheet shortcut (right-click) menu includes the following commands:

Command Description

Import >
From File

Imports a tabbed text file or a single sheet from an existingMicrosoft Excel file
into the table.

Note: The sheet you import replaces all data in the currently selected
sheet of the table, and the first row in the Excel sheet replaces the
column headers in the corresponding Data pane sheet. It is therefore
essential that the first row of your Microsoft Excel sheet exactly matches
the parameter names in your test.

Import >
From Database

Imports data from the specified database to the current sheet.

Export Exports the current sheet of the data table to a specifiedMicrosoft Excel
(.xlsor .xlsx) file.

Edit Menu (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

TheEdit shortcut (right-click) menu includes the following commands:

Command
Shortcut
Key Description

Cut CTRL+X Cuts the table selection and places it on the Clipboard.

Copy CTRL+C Copies the table selection and places it on the Clipboard.

Paste CTRL+V Pastes the contents of the Clipboard to the current table
selection.

Clear > All N/A Clears contents and formatting from the current selection.

Clear > Formats N/A Clears the formatting from the current selection.

Clear > Contents CTRL+D
EL

Clears the contents from the current selection.
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Command
Shortcut
Key Description

Insert CTRL+I Inserts empty cells at the location of the current selection. Cells
adjacent to the insertion are shifted tomake room for the new
cells. Note that this option is available only when a row or
column heading is selected.

Delete CTRL+K Deletes the entire current row or column selection. Cells
adjacent to the deleted cells are shifted to fill the space left by
the vacated cells. Note that this option is available only when a
row or column heading is selected.

Fill Right CTRL+R Copies data in the left-most cell of a selected range to all the
cells to the right of that left-most cell within the selected range.

Fill Down CTRL+D Copies data in the top cell of a selected range to all cells below
that top cell within the selected range.

Find CTRL+F Finds a cell containing specified text. You can search by row or
column in the table and specify to match case and/or find entire
cells only. You can also search for formulas or values.

Replace CTRL+H Finds a cell containing specified text and replaces it with
different text. You can search by row or column in the table and
specify to match case and/or to find entire cells only. You can
also search for formulas or values. You can also replace all
instances of the found text.

Go To N/A Goes to a specified cell. This cell becomes the active cell. You
must enter the column and row number of the cell.

Data Menu (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

TheData shortcut (right-click) menu includes the following commands:

Command
Shortcut
Key Description

Recalc F9 Recalculates any formula cells in the table.

Sort N/A Sorts a selection of cells by row or column and keys in ascending or
descending order.

AutoFill
List

N/A Opens the AutoFill Lists dialog box (described on page 247).
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Command
Shortcut
Key Description

Encrypt N/A Encodes the text in the selected cells. Note that you cannot decrypt
data that has been encrypted.

You can also use the Password Encoder to encrypt any text string. This
can be useful for entering encrypted strings as method arguments in the
Editor. For details, see "Password Encoder Tool" on page 965.

Format Menu (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

The Format shortcut (right-click) menu includes the following commands:

Command Description

General Sets format to General. TheGeneral format displays numbers with as many
decimal places as necessary and no commas.

Currency
(0)

Sets format to currency with commas and no decimal places. Note: UFT uses the
currency symbol defined in yourWindows Regional Settings dialog box.

Currency
(2)

Sets format to currency with commas and two decimal places. Note: UFT uses the
currency symbol defined in yourWindows Regional Settings dialog box.

Fixed Sets format to fixed precision with commas and no decimal places.

Percent Sets format to percent with no decimal places. Numbers are displayed as
percentages with a trailing percent sign (%).

Fraction Sets format to fraction in numerator denominator form, e.g. 1/2.

Scientific Sets format to scientific notation with two decimal places.

date
(dynamic)

Sets format to Date with theM/D/YY format.

Time:
h:mm
AM/PM

Sets format to Timewith the h:mm AM/PM format.

Custom
Number

Sets format to a custom number format that you specify. This option enables you to
set special and customized formats for percentages, currencies, dates, times, and
so forth.
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Data Pane Specifications (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

Themain limitations for working with the Data pane are listed below:

Item Details

Maximum worksheet
size

65,536 rows by 256 columns

Maximum number of
worksheets

256 (255 sheets in addition to the Global data table).

Column width 0 to 255 characters

Text length 16,383 characters

Formula length 1024 characters

Number precision 15 digits

Largest positive number 9.99999999999999E307

Smallest positive
number

1E-307

Largest negative
number

-1E-307

Smallest negative
number

-9.99999999999999E307

Maximum number of
names per workbook

Limited by available memory

Maximum length of
name

255

Maximum length of
format string

255

Maximum number of
tables (workbooks)

Limited by system resources (windows andmemory)

Limitations l The use of colors and formatting in the Data pane is not
supported.

l Combo box and list cells, conditional formatting, and other
special cell formats are not supported in the Data pane.
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Guidelines for Working with the GUI Testing Data Pane

Relevant for: GUI tests and scripted GUI components

l When you add data to the Data pane, youmust enter the data in rows from top to bottom and left
to right—you cannot leave a gap of an entire row or column. For example, if there is data in row
1, you cannot enter data in a cell in row 3 until you have entered data in row 2. Similarly, if there
is data in column A, you cannot enter data in columnC until you have entered data in column B.

l The value returned from the data table is always converted to a string. If you want the value to be
converted to something other than a string, you can use VBScript conversion functions, such as
CInt, CLng, CDbl, and so forth. For example:

Window("Flight Reservation").WinComboBox("Fly From:").Select CInt(DataTable("ItemNumb
er", dtGlobalSheet))

l When you add content to a Data pane cell, the color of the row's bottom grid line changes from
gray to black. When you run your test using theRun on all rows option (defined in File >
Settings > Run pane, or theRun tab of the "Action Call Properties Dialog Box" (described on
page 895), UFT runs one iteration for each row whose bottom grid line is black. For details on
modifying the number of iterations, see "How toManage Data Tables in a GUI Test" on page
231.

l If you change a data parameter (column header), youmust also update the relevant the name of
the corresponding parameter wherever it is used in UFT, for example, parameterized argument
values, checkpoint or output values, action parameters, and repository parameters.

If your test is stored in ALM, youmust also update the relevant ALM parameter mappings in
each configuration defined for your test. For details, see "Change Parameter NameDialog Box
(GUI Testing Data Pane)" on page 248.
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AutoFill Lists Dialog Box (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

This dialog box enables you to create, edit, or delete an autofill list. An autofill list contains
frequently-used series of text such as months and days of the week.

To Access In the Data pane (described on page 239), right-click a cell or cell range and
select Data > AutoFill List.

Important
information

AutoFill items are case-sensitive.

Related Tasks "How toManage Data Tables in a GUI Test" on page 231

See Also "Data PaneOverview" on page 222

User-interface elements are described below:

UI
Element Description

Lists The lists that are available in your project. Four default lists are included.

Current
List

The selected list. This pane can be used to create a new list. Separate the items in a
new list with a semi-colon.

Add Adds a new list to the Lists box.

Delete Deletes a list from the Lists box.
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UI
Element Description

Open Opens theOpen dialog box, in which you can browse to a previously created list.

Save Opens the Save As dialog box, in which you can save a new list.

Change Parameter Name Dialog Box (GUI Testing Data Pane)

Relevant for: GUI tests and scripted GUI components

This dialog box enables you to change the Data pane parameter name, which is defined in the
column header in the Data pane.

To access In the Data pane (described on page 239), double-click a column header cell.

User-interface elements are described below:
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UI
Element Description

Data
pane
column
name

The Data pane parameter name, which is defined in the column header in the Data
pane.

For a list of naming conventions, see "Troubleshooting - Naming Conventions" on
page 2269.

Note: If youmodify the column header, youmust also:

l Change the name of the corresponding data table parameter wherever it is
used (for example, parameterized argument values, checkpoint or output
values, action parameters, and repository parameters).

l For tests stored in HP ALM: In the Test Planmodule, youmust also
update the parameter mappings in each configuration defined for your test.

Database Query Wizard

Relevant for: GUI tests and scripted GUI components

This wizard enables you to import data from a database to a Data pane sheet.

To access In the "Data Pane User Interface (GUI Testing)" (described on page 239), right-
click the sheet to which you want to import the data and select Sheet > Import >
From Database.

Important
information

l You can install Microsoft Query from the custom installation option of
Microsoft Office.

l UFT takes several seconds to capture the database query and restore the UFT
window. The resulting data from the database query is displayed in the Data
pane.

l Contrary to importing an Excel file (File > Import From File), existing data in
the Data pane is not replaced when you import data from a database. If the
database you import contains a columnwith the same name as an existing
column, the database column is added as a new columnwith the column name
followed by a sequential number.

For example, if your data table already contains a column called departures, a
database column by the same namewould be inserted into the data table as
departures1.

Relevant
tasks

l "How toManage Data Tables in a GUI Test" on page 231

l "How to Import Data Into a GUI Test UsingMicrosoft Query" on page 233
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Wizard
map

TheDatabase Query Wizard contains:

Connect to database using ODBC (250) > Specify SQL statement (page 251)

Connect to Database Using ODBC Page (Database Query Wizard)

Relevant for: GUI tests and scripted GUI components

This wizard page enables you to select a data source to import from.

Wizard map The "DatabaseQuery Wizard" contains:

Connect to database using ODBC > Specify SQL statement

User interface elements are described below:

UI Elements Description

Create query
using
Microsoft
Query

Opens Microsoft Query, enabling you to create a new query. After you finish
defining your query, you exit back to UFT. This option is only available if you
haveMicrosoft Query installed on your computer.

Specify SQL
statement
manually

Opens theSpecify SQL statement page in the wizard, which enables you to
specify the connection string and an SQL statement.
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UI Elements Description

Maximum
number of
rows

Themaximum number of database rows to import. You can specify amaximum
of 32,000 rows.

Show me
how to use
Microsoft
Query

Displays an instruction screen before openingMicrosoft Query when you click
Next. (Enabled only whenCreate query using Microsoft Query is selected).

Specify SQL Statement Page (Database Query Wizard)

Relevant for: GUI tests and scripted GUI components

This wizard page enables you to define the SQL statement to import into the Data pane.

Wizard map The "DatabaseQuery Wizard" contains:

Connect to database using ODBC > Specify SQL statement

User interface elements are described below:

UI
Elements Description

Connection
string

The connection string to import.
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UI
Elements Description

Create Opens theODBC Select Data Source dialog box. You can select a .dsn file in the
ODBC Select Data Source dialog box or create a new .dsn file to have it insert the
connection string in the box for you.

SQL
statement

The details of the SQL statement.

Data Pane User Interface (API Testing)
For details about the GUI testing Data Pane interface, see "Data Pane User Interface (GUI Testing)
" on page 239. For details about the BPT Data Pane interface, see "Data Pane User Interface (BPT
in UFT)" on page 265.

Relevant for: API testing only

The Data pane enables you to add, view, and edit data sources for use as property values when
running tests.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the
document pane.

n In the solution explorer, select an API test or component

2. Select View > Data or select the Data pane tab.

Important
information

In order to see the contents of a data source, click its node in the left
pane.

Relevant tasks "How to Add Data Sources to an API Test" on page 233
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See also l "How to Assign Data to API Test/Component Steps" on page 1819

l "How to Set the Data Source Navigation Properties" on page 1825

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<data
source
tree>

A hierarchy of the data sources and their subnodes, displayed in the left pane. There
are separate nodes for the test and action data sources: Current Test, <action1>,
<action2>, and so forth.

For Excel files, each sheet represents another set of properties.

<data
source
content>

The data associated with the selected node, displayed in the right pane. You can edit
values directly from this pane.

If the current test calls another test or action with its own data source, this area
shows the data, provided that you enabled the data to be viewed as described below.

Note: To enable this data to be viewed and edited, click the node in the original
location of the data, and enable theAllow other tools to override the data
option. For details, see "Data Source Properties Tab (Properties Pane - API
Testing)" on page 406.

New Data Source. Creates a new a data source. Expand the drop down to select a
data source type: Excel, XML, Database, or Local Table.

Remove. Removes the selected data source from the Data pane.

XML Data Source - Toolbar
The following controls are available when selecting an XML data source in the Data pane.

UI Elements Description

Go back. Returns to the previous view.

Go to start. Returns to the first row.

Go to the previous row. Navigates to the previous row (one row up).

Row The current row number out of the total rows, such as
1/3 and so forth. Use the drop down tomove to the desired row.

Description A title for the row currently displayed.

Go to the next row. Navigates to the next row (one row down).
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UI Elements Description

Go to end. Navigates to the last row.

Import data from an XML file. Loads data from an XML file.

Export data from an XML file. Exports the current data to an XML file.

Move up.Moves the current row forwards.

Move down.Moves the current row backwards.

Adds a new empty row at one of the following locations.

l Add after current

l Add at start

l Add at end

Duplicates the current row at one of the following locations.

l Duplicate after current

l Duplicate at start

l Duplicate at end

Deletes the current row.

Database Data Source Nodes
The following controls are available when selecting a database data source in the Data pane.

UI
Elements Description

Refresh. Updates the data from the database.

Count. Opens amessage box with a row count. By default the Data pane shows the
first ten rows of the query data. To change the number of displayed rows, use the
"General Pane (Options Dialog Box > API Testing Tab)"(described on page 565).
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New/Change Excel Data Source Dialog Box

Relevant for: API testing only

This dialog box enables you to add a new Excel data source to the Data pane or change the
underlying file for existing Excel data sources.

To access Before you open the dialog boxes, make sure that an API test or component is in
focus in the document pane.

To open the New Excel Data Source dialog box:

1. Select View > Data

2. Click on theNew Data Source down arrow and select Excel.

To open the Change Excel Data Source dialog box:

1. Select themain node of an existing Excel data source.

2. In the Properties pane, click Change Excel File.

Relevant
tasks

"Add an Excel data source" on page 234

See also "Data Link/RelationMessage Box" on page 1837
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User interface elements are described below:

UI Element Description

Data source
name

A name for the data source as it will appear in the Data pane. If no value is
specified, it uses the file name.

Note: This field is read-only in the Change Excel Data Source dialog box.

Excel file
path

The complete path of an Excel file on the file system. Use theBrowse button to
locate the file.

Note: Youmust use an absolute path for the Excel file path.

Excel file
contains
header row

Indicates whether the data in the Excel table contains a header row. Header rows
are ignored when running the test.

File
location

The location for storing the imported Excel data:

l Link to the Excel file in its original location. If the data changes at its
source, it affects your test. In addition, if youmodify the data in your test, it
affects the data at its source.

l Make a copy of the Excel file. Copies the Excel file locally. If the data
changes at its source, it does not affect your test. In addition, the data is
portable together with the test.

Allow other
tools to
override the
data

Enables you to overwrite data from the imported Excel file with values from other
tools, such as an ALM Data Resource (for versions ALM 11.00 and higher), and
GUI or API tests.

For details about ALM data resources, see "Data Awareness in ALM" on page
715.

Tip: If you did not enable this option when you imported the Excel file, you
can enable it separately for each data source in the Properties pane. For
details, see "Data Source Properties Tab (Properties Pane - API Testing)" on
page 406.
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New XML Data Source Dialog Box

Relevant for: API testing only

This dialog enables you to add new XSD or XML data sources to the Data pane.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. Create or open a test or component.

3. Select View > Data.

4. Click on theNew Data Source down arrow and select XML.

Relevant tasks "Add an XML data source" on page 234

See also "XMLData Source - Toolbar" on page 253

User interface elements are described below:

UI
Element Description

Data
source
name

The display name of the data source. If no name is specified, it uses the file name.
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UI
Element Description

Based
on

The file on which to base the data table:

l Schema file. A file with an XSD extension.

l XML file. A file with an XML extension.

l Use existing. An existing data resource created within another test. Since this
data source is referenced, changes made to it are reflected in all tests using the
data source.

Use theBrowse button to navigate to the desired location.

Add New Database Data Source Wizard

Relevant for: API testing only

This wizard enables you to create a data source by retrieving data rows from a database table. You
specify a connection string and an SQL statement to retrieve the data.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. Create or open a test or component.

3. Select View > Data.

4. Click on theNew Data Source down arrow and select Database.

Relevant tasks "Add a database data source" on page 235

Wizard map This wizard contains:

"Set Database Connection Page" > "Set SQL Statement Page"

See also "Query Builder Dialog Box" on page 1722

Parent Topic: "Data Pane User Interface (API Testing)" on page 252
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Set Database Connection Page

Relevant for: API testing only

This wizard page enables you to define a connection string for connecting to the database.

Wizard map This wizard contains:

Set Database Connection Page > "Set SQL Statement Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Connection
type

The type of database connection: OleDB orODBC.

<connection
list>

A drop down list of previously defined connection strings.

Build Connection String.

l ForOleDB connections: Opens theMicrosoft Data Link Properties dialog
box.

l ForODBC connections: Opens the Select Data Source Name dialog box.
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UI Element Description

<connection
string area>

An editable area for pasting in existing strings, or for editing the connection string
selected in the drop down list.

Tip: To add a string to the drop down list, click Check Connection.

Password The password with which to access the database.

Insert. Inserts the encoded password into the displayed connection string.

Test
Connection

Sends the current connection string to the database server to check its validity.

<connection
status>

Displays the status of the database connection. If it is a valid connection, the
wizard adds the connection string to the list of Connection strings and changes

the status toConnected .

Set SQL Statement Page

Relevant for: API testing only

This wizard page enables you to prepare an SQL statement for retrieving your data.

Wizard map This wizard contains:

"Set Database Connection Page" > Set SQL Statement Page
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Data source
name

The name of the data source as it is be referenced by your test. If no value is
specified, it uses the name of the table or view.

SQL
statement

A drop down list of the available SQL statements.

Opens the "Query Builder Dialog Box" (described on page 1722).

<SQL
statement
area>

An editable area for pasting existing SQL strings or for editing the SQL string
selected in the drop down list.

Tip: To add an SQL statement pasted into the text area to the drop down list,
click Check SQL Statement.

Check SQL
Statement

Executes the SQL statement shown in the text area and opens the results in a
Query Previewwindow.

<query
status>

If the statement is valid, the wizard adds it to the drop down list of SQL
statements and changes the status toQuery executed successfully.
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Select Data Source Name Dialog Box

Relevant for: API testing only

This dialog helps you build a connection string for an ODBC data source.
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To
access

Do one of the following:

From the Database wizard:

1. ChooseDatabase in the Data pane to open the wizard. For details, see "Add
New Database Data SourceWizard" on page 258.

2. Select ODBC as a connection type.

3. Click on theBuild Connection String button adjacent to the Connection
list drop down list.

From the Properties pane:

1. Add a DatabaseOpen Connection activity to the canvas.

2. Click the Input/Checkpoints tab in theProperties pane and click the browse
button in theConnection string property row.

3. In the "Connection Builder Dialog Box" (described on page 1720), select ODBC
as a connection type.

4. Click on theBuild Connection String button adjacent to the Connection
list drop down.

Relevant
tasks

"Add a database data source" on page 235

See also "Add New Database Data SourceWizard" on page 258

User interface elements depend on the type of DSN selected:

UI Element Description

Reload DSN List. Reloads the items that will appear in the drop down list.

User DSN Allows you to select a User DSN and provide credentials:

l User Name

l Password

System DSN Allows you to select a System DSN and provide credentials:

l User Name

l Password
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UI Element Description

File DSN Allows you to provide the following information for the File DSN or select a file
with the required settings.

l User Name

l Password

l File Content

Test
Connection

Sends the current DSN information to the database server to check its
validity.

Manage ODBC
Data Sources

Opens theMicrosoft ODBC Data Source Administrator dialog box. This dialog
box lets you add, edit or delete data sources at theWindows level.

Tip: After you create or modify a data source on theWindows level, click
theReload DSN List button to refresh the DSN list.

New Local Table Data Source Dialog Box

Relevant for: API testing only

This dialog box enables to create local data tables in the Data pane for use with your test.
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To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. Create or open a test or component

3. Select View > Data.

4. Click on theNew Data Source down arrow and select Local
Table.

Relevant tasks "Add a local data table" on page 238

User interface elements are described below:

UI
Element Description

Adds a new column to the local data table. New entries are added below the last
column.

Deletes the selected data table column.

Raises or lowers the selection in the column list.

Columns A list of the columns in the local data table. Click inside a table row to set or edit the
following values:

l Name. The name of the column.

l Data Type. A data type: String, Integer, Double, orDate.

l Description. A description of the data in the column.

Data Pane User Interface (BPT in UFT)
For details about the GUI testing Data Pane interface, see "Data Pane User Interface (GUI Testing)
" on page 239. For details about the API testing Data Pane interface, see "Data Pane User
Interface (API Testing)" on page 252.

Relevant for: business process tests and flows

The Data pane for business process tests enables you to set the number of iterations to run a
selected component or group as well as set the values for the parameters included with the
components.
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The following image shows an example of the Data pane when a component is selected in the
document pane, while editing a test.

If the user was editing a flow, the Data pane would display an additional Output tab for output
parameters.

The following image shows an example of the Data pane when a group is selected in the document
pane. Columns are displayed for each component in the group, with cells for each parameter value
in the various iterations.

To access 1. Ensure that a business process test or flow is in focus in the document pane,
and a component, flow, or group is selected.

2. Do one of the following:

n Select View > Data.

n Click theData toolbar button.
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Important
Information

The first column in the Data pane grid always displays the iteration number. Other
columns display data for specific parameters, or if you have a group selected in
the document pane, for specific components or flows in the group.

After adding iterations, enter text or formulas in the cells to add parameter data for
the specific iteration.

For more details, see "Considerations for BPT Test Iterations and Parameters" on
page 224.

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and Flows in
UFT" on page 2071

User interface elements are described below:

UI Element Description

Add New Iteration. Adds a new iteration without setting any parameter
values.

Click the drop-down button to perform one of the following tasks:

l Add New Iteration. Adds a new iteration without setting any parameter
values.

l Copy Iteration. Adds a new iteration by copying the values of a selected
iteration’s parameters.

l Create Iteration with Default Values. Adds a new iteration and sets the
parameter values to the default values.

Note: This button is disabled if the component or flow for which you are
adding an iteration is in a group or a flow, or, if you are selecting a
specific cell in the table.

To enable this button, select an iteration row in the grid andmake sure
that the component or flow selected in the document pane is not in a
group.

Delete. Deletes the selected iteration.

Note: This option is disabled when the component or flow for which you
are adding an iteration is in a group or a flow.

Copy (CTRL+C). Copies the data in the selected iteration or cell to the
clipboard.
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UI Element Description

Paste (CTRL+V). Pastes the copied iteration or cell. This action replaces
the selected data with the copied data.

You can also use this button to paste data from an external source, such as
an Excel spreadsheet.

Link Parameters. Opens the Select Link Source dialog box (described on
page 2128), which enables you to link parameter values to other parameters
in your test or flow.

Note: This button is disabled if you have an entire iteration row selected
in the grid.

Run iterations
from:

Enables you to select specific iterations to run. Select the first iteration to
run from the first drop-downmenu, and then select the last iteration to run
from the second drop-downmenu.

Encrypt. Encrypts the currently selected parameter.

Search toolbar. Enables you to search the data pane for a specific value.
Use the up and down arrows to navigate to the next or previous search
result.

Input/Output
tabs

Enables you to add andmodify iteration data for input or output parameters.

TheOutput tab is available only when editing flows.

<iteration #
column>

Indicates the iteration number for the row, in ascending order.

<value
columns>

Displays the value for each parameter in the displayed iteration. Test or flow
parameters (parameters whose values are to be taken from the test or flow
level), are shown in braces {}.

Enter values directly in the cell or link them using the Select Link Source
dialog box. To promote a parameter value to a test or flow parameter, add
braces around the value you enter.

If no value is specified in the Properties pane Parameters tab, the default
value for that parameter is used.
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Troubleshooting and Limitations - Data Pane
Relevant for: GUI tests, scripted GUI components, andAPI testing.

This section describes troubleshooting and limitations for working with the Data pane.

Incompatible Microsoft Excel Files (GUI tests and components only)
Microsoft Excel files may not be compatible with UFT. This may occur because the .xlsor .xlsx file
you are attempting to import contains features or functionality that is unavailable for GUI tests.

Workaround 1: Create and import .xls or .xlsx files that contain only functionality that is available
from theGUI testing Data pane itself. For a list of the available functionality in the Data pane, see
the relevant shortcut menu in "Data Pane User Interface (GUI Testing)" on page 239.

Workaround 2: If you need to alter an existing .xls or .xlsx file, you can use one of the following
options:

l Determine what are themost recent changes to the .xlsor .xlsx file, and undo or remove them.

l Remove any existingmacros.

l In each worksheet in the .xls or .xlsx file, select all rows and columns, and select Edit > Clear
> Formats to remove all formatting from the worksheet.

l Create a new .xls or .xlsx file, and copy the data from the non-compatible file. You can do this by
using the standard copy and paste operations, or you can do this by saving each worksheet as a
tab delimited .txt file (File > Save As), opening each .txt file in a text editor, and copying the
data from that file to a new .xlsor .xlsx file.

Caution:

n Make sure to back up your .xls or .xlsx file before changing or removing any data or
functionality.

n Even though some of the operations in this workaround can be automated, due to the
way that Microsoft Excel exports data to tab delimited text files, the actual exported data
may not exactly match the original data. Therefore, make sure to verify all exported data.

Importing/Exporting a Data Table
If you import a Microsoft Excel table containing a combo box, list cells, conditional formatting, or
other special cell formats, the formats are not imported and the cells are displayed in the data table
with fixed values. Make sure to verify all imported data from cells containing any of these special
formats because the original formattingmay affect the values, and the values may not be imported
correctly.

Data Table Cell Content
Entering a very large number in the data table may cause unexpected behavior.
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Troubleshooting and limitations for using the Data pane with API tests and
components.

l Excel data with column headers beginning with digits or containing symbols (such as !,@, or # )
are not supported.

l XML data sources: .xml files that use XSL are not supported.
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Chapter 9: Debug Panes
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This chapter includes:

Concepts 272

Debug Panes Overview 272

Reference 273

Debug Pane Interface 273

Troubleshooting and Limitations - Debug Panes 301
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Concepts

Debug Panes Overview
Relevant for: GUI actions, scripted GUI components, function libraries and user code files

After creating a test, component, function library, or user code file, you can check to see if they run
properly. Using the debug panes, you can then debug your tests, components, function libraries, or
user code files using UFT's debugging capabilities.

The debug panes are the primary interface for viewing information about your application during run
sessions, as well as addressing any errors in the run session.

For a conceptual overview of UFT's debugging capabilities, see "Debugging Overview" on page
675.

For a task related to debugging, see "How to Debug Your Test, Component, Function Library, or
User Code File" on page 683.

For exercises to practice using UFT's debugging capabilities, see :

l "How to Debug aGUI Action or a Function - Exercise" on page 689

l "How to Debug an API User Code File - Exercise" on page 693

l "How to Step Into, Out of, or Over a Specific Step in a GUI Test - Exercise" on page 697
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Reference

Debug Pane Interface
Relevant for: GUI actions, scripted GUI components, function libraries and user code files

The Debug panes enable you to perform different debugging activities when a run session is
suspended, such as:

l View, set, or modify the current value of objects or variables in your test, scripted GUI
component, function library, or user code file

l Run VBScript or C# commands in your paused run session

l Viewing information about the current call stacks of yourAPI test

l View information about the associated .dll files and threads being used in yourAPI run session

The image below shows all the Debug panes open as tabs for aGUI test. The default debug pane
shown is the Debug Breakpoints tab.
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The image below shows all the Debug panes open as tabs for anAPI event handler. The default
debug pane shown is the Debug Breakpoints tab.

To
access

1. Ensure that a test, component, function library, or user code file is in focus in the
document pane.

2. Select View > Debug and choose the relevant debug pane.
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Import
ant
inform
ation

Debug panes display information only when a run session is paused. A run session can
be suspended in the following situations:

l The run session stops at a breakpoint.

l You useRun menu commands or context-menu options (such as PauseorRun to
Step) to suspend a run session.

l A step fails and you select theDebug option in the "Run Error Message Box"
(described on page 701).

Releva
nt
tasks

"How to Debug Your Test, Component, Function Library, or User Code File" on page
683

See
also

l "Debugging Overview" on page 675

l "Considerations for Debugging GUI Tests and Components" on page 676

l "Considerations for Debugging API User Code Files" on page 676

l "How to Debug aGUI Action or a Function - Exercise" on page 689

l "How to Debug an API User Code File - Exercise" on page 693

The following debug panes are available:

UI Element Description

Breakpoints
pane

Displays the information about all breakpoints inserted into your action, scripted
component, function library, or user code file and enables you to enable or disable
any or all breakpoints in a run session. For details, see " Breakpoints Pane" on
the next page.

Call Stack
pane

Displays information about the functions, methods, or context currently relevant
to your run session. For details, see "Call Stack Pane" on page 281.

Loaded
Modules
pane
(API testing
only)

Displays information about the .dll files associated with your run session and
provides the path to find and debug them. For details, see "LoadedModules Pane
(API Testing) " on page 285.

Threads
pane
(API testing
only)

Displays information about the threads running in your current run session. For
details, see "Threads Pane (API Testing) " on page 287.
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UI Element Description

Local
Variables
pane

Displays the current values and types of all variables in the current context of the
document. For details, see "Local Variables Pane" on page 288.

Console
pane

Enables you to run VBScript or C# commands in your paused run session. For
details, see "Console Pane" on page 292.

Watch pane Displays the current values and types of variables and VBScript or C#
expressions that you add to theWatch pane. For details, see "Watch Pane" on
page 297.

Breakpoints Pane

Relevant for: GUI actions, scripted GUI components, function libraries and user code files

This debug pane enables you to view information about breakpoints inserted into yourGUI actions,
scripted GUI components, function libraries or user code files and navigate directly to the
breakpoint location in the relevant document.

The image below shows the breakpoints pane for aGUI test:
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The image below shows the canvas for aAPI test event handler.
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To access 1. Do one of the following:

n Ensure that a test, component, function library, or user code file is in focus
in the document pane.

n In the solution explorer, select a test, component, function library, or user
code node.

2. Select View > Debug > Breakpoints

Note: This pane displays information only when a breakpoint is inserted into
a document.

Important
information

l The pane displays the breakpoints for theGUI actions, scripted GUI
components, function libraries, or API tests that are part of the current solution.

l You can double-click on a breakpoint to navigate directly to the relevant line.

l Breakpoints are saved with your test, scripted component, function library, or
user code file and aremaintained even after you close UFT.

Relevant
tasks

"How to Use Breakpoints " on page 687

See also "Breakpoints " on page 681

User interface elements are described below:

UI
Element Description

Remove Current Breakpoint. Removes the current breakpoint from your document.

Disable/Enable Breakpoint. Disables or enables the selected breakpoint, which
instructs UFT to use or ignore it during a run session.

Go to Source. Navigates directly to the line containing the selected breakpoint in
your document.

Remove All. Removes all breakpoints listed in the pane from the documents that
contain them.

Enabled A check box that specifies whether the breakpoint is enabled or disabled.

Name The file name of the document that contains the breakpoint, and the number of the line
in the file that contains the breakpoint.

Script The name of the GUI action, scripted GUI component, function library, or user code
file that contains the breakpoint.
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Call Stack Pane

Relevant for: GUI actions, scripted GUI components, function libraries and user code files

This debug pane enables you to view information about themethods and functions that are currently
on the call stack of your test, component, function library, or user code file or the context in which
the run session was paused.

The image below shows the Call Stack pane for aGUI test.
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The image below shows the Call Stack pane for aAPI testing event handler.
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To access 1. Do one of the following:

n Ensure that a test, component, function library, or user code file is in focus
in the document pane.

n In the solution explorer, select a test, component, function library, or user
code node.

2. Select View > Debug > Call Stack.

Note: This pane displays information only when a run session is paused.

Important
information

l This pane is read-only.

l You can navigate directly to the beginning line of a function, method, or context
in your document by clicking on its row in the pane. If the relevant document is
not open, UFT opens it.

l TheWatch pane and Local Variables pane display information relevant to the
context that you select in the Call Stack pane.

For example, if you select the row for a specific function in the Call Stack
pane, the variables from this function and expressions selected to watch from
this function are displayed in their respective panes.

l Caution for API testing users: If you navigate to a stack that is not defined in
a user code file, UFT opens other coding files. Do not edit this code. Doing so
can cause unexpected behavior in your run sessions.

User interface elements are described below:

UI
Element Description

Function
name

The name of the function, method, or context currently relevant.

l If a run session is suspended before running a step or event or there is no specific
function or event being run, then this pane displays the stringVBScript global
code (for GUI tests) orScript.TestUserCode.<event name> (for API tests). The
expressions displayed in the Local Variables andWatch panes are evaluated
within the context of the suspended step or event.

l For GUI testing: If a run session is suspended within a function library, this pane
initially displays the name of the function in which the run paused and enables you
to switch to the context of other functions and subroutines within the same
function library.
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UI
Element Description

File
name

The name of the file containing the called function, method, or context. This is the
location in the file system or an ALM project.

Line # The line number on which the function, method, or context definition begins.

Note: (for API testing) Line numbers can be displayed by right-clicking and
selectingShow line number.

Context
menu
options
(API
testing
only)

The following context menu options are available only for API tests:

l Show external methods. Displays all methods running in the background during
a run session.

Note: The Call Stack pane displays the external methods for informational
purposes. You cannot navigate to the stack displayed in thesemethod calls.

l Show module names. Displays the .dll file in which themethod call is found.

l Show argument values.

l Show line number. Displays the line number on which themethod call begins for
accessible internal methods.
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Loaded Modules Pane (API Testing)

Relevant for: User code files only

This debug pane enables you to view information about the .dll files loaded and executed as an API
test runs.
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To access 1. Do one of the following:

n Ensure that an API test, component, or user code file is in focus in
the document pane.

n In the solution explorer, select an API test, component, or user
code node.

2. Select View > Debug > Loaded Modules

Note: This pane displays information only when a run session is
paused.

Important
information

The list of .dll files is displayed only when you pause a run session.

User interface elements are described below:

UI
Element Description

Name The name of the .dll file.

Address The numeric address of the .dll file.

Path The location of the .dll file in the file system.

Order The order in which the .dll files are used in your run session.

Symbols The symbols included with each .dll file, which allow for debugging of loaded
modules.

Note:

l A .dll file's symbols must be loaded to enable you to debug a .dll file.

l Many of the .dll files listed in this pane have no symbols loaded, as they are
files called by UFT during an API run session.

l Any .dll files you add to your test can be debugged if there is a run error.
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Threads Pane (API Testing)

Relevant for: User code files only

This pane enables you to view information about the threads currently running as part of the run
session.
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To access 1. Do one of the following:

n Ensure that an API test, component, or user code file is in focus in the
document pane.

n In the solution explorer, select an API test, component, or user code
node.

2. Select View > Debug > Threads

Note: This pane displays information only when a run session is paused.

Important
information

l The list of threads is displayed only when you pause a run session.

l If your test contains only one thread, then this pane is not available.

l If the thread is contained within a user code file, you can double-click on the
thread to navigate directly to the beginning of the thread.

User interface elements are described below:

UI
Element Description

ID The numeric identification of the thread.

Name The name given to a particular thread.

Location The location in which the thread is found.

Note: Some threads are not found in your user code, but represent background
threads that are part of your test. These threads are not accessible.

Priority The order in which the threads can be used when running amulti-thread operation.
Higher priority threads are called first.

Frozen Indicates whether a thread is frozen or unfrozen. Right-click a thread to freeze or
unfreeze it.

Local Variables Pane

Relevant for: GUI actions, scripted GUI components, function libraries and user code files

This debug pane displays the current values and types of all variables in current the context of your
document.

The image below shows the Local Variables pane for aGUI test.
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The image below shows the Local Variables pane for aAPI testing event handler.
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To access 1. Do one of the following:

n Ensure that a test, component, function library, or user code file is in focus
in the document pane.

n In the solution explorer, select a test, component, function library, or user
code node.

2. Select View > Debug > Local Variables

Note: This pane displays information only when a run session is paused.

Important
information

l The information displayed in this pane is read-only.

l You cannot edit the value of expressions in the pane. To change the value of
an expression, enter a command in the "Console Pane".

l Only variables that were recognized up to the last step or event that occurred
are displayed in the Local Variables pane. As you continue stepping through
the subsequent steps in your document, UFT adds any additional variables
that it recognizes and updates the values displayed in the Local Variables
pane.

Relevant
tasks

"How to Debug Your Test, Component, Function Library, or User Code File" on
page 683

See also l "Debugging Overview" on page 675

l "Considerations for Debugging GUI Tests and Components" on page 676

l "Considerations for Debugging API User Code Files" on page 676

l "Watching the Values of Variables and Properties of Objects During a Run
Session" on page 680

l "How to Debug aGUI Action or a Function - Exercise" on page 689

l "How to Debug an API User Code File - Exercise" on page 693

User interface elements are described below:

UI
Element Description

Name The name of the variable, or an expandable node whose child elements contain
details about the variable. For example, if a variable is assigned to an object, you can
expand the variable in the pane and view its methods and properties.
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UI
Element Description

Value The current value of the variable.

Note: If a variable node contains child elements, the value column indicates the
number of child elements.

Type
Name

The type of the variable's value (for example, Integer orString).

Console Pane

Relevant for: GUI actions, scripted GUI components, function libraries and user code files

This debug pane enables you to run lines of VBScript code or C# code in your suspended run
session.

For example, you can run code that performs any of the following activities before you resume the
run session:

l Retrieves information from the application you are testing

l Runs a test object method and displays the return value, enabling you to learnmore about how
themethod works

l Modifies the value of a native (run-time object) property in the application

l Calls a native (run-time object) method in the application

l Modifies the input and output properties for a step

l Sets or modifies a variable

The image below shows the Console pane for aGUI test.
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The image below shows the Console pane for aAPI testing event handler.
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To access 1. Do one of the following:

n Ensure that a test, component, function library, or user code file is in focus
in the document pane.

n In the solution explorer, select a test, component, function library, or user
code node.

2. Select View > Debug > Console

Note: This pane displays information only when a run session is paused.

Important
information

l You can enter lines of code in the Console pane only when a run session is
suspended. When no run session is suspended, you can view the command
history, select and copy text from it, or use theClear All context menu.

l For GUI testing: RunningRunAction or LoadAndRunAction statements
from this pane is not supported.

Relevant
tasks

"How to Debug Your Test, Component, Function Library, or User Code File" on
page 683

See also l "Debugging Overview" on page 675

l "Considerations for Debugging GUI Tests and Components" on page 676

l "Considerations for Debugging API User Code Files" on page 676

l "Watching the Values of Variables and Properties of Objects During a Run
Session" on page 680

l "How to Debug aGUI Action or a Function - Exercise" on page 689

l "How to Debug an API User Code File - Exercise" on page 693

UI elements for GUI testing
Console pane user interface elements are described below (unlabeled elements are shown in angle
brackets):

UI Element Description

<command
line
prompt>

Enables you to enter a line of code to be run in the context of your suspended run
session. Type or paste the line of code in the window and press ENTER to run the
code.
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UI Element Description

<command
line
history>

Displays the lines of code that you ran.

l You cannot make any changes to these lines, but you can select and copy text
from them.

l You can use the UP and DOWN arrow keys to browse through the command
history. UFT copies the commands to the active command line, enabling you to
repeat or reuse commands that you entered earlier.

<right-click
context
menu>

Provides commands that you can use to edit the content of the Console pane.

l TheCut, Copy, andPaste commands enable you to use the clipboard to copy
text from the command history and to edit the active command line.

l TheClear All command enables you to erase all of the command history.

UI elements for API testing
Console pane user interface elements are described below (unlabeled elements are shown in angle
brackets):

UI Element Description

Clear Console. Enables you to erase all of the commands entered in the
command line area.

Delete History. Clears all previously saved commands. By default, all previous
commands are saved in the pane and can be selected for a new command by
using the up or down arrows.

Toggle Word Wrap. Enables or disables word wrap behavior for commands
given in the command line area.

<command
line area>

Enables you to enter a line of code to be run in the context of your suspended run
session. Type or paste the line of code in the window and press ENTER to run the
code.

This area also displays the command line history, including the lines of code that
you ran.

Notes:

l You cannot make any changes to these lines, but you can select and copy
text from them.

l You can use the UP and DOWN arrow keys to browse through the
command history. UFT copies the commands to the active command line,
enabling you to repeat or reuse commands that you entered earlier.
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Watch Pane

Relevant for: GUI actions, scripted GUI components, function libraries and user code files

This debug pane enables you to view the current values and types of selected variables, properties,
and VBScript or C# expressions in your suspended run session.

The image below shows theWatch pane for a GUI test.

The image below shows theWatch pane for an API testing event handler.
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To access 1. Do one of the following:

n Ensure that a test, component, function library, or user code file is in focus
in the document pane.

n In the solution explorer, select a test, component, function library, or user
code node.

2. Select View > Debug > Watch.

Note: This pane is only relevant when a run session is paused.

User Guide
Chapter 9: Debug Panes

HP Unified Functional Testing (12.00) Page 298 of 2274



Important
information

l You can add, edit, or remove expressions within theWatch pane using the
pane's toolbar buttons in addition to theRun menu command (Run > Add to
Watch).

l You cannot edit the value of expressions in the pane. To change the value of a
watched expression, enter a command in the "Console Pane".

l You can expandWatch pane items if the property selected contains multiple
values.

l You can sort the columns in the watch pane by expression, value, or type
name by clicking the column headers.

l Watch expressions are saved with the test andmaintained between testing
sessions and as you switch between open documents.

l For API testing: If you added an item to this pane from an user code file that
already ran, the pane will show it as undefined.

Relevant
tasks

"How to Debug Your Test, Component, Function Library, or User Code File" on
page 683

See also l "Debugging Overview" on page 675

l "Considerations for Debugging GUI Tests and Components" on page 676

l "Considerations for Debugging API User Code Files" on page 676

l "Watching the Values of Variables and Properties of Objects During a Run
Session" on page 680

l "How to Debug aGUI Action or a Function - Exercise" on page 689

l "How to Debug an API User Code File - Exercise" on page 693

User interface elements are described below:

UI Element Description

Add New Watch Expression. Opens the Add New Watch dialog box, which
enables you to add a new expression to theWatch pane. After you enter the
expression and click OK, UFT displays the value and type of the expression in the
pane.

Edit Watch Expression. Enables you to edit the selected expression during your
debug session.

Remove Watch Expression. Removes the currently selected expression from
theWatch pane.

Remove All. Removes all the expressions currently displayed in theWatch pane.
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UI Element Description

Expression The expression whose value you want to watch. For details on adding and
removing expressions from theWatch pane, see "Watching the Values of
Variables and Properties of Objects During a Run Session" on page 680.

Caution: UFTruns the expressions in theWatch pane to evaluate them.
Therefore, do not enter a test object method or any expression whose
evaluation could affect the state of the test or a test object, as this can lead to
unexpected behavior of your test or function library.

Value The current value of the expression. The evaluated value is displayed only when a
run session is suspended.

Type name The type of the expression's value after it is evaluated (for example, Integer or
String).

If an expression cannot be evaluated in the current context, the type displayed is
Incorrect expression.
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Troubleshooting and Limitations - Debug Panes
Relevant for: GUI actions, scripted GUI components, function libraries and user code files

This section describes troubleshooting and limitations for the Debug Pane.

l You cannot edit variables or properties from the Local Variables orWatch Panes.

Workaround:Use the Console pane to edit andmodify your variable and property values by
running a command line to assign the new value.

l For GUI testing: (Relevant only if Microsoft PDM 9.x or later is installed on your computer.) If
you add Action automation objects to theWatch pane and then close and re-open your test
without closing and re-opening UFT, these actions may not load successfully in the re-opened
test.

Workaround: Restart UFT and open your test.
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Chapter 10: Document Pane
Relevant for: GUI tests and components, API testing, and business process testing

This chapter includes:

Concepts 303

Document PaneOverview 303

Editing Text and Code Documents 305

Regular Expressions Overview 318

Tasks 321

How to Use Bookmarks in the Editor 321

How to Use theGo ToDialog Box in the Editor 322

How to Use Code Snippets and Templates 322

How to Search for References or Classes in Documents in the Editor (API Testing Only) 325

How to Find or Replace Strings in Files 327

Reference 330

Document Pane User Interface 330

Document Pane Context MenuOptions 332

Editor User Interface 334

Find Dialog Box (Document Pane Editor) 342

Replace Dialog Box 344

Go ToDialog Box 347

Editor Context MenuOptions 349

Regular Expression User Interface 352

Troubleshooting and Limitations - Statement Completion 363
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Concepts

Document Pane Overview
Relevant for: GUI tests and components, API testing, and business process testing

The document pane is themain design area in UFT and displays all open documents as separate
tabs. Each tab can also be individually moved, docked, or floated as an independent pane, and you
can drag and drop or pin any of the UFT panes within the document pane.

For details on how tomove UFT panes, see "How to Customize the UFTWindow " on page 184.
You can also restore the tabs or panes to the default location from theView menu.

The document pane displays the following types of documents:

GUI testing
documents

l GUI tests

l GUI actions

l Function libraries

API testing
documents

l API tests

l API actions

l C# files containing event handler code (TestUserCode.cs files)

l C# user code files

BPT documents l Business process tests

l Business process flows

l Business components, including API, keyword GUI, and scripted
GUI components

l Application areas

Non-testing
documents

l Text files
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The features available for viewing and editing documents depend on the document type, as
described in the following table.

Document Type Opens in the:

l GUI and API tests

l API actions

l API business
components

Canvas. Graphically displays and enables you to edit the flow of
your test, action, or component.

For details, see: "The Canvas" on page 209

l GUI actions

l Scripted GUI
components

l Keyword GUI
components

Keyword View. Enables you to create and view the steps of your
action or component in a keyword-driven, modular, table format.

For details: "Keyword View User Interface" on page 942

l GUI actions

l Scripted GUI
components

l Function libraries

l C# code files

l Text files

Editor. Provides text and code editing features that facilitate the
design of your text, script, and code documents.

For details:

l General Editor information: "Editing Text and Code
Documents" on the next page

l For GUI testing: "Programming in GUI Testing Documents in
the Editor - Overview " on page 995

l For API testing: "How to Open aWindow forWriting Custom
Code" on page 1948

l Business process
tests

l Business process
flows

BPT in UFT. Displays and enables you to edit business process
tests and flows, including grouping components and flows, and
modifying run order. For details, see "Business Process Testing in
UFT - Overview" on page 2065

Application areas Application Area. Displays and enables you to edit the application
area settings and resource associations.

For details: "Application Area User Interface" on page 2101
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Multiple Document Types in the Document Pane

Relevant for: GUI tests and components and API testing

Using the document pane, you can open and work with multiple documents simultaneously. To
openmultiple documents, they must all be included in the same solution.

Note: You can openmultiple function libraries independently from a solution.

You can navigate betweenmultiple documents by clicking the tab name of the document you want
to view. You can also use the document view drop-down arrow to display a list of open
documents.

For details onmanaging documents, see "How to Create andManage Documents" on page 136.

Editing Text and Code Documents
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

You can write customized code for your tests by modifying actions, function libraries, and user
code files in the Editor, as well as enhance your tests and function libraries using a few simple
programming techniques.

The Editor supports common text and code editing features. For details, see:

l "Statement Completion in the Editor" on the next page

l "Automatic Code Completion" on page 316

l "Bookmarks Overview" on page 204

l "Searching and Replacing in the Editor " on page 317

l For GUI testing: "Programming in GUI Testing Documents in the Editor" on page 994

l For API testing: "Writing Event Handlers for API Test Steps" on page 1935

Other notable Editor features include expanding and collapsing code, zooming in and out using the
mouse, and code templates defined in the Code Templates pane of the Options dialog box (Tools >
Options > Coding tab > Code Templates node). For details about defining code templates, see
"Code Templates Pane (Options Dialog Box > Coding Tab)" on page 573.

To define other preferences related to viewing and editing documents in the Editor, see "Text Editor
Tab (Options Dialog Box)" on page 574.

For a user interface description of the Editor, see "Editor User Interface" on page 334.
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Statement Completion in the Editor

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

Statement completion, which is similar to Microsoft's IntelliSense functionality, enables you to
increase programming speed and accuracy by providing dynamic lists of items, in the form of
tooltips, drop-down lists, or popup windows, while writing statements in the Editor.

As you type in the Editor,UFT displays items youmight want to add to your statement, as well as
the syntax relevant to what you are typing. UFT provides this type of statement completion
information, when available, for:

l Activity-specific properties (API testing only)

l Function andmethod syntax

l Objects you create in your code

l Operations

l Properties or operations that return objects

l Structured parameters

l Variable definitions andmethods

l Variables to which classes, objects or test objects are assigned

l VBScript classes, user defined functions, or constants (GUI actions and scripted components
only)

l Reserved objects

l Test objects and collections (GUI actions and scripted components only)

l Utility objects

Note: (for GUI testing only) The list of available statements is displayed even if you typed
an object that has not yet been added to the object repository. If the action contains a
function, or the action or component is associated with a function library, the functions are
also displayed in the list.

For details about statement completion in the Editor, see:

l "Statement Completion Options" on the next page

l "Statement Completion Considerations" on page 311
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l "Statement Completion Example for GUI Testing" on page 313

l "Troubleshooting and Limitations - Statement Completion" on page 363

Statement Completion Options

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

The following table summarizes some statement completion options available when you enter
specific items and keystrokes.

If you
enter: Followed by: UFT displays:

An
operation
name

SPACE or Open
parenthesis"("

The operation syntax, including its mandatory and optional
arguments. When you add a step that uses an operation, youmust
define a value for eachmandatory argument associated with the
operation.

An
argument

Comma (,) The operation syntax, bolding the next argument for which you need
to enter a value.

Relevant if you enter a comma after any argument value other than
the last one in a step.

Note: For certain operations, when you type the space or
comma before an argument that has a predefined list of values,
UFT displays the list of possible values.

An
operation
or
function
name

CTRL+SHIFT
+SPACE

or

For GUI
testing:
Select Edit >
Format >
Argument
Info

The statement completion (argument syntax) tooltip for that item.
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If you
enter: Followed by: UFT displays:

CTRL+SPACE

or

For GUI testing: Select
Edit > Format >
Complete Word

A dynamic list of the relevant:

l operations

l properties

l user-defined functions

l constants and local variables relevant to the current
programming scope

l functions andmethods relevant to the current programming
scope

GUI testing only:

l test objects

l utility objects

l collections

Note: If there is only one relevant item defined, its name is
automatically entered in the step, without opening the list. For
example, if you typed the beginning of the item name before
pressing CTRL+SPACE, and only one itemmatches the text you
typed.

The beginning of an item
in the statement
completion list

The list of items, highlighting the first item (alphabetically) that
matches the text you typed. Pressing ENTER or SPACE adds the
highlighted word to the step.
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Statement Completion Options for GUI Testing Only
The following table summarizes some additional statement completion options available in GUI
tests only, when you enter specific items and keystrokes.

If you enter: Followed by: UFT displays:

l A test object type

l "Environment"

l "Parameter"
(for tests and
scripted
components)

Open
parenthesis"("

Respectively, an alphabetically sorted list of the
relevant available:

l Test objects (for example, Page( displays a list of all
the Page test objects in the object repository)

l Environment variables (built-in, user-defined, and
external)

l Action parameters (output and input)

If there is only one selection available, UFT
automatically enters its name in quotes after the open
parenthesis.

l A test object

l A collection
object

l A variable that
was assigned an
object

l An object that you
created in the test
or component
(using
CreateObject, for
example)

Period (.) Depending on the type of object and its hierarchy, a
dynamic list of the relevant:

l test objects (Editor only)

l collections

l operations

l properties

l registered functions

Example:

l The list displayed for a container object includes
the objects it contains.

l The list displayed for a collection object includes
collectionmethods.

l The list displayed for a variable that was
assigned an Excel worksheet (Set var =
CreateObject ("excel.application")) includes
worksheet methods and properties.
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If you enter: Followed by: UFT displays:

A variable that was
assigned a VBScript
class

Period (.) A list of the relevant VBScript class methods,
properties, and variables

AWith statement Period (.) A list of the operations and properties available for the
relevant object.

Note: If youmanually type aWith statement (as
opposed to using amenu command to create it),
youmust use theEdit > Format > Apply "With"
to Script command (or press CTRL+W) to enable
statement completion within theWith statement.

TheObject property Period (.) A list of the object's native operations and properties.

Available only if the object data is currently available in
the Active Screen (tests and scripted components only)
or the open application.

For details related to tests and scripted components,
see "Statement Completion Considerations" on the next
page.

A structured
parameter

Colon (:) A list of the elements available, according to the
structure definition.

Example:

If you define a ZMOVIE structure, with the
elements TITLE, DIRECTOR, GENRE, and
STARRING, and thenmap a parameter named
Movie to a structure of this type, then when you
type:

Parameter ("Movie:

the displayed list includes the elements of a
ZMOVIE structure: TITLE, DIRECTOR, GENRE,
STARRING.
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If you enter: Followed by: UFT displays:

A structured
parameter's element
or sub-element

Period (.) A list of the sub-elements available, according to the
structure definition.

Example:

If you type:

Parameter ("Movie:Starring.item[1].

the displayed list includes the sub-elements of a
Starring element: FIRST_NAME, LAST_NAME.

Statement Completion Considerations

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

Whenworking with UFT's statement completion feature, consider the following:

l To close the statement completion drop-down list without selecting from it, press ESC.

l If you resize the frame in which the statement completion drop-down list is displayed, UFT
subsequently uses the new size when it displays statement completion drop-down lists.

l UFTmight not display statement completion information if the statement is typed incorrectly and
contains syntax errors. In many cases, you can view such errors in the "Errors Pane" (described
on page 364) when you save your changes.

Statement Completion Considerations for GUI Testing Only

l Although statement completion in function library documents is supported to help generate test
object statements, it is generally not recommended to include a full object hierarchy statement in
a function. It is preferable tomake your functions generic so that they can be used with different
objects.

l In some cases, UFT needs to retrieve statement completion information from an object in the
application. In such cases, youmay experience a delay while typing in the Editor.

l When you record in a browser other than Internet Explorer, UFT captures the dynamic HTML
from the relevant browser. However, the Active Screen uses an Internet Explorer engine and
thus renders Web-based pages as static HTMLwith the Internet Explorer DOM exposed.

Therefore, if you insert theObject property for aWeb object when only Active Screen object
data is available (the object is not displayed in an open application), then UFT statement
completion displays the available native operations and properties for the Internet Explorer
DOM, even if you recorded the object in another browser.

For details on theObject property, see "Native Properties andOperations" on page 1008.
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l In the Editor, when working with Java or ActiveX objects,UFT dynamically retrieves the list of
possible values for certain arguments from the object in the application. For UFT to retrieve the
possible values, the applicationmust be open and the relevant object must be visible. For
example, UFT can retrieve the list of items in a specific Java list object, and display them as the
possible values for the Item argument of the Select method.

Note:When you edit a test during a recording session, UFT does not retrieve the possible
argument values from the application.

l If you assign an object to a variable, and then type the name of the variable followed by a period,
UFT displays a list of the operations and properties available for the object.

In some cases, the value of a variable cannot be determined while editing the test (for example,
if the value is set by a conditional assignment or returned by another function). In this case, UFT
provides statement completion information according to themost recent line of code in which the
value of the variable could be evaluated, if any.

The following examples illustrate this:

Example 1:

Line 1: Set x = CreateObject("Excel.Application")
Line 2: z = GetValueFromUser()
Line 3: If z = 2 Then
Line 4:    Set x = CreateObject("Word.Application")
Line 5: End If
Line 6: x.

While editing this test, UFT cannot determine which object will actually be assigned to x in
line 6. However, because the value of x can be evaluated independently in line 4, UFT
displays the statement completion information relevant to the object "Word.Application" for
the variable x in line 6.

Example 2:

Line 1: Set x = CreateObject("Excel.Application")
Line 2: Set x = MyGetObject()
Line 3: x.

While editing this test, UFT cannot determine the type of object that theMyGetObject
function returns (line 2). Therefore, in line 3 in the example above, UFT displays the
statement completion information relevant to the object "Excel.Application", because line 1
is themost recent line of code in which the value of x could be evaluated. However, if line 2
were not preceded by a line in which the value could be evaluated, UFT would not display
any statement completion information for x in line 3.
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Statement Completion Example for GUI Testing

Relevant for: GUI actions, scripted GUI components, and function libraries

These examples demonstrate using the statement completion functionality step-by-step:

l "Use statement completion in the Editor" below

l "Use statement completion in a function library" on page 315

Use statement completion in the Editor

1. In the Editor, type an object followed by an open parenthesis (.

If there is only one object of this type in the object repository, UFT automatically enters its
name in quotes after the open parenthesis. If more than one object of this type exists in the
object repository, UFT displays them in a list.

2. Double-click an object in the list or use the arrow keys to choose an object and press ENTER or
SPACE. UFT inserts the object into the statement.

3. Type a period (.) after the object on which you want to perform the operation. Type the period
after the object description, for example ("username").
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UFT displays a list of the available operations and properties for the object.

As you type the name of an operation or property, UFT highlights the first item (alphabetically)
that matches the text you typed. Pressing ENTER or SPACE inserts the highlighted word into the
step.

4. Double-click an operation in the list or use the arrow keys to choose an operation and press
ENTER or SPACE.

UFT inserts the operation into the statement. If the operation contains arguments, UFT
displays the syntax of the operation in a tooltip.

In the following example, theSetmethod has one argument, called Text. The argument name
represents the text to insert in the box.

5. Enter the operation arguments after the operation according to the displayed syntax. For
example:

Browser("Welcome:Mercury Tours").Page("Book a Flight:Mercury").WebEdit("username").Se
t."mercury"

After you add a step in the Editor, you can view the new step in the Keyword View. If the
statement that you added in the Editor contains syntax errors, UFT displays the errors in the

User Guide
Chapter 10: Document Pane

HP Unified Functional Testing (12.00) Page 314 of 2274



Errors pane when you select the Keyword View. For details, see "Errors Pane User Interface"
on page 374.

Use statement completion in a function library

1. Type the full hierarchy of a test object, for example:

Browser("Welcome: Mercury Tours").Page("Book a Flight:Mercury).WebEdit("username")

2. Type a period (.) after the object description, for example ("username"). UFT displays a list of
the available operations and properties for the object.

3. Double-click an operation in the list or use the arrow keys to choose an operation and press
ENTER or SPACE. UFT inserts the operation into the statement. If the operation contains
arguments, UFT displays the syntax of the operation in a tooltip.

In the following example, theSetmethod has one argument, called Text. The argument name
represents the text to insert in the box.
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In the following example, theReportEventmethod has four arguments.

4. Enter the operation arguments after the operation.

Automatic Code Completion

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

UFT provides automatic code completion features, to facilitate coding in the Editor. This includes
some basic, static code snippets that you can insert automatically into your document, as well as
templates that you can use to insert additional code snippets by typing specific keywords.

For example, if you enter the letters if at the beginning of an empty line in a GUI action, followed by
a SPACE, UFT automatically enters:

If True Then
End If

The word True is highlighted, reminding you to replace it with the relevant condition.

You can alsomodify the templates provided, or build your own customized templates as needed,
and define the keywords used to invoke the use of each template.

For example, youmight repeat a complicated If...Then statement many times your document. You
can use an existing template for the If...Then statement to create your own customized template
with your more complicated code. You can also create templates from scratch, such as a comment
block template, whichmight include information such as programmer identification, date added, or
other details you want included in all comments.

Code templates are defined in the "Code Templates Pane (Options Dialog Box > Coding Tab)"
(described on page 573), and are supported for the following file types, used for actions and function
libraries:

l .txt files

l For GUI testing: .mts, .qfl, or .vbs files

l For API testing: .cs files

For details, see "How to Use Code Snippets and Templates" on page 322.

For GUI testing only: If you enter two characters that are the initial characters of multiple
VBScript keywords, a drop-downmenu appears with all of the relevant keywords, and you can
select the one you want. For example, if you enter the letters pr and then enter a space, the drop-
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downmenu is displayed, containing the keywords preserve, private, and property. You can then
select a keyword from the list and press ENTER to insert it into your script.

Searching and Replacing in the Editor

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

When searching in GUI tests you can search in the Editor for text strings only. When searching API
tests, you can search in the Editor for text strings, as well as references, derived classes, base
classes, or overridingmethods, for the current method, function or class.

When searching for text, you can use standard text or regular expressions in your search strings,
and you can perform string replacements. You can also search in documents that are closed but
accessible by the search functionality, either by searching an entire solution, or specifying a search
folder.

For details, see "How to Find or Replace Strings in Files" on page 327 and "How to Search for
References or Classes in Documents in the Editor (API Testing Only)" on page 325.

Note: Search and replace functionality is not available in the Keyword View, the canvas, or an
application area.

For details, see:

l " Regular Expressions in the Find and Replace Dialog Boxes" on page 357

l "File and Item Types Included in String Searches" below

File and Item Types Included in String Searches

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

When performing text searches or replacements you can search throughout an entire solution, test,
or folder. However, the specific file and item types searched within the solution, test, or folder are
defined by the search algorithm and cannot bemodified by users.

Note: The search is limited to the text in the file at the time that the Find or Replace dialog box
was opened. Any changes made after opening the dialog box are not included the search.

Searches for strings in GUI tests and scripted components
When you search for text strings in GUI tests, you can search in actions, function libraries, *.vbs
files, or *.txt files. The search is performed in the action scripts, for each action defined in the test.

When you search in scripted components, the search is performed in any defined function libraries.

Searches for strings in API tests
When you search for text strings inAPI tests, you can search in actions, *.cs files, or *.txt files. The
search is performed in each source codemodule and in the test flow.
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When you search in a specific C# source code file, the search is performed throughout all user code
in theAPI test, as a single text file.

You can search for the following types of items in API tests:

l Activity or event display names or event handles

l Global environment variable display names and values

l Link expressions

l Loaded XML or schema files

l Test setting definitions

l Visible checkpoint or property display names and values

l X-paths

Regular Expressions Overview
Relevant for: GUI tests and components and API testing

A regular expression is a string that specifies a complex search phrase. By using special
characters, such as a period (.), asterisk (*), caret (^), and brackets ([ ]), you can define the
conditions of a search.

Regular expressions are used to identify objects and text strings with varying values. You can use
regular expressions to instruct UFT to find a value that matches a particular pattern or condition
instead of a specific hard-coded value.

Use case examples:

l Suppose the name of a window's title bar changes according to a file name. You can use a
regular expression in a test object description to identify a window whose title bar has the
specified product name, followed by a hyphen, and then any other text. When the relevant
step runs, UFT compares the regular expression that you provide with the corresponding
value in your application.

l Suppose the text property of an object is a date value, but the displayed date changes
according to the current date. You can define a regular expression for the date, so that UFT
can identify the object that contains text with the expected date format, rather than the
exact date value.

Whenever a UFT feature supports regular expressions, the relevant dialog box includes aRegular
Expression check box. Selecting this check box instructs UFT to treat the provided value as a
regular expression. Some dialog boxes that contain aRegular Expression check box, also contain
a right arrow adjacent to the text box for the value. Clicking this arrow enables you to select regular
expression characters from a drop-down list, and to test your regular expression tomake sure it
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suits your needs. For more details, see "Smart Regular Expression List" on page 361 and "Regular
Expression Evaluator" on page 358.

The following are some examples of situations in which you can use regular expressions in GUI
testing:

l When defining the property values of an object in dialog boxes or in programmatic descriptions
used within a function library

l When defining expected values for checkpoints in tests

l When defining pop-up window conditions in a recovery scenario

You can use regular expressions only for values of type string.

For details on defining regular expressions, including regular expression syntax, see "Regular
Expression Characters and UsageOptions" on page 352.

For GUI testing only: This section also includes:

Regular Expressions for Property Values 319

Regular Expressions in Checkpoints 320

Regular Expressions for Property Values

Relevant for: GUI tests and components

If you expect the value of an object property in your application to change in a predictable way
during each run session, you can use regular expressions when defining identification property
values, for example, in the Object Repository window, or in programmatic descriptions. For details
on programmatic descriptions, see "Programmatic Descriptions" on page 995.

For example, yourWeb site may include a form in which the user inputs data and clicks theSend
button to submit the form. When a required field is not completed, the form is displayed again for the
user to complete. When resubmitting the form, the user clicks theResend button. You can define
the value of the button's name property as a regular expression, so that this variation in the button
name is ignored when identifying the button in your application.

Tip: For tests and scripted components, UFT provides a tool to test your regular expressions
to help youmake sure that they suit your needs. For more details, see "Regular Expression
Evaluator" on page 358. UFT provides a list of commonly used regular expression characters
that you can select when creating a regular expression. For more details, see "Smart Regular
Expression List" on page 361.
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Regular Expressions in Checkpoints

Relevant for: GUI tests and components

When creating a standard checkpoint to verify the property values of an object, you can set the
expected value of an object's property as a regular expression so that an object with a varying value
can be verified.

For example, suppose you want to check that every window and dialog box in your application
contains the name of your application followed by a hyphen (-) and a descriptive title. You can add a
checkpoint for each dialog box object in your test to check that the first part of the title contains the
name of your application followed by a hyphen.

Additional Information for GUI Tests

When creating a text checkpoint to check that a varying text string is displayed on your application,
you can define the text string as a regular expression.

For example, when booking a flight in theMercury Tours sampleWeb site, the total cost charged to
a credit card number should not be less than $300. You define the amount as a regular expression,
so that variations in the text string will be ignored as long as the value is not less than $300.

You can apply the same principles to any checkpoint type whose dialog box contains aConfigure
Value area similar to that described in "Configure Value Area " on page 1575.

For example, for table checkpoints you can set cell values as regular expressions, and for XML
checkpoints you can set attribute or element values as regular expressions. For details on specific
checkpoint types, see the relevant chapter for the checkpoint type.

Tip: For tests and scripted components, UFT provides a tool to test your regular expressions
to help youmake sure that they suit your needs. For more details, see "Regular Expression
Evaluator" on page 358. UFT provides a list of commonly used regular expression characters
that you can select when creating a regular expression. For more details, see "Smart Regular
Expression List" on page 361.
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Tasks
For details about how tomodify business process test and flows, see "How to Create, Maintain,
and Run Business Process Testing Tests and Flows in UFT" on page 2071.

How to Use Bookmarks in the Editor
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This task describes how to use bookmarks in testing documents and includes the following steps:

l "Insert bookmarks into a document" below

l "Navigate between bookmarks and to specific bookmarks" below

l "Clear bookmarks" below

Insert bookmarks into a document

1. Create or open an action, scripted GUI component, function library, or user code file. For
details, see "How to Create andManage Documents" on page 136.

(If you are editing aGUI action or scripted GUI component, open it in the Editor.)

2. Click in the line to which you want to assign a bookmark.

3. Select Search > Bookmarks > Toggle Bookmarks, or press the Bookmarks button in the
Bookmarks pane. A bookmark icon is added to the left of the selected line and is also
displayed in the "Bookmarks Pane" (described on page 203).

Navigate between bookmarks and to specific bookmarks

1. To navigate between bookmarks listed in the "Bookmarks Pane", do one of the following:

n Select Search > Bookmarks > Next Bookmark orSearch > Bookmarks > Previous
Bookmark to navigate forward and backward, respectively.

n In the "Bookmarks Pane", click theNext Bookmark andPrevious Bookmark
buttons.

2. To navigate to a specific bookmark, double-click the bookmark's line in the "Bookmarks Pane".

Clear bookmarks
Do one of the following:

l Click a bookmark icon to the left of the selected line to delete the bookmark.

l In the "Bookmarks Pane", click theDelete

HP Unified Functional Testing (12.00) Page 321 of 2274



button to delete the selected bookmark.

l In the "Bookmarks Pane", select Search > Bookmarks > Clear All Bookmarks or click the

Delete All button in the "Bookmarks Pane" to delete all bookmarks.

How to Use the Go To Dialog Box in the Editor
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This task describes how to go to a specific line of code, API test class, or function, in a GUI action,
scripted GUI component, function library, or user code, or to navigate to any file.

1. Create or open anaction, scripted GUI component, function library, oruser code file. For details,
see "How to Create andManage Documents" on page 136.

(If you are editing aGUI action or scripted GUI component, open it in the Editor.)

2. In the Editor, select Search > Go To > Location. The "Go ToDialog Box" (described on page
347) opens.

Tip: By default, line numbers are displayed in the Editor. If they are not displayed, you can
select theShow line numbers option in the General pane of the Text Editor pane (Tools >
Options > Text Editor tab > General node). For details on the Text Editor options, see
"General Pane (Options Dialog Box > Text Editor Tab)" on page 575.

How to Use Code Snippets and Templates
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This task describes how to insert pre-designed code snippets or blocks of text into your document,
as well as how tomanage templates for such snippets in the "Code Templates Pane (Options
Dialog Box > Coding Tab)" (described on page 573). For details on code snippets and templates,
see "Automatic Code Completion" on page 316.

This task includes the following steps:

l "Insert code snippets into your document in the Editor" below

l "Modify an existing list of code templates" on the next page

l "Remove an existing list of code templates" on page 324

l "Add a new list of code templates" on page 324

Insert code snippets into your document in the Editor

1. Create or open an action, scripted GUI component, function library, or user code file. For
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details, see "How to Create andManage Documents" on page 136.

(If you are editing aGUI action or scripted GUI component, open it in the Editor.)

2. In an API test:Place your cursor at the point in the file that you want to insert the code
snippet, type the keyword for a code template defined in the Code Templates pane of the
Options dialog box, and press TAB.

In a GUI test or scripted component:Place your cursor at the point in the document that you
want to insert the code snippet and then enter text as described in the following table.

If you enter: Followed by: UFT does the following:

The keyword for a
code snippet
listed in theEdit
> Code Snippet
menu
(GUI tests and
scripted
components)

SPACE Inserts the first VBScript snippet defined for the
keyword you entered, as listed in theEdit > Code
Snippet menu.

Note: You can also insert these snippets by
selecting them from theEdit > Code Snippet
menu.

The keyword for a
code template
defined in the
Options dialog
box

TAB Inserts the code snippet defined in the relevant
template in the "Code Templates Pane (Options
Dialog Box > Coding Tab)" (described on page 573).

Note: If multiple templates are defined for the
keyword you entered, the first template in the list
is inserted.

Part of a code
template keyword

CTRL+SPACE Displays a list of the code snippets and templates
whose keywords match the characters you entered.

The list includes the static VBScript snippets listed in
theEdit > Code Snippetmenu, as well as the code
templates defined for the relevant file type in the
"Code Templates Pane (Options Dialog Box > Coding
Tab)"(described on page 573).

In the drop-down list, browse to the keyword for the
template you want to insert, and press Tab to insert
its snippet into your document.

Modify an existing list of code templates

1. Open the "Code Templates Pane (Options Dialog Box > Coding Tab)" (described on page 573).
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2. From the File Types drop-down list, select the item associated with the list of templates you
want to modify. The table lists all code templates defined for the selected file type or types.

3. To edit the file types associated with the selected list, click Edit List. In the Edit List dialog
box, enter the file type or types that should be supported by the selected list, separated by
semi-colons (;).

4. To edit the list of code templates, select the table row for the code template you want to modify
and do one of the following:

n Add a new template in the list:Click the empty space below the last row in the table,
above the syntax area.

n Edit the template name:Double-click the cell in the Template column, and update the
name.

n Edit the keyword:Double-click the cell in the Keyword column, and update the keyword.
The keyword is the text that you enter in the Editor to insert the template.

n Edit the code template description:Double-click the cell in the Description column and
update the description text.

n Edit the code syntax inserted into your code:Click inside the code syntax area below
the table and update the code.

Note: Note that changes made here do not affect the code snippets available from the
Edit > Code Snippetmenu, which are static and cannot bemodified.

Remove an existing list of code templates

1. Open the "Code Templates Pane (Options Dialog Box > Coding Tab)", described on page 573.

2. From the File Types drop-down list, select the item associated with the list of templates you
want to remove. The table lists all code templates defined for the selected file type or types.

3. Click Remove List. All code templates associated with the selected file types are removed,
as well as the File Types item.

Caution: This action is irreversible.

Add a new list of code templates

1. Open the "Code Templates Pane (Options Dialog Box > Coding Tab)", described on page 573.

2. Click Add List.
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3. In the Add List dialog box, enter the file types you want to associate with your new list of
templates, separated by semi-colons (;). A blank list is added to the table.

4. In each of the cells in the rows, enter text to add template names, keywords to be entered in
the code, and descriptions of each template. In the syntax area below the table, enter the code
template to be inserted in your code.

5. To add a new row in the list, click the empty space below the last row in the table, above the
syntax area.

How to Search for References or Classes in Documents
in the Editor (API Testing Only)

Relevant for: User code files

This task describes how to search for references to functions or method definitions, or base or
descending classes, and includes the following steps:

l "Search for references to the currently selected function or method" below

l "Search for classes derived from the currently selected class" below

l "Search for methods that override a virtual method" on the next page

l "Search for the base class of the current class" on the next page

Search for references to the currently selected function or method

1. Create a new user code file, or open an existing one. For details, see "Add an event handler -
optional" on page 1601 or "How to Open aWindow forWriting Custom Code" on page 1948.

2. Select a function or method definition, and then select Search > Find References.

The search results found are displayed in the "Search Results Pane" (described on page 466).

Search for classes derived from the currently selected class

1. Create a new user code file, or open an existing one. For details, see "Add an event handler -
optional" on page 1601 or "How to Open aWindow forWriting Custom Code" on page 1948.

2. Select a class and then select Search > Find Derived Symbols.
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The derived classes are displayed in a small drop-down box under the selected class. For
example:

Search for methods that override a virtual method

1. Create a new user code file, or open an existing one. For details, see "Add an event handler -
optional" on page 1601 or "How to Open aWindow forWriting Custom Code" on page 1948.

2. Select a class and then select Search > Find Derived Symbols.

The overridingmethods are displayed in a small drop-down box under the selected class. For
example:

Search for the base class of the current class

1. Create a new action or user code file, or open an existing one. For details, see "Add an event
handler - optional" on page 1601, "How to Open aWindow forWriting Custom Code" on page
1948, or "How to Use Actions in an API Test" on page 1793.

2. Select a class and then select Search > Find Base Classes.

The base classes are displayed in a small drop-down box under the selected class. For
example:
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How to Find or Replace Strings in Files
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This task describes how to search for strings in files that are open in the document pane or
supported by the search functionality and includes the following steps:

l "Define the search or replace criteria" below

l "Search for strings in files" on the next page

l "Replace strings in files" on page 329

You can find individual occurrences, display all search results, or replace occurrences of the search
string with a different string. If a search generates multiple results, all results are displayed in the
"Search Results Pane" (described on page 466).

Note: You cannot modify the file and item types included in the search, which are defined by
the search algorithm. For details, see "File and Item Types Included in String Searches" on
page 317.

Define the search or replace criteria

1. Create or open an action, scripted GUI component, function library, or user code file. For
details, see "How to Create andManage Documents" on page 136.

(If you are editing aGUI action or scripted GUI component, open it in the Editor.)

2. Do one of the following:

n To only find strings, open the "Find Dialog Box (Document Pane Editor) ", described on page
342.

n To find and replace strings, open the "Replace Dialog Box", described on page 344.

3. In the Find text field, enter a search string using plain text or regular expressions. For details,
see " Regular Expressions in the Find and Replace Dialog Boxes" on page 357.

4. If you entered a regular expressionmanually, select theRegular Expression check box. (If
you selected a regular expression from theExpression Builder drop-down list, theRegular
Expressions check box is automatically selected.)

5. For replacements only: In theReplace with field, enter the replacement string.

6. From the Look in drop-down list, select a location in which to search, or search and replace.
Supported locations include the current solution, test, document, or any specified folder,
except for folders stored in ALM. If you want to search inside a document stored in ALM, you
must open the document first.
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7. Select any of the other search options as needed, includingmatching the text case, matching
the whole word, searching upwards in the file instead of downwards, or including subfolders if
you selected a folder to search.

Search for strings in files
To search for occurrences of the string one by one:

Do one of the following:

l In the "Find Dialog Box (Document Pane Editor) " (described on page 342), click Find Next.

l To search again for themost recently defined search criteria without opening the Find dialog box,
select Search > Find Next or press F3.

The cursor jumps to the next occurrence of the search string and highlights the string. If the search
string is found in a closed file, the file automatically opens in the document pane.

Note: (for GUI tests only) If you switch to the Keyword View, the entire row containing the
matched string is highlighted.

To search for all occurrences of the search string:

In the Find dialog box, click Find All. The search results are displayed in the "Search Results
Pane" (described on page 466).

To perform an incremental search as you type:

1. Do one of the following:

n To search from the cursor location towards the end of the file, select Search > Incremental
Search or press CTRL+E.

n To search from the cursor location towards the top of the file, select Search > Reverse
Incremental Search or press CTRL+SHIFT+E.

The cursor changes to a binoculars icon with an arrow pointing in the search direction.

2. Start typing the string you want to find. UFT highlights the next matching string.

3. Click anywhere in the file to change the cursor back to the regular cursor.

Note:When performing incremental searches, you can find only one search result at a
time. Repeat this step to find the next occurrence of the search string.
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Replace strings in files
To replace occurrences of the string one by one:

1. In the "Replace Dialog Box" (described on page 344), click Find Next until you reach the
search result you want to replace.

2. Click Replace. The selected string is replaced with the defined replacement text. The next
occurrence is automatically highlighted.

To replace all occurrences of the search string:

In the Replace dialog box, click Replace All. A confirmationmessage lists the number of
occurrences replaced.
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Reference

Document Pane User Interface
Relevant for: GUI tests and components and API testing

This pane enables you to view and edit UFT documents. For details on the types of available
documents, see "Document PaneOverview" on page 303.

The image below shows the various document views available in UFT, including (from left to right):

l An API test (canvas)

l A GUI action (Keyword View)

l The event handler code file (TestUserCode.cs) (Editor)

All UFT documents are shown in the document pane. For other examples, see "Application Area
User Interface" on page 2101 and "Business Process Testing in UFT User Interface" on page 2074.

Note: The documents shown in the image below are undocked from the document pane. By
default, these views are displayed as tabs in the document pane.

To access Do one of the following:

l Create or open a document.

l Double-click a node in the Solution Explorer.

A document opens as a tab in the document pane.
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Important
information

l If you select a document in the Solution Explorer, but do not double-click it to
bring it into focus in the document pane, some other panes (such as the
Properties pane), automatically display content relevant for that document.
Therefore, the document displayed in the document panemay not correspond
to the content of other open panes.

l When you bring a document into focus, the corresponding node in the Solution
Explorer is highlighted, and other panes are updated accordingly.

Relevant
tasks

"How to Create andManage Documents" on page 136

See also l "Document PaneOverview" on page 303

l "Document Pane Context MenuOptions" on the next page

l "Editor User Interface" on page 334

User interface elements for the document when documents are displayed as tabs are described
below (unlabeled elements are shown in angle brackets):

UI
Element Description

<tab
name>

The name of the document.

If you hover over the name of the tab, you can view information about the selected
document:

l For actions: the test in which the action is located

l For function libraries and user code files: the path on the file system in which
the document is saved

l For application areas: the ALM path of the application area

Displays a drop-down list of all documents currently open in the document pane.

Closes the active document.

User interface elements for the document when documents are displayed as floating documents
are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<window name> The name of the document.

Closes the active document.
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Document Pane Context Menu Options
Relevant for: GUI tests and components and API testing

This section describes the context menu options available for documents displayed as tabs or
document windows in the documents pane.

To access Right-click the document tab or title bar (for floating documents).

Important
information

This information describes the context menu options for general document pane
tabs and floating documents. For details on the context menu options for a
specific type of document, see the relevant section in this guide.

The context menu options for documents displayed as tabs are described below:

Menu
Command

Keyboard
Shortcut Description

Close CTRL+F4 Closes the current document.

Close All
Documents

CTRL+S
HIFT+
F4

Closes all documents.

Close All
but This

Closes all documents except the current document.

Save CTRL+S Saves the current document.

Note: This command is enabled only if you havemodified a
document.

Save As Opens the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 164) so you can save a copy of the current
document. with another name or in another location.

Note:

This option is enabled only if a document is able to be saved
under a different name. For example, you can perform Save as
for a test but not a test action.

This option is only available if the open document is an editable
file (such as aGUI test action, user code file, or function
library.)
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Menu
Command

Keyboard
Shortcut Description

Copy
file/path
name

Copies the full path of the document in the file system or an ALM
project to the Clipboard.

Note: This option is only available if the open document is an
editable file (such as aGUI test action, user code file, or
function library.)

Open
Containing
Folder in
Explorer

Opens the folder containing the document inWindows Explorer.

Note: This option is only available if the open document is an
editable file (such as aGUI test action, user code file, or
function library.)

The context menu options for documents displayed as floating windows are described below:

UI Element Description

Close Closes the document.

Dock as Tabbed Document Attaches the document as a tab in the document pane.
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Editor User Interface
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This view enables you to edit text and code for GUI actions, scripted GUI components, function
libraries, user code files, and text files.
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To access Create a new action, scripted GUI component, function library, or user code file,
or open an existing one.

(If you are editing aGUI action or scripted GUI component, open it in the Editor.)

Important
information

To open the help topic for a specific object or method from the Editor, do the
following:

1. Verify that you do not have any text highlighted.

2. Place the cursor in themiddle of the word and press F1.

Note: You can also use these steps to find VBScript items referenced in the
Microsoft VBScript help, included in the UFT Help. If you place the cursor in
an item that is not part of the UFT test object model and press F1, the UFT
Help displays the item as found in the index, or if the exact item is not found,
the closest alphabetical item in the index.
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Relevant
tasks

"How to Create andManage Documents" on page 136

API tests only: "How to Create an API Test" on page 1598

"How to Use Bookmarks in the Editor" on page 321

"How to Use theGo ToDialog Box in the Editor" on page 322

"How to Use Code Snippets and Templates" on page 322

"How to Search for References or Classes in Documents in the Editor (API
Testing Only)" on page 325

"How to Find or Replace Strings in Files" on page 327

See also l "Editing Text and Code Documents" on page 305

l API tests only: "Writing Event Handlers for API Test Steps" on page 1935

l GUI tests only: "Programming in GUI Testing Documents in the Editor" on
page 994

l "Text Editor Tab (Options Dialog Box)" on page 574

l "Find Dialog Box (Document Pane Editor) " on page 342

l "Replace Dialog Box" on page 344

l "Go To Dialog Box" on page 347

l "Bookmarks Pane User Interface" on page 206
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<class
and
function
browsers>

Drop-downmenus that enable you to quickly browse to a class and function by
selecting from those available in the current document. These drop-downmenus
aremost helpful in documents that includemany function definitions, such as
function libraries.

To navigate to a class or function definition, first select the class from the left drop-
downmenu, and then select the function from the right drop-downmenu.

For GUI actions only: In a GUI action, the class browser:

l Displays only those functions actually defined in the action, and does not
display all functions defined in the function libraries associated with the test.

l Always displays Main as the root menu item. In a document that includes
function definitions, the functions will be listed as sub-items in themenu. In a
document that includes no function definitions (such as most actions), this
menu will include only theMainmenu item. For example, see "Class and
Function Browser Examples" on the next page.

Note: If the class and function browsers are not displayed, you can select the
Show class/function browser option in the General pane of the Text Editor
pane (Tools > Options > Text Editor tab > General node).

<Icon
margin>

Display icons for lines with specific types of code, such as classes, events, or
fields. For details, see "Editor Icons" on page 339.

<Line
number
margin>

Displays the line numbers for each line of code. You can use the "Go ToDialog
Box" (described on page 347) to navigate to a specific line in the code.

Note: If the line numbers are not displayed, you can select theShow line
numbers option in the General pane of the Text Editor pane (Tools > Options
> Text Editor tab > General node.

<Expand and collapse>. Expands or collapses folded code. Folded code is
indicated by an ellipsis at the end of the first line of the folded code.

Tip: Hover over the ellipses to display a snapshot of the hidden code.

Note: If the expand and collapse buttons are not displayed, you can select the
Enable folding option in the General pane of the Text Editor pane (Tools >
Options > Text Editor tab > General node.
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UI
Element Description

<Zoom control bar>. Displayed in the lower left corner of the Editor, only after
having zoomed in or out of the text for the first time in a session.

l Click the Zoom in icon to zoom in.

l Click the Zoom out to zoom out.

l Click theDefault zoom icon to return the text to the default size.

Class and Function Browser Examples

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

The following image shows an example of an action containing two classes and a function. Each of
the classes contains two functions.

The functions defined in a specific class are displayed in the function browser only when you select
that class in the class browser. If you select one of these functions, the cursor jumps to that
function definition. If you select a different class from the class browser, the cursor jumps to that
class definition.

In this image, theMain.class1 class is selected in the class browser, and the function browser is
expanded, displaying the functions defined in the class1 class (fucnt_1a and fucnt_1b).
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In the class browser, theMain item represents the context of the document. In this image, if you
selectMain from the class browser, the function browser displays only funct_A.

Editor Icons

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

Icons used in the Editor to indicate the different types of code are described below:

Type Icon Description

Class Class

Internal class

Private class

Protected class
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Type Icon Description

Delegate Delegate

Internal delegate

Private delegate

Protected delegate

Enumeration definition Enumeration definition

Internal enumeration definition

Private enumeration definition

Protected enumeration definition

Event Event

Internal event

Private event

Protected event

Extension method Extensionmethod

Internal extensionmethod

Private extensionmethod

Protected extensionmethod

Field Field

Internal field

Private field

Protected field

Indexer Indexer

Internal indexer

Private indexer

Protected indexer
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Type Icon Description

Interface Interface

Internal interface

Private interface

Protected interface

Keyword Keyword

Literal Literal

Local Local

Method Method

Internal method

Privatemethod

Protectedmethod

Namespace Namespace

Operator Operator

Parameter Parameter

Property Property

Internal property

Private property

Protected property

Reference Reference

Structure Structure

Internal structure

Private structure

Protected structure
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Find Dialog Box (Document Pane Editor)
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This dialog box enables you to search for strings in files displayed in the Editor or located in a
specific folder.

You can either find literal text or use regular expressions. You can also use other options to further
fine-tune your search.

To access 1. Create or open the document in which you want to search, or, to search in
multiple files, open any document.

2. Select Search > Find or press CTRL+F.

Important
information

l You cannot use the Find dialog box to search in the Keyword View, the
canvas, or application areas.

l The search is limited to the text in the file at the time that the Find dialog box
was opened. Any changes made after opening the Find dialog box are not
included the search.

Relevant
tasks

"How to Find or Replace Strings in Files" on page 327

See also "Searching and Replacing in the Editor " on page 317
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User interface elements are described below:

UI
Elements Description

Find text The text string you want to locate.

For details on searching with a regular expression, see theExpression Builder
button description.

Recent searches. Click to select a recently used search string.

The list includes the last ten search strings.

Expression Builder. Click to select a predefined regular expression and insert it
into your search string at the cursor location.

When you click this button, theRegular expression check box is automatically
selected.

For details on regular expressions in search strings, see " Regular Expressions in
the Find and Replace Dialog Boxes" on page 357.

Regular
Expression

Treats the specified search string as a regular expression. This option is
automatically selected when you select a regular expression from the Smart
Regular Expression drop-down list.

Look in The files or folder you want to search.

Select one of the following from the drop-down list:

l Current Document. Searches within the document currently open in the
Editor. This is the default option.

l Current Test. Searches within the currently open test.

l Entire Solution. Searches within the entire solution for the file currently open
in the Editor.

l <Files...>. Enables you to browse to a select a specific folder in the file
system.

Note: (for ALM users)You cannot browse to an ALM path.

The drop-down list also displays the last ten folders you selected, with themost
recent folder listed first. Select one to search in the same folder again.

For details, see "File and Item Types Included in String Searches" on page 317.
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UI
Elements Description

Match case Distinguishes between upper-case and lower-case characters in the search, and
searches only for occurrences with exact matches to the casing in the search
string.

Match
whole
word

Searches only for occurrences that are whole words and not part of longer words.

Search up Searches from the cursor location towards the top of the file, and then wraps
around to the current cursor location from the bottom of the file.

By default, the search is performed downwards in the file.

Include
sub-folders

Searches through any sub-folders found in the selected folder.

Note: This option is available only when you select a specific folder from the
Look in drop-down list.

Find Next Searches for the next occurrence of the defined search criteria.

Find All Searches for all occurrences of the defined search criteria.

Search results are listed in the Search Results pane. For details, see "Search
Results Pane User Interface" on page 466.

Replace Dialog Box
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This dialog box enables you to search for strings in files displayed in the Editor or located in a
specific folder, and replace them with a different string.

You can either find and replace literal text or use regular expressions. You can also use other
options to further fine-tune your find and replace process.
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To access 1. Create or open the document in which you want to search, or, to search in
multiple files, open any document.

2. Select Search > Replace or press CTRL+H.

Important
information

l You cannot use theReplace dialog box to search in the Keyword View, the
canvas, or application areas.

l The search is limited to the text in the file at the time that theReplace dialog
box was opened. Any changes made after opening theReplace dialog box are
not included the search.

Relevant
tasks

"How to Find or Replace Strings in Files" on page 327

See also "Searching and Replacing in the Editor " on page 317

User interface elements are described below:

UI
Elements Description

Find text The text string you want to locate. For details on searching with a regular
expression, see theExpression Builder button description.
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UI
Elements Description

Recent searches and replacements. Click to select a recently used string. The
list includes the last ten search strings.

Expression Builder. Click to select a predefined regular expression and insert it
into your search string at the cursor location.

When you click this button, theRegular expression check box is automatically
selected.

For details on regular expressions in search strings, see " Regular Expressions in
the Find and Replace Dialog Boxes" on page 357.

Regular
Expression

Treats the specified text string as a regular expression. This option is
automatically selected when you select a regular expression from the list.

Replace
with

The text string you want to use as the replacement string. The text is replaced
using the same casing as defined in the replacement string.

Look in The files or folder you want to search.

Select one of the following from the drop-down list:

l Current Selection. Searches within the currently highlighted text. Youmust
highlight a specific area in the current file before selecting this option.

l Current Document. Searches within the document currently open in the
Editor. This is the default option.

l Current Test. Searches within the currently open test.

l Entire Solution. Searches within the entire solution for the file currently open
in the Editor.

l <Files...>. Enables you to browse to a select a specific folder in the file
system.

Note: (for ALM users) You cannot browse to an ALM path. If you want to
search in a document stored in ALM, youmust open the document first.

The drop-down list also displays the last ten folders you selected, with themost
recent folder listed first. Select one to search in the same folder again.

For details, see "File and Item Types Included in String Searches" on page 317.

Match case Distinguishes between upper-case and lower-case characters in the search, and
searches only for occurrences with exact matches to the casing in the search
string.
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UI
Elements Description

Match
whole
word

Searches only for occurrences that are whole words and not part of longer words.

Search up Searches from the cursor location towards the top of the file, and then wraps
around to the current cursor location from the bottom of the file.

Include
sub-folders

Searches and replaces through any sub-folders found in the selected folder.

Note: This option is available only when you select a specific folder from the
Look in drop-down list.

Find Next Searches for the next occurrence of the defined search criteria.

Replace Replaces the string defined in the Find text field with the string defined in the
Replace with field.

Replace
All

Replaces all occurrences of the string defined in the Find text field with the string
defined in theReplace with field, throughout the location defined in the Look in
drop-down list. All strings are found and replaced in the same action.

Go To Dialog Box
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This dialog box enables you to navigate to a specific line,API testclass, or function in aGUI action,
scripted GUI component, function library, or user code file, or to navigate to any file.
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To access 1. Create a new solution or open an existing solution.

2. Open the necessary documents. For details on how to open documents
included in a solution, see "How toManage Items in the Solution Explorer
Pane" on page 473.

3. Select Search > Go To.

Important
information

Search Limitations:

l When you navigate to an API test class, or function name, UFT searches all
files within the open solution for occurrences of the search terms.

l When you navigate to line numbers, UFT searches only the currently selected
document.

l You can navigate to any file name contained within the current solution.

Relevant
tasks

"How to Use theGo ToDialog Box in the Editor" on page 322

See also "Bookmarks Overview" on page 204

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

<search
text>

The location to which you want to go. Enter one of the following:

l A line number

l An API test class name

l A function name

l Any file name

<search
results>

The locations that match the text you entered.

As you enter a navigation search string, all locations that match the current string are
displayed. Double-click a specific location to navigate directly to it.

If a document containing the location is closed, UFT opens the relevant document.
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Editor Context Menu Options
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This section describes the context menu options available for the different document types
displayed in the Editor.

To access 1. Create or open anaction, scripted GUI component, function library, oruser
code file.

(If you are editing aGUI action or scripted GUI component, open it in the
Editor.)

2. Right-click in the document.

Important
information

l Some options are also available throughmenu commands or toolbar buttons.

l Some of the context-menu options may be hidden depending on the view of
the document or the content of the document.

Relevant
tasks

For GUI testing: "How to Enhance Your Actions, Scripted Components, and
Function Libraries Using theWindows API" on page 1011

For API testing:"How to Open aWindow forWriting Custom Code" on page
1948

See also For GUI testing:

l "Programming in GUI Testing Documents in the Editor - Overview " on page
995

l "Programmatic Descriptions" on page 995

For API testing: "Writing Event Handlers for API Test Steps" on page 1935

Context menu options are described below:

Note: Themenu commands described below may not be displayed in the exact order
presented here. The options available differ depending where in your document you right-click.

Menu Command
Keyboard
Shortcut Description

Object
Properties

Opens the "Object Properties Dialog Box" (described on page
1271).

Note: This option is only available when right-clicking on
an object description.
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Menu Command
Keyboard
Shortcut Description

Cut Removes the currently selected step or text from your action or
component.

Copy CTRL+C Copies the currently selected step or text.

Paste CTRL+V Pastes the currently copied step or text.

Delete Deletes the selected step or text from your action or
component.

Comment CTRL+M Adds a comment to the selected line.

Uncomment CTRL+
SHIFT+M

Removes a comment from the selected line.

Indent TAB Indents the current line.

Outdent Shift+Tab Removes an indent from the selected line.

Insert Standard
Checkpoint
(GUI testing
only)

F12 Inserts a standard checkpoint step into your document.

Insert Output
Value
(GUI testing
only)

CTRL
+F12

Inserts an output value step into your document.

Insert Step >
Start
Transaction
(GUI testing
only)

Inserts a StartTransaction step into your action, marking the
beginning of the transaction to be timed.

(Relevant only if the test includes transactions to be used by
LoadRunner or Business Availability Center.)

Insert Step >
End Transaction
(GUI testing
only)

Inserts an EndTransaction step in the action, marking the end
of the transaction to be timed.

(Relevant only if the test includes transactions to be used by
LoadRunner or Business Availability Center.)

Insert Step >
Step Generator
(GUI testing
only)

F7 Opens the "Step Generator Dialog Box""Step Generator Dialog
Box" (described on page 983).

Action >
Properties
(GUI tests only)

Displays the Action Properties dialog box.
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Menu Command
Keyboard
Shortcut Description

Action > Insert
Call to New
(GUI tests only)

Opens the "Insert Call to New Action Dialog Box (GUI Testing)
" (described on page 913), which enables you to create a new
action and inserts it in the specified location.

Action > Insert
Call to Copy
(GUI tests only)

Opens the "Select Action Dialog Box " (described on page 915),
which enables you to insert a call to an editable copy of an
existing action.

Action > Insert
Call to Existing
(GUI tests only)

Opens the "Select Action Dialog Box " (described on page 915),
which enables you to insert a call to an existing reusable action.

Action > Split
(GUI tests only)

Separates an action into two sibling actions or into parent-child
nested actions.

Associate
Function Library
with <test
name>
(GUI tests only)

Associates the selected function library with any test in the
current solution.

Go to Definition Ctrl+
Enter

Navigates directly to the definition of the function that is called
in the currently selected step.

Insert/Remove
Breakpoint

F9 Sets or clears a breakpoint in the test or component.

Enable/Disable
Breakpoint

Ctrl+F9 Enables or disables the currently selected breakpoint.

Run from Step
(GUI testing
only)

Starts a run session from the selected step.

Debug from
Step
(GUI testing
only)

Runs the test or component from the selected step instead of
the start of the test or component.

Run to Step
(GUI testing
only)

Runs until the current step.

Add to Watch Ctrl+T Adds the selected item to theWatch pane.

Select All Ctrl+A Selects all steps or text.
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Regular Expression User Interface
Relevant for: GUI tests and components and API testing

By default, UFT treats all characters in a regular expression literally, except for the period (.),
hyphen (-), asterisk (*), caret (^), brackets ([ ]), parentheses (()), dollar sign ($), vertical line (|), plus
sign (+), questionmark (?), and backslash (\). When one of these special characters is preceded by
a backslash (\), UFT treats it as a literal character.

If you enter a special character in the value box of any dialog box that contains theRegular
Expression check box, and then you select theRegular Expression check box, UFT asks you if
you want to add a backslash (\) before each special character. If you click Yes, a backslash (\) is
added before the special character to instruct UFT to treat the character literally. If you click No,
UFT treats the special character as a regular expression character.

For GUI tests only: All programmatic description property values are automatically treated as
regular expressions. For details on programmatic descriptions, see "Programmatic Descriptions"
on page 995.

For details, see:

Regular Expression Characters and UsageOptions 352

Regular Expressions in the Find and Replace Dialog Boxes 357

Regular Expression Evaluator 358

Smart Regular Expression List 361

Regular Expression Characters and Usage Options

Relevant for: GUI tests and components and API testing

This section describes some of themore common options that can be used to create regular
expressions:

Using the Backslash Character ( \ )
A backslash (\) can serve two purposes. It can be used in conjunction with a special character to
indicate that the next character be treated as a literal character. For example, \. would be treated as
period (.) instead of a wildcard. Alternatively, if the backslash (\) is used in conjunction with some
characters that would otherwise be treated as literal characters, such as the letters n, t, w, or d, the
combination indicates a special character. For example, \n stands for the newline character.

If the backslash character is not used for either of these purposes, it is ignored.

For example:

l w matches the characterw

l \w is a special character that matches any word character including underscore
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l \\matches the literal character \

l \(matches the literal character (

l one\twomatches the string onetwo

For example, if you were looking for aWeb site called:

newtours.demoaut.com

the period would bemistaken as an indication of a regular expression. To indicate that the period is
not part of a regular expression, you would enter it as follows:

newtours\.demoaut\.com

Matching Any Single Character ( . )
A period (.) instructs UFT to search for any single character (except for \n). For example:

welcome.

matches welcomes, welcomed, orwelcome followed by a space or any other single character. A
series of periods indicates the same number of unspecified characters.

Tomatch any single character including \n, enter:

(.|\n)

Formore details on the ( ) regular expression characters, see "Grouping Regular Expressions ( ( ) )"
on the next page. For more details on the | regular expression character, see "Matching One of
Several Regular Expressions ( | )" on the next page.

Matching Any Single Character in a List ( [xy] )
Square brackets instruct UFT to search for any single character within a list of characters. For
example, to search for the date 1967, 1968, or 1969, enter:

196[789]

Matching Any Single Character Not in a List ( [^xy] )
When a caret (^) is the first character inside square brackets, it instructs UFT tomatch any
character in the list except for the ones specified in the string. For example:

[^ab]

matches any character except a or b

Note: The caret has this special meaning only when it is displayed first within the brackets.

Matching Any Single Character within a Range ( [x-y] )
Tomatch a single character within a range, you can use square brackets ([ ])with the hyphen (-)
character. For instance, to match any year in the 1960s, enter:

196[0-9]
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A hyphen does not signify a range if it is displayed as the first or last character within brackets, or
after a caret (^).

For example, [-a-z]matches a hyphen or any lowercase letter.

Note:Within brackets, the characters ".", "*", "[" and "\" are literal. For example, [.*]matches .
or *. If the right bracket is the first character in the range, it is also literal.

Matching Zero or More Specific Characters ( * )
An asterisk (*) instructs UFT tomatch zero or more occurrences of the preceding character. For
example:

ca*r

matches car, caaaaaar, and cr

Matching One or More Specific Characters ( + )
A plus sign (+) instructs UFT tomatch one or more occurrences of the preceding character. For
example:

ca+r

matches car and caaaaaar, but not cr

Matching Zero or One Specific Character ( ? )
A questionmark (?) instructs UFT tomatch zero or one occurrences of the preceding character. For
example:

ca?r

matches car and cr, but nothing else

Grouping Regular Expressions ( ( ) )
Parentheses (()) instruct UFT to treat the contained sequence as a unit, just as in mathematics and
programming languages.

Using groups is especially useful for delimiting the arguments to an alternation operator ( | ) or a
repetition operator: ( * , + , ? , { } )

Matching One of Several Regular Expressions ( | )
A vertical line (|) instructs UFT tomatch one of a choice of expressions. For example:

foo|bar

causes UFT tomatch either foo or bar

fo(o|b)ar

causes UFT tomatch either fooar or fobar

Matching the Beginning of a Line ( ^ )
A caret (^) instructs UFT tomatch the expression only at the start of a line, or after a newline
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character.

For example:

book

matches book within the lines—book, my book, and book list, while

^book

matches book only in the lines—book and book list

Matching the End of a Line ( $ )
A dollar sign ($) instructs UFT tomatch the expression only at the end of a line.

For example:

book

matches book within the lines—my book, and book list, while a string that is followed by (\n), (\r), or
($), matches only lines ending in that string. For example:

book$

matches book only in the line—my book

Matching a Newline or Carriage Return Character ( \n ) or ( \r )
\n or \r instruct UFT tomatch the expression only when followed by a newline or carriage return
character.

l \n instructs UFT tomatch any newline characters.

l \r instructs UFT tomatch any carriage return characters.

For example:

book

matches book within the lines—my book, and book list, while a string that is followed by (\n) or (\r)
matches only lines that are followed by a newline or carriage return character. For example:

book\r

matches book only when book is followed by a carriage return

Matching Any AlphaNumeric Character Including the Underscore ( \w )
\w instructs UFT tomatch any alphanumeric character and the underscore (A-Z, a-z, 0-9, _).

For example:

\w* causes UFT tomatch zero or more occurrences of the alphanumeric characters—A-Z, a-z, 0-9,
and the underscore (_). It matches Ab, r9Cj, or 12_uYLgeu_435.
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For example:

\w{3} causes UFT tomatch 3 occurrences of the alphanumeric characters A-Z, a-z, 0-9, and the
underscore (_). It matches Ab4, r9_, or z_M.

Matching Any Non-AlphaNumeric Character ( \W )
\W instructs UFT tomatch any character other than alphanumeric characters and underscores.

For example:

\W

matches &, *, ^,%, $, and #

Matching a Decimal Digit ( \d )
\d instructs UFT tomatch any decimal digit.

For example:

\d

matches 1, 2, 4, and 5

Matching an Integer ( \D )
\D instructs UFT tomatch any whole integer.

For example:

\D

matches 145643, 20, 3426767, 4, and 5

Combining Regular Expression Operators
You can combine regular expression operators in a single expression to achieve the exact search
criteria you need.

For example, you can combine the `.' and `*' characters to find zero or more occurrences of any
character (except \n).

For example,

start.*

matches start, started, starting, starter

You can use a combination of brackets and an asterisk to limit the search to a combination of non-
numeric characters. For example:

[a-zA-Z]*

Tomatch any number between 0 and 1200, you need tomatch numbers with 1 digit, 2 digits, 3
digits, or 4 digits between 1000-1200.

The regular expression below matches any number between 0 and 1200.

([0-9]?[0-9]?[0-9]|1[01][0-9][0-9]|1200)
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Note: For a complete list and explanation of supported regular expressions characters, see the
Regular Expressions section in theMicrosoft VBScript documentation (select Help > HP
Unified Functional Testing Help to open the UFT Help. Then select VBScript Reference >
VBScript > VBScript User's Guide > Introduction to Regular Expressions).

Regular Expressions in the Find and Replace Dialog Boxes

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

You can use regular expressions in the Find text fields to enhance your search in both the "Find
Dialog Box (Document Pane Editor) " (described on page 342) and "Replace Dialog Box" (described
on page 344).

You can insert a regular expression into your search string by selecting one from a predefined list, or
by entering onemanually. For a general understanding of regular expressions in UFT, see "Regular
Expressions Overview" on page 318.

For more details about find and replace functionality, see "Searching and Replacing in the Editor "
on page 317.

Note: Not all the regular expressions listed for other parts of UFT are supported for the search
strings in the Find and Replace dialog boxes.

The following table lists the regular expressions supported for search strings, as well as
descriptions of each regular expression. For details, see "Regular Expression Characters and
UsageOptions" on page 352.

Character Description Reference

. (period) Matches any single character "Matching Any Single Character ( . )
" on page 353

*
(asterisk)

Matches zero or more specific characters "Matching Zero or More Specific
Characters ( * )" on page 354

+ (plus
sign)

Matches one or more specific characters "Matching One orMore Specific
Characters ( + )" on page 354

?
(question
mark)

Matches zero or one specific character "Matching Zero or One Specific
Character ( ? )" on page 354

^ (caret) Matches the beginning of a line "Matching the Beginning of a Line
( ̂  )" on page 354

$ (dollar
sign)

Matches the end of a line "Matching the End of a Line ( $ )" on
page 355
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Character Description Reference

\n Matches a line break "Matching a Newline or Carriage
Return Character ( \n ) or ( \r )" on
page 355

\r Matches a carriage return "Matching a Newline or Carriage
Return Character ( \n ) or ( \r )" on
page 355

[] Matches any single character in a list "Matching Any Single Character in
a List ( [xy] )" on page 353

[^] Matches any single character not in a list "Matching Any Single Character
Not in a List ( [^xy] )" on page 353

\w Matches any alphanumeric character
including the underscore

"Matching Any AlphaNumeric
Character Including the Underscore
( \w )" on page 355

\W Matches any non-alphanumeric character "Matching Any Non-AlphaNumeric
Character ( \W )" on page 356

\d Matches a decimal digit "Matching a Decimal Digit ( \d )" on
page 356

\D Matches an integer "Matching an Integer ( \D )" on page
356

| Matches one of several regular expressions "Matching One of Several Regular
Expressions ( | )" on page 354

\ Matches a special character treated as a
literal character, or a literal character treated
as a special character

"Using the Backslash Character ( \ )
" on page 352

Regular Expression Evaluator

Relevant for: GUI tests, scripted GUI components, and API testing

This dialog box enables you to create and test a regular expression to determine whether it suits
your needs. You can enter a regular expression and sample text to test. When you click Highlight,
UFT searches the sample text for matches, highlights thesematches, and displays the number of
matches.

The following example searches for the word product followed by a space or other character
because the regular expression includes the period (.) character.
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To access 1. Do one of the following:

n Ensure that a test, action, or component is in focus in the document pane.

n In the Solution Explorer, select a test or component node.

2. Use one of the following:

n Select the Tools > Regular Expression Evaluator menu command.

n Click theSmart Regular Expression button to the right of a value
box in any dialog box (except the Find and Replace dialog boxes) in which
theRegular Expression check box is selected. Select theOpen
Regular Expression Evaluator list item.

Important
information

The list of selectable regular expression characters available from this dialog box
is also available from other UFT dialog boxes that contain a selectedRegular

Expression check box and theSmart Regular Expression button .

Note: The Regular Expression Evaluator is not supported for regular
expressions in the Find and Replace dialog boxes.

See also Conceptual overview: "Regular Expression Characters and UsageOptions" on
page 352

Additional related topics: "Smart Regular Expression List" on page 361
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User interface elements are described below:

UI
Elements Description

Smart Regular Expression. Click to display a list of regular expression
characters that you can select. For details on each of the regular expression
characters, see "Smart Regular Expression List" on the next page.

Regular
Expression

The regular expression to test. Enter the regular expression in this box.

Tip: Click the right arrow to display a list of regular expression
characters that you can insert.

Highlight Searches for the regular expression in theSample text area and highlights all
matches.

Note: Before you click Highlight, make sure that the text to search is
displayed in theSample text area.

Sample
text

The text to use when testing the regular expression.

Note: Text may already be displayed in theSample text area when the dialog
box opens, depending on the steps you performed to open this dialog box.

TheSample text area is editable. You can insert any text to test your regular
expression.

Number of
matches

The number of matches for the regular expression within the sample text. These
matches are highlighted in theSample text area.
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Smart Regular Expression List

Relevant for: GUI tests and scripted GUI components

This list:

l Displays a list of commonly used regular expression characters.

l Enables you to select a regular expression character from the list and insert it in a value.

l Enables you to access the "Regular Expression Evaluator" (described on page 358).

Note: If you open the Smart Regular Expression list from the Regular Expression Evaluator,
theOpen Regular Expression Evaluator command is not included in the list.

User Guide
Chapter 10: Document Pane

HP Unified Functional Testing (12.00) Page 361 of 2274



To
access Click theExpression Builder button to the right of a value box in which regular

expressions can be used, such as the Find dialog box.

See
also

Conceptual overview: "Regular Expressions Overview" on page 318 and "Regular
Expression Characters and UsageOptions" on page 352

Additional related topics: "Regular Expression Evaluator" on page 358

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

<Regular
expression
options>

The list of regular expression characters that you can select when creating a
regular expression.

When you select a regular expression character from the list, UFT inserts it in the
currently open dialog box and closes the list. Depending on its type, a regular
expression character can be inserted:

l At the cursor location

l Around selected text

l In place of selected text

Example 1: If you select text and then select the [ ] Any character in the
set option, the brackets are inserted on either side of the selected text, as
follows: [text]

Example 2: If you select text and then select the \d Any digit option, the
selected content is replaced with \d. For example, if you select 1 in
Document1 and then select the \d Any digit option, the selected content is
replaced with \d, as follows: Document1 becomes Document\d

Note: The \n New line option is available only if applicable.

For details on working with regular expression characters, see "Regular
Expression Characters and UsageOptions" on page 352.

Open
Regular
Expression
Evaluator

Opens the "Regular Expression Evaluator" dialog box, enabling you to test your
regular expression tomake sure that it suits your needs. For details, see "Regular
Expression Evaluator" on page 358.

Note: This command is not available from the Smart Regular Expression List
dialog box.
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Troubleshooting and Limitations - Statement
Completion

Relevant for: GUI actions, scripted GUI components, and function libraries

This section describes troubleshooting and limitations for the document pane.

Statement completion is not available for the following types of code:

l Variables. For example:

Set x = CreateObject(“Application.Excel”)
x

l Class methods. For example:

class fooClass
publicfunctionfoo
sin(45)
end function
End Class
Set x = New fooClass
x

l Data tables and checkpoints.
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Chapter 11: Errors Pane
Relevant for: GUI testing and API testing

This chapter includes:

Concepts 365

Errors PaneOverview 365

Missing Resources Types 367

Tasks 369

How toManage Errors in the Errors Pane 369

How to Locate aMissing GUI Action 371

Reference 374

Errors Pane User Interface 374
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Concepts

Errors Pane Overview
Relevant for: GUI tests and components, function libraries, and API testing

The Errors pane displays a list of errors generated when opening, working with, saving, and running
tests, components, function libraries, and user code files. The Errors pane also displays the error
severity levels:Message,Warning, orError. For user interface details, see "Errors Pane User
Interface" on page 374.

The following types of errors can occur:

l "Code syntax errors" below

l "Missing resources (GUI testing only)" below

l "Missing References (API testing only) " on the next page

l "Missing Property Values (API testing only)" on the next page

Code syntax errors
UFT checks for syntax errors whenever you save a test, component, function library, or user code
file. If a syntax error is present in your code, the error description is displayed as anError in the
Errors pane.

For GUI testing:You canmanually check the syntax of an action, scripted GUI component, or
function library at any time by selectingDesign > Check Syntax. If UFT finds any errors, it
displays them in the Errors pane. UFT also checks for syntax errors in your script automatically
when switching from the Editor to the Keyword View and vice versa.

You can view a description of each of the VBScript errors in the VBScript Reference.

For API testing:You can view a description of code syntax to help you resolve code errors that are
displayed in the Errors pane in theMicrosoft C# Reference. For details, see
http://msdn.microsoft.com/en-us/library/ms228296(v=vs.90).aspx.

For details, see "How toManage Errors in the Errors Pane" on page 369.

Missing resources (GUI testing only)
Each time you open a test, component, or application area, UFT verifies that the specified
resources are available.

If one or more resources cannot be found, UFT lists them in the Errors pane together with the
location in which UFT expected to find these resources. If one of the resources listed in this pane is
unavailable during a run session, the runmay fail.

Note: If a test or application area is associated with a resource that is located on a password-
protected network host, the resource is always listed as missing in the Errors pane unless you
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open the resource prior to opening the test or application area.

The Errors pane enables you to locate or removemissing resources from your test or application
area. (You resolvemissing resources for GUI components from the application area, with the
exception of unmapped repository parameters.)

After you successfully handle amissing resource, it is removed from the pane.

For details, see:

l "Missing Resources Types" on the next page

l "How toManage Errors in the Errors Pane" on page 369

l "How to Locate aMissing GUI Action" on page 371

Missing References (API testing only)
In the Solution Explorer, each API test contains numerous reference files used in the run session of
the test. In addition, you can add additional references to a test. For details on theReferences node
in the Solution Explorer, see "References Node" on page 482.

When an API test is run, UFT checks that all necessary reference files are present. If a reference
file needed for the run session is not present, then this missing reference is displayed in the Errors
pane, along with the location where UFT expected to find the reference.

Note: If a reference file is located on a password-protected network host, the reference is
listed as missing in the Errors pane unless you add the resource prior to opening the test.

The Errors pane enables you to find the name of themissing reference file and add it to the test.
After you save and run the test again, the error disappears from the Errors pane.

For details on adding references to a test, see "Add Reference Dialog Box" on page 485.

Missing Property Values (API testing only)
When you add certain API test steps to the canvas, you are also required to provide input values
and property definitions in the "Parameters/Checkpoints Tab (Properties Pane - API Testing)" of the
Properties pane (described on page 417) After you add these steps to the canvas, an error message
is displayed in the Errors pane explaining the necessary property value to enter.

You can double-click on the error description in the Errors pane to navigate to the field necessary to
resolve the error. After entering the requested values, the error is longer listed in the Errors pane.

For details on input properties for API test steps, see "Standard Activities" on page 1611.
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Missing Resources Types
Relevant for: GUI tests and components

UFT reports errors for the following types of missing resources:

l "Missing GUI Actions" below

l "Missing Function Libraries" below

l "Missing SharedObject Repositories" below

l "Missing Recovery Scenarios" on the next page

l "Missing Environment Variable Files" on the next page

l "Unmapped SharedObject Repository Parameter Values" on the next page

Missing GUI Actions
If your test contains a call to one or more actions that cannot be found, UFT lists these actions in
the Errors pane.

If your test contains calls to more than onemissing action, when you locate themissing action in
another test, UFT may identify additional missing actions that are found in the same test. This can
occur, for example, if the source test containing the actions that are being called was moved to
another folder. In such cases, UFT displays amessage box prompting you tomap thesemissing
actions as well.

You can instruct UFT to locate these actions simultaneously, or you can handle each call to a
missing action individually.

Similarly, if you select to remove an action, and your test contains additional missing actions in the
same test, a message box opens, asking whether you want to remove all the actions with the same
path.

Note: If a test is opened in read-only format, you cannot view ormap its missing actions.

For details, see "How to Locate aMissing GUI Action" on page 371.

Missing Function Libraries
If you choose to remove rather than locate amissing function library, keep inmind that removing
this association does not remove calls to those functions from your test or component steps.
Therefore, make sure that you handle any calls to functions in removed function libraries.

Missing Shared Object Repositories
You resolve amissing object repository by associating a new object repository with your test or
application area, using the Associate Repositories dialog box, when working with tests, or the
Object Repositories pane of the Application Area, when working with application areas. The
missing object repository is still associated with your test or application area, and still appears in
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the Errors pane. To remove themissing object repository from the Errors pane and your test or
application area, youmust use the Remove Repository option of the Associate Repositories dialog
box when working with tests, or the Object Repositories pane of the Application Area, when
working with application areas.

For more details, see:

l For tests: "Associate Repositories Dialog Box" on page 1266

l For components: "Object Repositories Pane (Application Area)" on page 2105

Missing Recovery Scenarios
If your test, component, or application area, contains more than onemissing recovery scenario,
then when you locate amissing scenario in a recovery file, UFT may identify additional missing
scenarios in that file. You can instruct UFT to locate thesemissing recovery scenarios
simultaneously, or you can handle eachmissing scenario individually.

Missing Environment Variable Files
If UFT indicates that an external environment variable file is missing, you can navigate to the file
and relink it to your test or component.

Unmapped Shared Object Repository Parameter Values
Every repository parameter used in your test or component must have a specified value. This can
be a either a default value that was specified when the parameter was created, or it can be a value
that you specify in your test or component. (For details on repository parameters, see "Working with
Repository Parameters" on page 1287.)

When you open a test or component that uses an object repository with a repository parameter
without a value, UFT indicates this by displaying aRepository Parameters item in the Errors
pane.

For example, suppose your application contains an edit box whose name property changes
depending on a selectionmade in a previous screen. If you parameterized the value of the name
property in the object repository using a repository parameter, but a default value was not defined
for the repository parameter, you need to define a value for it. When working with tests, you can
map the default value to a Data Table parameter, an environment variable, a random number, or a
test or action parameter, and when working with components, you canmap it to a local or
component parameter. You can also define a constant value for it, and so forth.
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Tasks

How to Manage Errors in the Errors Pane
Relevant for: GUI tests and components, and API testing

This task describes the different operations that can be performed in the Errors Pane and includes
the following steps:

l "Select the errors to display" below

l "Check an action for syntax errors (GUI testing only)" below

l "Locate syntax errors" below

l "Locate amissing resource (GUI testing only)" on the next page

l "Locate amissing reference file (API testing only)" on the next page

l "Locate amissing test step property value (API testing only)" on page 371

Select the errors to display
Use the drop-down list at the left side of the pane to select the errors to display in the pane. You can
choose to display all errors in the current solution, or sort by individual documents.

Check an action for syntax errors (GUI testing only)

1. In the document pane, or solutionmanager select the test or action for which you want to
check code syntax.

2. In the Errors pane, select whether to check the syntax in a specific test or in the whole
solution.

3. Select Design > Check Syntax.

Any syntax errors in the solution or the selected test are displayed in the Errors pane.

Locate syntax errors
In the Errors pane, do one of the following:

l Double-click the error description.

l Right-click the error description and select Locate.

l Select the line containing the syntax error and click the Locate button.

In the document pane, the cursor jumps to the source of the syntax error. For user code files, the
characters containing syntax error are also underlined.

HP Unified Functional Testing (12.00) Page 369 of 2274



Locate a missing resource (GUI testing only)

1. Prerequisites:

n Determine the cause of the problem: In the Errors, pane, look at the details of the item
you want to resolve and analyze the source of the problem. For example, the resource file
may have been renamed, move to a different folder, or deleted accidentally or intentionally.

n Determine whether to resolve the problem or remove the association of this
resource with your testing asset: Decide whether themissing resource is still necessary
for your test or component.

If you no longer need this resource file, remove the association in the Solution Explorer or
right-click the error description and select Remove Missing Resource.

2. In the Errors pane, double click the error description. A dialog box opens, enabling you to locate
the resource file:

n For a missing action: "Select Action Dialog Box " on page 915. For full task details, see
"How to Locate aMissing GUI Action" on the next page.

n For a missing function library: "Open/New <Document>/<Resource> Dialog Box" on
page 156

n For a missing shared object repository: "Associate Repositories Dialog Box" on page
1266

n For a missing recovery scenario: "Add Recovery Scenario Dialog Box" on page 1120

n For a missing environmental variable file: "Open/New <Document>/<Resource>
Dialog Box" on page 156

n For a missing object repository parameter: "Associate Repositories Dialog Box" on
page 1266

n For a missing data table: "Open/New <Document>/<Resource> Dialog Box" on page
156

In the selected dialog box, navigate to themissing resource and associate it with your test.

Note: A missing object repository is still associated with your test or application area, and
still appears in the Errors pane. To remove themissing object repository from the Errors
pane and your test or application area, youmust use the Remove Repository option of the
Associate Repositories dialog box, when working with tests, or the Object Repositories
pane of the Application Area, when working with application areas.

Locate a missing reference file (API testing only)

1. Locate the source of themissing reference files, as described in the step"Locate syntax errors"
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(described above).

The relevant test code file opens and the cursor flashes at the place in which themissing
reference file is called during a test run displaying the reference file's name.

2. In the Solution Explorer, right-click theReferences node located under an API test and select
Add Reference.

3. In the "Add Reference Dialog Box" (described on page 485), navigate to themissing reference
file and associate it with your test.

Locate a missing test step property value (API testing only)

1. Locate the source of themissing reference files, as described in the step"Check an action for
syntax errors (GUI testing only)" (described above).

The field requiring themissing property value is highlighted in the "Parameters/Checkpoints
Tab (Properties Pane - API Testing)" in the Properties pane (described on 417).

2. Enter the required information for the property value.

Note: An alert is also displayed in the step in the canvas. For details, see "Alerts (API
Testing only)" on page 210.

How to Locate a Missing GUI Action
Relevant for: GUI tests only

To locate a missing GUI action:

1. In the Errors pane, double-click the action you want to locate or right-click the action and select
Locate from the context menu.
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The Select Action dialog box opens.

When the Select Action dialog box opens, the Test box displays either the name of the test
containing themissing action (if UFT can identify the source test), or <Current Test>.

Note: If themissing action is a nested action that is called from another test, you cannot
use the Locate button to browse to that action. Instead, youmust resolve themissing
action from within the external test. For example, if ActionAA (in TestA) calls ActionBB
(from TestB), andActionBB calls ActionCC (from TestC), if you open TestA and the call to
ActionCC is missing, then you can only resolve themissing action by opening TestB and
locatingActionCC. (You cannot resolve it from within TestA.)

2. Click theBrowse button to find the test that contains the action you want to locate. The
Action box displays all reusable actions in the test you select.

Note:

n When you select a test, the Test box is renamed to From test. If the test you select
contains reusable actions, these are listed in theAction box.

n You can enter an ALM folder or a relative path in the Test/From test box. If you enter a
relative path, UFT searches for the test in the folders listed in the Folders pane of the
Options dialog box (Tools > Options > GUI Testing tab > Folders pane). For details,
see "Folders Pane (Options Dialog Box > GUI Testing Tab)" on page 544 and "Relative
Paths in UFT for GUI Testing" on page 130.
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If you are working with the Resources and Dependencies model with
Quality Center 10.00 or ALM, specify an absolute ALM path. For details, see "Relative
Paths and ALM" on page 758.

3. In theAction list, select the action you want to call. When you select an action, its type
(Reusable Action) and description, if one exists, are displayed. This helps you identify the
action you want to call. For details on action descriptions, see "General Tab (Action Properties
Dialog Box)" on page 900.

4. Click OK. UFT updates the test with your changes and removes the action from the Errors
pane.

Note: If your test contains additional missing actions that can be located in the same test,
UFT opens amessage box asking you if you want to map these actions as well. Click Yes
to map all relevant actions, or click No to map only the action you specified.
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Reference

Errors Pane User Interface
Relevant for: GUI tests and components, function libraries and API testing

The Errors pane lists the syntax errors found in your test, scripted GUI component, function library,
or user code document, and enables you to locate each syntax error so that you can correct it. It
also provides a list of the resources that are referenced in your test or component but cannot be
found.

The image below shows the Errors pane displayed when opening aGUI test with missing actions,
recovery scenarios, function libraries, and object repositories.

The image below shows an example of the Errors pane when opening an API test with missing
resources andmissing property values.

To access Do one of the following:

l Select View > Errors.

l Click theErrors tab in the bottom pane.
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Important
information

l The Errors pane displays the errors for all tests contained in your solution. You
can also sort to display errors for each individual document contained within
the solution.

l Each time you open aGUI test or component, UFT automatically checks that
all specified resources are accessible. If any resources are not accessible,
UFT lists them in the Errors pane. If the Errors pane is not currently displayed,
UFT automatically opens it when amissing resource is detected.

l Click on a row to jump to the line in the code that generated the error.

l Click any column header, for example Line or Item, to sort by that criteria.

Relevant
tasks

l "How toManage Errors in the Errors Pane" on page 369

l "How to Locate aMissing GUI Action" on page 371

l "How to Run an API Test" on page 643

See also l "Basic VBScript Syntax" on page 1013

l "Alerts (API Testing only)" on page 210

The following sections describe:

l "Main User Interface Elements" below

l "Context Menu Items" on page 377

Main User Interface Elements
Themain user interface elements are described below (unlabeled elements are shown in angle
brackets):

UI Elements Description

<Show errors
from>

Filters themessage list by the source of the error.
Default:Solution

Shows or hides syntax errors, property value errors (API testing only) and
missing resources.

Shows or hides warnings detected during the run.

Shows or hides informational messages detected during the run.
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UI Elements Description

Locate l Syntax errors: Jumps to the line in the Editor that contains the error.

l Missing resources (GUI testing only). Opens the relevant dialog box for
the selectedmissing resource, enabling you to browse to the correct path for
the resource.

l Missing references (API testing only). Opens the relevant testing code
file to highlight the name of themissing resource.

l Missing property value (API testing only). Highlights the input field in the
Input/Checkpoints tab in the Properties pane.

Available also by right-clicking an error line. For details, see "Context Menu
Items" on the next page.

!
<Exclamation
Point>

Message type:

l Error

l Warning

l Informational message

Line The line containing the error.

For GUI tests, lines are numbered from the beginning of each action or function
library. For API tests, the lines are numbered from the beginning of the
TestUserCode.cs file.

Note: Formissing resources, the line number is 1.

Description Description of the error, warning or message and advice on how to fix the
problem.

For example, a syntax error is displayed if you opened a block of code with a {
but did not close it with an }, the description is Expected end of statement.

Note: In certain cases, UFT is unable to identify the exact error and
displays a number of possible error conditions, for example: Expected 'End
Sub', or 'End Function', or 'End Property'. Check the statement at the
specified line to clarify which error is relevant in your case.
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UI Elements Description

Item l Syntax errors. The name of theGUI action, function library, or user code file
containing the problematic statement.

l Missing resources (GUI testing only). The name of themissing resource.

l Missing references (API testing only). The name of the test user code
that contains the call to themissing reference.

l Missing property values (API testing only). The name of the activity
containing themissing property value.

l Missing repository parameter (GUI testing only). The name and path of
the test containing themissing parameter.

Path The full path of the file that generated the error.

Test The name of the relevant test or component containing the error.

Context Menu Items
The user interface elements described below are available when you right-click an error in the Errors
pane.

UI Elements Description

Copy Copies the content of the selected error to the clipboard.

Locate l Syntax errors. Jumps to the location that contains the error.

You can double-click a syntax error to locate the error in the
relevant document, and then correct it.

l Missing resources (GUI testing only). Opens the relevant
dialog box for the selectedmissing resource, enabling you to
browse to the correct path for the resource.

l Missing references (API testing only). Opens the test code file
that contains the call to the reference file and highlights the name
of themissing reference.

l Missing property value (API testing only). Opens the relevant
field in the Input/Checkpoints tab in the Properties pane.

Note: Double-clicking amissing resource item has the same
effect as selecting the Locate option from the right-click menu or
from the toolbar.
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UI Elements Description

Remove
(for missing resources
in GUI tests or
components only)

Removes the association of this resource with your action, test, or
application area.
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Chapter 12: Output Pane
Relevant for: GUI tests and components and API testing

This chapter includes:

Concepts 380

Output PaneOverview 380

Reference 381

Output Pane User Interface 381

Troubleshooting and Limitations - Output Pane 384
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Concepts

Output Pane Overview
Relevant for: GUI tests and components and API testing

TheOutput pane displays the following information:

l Details about assets that cannot be located or loaded during a run session.

l For GUI tests and components: Information sent using thePrintUtility statement during the
run session. For details, see "Message Statements" on page 975.

l For API tests:Output messages generated in the Output log while compiling and running the
test.

For user interface details, see "Output Pane User Interface" on the next page.
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Reference

Output Pane User Interface
Relevant for: GUI tests and components and API testing

TheOutput pane displays the following information:

For GUI tests and components: Information sent using thePrintUtility statement during the run
session. For details, see "Message Statements" on page 975.

For API tests:Output messages generated in the Output log while compiling and running the test.

The image below shows theOutput pane during aGUI test run session.

The image below shows theOutput pane during an API test run session.

To Access Do one of the following:

l Select View > Output.

l During a paused run session, click theOutput Pane toolbar button .

Important
information

For API tests: Click on a row to navigate to the code that generated the output
message.
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Relevant
tasks

For API tests: "How to Run an API Test" on page 643

See also For details on generating output messages during aGUI testing run session,
see "Message Statements" on page 975.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<Show
output
from>

The type of output to display. The following types are available:

l Build(API testing only)Displays all API test build information.

l Debug: Includes debug information, such as all Print command (print log)
outputs and details about API tests called from GUI tests.

Clear All Lines. Clears all of themessages from themessage list.

Toggle Word Wrap. When selected, wraps the text of eachmessage onto the
next line.

Locate Jumps to the location in the source document relevant to the selected output
message.

Note: This option is relevant for API testing only.

<Find box>.The text string you want to find. You can refine your search by
selecting one of the "Options" described below.

Press ENTER to begin the search.

Find Previous / Find Next. Highlights the next or previous string that matches the
text that you entered in the Find box.

Available only after you enter text in the Find box.
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UI
Element Description

Options Enables you to refine your search with the following options:

l Match Case. Distinguishes between upper-case and lower-case characters in
the search.

l Match Whole Word. Searches for occurrences that are only whole words and
not part of longer words.

l Use Regular Expression. Treats the specified text string as a regular
expression.

Note: Extended regular expressions andmulti-line searches are not
supported.

Save Output to a Text File. Opens the "Save <Resource>/Save <Document> As
Dialog Box" (described on page 164), enabling you to save the contents of the
message list as a text file.

<Message
list>

All messages sent during the test run session.

Eachmessage corresponds to one of the following:

For GUI tests and components:A Print statement line in the action or function
library.

For API tests: A message generated in the Output log.

Copy Shortcut (right-click) menu option that copies the selected content to the clipboard.

Locate Shortcut (right-click) menu option that jumps to the relevant line in the source
document for the selected output message.

Note: This option is relevant for API testing only.
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Troubleshooting and Limitations - Output Pane
Relevant for: API testing only

l TheOutput tabmay be unable to display the run results for very large tests, exceeding a
thousand steps.

HP Unified Functional Testing (12.00) Page 384 of 2274



Chapter 13: Properties Pane
Relevant for: GUI testing, API testing, and business process testing

This chapter includes:

Concepts 386

Properties PaneOverview 386

Reference 387

Properties Pane User Interface (GUI Testing) 387

Properties Pane User Interface (API Testing) 402

Properties Pane User Interface (BPT in UFT) 438
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Concepts

Properties Pane Overview
Relevant for: GUI tests and components, API testing, and business process tests and
flows

The properties pane is used for viewing and editing global and specific properties of your tests and
components. This pane reflects the active document that is selected in the solution explorer.

For GUI tests and components: The Properties pane displays the properties of your solution,
test, action, component, associated function library, application area, object repository, or recovery
scenario. It also enables you to edit the parameters of the selected test, action, or component. The
available information in this pane corresponds with the available information in the relevant pane of
the Settings dialog box or the Properties or Additional Settings panes of an application area.

For user interface details, see "Properties Pane User Interface (GUI Testing)" on the next page.

For details on how to work with test and action input parameters, see "Test and Action Input
Parameters" on page 1528.

For API testing:Each step or test activity may contain several customizable properties or
parameters. The Properties pane provides several views that allow you to define or assign values to
the properties and define handler events.

The Properties pane's toolbar also provides action buttons that allow you to data drive properties
and load files.

For details, see "Properties Pane User Interface (API Testing) " on page 402.

For BPT in UFT:When a business process test or flow is selected in the solution explorer, the
Properties pane displays basic information about the test and enables you tomanage test
parameters for the selected test or flow.

When a component or flow is selected in the document pane, the Properties pane enables you to
edit parameters for the selected component or flow including promoting parameters to the next
level, as well as add or modify other properties..

For details about promoting BPT component and flow parameters, see "Promoting Parameters in a
Business Process Test" on page 2123.

For details, see "Properties Pane User Interface (BPT in UFT)" on page 438.
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Reference

Properties Pane User Interface (GUI Testing)
Relevant for: GUI tests and components

For details on the Properties pane options available for API tests, see "Properties Pane User
Interface (API Testing) " on page 402. For details about the Properties pane options available for
business process tests, see "Properties Pane User Interface (BPT in UFT)" on page 438

The Properties pane displays the properties and parameters of the selected solution, test, action,
component, associated function library, application area, associated object repository, or
associated recovery scenario that is selected in the solution explorer. The following tabs are
available:

The image below shows an example of the General Properties tab displaying test properties.
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The image below shows the Parameters tab displaying action parameters.
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This image below shows an example of the Used By tab, which lists the tests and actions
containing calls to the actions currently selected in the solution explorer.
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To Access 1. Do one of the following:

n Ensure that a GUI document is in focus in the document pane.

n In the solution explorer, select a GUI document node or one of its child
nodes.

2. Select View > Properties to open the pane or click theProperties pane

button .

Important
information

l The information displayed in this pane is dependent upon the active document
as selected in the solution explorer.

l The options that you define in this pane aremaintained after you close and
reopen the pane, or after you switch between active documents.

l TheUndo command is not supported for this pane.

l You can access the Test Settings dialog box by clicking on theSettings link in
the upper-right corner of the pane when a test is the active document in the
solution explorer pane.

l Properties are displayed in this pane only for testing documents, not solution
items. For example, if a function library is added to your solution but not
associated with a test or component, its properties are not visible.

See also l "Properties PaneOverview" on page 386

l "Properties Pane (Test/Business Component Settings Dialog Box)" on page
590

This section includes the following tabs:

General Properties Tab (Properties Pane - GUI Testing) 390

General Properties Tab (Properties Pane for Application Areas) 391

Parameters Tab (Properties Pane - GUI Testing) 394

Used By Tab (Properties Pane - GUI Testing) 401

General Properties Tab (Properties Pane - GUI Testing)

Relevant for: GUI tests and components

This tab enables you to view and define general information about your solution, test, action,
component, associated function library, associated object repository, or associated recovery
scenario. These details correspond with the settings for a test, action, component, or application
area in the Properties pane of the Test/Business Component Settings dialog box.
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For user interface details relevant for tests and actions, see "Properties Pane (Test/Business
Component Settings Dialog Box)" on page 590.

Note: The associated add-ins displayed for a test are read-only. Tomodify the associated add-
ins, see the Properties pane in the Test Settings dialog box.

For user interface details for application areas, see "General Properties Tab (Properties Pane for
Application Areas)" below.

Note: The fields displayed in this tab for each type of document selected in the solution
explorer vary.

General Properties Tab (Properties Pane for Application Areas)

Relevant for: GUI components only

This pane enables you to view and define general properties for your application area, including its
description and any add-ins associated with it.

For details about application areas, see "Application Areas" on page 2095.

The image below shows an example of General Properties tab with application area properties.
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User interface elements are described below:

To Access l Do one of the following:

n Ensure that an application area is in focus in the document pane.

n In the solution explorer, select an application area node.

l Select View > Properties to open the pane.
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Important
information

l The information displayed in this pane is dependent upon the active document
as selected in the solution explorer.

l The options that you define in this pane aremaintained after you close and
reopen the pane, or after you switch between active documents.

l TheUndo command is not supported for this pane.

l Properties are displayed in this pane only for testing documents, not solution
items. For example, if a function library is added to your solution but not
associated with a test or component, its properties are not visible.

See also l "Properties PaneOverview" on page 386

User interface elements are described below:

UI Element Description

Name The name of the application area (the file name provided when creating the
application area).

Author The ALM user name of the person who created the application area.

Location The ALM path and file name of the application area.

Description The description specified for your application area.

This field is mandatory, but a non-empty description is created by default for new
application areas.

It is important that you replace this default with a clear description of the
application area. This is because the users who decide which application area to
choose when creating a new component, do so based on theName and
Description of the application area.

You can update the description, as needed. For example, if you created an
application area but have not finished defining it, you can note this in the
Description area. Later, after you finalize the application area, you can update the
Description.
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UI Element Description

Associated
add-ins

The add-ins associated with the application area. The associated add-ins are
those loaded by UFT when components are accessed.

Note:When a business process test runs, the add-ins associated with the
first component in the test are loaded. Therefore, it is important to ensure that
all required UFT add-ins are associated with the application area for the first
component in the business process test.

For details on associating add-ins, see "Add-in Associations in a GUI Test" on
page 583.

For details on UFT add-in environments, see theHP Unified Functional Testing
Add-ins Guide.

Modifying the list of associated add-ins

l If this dialog box contains a child add-in, and you select it, the parent add-in is
selected automatically.

l If you clear the check box for a parent add-in, the check boxes for its children
are also cleared.

l If a specific add-in is not currently loaded, but you want to associate it with
your test or application area, reopen UFT and load the add-in from the Add-in
Manager.

If the Add-in Manager dialog box is not displayed when you open UFT, you can
choose to display it the next time you open UFT. To do so, select Display
Add-in Manager on startup from the Startup Options pane of the Options
dialog box (Tools > Options > General tab > Startup Options node). For
details, see "UFT Global Options" on page 522.

l If youmodify this list, youmay be required to restart UFT for the changes to
take effect.

Parameters Tab (Properties Pane - GUI Testing)

Relevant for: GUI tests and components

This tab enables you to define input parameters that pass values into your test, action, or
component and output parameters that pass values from your test, action, or component to external
sources. This tab is not available for application areas.

Parameter details in this pane correspond with the parameter settings for a test, action, component
as defined in the Parameters pane of the Settings dialog box (File > Settings).
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User interface elements are described below:

UI Element Description

Add Opens the "Add/Edit Input/Output Parameter Dialog Box (Properties Pane - GUI
Testing)" on page 397, enabling you to add a new input or output parameter.

Edit Parameter. Enables you to edit the selected input or output parameter in the
"Add/Edit Input/Output Parameter Dialog Box (Properties Pane - GUI Testing)" on
page 397.

Delete Parameter. Deletes the selected input or output parameter.

Caution: TheUndo command is not supported for the Properties pane.
Therefore, before you delete a parameter, verify that the parameter is not in
use. Deleting a parameter that is in usemay cause the corresponding step to
fail.

Maintain SAP Parameters. Only available when working with SAP Solution
Manager in IntegrationMode.

Allows you to add, delete, and edit Structured Parameters in the SAP Solution
Manager Test Data Container. Clicking the icon opens SAP SolutionManager and
hides the UFT window.
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UI Element Description

<input
parameters
list>

The list of input parameters for the selected test, action, or component. The
following information is available:

l Name. The name of the parameter.

l Type. An icon that represents the type of the parameter.

Possible types include:

n String

n Password

n Number

n Date

n Boolean

n Any

n Structured

l Default Value. The default value of the parameter.

UFT assigns a default value for each type as specified below, if you do not
specify a default value for each parameter, and for parameters of components
stored in a Quality Center 10.00 or earlier project.

n String. Empty string

n Password. Empty string

n Number.0

n Date. The current date

n Boolean. False

n Any. Empty string

n Structured. The default value provided in the SAP SolutionManager Test
Data Container

Note:

l The information is displayed in read-only format. To edit any of these
fields, use the "Add/Edit Input/Output Parameter Dialog Box (Properties
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UI Element Description

Pane - GUI Testing)" (described on page 397).

l An ALM icon next to a parameter's default value indicates that it is an
AUT parameter. For details, see "AUT Environment Parameters" on page
713.

<output
parameters
list>

The list of output parameters for the selected test, action, or component.

l Name. The name of the parameter.

l Type. An icon that represents the type of the parameter (as described in the
"<input parameters list>").

Note: The information is displayed in read-only format. To edit any of these
fields, use the "Add/Edit Input/Output Parameter Dialog Box (Properties
Pane - GUI Testing)" (described on page 397) or double-click the parameter
name.

<parameter
description
area>

The name and description of the selected input or output parameter.

Note: The information is displayed in read-only format. To edit any of these
fields, use the "Add/Edit Input/Output Parameter Dialog Box (Properties
Pane - GUI Testing)" (described on page 397).

Add/Edit Input/Output Parameter Dialog Box (Properties Pane - GUI Testing)

Relevant for: GUI tests and components

This dialog box enables you to define an input or output parameter to use in the selected test,
action, or component.

The image below shows the dialog used to add an input parameter. This example also shows the
options available when adding a test parameter to a test stored on an ALM server with Lab
Management.
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To
Access

1. In the solution explorer, select a GUI test, component, or action.

2. In the Properties Pane, select theParameters tab and then do one of the
following:

n To add a new input parameter:Select Add > Add Input Parameter.

n To add a new output parameter:Select > Add > Add Output Parameter.

n To edit an existing input or output parameter: Select an existing input or

output parameter and click theEdit Parameter button.

Relevant
tasks

"How to Run a Test Using Server-Side Execution" on page 727.

See also l "Properties Pane User Interface (GUI Testing)" on page 387

l "Properties PaneOverview" on page 386

l "Running Tests in Server-Side Execution" on page 713

l "Select AUT Parameter Dialog Box" on page 742

User interface elements are described below:

UI Element Description

Name The parameter name (case-sensitive).
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UI Element Description

Type The parameter type.

(Relevant for tests and for components stored in Quality Center 10.00 or earlier)

The following types are available:

l String

l Boolean

l Date

l Number

l Password

l Any (tests only)

Note: For parameters linked to ALM AUT parameters, the type will always be
String.
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UI Element Description

Default
Value
(available
only for
input
parameters)

For tests: The default value for the parameter, used during the run session if no
other value is provided for the parameter.

Note: If you want to use fractions in your parameter values, the Decimal
symbol character must be a period (.). This is defined in the computer's
Region and Language settings.

For components:An empty string.

UFT assigns a default value as specified below, if you do not specify a default
value for a test parameter, and for parameters of components stored in a Quality
Center 10.00 or earlier project:

l String: Empty string

l Boolean: True

l Date: The current date

l Number: 0

l Password: Empty string

l Any: Empty string (tests only)

When a test or component runs, the actual values used for parameters are
generally those sent by the application (UFT or ALM) calling the test or
component, as described below:

l UFT. Input Parameters tab of the Run dialog box. For details, see "Run Dialog
Box: Input Parameters Tab (For GUI and API tests and components)" on page
655.

l ALM.

n For tests: Test Labmodule. For details, see theHP Application Lifecycle
Management User Guide.

n For components: Iterations dialog box (Test Planmodule). For details, see
theHP Business Process Testing User Guide.

l For business process tests, flows, and components managed in UFT. The
Data Pane. For details, see "Data Pane User Interface (BPT in UFT)" on page
265.

Note: For ALM AUT parameters, you can set this value by selectingCopy
default value (override) in the "Select AUT Parameter Dialog Box"
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UI Element Description

(described on page 742).

ALM AUT
Parameter

The ALM AUT Parameter from the Lab Resources > AUT Environmentmodule
in ALM LabManagement.

Note: Available only if UFT is connected to an ALM server that has the Lab
Management module, and a test stored on that server is selected in the
solution explorer.

Select ALM application parameters. Opens the Select AUT Parameter dialog
box for selecting a parameter from an AUT environment defined in the Lab
Resources > AUT Environmentmodule. For details, see "Select AUT
Parameter Dialog Box" on page 742.

Note: Available only if UFT is connected to an ALM server that has the Lab
Management module, and a test stored on that server is selected in the
solution explorer.

Remove link to ALM application parameters. Removes the linking of the
selected parameter from ALM. This parameter will now be an ordinary test
property.

Note: Available only if UFT is connected to an ALM server that has the Lab
Management module, and a test stored on that server is selected in the
solution explorer.

Description A meaningful description for the parameter, for example, the purpose of the
parameter.

Used By Tab (Properties Pane - GUI Testing)

Relevant for: GUI actions only

This tab displays information on the tests calling the current actions. This tab is visible only when
an action is selected in the solution explorer. This tab only displays information for actions that are
stored in a test in an ALM project.

Note: In order for the information to be displayed in this tab, the test pathmust be included in
the Folders pane in the Options dialog box (Tools > Options > GUI Testing tab > Folders
pane). For details, see "Folders Pane (Options Dialog Box > GUI Testing Tab)" on page 544.

User interface details correspond with theUsed By tab in the "Action Properties Dialog Box"
(described on page 900).
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Note:When you are working with ALM and UFT in different locales, a test namewritten in an
different language than the language of the ALM server is not displayed correctly in this tab.

Properties Pane User Interface (API Testing)
For details about the GUI testing Properties Pane, see "Properties Pane User Interface (GUI
Testing)" on page 387. For details about the Properties pane options available for business process
tests, see API tests, see "Properties Pane User Interface (BPT in UFT)" on page 438

Relevant for: API testing only

The Properties pane displays a series of tabs showing the properties, schemas, and events for the
step selected in the canvas.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. Select View > Properties or click on the Properties pane tab.

Important
information

l Only active when the canvas is visible.

l The toolbar displays different buttons based on the type of activity or
view.

l The top row of buttons areView buttons, such as General orEvents
views.

l The bottom row of buttons are buttons that perform actions, such as
Data-Drive and Load XML.

Relevant tasks l "How to Create an API Test" on page 1598

l "How to Set Security for aWeb Service on the Port Level" on page 1885

This section includes:

Properties Pane Tabs 403

Action Buttons 435

Value Column Icons 437

Array Control Buttons 438
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Properties Pane Tabs

Relevant for: API testing only

The following section describes each of the Properties pane tabs.

Asynchronous Tab (Properties Pane - API Testing)

This tab enables you to indicate whether the response for aWeb Service is asynchronous.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theAsynchronous tab .

Relevant tasks "How to Create an API Test for an Asynchronous Web Service" on page 1931

See also "Asynchronous Services" on page 1928

TheAsynchronous tab's user interface elements are described below.

UI Element Description

This is an
asynchronous call

Indicates whether the call is asynchronous and enables you to specify a
listener.

Listen for response
on

The port upon which to listen for a response. This property is visible only
if you enable the above option.

Attachments Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to view input and output attachments associated with the current test step.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theAttachments tab .

Relevant tasks "Add input attachments to the test - optional" on page 1600
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TheAttachments tab's user interface elements are described below (unlabeled elements are
shown in angle brackets).

UI Elements Description

<Input
Attachment>

Input attachments for the current Web Service step:

l Type. Attachment type: NONE, DIME, orMIME.

l Attachments. A list of the input attachments and their properties:

n Origin. The name of the file to send as an attachment. Click theBrowse
button to navigate to the directory in which the attachment is saved.

Note: You can use the output from a different test step as an
attachment. Click the Link to data source button and choose the
test property in the "Select Link Source Dialog Box (API Testing)"
(described on page 1840).

n Content Type. The type of file and format. Possible file types include:

o application/zip

o image/gif

o image/ief

o image/jpeg

o image/png

o image/tiff

o text/plain

o text/richtext

o text/html

o text/xml

n Content ID. A unique ID for the attachment orAuto for an ID generated by
UFT.

Note: To add input attachments, click the button in the parent node.
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UI Elements Description

<Output
Attachment>

The server response saved as an attachment.

l Attachments. A list of the output attachments and their properties to validate:

n Content. The file content's checksum value. The checksum is computed
by applying theMD5 hash function to the file.

n Content Type. The attachment's content type.

n Content ID. The unique ID of the attachment.

Note: To add output attachments, click theAttachments row in the
Checkpoints pane, and click to add an array element. (Youmay need to
expand the columnwidth to access the button).

Tip: To validate an output attachment, select the check box adjacent to the
elements you want to validate. Received attachments are saved in the
test's folder, with bin extensions.

Data Sources Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to set the data navigation instructions for the data sources associated with
your test flow.

To access 1. Open the Properties pane.

2. Select the Test Flow in the canvas.

3. In the Properties Pane, select theData Sources tab .

Important
information

You can havemore data sources associated with a test in the Data Pane than
are associated with a particular test flow.

Relevant
tasks

"How to Set the Data Source Navigation Properties" on page 1825

See also l "NavigatingWithin a Data Source" on page 1813

l "Data Navigation Dialog Box" on page 1846
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TheData Sources tab's user interface elements are described below.

UI
Element Description

Data
Navigation
Policies

A list of the data sources sorted by:

l Data Source Name. The name of the data source as it appears in the Data
Pane.

l Policy. A summary of the data navigation policy, for example: Start at first
row, forward one row, wrap around.

Add Opens the "Attach Data Source to Loop Dialog Box " (described on page 1839) for
selecting data sources from the Data Pane.

Note: In order to add a define navigation properties for a Data Source, you
must associate it with your test in the Data pane. For details, see "How to Add
Data Sources to an API Test" on page 233.

Edit Opens the "Data Navigation Dialog Box" (described on page 1846) for setting the
data policy—the way to use the data from the table.

Remove Deletes the selected data source from the list—not from the Data Pane.

Data Source Properties Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to define the usage properties for your test's data sources.

To access 1. Open the Properties pane.

2. In the Data Pane, select a data source. This tab appears by default and all
other properties pane tabs are hidden..

Relevant
tasks

"Create a new child relation" on page 1826

TheData Source Properties tab's user interface elements are described below.

UI Element Description

Name The name of the data source node.
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UI Element Description

Child
Relations

A list of the data sources sorted by:

l Child Data Source. The sheet or table to use as a data source.

l Primary Key. A column in the parent data source to use as a primary key
for the child relation.

l Foreign Key. The column in the child data source to use as a foreign key for
the child relation.

To add, edit, or remove a child relation, use the corresponding buttons. For
details, see the see "Define New/Edit Data Relation Dialog Box" on page 1849.

Allow other
tools to
override the
data

Allows other tools or tests to override Excel data. Enabling this option allows
you to overwrite the data table values with ALM Test Resources. For details,
see "Data Awareness in ALM" on page 715.

This option also allows action data to be edited when called by another test. For
details, see "Data Pane User Interface (API Testing)" on page 252.

Note: This only applies to Excel data sources.

Caution: For Excel data sources with multiple sheets, youmust enable
this option for each data sheet if you did not enable it when importing the
Excel file.

Data source
policy

The policy by which to handle the data (only relevant for steps that call actions
from an external test, to which data was assigned).

l Use data stored with original action (read-only). Use the data that is
associated with the action, as is.

l Use a local, editable copy. Create of local copy of the action's data, to
allow you to edit the values in the Data Pane.

Note: This only applies to Excel data sources.
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Database Data Source Properties Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to view the properties for your database data sources.

To access 1. Open the Properties pane.

2. Select a Database data source in the Data pane.

Relevant tasks "Add a database data source" on page 235

See also "Add New Database Data SourceWizard" on page 258

TheDatabase Data Source Properties tab's user interface elements are described below.

UI Element Description

Name The name of the data source (read-only).

Connection type The type of connection: OleDB orODBC.

Connection
string area

TheConnection string section contains the following elements:

l Connection string. A drop down list of connection strings that were
defined.

l Build Connection String .

n ForOleDB types, it opens Microsoft's Data Links Properties dialog
box.

n ForODBC types, it opens the "Select Data Source NameDialog
Box", described on page 262.

l Edit . Opens a text editor for editing the connection string.

l <Connection string text>. A read-only window showing the selected
connection string.

l <Connection status>. A string indicating whether there is an open
connection to the database.
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UI Element Description

SQL statement
pane

TheSQL statement section contains the following elements:

l SQL statement. A drop down list of SQL statements strings that were
defined in this test.

l Build Query Statement. Opens theQuery Designer. For details,
see the "Query Designer Dialog Box" on page 1724.

l Edit . Opens a text editor for editing the SQL statement.

l <SQL statement text>. A read-only window showing the selected SQL
statement.

l <Query status>. A string indicating whether or not the query was
executed successfully.

Dependencies Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab shows a list of all external resources (Web Services, REST services, and .NET
assemblies) used in your test flow.

To access 1. Open the Properties pane.

2. Select theStart orEnd steps in the canvas.

3. In the Properties Pane, select theDependencies tab .

TheDependencies tab's user interface elements are described below.

UI Element Description

Resource Name The name of the resource as imported into the test

Type The type of resource, for example, WSDL.

Location The location in the test in which the resource is used.

Events Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to enter custom code to run special custom code in conjunction with the steps
of your test.
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To access 1. Open the Properties pane.

2. Select a test step in the canvas.

3. In the Properties Pane, select theEvents tab .

Relevant tasks "How to Open aWindow forWriting Custom Code" on page 1948

See also "Writing Code for API Test Events - Overview" on page 1938

User interface elements are described below (unlabeled elements are shown in angle brackets).

UI Element Description

<Events list> - default A list of events for the activity:

l CodeCheckPointEvent. Triggered when the activity is executed.

l AfterExecuteStepEvent. Triggered after the activity was
executed.

l BeforeExecuteStepEvent. Triggered before the activity is
executed.

l ExecuteEvent. Triggered when the activity in the step is run.

Tip: For details about an event, select it and select Create a
default handler. Refer to comments in the template.

<Events list> -
Conditional. Loop
steps

Condition. Defines the conditions under which the code should be
run.

<Events list> -
HTTP Receiver

l OnFilter. The code to execute when themessages are filtered.

l ReceiveRequest. The code to execute when a request is
received.

l SendResponse. The code to execute when a response is sent.
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UI Element Description

<Events list> -
IBM Websphere MQ

l BeforeCreateQueueManager. Code to execute before creating a
QueueManager.

l BeforeMQGet. Code to execute before getting themessages
from theMQ queue through browsing.

l AfterMQGet. Code to execute after getting themessages from
theMQ queue through browsing.

l BeforeMQPutMessage. Code to execute before putting a
message from theMQ queue.

l AfterMQPutMessage. Code to execute after putting amessage
from theMQ queue.

l BeforeMQGetMessage. Code to execute before getting a
message from theMQ queue.

l AfterMQGetMessage. Code to execute after getting amessage
from theMQ queue.

l BeforeMQPublishMessage. Code to execute before publishing a
message to anMQ topic.

l AfterMQPublishMessage. Code to execute after publishing a
message to anMQ topic.

l BeforeMQReceiveMessage. Code to execute before receiving a
message published on anMQ topic.

l AfterMQReceiveMessage. Code to execute after receiving a
message published on anMQ topic.

For task details, see "How to RetrieveMessages from anMQ
Queue" on page 1635.

<Events list> -
Wait

l TimeoutReached. The code to execute when the timeout (Input
properties) is reached.

Excel File Properties Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to change the Excel file associated with your Excel data sources.

To access In the Data pane, select the parent node for an Excel data source. The other
Properties pane tabs are hidden.

Relevant
tasks

Add list of cross references using bullets for multiple entries. Do not use periods.
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The user interface elements are described below.

UI
Element Description

Name The name of the data source as it appears in the Data pane (read-only).

File Path The current path to the Excel file (read-only).

Change
Excel
File

Opens the "New/Change Excel Data Source Dialog Box" (described on page 255)
which enables you to select a new file for the selected data sources.

Filter Settings Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to set a filter for receivedmessages. This tab is available forHTTP Receive
steps and operations fromWeb Service calls imported as server response steps.

To access 1. Open the Properties pane.

2. Select an HTTP Receive orWeb Service step in the canvas.

3. In the Properties Pane, select the Filter tab .

Relevant tasks "How to Create an API Test for an Asynchronous Web Service" on page 1931

See also "Asynchronous Services" on page 1928

The Filter Settings tab's user interface elements are described below.

UI
Element Description

Clears the text in the filter area.

Opens the "Select Link Source Dialog Box (API Testing)" (described on page 1840),
to allow you to link to existing data.

<filter
text>

A text area containing the filtering expression. You can enter free text or a regular
expression and use the Select Link Source dialog box to create a data expression.

Note:When filtering request headers, you can only filter requests that contain
both a key and value. Headers that have a key, but no value, cannot be filtered.
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UI
Element Description

Filter
Type

The type of filtering: Exact match, Starts with, Ends with, Contains, andRegular
expression.

Note: If you specify Exact Match and you are trying tomatch a key-value pair,
youmust specify both the key and value strings.

General Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab displays general information about the selected test step.

To access 1. Open the Properties pane.

2. Select any step in the canvas.

3. In the Properties Pane, select theGeneral tab .

TheGeneral tab's user interface elements are described below. The properties differ based on the
activity type.

For details about activity-specific general properties, see the specify activity in "Standard
Activities" on page 1611.

UI Element Description

Comment An editable note describing the purpose of the step. UFT also
places the comment in the test report.

Properties - default l Step ID. A unique ID for the step.

l Name. Step name as it should appear in the canvas.

Properties - HP
Automated Testing
Tools

l Test path. The path of the API or GUI test or VuGen script
(LoadRunner's Virtual User Generator) to run.

l Action name. The name of the action in the test (not relevant
for Virtual User Generator scripts).

l Description. A description of the step.

l Result directory. The path of the results relative to the solution
directory (ForCall API Action or Test only).
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HTTP Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to define request and response data for your test steps that perform an
HTTP Request to aWeb Service or REST service.

To access 1. Open the Properties pane.

2. Select an HTTP Request or REST service step in the canvas.

3. In the Properties Pane, select theHTTP tab .

Relevant tasks "How to a Create a REST Service" on page 1746

See also "Network Activities" on page 1684

User interface elements are described below (unlabeled elements are shown in angle brackets).

UI Element

Pane

Body type Description

Request/Response:

l XML

l Text

l File

l JSON

l Post Form
(Request only)

Remove. Deletes the contents of the:

l Body text

l Entered path

l Selected value in grid

Request/Response:

l File

Browse. Enables you to load a non-XML file containing
the request/response body.

Request/Response:

l XML

l Text (Request
only)

l File

l JSON

Link Body. Opens the "Select Link Source Dialog Box
(API Testing)" (described on page 1840) for selecting a
data source.
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UI Element

Pane

Body type Description

<checkpoint
list>

Response pane A list of the checkpoints with the following information:

l Name. The name of the checkpoint as it will appear in
the results.

l Regular Expression. A regular expression
representing the expected value.

l Validate. Compares the actual value with the expected
value.

<message
body>

Request/Response
panes

l XML

l Text

l JSON

The body of the request or response loaded through a file,
pasted from a clipboard (Edit > Paste), or manually
entered (Post form).

<post form
list>

Request pane:

l Post Form

A list of the Post form elements:

l Name. The name of the element.

l Value. The element's value.

Clear Request/Response:

l XML

Clears the contents of theRequest/Response Body
areas.

Import
Schema

Request/Response:

l XML

Imports an .xsd file containing the schema of the request
or response.

Load File Request pane:

l Text

Loads a non-.xml file containing the request.

Load JSON Request/Response:

l JSON

Loads a .json file containing the request or response.

Load XML Request/Response:

l XML

Loads an .xml file with the request or response body.

Request
Body

Request pane The format of the request body: XML, Text, File, JSON, or
PostForm.

User Guide
Chapter 13: Properties Pane

HP Unified Functional Testing (12.00) Page 415 of 2274



UI Element

Pane

Body type Description

Response
Body

Response pane The format of the response body: XML, Text, File, or
JSON.

HTTP Receiver Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to define response data for steps that receive a response from aHTTP or
SOAP-basedWeb Service.

To access 1. Open the Properties pane.

2. Select an HTTP Receiver step in the canvas.

3. In the Properties Pane, select theHTTP Receiver tab
.

See also "Network Activities" on page 1684

User interface elements are described below (unlabeled elements are shown in angle brackets).

UI Elements
Response Body
type Description

Received Message
Body

XML, Text, JSON The way in which to represent the response: XML,
Text, or JSON.

Name Text The text element in the receivedmessage.

<regular
expression>

Text A grid with regular expression containing the
response body values to validate.

Validate Text Instructs UFT to validate the selected text from
the receivedmessage.

Clear XML, JSON Clears the contents of the body.

Import Schema XML Imports an .xsd file containing the schema of the
response.

Load XML XML Loads an .xml file with the response values.

Load JSON JSON Loads a .json file with the response values.

<body of received
message>

XML, JSON The body of the response loaded through a file.

Text Clear. Clears the contents of the selected cells in
regular expression grid.
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Parameters/Checkpoints Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to define input and output properties and parameters and checkpoint
properties for your test steps.

To access 1. Open the Properties pane.

2. Select one of the following in the canvas.

n TheStart orEnd steps

n The Test Flow

n A test step

3. In the Properties Pane, select the tab. This tab's name and content
depend on the test step you selected.

Important
information

The name of this tab depends on the test step you select:

l If you selected aStart orEnd steps, this tab is Test Input/Output
Parameters.

l If you selected the test flow, this tab is Input.

l If you selected any other step, this tab is Input/Checkpoints.
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Test Input/Output Parameters Tab
When theStart orEnd step of your test is selected, this tab is displayed. You can use the tab to
create and define values for input and output properties/parameters to which any test step in your
test can link.
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The tab's user interface elements are described below (unlabeled elements are shown in angle
brackets).

UI
Elements Description

<Properties
list>

A list of all available properties.

Add Opens the "Add Input/Output Property/Parameter Dialog Box (API Testing)"
(described on page 1775) which enables you to define custom input and output
properties or parameters for your test.

Edit Parameter.When a property/parameter is selected, opens the "Add
Input/Output Property/Parameter Dialog Box (API Testing)" (described on page
1775), enabling you to edit any custom input or output properties/parameters

Delete. Deletes the selected property/parameter.

Input Tab
When the Test Flow is selected, this tab is displayed. You can use the tab to specify properties for
iteration test runs.

The following options are available:

UI
Element Description

Do While
Loop -
Use
condition

Repeats the loop as long as the specified condition is met:

l Variable. The variable to evaluate. Use the Select Link Source button to
enter a data source expression.

l Operator. A comparison operator relevant to the variable such as =, !=,
Contains, Starts andRegex.

l Value. The value with which to compare the result.

Do While
Loop -
Use event

Performs iterations until the event returns True. This mode is useful for complex
conditions that can be defined in an event handler. When you select this option, the
Input Properties grid opens.

l Click to define properties.

l Click to open theEvents view. Click Create a default handler in the
Handler column.

l Modify or add code to the event handler method that defines your condition.
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UI
Element Description

For Each
Loop

Performs an iteration for each element in the associated array or collection of
objects. Data is selected using theSelect Link Source button .

Note:When you delete data from a data table, it continues to run an iteration
for that row, with empty values. To remove an entire row of a data, click the
row and select Delete from the shortcut menu (only with Excel installations).

For Loop Performs the Test Flow or custom loop the number of times that you specify in the
Number of Iterations box.

Input/Checkpoints Tab
When a test step is selected, this tab is displayed. You can use the tab to specify input and
checkpoint properties for the selected test step.
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For details on the different toolbar buttons that are displayed when a test activity is selected, see
"Action Buttons" on page 435
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The tab's user interface elements are described below (unlabeled elements are shown in angle
brackets).

UI Elements Description

<properties
list>

A list of all available properties. The fields differ per step type:

l Formost activities: The activity's Input properties. For details on the
available input properties, see the individual activity descriptions in
"Standard Activity Types" on page 1650.

l ForWeb Service, REST Service, andWADLmethods:

n the properties as designed in theWSDL orWADL file (forWeb Service or
Web Applicationmethods),

n The custom input or output properties defined for your REST method in
the REST Service editor. For details on creating input or output properties
for REST Servicemethods, see "Define custom properties - optional" on
page 1748.

<checkpoint
list>

A list of the step's output properties/parameters, displaying the following
columns:

l Checkpoints. A list of the output properties/parameters.

l Validate.When selected, UFT validates the current output
properties/parameters when running the step. When cleared, UFT does not
check the output properties/parameters.

l Expected Value. The expected value for the output parameter. Select the
down arrow to view a drop down list of comparison operators, number
scrolling, and boolean values. You can alsomanually enter the expected
value into the cell.

Additional checkpoint properties include:

l Trim whitespace (from start and end of string). Removes whitespace
before and after the text.

l Ignore case.When looking for amatch, ignores the case.

l Stop test if checkpoint fails. Exits the test run if the checkpoint fails. You
set this individually for each checkpoint.

Note: Youmust click on a row in the Checkpoint section to see these
properties. The first two properties are available only for string data types.
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UI Elements Description

<checkpoints
list>
(available
for- Web
Service and
SOAP
Request
steps)

Checkpoints options forWeb Service and SOAP request steps include:

l Send request to service. Sends the step's request to the service when
running the test. This is the normal behavior forWeb Services andmost
types of actions. It is enabled by default.

Note: To sendmessages using JMS transport, clear this check box.
Link a subsequent JMS step to the output of this step. ForWeb
services, you can set the security settings and include attachments,
and send this over JMS.

l Validate Structure. Adds a checkpoint that verifies that the service is in
conformance with the schema defined for the SOAP XML response—either
for the response defined in the operation or a SOAP Fault response. The Run
Results Viewer indicates whether or not the validation succeeded.

This option is available only when theSend request to server option is
enabled. It is enabled by default.

Note: If youmodify the elements in the response, this will not affect the
response schema. For example, adding array elements, selecting
specific Choice elements, changing the derived type, and so forth,
affect only the response—not the schema. To validate the element
values, specify expected values in theValue column or use an XPath
expression.

l Validate WS-I. Adds a checkpoint to verify that the SOAP response in
compliance withWS-I standards. The RunResults Viewer indicates whether
the response was in compliance. It also provides aView Report link that
opens theWS-I Validation report in a separate window.
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UI Elements Description

<XPath
checkpoint
options>
(available for
steps with
XML output
properties)

For steps with XML output properties (such as String to XML), the following
additional options are relevant:

l XML tab. A grid representation of the response's schema. In this section you
can enter the expected response values. Use the following options to enter
your XML:

n Import Schema. Imports a schema for the XML response.

n Load XML. Loads an XML file as a basis for the schema of the response.

n Clear. Removes the displayed schema.

l XPath tab. A list of XPath expressions used to evaluate the XML response.
Use the following options to use XPath expressions:

n Adds a line for a new XPath expression.

n Removes the selected XPath expression.

n Ignore namespaces: Ignores namespaces in the XPath validation,
allowing you to use simple XPath expressions. For details, see "How to
Set XPath Checkpoints for Test Steps" on page 1617.
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Context Menu Options
The following context menu options are available in this tab:

UI Elements Description

<context
menu>-
input
properties

Provides shortcuts for including properties and setting their values.

l Collapse/Expand All. Displays or hides the list of array elements.

l Set Auto-value. Inserts a sample value for the argument, based on its data
type.

l Include/Include All. Includes the current or all Choice input properties in the
test run.

l Exclude/Exclude All. Excludes the current or all Choice input properties
from the test run.

l Copy XPath. Copies a simplified XPath expression to the clipboard. For
details, see "XPath Checkpoints" on page 1613.

l Copy Fully Qualified XPath. Copies the complete XPath expression of the
value to the clipboard.

l Link to Data Source. Opens the "Select Link Source Dialog Box (API
Testing)" on page 1840

l Clear Cell Contents. Clears the contents of the cell.

Note: Some options are available only for specific property types.
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UI Elements Description

<context
menu> -
checkpoints
list

Provides shortcuts for including properties and setting their values.

l Remove Array Element. Removes the selected array element.

l Duplicate Array Element. Duplicates the selected array element with its
values.

l Select All. Selects/clears the Validate check box for all child array elements.

l Expand/Expand All. Expands all elements included in an array.

l Collapse/Collapse All. Controls the display of array elements.

l Clear/Clear All. Clears the selected or all check boxes for validation.

l Set Auto-value. Inserts a sample value for the argument, based on its data
type.

l Copy XPath. Copies a simplified XPath expression to the clipboard. For
details, see "XPath Checkpoints" on page 1613.

l Copy Fully Qualified XPath. Copies the complete XPath expression of the
value to the clipboard.

l Link to Data Source. Opens the "Select Link Source Dialog Box (API
Testing)" (described on page 1840).

l Display Outgoing Links. Lists the property's outgoing links. For details,
see "Outgoing Links" on page 1808.

l Insert Keyword. Insert a keyword in theExpected Value column. The
available keywords are #NIL#, #EXISTS#, #NOT_FOUND#, and #SKIP#.
For details, see "Data Keywords" on page 1817.

Multipart Tab (Properties Pane - API Testing)

Relevant for: API testing only

For HTTP steps, this tab enables you to configuremultipart requests. Multipart messages are sent
with the HTTP request and consist of two or more header/body sets.

To access 1. Open the Properties pane.

2. Select an HTTP Request in the canvas.

3. In the Properties Pane, select theMultipart tab .

Relevant tasks "How to Send aMultipart HTTP Request" on page 1626

User Guide
Chapter 13: Properties Pane

HP Unified Functional Testing (12.00) Page 426 of 2274



User interface elements are described below:

UI Elements Description

Enable Multipart Enables the Input/Checkpoints tab for multipart HTTP requests.

For details about the input and output properties, see "Network Activities" on page 1684.

Result Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you check the output of String to XML andString to JSON activity steps.

To access 1. Open the Properties pane.

2. Select aString to XML orString to JSON step in the canvas.

3. In the Properties Pane, select theResults tab .

See also l "XML Activities" on page 1717

l "JSON Activities" on page 1690

User interface details are shown below:

UI
Elements Description

Result A boolean variable indicating whether the string had the correct structure to be
converted into XML or JSON.

Validate Instructs UFT to check if the expected output is correct.

Expected
Value

The expected result of the step: True, False, 0, or 1.

Security Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to configure the security settings for yourWeb Service activities.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theSecurity Settings tab .
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Relevant tasks l "How to Set Security for aWeb Service on the Port Level" on page 1885

l "How to Set Security for a Specific Step" on page 1886

See also l "Setting Security Overview" on page 1878

l "Security Settings for Port <Port_Name> Dialog Box" on page 1900

User interface elements are described below:

UI Element Description

Use the
port's
security
settings

Enables you to use the security settings from the currently selected step's port.

Note: If you clear this check box, youmust configure the security settings
in this tab.

Save Saves the security settings.

Import Imports a security settings file (.stss).

<security
settings
area>

Enables you to set security information for theWeb Service activity. For full
user interface details, see "Security Settings for Port <Port_Name> Dialog Box"
on page 1900.

Edit port's
settings

Enabled only when the Use the port's security settings option is selected.

Opens the "Security Settings for Port <Port_Name> Dialog Box" (described on
page 1900), enabling you to configure the security information used for theWeb
Service's port.

SOAP Fault Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to set the expected result of anWeb Service or SOAP activity.

To access 1. Open the Properties pane.

2. Select aWeb Service or SOAP step in the canvas.

3. In the Properties Pane, select theSOAP Fault tab .

See also l "Network Activities" on page 1684

l "Negative Testing of Web Services" on page 1738
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User interface elements are described below.

UI
Element Description

Fault is
expected

Indicates that a SOAP fault is expected during the test run. This setting confirms that
the application did not perform a task that it was not designed to perform.

XML tab The SOAP envelope, containing the Header and Body of the SOAP message. In this
section you enter the expected response.

You can defineAny type elements or values for the following properties:

l faultcode. A status code indicating that the SOAP request was invalid.

l faultstring. A response string indicating that the SOAP request was invalid.

l faultactor. An indication of the source of the fault.

XPath
tab

A list of XPATH expressions used to evaluate the SOAP response.

l Adds a line for an XPATH expression.

l Removes the selected entry.

Test Settings Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to set global preferences and properties for your test.

To access 1. Open the Properties pane.

2. Select a step in the canvas.

3. In the Properties Pane, select the Test Settings tab .

Important information Test settings apply to all steps in the test.

User interface elements are described below.

Test Settings Tab - Action Buttons

UI Elements Description

Export Exports the current Test settings to an XML file.

Import Imports an XML file with previously saved Test settings.
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Load Settings

UI Elements Description

Load
Enabled
(read-only)

Indicates whether the test is enabled for load testing. To enable this capability,
select Design > Operation > Enable Test for Load Testing.

Note: Once a test is enabled for load testing, you cannot disable it.

JVM (Java Virtual Machine) Settings
These settings are relevant for all Java related activities such as JMS andCall Java Class
activities.

UI Elements
(A-Z) Description

Additional
VM
Parameters

Extra parameters to send to the JVM such as Xbootclasspath, and any
parameters specified by the JVM documentation.

Classpath The vendor implementation of Java classes together with any other required
supporting classes, as determined by the implementation vendor.

JMS Settings

UI Elements
(A-Z) Description

Automatically
generate
selector

Generates a selector for the responsemessage with the correlation ID of the
request (No by default). Each JMS message sent to the server has a specific
ID. Enable this option if you want UFT to automatically create a selector that
includes themessage ID.

Note: This option only affects theSend and Receive Message from
Queue activity.

JMS
connection
factory

The JNDI name of the JMS connection factory. This setting is unique for each
test.

JMS security
credentials

The principal's credentials for the authentication scheme.

JMS security
principal

Identity of the principal (for example the user) for the authentication scheme.
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UI Elements
(A-Z) Description

JNDI initial
context
factory

The fully qualified class name of the factory class that will create an initial
context. It provides a list of context factories and enables manual entries.

JNDI
provider URL

The URL of the service provider. For example:
Websphere - iiop://myserver:myport

Number of
JMS
connections
per process

The number of JMS connections each execution process creates. The default
is 1, and themaximum is 50. The fewer connections you have, the better your
performance.

Received
message
timeout
options

The timeout for receivedmessages.

l Indefinite wait.Wait as long as required for themessage before continuing.

l No wait. Do not wait for the Receivemessage, and return control to the
script immediately. If there was nomessage in the queue, the operation
fails.

l User defined timeout.Wait a specified number of seconds for the
message. If it does not arrive, the operation fails.

User defined
timeout

The amount of seconds to wait for themessage before timing out. The default is
20 seconds.

.NET Settings

UI
Elements Description

Assembly
paths

The .NET assembly paths for the test.

This entry should include all relevant folder paths and environment variables.
Separatemultiple values with semicolons.

General Settings

UI Elements Description

Stop test on step failure Exits the test if a step fails during the test run.

Default: True
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Reporting Settings

UI Elements Description

Use the reporting
mechanism

Tells UFT to automatically open the Run Results Viewer after a
test run.

Test Variables Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to set global test variables for use in your test.

To access 1. Open the Properties pane.

2. Select theStart orEnd step in the canvas.

3. In the Properties Pane, select the Test Variables tab .

Relevant tasks "How to Define API Test Properties or User/System Variables" on page 141

See also l "New Test Profile Dialog Box" on page 172

l "Manage Profiles Dialog Box" on page 173

User interface elements are described below.

UI
Element Description

User
variables

A list of the user variables for all profiles. When enabling theCompare Profiles
option, the grid displays the variable values for each profile in separate columns.
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UI
Element Description

System
variables

A read-only list of common system variables and their values:

l ScenarioID

l SystemTempDir

l GroupName

l TestDir

l TestName

l LocalHostName

l OS

l OSVersion

l ProductDir

l ProductName

l ProductVer

l UserName.

Test Variables Tab - Action Buttons

UI
Elements Description

Add New User Variable. Adds a new user variable to the all profiles.

Remove User Variable. Deletes the selected user variable from all profiles.

Add New Profile. Adds a new User Variable profile to the list.

Edit Active Profile. Opens theManage Profiles dialog box that lets you to remove
or rename profiles.

Compare Profiles. Displays the profiles side-by-side for comparison.

<Profile
list>

A list showing the existing User Variable profiles.
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XML Body Tab (Properties Pane - API Testing)

Relevant for: API testing only

This tab enables you to configure the response XML data for a SOAP Request step.

To access 1. Open the Properties pane.

2. Select aWeb Service step in the canvas.

3. In the Properties Pane, select theXML Body tab .

See also "Network Activities" on page 1684

User interface elements are described below (unlabeled elements are shown in angle brackets).

UI Elements Description

Grid Shows a grid view of the schema.

Text Opens an editable text view for the schema.

Revert Text view only—reverts back to the last version of the schema since you last
opened the Text view.

Syntax error. Data at the root level is invalid. Move themouse over the icon to
see the error's line number (Text view only).

Syntax warning. A warning indicating a problem in the entered text, for example,
if the specified element is not in the namespace. For details, move themouse
over the icon (Text view only).

Import
Schema

Imports an .xsd file representing the schema, for both Input properties and
checkpoints.

Load XML Loads an .xml file containing values for the schema, for both Input properties and
checkpoints.

Deletes the contents that you entered for the schema. This affects both the Grid
and Text views.

Input pane A grid or text representation of the schema's request header and body.

Checkpoints
pane - XML
view

A grid representation of the response's schema. In this section you can enter the
expected response values.

l Import Schema. Imports a schema for the XML response.

l Load XML. Loads an XML file with the expected response values.

l Clear. Deletes the contents of the schema.
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UI Elements Description

XPath
Checkpoints
pane

A list of XPath expressions used to evaluate the XML response.

l Adds a line for a new XPath expression.

l Removes the selected XPath expression.

Ignore namespaces: Ignores namespaces in the XPath validation, allowing you
to use simple XPath expressions. For details, see "How to Set XPath
Checkpoints for Test Steps" on page 1617.

Note: To retrieve an XPath expression, use the right-click menu options in
the Grid view.

Action Buttons

Relevant for: API testing only

The following buttons represent actions, primarily performed on step properties. The availability of
the buttons depends on the step type.

UI
Elements Description

Data Drive Entire Step. Data-drives all values for the step. It adds data
expressions to theValue columns of all input properties.

For details, see "How to Data Drive an API Test Step" on page 1827.

Edit Property. Opens the Edit Property dialog box for changing the name, type, or
description of a property.

Note: Only available for Custom Code, RESTmethod, and Start/End steps.

Load from Replay. Loads data from a recent replay in order to populate the
service's properties with values (forWeb Services only).

For details, see "How to Run an API Test" on page 643.

Remove Property. Deletes the selected property from the list.

Note: Only available for Custom Code, RESTmethod, and Start/End steps.
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UI
Elements Description

Add Input/Output Property/Parameter. Opens the "Add Input/Output
Property/Parameter Dialog Box (API Testing)" (described on page 1775), allowing
you to define a new property and its data type.

Note: Only available for Custom Code, RESTmethod, and Start/End steps, or
when selecting the entire canvas.

For details, see "Writing Event Handlers for API Test Steps" on page 1935.

Load
XML

Loads XML data in order to populate a service's schemawith values (forWeb
Services only).

For details, see "How to Run an API Test" on page 643.

Load
options

Loads an XML file containing theCompare XML ignore settings that you saved with
another test.

Save
options

Saves theCompare XML ignore settings so that you can load them into a future
test.

Select
GUI/API
Test

ForCall GUI Test and Call API Test steps: Invokes the "Select Action or Test
Dialog Box" (described on page 1797), enabling you to selecting a test to call from
this step.

Select
Java File

Opens the "Java Class Dialog Box" for setting additional classpaths for the call (for
Call Java Class steps only).

For details, see the "Java Class Dialog Box" on page 1727.

Refresh
GUI/API
Test

ForCall GUI Test andCall API Test steps: Updates the test from its original
location.

Load
JSON

Loads a JSON file to convert to or from a string.

Note: Only available for JSON to String andString to JSON steps.
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Value Column Icons

Relevant for: API testing only

The following buttons represent information, drop-down lists, or actions within the Properties pane's
Value column:

UI
Elements Description

Include argument in the request. Toggle to clear the triangle and exclude the
argument.

Set to NIL. Toggle to clear the icon and remove the NIL value assignment.

Read-only node. Values that cannot be changed such as properties linked to a data
source other than a constant value, or nodes with read-only attribute in the activity
signature, first HTTP header, and so forth.

Warning. A warning related to the data source. For example, The data types of the
link source and link destination do not match.

l For Input properties:

A drop-down list of possible values. For example, for boolean values it provides a
list of values for boolean type data: true, false, 0, or 1. For date types, it opens a
calendar. This drop-down arrow is located adjacent to the Link to a data source
button .

l ForCheckpoints:

A drop-down list of the relevant comparison operators such as: =,!=, >, >=, <, <=,
Starts, Ends, Contains, orRegex. The greater than operator, >, when used with
strings, indicates that it appears later in the alphabet.

Scroll. A scroll control for integer data types.

Browse. Enables you to locate a file or folder for example, when using a File
System type step.

For anOpen Connection step, this opens the "Connection Builder Dialog Box"
(described on page 1720).

Link to a data source. Opens the "Select Link Source Dialog Box (API Testing)"
(described on page 1840), allowing you to select values for the property from a data
source.

Display list of outgoing links. Shows a list of all input properties that link to this
output property. For details, see "Outgoing Links" on page 1808.
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Array Control Buttons

Relevant for: API testing only

The following buttons allow you to handle array type properties. These buttons are adjacent to the
property name in the Properties pane's left pane.

After you add array elements, you can set the number of iterations to use the different array values.
For details, see "Flow Control Activities" on page 1651.

UI
Elements Description

Add array element. Adds one array element to the selected node in the in the
Properties tree.

Remove array element. Removes the selected array element from theProperties
tree.

Duplicate array element. Adds a copy of the selected array element.

Properties Pane User Interface (BPT in UFT)
For details about the GUI testing Properties Pane, see "Properties Pane User Interface (GUI
Testing)" on page 387. For details about the API testing Data Pane, see "Properties Pane User
Interface (API Testing) " on page 402.

Relevant for: business process tests and flows

This pane displays properties, parameters, and other details defined for business process tests,
flows, components and groups, and enables you tomodify many of them. The tabs displayed, and
in some cases, the options displayed on each tab, differ depending on whether you are editing a test
or flow, and have selected a component, flow, or group instance in the document pane.

This section includes the following:

General Properties Tab (Properties Pane - BPT) 439

Test Parameters Tab (Properties Pane - BPT) 440

Parameters Tab (Properties Pane - BPT) 444

Properties Tab (Properties Pane - BPT) 447

Component Details Tab (Properties Pane - BPT) 451
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General Properties Tab (Properties Pane - BPT)

Relevant for: business process tests and flows

This tab displays read-only information about the business process test or flow selected in the
Solution Explorer.

The image below shows an example of the General Properties tab displaying properties for a
business process test or flow. TheGeneral Properties tab is available only when a business
process test or flow is selected in the Solution Explorer.

To
access

1. In the Solution Explorer, make sure that the business process test or flow for
which you want to view properties is selected.

2. Select View > Properties or click theProperties pane button . TheGeneral
Properties tab is displayed by default.

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and Flows in
UFT" on page 2071

User interface elements are described below:

UI Element Description

Name The name of the selected test or flow.

ID The ALM ID of the selected test or flow.

Status The ALM status for the selected test or flow.
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Test Parameters Tab (Properties Pane - BPT)

Relevant for: business process tests and flows

This tab enables you to add, delete, andmodify test, or flow input and output parameters.

The image below shows the Test Parameters tab displaying input and output parameters for a flow
selected in the Solution Explorer. (Output parameters are not displayed for tests.)

The Test Parameters tab is available only when a business process test or flow is selected in the
Solution Explorer.
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To access 1. In the Solution Explorer, make sure that the business process test or flow
for which you want to view properties is selected.

2. Select View > Properties or click theProperties pane button .

3. Click the Test Parameters tab.

Important
information

"Considerations for BPT Test Iterations and Parameters" on page 224

"Promoting Parameters in a Business Process Test" on page 2123

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and Flows
in UFT" on page 2071

User interface elements are described below:

UI Element Description

Add Opens the Add/Edit Input/Output Parameter dialog box, enabling you to add a
new input or output parameter.

For details, see "Add/Edit Input/Output Parameter Dialog Box (Properties Pane -
BPT)" on the next page.

Edit Parameter. Opens the Add/Edit Input/Output Parameter dialog box,
enabling you to edit the selected parameter.

For details, see "Add/Edit Input/Output Parameter Dialog Box (Properties Pane -
BPT)" on the next page.

Delete Parameter. Deletes the selected parameter.

<input
parameters
list>

The list of input parameters for the test or flow selected in the Solution Explorer.
The following information is available:

Used. Indicates whether the parameter is used in the test or flow.

Input. The name of the input parameter.

Default Value. The default value of the input parameter. This value is used
during a run session if no other value is supplied by the component.

<output
parameters
list>

The list of output parameters for the selected flow, and is displayed only for
flows. The following information is available:

Used. Indicates whether the parameter is used in the test or flow.

Output. The name of the output parameter.
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UI Element Description

<parameter
description
area>

Lists the following information about the selected parameter:

l Name and description. These are entered in the "Add/Edit Input/Output
Parameter Dialog Box (Properties Pane - BPT)" below.

l Parameter promotion status. (Used By:) The components or flows that
use the selected parameter, if the parameter was promoted from the
component or flow in the test.

Add/Edit Input/Output Parameter Dialog Box (Properties Pane - BPT)

Relevant for: business process tests and flows

This dialog box enables you to define an input or output parameter to use in the selected test or
flow.

To access 1. In the Solution Explorer, select a business process test or flow.

2. In the Properties Pane, select the Test Parameters tab and then do one of
the following:

n To add a new input parameter:Select Add > Add Input Parameter.

n To add a new output parameter:Select Add > Add Output
Parameter.

n To edit an existing input or output parameter: Select an existing input

or output parameter and click theEdit Parameter button.
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Important
information

You can add or edit output parameters only when editing a flow. These options
are disabled when editing a business process test.

"Considerations for BPT Test Iterations and Parameters" on page 224

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and Flows
in UFT" on page 2071

User interface elements are described below:

UI Element Description

Name The parameter name (case-sensitive).

Default Value
(available only for
input parameters)

The default value for the parameter, used during the run session if no
other value is provided for the parameter.

Description A meaningful description for the parameter, for example, the purpose
of the parameter.

Parent topic: "Test Parameters Tab (Properties Pane - BPT)" on page 440

User Guide
Chapter 13: Properties Pane

HP Unified Functional Testing (12.00) Page 443 of 2274



Parameters Tab (Properties Pane - BPT)
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Relevant for: business process tests and flows

This tab enables you to define parameter data for a selected component or flow in a business
process test or flow.

The Parameters tab is available only when a component or flow is selected in the document pane.

The image below shows the Parameters tab displaying input and output parameters for the selected
component or flow. Neither of the input parameters shown in this image have been promoted.

The image below shows the Parameters tab displaying input and output parameters for the selected
component or flow. All of these parameters have been promoted to the next level.
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To access 1. In the Solution Explorer, make sure that the business process test or flow for
which you want to view properties is selected. In the document pane, make
sure that specific component or flow you want to modify is selected.

2. Select View > Properties or click theProperties pane button . The
Parameters tab is displayed by default.

Important
information

"Considerations for BPT Test Iterations and Parameters" on page 224

"Promoting Parameters in a Business Process Test" on page 2123

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and Flows in
UFT" on page 2071

User interface elements are described below:

UI
Element Description

Promote parameters. Promotes the selected parameters to the next level, and
replaces the selected parameter value with a link to the new parameter.

If there are no test parameters with the same name, or if theAlways link to existing
test parameters option is not selected in the BPT Testing tab in the Options dialog
box, UFT creates new test parameters, and links the selected component parameter
value to the new test parameter values.

If test parameters already exist with the same name, and theAlways link to
existing test parameters option is selected, the select component parameter value
is automatically linked to the existing test parameter value.

This button is disabled if the component or flow parameter is already linked to a
parameter at the next level.

For more details about promoting parameters, see "Linking Parameters in Business
Process Tests" on page 2119.

For configuration details, see "BPT Testing Tab (Options Dialog Box)" on page 570.
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UI
Element Description

Input The list of input parameters for the component or flow selected in the document pane.
The following information is available:

Input: The name of the input parameter.

Value: The parameter's value. Enter text or link the parameter to another test, flow, or
component parameter using theSelect Link Source dialog box (described on page
2128).

Hover over theValue cell to display the Link andRemove Link buttons.

Caution: Removing this link will remove the linked data for the selected
parameter in all iterations for the selected component.

The <p> linked icon indicates that the parameter value is linked to another
parameter.

Output The list of output parameters for the component or flow selected in the document
pane. The following information is available:

Output: The name of the output parameter.

Value: The parameter's value. Enter text or link the parameter to another test, flow, or
component parameter using theSelect Link Source dialog box (described on page
2128). Values are displayed for output parameters only when a component is in a
flow.

If you are editing a flow, hover over theValue cell to display the Link and
Remove Link buttons. These buttons are not displayed if you are editing a test.

Caution: Removing this link will remove the linked data for the selected
parameter in all iterations for the selected component.

The locked icon indicates that the parameter value is linked to another parameter.

Properties Tab (Properties Pane - BPT)

Relevant for: business process tests and flows

This tab enables you tomodify run conditions, On Failure settings, and comments for a selected
component instance.
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The options displayed in this pane depend on whether you are editing a test or a flow, and have
selected a component, flow, or group in the document pane:

l If you are editing a business process test, you can edit only on failure settings and comments for
the selected component or flow.

l If you are editing a business process flow, but have selected a group in the document pane, you
can only edit comments for the selected group.

l If you are editing a business process flow, and have selected a component, you canmodify run
conditions, On Failure settings, and comments for the selected component.

The image below shows an example of the Properties tab, when a component is selected in the
document pane, and the user is editing a flow.

The Properties tab is available only when a component or flow is selected in the document pane
and, the content will differ depending on whether you are editing a test or a flow, and what sort of
instance you selected in the document pane.
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To access 1. In the Solution Explorer, make sure that the business process test or flow for
which you want to view properties is selected. In the document pane, make
sure that specific component or flow you want to modify is selected.

2. Select View > Properties or click theProperties pane button .

3. Select the Properties tab.

Important
information

"Considerations for BPT Test Iterations and Parameters" on page 224

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and Flows in
UFT" on page 2071

User interface elements are described below:

UI Element Description

Run conditions (for flows, with a component selected)

Use run
condition

Indicates whether to use the defined run conditions for the selected component.

Select the checkbox to enable the other run condition options.

Run if: Enables you to begin a conditional statement, defining that the selected
component should run only if it matches the defined conditions.

This dropdownmenu lists the parameter types defined for the selected
component. The following types are available:

l Input parameter. Available only if one or more input parameters are defined
for this component.

l Output parameter. Available only if one or more output parameters are
defined for one or more of the previous components in the flow.

l Flow parameter. Available only if one or more flow input parameters are
defined.

Tip:When creating a run condition on a parameter that contains a dynamic
date value, define the run condition as a static date (for
example,12/10/2011), which is compared to the actual date used in the run.
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UI Element Description

<parameter
name>

Lists the available parameters. If you selectedOutput parameter, the
component name is appended to the parameter name.

Encrypted parameters are not listed.

Tip: Parameters with encrypted values cannot be chosen from the list when
defining run conditions. It is recommended that you do not use parameters
whose default values are encrypted when defining run conditions.

Is: Lists the operators that need to bemet for the component to run. The following
conditions are available:

l equal to

l not equal to

l less than

l less than or equal

l greater than

l greater than or equal

After you select one of the options from the dropdownmenu on the left, enter the
value for the relevant option in the text box on the right.

<value> Enables you to enter the valid value for the condition.

Else: Specifies what to do if the condition is not met. The following options are
available:

l Skip to next component and continue. If the condition is not met, the
selected component does not run, and the test run continues with the next
component in the flow. The component is not displayed in the run results.

l End component run and fail. If the condition is not met, the component for
which the run condition is set does not run, but instead sets the status of the
component run as Failed. The flow either continues to the next component or
ends, depending on the failure condition set for the component.

Tip: Your selection from theElse dropdownmenu applies only if the run
condition is not met. To specify whether to continue or end the entire run if a
component run fails, modify theOn failure settings for the component.

On failure settings (for tests and flows)
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UI Element Description

On failure: Enables you to define whether a run continues or ends if a specific business
component or flow in the test fails.

l Continue. The business process test will run the next business component or
flow if the selected component fails. By default, this failure condition is
defined for each component when it is added to a test

l Exit. The business process test run ends if the selected business component
fails.

Comments (for tests and flows, when a component, flow, or group is selected)

<Comments
box>

Enables you to view and edit comments for the selected component or flow.

Comments are free text entries that you can use to improve readability.

For example:

l Add comments before each section of a component's automated tests to
specify what that section includes.

l Add comments that describe the steps to be included before your
application is ready to be tested. When your application is ready, you can
use such comments to verify that every item that needs to be tested is
included in the steps.

Component Details Tab (Properties Pane - BPT)

Relevant for: business process tests and flows

This tab enables you to view the description defined in ALM for the selected component, as well as
fields and their values, including any user defined fields.

The image below shows an example of the Component tab, displaying the description and fields
defined in ALM for the selected component.

The Component tab is available only when a component or flow is selected in the document pane.
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To
access

1. In the Solution Explorer, make sure that the business process test or flow for
which you want to view properties is selected. In the document pane, make sure
that specific component or flow you want to modify is selected.

2. Select View > Properties or click theProperties pane button .

3. Select theComponent Details tab.

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and Flows in
UFT" on page 2071
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User interface elements are described below:

UI Element Description

Field name The name of the field.

The following fields are always displayed:

l Name. The component's name

l Script Type. The type of component.

l Status. The component's ALM status

TheVersion Checked field is visible when the
component is currently checked out of an ALM project,
and defines the user to whom the component is checked
out.

Value The field value, if defined.

Description The description defined for the selected component or
flow.
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Chapter 14: Run Step Results Pane
Relevant for: API testing only

This chapter includes:

Concepts 455

Running Test Steps - Overview 455

Reference 457

Run Step Results Pane User Interface 457

Run Step Dialog Box 459

Troubleshooting and Limitations - Running Steps and Run Step Results 461
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Concepts

Running Test Steps - Overview
Relevant for: API Tests

Before you run your test, you can test individual steps tomake sure they run properly. This feature,
Run Step, is available directly from the canvas and is available for most step types. To run an
individual step, select it and chooseRun Step from its right-click menu.

After you run the step, the Run Step Results pane opens and shows the properties and results.

For services using SOAP, this pane shows the Input andOutput envelopes. You can expand and
collapse the nodes of the envelope tomake it more readable.
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This can be especially useful in checking the validity of your input property values. In the following
example, the specified flight number was not valid.

The Run Step feature also verifies checkpoints that are selected in the Checkpoints pane, including
those of Fixed array type.

For a user interface description, see "Run Step Results Pane User Interface" on the next page.

For RESTmethods, use the RunMethod feature in the REST user interface. For details, see
"Add/Edit REST Service Dialog Box" on page 1772.

User Guide
Chapter 14: Run Step Results Pane

HP Unified Functional Testing (12.00) Page 456 of 2274



Reference

Run Step Results Pane User Interface
Relevant for: API testing only

The Run Step Results pane shows the results of the run. For a simple built-in activity, it shows the
status of the run. For SOAP messages, it shows the Input andOutput envelopes.

To access Select View > Run Step Results

Relevant tasks "How to Create an API Test" on page 1598

See also l "The Canvas" on page 209

l "Run Step Dialog Box" on page 459
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The user interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<Step Name> table A table showing the names and values of properties and an invocation
summary. The following is a list of the common fields:

l Name. The name of the step as it appears in the General properties.

l Comment. The text in the General properties tab's Comment field.

l <Properties>. The input and output property names and values (non
SOAP steps).

l Input Envelope. A tree hierarchy of the SOAP envelope for the input
properties.

l Output Envelope. A tree hierarchy of the SOAP envelope for the
output properties.

l Invocation Results. Text describing the results of the run—both
upon success and failure.

Checkpoints
(<success ratio>)
table

A table showing the checkpoints, with the following information:

l Property name

l Expected andActual values

l Operator (=, <, >, and so forth)

l XPath of the property
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Run Step Dialog Box
Relevant for: API testing only

This dialog box enables you to set constant values for theRun Step operation.

To access Do the following:

1. Add a step to the canvas that supports Run Step.

2. Link one or more properties to an output property from a previous step.

3. Click the step in the canvas and select Run Step from the right-click menu.

Important
information

A property is listed when one of the following applies:

l The property's input value is linked to the output property of a previous step.

l The property requires a value, such as a URL for an HTTP Request step, and
that value was not specified in the Properties pane.

Note:When you assign constant values to the properties, the value is only
used for this local Run Step step—the link to the output property in the
Properties pane is not affected.

Relevant
tasks

"How to Create an API Test" on page 1598.

See also "Run Step Results Pane" on page 454

User Guide
Chapter 14: Run Step Results Pane

HP Unified Functional Testing (12.00) Page 459 of 2274



User interface elements are described below:

UI
Element
(A-Z) Description

Open Text Editor. Opens an editor for editing text strings.

Note: For properties with enumeration, this button is not shown. Instead, a drop
down list is available for selecting a value.

Import from File. Allows you to import a property value from a file. This is useful for
complex properties whose values are stored in XML files.

Note: For properties with enumeration, this button is not shown. Instead, a drop
down list is available for selecting a value.

<property
list>

A list of the properties to which a data source was assigned, that need to be given a
constant value. It shows the following information:

l Section Name. The origin or type of property, usually Input orOutput.

l Property Name. The property name as it appears in the Properties pane.

l Value. The value to use in the run. By default, it takes the value from the first row
of the data source.
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Troubleshooting and Limitations - Running Steps and
Run Step Results

Relevant for: API testing only

This section describes troubleshooting and limitations for the Run Step Results pane.

l Whenworking in non-English operating systems, certain entries in the Run Step Results pane
are hard-coded in English and not translated.

l The Run Step command is not supported for Java or JMS activities.
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Chapter 15: Search Results Pane
Relevant for: GUI testing and API testing

This chapter includes:

Concepts 463

Search Results PaneOverview 463

Tasks 464

How to Navigate Through the Search Results Pane 464

Reference 466

Search Results Pane User Interface 466
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Concepts

Search Results Pane Overview
Relevant for: GUI tests and components and API testing

The Search Results pane displays all occurrences of the search criteria you define using the Find
dialog box or other Searchmenu items. Search results are displayed in one continuous list or
grouped according to source file.

You can browse through the search results, locate specific results in their source files, and perform
recent searches again to retrieve updated results.

For details on searching for specific strings, see "How to Navigate Through the Search Results
Pane" on the next page.

For user interface details, see "Search Results Pane User Interface" on page 466.

Note: Searches are not supported in the Keyword View or the canvas.
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Tasks

How to Navigate Through the Search Results Pane
Relevant for: GUI tests and components and API testing

This task describes how to navigate through results displayed in the Search Results pane, as well
as how to access the recent search history.

This task includes the following steps:

l "Prerequisite" below

l "Modify the search results display" below

l "Browse and locate search results" on the next page

l "Display updated results for recent searches" on the next page

l "Clear the recent search history" on the next page

For user interface details, see "Search Results Pane User Interface" on page 466.

Prerequisite
Do one of the following:

l Perform a search using the Find All button in the "Find Dialog Box (Document Pane Editor) "
(described on page 342). For details, see "How to Find or Replace Strings in Files" on page 327.

l API testing only: Search for references using the Searchmenu options. For details, see "How
to Search for References or Classes in Documents in the Editor (API Testing Only)" on page
325.

Modify the search results display
To toggle between display modes:

Click theSelect search list mode button to toggle between the following display
modes:

l Flat list. Displays all search results in a single list.

l Grouped per file. Displays all search results in a hierarchical list according to their source files.
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When the results are grouped per file, a file information line is displayed above each group of
results, indicating the source file and number of occurrences found in the file. For example:

To collapse or expand the results per file:

Click theCollapse per file orExpand per file icon to the left of the file information line to view
the results found in a specific file.

Browse and locate search results

l Use the scroll bar to move up or down in the search results list.

l Do one of the following to jump to the location of a search result in the document pane and
highlight the search string:

n Double-click a search result in the list.

n Click Previous to select the previous item in the search results list.

n Click Next to select the next item in the search results list.

If the file containing the search result is closed, it is automatically opened in the document pane. If
you switch to the Keyword View, the entire row containing the search result is highlighted.

Display updated results for recent searches

Click theShow last searches button and select a search string from the drop-down list.

TheShow last searches drop-down list displays the last ten search strings used.

Clear the recent search history

Click theShow last searches button and select Clear history.

TheShow last searches drop-down list is cleared of all recent search strings.
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Reference

Search Results Pane User Interface
Relevant for: GUI tests and components and API testing

This pane displays all occurrences of the search criteria you defined and enables you to:

l Locate specific search results in their source files

l Retrieve updated search results for recent searches

l Clear the search history

To access Do one of the following:

l Select View > Search Results to view the results of your last search.

l In the Find dialog box, define the search criteria and click Find All.

l API testingonly: Perform a search for references using the Searchmenu
options.

Important
information

Click on a row or use thePrevious andNext buttons to jump to the location of the
search result in the document pane and highlight the search string.

Note: Searches are not supported in the Keyword View or in the canvas.
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Relevant
tasks

l "How to Navigate Through the Search Results Pane" on page 464

l "How to Find or Replace Strings in Files" on page 327

l "How to Search for References or Classes in Documents in the Editor (API
Testing Only)" on page 325

See also "File and Item Types Included in String Searches" on page 317

The following sections describe:

l "Main User Interface Elements" below

l "Context Menu User Interface Elements" on the next page

Main User Interface Elements
User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Eleme
nt Description

<Show recent searches>. Enables you to:

l View a drop-down list displaying the last ten Find All search strings used.

l Clear the search history entirely.

Select a search string to retrieve themost recent results, or select Clear search
history to clear the recent search history.

<Search list display mode>. Enables you to display all search results in a single list
or grouped according to source file.

Previous result. Selects the previous item in the search results list, jumps to the
location of the search result in the document pane, and highlights the search string.

Next result. Selects the next item in the search results list, jumps to the location of the
search result in the document pane, and highlights the search string.

<Collapse or expand per file>. Enables you to collapse or expand the list of search
results located in a specific file, when viewing an expanded list of results grouped by
file.

Note: This icon is displayed when the results are grouped by file.
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UI
Eleme
nt Description

<Searc
h
results
list>

Search results are displayed with the following syntax, depending on the type of source
file:

GUI actions and function libraries for both grouped by file and flat list views

<File Path> (<line>,<column>): <text>

Note: For function library results found in a solution or tests, the file path is the
name of the function library.

API test flow

l Grouped per file:

<Activity StepID>/<Tab Name>/<Property Name> : <Property Value>

l Viewed in flat list:

n <Test Name>/<Activity StepID>/<Tab Name>/<Property Name> : <Property Valu
e>

or

n <Test Name><(Action)>/<Activity StepID>/<Tab Name>/<Property Name> : <Prop
erty Value>

API user source code

l Grouped per file:

<line>,<column> : <text>

l Viewed in flat list:

<File Path> (<line>,<column>): < text >

Context Menu User Interface Elements
The user interface elements described below are available when you right-click a search result in
the Search Results pane:

UI
Elements Description

Copy Copies the content of the selected search result to the clipboard.
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UI
Elements Description

Locate Jumps to the location of the selected search result in the document pane and
highlights the search string.

Note: You can also double-click the search result.
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Chapter 16: Solution Explorer Pane
Relevant for: GUI tests and components and API testing

This chapter includes:

Concepts 471

Solutions in UFT Overview 471

Solution Explorer PaneOverview 471

Tasks 473

How toManage Items in the Solution Explorer Pane 473

Reference 478

Solution Explorer Pane User Interface 478

Troubleshooting and Limitations - Solution Explorer Pane 496
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Concepts

Solutions in UFT Overview
Relevant for: GUI tests and components and API testing

A solution is a collection of testing documents and other resources, similar to a binder or notebook.
You can use solutions to organize your testing documents to help you perform comprehensive
application testing.

For example, suppose you want to test aWeb application for a flight booking application. You can
create a solution containing several tests or components that verify various aspects of your
application, such as logging in, booking a reservation, verifying the connection between your
application and database, and verifying the transfer of booking information from your application to
an airline server.

In UFT, all testing documents must be part of a solution. Therefore, when you create a testing
document, you assign it immediately to a solution. You can provide descriptive names for your
solutions, or you can accept the default names provided by UFT.

UFT solutions can includeGUI and API (non-GUI) tests, business components, business process
tests and flows, application areas, function libraries, or user-created code documents. When you
add a testing document to a solution, it retains its unique associations to other testing documents
and resource files and does not create links to the other testing documents in that solution. The
relationship between solutions and testing documents goes in one direction. The solution contains
references to its testing documents, but the testing documents do not contain a reference back to
any solutions that contain it.

You can create solutions for own use, or you can share solutions with other users by saving them in
an accessible location, such as a network drive. Although your testing documents can be stored in
the file system or ALM, solutions are always stored somewhere in the file system.

You view andmanage solutions in the Solution Explorer pane.

Solution Explorer Pane Overview
Relevant for: GUI tests and components and API testing

You use theSolution Explorer pane to view andmanage the testing documents in a solution. The
Solution Explorer is displayed as a tree in the Solution Explorer pane. This tree displays a separate
node for each type of testing document, with sub-nodes for all associated or referenced items.

From the Solution Explorer, you can:

l Add new or existing testing documents to a solution.

l Open any testing document directly from the Solution Explorer. You can open several testing
documents side-by-side in the same session.
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l Display the properties and settings for the solution or any of its testing documents by
highlighting the relevant node. This refreshes most of the panes in UFT as the Solution Explorer
pane serves as themaster pane in UFT.

l Add resource files to a GUI testing document.

l Prioritize GUI testing resource files.

l Add user-created functions to a test by adding a function library (GUI testing) or C# user code
file (API testing).

l Add an external reference file toan APItest for a run session or add aWeb reference for use in an
API test (API testing).

l Rename the solution andmany of its sub-nodes.

l Run a test or component from the solution.

Note:When you open a testing document from outside of the Solution Explorer (from the File
menu, for example), the testing document always opens in a new, untitled solution, even if it
is part of the currently open solution. Therefore, if you want to open a testing document that is
part of the current solution, and you do not want to close any other open testing documents,
open the testing document from the Solution Explorer.

For an overview of solutions, see "Solutions in UFT Overview" on the previous page.

For task details, see "How toManage Items in the Solution Explorer Pane" on the next page.

For user interface details, see "Solution Explorer Pane User Interface" on page 478.
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Tasks

How to Manage Items in the Solution Explorer Pane
Relevant for: GUI tests and components and API testing

This task describes how to perform various operations in the Solution Explorer pane.

This task includes the following steps:

l "Prerequisite: Show the Solution Explorer pane" on the next page

l "Create a solution" on the next page

l "Open a solution" on the next page

l "Create a document" on the next page

l "Add a document to the current solution" on page 475

l "Open an existing document from the current solution" on page 475

l "Add a resource file to your test (GUI testing only)" on page 475

l "Open a resource file (GUI testing only)" on page 476

l "Add an object repository file to the current solution (GUI testing only)" on page 476

l "Remove the association of a resource file with the test or action (GUI testing only)" on page 476

l "Change the priority of a resource file (GUI testing only)" on page 476

l "Run a test or component from the current solution" on page 477

l "Display the GUI test properties (GUI testing only)" on page 477

l "View or hide the sub-nodes in the test" on page 477

l "Remove a document from the current solution" on page 477

l "Save an individual document within the solution" on page 477

l "Save the solution" on page 477

l "Close the solution" on page 477
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Prerequisite: Show the Solution Explorer pane
Do one of the following:

l Select View > Solution Explorer.

l Click theSolution Explorer button in the toolbar.

l Click theSolution Explorer tab in themain UFT window.

Create a solution
Do one of the following:

l Select File > New > Solution.

l Click theNew button down arrow in the toolbar and select New Solution.

l Select File > New and choose the type of document to create.

In the "New <Document> Dialog Box" (described on page 152), enter a solution name in the
Solution Name field and select theCreate directory for solution option.

A new solution, also containing the type of document selected, opens in the Solution Explorer pane.

Note: If you do not create a named solution, a generic solution calledSolution Untitled is
created.

Open a solution
Select File > Open > Solution. In the dialog box, select the name of your solution file.

If a document included in a solution is unavailable, due to issues with ALM connectivity or resource
file problems, it appears in gray and an error describing the problem is displayed in the Errors pane.
Right-click Reload after resolving the error to add the document to the solution for editing.

Note:

l If you open a solution when another solution is open, the first solution is closed and you are
prompted to save any unsaved changes to documents contained in the closed solution.

l You can save and open solutions only on the file system.

Create a document
Right-click the <solution name> node and select Add > Add New Test/Business
Component/Function Library/Application Area.

The "Add Test/Component to Solution Dialog Box"(described on page 146) opens, enabling you to
create a new document and add it into your solution file.
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Add a document to the current solution
Right-click the <solution name> node and select Add > Add Existing Test/Business
Component/Function Library/Application Area.

The "Add <Existing Document> to Solution Dialog Box" (described on page 145) opens, enabling
you to add a document to your solution file.

Note: You can add amaximum of 10 documents to a solution.

Open an existing document from the current solution
Double-click a node for your document:

l For GUI tests or components: the <test name>/<component name> node.

l For GUI actions: the <action name> node located under the <test name> node.

l For application areas: the node containing the application area.

Application area nodes are located in different places depending on their association with a
component:

n For an independent application area, click the <application area name> found in the
Additional Items folder.

n For an application area associated with a component, click the <application area name>
node under the component.

l ForAPI tests and components: the Flow node located under the test or component node.

l ForAPIevent handlers: theEvents node located under the test or component name.

l ForAPI user code files: the <User Code file name> node located under the test or
component name.

A tab opens in the document pane with the selected document.

Add a resource file to your test (GUI testing only)
To add a resource file to your test, do one of the following:

l For a function library:Right-click the test node and select Associate Function Library.

l For a recovery scenario:Right-click the test node and select Associate Recovery Scenario.

The "Open/New <Document>/<Resource> Dialog Box" (described on page 156) opens. Browse to
and select the resource file to add.
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Open a resource file (GUI testing only)
Double-click the selected node for your resource file:

l For function libraries: the node containing the function library.

The function library nodes are located in different places, depending on their association with a
test, component, or application area:

n For a function library associated with a test or application area, click the <function library
name> found in the Function Libraries node in the test/application area node.

n For a function library not associated with a test or application area, click the <function
library name> found in theSolution Items folder node.

l For an object repository: the <object repository name> found under an action, component,
or application area node.

l For a recovery scenario: the <recovery scenario name> found under theRecovery
Scenarios node in an action or component node.

Add an object repository file to the current solution (GUI testing only)
Right-click on an <action name> node and select Associate Repository with Action.

In the "Open/New <Document>/<Resource> Dialog Box" (described on page 156), select the
object repository to add to the current action.

Remove the association of a resource file with the test or action (GUI
testing only)
Right-click the resource node and select the relevant command:

l Remove Function Library from List. Removes the association of the selected function library
with your test.

l Remove Recovery Scenario from List. Removes the selected recovery scenario from your
test.

l Remove Repository from List. Removes the selected object repository from the action.

Removing a resource node severs the association between the resource and the test or action. The
resource node is deleted from the Solution Explorer pane and any other location that indicates
associations, such as the Test Settings dialog box (for function libraries and recovery scenarios)
and the Associate Repositories dialog box (for shared object repositories).

Change the priority of a resource file (GUI testing only)
Right-click the resource node and selectMove Up orMove Down.

Note: By default, resources are listed in priority order in the order in which they were
associated with a test, component, or application area.
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Run a test or component from the current solution
Right-click on a test or component node and select Run. The Run dialog opens, enabling you to
choose preferences for your run session. For details, see "Run Dialog Box" on page 651.

Display the GUI test properties (GUI testing only)
Right-click theGUITest node in the tree and then select Settings to open the Test Settings dialog
box. Details of the test and its path are displayed. For details, see "Settings for GUI Tests, GUI
Business Components, and Application Areas" on page 580.

View or hide the sub-nodes in the test
Do one of the following:

l Right-click the Test node in the tree and select Expand All or Collapse All.

l Click the expand or collapse icons next to the node to expand or collapse the node.

Remove a document from the current solution
Do any of the following:

l Right-click a document node and select Remove from Solution.

l Select a document and press DELETE.

Note: Removing a document from a solution does not delete it from your file system or ALM
project.

Save an individual document within the solution
Right-click a document name and select Save As.

The "Save <Resource>/Save <Document> As Dialog Box"(described on page 164) opens,
enabling you to save the document with a different name or in a different location.

Save the solution

Select File > Save All or press theSave All button on the toolbar.

Note: Selecting this command also saves any modified document within the solution.

Close the solution
Select File > Close Solution.

Note: Closing a solution closes all documents that are part of the solution file. These files are
not deleted from your file system or ALM project when a solution is closed.
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Reference

Solution Explorer Pane User Interface
Relevant for: GUI tests and components and API testing

This pane enables you to:

l View the currently open solution, and its documents, and resource files

l Add or remove items from a solutions

l Open documents contained in a solution

l Associate GUI resource files to a specific test or component

l Run a test or component

The following image shows the Solution Explorer pane displaying a node for the different types of
GUI testing documents and their resource files.
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To access Do one of the following:

l Select View > Solution Explorer

l Click theSolution Explorer toolbar button .
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Important
information

l The Solution Explorer pane is displayed by default when you start UFT.

l The Solution Explorer pane is the control pane within UFT. Other panes,
menus, and toolbars update their content to match the document selected in
the Solution Explorer pane.

l Document nodes are displayed in alphabetical order.

l The active document is shown as bold in the Solution Explorer pane.

l Note for GUI testing: Resource nodes contained under a document node are
displayed in alphabetical order, but specific resources files are displayed in the
order in which they were associated to a document. You can use the context
menu for each resource node to change the priority order of resource files.

Relevant
tasks

"How toManage Items in the Solution Explorer Pane" on page 473

See also "Solution Explorer PaneOverview" on page 471

The Solution Explorer pane can display the following key nodes:

Solution Node (Solution Explorer Pane) 480

API Test/Component Node (Solution Explorer Pane) 481

Business Process Test/Flow Node (Solution Explorer Pane) 487

GUI Test Node (Solution Explorer Pane) 487

GUI Component Node (Solution Explorer Pane) 491

Application Area Node (Solution Explorer Pane) 494

Note: All user interface descriptions of each node also contain the descriptions of the context
menus available for the node.

Solution Node (Solution Explorer Pane)

Relevant for: GUI tests and components and API testing

The solution node displays the name of the solution and contains all the tests, component,
application area, and resource nodes necessary to edit and run a test or component. For details
about a specific type of document node, see the relevant section on each node below.

The following context menu options are available when you right-click the solution:

l Add New/Existing <Document>. Opens the "Add Test/Component to Solution Dialog Box"
(described on page 146) or "Add <Existing Document> to Solution Dialog Box" (described on
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page 145), which adds a new or existing document to a solution.

Note: You can add amaximum of 10 documents to a solution.

l Expand All. Expands all test, component, or application area sub-nodes contained in the
solution.

l Collapse All. Collapses all sub-nodes contained in the solution.

l Compile solution (API testing only) Compiles the solution files that have changed.

l Recompile solution (API testing only). Compiles all solution files, regardless of whether they
changed. You should run theClean solution command before this command.

l Clean solution (API testing only). Removes all files generated in the previous compilation of
the solution.

Note:

n TheCompile, Recompile, andClean commands are applicable only if your solution
contains API UFT tests. This command is not available if a solution contains only GUI
tests or components.

n Compiling GUI tests is not supported.

API Test/Component Node (Solution Explorer Pane)

Relevant for: API testing only

This API Test node is available only if your solution contains an API test or component. Some of
the nodes contained within this one, are available only if a relevant resource is created in a test or
component.

This node can contain the following sub-nodes:

l "References Node" on the next page

l "Flow Node" on the next page

l "Events Node" on the next page

l "Action Node" on the next page

l "External Tests/Actions Node" on the next page
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l "UserCode Node" on the next page

l "Context MenuOptions" on the next page

References Node
This node contains all of the .dll files used by UFT to runAPI tests.

Note: Do not remove any of the reference files contained by default in this node. They are
required to perform anAPI run session. You can add additional user-created reference files
using the context menu options. For details, see "Add Reference Dialog Box" on page 485.

Flow Node
This node provides a link to the API test canvas, which displays the test's flow. Double-clicking
this node displays the canvas or opens the canvas's tab (if closed). Each individual action also
contains a flow node for the action's steps.

For details on using the canvas, see "The Canvas" on page 209.

Events Node
This node provides a link to the test or action's TestUserCode.cs file used for coding event
handlers. Double-click on this node to display the file. Each individual action within a test also has
an events node for the action.

Note: If you double-click on this link independently of the events tab in the Properties pane, the
global test or component user code is displayed, including all event handlers currently written
into the test.

For details on coding API testing events, see "Writing Code for API Test Events - Overview" on
page 1938.

Action Node
This node contains all of the actions created in anAPI test.

Each action node contains a Flow andEvents node.

Note: This node is displayed only when you create an action in anAPI test. For details, see
"Actions in API Testing - Overview" on page 1787.

External Tests/Actions Node
This node contains all of the tests or actions (both GUI and API) called from the API test. The
different types of called actions are noted by their icons. For details on the different GUI action
icons, see "The Canvas" on page 209.

Note: This node is only displayed when you create a call to an external test or action. For
details on using HP Functional Testing activities in an API test, see "HP Automated Testing
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Tools Activities" on page 1714.

UserCode Node
This node contains any user code files associated with the test. The following user interface
elements are available:

UI Element Description

<file name> The name of the user code file name.

Note: Only .cs files can be associated with anAPI.

<folder name> The name of a folder containing user-generated code to add to a test.

Context Menu Options
The following context menu options are available for theAPI Test node:

Node Context Menu Option

<test
name>

l Run. Opens the "Run Dialog Box" (described on page 651) to begin a run
session for the current test.

l Expand All. Expands all sub-nodes found under the test.

l Collapse All. Collapses all sub-nodes found under the test.

l Remove from Solution. Removes the current test from the solution file.

l Save As. Opens the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 164), enabling you to save the selected test under a
different name or in a different location.

References
folder

l Add Reference. Opens the "Add Reference Dialog Box" (described on page
485), which adds a external reference file to your test.

<reference
name>

l Refresh. Updates the selected reference file with any changes made to the
file.

l Remove. Removes the current reference from the list.

l Properties. Displays the properties of the reference file in the Properties pane.

Caution: Do not remove the reference files included in this node, as doing so
may cause a run session to fail.
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Node Context Menu Option

<action
name>

l Delete Action. Removes the selected action from the test.

l Rename Action. Opens the "Rename Action Dialog Box" on page 1798,
enabling you to rename the action.

Note: Before renaming an action, youmust close the action's tab and user
code file and save your test.

User Code l Add New File. Opens a dialog box to add a new custom code file to your test.
For user interface details, see "Open/New <Document>/<Resource> Dialog
Box" on page 156.

l Add Existing File. Opens the "Add <Existing Document> to Solution Dialog
Box" (described on page 145), which adds an existing custom code file to the
test.

<user code
file/folder
name>

l Open. Opens the file in the document pane or brings it into focus.

l Open Containing Folder in Explorer. Opens the folder containing the user
code file inWindows Explorer.

l Remove. Removes the user code file from the user code node and deletes it.

l Exclude From Test. Removes the association of this user code file from your
test.

l Rename. Renames the selected file.

l Properties. Opens the file's properties in the Properties pane.
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Add Reference Dialog Box

Relevant for: API testing only

This dialog box enables you to add a reference file to your API test.

To access Do one of the following:

l Select theReferences node of an API test, right-click and select Add
Reference.

l Select Design > Add Reference.
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User interface elements are described below:

UI Element Description

GAC tab Displays a list of the GAC (Global Assembly Cache) assemblies and version
numbers.

Note:

l If you select theChoose specific assembly version option, the pane
displays a list of all versions of all assemblies. You can then select a
specific version of an assembly to insert in the test.

l If you enter a text string into theSearch field, UFT searches through the
list of assemblies for the assembly that matches your search string.

Tests tab A list of all tests contained in the current solution.

.NET
Assembly
Browser
tab

Enables you to searches the file system for .NET assemblies to import into a test.

The browser displays the following information:

l <directory location>. The location on the file system for a folder or assembly.

l Back/Up buttons. Enable you to return to the previously selected directory or
the previous level on the directory hierarchy to search for an assembly.

l <files list>. The list of all available files in a directory location.

COM tab A list of all software components and their location in the file system.

Note: If a path to a component is not listed in the pane, then the component is
located in the <Unified Functional Testinginstallation>/bin folder.

Select Adds the current assembly, project, or software component to theSelected
References list.

Remove Removes the current assembly, project, or software component from the
Selected References list.

Selected
References

A list of all assemblies, projects, or software components to add to your test. The
grid displays the following information:

l Reference Name. The reference name as displayed in the References node in
the Solution Explorer pane.

l Type. The type of reference for the selected reference, project, or assembly.

l Location. The location of the selected reference in the file system. If a location
is not displayed for the reference, it is located in the< Unified Functional
Testing installation>/bin folder.
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Business Process Test/Flow Node (Solution Explorer Pane)

Relevant for: business process tests and flows

The Solution Explorer pane does not display sub-nodes for business process tests or flows. You
can view the components in the document pane.

The following context menu options are available for a business process test or flow:

l Run. Runs the current business process test or flow.

l Remove from Solution. Removes the current business process test or flow from the solution.

You canmaintain your business process tests and flows in both UFT and ALM. For details, see
"Business Process Testing in UFT - Overview" on page 2065 and theHP Business Process
Testing User Guide.

GUI Test Node (Solution Explorer Pane)

Relevant for: GUI tests only

TheGUI test node is available only if your solution contains a GUI test. Some of the nodes
contained within this one, are available only if a relevant resource is associated with the test.

This node can contain the following sub-nodes:

l "Action Node" below

l "External Actions Node" below

l "External Tests Node" on the next page

l "Function Libraries Node" on the next page

l "Recovery Scenarios Node" on the next page

l "Context MenuOptions" on page 489

Action Node
This node contains all of the actions in the GUI test.

Each action node contains a Local node, for its local object repository, and an additional node for
each object repository associated with the action.

The order in which the object repositories are listed determines the priority of the object repository,
the order in which UFT searches the object repositories for an object in a step.

External Actions Node
This node contains all of the external actions called by the GUI test.
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External Tests Node
This node contains all of the external tests called by the GUI test.

Function Libraries Node
This node contains all of the function libraries associated with the test.

The order of the function libraries in the list determines the order in which UFT searches for a
function or subroutine that is called from a step in your test or component.

Recovery Scenarios Node
This node contains all of the recovery scenarios associated with the test.

The order of the recovery scenarios in the list determines the order in which UFT searches for a
relevant scenario when an error occurs during a run session.
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Context Menu Options
The following context menu options are available for GUI Test node:

Node Context Menu Option

Test l Add. Adds action calls or associates resource files with a test. The following
commands are available:

n Add Call to New Action. Opens the "Insert Call to New Action Dialog
Box (GUI Testing)""Insert Call to New Action Dialog Box (GUI Testing)
"described on page 913).

n Add Call to Copy of Action/Add Call to Existing Action. Opens the
"Select Action Dialog Box " (described on page 915).

n Associate Function Library/Associate Recovery Scenario. Opens the
"Open/New <Document>/<Resource> Dialog Box" (described on page
156).

l Run. Opens the "Run Dialog Box" (described on page 651).

l Expand All. Expands all sub-nodes under the <test name> node.

l Collapse All. Collapses all sub-nodes under the <test name> node.

l Remove from Solution. Removes the current test from the solution.

Note: Removing a test from a solution does not delete it from your file
system or ALM project.

l Save As. Opens the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 164), which enables you to save a test with a different
name or in a different location.

l Settings. Opens the "Properties Pane (Test/Business Component Settings
Dialog Box)""Properties Pane (Test/Business Component Settings Dialog
Box)"described on page 590).
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Node Context Menu Option

Action
Note: Many of these options are applicable to external action nodes also.

l Associate Repository with Action. Opens the "Open/New
<Document>/<Resource> Dialog Box" (described on page 156), which adds
the object repository to the selected action.

l Rename. Renames the selected action.

l Delete Action. Deletes the action from the current test.

l Properties. Opens the action's properties in the "General Properties Tab
(Properties Pane - GUI Testing)" of the Properties pane (described on page
390).

Object
Repository Note: These options are applicable for object repositories that are

associated with an action.

l Open Repository. Opens the selected object repository in the "Object
Repository Window" (described on page 1274).

l Remove Repository from List. Removes the selected object repository
from the list of associated object repositories.

l Move Up. Moves the selected object repository up the priority list of
associated repositories.

l Move Down. Moves the selected object repository down the priority list of
associated repositories.

<external
tests list>

l Add to current solution. Adds the selected test to the solution and opens it
in the document pane.

l Remove. Removes the selected test from the calling test.

Function
Libraries

Associate Function Library. Opens the "Open/New
<Document>/<Resource> Dialog Box"(described on page 156) to associate an
existing function library with the current test.

User Guide
Chapter 16: Solution Explorer Pane

HP Unified Functional Testing (12.00) Page 490 of 2274



Node Context Menu Option

<function
libraries list>

l Open Function Library. Opens the selected function library or brings the
document into focus in the document pane.

l Remove Function Library from List. Removes the current function library
from the associated function libraries list.

l Move Up. Moves the current function library up the priority list of associated
function libraries.

l Move Down. Moves the current function library down the priority list of
associated function libraries.

l Properties. Opens the function library's properties in the "General Properties
Tab (Properties Pane - GUI Testing)" of the Properties pane (described on
page 390).

Associated
Recovery
Scenarios

Associate Recovery Scenario. Opens the "Add Recovery Scenario Dialog
Box"(described on page 1120), creates or opens recovery scenarios for your
test.

<recovery
scenario
list>

l Recovery Scenario Properties. Opens the "Recovery Scenario Properties
Dialog Box"(described on page 1124), which displays details about the
current recovery scenario.

l Remove Recovery Scenario from List. Removes the current recovery
scenario from the list of associated recovery scenarios.

l Move Up.Moves the current recovery scenario up the priority list of
associated recovery scenarios.

l Move Down. Moves the current recovery scenario down the priority list of
associated recovery scenarios.

l Enable/Disable Recovery Scenario. Enables or disables the current
recovery scenario.

Each recovery scenario displays an icon to indicate whether it is enabled or
disabled .

GUI Component Node (Solution Explorer Pane)

Relevant for: GUI components only

TheGUI component node is displayed only if your solution contains a keyword GUI component or
a scripted GUI component. Some of the nodes contained within this one, are available only if a
relevant resource is associated with the test.
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This node can contain the following sub-nodes:

l Local Repository node

l Associated Application Area node

This node lists all of the application areas associated with the component. Each application area
node contains the following:

Option Description

<application area
name>

The name of the application area

Function Libraries
node

A list of all function libraries associated with the application area of a
component.

By default, UFT displays theCommon.txt, ActiveX.txt, Visual_
Basic.txt, andWeb.txt function libraries.

<associated shared
repositories>

A list of all shared repositories associated with the application area of
a component.

The following context menu options are available for a GUI component node:

Node Context Menu Option

<component
name>

l Run. Opens the "Run Dialog Box" (described on page 651), enabling you to
run your component.

l Expand All. Expands all sub-nodes contained under the <component
name> node.

l Collapse All. Collapses all sub-nodes contained under the <component
name> node.

l Remove from Solution. Removes the current component from the solution.

l Save As. Opens the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 164), enabling you to save the component with a different
name or in a different location.

l Change Application Area. Opens the "Open/New
<Document>/<Resource> Dialog Box" (described on page 156), enabling
you to change the application area associated with the selected component.

l Settings. Displays the component properties in the "General Properties Tab
(Properties Pane - GUI Testing)" of the Properties pane (described on page
390).
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Node Context Menu Option

Object
repository

l Open Repository. Opens the "Object Repository Window" (described on
page 1274).

l Remove Repository from List. Removes the local object repository from
the list of associated repositories.

l Move Up.Moves the selected object repository up the priority list of local
object repositories.

l Move Down.Moves the selected object repository down the priority list of
local object repositories.

<application
area>

l Expand All. Expands all sub-nodes contained under the <application area>
node.

l Collapse All. Collapses all sub-nodes contained under the <application
area> node.

l Open Associated Function Library.Opens the selected application area to
the Function Libraries pane in order to enable you to open and edit any
associated function libraries.

l Open Associated Object Repository. Opens the selected application area
to the Object Repositories pane in order to enable you to open and edit any
associated object repositories.

l Add Application Area to Solution. Adds the selected application area to a
solution to enable you to edit it.

<associated
function
library
name>

l Open Function Library. Opens the selected function library or brings it into
focus in the document pane.

l Remove Function Library from List. Removes the selected function
library from the list of associated function libraries.

l Move Up.Moves the selected function library up the priority list of
associated function libraries.

l Move Down.Moves the selected function library down the priority list of
associated function libraries.

l Properties. Opens the function library properties in the "General Properties
Tab (Properties Pane - GUI Testing)" of the Properties pane (described on
page 390).
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Application Area Node (Solution Explorer Pane)

Relevant for: GUI components only

The application area node is displayed under theAdditional Items folder. It is displayed only if
your solution contains a separate application area independent of a component. The following user
interface elements are displayed:

UI Element Description

Function libraries
node

A list of all function libraries associated with the application area of a
component.

By default, UFT displays theCommon.txt, ActiveX.txt, Visual_Basic.txt,
andWeb.txt function libraries.

Shared Object
Repositories

A list of all shared repositories associated with the application area of a
component.

Note: Associating a resource file is done in the application area in the document pane. For
details see "How to Create andManage Application Areas" on page 2097.

The following context menu options are available:

Node Context Menu Option

<application
area name>

l Expand All. Expands all sub-nodes contained under the <application area>
node.

l Collapse All. Collapses all sub-nodes contained under the <application
area> node.

l Associate Function Library. Opens the "Function Libraries Pane
(Application Area)" (described on page 2102).

l Associate Object Repository. Opens the "Object Repositories Pane
(Application Area)" (described on page 2105).

l Remove from Solution. Removes the current application area from the
solution.

l Save As. Opens the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 164).
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Node Context Menu Option

<function
library
name>

l Open Function Library. Opens the selected function library or brings it into
focus in the document pane.

l Remove Function Library from List. Removes the selected function library
from the list of associated function libraries.

l Move Up.Moves the selected function library up the priority list of associated
function libraries.

l Move Down.Moves the selected function library down the priority list of
associated function libraries.

l Properties. Opens the function library’s properties in the "General Properties
Tab (Properties Pane - GUI Testing)" of the Properties pane (described on
page 390).

<shared
object
repository>

l Open Repository. Opens the object repository in the "Object Repository
Window" (described on page 1274).

l Remove Repository from List. Removes the selected object repository
from the application area.

l Move Up. Moves the selected object repository up the priority list of
associated shared object repositories.

l Move Down. Moves the selected object repository down the priority list of
associated shared object repositories.
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Troubleshooting and Limitations - Solution Explorer
Pane

Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for the Solution Explorer pane.

Solutions stored on a network location are not locked when opened by UFT.
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Chapter 17: Tasks Pane
Relevant for: GUI tests and components and API testing

This chapter includes:

Concepts 498

Tasks PaneOverview 498

Tasks 499

How to Create andManage TODOComments 499

Reference 501

Tasks Pane User Interface 501
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Concepts

Tasks Pane Overview
Relevant for: GUI tests and components and API testing

The Tasks pane enables you to create andmanage TODO comments for issues that need to be
handled in yourGUI actions, GUI components, function libraries, and user code files.

TODO comments are reminders that are inserted as comments adjacent to the relevant steps in
your testing document. For example, you can provide instructions to someone else during a
handover, or you can remind yourself to do something.

When you create event handlers in an API test, the editor automatically inserts TODO text,
indicating where you need to enter your code.

You can access TODO comments from the Tasks pane or directly from the testing document. For
details, see "Tasks Pane User Interface" on page 501.

If needed, you can export your TODO comments to an XML file or Microsoft Excel.
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Tasks

How to Create and Manage TODO Comments
Relevant for: GUI tests and components and user code files

This task describes the different operations you can perform tomanage TODO comments inGUI
actions, GUI components, function libraries, or user code files.

l To add a new TODO comment, insert a comment adjacent to the relevant step in your
document. A comment can begin with any of the following permutations of the words to do:
To Do, todo, to-do, or TODO.

For details on comments in GUI testing, see "Comments in the Keyword View" on page 922 and
"Comments in VBScript" on page 1017.

l To delete a TODO comment, youmust delete the source line in the document. This removes the
TODO comment from the pane. (To jump to the source line, you can either double-click a
comment in the Tasks pane, or you can highlight the comment in the Tasks pane and then click
the Locate button.)

l To sort by a specific column, click on the column header.

l To rearrange columns, drag a column header to a different location.

l To filter TODO comments, click theShow Tasks from button and select one of the following:

n Solution. Displays all of the TODO comments stored in all of the tests included in the
solution (including closed tests).

n A specific test or component. Displays only the TODO comments that are stored in that
test or component.

n Function Libraries. Displays only the TODO comments that are stored in any function
libraries that are currently open and any function libraries associated to tests in the solution.

l When showing TODO comments from a solution or a specific GUI test, you can show or hide
comments stored in external actions or associated function libraries, by clicking the and/or

toggle buttons, respectively. For more details, see "Tasks Pane User Interface" on page
501.

l To export TODO comments:

a. Click theExport Task List button.

b. In the "Save <Resource>/Save <Document> As Dialog Box" on page 164 (described on
page 164), browse to the required location in the file system.
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c. Enter a file name and specify the file type. You can export the file as XML, CSV, or .xls/.xlsx
(if Excel is installed on the computer).

d. Click Save. The TODO comments are saved to a file in the specified location and in the
specified format.
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Reference

Tasks Pane User Interface
Relevant for: GUI tests and components and user code files

This pane enables you to view and access TODO comments inGUI actions, GUI components,
function libraries, or user code files.

To access In themain UFT window, select View > Tasks.
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Important
information

l This view can display any comment step that begins with any of the following
permutations of the words to do: To Do, todo, to-do, or TODO (not case-
sensitive).

Example: ToDo need to ask Sarah to add design steps

l The text displayed in the Comments view is limited to 260 characters. If the
text exceeds this limit, and you want to view the entire comment, you can jump
to the comment in the testing document by double-clicking the comment line in
the Comments view.

n Local GUI actions andGUI components contained in the solution or in the
selected GUI test.

n Any currently openGUI component.

n Any currently open function library.

n Any function library associated with a selected GUI test or component, or
with any GUI test or component in the solution.

n Any external actions associated with a selected test or with any test in the
solution.

n Any user code file contained in the current solution or in the selected API
test or component.

l By default, this view displays all TODO comments in any GUI actions, GUI
components, and user code files contained in the solution.

Relevant
tasks

"How to Create andManage TODOComments" on page 499

See also "Tasks PaneOverview" on page 498

User interface elements are described below:

Toolbar Buttons

Toolbar
Option Description

<Filter> Enables you to show all of the TODO comments for the solution, or to
filter the display to show TODO comments only for a specific test or
component, or only for function libraries.
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Toolbar
Option Description

Locate Jumps to the comment line in theGUI action, GUI component, function
library, or user code file for the currently selected TODO comment.

Tip: You can also double-click a TODO comment to jump to its
location in the source document.

Note: This option is available only when a line in the Tasks pane is
selected.

Show
Comments in
External
Actions

Toggle button that enables you to display or hide any TODO comments
from external actions, when showing TODO comments from a solution
or test.

Show
Comments in
Function
Libraries
(GUI testing
only)

Toggle button that enables you to display or hide any TODO comments
from function libraries (in addition to other TODO comments displayed
in the pane).

Export Task
List

Saves the TODO comments to an external file, such as a text file.

You can save the list of TODO comments in any of the following
formats:

l XML (Extensible Markup Language)

l XLS/XLSX (Microsoft Excel file)

l CSV (Comma-Separated Values file)

Columns

Column Description

Line The line number of the TODO comment in the source document.

Description The text of the TODO comment.

Source The name of the GUI action or component, or the file name of the function library
or user code file containing the TODO comment.

Test The name of the test containing the TODO comment, or associated with it.
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Context Menu Options

Context
Menu
Option Description

Copy Copies the TODO comment to the Clipboard.

Locate Jumps to the comment line in theGUI action, GUI component, function library, or
user code file for the currently selected TODO comment.

Tip: You can also double-click a TODO comment to jump to its location in
the source document.
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Chapter 18: Toolbox Pane
Relevant for: GUI testing, API testing, and business process testing

This chapter includes:

Concepts 506

Toolbox PaneOverview 506

Tasks 508

How toWork with the Toolbox Pane (GUI Testing) 508

References 510

Toolbox Pane User Interface (GUI Testing) 510

Toolbox Pane User Interface (API Testing) 514

Toolbox Pane User Interface (BPT in UFT) 518
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Concepts

Toolbox Pane Overview
Relevant for: tests, components, actions, function libraries, and flows

The Toolbox pane contains items that you can use to create steps in your testing document.

The items available in the toolbox depend on the document that is currently in focus in the
document pane.

For GUI testing: The Toolbox pane displays the test objects and functions available to the current
action, component, or function library. When aGUI test is in focus, the toolbox is empty.

You can view these items, open them in the object repository, action, or function library in which
they are defined, or use them to create steps in your document.

Drag and drop, or copy and paste, a test object or function into the document pane to add a step
your GUI testing document.

l When you drag and drop a test object into an action or component, a step is inserted with the
default operation for that test object.

l When you drag and drop a function into an action, component, or function library, a call to that
function is inserted.

Examples of usage

l If you drag and drop a button object into an action or component, a step is added using the
button with aClick operation (the default operation for a button object).

l If you drag and drop the function count_items (obj, num) into an action, component, or
function library, a comment and a call to that function are added:

' count_items (obj, num)
count_items

For API Testing: The Toolbox pane provides a collection of standard service activities for
functional testing in areas such as XML, SOAP, Java, JMS, IBMMQWebsphere and HTTP. You
can addmore activities to the Toolbox pane by importingWSDLs or using services from the
repository.

After you import aWeb service, it appears in the Toolbox pane, under the Local Activities > Web
Services node. When you expand theWeb Services node, the Toolbox pane displays the service's
name, port, and operations.

You can also create new custom activities, using the built-in Activity Wizard. For details, see "API
Testing Extensibility" on page 2022.
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Drag and drop an activity from the Toolbox pane into the document pane to add a step to your API
test or action.

For business process testing: The Toolbox pane displays the components and flows that are
available for you to add to the current business process test or flow. Double-click or drag and drop a
component or flow to add it to BPT test or flow open in the document pane.

Toolbox items are listed according to their ALM path, and you can use the search bar to find a
specific component or flow by name.
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Tasks
For details about the API testing Toolbox pane, see "Toolbox Pane User Interface (API Testing) "
on page 514.

For details about the business process testing Toolbox pane, see "Toolbox Pane User Interface
(BPT in UFT)" on page 518.

How to Work with the Toolbox Pane (GUI Testing)
Relevant for: GUI actions, components, and function libraries

For details about the API testing Toolbox pane, see "Toolbox Pane User Interface (API Testing) "
on page 514.

For details about the business process testing Toolbox pane, see "Toolbox Pane User Interface
(BPT in UFT)" on page 518.

This task describes how to work with the Toolbox pane when aGUI action, component, or function
library is in focus in the document pane.

Add a step using a test object
Drag the test object into the action or component. A step with the default operation for that test
object is inserted. Modify the operation and enter arguments for the step, as needed.

You can drag test objects into an action or scripted component in both the Keyword View and the
Editor.

Add a call to a function
Drag the function into the action, component, or function library. A comment and call to that function
are added.

The comment indicates that a call to the function was added to your action or component, and
indicates any necessary arguments. You then provide the arguments for that function.

You can drag functions into an action or scripted component in both the Keyword View and the
Editor.

Open the test object's object repository
Do one of the following:

l Right-click the test object and select Open Resource.

l Double-click the test object.

TheObject Repository window opens and highlights that test object.

Locate a function in an action or function library
Double-click the function you want to locate, or right-click it and select Open Resource. The action
or associated function library containing that function opens in the document pane and points to the
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function.

Copy and paste the selected test object or function
Right-click the test object or function and select Copy Keyword. The test object or function is now
in the clipboard, and you can paste it into a function library, or for tests, into an action in the Editor.

Pasting the test object or function into the document pane has the same result as dragging it in from
the Toolbox pane.
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References

Toolbox Pane User Interface (GUI Testing)
For details about the API testing Toolbox pane, see "Toolbox Pane User Interface (API Testing) "
on page 514. For details about the business process testing Toolbox pane, see "Toolbox Pane User
Interface (BPT in UFT)" on page 518.

Relevant for: GUI actions, components, and function libraries

The Toolbox pane displays test objects and functions available to your document sorted
alphabetically. You can view these items, open them in the object repository, action, or function
library in which they are defined, or use them to add steps to your document (by dragging or copying
the item into the document pane).
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To access 1. Do one of the following:

n Ensure that an action, component, or function library is in focus in the
document pane.

n In the Solution Explorer, select a GUI test or component node, or one of
its child nodes.

2. Select View > Toolbox.

Note: If the Toolbox pane is open, but not in focus, click the Toolbox tab at

the bottom .
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Important
information

l Checkpoint and output value objects are not displayed in this pane, even if
they are included in an associated object repository.

l The Toolbox pane displays the test objects and functions available to the
document that is currently in focus.

l For function libraries, the Toolbox pane displays only the Local Functions
node.

Relevant
tasks

l "How toWork with the Toolbox Pane (GUI Testing) " on page 508

l "How to Select an Item for Your Step " on page 926

l "How to Create aGUI Test Using the Keyword-DrivenMethodology" on page
836

See also For details on dragging and dropping test objects from other locations, see:

l "Object Repository Window" on page 1274

l "How toManageObjects in SharedObject Repositories" on page 1294

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Expand/Collapse sub tree. Expands or collapses the Library Functions,
Local Functions, or Test Objects nodes.

Library
Functions

All functions available to the action or component in associated function
libraries.

l The functions are sorted alphabetically, regardless of the function library in
which they are defined.

l When you click on a function, the file name of its function library is displayed
in the description area at the bottom of the pane.

l When you hover over a function, the file name of its function library is
displayed in a tooltip.

Note:

l If more than one function in the same function library has the same
name, only the first function is displayed (this is the one UFT uses).

l If functions in different function libraries have the same name, they are
displayed in order of the priority of their function libraries.
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UI Elements Description

Local
Functions

All of the functions defined within the action or function library, sorted
alphabetically.

Note: If more than one function has the same name, only the first is
displayed (this is the one UFT uses).

Available for: actions, scripted components, function libraries.

Test Objects All test objects available to the action or component. This includes test objects
located in the local object repository of the action or component, or in shared
object repositories associated with the action or the component's application
area.

l The test objects are grouped by their parent objects and their test object
type, and sorted alphabetically, regardless of the object repository in which
they are stored.

l When you click on a test object, its object repository's file path is displayed
in the description area at the bottom of the pane.

l When you hover over a test object, its object repository's file path is
displayed in a tooltip.

Note: If the same test object exists in more than one object repository,
only one test object is displayed (the one from the object repository with
the highest priority).

<Search
Toolbox>

A text box in which you enter the text by which you want to filter test objects
and functions.

Note: For test objects, the filter applies only to the child node and not to
any of its parent test objects.

Refreshes the Toolbox pane.

Open
Resource

(Context-menu) For test objects, this opens the Object Repository window to
display the resource file in which the test object is stored. You can also activate
this option by double-clicking a test object.

For functions, this opens the containing action or function library in the
document pane, and points to the function.

Copy
Keyword

(Context-menu) Copies the selected keyword to the Clipboard.

The test object or function is now in the clipboard, and you can paste it into an
action, function library, or scripted component in the Editor.
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UI Elements Description

<description> The bottom area of the Toolbox pane displays the name of the selected test
object or function, and the location or resource in which it is stored.

Toolbox Pane User Interface (API Testing)
For details about the GUI testing Toolbox pane, see "Toolbox Pane User Interface (GUI Testing)"
on page 510. For details about the business process testing Toolbox pane, see "Toolbox Pane User
Interface (BPT in UFT)" on page 518.

Relevant for: API actions, tests, and components

The Toolbox pane enables you to view all of the available activities. This includes imported
services and built-in activities such as that you can use in your visual design, such as Replace
String or File Exists.
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This pane is UFT's main window for creating and populating tests.
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To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. Do one of the following:

n Click the Toolbox tab in the bottom of the left pane.

n Select View > Toolbox or click the Toolbox tab in themain UFT
window.

Important
information

l You double-click or drag activities from this pane onto the canvas.

l The activity becomes as test step when it appears in the canvas.

l Click on the down arrows at the top of the pane to access the toolbar
controls.

Relevant tasks "How to Create an API Test" on page 1598

Toolbar Controls
The following toolbar controls elements are included in the Toolbox pane. To see all of the controls,
expand the pane or use the drop downmenus.

Tree
Elements Description

Expand All. Expands all nodes in the Toolbox pane.

Collapse All. Collapses all nodes in the Toolbox pane.

Security Settings. Opens the "Security Settings for Port <Port_Name> Dialog Box"
(described on page 1900). These settings apply to all operations in the port.

Note: Only available when selecting the Port node of aWeb service.

Choose Activities. Opens the Choose Toolbox Activities dialog box, for selecting
activities stored in the File System or ALM repository to add to the Toolbox pane.

This is useful for retrieving activities that you removed from the Toolbox using the
Remove Activities command.
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Tree
Elements Description

Remove Activities. Opens the Remove Toolbox Activities dialog box for selecting
the activities to remove from the Toolbox pane.

Note:

l Removing an activity stored in the repository, only removes it from the
Toolbox pane. It remains, however, in the repository, for future use.

l This command does not apply toStandard Activities.

Update WSDL. Reimports theWSDL from its original location. If the service's
operations changed, this will be reflected in its node in the Toolbox pane.

Note: Only available when selecting the parent node of aWeb service.

Update
WSDL
from

Opens the UpdateWSDL From dialog box, allowing you to update theWSDL from
any location.

Note: Only available when selecting the parent node of aWeb service.

Refresh. Refreshes the activities in their stored location. This is useful when the
WSDL is stored on a shared location andmay have beenmodified by another user.
You can refresh the activities instead of re-importing the service.

Note: Only available when selecting the parent node of aWeb service.

Delete. Deletes the selected entry from the Toolbox pane. This is not available for
built-in activities.

Validate WSI-Compliance. Runs theWSI validator. TheOutput pane shows a
summary of the validation and provides a path to the report.

Note: Only available when selecting the parent node of aWeb service.

Edit Service. Opens the "Add/Edit REST Service Dialog Box" (described on page
1772).

Note: Only available when selecting the parent node of a REST service.
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Tree
Elements Description

Move to Move to. An expandablemenu that enables you tomove an item to the file system
or ALM repository. For details, see "Activity Sharing" on page 1737.

Note: Only available when selecting the parent node of an item in the Local
Activities section.

Filter
box

Filters the Toolbox pane display by the entered text.

Toolbox Activities
The Toolbox pane contains the following sections:

Activity
Category Description

Local
Activities

A tree hierarchy of all imported or items created by the user:Web Services, REST
Services, and .NET Assemblies. For details, see "Local Activities" on page 1733.

Standard
Activities

The built-in activities, by category. For details, see "Standard Activities" on page
1611.

File
System
Activities

Local activities that weremoved to the file system repository using theMove to
option from the right-click menu. For details, see "Activity Sharing" on page 1737.

ALM
Activities

Local activities that weremoved to the ALM repository using theMove to option
from the right-click menu. For details, see "Activity Sharing" on page 1737.

Recently
Used
Items

The activities or operations that were usedmost recently.

Toolbox Pane User Interface (BPT in UFT)
For details about the GUI testing Toolbox pane, see "Toolbox Pane User Interface (GUI Testing)"
on page 510. For details about the API testing Toolbox pane, see "Toolbox Pane User Interface
(API Testing) " on page 514.

Relevant for: business process tests and flows

The Toolbox pane enables you to view all of the available components and flows in the project that
you can use in your business process test or flow.
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This pane is UFT's main window for creating and populating business process tests and flows.

To access 1. Make sure that an business process test or flow is in focus in the
document pane.

2. Do one of the following:

n Click the Toolbox tab in the bottom of the left pane.

n Select View > Toolbox or click the Toolbox button in themain
UFT window.

Important
information

l Components and flows are organized according to their ALM paths.

l Double-click or drag and drop components or flows from this pane into the
test or flow displayed in the document pane.

l When you select an item in the tree, its name is displayed in the description
area at the bottom of the pane.

Relevant
tasks

"How to Create, Maintain, and Run Business Process Testing Tests and
Flows in UFT" on page 2071

User interface elements are described below:

UI Element Description

Expand/Collapse sub tree. Expands or collapses theComponents or Flows
nodes.
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UI Element Description

<Search
Toolbox>

A text box that enables you to filter the components and flows displayed by the
entered text.

Refreshes the content of the toolbox pane with any new components or flows
that were recently created in ALM.
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Chapter 19: UFT Global Options
Relevant for: GUI testing and API testing

This chapter includes:

Concepts 523

Global Options - Overview 523

Reference 524

General Tab (Options Dialog Box) 524

GUI Testing Tab (Options Dialog Box) 535

API Testing Tab (Options Dialog Box) 564

BPT Testing Tab (Options Dialog Box) 570

Coding Tab (Options Dialog Box) 572

Text Editor Tab (Options Dialog Box) 574

Troubleshooting and Limitations - Options Dialog 579
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Concepts

Global Options - Overview
Relevant for: GUI testing and API testing

TheOptions dialog box enables you tomodify the general appearance and behavior of UFT. For
example, you can define the user interface language, set startup options, or modify the font and
colors of code elements in the Editor. The values you set remain in effect for all documents and for
subsequent testing sessions.

Note: TheRestore Factory Defaults button resets all Options dialog box options to their
defaults.

For user interface details, see:

l "General Tab (Options Dialog Box)" on the next page

l "GUI Testing Tab (Options Dialog Box)" on page 535

l "API Testing Tab (Options Dialog Box)" on page 564

l "Coding Tab (Options Dialog Box)" on page 572

l "Text Editor Tab (Options Dialog Box)" on page 574
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Reference

General Tab (Options Dialog Box)
Relevant for: GUI tests and components and API testing

This tab enables you to define general options for UFT.

To access Select Tools > Options > General tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "GUI Testing Tab (Options Dialog Box)" described on page 535

l "API Testing Tab (Options Dialog Box)" (described on page 564

l "Coding Tab (Options Dialog Box)" (described on page 572)

l "Text Editor Tab (Options Dialog Box)" (described on page 574)

This tab includes the following panes:

Startup Options (Options Dialog Box > General Tab) 525

Run Sessions Pane (Options Dialog Box > General Tab) 526

Output Pane (Options Dialog Box > General Tab) 534
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Startup Options (Options Dialog Box > General Tab)

Relevant for: GUI tests and components and API testing

This pane enables you to select what to show when UFT opens.

To access Select Tools > Options > General tab > Startup Options node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

Relevant tasks "How to Start UFT" on page 114

See also l "Start Page" on page 121

l "Add-in Manager Dialog Box" on page 118

User Guide
Chapter 19: UFT Global Options

HP Unified Functional Testing (12.00) Page 525 of 2274



User interface elements are described below:

UI Element Description

Display Add-in
Manager on startup
(GUI testing only)

Opens the Add-in Manager when starting UFT. For details, see the
section on loading add-ins in theHP Unified Functional Testing Add-
ins Guide.

Note: The add-ins selected in the Add-in Manager are relevant
only for GUI tests and components.

Display Start Page on
startup

Displays the Start Page when UFT opens.

Close Start Page after
test loads

Instructs UFT to close the Start Page after a test or business
component is created or opened.

Display warning if
associated add-ins are
not loaded
(GUI testing only)

Displays a warningmessage if you open a test or business
component that requires add-ins that are not currently loaded.

Default test location The default place to save a new test.

Default:C:\My Documents\Unified Functional Testing

Note: Business components are always saved in the Business
Components module in ALM.

Run Sessions Pane (Options Dialog Box > General Tab)

Relevant for: GUI tests and components and API testing

This pane enables you to determine global UFT run settings that are applicable to both GUI testing
and API testing.
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To access Select Tools > Options > General tab > Run Sessions node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

Relevant tasks See the following tasks in theHP RunResults Viewer User Guide:

l How to Open RunResults

l How toManually Submit Defects to ALM

l How to Automatically Submit Defects to an ALM Project

l How to Export Run Results)

See also The following topics in theHP RunResults Viewer User Guide:

l The RunResults Viewer overview

l The section on the Run Results Viewer User Interface

User interface elements are described below:

UI Element Description

View results when
run session ends

Instructs UFT to open the Run Results Viewer and display the results
automatically following the run session.
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UI Element Description

Automatically
export run results
when run session
ends

Instructs UFT to export the run results to the location you specify in the
"Configure Automatic Export of Run Results Dialog Box" (described on
page 531).

Note: If this option is selected, and the Run Results Viewer is not
installed on the computer running the test or component, then the
results are not exported and an error message is displayed at the end
of the run session.

Configure Opens the "Configure Automatic Export of Run Results Dialog Box"
(described on page 531), in which you can define settings that instruct
UFT to automatically export run results to a specific folder in the file
system after a run session. These settings specify the type of report, the
export location in the file system, and whether to export all run results or
only results for failed run sessions.

Stop command
shortcut key

Enables you to define a shortcut key or key combination that stops the
current record (for GUI tests only) or run operation, even if UFT is not in
focus or is in hiddenmode.

Click in the field and then press the required key or key combination on
the keyboard.

The default key combination is CTRL+ALT+F5.

Note: It is important to define a shortcut that is not already defined for
some other operation by application being tested. If this is the case
and:

l you open the applicationmanually before you click Record or
Run, the shortcut defined in the application is applied for its
original purpose.

l you start a record or run session and UFT opens the application
for you, the shortcut you define stops the session.
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UI Element Description

Allow UFT to
continue running
GUI or business
process tests after
disconnecting
from an
RDP computer

Enables GUI or business process tests in UFT to continue running on a
remote computer when a local RDP (Remote Desktop Protocol)-based
client is disconnected from it.

Note: If you want to run UFT in aminimized RDP session, and you
are using an RDP 6.0 or later client, you can enable it by setting a
registry value on the computer that is running the RDP client:

1. If it does not exist, create theRemoteDesktop_
SuppressWhenMinimized registry value (DWORD type) in one
of the following registry paths on the computer that is running the
RDP client:

n For 32-bit operating systems: <HKEY_CURRENT_USER
or HKEY_LOCAL_MACHINE>\Software\Microsoft\Terminal
Server Client

n For 64-bit operating systems: <HKEY_CURRENT_
USER>\Software\Wow6432Node\Microsoft\Terminal Server
Client

2. Set the data for this value to 2.

Youmust restart your remote session in order for this setting to
take effect.

In order to run a test with a disconnected Remote Desktop connection,
ensure the following:

l You remain logged on to the computer running UFT.

l If you want to use automation to run aGUI test and schedule it in the
Windows Task Scheduler, theRun only when user is logged on
option should be selected.
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UI Element Description

l For a UFT server that allows multiple users to log in with the same
username/password: When a user initiates a test run and disconnects
from RDP during the run, the run execution goes to the background
and the user has no access to the execution when they log in again,
because the test is executed in another session.

Note: This feature is not supported in theMicrosoft Windows®
XP environment or the Hyper-V virtualization server.

User Name The user name that the local RDP-based client uses to connect to the
remote computer running UFT, in the following format: <domain>\<user
Name>.

Password The password that the local RDP-based client uses to connect to the
remote computer running UFT.

Check Connection Verifies the connection to the remote computer running UFT, using the
user name and password that you entered in the fields above.
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Configure Automatic Export of Run Results Dialog Box

Relevant for: GUI testing and API testing

This dialog box enables you to define settings that instruct UFT to automatically export run results
to a specific folder in the file system after a run session.

To access 1. Select Tools > Options > General tab > Run Sessions node to open the
Run Sessions pane.

2. Select Automatically export run results when run session ends.

3. Click theConfigure button.
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Important
information

l GUI testing only: Screen capture images are not exported for steps on
Web-based applications. When you export run results containing steps on a
Web application, any screen capture images for those steps are not exported
to the file. This is because forWeb-based applications, the Run Results
Viewer displays the HTML corresponding to the relevant Web page (with
downloaded images) rather than a captured image and thus no image is saved
with the report.

l Manually exporting run results. You can also export run results manually
after a particular run session. For details, see the section on how to export run
results (described in theHP RunResults Viewer User Guide).

l Note for API testing: Not all options are relevant for API tests.

l The settings from this dialog box are saved in a configuration file,
ReportExportOption.xml.

See also "Test Runs Pane (Options Dialog Box > GUI Testing Tab)" on page 539

User interface elements are described below:

UI
Element Description

Step
Details

Themain report type. This includes the entire run results tree. (Default)

l Export type. The file type for the exported results. Possible options:

n HTML (Default)

n PDF

l Export format. The format and amount of detail to include in the exported results.
Possible options:

n Short. Exports a summary line (when available) for each item in the run results
tree. The short report does not include still images associated with the steps in
your run results. (Default)

n Detailed. Exports all available information for each item in the run results tree.
The detailed report includes still images associated with the steps in your run
results. (In the Run Results Viewer, these images are displayed in the
Captured Data pane.) If a bitmap checkpoint step displays expected, actual,
and difference bitmaps, these are also included in the printed report.

n User-defined XSL. Enables you to browse to and select a customized .xsl
file. You can create a customized .xsl file that specifies the information to be
included in the exported report, and the way it should appear. For details, see
the section on the Run Results XML File (described in theHP RunResults
Viewer User Guide).
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UI
Element Description

Screen
Recorder
(GUI
testing
only)

A movie of the run session.

For details on how to configure when and how UFT captures screens of the
application being tested, see "Screen Capture Pane (Options Dialog Box > GUI
Testing Tab)" on page 557.

Data
Table

The runtime version of the data table associated with your ALM configuration. It
displays the values used to run a test or configuration that contains Data Table
parameters, as well as any output values retrieved from a test or an ALM
configuration during a run session.

For details on the GUI testing Data pane, see "Data Pane" on page 221. For details
on theAPI testing Data pane, see "Data Pane User Interface (API Testing)" on page
252.

Log
Tracking
(GUI
testing
only)

A complete list of logmessages that UFT received from your application during the
run session.

For details on what is displayed, see the section on the Run Results Viewer Log
Tracking Pane (described in theHP RunResults Viewer User Guide).

For configuration details, see "Log Tracking" on page 586.

System
Monitor
(GUI
testing
only)

The system counters that aremonitored for a run session displayed in a line graph.

For configuration details, see "Local SystemMonitor" on page 585.

Export
location

The folder in which to store the exported files. Clicking the browse button opens the
Browse For Folder dialog box, enabling you to select a folder on the file system.

If you do not specify a folder, UFT automatically exports the files to the default
folder: <test folder>\<result folder>\Report. (For example,
%ProgramFiles%\HP\UFT\Tests\MyTest\Res9\Report.)

Export
run
results
only if
the run
session
fails

l Select this check box to export run results only for failed run sessions.

l Clear this check box to export all run session results.

UFT stores the export options in theReportExportOption.xml file in the
%AppData%\Roaming\Hewlett-Packard\UFT\ConfigurationUI folder. This file is useful when
using the Test Batch Runner from the command line. For details, see "How to Run a Test Batch
Using theWindows Command Line" on page 648.
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Output Pane (Options Dialog Box > General Tab)

Relevant for: GUI tests and components and API testing

This pane enables you to define display options for the Output pane.

To access Select Tools > Options > General tab > Output Pane node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "Output PaneOverview" on page 380

l "Output Pane User Interface" on page 381

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

Word wrap When selected, wraps the text of eachmessage onto the next line.

Text Font The font in which to display the content of the Output pane.

Size The size in which to display the text in the Output pane.

<preview
area>

Shows an example of the formatting selected in the Text Font andSize drop-
down lists.

User Guide
Chapter 19: UFT Global Options

HP Unified Functional Testing (12.00) Page 534 of 2274



GUI Testing Tab (Options Dialog Box)
Relevant for: GUI tests and components

This tab enables you tomodify global testing options for GUI tests and components.

To access Select Tools > Options > GUI Testing tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

This panemay also contain additional nodes, depending on the add-ins that are
currently loaded with a test or component. For details on add-ins, see the relevant
section in theHP Unified Functional Testing Add-ins Guide.

See also l "General Tab (Options Dialog Box)" on page 524

l "API Testing Tab (Options Dialog Box)" on page 564

l "Coding Tab (Options Dialog Box)" on page 572

l "Text Editor Tab (Options Dialog Box)" on page 574

This tab includes the following panes:

General Pane (Options Dialog Box > GUI Testing Tab) 536

Test Runs Pane (Options Dialog Box > GUI Testing Tab) 539

Text Recognition Pane (Options Dialog Box > GUI Testing Tab) 542

Folders Pane (Options Dialog Box > GUI Testing Tab) 544

Active Screen Pane (Options Dialog Box > GUI Testing Tab) 547

Screen Capture Pane (Options Dialog Box > GUI Testing Tab) 557

Insight Pane (Options Dialog Box > GUI Testing Tab) 561
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General Pane (Options Dialog Box > GUI Testing Tab)

Relevant for: GUI tests and components

This pane contains general options for working with GUI tests and components.

To access Select Tools > Options > GUI Testing tab > General node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

User interface elements are described below:

UI Element Description

Disable
recognition of
virtual objects
while recording
(GUI tests only)

Determines whether the defined virtual objects stored in the Virtual Object
Manager are recognized while recording. For details, see "Virtual Objects"
on page 1384.
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UI Element Description

Automatically
update test and
component steps
when you rename
test objects

Determines whether to automatically update test and component steps
when you rename test objects in the local or shared object repository. For
details, see "Renaming Test Objects " on page 1206.

Note: Applicable only if there are no syntax errors in the test or
component when you rename the test object.

Automatically
parameterize steps
using
(tests only)

Instructs UFT to automatically parameterize the test object method
arguments in any action in which you recorded one or more steps during a
recording session.

You can select to parameterize the steps withGlobal Data Table
Parameters or Test Parameters.

For details, see "Automatically Parameterizing Steps" on page 1539.

Automatically
generate "With"
statements after
recording
(tests only)

Instructs UFT to automatically generateWith statements when you
record. For details, see "How to GenerateWith Statements for Your Test"
on page 978.

Generate "With"
statements for __
or more objects
(tests only)

Indicates theminimum number of identical, consecutive objects for which
you want to apply theWith statement. This setting is used when UFT
automatically generates With statements after recording and when you
select to generateWith statements for an existing action.

Default = 2

For details, see "How to GenerateWith Statements for Your Test" on
page 978.

When pointing at a
window, activate it
after __ tenths of a
second

Specifies the time (in tenths of a second) that UFT waits before it sets the
focus on an application window when using the pointing hand to point to
an object in the application (for example, when using the Object Spy,
checkpoints, Step Generator, Recovery ScenarioWizard, and so forth).

Default = 5
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UI Element Description

Generate Script Generates a UFT script containingmost of the current global testing
options.

When you click theGenerate Script button, a Save As dialog box opens,
enabling you to specify the name and file system location to store the
generated file.

You can use some or all of the script lines from this generated script in a
test. This can be useful, for example, if you want to create an initialization
script that opens UFT with a pre-defined set of options applied.

For details, see "UFT Automation Scripts" on page 1155 and theUFT
Object Model Reference (Help > HP Unified Functional Testing Help
> Object Model Reference for GUITesting).

Sample Generated Script for Global Testing Options

Relevant for: GUI tests and components

The UFT script below shows a sample script that was generated using the Generate Script button
in the Options dialog box. The script was generated with theWeb and Java Add-ins loaded.

Dim App 'As Application
Set App = CreateObject("QuickTest.Application")
App.Launch
App.Visible = True
App.Options.DisableVORecognition = False
App.Options.AutoGenerateWith = False
App.Options.WithGenerationLevel = 2
App.Options.TimeToActivateWinAfterPoint = 500
App.Options.SaveLoadAndMonitorData = True
App.Options.Run.RunMode = "Normal"
App.Options.Run.ViewResults = True
App.Options.Run.StepExecutionDelay = 0
App.Options.Run.MovieCaptureForTestResults = "Never"
App.Options.Web.AddToPageLoadTime = 10
App.Options.Web.RecordCoordinates = False
App.Options.Web.RecordMouseDownAndUpAsClick = False
App.Options.Web.RecordAllNavigations = False
App.Options.Web.RecordByWinMouseEvents = ""
App.Options.Web.BrowserCleanup = False
App.Options.Web.RunOnlyClick = False
App.Options.Web.RunMouseByEvents = True
App.Options.Web.RunUsingSourceIndex = True
App.Options.Web.EnableBrowserResize = True
App.Options.Web.PageCreationMode = "URL"
App.Options.Web.CreatePageUsingUserData = "Get Post"
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App.Options.Web.CreatePageUsingNonUserData = ""
App.Options.Web.CreatePageUsingAdditionalInfo = True
App.Options.Web.FrameCreationMode = "URL"
App.Options.Web.CreateFrameUsingUserData = "Get Post"
App.Options.Web.CreateFrameUsingNonUserData = ""
App.Options.Web.CreateFrameUsingAdditionalInfo = True
App.Options.Java.RecordListByIndex = False
App.Options.Java.RecordComboByIndex = False
App.Options.Java.RecordTreeByIndex = False
App.Options.Java.RecordTabByIndex = False
App.Options.Java.AWTEventModel = "Auto"
App.Options.Java.AnalogTableRecording = False
App.Options.Java.TreePathSeparator = ";"
App.Options.Java.TableExternalEditors = ""
App.Options.Java.TableInternalEditors = ""
App.Options.WindowsApps.AttachedTextRadius = 35
App.Options.WindowsApps.AttachedTextArea = "TopLeft"
App.Options.WindowsApps.ExpandMenuToRetrieveProperties = True
App.Options.WindowsApps.NonUniqueListItemRecordMode = "ByName"
App.Options.WindowsApps.RecordOwnerDrawnButtonAs = "PushButtons"
App.Options.WindowsApps.ForceEnumChildWindows = 0
App.Options.WindowsApps.ClickEditBeforeSetText = 0
App.Options.WindowsApps.VerifyMenuInitEvent = 0
App.Options.TextRecognitionOrder = "APIThenOCR"
App.Options.TextRecognitionBlockType = "Multiple"
App.Options.TextRecognitionLanguages = "English"
App.Options.DisplayKeywordView = True
App.Folders.RemoveAll
App.Folders.Add("C:\Temp\MyTests")

Test Runs Pane (Options Dialog Box > GUI Testing Tab)

Relevant for: GUI tests only

This pane enables you to determine how UFT runs GUI tests and components. For additional run
options, see "Run Sessions Pane (Options Dialog Box > General Tab)" on page 526.
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To access Select Tools > Options > GUI Testing tab > Test Runs node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

Relevant tasks "How to Run an API Test" on page 643

See also l "Running API Tests - Overview " on page 636

l "Run Dialog Box" on page 651

User Guide
Chapter 19: UFT Global Options

HP Unified Functional Testing (12.00) Page 540 of 2274



User interface elements are described below:

UI Element Description

Run mode Instructs UFT how to run your test or component:

l Normal (displays execution marker) (default). Runs your test or
component with the execution arrow to the left of each step or statement as it
is performed. If the test contains multiple actions, the tree in the Keyword
View Item column expands to display the steps, and the Editor displays the
script, of the currently running action.

Delay each step execution by. You can specify the time inmilliseconds that
UFT should wait before running each consecutive step (up to amaximum of
10000 ms.).

TheNormal runmode option requires more system resources than the Fast
option, described below.

Note: Youmust haveMicrosoft Script Debugger installed to enable this
mode. For details, see theHP Unified Functional Testing Installation
Guide.

l Fast. Runs your test or component without the execution arrow to the left of
the Keyword View or Editor (for tests) and does not expand the item tree or
display the script of each action as it runs. This option requires fewer system
resources.

Note:When running a test set from ALM, tests or components are
automatically run in Fastmode, even if Normalmode is selected.

Submit a
defect to
ALM for
each failed
step

Instructs UFT to automatically submit a defect to ALM for each failed step in your
test. This option is available only when you are connected to an ALM project. For
details, see the section on how to automatically submit defects to an ALM project
in theHP RunResults Viewer User Guide.

Allow other
HP
products to
run tests
and
components

Enables other HP products such as ALM and Test Batch Runner to run tests and
components on this computer.

Note: If theWindows Firewall is turned on on your computer, and you
want to enable business process tests to be run on your computer from a
remote ALM client, then youmust alsomanually create a firewall exception
for the bp_exec_agent.exe remote agent. For details, see "How to Enable
the BPT Remote Agent" on page 733.

User Guide
Chapter 19: UFT Global Options

HP Unified Functional Testing (12.00) Page 541 of 2274



Text Recognition Pane (Options Dialog Box > GUI Testing Tab)

Relevant for: GUI tests and components

This pane enables you to configure how UFT identifies text in your application. You can use this
pane tomodify the default text capturemechanism, OCR (optical character recognition)
mechanismmode, and the language dictionaries the OCR mechanism uses to identify text.

To access Select Tools > Options > GUI Testing tab > Text Recognition node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

Related tasks l "How to Configure Text Recognition Settings" on page 1429

l "How to Insert a Checkpoint in a GUI Test or Component" on page 1419

l "How to Create or Modify anOutput Value Step" on page 1494

See also l "Text Recognition Overview" on page 1408

l "Guidelines for Text Recognition" on page 1409

l "Checking Text in an Image - Use-Case Scenario" on page 1414

l "Checking Text Overview " on page 1408
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User interface elements are described below:

UI Element Description

Use text
recognition
mechanisms
in this order

Specifies the text recognitionmechanism that UFT uses when capturing text.

Possible values:

l First Windows API then OCR. (Default) Instructs UFT to first try to retrieve
text directly from the object using theWindows API-basedmechanism. If no
text can be retrieved (for example, because the text is part of a picture), UFT
tries to retrieve text using the OCR (optical character recognition)
mechanism. (This setting is highly recommended when working with CJK
(Chinese, Japanese, Korean) languages.)

l First OCR then Windows API. Instructs UFT to first try to retrieve text from
the object using the OCR mechanism. If no text can be retrieved, then UFT
uses its Windows API-basedmechanism to retrieve text from the object.

l Use Only Windows API. Instructs UFT to use only theWindows API-based
mechanism (and not the OCR mechanism) to retrieve text from the object.

l Use Only OCR. Instructs UFT to use only the OCR mechanism (and not the
Windows API-basedmechanism) to retrieve text from the object. (Required
when working withWindows Vista; the only option available when working
withWindows 7 andWindows Server 2008 R2.)

For details, see "Notes andGuidelines" on the next page.

Single text
block mode

Select this radio button if the text on the object is uniform in font, size, color, and
background. For example:

The single text block mode instructs the OCR mechanism to focus on the area
and treat it as a single text block. This is especially useful when trying to capture
text on small objects or in a small text area.

Multiple text
block mode

Select this radio button only if the text on the object comprises different fonts,
font sizes, colors, and/or backgrounds. For example:

Themultiple text block mode instructs the OCR mechanism to handle each text
area in the object that has a different background font and size. TheOCR
mechanism decides where to divide the text blocks according to an internal
algorithm.
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UI Element Description

Available
languages

Lists all of the language dictionaries that the OCR mechanism can potentially
use when retrieving text from the object.

To specify the language dictionaries used by the OCR mechanism:Move
a language to theSupported languages list box by selecting a language and
clicking the right arrow button (>).

Supported
languages

Lists the language dictionaries that the OCR mechanism uses when capturing
text. TheSupported languages list box can contain either:

l OneCJK (Chinese, Japanese, Korean) language.
(Note:By default, English is also supported when capturing text in CJK
languages.)

l One ormore non-CJK languages.

To remove a language dictionary from the Supported languages list:
Select the language and click the left arrow button (<).

Notes and Guidelines

l TheWindows API text recognitionmechanism is provided as is. If it does not work as you
expect, change the option to useOCR. (AlthoughOCR accuracy is usually very high, keep in
mind that as with all OCR technologies, the OCR mechanism does not guarantee 100%
accuracy.) For details, see "Guidelines for Text Recognition" on page 1409.

l Guidelines for Windows Vista, Windows 7, Server 2008, Server 2008 R2, Windows 8,
and Windows Server 2012 Users. These operating systems do not support theWindows API
text recognitionmechanism. Therefore, only theUse only OCR option is available when UFT is
installed on these operating systems.

Folders Pane (Options Dialog Box > GUI Testing Tab)

Relevant for: GUI tests and components

This pane enables you to enter the folders (search paths) in which UFT searches for tests,
components, actions, or resource files that are specified as relative paths in dialog boxes and
steps.

For example, suppose you add the folder in which all of your tests are stored to the folders list. If
you later insert a copy of an action to a test, you only have to enter the name of the test containing
the action you want to insert in the Insert Copy of Action dialog box. UFT searches for the test's
path in the folders you specified in the Folders pane. For components and application areas, all files
must be stored in an ALM path.
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To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Options > GUI Testing tab > Folders node.
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Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l The current test or component is listed in theSearch list by default. It cannot
be deleted.

l If you are working with the Resources and Dependencies model with Quality
Center 10.00 or ALM, specify an absolute Quality Center or ALM path. For
details, see "Relative Paths and ALM" on page 758.

l You can use aPathFinder.Locate statement in your test to retrieve the
complete path that UFT uses for a specified relative path based on the folders
specified in the Folders pane. For details, see theHP UFT Object Model
Reference for GUI Testing.

l UFT searches for the specified test, component, action, or file in the order in
which the folders are displayed in the search list. If the same file name exists
in more than one folder, UFT uses the first instance it finds.

See also l For details on relative or absolute paths, see "Relative Paths in UFT for GUI
Testing" on page 130.

User interface elements are described below:

UI Element Description

Search list Indicates the folders in which UFT searches for tests, components, actions, or
files. If you define folders here, you do not need to designate the full path of a
test, component, action, or file in other dialog boxes or call statements. The
order of the search paths in the list determines the order in which UFT
searches for a specified action or file.

Adds a new folder to the search list.

Tip:

l To add an ALM path when connected to ALM, click this button. UFT
adds [ALM], and displays a browse button so that you can locate the
ALM path.

l When not connected to ALM, hold the SHIFT key and click this button.
UFT adds [ALM], and you enter the path. You can also type the entire
ALM pathmanually. If you do, youmust add a space after [ALM]. For
example: [ALM] Subject\Tests.

l UFT searches ALM project folders only when you are connected to the
corresponding ALM project.
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UI Element Description

Deletes the selected folder from the search list.

Moves the selected folder up in the list.

Moves the selected folder down in the list.

Remind me to
use relative
paths when
specifying a
path to a
resource

When associating a resource, you can choose to be prompted to use a relative
path. For details, see "Relative Paths in UFT for GUI Testing" on page 130.

Note:WhenUFT is connected to a Quality Center 10.00 or ALM project,
a reminder is displayed only if you select a path in the file system or in a
Quality Center 9.2 project.

Active Screen Pane (Options Dialog Box > GUI Testing Tab)

Relevant for: GUI tests only

This pane enables you to specify which information UFT saves and displays in the Active Screen
while recording and running tests.

Themore information saved in the Active Screen, the easier it is to edit the test after it is recorded.
However, more information saved in the Active Screen adds to the recording time and disk space
required. This is especially critical withWindows-based add-ins, as they require more disk space to
save Active Screen data.
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To access Select Tools > Options > GUI Testing tab > Active Screen node.

Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l When you are recording on anMDI (Multiple Document Interface) application,
the Active Screen does not capture information for non-active child frames.

Related
tasks

l "How toModify the Active Screen Settings" on page 198

l "How to Use the Active Screen in Your Test" on page 197

l "How to Update Test Object Descriptions, Checkpoints, or Output Values, or
Active Screen Captures" on page 1088

See also l "Custom Active Screen Capture Settings Dialog Box" on page 551

l "Active ScreenOverview" on page 194

The Active Screen pane contains the following key areas:

l "Capture Level Area" on the next page

l "Appearance (Web) Area" on page 550
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Capture Level Area

UI
Element Description

Capture
level

Specifies the objects for which UFT stores data in the Active Screen.

Use the slider to select one of the following options:

l Complete. Captures all properties of all objects in the application's active
window/dialog box/Web page in the Active Screen of each step. This level saves
Web pages after any dynamic changes and saves Active Screen files in a
compressed format.

l Partial. Captures all properties of all objects in the application's active
window/dialog box/Web page in the Active Screen of the first step performed in an
application's window, plus all properties of the recorded object in subsequent
steps in the samewindow. This level saves Web pages after any dynamic
changes and saves Active Screen files in a compressed format.

l Minimum (default). Captures properties only for the recorded object and its
parent in the Active Screen of each step. This level saves the original source
HTML of all Web pages (prior to dynamic changes) and saves Active Screen files
in a compressed format.

l None. Disables capturing of Active Screen files for all applications andWeb
pages.

Custom
Level

Enables you to specify custom Active Screen options. For details, see "Custom
Active Screen Capture Settings Dialog Box" on page 551.

Default
Level

Restores the capture level settings to the predefined default level (Partial).
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Appearance (Web) Area

UI Element Description

Appearance
(Web)

Enables you tomodify how UFT displays capturedWeb pages in the Active
Screen.

Note:

l UFT loads ActiveX controls or Java applets to the Active Screen in view-
only mode. You cannot perform operations or retrieve additional
information on the loaded ActiveX or Java objects. To perform operations
on these items from the Active Screen, youmust load the relevant add-in
and then record directly on the ActiveX or Java object.

l ActiveX controls or Java applets that are loaded to the Active Screenmay
not work exactly as they do in the application. In some cases, this may
cause unexpected behavior, depending on the implementation of the
specific controls or applets that are loaded.

Run scripts Specifies whether UFT runs scripts when a page is loaded in the Active Screen,
according to one of the following options:

l Enabled. Runs scripts whenever loading a page in the Active Screen.

l Automatic. Runs scripts as needed, according to the page that is displayed.

l Disabled. Prevents scripts from running when loading a page in the Active
Screen.

Note:

This option refers only to scripts that run automatically when the page
loaded. It does not enable you to activate scripts in the Active Screen by
performing an operation on the screen.

When working with theWeb 2.0 ASPAjax Add-in, this option is disabled by
default.

Load
ActiveX
controls

Instructs UFT to load ActiveX controls from your browser page to the Active
Screen, so that for each step you can preview how the page is actually displayed
in the application. If this option is cleared, a default ActiveX image is displayed in
the Active Screen for all ActiveX control objects.

Load
images

Instructs UFT to load images from your browser page to the Active Screen.
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UI Element Description

Load Java
applets

Instructs UFT to load Java applets from your browser page to the Active Screen,
so that for each step you can preview how the page is actually displayed in the
application. If this option is cleared, a default Java image is displayed in the
Active Screen for all Java applet objects.

Custom Active Screen Capture Settings Dialog Box

Relevant for: GUI tests only

This dialog box enables you to customize how UFT captures and saves Active Screen information.

When you apply custom Active Screen settings, you override the capture-level setting in the Active
Screen pane with all of the settings in the Custom Active Screen Capture Settings dialog box.

To access Select Tools > Options > GUI Testing tab > Active Screen node > Custom
Level.
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Important
information

l The Custom Active Screen Capture Settings dialog box may also contain
options applicable to any UFT add-ins installed on your computer.

l The default settings in the Custom Active Screen Capture Settings dialog box
do not reflect the selected capture-level setting in the Active Screen pane of
the Options dialog box. If you want to customize only specific settings, use the
Reset to option to ensure that all other settings are using the capture-level
setting you prefer and thenmodify the specific settings you need.

Related
tasks

l You can specify whether to save screen captures of the Active Screen using
theSave Active Screen files option in the Save dialog box. See "Save
<Resource>/Save <Document> As Dialog Box" on page 164.

l You can use theUpdate Run Mode option tomodify the amount of
information saved in the Active Screen after youmodify the Active Screen
capture settings. See "Update Options Tab (Update Run Dialog Box)" on page
1107.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

<settings
box>

Enables you to select the specific setting options that determine how UFT
captures and saves Active Screen information. The Settings box may also
contain options applicable to UFT add-ins installed on your computer.

For details, see:

l "General" on the next page

l "Capture Level - General" on the next page

l "Capture Level - Java Applications or Applets" on the next page

l "Capture Level - SAP GUI forWindows Applications" on page 554

l "Capture Level - Oracle Applications" on page 555

l "Capture Level -Windows Applications " on page 555

l "Capture Level - Terminal Emulator Applications" on page 556

l "Web" on page 556

Description Provides a description of the option selected in the Settings box.

Reset
custom
settings

Enables you to reset the custom settings to one of the predefined levels provided
with UFT (Complete, Partial,Minimum, orNone) by choosing a level from the
Reset to list and clicking theReset button. For details on the available capture
levels, see "Capture Level - General" on the next page.
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General
By selecting aCaptured files storage option, you can specify the type of compression UFT uses
for storing captured Active Screen information:

l Simple. Instructs UFT to save Active Screen captures in standard uncompressed file formats
(for example, .html and .png).

l Compressed. Instructs UFT to save Active Screen captures in a compressed (zipped) file
format. Using this option saves disk space, but it may affect the time it takes to load images in
the Active Screen. This is the default option.

Capture Level - General
The Custom Active Screen Capture Settings dialog box enables you to customize how UFT
captures and saves Active Screen information.

Capture level options are available for Java applets or applications, SAP GUI forWindows
applications, Oracle applications, Windows-based applications, and Terminal Emulator
applications. The options available in the Custom Active Screen Capture Settings dialog box
depend on the add-ins that are installed.

By selecting aCapture level option, you can specify which properties are captured for each object
in an application when it is captured for the Active Screen.

Depending on your testing requirements, you can choose between different levels of Active Screen
capture. However, you should take into consideration that the less information captured for the
Active Screen, the better the performance.

For example, if you select theComplete capture level option, you can add checkpoints on every
test object displayed in any Active Screen capture after recording, but it takes more time and use
more disk space to record a single operation. SelectingPartial enables UFT to record faster and
use less disk space, but theremay be limitations on the operations you can perform from the Active
Screen after recording.

The following sections describe the capture level options available for different environments.

Capture Level - Java Applications or Applets
The followingCapture level options are available for Java applications or Java applets:

l Complete. Instructs UFT to save all identification properties of all objects in the application or
applet's open window/dialog box in the Active Screen of each step.

l Partial. (Default) Instructs UFT to save all identification properties of all objects in the
application or applet's open window/dialog box in the Active Screen of the first step performed in
that window, plus all properties of the recorded object only, in subsequent steps in the same
window.

l Minimum. Instructs UFT to save all identification properties for the recorded object plus all
identification properties for the parent objects in the recording hierarchy.

l None. Disables capture of Active Screen files for Java applications or Java applets.
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When theComplete orMinimum capture level is selected, the following setting in the Custom
Active Screen Capture Settings dialog box is also relevant for Java applications or Java applets:

Disable capture of the following objects. Prevents UFT from capturing the data of steps
performed on other objects for the selected test object types in the Active Screen. These objects
are visible in the Active Screen as images only.

By default, JavaObject and JavaMenu are selected (meaning that identification properties are not
captured for these objects).

Note: If you record on a specific test object, its identification properties are captured even if the
Disable capture of the following objects option is selected.

Capture Level - SAP GUI for Windows Applications
The followingCapture level options are available for SAP GUI forWindows applications:

l Complete. Instructs UFT to save the property values of all objects in the application's open
window/dialog box in the Active Screen of each step.

This optionmakes it possible for you to insert checkpoints and perform other operations on any
object in the window/dialog box from the Active Screen of any step. However, it may result in
longer recording times and require more disk space.

Note: The properties for inner objects of some container objects (such as table cells or tree
nodes) are not captured in the Active Screen. Use the appropriate SAPGuiTable or
SAPGuiTreemethods to access information for these objects. For details, see the SAP
GUI forWindows section of theHP UFT Object Model Reference for GUI Testing.

l Partial. (Default) Instructs UFT to save properties of the recorded object and of its parent in the
Active Screen of each step.

This option enables speedy recording and requires relatively little disk space. However, you can
insert checkpoints and perform other operations only on the recorded object and on the
window/dialog box itself. You cannot perform operations on the other objects displayed in the
Active Screen.

l None. Disables the capture of Active Screen files for SAP GUI forWindows applications.

This option allows extremely fast recording and requires only minimum disk space. However,
you cannot perform post-recording test editing (such as inserting checkpoints, output values,
and so forth) from the Active Screen.

Notes:

n The property values of the objects in the Active Screen reflect the values at the time that
the steps are added to your test (when information is sent to the SAP server). These
values may potentially be different from the property values at the time that a particular
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step is performed.

n The Active Screen captures only the visible part of the SAP GUI forWindows
applications window at the time that the step is added to the test.

Capture Level - Oracle Applications
The followingCapture level options are available for Oracle applications:

l Complete. Instructs UFT to save all identification properties of all objects in the application's
open window/dialog box in the Active Screen of each step.

l Partial. (Default) Instructs UFT to save all identification properties of all objects in the
application's open window/dialog box in the Active Screen of the first step performed in that
window, plus all identification properties of the recorded object only, in subsequent steps in the
samewindow.

l Minimum. Instructs UFT to save all identification properties for the recorded object plus all
identification properties for the parent objects in the recording hierarchy.

l None. Disables capture of Active Screen files for Oracle applications.

Capture Level - Windows Applications
The followingCapture level options are available forWindows applications.

l Complete. Instructs UFT to save all properties of all objects in the application's open
window/dialog box in the Active Screen of each step.

This optionmakes it possible for you to insert checkpoints and perform other operations on any
object in the window/dialog box, from the Active Screen for any step.

l Partial. (Default) Instructs UFT to save all properties of all objects in the application's open
window/dialog box in the Active Screen of the first step performed in an application's window,
plus all properties of the recorded object in subsequent steps in the samewindow.

This optionmakes it possible for you to insert checkpoints and perform other operations on any
object displayed in the Active Screen, while conserving recording time and disk space. Note that
with this option the Active Screen informationmay not be fully updated for subsequent steps.

l Minimum. Instructs UFT to save properties only for the recorded object and its parent in the
Active Screen of each step.

This option enables speedy recording and requires relatively little disk space. However, you can
insert checkpoints and perform other operations only on the recorded object and on the
window/dialog box itself. You cannot perform operations on the other objects displayed in the
Active Screen.
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l None. Disables capture of Active Screen files forWindows applications.

This option allows extremely fast recording and requires only aminimum of disk space.
However, you cannot perform post-recording test editing from the Active Screen.

Capture Level - Terminal Emulator Applications
The followingCapture level options are available for applications run on terminal emulators:

l Complete. Instructs UFT to save all properties of all objects in the application's open
window/dialog box in the Active Screen of each step.

This optionmakes it possible for you to insert checkpoints and perform other operations on any
object in the window/dialog box, from the Active Screen for any step.

l None. Disables capture of Active Screen files for Terminal Emulator applications.

Web
You can specify whether UFT captures Web pages for the Active Screen.

l Disable Active Screen capture. Disables the screen capture of all steps in the Active Screen.

If you do not select this option, you can also delete Active Screen information after you have
finished editing your test by selectingSave As, and clearing theSave Active Screen files
check box. For details, see "Save <Resource>/Save <Document> As Dialog Box" on page 164.

l Capture original HTML source. Captures the HTML source of Web pages as they appear
originally, before any scripts are run. Deselecting this option instructs UFT to capture the HTML
source of Web pages after any dynamic changes have beenmade to the HTML source (for
example, by scripts running automatically when the page is loaded).
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Screen Capture Pane (Options Dialog Box > GUI Testing Tab)

Relevant for GUI tests and components

This pane enables you to control how UFT captures images andmovies of the application being
tested.

To access Select Tools > Options > GUI Testing tab > Screen Capture node.

Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l Vista/Windows 7/Windows 8 users: In addition to the options described
below, if yourWindows color scheme (or theme) is set toAero, UFT
automatically sets it toVista/Windows 7 Basicwhile capturingmovies of a
run session tomaximize performance. The color scheme is returned to its
previous settings when the run session ends.

For movies, see "Savemovie to results" on page 559, below.

See also How to Play a Screen Recorder Movie in theMicro Player (described in the
HP RunResults Viewer User Guide)
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This pane contains the following user interface elements:

UI Element Description

Save still
image captures
to results

Instructs UFT when to capture still images of the application during the run
session and save them in the run results. When images are available in the
run results, UFT displays them in the Captured Data pane of the Run Results
Viewer.

l Always. Captures images for all steps in the run.

l For errors. Captures images only for failed steps. This is the default
setting.

l For errors and warnings. Captures images only for steps that return a
failed or warning status.

Note: This setting also affects the availability of other information
displayed in the Captured Data pane of the Run Results Viewer, such
as:

l XML checkpoint and output value result details

l Bitmap checkpoint images (expected, actual, and, if relevant,
difference)
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UI Element Description

Save movie to
results

Instructs UFT when to capture amovie of the application during the run
session and save it in the run results. Whenmovies are available in the run
results, UFT displays them in the Screen Recorder tab in the Run Results
Viewer.

This option is disabled by default.

Select the check box to enable this option and then select an option from the
list:

l Always. Captures amovie of all steps in the run.

l For errors. Captures movies only for failed steps.

l For errors and warnings. Captures movies only for steps that return a
failed or warning status.

Important:

l Recording only on primary monitor: The Screen Recorder records a
movie of the operations performed on your primary monitor. Therefore, if
you are working with multiple monitors, make sure that your application is
fully visible on your primary monitor when recording or running a test or
component.

l Recording entire desktop. The Screen Recorder saves amovie of your
entire desktop. You can prevent the UFT window from partially obscuring
your application while capturing themovie by minimizing UFT during the
run session. For details on how tominimize UFT during run sessions, see
"UFTWindow Layout Customization in Different Modes" on page 183.

l Vista Users. For best results when working with Microsoft Windows
Vista, set theWindow's display settings to the Classic Windows theme.

l Unicode Characters in Test and Component Names. The HP Screen
Recorder does not support Unicode. When you save a test or component
using a name containing Unicode characters, and the run results contain a
Screen Recorder movie, themovie is not saved.

Save movie
segment up
to __ KB prior
to each error
and warning

Instructs UFT to savemovie segments for each error (or warning). Each
segment contains the specified number of kilobytes of themovie prior to the
failed (or warning) step. You can enter any value from 400 (0.4MB) to
2097152 (2 GB). If more than one segment is captured for a run session, UFT
stores a single movie comprised of all the relevant movie segments.

Note: This option is enabled only when For errors or For errors and
warnings is selected in theSave movie to results option.
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UI Element Description

Save movie of
entire run

Instructs UFT to save amovie of the entire run if at least one error (or
warning) occurs.

Note: This option is enabled only when For errors or For errors and
warnings is selected in theSave movie to results option.

Record sound Instructs UFT to save sound with themovie of your application.

Set plain
wallpaper

Sets the wallpaper of your desktop to a solid blue color for the duration of the
run session.

Do not show
window
contents when
dragging
windows

Instructs Windows to display only the outline of a window, without its
contents, whenever the window is dragged during the run session.

Install/Uninstall
button

Installs or uninstalls the Screen Recorder Capture Driver. The Screen
Recorder Capture Driver improves the performance of the Screen Recorder
duringmovie recording.

Note: The Screen Recorder Capture Driver cannot be installed or
uninstalled when running UFT via a remote connection.
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Insight Pane (Options Dialog Box > GUI Testing Tab)

Relevant for: GUI tests and components

This pane enables you to define options that customize how UFT handles Insight test objects when
creating test object, and during record and run sessions.

To access Select Tools > Options > GUI Testing tab > Insight node.
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Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l UFT captures additional snapshots of the application together with the Insight
test objects that it creates. You can use these additional snapshots to adjust
the test object images that identify the controls.

The number of snapshots saved with a test object, as well as the test object
imagemargin, affect the disk space required by your object repository. These
settings can also affect UFT performance when recording and running Insight
steps.

n Changes made in this pane affect only new snapshots and not previously
saved ones.

n In the object repository, you can delete all of the snapshots stored with the
Insight test objects after you finalize the test object images and verify that
they enable correct object identification in all relevant scenarios.

Relevant
tasks

l "How to Add an Insight Object to the Object Repository" on page 1214

l "How to Record a Test or Component Using Insight Recording" on page 860

See also "Identifying Objects Using Insight" on page 1176

User interface elements are described below:

UI Element Description

When recording a test object

Save the clicked
coordinates as the
test object's
ClickPoint

Instructs UFT to define the ClickPoint of each Insight test object added
to the object repository during a recording session, according to the
location that the user clicks. The coordinates of the first click on the
object are used.

l You canmodify a test object's ClickPoint manually in the object
repository.

If this option is cleared, the ClickPoint for objects learned by
recording is set to Center.

l Modifying this option does not affect test objects previously added to
the object repository. It affects only objects learned in subsequent
recording sessions.

When running a step

Display mouse
operations

Instructs UFT to show mouse drag operations and clicks when running
steps on Insight test objects.
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UI Element Description

When editing

Show test object
image in steps

Instructs UFT to display Insight test object images in steps in the Editor.

If cleared, UFT displays the test object names instead.

Display Select
Learn Mode dialog
box

Instructs UFT to open the "Select LearnMode Dialog Box" (described

on page 1248) when you click theAdd Insight Object to Local or

Add Insight Object button to add an Insight object to an object
repository.

When taking snapshots

Limit test object
image margin in
snapshot

Instructs UFT to limit the snapshot size when creating a new Insight
test object by including only a limited area of the screen around the
control in the snapshot. Specify themargin size in the "Maximum pixels
around the image" box.

If cleared, UFT includes the whole screen in the snapshot.

Note: Relevant when adding a new Insight test object (recording or
learning).

Maximum pixels
around the image

Themaximum size of the area around the control to include in the
snapshot. UFT includes up to the specified number of pixels on all sides
of the control.

Maximum value: 1000.

Note: Available only when the "Limit test object imagemargin in
snapshot" option is selected.
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UI Element Description

Maximum number
of snapshots to
save when
recording a test
object

Instructs UFT not to savemore than the specified number of snapshots
when recording a test object.

Separately specify the number of snapshots to saveBefore the
selected image andAfter the selected image.

UFT selects the image that seems most appropriate to use for the object
description, and then saves additional snapshots taken during the
recording session, before or after the selected image, as available.

The total number of snapshots savedmay include up to themaximum
number of snapshots you specified to save before and after the selected
image, and onemore snapshot for the test object image itself.

Maximum value: 10 before and 10 after.

Note: Relevant during a recording session.

API Testing Tab (Options Dialog Box)
Relevant for: API testing

The options in the API Testing tab of the Options dialog box enable you to customize your work
environment when working with APIUFT tests or components. For example, you can define relative
or absolute paths for saved files, repository locations, and auto values.

To access Select Tools > Options > API Testing tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "General Tab (Options Dialog Box)" on page 524

l "GUI Testing Tab (Options Dialog Box)" on page 535

l "Coding Tab (Options Dialog Box)" on page 572

l "Text Editor Tab (Options Dialog Box)" on page 574

This tab includes the following panes:

General Pane (Options Dialog Box > API Testing Tab) 565

Auto Values Pane (Options Dialog Box > API Testing Tab) 567

SAP Connections Pane (Options Dialog Box > API Testing Tab) 568
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General Pane (Options Dialog Box > API Testing Tab)

Relevant for: API testing

This pane enables you to set the test executionmode, the default location for importingWSDL files,
and the repository locations for activity sharing.

To access Select Tools > Options > API Testing tab > General node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also "Auto Values Pane (Options Dialog Box > API Testing Tab)" on page 567

User interface elements are described below:

UI Element Description

Compile as Themode for a run session. Options includeDebug orRelease.

Select theRelease option for faster run sessions. Run sessions performed
with theDebug option runmore slowly and generate additional information
in the Output pane.

Use relative
paths to call
assets

Instructs UFT to use relative paths for all steps that require a path or file
name.

User Guide
Chapter 19: UFT Global Options

HP Unified Functional Testing (12.00) Page 565 of 2274



UI Element Description

Run test in
debugging mode

Runs a test with debugging capabilities active.

By default, tests run without any of the debugging capabilities, enabling
them to run faster. If you check this option, it activates the debugging
capabilities during a test run, slowing the speed of a test run.

Number of items
to show in WSDL
import history

Specifies themaximum number of WSDL addresses to display in the
address drop down list of the "Import/UpdateWSDL from URL or UDDI
Dialog Box" (described on page 1766).

Default: 10

Default page for
WSDL browser

The default Web page that opens when you click theBrowse button in the
"Import/UpdateWSDL from URL or UDDI Dialog Box" (described on page
1766).

Shows encrypted
passwords in the
Output pane

Displays passwords used in a test or component in the information
displayed in the Output pane in an unencrypted form.

Activity
Repositories

Displays the locations for activity repositories:

l File system path. The folder in the file system in which to store
activities.

l ALM path. The path in the ALM repository in which to store activities.

Tip:

l Click theBrowse button to select a location.

l Tomove an activity to a repository so that it can be used in
subsequent tests, right-click the parent node and selectMove to.

Note: Youmust be connected to ALM to set theALM activities path
location (select ALM > ALM Connection).

Number of
records to show
in query preview

Sets themaximum number of strings for:

l TheQuery Preview window (accessible by clicking theCheck SQL
Statement button in the "Set SQL Statement Page" (described on page
260).

l A database source in the Data Pane

Default: 10
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UI Element Description

Database
connection
timeout

The number of seconds to wait without a successful connection to a
database before timing out the connection.

Default: 30

Auto Values Pane (Options Dialog Box > API Testing Tab)

Relevant for: API testing

This pane enables you to provide default values for populating activity properties.

To access Select Tools > Options > API Testing tab > Auto-values node.

Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l To assign an auto value to a property, select Set Auto-value from the right-
click menu in theValue column of the Properties pane.

l To set values for an array of properties, select the parent node.

See also "General Tab (Options Dialog Box)" on page 524
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User interface elements are described below:

UI Element Description

String The default value to use for a property defined as a string.

Default: abcd.

Date/time The default value to use for a property requiring a time and date.

Default: long notation of the current time and date.

Boolean The default value to use for a property defined as boolean: True or False.

Default: False.

Integer The default value to use for a property defined as integer.

Default: 1,234.

Long The default value to use for a property defined as Long.

Default: 1,234.

Float The default value to use for a property defined as Float.

Default: 12.300000.

Decimal The default value to use for a property defined as decimal.

Default: 12.340000.

Double The default value to use for a property defined as double.

Default: 12.340000.

SAP Connections Pane (Options Dialog Box > API Testing Tab)

Relevant for: API testing

This pane enables you tomanage SAP connections. You can add and remove connections, add
authentication information, and check the connection.
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To access Select Tools > Options > API Testing tab > SAP Connections node.

Important
information

l TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

l To define a connection, youmust have the 32-bit version of SAP .NET
Connector installed on your machine. The installation is available on the SAP
Help portal, at http://help.sap.com/saphelp_
NW04/helpdata/en/e9/23c80d66d08c4c8c044a3ea11ca90f/content.htm.

Relevant
tasks

"How to Create an SAP API Test Step" on page 1638

See also "SAP Activities" on page 1737

User interface elements are described below:

UI Element Description

Add Connection. Adds a new editable entry to the list of connections.

Delete Connection. Deletes the selected connection.

Move up.Moves the selection up on the connection list.

Move down.Moves the selection down in the connection list.
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UI Element Description

Import. Allows you to import a saplogon and connection file (.ini or .xml) with
the connection settings information.

Export. Allows you to export the connection settings to an XML file.

Ping Connection. Tests the selected connection and inserts the date and
time in the Last Pinged column.

<SAP
connection
list>

Displays information about the current connection:

l Name. The connection's name.

l Application Server. The URL or IP of the application server.

l System Number. The value of the SAP system number.

l Client. The type of client.

l Username/Password. The authentication information.

l Description. A description of the connection.

l Last Pinged. The date and time that a ping request was issued to the
server.

BPT Testing Tab (Options Dialog Box)
Relevant for: business process tests and flows

This tab enables you to set options for parameter use of a BPT test and its components in UFT.
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To access Select Tools > Options > BPT Testing tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

Relevant tasks "How to Create, Maintain, and Run Business Process Testing Tests and
Flows in UFT" on page 2071

User interface elements are described below:

UI Element Description

Promote
component
parameters

Determines whether UFT automatically promotes parameters to the flow or test
level (when adding a component to a flow or test) or promotes flow parameters
to the test level (when adding a flow to a test).

Always link
to existing
test
parameters

Determines whether UFT uses an existing test parameter during promotion or
creates an additional test parameter, when a parameter with the same name
already exists in the test or flow.

If selected, the Test/Flow Parameter Name suffix is removed, because the
parameter may have been promoted frommultiple components.
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Coding Tab (Options Dialog Box)
Relevant for: GUI testing and API testing

This tab enables you to set options that facilitate designing code.

To access Select Tools > Options > Coding tab.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "General Tab (Options Dialog Box)" on page 524

l "GUI Testing Tab (Options Dialog Box)" on page 535

l "API Testing Tab (Options Dialog Box)" on page 564

l "Text Editor Tab (Options Dialog Box)" on page 574

This tab includes the following pane:

Code Templates Pane (Options Dialog Box > Coding Tab) 573

User Guide
Chapter 19: UFT Global Options

HP Unified Functional Testing (12.00) Page 572 of 2274



Code Templates Pane (Options Dialog Box > Coding Tab)

Relevant for: GUI testing and API testing

This pane enables you to create and edit templates of pre-designed code snippets or blocks of text
used for automatic code completion. You can create different lists of templates for different file
types.

To access Select Tools > Options > Coding tab > Code Templates node.

Important
information

l TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

l You can edit the names, keywords, descriptions, and code snippets of any
template defined in this pane.

l UFT provides default file types and snippets. You can add additional lists
of file types and snippets as needed.

Relevant tasks "How to Use Code Snippets and Templates" on page 322

See also For GUI testing and API testing:"Automatic Code Completion" on page 316

For GUI testing only:

l "Comments, Control-Flow, andOther VBScript Statements " on page 1006

l "Basic VBScript Syntax" on page 1013
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User interface elements are described below:

UI Element Description

File types The file types for which the displayed list of templates is used.

Select an item from the drop-down list to display the templates associated with
the selected file extensions.

Default options include:

l .vb files .

l .cs files (used for API tests)

l .mts, .qfl, or .vbs files (used for GUI tests)

Add List Adds a new list of templates and the file types for which to use them.

A new item is added to the File types drop-down list.

Remove
List

Removes the currently displayed list of templates and the associated File types
item.

Caution: Deleting a list is irreversible.

Edit List Enables you to edit the file extensions associated with the displayed list of
templates.

Template The name of the template.

Keyword The keywords that trigger the use of the template when invoking code completion
in files of the selected types.

Description A string that describes the code snippet.

<code
snippet>

The code that is inserted into your document. The snippet can include text that is
inserted as is, as well as variables (prefaced by a dollar sign $) that are replaced
with actual values when they are inserted into the document.

Tip: To edit the code snippet, modify the text in this area and click another
template row orOK.

Text Editor Tab (Options Dialog Box)
Relevant for: GUI testing and API testing

This tab enables you to set options for editing text and code files.

To access Select Tools > Options > Text Editor tab.
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Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "General Tab (Options Dialog Box)" on page 524

l "GUI Testing Tab (Options Dialog Box)" on page 535

l "API Testing Tab (Options Dialog Box)" on page 564

l "Coding Tab (Options Dialog Box)" on page 572

This tab includes the following panes:

General Pane (Options Dialog Box > Text Editor Tab) 575

Fonts and Colors Pane (Options Dialog Box > Text Editor Tab) 577

General Pane (Options Dialog Box > Text Editor Tab)

Relevant for: GUI testing and API testing

This pane enables you to set general preferences for editing code and text files.

To access Select Tools > Options > Text Editor tab > General node.
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Important
information

TheRestore Factory Defaults button resets all Options dialog box options
to their defaults.

See also l "Editing Text and Code Documents" on page 305

l "Editor User Interface" on page 334

User interface elements are described below:

UI Element Description

Word wrap Wraps lines of code to continue onto subsequent lines without the insertion of a
line break character. If disabled, the line of code continues indefinitely on a
single line until youmanually stop it by pressing theENTER key or entering a
line break character.

Enable
folding

Enables sections of code that are grouped together to be expanded and
collapsed.

Show
class/function
browser

Shows or hides the drop-down lists of classes and functions. These lists are
located at the top of the Editor. Using the browsers, you can navigate to
different classes and functions within your document.

Show line
numbers

Shows or hides the line number to the left of each line of code.

Show hidden
definitions

Shows or hides text and function definitions defined as hidden.

Show All
characters

Displays all SPACE, TAB, and End of Line characters. You can also select
to display only some of these characters by selecting or clearing the relevant
check boxes.

Convert tabs
to spaces

Changes TAB keystrokes in your code to the number of SPACE characters
defined in the Tab spacing option.

Tab spacing The number of characters inserted into a line of code for a TAB character. The
number of characters can range from 1 to 16.
Default: 4
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Fonts and Colors Pane (Options Dialog Box > Text Editor Tab)

Relevant for: GUI testing and API testing

This pane enables you to specify color preferences for the text you are editing. You can set unique
coloring rules for each code element.

To access Select Tools > Options > Text Editor tab > Fonts and Colors node.

Important
information

TheRestore Factory Defaults button resets all Options dialog box options to
their defaults.

The options in this pane apply only to documents in the Editor. For details on the
GUI testing Keyword View formatting options, see "Fonts and Colors Tab
(Keyword View Options Dialog Box)" on page 955.

See also l "Editing Text and Code Documents" on page 305

l "Editor User Interface" on page 334
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User interface elements are described below:

UI
Element Description

Font The font name and size to use for all elements. The Default is Consolas, 10 points.

Note:When testing in a Unicode environment, youmust select a Unicode-
compatible font. Otherwise, elements in your document may not be correctly
displayed in the document window. However, the test or component still runs in
the sameway, regardless of the font you choose. If you are working in an
environment that is not Unicode-compatible, youmay prefer to choose a fixed-
width font, such as Courier, to ensure better character alignment.

Syntax
Coloring

The language or languages whose appearance you want to customize.

Available options:

l All languages

l C#

l VBScript

l XML

The box below your selection displays all of the elements for which you can configure
color and style settings.

You canmodify the Foreground andBackground colors for a selected element.
You can alsomodify theStyle (Bold or Italic), if enabled.

Preview An example of the text element according to your selections above.

Reset Resets all colors and styles to default settings.
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Troubleshooting and Limitations - Options Dialog
Relevant for: GUI tests and components

This section describes troubleshooting and limitations for the Options Dialog.

l UFT cannot resolve ALM folders paths specified in the Folders pane of the Options dialog box, if
any of the folder names contain a forward slash.

Workaround:Remove the slash in the folder name in ALM or specify paths using this folder
using absolute paths (instead of relative paths that reference the Folders pane).
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Chapter 20: Settings for GUI Tests, GUI Business
Components, and Application Areas

Relevant for: GUI tests and components

This chapter includes:

Concepts 581

Settings Overview 581

Add-in Associations in a GUI Test 583

Add-in Associations in a GUI Component 584

Understanding GUI Component Statuses 584

Local SystemMonitor 585

Log Tracking 586

Tasks 587

How toManually Configure Log Tracking Settings 587

Reference 590

Properties Pane (Test/Business Component Settings Dialog Box) 590

Snapshot Pane (Business Component Settings Dialog Box) 596

Applications Pane (Business Component Settings Dialog Box / Application Area -
Additional Settings Pane) 597

Run Pane (Test Settings Dialog Box) 601

Resources Pane (Test/Business Component Settings Dialog Box) 603

Environment Pane (Test Settings Dialog Box) 608

Recovery Pane (Test/Business Component Settings Dialog Box / Application Area -
Additional Settings Pane) 613

Log Tracking Pane (Test/Business Component Settings Dialog Box / Application Area -
Additional Settings Pane) 617

Local SystemMonitor Pane (Test/Business Component Settings Dialog Box / Application
Area - Additional Settings Pane) 623
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Concepts

Settings Overview
Relevant for: GUI tests and components

You can use the Test or Business Component Settings dialog box or the Additional Settings pane in
an application area to set testing options that affect how UFT works with a specific test or
component. Most of the settings for components are defined in application areas and their settings.

Different panes and settings are available, depending on the document (test, component, or
application area) that is in focus when you open the Settings dialog box or the Additional Settings
pane.

Note: You can also set testing options that affect all tests and components. For details, see
"UFT Global Options" on page 522.

GUI Test Settings

Use the Test Settings dialog box to set testing options that affect how UFT works with a specific
test. For example, you can instruct UFT to run a parameterized test for only certain lines in the data
table. The individual testing options that you specify are saved when you save the test.

GUI Business Component Settings

Business components are automatically linked to the settings defined in their associated
application area. For details, see "Application Area Settings " below. The Business Component
Settings dialog box displays most of these settings in read-only format.

You can also define some additional component-specific settings, such as input and output
parameters, component snapshots, and the component status, in the Business Component
Settings dialog box.

Application Area Settings

You define the settings and resources needed for a business component in its associated
application area.

The following application area settings are used only if the application area is associated with the
first business component in a business process test:

l Associated Add-ins

l Local SystemMonitor

l Log Tracking
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If you need a particular add-in or you want the local systemmonitor or log tracking options to be
active for your business process test, youmust make sure that the required settings are applied in
the application area for the first component in that test. If these settings are active for application
areas associated with later components in the test, they are ignored.

For details on working with application areas, see "Application Areas" on page 2095.

The Settings Dialog Box Panes

The table below lists the panes contained in the Settings dialog box. Some of these panes are
available in the application area's Additional Settings pane.

Node Options

Properties The properties of the test or component, for example, its description and
associated add-ins. You can also set the status of a component. For details, see
"Properties Pane (Test/Business Component Settings Dialog Box)" on page
590.

Snapshot
(components
only)

Options for capturing or loading a snapshot image to be saved with the
component for display in ALM. For details, see "Snapshot Pane (Business
Component Settings Dialog Box)" on page 596.

Run
(tests only)

The run session preferences for your test. For details, see "Run Pane (Test
Settings Dialog Box)" on page 601.

Applications
(components
only)

TheWindows-based applications on which the component can record and run.
For details, see "Applications Pane (Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 597.

Note:

l For components, define in the application area's Additional Settings
pane.

l Read-only in the Business Component Settings dialog box.

Resources The resources associated with your test or component, such as function
libraries, shared object repositories, and data tables. For details, see
"Resources Pane (Test/Business Component Settings Dialog Box) " on page
603.

Note:

l For components, define in the application area.

l Read-only in the Business Component Settings dialog box.
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Node Options

Environment
(tests and
scripted
components
only)

Options for viewing existing built-in and user-defined environment variables,
adding, modifying and saving user-defined environment variables, and selecting
the active external environment variables file. For details, see "Environment
Pane (Test Settings Dialog Box)" on page 608.

Recovery Options for setting how UFT recovers from unexpected events and errors that
occur in your testing environment during a run session. For details, see
"Recovery Pane (Test/Business Component Settings Dialog Box / Application
Area - Additional Settings Pane)" on page 613.

Note:

l For components, define in the application area's Additional Settings
pane.

l Read-only in the Business Component Settings dialog box.

Log
Tracking

Options for activating and setting run-time preferences for tracking log
messages generated by the log framework that monitors events occurring in
your application. For details, see "Log Tracking Pane (Test/Business
Component Settings Dialog Box / Application Area - Additional Settings Pane)"
on page 617.

Local
System
Monitor

Options for activating and setting preferences for tracking system counters
during a run session. For details, see "Local SystemMonitor Pane
(Test/Business Component Settings Dialog Box / Application Area - Additional
Settings Pane)" on page 623.

Note: For components, define in the application area's Additional Settings
pane.

The Settings dialog box may also contain additional panes corresponding to any UFT add-ins that
are installed or loaded. For details on add-ins, see the relevant section in theHP Unified Functional
Testing Add-ins Guide.

Add-in Associations in a GUI Test
Relevant for: GUI tests only

For components, see "Add-in Associations in a GUI Component " on the next page.

When you open UFT, you select the add-ins to load from the Add-in Manager dialog box. You can
create and edit tests that work with any environment for which the necessary add-in is loaded.

When you create a new test, the add-ins that are currently loaded are automatically associated with
your test.
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Choosing to associate an add-in with your test instructs UFT to check that the associated add-in is
loaded each time you open that test. For details, see "Add-in Manager Dialog Box" on page 118.

When you open a test, UFT notifies you if an associated add-in is not currently loaded, or if you
have loaded add-ins that are not currently associated with your test. This process ensures that your
run session will not fail due to unloaded add-ins and reminds you to add required add-ins to the
associated add-ins list if you plan to use them with the currently open test. For details on loading
and working with add-ins, see theHP Unified Functional Testing Add-ins Guide.

ALM uses the associated add-ins list to determine which add-ins to load when it opens UFT to run
or view a test. For details on working with ALM, see "ALM Integration" on page 707.

Add-in Associations in a GUI Component
Relevant for: GUI components only

For tests, see "Add-in Associations in a GUI Test" on the previous page.

When you open UFT, you can select the add-ins to load from the Add-in Manager dialog box. You
can record on any environment for which the necessary add-in is loaded.

Choosing to associate an add-in with an application area instructs UFT to check that the
associated add-in is loaded each time you open a component that is associated with that
application area. When you create a new component, its associated add-ins are those defined in the
component's application area. For details, see "Add-in Manager Dialog Box" on page 118.

When you open a component, UFT notifies you if an associated add-in is not currently loaded, or if
you have loaded add-ins that are not currently associated with your component (via its application
area). This process reminds you to add the required add-ins to the associated add-ins list if you plan
to use them with the currently open component, thereby helping you to ensure that your run session
will not fail due to unloaded add-ins.

When a business process test is opened in ALM, the UFT add-ins that are associated with the first
component in the business process test are loaded automatically. Add-ins associated with other
components in the business process test are not loaded. Therefore, it is important to ensure that all
required UFT add-ins are associated with the application area of the first component in the business
process test.

Understanding GUI Component Statuses
Relevant for: GUI components only

You can assign statuses to business components in UFT or in ALM. You can specify business
component statuses manually, or in certain cases, ALMmay automatically assign them. For
example, you can use aReady status to indicate that a business component is ready to be run in a
business process test, or anError status may be automatically assigned to a component that has
errors that prevent it being successfully run in a business process test.

Knowing the status of a business component is important because it affects the status of any
business process tests of which it is a part. In general, the component with themost severe status
determines the status of the entire business process test. For example, a component with anError
status causes every business process test of which it is a part to have anError status.
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A component can be assigned one of the following statuses:

l Error. The component contains errors that need to be fixed. For example, this may occur due to
a change in the application. When a business process test contains a component with this
status, the status of the entire business process test is alsoError.

l Maintenance. The component is currently being developed and tested and is not yet ready to
run, or it was previously implemented and is now beingmodified to adapt it for changes that have
beenmade in the application.

l Ready. The component is fully implemented and ready to be run. It answers the requirements
specified for it and has been tested according to the criteria defined for your specific system.

l Under Development. The component is currently under development. This status is
automatically assigned to:

n New components created in the Business Components module of ALM with BPT support.

n Component requests dragged into the component tree in ALM with BPT support.

l Not Implemented. The component has been requested in the Test Planmodule of ALM. The
status changes automatically from Not Implemented toUnder Developmentwhen the
request is moved from the Component Requests folder in the component tree in the Business
Components module.

For details on setting component statuses, see "Properties Pane (Test/Business Component
Settings Dialog Box)" on page 590.

Local System Monitor
Relevant for: GUI tests and components

Local systemmonitor tracking enables you to track application performance counters during a run
session. These counters enable you tomonitor the resources used by your application.

The system counters that can bemonitored are the process counters that are accessible through
the performance console (select Start > Run > and then enterPerfmon). For details on these
process counters, see the performance console's Help.

You can also define limits for the counters. If the specified counters exceed these limits, the run
session will fail. The results of the system counters are viewed in the Run Results Viewer. For
details, see Run Results Viewer (described in theHP RunResults Viewer User Guide).

You can use the Local SystemMonitor pane of the Test Settings dialog box (for tests) or application
area's Additional Settings pane (for components) to activate and set preferences for tracking
system counters during a run session. For details, see "Local SystemMonitor Pane (Test/Business
Component Settings Dialog Box / Application Area - Additional Settings Pane)" on page 623.

When Running a Business Process Test

l Local systemmonitoring is performed only if the application area associated with the first
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business component in the business process test is configured to do so.

l Local systemmonitoring is performed only on the application defined in the Local System
Monitor pane of the application area additional settings for the first component in the business
process test.

This means that if a component running later in the test is associated with a different application
area, local systemmonitor settings from that application area are ignored and local system
monitoring is not performed on that application's process.

l Local systemmonitoring can only monitor the status of one instance of the application. If more
than one instance of the application is running, UFT monitors only the instance that was opened
first.

Log Tracking
Relevant for: GUI tests and components

If theWindows-based application you are testing uses a supported Java or .NET log framework
that includes a UDP appender, you can enable UFT to receive logmessages from that framework
and send them to the run results.

You do this by configuring your application's log configuration file. You can configure this file using
UFT, or you can configure the file manually. To configure this file using UFT, you define the settings
in the Log Tracking pane in the Settings dialog box described on page 586. For details on
configuring the log configuration file manually, see "How toManually Configure Log Tracking
Settings" on the next page.

When you configure your application's log configuration file, you specify theminimum logmessage
level that you want UFT to receive, the logmessage source and port, and so on. During a run
session, UFT receives the relevant logmessages that are generated for your application and sends
them to the run results. In the Run Results Viewer, these logmessages are displayed in the Log
Tracking Results pane. In the Run Results Viewer, logmessages are associated with steps
according to their timestamp. For details, see the section on the Run Results Viewer Log Tracking
Pane (described in theHP RunResults Viewer User Guide).

Analyzing the logmessages that were generated as a result of a particular step can help you
pinpoint the causes of unexpected behavior in your application, such as application crashes during
automated runs.

For more details, see:

l "How toManually Configure Log Tracking Settings" on the next page

l "Log Tracking Pane (Test/Business Component Settings Dialog Box / Application Area -
Additional Settings Pane)" on page 617
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Tasks

How to Manually Configure Log Tracking Settings
Relevant for: GUI tests and components

You can specify your log tracking and collection preferences manually. This is useful, for example,
if your test or component is validatingmore than one application, and you need to configure a file for
each application being tested.

Note: If you want to instruct UFT to automatically configure your application's log configuration
file, use the Log Tracking pane in the Settings dialog box, described on page 617.

The following steps describe how tomanually specify your log tracking and collection preferences.

l "Prerequisites" below

l "Open the relevant log configuration file and specify your preferences" below

l "Configure the settings in the Log Tracking pane so that UFT will use the same settings that you
defined in the previous step" on the next page

l "Results" on page 589

1. Prerequisites
a. YourWindows-based applicationmust use a Java or .NET log framework that includes a

UDP appender.

b. Verify the following:

o Which log framework version is used with your application?Make sure that it includes a
UDP appender and that the specific version is supported when working with UFT.

o Make sure that logging is enabled on your application. Find out how to enable and
disable logging. (Youmay want to enable logging for some run sessions and disable
logging for others.) Do you need to define an XML parameter or modify a registry key?

o Where is the log configuration file located?Make sure that it is writable.

2. Open the relevant log configuration file and specify your preferences
This step describes how tomanually configure a log configuration file so that UFT will be able
to receive logmessages during a run session.

For a list of supported log frameworks, see theHP Unified Functional Testing Product
Availability Matrix, available from the UFT Help or the root folder of the Unified Functional
Testing DVD.
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a. Add an appender-ref ref attribute with the value of QtpUdpAppender to the root element.

b. Specify theminimum logmessage level that you want to include in the run results.

Example:

...
<root>
<level value="DEBUG" />

...
<appender-ref ref="QtpUdpAppender" />

</root>

c. Add an appender element and its attributes, as shown in the following example.

Example:

<appender name="QtpUdpAppender"
type="log4net.Appender.UdpAppender">
<remoteAddress value="1.1.1.1" />
<remotePort value="18081" />
<encoding value="utf-16" />
<layout type="log4net.Layout.XmlLayoutSchemaLog4j">
<prefix value="" />

</layout>
</appender>

Note: To enable UFT to receive logmessages, theAdd log messages to run
results area of the "Log Tracking Pane (Test/Business Component Settings Dialog
Box / Application Area - Additional Settings Pane)" on page 617 of the Settings dialog
box must also be configured, as described below.

3. Configure the settings in the Log Tracking pane so that UFT will use
the same settings that you defined in the previous step
This step enables UFT to receive logmessages during a run session.
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In the Log Tracking pane of the Settings dialog box:

n Select the "Add logmessages to run results" on page 620 check box.

n Specify the settings in the upper half of the pane:

o Log messages source

o Port

o Minimum level to add node to results tree

For details on these fields, see "Log Tracking Pane (Test/Business Component Settings
Dialog Box / Application Area - Additional Settings Pane)" on page 617.

n Clear theAuto-configure log mechanism check box. This prevents UFT frommodifying
the configuration file.

4. Results
During a run session, UFT receives any logmessages that match or exceed theminimum log
message level that you specified in the Log Tracking pane and displays them in the run results.

In the run results tree, a node is also inserted for the first message that matches or exceeds the
Minimum level to add node to results tree. This node is inserted directly after the step that
triggered (or preceded) the relevant logmessage (according to its timestamp).
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Reference

Properties Pane (Test/Business Component Settings
Dialog Box)

Relevant for: GUI tests and business components

This pane enables you to view general information about your test or component, including its
description and any add-ins associated with it.

For tests:You can also define the information in this pane, as well as choose to generate an
automation script for the test settings.

For components:You can also set or modify the component status. All other information is
displayed as defined for the application area, in read-only mode.
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To access Do one of the following:

l With a test, action, or business component in focus, select File > Settings.

l For tests only: In the canvas, right-click theStart orEnd nodes of the test and
select Settings.

Important
Information

The information displayed in this pane is also available in the "General Properties
Tab (Properties Pane - GUI Testing)" (described on page 390).

See also For tests only: "Modify Associated Add-ins Dialog Box" on page 594

User interface elements are described below:

UI Element Description

Name Indicates the name of the test or component. If the test or component is saved in
a version-controlled project in ALM, the version number is also shown.

Author Indicates theWindows user name of the person who created the test.
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UI Element Description

Application
Area
(components
only)

Indicates the name of the application area which is associated with the
component. For details, see "How to Create andManageGUI Business
Components" on page 2088.

Note: If the component was created in ALM and no application area was
selected, this is indicated by Not selected. Before business component
steps can be implemented, an application areamust be selected.

Created in
version

Indicates the version of QuickTest or UFT used to create the test or component.

Modified in
version

Indicates the version of QuickTest or UFT last used tomodify the test or
component.

Created on
date

Indicates the date and time that the test or component was created.

Modified on
date

Indicates the date and time that the test or component was last modified.

Location Indicates the path and filename of the test, or the ALM path and filename of the
component.

Description l For tests:Enables you to specify a description for your test.

l For components:Displays the description specified for your component.
This field can be entered or modified only in ALM.

Associated
add-ins

l For tests: Lists the add-ins associated with the test. For details, see "Add-in
Associations in a GUI Test" on page 583.

l For components: Lists the add-ins associated with the component (via its
associated application area). The associated add-ins are loaded by business
components when they are accessed.

Modify
(tests only)

Enables you to select the add-ins to associate with your test. For details, see
"Modify Associated Add-ins Dialog Box" on page 594.
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UI Element Description

Generate
Script

Generates a UFT automation script containing the current test settings.

When you click theGenerate Script button, a Save As dialog box opens,
enabling you to specify the name and file system location to store the generated
file.

You can use some or all of the script lines from this generated script in an
automation script. This can be useful, for example, if you want to open a test
with required test settings already set or to set the same test settings for
multiple tests by looping through the tests in a folder.

For details, see "UFT Automation Scripts" on page 1155 and theUnified
Functional Testing Automation Object Model Reference (Help > HP UFT GUI
Testing Advanced References > Automation Object Model Reference).

Business
component
Status
(components
only)

Specifies the status of the component. You can change the status of the
component by selecting a different option from the list. For details on status
options, see "Understanding GUI Component Statuses" on page 584.
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Modify Associated Add-ins Dialog Box

Relevant for: GUI tests and components

This dialog box lists all the add-ins currently associated with your test, as well as any other add-ins
that are currently loaded in UFT, and enables you to associate or disassociate add-ins with your
test.

To access In the "Properties Pane (Test/Business Component Settings Dialog Box)", click
Modify.
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Important
information

l If this dialog box contains a child add-in, and you select it, the parent add-in is
selected automatically.

l If you clear the check box for a parent add-in, the check boxes for its children
are also cleared.

l If a specific add-in is not currently loaded, but you want to associate it with
your test or application area, reopen UFT and load the add-in from the Add-in
Manager. If the Add-in Manager dialog box is not displayed when you open
UFT, you can choose to display it the next time you open UFT. To do so,
select Display Add-in Manager on startup from the Startup Options pane of
the Options dialog box (Tools > Options > General tab > Startup Options
node). For details, see "UFT Global Options" on page 522.

See also l "Add-in Associations in a GUI Test" on page 583

l For details on the Add-in Manager, see the section on working with UFT add-
ins in theHP Unified Functional Testing Add-ins Guide.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

<Add-ins
list>

The list of the add-ins that are currently loaded in UFT. You can select the check
boxes for add-ins that you want to associate with your test or application area, or
clear the check boxes for add-ins that you do not want to associate with your test
or application area.

In the image above:

l Web is loaded and associated with the test or application area.

l ActiveX is loaded, but not associated with the test or application area.

l Visual Basic is associated with the test or application area, but is not loaded.

Note:

l Add-ins that are associated with your test or application area but not
currently loaded are shown dimmed.

l This list might also include child nodes representing add-ins that you or a
third party developed to support additional environments or controls using
add-in extensibility.

Description The description of the selected add-in.
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Snapshot Pane (Business Component Settings Dialog
Box)

Relevant for: GUI components only

This pane enables you to capture or load an image and save it with the component. The image
provides a visual indication of the component's main purpose. You can view the image in ALM, in
the component and in any business process test in which the component is included.

To access With a business component in focus, select File > Settings > Snapshot.

Important
information

The snapshot image can also be captured and saved with the component from the
Snapshot tab in ALM when installed with BPT support. For details on capturing a
snapshot for a component in ALM, see theHP Business Process Testing User
Guide.
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User interface elements are described below:

UI
Elements Description

Capture
snapshot
from
application

Enables you to define the image to be captured by clicking theCapture Snapshot
button. You can then drag the crosshairs pointer to select the area to be captured.
When you release themouse button, the captured area is displayed in the
Snapshot pane.

Load from
file

Specifies the .png or .bmp file containing the required image. You can enter the
path and filename or use the browse button to locate the file.

Applications Pane (Business Component Settings Dialog
Box / Application Area - Additional Settings Pane)

Relevant for: GUI components only

Application Areas: This pane enables you to specify theWindows-based applications on which
the components associated with the application area can record and run. It also displays the
environments on which the component can currently record (based on the currently loaded add-ins).

Business Components:When viewing this pane from the Business Component Settings dialog
box, the options are read-only.

The following image is an example of theApplications pane in the Business Component Settings
dialog box. These settings are identical to the ones available in an application area's Additional
Settings pane.
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To access Do one of the following:

l For a business component:

With a component in focus, select File > Settings > Applications node.

l For an application area:

Open the application area and select Additional Settings > Applications in
the sidebar.
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Important
information

l You can use the Applications pane to set or modify your application
preferences in the following scenarios:

n You have already recorded one or more steps in an associated component
and you want to modify the settings before you continue recording.

n Youwant to record and run the component on a different application than the
one you previously used.

l You can record component steps only on the specified applications.

l If you are recording a new component, set your application settings in the
Applications pane of the Application Area Additional Settings using the
Applications dialog box. This dialog box opens when you start to record, and
contains the same options as the Applications pane, described in this section.

l The Applications dialog box and Applications panemay also contain options
applicable to any UFT add-ins installed on your computer. For details regarding
these options, see the documentation provided for the specific add-in.

See also "Select Application Dialog Box" on the next page

User interface elements are described below:

UI Element Description

Windows
applications

Lists the details of theWindows-based applications on which to record and
run components associated with this application area. For details on the
details displayed, see "Select Application Dialog Box" on the next page.

If you do not want to record or run onWindows-based applications, leave the
application list blank. (This is the default setting.)

Adds an application to the application list. You can add up to ten
applications. For details, see "Select Application Dialog Box" on the next
page.

Removes the selected application from theApplication list.

Record and run
on any
applications
opened by UFT

Records and runs on any applications invoked by UFT (as child processes
of UFT), for example, applications opened during a record or run session
using anOpenApp function.

Other Displays the environments on which the application area's associated
components can currently record (based on the currently loaded add-ins).
For details, see theHP Unified Functional Testing Add-ins Guide.
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Select Application Dialog Box

Relevant for: GUI components only

This dialog box enables you to select applications for use in your application area.

To access In the "Applications Pane (Business Component Settings Dialog Box / Application

Area - Additional Settings Pane)" (described on page 597), click theAdd
button.

Important
information

l You can add up to ten applications to the application list displayed in the
Applications pane, and you can edit an existing application in the list. You can
also select whether to record and run on the application's descendant
processes.

l The details entered in the Select Application dialog box are displayed as a
single line for each application in theWindows-based applications area of
the Applications pane.

User interface elements are described below:

UI Element Description

Executable
file

Instructs UFT to record and run on the specified executable file.

Include
descendant
processes

Instructs UFT to record and run on processes created by the specified application
during the record and run session. For example, a process that is used only as a
launcher may create another process that actually provides the application
functionality. This descendant process must therefore be included when recording
or running components on this application, otherwise the functionality will not be
recorded, or the run session will fail.

Default value:Selected.
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Run Pane (Test Settings Dialog Box)
Relevant for: GUI tests only

This pane enables you to choose what to do when an error occurs during the run session, set the
object synchronization timeout, and choose whether or not to disable the Smart Identification
mechanism for the test.

To access With a test or an action in focus, select File > Settings > Run.

Important
information

l This pane applies to the entire test. You can set the run properties for an
individual action in a test from the Run tab in the Action Call Properties dialog
box of a selected action. For details on action run properties, see "Run Tab
(Action Call Properties Dialog Box)" on page 895.

l By default, when you run a test with global data table parameters, UFT runs
the test for each row in the Data pane using the parameters you specified. For
details, see "When to ChooseGlobal or Action Data Table Parameters " on
page 1538.

l You can use this pane to instruct UFT to run iterations on a test only for certain
lines in the Global tab in the Data pane.
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User interface elements are described below:

UI Element Description

Data Table
iterations

Specifies the iterations for the test. Select an option:

l Run one iteration only. Runs the test only once, using only the first
row in the global data table.

l Run on all rows. Runs the test with iterations using all rows in the
global data table.

l Run from row __ to row __. Runs the test with iterations using the
values in the global data table for the specified row range.

When error occurs
during run session

Specifies how UFT responds to an error during the run session. For
details on the different responses, see "Error ResponseOptions" on the
next page.

Object
synchronization
timeout

Sets themaximum time (in seconds) that UFT waits for an object to load
before running a step in the test.

Note:Whenworking withWeb objects, UFT waits up to the
amount of time set for theBrowser navigation timeout option,
plus the time set for the object synchronization timeout. For details
on theBrowser navigation timeout option, see theHP Unified
Functional Testing Add-ins Guide.

Disable Smart
Identification during
the run session

Instructs UFT not to use the Smart Identificationmechanism during the
run session.

Note:When you select this option, theEnable Smart
Identification check boxes in the Object Properties andObject
Repository windows are disabled, although the settings are saved.
When you clear this option, theEnable Smart Identification
check boxes return to their previous on or off setting.

Save image of
desktop when error
occurs (if test is run
by the HP Business
Process Monitor)

This option is applicable only to tests that are run by the Business
Process Monitor component of HP Business Availability Center.

Selecting this option instructs UFT to capture a snapshot of the desktop
if an error occurs during a run session of a test initiated by the Business
Process Monitor. The image is saved in Business Availability Center.
The Business Process Monitor forwards the run results to the Business
Availability Center servers.
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Error Response Options

Relevant for: GUI tests only

By default, if an error occurs during the run session, UFT displays a popupmessage box describing
the error. Youmust click a button on this message box to continue or end the run session.

In the Run pane of the Test Settings dialog box, you can accept the popup message box option or
you can specify a different response by choosing one of the alternative options in the list in the
When error occurs during run session box:

l proceed to next action iteration. UFT proceeds to the next action iteration when an error
occurs.

l stop run. UFT stops the run session when an error occurs.

l proceed to next step. UFT proceeds to the next step in the test when an error occurs.

Note: If you accept the popup message box option, UFT also continues to the next step of
the run.

UFT first performs any recovery scenarios associated with the test, and performs the option
selected above only if the associated recovery scenarios do not resolve the error. For details, see
"Recovery Pane (Test/Business Component Settings Dialog Box / Application Area - Additional
Settings Pane)" on page 613.

Note: If you are working with many tests, youmay want to use a UFT automation script to set
a different value for each test. To access the automation script line that controls this option,
you can use theGenerate Script button in the Properties pane of the Test Settings dialog box.

For details, see "UFT Automation Scripts" on page 1155 or theHP UFT Object Model
Reference for GUI Testing (Help > HP UFT GUI Testing Advanced References Help >
HP Unified Functional Testing Automation Object Model Reference).

Resources Pane (Test/Business Component Settings
Dialog Box)

Relevant for: GUI tests and components

This pane displays the list of resources associated with your test or component (component
associations aremade via the component's application area).

For tests: The pane enables you to associate function libraries and data table files with your test.
You can also set the currently associated function library settings as the default settings for all new
tests.

For components: The pane displays a list of the function libraries and object repositories
associated with the component via its application area, in read-only mode.
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To access With a test, action, or business component in focus, select File > Settings >
Resources.

Important
information

For tests:

l Object repositories are associated with individual actions in your test. You can
associate an object repository with an action using the Action Properties dialog
box (right-click an action in the canvas and select Action Properties) and the
Associate Repositories dialog box (Resources > Associate Repositories).

l When running a test, UFT uses associated function libraries from ALM project
folders only when you are connected to the corresponding ALM project. For
details, see "ALM Integration" on page 707.

For components:

The information in this pane is read-only. You define the settings for this pane
using the "Function Libraries Pane (Application Area)" on page 2102 and the
"Object Repositories Pane (Application Area)" on page 2105.

See also l "Associated Function Libraries" on page 1031

l "Function Libraries Pane (Application Area)" on page 2102 (for components)
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User interface elements are described below:

UI Element Description

Associated
function
libraries

The list of function libraries associated with your test or component.

The order of the function libraries in the list determines the order in which UFT
searches for a function or subroutine that is called from a step in your test or
component.

For tests:You can add, delete, and prioritize the files. You can also set the
default function libraries for new tests.

Associates a function library with the test. (If the function library contains syntax
errors, a message opens stating that your test or component will fail because of
these syntax errors.)

You can enter the absolute or relative path and filename of the function library, or
use the browse button to locate the required file. The function library can be
located in the file system or in an ALM project folder.

If you enter a relative path, then during a run session, UFT searches for the file in
the folder for the current test, and then in the folders listed in the Folders pane of
the Options dialog box. For details, see "Relative Paths in UFT for GUI Testing"
on page 130.

Note:

l If you are working with the Resources and Dependencies model with
Quality Center 10.00 or ALM, specify an absolute Quality Center or ALM
path. For details, see "Relative Paths and ALM" on page 758.

l When you are connected to ALM and, UFT adds [ALM], and displays a
browse button so that you can locate the ALM path.

l When not connected to ALM, you can add a file located in an ALM
project folder by holding the SHIFT key and clicking this button. UFT
adds [ALM], and you can enter the path. You can also type the entire
ALM pathmanually. If you do, youmust add a space after [ALM]. For
example: [ALM] Subject\Tests.

Removes an associated function library from the list.

Moves the selected function library up in the list, assigning it a higher priority.

Moves the selected function library down in the list, assigning it a lower priority.
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UI Element Description

Set as
Default
(tests only)

Sets the current list of function libraries as the default list to be associated with
new tests. This does not affect existing tests.

Note: This button is enabled when the list of associated function libraries
for this test is different from the list that was previously set as default for all
tests.

Caution: If the default function library is moved or renamed, UFT will not be
able to locate it. The function library will be displayed in the Errors pane
when new tests are created. For details on resolvingmissing resources,
see "Errors Pane" on page 364.

Check
Syntax
(tests only)

Verifies whether any of the associated function libraries contain syntax errors
that will prevent the test from running properly. Click theCheck Syntax button
to check the files for syntax errors before finalizing the test. If any syntax errors
are found, the Errors pane opens listing the files containing syntax errors.
Otherwise, an information box opens confirming that the syntax in all of the
function libraries is valid.

Note:

l UFT checks only the associated function libraries that can be accessed.
For example, if an associated function library is stored in an ALM project
to which you are not currently connected, its syntax will not be checked.

l You cannot instruct UFT to check syntax for function libraries that are
loaded dynamically during a run.

Data Table
(tests only)

The location of the data table to be used in your test:

l Default location (under test folder). Instructs UFT to use data stored in the
default data table location under the test folder.

l Other location. Instructs UFT to use data stored in the specified data table
location. The data table can be any Microsoft Excel (.xls or .xlsx) file.

For details on data tables, see "Data PaneOverview" on page 222.

Note: You can specify Microsoft Excel files stored in ALM as data tables.
For details, "How toManage Data Tables in a GUI Test" on page 231.
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UI Element Description

Associated
object
Repositories
(components
only)

The list of shared object repositories currently associated with your component
via its associated application area (in addition to the local object repository).

The order of the object repositories in the list determines the order in which UFT
searches for a test object description.

Components use shared object repository files stored in ALM. For details on
associating object repositories with application areas, see "Object Repositories
Pane (Application Area)" on page 2105.

Environment Pane (Test Settings Dialog Box)
Relevant for: GUI tests and scripted GUI components

This pane displays existing built-in and user-defined environment variables. It also enables you to
add, modify, or delete internal user-defined environment variables, export the defined variables to
an external .xml file, and retrieve them from a file.
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To access With a test, action, or scripted component in focus, select File > Settings >
Environment.

Important
information

Variables from an external environment variables file are displayed in blue.
Internal environment variables are displayed in black.

See also "Environment Variable Parameters" on page 1536

This pane includes the following key areas:

l "Variable Type Selection Area" on the next page

l "Built-in Environment Variables Area" on the next page

l "User-Defined Environment Variables Area" on the next page
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Variable Type Selection Area

UI
Element Description

Variable
type

Enables you to select either aBuilt-in environment variable or aUser-defined
environment variable to define.

Built-in Environment Variables Area
Relevant for: GUI tests and scripted GUI components

Displays the built-in environment variables defined by UFT and their current values.

This area provides the following information:

UI Element Description

Name The name of each built-in environment variable.

Description A short description of each built-in environment variable.

Current value The current value of the selected environment variable.

User-Defined Environment Variables Area
Relevant for: GUI tests only

Displays both internal and external user-defined environment variables and their current values.

This area provides the following information:

UI
Element Description

Name The name of each user-defined variable.

Value The value assigned to each user-defined variable.

Type The type of each user-defined variable: Internal or External. Internal environment
variables are available only to the test in which they are defined.

Enables you to define a new internal environment variable and add it to the list. For
details, see "Add New/View/Edit Environment Parameter Dialog Box" on the next
page.

Deletes a selected internal environment variable from the list.

Note: After you confirm the deletion of the environment variable, you cannot
retrieve it, even if you click Cancel in the Test Settings dialog box.

User Guide
Chapter 20: Settings for GUI Tests, GUI Business Components, and Application Areas

HP Unified Functional Testing (12.00) Page 610 of 2274



UI
Element Description

Enables you to edit the value of a selected internal environment variable or to view
the properties of a selected external environment variable. For details, see "Add
New/View/Edit Environment Parameter Dialog Box" below.

Export Exports your user-defined environment variables to an external .xml file for use with
other tests. You can then use the exported environment variable file with any test by
loading them from the file as external user-defined environment variables. For
details, see "Save <Resource>/Save <Document> As Dialog Box" on page 164.

Note:

l If the file is saved to the file system, its values are loaded each time the test
runs. If the file is saved to an ALM project, its values are loaded when the
test is first loaded.

l If the values are changed after the test is loaded, UFT will not use the new
values until the next time the test is loaded.

l If you are working with the Resources and Dependencies model with
Quality Center 10.00 or ALM, you should specify an absolute Quality Center
or ALM path. For details, see "Relative Paths and ALM" on page 758.

Load
variables
and
values
from
external
file

Instructs UFT to load the variables saved in the .xml file that you specify for use
with your test.

File The environment variable .xml file to load and use when your test runs. Click the
Browse button to open theOpen XML File dialog box. For details, see "Open/New
<Document>/<Resource> Dialog Box" on page 156.

Add New/View/Edit Environment Parameter Dialog Box

Relevant for: GUI tests only

This dialog box enables you to add, edit and internal user-defined environment variables from the
Environment pane of the Test Settings dialog box. For external user-defined environment variables,
you can view the variable details in read-only format.

The following image is an example of the dialog box when adding a new environment parameter.
The actual name of the dialog box may differ depending on the operation you are performing.
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To access In the user-defined environment variable area of the "Environment Pane (Test
Settings Dialog Box)""Environment Pane (Test Settings Dialog Box)", do one of
the following:

l To add:Click theNew button.

l To view, modify, or copy:Select the environment variable and click the

View/Edit Environment Variable button .

Important
information

Internal environment variables are available only to the test in which they are
defined.

User interface elements are described below:

UI
Elements Description

Name The name of the variable.

Value The value of the variable.

Tip: To copy the value of the variable to the Clipboard, select the value text,
right-click, and select Copy.

View/Edit Complex Value. Enables you to view the contents of the value in a
multi-line edit box. Available only when the value cannot be displayed entirely in the
Value box.
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Recovery Pane (Test/Business Component Settings
Dialog Box / Application Area - Additional Settings Pane)

Relevant for: GUI tests and components

This pane displays a list of all recovery scenarios associated with the current test or application
area. Recovery scenario settings enable you to specify how a test or business component recovers
from unexpected events and errors during a run session.

This pane also enables you to associate additional recovery scenarios with the test or application
area, create recovery scenarios, remove scenarios from the test or application area, change the
order in which they are applied to the run session, and view a read-only summary of each scenario.

For tests:You can also specify the default list of scenarios to associate with all new tests.

For components: This pane displays the recovery information defined for the application area, in
read-only mode.

The following image shows theRecovery pane in the Test Settings dialog box.

The options and the panes available in the sidebar differ slightly in an application area's Additional
Settings pane and in the Business Component Settings dialog box.
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To access Do one of the following:

l For a test or business component:

With a test, action, or component in focus, select File > Settings > Recovery
node.

l For an application area:

Open the application area and select Additional Settings > Recovery in the
sidebar.

Important
information

For tests:

l The default recovery scenarios provided with UFT are installed in your UFT
installation folder. The paths specifying the default recovery scenarios in the
Recovery pane use an environment variable (%ProductDir%) in the file path.
This enables UFT to locate these recovery scenarios when tests associated
with them are run on different computers or by different HP products. Do not
modify the file paths of these default recovery scenarios or attempt to use the
environment variable for any other purpose.

l You can also associate, remove, enable, disable, prioritize, and view the
properties of the recovery scenarios associated with your test in the Solution
Explorer. For details, see "Solution Explorer Pane" on page 470.

For components:

l The options in this pane are read-only. You define the recovery scenario
settings for a component in its associated application area.

l UFT provides you with a sample recovery file forWeb-related testing. The file
is located in the Test Resources module of your ALM project under
Resources\BPT Resources\Recovery Scenarios\DefaultWeb.qrs.

See also "Recovery Scenarios for GUI Testing" on page 1111

This pane includes the following key elements:

l "Scenarios Area" on the next page

l "Scenario Description andGeneral Options Area" on page 616

l "Scenario Type Icons" on page 616
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Scenarios Area

UI
Element Description

Opens the Add Recovery Scenario dialog box, which enables you to associate one or
more recovery scenarios with the test or application area. For details, see "Add
Recovery Scenario Dialog Box" on page 1120.

Removes the selected recovery scenario from the test or application area.

Moves the selected scenario up in the list, giving it a higher priority.

Moves the selected scenario down in the list, giving it a lower priority.

Displays summary properties for the selected recovery scenario in read-only format.
For details, see "Recovery Scenario Properties Dialog Box" on page 1124.

Scenario
Name

The name of each recovery scenario associated with your test or application area.
You can add, delete, and prioritize the scenarios in the list.

File The file path for each recovery scenario associated with your test or application area.
You can edit the recovery scenario file path by clicking the path once to highlight it,
and then clicking it again to enter edit mode. For details on scenario type icons, see
"Scenario Type Icons" on the next page.

For example, youmay want to modify an absolute file path to be a relative file path.

If youmodify a recovery scenario file path, ensure that the recovery scenario exists
in the new path location before running your test or component.

For tests:

l If your recovery files are stored in the file system and you want other users or HP
products to be able to run this test on other computers, you should set the
recovery file path as a relative path. (Click the path once to highlight it, and then
click it again to enter edit mode.) Any users who want to run this test should then
specify the drive letter and folder in which UFT should search for the relative path
in the Folders pane of the Options dialog box (Tools > Options > GUI Testing
tab > Folders node). For details, see "Folders Pane (Options Dialog Box > GUI
Testing Tab)" on page 544 and "Relative Paths in UFT for GUI Testing" on page
130.

l If you are working with the Resources and Dependencies model with
Quality Center 10.00 or ALM, you should store your recovery files in the Test
Resources module and specify an absolute Quality Center or ALM path in the
Folders pane. For details, see "Relative Paths and ALM" on page 758.
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Scenario Description and General Options Area

UI
Elements Description

Scenario
description

Displays the textual description of the scenario selected in the Scenarios box. You
can select or clear the check box next to each scenario to enable or disable it for
the current test or application area.

Activate
recovery
scenarios

Indicates how often UFT should activate the recovery mechanism:

l On every step. The recovery mechanism is activated after every step.

l On error. The recovery mechanism is activated only after steps that return an
error return value.

l Never. The recovery mechanism is disabled.

Note: ChoosingOn every step may result in slower performance during the
run session.

Set as
Default
(tests only)

Sets the current list of recovery scenario files as the default list to be associated
with new tests.

Note: TheSet as Default option is available for tests only. It is enabled when
the setting for this test is different from the default for all tests.

Note: If the file containing the recovery scenarios is moved or renamed, UFT
will not be able to locate it. The recovery scenario file will be displayed in the
Errors pane when new actions or tests are created. For details on resolving
missing resources, see "Errors Pane" on page 364.

Scenario Type Icons

Icon Description

Indicates that the recovery scenario is triggered by a specific pop-up window in an open
application during the run session.

Indicates that the recovery scenario is triggered when the property values of an object in
an applicationmatch specified values.

Indicates that the recovery scenario is triggered when a step in the test or component
does not run successfully.

Indicates that the recovery scenario is triggered when a specified application fails during
the run session.
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Icon Description

Indicates that the recovery scenario is no longer available for the test or component—
possibly because the recovery file has been renamed ormoved, or can no longer be
accessed by UFT. When an associated recovery file is not available during a run session,
amessage is displayed in the run results.

Log Tracking Pane (Test/Business Component Settings
Dialog Box / Application Area - Additional Settings Pane)

Relevant for: GUI tests and components

This pane enables you to configure your log tracking and collection preferences.

This pane enables you to view your log tracking and collection preferences.

For tests:Use this pane to configure your preferences.

For components: This pane displays the log tracking information defined for the application area,
in read-only mode.

This pane is divided into two sections:

l The settings in the top half are UFT-specific, enabling it to receive logmessages during a run
session.

l The settings in the bottom half are specific to the log configuration file used by your application.

When configured, these settings are used during a run session if yourWindows-based application
uses a Java or .NET log framework that includes a UDP appender. The logmessages generated by
your application are displayed in the run results. You can use this information to detect unexpected
behavior in your application.

The following image shows the Log Tracking pane in the Test Settings dialog box.
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The panes available in the sidebar differ slightly in an application area's Additional Settings pane
and in the Business Component Settings dialog box.

To access Do one of the following:

l For a test or business component:

With a test, action, or component in focus, select File > Settings > Log
Tracking node.

l For an application area:

Open the application area and select Additional Settings > Log Tracking in
the sidebar.
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Important
information

Prerequisites:

l Make sure that the firewall does not block the UDP port.

l The log framework must use an XML-based configuration file. (This enables
you to configure it to send logmessages to UFT.)

l UFT uses timestamps to associate logmessages with the relevant test or
component step. Therefore, if your logging application is located on a remote
computer, make sure that the system clocks on your application's computer
(where UFT is installed) and the remote computer are synchronized.

l Some applications may need to be restarted after modifying the log
configuration file.

Limitations:

l These settings cannot bemodified during a run session.

l If external events affect your application while it is being tested, messages
about these events may also be sent to the run results.

l

Caution: To ensure that log tracking settings are saved for application
areas, make sure that youmake at least one other modification after
modifying theMinimum level to log settings. If necessary, select a
checkbox and then clear it. Settings will not be saved if theMinimum level
to log is the last setting defined.

l For business process tests: Log tracking runs only if the application area
associated with the first component in the business process test enables it.
This means that if another component that runs later in the business process
test is associated with a different application area, log tracking settings from
that application area are ignored.

Relevant
tasks

"How toManually Configure Log Tracking Settings" on page 587

See also l "Log Tracking" on page 586

l The section on the Log Tracking pane in theHP RunResults Viewer User
Guide
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User interface elements are described below:

UI Elements Description

Add log
messages to
run results

Enables UFT to receive logmessages from the log framework used by your
application and to include thesemessages in the run results.

In the Run Results viewer, thesemessages are displayed in the Log Tracking
Results pane. You can click a logmessage to locate the step in the run results
tree at which the event that preceded/triggered themessage occurred
(according to its timestamp). For details, see the section on the Log Tracking
pane in theHP RunResults Viewer User Guide.

Log
messages
source

l Network (0.0.0.0). (Default) Enables UFT to receive logmessages from the
log framework wherever it is located—either on a remote computer on the
network or on the local computer.

l Local (127.0.0.1). Enables UFT to receive logmessages only from the log
framework on the local computer.

Port The port that UFT listens to on the computer on which the log framework runs.
You can select any UDP port that is not in use.

Minimum
level to add
node to
results tree

Theminimum logmessage level for which a node is added to the run results.

A node is inserted in the run results tree directly following each step that
triggers a logmessage that matches or exceeds the value you select in this
option. You can view details for thesemessage in the Result Details pane.

You can also view the generatedmessages in theResults.xml file in the
<Result Name>\Report folder.

Possible values in order of severity:

l TRACE (maps tomicDone)

l DEBUG (maps tomicDone)

l INFO (maps tomicPass)

l WARN (maps tomicWarning)

l ERROR (maps tomicFail)

l FATAL (maps tomicFail)

Default: ERROR
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UI Elements Description

Auto-
configure log
mechanism

Instructs UFT to configure the log framework (via its log configuration file) at the
beginning of every run session according to the settings in this pane.

If you clear this check box, UFT receives logmessages only if youmodify the
log configuration file accordingly. For details, see "How toManually Configure
Log Tracking Settings" on page 587.

When using theAuto-configure log mechanism option, make sure that:

l All logging prerequisites aremet, for example, youmay need to set registry
values that are specific to your application.

l The log framework's configuration file is writable and is in a location that
UFT can access.

l Your application's log framework is configured to use the same file you
specified in the "Configuration file" edit box.

l Your application's log framework canmonitor changes in the configuration
file. If not, then youmust always start your application after the run session
begins so that UFT canmodify the configuration file. For details on starting
your application, see theSystemUtil.Run Method in theStandard
Windows section of theHP UFT Object Model Reference for GUI Testing.
You can also use any standard VB Script command that starts an
application.

Note: If your application's log framework monitors your configuration
file infrequently (for example, once per minute), start your application
immediately after the run session begins. This enables UFT tomodify
the configuration file in time to receive the logmessages generated
during the run session.
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UI Elements Description

Configuration
file

The root path of the configuration file used by the logmechanism. The
configuration file can be stored in any accessible location.

Possible configuration file types:

l *.XML (Java and .NET)

l *.CONFIG (.NET)

l *.LOG4NET (.NET)

Note: UFTcan update only one file per run session, so if there aremultiple
configuration files (for example, if the test or component is validatingmore
than one application - each with its own configuration file), UFT modifies
only the file specified in this text box. If you need to configuremultiple files,
do somanually. UFT can receive logmessages frommultiple applications,
but can auto-configure only one of them.

Minimum
level to log

Theminimum logmessage level that UFT receives from the log framework and
sends to the run results. These logmessages are displayed in the Log Tracking
Pane in the Run Results Viewer and can also be viewed in the
LogMessage.xml file in the <Result Name>\Report folder.

Possible values in order of severity:

l TRACE (maps tomicDone)

l DEBUG (maps tomicDone)

l INFO (maps tomicPass)

l WARN (maps tomicWarning)

l ERROR (maps tomicFail)

l FATAL (maps tomicFail)

Default:WARN

Recover
original
configuration
file after run
session

Restores the configuration file that existed prior to the beginning of the run
session (instead of keeping the configuration file modified at the beginning of
the run session).
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Local System Monitor Pane (Test/Business Component
Settings Dialog Box / Application Area - Additional
Settings Pane)

Relevant for: GUI tests and components

This pane enables you to activate systemmonitoring, and define the system counters you want to
track during a run session. These counters enable you tomonitor the resources used by your
application.

The following image shows the Local System Monitor pane in the Test Settings dialog box.

The panes available from the sidebar differ slightly in the Business Component Settings dialog box
or an application area's Additional Settings pane.
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To access Do one of the following:

l For a test:

With a test, action, or business component in focus, select File > Settings >
Local System Monitor node.

l For an application area:

Open the application area and select Additional Settings > Local System
Monitor in the sidebar.

Important
information

l For components, this pane is read-only.

The Local SystemMonitor data that is captured during a run session is
displayed in the Run Results Viewer. For details, see the section on the the
Run Results Viewer SystemMonitor Pane (described in theHP RunResults
Viewer User Guide).

l If more than one process with the same name runs during a run session, and
youmonitor a counter for that process (for example, you select to monitor a
counter for the iexplorer.exe process, andmore than one Internet Explorer
browser is open on your desktop during the run session), the counter is
sampled from the application that contains at least one test object from the test
or component. If more than one applicationmeets this criterion, only one
application is monitored.

l For business process tests: Local systemmonitoring runs only if the
application area associated with the first component in the business process
test is set to run local systemmonitoring, and only on the application defined in
the Local SystemMonitor pane. This means that if another component that
runs later in the business process test is associated with a different application
area, local systemmonitor settings from that application area are ignored.

See also "Local SystemMonitor" on page 585

User interface elements are described below:

UI Element Description

Enable local
system
monitoring
every: __
seconds

The frequency in seconds, by which the system counters for this application
will be checked.

Use the up and down arrows or enter a value in the edit box to change the
number of seconds.

Minimum value:One second.
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UI Element Description

Application to
monitor

The application whose system counters you want to monitor. You can define
the application in any of the following ways:

l Enter the name of the application's executable file (without file extension)
in the edit box.

l Clicking the down arrow in the edit box, displays a list that contains the
following:

n Applications previously run in UFT.

n Currently running applications.

n Applications currently specified in theWindows-based Applications
tab of the Record and Run Settings dialog box.

n Applications currently specified in the "Applications Pane (Business
Component Settings Dialog Box / Application Area - Additional
Settings Pane)".

l Click the browse button and browse to the application's executable
file.

l Make sure that your application is currently running. Then click the

pointing hand and point to the application on your desktop.

Note: Sometimes a process is used only as a launcher that creates
another process that provides the application functionality. Make sure
to select the executable file that actually provides the application
functionality.

System Counter The system counter you want to track for the selected application. Click
inside a cell and then click the down arrow. Select the counter from the list.
Click the expand button when displayed to show more counters.

You canmonitor the process counters, which are accessible through the
performance console (select Start > Run > and then enterPerfmon). For
details these process counters, see the performance console's Help.

Limit The upper limit of the counter selected in theSystem Counter column. If
the selected counter exceeds this value during the run session, the run fails.

The Limit value is optional. If you do not supply a value, the counter is
tracked and the results are displayed in the Run Results Viewer.

Removes the system counter definition from your test or application area.
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UI Element Description

Description The description of the counter selected in theSystem Counter column, as
provided by the performance console application.

User Guide
Chapter 20: Settings for GUI Tests, GUI Business Components, and Application Areas

HP Unified Functional Testing (12.00) Page 626 of 2274



Chapter 21: Setting GUI Testing Options
Programmatically During the Run Session

Relevant for: GUI tests and scripted GUI components

This chapter includes:

Concepts 628

Setting GUI Testing Options Programmatically During the Run Session - Overview 628

Tasks 629

How to Set GUI Testing Options Programmatically During a Run Session 629
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Concepts

Setting GUI Testing Options Programmatically During the
Run Session - Overview

Relevant for: GUI tests and scripted GUI components

You can use theSetting object to control how UFT runs tests by setting and retrieving testing
options during a run session.

GUI testing options affect how you work with tests. For example, you can set themaximum time
that UFT allows when loading aWeb page, before determining that the URL address cannot be
found.

You can set and retrieve the values of testing options during a run session using the Setting object
in the Editor. For details on working in the Editor, see "Programming in GUI Testing Documents in
the Editor" on page 994.

By retrieving and setting testing options using the Setting object, you can control how UFT runs a
test.

You can also set many testing options using the Options dialog box (global testing options) and the
Test Settings dialog box (test-specific settings). For details, see "UFT Global Options" on page 522
and "Settings for GUI Tests, GUI Business Components, and Application Areas" on page 580.

This chapter describes some of the GUI testing options that can be used with theSetting object
from within a test script. For detailed information on all the available methods and properties for the
Setting object, see theUtility Objects section of theHP UFT Object Model Reference for GUI
Testing.

Note: You can also control UFT options as well as most other UFT operations using
automation scripts. For details, see "UFT Automation Scripts" on page 1155 or theHP Unified
Functional Testing Automation Object Model Reference for GUI Testing (Help > HP UFT GUI
Testing Advanced References > Automation Object Model Reference ).
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Tasks

How to Set GUI Testing Options Programmatically During
a Run Session

Relevant for: GUI tests and scripted GUI components

The following steps describe how you can set and retrieve the values of testing options during a run
session using theSetting object in the Editor.

l "Set the value of a testing option from within the test script" below

l "Retrieve Testing Options" on the next page

l "Control the Test Run" on the next page

l "Add and Remove Run-Time Settings" on page 631

Set the value of a testing option from within the test script
To set the option, use the following syntax:

Setting (testing_option) = new_value

Some options are global and others affect only the current test. After you use aSetting object to set
a testing option, the setting remains in effect until it is changed again or until the end of your current
UFT session. You can also use theSetting object to change a setting for a specific part of a
specific test. For details see "Control the Test Run" on the next page.

Some of the testing options that you can set using theSetting object are also available in the
Options dialog box (global options) or the Test Settings dialog box (test specific settings). When
you use theSetting object to set these options, the change is reflected in the relevant dialog box.
Other test settings can be accessed using only onemethod, either the relevant dialog box or the
Setting object. For more details, see "Setting GUI Testing Options Programmatically During the
Run Session - Overview" on the previous page.

Example:

If you run the following statement with theWeb Add-in loaded:

Setting("AutomaticLinkRun")=1

UFT disables automatically created checkpoints in the test. The setting remains in effect
during your current UFT session until it is changed again, either with another Setting
statement, or by clearing the Ignore automatic checkpoints while running tests or
components check box in theWeb Advanced pane (Tools > Options > GUI Testing tab >
Web > Advanced node).

If you run the following statement:
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Setting("WebTimeOut")=50000

UFT automatically changes the amount of time it waits for aWeb page to load before running a
test step to 50000milliseconds. The setting remains in effect during your current UFT session
until it is changed again, either with another Setting statement, or by setting theBrowser
Navigation Timeout option in theWeb pane of the Test Settings dialog box (File > Settings
> Web pane).

Note: Although the changes youmake using the Setting object are reflected in the Options
and Test Settings dialog boxes, these changes are not saved when you close UFT, unless
youmake other changes in the same dialog box manually and click Apply orOK (which
saves all current settings in that dialog box).

Retrieve Testing Options
You can use theSetting object to retrieve the current value of a testing option.

To store the value in a variable, use the syntax:

new_var = Setting ( testing_option )

To display the value in amessage box, use the syntax:

MsgBox (Setting (testing_option) )

For example:

LinkCheckSet = Setting("AutomaticLinkRun")

assigns the current value of theAutomaticLinkRun setting to the user-defined variable
LinkCheckSet.

Control the Test Run
You can use the retrieve and set capabilities of theSetting object together to control a run session
without changing global settings. For example, if you want to change theDefaultTimeOut testing
option to 5 seconds for objects on oneWeb page only, insert the following statement after theWeb
page opens in your test script:

‘Keep the original value of the DefaultTimeOut testing option
old_delay = Setting ("DefaultTimeOut")
‘Set temporary value for the DefaultTimeOut testing option
Setting("DefaultTimeOut")= 5000
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To return theDefaultTimeOut testing option to its original value at the end of theWeb page, insert
the following statement immediately before linking to the next page in the script:

`Change the DefaultTimeOut testing option back to its
`original value.

Setting("DefaultTimeOut")=old_delay

Add and Remove Run-Time Settings
You can add, modify, and remove custom run-time settings. These settings are applicable during
the run session only.

To add a new run-time setting, use the syntax:

Setting.Add "testing_option", "value"

For example, you could create a setting that indicates the name of the current tester and displays
the name in amessage box.

‘Change the DefaultTimeOut testing option back to its original
‘value.
Setting("DefaultTimeOut")=old_delay

Tip:When using aSetting.Add statement, an error occurs if you try to add an existing setting
option. To avoid this error you should use aSetting.Exists statement first. For details about all
theSettingmethods, see theHP UFT Object Model Reference for GUI Testing.

To modify a run-time setting that has already been initialized, use the same syntax you use
for setting any standard setting option:

Setting ( testing_option ) = new_value

For example:

Setting("Tester Name")="Alice Wonderland"

To delete a custom run-time setting, use the following syntax:

Setting.Remove ( testing_option )
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For example:

Setting.Remove ("Tester Name")

Tip:When using aSetting.Remove statement, an error occurs if you try to remove a setting
option that does not exist. To avoid this error you should use aSetting.Exists statement first.
For more details about all theSettingmethods, see theHP UFT Object Model Reference for
GUI Testing.
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Chapter 22: Running Tests and Components
Relevant for: GUI tests and components and API testing

This chapter includes:

Concepts 635

Running GUI Tests and Components - Overview 635

Running API Tests - Overview 636

Optional Steps 637

Test Batch Runner Overview 637

Tasks 639

How to Run aGUI Test, Business Process Test, or Component 639

How to Set Optional Steps 642

How to Run an API Test 643

How to Create and Run a Test Batch 646

How to Run a Test Batch Using theWindows Command Line 648

Reference 650

Default Optional Steps 650

RunDialog Box 651
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Concepts

Running GUI Tests and Components - Overview
Relevant for: GUI tests and components

When you run a test or component, UFT performs the steps it contains. If you have defined test or
component parameters, UFT prompts you to enter values for them. When the run session is
complete, UFT displays a report detailing the results. For details on viewing run results, see the
HP RunResults Viewer User Guide.

For details about running business process tests, see "How to Create, Maintain, and Run Business
Process Testing Tests and Flows in UFT" on page 2071.

Run Preferences
UFT always runs a test or component from the first step, unless you specify otherwise. You can:

l Run the entire test or component from the beginning.

l Run only a part of a test using the following options:

n Run from Action

n Run to Action

l Run only a part of a test or component. These features are useful if you want to check a specific
section of the test or component, or to confirm that a certain part of your test or component runs
smoothly, without running it from the beginning or to the end. TheRun to Step and theRun to
Action options are also useful if you want to open your application to a specific location to add
steps or debug your test or component. Use the following options:

n Run from Step

n Run to Step

l Debug a section of a test or component using theDebug from step or theDebug from Action
option. (Make sure that the application is open to the relevant location before using this option.)
For details, see "Running to a Step and Debugging from a Step " on page 678.

l Update your test or component to change the test object descriptions.

For tests:You can also change the expected checkpoint values, and/or the Active Screen
images and values. For details, see "Maintaining and Updating GUI Tests or Components " on
page 1078.

l Run tests and components on objects with dynamic descriptions. For details, see "Managing
Test Objects in Object Repositories" on page 1198.

HP Unified Functional Testing (12.00) Page 635 of 2274



l For tests:

n Run an iteration of a single action using theRun Current Action option. Even though this
option runs only one iteration, if the action contains nested actions, UFT runs the nested
actions for the defined number of iterations.

n Run only one iteration of your entire test by selectingRun one iteration only from the Run
pane in the Test Settings dialog box. For details, see "Run Pane (Test Settings Dialog Box)"
on page 601.

n Designate certain steps as optional, to enable UFT to bypass them instead of aborting the
run if these steps do not succeed. For details, see "Default Optional Steps" on page 650.

n Set up a batch of tests and run them sequentially, using the UFT Test Batch Runner. For
details, see "Test Batch RunnerWindow" on page 656.

For tests: Global Data Table Parameters
If your test contains a global Data Table parameter, UFT runs the test once for each row in the Data
pane. If your test contains a Data Table parameter for the current action data sheet, UFT runs the
action once for each row of data in that action data sheet. You can also specify whether to run the
first iteration or all iterations, for the entire test or for a specific action in the test; or to run the
iterations for a specified range of data sets. For details on test iterations, see "Run Pane (Test
Settings Dialog Box)" on page 601. For details on Data Table parameters see, "Data Table
Parameters" on page 1533.

Running API Tests - Overview
Relevant for: API testing

You can run tests directly from the UFT interface or from the command line. The test run enables
you to determine if the activities are functional and if they are performing as expected.

Before running the test, you can select a location in which to store the results, and set input
parameter values specifically for this test run. For details, see "Run Dialog Box" on page 651.

For details about the command line, see "Command Line Syntax for Running API Tests" on page
659.

The RunResults Viewer provides a detailed report about each step and its checkpoints.

When you run custom code from the user interface, you can also use breakpoints and other tools to
debug your code.

Using the Options dialog box, you can set the run configuration—Debug orRelease. TheRelease
mode is more efficient, and is recommended for Load Testing. For details, see "General Pane
(Options Dialog Box > API Testing Tab)" on page 565.

When a test step fails, by default, UFT stops the test. You can instruct UFT to continue the test if
you set theStop test if checkpoint fails option toNO in the Test Settings tab. For details, see
"Test Settings Tab (Properties Pane - API Testing)" on page 429.
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ForWeb Service steps, you can validate the SOAP response against a schema orWS-I standards.
For details, see "Parameters/Checkpoints Tab (Properties Pane - API Testing)" on page 417.

Optional Steps
Relevant for: GUI tests and scripted GUI components

An optional step is a step that is not necessarily required to successfully complete a run session.
For example, suppose that when creating a test or component, you add login steps because the
application you are testing prompts you to enter a user name and password in a login window.
Suppose, too, that this particular application remembers user login details, so that you do not need
to log in every time you open the application. During a run session, the application does not prompt
you to enter your user name and password because it retained the information that was previously
entered. In this case, the steps that you added for entering the login information are not required and
should, therefore, bemarked optional.

During a run session, if the object of an optional step does not exist in the application, UFT
bypasses this step and continues to run the test or component. When the run session ends, a
message is displayed for the step indicating that the step was not performed, but the step does not
cause the run to fail.

However, if, during a run session, UFT cannot find the object from the optional step in the object
repository (for example, if the object namewas modified in the test or component but not in the
object repository, or if the object was removed from the object repository), an error message is
displayed listing the required object, and the run fails.

During a recording session, UFT automatically marks steps that open certain dialog boxes as
optional. (For a list of these dialog boxes, see "Default Optional Steps" on page 650.)

You can alsomanually designate steps as optional. For example, you can add conditional
statements or use recovery scenarios to automatically click a button, press ENTER, or enter login
information in a step. For details, see "Conditional Statements" on page 970, "How to Insert
Conditional Statements from the Keyword View" on page 930, and "Recovery Scenarios for GUI
Testing" on page 1111.

For details, see:

l "How to Set Optional Steps"

l "Default Optional Steps"

Test Batch Runner Overview
Relevant for: GUI testing and API testing

Test Batch Runner enables you to run tests in a collective, successive test run. Tests are run
individually but sequentially in a single session.

You can use Test Batch Runner only on tests stored on the file system. You cannot use Test Batch
Runner for tests stored in ALM.

Using Test Batch Runner, you create a list of tests and save the list as a batch .mtb file, so that you
can run the same batch of tests again at another time. You can choose to include or exclude a test
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in your batch list from running during a particular batch run without affecting the other tests in the
batch.

You can add tests individually to Test Batch Runner by navigating to the folder in which the test is
located. Test batches can also be added to another test batch by adding an .mtb test batch file to a
new test batch. When Test Batch Runner opens, it checks tomake sure that all tests within a test
batch exist.

When running the test batch, the Output pane allows you view the results of the test run in run time.
During the test batch run, the Output pane displays the test's path in the file system, the progress of
the test, as well as any errors that occur during the run.

Following the test batch run, the results are saved to a run results file including whether the test
passed or failed and errors in running the test. TheReport column of the Tests pane displays a link
to the run results file.

If you do not want to run the test batch through the Test Batch Runner interface, you can run the
Test Batch Runner from theWindows Command Line. You provide the location of a .mtb file, a test
folder, or a directory of tests as a command argument and Test Batch Runner runs the test batch
and displays the run results.

Tip: Using the command line options of the Test Batch Runner, you can include UFT tests in
as part of build runs in a continuous integration system.
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Tasks
For details about running business process tests, see "How to Create, Maintain, and Run Business
Process Testing Tests and Flows in UFT" on page 2071.

How to Run a GUI Test, Business Process Test, or
Component

Relevant for: GUI tests and scripted GUI components

This task describes the various ways in which you can run a test or component.

This task includes the following steps:

l "Prerequisites" below

l "Run an entire test or component" below

l "Run to a selected step or action" on the next page

l "Run a single action, test, or a component from a selected step" on the next page

l "Interrupt a run session" on page 641

l "Results" on page 642

Prerequisites

1. Ensure that any required UFT add-ins are loaded. For details, see "How to Start UFT" on page
114.

2. Open the test or component you want to run. For details, see "Open/New
<Document>/<Resource> Dialog Box" on page 156

Run an entire test or component

1. Open the Run dialog box in one of the following ways:

n Click theRun button.

n Select Run > Run.

The Run dialog box opens.
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2. In the Run dialog box, choose where to save the run session results, and define any input
parameters you want to use, as described in "Run Dialog Box" on page 651, and "Run Dialog
Box: Input Parameters Tab (For GUI and API tests and components)" on page 655.

Note: (For tests)When running part of a test within the scope of an action, you need to
specify the action's parameters, not the test parameters, in the Input Parameters tab of
the Run dialog box. For details, see "Parameters Tab (Action Properties Dialog Box)" on
page 903.

3. Click OK. The Run dialog box closes and the run session starts.

Note: For GUI testing:When running a test with external resource files (like function
libraries, data tables, recovery scenarios,etc.) that are saved in ALM, the resource files
are not refreshed for each test run. As a result, any changes made to these external
resource files during the current session are not reflected in a test run until you close and
reload test and its resource files.

Run to a selected step or action

1. Do one of the following:

n For tests:

o Select Run > Run to Step.

o Right-click a step and select Run to Step.

o Right-click an action in the canvas and select Run to Action.

n For components:Select Run > Run to Step.

2. In the Run dialog box, choose where to save the run session results, and define any input
parameters you want to use, as described in "Run Dialog Box" on page 651, and "Run Dialog
Box: Input Parameters Tab (For GUI and API tests and components)" on page 655.

Note: (For tests)When running part of a test within the scope of an action, you need to
specify the action's parameters, not the test parameters, in the Input Parameters tab of
the Run dialog box. For details, see "Parameters Tab (Action Properties Dialog Box)" on
page 903.

The run starts at the beginning of the test or component and pauses at the selected step.

Run a single action, test, or a component from a selected step

1. Make sure your application is in a statematching the step or action you want to run.
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2. Select the step or action where you want to start running the test or component.

Make sure that the step or action you choose is not dependent on previous steps, such as a
retrieved value or a parameter defined in a previous step.

For tests, do one of the following:

n In the canvas, select the action.

n In the Keyword View, highlight a step or action row.

n In the Editor, place your cursor in a line of VBScript.

3. Do one of the following:

n For tests:

o Select Run > Run from Step.

o Select Run > Run Current Action.

o Right-click the step and select Run from Step.

o Right-click the action in the canvas and select Run from Action.

n For components:Select Run > Run from Step.

The Run dialog box opens.

4. In the Run dialog box, choose where to save the run session results, and define any input
parameters you want to use, as described in "Run Dialog Box" on page 651, and "Run Dialog
Box: Input Parameters Tab (For GUI and API tests and components)" on page 655.

Note: (For tests)When running part of a test within the scope of an action, you need to
specify the action's parameters, not the test parameters, in the Input Parameters tab of
the Run dialog box. For details, see "Parameters Tab (Action Properties Dialog Box)" on
page 903.

Interrupt a run session
Do one of the following:

l Click thePause button in the toolbar or select Run > Pause. The run pauses. To resume
running a paused run session, click theRun button or select Run > Run. (Before using the
Pause button, select Run test in debug mode in theOptions > API Testing tab > General
node.)

l Click theStop button, select Run > Stop, or press F4.
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l Perform a file operation (for example, open a different test or component or create a new test or
component).

Results

By default, when the run session ends, the Run Results Viewer opens. For details, see the Run
Results Viewer Overview (described in theHP RunResults Viewer User Guide). If you run part of a
test or component, the Run Results summary displays a note indicating that the test or component
was run using theRun from Step orRun Current Action option.

Note: If you cleared theView results when run session ends check box in theRun
Sessions pane of the Options dialog box (Tools > Options > General tab > Run Sessions
node), the Run Results Viewer does not open at the end of the run session. For details, see
"Run Sessions Pane (Options Dialog Box > General Tab)" on page 526.

You can also optionally automatically upload your run results to ALM if you are running a test from
ALM. This option is set in ALM as a site parameter for your project. For details, see the
HP Application Lifecycle Management Administrator Guide.

How to Set Optional Steps
Relevant for: GUI tests and scripted GUI components

This task describes how to set an optional step.

Do one of the following:

l In the Keyword View, right-click the step and select Optional Step. TheOptional Step icon
is added next to the selected step.

l In the Editor, addOptionalStep to the beginning of the VBScript statement. For example:

OptionalStep.Browser("Browser").Dialog("AutoComplete").WinButton("Yes").Click

For details on working in the Editor, see "Programming in GUI Testing Documents in the Editor"
on page 994.
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How to Run an API Test
Relevant for: API tests

This task describes how to run a test through the user interface and view its results.

For details on running a test through the command line, see "Command Line Syntax for Running
API Tests" on page 659.

This task includes the following steps:

l "Add new tests to a solution - optional" below

l "Set values for the test variables - optional" on the next page

l "Configure checkpoints" on the next page

l "Save the test in ALM - optional" on the next page

l "Add external references - optional" on page 645

l "Set the number of iterations" on page 645

l "Select a location for the run results - optional" on page 645

l "Set runtime property values - optional" on page 645

l "Validate the structure of the SOAP response " on page 645

l "Run the test" on page 645

l "Debug the test - optional " on page 645

l "Analyze the Results" on page 646

1. Add new tests to a solution - optional
To addmore tests to the solution, select File > Add > New Test or File > Add > Existing
Test. To add tests to an ALM repository, first connect to the ALM server. For details, see "ALM
Connection Dialog Box" on page 737.

UFT adds the test to the Solution Explorer pane.

For user interface details, see the "Add Test/Component to Solution Dialog Box" on page 146
or "Add <Existing Document> to Solution Dialog Box" on page 145

Note: If you are running an API test that is stored in ALM and calls a GUI test, youmust
either ensure that UFT is open with a solution open, or youmust close UFT and allow ALM
to open it. The test will not run if UFT is open with no solution.
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2. Set values for the test variables - optional
Select the test properties or user/system variables. For details, see "How to Define API Test
Properties or User/System Variables" on page 141.

3. Configure checkpoints
Checkpoints let you validate the results. For details, see "Checkpoint Validation for Test
Steps" on page 1612.

To add checkpoints, do the following:

a. Click the Input/Checkpoints tab . By default, the pane displays theXML tab. Provide
an expected value for each row in one of the following ways:

o Manually

o Select Link Source dialog box .

o Load from replay button .

b. Select a comparison operator, such as =, >, orRegex. Thesemay differ depending on the
data type.

c. Select theValidate check boxes in the rows of the properties that you want to validate.
Clear the check boxes for the properties you are not validating.

d. Set checkpoints for array elements. For details, see "How to Set Array Checkpoints for
Test Steps" on page 1615:

e. To validate against an XPath expression, click theXPath tab and provide the expression.
For details, see "How to Set XPath Checkpoints for Test Steps" on page 1617:

f. To halt the test run if the response does not return the expected value select Stop test if
checkpoint fails.

Tip: You can customize and override the checkpoint settings using an event handler.
For details, see "Set the value of a checkpoint" on page 1970.

For user interface details, see the "Parameters/Checkpoints Tab (Properties Pane - API
Testing)" on page 417.

For details on how to work with array checkpoints, see "How to Set Array Checkpoints for
Test Steps" on page 1615.

4. Save the test in ALM - optional
To save results in ALM, you need to first save the actual test in ALM. Connect to ALM and then
select File > Save as.
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5. Add external references - optional
You can add one or more references to your test.

a. Open the Solution Explorer pane.

b. Expand the test's tree and select theReferences node.

c. Select Add Reference from the context menu.

d. Specify an external .dll file as a reference.

For details, see the "Add Reference Dialog Box" on page 485.

6. Set the number of iterations

Click in the Test Flow or Loop box and select the Input/Checkpoints tab . Set the number
of iterations in the Properties pane. For details, see "Parameters/Checkpoints Tab (Properties
Pane - API Testing)" on page 417.

7. Select a location for the run results - optional

Tip: To run a test bypassing the Run dialog box, select Run > Run Now.

a. Click theRun button on the toolbar and select theResults Location tab.

b. For tests saved on the File System, select a location in which to store the run results—
New run results folder or Temporary run results folder. Choose the latter if you do not
expect to use and analyze the results. For details, see "Run Dialog Box: Results Location
Tab (For GUI and API Tests Stored on File System)" on page 653.

c. For tests saved in ALM, specify a run name. If relevant, select a Test Set and Instance.

8. Set runtime property values - optional
In the Run dialog box, click the Input Parameters tab and set the values that you want the run
session to use for the listed properties.

9. Validate the structure of the SOAP response
ForWeb Service steps, you can instruct UFT to validate the SOAP response against the
schema orWS-I standards. Set the desired validations in the bottom of the Checkpoints area.
For details, see the "Parameters/Checkpoints Tab (Properties Pane - API Testing)" on page
417.

10. Run the test
Click theOK button in the Run dialog box.

11. Debug the test - optional
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By default, UFT runs tests in releasemode—not debuggingmode. This allows the test to run
much quicker. To run the test in debuggingmode, which also allows you to pause the test
during its run, you need to enable it in the Options dialog box. For details, see "General Pane
(Options Dialog Box > API Testing Tab)" on page 565.

In debuggingmode, select Run > Pause to stop the test run at any point. Use the debug panes
to solve any runtime issues. For user interface details, see the or "Debug Panes" on page 271.

12. Analyze the Results
View the results in the Run Results Viewer. The Run Results Viewer opens automatically after
a test run.

n A green check mark indicates success.

n A redXmark indicates a failure in one of the steps. Expand the nodes of the report to view
details about each step and checkpoint.

To view the report at a later stage, select View > Last Run Results.

To prevent the Results viewer from opening, select Tools > Options > General tab >
General node. Clear the View results when run session ends option.

You can also optionally automatically upload your run results to ALM if you are running a test
from ALM. This option is set in ALM as a site parameter for your project. For details, see the
HP Application Lifecycle Management Administrator Guide.

How to Create and Run a Test Batch
Relevant for: GUI tests and components and API testing

This task explains how to create and run a test batch using Test Batch Runner.

This task includes the following steps:

l "Open Test Batch Runner" on the next page

l "Access the test batch file" on the next page

l "Add batches or tests" on the next page

l "Select the tests to be part of the test batch run" on page 648

l "Save the test batch" on page 648

l "Run the test batch" on page 648

l "View the test batch run results" on page 648
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1. Open Test Batch Runner
Select Start > All Programs > HP Software > HP Unified Functional Testing > Tools >
Test Batch Runner. This opens a separate window for the Test Batch Runner program.

Note:

n You do not need to have UFT open to use Test Batch Runner.

n For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 75.

2. Access the test batch file

n To create a new test batch file, select File > New or click theNew batch file button .

n To open an existing batch file, select File > Open or click theOpen batch file button .
In the Open dialog box, navigate to the folder in which the batch file is found and click Open.
The tests from the opened batch file are added to the Test Batch Runner main window.

3. Add batches or tests

n To add a test batch file (.mtb), select File > Add or click theAdd button . Navigate to
the folder in which the batch file is saved.
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n To add individual tests, select Tests > Add or click theAdd button . In theBrowse
For Folder dialog box, select the folder in which your tests are located. All the tests from
the selected folder are added to the Tests pane in themain Test Batch Runner window.

Note:When adding tests through the Tests > Add menu command, youmust select
all the tests from the target folder. If you do not want to run all the tests in the target
folder, select the check boxes next to the tests you want to run before you run the test
batch.

4. Select the tests to be part of the test batch run
Select the checkboxes for the tests that you want to include in the test batch run.

5. Save the test batch

Select File > Save or click theSave button in the toolbar to save the test batch with the
included test. Give your batch file ameaningful name and assign it to a place in your directory.

6. Run the test batch

Click theRun button to run the test batch. TheOutput pane provides run log details of the
batch run while the batch is running.

7. View the test batch run results
In the Tests pane, click the results link for a specific test in theRun Results column. This
opens the results for that test in the Run Results Viewer. For details on the Run Results
Viewer, click F1 within the viewer window.

How to Run a Test Batch Using the Windows Command
Line

Relevant for: GUI tests and components and API testing

This task describes how to run a test using theWindows Command Line.

This task includes the following steps:

l "Open theWindows Command Line window" on the next page

l "Provide the source folder for the batch file or tests" on the next page

l "Run the test batch" on the next page

l "View the test batch run results (API testing only)" on the next page
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1. Open the Windows Command Line window
Run cmd.exe to open the Command Line window. (For example, from theWindows Run dialog
box.)

2. Provide the source folder for the batch file or tests
In the Command Line window, enterUFTBatchRunnerCMD.exe and the source switch
followed by the test batch file (.mtb) or folder containing the test.

For example, your command linemight contain text like this:

UFTBatchRunnerCMD.exe -source "C:\users\MySample.mtb"
UFTBatchRunnerCMD.exe -source "C:\users\APITest1"

3. Run the test batch
After entering the Test Batch Runner command and the location of the folder containing your
tests, press ENTER. Test Batch Runner runs the test batch. For API tests, the test log is
displayed in the commandwindow.

4. View the test batch run results (API testing only)
When the test batch run is complete:

a. Open the Run Results Viewer from theStartmenu. TheOpen RunResults dialog box
opens.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75.

b. In the Open RunResults dialog box, select theResults XML file option.

c. Navigate to theResults.xml file under the test's Report folder and click Open.

Each test has its own results. For details, see theHP RunResults Viewer User Guide.
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Reference

Default Optional Steps
Relevant for: GUI tests and scripted GUI components

By default, UFT considers steps that open the following dialog boxes or message boxes as optional
steps:

Dialog Box / Message Box Title Bar

AutoComplete

File Download

Internet Explorer

Enter Network Password

Error

Security Alert

Security Information

Security Warning

Username and Password Required

For an overview and task details, see "Optional Steps" on page 637 and "How to Set Optional
Steps" on page 642.
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Run Dialog Box
Relevant for: GUI testing, API testing, and Business Process Testing

This dialog box lets you prepare for the test run by selecting the test to run and providing a location
for the results.
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To access 1. Do one of the following:

n Ensure that a test or component is in focus in the document pane.

n In the Solution Explorer, select a test or component node.

2. Select one of the following:

n Click theRun button or select Run > Run.

n For GUI tests:

o Click theRun button and selectMaintenance Run Mode or select
Run > Maintenance Run Mode.

o Click theRun button and select Update Run Mode or select Run >
Update Run Mode.

Important
information
(for GUI
and API
tests)

As a test runs, each step is highlighted in the Keyword View (GUI Tests only).

l When the test stops running, the Run Results Viewer opens unless you have
cleared theView results when test run ends check box in theRun
Sessions pane of the Options dialog box (Tools > Options > General tab >
Run Sessions node). For details, see "Run Sessions Pane (Options Dialog
Box > General Tab)" on page 526.

l You can also optionally automatically upload your run results to ALM if you are
running a test from ALM. This option is set in ALM as a site parameter for your
project. For details, see theHP Application Lifecycle Management
Administrator Guide.

l You can report defects to an ALM project either automatically as they occur, or
manually directly from the Run Results Viewer. For details, see the online help
in the Run Results Viewer.

l When running API tests, you can bypass this dialog box using theRun > Run
Now menu item.

l For GUI testing:When running a test with external resource files (like
function libraries, data tables, recovery scenarios,etc.) that are saved in ALM,
the resource files are not refreshed for each test run. As a result, any changes
made to these external resource files during the current session are not
reflected in a test run until you close and reload test and its resource files.
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Important
Information
(for
business
process
tests and
flows)

When you run business process tests and flows in UFT, you can only select the
document you are running, if you havemultiple documents open. You cannot
modify the results location, nor can you define any other options.

Note: For improved performance when running business process tests or
flows, UFT creates and runs a hosting test, named Test Runtime. The Test
Runtime test is recreated each time the test or flow runs, and is not saved
with the run.

Relevant
tasks

l "How to Run aGUI Test, Business Process Test, or Component" on page 639

l "How to UseMaintenance RunMode to Update Your Test or Component
When Your Application Changes " on page 1085

l "Running to a Step and Debugging from a Step " on page 678

l "How to Run an API Test" on page 643

l "How to Create, Maintain, and Run Business Process Testing Tests and
Flows in UFT" on page 2071

User interface elements are described below:

UI Elements Description

Test Name The test or component to run. You can select any open item
from the drop-down list.

Results Location
(for GUI, API, and business
process tests)

The target location for the results.

For GUI and API tests, you can specify this location in the
Results Location tab.

For business process tests, results are always saved in the
temporary run results folder.

Options
(for GUI and API tests)

Expands or collapses the dialog box to show theResults
Location and Input Parameters tabs.

Run Begins the run session.

Run Dialog Box: Results Location Tab (For GUI and API Tests Stored on
File System)
This tab enables you to specify where to save run results when running tests stored on the file
system.
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User interface elements are described below:

UI
Elements Description

New run
results
folder

An area allowing you to indicate the results location.

The area displays the default path and folder name in which the results are saved.
A new folder is created for each run. By default, results are stored in the following
locations:

l For tests: The test folder

l For components:An ALM cache folder on your computer

Temporary
run results
folder

Saves the run results in a temporary folder. This option overwrites any results
previously saved in this folder.

Note:

l The path in the text box of the Temporary run results folder option
cannot be changed. Additionally, if you save results to an existing results
folder, the contents of the folder are deleted when the run session starts.

l UFT stores temporary results in%TMP%\TempResults (which is usually
<System Drive>\Documents and Settings\<user name>\Local
Settings\Temp\TempResults).

Run Dialog Box: Results Location Tab (For GUI and APITests Stored in
ALM)
This tab enables you to specify where to save run results when running tests stored in ALM.
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User interface elements are described below:

UI
Elements Description

New run
results in
ALM
project

l Project name. Displays the ALM project to which you are currently connected.

l Run name. The name of the run. You can accept the automatically generated
name or enter a different one.

l Test set. A group of tests selected to achieve specific testing goals. For
example, you can create a test set that tests the user interface of the
application or the application's performance under stress. (You define test sets
when working in the ALM test runmode. For details, see your ALM
documentation.)

l Instance. The instance of the test in the test set. If there is more than one
instance, select the instance of the test for which you want to save the results.

Temporary
run results
folder

Saves the run results in a temporary folder. This option overwrites any results
previously saved in this folder.

Note:

l The path in the text box of the Temporary run results folder option
cannot be changed. Additionally, if you save results to an existing results
folder, the contents of the folder are deleted when the run session starts.

l UFT stores temporary results in%TMP%\TempResults (which is usually
<System Drive>\Documents and Settings\<user name>\Local
Settings\Temp\TempResults)

Run Dialog Box: Input Parameters Tab (For GUI and API tests and
components)
This tab enables you to specify to specify the run-time values of input parameters to be used during
the run session.

User interface elements are described below:

UI
Elements Description

Input
parameters

The input parameters that were defined for the test or component.

To set the value of a parameter to be used during the run session:

Click in theValue field for the specific parameter and enter the value, or select a
value from the list. If you do not enter a value, it uses the default value from the
Test Settings or Business Component Settings dialog box during the run session.
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Test Batch Runner Window
Relevant for: GUI tests and API tests

The Test Batch Runner enables you to create andmaintain test batch files and add tests to a test
batch file.

To access Select Start > All Programs > HP Software > HP Unified Functional Testing
> Tools > Test Batch Runner.

Note: For details on accessing UFT and UFT tools and files inWindows 8,
see "Accessing UFT inWindows 8Operating Systems" on page 75.

Important
information

l You can use Test Batch Runner without having UFT open.

l Test Batch Runner cannot include tests created in QuickTest 9.2 or earlier or
Service Test 10.00 or earlier.

l The panes within this window can bemoved or pinned. Click on a pane and
drag it to move it to your desired location, or right-click on the title of the pane to
change the options for its display.

For more information on how UFT windows can be displayed, see "How to
Customize the UFTWindow " on page 184.

Relevant
tasks

"How to Create and Run a Test Batch" on page 646

See also "Test Batch Runner Menu Commands" on page 658
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Tests Pane
The user interface elements below describe the columns in the Tests pane.

UI
Element Description

Checkboxes that enable you to select the tests to include in the current test batch
run.

Test The name of the tests or test batches included in the test batch.

Opens the filter window that enables you to group tests and results included in the
batch file.

You can filter the tests by a number of criteria using the drop-downmenus at the
bottom of the filter window. You can usemultiple filters by choosing the combination
argument from themiddle drop-downmenu.

Note: This filter can be used for both the Test, Last Run, andRun Results
columns.

Type Displays the type of test: Service Test (ST)/UFT API) or QuickTest (QTP)/UFT GUI.

Status Displays the run status of the test:

l Unknown. The test has not been run or its status is unknown.

l Passed.

l Failed.

l Running.

l Error. The test encountered an error when running the test, such as Test Batch
Runner not being able to find the test or a test missing an testing object.

Note: If the status is displayed as Error, hover over the error icon to see a short
description of the error.

Run
Results

The link to the folder in which the results for the test is saved.

Output Pane
TheOutput pane displays the run long of the test batch. This includes information on the test run:

l the test currently running

l the step that is currently running within a test
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l errors encountered during the test run

l the location of the run results.

Note: This area will remain blank unless there is a test batch running or a batch that has
completed running.

Test Batch Runner Menu Commands
Relevant for: GUI testing and API testing

Youmanage your test batch and individual tests the File and Testsmenu commands.

File Menu Commands
File menu commands are used to create, update, andmaintain test batch (.mtb) files.

Command Shortcut Key Function

New CTRL+N Creates a new batch file (.mtb).

Open CTRL+O Opens an existing batch file.

Add INSERT Adds a batch file to the current batch.

Save CTRL+S Saves a new batch file.

Save As Enables you to save the batch file under another name.

Exit ALT+F4 Closes Test Batch Runner.

Tests Menu Commands
Test menu commands are used to add andmaintain individual tests within the batch file.

Command
Shortcut
key Function

Add Adds individual tests (not batch files) to the current batch.

Note:When using this command, youmust add all tests
from the selected folder to the batch file.

Remove DEL Removes a test from the batch file.

Run F5 Runs the selected tests in the batch file.

Stop Stops the test batch run.
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Test Batch Runner Toolbar
Many of themenu commands are also available by default from the toolbar, shown below:

In addition, the UFT button is not present in the File or Tests menus. It is described below:

UI
Element Description

Use HP Unified Functional Testing license. Instructs Test Batch Runner to use a
Unified Functional Testing license during a batch run. Use this button only if your
batch contains both Service Test/UFT API tests andQuickTest/UFT GUI tests.

How does it work?

When you click Run (or select Tests > Run), Test Batch Runner instructs UFT
to use an HP Unified Functional Testing license. If it cannot use the license type, an
error message opens informing you that if your run a test batch with both Service
Test/UFT API tests andQuickTest/UFT API tests, they will fail.

Note: If you click this button and UFT begins using an HP Unified Functional
Testing license, UFT will continue to use this license for the duration of the batch
run session. To clear this license, youmust close the Test Batch Runner.

Command Line Syntax for Running API Tests
Relevant for: API testing only

You can also run API tests using theServiceTestExecuter.exe application, located in the product's
bin directory.

The following table describes the command line options forServiceTestExecuter.exe:

UI
Elements Description

-test The full path of the test (required). Specify the test directory—not the solution
directory.

-inParams The full path of an XML file containing the input property values (optional).

-
outParams

The full path of an XML file containing the output property values (optional).

-profile The name of an Test profile (optional). For details, see "How to Define API Test
Properties or User/System Variables" on page 141.

-report The directory in which to store the report.
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Tip: To retrieve a list of all of available parameters, runServiceTestExecuter.exewithout any
parameters.

The following example runs Test1 using input properties from inParams.xml and output properties
from outParams.xml:

%ProgramFiles%\HP\Unified Functional Testing\bin> ServiceTestExecuter.exe -test "c:\MyTests
\Test1\" -inParams "c:\MyData\inParams.xml" -outParams "c:\MyData\outParams.xml"
-profile Profile1

where the input property file, InParams.xml, has, for example, this structure:

<TestParameters>
<Values>

<Arguments>
<a>1</a>
<b>2</b>

</Arguments>
</Values>

</TestParameters>

Note: To run a test from the command line, youmust save and run the test at least once.
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Troubleshooting and Limitations - Run Sessions
Relevant for: GUI and API tests

This section describes troubleshooting and limitations related to running tests.

UFT run sessions

l When running UFT on a remotemachine using a Remote Desktop Connection session (RDC) or
using Citrix, if the computer on which the application is being tested is logged off or locked, the
following problems may occur:

n The test or component run sessionmay fail.

n Steps that contain keyboard or focus operations may fail.

n The RunResults still image capture and/or the Screen Recorder may display a black screen.

n Steps for which the device level replay is configured to use themouse (instead of browser
events) to runmouse operations may fail. (You set the device level replay using a
Setting.WebPackage("ReplayType") statement or by setting theReplay type option in the
AdvancedWebOptions dialog box.)

Workaround: If you are using Citrix or a Remote Desktop Connection session to run a test or
component, make sure that the computer on which the application is being tested is not logged
off or locked.

l When running UFT tests or components on a local machine, if the computer on which the
application is being tested is locked, your test runmay fail.

Workaround: Install UFT on a virtual machine (without a screensaver or lock password), and
start or schedule your run session on the virtual machine. Then you can lock your local computer
without locking the virtual machine.

l It is not recommended to use Test Batch Runner with the UAC (User Account Control) feature
set toON.

Learning objects, running steps, and recording steps (GUI testing only)

l UFT cannot record or run steps if it has limited access to the processes of the application you
are testing.

Workarounds:

n Make sure that the application you are testing is started by the sameWindows user as UFT.

n Make sure that neither you nor the tested application actively prevent UFT from accessing
the application's processes.
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l When the title of a window changes during recording, UFT may fail to recognize objects within
that window while running the test or component.

Workaround:Remove the text property from the window's test object description in the Object
Repository window.

l UFT cannot record steps in an action opened as read-only.

Workaround:Make sure that you have read-write access to the action you are recording in.

l When running steps that contain Insight objects:

n The computer sessionmust be active, and the application visible (and not minimized). for the
steps to run successfully. This is because Insight uses data from the screen to compare to
the images stored with your test.

n If you are testing an application running on a remote computer, and you use aminimized
Remote Desktop Connection window, these steps will fail.

Workaround:Use a different program (for example, Virtual Network Computing) instead of
Remote Desktop Connection to run steps on a remote computer.

n For Insight object identification to succeed, the display size defined in the operating system
and the browser zoom levels (if working on a browser) must be the samewhen the test runs
as they were when the objects were learned or recorded.

n When using excluded areas in Insight, the included areamust contain enough significant
content to enable object recognition. If the remaining content is not detailed enough, UFT may
locate too few or toomany matching controls on the screen.

Workaround:Do one or both of the following:

o Use a larger area of the screen for the test object image (make sure to adjust the
ClickPoint such that UFT clicks the correct location on the control). For details, see
"Change Test Object Image / Add Insight Test Object Dialog Box" on page 1233.

o Define Visual Relation Identifiers to help identify the control. For details, see "Visual
Relation Identifier Dialog Box" on page 1251.

n When searching for an Insight object within a parent Browser test object, UFT searches
within the selected browser tab, not in the whole browser window.

n Dual monitor support. Insight is supported only on the primary monitor. Therefore, if you are
working with dual monitors, make sure that your application is visible on the primary monitor
when you use UFT for Insight test objects.

l If you selected theSave movie to results option in the "Screen Capture Pane (Options Dialog
Box > GUI Testing Tab)", the Screen Recorder records amovie of the operations performed on
your primary monitor.
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Therefore, if you are working with multiple monitors, make sure that your application is fully
visible on your primary monitor when recording or running a test or component.

Running Tests (API testing only)

l When youmanually add a reference to an external .dll, UFT prompts you to save it locally. To
change your preference about a specific referenced file, remove the reference and add it again
manually.

l Running tests on remotemachines using shared folders, may require adjusting the .NET 2.0
security settings.

Suggestion:Open theControl Panel and locate theAdministrative Tools, either by browsing
or through a search. In the list of Administrative Tools, look for the following entry:Microsoft
.NET Framework 2.0 Configuration. If it is not present, youmust install the .NET Framework 2.0
SDK.

l The Validate Structure checkpoint fails if the expected value is a SOAP Fault and theWeb
Service call returns anUnsupportedMediaType status.
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Chapter 23: Running Tests with Virtualized
Services

Relevant for: GUI tests and API tests

This chapter includes:

Concepts 665

Running Tests with Virtualized Services - Overview 665

Tasks 667

How to Use a Virtualized Service for a UFT Test 667

Reference 671

Virtualized Services Settings Dialog Box 671
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Concepts

Running Tests with Virtualized Services - Overview
Relevant for: GUI tests API tests

Application testing is usually performed on a real deployment of an application. However,
sometimes the service upon which an application is based is unavailable or impractical for repeated
use or testing. For example, it is impractical to test a flight booking application which requires the
entry of a customer's credit card using the real credit card service run in combination with the
application, as each time the test is run, the customer's credit card is charged. In such cases, you
can replace your application's service with a virtualized service during testing.

Using HP Service Virtualization, you create a virtualized service by configuring the behavior of the
virtual service tomatch the expected behavior of the real service. When you are finished creating
the service's details in Service Virtualization, the service's details are saved as part of a
virtualization project. In UFT, you add the virtualization project to a test. The project's settings
are saved with the test for future testing sessions.

For details on creating a virtualization project and virtual services, see theHP Service Virtualization
User Guide.

When designing your test, you insert the virtual service address differently for GUI and API tests:

l For a GUI test, you insert the service address into your application's code in the function where
the application calls the real service.

l For an API test, you insert the service's address in place of a URL or service address as a step
property.

Before running the test containing the virtualized service, you deploy the service on the Service
Virtualization Server. Then, when you run your test, the test runs using the virtual service as
needed.

For task details, see "How to Use a Virtualized Service for a UFT Test" on page 667.

For user interface details, see "Virtualized Services Settings Dialog Box" on page 671

This section also includes:

Assigning Data and PerformanceModels to a Virtualized Service 665

Assigning Data and Performance Models to a Virtualized Service

Relevant for: GUI tests and API tests

When you create and design a virtualized service, part of the configuration process is defining the
expected behavior for the service: how quickly it should respond, what the requests and responses
to this service should be, and so forth.
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Because of this, you define performancemodels and datamodels for each virtualized service using
Service Virtualization. Thesemodels are then saved with your virtualization project.

Later, when you add a virtualization project in a UFT test, the performancemodels and datamodels
are included with each virtualized service. When you run a test using the virtualized service, you
select one of themodels to use for a test run.

Performance Models
When you create a virtualization project and add services to the project, you can specify precisely
how these services should perform when deployed and run. You can define how quickly the service
responds, how often to send requests and responses to the service, the data load for the simulated
server, and so forth.

After you create the necessary models in Service Virtualization and add the project to a test in UFT,
you can choose whichmodel to use for each test run.

There are a number of different types of performancemodels for a virtualization project:

User-defined: This model reflects the customized performance settings created in Service
Virtualization for a service. Each of the user-defined performancemodels is available for use in your
UFT test.

Offline: This model simulates the unavailability of a service. This model is available for all UFT
tests.

None: This model makes the service respond as quickly as possible. This model is available for all
UFT tests.

For details on setting and defining performancemodels for your service, see theHP Service
Virtualization User Guide

Data Models
In addition to defining performancemodels for your virtualized service, you can also specify data
models. Like performancemodels, the settings for eachmodel are defined in Service Virtualization,
and available for use in UFT tests.

Datamodels enable you to customize the requests and responses of the service to simulate real
service performance. When you create a virtual service, you define the datamodel, either by
providing the requests and responses for the service, or providing a data source that supplies the
request and response values. In addition, you can set rules defining the data source use for each of
the services and each of the different models.

All datamodels are user-defined.

For details on setting and defining datamodels for your service, see theHP Service Virtualization
User Guide.
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Tasks

How to Use a Virtualized Service for a UFT Test
Relevant for: GUI tests and API tests

This task describes how to deploy and use a virtualization project in your test.

This task includes the following steps:

l "Prerequisite - Deploy the Service Virtualization server" below

l "Add a virtualization project to your test in UFT" below

l "Deploy a virtualization project" on the next page

l "Set security credentials for your test to access the virtualization project (optional)" on the next
page

l "Set the data and performancemodels for the virtualization project " on the next page

l "Use the virtualization project in your GUI test" on page 669

l "Use the virtualization project in your API test" on page 669

l "Run the test with a virtualized service" on page 669

l "View the virtualized service details in the run results" on page 669

1. Prerequisite - Deploy the Service Virtualization server
Before you use a virtualization project in a UFT session, youmust start the Service
Virtualization Server. For details, see theHP Service Virtualization User Guide.

2. Add a virtualization project to your test in UFT

a. In UFT, click theVirtualized Services Settings button in the toolbar.

b. In the "Virtualized Services Settings Dialog Box" (described on page 671), click theAdd
Project button.

c. In the Add Project dialog box, navigate to your virtualization project or virtualization project
archive and click OK.

Note: You can open virtualization projects saved in the file system or in an ALM
project.
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d. In themain Virtualized Services Settings dialog box, click OK to add the virtualization
project to your UFT test.

Note: You can addmultiple virtualization projects to the same test.

Tip: If you change your virtualization project at a later date, update the project in UFT
by clickingRefresh Project in themain Virtualized Services Settings dialog box.

3. Deploy a virtualization project
After adding the project to the test, and before running the test with a project, youmust deploy
the project. For subsequent test runs, it is sufficient to check the deployment.

a. In the "Virtualized Services Settings Dialog Box", select the project you want to deploy.

b. Click theDeploy Project button. UFT pauses and checks, and deploys (if necessary) the
project on the server.

If the project is successfully deployed on the Service Virtualization Server, a is
displayed in theDeployed Column of the Virtualized Services Settings dialog box. If the

project is not deployed correctly, a is displayed for the project.

If a project does not deploy correctly, hover over the to see a description of the
problem.

Note: After the initial deployment, you can check the service's deployment before
subsequent run sessions by clicking theCheck Deployment button.

4. Set security credentials for your test to access the virtualization project
(optional)
If the Service Virtualization server running the service requires security, youmust provide
security credentials for UFT to use the deployed service:

a. In the "Virtualized Services Settings Dialog Box", click theServers Security button.

b. In the Servers Security dialog box, enter the user name and password for the servers
running your virtualized service.

UFT uses these credentials each time that it accesses the virtualized service during a test
run.

5. Set the data and performance models for the virtualization project
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For each of your virtualization projects, you can configure how the service uses data when
running the virtualized service. Before running a test using the virtualized service, you need to
instruct UFT which of the associated datamodels to use:

a. In the "Virtualized Services Settings Dialog Box", select the virtualization project to use for
the current test run.

b. In theData Model andPerformance Model column, select the name of the datamodel
and performancemodel from the drop-down list to use for the current test run.

UFT uses the settings specified in the virtualization project for the service's performance
and data usage.

For details on data and performancemodels in your virtualized service, see "Assigning Data
and PerformanceModels to a Virtualized Service" on page 665.

6. Use the virtualization project in your GUI test
Make sure that your application is configured to use the virtual service address, as specified in
the virtualization project. For details on defining virtual service addresses in your virtualization
project, see theHP Service Virtualization User Guide.

7. Use the virtualization project in your API test
When creating your API test steps, you can use the virtualized services in place of calls or
requests to real services, including:

n The URL for yourWeb Service steps

n The URL for your REST Service steps

n The URL for a HTTP Request or SOAP request step

8. Run the test with a virtualized service
After making all necessary changes for your associated virtualization project, run the test by

selectingRun > Run or clicking theRun button .

When the test runs the step using the virtualized service, it accesses the necessary service as
defined in your virtualization project and runs the service.

Note: If you want to disable the virtual services and run the test with the real service, use
theSet all simulated services to standby mode option in the Virtualized Services
Settings dialog box. UFT places all virtualized services in standby and runs the test with a
real service.

9. View the virtualized service details in the run results
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In the Run Results Viewer, navigate to the virtualization step . The service address is
displayed in the result details. as well as details about the service performance (both for the
data and performancemodels).

Note: If your service's deployment state was changed after you checked its deployment
using theCheck Deployment button, the run results report the current deployment state
in the Virtualization table and themost recent seen deployment state from Virtualized
Services Setting dialog box in the service details.
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Reference

Virtualized Services Settings Dialog Box
Relevant for: GUI tests and API tests only

This dialog box enables you to assign a virtualization project created in HP Service Virtualization to
your test and use this virtualized service during a test run.

To access 1. Do one of the following:

n Ensure that a test is in focus in the document pane.

n In the Solution Explorer, select a test.

2. Click theVirtualized Services Settings toolbar button .

Important
information

l If you deployed a service with the Service Designer in Service Virtualization,
youmust stop the service simulation in the Service Virtualization Designer
window, before running the test that uses the virtualized service. Failure to do
so will result in the service being locked for all other users.

l If you loaded a test or a service from the file system or an ALM project and you
lost or changed the ALM connection information, any services and projects are
reported as missing when you refresh the test. If you check the deployment of
the services, they will still work as intended.

l You should not call a test that uses the same virtual service as the current test,
as the virtualized service is locked by the calling test and the called test cannot
run.
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Relevant
tasks

"How to Use a Virtualized Service for a UFT Test" on page 667

See also l "Running Tests with Virtualized Services - Overview" on page 665

l "Assigning Data and PerformanceModels to a Virtualized Service" on page
665

The user elements are described below:

UI Element Description

Set all
simulated
services to
standby mode

Disables the current deployment of all virtualized services currently associated
with your test. When you run your test, the test accesses the real service
instead of the virtual service. By default, this option is selected.

Note: You cannot edit your service details when this option is selected.

Add Project Opens the Add Project dialog box, which enables you to assign virtualization
projects to your test from the file system or from an ALM project.

Note: You can assignmultiple virtualization projects to a test.

Delete Project Deletes association of the selected projects from the test.

Refresh
Project

Updates any changes made in the selected virtualization project.

Caution: After refreshing a project, you need to check that your server
security settings are not lost.

Simulate Enables you to enable or disable the deployment of the selected virtualized
service. When this option is selected, clicking theDeploy Project button or
theCheck Deployment is performed for the selected service only.

Project Name The name of the virtualization project.

Service Name The name of the virtualized service.

Note: This name can be different from the name of the virtualization
project, as you can havemultiple virtual services in the same virtualization
project. For details, see theHP Service Virtualization User Guide.

Data Model The datamodel to use for the current test run. The datamodels and their
properties are defined when designing the virtualization project.

Performance
Model

The performancemodel to use for the current test run. You can choose from a
performancemodel you define in the virtualization project, Offline, orNone.
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UI Element Description

Simulation
Server

The address of the server on which the virtualized service is run.

Note: If the value was configured on the server machine as localhost, be
sure to change it in UFT to the actual server name.

Deployed The status of the selected service. You can see one of the following statuses:

l Unknown.

l Deployed. Successfully deployed.

l Not Deployed. The service is not deployed on the specified Service
Virtualization server.

Tip: If a project does not deploy, hover over the icon to see a
description of the problem.

Deploy
Project

Deploys the selected service on the Service Virtualization Server, if it is not
already deployed.

Note: If you are deploying your project on a secure Service Virtualization
server and you have not installed the service certificate on your machine,
any project that you try to deploy is reported as Not Deployed.

Check
Deployment

Checks the deployment of the selected project and service.

Servers
Security

Opens the Servers Security dialog box, which enables you to enter the user
name and password for the Service Virtualization Server running your
virtualized service.

Note: This information is used by UFT to access a secure server when
running the virtual service during a test run.
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Chapter 24: Debugging Tests and Components
Relevant for: GUI actions, scripted GUI components, function libraries, user code files,
and business process tests

This chapter includes:

Concepts 675

Debugging Overview 675

Considerations for Debugging GUI Tests and Components 676

Considerations for Debugging API User Code Files 676

Debug Session Speed 677

Single Step Commands 677

Running to a Step and Debugging from a Step 678

Watching the Values of Variables and Properties of Objects During a Run Session 680
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Run Errors 682

Tasks 683

How to Debug Your Test, Component, Function Library, or User Code File 683

How to Use Breakpoints 687

How to Debug aGUI Action or a Function - Exercise 689

How to Debug an API User Code File - Exercise 693

How to Step Into, Out of, or Over a Specific Step in a GUI Test - Exercise 697

Reference 701

Run Error Message Box 701

Run/Debug Session Toolbar 702

Troubleshooting and Limitations - Debugging 704
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Concepts

Debugging Overview
Relevant for: GUI actions, scripted GUI components, function libraries, user code files,
and business process tests

After you create testing documents such as a test, component, function library, event handler, or
user code file, you should check that it runs smoothly, without errors in syntax or logic.

By controlling and debugging your run sessions, you can identify and handle problems in your tests,
components, function libraries, registered user functions, event handlers, or user code files.

In order to debug a function library, youmust first associate it with a test or with a component
via its application area, and then debug it from that test or component.

UFT provides different options that you can use to detect and isolate defects in adocument. For
example:

l You can control the run session using thePause command, breakpoints, and various step
commands that enable you to step into, over, and out of a specific step.

l When a run session is suspended, you can use the Debug panes to check andmodify the
values of code objects and variables and tomanually run script or code commands.

l For GUI testing:

n If UFT displays a run error message during a run session, you can click theDebug button on
the error message to suspend the run and debug the document.

n If you are working in a test or component, you can use theDebug from Action (for tests
only) orDebug from Step command to begin (or pause) your debug session at a specific
point in your test or component. You can also use theRun to Action (for tests only) orRun
to Step command to pause the run at a specific point in your test or component. You can set
breakpoints, and then enable and disable them as you debug different parts of your test,
component, or function library.

You can also use theRun from Action (for tests only) orRun from Step to run your test or
component from a selected step or action. This enables you to check a specific section of
your application or to confirm that a certain part of your test, component, or function library
runs smoothly.

n To check a specific section of your test, use theRun Current Action command. This
enables you to check a specific section to ensure that it runs smoothly without running the
entire test.

Debugging business process tests consists of adding breakpoints to specific components or flows
in your test, and running the test, or pausing the test in themiddle of a run session to debug a
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specific step. For details, see "Breakpoints " on page 681. For details about running business
process tests, see "How to Create, Maintain, and Run Business Process Testing Tests and Flows
in UFT" on page 2071.

Considerations for Debugging GUI Tests and
Components

Relevant for: GUI actions, scripted GUI components, and function libraries

l While a test, component, action, or function library is running in debugmode, it is read-only. You
canmodify the content after you stop the debug session (not when you pause it). After you
implement your changes, you can continue debugging your document.

Note: If needed, you can enable the function library for editing after you stop the session.
Right-click the function library tab in the document pane and select Enable Editing. (You
cannot enable editing if the function library is locked by another user or checked in to an
ALM project.)

l If you perform a file operation (for example, you open a different test or component, or create a
new test or component), the debug session stops.

l When debugging a test: If a file is called using anExecuteFile Statement, you cannot debug
the file or any of the functions contained in the file. In addition, when debugging a test that
contains anExecuteFile statement, the executionmarker may not be displayed correctly.

To debug a dynamically loaded function library, use a LoadFunctionLibrary Statement
statement to load it instead of anExecuteFile statement.

l When you open a test or component, UFT creates a local copy of the external resources that are
saved to your ALM project. Therefore, any changes you apply to any external resource that is
saved in your ALM project, such as a function library, will not be recognized in the test or
component until the test or component is closed and reopened. (An external resource is any
resource that can be saved separately from the test or component, such as a function library, a
shared object repository, or a recovery scenario.)

In contrast with this, any changes you apply to external resources saved in the file system, such
as function libraries, are implemented immediately, as these files are accessed directly and are
not saved as local copies when you open your test.

Considerations for Debugging API User Code Files
Relevant for: User code files

l In order to use theAPI debugging features, youmust enable the debugger in the API Testing
General pane of the Options dialog box (Tools > Options > API Testing tab > General node).
Select theRun test in debugging mode check box. For details, see "General Pane (Options
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Dialog Box > API Testing Tab)" on page 565.

l While tests are running in debugmode, they are read-only. You canmodify user code files after
you stop the debug session (not when you pause it).

l When you open a test saved on an ALM project, UFT creates a local copy of the external
references that are saved to your ALM project. Therefore, any changes you apply to any external
reference that is saved in your ALM project, such as aWSDL file, will not be recognized in the
test or component until the test or component is closed and reopened. (An external reference is
any resource that can be saved separately from the test or component, such as aWSDL file,
XML file, or data table.)

Debug Session Speed
Relevant for: GUI actions and scripted GUI components

During a run session, UFT normally runs steps quickly. While you are debugging a test,
component, or function library, youmay want UFT to run the steps more slowly so you can pause
the run when needed or perform another task.

For task details, see "Slow your debugging session (GUI testing only)" on page 684.

Single Step Commands
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

You can run a single step or step-by-step in a test, component, function library, or user code file by
using theStep Into, Step Out, andStep Over commands.

Step Into
Step Into runs only the current step in the active document.

Note: (For GUI testing): When debugging aGUI test, if the current step calls another action or
a function, the called action or function is displayed in the document pane. The test or function
library pauses at the first line of the called action or function.

Step Out
After usingStep Into to enter a step or function in a function library or in a user code file, you can
use theStep Out command. Step Out continues the run to the end of the function, or user code
file, returns to the calling test, component, or function library, and then pauses the run session at
the next line (if one exists).

Step Over
Step Over runs only the current step in the active document.
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If the current step calls a user-defined function, the called function is executed in its entirety, but the
called function script is not displayed in the document pane. The run session then returns to the
calling document and pauses at the next step (if one exists).

Note: (For GUI testing): If the current step calls another action, the called action is displayed
in the document pane, and the run session pauses at the first line of the called action (likeStep
Into).

For task details, see "Step into, out of, or over a specific step during a debug session (GUI and API
tests only)" on page 684.

Running to a Step and Debugging from a Step
Relevant for: GUI actions and scripted GUI components

You can use theRun to Action (tests only), Run to Step, andDebug from Step commands to
instruct UFT to run a test, action, or component (including any associated function library), until it
reaches a particular step or action, or to begin debugging from a specific step or action. You can
also use theDebug from Action (tests only), Run from Action (tests only), andRun from Step
commands to start or continue a run from a particular step or action.

TheRun to Step, Debug from Step, andRun from Step commands are available in theRun
menu, and when you right-click a step in your action or component.

For tests only: TheRun to Action, Debug from Action, andRun from Action commands are
available when you right-click an action in the test canvas.

Run to Step
You can instruct UFT to run from the beginning of the test, action, or component—or from the
current location in the test, action or component—and to stop at a particular step. This is similar to
adding a temporary breakpoint to a step. For example, if you want to begin debugging your test,
action, or component from a particular step, youmay want to run your test, action, or component to
that step, as this opens your application to the relevant location.

Debug from Step
You can instruct UFT to begin your debug session from a particular step instead of beginning the
run at the start of the test, action, or component. Before you start debugging from a specific step,
make sure that the application is open to the location where you want to start debugging. You can
begin debugging from a specific step in your test, action, or component when editing a test, action,
or component.

For task details, see "Start or pause your debugging session at a specific step or action in your test
or component (GUI testing only)" on page 685.

Run from Step
You can instruct UFT to run your test, action, or component from a particular step instead of from
the beginning of the test, action, or component. Before you start running from a specific step, make
sure that the application is open to the location where you want the run to begin.
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For tests:

l In the Editor, theRun from Step option runs your test from the selected step until the end of the
action (or until it reaches a breakpoint). UsingRun from Step in this mode ignores any
iterations. However, if the action contains nested actions, UFT runs the nested actions for the
defined number of iterations of the nested action.

l In the Keyword View, if a single action is displayed, theRun from Step option runs your action
from the selected step until the end of the action (or until it reaches a breakpoint). If the test flow
is displayed, theRun from Step option runs the test from the selected step until the end of the
test (or until it reaches a breakpoint), as long as all of the actions are internal actions that are
local to your test.

Iterations are handled as follows:

n If you select an Action node, theRun from Step option runs only one iteration of the test,
from the selected step until the end of the test. Within the part of the test that runs, UFT runs
each action for the number of iterations defined for that action.

n If you select a step inside an action, theRun from Step option runs only one iteration of the
action, from the selected step until the end of the action. Within the part of the action that
runs, UFT runs any nested actions for the number of iterations defined.

Note: If your test contains a call to an external action, the run session stops when that
action is reached. Similarly, if you use theRun from Step option from within an external
action, the run stops at the end of that action (or when a breakpoint is reached).

For components: TheRun from Step option runs your component from the selected step until the
end of the component (or until it reaches a breakpoint).

Example:

After you debug a part of your action or component, youmay want to skip over a set of steps
that you know work correctly, and then continue the debug session from a later step. You can
do this by inserting a breakpoint in the step where you want to continue debugging, and then
using theRun from Step option to run the action or component from the step at which you
stopped debugging until it reaches the breakpoint.

Alternatively, you can use theRun from Step option to continue the run session from a
particular step to the end of the test, action, or component instead of stopping at a breakpoint.

Run to Action (tests only)
You can instruct UFT to run from the beginning of the test until the beginning of the selected action
and then pause the run session. For example, if you want to begin debugging your test from a
particular action, youmay want to run your test until that action, as this opens your application to
the relevant location.
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Debug from Action (tests only)
You can instruct UFT to begin a debug session, and pause it, at the beginning of the selected
action.

Run from Action (tests only)
You can instruct UFT to start a run session from the beginning of the selected action.

Watching the Values of Variables and Properties of
Objects During a Run Session

Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

You can use theWatch pane and Local Variables pane to view the current value of different code
expressions, variables, and object properties in a suspended run session of your test or component.
A run session is suspended, for example, if you use theRun > Pause command, or when it stops
at a breakpoint.

The Local Variables pane displays the current values and types of all variables in themain script of
the current action, or in a selected function in your test, function library, or user code files.

TheWatch pane displays the current values and the types of code expressions and objects that
you add to the pane.

As you continue stepping through the subsequent steps in your test, function library, or user code
file, UFT automatically updates theWatch pane and Local Variables pane with the current value for
any variable or expression whose value changes. In addition, UFT reevaluates the information
displayed in theWatch pane and Local Variables pane as youmake changes in the context of your
debug session, as selected in the Call Stack pane,

You can add any of the following types of expressions to theWatch pane:

l The name of a GUI test object

l The name of a variable

l The name of a property

l Any other type of code expression

Caution: UFT runs the expressions in theWatch pane to evaluate them. Therefore, do not
add amethod or any expression whose evaluation could affect the state of the test or any
GUI test object, as this can lead to unexpected behavior of your test, component, function
library, or user code file.

Expressions added to theWatch pane are saved with the document and updated accordingly as
youmake changes to your document.

For task details, see "Check andmodify the values of variables and code expressions during a
debug session" on page 685.
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Breakpoints
Relevant for: GUI actions, scripted GUI components, function libraries, user code files,
and business process tests

You can use breakpoints to instruct UFT to pause a run session at a predetermined place in
adocument. UFT pauses the run when it reaches the breakpoint, before executing the step. You
can then examine the effects of the run up to the breakpoint, make any necessary changes, and
continue running the document from the breakpoint.

Breakpoints are saved with your document and aremaintained even after you close and reopen
UFT. UFT maintains the breakpoints inserted in a test or component per user on a given computer.

You can use breakpoints to:

l Suspend a run session and inspect the state of your application

l Mark a point from which to begin stepping through adocument using the "Single Step
Commands" on page 677

For task details, see "How to Use Breakpoints " on page 687.

Note:

l If you a run a test using the Run automationmethod, the test does not stop at breakpoints
even if they are saved in the test.

l If you run a test with breakpoints using the Run automationmethod, the breakpoints remain
visible but are ignored during the test run.

l If you are running a test from the ALM Test Labmodule in hidden mode (as specified in the
UFT Remote Agent, UFT will not stop the test at the breakpoints.

l If you are running a test from the ALM Test Planmodule not in hiddenmode, the test stops
at breakpoints if you select theRun Test Sets in debug mode option in the UFT Remote
Agent

For details on Remote Agent settings, see "Remote Agent Settings Dialog Box" on page 745.

Enabling and Disabling Breakpoints

Relevant for: GUI actions, scripted GUI components, function libraries, user code files,
and business process tests

You can instruct UFT to ignore an existing breakpoint during a debug session by temporarily
disabling the breakpoint. Then, when you run your document, UFT runs the step containing the
breakpoint, instead of stopping at it. When you enable the breakpoint again, UFT pauses there
during the next run. This is particularly useful if your document contains many steps or events, and
you want to debug a specific part of it.
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You can enable or disable breakpoints individually or all at once. For example, suppose you add
breakpoints to various steps throughout your document, but for now, you want to debug only a
specific part of it or a specific event. You could disable all breakpoints in your document and then
enable breakpoints only for specific steps or in specific event handlers. After you finish debugging
that section, you could disable the enabled breakpoints, and then enable the next set of breakpoints
(in the section or event you want to debug). Because the breakpoints are disabled and not removed,
you can find and enable any breakpoint, as needed.

Enabled breakpoint. An enabled breakpoint is indicated by a filled red circle icon (  ) in the left
margin adjacent to the selected step.

Disabled breakpoint. A disabled breakpoint is indicated by an empty circle icon (  ) in the left
margin adjacent to the selected step.

When UFT runs a test without stopping on breakpoints, such as when running in hiddenmode, the
Editor indicates that the breakpoint is not in use.

Run Errors
Relevant for: GUI actions, scripted GUI components, and function libraries and user code
files

Run errors are treated differently for GUI and API tests.

For GUI testing: There are two types of Run Error message boxes that can be displayed during a
run session:

l A pure syntax error. When a syntax run error message box is displayed, click OK in the
message box and address the error.

l The other message box can be displayed in a number of situations. It offers information about
the error and a number of buttons for dealing with errors encountered.

For user interface details, see "Run Error Message Box" on page 701.

For API testing:Run-time errors are reported in the run results.
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Tasks

How to Debug Your Test, Component, Function Library,
or User Code File

Relevant for: GUI actions, scripted GUI components, function libraries, user code files,
and business process tests

This task describes different ways you can control and debug your run sessions so you can identify
and handle problems in your documents.

To practice this task, see "How to Debug aGUI Action or a Function - Exercise" on page 689 (for
GUI testing) or"How to Debug an API User Code File - Exercise" on page 693 (for API testing).

Note: (for GUI testing): You can use the Screen Recorder to capture amovie of your
application as it is being tested. For details, see the section on the Run Results Viewer Screen
Recorder Pane (described in theHP RunResults Viewer User Guide).

This task contains the following sections:

l "Prerequisites" on the next page

l "Slow your debugging session (GUI testing only)" on the next page

l "Step into, out of, or over a specific step during a debug session (GUI and API tests only)" on the
next page

l "Start or pause your debugging session at a specific point (GUI testing and business process
testing only)" on the next page

l "Start or pause your debugging session at a specific step or action in your test or component
(GUI testing only)" on page 685

l "Use breakpoints in your document" on page 685

l "Handle run errors (GUI testing only)" on page 685

l "Check andmodify the values of variables and code expressions during a debug session" on
page 685

l "Manually run code commands during a debug session" on page 686

l "View the current call stacks" on page 687

l "View currently running threads (API testing only)" on page 687

l "View the loadedmodules associated with the run session (API testing only)" on page 687
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Prerequisites
Youmust have theMicrosoft Script Debugger installed to run tests or components in debugmode.
If it is not installed, you can use the UFT Additional Installation Requirements Utility to install it.
(Select Start > All Programs > HP Software > HP Unified Functional Testing > Tools >
Additional Installation Requirements.)

For GUI testing: To debug components in UFT, youmust enable integration between UFT and
your ALM project. In UFT, select Tools > Options > GUI Testing tab > Run Sessions node and
select theAllow other HP products to run tests and components check box.

For API testing: To debug API tests, youmust enable the debugger. Select Tools > Options >
API Testing tab > General node and select Run test in debugging mode.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 75.

Slow your debugging session (GUI testing only)
In the Test Runs pane of the Options dialog box (Tools > Options > GUI Testing tab > Test
Runs node), specify the time (in milliseconds) UFT pauses between each step by modifying the
Delay each step execution by option. For details on the Run pane options, see "Test Runs Pane
(Options Dialog Box > GUI Testing Tab)" on page 539.

Step into, out of, or over a specific step during a debug session (GUI and
API tests only)

l To use theStep Into command select Run > Step Into, click the Step Into button , or
press F11.

l To use theStep Out command select Run > Step Out, click theStep Out button , or press
SHIFT+F11.

l To use theStep Over command select Run > Step Over, click the Step Over button , or
press F10.

For details, see "Single Step Commands" on page 677.

For GUI testing: For an example of using single step commands, see "How to Step Into, Out of, or
Over a Specific Step in a GUI Test - Exercise" on page 697.

Start or pause your debugging session at a specific point (GUI testing and
business process testing only)

l To temporarily suspend a run session, click thePause button or select Run > Pause. A
paused document stops running when all previously interpreted steps have been run.

l To resume running a paused run, click theRun button or select Run > Run. The run
continues from the point it was suspended.
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Start or pause your debugging session at a specific step or action in your
test or component (GUI testing only)

l To instruct UFT to run to a particular step, select the step in your document at which you want
UFT to stop and select Run > Run to Step or press CTRL+F10.

l To instruct UFT to run from a particular step, select the step at which you want UFT to start the
run and select Run > Debug from Step.

Note: These commands can also be used to stop at a specific action. Right-click an action in
the canvas and select Run to Action, Debug from Step, orRun from Action.

Use breakpoints in your document
For details, see "How to Use Breakpoints " on page 687.

Note:

l If you a run a test using the Run automationmethod, the test does not stop at breakpoints
even if they are saved in the test.

l If you run a test with breakpoints using the Run automationmethod, the breakpoints remain
visible but are ignored during the test run.

l If you are running a test from the ALM Test Labmodule in hidden mode (as specified in the
UFT Remote Agent, UFT will not stop the test at the breakpoints.

l If you are running a test from the ALM Test Planmodule not in hiddenmode, the test stops
at breakpoints if you select theRun Test Sets in debug mode option in the UFT Remote
Agent

For details on Remote Agent settings, see "Remote Agent Settings Dialog Box" on page 745.

Handle run errors (GUI testing only)
For details, see "Run Error Message Box" on page 701.

Check and modify the values of variables and code expressions during a
debug session

l To add an expression to theWatch Pane, do one of the following:

n Click theAdd New Watch Expression button in the "Watch Pane" (described on page
297) and enter the name of the expression in the Add New Watch dialog box.

n For GUI actions, scripted GUI components, and function libraries only:Highlight the
selected expression and select Run > Add to Watch right-click the expression and select
Add to Watch from the context menu.
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l To remove an expression from the "Watch Pane", select the row in theWatch pane that you

want to remove and press theDELETE key on your keyboard or press theDelete button .

l To view the current values for all variables up to the current step in the document, use the "Local
Variables Pane".

You can also change the value of a variable or property manually by running code commands in the
Console pane.

For more details, see:

l "Watch Pane" on page 297

l "Local Variables Pane" on page 288

l "Console Pane" on page 292

Note: (GUI testing only)

l To add an identification property to theWatch pane, youmust use an expression that
calls GetROProperty. This enables you to watch the run-time value of the object's
identification property. For example, to watch the value currently displayed in the Calculator
application, you can add the expression:

Window("Calculator").WinEdit("Edit").GetROPRoperty("text")

l You cannot modify the run-time value of an object's identification property from theWatch
pane or the Local Variables pane.

l You can add an expression to theWatch pane from the Editor or from a function library, but
not from the Keyword View.

l To expand the ability of UFT to display information on test objects, it is recommended to
register PDM from Internet Explorer (for versions of Internet Explorer 8 or higher and Visual
Studio 2008).Enter the following in the command line to register the .dll:

regsvr32 "%ProgramFiles%\Internet Explorer\pdm.dll"

Manually run code commands during a debug session
For details, see "Console Pane" on page 292.
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View the current call stacks
To view the currently running call stacks in your run session, select View > Debug > Call Stack.
You can double-click on a stack name in the pane to navigate directly to the line of code that begins
the call stack.

Note: If the location of the call stack is not in a currently open file, UFT opens the relevant file.

View currently running threads (API testing only)
To view the code threads currently running in the run session, select View > Debug > Threads.
You can double-click on a thread's name in the "Threads Pane (API Testing) " (described on page
287) to navigate directly to the beginning of the thread.

Note: If the file containing the beginning of the selected thread is not open, then UFT opens the
relevant file.

View the loaded modules associated with the run session (API testing
only)
To view the associated loadedmodules for your run session, select View > Debug > Loaded
Modules.

How to Use Breakpoints
Relevant for: GUI tests, scripted GUI components, function libraries, user code files, and
business process tests

The following steps describe how to set breakpoints, and temporarily enable or disable them. After
you finish using them, you can remove them from your document.

This task includes the following sections:

l "Set a breakpoint" below

l "Enable or disable a breakpoint" on the next page

l "Enable or disable all breakpoints" on the next page

l "Remove a single breakpoint or all breakpoints" on the next page

Set a breakpoint
To set a breakpoint, do one of the following:

l Click in the left margin of a step in the document where you want the run to stop.

l Select the line where you want the run to stop and select Run > Insert/Remove Breakpoint.

The breakpoint symbol is displayed in the left margin adjacent to the selected step.
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Note:

l If you a run a test using the Run automationmethod, the test does not stop at breakpoints
even if they are saved in the test.

l If you run a test with breakpoints using the Run automationmethod, the breakpoints remain
visible but are ignored during the test run.

l If you are running a test from the ALM Test Labmodule in hidden mode (as specified in the
UFT Remote Agent, UFT will not stop the test at the breakpoints.

l If you are running a test from the ALM Test Planmodule not in hiddenmode, the test stops
at breakpoints if you select theRun Test Sets in debug mode option in the UFT Remote
Agent

For details on Remote Agent settings, see "Remote Agent Settings Dialog Box" on page 745.

Enable or disable a breakpoint
To enable/disable a specific breakpoint, do one of the following:

l Right-click the step containing the breakpoint and select Enable/Disable Breakpoint.

l In the " Breakpoints Pane", select the breakpoint you want to enable or disable and press the

Disable/enable breakpoint button .

Enable or disable all breakpoints
To enable/disable all breakpoints, select Run > Enable/Disable All Breakpoints. If at least one
breakpoint is enabled, UFT disables all breakpoints in the document. Alternatively, if all breakpoints
are disabled, UFT enables them.

Remove a single breakpoint or all breakpoints
To remove a single breakpoint, click the breakpoint icon in the left margin of the step. The
breakpoint symbol is removed from the left margin of the document.

To remove all breakpoints, do one of the following:

l Select Run > Clear All Breakpoints.

l In the " Breakpoints Pane", click theRemove all button .

l In the " Breakpoints Pane", right-click and select Remove all.

All breakpoint symbols are removed from the left margin of the document.

Navigate to a specific breakpoint

1. In the " Breakpoints Pane", select the specific breakpoint to which you want to navigate.
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2. Do one of the following:

n Double-click the line containing the breakpoint name.

n Click theGo to source button .

n Right-click the line containing the breakpoint and select Go to Source.

The cursor flashes in themain document window in the line containing the breakpoint.

How to Debug a GUI Action or a Function - Exercise
Relevant for: GUI actions. scripted GUI components, and function libraries

In this exercise, you create and debug an action or a function, to practice using some of UFT's
debugging capabilities for GUI tests.

Suppose you create an action or a function that defines variables that are used in other parts of your
test or function library. You can add breakpoints to the action or function to see how the value of the
variables changes as the test or function library runs. To see how the test or function library handles
the new value, you can also change the value of one of the variables during a breakpoint.

Note: For a task related to this exercise, see "How to Debug Your Test, Component, Function
Library, or User Code File" on page 683.

This exercise includes the following steps:

l "Create a new action or function" below

l "Associate the function library with a test or application area (function libraries only)" on the next
page

l "Add a call to the function in your test or component (function libraries only)" on page 691

l "Add breakpoints" on page 691

l "Begin running the test or component" on page 691

l "Check the value of the variables in the debug panes" on page 691

l "Check the value of the variables at the next breakpoint" on page 692

l "Modify the value of a variable using the Console pane" on page 692

l "Repeat a command from the command history" on page 692

1. Create a new action or function
a. Do one of the following:
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o For tests:Create or open a test. In addition, as an optional step, you can create or open
a function library.

o For components:Create or open a function library. For details on creating a function
library, see "How to Create andManage Function Libraries" on page 1041.

b. Create a new function calledSetVariables. For details on working with functions, see
"User-Defined Functions and Function Libraries" on page 1029.

Enter the VBScript code in the Editor of your action or the function library, as follows:

Action

Dim a
a="hello"
b="me"
MsgBox a

Function Library

Function SetVariables

Dim a
a="hello"
b="me"
MsgBox a

EndFunction

Formore details on the Editor, see "Programming in GUI Testing Documents in the Editor"
on page 994.

Note: If you are working only with an action in the Editor, skip to Add Breakpoints. If you
are working in a function library (in a test or component), proceed to the next step.

2. Associate the function library with a test or application area (function
libraries only)
a. If you are working with a component, make sure the application area associated with your

component is open.

b. Bring the function library into focus.

c. Right-click the function library document tab and select Associate Library '<Function
Library Name>' with '<Test/ Application Area Name>'. UFT associates the function
library with your test or application area.
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Note: For additional details on how to associate a function library, see "How toManage
Function Library Associations" on page 1045.

3. Add a call to the function in your test or component (function libraries
only)
Do one of the following:

n For tests:Add a call to the function by typing the following in the Editor:

SetVariables

n For components:Add a call to the function by inserting a new operation and choosing
SetVariables from theOperation list.

4. Add breakpoints
Add breakpoints at the lines containing the text b="me" andMsgBox a. For details on adding
breakpoints, see "Breakpoints " on page 681.

5. Begin running the test or component
Run the test or component. The test or component stops at the first breakpoint, before
executing that step (line of script).

6. Check the value of the variables in the debug panes
a. Select View > Debug > Watch to open theWatch pane.

b. In the Editor of your test action or in the function library, highlight the variable a and select
Run > Add to Watch.

UFT adds the variable a to theWatch pane. TheValue column indicates that the value of a
is currently "hello", because the breakpoint stopped after the value of variable a was
initiated. The Type column indicates that a is aString variable.

c. In the Editor displaying your test action or in the function library, highlight the variable b and
select Run > Add to Watch.

UFT adds the variable b to the DebugWatch pane. TheValue column indicates <Variable
is undefined: 'b'> (and the Type column displays Incorrect expression), because the
test or component stopped before variable bwas declared.

d. Select View > Debug > Local Variables to open the Local Variables pane.

For tests:Only variable a is displayed (with the value "hello"), because a is the only
variable that was initiated up to this point.
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For components:BothSetVariables (with the valueEmpty) and variable a (with the
value "hello") are displayed.

For both tests and components, variable b is not displayed because the test or component
stopped before variable bwas declared.

7. Check the value of the variables at the next breakpoint
Click theRun button to continue running the test or component.

The test or component stops at the next breakpoint. Note that the values of variables a and b
were both updated in theWatch and Local Variables panes.

8. Modify the value of a variable using the Console pane
a. Select View > Debug > Console.

b. At the command prompt at the bottom of the pane, enter:
if b="me" then a="b is me" else a="b is you" end if
Then press ENTER on the keyboard.

c. Click the Local Variables pane to verify that the value of variable awas updated according
to the command you entered and now displays the value: "b is me"

d. Click theRun button to continue running the test or component.

Themessage box that opens displays "b is me" (which is themodified value of a). This
indicates that you successfully modified the values of both a and b using the Debug
Console pane.

e. Click OK to close themessage box.

9. Repeat a command from the command history
a. Remove the first breakpoint and run the test or component again.

When the test or component stops at the breakpoint (before displaying themessage box),
modify the value of variable b in the Console pane by running the command b="not me".

b. In the Console pane, highlight the command line that reads if b="me" then a="b is me" else
a="b is you". Then right-click and select Copy.

c. In the command prompt, right-click and select Paste.

d. Press ENTER to run the command, and then click theRun button to complete the test or
component run.

A message box saying "b is you" opens. Click OK to close themessage box.
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How to Debug an API User Code File - Exercise
Relevant for: User code files

In this exercise, you create and debug an API user code file to practice using some of UFT's
debugging capabilities for API tests.

Note: For a task related to this scenario, see "How to Debug Your Test, Component, Function
Library, or User Code File" on page 683.

This scenario includes the following steps:

l "Create test steps" below

l "Set properties for themath steps" below

l "Create parameters for the Custom Code activity" on the next page

l "Link the Custom Code activity to existing steps" on the next page

l "Create events for the Custom Code activity" on page 695

l "Run the test" on page 695

l "Check the value of the variables at the first breakpoint" on page 695

l "Add a variable to theWatch Pane" on page 696

l "Check the value of the variables at the next breakpoint" on page 696

1. Create test steps
a. Create an API test.

b. From the "Toolbox Pane User Interface (API Testing) ", drag theAdd activity,Multiply
activity, and theCustom Code activity to the canvas.

2. Set properties for the math steps
a. In the Input/Checkpoints tab , in the Input pane, enter the values for theAdd4

operation.

o In theValue column forA, enter 10.

o In theValue column forB, enter 6.
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b. In the Input/Checkpoints tab, enter the values for theMultiply operation.

o In theValue column forA, enter 2.

o In theValue column forB, enter 4.

3. Create parameters for the Custom Code activity
a. In the "Add Input/Output Property/Parameter Dialog Box (API Testing)" (described on page

1775), enter the details for the input parameter.

o In theName field, enterAddResult.

o In the Type field, select String from the drop-down list (if it is not already selected).

A new input property calledAddResult appears in the Input pane inside the
Input/Checkpoints tab.

b. Create another input parameter calledMulResult. This time, in the "Add Input/Output
Property/Parameter Dialog Box (API Testing)":

o In theName field, enterMulResult.

o In the Type field, select String from the drop-down list (if it is not already selected).

A new input property calledMulResult appears in the Input pane inside the
Input/Checkpoints tab.

c. Click theAdd button again and select Add Output Property.

d. In the "Add Input/Output Property/Parameter Dialog Box (API Testing)" (described on page
1775), enter the details for the output parameter.

o In theName field, enterResult.

o In the Type field select Decimal from the drop-down list.

e. In theCheckpoints pane, enter the value of 128.

4. Link the Custom Code activity to existing steps
a. In the "Select Link Source Dialog Box (API Testing)" (described on page 1840), select the

AddActivity step. In the right pane, select Result and click OK.

The link sourceStep.OutputProperties.AddActivity<number>.Result appears in the
AddResult row.
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b. In the dialog, select theMultiply step. In the right pane, select Result and click OK.

The link sourceStep.OutputProperties.MultiplyActivity<number>.Result appears in the
MulResult.

5. Create events for the Custom Code activity
a. In the Properties pane, select theCustomCode activity from the drop-down list or by

clicking theCustomCode activity in the canvas.

b. In the Properties pane, select theEvents tab.

c. In the "Events Tab (Properties Pane - API Testing)" (described on page 409), create a
default handler forExecuteEvent andAfterExecuteStepEvent. Two events,
CodeActivity<number>_OnExecuteEvent andCodeActivity<number>_
OnAfterExecuteEvent are added to the TestUserCode.cs file.

For details on API testing event handlers, see "Writing Code for API Test Events -
Overview" on page 1938.

d. In the TestUserCode.cs file, enter the following text in theCodeActivity_OnExecuteEvent:

decimal AddResult = AddActivity.Result;
decimalMulResult = MultiplyActivity.Result;
CodeActivity<number>.Output.Result = AddResult*MulResult;

e. Enter a breakpoint on the last line of this method.

f. In the TestUserCode.cs file, enter the following text in theCodeActivity<number>_
OnAfterExecuteStepEvent:

decimal result = CodeActivity<number>.Output.Result;

g. Enter a breakpoint on the last line of this method.

h. Save the test.

6. Run the test
Select Run > Run or press F5.

7. Check the value of the variables at the first breakpoint
a. When the test run stops at the first breakpoint, select View > Debug > Local Variables to

open the "Local Variables Pane".

b. In the Local Variables pane, see the current values of theAdd andMultiply activity. The
current values should be 16 for theAddActivity and 8 for theMultiplyActivity.
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You can expand the notes on various rows to see the variable values of the different items
used in your test run.

8. Add a variable to the Watch Pane
a. In the TestUsercode.cs tab, highlight the text AddResult.

b. Open theWatch pane by selectingView > Debug > Watch.

c. In the "Watch Pane" (described on page 297), click theAdd New Watch Expression

button and enterAddResult.

A line with the expressionAddResult, with a value of 16, and typeDecimal appears.

d. Click theAdd New Watch Expression button again to add the variableMulResult to the
Watch pane. The pane should display the expressionMulResult, with a value of 8, and
typeDecimal.

9. Check the value of the variables at the next breakpoint
a. Continue the run session by selectingRun > Continue or pressing F5.

b. When the run session pauses at the next breakpoint, highlight the text
CodeActivity<number>.Output.Result and add it to theWatch pane.

The pane displays that the value of this variable is 128.

Note that theAddResult andMulResult values, which you added in the previous step to
theWatch pane, are undefined with a type Incorrect Expression. This is because these
values are present and relevant to the current event.
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c. Click the Local Variables tab. Note that the lineResult displays a value of 128, since the
custom code entered earlier noted that Result is equal toCodeActivity6.Output.Result,
which was equal toAddResult*MulResult.

In addition, if you hover over the variable names in the Editor in the paused run session, an
expandable tooltip displaying the current value of the variable and its properties can be
viewed.

d. Select Run > Continue or click F5 to complete the run session and view the run results.

How to Step Into, Out of, or Over a Specific Step in a GUI
Test - Exercise

Relevant for: GUI actions, scripted GUI components, and function libraries

In this exercise, you create a sample function library and run it (from a test or component) using the
Step Into, Step Out, andStep Over commands.

Note: For a task related to this exercise, see "How to Debug Your Test, Component, Function
Library, or User Code File" on page 683.

This exercise includes the following steps:

l "Create the sample function library and test (tests only)" on the next page

l "Create the sample function library and component (components only)" on the next page

l "Run the function library from your test or component, and use the Step Into, Step Out, and Step
Over commands" on page 699
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1. Create the sample function library and test (tests only)

Note: This procedure is relevant for test actions and function libraries only. If you are
working with a component, see the relevant "Create the sample function library and
component (components only)" belowfor components below.

a. Select File > New > Function Library to open a new function library.

b. In the function library, enter the following lines exactly:

public Function myfunc()
msgbox "one"
msgbox "two"
msgbox "three"

TheEnd Function is automatically added by UFT.

c. Save the function library to your ALM project or to the file system, with the name
SampleFL.qfl. (For details, see "How to Create andManage Function Libraries" on page
1041.)

d. Select File > New > Test and select GUI Test to open a new test.

e. Click the document tab for theSampleFL.qfl function library to bring it into focus.

f. Right-click the function library document tab and select Associate Library
'SampleFL.qfl' with 'Test' to associate the function library with your test.

g. Click the document tab for the action you created to bring it into focus. Click the
Editor/Keyword View toggle button to display the Editor and enter the following lines
exactly:

myfunc
myfunc
myfunc
endOfTest="true"

2. Create the sample function library and component (components only)

Note: This procedure is relevant for components and function libraries only. If you are
working with a test, see the relevant "Create the sample function library and test (tests
only)" abovefor tests, above.
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a. Select File > New > Function Library to open a new function library.

b. In the function library, enter the following lines exactly:

public Function myfunc()
msgbox "one"
msgbox "two"
msgbox "three"

TheEnd Function is automatically added by UFT.

c. Save the function library to your ALM project or to the file system, with the name
SampleFL.qfl. (For details, see "How to Create andManage Function Libraries" on page
1041.)

d. Select File > New > Application Area to open a new application area.

e. Save the application area in your ALM project with the nameSampleAA. (For details, see
"How to Create andManage Application Areas" on page 2097.)

f. Click the document tab for theSampleFL.qfl function library to bring it into focus.

g. Right-click on the function library document tab and select Associate Library
'SampleFL.qfl' with 'SampleAA' to associate the function library with the open
application area.

h. Select File > New > Business Component and select GUI Keyword Component. In
the "New <Document> Dialog Box" (described on page 152), associate the component
with theSampleAA application area that you created and saved in your ALM project.

i. In the component, insert four identical steps. For each step:

o In the Item cell, select Operation.

o In theOperation cell, selectmyfunc.

3. Run the function library from your test or component, and use the Step
Into, Step Out, and Step Over commands
a. Select the first step of the action or component (the first call to themyfunc function) and

add a breakpoint by pressing F9 (Insert/Remove Breakpoint). The breakpoint symbol is
displayed in the left margin . For details, see "Breakpoints " on page 681.

b. Run the test or component. The test or component pauses at the breakpoint.

c. Press F11 (Step Into). The execution arrow points to the first line (msgbox "one") of the
function in the function library.

d. Press F11 (Step Into) again. A message box displays the text one.
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e. Click OK to close themessage box. The execution arrow moves to the next line in the
function.

f. Continue pressing F11 (Step Into) (and pressingOK on themessage boxes that open)
until the execution arrow leaves the function and is pointing to the second step in the action
or component (the second call to themyfunc function).

g. Press F11 (Step Into) to enter the function again. The execution arrow points to the first
msgbox line within the function.

h. Press SHIFT+F11 (Step Out). Close each of themessage boxes that opens. Notice that
the execution arrow continues to point to the first line in the function until you close the last
of the threemessage boxes. After you close the third message box, the execution arrow
points to the next line in the action or component (the third call to themyfunc function).

i. Press F10 (Step Over). The threemessage boxes open again—this time, in the Keyword
View. The execution arrow remains on the same step in the action or component until you
close the last of the threemessage boxes. After you close the third message box, the
execution arrow points to the next step in the action or component.
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Reference

Run Error Message Box
Relevant for: GUI actions, scripted GUI components, and function libraries

This message box enables you to handle run errors during a run session.

To access This message box is displayed when there is a run error during a run session.

Relevant
tasks

"How to Debug Your Test, Component, Function Library, or User Code File" on
page 683

See also "How to Debug aGUI Action or a Function - Exercise" on page 689

User interface elements are described below:

UI
Elements Description

Stop Stops the run session. The run results are displayed if UFT is configured to show run
results after the run.

Retry UFT attempts to perform the step again. If the step succeeds, the run continues.

Skip UFT skips the step that caused the error, and continues the run from the next step.

Debug UFT suspends the run, enabling you to debug the relevant test, component, function
library, or event handler.

You can perform any of the debugging operations described in this chapter. After
debugging, you can continue the run session from the step where the action
component, or function library stopped, or you can use the step commands to control
the remainder of the run session.

Help Opens the UFT troubleshooting Help for the displayed error message. After you
review the Help topic, you can select another button in the error message box.
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Run/Debug Session Toolbar
Relevant for: GUI actions, scripted GUI components, function libraries, and user code files

This toolbar is displayed when you begin a run or debug session.

To access Start a run or debug session.

Important
information

The toolbar buttons described are unique to the Run/Debug Session toolbar. Most
of the toolbar buttons displayed during a run or debug session are common to the
toolbar displayed when designing or editing a test or component.

Relevant
tasks

"How to Debug Your Test, Component, Function Library, or User Code File" on
page 683

See also l "How to Debug aGUI Action or a Function - Exercise" on page 689

l "How to Debug an API User Code File - Exercise" on page 693

User interface elements are described below:

Toolbar
button Name Description

Run Starts a run session or continues a paused run or debug session.

Stop Stops the current run session.

Pause Pauses the current run session.

Step Into Enables you to run only the current step in your document. For details,
see "Step Into" on page 677.

Step Over Enables you to run only the current step in the document. For details,
see "Step Over" on page 677.

Step Out Continues the current run session after the current step until the end of
the current function. For details, see "Step Out" on page 677.

Solution
Explorer
Pane

Displays the Solution Explorer pane as the active pane.

Toolbox
Pane

Displays the Toolbox pane as the active pane.

Data Pane Displays the Data pane as the active pane.
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Toolbar
button Name Description

Properties
Pane

Displays the Properties pane as the active pane.

Debug
Pane

Opens a drop-down list of the debug panes you can bring into focus.
For details, see "Debug Pane Interface" on page 273.

Output
Pane

Displays the Output Pane as the active pane.

Errors Pane Displays the Errors pane as the active pane.

Tasks Pane Displays the Tasks pane as the active pane.

Active
Screen

Displays the Active Screen pane as the active pane.

User Guide
Chapter 24: Debugging Tests and Components

HP Unified Functional Testing (12.00) Page 703 of 2274



Troubleshooting and Limitations - Debugging
Relevant for: GUI actions and scripted GUI components, and function libraries

This section describes troubleshooting and limitations for debugging.

l If a run-time error occurs during a run session, you can click Skip in the error message box that
opens, to skip the problematic step and continue the run session. However, during a debugging
session, if you set a breakpoint on a line immediately after a line that causes a run-time error,
UFT does not stop at this breakpoint when the run session continues after the error.

Workaround:Set the breakpoint at least two lines after the line that causes the run-time error.

l When debugging a test that is running from ALM, use the F9 key andDebugmenu command to
toggle breakpoints. Clicking the left banner in the Editor to toggle breakpoints is not supported in
this scenario.

l GUI testing only:UFTmay stop responding during a debug run session in the following
scenario: If there is a breakpoint at a function call from an associated function library, and you
open the function library after the run stops at the breakpoint, and then you insert or remove a
breakpoint on the first line of the called function.

l GUI testing only:Youmight not be able to run theMicrosoft Visual Studio debugger if UFT is
configured to record and run your test or component on any openWindows-based application.
For tests, you can configure this by selectingRun > Run Settings > Windows Applications.

Workaround:Do one of the following:

n In theMicIPC section of themercury.ini file (located in%SYSTEMROOT%) add these
entries:

devenv.exe=0
msdev.exe=0
msscrdbg.exe=0

n Open the debugging program from a user account other than the one running UFT.

l GUI testing only:WhenMicrosoft PDM 9.x or later is installed on your computer, if you add
action automation objects to theDebug > Watch pane and then close and reopen your test
without closing and opening UFT, these actions may not load successfully.

Workaround:Restart UFT and open your test.

l If you are running a test from the ALM Test Labmodule in hidden mode (as specified in the
UFT Remote Agent, UFT will not stop the test at the breakpoints.
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If you are running a test from the ALM Test Labmodule not in hiddenmode, the test stops at
breakpoints if you select theRun Test Sets in debug mode option in the UFT Remote Agent.

For details on Remote Agent settings, see "Remote Agent Settings Dialog Box" on page 745.

l If you run a BPT test from the ALM Test Planmodule or from UFT, UFT stops the test at all
breakpoints in bothDebug andNormalmodes.
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Chapter 25: ALM Integration
Relevant for: GUI tests and components and API testing

Note: Unless otherwise specified, references toApplication Lifecycle Management orALM
in this guide apply to all currently supported versions of ALM andQuality Center. Note that
some features and options may not be supported in the specific edition of ALM or Quality
Center that you are using.

For a list of the supported versions of ALM or Quality Center, see theHP Unified Functional
Testing Product Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD. Themost up-to-date product availability matrix is available from the
HP Software Product Manuals site, at http://h20230.www2.hp.com/selfsolve/manuals
(requires an HP Passport).

For details on ALM or Quality Center editions, see theHP Application Lifecycle Management
User Guide or theHP Quality Center User Guide.

This chapter includes:

Concepts 709

ALM Integration Overview 709

Template Tests 711

ALM Test Run Preferences 712

Running Tests in Server-Side Execution 713

UFT Remote Agent Preferences 715

Data Awareness in ALM 715

Tasks 719

How toWork with Tests and Components in ALM 719

How to Data Drive a Test Using Data from ALM 720

How to Enable ALM to RunGUI Tests or Components on a UFT Computer 726

How to Run a Test Using Server-Side Execution 727

How to Use the ALM Connectivity Add-in 730

How to Create a Template GUI Test 730

How to Create aGUI Test in ALM Using a Template Test 731

How to Enable the BPT Remote Agent 733

How to View orModify Remote Agent Settings 734

How to Install a Certificate for ALM Servers in a Environment Using External
Authentication 734
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Reference 736

ALM Data Awareness - Task Breakdown 736

ALM Connection Dialog Box 737

Select AUT Parameter Dialog Box 742

Remote Agent Settings Dialog Box 745

Troubleshooting and Limitations - ALM Integration 749

Troubleshooting and Limitations - General ALM Integration 749

Troubleshooting and Limitations - ALM Integration with GUI Testing 752

Troubleshooting and Limitations - ALM Integration with API Testing 752
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Concepts

ALM Integration Overview
Relevant for: GUI tests and components and API testing

UFT integrates with ALM, the HP centralized quality solution. ALM helps youmaintain a project of
all kinds of tests (such as tests, components, business process tests, manual tests, tests created
using other HP products, and so on) that cover all aspects of your application's functionality. Each
test or component in your project is designed to fulfill a specified testing requirement of your
application. Tomeet the goals of a project, you organize the tests in your project in unique groups.

ALM provides an intuitive and efficient method for scheduling and running tests or components,
collecting results, analyzing the results, andmanaging test and component versions. It also
features a system for tracking defects, enabling you tomonitor defects closely from initial detection
until resolution.

At its most basic level, integrating UFT with ALM enables you to store and access tests,
components, application areas, and resource files in an ALM project, when UFT is connected to
ALM.

For API testing users: UFT integrates with Service Test Management, ALM's extension for
storing andmanaging application components, such as Web services. Service Test Management
is an extension of ALM and it provides an efficient method for storing and retrieving application
components.

This section also includes: "What is an ALM Project?" below

What is an ALM Project?

Relevant for: GUI tests and components and API testing

An ALM project is a database for collecting and storing data relevant to a testing process. For UFT
to access an ALM project, youmust connect to the local or remoteWeb server where ALM is
installed.

When UFT is connected to ALM, you can:

l Create tests, components, and resources and save them in your ALM project.

l View the contents of your tests. This can help you decide if you want to run a test as part of a
test set. Note that the Test Flow in ALM and the canvas in UFT display only the actions that are
run when the currently selected test runs. This means that if a nested action is commented out,
for example, that action is not displayed in ALM or in the UFT canvas. You can uncomment it in
the UFT Editor when needed.

l Run your tests and components and view the results in ALM.

l Associate a test, an API component, or a GUI component's application area with
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external files stored in the Test Resources module of an ALMproject.

l Associate external files for all tests or for a single test. For example, suppose you set the
shared object repository mode as the default mode for new GUI tests. You can instruct UFT to
use a specific object repository stored in the Test Resources module in ALM.Likewise, you can
set the default activity repository location for your customAPI test activities in the Test
Resources module in ALM.

For GUI testing: For details on specifying external files for all new GUI tests, see "Folders
Pane (Options Dialog Box > GUI Testing Tab)" on page 544. For details on specifying external
files for a single test, see "Settings for GUI Tests, GUI Business Components, and Application
Areas" on page 580.

For API testing:For details on specifying the default location forAPI activity repositories, see
"General Pane (Options Dialog Box > API Testing Tab)" on page 565.

l Take advantage of all the features provided with the Resources and Dependencies
model. For details, see "Resources and Dependencies Model" on page 754.

GUI testing users can also use these additional features:

l Use the QCUtil object to access and use the full functionality of the ALM OTA (Open
Test Architecture). This enables you to automate integration operations during a run session,
such as reporting a defect directly to an ALM database. For details, see theUtility Objects
section of theHP UFT Object Model Reference for GUI Testing and the ALMOpen Test
Architecture documentation.

l Use the TDOTA object in your automation scripts to access the ALM OTA. For details,
see theHP UFT Object Model Reference for GUI Testing (Help > HP UFT GUI Testing
Advanced References Help > Automation Object Model Reference).

l Report defects to an ALM project either automatically as they occur, or manually
directly from the Run Results Viewer. For details onmanually or automatically reporting
defects to an ALM project, see and the sections on how tomanually or automatically submit
defects to an ALM project in theHP RunResults Viewer User Guide.

Tip: You can save standalone, portable copies of tests stored in an ALM project when
needed. For example, youmay need to open or run a test while traveling because you do not
have access to ALM. For details, see "Portable Copies of Tests" on page 133.

For details on working with ALM, see theHP Application Lifecycle Management User Guide.

For a list of required access permissions for working with ALM, see "Access Permissions " on page
73.
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Template Tests
Relevant for: GUI tests only

Template tests serve as the basis for all tests created in ALM. A template test is a test that
contains default test settings. For example, a template test might specify the UFT add-ins,
associated function libraries, and recovery scenarios that are associated with a test. You can
modify these test settings in the Test Settings dialog box (File > Settings) in UFT.

In addition to default test settings, a template test can also contain any comments or steps you
want to include with all new tests created in ALM. For example, youmay want to add a comment
notifying users which add-ins are associated with the template test, or youmay want to add a step
that opens a specific Web page or application at the beginning of every test. Any steps or
comments you add to a template test are included in all new tests created in ALM that are based on
that template test.

All template tests are saved in your ALM project (except for the default template test, which is
located on the ALM client) and do not need to be copied to each user's local computer. This enables
users to customize their local default template tests, if needed, and still have access to globally
maintained template tests.

When tests based on a specific template test are run from ALM, UFT automatically loads the
associated add-ins and applies the required settings, as defined in the test.

Default Template Test

l A default template test is installed on each ALM client when the Unified Functional Testing Add-
in for ALM is installed in the <Unified Functional Testing folder>\bin\Templates folder on your
computer (for example:%ProgramFiles%\HP Software\Unified Functional
Testing\bin\Templates\Template1).

l When an ALM user creates a new test in ALM, the default template test for the installed UFT
version is automatically associated with the test unless the user selects another template test,
as described in "How to Create a Template GUI Test" on page 730.

l The default template test is installed locally, therefore any changes youmake to the template
test are applied only to tests created on your computer (using the ALM client).

Working with New Template Tests
When you create new template tests, they are stored in your ALM project, making them available to
all ALM users as the basis for new tests created in that ALM project.

You create a template test by first creating a blank test in UFT with the required test settings. Then,
in the Test Plan module of your ALM project, you browse to your test andmark it as a Template
Test. For details, see "How to Create a Template GUI Test" on page 730.

You can createmultiple template tests, each for a specific testing purpose.
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Example of Usage

Youmay want to create one template test for tests that test Web applications with ActiveX
controls, and another for tests that test standardWindows application. You would associate
the ActiveX andWeb add-ins with the first template test. For the second template test, you
would not associate any UFT add-ins at all, but youmight specify theWindows application that
you want to test. You could alsomake other modifications to the test settings for each of the
template tests, as needed.

ALM Test Run Preferences
Relevant for: GUI tests only

You can run tests that are stored in an ALM database via:

l UFT

l ALM client that is installed on your computer

l A remote ALM client

ALM cannot run tests using UFT if the UFT computer is logged off or locked.

When ALM runs your test, it uses the associated add-ins list to load the proper add-ins for you test
on the UFT computer. For details, see "Add-in Associations in a GUI Test" on page 583 and
"Template Tests" on the previous page.

You can instruct UFT to report a defect for each failed step when an ALM test runs on your UFT
computer. You can also submit defects to ALMmanually from the Run Results Viewer. For details,
see How toManually Submit Defects to ALM (described in theHP RunResults Viewer User
Guide).

Before an ALM client can runGUI tests on your computer, youmust give ALM permission to use
UFT (described in "How to Enable ALM to RunGUI Tests or Components on a UFT Computer" on
page 726).

You can also view ormodify the UFT Remote Agent settings (described in "How to View orModify
Remote Agent Settings" on page 734).

Hidden Mode
By default, UFT opens and runs in hiddenmode when ALM activates it to run a test in a test set.
This helps to improve performance.

You can change this setting in the UFT Remote Agent. You can also instruct the Remote Agent to
display a tooltip window indicating that UFT is running an ALM test in hiddenmode. For details, see
"UFT Remote Agent Preferences" on page 715.

While UFT is running in hiddenmode, you can open UFT to view the steps being run in the Editor by
clicking the button in the status bar.
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Running Tests in Server-Side Execution
Relevant for: GUI tests and API testing

You can run tests in server-side execution when the tests are saved on a LabManagement-enabled
ALM server.

Server-side execution enables ALM to run UFT tests on remote hosts at predefined times or on an
ad-hoc basis, without anyone logged in to the host to initiate and control the test runs.

In contrast, client-side execution requires a user to be logged in to the host computer on which ALM
runs the UFT test.

To set up server-side execution on ALM:

1. In the Testing > Test Lab module, create functional test sets. A functional test set is a group
of automated tests or test configurations in an ALM project, designed to achieve a specific
goal.

2. In the Lab Resources > Testing Hostsmodule, select hosts upon which the tests can run
remotely.

3. If you want to use different values for specific parameters when running the tests on different
environments or situations, you can define AUT parameters in the Lab Resources >
AUT Environmentsmodule.

4. In the Testing > Timeslotsmodule, schedule automatic test runs, or reserve timeslots to use
for runningmanually.

Tip: You do not need to reserve a timeslot if you run the tests ad-hoc.

For additional information, see theHP Application Lifecycle Management User Guide.

In UFT, you can link your test parameters to ALM AUT Environment parameters. This enables the
test to use AUT environment parameter values passed from ALM when your UFT test runs in
server-side execution. For details, see "AUT Environment Parameters" below.

Note: Server-side execution is available only for ALM Edition and Performance Center Edition,
version 11.50 or later. Youmust also have LabManagement support for the ALM project.

For task details, see "How to Run a Test Using Server-Side Execution" on page 727.

AUT Environment Parameters

Relevant for: GUI tests and API testing

In ALM, you can define AUT environments, which contain AUT environment parameters, to be
used in tests that run using server-side execution. When ALM runs the tests, it passes the values
for the AUT parameters to the test.
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To createmultiple sets of parameter values for your test runs, you definemultiple AUT environment
configurations in your ALM project. This enables you to use different values for various data in your
test, depending on the application, situation, or environment on which the test runs. For example,
youmay want to run the same test on different Web-based databases, each requiring a different
URL, user name, and password.

In UFT, you can link test parameters to AUT parameters defined in a specific AUT environment in
ALM. Subsequently, when ALM runs the test in server-side execution, the test parameters will
receive the AUT environment parameter values passed from ALM.

l When the test runs in server-side execution, it uses the values provided by ALM for the
corresponding AUT environment parameter.

l When the test runs from UFT, the test uses the parameter’s default values.

For details on how to link test parameters to AUT parameters, see "How to Run a Test Using
Server-Side Execution" on page 727

Note: All of the AUT parameters that you usemust be from the same ALM AUT environment.

If you save the test to the file system, the links to the AUT parameters are removed, and the test
parameters become ordinary parameters. The default values remain defined.

In the Properties pane, an ALM icon next to a parameter's default value indicates that it is an
AUT parameter.

What happens if the ALM AUT parameters linked to the UFT test
parameters are deleted from ALM?

l If you open aGUI test with parameters linked to deleted AUT parameters, UFT displays a
message specifying themissing parameters, and the AUT environment configuration to which
they belonged. The the links to themissing AUT parameters are removed, and those test
parameters become ordinary parameters.

l If you open an API test with test parameters that are linked to deleted ALM AUT parameters, the
links remain unchanged.

l If you run a test with test parameters linked to deleted ALM AUT parameters, the test will fail to
run.
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UFT Remote Agent Preferences
Relevant for: GUI tests and components

When you run a test or business process test from ALM, the UFT Remote Agent opens on the UFT
computer where the test runs. The UFT Remote Agent determines how UFT behaves when a test
is run by a remote application such as ALM.

You can open the Remote Agent Settings dialog box at any time to view ormodify the settings that
UFT uses when ALM runs a test on your computer. For details, see "Remote Agent Settings Dialog
Box" on page 745.

Data Awareness in ALM
Relevant for: GUI tests and components and API testing

Note: The data awareness feature is available when integrating UFT with ALM. It requires the
Unified Functional Testing Add-in for ALM or the QuickTest Professional Add-in for ALM.

In ALM, you can upload and store your Microsoft Excel (.xls) test data resource files in the Test
Resources module, enabling you to use the same data for multiple tests or components, or different
data for each test run.

In ALM, you run configuration instead of standard tests. When working with data-driven tests in
ALM, each configuration is a test that is set to run with a selected data resource file and optional
data filter settings. The filter settings enable you to filter data by specified row numbers, by
parameter text values, or both.

Note: You define andmanage configurations only in ALM.

Example

Suppose you define three configurations in a single test to test an application that provides
different solutions for Gold Card, Silver card, and Bronze Card users. You could use the same
data resource for each configuration by filtering the rows or text of the data resource tomatch
the relevant user type. Similarly, if your data is stored in various .xls or .xlsx files, youmight
want to run the same test using a different data source each time. You would do this by
associating a different data source with each configuration.

By managing your data as a resource in ALM, you can see at a glance which data resource files are
associated with a particular test or configuration, and which tests or configurations are using a
specific data resource. For more details, see "Advantages of Data Awareness in ALM" on page
717.
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How Does Data Awareness in ALM Work?

When you create a test in ALM (or save a test to an ALM project from UFT for the first time), a
default configuration with the same name as the test is created simultaneously. You can view this
configuration in the Configuration tab of the Test Planmodule.

In the ALM Test Resources module, you create one or more data resources and upload one
Microsoft Excel (.xls or .xlsx) file for each.

After you upload a data resource file to your ALM project, you can define the test-level configuration
settings for a particular test. You do this in the Parameters tab of the Test Planmodule by selecting
the data resource file andmapping its column names to the data table parameters in your test. You
can associate one data resource with the test-level configuration. By mapping the column names to
data table parameters, you enable UFT to identify and use the correct parameter value during a run
session.

Note:

For GUI testing:

l Specifying a test-level data resource in the Parameters tab of the ALM Test Planmodule
overrides theData pane settings in the Resources pane of the Test Settings dialog box.

l The data table parameters in your test must be defined in theGlobal sheet.

For API testing:

When running a test, API Testing's Data Navigation feature looks at the data resulting from the
specific configuration. For example, if your ALM configuration filters the data to use only rows 3
through 5, and the API Test Navigation says to iterate rows 2 through 3, the actual data used
will be rows 4 and 5 from the test resource.

In the configuration tab of the Test Planmodule, you can create as many additional configurations
as needed. By default, every configuration uses the test-level configuration settings unless you
override the data resource.

If you associate a configuration with the data resource defined in the Parameters tab, you do not
need tomap the data table parameters to column names. You can, however, modify the filter
settings by applying text filters to any parameter, and/or selecting the rows on which the
configuration can run.

If you associate a different data resource with a configuration, or you select to override the test data
resource and then select the same data resource file that you selected in the Parameters tab (which
the same as selecting a different data resource), you need tomap the data table parameters to the
column names in the .xls or .xlsx file. You can also apply filter settings, as described previously.

If the data table parameter names in theGlobal sheet and the column names in the associated
data resource are identical, you do not need to perform any mappings.
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Next, in the Test Labmodule, you can run any or all of the configurations defined for a test (or
associated with a requirement) by adding them to a test set. When you run a configuration
containing steps that use data table parameters, the parameter values are retrieved from the data
resource files according to the settings defined for that configuration.

For a task describing how to work with configurations, see "How to Data Drive a Test Using Data
from ALM" on page 720.

For a chart listingmodules and tabs in which you perform tasks in ALM, see "ALM Data
Awareness - Task Breakdown" on page 736.

This section also includes:

Advantages of Data Awareness in ALM 717

Considerations for Data Awareness in ALM 718

Advantages of Data Awareness in ALM

Relevant for: GUI tests and API testing

Test reuse. You can use the same test to test various scenarios, each time with a different set of
data. You can do this associated a different data resource with each configuration, by associating a
single data resource with different configurations and then filtering each configuration, or by using a
combination of both.

Data Reuse. You can associate the same data resource with multiple tests or configurations.

Ease of Management. All of your resources are stored in one central location.

Visibility. You can see which tests are using a particular data table, and you can see which data
table each test is using.

Requirements Coverage. You can cover all of your testing requirements by linking them to
specific configurations. This enables you, for example, to use a single test to cover multiple
requirements by associating different configurations in the same test with each requirement.

Resources and Dependencies Model. By storing your data in the Test Resources module, you
can take advantage of additional ALM integration features, such as:

l Version control and baselines

l Asset comparison Tool and Asset Viewer

l Sharing data resources across ALM projects
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Considerations for Data Awareness in ALM

Relevant for: GUI tests and API testing

Consider the following whenmanaging your data resources in ALM:

l Only Microsoft Excel (.xls or .xlsx) files are supported as data resources.

l If youmodify a data table parameter or a column name in the associated data resource after they
aremapped to each other, youmust update themappings accordingly. Additionally, in API tests,
if you update an Excel data source and link properties to the new data source, the new values
will not be reflected in ALM until you remap the properties using theMap Parameters dialog box.

For details, see "How to Data Drive a Test Using Data from ALM" on page 720.

l For GUI testing only: If the data table parameter names in your test's Global sheet are identical
to the column names in the associated data resource file, you do not need to perform any
mapping.
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Tasks

How to Work with Tests and Components in ALM
Relevant for: GUI tests and components and API testing

The following steps describe the workflow of how to work with tests and components saved in an
ALM project.

This task includes the following steps:

l "Prerequisites forWindows 7 andWindows Server 2008 R2Users" below

l "Connect to an ALM Project" below

l "Create or open a test or component" on the next page

l "Create a template test (GUI testing only) - optional" on the next page

l "Create a test using a template test (GUI testing only) - optional" on the next page

l "Set UFT Remote Agent Preferences" on the next page

l "Run your test or component in the ALM project" on the next page

l "Manage versions of your project using version control - optional" on the next page

l "Disconnect from the ALM project" on the next page

Prerequisites for Windows 7 and Windows Server 2008 R2 Users
The security settings inWindows 7 andWindows Server 2008 R2may prevent you from
connecting to an ALM project.

This can occur when the UAC (User Account Control) option is set to ON, and you have never
connected to an ALM project.

To connect to ALM for the first time, youmust disable the UAC option and restart your computer.
After you successfully connect to ALM, you can turn the UAC option on again. Thereafter, you
should be able to connect to ALM, as needed. For details, see "Tools in the HP UFT program group"
on page 2263.

Connect to an ALM Project
For details, see "ALM Connection Dialog Box" on page 737.

Note: If you are connecting to an ALM server using external authentication, you are prompted
as part of the login to select your external certificate.
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Create or open a test or component
For details, see "New <Document> Dialog Box" on page 152 or "Open/New
<Document>/<Resource> Dialog Box" on page 156.

Create a template test (GUI testing only) - optional
Perform this step to create a template test that has pre-defined test settings. You can then use this
template test when creating new tests in ALM. For details, see "How to Create a Template GUI
Test" on page 730.

Create a test using a template test (GUI testing only) - optional
Perform this step to create a test that has the pre-defined test settings defined in a template test.
For details, see "How to Create aGUI Test in ALM Using a Template Test" on page 731.

Set UFT Remote Agent Preferences
Use the Remote Agent to view ormodify the settings that UFT uses when ALM runs a test or
business process test on your computer. For details, see "Remote Agent Settings Dialog Box" on
page 745.

Run your test or component in the ALM project
For GUI testing:"How to Run aGUI Test, Business Process Test, or Component" on page 639
and "Run Dialog Box" on page 651

For API testing: "How to Run an API Test" on page 643 and "Run Dialog Box" on page 651.

Manage versions of your project using version control - optional
For details, see "Managing Versions of Assets in ALMOverview" on page 795.

Disconnect from the ALM project
For details, see "ALM Connection Dialog Box" on page 737.

Note:When you disconnect from a project, all open documents from the project automatically
close.

How to Data Drive a Test Using Data from ALM
Relevant for: GUI tests and API testing

This task provides a general overview of the steps involved in data driving a test with data stored in
ALM. After you are familiar with the steps, you can perform many of them in the order you choose.
Some steps may not be necessary in all cases.

To see a demonstration of this functionality, go to the HP Live Network (HPLN) page and
select theHP ALM Data Awareness for UFTmovie from the list.
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This task includes the following steps:

l "Prerequisites" below

l "Import data into a test (API testing only)" below

l "Data drive the test steps (API testing only)" below

l "Create a data resource file in your ALM project" below

l "Specify a default data table resource for all new test configurations" on the next page

l "Define your test configurations" on page 723

l "Link your configurations to requirements to create requirements coverage - Optional" on page
725

l "Run your test configuration" on page 725

1. Prerequisites
a. Connect to ALM, as described in "ALM Connection Dialog Box" on page 737.

b. Make sure that your test is saved in your ALM project. For details on creating tests and
saving them to ALM, see "New <Document> Dialog Box" on page 152

c. For GUI testing:Make sure you have a test that uses data table parameters from the
Global sheet. For details, see "How to Define Values for Your Step Arguments " on page
928.

2. Import data into a test (API testing only)

a. In the Data pane, click theNew Data Source button and select Excel.

b. In the "New/Change Excel Data Source Dialog Box" (described on page 255), select the
.xls or .xlsx file containing the data and Select theAllow other tools to override the
data option. Click OK to import the data source into your test.

3. Data drive the test steps (API testing only)
For details, see "How to Assign Data to API Test/Component Steps" on page 1819.

4. Create a data resource file in your ALM project
In the Test Resources module:

a. Expand the Resources tree and select the required node.

b. Select Resources > New Resource to add a resource under that node.
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c. In the New Resource dialog box:

o In the Type list, select Data table.

o In theName box, enter a name for the data resource, for example, the name of the
Microsoft Excel (.xls or .xlsx) file you plan to use.

o Fill in the remaining fields (optional) and click OK to close the dialog box.

d. In the Resource Viewer tab, click Upload File. Then browse to and upload the relevant
.xls or .xlsx file.

Note: You can convert an internal data table from an open test to an uploadable data
resource file by right-clicking the Data pane, selecting File > Export, saving the data
table to the file system as an .xls or .xlsx file, and then uploading it as described
above.

5. Specify a default data table resource for all new test configurations
a. In the Parameters tab of the Test Planmodule, select the data table resource you want to

use as the default for all test configurations.

For GUI testing: If you do not specify a data table resource, the data specified in the
Resources pane of the Test Settings dialog box (File > Settings) is used instead.

Note: In this tab, only the Parameter Name column is relevant for GUI tests.
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b. Click theMap Parameters button . In theMap Parameters dialog box, map the data
table parameters (column headings) to the test parameters by entering thematching data
table parameter names in theResource Parameter Name column, as shown in the
example below.

All new configurations use the default mappings unless you specify otherwise in the Data
tab of the Configurations tab. For details, see the next step, Define your test
configurations.

6. Define your test configurations
Define test configurations for various run sessions. For each configuration, you specify
whether to use the default resource file that you specified in the previous step, or whether to
use a different data resource file.

a. In the ALM Test Planmodule, browse to and select the test to which you want to associate
your data table resource. For details, see theHP Application Lifecycle Management User
Guide.

b. Click the Test Configurations tab. A default configuration is displayed in the grid. This
configuration was created when your test was added to the ALM project. For details on
configurations, see "Data Awareness in ALM" on page 715.

c. In the bottom pane of the Configurations tab, click theData tab.

d. In the Data tab:

o Select theOverride test data resource check box to select a different data resource
file from the Test Resources module, or leave the check box blank to use the default
resource file you selected in the Parameters tab in the previous step.

User Guide
Chapter 25: ALM Integration

HP Unified Functional Testing (12.00) Page 723 of 2274



o In theData Resource box, browse to and select the relevant data resource file to
associate with this configuration. (Relevant only if you selected theOverride test data
resource check box)

o Click theData Resource Settings button, and in the Filter Settings dialog box:

o Map the data table parameters from your test to the column headers in the data table
file (Relevant only if you selected a different data resource file in the previous step)

o Apply filter conditions (text strings), as needed. You can apply one filter condition to
each parameter.

o Specify the rows on which to run iterations. For example, if you run a configuration
namedGold, and users of this type are listed in rows 2-114, then specify these rows
only.

Note: If you apply filter conditions and specify rows, AND logic is used, meaning
that the parameter valuemust equal the filter text value and the parameter value
must be located in one of the specified rows.

Example:
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The pLastName data table parameter is mapped to Last_Name and is filtered to
include only parameter text values that equal Smith. The configuration is set to run
only on rows 1-18 in the .xls or .xlsx file you uploaded as the data resource.

For details on this dialog box, see theHP Application Lifecycle Management User Guide.

7. Link your configurations to requirements to create requirements
coverage - Optional
If you want to make sure that your requirements are fully covered, link them to configurations.
This enables you to select configurations to run based on requirement coverage when you plan
your run session.

a. In the Test Planmodule, click theReq Coverage tab.

b. Click theSelect Req button. The Requirement Tree tab is displayed in the right pane.

c. From the Requirement Tree tab, select a requirement to add to the Req Coverage grid.
When you add the requirement, the Add Advanced Coverage dialog box opens.

d. Select the test configurations that cover this requirement.

8. Run your test configuration
You run configurations from ALM.

a. For GUI testing: In UFT, make sure that in the Tools > Options > GUITesting tab >
Test Runs node, theAllow other HP products to run tests and components is
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selected.

b. In the ALM Test Labmodule, select or create a test set. For details, see theHP Application
Lifecycle Management User Guide.

c. In the right pane, select theExecution Grid tab.

d. Click theSelect Tests button to display the Test Plan Tree andRequirements Tree tabs
in the right pane.

e. Do one of the following to select the configurations to run:

o From the Test Plan Tree tab, select a test to add to the Execution Grid. When you add
the test, all of its configurations are added to the Execution Grid. (The test itself is not
added to the Execution Grid because ALM runs configurations, not tests.)

o Below the Test Plan Tree tab, expand the Test Configurations pane, and add the
specific configurations that you want to run to the Execution Grid.

o Below the Requirements Tree tab, expand the coverage pane, and select a test to add
to the Execution Grid. When you add the test, all of its configurations are added to the
Execution Grid. (The test itself is not added to the Execution Grid because ALM runs
configurations, not tests.)

f. Click theRun button to run the selected configurations.

g. After the run session, click the Launch Report button in the Last Run Report tab to view
the results.

How to Enable ALM to Run GUI Tests or Components on
a UFT Computer

Relevant for: GUI tests and components

To enable ALM to run tests or components:
In UFT, select theAllow other HP products to run tests and components option in the in the
Test Runs pane of the Options dialog box (Tools > Options > GUI Testing tab > Test Runs
node). For details, see "Test Runs Pane (Options Dialog Box > GUI Testing Tab)" on page 539.

For security reasons, remote access to your UFT application is not enabled by default. This option
enables ALM (or other remote access clients) to open and run tests.

To enable full access to tests from ALM:
Make sure that the Unified Functional Testing Add-in for ALM or BPT is installed on your ALM client
computer. This enables you to view the test and view the run results in the Run Results Viewer. For
details on this add-in, go to the Unified Functional Testing Add-in screen (accessible from themain
ALM screen).
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You can also optionally automatically upload your run results to ALM if you are running a test from
ALM. This option is set in ALM as a site parameter for your project. For details, see the
HP Application Lifecycle Management Administrator Guide.

For limitations for specific operating systems, see "Troubleshooting and Limitations - ALM
Integration" on page 749.

How to Run a Test Using Server-Side Execution
Relevant for: GUI tests and API testing

This task describes how to run a UFT test from ALM, using server-side execution.

For an overview, see "Running Tests in Server-Side Execution" on page 713.

This task includes the following steps:

l "Prerequisites" below

l "Create tests and save them in ALM" below

l "Create functional test sets in ALM" below

l "Set up AUT Parameters in ALM and link your test parameters to them in UFT - optional" on the
next page

l "Set up hosts in ALM onwhich the UFT tests can run " on page 729

l "Schedule the tests in ALM - optional" on page 729

l "Run the tests from ALM" on page 729

Most of the steps in this task must be performed on ALM. In UFT, you can link your test parameters
to AUT parameters defined in ALM.

1. Prerequisites
n Connect to an ALM project with LabManagement support. For details on connecting to

ALM, see "ALM Connection Dialog Box" on page 737.

n Make sure that HP ALM Lab Service is installed on the UFT computer.

For details, see the ALM LabManagement Guide.

2. Create tests and save them in ALM
Create your tests in UFT or ALM, and save them in ALM.

3. Create functional test sets in ALM
a. In ALM, in the Testing > Test Labmodule, create a functional type test set and specify

the required information.
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b. Select theExecution Grid tab and click Select Tests.

c. In the Test Plan tree, select the tests you want to add to the test set.

4. Set up AUT Parameters in ALM and link your test parameters to them in
UFT - optional
To use parameter values from value sets stored in ALM:

a. In ALM, in the Lab Resources > AUT Environmentsmodule, define AUT environments
with parameters and set values for the parameters. For details, see theHP Application
Lifecycle Management User Guide.

b. In UFT, open the Properties pane to the test parameters tab by doing one of the following:

o Open an API test, select theStart orEnd steps in the canvas, and open the Properties
pane. Then select the Test Input/Output Parameters tab , described on page 417.

o Select a GUI test in the solution explorer. Open the Properties pane, and select the
Parameters tab , described on page 394.

c. Click Add > Add Input Parameter.

For details on the Add Input Parameter dialog box that opens, see "Add/Edit Input/Output
Parameter Dialog Box (Properties Pane - GUI Testing)" on page 397 for GUI tests, or "Add
Input/Output Property/Parameter Dialog Box (API Testing)" on page 1775 for API tests.

d. In the Add Input Parameter dialog box, click theSelect ALM application parameters

button .

e. In the Select AUT Parameter dialog box, expand theAUT Environment node and select a
parameter. Click OK. For details, see "Select AUT Parameter Dialog Box" on page 742.

f. In the Add Input Parameter dialog box, provide a name for the parameter and set the default
value, if necessary. Click OK.

In the Properties pane, an ALM icon next to a parameter's default value indicates that it
is an AUT parameter.

g. To edit the parameters, click theEdit Parameter button in the Properties pane.
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h. To change the parameter to an ordinary parameter, without a linkage to an AUT

environment, click theRemove link to ALM application parameters button in the
Edit Parameter dialog box .

You can repeat these steps to add additional test parameters and link them to ALM
AUT parameters, but all of the AUT parameters that you usemust be from the same ALM
AUT environment.

For more details, see "AUT Environment Parameters" on page 713.

5. Set up hosts in ALM on which the UFT tests can run
In ALM, in the Lab Resources > Testing Hostsmodule, you can view the hosts defined in the
LabManagement project for all projects on your ALM server. Optionally, you can define
additional host machines for your project.

When you define a new host, define its purpose, for example, QuickTest or Service Test, to
indicate the type of test to run on this host. For details, see theHP Application Lifecycle
Management User Guide.

Notes:

n Make sure that UFT is installed on the host computers you create or define in ALM.

n If UFT is not available in the list of purposes that you can select for a host, select
QuickTest Professional for GUI tests orService Test for API tests. Select both if you
plan to run both types of tests.

n For each UFT host on which you want to run GUI tests, enable theAllow other HP
products to run tests and components option in UFT. For details, see "Test Runs
Pane (Options Dialog Box > GUI Testing Tab)" on page 539.

6. Schedule the tests in ALM - optional
In ALM, in the Testing > Timeslotsmodule, schedule times for the tests to run automatically,
or reserve timeslots to use later to run the tests manually.

If you are running the tests ad-hoc, you can skip this step.

7. Run the tests from ALM
In ALM's Testing > Test Lab, specify the hosts on which you want to run the tests, and run
the tests. For details, see theHP Application Lifecycle Management User Guide.

You can also optionally automatically upload your run results to ALM if you are running a test
from ALM. This option is set in ALM as a site parameter for your project. For details, see the
HP Application Lifecycle Management Administrator Guide.
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How to Use the ALM Connectivity Add-in
Relevant for: GUI tests and components and API testing

Install the ALM Connectivity Add-in
You integrate UFT with ALM using the ALM Connectivity Add-in. You can install this add-in as part
of the installation..

You can also install it manually from the ALM Add-ins page by choosingHelp > Add-ins Page >
HP ALM Connectivity in ALM.

After you install the UFT Add-in for ALM as part of the standard installation, youmust also install
theMicrosoft Visual C++ 2005 SP1Redistributable Package on your computer. You can download
this file from http://www.microsoft.com/en-us/download/details.aspx?id=5638.

View the version of the ALM Connectivity Add-in that is currently installed
on your computer
Select Help > About Unified Functional Testing and select Detailed Info. For details, see
"About Unified Functional Testing Dialog Box" on page 115.

How to Create a Template GUI Test
Relevant for: GUI tests only

This task describes how to create a template GUI test. For an overview, see "Template Tests" on
page 711.

How to create a template GUI test in UFT

1. Open an existing test with the required add-ins loaded. For details on loading UFT add-ins, see
the section on loading UFT add-ins in theHP Unified Functional Testing Add-ins Guide.

Note: Make sure that the add-ins included in the opened test are actually installed on the
UFT computer on which the test will eventually run. Otherwise, when the test is run, UFT
will not be able to load the required add-ins and the test may fail.

2. Define the required settings in the Test Settings dialog box (File > Settings). For details, see
"Settings Overview" on page 581.

3. If you want to include comments or steps in all tests based on this template test, add them.

4. Select File > Save As. In the "Save <Resource>/Save <Document> As Dialog Box"
(described on page 164), save the test to your ALM project using a descriptive name that
clearly indicates its purpose.

Tip:
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n In the ALM test plan tree (Test Planmodule), youmay want to create a special folder for
your template tests. This enables other uses to quickly locate the relevant template test
when they create new tests in ALM.

n When you save the test in UFT, you should apply a descriptive name that clearly
indicates its purpose. For example, if the template test is used to associate the ActiveX
andWeb Add-ins with a new test, you could call it ActiveX_Web_Addins_Template.

How to create a template GUI test in ALM

1. Open the project in ALM, click the Test Plan button on the sidebar to open the Test Plan
module, and browse to the test you previously created in UFT and saved in your ALM project.

2. Right-click the test and selectMark as Template Test. The test is converted to a template
test.

How to Create a GUI Test in ALM Using a Template Test
Relevant for: GUI tests only

This task describes how to create a GUI test in ALM using a template test as its basis.

1. In ALM, click the Test Plan button on the sidebar to open the Test Planmodule.

2. In the test plan tree, select a folder.
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3. Click theNew Test button or select Test > New Test. The Create New Test dialog box
opens.

Note: The Template list is displayed only if theUnified Functional Testing Add-in for
ALM is installed on your computer. If the Template box is not displayed, youmust install
theUnified Functional Testing Add-in for ALMfrom the Unified Functional Testing
DVD or from theMore ALM add-ins page (opened from the ALMOptions window, or from
Help > Add-ins Page in ALM.

4. From the Test Type list, select QUICKTEST_TEST.

5. In the Test Name box, type a name for the test start using English (Roman) letters, numbers,
and underscores (if needed). For a list of naming conventions, see "Troubleshooting - Naming
Conventions" on page 2269.

6. Click the Template box browse button. The Select Tests dialog box opens.

7. Expand the folder containing your template test.

8. Select the template test on which to base your new test and click theAdd button . The
Select Tests dialog box closes and the template test you selected is displayed in the Template
box (in the Create New Test dialog box).

9. In the Create New Test dialog box, click OK. The new test is created with the test settings
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defined in the template test.

10. The new test is displayed in the Test Plan tree under the subject folder you selected.

Note: If the Required Fields dialog box opens, set the required values and click OK. For
details, see the ALM administrator guides.

11. Continue creating the test. For details on creating tests in ALM, see theHP Application
Lifecycle Management User Guide.

How to Enable the BPT Remote Agent
Relevant for: GUI tests and components and API testing

If theWindows Firewall is turned on on your computer, and you want to enable business process
tests to be run on your computer from a remote ALM client, then youmust manually create a firewall
exception for the remote agent.

This task describes how to create a firewall exception for the Remote Agent.

1. Make sure you open the ALM or Quality Center client at least once on your computer.

2. Run Firewall.cpl from the command line. TheWindows Firewall dialog box opens.

Note: The remaining steps in this proceduremay be different in different operating
systems.

3. Click theExceptions tab.

4. Click theAdd Program button.

5. In the Add a Program dialog box, browse to the location where the ALM or Quality Center client
is installed and select any of the following files that exist:

n bp_exec_agent.exe

n ComWrapperRemoteAgent.exe

n BptRemoteAgenApplication.exe

Note: Youmay have to repeat this step a few times to add all relevant files.

6. Click OK in the Add a Program dialog box. The files you selected are added to the Programs
and Services list in theWindows Firewall dialog box.

7. Click OK to close theWindows Firewall dialog box.
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For details about Windows firewall exceptions, see your documentation or contact your system
administrator.

How to View or Modify Remote Agent Settings
Relevant for: GUI tests and components

This task describes how to view ormodify the settings in the Remote Agent Settings dialog box.

1. Select Start > All Programs > HP Software > HP Unified Functional Testing > Tools >

Remote Agent. The Remote Agent opens and theRemote Agent icon is displayed in the
task bar tray.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75.

2. Right-click theRemote Agent icon and select Settings. The "Remote Agent Settings Dialog
Box" dialog box (described on page 745) opens.

3. View ormodify the settings in the dialog box. For details, see "Remote Agent Settings Dialog
Box" on page 745.

4. Click OK to save your settings and close the dialog box.

5. Right-click theRemote Agent icon and select Exit to end the Remote Agent session.

How to Install a Certificate for ALM Servers in a
Environment Using External Authentication

Relevant for: GUI tests and components, API testing and business process testing

This task describes how to install a certificate to use an ALM server running in a CAC (Common
Access Card) environment.

1. Request the following from your certificate authority:

n The certificate authority certificate in PEM format. Rename to TrustedCA.pem.

n The web server certificate in PEM format. The full server name should appear in the
certificate. Rename toWebServerPublicCert.pem.

n The server certificate private key file in PEM format. Rename to
WebServerPrivateCert.pem.

n The software client certificate (if a Common Access Card is not used) for one user.

2. Place the certificate files in your web server configuration directory.
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If you receive certificates in different formats, you can use openssl to convert them. To
install openssl, go to http://www.openssl.org/related/binaries.html.

n To convert from CER, use openssl x509 -in /<webserver-directory>/conf/cert.cer -
outform pem -out cert.pem.

n To convert from PFX, do the following: 

o Export the public key by using openssl pkcs12 -in /<webserver-
directory>/conf/cert.pfx -clcerts -nokeys -out certPublic.pem.

o Export the private key by using openssl pkcs12 -in /<webserver-
directory>/conf/cert.pfx -nocerts -nodes -out certPrivate.pem.
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Reference

ALM Data Awareness - Task Breakdown
Relevant for: GUI tests and components and API testing

The following table lists where to perform specific data awareness tasks in ALM:

Module Tab Task

Test Plan Parameters Define the test-level configuration for the current test:

l Specify a data resource file.

l Map the data table parameters used in your test steps to the
column names in your data resource file.

Test
Configurations

Create additional configurations. (Optional)

Data tab:

l Select a different data resource. (Optional)

l Specify the data resource settings:

n Specify the rows to be used during a run session.

n Specify any text parameters values filters. (Optional)

n If you select a different data resource (by overriding the
data resource defined in the Parameters tab), map the
data table parameters used in your test steps to the
column names in your data resource file.

Req Coverage If you add requirement coverage to a test that contains multiple
configurations, specify which configuration(s) to use for
coverage.

(Can also be done from the Requirements module)

Test
Resources

Resource
Viewer

l Create a data resource.

l Upload aMicrosoft Excel (.xls or .xlsx) file to use as the data
resource.
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Module Tab Task

Test Lab Execution Grid l Add all of the configurations in a test to a test set.

l Add only specific configurations to a test set.

l Add all of the configurations contained in a tests that cover
specific requirements to a test set.

l Add only the configurations associated with a specific
requirement to a test set.

ALM Connection Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to connect to or disconnect from a project in any supported version of
ALM.

For more details, see "ALM Integration Overview" on page 709.
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To access Use one of the following:

l In UFT:Select ALM > ALM Connection.

l In the Run Results Viewer: Select Tools > ALM Connection.

l Click theALM toolbar button .
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Important
information

l 1st time connection. The first time you connect to an ALM server, youmust
connect as a user with administrator privileges on the computer on which you
are connecting.

l Connecting to ALM while a Web connection to Quality Center 10.00 is
open. You can simultaneously connect yourWeb browser to an ALM client
and aQuality Center 10.00 client. However, if you want to connect to an ALM
client from UFT, youmust close any Web connections to a
Quality Center 10.00 client.

l Connecting to different versions of Quality Center or ALM. You cannot
connect to multiple versions of Quality Center or ALM in the sameUFT
session. Close and reopen UFT to connect to a different version of Quality
Center or ALM.

l Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server
2012 Users. The security settings in the following operating systems may
prevent you from connecting to an ALM project:

n Windows 7

n Windows Server 2008 R2

n Windows 8

n Windows Server 2012

This can occur when the UAC (User Account Control) option is set to ON, and
you have never connected to an ALM project.

To connect to ALM for the first time, youmust disable the UAC option. After
you successfully connect to ALM, you can turn the UAC option on again.
Thereafter, you should be able to connect to ALM, as needed.

For details see "Tools in the HP UFT program group" on page 2263.

l Connect. The connection process has two steps. First, you connect to a local
or remote ALM server. This server handles the connections between UFT and
the ALM project. Youmust provide a user name and a password.

Next, you choose the project you want to access. The project stores tests and
run session information for the application you are testing.

l Disconnect. You can disconnect from an ALM project or from an ALM server.

n If you disconnect from an ALM server without first disconnecting from a
project, the UFT connection to that project database is automatically
disconnected.

n After you open a Business Process test in UFT, you cannot log out of a
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project and log in to another project on the same server. Youmust first
disconnect from the server and reconnect before logging in to another
project.

l SSL Certificates. If you are attempting to connect to an ALM project with a
https:// prefix, but your computer does not have a valid SSL certificate, the
connection will fail.

l ALM servers using external authentication. To use an ALM server using
external authentication, youmust have your external certificate installed on
both the computer running ALM and the computer running UFT. When you log
in to the ALM server using external authentication, a dialog prompts you to
select your certificate from the list of available certificates.

l After running tests, from ALM, you can optionally automatically upload your run
results to ALM if you are running a test from ALM. This option is set in ALM as
a site parameter for your project. For details, see theHP Application Lifecycle
Management Administrator Guide.

If an ALM test or shared file (such as a shared object repository or data table file)
is open when you disconnect from ALM, then UFT closes it in the document pane.
The document remains in the Solution Explorer and is marked as unloaded.

Relevant
tasks

To view the current connection:

l In UFT:Point to the icon on the status bar. A tooltip displays the server name
and project to which UFT is connected.

l In the Run Results Viewer: The icon on the status bar is labeled with the
server name and project to which the Run Results Viewer is connected.
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User interface elements are described below:

UI Elements Description

Server URL The URL address of theWeb server where ALM is installed.

You can choose a server that is accessible via a Local Area Network
(LAN) or aWide Area Network (WAN).

You can connect to any currently supported version of ALM. For a list
of supported versions, see theHP Unified Functional Testing
Product Availability MatrixHP Service Test Product Availability
Matrix, available from the root folder of the UFT DVD.

User Name Your ALM user name.

Note: If you are connecting to an ALM server using external
authentication, you do not need to enter a user name. If you do
enter a user name, UFT ignores the entered namewhen
connecting.

Password Your ALM password.

Note:

To enter a password in any CJK (Chinese, Japanese, Korean)
language, copy/paste the password into the edit box. (Windows
does not support typed CJK characters in password fields.)

If you are connecting to an ALM server using external
authentication, you do not need to enter a password. If you do
enter a password, UFT ignores the entered password when
connecting.

Connect / Disconnect Connects to or disconnects from the selected ALM server.

Note: After you successfully connect to a server, the button
changes toDisconnect, and at the top of the dialog box, the

Disconnected icon changes to aConnected icon .

Domain The domain that contains the ALM project.

Project The ALM project with which you want to work.

Note: Only those projects for which you are a defined user are
displayed.

Restore connection on
startup

Instructs UFT to automatically reconnect to the ALM server every
time you open UFT.
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Select AUT Parameter Dialog Box
Relevant for: GUI tests and API testing

This dialog box enables you to link a test parameter to an AUT parameter contained in an ALM AUT
environment configuration.

User Guide
Chapter 25: ALM Integration

HP Unified Functional Testing (12.00) Page 742 of 2274



To access 1. Open a test stored on an ALM server with LabManagement enabled.

Do one of the following:

n Open an API test, select theStart orEnd step in the canvas, and open the
Properties pane. Then select the Test Input/Output Parameters tab .

n Select a GUI test in the solution explorer. Open the Properties pane, and
select the Parameters tab .

2. Click Add > Add Input Parameter or select a parameter and click theEdit

Parameter button .

3. In the Add/Edit Input Parameter dialog box, click .

Note: Available only if UFT is connected to an ALM server that has the
LabManagement module, and a test stored on that server is selected in
the solution explorer.

Important
information

AUT parameters are used for server-side execution. To set up server-side
execution, create functional test sets in ALM, and use ALM's Lab Resources
module to define hosts on which the tests run. For details, see "Running Tests in
Server-Side Execution" on page 713, and theHP Application Lifecycle
Management User Guide.

Note: All of the AUT parameters that you usemust be from the same ALM
AUT environment.

Relevant
tasks

"How to Run a Test Using Server-Side Execution" on page 727

See also l "Add Input/Output Parameter for Test Settings" on page 1777

l "Add/Edit Input/Output Parameter Dialog Box (Properties Pane - GUI Testing)"
on page 397
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User interface elements are described below:

UI Elements Description

AUT
Environments

The list of AUT environment configurations defined in the Lab Resources
> AUT Environmentmodule.

Expand theAUT Environments node to view the available
AUT environments, and then select an environment to view the available
parameters.

If any test parameter is already linked to an AUT parameter, only the
environment containing that AUT parameter is displayed.

Parameter column The AUT parameter names, grouped in AUT environment configurations.

Value column The value defined for the AUT parameter in ALM.

Copy default
value (override)

Specifies whether to copy the parameter value displayed in this dialog box
into theDefault Value box in the Edit/Add Input Parameter dialog box.

Copying overwrites any Default Value previously defined in the Edit/Add
Input Parameter dialog box. However, after it is copied, you can edit the
Default Valuemanually.
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Remote Agent Settings Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to view ormodify the settings that UFT uses when ALM runs a test or
business process test on your computer.

To access 1. Select Start > All Programs > HP Software > HP Unified Functional
Testing > Tools > Remote Agent. The Remote Agent opens and the

Remote Agent icon is displayed in the task bar tray.

2. Right-click theRemote Agent icon and select Settings. The Remote
Agent Settings dialog box opens.

Note: For details on accessing UFT and UFT tools and files inWindows
8, see "Accessing UFT inWindows 8Operating Systems" on page 75.
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Relevant tasks "How to View orModify Remote Agent Settings" on page 734.

See also "UFT Remote Agent Preferences" on page 715.

User interface elements are described below:

UI
Element Description

Restart
testing
tool after
__ runs

For tests, restarts UFT after ALM completes the specified number of tests runs.
When UFT restarts, it continues with the next test in the test set.

For business process tests, restarts UFT after ALM completes the specified
number of component iterations. However, if it reaches the specified number of
iterations in themiddle of a business process test run, it waits until the current
business process test iteration is finished before restarting.

Youmay want to use this option tomaximize available memory.

If you do not want UFT to restart during a test set run, enter 0 (default).

Close
testing
tool after
__ idle
minutes

Closes UFT after it has been idle for the specified number of minutes.

Run
GUITest
Sets in
debug
mode
GUI tests
only

Instructs UFT to pause test runs at breakpoints inside in a test.

Note: If you select this option when theRun UFT in hidden mode option is
also selected, UFT does not stop at the breakpoints.

Save the
open,
modified
test
before the
test run

If an existing test or keyword GUI component is open in UFT when the Remote
Agent begins running a test, this option instructs UFT to save any unsaved
changes to the open test or keyword component.

Note: (for GUI testing): This option is not relevant for function libraries.
Therefore, if an existing function library is open in UFT when the Remote Agent
begins running a test, the function library is not saved.

Save the
open,
new test
before the
test run

If a new test is open in UFT when the Remote Agent begins running a test, the test
is saved in:<Unified Functional Testing>\Tests\ALM with a sequential test name.

Note: (for GUI testing): This option is relevant only for tests. Therefore, if a
new keyword component or function library is open in UFT when the Remote
Agent begins running a test, the component or function library is not saved.
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UI
Element Description

Open a
new test
after the
test run

By default, the last test or component run by the Remote Agent stays open in UFT
when it finishes running the test or component. However, while it remains open, it is
locked to other users. You can select this option to ensure that the last test or
component that ALM runs on your computer is closed, and a blank test or
component is open instead.

Run UFT
in hidden
mode

Specifies whether to run UFT in hidden (silent) mode when you run a test set from
the Test Labmodule in ALM. By default, this option is selected.

Display hidden-mode notification tooltip: If this check box is selected, the
Remote Agent displays a tooltip window when UFT runs an ALM test in hidden
mode. You can click the tooltip to display UFT during the test set run. By default,
this option is selected.

Note:

l Clicking the notification tooltip clears theRun UFT in hidden mode check
box and UFT runs in normal mode. You can run UFT in hiddenmode again
by reselectingRun UFT in hidden mode before the next test set run.

l When running in hiddenmode, UFT can be optionally redisplayed at the end
of each test or at the end of the test set. This behavior is configured in ALM
Site Administration using theSUPPORT_TESTSET_END parameter. For
details, see the section on setting ALM configuration parameters in the
HP Application Lifecycle Management Administrator Guide.

l If you are running a test from the ALM Test Labmodule, UFT does not stop
the test at any breakpoints inserted into the test.
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UI
Element Description

Keep UFT
open after
a Test
Lab run
session
ends

By default, when ALM opens UFT on a remote computer during a test set run (or
when it runs selected tests or configurations from the Test Labmodule), it closes
UFT at the end of that Test Lab run session. This ensures that the UFT license is
released at that point andmade available for other UFT users.

Selecting this option causes UFT to stay open on your computer (and to continue
using the UFT license) after a Test Lab run session ends.

Note: The behavior described above is relevant only when UFT is opened from
an ALM server that has theSUPPORT_TESTSET_END parameter set toY.
(Y is the default setting).

If UFT is opened from an earlier version of ALM (or the above-mentioned parameter
is set toN), this option is ignored and UFT always remains open at the end of run
session.

For details on theSUPPORT_TESTEND_END parameter, see the section on
setting ALM configuration parameters in theHP Application Lifecycle Management
Administrator Guide.

Restart
testing
tool after

Restarts UFT if there is no response after the specified number of seconds for:

l Operations.UFT operations such as Open orRun.

l Queries. Standard status queries that remote applications perform to confirm
that the application is responding (such as theALMget_status query).

The default value for both options is 2700 seconds (45 minutes). However, while
UFT operations may take a long time between responses, queries usually take only
several seconds. Therefore, youmay want to set different values for each of these
options.

Note: If a function library with unsaved changes is open in UFT, UFT prompts
you to save it. If the function library is not saved within 10 seconds, UFT
restarts and any unsaved changes are lost.
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Troubleshooting and Limitations - ALM Integration
Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for working with tests and components and
ALM, and includes:

Troubleshooting and Limitations - General ALM Integration 749

Troubleshooting and Limitations - ALM Integration with GUI Testing 752

Troubleshooting and Limitations - ALM Integration with API Testing 752

Troubleshooting and Limitations - General ALM
Integration

Relevant for: GUI tests and components and API testing

l The first time you connect to your ALM server, (either within UFT or through a browser) you
must connect as an administrator. This allows themachine to properly install the ALM client
with the required connectivity. For all subsequent connections, you do not need to log in as
administrator. This step is also required after installing ALM patches.

l Before you run tests remotely from ALM, youmust perform the following prerequisites:

a. Youmust enable COM+ access. For details, see the Installation Guide.

b. Change DCOM permissions and open firewall ports. For details, see the Installation Guide.

c. RunRmtAgentFix.exe from the <Unified Functional Testing installation>\bin folder, or use
the Additional Requirements Utility, which you open by selectingStart > Programs > HP
Software > HP Unified Functional Testing > Tools > Additional Installation
Requirements.

This is due to a problem with opening DCOM permissions onWindows 7 andWindows
Server 2008 R2.

d. Disable User Account Control (UAC) inWindows and restart your computer before you first
connect to ALM. For details, see "Troubleshooting and Limitations - UFT Program
Management" on page 2263.
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l The security settings inWindows 7, Windows Server 2008 R2, andWindows 2012may prevent
you from performing a UFT related installation, such as a patch installation, or connecting to an
ALM project (either directly or from UFT). This can occur when the UAC (User Account Control)
option is set to ON, and you have not yet connected to an ALM project (if relevant).

Workaround: Temporarily turn off the UAC option. For details, see "Troubleshooting and
Limitations - UFT ProgramManagement" on page 2263.

After disabling the UAC option as described above, perform the required installation or connect
to ALM as usual. When you are finished, you can turn the User Account Control (UAC) option on
again. Hereafter, you should be able to connect to ALM, as needed.

l InWindows 8, when trying connecting to ALM in UFT with the UAC turned off, you cannot
connect to ALM.

Workaround: Run UFT as an administrator (even if you are the admin user).

l If you are connected to an ALM server, and you want to connect to a different server, disconnect
from the first ALM server, restart UFT, and connect to the second server.

l If UFT closes unexpectedly while an asset is open from ALM, the asset may remained locked
by ALM for more than fifteenminutes. In some cases, youmay be able to reopen UFT and
reopen the test, but when trying to save it, you will receive an error message indicating that the
test entity is already locked by you.

Workaround:Wait fifteenminutes or more and try again.

l Renaming a test or component from ALMmay cause the test or component to behave
unexpectedly.

Workaround: To rename a test or component, open it in UFT and rename it using theSave As
option. If the test or component has already been renamed from ALM, use the rename option
again to restore the old name, and then use theSave As option in UFT. Renaming a test
parameter from UFT causes any run-time parameter values already set for this parameter in
ALM to be lost.

l If an ALM user manually changes the status of a test instance run, ALM creates fast run results
to record the change of the test status. The fast run results are not valid run results files.
However, when you try to select results to open or delete in the Run Results Viewer or Run
Results Deletion tool, the fast run results are available in the list.

l For tests or business components saved on ALM, if you perform a checkout from within ALM, it
is not reflected in UFT for the current test—the test or business component still appears to be
checked in.

Workaround:Close and reopen the test in UFT.

l When running a test from UFT with ALM 11.50 and later with an ALM project that supports
versioning, the test instance run status will not be updated for tests that are checked out.
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l ALM supports non-Unicode projects. If you are working with an ALM project that is not Unicode
compliant:

n You should not use Unicode values (such as the name of the test or component, the name of
an application area, the default value of a test, action, or component parameter, method
argument values, and so forth).

n Data that is sent to UFT from ALM (such as values for test, action, or component parameters)
is not Unicode compliant.

n UFT results containing Unicode characters may appear corrupted in the ALM result grid. You
can, however, open and view results containing Unicode characters in the UFTRunResults
Viewer.

For additional details on UFT Unicode issues, see "Troubleshooting and Limitations -
 Multilingual Applications in GUI Testing" on page 2266.

l If there is a forward proxy with Basic Authentication between the server and client machines,
before the first connection to an ALM platform, each ALM client must configure the proxy
credentials by using theWebgate Customization Tool. If you do not runWebGate, youmay
be unable to connect, or youmay need to enter your credentials multiple times.

To run the tool:

a. Go the following location on the ALM client machine: http:\\<ALM Platform server name>
[<:port number>]/qcbin/Apps/

b. Click on theWebgate Customization Tool link and select Run.

c. InWebGate Customization, click in theProxy Credentials area. Select theUse these
credentials check box, and type values in theProxy Username andProxy Password
boxes.

d. Click Save and thenClose.

l In UFT, when you run a test or flow that was recorded in QTP 11.00 using the BPTEE extension,
and is currently stored in ALM 11.00, any ALM Detect Changes settings are ignored, and no
changes are detected.

l In order to run a UFT test from an ALM server using external authentication, youmust select the
Non-interactive mode option in theWebgate Customization tool and select the
external certificate in the same dialog.
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Troubleshooting and Limitations - ALM Integration with
GUI Testing

Relevant for: GUI tests and components

l If the parameter names in yourGlobal data table are identical to the parameter names in an
external data table, running a test configuration with data table parameter mapping to other data
table parameters causes unexpected results. For example, if yourGlobal data table parameters
are Login andPassword, and your external data table parameters are Login, Password, Login_
localized, andPassword_localized, a test configuration run with mapping from Login to Login_
localized andPassword toPassword_localizedwill cause unexpected results.

Workaround: Split the external data table into multiple tables.

l To run a test or component from ALM, youmust first invoke UFT at least once. Otherwise, ALM
may be unable to open UFT.

Troubleshooting and Limitations - ALM Integration with
API Testing

Relevant for: API testing

l While connected to an ALM project, if you change the available license for an API test, ALM
continues to use the original license.

Workaround: Log out from your ALM project and restart Internet Explorer.

l For Service Test Management: Before importing aWSDL from Service Test Management, you
must connect at least once to the Service Test Management-ALM server through Internet
Explorer.

l To enable test versioning in Quality Center version 10.00, create a file in the <QC installation
folder>\repository\sa\DomsInfo\Metadata\TEST folder calledServiceTest.xml with the
following content:

<?xml version="1.0" encoding="UTF-8" ?>
<Test Type="SERVICE-TEST">
<Repository>
<Folders ID="1" Filter="." BlindCopy="true" />

</Repository>
<Versioning Enabled="true" />
<Baselining Enabled="false" />
</Test>

l You can create andmanage API components in much the sameway as you would API tests, as
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described in "API Testing Design" on page 1588. For details about exceptions that apply when
working with API components, see "Troubleshooting and Limitations - Business Process
Testing in UFT" on page 2079.

l When editing a test on UFT on a computer runningWindows XP, youmust save your test before
running it from ALM.
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Chapter 26: Resources and Dependencies Model
Relevant for: GUI tests and components and API testing

Note: The references to ALM in this chapter apply to Quality Center 10.00 and ALM. Note that
some features and options may not be supported in the Quality Center or ALM edition you are
using. For information onQuality Center or ALM editions, see theHP Quality Center User
Guide or theHP Application Lifecycle Management User Guide.

This chapter includes:

Concepts 755

Resources and Dependencies Model Overview 755

Asset Dependencies - Advantages 756

Reference 758

Relative Paths and ALM 758

Resources and Dependencies Model Terminology 759

ALM Resources-Related User Interface 761

Troubleshooting and Limitations - Resources and Dependencies 769
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Concepts

Resources and Dependencies Model Overview
Relevant for: GUI tests and components and API testing

UFT enables you to use the Resources and Dependencies model to fully integrate your tests and
components into ALM projects.

Note: Before you read this section, youmay want to familiarize yourself with the "Resources
and Dependencies Model Terminology" (described on page 759).

l Replaces the use of attachments with linked assets. For example, GUI tests, actions, and
application areas can be linked with function libraries and shared object repositories,
respectively orAPItests can be linked with data tables, user code files, or activities. You store
your tests or components in the Test Plan or Business Components module, respectively, and
you store your resource files (including application areas) in the Test Resources module. When
you associate a resource file to a test or a GUI component's application area, these assets
become linked. Linking assets improves runtime performance by decreasing download time.
(Using attachments instead of resources increases download time from Quality Center 10.00
and ALM.) Linking assets also helps to ensure that the relationships between dependent assets
aremaintained.

l Supports versioning for tests or components and resource files. You can create versions
of these assets in UFT or in ALM, and you canmanage asset versions in ALM. For details, see
"Version Control in ALM" on page 794.

l Supports baselines for tests or components and resource files. You can view baseline
history in UFT, and you can view andmanage baselines in ALM. For details, see "Baseline
History Dialog Box" on page 805.

l Enables you to view and compare your assets in both ALM and UFT. You can use the
Asset Comparison Tool to compare versions of individual assets and the Asset Viewer for
viewing an earlier version of a asset. Both of these viewers are available in ALM and in UFT. For
details, see "Viewing and Comparing Versions of UFT Assets" on page 770.

l Enables you to import and share assets across ALM projects. For details, see the
HP Application Lifecycle Management User Guide.

For details about the advantages of working with this model, see "Asset Dependencies -
Advantages" on the next page.
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Asset Dependencies - Advantages
Relevant for: GUI tests and components and API testing

When you associate a dependent resource file with a test's or a GUI component's application area,
the assets become integrally linked, and these links can be viewed in ALM (in the Dependencies
tab of various modules) and—for external GUI actions—in UFT (in the Action Properties dialog
box).

Assets stay linked
When youmove a test, or rename a test, action, component, application area, folder, or resource,
dependent assets are automatically updated to reflect the change. This helps ensure that there are
nomissing resources during a run session.

Resource files are all stored in one ALMmodule
Resource files are stored in the Test Resources module, enabling you tomanage your resources in
one central location, and to view at a glance which tests and application areas are using each
resource file. For details on the Test Resources module, see theHP Application Lifecycle
Management User Guide.

Using resources stored in the Test Resources module improves runtime
performance
Tests or components open and run faster when the associated resource files are stored in the Test
Resources module (instead of being stored as attachments to tests in the Test Planmodule).

Version control can also be applied to resource files
When version control is enabled for a project, all of the assets can be checked into the version
control database. For details, see "Version Control in ALM" on page 794.

You can create, view, compare, and run baselines
In ALM, you can create baselines that capture the developmental stage for each asset, view and
compare these read-only baseline "snapshots", and run baselines from a project. In UFT, you can
view and compare baselines. For details, see "Baseline History Dialog Box" on page 805.

You can share assets with other projects and synchronize them
You can copy assets from other projects. This enables you to reuse your existing assets instead of
creating new assets whenever you create a new project. For example, you can create a "template"
set of assets to use as a basis for new projects.

You can synchronize these assets in both projects when changes aremade, or you can customize
your assets to suit the unique needs of each development project. For details, see the sections on
importing and synchronizing libraries in theHP Application Lifecycle Management User Guide.

Deleting assets is easier
When you delete an asset (a reusable GUI action or component or associated resource file), a
warningmessage informs you if the asset is used by other tests (or more than once in the current
test) or is associated with an application area. This message contains aDetails section that lists
the tests or application areas that are associated with this asset or contain calls to this action so
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you canmodify the tests or application areas, as needed. This helps youmanage your business
process tests andGUI action calls so that tests do not inadvertently fail.

You can verify which tests or components are associated with specific
resources and vice versa
In the ALM Test Planmodule and Business Components module, you can highlight a test or
component and, in the Dependencies tab, see which assets are using the test or component, and
see which assets the test or component is using. Similarly, in the ALM Test Resources module,
you can highlight a resource file and see the assets with which it is associated.

For details, see "Dependencies Tab (ALMModules) " on page 762.

You can verify which tests contain calls to an action (GUI testing only)
You can view a list of the tests that contain calls to a particular action by focusing on the action and
opening the Used By tab in the Action Properties dialog box. (Right-click an action in the canvas
and select Action Properties.) For details, see "Used By Tab (Action Properties Dialog Box)" on
page 909.
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Reference

Relative Paths and ALM
Relevant for: GUI tests and components and API testing

Resource files andGUI actions that are associated with tests or application areas using a relative
path are not considered dependencies. To ensure that your resource files are recognized as
dependencies, they must be saved in the Test Resources module in ALM, and they must be
associated using the full ALM path. This enables you to benefit from the features provided by the
Resources and Dependencies Model, as described in "Asset Dependencies - Advantages" on page
756.

For GUI testing:Despite this, theremay be cases in which youmay want to use a relative path.
For example, if your application is released in different languages, youmay want to use a relative
path when associating shared object repositories with your tests or component’s application areas,
as this enables you to use the same test with localized shared object repositories.

Limitations - Relative Paths and ALM

l Run-time performance times are slower.

l Dependency information for these assets is not displayed in:

n The Using and Used By grids in the Dependencies tab in ALM. For details, see:
"Dependencies Tab (ALMModules) " on page 762

n Themessage box that opens when you delete an asset that is associated with other
assets.For details, see "Asset Dependencies - Advantages" on page 756

n For GUI tests only: The Used By tab of the Action Properties dialog box in UFT. For details,
see: "Used By Tab (Action Properties Dialog Box)" on page 909

l ALM does not verify that these assets are included during the baseline verification process. For
details, see "Viewing Baseline History" on page 798

l When opening or running tests or components from a baseline, any associated external GUI
action or resource file that is associated via a relative path but is not included in the baseline is
considered amissing resource. This may cause a test or component run to fail. (Note that the
baseline version of an associated asset is used if the asset associated via a relative path is
included in the baseline.), For details, see: "Viewing Baseline History" on page 798

l When using the Asset Comparison Tool to view a test or component, you cannot drill down to
view assets that are associated via a relative path.
See: "Asset Comparison Tool and Asset Viewer - Overview" on page 771
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Resources and Dependencies Model Terminology
Relevant for: GUI tests and components and API testing

Term Description

Asset Any testing document or resource file, including:

For GUI testing:

l tests

l actions (GUI testing only)

l components

l application areas (GUI testing only)

l function libraries (GUI testing only)

l shared object repositories (GUI testing only)

l recovery scenarios (GUI testing only)

l data table files

l environment variable files

For API testing:

l tests

l components

l data table files

l XML files

l testing activities

l Web references (done via Service Test Management)

l user code files

Note: In ALM, UFT assets are referred to by themore general term
entities.
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Term Description

Resource Any asset stored in the ALM Test Resources module that is used by a test or
component. For example, aGUI test or componentmay contain calls to
functions in associated function libraries, and it may reference test objects
stored in shared object repositories that are associated with the test or
component's application area. AnAPI test or componentmay contain
references to a data table file or use a custom testing activity.

GUI testing resources include:

l application areas

l function libraries

l shared object repositories

l recovery scenarios

l data table files

l environment variable files

API testing resources include:

l data table files

l XML files

l testing activities

l Web references (done via Service Test Management)

l user code files

Note: In some cases, a resource can be used by another resource. For
example, a GUI test's recovery scenario can use functions in a function
library.
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Term Description

Dependency The linked relationship between a resource or external GUI action and a
particular test or application area. Associated resource files andGUI actions
are linked to each test or GUI component's application area that uses these
resources or calls theseGUI actions.

In some cases, a resource can also be linked to another resource. For example,
a GUI test's recovery scenario can call functions in a function library.

Assets are considered dependencies if they are associated using absolute
paths, and they are stored in the followingmodules:

l Test Plan module: tests

l Business Components module: components

l Test Resources module:

n GUI testing resources like application areas, function libraries, shared
object repositories, recovery scenarios, data table files, environment
variable files

n API testing resources like data table files, .xml files, testing activities,
and user code files

Note: Tests or components stored in theUnattached or Obsolete folders
in the Test Plan or Business Components module, respectively, are not
considered dependencies because they are not associated with any test or
component.

Configuration A test that is set to run from ALM with an optional data resource file and optional
data filter settings. In ALM, you can define various configurations for the same
test or business process test.

For tests, see "Data Awareness in ALM" on page 715

For components, see theHP Business Process Testing User Guide.

ALM Resources-Related User Interface
Relevant for: GUI tests and components and API testing

When you create an ALM project in your ALM server, the tests or components that you create in
this project are saved to the Test Plan or Business Components module, respectively. You save
your resource files to the Test Resources module. By associating resource files with your tests or
GUI components' application areas, they become linked dependencies.

This section provides a general overview of the tabs that are relevant for tests, components, or
applications areas. For details on using any of these tabs, see the relevant section in the
HP Application Lifecycle Management User Guide.
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This section includes (in alphabetical order):

Dependencies Tab (ALMModules) 762

History Tab (ALMModules) 767

Libraries Module (ALMModules) 768

Dependencies Tab (ALM Modules)

Relevant for: GUI tests and components and API testing

This tab displays the relationship between a selected asset, such as a test or component, and the
assets with which it is associated. You use the Dependencies tab to see at a glance which
resources are used by a particular asset, and which asset is using a particular resource. This
information is displayed in the "Using Grid" on page 765 and "Used By Grid" on page 764 in the
Dependencies tab in the Test Plan and Test Resources modules or the Business Components
module.

Usage Example

For GUI testing:Suppose you want to modify the objects in a shared object repository. You
can navigate to the shared object repository in the Test Resources module to view a list of the
tests or application areas with which it is associated. This enables you to determine which
assets this resource file is used by and helps you to analyze the impact that a proposed
changemay make to the dependent assets.

For API testing: Suppose you want to modify the values in a data table. You navigate to the
data table in the Test Resources module to view a list of the tests or components with which it
is associated. This enables you to determine which assets this resource file is used by and
helps you to analyze the impact that a proposed changemay make to the dependent assets.
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To access In ALM, the Dependencies tab is available from the followingmodules:

l Business Components module

l Test Planmodule

l Test Resources module

Important
information

For details on using this tab, see theHP Application Lifecycle Management User
Guide.

For GUI testing:When running a test with external resource files (like function
libraries, data tables, recovery scenarios,etc.) that are saved in ALM, the resource
files are not refreshed for each test run. As a result, any changes made to these
external resource files during the current session are not reflected in a test run
until you close and reload test and its resource files.

Relevant
Tasks

l For GUI testing: In UFT, you can view Used By information for actions in the
Action Properties dialog box. For details, see "Used By Tab (Action
Properties Dialog Box)" on page 909.

UFT also displays Used By information when you try to delete a dependent
asset, so that you can determine how the changemight affect associated
assets before you delete the asset.

l In the Business Components module, the Dependencies contains the
following grids:

n Used By. Displays the business process tests that include this component.

n Using. Displays the application area with which the component is
associated.

For more details on the Dependencies tab in the Business Components
module, see theHP Business Process Testing User Guide.

Business
Process
Testing

In the Business Components module, the Dependencies contains the following
grids:

l Used By. Displays the business process tests that include this component.

l Using. Displays the application area with which the component is associated.

For more details on the Dependencies tab in the Business Components module,
see theHP Business Process Testing User Guide.
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UFT-specific user interface elements are described below.

Used By Grid
This grid lists the assets that are using the asset currently selected in the tree. Suppose you
are looking at the Used By grid for a shared object repository (for a GUI test) or a data table (for an
API test). The Used By grid lists all of the GUI tests or application areas that are associated with
the selected shared object repository or all the API tests that are associated with the data table.
This list indicates the assets that will be affected if youmodify or delete the asset selected in the
tree.

Column Description

ID A unique numeric ID assigned automatically by ALM. If the ID is a link, you can
click it to jump to that asset in ALM.

Example:Suppose you are looking at the Used By grid for a specific function
library (GUI testing only) or user code file (API testing only) in the Test
Resources module. You can click the ID link to jump to the test or application
area with which it is associated. (The link takes you to the Test Plan or
Business Components module.)

Name The name of the asset that is using the asset selected in the tree, for example, the
name of a test, GUI action, application area, or business process test that is using
the asset selected in the tree.

GUI-related owner names include:

l Main Test Flow. Indicates the test container called by the top-level action in
the currently selected test in the Test Planmodule. WhenMain Test Flow is
displayed, theOwner Type is Test.

l Action<#>. Indicates the internal name of the action that is called by an action
in the currently selected test in the Test Planmodule. Action<#> refers to the
sequential number of the action when it was created. Action<#> is displayed
when theOwner Type is QTP Action.
Note:Action<#> is displayed even if an action was renamed in the test.

l The actual name of the asset if the asset is not an action.

An asset linked to anAPI test or component lists the name of the asset.

Type The type of asset that is using the asset selected in the tree, for example
ApplicationArea or BUSINESS-PROCESS or Test, QTP Action,QUICKTEST_
TEST, orSERVICE_TEST.
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Column Description

Description The description specified in theDetails tab for the asset listed in theName
column (see description above).

Note: (for GUI testing)

l If the Type is QTP Action, displays the actual name of the action as
shown in UFT (for example, if the action was renamed, the user-defined
name is displayed) and displays its description, if any.

l If the Type is QUICKTEST_TEST or Test, this cell is empty.

Owner
Name
(GUI tests
only)

The name of the asset that owns the asset listed in theName column. For
example, if the asset listed in theName column is an action, then theOwner
Name is the name of the test in which that action is stored. (Not relevant for
components or API tests)

Owner
Type
(GUI tests
only)

The type of asset that owns the asset listed in theName column. GUI-related
owner types include:

l QUICKTEST_TEST. A GUI test in the Test Planmodule.

l QTP Action. An action that is part of a test in the Test Planmodule.

Using Grid
This grid lists all of the dependencies that the selected asset is using. For example, suppose
you are looking at a test or component. You can see all of the external actions called by the test, all
of the shared object repositories containing test objects used by the test or component, function
libraries containing functions called by the test or component, and so on.

Column Description

ID A unique numeric ID assigned automatically by ALM.
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Column Description

Name The name of the associated asset that the selected asset uses, for example, the
name of the shared object repository, data table resource, or function library.

GUI-related names include:

l For business process tests, lists the names of the flows and/or components
that are included in that test.

l For business process flows, lists the name of the components that are
included in that flow.

l For components, lists the name of the associated application area.

l Action<#>. Indicates the internal name of the action that is called by an action
in a test in the Test Planmodule. Action<#> refers to the sequential number of
the action when it was created. Action<#> is displayed when theRelated
Type is QTP Action.
Note:Action<#> is displayed even if an action was renamed in the test.

l For application areas, lists the name of all associated resources, including
function libraries and shared object repositories.

l The actual name of the asset if the asset is not a test.

Type The type of associated asset that the selected asset uses, for example,
ApplicationArea, Component, FLOW, QTP Action, Data table, Function
library, Shared object repository, andRecovery scenario.

Description The description of the associated asset that the selected asset is using, if any.

If the Type is QTP Action, displays the name of the action as shown in UFT and
displays its description, if any.

Owner
Name

The name of the asset that owns the asset listed in theName column. For
example, if the asset listed in theName column is an action, then theOwner
Name is the name of the test in which that action is stored. (Not relevant for
components)

Owner
Type

The type of asset that owns the asset listed in theName column, for example,
QUICKTEST_TEST. (Not relevant for components)
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History Tab (ALM Modules)

Relevant for: GUI tests and components and API testing

This tab enables you to:

l View version information for a selected file.

l View baseline information for a selected file.

l View and compare file versions.

l View the baseline in which a version is stored (if applicable).

l Check out an earlier version of a file if you want to roll back to that version. (When you check the
file back into the version control database, that version becomes the current version.)

To access In ALM, the History tab is available from the followingmodules:

l Business Components module

l Test Planmodule

l Test Resources module

Note: The History tab is located in the pane on the right side of the window.
Youmay need to scroll to the right to display it.

Important
information

For details on using this tab, see theHP Application Lifecycle Management
User Guide.

Relevant
tasks

In UFT, you can also view version history and baseline history by selecting one
of the following:

l ALM > Version History

l ALM > Baseline History

See also l "Version History Dialog Box" on page 803

l "Viewing Baseline History" on page 798
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Libraries Module (ALM Modules)

Relevant for: GUI tests and components

This module enables you to:

l Create, view, and compare baselines. For details, see "Viewing Baseline History" on page
798 and the sections describing baselines in theHP Application Lifecycle Management User
Guide.

l Import assets from other ALM projects. This enables you to create a complete copy of the
assets that are included in a baseline in another project in any accessible domain. For details,
see theHP Application Lifecycle Management User Guide.

To access In the ALM sidebar, underManagement select Libraries.

Important
information

For details on using this tab, see theHP Application Lifecycle
Management User Guide.
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Troubleshooting and Limitations - Resources and
Dependencies

Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for resources and dependencies.

l When you save a resource to ALM (either from UFT or using theUpload option from the ALM
Test Resources module), and the resource file has a comma in the file name, the resource
appears to be saved successfully, but the file is not actually uploaded to the ALM server.

l For GUI testing: If you insert a call to an external action that is associated with a data table,
and that data table was previously renamed ormoved in the Test Resources module of Quality
Center 10.00 or ALM, UFT tries to locate the data table in its original location.

Workaround:Save the test, close it, and reopen it.
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Chapter 27: Viewing and Comparing Versions of
UFT Assets

Relevant for: GUI tests and components and API testing

Note: The references to ALM in this chapter apply to Quality Center 10.00 and ALM. Note that
some features and options may not be supported in the Quality Center or ALM edition you are
using. For information onQuality Center or ALM editions, see theHP Quality Center User
Guide or theHP Application Lifecycle Management User Guide.

This chapter includes:

Concepts 771

Asset Comparison Tool and Asset Viewer - Overview 771

Tasks 774

How to Open the Asset Comparison Tool 774

How to Open the Asset Viewer 776

How toWork with the Asset Comparison Tool and Asset Viewer 778

Reference 780

Asset Comparison Tool 780

Asset Viewer 788

Troubleshooting and Limitations - Asset Comparison Tool 792
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Concepts

Asset Comparison Tool and Asset Viewer - Overview
Relevant for: GUI tests and components and API testing

An asset is a UFT testing document (such as a test, component, or application area) or any
resource file that is used by a UFT testing document (such as a function library, a shared object
repository, a data table, a recovery scenario, or an environment variable XML file). The Asset
Comparison Tool and Asset Viewer enable you to view and compare versions of a particular asset.

Using these tools, you can:

View any version of an asset using the Asset Viewer
For details, see "Asset Viewer" on page 788.

Compare two versions of an asset using the Asset Comparison Tool
For details, see "Asset Comparison Tool" on page 780.

Drill down to view or compare versions
Drilling down enables you to:

l View or compare versions of an integral element. An integral element is a resource file that is a
part of the test or component (not saved as an external resource), such as a local object
repository (for GUI testing) or a data table (for API testing). When you check in a test or
component, these elements are checked in, too, because they are part of the test or component.
Therefore, when you drill down in the asset, you can view or compare the version that existed
when the test or component was checked in, in addition to the currently saved version.

l View or compare versions of associated external assets. An associated asset is any external
(not integral) resource file used by an asset (such as a function library, a shared object
repository, a data table, a recovery scenario, or an environment variable XML file).

Note:

n When you drill downwhile viewing or comparing an asset, the currently checked in
content of the associated assets is displayed, even if you are viewing or comparing an
earlier version of themain asset.

To view or compare an earlier version of the drilled-down associated asset, open the
resource file itself and use the Asset Viewer or Asset Comparison Tool.

n To view or compare by drilling down, the resource file must be associated via an absolute
or ALM path. For details, see "Relative Paths and ALM" on page 758.
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View a screen capture depicting the UFT location of an element (GUI
testing only)
The screen capture displays an example of the relevant dialog box. The option (or area) for the node
you right-clicked is highlighted in the screen capture.

Example for tests:Suppose you are viewing a comparison of a test and you notice that the
Disable Smart Identification during the run session node is highlighted, indicating that it was
modified. If you are not sure where this option is located in UFT, you can right-click the node in
the comparison tree and select View Sample Snapshot. UFT then opens a dialog box
showing you that this area is located in the Run pane of the Test Settings dialog box. The title
bar of the dialog box lists the selected element, and a highlighted rectangle outlines the option.

Example for components:Suppose you are viewing a comparison of a component and you
notice that the Input parameters node is highlighted, indicating that it was modified. If you are
not sure of where this option is located in UFT, you can right-click the node in the comparison
tree and select View Sample Snapshot. UFT then opens a dialog box showing you that this
area is located in the Parameters pane of the Business Component Settings dialog box. The
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title bar of the dialog box lists the selected element, and a highlighted rectangle outlines the
option.

For details, see "How toWork with the Asset Comparison Tool and Asset Viewer" on page 778 and
"Shortcut Menu Commands (GUI testing only)" on page 784.
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Tasks

How to Open the Asset Comparison Tool
Relevant for: GUI tests and components and API testing

This task describes how to open the Asset Comparison Tool.

Prerequisites
To open the Asset Comparison Tool from UFT or from ALM, the asset must be saved in a version
control-enabled ALM project or in a baseline of an ALM project.

Open the Asset Comparison Tool from any of the following:

The main UFT window

1. Open the test, component, or function library (GUI testing only) whose versions you want to
compare.

2. Select ALM > Version History orBaseline History. The Version History or Baseline History
dialog box opens.

3. Select two versions (using the CTRL key) and click Compare. The Asset Comparison Tool
opens.

The Object Repository Manager (GUI testing only)

1. Open theObject Repository Manager (Resources > Object Repository Manager).

2. Browse to and open the shared object repository whose versions you want to compare. For
details, see "Open a shared object repository" on page 1292.

3. Select ALM > Version History orBaseline History. The Version History or Baseline History
dialog box opens.

4. Select two versions (using the CTRL key) and click Compare. The Asset Comparison Tool
opens.

The Recovery Scenario Manager (GUI testing only)

1. Open the Recovery Scenario Manager (Resources > Recovery Scenario Manager).

2. Open the recovery scenario file whose versions you want to compare. For details, see
"Recovery Scenario Manager Dialog Box" on page 1121.

3. Click theVersion Control down arrow and select Version History orBaseline History.

4. Select two versions (using the CTRL key) and click Compare. The Asset Comparison Tool
opens.
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From within ALM

1. In ALM, connect to the project containing the asset you want to compare.

2. Do one of the following:

n In the sidebar, click the Test Plan button (for tests) or theBusiness Components button
(for components) to open the Test Plan or Business Components module.

n Click the Test Resources button in the sidebar to open the Test Resourcesmodule. This
module contains the resource files associated with your test or component, such as function
libraries, shared object repositories, data tables, recovery scenarios, or environment
variable XML files.

3. In the tree, select the file whose versions you want to compare.

4. Click theHistory tab, and then click theVersions or Baselines tab.

5. In the grid, select two versions to compare (using the CTRL key), and then click theCompare
button.

6. In the sidebar of the window that opens, click theQTP Comparison/ST Comparison or
Automation button. The Asset Comparison Tool opens.

Tip: You can also compare baselines from theManagementmodule. Click the
Management button in the side bar to open theManagementmodule. Select a baseline in

the tree and click theCompare To button. For details, see the ALM user guide. For
more details on baselines, see "Managing Versions of Assets in ALMOverview" on page
795.

The Command Line Interpreter (cmd.exe) (tests only)
You can use theUFTDiffApplication.exe tool from the command line to compare two assets from
the file system.

1. Open the Command Line Interpreter.

2. Enter the command using the following syntax:

"<UFT installation folder>\bin\UFTDiffApplication.exe" P1: "<file path 1>" P2: "<file path
2>"

whereP1 = the file system path to the first asset, andP2 = the file system path to the second
asset.
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Note: Make sure you insert a blank space after each argument. The options are not case-
sensitive and can be entered in any order.

Example

""%ProgramFiles%\HP\Unified Functional Testing\bin\UFTDiffApplication.exe"
P1: "%ProgramFiles%\HP\Unified Functional Testing\Tests\Test1"
P2: "%ProgramFiles%\HP\Unified Functional Testing\Tests\Test2"

How to Open the Asset Viewer
Relevant for: GUI tests and components and API testing

This task describes how to open the Asset Viewer.

Prerequisites
To open the Asset Viewer from UFT or from ALM, the asset must be saved in a version control-
enabled ALM project.

Open the Asset Viewer from any of the following:

The main UFT window

1. Open the test, component, or function library for which you want to view an earlier version.

2. Select ALM > Version History. The Version History dialog box opens.

3. Select a version and click View. The Asset Viewer opens.

The Object Repository Manager (GUI testing only)

1. Open theObject Repository Manager (Resources > Object Repository Manager).

2. Browse to and open the shared object repository for which you want to view an earlier version.
For details, see "Open a shared object repository" on page 1292.

3. Select ALM > Version History. The Version History dialog box opens.

4. Select a version and click View. The Asset Viewer opens.

The Recovery Scenario Manager (GUI testing only)

1. Open the Recovery Scenario Manager (Resources > Recovery Scenario Manager).

2. Open the recovery scenario file for which you want to view an earlier version. For details, see
"Recovery Scenario Manager Dialog Box" on page 1121.
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3. Click theVersion Control down arrow and select Version History.

4. Select a version and click View. The Asset Viewer opens.

From within ALM
Connect to the project containing the asset you want to view, and do one of the following:

To view the current version of an asset:

In the Test Resources module, select the resource and click theResource Viewer tab.

To view the current or earlier version of an asset:

1. Do one of the following:

n In the sidebar, click the Test Plan button (for tests) or theBusiness Components button
(for components) to open the Test Plan or Business Components module.

n Click the Test Resources button to open the Test Resourcesmodule. This module
contains the resource files associated with your test or component, such as function
libraries, shared object repositories, data tables, recovery scenarios, and environment
variable XML files.

2. In the tree, select the file for which you want to view an earlier version.

3. Click theHistory tab, and then click theVersions or Baselines tab.

4. In the grid, select a version, and then click theView button. (You cannot view a version that is
currently checked out.) A window opens with buttons in the sidebar enabling you to access
version-specific information for the selected asset. (These buttons are identical to the tabs
displayed in the right pane of themain window for the latest version of the selected asset.) For
details, see the ALM user guide.

The Command Line Interpreter (cmd.exe) (tests only)
You can use theUFTDiffApplication.exe tool from the command line to view an asset from the file
system.

1. Open the Command Line Interpreter.

2. Enter the command using the following syntax:

"<UFT installation folder>\bin\UFTDiffApplication.exe" P1: "<file path 1>"

whereP1 = the file system path to the asset.

Example:
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"%ProgramFiles%\HP\Unified Functional Testing\bin\UFTDiffApplication.exe"
P1: "%ProgramFiles%\HP\Unified Functional Testing\Tests\Test1"

How to Work with the Asset Comparison Tool and Asset
Viewer

Relevant for: GUI tests and components and API testing

The following steps describe the tasks most often performed using the Asset Comparison Tool and
the Asset Viewer.

View a comparison of two asset versions (Asset Comparison Tool)
For details, see "Asset Comparison Tool" on page 780.

Drill down to compare or view a specific element (GUI testing only)

Note: You can drill down any asset that has a blue drilldown arrow adjacent to it.

l Click the blue drilldown arrow adjacent to any asset that can be compared. (The pointer
changes into a pointing hand in the proximity of the drilldown arrow.)

l Double-click the asset.

l Right-click the asset and select View Drilldown. For details, see "Shortcut Menu Commands
(GUI testing only)" on page 784.

l Select an asset and press ENTER on your keyboard.

View the UFT location of an element (GUI testing only)
Right-click the relevant node and select View Sample Snapshot. The screen capture displays an
example of the relevant dialog box. The option (or area) for the node you right-clicked is highlighted
in the screen capture. For details, see "View a screen capture depicting the UFT location of an
element (GUI testing only)" on page 772.

Modify text and background colors
Modify the text and background colors for the filter types (modified, added, deleted, and so on) in
the Asset Comparison Tool window using the Color Settings dialog box (described on page 785).

When youmodify the background color of a filter type, the color of the filter type in the legend at the
top of the window changes accordingly. These changes remain in effect unless you change them
again or restore the default settings.

View the number of differences for a specific element
In the Asset Comparison Tool, collapse the node representing an element.
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If the sub-elements of that element are different between versions, a legend is displayed adjacent to
the node. The legend indicates the number of differences that exist under the collapsed element.

In the following example, three sub-elements weremodified, one was deleted, and seven were
added:

For details, see "Legend" on page 784.
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Reference

Asset Comparison Tool
Relevant for: GUI tests and components and API testing

This window enables you to compare two versions of a particular UFT asset, such as an application
area, a test, a component, a function library, a shared object repository, a data table, a recovery
scenario, or an environment variable XML file. It also enables you to drill down in an asset to view a
comparison of entities that are associated with the asset, for example, an associated data table or
shared object repository.

The following image shows an example of a test comparison in the Asset Comparison Tool. When
viewing a comparison of a component, there are fewer items displayed. For example, a component
comparison does not display an associated resources section and a test flow section.
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To access "How to Open the Asset Comparison Tool" on page 774

Important
information

l To open the Asset Comparison Tool in UFT or ALM, the asset must be stored
in an ALM project that has version control enabled.

l The Asset Comparison Tool does not enable you to drill down to view assets
that are associated via a relative path. For details, see "Relative Paths and
ALM" on page 758.
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Relevant
tasks

"How toWork with the Asset Comparison Tool and Asset Viewer" on page 778

See also l "Asset Viewer" on page 788

l "Color Settings Dialog Box (Asset Comparison Tool and File Content
Checkpoint Preview)" on page 785

l "Filter Dialog Box (Asset Comparison Tool and File Content Checkpoint
Preview)" on page 787

User interface elements are described below:

Menu, Toolbar, and Button Options

UI Elements Description

File > Exit Closes the Asset Comparison Tool window.

Shortcut key:ALT+F4

View > Next
Difference

Finds the next difference between the elements in the compared
versions.

Shortcut key:CTRL+DOWN ARROW

View >
Previous
Difference

Finds the previous difference between the elements in the compared
versions.

Shortcut key:CTRL+UP ARROW

View >
Expand All
or Collapse
All

Expands or collapses the tree of asset properties.

View >
Refresh

Performs a new comparison of the selected asset versions.

Note: This is useful if you are comparing the current version of an
asset. If youmodify and save the asset, you can use theRefresh
command to view an updated comparison.

Shortcut key: F5

Tools >
Color
Settings

Opens the Color Settings dialog box (described on page 785), enabling
you to define the text and background color for each filter type.
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UI Elements Description

Tools >
Filter

Opens the Filter dialog box (described on page 787), enabling you to show
or hide the following types of filter elements in the comparison window:

l Modified

l Deleted

l Added

l Identical

Tip: The "Legend" on the next page in the top-right corner of the
comparison window indicates how many elements match each filter
type. The legend adjacent to a collapsed node indicates how many
sub-nodes match each filter type. For details, see Legend.

Window >
Close Tab

Closes the currently active comparison tab if it was opened from themain
window. Enabled only if more than one tab is open.

Tip:

l You can open another tab to view a comparison of an asset that is
associated with the currently compared asset, such as a shared
object repository or data table. You do this by clicking the blue
drilldown arrow adjacent to any asset that can be compared.

l You can also close the comparison tab by clicking theX in the tab
at the bottom of the window.

Window >
View
Horizontal
or View
Vertical

View Horizontal. Displays the open documents one above the other.

View Vertical. Displays the open documents side-by-side.

Window >
<Compared
Asset Path>

Enables you to navigate between the open comparison tabs.

Help >
Asset
Comparison
Tool Help

Opens the Asset Comparison Tool Help.

Shortcut key: F1
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UI Elements Description

Previous
2000 Lines

If the testing document has more than 2000 lines, this button is displayed
at the top of the comparison pane. Click to hide the current 2000 lines and
display the previous 2000 lines of the testing document.

Next 2000
Lines

If the testing document has more than 2000 lines, this button is displayed
at the bottom of the comparison pane. Click to hide the current 2000 lines
and display the next 2000 lines of the testing document.

Shortcut Menu Commands (GUI testing only)

Command Description

View
Drilldown
of Selected
Asset

Opens a drilldown version comparison of the selected asset in a new tab.
(Relevant only for assets that can be compared.)

Shortcut key:ENTER

Tip:

l You can also click the blue drilldown arrow adjacent to the node to open
a drilldown version comparison in a new tab.

l You cannot drill down to view assets that are associated via a relative
path. For details, see "Relative Paths and ALM" on page 758.

View
Sample
Snapshot

Opens a window containing a sample image of the selected element in UFT, for
example, the Resources pane in the Test Settings or Business Component
Settings dialog box. The element itself is highlighted in the snapshot.

Shortcut key:CTRL+Q

Legend
If the sub-elements of an element are different between versions, and you collapse the node
representing that element, a legend is displayed adjacent to the node. This legend indicates the
number of differences that exist under the collapsed element.

The following is an example of the filter legend displayed in the top-right corner of the Asset
Comparison Tool window:
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Important
information

l If youmodify the background color of a filter type (using the Color Settings
dialog box), the color of the filter type in the legend changes accordingly.

l If you collapse an asset in the comparison window, the tool displays a legend for
that asset, as shown in the following example:

Relevant
tasks

"How toWork with the Asset Comparison Tool and Asset Viewer" on page 778

See also "Color Settings Dialog Box (Asset Comparison Tool and File Content Checkpoint
Preview)" below

User interface elements are described below:

Symbol Description Number

Modified Indicates the number of modified elements in the comparison.

Deleted Indicates the total number of elements that were deleted from either of
the versions being compared.

Added Indicates the total number of elements that were added to either of the
versions being compared.

Color Settings Dialog Box (Asset Comparison Tool and File Content
Checkpoint Preview)

Relevant for: GUI tests and components and API testing

This dialog box enables you tomodify the text and background colors for the various filter elements
in the Asset Comparison Tool window and the File Content Checkpoint Preview (for GUI testing
only). The changes remain in effect for all subsequent sessions.
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To access In the Asset Comparison Tool window:

l Select the Tools > Color Settings menu command.

l Click theColor Settings toolbar button .

For GUI testing: In the File Content Checkpoint Preview, click theColor

Settings toolbar button .

Important
information

If you change the background color for a filter type, the legend in the top-right
corner of the window changes accordingly. These changes remain in effect unless
you change them again or restore the default settings.

See also l "Asset Comparison Tool" on page 780

l "Checkpoint Properties Dialog Box" on page 1432

User interface elements are described below:

UI Elements Description

Modified/ Deleted/ Added/
Identical

Text color and background color for the relevant filter
elements.

You can:

l Click a down arrow to select a color from the list of
colors in the Custom, Web, or System tabs.

l Enter an RGB value directly in the edit box.

Restore Restores the default color values for each of the filter
elements.
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Filter Dialog Box (Asset Comparison Tool and File Content
Checkpoint Preview)

Relevant for: GUI tests and components and API testing

This dialog box enables you to show or hide elements in the comparison window according to filter
criteria.

To access In the Asset Comparison Tool window:

l Select the Tools > Filter menu command.

l Click the Filter toolbar button .

In the File Content Checkpoint Preview, click the Filter toolbar button .

See also l "Asset Comparison Tool" on page 780

l "Checkpoint Properties Dialog Box" on page 1432

User interface elements are described below:

UI
Elements Description

Select
elements
to show

Select or clear a check box. The comparison window displays only those
elements that match the defined filter. You can show or hide the following types of
elements:

l Modified

l Deleted

l Added

l Identical
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Asset Viewer
Relevant for: GUI tests and components and API testing

This window provides a functional overview of an asset, enabling you to view its configurations and
settings in a viewer format. The tree view enables you to drill down to view or verify a particular
setting without needing to open different dialog boxes or even UFT.

The image displayed below shows the Asset Viewer for a GUI test. When viewing a component in
the Asset Viewer, only the following nodes are displayed: Settings, Properties, Parameters,
Local Object Repository, Repository Parameters
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The image below shows the Asset Comparison tool for an API test.
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To access "How to Open the Asset Viewer" on page 776

Important
information

l To open the Asset Viewer in UFT or ALM, the asset must be stored in an ALM
project that has version control enabled.

l The Asset Viewer does not enable you to drill down to view assets that are
associated via a relative path. For details, see "Relative Paths and ALM" on
page 758.

Relevant
tasks

"How toWork with the Asset Comparison Tool and Asset Viewer" on page 778

See also "Asset Comparison Tool" on page 780
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User interface elements are described below:

Button Options

UI
Elements Description

Previous
2000
Lines

If the testing document has more than 2000 lines, this button is displayed at the top
of the pane. Click to hide the current 2000 lines and display the previous 2000 lines
of the testing document.

Next
2000
Lines

If the testing document has more than 2000 lines, this button is displayed at the
bottom of the pane. Click to hide the current 2000 lines and display the next 2000
lines of the testing document.

Context Menu Commands (GUI testing only)

Command Description

View
Drilldown
of Selected
Asset

Opens a drilldown version comparison of the selected asset in a new tab.
(Relevant only for assets that can be compared.)

Shortcut key:ENTER

Tip:

l You can also click the blue drilldown arrow adjacent to the node to open
a drilldown version comparison in a new tab.

l You cannot drill down to view assets that are associated via a relative
path. For details, see "Relative Paths and ALM" on page 758.

View
Sample
Snapshot

Opens a window containing a sample image of the selected element in UFT, for
example, the Resources pane in the Test Settings or Business Component
Settings dialog box. The element itself is highlighted in the snapshot.

Shortcut key:CTRL+Q
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Troubleshooting and Limitations - Asset Comparison
Tool

Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for the Asset Comparison Tool and the Asset
Viewer.

l For GUI testing only:Sometimes, checkpoint and output value comparison information
disappears from the bottom panes of the Asset Comparison Tool after refreshing it. This can
occur if you:

a. Open the Asset Comparison Tool to view a comparison.

b. Switch to the Object Repository Manager.

c. Modify any of the current comparison's checkpoints or output values.

d. Save your changes.

e. Switch back to the Asset Comparison Tool.

f. Refresh the Asset Comparison Tool.

g. Select the checkpoint or output value that youmodified.

Workaround: If this occurs, close the Asset Comparison Tool, and then open it again after you
save your changes.

l When comparing two baselines, if the only change in a resource is its association to a test or
component, the Asset Comparison Tool does not indicate any change in the resource even
though ALMmay indicate that the resource is Modified.

l For GUI testing only:Whenworking with a localized installation of UFT, selecting theView
Sample Snapshot option in the UFT Asset Comparison Tool opens a window containing a
sample image of the selected element in UFT. The image displays the English user interface.

l For API testing: The Asset Comparison tool is not available for API components.

l For API testing: The Asset Comparison tool does not show differences for the following API
testing features:

n Changes of properties for asynchronous Web service calls

n Changes inmultipart properties for HTTP Request steps

n Changes in XML fault checkpoints
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n Changes in attachments forWeb service calls and SOAP Request steps

n Changes in security settings forWeb services and SOAP Request steps
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Chapter 28: Version Control in ALM
Relevant for: GUI tests and components, API testing, and business process tests and
flows

Note: The references to ALM in this chapter apply to Quality Center 10.00 and ALM. Note that
some features and options may not be supported in the Quality Center or ALM edition you are
using. For information onQuality Center or ALM editions, see theHP Quality Center User
Guide or theHP Application Lifecycle Management User Guide.

This chapter includes:

Concepts 795

Managing Versions of Assets in ALMOverview 795

How ALMManages Assets 796

View and Compare Asset Versions 796

Adding Assets to the Version Control Database in an ALM Project 797

Checking Assets Out of the Version Control Database 797

Checking Assets into the Version Control Database 798

Viewing Version Control InformationWhenOpening a Test 798

Viewing Baseline History 798

Version History Versus Baseline History 799

Tasks 800

How toManage Version Control Operations 800

Reference 802

VersionManagement Commands 802

Check In/Check Out Dialog Box 802

Version History Dialog Box 803

Baseline History Dialog Box 805

Troubleshooting and Limitations - ALM Version Control 807
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Concepts

Managing Versions of Assets in ALM Overview
Relevant for: GUI tests and components, API testing, and business process tests and
flows

WhenUFT is connected to an ALM project with version control support, you can update and revise
your UFT assets while maintaining earlier versions of each asset. This helps you keep track of the
changes made to each asset and see what was modified from one version to another. Assets can
include tests, components, function libraries, application areas, shared object repositories,
recovery scenarios, and external data tables, XML files, user code files, or test activities.

You can check in the asset at any time. For example, youmay want to check the asset in every day
or when you complete a task. While the asset is checked out to you, other users can view the last
checked in version of that asset in read-only mode, but they cannot modify the asset or view your
changes until you check in the asset.

If the
asset
is... You can...

checked
in

l Open the asset in read-only mode using theOpen option. You cannot modify the
asset.

l Open the asset and check it out by selectingALM > Check Out.

Tip: (for GUI testing): If a test, component, function library, or application area
is checked into a project with version control, the document tab indicates its
(Read-Only) status.

Note: If you check out a test, and that test is associated with a data table that is
currently checked in to the ALM project, the data in that data table is read-only,
even though the test is editable. Tomodify the data table, youmust first check
out the data table in the ALM Test Resources module.

checked
out to
your
ALM
user
name

Open the asset in read-write mode, using theOpen option andmodify the asset as
needed.

Tip: If a test, component, function library, or application area is checked out to

your ALM user name, an unlocked icon in the Solution Explorer indicates
this status.
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If the
asset
is... You can...

checked
out to
another
ALM
user

Open the asset in read-only mode using theOpen option. UFT displays amessage
indicating that the asset is checked out to another ALM user. You can view the last
checked in version of the asset now, and you can check out the asset later after the
other user checks in the asset.

Tip: If a test, component, function library, or application area is checked out to
another ALM user name, the document tab indicates this status by displaying a
locked icon and (Read-Only) adjacent to the document's name.

In UFT, you can check out only the latest version of an asset, although you can view and compare
earlier versions. This is because assets that are stored in ALM are often linked to or dependent on
one another.

For example, if you try to run an earlier version of a test or component with a later version of a
shared object repository or a data table, your test or component might fail because the objects in the
object repository or data table would not necessarily match the objects or steps in the test or
component. For more details, see "Troubleshooting and Limitations - ALM Version Control" on page
807.

How ALM Manages Assets
Relevant for: GUI tests and components, API testing, and business process tests and
flows

Youmanage asset versions by checking assets in and out of the version control database.

You add an asset to the version control database by saving it in an ALM project with version control
support. When you save an asset for the first time, UFT automatically checks the asset into the
ALM version control database, assigns it version number 1, and automatically checks the asset out
for you so that you can continue working on it. When you check the asset in, the asset retains
version number 1, since this is the first version that can contain content. Then, each time the asset
is checked out and in again, the version number increases by 1.

Note: If you create an asset directly in ALM, the asset is assigned version number 1 and is
immediately checked out to you. In ALM, version number 1 represents the created asset
without content. When you next check the asset in, ALM assigns it version number 2.

View and Compare Asset Versions
Relevant for: GUI tests and components and API testing

You can view and compare the versions of an asset using the Asset Comparison Tool. For details,
see "Viewing and Comparing Versions of UFT Assets" on page 770.
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If your project administrator creates project baseline versions when amilestone is reached during
product development, you can view and compare the asset versions stored in these baselines. For
details, see "Viewing Baseline History" on the next page.

Note:With the exception of theBaseline History option, theALM Version Control options
in theALMmenu are available only when you are connected to an ALM project with version
control support, and an asset stored in ALM is open in the UFT window.

Adding Assets to the Version Control Database in an
ALM Project

Relevant for: GUI tests and components, API testing, and business process tests and
flows

When you create a new asset or useSave As to save an existing asset in an ALM project with
version control support, UFT automatically saves the asset in the project, checks the asset into the
version control database with version number 1, and then checks it out so that you can continue
working. This is an administrative version of the asset, similar to a placeholder. The version number
indicates that the asset exists in the database. When you later check in the asset, the version
number remains version number 1—the first version that you are checking in. Subsequent checkins
increase the version number by 1.

Saving your changes to an existing asset does not check them in. Even if you save and close the
asset, the asset remains checked out until you choose to check it in. For details, see "Checking
Assets into the Version Control Database" on the next page.

Checking Assets Out of the Version Control Database
Relevant for: GUI tests and components, API testing, and business process tests and
flows

When you open an asset that is currently checked in to the version control database, it is opened in
read-only mode. You can review the checked-in asset. You can also run the asset and view the
results.

Tomodify the asset, youmust check it out. When you check out an asset, ALM copies the asset to
your unique check-out folder (automatically created the first time you check out an asset), and
locks the asset in the project database. This prevents other users of the ALM project from
overwriting any changes youmake to the asset. However, other users can still run the version that
was last checked in to the database.

You can save and close the asset, but it remains locked until you return the asset to the ALM
database. To release the asset, either check the asset in, or undo the check out operation. For more
details on checking assets in, see "Checking Assets into the Version Control Database" on the
next page. For details on undoing the check-out, see "How to Cancel a Check-Out Operation" on
page 801.

In UFT, the check out option accesses the latest version of the asset. In ALM, you can also check
out earlier versions of any asset except for application areas. For details, see "Version History
Dialog Box" on page 803 and the ALM user guide.
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Checking Assets into the Version Control Database
Relevant for: GUI tests and components, API testing, and business process tests and
flows

While an asset is checked out, ALM users can run the previously checked-in version of your asset.
For example, suppose you check out version 3 of an asset andmake a number of changes to it and
save the asset. Until you check the asset back into the version control database as version 4, ALM
users can continue to run version 3.

When you have finishedmaking changes to an asset and you are ready for ALM users to use your
new version, you check it in to the version control database.

Note: If you do not want to check your changes into the ALM database, you can undo the
check-out operation.

When you check an asset back into the version control database, ALM deletes the asset copy from
your checkout folder and unlocks the asset in the database so that the asset version is available to
other users of the ALM project.

Viewing Version Control Information When Opening a
Test

Relevant for: GUI tests and components, API testing, and business process tests and
flows

When you open a test from an ALM project with version control support, you can view version
control information for the test by using theDetails view in the "Open/New
<Document>/<Resource> Dialog Box" (described on page 156).

TheChecked Out To column specifies the user name of the ALM user to whom the test is checked
out, if it is checked out. If the test is currently checked in to the version control database, there is no
indication in the dialog box.

Viewing Baseline History
Relevant for: GUI tests and components and API testing

In ALM, a project administrator can create baselines that provide "snapshots" of an entire project (or
part of a project) at different stages of development. A baseline represents a version of a project at
a specific point in a project's life cycle. For example, baselines are often created for eachmilestone
or when specific phases in a project are completed.

Baselines can be created for ALM projects that are enabled for version control, and for projects for
which version control is not enabled.

The project administrator creates the baseline in the Libraries tab of theManagement module in
ALM. Creating a baseline is a two-fold process. The administrator first creates a library, which
specifies the root folders from which to import the data. The administrator makes sure to include all
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of the associated resource files, such as shared object repositories and function libraries. The
administrator then creates the actual baseline, which comprises the latest versions of every asset
included in the library. If the project is version control-enabled, then these are the latest checked in
versions of every asset.

During the creation process, ALM verifies that all of these assets (such as associated resource
files) are included in the baseline. If any assets are not included, ALM informs the administrator so
that the library and baseline can bemodified accordingly. For more details, see the ALM user guide.

In ALM, these baselines can be viewed and compared in their entirety.

In UFT, you can view and compare the assets saved in these baselines. This enables you to review
the content of an asset at a specific phase in the project time line.

You can also run a test or component from a baseline.

Version History Versus Baseline History
Relevant for: GUI tests and components and API testing

This section focuses on the differences between version history and baseline history and describes
when to use each.

l You use version control to check in and check out assets as needed. For example, youmay
want to check in an asset on a daily basis or only when significant results are achieved. This
enables you tomonitor the asset's development.

If you want to view the content of an asset on a particular date or after a particular user checked
in the asset, use theVersion History option to view or compare the asset.

l The ALM project administrator creates baselines that represent "snapshots" of a project's
assets at various milestones in a project's life cycle. Each baseline links to the assets specified
by the administrator when the baseline was created. The asset version represented in the
baseline is always the version that was checked in when the baseline was created.

If you want to view an asset as it was saved for a particular milestone, use theBaseline
History option.
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Tasks

How to Manage Version Control Operations
Relevant for: GUI tests and components, API testing, and business process tests and
flows

This task describes how to check in the currently open asset, check out the latest version of an
asset in order to edit it, and cancel a check-out operation if needed.

After you edit an asset, you can save changes and close it without checking in themodified asset.
However, your changes are not available to other ALM users until you check it in. If you do not want
to check your changes in, you can undo the check-out by canceling it.

For more details on checking assets in, see "Checking Assets into the Version Control Database"
on page 798.

This task includes the following steps:

l "How to Check In the Currently Open Asset" below

l "How to Check Out the Latest Version of an Asset" below

l "How to Cancel a Check-Out Operation" on the next page

How to Check In the Currently Open Asset

1. Confirm that the currently open asset is checked out to you. For details, see "Version History
Dialog Box" on page 803.

Note: If the open asset is currently checked in, theCheck In option is disabled. If you
open an asset that is checked out to another user, all ALM Version Control options,
except theVersion History option, are disabled.

2. Select ALM > Check In, and check in the asset using the Check In dialog box. For details,
see "Check In/Check Out Dialog Box" on page 802.

How to Check Out the Latest Version of an Asset

1. Make sure the asset you want to check out is currently checked in. If you open an asset that is
checked out to you, theCheck Out option is disabled. If you open an asset that is checked out
to another user, all ALM version control options, except theVersion History option, are
disabled.

Note: Note about version numbers:Prior to Quality Center 10.00, version numbers
consisted of three segments separated by periods, for example 1.7.4. In
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Quality Center 10.00 and ALM, version numbers consist of a single segment, for
example 12.

2. Open the "Open/New <Document>/<Resource> Dialog Box" as follows:

If the asset is
a: Do this:

Test,
Component
or Function
Library

In themain UFT window, select File > Open > and select Test, Business
Component, Function Library, orApplication Area or click theOpen
down arrow and select the asset type from the list.

Shared
Object
Repository
(GUI testing
only)

In the Object Repository Manager, select File > Open or click theOpen
button.

Recovery
Scenario
(GUI testing
only)

In the Recovery Scenario Manager, click theOpen button.

3. Browse to and open the asset.

The document opens in the document pane as read-only with a lock icon in the document's tab.

4. Select ALM > Check Out to check out the document and edit it.

How to Cancel a Check-Out Operation

1. Open the asset if it is not already open.

2. Select ALM > Undo Check out.

3. Click Yes to confirm the cancellation of your check out operation.

The check out operation is cancelled. The checked out asset closes, and the previously
checked in version reopens in read-only mode.
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Reference

Version Management Commands
Relevant for: GUI tests and components, API testing, and business process tests and
flows

The following version control commands are available in UFT and can be used when connected to
an ALM project that has version control enabled:

l Check Out. Enables you to check a version-controlled asset out of the version control
database. For details, see "Checking Assets Out of the Version Control Database" on page 797.

l Undo Check Out. Enables you to cancel the check out of a version-controlled asset from the
version control database.

l Check In. Enables you to check an asset in to the version control database. For details, see
"Checking Assets Out of the Version Control Database" on page 797.

l Version History. Enables you to view or compare the versions of a particular asset. For details,
see "Managing Versions of Assets in ALMOverview" on page 795.

l Baseline History. (GUI tests and components, API testing only)Enables you to view or
compare the versions of a particular asset as it was saved in a project's baselines. For details,
see "Viewing Baseline History" on page 798.

Check In/Check Out Dialog Box
Relevant for: GUI tests and components, API testing, and business process tests and
flows

This dialog box enables you to check in or check out an ALM asset in to or from the ALM version
control database.

The image below shows an example of the Check-in dialog box for a version-controlled test.
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To access ALM > Check In or Check Out

Relevant tasks l "How to Check In the Currently Open Asset" on page 800

l "How to Check Out the Latest Version of an Asset" on page 800

User interface elements are described below:

UI
Elements Description

Name The asset name.

Version The new version number. By default, the new version number is one number higher
than the previously checked in version.

Comments If you entered a description of your change when you checked out the asset, the
description is displayed in theComments box. You can enter or modify the
comments in the box.

Version History Dialog Box
Relevant for: GUI tests and components, API testing, and business process tests and
flows

This dialog box enables you to view the version history for an asset, and depending on the type of
asset, view the content of a previous asset version and compare two asset versions.
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To access l From most assets:Open the asset and select theALM > Version History
menu command.

l From a recovery scenario (GUI testing only): In the Recovery Scenario
Manager, open the recovery scenario, click theVersion Control down arrow,
and select Version History.

Important
information

To view a version for an asset:Select a version and click View.

To compare two versions of an asset:Select two versions and click Compare.

You cannot check out an earlier version of an asset from this dialog box. (You can
check out earlier version of most assets directly from the ALM project. For details
on checking out assets from ALM, see the ALM user guide.)

See also "Managing Versions of Assets in ALMOverview" on page 795

User interface elements are described below:

UI Elements Description

Name The name of the currently open asset.

Version column A list of all versions of the asset.

Last Modified
column

The date that each version was checked in.

Modified By
column

The user who checked in each listed version.
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UI Elements Description

Comments
column

The comments that were entered when the selected asset version was
checked in.

View button
(GUI tests and
components and
API testing only)

Enables you to view the selected version of the current asset.

To view a version of an asset: Select an asset version and click View. UFT
opens the checked in version of the asset in the Asset Viewer. For details on
the Asset Viewer, see "Asset Viewer" on page 788.

Compare button
(GUI tests and
components and
API testing only)

Enables you to compare two versions of the currently open asset.

To compare two versions:Select the versions you want to compare and
click Compare. UFT opens the two asset versions in the "Asset
Comparison Tool" on page 780.

Baseline History Dialog Box
Relevant for: GUI tests and components and API testing

This dialog box enables you to view and compare read-only baseline "snapshots" of an asset.

To access l Most assets:Open the asset and select theALM > Baseline History menu
command.

l Recovery scenario (GUI testing only): In the Recovery Scenario Manager,
open the recovery scenario, click theVersion Control down arrow, and select
Baseline History.

Important
information

In the ALM Test Labmodule, you can use thePin to Baseline option to run a
baseline version of an asset. For more details, see the ALM user guide.

See also "Viewing Baseline History" on page 798
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User interface elements are described below:

UI
Elements Description

Refresh
button

Reloads the baselines in the Baseline History dialog box with the latest changes.
For example, if a baseline is added while this dialog box is open, clickingRefresh
updates the list of baselines.

Baseline
column

Lists all of the baselines that include this asset. Baselines are defined in the ALM
project (Managementmodule > Libraries tab).

Library
column

Lists the libraries from which each baseline was created.

Date
column

Lists the date that each baseline was created.

Captured
By column

Lists the ALM user who created each listed baseline.

Description
column

Displays any comments that were added when the baseline was created.

Compare
button

Enables you to view a comparison of the currently open asset in two baselines.

To compare two baselines:Select the baselines you want to compare and click
Compare. UFT opens the two baseline versions of the asset in the "Asset
Comparison Tool" on page 780.

Get button Enables you to open the current asset from the selected baseline.

To view the asset as it was stored in a baseline:Select a baseline from the list
and click View.

When you click Get, UFT:

l Closes the currently open asset.

l Opens the same asset from the baseline you selected.

l Loads the baseline version of the external actions and resource files that are
associated with the asset, if any, when they are called.

Note: If an external GUI action or resource file is associated via a relative
path, loads the latest version of the action or resource file instead of the
version from the baseline.
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Troubleshooting and Limitations - ALM Version Control
Relevant for: GUI tests and components, API testing, and business process tests and
flows

This section describes troubleshooting and limitations for ALM version control.

l If you need to check out an earlier version of an asset, for example, to roll back to an earlier
version, contact your ALM project administrator. Your administrator needs to ensure that the
correct versions of all relevant assets become the latest versions.

l Whenworking with a version-control-enabled ALM project, it takes a long time to save a test for
the first time (up to twice as long as saving the same test in a project without version control
support enabled). This delay does not occur on subsequent saves of the test.

l To enable API test versioning in Quality Center version 10.00, create a file in the <QC
installation folder>\repository\sa\DomsInfo\Metadata\TEST folder calledServiceTest.xml with
the following content:

<?xml version="1.0" encoding="UTF-8" ?>
<Test Type="SERVICE-TEST">
<Repository>
<Folders ID="1" Filter="." BlindCopy="true" />
</Repository>
<Versioning Enabled="true" />
<Baselining Enabled="false" />
</Test>
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Chapter 29: HP Sprinter
Relevant for: GUI tests only

This chapter includes:

Concepts 809

HP Sprinter Overview 809
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Concepts

HP Sprinter Overview
Relevant for: GUI tests only

Although UFT automated tests can answermany of your testing needs, youmay also need to
perform some of your tests manually. You can run your manual tests using HP Sprinter, HP's
solution for manual testing. Sprinter provides advanced functionality and tools to makemanual
testingmore efficient and effective.

Manual testing often requires that you leave your testing application to accomplish tasks related to
your test. For example, youmay need to use graphic software to take a screen capture of your
application, youmay want to record amovie of the application during the test, and you need to
switch to your defect tracking software to report defects.

Sprinter addresses these needs in themanual testing process, and enables you to accomplish
these tasks without disrupting your test flow. Sprinter includes many tools to help you detect and
submit defects. Sprinter can also perform many of the repetitive and tedious tasks of manual
testing for you. These features ensure that you can perform all the tasks necessary for your manual
test with minimum interruptions to your testing work.

Sprinter is fully integrated with ALM 11.00 and later, enabling you to get themaximum benefit from
both solutions.

Note: Unified Functional Testing (UFT) and Sprinter share a variety of system resources.
Consider the following when deciding whether to install Sprinter on your UFT computer:

l Sprinter and UFT can be installed on the same computer.

l Sprinter and UFT cannot be run simultaneously on the same computer.

l Any changes to the installation of one of these products will affect the other. If you uninstall,
modify, or upgrade one product, the other may fail. You need to repair the installation of the
affected product. For details, see theHP Unified Functional Testing Installation Guide and
theHP Sprinter Readme.

With Sprinter you can:

l Run ALM manual tests and Business Process tests with new step display:

n Clear steps display. Steps are presented in a clear, organized, and user-friendly design,
making it easier to view step information and update step status.

n Move easily between tests in your run. You can easily move between the tests in your run
without interrupting your test flow. Sprinter updates all your displayed step and run
information tomatch your current test.
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n Edit actual parameter values during your test run. You can easily edit the actual values
of parameters in your test, during your test run.

n Multiple views. Change the way you view your steps depending on your testing needs. View
in normal mode whenmore details are needed, or view in Subtitles mode if you need to see
more of your application.

n Actual value including screen captures. Attach a plain or annotated screen capture of your
application to the step's actual value.

l Create formal tests from exploratory tests with no pre-defined steps. If you run a test
without pre-defined steps, Sprinter can keep a record of all the user actions you took during your
test. You can then export this list to an Excel spreadsheet, modify the text as needed and import
the spreadsheet to a test in ALM. This converts an exploratory test to a formal test, with pre-
defined steps.

l Submit defects to ALM. Submit an ALM defect directly from within Sprinter. You can optionally
let Sprinter create a defect scenario by automatically generating a text description of all the user
actions or steps in your test. You can also attach a screen capture or amovie of your application
to the defect.

l Create and annotate screen captures of your application. Sprinter provides tools that
enable you to take and annotate a screen capture of your application at any point in the testing
process. Tools are included that makemeasuring and comparing user interface elements easier.
Report defects in the display by attaching the annotated screen capture to an ALM defect,
saving it as a file, or attaching it to an email. You can also include annotated screen captures in
the Actual Result of a step.

l Let Sprinter perform some manual testing tasks for you.

You can create and runmacros to automate a set of actions in your application. Sprinter can
also inject data automatically into fields in your application.

l Replicate your actions on another computer. Replicate your user actions onmultiple
computers with different configurations (operating system, browser). Sprinter detects
differences in the displays of these computers and enables you to report defects on these
differences.

l View test results. Sprinter includes a powerful Storyboard that displays each action you
performed in your test. For each action you can see a screen capture of the action, any defects
that you reported, defect reminders, and comments. If you ran the test with multiple
configurations you can view the differences between the displays of different computers.

For more details, contact your HP representative.
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Chapter 30: GUI Test Creation Overview
Relevant for: GUI tests and components

This chapter includes:

Concepts 813

Methodologies for Creating Tests 813

Enhancing Your Tests 815

Editor and Keyword View - A Comparison 816

Sample Test 818
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Concepts

Methodologies for Creating Tests
Relevant for: GUI tests only

You can create tests using the keyword-drivenmethodology, step recording, importing steps from
HP Sprinter, or a combination of all of thesemethods.

l The keyword-drivenmethodology enables you to select keywords to indicate the operations you
want to perform on your application.

l Step recording enables you to record the operations you perform on your application.

l Importing steps from Sprinter enables you to convert manual tests to UFT GUI tests.

This section includes:

Creating Tests Using the Keyword-DrivenMethodology 813

Creating Tests By Recording Steps on Your Application 814

Creating Tests by Importing Steps from HP Sprinter 815

Creating Tests Using the Keyword-Driven Methodology

Relevant for: GUI tests only

This methodology requires an infrastructure for all of the required resources. Resources include
shared object repositories, function libraries, and recovery scenarios. Setting up the infrastructure
requires in-depth knowledge of your application and a high level of UFT expertise.

Although setting up the infrastructuremay initially require a longer time-investment in comparison to
recording tests, using the keyword-drivenmethodology enables you to create tests at amore
application-specific level and with amore structured design. This enables you tomaintain your
tests more efficiently and provides you with more flexibility than a recorded test.

When to Use Keyword-Driven Testing

l Keyword-driven testing enables you to design your tests at a business level rather than at the
object level. For example, UFT may recognize a single option selection in your application as
several steps: a click on a button object, a mouse operation on a list object, and then a keyboard
operation on a list sub-item. You can create an appropriately-named function to represent all of
these lower-level operations in a single, business-level keyword.

l By incorporating technical operations, such as a synchronization statement that waits for client-
server communications to finish, into higher level keywords, tests are easier to read and easier
for less technical application testers to maintain when the application changes.
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l Keyword-driven testing naturally leads to amore efficient separation between resource
maintenance and test maintenance. This enables the automation experts to focus on
maintaining objects and functions while application testers focus onmaintaining the test
structure and design.

l When you record tests, youmay not notice that new objects are being added to the local object
repository. This may result in many testers maintaining local object repositories with copies of
the same objects. When using a keyword-drivenmethodology, you select the objects for your
steps from the existing object repository. When you need a new object, you can add it to your
local object repository temporarily, but you are also aware that you need to add it to the shared
object repository for future use.

l When you record a test, UFT enters the correct objects, methods, and argument values for you.
Therefore, it is possible to create a test with little preparation or planning. Although this makes it
easier to create tests quickly, such tests are harder to maintain when the application changes
and often require re-recording large parts of the test.

When you use a keyword-drivenmethodology, you select from existing objects and operation
keywords. Therefore, youmust be familiar with both the object repositories and the function
libraries that are available. Youmust also have a good idea of what you want your test to look
like before you begin inserting steps. This usually results in well-planned and better-structured
tests, which also results in easier long-term maintenance.

l Automation experts can add objects and functions based on detailed product specifications
even before a feature has been added to a product. Using keyword-driven testing, you can begin
to develop tests for a new product or feature earlier in the development cycle.

For details on creating tests using the keyword-drivenmethodology, see "Test Creation - Keyword-
DrivenMethodology" on page 820.

Creating Tests By Recording Steps on Your Application

Relevant for: GUI tests only

In some cases, youmay want to let UFT generate test steps by recording the typical processes
that you perform on your application.

As you navigate through your application, each step you perform is graphically displayed as a row in
the Keyword View. A step is anything a user does that changes the content of a page or object in
your application, for example, clicking a link or typing data into an edit box. Recordingmay be
easier for new UFT users or when beginning to design tests for a new application or a new feature.

When to Record Tests
Recording can be useful in the following situations:

l Recording helps novice UFT users learn how UFT interprets the operations you perform on your
application, and how it converts them to UFT objects and built-in operations.

l Recording can be useful for more advanced UFT users when working with a new application or
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major new features of an existing application (for the same reasons described above). Recording
is also helpful while developing functions that incorporate built-in UFT keywords.

l Recording can be useful when you need to quickly create a test that tests the basic functionality
of an application or feature, but does not require long-term maintenance.

For details on recording tests, see "Recording GUI Tests and Components - Overview" on page
843.

Creating Tests by Importing Steps from HP Sprinter

Relevant for: GUI tests only

Sprinter, HP's manual testing solution, enables themanual tester to perform operations (user
actions) on an application while Sprinter captures and saves information about each user action and
relevant test object in the background during the run session. This process is similar to recording
steps on your application in UFT.

After the Sprinter run session ends, themanual tester can export the captured user actions, test
objects, and comments, to an automated test data file in XML format.

You can then import this file to UFT, which converts it to a UFT GUI test with a local object
repository. Each step in the new text represents a user action that was performed in Sprinter, and
any comments that were added in Sprinter are displayed in the Comment column for the
corresponding step in the Keyword View.

This method helps to increase testing coverage for the application, as it creates amore seamless
workflow betweenmanual testers and automation experts that are testing the same application.

For task details, see "How to Create andManage Documents" on page 136.

Enhancing Your Tests
Relevant for: GUI tests only

After creating an initial test, you can further enhance it by adding andmodifying steps in the
Keyword View or the Editor.

You can also use a variety of options to enhance your existing tests. This section describes some
of the ways in which you can enhance your existing tests.

Checkpoints
You can add checkpoints to your test. A checkpoint is a step in your test that compares specified
items during a run session with the values stored for the same items within the test. This enables
you to identify whether or not your application is functioning correctly. There are several different
checkpoint types. For more details on creating checkpoints, see theCheckpoints Overview
section in theHP Unified Functional Testing User Guide.

Tip: You can also use theCheckPropertymethod, which enables you to verify the property
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value of an object without using the checkpoint interface. For details, seeHP UFT Object
Model Reference for GUI Testing.

Parameterization
When you test your application, youmay want to check how it performs the same operations with
different data. You can do this by replacing fixed values with values from an external source during
your run session. This is called parameterizing your test. You can supply data from a data table,
environment variables you define, or values that UFT generates during the run session. For more
details, see "Parameterizing Object Values" on page 1526.

Output Values
You can retrieve values from your test and store them in the data table as output values. You can
subsequently use these values as an input parameter in your test. This enables you to use data
retrieved during a test in other parts of the test. For more details, see "Output Values Overview" on
page 1488.

Actions
You can divide your test into actions to streamline the testing process of your application. For
details, see "Actions in GUI Testing - Overview" on page 872.

Programming Statements
You can use special UFT options to enhance your test with programming statements. The Step
Generator guides you step-by-step through the process of adding recordable and non-recordable
operations (methods and properties) to your test. You can also synchronize your test to ensure that
your application is ready for UFT to perform the next step in your test, and you canmeasure the
amount of time it takes for your application to perform steps in a test by defining andmeasuring
transactions. For more details, see "Generated ProgrammingOperations" on page 968.

You can alsomanually enter standard VBScript statements, as well as statements using UFT test
objects and operations, in the Editor. For details, see "Programming in GUI Testing Documents in
the Editor" on page 994.

Active Screen Updates
As the content of your application changes, you can update the selected Active Screen display and
use the Active Screen to add new steps to your test instead of re-recording steps on new or
modified objects. For details, see "How to Update Test Object Descriptions, Checkpoints, or
Output Values, or Active Screen Captures" on page 1088.

Editor and Keyword View - A Comparison
Relevant for: GUI actions and scripted GUI components

If you prefer to work with VBScript statements when editing actions or scripted components, you
can choose to work in the Editor, as an alternative to using the Keyword View. You canmove
between the two views as you wish, by selecting the Editor / Keyword View toggle button.

User Guide
Chapter 30: GUI Test Creation Overview

HP Unified Functional Testing (12.00) Page 816 of 2274



The Editor displays the same steps and objects as the Keyword View, but in a different format:

l In the Keyword View, UFT displays information about each step and shows the object hierarchy
in an icon-based table. For details, see "Keyword View" on page 919.

l In the Editor, UFT displays each step as a VBScript line or statement. In object-based steps, the
VBScript statement defines the object hierarchy.

The following diagram shows how the same object hierarchy is displayed in the Editor and in the
Keyword View:

Each line of VBScript in the Editor represents a step. The example above represents a step in an
action in which the user inserts the namemercury into an edit box. The hierarchy of the step
enables you to see the name of the site, the name of the page, the type and name of the object in
the page, and the name of the operation performed on the object.

The table below explains how the different parts of the same step are represented in the Keyword
View and the Editor:

Keyword
View Editor Explanation

Browser ("Welcome:
Mercury Tours")

The name of the browser test object isWelcome: Mercury
Tours.

Page ("Welcome:
Mercury Tours")

The name of the current page isWelcome: Mercury Tours.

WebEdit
("userName")

The object type isWebEdit; the name of the edit box on
which the operation is performed is userName.

Set Themethod performed on the edit box is Set.

"mercury" The value inserted into the username edit box is mercury.
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Formore details, see:

l "Checkpoint andOutput Statements" on page 1013

l "Parameter Indications in VBScript" on page 1018

l "Basic VBScript Syntax" on page 1013

l "Automatic Code Completion" on page 316

Sample Test
Relevant for: GUI tests only

The following is a sample action of a login procedure to theMercury Tours site, the sampleWeb
site. When you create tests, UFT creates both a graphical representation and script of the steps
you perform on your application.

The graphical representation of these steps is displayed in the Keyword View.

The table below provides an explanation of each step in the Keyword View.

Step Description

Action1 is the action name.

The browser invokes theWelcome: Mercury ToursWeb site.

Welcome: Mercury Tours is the name of theWeb page test object.

userName is the name of the edit box test object. Set is themethod performed on the edit
box. tutorial is the value property of this edit box.

password is the name of the edit box test object. SetSecure is an encryptionmethod
performed on the edit box. 4ff405198a68b24867227da98b21e547cfc0c2f47d31 is the
encrypted value of the password.

Sign-In is the name of the image link test object. Click is themethod performed on the
image. 26, 4 are the x- and y-coordinates where the image was clicked.
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The Editor displays these same steps using a VBScript program based on the UFT object model.

Browser("Welcome: Mercury Tours").Page("Welcome: Mercury Tours").WebEdit("userName").Set
"tutorial"
Browser("Welcome: Mercury Tours").Page("Welcome: Mercury Tours").WebEdit("password").Set
Secure "4ff405198a68b24867227da98b21e547cfc0c2f47d31"
Browser("Welcome: Mercury Tours").Page("Welcome: Mercury Tours").Image("Sign-In").Click 26,
4
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Chapter 31: Test Creation - Keyword-Driven
Methodology

Relevant for: GUI tests only

This chapter includes:

Concepts 821

Keyword-DrivenMethodology - Overview 821

Test a Flight Application Using the Keyword-DrivenMethodology - Use-Case Scenario 828

Tasks 836

How to Create aGUI Test Using the Keyword-DrivenMethodology 836
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Concepts

Keyword-Driven Methodology - Overview
Relevant for: GUI tests only

Keyword-driven testing is a technique that separates much of the programming work from the
actual test steps so that the test steps can be developed earlier and can often bemaintained with
only minor updates, even when the application or testing needs change significantly. This enables
you to create structured tests that are easier to update andmaintain over time.

The keyword-drivenmethodology is especially useful for organizations that have both technical and
less technical users because it offers a clear division of automation tasks. This enables a few
experts to maintain the resource framework while less technical users design andmaintain
automated test steps. Additionally, after the basic infrastructure is in place, both types of users can
often do their jobs simultaneously.

Using the keyword-drivenmethodology, you create tests that enable users to select keywords to
indicate the operations to be performed on your application. By creating your tests with a keyword-
drivenmethodology in mind, your tests becomemoremodular, focusing on the operations to test
using both UFT built-in keywords and your own user-defined keywords. Additionally, because it is
possible to add objects to the object repository before they exist in an application, it is possible to
begin preparing your automated keyword-driven tests even before a software build containing the
new objects is available.

One or a few automation experts usually develop the test automation infrastructure that all tests
related to a certain application or functionality can use. The automation infrastructure usually
includes one or more shared object repositories and one or more function libraries.

The information in the sections listed below provides guidance on themain steps involved in
creating these resources and describes where you can find detailed documentation for these steps:

Analyzing Your Application 821

Setting UpObject Repositories 823

Creating Function Libraries 824

Configuring UFT According to Your Testing Needs 825

Building Your Tests 825

Adding Steps to Your Test Actions 826

Running and Troubleshooting Your Tests 827

Analyzing Your Application

Relevant for: GUI tests only

The first step in creating a test is to analyze your application to determine your testing needs.
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What development environments need to be supported by UFT?
From the perspective of UFT, your application comprises windows containing a hierarchy of objects
that were created in one or more development environments. UFT provides support for these
environments using add-ins.

You load UFT add-ins when UFT opens by using the Add-in Manager dialog box. You can check
which add-ins are loaded by choosingHelp > About HP Unified Functional Testing. For details,
see theHP Unified Functional Testing Add-ins Guide.

What information does UFT need to identify objects in your application?
You need to know the URL, the executable file name and path, or other command-line information.
Later, you will enter this in "Record and Run Settings Dialog Box" (described on page 865). This
enables UFT to identify objects in your application and optionally open your application at the
beginning of a run session. For details, see the sections describing the Record and Run options for
your testing environment in theHP Unified Functional Testing Add-ins Guide.

What actions do you need to create?
You need to analyze the various business processes that customers perform while using your
application and to create an action for each sub-process, or task, a customermight perform.

To determine which actions you need, you navigate through your application from a customer's
perspective. While doing this, you perform the steps that customers might perform. Each process
you perform in your application will be represented as an action in UFT. You can create your tests
now, or you can wait until you are ready to add steps to your tests

As you perform a process, try to compartmentalize or "chunk" it into modular units.

Example:

An application that enables users to purchase items onlinemight contain various business
processes, including registering on the site and purchasing items. Each process may require
one or more tasks—you create actions based on these tasks. For example, registering on the
site may be a simple process requiring only one action, whereas purchasing items may be
more complex, requiring several actions, such as a Login action, aBrowse action, an
AddToCart action, aPurchaseItems action, and a Logout action.

By creating separate reusable actions for each sub-process, you can include calls to the same
actions frommultiple tests. For example, youmay want to include a Login action in many of your
tests.

You can create empty actions now to set up a skeleton infrastructure for your tests, or you can
create them when you are ready to add steps to your actions. For details, see "Actions in GUI
Testing - Overview" on page 872.

Youmay also want to create a single test storing all actions relevant for an application. Then all
other tests can call the actions stored in this central repository. This helps with test structure and
maintenance.

Tip: As you plan your tests and actions, keep inmind that short tests and actions that check
specific functions of the application or complete a transaction are better than long ones that
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perform several tasks, as they are easier to reuse andmaintain over time.

Setting Up Object Repositories

Relevant for: GUI tests only

In this step, you build one or more object repositories and ensure that all objects have clear names
that follow any predetermined naming conventions defined by your organization.

You can create object repositories using UFT functionality to recognize and learn the objects in your
application, or you canmanually define objects. The object repository should contain all the objects
that are relevant for the tests using this infrastructure.

By creating and populating shared object repositories that can be associated with multiple actions,
you can use the same object repository in multiple tests. By maintaining all objects that are relevant
to an area of an application within one shared object repository, and by associating that object
repository with all relevant actions, changes to the application can be reflected in the object
repository without the need to update tests.

Before you create a new object repository, verify whether an object repository containing the
objects you are testing already exists. If not, you can create a new object repository or add objects
to an existing one.

Creating shared object repositories for the test automation infrastructure includes one or more of the
following:

Changing the way that UFT identifies specific objects
This is particularly helpful when your application contains objects that change frequently or are
created using dynamic content, for example, from a database. This needs to be done before you
create your object repository. For details, see "Configuring Object Identification" on page 1310.

Deciding how to organize your object repositories
For individual tests, you can work with the individual action's object repositories, or you can work
with a common (shared) object repository that can be used with multiple actions andmultiple tests.
If you are new to testing, youmay want to use the default (local) object repository that is unique to
each action. As you feel more comfortable with the basics of test design, youmay want to take
advantage of shared object repositories.

If you decide to work with shared object repositories, you need to determine how many shared
object repository files are required for your application. You also need to determine which shared
object repository will be used for each area of your application.

For details, see "Managing Test Objects in Object Repositories" on page 1198.

Adding (learning) objects from your application
You can instruct UFT to learn the objects in your application according to filters that you define. For
details, see "Adding and Deleting Test Objects in a Local or SharedObject Repository" on page
1199.
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Creating new objects with easily understandable names
Youmay create new objects to represent objects that do not yet exist in your application. You then
update the properties and values of these objects as necessary after they exist in the application.
For details, see "Define New Test Object Dialog Box" on page 1240.

When you create objects, make sure that they have names that are easy for application testers to
recognize and that follow any established object naming guidelines. This helps make both test
creation andmaintenance easier over time.

Copying or moving objects from one repository to another
For details, see "SharedObject Repositories" on page 1285.

Merging objects from local repositories to shared object repositories
Application testers may create objects that are saved in an action's local object repository. You can
merge these objects into a shared object repository. You can alsomerge two or more existing
shared object repositories. For details, see "Object Repository Merge Tool" on page 1351.

Creating Function Libraries

Relevant for: GUI tests only

Creating function libraries involves developing customized functions for the application you want to
test. Youmay want to develop functions to test special application functionality that is not already
supplied by themethods in the UFT object model. This enables you to create keywords that
perform operations that are not normally available for use with a particular test object class. For
example, youmay need to add a worksheet to an Excel file, or to generate a text file during a run
session.

It may also be useful to wrap existingmethods and functions together with additional programming
to create application-specific functions for testing operations or sequences that are commonly
performed in your application. The functions you create will be available either as extra keywords or
as replacements for built-in UFT keywords during the test creation stage.

By encapsulatingmuch of the complex programming into function libraries, and by making these
functions flexible enough to use inmany testing scenarios (through the use of function parameters
that control the way the functions behave), one or a few automation experts can prepare the
keywords that many application testers (who are less technical) can include inmultiple tests. This
alsomakes it possible to update testing functionality without having to update all the tests that use
the keywords.

When creating a function library for the test automation infrastructure, youmay do the following:

l Determine whether you need to create any user-defined functions or whether you
should associate any existing function libraries with your test.

l Determine which keywords are needed.

l Develop and document business-level keywords in function libraries. For details, see
"User-Defined Functions and Function Libraries" on page 1029 and "How to Create andManage
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Function Libraries" on page 1041.

l Create the actual functions within the function libraries. You can do this manually, or you
can use the Function Definition Generator to generate function definitions and header
information. For details, see "How to Create and Register a User-Defined Function Using the
Function Definition Generator" on page 1051.

l Optionally define functions as new or replacement methods for test objects. For details,
see "Registered User-Defined Functions" on page 1035.

l Debug your function libraries. For details, see "Debug a function in a function library" on page
1042.

Configuring UFT According to Your Testing Needs

Relevant for: GUI tests only

After you set up the test automation infrastructure, you need to configure UFT to use this
infrastructure. This involves one or more of the following:

Defining your global testing preferences
You need to specify configuration settings that affect how you create and run tests in general—
these settings are not test-specific. For example, you can instruct UFT to record amovie of the run
session under certain conditions, and to enable other HP products to run UFT tests (for example, if
you want to run your tests from ALM).

You can set global testing options using the Options dialog box (Tools > Options) or by inserting
statements in the Editor. For details, see "Global Options - Overview" on page 523.

Creating recovery scenarios
Although not directly associated with the keyword-drivenmethodology, the automation experts who
maintain the object repositories and function libraries also oftenmaintain a set of recovery
scenarios that all application testers can associate with their tests. Recovery scenarios instruct
UFT how to proceed when a step fails. For details, see "Recovery Scenarios for GUI Testing" on
page 1111.

Configuring the UFT IDE to suit your testing preferences
This enables you to easily access any needed panes, such as the canvas, the Solution Explorer
pane, the Toolbox pane, or the Data pane. For details, see "UFTWindow Layout" on page 182.

Building Your Tests

Relevant for: GUI tests only

You can create tests that are as simple or complex as needed. In general, it is best to create tests
and actions that check just one or a few simple functions or complete a transaction rather than
creating long tests and actions that perform several complex tasks or that perform many tasks.
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Youmay do the following when creating tests and test steps:

l Create new tests, if needed. For details, see "Create a new standalone document" on page
136 or "Create a new document within an existing solution" on page 137.

l Create the required actions. For details, see "Analyzing Your Application" on page 821.

l Insert calls to the relevant actions. For example, if the first step in a test logs in to the
application, and you already created a Login action, insert a call to that action to include it in your
test. For details, see "Calls to Existing Actions and Copies of Actions" on page 875.

l Associate your object repositories with the relevant actions. This enables you to insert
steps that perform operations on those objects. For details, see "Associated Repositories Tab
(Action Properties Dialog Box)" on page 906.

l Associate your function libraries with the relevant tests. This enables you to use your
special keywords in any of the associated tests. For details, see "How toManage Function
Library Associations" on page 1045.

l Optionally associate recovery scenarios with your test. For details, see "How toManage
Recovery Scenario Associations" on page 1116.

Adding Steps to Your Test Actions

Relevant for: GUI tests only

When your actions are ready, you can add steps to them. This involves one or more of the
following:

Adding steps by selecting the keywords (operations) that represent the
application functionality you want to test
For details, see "Keyword View" on page 919.

You can insert steps in the Keyword View, the Editor, or a combination of both. You can add steps
by dragging test objects from the Toolbox pane, using theNew Step option, using the Step
Generator, entering steps manually, and so on. Make sure to fill in any missing values, as needed.

For details, see "How to Add a Standard Step to Your Test or Component" on page 925, "Types of
Action and Component Steps " on page 921, and "Statement Completion in the Editor" on page 306.

Enhancing your tests by inserting checkpoints and output values

l You can insert checkpoints to check for differences in the text strings, objects, and tables in
your application. For details, see "Checkpoints Overview" on page 1396.

l You can insert output value steps that retrieve values in your test and store them for use as input
values at a different stage in the run session. For details, see "Output Values Overview" on page
1488.
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Data-driving your test
You can use the Data pane to data-drive your test using different data input during subsequent run
sessions. This enables you to check how your application behaves duringmultiple iterations of the
same action during a single run session. For details, see "Data Pane" on page 221.

Replacing fixed values with parameters
When you parameterize your test, you can check how it performs the same operations with multiple
sets of data, or from data stored or generated by an external source. This enables you to increase
the power and flexibility of your test. For details, see "Parameterizing Object Values" on page 1526.

Running and Troubleshooting Your Tests

Relevant for: GUI tests only

When your tests are ready, you run them, view the run results, and troubleshoot your tests, as
needed.

l Before you run a test, ensure that all of the required settings are configured as needed
and that the required UFT add-ins are loaded.Make sure that your application is open to the
appropriate location for the beginning of the test, or that you instructed UFT to open it for you.
Additionally, make sure that the Test Settings dialog box (File > Settings) and Record and Run
Settings dialog box (Record > Record And Run Settings) are configured for your test. For
details, see "Running Tests and Components" on page 634.

l After your test runs, view the run results. Expand the nodes in the Run Results Viewer to
see where steps failed and to try to understand why. For details, see the Run Results Viewer
Result Details Pane (described in theHP RunResults Viewer User Guide).

l Troubleshoot your test so that it runs correctly. For example, youmay need to add or
modify test steps. For details, see "Maintaining and Updating GUI Tests or Components " on
page 1078.
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Test a Flight Application Using the Keyword-Driven
Methodology - Use-Case Scenario

Relevant for: GUI tests only

The process of creating a test is actually comprised of several steps. This section walks you
through the activities youmight perform for each of these steps, if you were preparing a test suite
for theMercury Tours application, including:

Define the Testing Environment for theMercury Tours Application 828

Analyze theMercury Tours Application 828

Plan and Create theMercury Tours Test Action Repository 831

Set Up theObject Repositories for theMercury Tours Application 832

Create the Function Libraries and Functions Required for Testing theMercury Tours
Application 833

Create Tests and Test Steps for theMercury Tours Business Processes 834

Mercury Tours is aWeb-based demo application that simulates an online flight reservation
application. You can view and experiment with this demo application at
http://newtours.demoaut.com.

Define the Testing Environment for the Mercury Tours Application

Relevant for: GUI tests only

Defining the testing environment includes determining which add-ins to load and the data required to
open the application.

Mercury Tours is aWeb application that contains a few Java applets. Therefore, we need to ensure
that the UFTWeb and Java Add-ins are installed and loaded.

To open the application, we need to run a URL in aWeb browser. The URL is
http://newtours.demoaut.com.

Analyze the Mercury Tours Application

Relevant for: GUI tests only

When analyzing the application to determine which business processes wemay want to test, we
can consider both the existing business processes in the application as well as functionality that is
planned for the upcoming release of the application.
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The business processes that should be tested for theMercury Tours application include:

l Registering on the site

l Reserving a flight

l Viewing the itinerary of a pending reservation

l Canceling a reservation

l Updating user profile information

l Reserving hotel rooms

l Renting a car

Although the last two items above have not yet been implemented in the application wewant to
test, it is important to take them into account in the planning stage.

Now that we have determined the primary business processes, we should analyze each one to
determine the break-down of these business processes into their reusable building-block elements
(what will later become the actions of our tests).

A logical breakdown of the above business processes could be:

l Registering on the site

n Open the application

n Go to the registration page

n Enter the required information in the form

n Submit the form

n Verify that the form information is valid

o If a mandatory field did not have a value, an error message is displayed.

o If the password and confirm password values are not the same, an error message is
displayed.

o If the username entered in the form already exists in the database, an error message is
displayed.

o Otherwise, the successful registration page is displayed.
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l Reserving a flight

n Open the application

n Sign on

n Navigate to the Flight Finder page

n Enter the flight details

n Enter the service class and airline preferences

n Click Next to navigate to the next page

n Select the departure and return flights

n Click Next to navigate to the next page

n Enter the passenger details

n Verify that the form information is valid

o If the return date is earlier than the departure date, an error message is displayed.

o If a mandatory field was not entered, an error message is displayed.

o Otherwise, the flight confirmation page is displayed.

l Viewing the itinerary of a pending reservation

n Open the application

n Sign on

n Navigate to the Itinerary page

l Canceling a reservation

n Open the application

n Sign on

n Navigate to the Itinerary page

n Select the reservation to cancel

n Click theCancel Checked Reservations button
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n Verify

n Successful cancellation

l Updating user profile information

n Open the application

n Sign on

n ...

And so on for each of the remaining processes.

Comparing the sub-items in each of the business-processes helps to identify the reusable elements
of each business process.

Plan and Create the Mercury Tours Test Action Repository

Relevant for: GUI tests only

By analyzing the breakdown performed in the previous step, we are able to identify some logical,
and reusable sub-processes. Each of these is created as a reusable action.

The required actions for the set of business processes we defined could include:

l Register

l SignOn

l Flight Details and Preference

l Select a Flight

l Enter Passenger Details

l Verification and Confirmation

l Navigate to Itinerary

l Cancel Flight
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Although we are not yet ready to create the actual tests or steps yet, we can create a single test. In
the test, we can already define empty test actions for each of these. This test then acts as the
action repository, and the tests that test each of our business processes all call actions from this
action repository test.

Set Up the Object Repositories for the Mercury Tours Application

Relevant for: GUI tests only

Now that we know which business processes and sub-processes wewant to test, we can analyze
the application in detail to determine which objects are important to test and how wewant to
organize the objects we will learn for these tests.

We know that it is best to createmanageable-sized object repositories that are organized by areas
of the application.

Most of the business processes we plan to test are in the central flight reservation area of the
application and thus many of the same objects will be used in each of the relevant tests, but the
sign on and registration processes aremore standalone areas and it makes sense to store their
objects separately. Thus it seems logical to create two object repository files:

l SignOn_Register

l Reservations

To create each of these repositories, we take advantage of the "Navigate and Learn Toolbar"
(described on page 1302), which enables us to navigate to each page that is relevant for the object
repository to automatically learn all the objects in the page. By using the filter options in the
Navigate and Learn toolbar, we can ensure that we learn only the types of objects we need. For
example, we can avoid learning all the non-link image objects on every page, since these objects
probably do not need to be tested and would otherwise result in a larger and less manageable object
repository.
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Afterward, we should open the object repository for editing to delete specific objects that are not
necessary and to rename objects that may otherwise be difficult to recognize when we later want to
create steps with these objects.

OurSignOn_Register object repository may look something like this:

Note that each page contains only the relevant objects for the Sign on and Register business
processes.

Create the Function Libraries and Functions Required for Testing
the Mercury Tours Application

Relevant for: GUI tests only

In some of our business processes, we want to test not only that the business processes can be
performed to completion, but that certain features in the application behave as expected.

Because testing such functionality requires complex programming, and because wewant to test
the functionality in several different sub-processes, it makes sense to create these functionality
checks in the form of functions, and to store them in function libraries, so that we can call the
functions frommore than one test action.
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For example, we want to verify that theMercury Tours application properly handles various invalid
data in forms and wewant to verify that the application properly calculates ticket prices for various
types of itineraries.

We also want to make sure that we have ways to recover from certain application problems so that
if such a problem occurs while a step is running, it does not prevent the action or test from
completing its run or prevent other tests from running afterward. This recovery function can be used
by recovery scenarios that we will associate with our tests at later stages.

At this stage, we can create a function library containing functions such as:

l VerifyForm

l VerifyTicketPrice

l DataBaseFailureRecoveryFunction

Create Tests and Test Steps for the Mercury Tours Business
Processes

Relevant for: GUI tests only

Now that we have planned and prepared all of the required resources for our tests, we are ready to
use them to create tests and test steps that represent the steps a real user would perform on the
Mercury Tours application as well as inserting functions that verify the expected functionality of
various features.

We start by using the solution explorer to associate the relevant object repository with each action
in the action repository test and to associate our function library with the test as well.
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Then we use the Toolbox pane to drag objects and functions into our actions to create the individual
steps of each action.

As we design our steps, wemake sure to parameterizemethod arguments as necessary to
maximize reusability of the actions in different business processes (tests).

Finally, we create new tests for each of the processes we defined in the "Analyze theMercury
Tours Application" step (see page 828). We use the solution explorer to associate our function
library with each test and then we insert calls to the relevant actions.
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Tasks

How to Create a GUI Test Using the Keyword-Driven
Methodology

Relevant for: GUI tests only

This task describes how to create a test using the keyword-drivenmethodology. For details on a
specific step, see the parallel section in "Keyword-DrivenMethodology - Overview" on page 821.

This task includes the following steps:

l "Analyze your application" below

l "Prepare the testing infrastructure " below

l "Add steps to the actions in your test action repository" on page 838

l "Enhance your test " on page 838

l "Run your test " on page 839

l "Analyze the run results and report any defects" on page 840

1. Analyze your application
Before you begin creating a test, you need to analyze your application and determine your
testing needs. You need to:

n Determine the development environments in which your application controls were
developed, such as Web, Java, or .NET, so that you can load the required UFT add-ins.

n Determine the functionality that you want to test. To do this, you consider the various
activities that customers perform in your application to accomplish specific tasks. Which
objects and operations are relevant for the set of business processes that need to be
tested?Which operations require customized keywords to provide additional functionality?

n Decide how to divide these processes into smaller units that will be represented by
your test's actions. Each action should emulate an activity that a customermight perform
when using your application.

As you plan, try to keep the amount of steps you plan to include in each action to a
minimum. Creating small, modular actions helps make your tests easier to read, follow, and
maintain.

For an overview of this step, see "Analyzing Your Application" on page 821.

2. Prepare the testing infrastructure
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To complete the infrastructure that is part of the planning process, you need to:

n Build the set of resources to be used by your tests, including:

o shared object repositories containing test objects (which are representations of the
objects in your application).

For details, see "Managing Test Objects in Object Repositories" on page 1198.

o function libraries containing functions that enhance UFT functionality.

For details, see "User-Defined Functions and Function Libraries" on page 1029

o recovery scenarios that instruct UFT to recover from unexpected events and errors that
occur in your testing environment during a run session. (Optional)

For details, see "Recovery Scenarios for GUI Testing" on page 1111.

o additional optional files, such as data table files and environment variable files.

n Configure UFT according to your testing needs. This can include:

o setting up your global testing preferences.

For details, see "Global Options - Overview" on page 523.

o setting up any test-specific preferences.

For details, see "Settings for GUI Tests, GUI Business Components, and Application
Areas" on page 580.

o configuring your run session preferences.

For details, see "Run Sessions Pane (Options Dialog Box > General Tab)" on page 526,
"Test Runs Pane (Options Dialog Box > GUI Testing Tab)" on page 539, and "Run Pane
(Test Settings Dialog Box)" on page 601.

o defining and associating recovery scenarios.

For details, see "Recovery Scenarios for GUI Testing" on page 1111.

o creating automation scripts that automatically set the required configurations (such as
the add-ins to load) on the UFT client at the beginning of a run session. For details, see
"UFT Automation Scripts" on page 1155.

n Create one or more tests that serve as action repositories in which you can store the
actions to be used in your tests, as this enables you tomaintain your actions in one central
location.

User Guide
Chapter 31: Test Creation - Keyword-DrivenMethodology

HP Unified Functional Testing (12.00) Page 837 of 2274



n Associate your shared object repositories with the relevant actions (in these action
repositories). This enables you to later insert steps using the objects stored in the object
repositories. When you create your tests, you insert calls to one or more of the actions
stored in this repository.

For an overview of this step, see "Setting UpObject Repositories" on page 823.

For details, see "Associate Repositories Dialog Box" on page 1266.

3. Add steps to the actions in your test action repository
n (Prerequisite) Associate your function libraries and recovery scenarios with the

relevant tests, so that you can insert steps using keywords.

For details, see "Solution Explorer Pane User Interface" on page 478.

n Create steps using keyword-driven functionality. You can use the table-like, graphical
Keyword View—or you can use the Editor if you prefer to program steps directly in VBScript.

You can add steps to your test in one or both of the following ways:

o Drag objects from your object repository or from the Toolbox pane to add
keyword-driven steps in the Keyword View or the Editor.

The object repository and Toolbox pane contain all of the objects that you want to test in
your application. You created one or more object repositories when you prepared the
testing infrastructure, as described in "Prepare the testing infrastructure " on page 836.

o Record on your application. As you navigate through your application during a
recording session, each step you perform is graphically displayed as a row in the
Keyword View. For details, see "Keyword View" on page 919.

For an overview of this step, see "Creating Function Libraries" on page 824.

4. Enhance your test
You can enhance the testing process by modifying your test with special testing options and/or
with programming statements, such as:

n Insert checkpoints and output values into your test.

For details, see "Checkpoints Overview" on page 1396 and "Output Values Overview" on
page 1488.

n Replace fixed values with parameters to broaden the scope of your test. For details, see
"Parameterizing Object Values" on page 1526.
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n Add user-defined functions by creating function libraries and calling their functions from
your test.

For details, see "User-Defined Functions and Function Libraries" on page 1029.

n Use the many functional testing features included in UFT to enhance your test and/or
add programming statements to achievemore complex testing goals.

For details, see "Generated ProgrammingOperations" on page 968.

For an overview of this step, see:

n "Creating Function Libraries" on page 824

n "Configuring UFT According to Your Testing Needs " on page 825

n "Building Your Tests" on page 825

n "Adding Steps to Your Test Actions" on page 826

5. Run your test
After you create your test, you can perform different types of runs to achieve different goals.
You can:

n Run your test to check your application. The test starts running from the first line in your
test and stops at the end of the test. While running, UFT connects to your application and
performs each operation in your test, including any checkpoints, such as checking any text
strings, objects, tables, and so on. If you parameterized your test with data table
parameters, UFT repeats the test (or specific actions in your test) for each set of data
values in the Data pane.
For details, see "Running Tests and Components" on page 634.

n Run your test to debug it. (Optional)

You can:

o Control your run session to help you identify and eliminate defects in your test.

o Use theStep Into, Step Over, andStep Out commands to run your test step by step.

o Begin your run session from a specific step in your test, or run the test until a specific
step is reached.

o Set breakpoints to pause your test at predetermined points.

o View or change the value of variables in your test each time it stops at a breakpoint in the
Debug Viewer.
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o Manually run VBScript commands in the Debug Viewer.

For details, see "Debugging Tests and Components" on page 674.

n Run your test using Maintenance Run Mode after your application changes.
(Optional)

UseMaintenance Run Mode to update your test when you know that your application has
changed, and you therefore expect that UFT will not be able to identify the objects in your
test. For details, see "Maintaining and Updating GUI Tests or Components " on page 1078.

n Run your test using Update Run Mode to update one or more of the following:
(Optional)

o property sets used for test object descriptions

o expected checkpoint values

o data available to retrieve in output values

o Active Screen images and values

For an overview of this step, see "Running and Troubleshooting Your Tests" on page 827.

6. Analyze the run results and report any defects
After you run your test, you can:

n View the results of the run in the Run Results Viewer. You can view a summary of your
results as well as a detailed report.

o If you captured still images or movies of your application during the run, you can view
these from the Screen Recorder tab of the Run Results Viewer.

For details, see the Screen Recorder Pane (described in theHP RunResults Viewer
User Guide).

o If you enabled local systemmonitoring for your test, you can view the results in the
SystemMonitor tab of the Run Results Viewer.

For details, see the section on the SystemMonitor Pane (described in theHP Run
Results Viewer User Guide).

n Report defects detected during a run session. (Optional)

If you have access to ALM, you can report the defects you discover to the project database
in either of the following ways:

o Instruct UFT to automatically report each failed step in your test.
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o Report failed steps manually from the Run Results Viewer.

For details, see "ALM Integration" on page 707.
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Chapter 32: Recording GUI Tests and Components
Relevant for: GUI tests and components

This chapter includes:

Concepts 843

Recording GUI Tests and Components - Overview 843

RecordingModes 845

Tasks 853

How to Record aGUI Test 853

How to Record aGUI Component 855

How to Record Using Analog Recording 858
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Analog Recording Settings Dialog Box 863

Record and Run Settings Dialog Box 865
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Troubleshooting and Limitations - Recording 870
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Concepts

Recording GUI Tests and Components - Overview
Relevant for: GUI tests and components

You can create themain body of a test or component by recording the typical processes that users
perform on your application. UFT records the operations you perform, adding them as steps to the
selected test action or component.

A step is anything you do that changes the content of a page or object in the application, for
example, clicking a link or typing data in an edit box. The steps in your action or component
represent the operations you perform on your application. As you record the action or component, if
it is visible in the Keyword View or the Editor, you can see the steps that are added based on the
operations you perform.

During a run session, UFT uses the recorded steps to replicate the operations you performed while
recording.

While you record the steps, UFT creates test objects representing the objects in your application on
which you perform operations, and stores them in an object repository. This enables UFT to identify
the objects in your application both while creating the test or component and during a run session.

Recording can be useful in the following circumstances:

l You are new to UFT and want to learn how UFT interprets the operations you perform on your
application and how it converts them to UFT objects and built-in operations.

l You need to quickly create a test or component that tests the basic functionality of an
application or feature, and does not require long-term maintenance.

l You are working with a new application or with major new features of an existing application, and
you want to learn how UFT interacts with the application.

l You are developing functions that incorporate built-in UFT keywords.

When you record a test or component, UFT enters the correct objects, methods, and argument
values for you. Therefore, it is possible to create a basic test or component with little preparation or
planning. During a recording session, you can also add checkpoint and output value steps, to check
or retrieve values from your application.

When recording a test, you can use the standalone Record toolbar, to divide the steps recorded into
multiple actions. For details on the Record toolbar, see "Record Toolbar" on page 866. For details
on why and how to work with multiple actions, see "Actions in GUI Testing" on page 871.
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By default, UFT records in the normal recordingmode. For tests and scripted components, UFT
supports additional recordingmodes that you can use. For example, these recordingmodes can be
useful in the following situations:

l If you are unable to record on an object in a given environment in the standard recordingmode.

l If you want to recordmouse clicks and keyboard input with the exact x- and y-coordinates.

l If you want UFT to recognize objects in your application based on what they look like, instead of
using properties that are part of their design.

For details, see "RecordingModes" on the next page.

You can also create a test or component by using the keyword-drivenmethodology, which enables
you to select keywords to indicate the operations you want to perform on your application, as
described in "Test Creation - Keyword-DrivenMethodology" on page 820.

Guidelines for Recording Tests and Components

Relevant for: GUI tests and components

l Before you begin recording, you need to ensure that your tests and components cover your
testing requirements. For details on planning your tests and components, see "GUI Test
Creation Overview" on page 812.

l Consider increasing the power and flexibility of your test or component by replacing fixed values
with parameters. When you parameterize your test or component, you can check how it
performs the same operations with multiple sets of data, or from data stored or generated by an
external source. For details, see "Parameterizing Object Values" on page 1526.

l When you record tests or components, youmay not notice that new objects are being added to
the local object repository. This may result in many testers maintaining local object repositories
with copies of the same objects. When using a keyword-drivenmethodology, you select the
objects for your steps from the existing object repository. When you need a new object, you can
add it to your local object repository temporarily, but you are also aware that you need to add it to
the shared object repository for future use.

l If you are recording steps on aWeb-based application, evaluate the types of events you need to
record. If you need to recordmore or fewer events than UFT generally records by default, you
can configure the events you want to record. For details, see the section on configuringWeb
event recording in theHP Unified Functional Testing Add-ins Guide.

l If you are creating a test or component onWeb objects, you can record your test or component
onMicrosoft Internet Explorer or Mozilla Firefox and run it on another supported browser
(according to the guidelines specified in theHP Unified Functional Testing Product Availability
Matrix, available from the UFT Help or the root folder of the Unified Functional Testing DVD).

UFT supports running tests and components on the following browsers—Microsoft Internet
Explorer, Mozilla Firefox, Google Chrome, and applications with embeddedWeb browser
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controls. UFT can also connect to a remoteMac computer (with a UFT Connection Agent
installed) and run tests and components on Safari. For details, see theHP Unified Functional
Testing Add-ins Guide.

l If you have objects that behave like standard objects, but are not recognized by UFT, you can
define your objects as virtual objects. For details, see "How to Define Virtual Objects for
Unsupported Objects in Your Test or Scripted Component" on page 1387.

l After you create your test or component, you can enhance it using checkpoints and other special
testing options. After creating your initial test, you can further enhance it by adding and
modifying steps in the Keyword View or Editor.

Recording Modes
Relevant for: GUI tests and scripted GUI components

UFT provides the following recordingmodes:

l Normal Recording. Records the objects in your application and the operations performed on
them. This mode is the default and takes full advantage of the UFT test object model,
recognizing the objects in your application regardless of their location on the screen. For details,
see "How to Record aGUI Test" on page 853.

When working with specific types of applications, objects, operations, or environments,
however, youmay want to choose from the following, alternative recordingmodes:

l "Analog Recording". Enables you to record the exact mouse and keyboard operations relative
to the screen or the application window. This method records mousemovements. For details,
see "Analog Recording" on the next page.

l "Low-Level Recording". Enables you to record operations on the exact coordinates of any
object, whether or not UFT recognizes the specific object or the specific operation. This method
does not recordmousemovements. For details, see page "Low-Level Recording" on page 847.

l "Insight Recording" (tests and scripted components only). Enables you to record
operations on objects that UFT recognizes based on their appearance, instead of their native
properties. This can be useful if you are recording on an application whose technology is not
supported by UFT, or on an application running on an emulator or a remote computer. For details,
see page "Insight Recording" on page 849.

Use analog, low-level, or Insight recording only when normal recordingmode does not accurately
record your operation. Analog, low-level, and Insight recording require more disk space than normal
recordingmode.

Note: UFT supports an additional recordingmode, StandardWindows recording, which is
relevant when recording tests or components on SAP GUI forWindows applications. For
details, see the SAP GUI forWindows section of theHP Unified Functional Testing Add-ins
Guide.
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Analog Recording

Relevant for: GUI tests and scripted GUI components

This method enables you to record the exact mouse and keyboard operations that you perform, in
relation to either the screen or the application window. In this recordingmode, UFT records and
tracks every movement of themouse as you drag themouse around a screen or window.

This mode is useful for recording operations that cannot be recorded at the level of an object, for
example, recording a signature produced by dragging themouse.

Use analog recording for applications in which the actual movement of themouse is what you want
to record. These can include drawing amouse signature or working with drawing applications that
create images by dragging themouse.

You can switch to analog recording in themiddle of a recording session for specific steps. After you
record the necessary steps using analog recording, you can return to normal recordingmode for the
remainder of your recording session.

For task details, see "How to Record Using Analog Recording" on page 858.

Considerations for Analog Recording

l You can record in analog recordingmode relative to the screen or relative to a specific window.
For details, see "Analog Recording Settings Dialog Box " on page 863.

l The steps recorded using analog recording are saved in a separate data file. This file is stored
with the action in which the analog steps are recorded.

l When you record in analog recordingmode, UFT adds to your test action or scripted component
a singleRunAnalog statement that calls the recorded analog file. The corresponding Active
Screen displays the results of the last analog step that was performed during the analog
recording session.

l You cannot edit analog recording steps from within UFT.

l Analog recording requires more disk space than normal recordingmode.

Example

If you chose toRecord relative to the screen, UFT inserts theRunAnalog step for a
Desktop item. For example:

Desktop.RunAnalog "Track1"
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If you chose toRecord relative to the following window, UFT inserts theRunAnalog step
for aWindow item. For example:

Window("Windows Internet Explorer").RunAnalog "Track1"

The track file called by theRunAnalogmethod contains all your analog data and is stored with
the current action.

To use this track file in other actions or tests, youmust call the action or scripted component
that contains theRunAnalog step.

When entering theRunAnalogmethod, youmust use a valid and existing track file as the
method argument.

To stop an analog step in themiddle of a run session, press CTRL + ESC, then click Stop in the
Testing toolbar.

Low-Level Recording

Relevant for: GUI tests and scripted GUI components

This method enables you to record on any object in your application, whether or not UFT recognizes
the specific object or the specific operation. This mode records at the object level and records all
run-time objects as Window orWinObject test objects.

You can switch to low-level recording in themiddle of a recording session for specific steps. After
you record the necessary steps using low-level recording, you can return to normal recordingmode
for the remainder of your recording session.

For task details, see "How to Record Using Low-Level Recording" on page 859.

Considerations for Low-Level Recording

l Use low-level recording for recording on environments or objects not supported by UFT, if the
appearance of the objects might change, but their location will not. If the object’s appearance will
not change, you can use Insight recording for unsupported environments or objects.

l Use low-level recording for when you need to record the exact location of the operation on your
application screen. While recording in normal mode, UFT performs the step on an object even if
it has moved to a new location on the screen. If the location of the object is important to your test
or scripted component, switch to low-level recording to enable UFT to record the object in terms
of its x- and y- coordinates on the screen. This way, the step will pass only if the object is in the
correct position.

l While low-level recording, UFT records all parent level objects as Window test objects and all
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other objects as WinObject test objects. They are displayed in the Active Screen as standard
Windows objects.

l Low-level recording supports the followingmethods for each test object:

n WinObject test objects: Click, DblClick, Drag, Drop, Type

n Window test objects: Click, DblClick, Drag, Drop, Type, Activate,Minimize, Restore,
Maximize

l Each step recorded in low-level recordingmode is added to the test and can be viewed in the
Keyword View and Editor. (Analog recording records only the one step that calls the external
analog data file.)

l Low-level recordingmode is not fully supported for multibyte character input.

l Steps recorded using low-level recordingmodemay not run correctly on all objects.

l Low-level recording requires more disk space than normal recordingmode.

Example

The following examples illustrate the difference between the same operations recorded using
normal mode and low-level recordingmode.

Suppose you type the word tutorial into a user name edit box and then press the TAB key while
in normal recordingmode. Your action or scripted component is displayed as follows in the
Keyword View and Editor:

Browser("Welcome: Mercury Tours").Page("Welcome: Mercury Tours").WebEdit("userName"
).Set "tutorial"

If you perform the same action while in low-level recordingmode, UFT records the click in the
user name box, followed by the keyboard input, including the TAB key. Your action or scripted
component is displayed as follows in the Keyword View and Editor:

Window("Windows Internet Explorer").WinObject("Internet Explorer_Server").Click 536,261
Window("Windows Internet Explorer").WinObject("Internet Explorer_Server").Type "tutorial"
Window("Windows Internet Explorer").WinObject("Internet Explorer_Server").Type micTab
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Insight Recording

Relevant for: GUI tests and scripted GUI components

This mode enables you to record on any control (object) displayed on your screen, whether or not
UFT recognizes the object's technology and is able to retrieve its properties or activate its methods.

In this mode, UFT recognizes controls based on their appearance, and not their native properties.
This can be useful to test controls from an environment that UFT does not support or even from a
remote computer running a non-Windows operating system.

You can switch to Insight recording in themiddle of a recording session for specific steps. After you
record the necessary steps using Insight recording, you can return to normal recordingmode for the
remainder of your recording session.

For task details, see "How to Record a Test or Component Using Insight Recording" on page 860.

Considerations for Insight Recording

l Use Insight recording for recording on applications, environments, or controls that UFT does not
recognize when using the normal recordingmode.

l While recording in the Insight recordingmode, UFT creates an InsightObject test object for
every control on which you perform an operation. For details, see "Identifying Objects Using
Insight" on page 1176.

With every InsightObject, UFT stores an image of the control that the test object represents,
and, optionally, a number of snapshots of the application containing the control.

After you record the objects, you can use these snapshots in the Change Test Object Image
dialog box (described on page 1233) to change the image stored with the test object in the object
repository, if necessary.

l If theSave the clicked coordinates as the test object's ClickPoint option is selected in the
Insight pane of the Options dialog box (Tools > Options > GUI Testing tab > Insight node),
the test object's ClickPoint is set to the first location that you clicked on the control. You can
modify the ClickPoints manually in the "Change Test Object Image / Add Insight Test Object
Dialog Box" (described on page 1233) dialog box when you finish recording.

If you want the ClickPoint for Insight objects set toCenterwhen they are added during a
recording session, clear theSave the clicked coordinates as the test object's ClickPoint
option.

l When created, all Insight test objects are named InsightObject, with an incremental suffix
added if necessary, to avoid duplicate test object names within a single parent test object.

After recording, you canmodify the recorded test objects and steps to improve the readability
and efficiency of your test or component. For details, see the step about fine-tuning recorded
objects in "How to Record a Test or Component Using Insight Recording" on page 860.
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l Each step recorded in Insight recordingmode is added to the test and can be viewed in the
Keyword View and Editor. In the Editor, the test object image is displayed in the step instead of
the test object name. (To show test object names instead, clear theShow test object image in
steps in the Insight pane (Tools > Options > GUI testing tab > Insight node.)

l Insight recording requires more disk space than normal recordingmode, because of the test
object image and the snapshots stored with the test object.

To control the amount of space used, you can adjust the number of snapshots saved and their
size in the "Insight Pane (Options Dialog Box > GUI Testing Tab)" described on page 561.
These settings can also affect UFT performance when recording and running Insight steps.

In addition, after you finish recording all of the relevant test objects, andmodifying them to your
satisfaction in the object repository, you can delete all of the snapshots to reduce the amount of
disk space used. This does not delete the test object's image, which is used to recognize the
object in the application.

Troubleshooting for Insight Recording

l When using Insight recording to record operations on a remote computer accessed by a program
other than Remote Desktop Connection, the boundaries of the control being learnedmight not be
recognized correctly. This happens because unlike Remote Desktop Connection, other
programs do not suppress the cursor during screen capture. The cursor's presence in the
capturemakes the boundaries of the control more difficult to recognize.

Workaround:Configure the remote access program to not display the remote cursor.
Alternatively, you canmodify the test object image saved with the learned test object after the
recording session. For details, see "Change Test Object Image / Add Insight Test Object Dialog
Box" on page 1233.

l The Insight recording technology is based on image processing. During a recording session,
clicking on control images that contain straight lines may result in the object being recorded
incorrectly. Make sure that you click in the center of such objects.

l During a recording session, when recording amix of keyboard andmouse events (typing and
clicking) using Insight recording, the order of the recorded steps might not reflect the actual order
of events.

Only use Insight recording for mouse events. When possible, keyboard events should be
recorded using standard or low-level recording.

If you have to record keyboard events in Insight, wait two seconds before and after typing to
ensure that the events are recorded in the correct order.

If necessary, you can change the order of the steps manually after recording.

l When recording in Insight mode, window operations such as Close, Move, Minimize, and
Maximizemay be recorded on the wrong parent object.
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This is because in Insight mode, UFT processes the user's operations without halting the
application's responses. The image-processing algorithms used to identify controls are time
consuming, and in some cases, the operation is processed and recorded after the application
carried it out. If the window already closed or moved, the operation is recorded on the object that
is currently present in the clicked location.

Workaround:Do one of the following: 

n Use standard recording to record these operations.

n Instead of recording the operation, learn the control (in the Object Repository window, use
Add Insight Object to Local) and compose a step that clicks on the object.

l When recording in Insight mode, drag and drop operations of top-level windows may not be
recorded.

Workaround:Do one of the following:

n Record the drag and drop operations using normal recording. UFT will record these steps on
regular, non-Insight, UFT test objects.

n Learn the top-level window as a regular UFT test object and then compose the Drag and Drop
steps in the editor.

l Dual monitor support. When recording in Insight mode, UFT records only on the primary
monitor. Therefore, if you are working with dual monitors, make sure that your application is
visible on the primary monitor during a recording session.

Insight Recording Example

The following examples illustrate the difference between the same operation recorded using
normal mode and Insight recordingmode.

Suppose you click theSign-in button on theMercury Tours Web site while in normal recording
mode. UFT recognized theWeb control, and the recorded step is displayed as follows in the
Keyword View and Editor:

However, if you perform the same action on a browser running on a remote computer, UFT
does not recognize the button as aWeb control. Instead, UFT recognizes only the Remote
Desktop Connection window as a control, and your click is recorded at the relevant
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coordinates within it. The recorded step is displayed as follows in the Keyword View and
Editor:

For this step to succeed during a run session, the browser window must be in the exact same
location within the Remote Desktop Connection window.

You can solve this problem by recording the step using Insight recording. The recorded step is
displayed as follows in the Keyword View and Editor:

This step is easier to read, and will succeed even if the browser window is located in a different
location within the remote desktop window. This is because UFT looks for a shape that
resembles theSign-in button anywhere inside the Remote Desktop Connection control.
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Tasks

How to Record a GUI Test
Relevant for: GUI tests only

This task describes how to create a test in UFT by recording the steps that you perform on your
application.

This task includes the following steps:

l "General Prerequisites" below

l "Web-based Applications Prerequisites" below

l "Start a recording session and set the Record and Run settings if necessary" on the next page

l "Record steps into the test" on the next page

l "Use the Record toolbar to manage your recording session" on the next page

l "Switch to other recordingmodes - optional" on page 855

l "Stop recording and save the test" on page 855

1. General Prerequisites
n Close unnecessary applications. Before you start to record, close all applications not

required for the recording session.

n Determine application access. Decide how you want to open the application when you
record and run your test. You can choose to have UFT open one or more specified
applications, or record and run on any application that is already open. The "Record and Run
Settings Dialog Box" (described on page 865) contains tabbed pages corresponding to the
add-ins loaded. For details, see the section on setting Record and Run options in the
HP Unified Functional Testing Add-ins Guide.

n Set global record and run options. Choose how you want UFT to record and run your
test by setting global testing options in the Options dialog box and settings specific to your
test in the Test Settings dialog box. For details, see "UFT Global Options" on page 522 and
"Settings for GUI Tests, GUI Business Components, and Application Areas" on page 580.

2. Web-based Applications Prerequisites
Determine Browser activation timing. UFT can record only onWeb browsers that were
opened after UFT. If you plan to use theRecord and run tests on any open browser option
in the "Record and Run Settings Dialog Box" (described on page 865), make sure that the
browser you want to use for recording was opened after you opened UFT.
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Set security zone. If you are recording on aWeb site, determine the security zone of the site.
When you record on aWeb browser, the browser may prompt you with security alert dialog
boxes. Youmay choose to disable/enable these dialog boxes.

Modify object values. If you are recording on aWeb object, youmust modify the object's
value to enable UFT to record the step. For example, to record a selection in aWebList object,
youmust click on the list, scroll to an entry that was not originally showing, and select it. If you
want to select the item in the list that is already displayed, youmust first select another item in
the list (click it), then return to the originally displayed item and select it (click it).

Modify the Web event configuration. If you are recording on aWeb object, youmay want to
select a predefined configuration level in theWeb Event Recording Configuration dialog box
(described in theHP Unified Functional Testing Add-ins Guide). By default, UFT uses the
Basic recording level. If UFT does not record all the events you need, youmay require a higher
recording level.

3. Start a recording session and set the Record and Run settings if
necessary
a. Select the action that you want to record. To do this, do one of the following:

o In the canvas of an open test, click the action.

o Bring an open action document into focus.

b. Click theRecord button or select Record > Record.

c. If the "Record and Run Settings Dialog Box" (described on page 865) opens, set the
required settings. The settings in this dialog box can determine whether to open an
application for you at the beginning of record and run settings. It can also control on which
applications UFT records. For example, for performance reasons, the default setting in the
Windows Applications tab is to record and run only on the applications you specify (and not
on any open application). If you do not specify an application or change this option, UFT
will not record or run on any Windows-based application.

If the dialog box does not open automatically (for example, you are recording additional
steps in an existing test or youmanually opened and set options in this dialog box before
beginning the record session), but you want to view ormodify the settings, you can open it
using theRecord > Record And Run Settings dialog box menu command.

UFT is minimized, and a standalone "Record Toolbar" (described on page 866) is
displayed.

4. Record steps into the test

Navigate through your application. UFT records each step you perform and adds it to your test.

5. Use the Record toolbar to manage your recording session
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n To add your steps to existing actions: From the <Action Name> drop-down list, select
the action name in which to include the performed steps.

n To insert a call to a new action or call to an existing action: In the Record toolbar, click

the Insert Call to New Action button and choose the type of action call you want.
In the subsequent dialog box, name the action and define its properties.

n To insert a checkpoint/output value:Click the Insert Checkpoint and Output Value

button and choose the type of checkpoint or output value to insert. In the subsequent
dialog box, name the checkpoint and define its properties.

6. Switch to other recording modes - optional
For details, see:

n Analog recording: "How to Record Using Analog Recording" on page 858

n Low-level recording: "How to Record Using Low-Level Recording" on page 859

n Insight recording: "How to Record a Test or Component Using Insight Recording" on page
860

n StandardWindows recording (relevant when recording on SAP GUI forWindows
applications): The SAP GUI forWindows section of theHP Unified Functional Testing Add-
ins Guide

7. Stop recording and save the test
a. When you complete your recording session, click theStop button on the Record toolbar

or select Record > Stop.

b. To save your test, click theSave button or select File > Save.

How to Record a GUI Component
Relevant for: GUI components only

This task describes how to create a component in UFT by recording the steps that you perform on
your application.

This task includes the following steps:

l "General Prerequisites" on the next page

l "Web-based Applications Prerequisites" on the next page

l "Start a recording session and set the Application settings if necessary" on page 857
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l "Record steps into the component " on the next page

l "Use the Record toolbar to manage your recording session" on the next page

l "Switch to other recordingmodes - optional (scripted components only)" on the next page

l "Stop recording and save the component" on page 858

1. General Prerequisites
n Close unnecessary applications. Before you start to record, close all applications not

required for the recording session.

n Set global record and run options. Choose how you want UFT to record and run your
component by setting global options in the Options dialog box and settings specific to your
component in the Business Component Settings dialog box. For details, see "UFT Global
Options" on page 522 and "Settings for GUI Tests, GUI Business Components, and
Application Areas" on page 580.

Note: The settings that determine the windows-based applications on which the
component can record and run are defined in the application area (click Additional
Settings in the application area's sidebar and select Applications). You can view
these settings, in read-only mode, in the Business Components Settings dialog box
(File > Settings > Applications pane) or in the Applications dialog box that opens
when you begin recording. For details, see:

o "Applications Pane (Business Component Settings Dialog Box / Application Area -
Additional Settings Pane)" on page 597.

o "Associate a different application area with your component" on page 2090.

2. Web-based Applications Prerequisites
Determine Browser activation timing. UFT can record only onWeb browsers that were
opened after UFT. If you plan to record a web event, make sure that the browser you want to
use for recording was opened after you opened UFT.

Set security zone. If you are recording on aWeb site, determine the security zone of the site.
When you record on aWeb browser, the browser may prompt you with security alert dialog
boxes. Youmay choose to disable/enable these dialog boxes.

Modify object values. If you are recording on aWeb object, youmust modify the object's
value to enable UFT to record the step. For example, to record a selection in aWebList object,
youmust click on the list, scroll to an entry that was not originally showing, and select it. If you
want to select the item in the list that is already displayed, youmust first select another item in
the list (click it), then return to the originally displayed item and select it (click it).

User Guide
Chapter 32: Recording GUI Tests and Components

HP Unified Functional Testing (12.00) Page 856 of 2274



Modify the Web event configuration. If you are recording on aWeb object, youmay want to
select a predefined configuration level in theWeb Event Recording Configuration dialog box
(described in theHP Unified Functional Testing Add-ins Guide). By default, UFT uses the
Basic recording level. If UFT does not record all the events you need, youmay require a higher
recording level.

3. Start a recording session and set the Application settings if necessary

a. Click theRecord button or select Record > Record.

b. If this is the first time that you are recording in the current UFT session, the Applications
dialog box opens.

Verify that the application area is defined with the settings you need for your recording
session. If the settings do not meet your requirements, youmay need to associate a
different application area with your component. For details, see "Associate a different
application area with your component" on page 2090.

Note: If the Applications dialog box does not open, you can also verify the settings in
the Applications pane of the Settings dialog box (File > Settings), which has the
same user interface elements. For details, see "Applications Pane (Business
Component Settings Dialog Box / Application Area - Additional Settings Pane)" on
page 597.

UFT is minimized, and a standalone Record toolbar is displayed. For user interface details
on the Record toolbar, see "Record Toolbar" on page 866.

4. Record steps into the component

Navigate through your application. UFT records each step you perform and adds it to your
component.

5. Use the Record toolbar to manage your recording session
To insert a checkpoint/output value:Click the Insert Checkpoint and Output Value

button and choose the type of checkpoint or output value to insert. In the subsequent
dialog box, name the checkpoint and define its properties.

6. Switch to other recording modes - optional (scripted components only)
For details, see:

n Analog recording: "How to Record Using Analog Recording" on the next page

n Low-level recording: "How to Record Using Low-Level Recording" on page 859

n Insight recording: "How to Record a Test or Component Using Insight Recording" on page
860
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n StandardWindows recording (relevant when recording on SAP GUI forWindows
applications): The SAP GUI forWindows section of theHP Unified Functional Testing Add-
ins Guide

7. Stop recording and save the component
a. When you complete your recording session, click theStop button on the Record toolbar

or select Record > Stop.

b. Save your component by clicking theSave button or selecting File > Save.

How to Record Using Analog Recording
Relevant for: GUI tests and scripted GUI components

This task describes how to record a test or scripted component using analog recording, in which
your keyboard input, mousemovements, and clicks are recorded and saved in an external data file.

When UFT runs the test or scripted component, this external data file is called, and every
movement, mouse click, and operation are replicated exactly as you recorded them.

Note: This task is part of a higher-level task. See "How to Record aGUI Test" on page 853 or
"How to Record aGUI Component" on page 855 for details on:

l Prerequisites

l Starting a recording session

l Settings in the Record and Run Settings dialog box or the Applications dialog box

l Using the Record toolbar

To record in Analog Recording mode:

1. Select the action or scripted component that you want to record.

2. Click theRecord button or select Record > Record.

If the "Record and Run Settings Dialog Box" or the Applications dialog box opens, set the
required settings.

3. In the Record toolbar, select Analog Recording from theRecording Mode drop down.
The Analog Recording Settings dialog box opens. For details, see "Analog Recording Settings
Dialog Box " on page 863.

4. Start recording, and perform the operations you want to record in analog recordingmode.
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You can also use the Record toolbar to manage your recording session, and record steps into
different actions or add checkpoints or output value steps, as you would in a normal recording
session.

5. When you are finished and want to return to normal recordingmode, select Default from
theRecording Mode drop down in the Record toolbar to turn off the option.

How to Record Using Low-Level Recording
Relevant for: GUI tests and scripted GUI components

This task describes how to record a test or scripted component using low-level recording, in which
all of your keyboard input andmouse clicks are recorded based onmouse coordinates. When UFT
runs the test or scripted component, the cursor retraces the recorded clicks.

Note: This task is part of a higher-level task. See "How to Record aGUI Test" on page 853 or
"How to Record aGUI Component" on page 855 for details on:

l Prerequisites

l Starting a recording session

l Settings in the Record and Run Settings dialog box or the Applications dialog box

l Using the Record toolbar

To record in low-level recording mode:

1. Select the action or scripted component that you want to record.

2. Click theRecord button or select Record > Record.

If the "Record and Run Settings Dialog Box" or the Applications dialog box opens, set the
required settings.

3. In the Record toolbar, select Low-Level Recording from theRecording Mode drop
down.

4. Navigate through your application. UFT records each low-level operation you perform and adds
it to your test.

You can also use the Record toolbar to manage your recording session, and record steps into
different actions or add checkpoints or output value steps, as you would in a normal recording
session.

5. When you are finished and want to return to normal recordingmode, select Default from
theRecording Mode drop down in the Record toolbar to turn off the option.
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How to Record a Test or Component Using Insight
Recording

Relevant for: GUI tests and scripted GUI components

This task describes how to record a test or scripted component using Insight recording, in which
UFT recognizes controls based on their appearance, and not their native properties.

When UFT runs the test or component, it recognizes the controls in the application by matching
them to the images saved with each of the Insight test objects.

Note: This task is part of a higher-level task. See "How to Record aGUI Test" on page 853 or
"How to Record aGUI Component" on page 855 for details on:

l Prerequisites

l Starting a recording session

l Settings in the Record and Run Settings dialog box or the Applications dialog box

l Using the Record toolbar

1. Record operations using the Insight recording mode
a. Select the action or component that you want to record.

b. Click theRecord button or select Record > Record.

If the "Record and Run Settings Dialog Box" or the Applications dialog box opens, set the
required settings.

c. In the Record toolbar, select Insight Recording from theRecording Modes drop
down or select Record > Insight Recording.

d. Navigate through your application. UFT records each step you perform and adds it to your
test.

You can also use the Record toolbar to manage your recording session, and record steps
into different actions or add checkpoints or output value steps, as you would in a normal
recording session.

Note: Theremay be a delay after you perform the step in the application and before the
step is recorded. You can follow the progress of the recording by checking the number
of recorded steps, which is displayed in the Record toolbar's title bar.
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e. When you are finished and want to return to normal recordingmode, select Default
from theRecording Mode drop down in the Record toolbar to turn off the option.

2. Fine-tune the recorded test objects - optional
Youmay want to make changes in the recorded test objects, to improve the readability and
efficiency of your test or component.

In the "Change Test Object Image / Add Insight Test Object Dialog Box", described on page
1233, you can:

n Adjust the borders of the image saved with the test object in the object repository.

n Take a new snapshot to replace the image entirely.

n Specify areas to exclude from the test object image. UFT will ignore these areas when it
searches for the image on the screen to identify the object.

n Modify the test object's ClickPoint. This is the location to click in the control when running a
test object method on it.

In the object repository you can do any of the following:

n Rename the test object to a name that describes the control it represents. (Recommended)

n Move the test object within the test object hierarchy: If you place it under another test
object, then UFT searches for the object in the application only within its parent test object.
If youmove the Insight test object to be a top-level object, then UFT searches for the object
anywhere on the screen.

For details, see "How to Copy, Paste, Move, or Delete Objects in the Object Repository" on
page 1217.

n Add a similarity identification property to the test object description. For details about this
property, see the InsightObject Identification Properties section in theHP UFT Object
Model Reference for GUI Testing.

n Modify the ordinal identifier created for the test object. For details, see "Ordinal Identifiers"
on page 1312.

n Define visual relation identifiers for the test object. For details, see "Visual Relation
Identifiers" on page 1209.

Tips:

o Whenworking in the Editor, you can open the object repository by double-clicking an
InsightObject's image. The object repository opens with the InsightObject selected.
(If test object images are not displayed in the Editor, you can display them using the
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relevant option in the Tools > Options > GUI Testing tab > Insight pane.)

o Whenworking in the object repository, you can use theHighlight in Application
option to see which controls UFT identifies using the current test object's
description.

3. Fine-tune the recorded steps - optional
In the test or component, youmight want to remove unnecessary steps that were recorded or
make other adjustments. For example:

n During Insight recording, when you type in the application, UFT records the Typemethod on
a StandardWindows test object, and not on the Insight test object.

After recording, you can delete this step, and replace it with a Type step performed on the
relevant Insight test object.

n During recording, if you click in a control to bring it into focus before typing, UFT records a
Click step on the relevant Insight test object.

Similarly, if you press TAB to bring the control into focus before typing, a Type micTab step
is recorded on the relevant WinObject.

However, the InsightObject's Typemethod clicks in the control by default before beginning
the type operation, rendering the precedingClick or Type step redundant.

Therefore, after recording, you can delete the redundant Click or Type step.

4. Delete all snapshots from the object repository - optional
When you have finishedmodifying all of the Insight test objects to your satisfaction in the
object repository, you can delete all of the snapshots to reduce the amount of disk space used
(in the Object Repository window or the Object Repository Manager, Tools > Delete Insight
Snapshots).

This does not delete the test object images used for object identification.
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Reference

Analog Recording Settings Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to select whether UFT records mousemovements or keyboard input
relative to the coordinates of your screen, or relative to the coordinates of the specified window.

To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Click theRecord button to begin a recording session, and do one of the
following:

n Select Analog Recording from theRecording Mode drop down in
the Record toolbar.

n Select Record > Analog Recording.
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Important
information

l You can switch to analog recordingmode only while recording. The option is
not available while editing.

l When you record in analog recordingmode relative to the screen, the run
session will fail if you change the screen resolution or the screen location after
recording.

l The analog tracking continues to record themovement of themouse until you
drag themouse to the UFT window (for example, when you want to turn off
analog recording or to stop recording). Clicking on the UFT icon in the
Windows taskbar is also recorded. This should not affect your run session.
Themousemovements and clicks on the UFT screen itself are not recorded.

l If you have selected to record in analog recordingmode relative to a window,
any operation performed outside the specified window is not recorded while in
analog recordingmode.

Relevant
tasks

"How to Record Using Analog Recording" on page 858

See also "How to Record Using Low-Level Recording" on page 859

User interface elements are described below:

UI
Elements Description

Pointing Hand. Click this button to select the specific area or window of the
application to record. For details on using the pointing hand, see "Tips for Using the
Pointing Hand" on page 1196.

Window
title

Displays the name of the window to record on in analog recordingmode.

Record
relative
to the
screen

UFT records any mousemovement or keyboard input relative to the coordinates of
your screen, and disregards any open applications and any applications specified in
the Record and Run Settings dialog box.

Select this option if you perform your analog operations on objects located within
more than one window, or if the window itself may move while you are recording your
analog operations.

Record
relative
to the
following
window

UFT records any mousemovement or keyboard input relative to the coordinates of
the specified window.

Select this option if all your operations are performed on objects within the same
window and that window does not move during analog recording. This helps ensure
that the test or scripted component will run the analog steps in the correct position
within the window even if the window's screen location changes after recording.
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Record and Run Settings Dialog Box
Relevant for: GUI tests only

This dialog box enables you to set your record and run settings before you begin a record or run
session.

To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Record > Record And Run Settings.

Note: This dialog box opens automatically only before recording a new test,
and does not open the next time you record in that test.
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Important
information

l You can open this dialog box at any time, for example:

n If you have already recorded one or more steps in the test, you canmodify
the settings before you continue recording.

n If you want to run the test on a different application than the one you
previously used, you can select a different application to test.

l The tabs available in the Record and Run Settings dialog box depend on the
loaded add-ins.

l For details on the tab to use and the options available for the environment you
are testing, see the Record and Run Settings for Add-ins Overview in the
HP Unified Functional Testing Add-ins Guide.

l When you run a test, or if you begin a new recording session on an existing
test, UFT automatically uses the existing record and run settings for the test
and does not open the Record and Run Settings dialog box. However, it is
important to confirm that the options in the Record and Run Settings dialog box
are appropriate for the first step of your test before running it because you (or
someone else) may havemodified the Record and Run Settings dialog box
manually in a prior recording session.

Relevant
tasks

"How to Record aGUI Test" on page 853

See also "RecordingModes" on page 845

Record Toolbar
Relevant for: GUI tests and components

This toolbar enables you to perform, manage, and organize your recording session.

To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Record > Record. This toolbar opens automatically at the beginning
of a recording session.
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Important
information

l This toolbar provides the controls for the recording session. From the toolbar,
you can choose a type of recording (default, analog, low-level, Insight, or
Standard Windows Recording (SAP add-in only)) if necessary, add
checkpoints to the test or component, add actions to the test, and open the
Object Spy dialog box or the Object Repository window.

l By default, the toolbar is floating. You can place the toolbar anywhere on the
screen or pin it to the top of the screen.

l You canminimize the toolbar buttons while recording.

Relevant
tasks

l "How to Record aGUI Test" on page 853

l "How to Record Using Analog Recording" on page 858

l "How to Record Using Low-Level Recording" on page 859

l "How to Record a Test or Component Using Insight Recording" on page 860

See also l "Guidelines for Recording Tests and Components" on page 844

l "Analog Recording" on page 846

l "Low-Level Recording" on page 847

l "Insight Recording" on page 849

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Element Description

<title bar> The name of the test or component into which the recorded steps are inserted and
the number of steps recorded.

Stop. Stops the current recording session.

(tests
only)

<Action List>. The list of actions in the current test. You can select an action from
the drop-down list to assign the recorded steps to different actions.
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UI
Element Description

(tests
only)

Call to New Action. Inserts a call to an action during the recording session. The
following options are available:

l Call to New Action

l Call to Copy of Action

l Call to Existing Action

l Call to Existing API Test/Action

For details on the different types of actions, see "Calls to Existing Actions and
Copies of Actions" on page 875.

Note: The dialog box that opens after your choice differ depends on which type
of action you insert.

Recording
Mode

A drop down list enabling you to switch recordingmodes. When the drop down is
collapsed, it displays the current recordingmode.

Recordingmode choices include:

l Default. The normal recordingmode for UFT recording sessions. If no other
recordingmode is selected, then recording is done in default mode.

l Analog Recording. Activates Analog Recordingmode. Each time you
select this mode, the "Analog Recording Settings Dialog Box " (described on
page 863) opens. For details on analog recording, see "Analog Recording" on
page 846.

l Low-Level Recording. Activates Low-Level Recordingmode. For details
on low-level recording, see "Low-Level Recording" on page 847.

l Insight Recording. Activates Insight Recordingmode. For details on
Insight recording, see "Insight Recording" on page 849.

l Standard Windows Recording. Activates StandardWindows Recording
mode. For details, see the section on StandardWindows recording in the SAP
GUI forWindows User Guide.

Object Spy. Opens theObject Spy dialog box. For details, see "Object Spy Dialog
Box " on page 1189.

Object Repository. Opens theObject Repository window. For details, see "Object
Repository Document Window" on page 1299.
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UI
Element Description

Insert Checkpoint or Output Value.Inserts a checkpoint or output value to your
action or component while recording. For details on checkpoints and output values,
see "Checkpoint Types" on page 1397 and "Output Values Overview" on page
1488.

For details on how to use checkpoints and output values while recording, see "How
to Insert a Checkpoint in a GUI Test or Component" on page 1419 or "How to
Create or Modify anOutput Value Step" on page 1494.

Synchronization Point. Opens the "Add Synchronization Point Dialog Box"
(described on page 982), which enables you to add a wait period to your test for a
given step.
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Troubleshooting and Limitations - Recording
Relevant for: GUI tests and components

This section describes troubleshooting and limitations for recording tests and components.

l For troubleshooting and limitations for learning objects, and recording and running steps, see
"Learning objects, running steps, and recording steps (GUI testing only)" on page 661.

l Visual relation identifier. UFT does not record the visual relation identifier property when
recording steps. This property can be added only manually from theObject Properties dialog box
or the Object Repository Manager or window. For details, see "Visual Relation Identifiers" on
page 1209.

l Start menu. OnWindows Vista, Windows 7, Windows Server 2008, Windows Server 2008 R2,
Windows 8, orWindows 2012, if you begin a recording session after installing UFT without
restarting your computer, UFT cannot record operations on theWindows Startmenu orQuick
Launch Panel.

Workaround:Restart your computer and start a new recording session.

l Start menu. UFT does not record launchingWindows Help from theStartmenu.

l Start menu. UFT does not record the selection of Startmenu items that are customized as
menus, such as My Computer, Control Panel, or Recent Documents.

Workaround: Customize theStartmenu items as links so that UFT can record operations on
them or record the activation of these items another way (and not through theStartmenu).

l Dragging the Record toolbar to the top of the screen inWindows 7/Windows 8 is not allowed by
default.

Workaround: InControl Panel > Ease of Access > Ease of Access Center > Make the
mouse easier to use settings, disable thePrevent windows from being automatically
arranged when moved to the edge of the screen option.
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Chapter 33: Actions in GUI Testing
Relevant for: GUI tests only

This chapter includes:

Concepts 872

Actions in GUI Testing - Overview 872

Action Types 873

Action and Test Iterations Using the Data Pane 874
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Tasks 886

How to Display andModify Action-Related Information 886

How toManage the Structure of Your GUI Test 888
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Concepts

Actions in GUI Testing - Overview
Relevant for: GUI tests only

Actions help divide your test into logical units, such as themain sections of aWeb site, or specific
activities that you perform in your application.

A test is comprised of calls to actions. When you create a new test, it contains a call to a single
action. By creating tests that call multiple actions, you can design tests that aremoremodular and
efficient.

An action consists of its own test script, including all of the steps in that action, and any objects in
its local object repository and any associated shared object repositories.

Each action is stored together with the test in which you created it. You can insert a call to an action
that is stored with the test and, depending on the properties of the action, youmay also be able to
call an action stored with another test.

When you open a test, you can choose to view the test flow (calls to actions) in the canvas, or you
can view and edit the individual actions stored with your test, in the Keyword or Editor.

If you plan tests that will includemany steps or lines of script, it is recommended that you usemany
actions to divide your test steps. Actions should ideally contain nomore than a few dozen test
steps.

How to Use Actions
Actions enable you to parameterize and iterate over specific elements of a test. They can also
make it easier to modify steps in one action when part of your application changes.

For every action called in your test, UFT creates a corresponding action sheet in the Data pane so
that you can enter data table parameters that are specific to that action only. For more information
on global and action data sheets, see "Action and Test Iterations Using the Data Pane" on page
874. For information on parameterizing tests, see "Parameterizing Object Values" on page 1526,
and "Output Values Overview" on page 1488.

You can also pass information between actions in several ways. You can also specify input
parameters for actions, so that steps in an action can use values supplied from other actions in the
test. You can also output values from actions to be used in steps in later actions, or to be passed
back to the application that ran the test. For more information, see "Action Parameters" on page
877.

Example

Suppose you want to test several features of a flight reservation system. You plan several
tests to test various business processes, but each one requires the same login and logout
steps. You can create one action that contains the steps required for the login process, another
for the logout steps, and other actions for themain steps in your test. After you create the login
and logout actions, you can insert those actions into other tests.
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If you create a test in which you log into the system, book one flight, and then log out of the
system, your test might be structured as shown—one test calling three separate actions:

Action Types
Relevant for: GUI tests only

Each new test automatically includes one blank action. You can add all the steps andmake any
modifications to your test within this single action.

You can also divide your test into multiple actions by inserting calls to new actions or existing
actions. The actions used in the test, and the order in which they are run, are displayed in the
canvas. For details, see "The Canvas" on page 209.

When you run a test with multiple actions, the run results are divided by action within each test
iteration. This enables you to view the outcome of each action and the detailed results for each
action separately. For more information on the Run Results Viewer, see theHP RunResults
Viewer User Guide.

UFT provides the following types of actions:

Reusable action
An action that can be calledmultiple times by the local test (the test with which it is stored), as well
as by other tests. New actions are reusable by default, and you canmark each action as reusable
or non-reusable.

Only reusable actions can be calledmultiple times from the current test or from another test.
Inserting calls to reusable actions makes it easier to maintain your tests, because when an object
or procedure in your application changes, the action needs to be updated only once. Youmust
update reusable actions from the original test.

Non-reusable action
An action that can be called only in the local test, and can be called only once. You can store a copy
of a non-reusable action with your test and then insert a call to the copy, but you cannot directly
insert a call to a non-reusable action saved with another test.
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External action
A reusable action stored with another test. External actions are read-only in the calling test, but you
can choose to use a local, editable copy of the Data pane information for the external action. For
more information, see "Insert Call to New Action Dialog Box (GUI Testing)" on page 913.

Nested action
An action can call another action. This is known as nesting an action, and is described in "How to
Nest Actions - Use-Case Scenario" on page 892. Complex tests may havemany actions, as well
as nested actions, andmay share actions with other tests.

Action and Test Iterations Using the Data Pane
Relevant for: GUI tests only

When you use the Data pane to output a value or to add a parameter to your test or action, you can
specify whether to store the data in theGlobal data sheet or in the action data sheet.

l Global sheet. Enables you to define parameters for any action. When you run your test, UFT
inserts or outputs a value from or to the current row of the Global data sheet during each global
test iteration. This enables you to pass information between actions. For details, see "Global
Sheet" on page 226.

l Action sheet. Enables you to insert data that applies only to that action. Note that the name of
the action sheet is the same as the name of the relevant action. When you run your test, UFT
inserts or outputs a value from or to the current row of the current action (local) data sheet during
each action iteration. For details, see "Action Sheets" on page 226.

If you create data table parameters or output value steps in your action and select to use the
Current action sheet (local) option, be sure that the run settings for your action are set correctly in
the Run tab of the "Action Call Properties Dialog Box" on page 895.

When you delete an action, the corresponding action sheet is removed from the Data pane, but
columns related to this action that are located in the Global sheet are not removed.

For more information, see:

l "Data Pane" on page 221

l "Parameterizing Object Values" on page 1526

l "Output Values Overview" on page 1488

Example

Suppose you want to test how a flight reservation system handles multiple bookings. Youmay
want to parameterize the test to check how your site responds tomultiple sets of customer
flight itineraries. When you plan your test, you plan the following procedures:
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1. The travel agent logs into the flight reservation system.

2. The travel agent books five sets of customer flight itineraries.

3. The travel agent logs out of the flight reservation site.

When you consider these procedures, you realize that it is necessary to parameterize only the
second step—the travel agent logs into the flight reservation system only once, at the
beginning, and logs out of the system only once, at the end. Therefore, it is not necessary to
parameterize the login and logout procedures in your test.

By creating three separate actions within your test—one for logging in, another for booking a
flight, and a third for logging out—you can parameterize the second action in your test without
parameterizing the others, and without requiring separate actions for each itinerary.

A single test may include both global data table parameters and action (local) data table
parameters.

Example

You can create a test in which a travel agent logs into the flight reservation system, books
three flights, and logs out; the next travel agent logs into the flight reservation system, books
three flights, logs out, and so forth.

To parameterize the book a flight action, you select Current action sheet (local) in the
"Parameter Options Dialog Box" (described on page 1556) and enter the three flights into the
relevant Action tab in the Data pane. To parameterize the entire test, you select Global in the
"Parameter Options Dialog Box" (described on page 1556) and enter the login names and
passwords for the different agents into theGlobal tab in the Data pane.

Your entire test runs one time for each row in the Global data sheet. Within each test, each
parameterized action is repeated according to the number of rows in its data sheet and the run
settings selected in the "Run Tab (Action Call Properties Dialog Box)" (described on page 895).

Note: If your test is stored in ALM, make sure to save your data table parameters in the Global
sheet and not in a specific action sheet. For details, see "ALM Integration" on page 707.

Calls to Existing Actions and Copies of Actions
Relevant for: GUI tests only

When you plan a suite of tests or a solution, youmay realize that each test requires some identical
activities, such as logging in. Rather than inserting the login action three times in three separate
tests, and enhancing these actions separately for each test (with checkpoints, parameterization,
and programming statements), you can create a single action that logs into the system, and store
that action with one test. After you are satisfied with the action you created, you can insert calls to
the existing action into other tests.
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You can insert calls to existing actions by inserting a call to the original action, which remains read-
only in your test, or by inserting a call to a copy of the action, which allows you to customize the
action for your test.

You can also call actions dynamically during a run session using the LoadAndRunAction
statement. For details, see theUtility Objects section of theHP UFT Object Model Reference for
GUI Testing.

Calls to Copies of Actions
When you insert a call to a copy of an action into a test, the original action is copied in its entirety,
including checkpoints, parameterization, the corresponding action tab in the Data pane, plus any
defined action parameters. If the test you are copying has objects in the local or any associated
shared object repository, the copied action's local object repository and associated shared object
repository is also copied together with the action.

The action is inserted into the test as an independent action. If the original action was reusable, the
new, copied action is also reusable. After the action is copied into your test, you can add to, delete
from, or modify the action just as you would with any other non-reusable action. Any changes you
make to this action after you insert it affect only this action, and changes youmake to the original
action do not affect the copied action.

Calls to Existing Actions
You can insert a call to a reusable action that is stored in your current test (local action), or in any
other test (external action). Inserting a call to an existing action is similar to linking to it. You can
view the steps of the action in the action view, but you cannot modify them. The called action's
local object repository (if it has one) is also read-only.

If the called external action has data in the Data pane, however, you can choose whether you want
the data from the action's data sheet to be imported as a local, editable copy, or whether you want
to use the (read-only) data from the original action. (Columns and data from the called action's
global data sheet is always imported into the calling test as a local, editable copy.) For more
information, see "External Action Tab (Action Properties Dialog Box)" on page 911.

Tomodify a called, external action, youmust open the test with which the action is stored and
make your modifications there. Themodifications apply to all tests that call that action. If you chose
to use the original action's data when you call an external action, then changes to the original
action's data are applied as well.

Example

Suppose you want to create the following three tests for theMercury Tours site—booking a
flight, modifying a reservation, and deleting a reservation. While planning your tests, you
realize that for each test, you need to log in and log out of the site, giving a total of five actions
for all three tests.
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Youwould initially create three tests with five actions. Test 1 would contain two reusable
actions (Logging In and Logging Out). These actions can later be called by Test 2 and Test 3.

You would then finish creating Test 2 and Test 3 by inserting calls to the reusable actions you
created in Test 1.

Action Parameters
Relevant for: GUI tests only

You can specify input parameters for an action, so that steps in the action can use values supplied
from elsewhere in the test. Input values for an action parameter can be retrieved from any of the
following:

l the test (for a top-level action)

l the parameters of the parent action that calls it (for a nested action)

l the output of a previous action call (for a sibling action)

You can specify output parameters for an action, so that it can return values for use later in the
test. For example, you can output a parameter value to a parent action so that a later nested action
can use the output value.
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For information on defining action parameters and the values used in action calls, see "Parameters
Tab (Action Properties Dialog Box)" on page 903, and "Parameter Values Tab (Action Call
Properties Dialog Box)" on page 897.

When to Use Action Parameters
Action parameters enable you to transfer input values from your test to a top-level action, from a
parent action to a nested action, or from an action to a sibling action that occurs later in the test.
Action parameters also enable you to transfer output values from a step in an action to its parent
action, or from a top-level action back to the script or application that ran (called) your test. For
example, you can output a value from a step in a nested action and store it in an output action
parameter, and then use that value as input in a later step in the calling parent action.

Storing Action Parameters
An action's parameters are stored with the action and are the same for all calls to that action. If you
modify an action parameter's name, type, or description, and then view the action properties for a
call to that same action in a different part of the test, you will see that the action parameter has
changed.

The actual value specified for an input action parameter and the location specified for action output
parameter can be different for each call to the action. When you insert a call to a copy of an action,
the copy of the action is inserted with the action parameters and action call parameter values that
were defined for the action you copied.

Sharing Action Information
Relevant for: GUI tests only

There are several ways to share or pass values from one action to other actions:

l "Output Options Dialog Box " on page 1519. Store values in the output action parameters, and
use them in steps performed later in the test, whether in the calling action or sibling actions (for
nested actions), or subsequent actions in the test.

l "Sharing Values Using the Global Data Table" below. Store values from one action in the global
data table and use these values as data table parameters in other actions.

l "Sharing Values Using Environment Variables" on the next page. Set a value from one action as
a user-defined environment variable and then use the environment variable in other actions.

l "Sharing Values Using the Dictionary Object" on the next page. Add values to a Dictionary
object in one action and retrieve the values in other actions.

Sharing Values Using the Global Data Table

Relevant for: GUI tests only

You can share a value that is generated in one action with other actions in your test, by storing the
value in the global data table. Other actions can then use the value in the Data pane as an input
parameter. You can store a value in the Data pane by outputting the value to the global data table, or
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by usingData Table, Sheet andParameter objects andmethods in the Editor to add or modify a
value.

For more information, see:

l "Output Values Overview" on page 1488

l "Parameterizing Object Values" on page 1526

l "Data Pane" on page 221

l TheHP UFT Object Model Reference for GUI Testing

Example

Suppose you are testing a flight reservation application. When a user logs into the application,
the user's full name is displayed on the top of the page. Later, when the user purchases the
tickets, the user must enter the name that is listed on his or her credit card.

Suppose your test contains three actions—Login, SelectFlight, andPurchaseTickets and the
test is set to runmultiple iterations with a different login name for each iteration. In the Login
action, you can create a text output value to store the displayed name of the user. In the
PurchaseTickets action, you can parameterize the value that is set in the Credit Card Owner
edit box using the Data pane column containing the user's full name.

Sharing Values Using Environment Variables

Relevant for: GUI tests only

If you do not need to runmultiple iterations of your test, or if you want the value you are sharing to
stay constant for all iterations, you can use an internal, user-defined environment variable, which
can be accessed by all local actions in your test.

For example, suppose you want to test that your flight reservation application correctly checks the
credit card expiration date that the user enters. The application should request a different credit card
if the expiration date that was entered is earlier than the scheduled flight departure date. In the
SelectFlight action, you can store the value entered in the departure date edit box in an environment
variable. In thePurchaseTickets action, you can compare the value of the expiration date edit box
with the value stored in your environment variable.

For more information on environment variables, see "Parameterizing Object Values" on page 1526.
For information on theEnvironment object, see theHP UFT Object Model Reference for GUI
Testing.

Sharing Values Using the Dictionary Object

Relevant for: GUI tests only

As an alternative to using environment variables to share values between actions, you can use the
Dictionary object. The Dictionary object enables you to assign values to variables that are
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accessible from all actions called from the test in which the Dictionary object is created, including
both local and external actions.

To use the Dictionary object, youmust first add a reserved object to the registry (inHKEY_
CURRENT_USER\Software\Mercury Interactive\QuickTest
Professional\MicTest\ReservedObjects\) withProgID = "Scripting.Dictionary".

HKEY_CURRENT_USER\Software\Mercury Interactive\QuickTest Professional\MicTest\Reserv
edObjects\GlobalDictionary

After you add the reserved Dictionary object to the registry and restart UFT, you can add and
remove values to and from the Dictionary in one action, and retrieve the values in another action
called from the same test.

For more information on the Dictionary object, see the VBScript Reference documentation (Help >
HP Unified Functional Testing Help > VBScript Reference > Script Runtime).

Example

Suppose you want to access the departure date set in theSelectFlight action from the
PurchaseTickets action. You can add the value of the DepartDateWebEdit object to the
dictionary in theSelectFlight action as follows:

GlobalDictionary.RemoveAll

Then you can retrieve the date from thePurchaseTickets action as follows:

Dim CompareDate
CompareDate=GlobalDictionary("DateCheck")

Action Syntax in the Editor
Relevant for: GUI tests only

An action call in the Editor can define the action iterations, input parameter values, output
parameter storage locations, and an action return values.

This section includes:

l "Calling Actions Using Basic Syntax" on the next page

l "Calling Actions with Parameters" on the next page

l "Storing Action Return Values" on page 882
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Calling Actions Using Basic Syntax

Relevant for: GUI tests only

In the Editor, a call to a nested action with no parameters is displayed within the calling action with
the following basic syntax:

RunAction ActionName, IterationQuantity

Example

To call theSelect Flight action and run it one iteration:

RunAction "Select Flight", oneIteration

To call theSelect Flight action and run it as many iterations as there are rows in the Data
pane:

RunAction "Select Flight", allIterations

To call theSelect Flight action and run it four iterations (for the first four rows of the Data
pane):

RunAction "Select Flight", "1 - 4"

Calling Actions with Parameters

Relevant for: GUI tests only

If the action you are calling has input and/or output parameters, you can also supply the values for
the input parameters and the storage location of the output parameters as arguments of the
RunAction statement. Input parameters are listed before output parameters.

l For an input parameter, you can specify either a fixed value or you can specify the name of
another defined parameter from which the argument should take its value. This can be a data
table parameter, an environment parameter, or an action input parameter of the calling action.

l For an output parameter, you can specify either a variable in which you want to store the value or
the name of a defined parameter (data table parameter, environment parameter, or an action
output parameter of the calling action).

An action call with parameters has the following syntax:

RunAction ActionName, IterationQuantity, Parameters

Example

Suppose you call Action2 from Action1, andAction2 has one input and one output parameter
defined. The following statement supplies a string value ofMyValue for the input parameter and
stores the resulting value of the output parameter in a variable calledMyVariable.
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RunAction "Action2", oneIteration, "MyValue", MyVariable

The following statement uses the value defined for Action1's Axn1_In input action parameter
as the value for the input parameter, and stores the resulting value of the output parameter in
Action1's Data pane sheet in a column calledColumn1_out.

RunAction "Action2", oneIteration, Parameter("Axn1_In"),
DataTable("Column1_out", dtLocalSheet)

In the following example, the first statement calls Action2 using its default input parameter
value. The second statement uses the value defined for Action2's Axn2_out output action
parameter as the value for the call to Action 3's input parameter, and stores the resulting value
of the output parameter in Action1's Axn1_out so that the output value is available at the parent
action level.

RunAction "Action2", oneIteration
RunAction "Action3", oneIteration, Parameter("Action2","Axn2_out"),

Parameter("Axn1_out")

Note that the Action2 output parameter is available for use in the call to Action3, even though
no storage location is specified in the call to Action2.

Storing Action Return Values

Relevant for: GUI tests only

If the action called by theRunAction statement includes anExitAction statement, theRunAction
statement can return the value of theExitAction's RetVal argument. Note that this return value is a
return value of the action call itself, and is independent of any values returned by specific output
parameters of the action call.

To store the return value of an action call, use the syntax:

MyRetVal=RunAction (ActionName, IterationQuantity, Parameters)

Formore information on the Editor, see "Programming in GUI Testing Documents in the Editor" on
page 994. For more information on theRunAction statement, see theHP UFT Object Model
Reference for GUI Testing.

Considerations for Working with Actions
Relevant for: GUI tests only

Inserting Actions

l If you plan to use an identical or virtually identical procedure in more than one test, you should
consider inserting a call to an action from another test.
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l If you want to make slight modifications to the action in only one test, you should use the Insert
Call to Copy of Action option to create a copy of the action.

l If you want modifications to affect all tests containing the action, you should use the Insert Call
to Existing Action option to insert a link to the action from the original test, andmake any
modifications in the original test.

l If you want modifications to the action to affect all tests containing the action, but you want to
edit data in a specific test's data table, use the Insert Call to Existing Action option and, in the
External Action tab of the Action Properties dialog box, select Use a local, editable copy.

Storing Actions

l If you expect other users to open your tests and all actions in your tests are stored in the same
drive, you should use relative paths for your reusable actions so that other users will be able to
open your tests even if they havemapped their network drives differently.

l If you are working with the Resources and Dependencies model with Quality Center 10.00 or
ALM, specify an absolute Quality Center or ALM path. For more information, see "Relative
Paths and ALM" on page 758.

Organizing Actions in Your Test

l If your action runs more than one iteration, the actionmust end at the same point in your
application as it started, so that it can run another iteration without interruption. For example,
suppose you are testing a sample flight reservation site. If the action starts with a blank flight
reservation form, it should conclude with a blank flight reservation form.

l If you expect certain elements of your application to change regularly, it is a good idea to divide
the steps related to changeable elements into a separate action so that it will be easy to change
the required steps, if necessary, after the application is modified.

Naming Actions

l Youmay want to rename the actions in your test with descriptive names to help you identify
them. It is also a good idea to add detailed action descriptions. This facilitates inserting actions
from one test to another. You can rename an action by right-clicking an action in the canvas or
the Solution Explorer and selectingAction Properties. Make sure you follow the naming
conventions for actions, as described in "Troubleshooting - Naming Conventions" on page 2269.

l If a test contains a call to an action stored in another test, and that other test was renamed in
ALM, the original test name still appears (in square brackets) in the canvas. The obsolete name
in the canvas does not affect UFT's ability to locate and run the action. If it is important to
display the correct test name, delete the action call from the test and reinsert it.

l When you rename an action, consider how it will affect your test and any tests that call this
action. For example, if you rename an action that is used by another test, the duplicationmay
cause future run sessions may fail because the test cannot locate the specified action.
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l If you are working with the Resources and Dependencies model, and the test containing the
action you are renaming is stored the Test Planmodule in ALM, the internal (default) action
name is always displayed in the "Used By Tab (Action Properties Dialog Box)" (described on
page 909). This is true even if you rename the action.

Associating Object Repositories

l You can associate as many object repositories as needed with an action, and the same object
repository can be associated with different actions as needed. You can also set the default
object repositories to be associated with all new actions in a test.

l The order of the object repositories in the list determines the order in which UFT searches for a
test object description. If there are test objects in different object repositories with the same
name, object class, and parent hierarchy, UFT uses the first one it finds based on the priority
order defined in the "Associated Repositories Tab (Action Properties Dialog Box)" (described on
page 906). The local object repository is always listed first and cannot bemoved down the
priority list or deleted.

l You can enter an associated object repository as a relative path. During the run session, UFT
searches for the file in the folders listed in the Folders pane of the Options dialog box (Tools >
Options > GUI Testing tab > Folders node), in the order in which the folders are listed. For
more information, see "Folders Pane (Options Dialog Box > GUI Testing Tab)" on page 544.

l You can associate an object repository dynamically during a run session using the
RepositoriesCollection statement. For details, see theUtility Objects section of theHP UFT
Object Model Reference for GUI Testing.

Action Parameters
For details on using action parameters, see "Considerations for Setting Action Parameters" on page
1530.

Considerations for Removing Action Calls

Relevant for: GUI tests only

l If a test contains a call to an action that you removed, does not exist, or cannot be found, the
called action will still appear in the test or calling action, and UFT lists the action in the Errors

User Guide
Chapter 33: Actions in GUI Testing

HP Unified Functional Testing (12.00) Page 884 of 2274



pane. For more information, see "Errors Pane" on page 364.

l You can remove calls to actions from the following locations:

Location Description

Solution
Explorer

Remove all calls to a specific action.

Note:

If you remove a reusable or non-reusable local action, UFT removes all calls
to the action in this test and deletes the action in its entirety.

If you remove an external action, UFT removes all calls to the action from the
test, but does not affect the source action in any way.

Canvas /
Keyword
View

Remove specific calls to an action.

Note:

If a test contains multiple calls to a single reusable action, and you remove
some—but not all—of the calls, UFT removes the calls to the action in the
specified locations, but does not delete the action itself. This means that the
action can continue to be called by this test and by other tests, as needed.

If you remove all calls to an action, the result is the same as removing the
action from the Solution Explorer. For reusable and non-reusable actions,
UFT removes all calls to the action in this test and deletes the action in its
entirety. For external actions, UFT removes all calls to the action from the
test, but does not affect the source action in any way.
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Tasks

How to Display and Modify Action-Related Information
Relevant for: GUI tests only

This task includes the following:

l "Display an action in the Keyword View or Editor" below

l "Create an action template" below

l "Display and/or modify action properties" below

l "Display the action call properties" on the next page

l "Display the API test call properties" on page 888

l "Exit an action using programming statements" on page 888

Display an action in the Keyword View or Editor
From the Solution Explorer or the canvas, double-click an action to show only that action in the
Keyword View or Editor.

l TheKeyword View displays the steps of your test in amodular, table format. For details, see
"Keyword View" on page 919.

l TheEditor displays the script for the selected action. For details, see "UFT File Operations" on
page 127 and "Programming in GUI Testing Documents in the Editor" on page 994.

You can view and edit the individual steps of an action stored in this test, and view the steps for
each selected external action.

Create an action template

1. Create a text file containing the comments, function calls, and other statements that you want
to include in your action template. The text file must be in the structure and format used in the
Editor.

2. Save the text file as ActionTemplate.mst in your <UFT Installation Folder>\dat folder. All new
actions you create contain the script lines from the action template.

Note: Only the file nameActionTemplate.mst is recognized as an action template.

Display and/or modify action properties

1. Do one of the following:
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n Make sure that the action is in focus and select View > Properties to display the Properties
Pane. For details, see "General Properties Tab (Properties Pane - GUI Testing)" on page
390.

n Right-click an action and select Action Properties to open the "Action Properties Dialog
Box" (described on page 900). The name of the action and its path are displayed.

2. Use the "Action Properties Dialog Box" (described on page 900) or the "Properties Pane"
(described on page 385) to modify action properties. The following tabs are included:

Action Properties
dialog box

n "General Tab (Action Properties Dialog Box)" on page 900

n "Parameters Tab (Action Properties Dialog Box)" on page
903

n "Associated Repositories Tab (Action Properties Dialog
Box)" on page 906

n "Used By Tab (Action Properties Dialog Box)" on page 909

n "External Action Tab (Action Properties Dialog Box)" on
page 911

Action Properties pane n "General Properties Tab (Properties Pane - GUI Testing)" on
page 390

n "Parameters Tab (Properties Pane - GUI Testing)" on page
394

n "Used By Tab (Properties Pane - GUI Testing)" on page 401

Display the action call properties
Do one of the following:

l In the canvas, right-click an action and select Action Call Properties to open the "Action
Properties Dialog Box" (described on page 900).

l From theParameter presentation drop-down list, select one of themenu items to display the
selected input or output properties adjacent to the action. Select None to collapse the
properties, and show only the number of input or output properties per action. For details, see
"The Canvas" on page 209.

Note: To view the run values of the action call parameters, see the "Action Call Properties
Dialog Box".
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Display the API test call properties
Right-click a call to an API test within an action, and select Edit Call to API Test to open the "Call
to API Test/Action Dialog Box" (described on page 1075).

Exit an action using programming statements
Use one of the following exit action statements:

l ExitAction. Exits the current action, regardless of its iteration attributes.

l ExitActionIteration. Exits the current iteration of the action.

l ExitRun. Exits the test, regardless of its iteration attributes.

l ExitGlobalIteration. Exits the current global iteration.

You can view the exit action node in the Run Results tree. If your exit action statement returns a
value, the value is displayed in the action, iteration, or test summary, as applicable.

For more information on these functions, see theHP UFT Object Model Reference for GUI Testing.
For more information on the Run Results, see theHP RunResults Viewer User Guide.

How to Manage the Structure of Your GUI Test
Relevant for: GUI tests only

This task includes the following:

l "Insert a call to new action" below

l "Insert a call to existing action or copy of action" on the next page

l "Nest an action within an existing action" on the next page

l "Change the run order of actions" on page 890

l "Remove a call to an action or delete an action" on page 890

l "Delete a call to an API test" on page 891

l "Work with the object repository" on page 891

l "Run or debug a specific action" on page 891

Insert a call to new action

1. Do one of the following:

n Select Design > Call to New Action.

n In the Solution Explorer, right-click a test and select Call to New Action.
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n In the canvas, right-click anywhere and select Call to New Action.

n In the Record toolbar, click the Insert Action Call down arrow and select Call to New
Action during a recording session.

2. Define the action name and location in the "Action Properties Dialog Box" on page 900.

Insert a call to existing action or copy of action

1. Do one of the following:

n Select Design > Call to Copy of Action orDesign > Call to Existing Action.

n In the Solution Explorer, right-click a test and select Call to Copy of Action or Call to
Existing Action.

n In the canvas, right-click anywhere and select Call to Copy of Action or Call to Existing
Action.

n In the Record toolbar, click the Insert Action Call down arrow and select Call to Copy of
Action or Call to Existing Action during a recording session.

For details, see "Calls to Copies of Actions" on page 876 or "Calls to Existing Actions" on
page 876.

2. If you are prompted to save your test before continuing, click Yes in the dialog box to save your
test.

3. Define the action settings in the "Select Action Dialog Box " on page 915.

Nest an action within an existing action

1. In the Keyword View, highlight the step after which you would like to insert the call to the
action.

2. Follow the instructions for inserting a call to a new action as described in "Insert Call to New
Action Dialog Box (GUI Testing)" on page 913, or for inserting a call to a copy of an action or a
call to an existing action as described in "Insert Call to New Action Dialog Box (GUI Testing)"
on page 913.

For a user-case scenario, see "How to Nest Actions - Use-Case Scenario" on page 892.

User Guide
Chapter 33: Actions in GUI Testing

HP Unified Functional Testing (12.00) Page 889 of 2274



Change the run order of actions
In the canvas, you can perform any of the following steps tomove a top-level action (a direct child
of the test) and change the run order of the test accordingly. The action and any nested actions are
moved.

l Right-click a top-level action and then selectMove Up orMove Down.

l Select a top-level action and press CTRL+UP arrow or CTRL+DOWN arrow.

l Drag a top-level action up or down to the required location.

Note: You can drag only top-level actions. Selecting the container action automatically
includes all of its nested actions. You cannot drag a nested action, and you cannot drag a
container action together with only some of its child actions.

Remove a call to an action or delete an action

1. In the Solution Explorer, the canvas, or the Keyword View, do one of the following:

n Right-click the action you want to remove and select Delete.

n Select the action you want to remove and press theDelete key on your keyboard.

n Select the action you want to remove and select Edit > Delete.

2. Click Yes in the confirmationmessage.

Note: If you are deleting a reusable action that is called by another action, and if your test
is stored in ALM and is using the resources and dependencies model (described on page
755), a list of the actions that call the action that you are deleting is displayed in the
confirmationmessage box.
To copy any or all of the actions from the list to the Windows Clipboard:
1. Select the relevant actions from the list.
2. Right-click and select Copy Selected, or press CTRL+C on your keyboard.
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The following table illustrates what happens when you delete an action:

Action
Type How deleting the action affects the test:

Reusable
action
(action
stored in
the current
test)

n If multiple action calls exist in the current test, UFT removes only the call to
this action. Additional calls to the action in this test remain unchanged. The
corresponding action sheet in the data table remains unchanged.

n If this is only call to this action in the current test, UFT deletes the action in its
entirety, including its corresponding action sheet in the Data pane.

Caution: Be careful when deleting a local reusable action. If the action is
called by other tests, deleting the actionmay cause the other tests to fail.

Non-
reusable
action
(action
stored in
the current
test)

Deletes the action in its entirety, including its corresponding action sheet in the
Data pane.

External
action
(action
stored in a
different
test)

Removes the call to the action from the current test without affecting the action
in the source test. The original action remains stored with the test in which it
was created.

Delete a call to an API test
Right-click a call to an API test and select Delete to remove it from the action.

Work with the object repository
Right-click an action and select Object Repository to open theObject Repository window, which
displays a tree containing all objects in the current test. If there is a shared object repository
associated with the action, the shared object repository opens. If there is no shared object
repository associated with the action, the local object repository opens. For details, see "Shared
Object Repositories" on page 1285.

Run or debug a specific action
For details, see "How to Debug Your Test, Component, Function Library, or User Code File" on
page 683.
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How to Nest Actions - Use-Case Scenario
Relevant for: GUI tests only

Suppose you parameterized a step in which a user selects one of threemembership types as part
of a registration process. When the user selects amembership type, the page that opens depends
on themembership type selected in the previous page. You can create a separate action for each
type of membership, and then use If statements to determine themembership type selected in a
particular iteration of the test, and run the appropriate action for that selection.

For more information on inserting conditional statements, see "Conditional Statements" on page
970.

Browser("Membership Preference").Page("Membership Preference").WebRadioGroup("MemTyp
e").Select DataTable("memtype", dtGlobalSheet)
Mem_Type=Browser("Membership Preference").Page("Membership Preference").WebRadioGro
up("MemType").GetROProperty ("value")
If Mem_Type="paid" Then

RunAction "Paid_Mem", oneIteration
ElseIf Mem_Type = "free" Then

RunAction "Free_Mem", oneIteration
Else

RunAction "Preferred", oneIteration
End If
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How to Use Action Parameters - Use-Case Scenario
Relevant for: GUI tests only

Suppose you want to take a value from the external application that runs (calls) your test and use it
in an action within your test. If your test has anAction4 that is nested withinAction3, andAction3
is further nested withinAction2, you would need to pass the input test parameter from the external
application, throughAction2 andAction3, to the required step inAction4.

You would do this as follows:

1. Define the input test parameter (File > Settings > Parameters node) with the value that you
want to use later in the test.

2. Define an input action parameter for Action2 (right-click an action and select Action
Properties > Parameters tab) with the same value type as the input test parameter.

3. Parameterize the input action parameter value (right-click an action and select Action Call
Properties > Parameter Values tab) using the input test parameter value you specified
above.

4. Define an input action parameter for Action3 (right-click an action and select Action
Properties > Parameters tab) with the same value type as the input test parameter.

5. Parameterize the input action parameter value.

n Right-click an action and select Action Call Properties > Parameter Values tab and
select the input action parameter value you specified for Action2.

n Use theParameter utility object to specify the action parameter as theParameters
argument for theRunAction statement in the Editor. For more information, see "Calling
Actions with Parameters" on page 881.

6. Define an input action parameter for Action4 (right-click an action and select Action
Properties > Parameters tab) with the same value type as the input test parameter.
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7. Parameterize the input action parameter value.

n Right-click an action in the canvas or Keyword View and select Action Call Properties >
Parameter Values tab and select the input action parameter value you specified for
Action3.

n Use theParameter utility object to specify the action parameter as theParameters
argument for theRunAction statement in the Editor. For more information, see "Calling
Actions with Parameters" on page 881.

8. Parameterize the value in the required step in Action4.

n Click the parameterization icon  and specify the parameter in the "Value Configuration
Options Dialog Box" (described on page 1579) using the input action parameter you
specified for Action 4.

n Use theParameter utility object in the Editor to specify the value to use for the step. For
more information, see "Using Action Parameters in Steps in the Editor" on page 1529.

Note: You can alsomodify many of the action properties from the Properties pane. For
details, see "Properties Pane User Interface (GUI Testing)" on page 387.
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Reference

Action Call Properties Dialog Box
Relevant for: GUI tests only

This dialog box controls the way the action behaves in a specific call to the action. It enables you to
specify how many times UFT should run the called action (according to the number of rows in the
Data pane), as well as the initial value for any input action parameters and the location in which you
want to store the values of any output action parameters.

To access 1. Select a GUI test tab or action tab.

2. If you are working with an action, click theKeyword View toggle button or
select View > Keyword View /Editor.

3. Right-click an action in the canvas or an action node in the Keyword View
and select Action Call Properties.

Important
information

l This dialog box enables you to set options that apply only to a specific action
call.

l You can also define action calls and action call parameters in the Editor. For
more information, see "Action Syntax in the Editor" on page 880

Relevant
tasks

"How to Display andModify Action-Related Information" on page 886

The Action Call Properties dialog box contains the following tabs:

Run Tab (Action Call Properties Dialog Box) 895

Parameter Values Tab (Action Call Properties Dialog Box) 897

Run Tab (Action Call Properties Dialog Box)

Relevant for: GUI tests only

This tab enables you to instruct UFT to run only one iteration on the called action, to run iterations
on all rows in the Data pane, or to run iterations only for a certain row range in the Data pane.
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To access In the "Action Call Properties Dialog Box" (described on page 895), select the
Run tab.

Important
information

l If you runmultiple iterations on an action, the actionmust begin and end at the
same point in the application, so that the application is in the proper location
and state to run the next iteration of the action.

l This tab applies to individual action calls and refers to the rows in the action's
data sheet. You can set the Run properties for an entire test (setting iterations
for rows on theGlobal data sheet) from the Run pane in the Test Settings
dialog box. For more information, see "Settings for GUI Tests, GUI Business
Components, and Application Areas" on page 580.

Relevant
tasks

"How to Display andModify Action-Related Information" on page 886

See also "Parameter Values Tab (Action Call Properties Dialog Box)" on the next page
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User interface elements are described below:

Option Description

Run one iteration
only

Runs the called action only once, using the first row in the action's data
sheet.

Run on all rows Runs the called action with the number of iterations according to the
number of rows in the action's data table.

Run from row __
 to row __

Runs the called action with the number of iterations according to the
specified row range.

Parameter Values Tab (Action Call Properties Dialog Box)

Relevant for: GUI tests only

This tab enables you to specify the values of input action parameters used by the called action and
to specify the locations in which you want to store output action parameter values. You can also
parameterize the value used for a particular input action parameter using any available parameter
type.
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To access In the "Action Call Properties Dialog Box" (described on page 895), select the
Parameter Values tab.

Important
information

l Specifying input and output parameter values in action calls is optional.

l If you do not set a value for an input action parameter, the default value that is
specified in the Action Properties dialog box is used.

l If you do not define a storage location for an output parameter value, the calling
action still has access to the output parameter data generated by the actions it
calls. However, specifying a storage location canmake your action call
statements more readable.

l You can alsomodify parameters from the Properties pane.

l This tab enables you to link action parameters with test parameters.

Relevant
tasks

"How to Display andModify Action-Related Information" on page 886

See also l "Run Tab (Action Call Properties Dialog Box)" on page 895

l "Parameters Tab (Properties Pane - GUI Testing)" on page 394

User interface elements are described below:

UI
Elements Description

Name The name for the parameter. (Action parameter names are case sensitive.)
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UI
Elements Description

Type The value type for the parameter. The following options are available:

l String. A character string enclosed within a pair of quotationmarks, for
example, "New York". If you enter a value and do not include the quotation
marks, UFT adds them automatically when the value is inserted in the script
during the test run. The default value is an empty string.

l Boolean. A true or false value. If you select this value type, you can click in
theDefault Value column and click the arrow to select a True or False value.
The default value is True.

l Date. A date string, for example, 3/2/2005. If you select this value type, you
can click in theDefault Value column and click the arrow to open a calendar
from which you can select a date. The default value is today's date.

l Number. Any number. The default value is 0.

l Password. An encrypted password value. If you select this value type, the
password characters aremasked when you enter the password in theDefault
Value field. In the action, however, the value appears encrypted. The default
value is an empty string, which also appears as an encrypted value in the
actual action.

l Any. A variant value type, which accepts any of the above value types. If you
select this value type, youmust specify the value in the format that is required
in the location where you intend to use the value. For example, if you intend to
use the value later as a string, youmust enclose it in quotationmarks. When
you specify a value of Any type, UFT checks whether it is a number. If the
value is not a number, UFT automatically encloses it in quotationmarks. If you
are editing an existing value, UFT automatically encloses it in quotationmarks
if the previous value had quotationmarks. The default value is an empty string.

Value
(Input
Parameters)

The default value for the parameter. You can leave the default value provided for
the parameter value type. The default value is required so that you can run the
action without receiving parameter values from elsewhere in the test.

Store In
(Output
Parameters)

Opens the "Storage Location Options Dialog Box" (described on page 991),
enabling you to specify how and where to store a return value for the output
parameter.

Description The description of the parameter, for example, the purpose of the parameter in the
action. This description is displayed together with the name of the parameter in
any dialog box in which you can choose an action parameter, including the Output
Options, Parameter Options, and Value Configuration Options dialog boxes.
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Action Properties Dialog Box
Relevant for: GUI tests only

This dialog box enables you to define options for the stored action. These settings apply each time
the action is called. You canmodify an action name, add or modify an action description, and set an
action as reusable or non-reusable.

To access 1. Select a GUI test tab or action tab.

2. If you are working with an action, click theKeyword View toggle button or
select View > Keyword View /Editor.

3. Right-click an action in the canvas or an action node in the Keyword View
and select Action Properties.

Important
information

You can also define actions and action parameters in the Editor or the
Properties pane.

Relevant tasks "How to Display andModify Action-Related Information" on page 886

See also l "Action Syntax in the Editor" on page 880

l "General Properties Tab (Properties Pane - GUI Testing)" on page 390

This dialog box contains the following tabs:

l General tab (described on page 900). Enables you tomodify the name of an action, add or edit an
action's description, or change the reusability status of the action.

l Parameters tab (described on page 903). Enables you to define input and output parameters to
be used by the action.

l Associated Repositories tab (described on page 906). Enables you to specify the object
repositories that are associated with the action.

l Used By tab (described on page 909). Enables you to view a list of the tests and actions that
contain calls to this particular action. Available only if your tests are stored in ALM and are using
the resources and dependencies model.

l External Action tab"External Action Tab (Action Properties Dialog Box)". Enables you to set the
data table definitions. Available only when viewing properties for external actions. When this tab
is displayed, the other tabs are read-only.

General Tab (Action Properties Dialog Box)

Relevant for: GUI tests only

This tab enables you tomodify the name of an action, add or edit an action's description, or change
the reusability status of the action.
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To access In the "Action Properties Dialog Box" (described on page 900), select theGeneral
tab.

Important
information

l The name of the action and its path are displayed in the tab. If it was defined
with a relative path in UFT, then the path is displayed as
<test name>\<action name>.

l If the action is calledmore than once within the test flow or if the action is
called by a reusable action, theReusable action option is read-only. If you
want to make the action non-reusable, remove the additional calls to the action
from the test.

l You can view details of a reusable action by double-clicking the action. For
more information on the test flow and action views, see "How to Display and
Modify Action-Related Information" on page 886.

l You can alsomodify many action parameters from the Parameters pane.

Relevant
tasks

"How to Display andModify Action-Related Information" on page 886
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See also l "Parameters Tab (Action Properties Dialog Box)" on the next page

l "Associated Repositories Tab (Action Properties Dialog Box)" on page 906

l "Used By Tab (Action Properties Dialog Box)" on page 909

l "External Action Tab (Action Properties Dialog Box)" on page 911

l Properties pane: "General Properties Tab (Properties Pane - GUI Testing)" on
page 390

User interface elements are described below:

UI
Elements Description

Name The name of the action. By default, the action name is the internal name provided
by UFT, such as Action 1. This number is incremented by 1 for each new action
that is added to the test.

If the action is a reusable action or an external action, thenReusable action or
ExternalAction is displayed next to the action name.

You can rename the action, as needed. When renaming an action, keep the
following points in mind:

l Consider how the new namewill affect your test and any tests that call this
action. For example, if you rename an action that is used by another test,
future run sessions may fail because the test cannot locate the specified
action.

l If you are working with the Resources and Dependencies model, and the test
containing the action you are renaming is stored the Test Planmodule in ALM,
the internal (default) action name is always displayed in the "Used By Tab
(Action Properties Dialog Box)" described on page 909. This is true even if you
rename the action.

For a list of naming conventions, see "Troubleshooting - Naming Conventions" on
page 2269.

Location The folder or ALM path where the action is stored.
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UI
Elements Description

Description You can insert comments about the action. An action description helps you and
other testers know what a specific action does without reviewing all the steps in
the action. The description is also displayed in the description area of the "Select
Action Dialog Box " (described on page 915). This enables you and other testers
to determine which action you want to call or copy from another test without
having to open it. For more information on inserting copies and calls to actions,
see "How to Nest Actions - Use-Case Scenario" on page 892.

Note: You can also add a description when inserting a call to a new action.
For more information, see "Insert Call to New Action Dialog Box (GUI
Testing)" on page 913.

Reusable
action

Indicates whether the action is a reusable action. By default, this check box is
selected. A reusable action can be calledmultiple times within a test and can be
called from other tests. Non-reusable actions can be copied and inserted as
independent actions, but cannot be inserted as calls to the original action.

If the steps of the action were expanded, they collapse after changing a non-
reusable action to a reusable action. You can view the steps of the reusable action
by selecting the action name in the canvas.

Note: If an action stored in this test is called by other tests, deleting the
action in this test may cause other tests to fail.

Parameters Tab (Action Properties Dialog Box)

Relevant for: GUI tests only

This tab enables you to define input and output parameters for use in the selected action's
iterations.
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To access In the "Action Properties Dialog Box" (described on page 900), select the
Parameters tab.

Important
information

l When you delete an action parameter, make sure that you also delete or
modify any steps that use the action parameter.

l You can alsomodify action parameters from the Properties pane.

Relevant
tasks

l "How to Display andModify Action-Related Information" on page 886

See also l "General Tab (Action Properties Dialog Box)" on page 900

l "Associated Repositories Tab (Action Properties Dialog Box)" on page 906

l "Used By Tab (Action Properties Dialog Box)" on page 909

l "External Action Tab (Action Properties Dialog Box)" on page 911

l "Parameters Tab (Properties Pane - GUI Testing)" on page 394
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User interface elements are described below:

UI
Elements Description

Add. Adds a new parameter to the list.

Delete. Removes the selected parameter from the list.

Name The name for the parameter. For a list of naming conventions, see
"Troubleshooting - Naming Conventions" on page 2269.

Type The value type for the parameter. The following options are available:

l String. A character string enclosed within a pair of quotationmarks, for
example, "New York". If you enter a value and do not include the quotation
marks, UFT adds them automatically when the value is inserted in the script
during the test run. The default value is an empty string.

l Boolean. A true or false value. If you select this value type, you can click in
theDefault Value column and click the arrow to select a True or False value.
The default value is True.

l Date. A date string, for example, 3/2/2005. If you select this value type, you
can click in theDefault Value column and click the arrow to open a calendar
from which you can select a date. The default value is today's date.

l Number. Any number. The default value is 0.

l Password. An encrypted password value. If you select this value type, the
password characters aremasked when you enter the password in theDefault
Value field. In the action, however, the value appears encrypted. The default
value is an empty string, which also appears as an encrypted value in the
actual action.

l Any. A variant value type, which accepts any of the above value types. If you
select this value type, youmust specify the value in the format that is required
in the location where you intend to use the value. For example, if you intend to
use the value later as a string, youmust enclose it in quotationmarks. When
you specify a value of Any type, UFT checks whether it is a number. If the
value is not a number, UFT automatically encloses it in quotationmarks. If you
are editing an existing value, UFT automatically encloses it in quotationmarks
if the previous value had quotationmarks. The default value is an empty string.

Default
Value
(Input
Parameters)

The default value for the parameter. You can leave the default value provided for
the parameter value type. The default value is required so that you can run the
action without receiving parameter values from elsewhere in the test.

User Guide
Chapter 33: Actions in GUI Testing

HP Unified Functional Testing (12.00) Page 905 of 2274



UI
Elements Description

Description The description of the parameter, for example, the purpose of the parameter in the
action. This description is displayed together with the name of the parameter in
any dialog box in which you can choose an action parameter, including the Output
Options, Parameter Options, and Value Configuration Options dialog boxes.

Associated Repositories Tab (Action Properties Dialog Box)

Relevant for: GUI tests only

This tab enables you to associate object repositories with an action, andmanage the association
order and default settings.

To access In the "Action Properties Dialog Box" (described on page 900), select the
Associated Repositories tab.
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Important
information

l You can also associate shared object repositories with multiple actions
simultaneously, using the "Associate Repositories Dialog Box" (described on
page 1266).

l If UFT is not connected to an ALM project, all associated object repositories
that are stored in your ALM project are listed as missing in the Errors pane. For
details, see "Errors Pane User Interface" on page 374.

l If an object repository cannot be found, a warningmessage displays when you
click this tab. UFT also adds a questionmark to themissing object repository

icon  to the left of themissing object repository in theAssociated object
repositories list. For details, see "How toManage Errors in the Errors Pane"
on page 369.

Relevant
tasks

"How to Display andModify Action-Related Information" on page 886

See also l "General Tab (Action Properties Dialog Box)" on page 900

l "Parameters Tab (Action Properties Dialog Box)" on page 903

l "Used By Tab (Action Properties Dialog Box)" on page 909

l "External Action Tab (Action Properties Dialog Box)" on page 911

User interface elements are described below:

UI
Elements Description

Associated
object
repositories

The list of all associated object repositories.

Note: If you want other users or HP products to be able to run an action on
other computers, and the action's associated object repositories are stored in
the file system, you can set the file path as a relative path (click the path
once to highlight it, and then click it again to enter edit mode).

Any users who want to run this action should then specify the drive letter and
folder in which UFT should search for the relative path in the Folders pane of the
Options dialog box (Tools > Options> GUI Testing tab > Folders node).

For more information, see "Folders Pane (Options Dialog Box > GUI Testing Tab)
" on page 544, and "Relative Paths in UFT for GUI Testing" on page 130.
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UI
Elements Description

Associates an object repository with the action. You can enter the absolute or
relative path and filename of the object repository, or use the browse button to
locate the required file. You can associate object repositories that are saved in
your file system or in an ALM project.

Note: To use the Resources and Dependencies model with Quality Center
10.00 or ALM, specify an absolute Quality Center or ALM path. For more
information, see "Relative Paths and ALM" on page 758.

Tips for adding an ALM path:

l When connected to ALM, click this button. UFT adds [QualityCenter], and
displays a browse button so that you can locate the ALM path.

l When not connected to ALM, hold the Shift key and click this button. UFT
adds [ALM], and you enter the path. You can also type the entire ALM path
manually. If you do, youmust add a space after [ALM]. For example: [ALM]
Subject\ObjectRepositories\flight.tsr.

Removes an associated object repository from the list.

Assigns a higher priority to the selected object repository.

Assigns a lower priority to the selected object repository.

Set as
Default

Sets the current list of object repositories as the default list to be associated with
all new actions in this test.

Note: TheSet as Default option is enabled only when:

l One ormore shared object repositories are associated with any local
action in the test.

l The list of object repositories associated with this action is different from
the list associated with other local actions in this test.
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Used By Tab (Action Properties Dialog Box)

Relevant for: GUI tests only

This tab enables you to view a list of the tests and actions that contain calls to this particular action.
This tab is available only if your tests are stored in ALM and are using the resources and
dependencies model.

To access In the "Action Properties Dialog Box" on page 900 (described on page 900), select
theUsed By tab.

Important
information

l This list is the same list that is displayed in the Dependencies tab of the Test
Planmodule in ALM. For more information, see "Resources and Dependencies
Model" on page 754.

l Calls to external actions that are stored in Quality Center 10.00 or ALM via a
relative path are not listed in this pane because they are not using the
resources and dependencies model.

l You can also view this list from the "Used By Tab (Properties Pane - GUI
Testing)" (described on page 401).
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Relevant
tasks

"How to Display andModify Action-Related Information" on page 886

See also l "General Tab (Action Properties Dialog Box)" on page 900

l "Parameters Tab (Action Properties Dialog Box)" on page 903

l "Associated Repositories Tab (Action Properties Dialog Box)" on page 906

l "External Action Tab (Action Properties Dialog Box)" on the next page

l Properties pane:"Used By Tab (Properties Pane - GUI Testing)" on page 401

User interface elements are described below:

UI
Elements Description

Test The ALM path of the test containing a call to this action.

Action The name of the action containing a call to this action. If the called action is the top-
level action in the test from which it is called,Main Test Flow is displayed instead.
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External Action Tab (Action Properties Dialog Box)

Relevant for: GUI tests only

This tab enables you to specify the data source for the selected action. This tab is available only
when viewing properties for external actions.

To access In the "Action Properties Dialog Box" (described on page 900), select theExternal
Action tab.

Important
information

l When this tab is displayed, the other tabs are read-only.

l When you insert a call to an external action, the action is inserted in read-only
format, and theRecord button is disabled.

If you want to record, you first need to insert a call to a reusable or non-reusable
action into your test, or select a step from a reusable or non-reusable action that
already exists in your test.

Relevant
tasks

"How to Display andModify Action-Related Information" on page 886
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See also l "General Tab (Action Properties Dialog Box)" on page 900

l "Parameters Tab (Action Properties Dialog Box)" on page 903

l "Associated Repositories Tab (Action Properties Dialog Box)" on page 906

l "Used By Tab (Action Properties Dialog Box)" on page 909

User interface elements are described below:

UI
Elements Description

Data Table
parameters

Indicates where to store the data in the action's data table:

l Use data stored with the original action (read-only). Uses the original
action's data. If you select this option, the data is read-only when viewed from
the calling test, and all changes to the original action's data sheet apply when
the action runs in the calling test.

l Use a local, editable copy. Uses an editable copy of the data in the test's
data table. If you select this option, a copy of the called action's data sheet is
added to the calling test's data table and is independent of the original action.

Changes to the original action's data sheet do not affect the calling test even if
you insert another call to this action after the action's data sheet is modified.

If the called action has parameterized steps that rely on new information in the
original action's data sheet, enter the relevant column names and required data to
the action sheet in the calling test manually.

Note:When you call an external action, the global data sheet columns and
data from the called action's test are always imported as a local, editable copy
in the calling test's global data sheet.

Changes to the original action's global data sheet do not affect the calling test
even if you insert another call to this action after the called action's global data
sheet is modified.

If the called action has parameterized steps that rely on new information in the
global data sheet, enter the relevant column names and required data to the
calling test's global data sheet manually.
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Insert Call to New Action Dialog Box (GUI Testing)
Relevant for: GUI tests only

For API testing, see "Insert Call to New Action Dialog Box (API Tests) " on page 1796.

This dialog box enables you to insert a call to a new action.

To access 1. Do one of the following:

n Ensure that a GUI test or action is in focus in the document pane.

n In the Solution Explorer, select a GUI test or action node.

2. Do one of the following:

n Select Design > Call to New Action.

n Click the Insert Call to New Action toolbar button .

n Click theCall to New Action button in the Record toolbar during a
recording session and select Call to New Action.
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Important
information

l You can call the new action from your test flow as a top-level action, or you can
call the new action from within another action in your test as a sub-action (or
nested action). For more information, see "How to Nest Actions - Use-Case
Scenario" on page 892.

l When you click OK, a new action is stored with your test and the call to it is
added at the bottom of the test or after the current step.

l You canmove your action call to another location at a parallel (sibling) level
within your test by dragging it to the desired location. For more information on
moving actions, see "How toMove an Action or Component Step" on page
935.

Relevant
tasks

"How to Display andModify Action-Related Information" on page 886

User interface elements are described below:

UI
Elements Description

Name Enables you to type a new action name or accept the default name. If you rename
the action, see "Troubleshooting - Naming Conventions" on page 2269.

Description The description of the action. You can also add an action description at a later
time using the Properties pane.

Note: Action descriptions are displayed in the Select Action dialog box when
you add a call to an existing action. The description helps you to choose the
action you want to call. For more information, see "General Tab (Action
Properties Dialog Box)" on page 900.

Reusable
Action

When selected, enables you to call the action from other tests or multiple times
from within this test (default). You can set or modify this setting at a later time
using the Properties pane.

Location The location to insert the new action. The following options are available:

l At the end of the test. Creates a call from the test flow to a top-level action.

l After the current step. Inserts the call to the action from within the current
action (nests the action).

Note: If the currently selected step is a reusable action from another test, the
new action is added automatically to the end of the test (the location options
are disabled).
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Select Action Dialog Box
Relevant for: GUI tests only

This dialog box enables you to select actions to use in your test as copies or as external actions.

To access 1. Do one of the following:

n Ensure that a GUI test or action is in focus in the document pane.

n In the Solution Explorer, select a GUI test or action node.

2. Select one of the following:

n Design > Call to Copy of Action/Call to Existing Action

n Click the Insert Call to New Action down arrow in the toolbar and select
Call to Copy of Action/Call to Existing Action from the drop-down list.

n Click theCall to New Action down arrow in the Record toolbar during a
recording session and select Call to Copy of Action/Call to Existing
Action from the drop-down list.
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Important
information

l When inserting a call to copy of action, you can view the location of the original
action in the General tab of the Action Properties dialog box.

l When inserting a call to existing action, you can create an additional call to any
reusable or external action in your test by pressing CTRL while you drag and
drop the action to another location at a parallel (sibling) level within your test.

Related
tasks

"How to Display andModify Action-Related Information" on page 886

See also "Keyword View Overview" on page 921

User interface elements are described below:

UI Elements Description

From test The name of the test containing the action you want to use. You can also enter
an ALM folder or a relative path.

If you enter a relative path, UFT searches for the test in the folders listed in the
Folders pane of the Options dialog box (Tools > Options > GUI Testing tab >
Folders node). For more information, see "Folders Pane (Options Dialog Box >
GUI Testing Tab)" on page 544 and "Relative Paths in UFT for GUI Testing" on
page 130.

If you are working with the Resources and Dependencies model with Quality
Center 10.00 or ALM, specify an absolute Quality Center / ALM path. For more
information, see "Relative Paths and ALM" on page 758.

Action All local actions (actions that are stored with the test you selected).

When you select an action, its type (Non-reusable Action orReusable Action)
and description, if one exists, are displayed. This helps you identify the action
you want to copy. For more information on action descriptions see "General Tab
(Action Properties Dialog Box)" on page 900.

Note:When inserting an existing action, external actions that the test calls
are also displayed in the list. If the action you want to call is already called
from within the selected test, you can select it from the list of actions. This
creates another call to the original action.

Edit new
action
properties
(Call to
Copy of
Action only)

When selected, the "Action Properties Dialog Box" (described on page 900) is
displayed when you click OK. You can thenmodify the action properties.

Tip: If you do not select this option, you canmodify the action's properties
later by right-clicking the action icon in the Keyword View and selecting
Action Properties.
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UI Elements Description

Location The location to insert the action. The following options are available:

l At the end of the test

l After the current step

If the currently selected step is a reusable action from another test, the call to the
copy of the action is added automatically to the end of the test, and theAfter the
current step option is disabled.
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Troubleshooting and Limitations - Actions
Relevant for: GUI tests only

This section describes troubleshooting and limitations for working with actions.

l If youmake a copy of an existing test (either in the file system or in ALM), then you cannot insert
a call to the same action from both of these tests into the same test.

Workaround: Instead of creating a copy of the test, useSave As to create a duplicate of the
test.

l You cannot create a call to a new action calledGlobal, since Global is the name reserved for the
Global sheet in the Data pane. If you create an action called Global, you will not be able to select
the local or global data sheet when parameterizing a identification property.

l Calling an external action from a function library using theRunAction statement results in a run-
time error.

Workaround:Call the action using the LoadAndRunAction Statement. For details, see the
Utility Objects section of theHP UFT Object Model Reference for GUI Testing.

l You cannot add a new action as a nested action to an external action.

Workaround:Open the external action and add the call to the nested action directly.
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Chapter 34: Keyword View
Relevant for: GUI tests and components

This chapter includes:

Concepts 921

Keyword View Overview 921

Comments in the Keyword View 922

Output Value for Your Component Step - Output Column 923

Conditional and Loop Statements in the Keyword View 923

Standard Steps After a Conditional or Loop Block 924

Tasks 925

How to Add a Standard Step to Your Test or Component 925

How to Select an Item for Your Step 926

How to Select an Operation for Your Step 927

How to Define Values for Your Step Arguments 928

How to Insert Conditional Statements from the Keyword View 930

How to Insert Loop Statements In the Keyword View 933

How to Add a Standard Step After a Conditional or Loop Block 934

How toMove an Action or Component Step 935

How to Delete a Step 936

How to Navigate in the Keyword View andOther Tips 937

How to Insert and Remove Breakpoints in the Keyword View 940

How to View Properties of Step Elements in the Keyword View 941

Reference 942

Keyword View User Interface 942

Columns Tab (Keyword View Options Dialog Box) 954

Fonts and Colors Tab (Keyword View Options Dialog Box) 955

Select Test Object Dialog Box 958

Insert Comment Dialog Box 962
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Insert Report Dialog Box 964
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Password Encoder Tool 965

Troubleshooting and Limitations - Keyword View 967
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Concepts

Keyword View Overview
Relevant for: GUI actions and components

The Keyword View enables you to create and view the steps of your actions or components in a
modular, table-like format. Each step is displayed as a row in the Keyword View, and is comprised
of individual, modifiable parts. You can create andmodify steps by selecting items and operations
in the Keyword View and entering information as required. Each step is automatically documented
as you complete it, enabling you to view a description of your action or component in
understandable sentences. You can also use these descriptions as instructions for manual testing,
if required.

You can use the Keyword View to add new steps to an action or component and to view, modify,
and debug existing steps. When you add or modify a step, you select the test object or other step
type you want for the step, select themethod operation you want to perform, and define any
necessary values for the selected operation or statement. Working in the Keyword View does not
require any programming knowledge. The programming required to actually perform each test step
is done automatically behind the scenes by UFT.

Additional Details for Business Components
The Keyword View that you see in UFT is the same as the Automation tab in ALM.

The Keyword View for components differs from the Keyword View for actions in that it provides
component-specific options that are specially designed to facilitate the creation of business
components. For example, unlike action steps (test objects and operations) that are displayed
hierarchically in the Keyword View, component steps are displayed at the same hierarchical level,
even if they are child objects of the previous step or operations to be performed.

To work with components in the Keyword View, UFT must be connected to an ALM project with
BPT support.

Types of Action and Component Steps

Relevant for: GUI actions and components

You can insert the following types of steps using the relevant options from the Insert or shortcut
menus.

l A standard step. For details, see "How to Add a Standard Step to Your Test or Component" on
page 925.

l A checkpoint step. For details, see "Checkpoints Overview" on page 1396.

l An output value step.

For actions, see: "Output Values Overview" on page 1488
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For components, see: "Output Value for Your Component Step - Output Column" on the next
page

l Comments in steps to separate parts of an action or a component and to add details about a
specific part.

For details, see:

n For actions: "Insert Comment Dialog Box" on page 962

n For components: "Comments in the Keyword View" below

For actions and scripted components, you can also insert:

l A step that uses programming logic to:

n send information to the run results

n put a comment line in your test

n synchronize your test with your application

n measure a transaction in your test

For details, see "Generated ProgrammingOperations" on page 968.

l Steps containing conditional statements and loop statements. For details, see "Conditional
and Loop Statements in the Keyword View" on the next page and "Standard Steps After a
Conditional or Loop Block" on page 924.

Comments in the Keyword View
Relevant for: GUI actions and components

A Comment is a free text entry. You can use comments to improve readability and helpmake an
action or component easier to update. For example, youmay want to add a comment to describe
what is being tested. Alternatively, youmay want to use comments to plan your action or
component steps before your application is ready to be tested. Later, you can use your plan to verify
that every item that needs to be tested is included in the component steps.

The icon indicates a comment in the Keyword View. In actions, comments are displayed in the
Comment cell of a step. This column is hidden by default, so youmay need to show it to see
comments. In components, comments are displayed as a separate step. Comments are always
visible as long as one or more Keyword View columns are displayed.

For details on selecting columns to display, see "Columns Tab (Keyword View Options Dialog Box)
" on page 954.
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Output Value for Your Component Step - Output Column
Relevant for: GUI components

You define the output type and settings for the output value in theOutput cell. These determine
where the output value is stored and how it is used during the component run session. When the
output value step is reached, UFT retrieves each value selected for output and stores it in the
specified location for use later in the run session.

When you create a new output value step, UFT assigns a default definition to each value selected
for output. When you output a value for a step in a business component:

l If at least one output component parameter is defined in the component, the default output type
is Component parameter and the default output name is the first output parameter displayed in
the Parameters pane of the Business Component Settings dialog box.

l If no output component parameter is defined in the component, the default output type is Local
parameter and the default name is p_Local.

Youmodify the output parameter, as required. If you select a local parameter, you canmodify it
directly in the "Output Options Dialog Box " (described on page 1519). If you select a component
parameter, the details for the output parameter are read-only. You canmodify the parameter details
in the Parameters pane of the Business Component Settings dialog box. For details, see
"Parameters Tab (Properties Pane - GUI Testing)" on page 394.

If, after you specify an output value, you choose not to save the output value, you can cancel it. For
details, see "How to Navigate in the Keyword View andOther Tips" on page 937.

Conditional and Loop Statements in the Keyword View
Relevant for: GUI actions and scripted GUI components

Using conditional statements, you can incorporate decisionmaking into your tests. Using loop
statements, you can run a group of steps repeatedly, either while or until a condition is true. You
can also use loop statements to repeat a group of steps a specific number of times.

The following conditional statements are available in the Keyword View:

Icon Type Description

If...Then Performs a statement or a series of statements based on specified
conditions. If a condition is not fulfilled, the next Elseif condition orElse
statement is examined.ElseIf...Then

Else
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The following loop statements are available in the Keyword View:

Icon Statement Description

While...Wend Performs a series of statements as long as a specified condition is True.

For...Next Uses a counter to perform a group of statements a specified number of
times.

Do...While Performs a series of statements indefinitely, as long as a specified
condition is True.

Do...Until Performs a series of statements indefinitely, until a specified condition
becomes True.

After you insert a conditional or loop statement in the Keyword View, you can insert or record steps
after the statement to include them in the conditional or loop block.

Note: Formore details on loop statements, see the VBScript documentation (select Help >
HP Unified Functional Testing Help > VBScript Reference).

For task details, see:

l "How to Insert Conditional Statements from the Keyword View" on page 930

l "How to Insert Loop Statements In the Keyword View" on page 933.

l "How to Add a Standard Step After a Conditional or Loop Block" on page 934

Standard Steps After a Conditional or Loop Block
Relevant for: GUI actions and scripted GUI components

After you add a conditional or loop statement to your test, all steps that you add or record are
automatically inserted within the conditional or loop statement block.

When you finish adding steps to the block, you can add a step outside of the block, at a sibling level
to the conditional or loop statement step, as described in "How to Add a Standard Step After a
Conditional or Loop Block" on page 934. For details on conditional and loop statements, see
"Conditional and Loop Statements in the Keyword View" on the previous page and "Generated
ProgrammingOperations" on page 968.
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Tasks

How to Add a Standard Step to Your Test or Component
Relevant for: GUI actions and components

This task includes the following steps:

l "Insert a new step" below

l "Define the step " below

1. Insert a new step
Do any of the following:

n Click anywhere in the Keyword View (below the existing steps, if any) to add a step at the
end of the action or component. If no steps are defined yet, this adds the first step to the
action or component.

n Right-click an existing step and select Insert New Step from the shortcut menu.

n Drag and drop a test object from the Toolbox pane to an action displayed in either the
Keyword View or the Editor.

For actions:A new step is added to the Keyword View, either as a sibling step or a sub-
step of an existing step, according to the test object hierarchy, as described in "UFT Test
Object Hierarchy" on page 1174.

For components:A new step is added to the Keyword View below the selected step.

2. Define the step
Click in the cell for the part of the step you want to modify and specify its contents, as
described below. Each cell in the step row represents a different part of the step. For each
step, you can define the following:

n Item (described on page 944 for actions, and on page 945 for components). For task details,
see "How to Select an Item for Your Step " on the next page.

n Operation (described on page 946). For task details, see "How to Select an Operation for
Your Step " on page 927.

n Value (described on page 947). For task details, see "How to Define Values for Your Step
Arguments " on page 928.

n Assignment (actions only) (described on page 948). For task details, see "How to
Navigate in the Keyword View andOther Tips" on page 937.

n Comment (described on page 948). For task details, see "How to Navigate in the Keyword
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View andOther Tips" on page 937.

n Output (components only) (described on page 948). For additional details, see "Output
Value for Your Component Step - Output Column" on page 923.

Tip: You can use the standard editing commands (Cut, Copy, Paste, andDelete) in
theEditmenu or in the shortcut menu tomake it easier to define or modify your steps.
You can also drag and drop steps tomove them to a different location within your action
or component. For details, see "Keyboard Shortcuts in the Keyword View" on page 953.

How to Select an Item for Your Step
Relevant for: GUI actions and components

This task describes how to select an item for your step and includes the following steps:

l "Select an item from the displayed list" below

l "Drag and drop an item from the Toolbox pane" below

l "Select a test object from an associated object repository or from your application" below

Do one of the following:

Select an item from the displayed list

1. Click in the Item cell.

2. Click the down arrow and select the item onwhich you want to perform the step from the
displayed list. When you insert a new step, the list is displayed automatically.

For components: To specify a function for the step (instead of selecting a test object),
select Operation. Then specify an operation for the step as described in "How to Select
an Operation for Your Step " on the next page.

Drag and drop an item from the Toolbox pane
Drag and drop a test object from the Toolbox pane into your action or component. A step with the
default operation for that test object is inserted.

For more details, see "Toolbox Pane User Interface (GUI Testing)" on page 510.

Select a test object from an associated object repository or from your
application

1. Click in the Item cell to activate it.
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2. Click the down arrow and select Object from repository (for tests) orSelect another object
(for components) to open the "Select Test Object Dialog Box" (described on page 958).

For tests: The test objects available in the list are the sibling and child test objects of the
previous step's test object. You can select whether you want the operation for the step to
be a test object operation or a run-time object operation. If you select a run-time object, an
Object statement is added to the Keyword View.

How to Select an Operation for Your Step
Relevant for: GUI actions and components

This task describes how to specify the operation to be performed on the item listed in the Item
column.

This task includes the following steps:

l "Prerequisite" below

l "Select an operation" below

1. Prerequisite
Select an item in the Item cell. For details, see "How to Select an Item for Your Step " on the
previous page.

For components:

n If you selected a test object in the Item column, all selected operations for the test
object item (as defined in the Keywords pane in the application area) are automatically
displayed in theOperation column. TheOperation list for that test object can include
out-of-the-box operations and any user-defined functions that were registered to that
specific test object type.

n If you selectedOperation in the Item column, all functions defined in associated
function libraries are displayed, alphabetically. (Youmanage the function libraries for
components in the Function Libraries pane of the Application Area. For details, see
"Function Libraries Pane (Application Area)" on page 2102.)

2. Select an operation
a. Click in theOperation cell to activate it.

b. Click the down arrow and select the operation to be performed on the item.

For actions: The available operations vary according to the item selected in the Item
column. (For example, if you selected a browser test object, the list contains all of the
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methods and properties available for the browser object.) If you selected a test object
in the Item column, the default operation (most commonly-used operation) for the test
object is automatically displayed in theOperation column. This cell is not applicable if
you chose to insert a statement in the Item column.

For components: The operation can be either a standard operation or a user-defined
function that is enabled for use in the Keywords pane of the application area. For
details on user-defined functions, see "User-Defined Functions and Function
Libraries" on page 1029 and "Keywords Pane (Application Area)" on page 2107.

Tip:When you position the cursor over an operation in the list, a tooltip describes what
this operation performs. For user-defined functions, the tooltip is taken from the
description that you provided in the associated function library. For details, see "Add
documentation details to the function - optional" on page 1053.

How to Define Values for Your Step Arguments
Relevant for: GUI actions and components

This task describes how to specify the arguments for the operation to be performed on the item
listed in the Item column.

This task includes the following steps:

l "Define or modify a value " below

l "Addmulti-line arguments" on the next page

l "Parameterize the value for an argument " on page 930

l "Encode a password" on page 930

Define or modify a value

1. Click in theValue cell to activate it.

2. Click in each partition of theValue cell and enter the argument values for the selected
operation. As you click in theValue cell, a tooltip displays information for each argument. In
the tooltip, the argument for the partition that is currently highlighted is displayed in bold, and
any optional arguments are enclosed in square brackets.

User Guide
Chapter 34: Keyword View

HP Unified Functional Testing (12.00) Page 928 of 2274



Somemethods may display multiple partitions. For example:

You can enter constant or parameterized values. For details on parameterizing values, see
"Parameterize the value for an argument " on the next page.

For tests:After you enter the initial value, you can edit the value at any time in the
Keyword View for a test object, utility object, function call, conditional statement, or loop
statement. You cannot edit the value of a regular statement, such as x=10, in the Keyword
View after you define its initial value. You can edit the previously defined value of a regular
statement only in the Editor.

Add multi-line arguments
In aValue cell, press SHIFT+ENTER to add line breaks to your argument value. After you enter a
multi-line argument value, the value is automatically converted to a string, and only the first line of
the argument is displayed, followed by an ellipsis (...). This format for multi-line argument values is
also displayed in the Documentation column of the Keyword View.

Note:

l You can select the cell to display the entire argument value to be used in the step.

l The argument value is used during the run session exactly as it appears in the step. For
example, if you enter quotationmarks as part of the argument value, they are included in the
argument value used during the run session.

l Multi-line values are automatically interpreted as strings, so you do not need to add
quotationmarks for this purpose.
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Parameterize the value for an argument

Click the  button in the requiredValue cell. The Value Configuration Options dialog box opens.
For user interface details, see:

l For actions:"Value Configuration Options Dialog Box" on page 1579

l For components:

n Local input parameters in the Business Component Keyword View: "Value Configuration
Options Dialog Box" on page 1579

n Local output parameters in the Output Options dialog box: "Output Options Dialog Box " on
page 1519

Note: You cannot delete local parameters, but you can cancel the input or output to
them. For details on parameterizing a component value, see "Parameters Tab
(Properties Pane - GUI Testing)" on page 394.

Encode a password
You can encode passwords for use inmethod arguments and data table cells. For details on how to
encode passwords, see:

l For actions:"Password Encoder Tool" on page 965.

l For components stored in ALM. TheHP Business Process Testing User Guide. Do not
encode passwords in UFT. When business component tests run from ALM, all values are
treated as strings. Therefore, if you encode a password in UFT using the "Password Encoder
Tool" (described on page 965), the resulting string, for example,
4b8a4a999d0d0e2c9b6cce8bb8e3, will be used instead of the password it represents.

l For components stored in UFT."Password Encoder Tool" on page 965. You can use the
password encoder to insert passwords in UFT. (When your components are later upgraded to
ALM, the upgrade process automatically converts existing encoded strings to a format
recognized by ALM.)

How to Insert Conditional Statements from the Keyword
View

Relevant for: GUI tests and scripted GUI components

This task describes how to insert a conditional If...Then...Else statement from the Keyword View.

1. In the Keyword View, select the step that you want the conditional statement to follow. The
following example shows the userName row selected:
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2. Select Edit > Code Snippet and select If...Then. The new statement is added to the Keyword
View below the selected step. For example:

3. Click in the Item cell for the If statement. Then click the down arrow and select the object on
which you want to perform the conditional statement. For example:

4. Click in theOperation cell and select the operation you want to perform. For example:

5. If needed, click in theValue cell and enter the required condition. (In this example, theExist
property does not require a value in theValue cell.)
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6. Insert a Then statement by selecting the If statement step and inserting a new statement
(right-click and select Insert New Step) or by recording a new step. For example:

Make sure you set the values for the new step in theOperation andValue columns.

7. Delete the row immediately above the If statement. For example:

8. You can now complete the statement with anElse statement, or you can nest an additional
level in your statement. To do this, select the If statement and select one of the following
options:

Statement Option

If...Then Edit > Code Snippet > If...Then

ElseIf...Then Edit > Code Snippet > ElseIf...Then

Else Edit > Code Snippet > Else

For example, the statements below check that the User Name edit box exists in theMercury
Tours site. If the edit box exists, Then a user name is entered; Else amessage is sent to the
Run Results.
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The same example is displayed in the Editor as follows:

If Browser("Welcome: Mercury").Page("Welcome: Mercury").WebEdit("userName").Exist Then
Browser("Welcome: Mercury").Page("Welcome: Mercury").WebEdit("userName").Set DataTabl
e ("p_UserName", dtGlobalSheet)
Else
Reporter.ReportEvent micFail, "UserName Check", "The User Name field does not exist."
End If

9. (Optional) After you create a conditional statement, use the Insert Step After Block option to
insert a step outside of the conditional statement block. For details, see "Standard Steps After
a Conditional or Loop Block" on page 924.

How to Insert Loop Statements In the Keyword View
Relevant for: GUI tests and scripted GUI components

To insert a loop statement in the Keyword View:

1. Select the step that you want the loop statement to follow.

2. Select Edit > Code Snippet and select the statement type that you want to insert from the
sub-menus. The new statement is added to the Keyword View below the selected step.

3. In theValue column, enter the required condition, for example:
For i = 0 to ItemsCount - 1

4. To complete the loop statement, you can:

n Select the loop statement step and record a new step to add it to your loop statement.

n Select the loop statement step and right click and then select Insert New Step or press
INSERT to insert a new step into your loop statement.

5. (Optional) After you create a loop statement, use the Insert Step After Block option, or press
SHIFT+INSERT to insert a step outside of the loop statement block. For details, see "Standard
Steps After a Conditional or Loop Block" on page 924.

Note: For details on working in the Editor, see "Programming in GUI Testing Documents in the
Editor" on page 994.

Example:
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The following example counts the number of items in a list and then selects them one by one.
After each of the items has been selected, the test continues.

The same example is displayed in the Editor as follows:

itemsCount = Browser("Welcome: Mercury").Page("Find a Flight:").
WebList("toDay").GetROProperty ("items count")

For i = 1 To ItemsCount-1
ItemName = Browser("Welcome: Mercury").Page("Find a Flight:").

WebList("toDay").GetItem (i)
Browser("Welcome: Mercury").Page("Find a Flight:").WebList("toDay").

Select ItemName
Next

How to Add a Standard Step After a Conditional or Loop
Block

Relevant for: GUI actions and scripted GUI components

This task includes the following steps:

l "Select the end of the conditional or loop statement " below

l "Insert a new step using the New Step After Block option" below

l "Define the step" on the next page

1. Select the end of the conditional or loop statement
Select the conditional or loop statement step after and outside of which you want to add the
new step.

2. Insert a new step using the New Step After Block option
Right-click the conditional or loop statement and select Insert New Step After Block, or
press SHIFT+INSERT. A new step is added to the Keyword View at the end of the conditional or
loop block, outside of the conditional or loop statement (as a sibling).
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3. Define the step
Specify the content of the step by modifying it, as described in "How to Add a Standard Step to
Your Test or Component" on page 925.

How to Move an Action or Component Step
Relevant for: GUI actions and components

This task describes how tomove a step to a different location within an action or component.

This task includes the following steps:

l "Drag and drop a step " below

l "Copy/cut and paste a step" below

Drag and drop a step
In the Item column, drag the step up or down and drop it at the required location within the action or
component. When you drag a selected step, a line is displayed, enabling you to see the location to
which the step will bemoved.

For actions: If you drag a step within its parent object, the step is displayed in the new position
under its parent. If youmove the step to a different parent object, the parent is duplicated, and
the step is moved below it.

Copy/cut and paste a step
Copy or cut the step to the Clipboard and then paste it in the required location. (When youmove,
copy, or cut an action step, you alsomove, copy, or cut all of its sub-steps, if any.)

l Copy. UseEdit > Copy or CTRL + C.

l Cut. UseEdit > Cut or CTRL + X.

l Paste. UseEdit > Paste or CTRL + V.
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Additional Guidelines for Actions:

l Conditional and loop blocks. (Also relevant for scripted GUI components) You cannot copy
or cut only the child nodes of conditional or loop blocks. You can copy or cut them only in their
entirety. After you copy or cut conditional or loop blocks to the Clipboard, you can paste them in
valid locations.

l Parent and child objects. You cannot copy or cut a parent object together with only some of its
child objects. Youmust either select only the parent (which automatically includes all its child
objects) or the parent object together with all of its children.

How to Delete a Step
Relevant for: GUI actions and components

This task describes how to delete steps in the Keyword View.

This task includes the following steps:

l "Prerequisites" below

l "Delete the step " below

Note: You cannot delete a step if one of its cells is in edit mode.

1. Prerequisites
n Make sure that removing the step will not prevent the action or component from running

correctly.

n For actions:When a step has both an operation and sub-steps defined for it, as in the
example below, you can choose whether to delete only the step containing the operation of
the item, or to delete the step and all of its sub-steps.

2. Delete the step
a. Select the step that you want to delete.
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b. Select Edit > Delete, press the DELETE key, or right-click the step and select Delete from
the shortcut menu. A confirmationmessage opens.

For actions: If you are deleting a reusable action that is called by another action, and
if your test is stored in ALM and is using the resources and dependencies model
(described on page 755), a list of the actions that call the action that you are deleting is
displayed in the confirmationmessage box.

To copy any or all of the actions from the list to the Windows Clipboard:

1Select the relevant actions from the list.

2Right-click and select Copy Selected, or press CTRL+C on your keyboard.

c. Click Delete Step to confirm. The step is deleted from the action or component.

How to Navigate in the Keyword View and Other Tips
Relevant for: GUI actions and components

This task includes the following steps:

l "General Tips" below

l "Display or Hide Columns" on the next page

l "Item Column" on the next page

l "Value Column" on the next page

l "Assignment Column (Actions Only)" on the next page

l "Comment Column (Actions Only)" on the next page

l "Comment Step (Components Only)" on page 939

l "Output Column (Components Only)" on page 939

l "Documentation Column" on page 939

General Tips

l Use the left and right arrow keys tomove the focus one cell to the left or right, with the following
exceptions:

n In the Item column, the left and right arrow keys collapse or expand the item (if possible). If
not possible, the arrow keys behave as in any other column.
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n When a cell is in edit mode (for example, whenmodifying a value or comment), the left and
right arrow keys move the cursor within the edited cell.

l Use the standard editing commands (Cut, Copy, Paste, andDelete) in the Edit menu or in the
context menu to define or modify your steps. For details, see "Keyboard Shortcuts in the
Keyword View" on page 953.

l Drag and drop steps tomove them to a different location within your action or component.

Display or Hide Columns

l Use the Keyword View Options dialog box. For details, see "Columns Tab (Keyword View
Options Dialog Box) " on page 954.

l Right-click a column header row in the Keyword View. Then select or clear the required column
name from the shortcut menu.

l Rearrange columns by dragging a column header to its new location in the Keyword View. Red
arrows are displayed when the column header is dragged to an available location.

Item Column
When a row is selected (not a specific cell), you can type a letter to jump to the next row that starts
with that letter.

For actions:When the entire step is selected (by clicking to its left), use the + key (expands a
specific branch), - key (collapses a specific branch), and * key (expands all branches) to expand
and collapse the Item tree.

Value Column
When aValue cell is selected, press CTRL+F11 to open the "Value Configuration Options Dialog
Box" (described on page 1579).

Assignment Column (Actions Only)

l To create or edit an assignment to or from a variable, double-click in the left part of the
Assignment cell.

l To select eitherGet from orStore in (depending on whether you want to retrieve the value from
a variable or store the value in a variable), click the arrow button.

l To specify or modify the name of the variable, click in the right part of theAssignment cell.

Comment Column (Actions Only)

l To add a comment to an existing step, select the step and type your comment in theComment
column.
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Note: You can also insert a comment step. For details, see "Insert Comment Dialog Box"
on page 962.

l Tomodify an existing comment, double-click the comment in theComment column. The cell
becomes a free text field.

Comment Step (Components Only)

l To add a comment to your component, do one of the following:

n Select Edit > Format > Comment.

n Click in the Item cell and select Comment from the displayed list.

n Right-click a component step and select Insert Comment. A comment row is added below
the selected step.

Enter text in the Comment row. If you do not enter text, the comment is deleted when the
cursor focus is removed.

l Tomodify an existing comment, do one of the following:

n Double-click the comment in theComment column. The text box becomes a free text field.

n Click theComment icon, which acts as a toggle, making the comment either editable or
read-only.

l To delete a comment, do one of the following:

n Select the comment and select Edit > Delete.

n Press theDELETE key on your keyboard.

n Right-click and select Delete from the context menu.

Output Column (Components Only)

To cancel output to the parameter, click in theOutput cell. Then click theCancel button or
press theDELETE key.

Documentation Column

l To display only theDocumentation column, right-click the column header row and choose
Documentation Only from the shortcut menu.

l To copy the documentation, right-click the column header row and chooseCopy
Documentation to Clipboard from the shortcut menu. Paste the documentation into a different
application, as required.
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How to Insert and Remove Breakpoints in the Keyword
View

Relevant for: GUI actions and components

This task describes how to insert and remove breakpoints in the Keyword View. When you place a
breakpoint in a step in the Keyword View, it is also displayed in the Editor (for actions and scripted
components), and vice versa. For details, see "How to Use Breakpoints " on page 687.

This task includes the following steps:

l "Insert a breakpoint in the Keyword View" below

l "Remove a breakpoint from the Keyword View" on the next page

Insert a breakpoint in the Keyword View
Do any of the following:

l Click in the left margin at the point where you want to insert the breakpoint.

l Select a step and press F9.

l Select Run > Insert/Remove Breakpoint.

A red breakpoint icon is displayed.

Example of Inserting a Breakpoint in an Action

UFT automatically places the breakpoint next to the appropriate item for the step. In the
example shown below, even if you click next to theWelcome: Mercury browser or page item,
the breakpoint is automatically inserted next to the userName edit item, on which the step is
actually performed. When you collapse items, the breakpoint icons remain in the left margin
next to the closest visible item, so you can see that the test contains breakpoints.
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Remove a breakpoint from the Keyword View
Do any of the following:

l Click the breakpoint icon.

l Select a step and press F9.

l Select Run > Insert/Remove Breakpoint.

How to View Properties of Step Elements in the Keyword
View

Relevant for: GUI actions only

To view properties for a part of a step:Right-click the item whose properties you want to view,
and select the relevant option from the context menu.

For example, you can view object properties, action properties, action call properties, checkpoint
properties, and output value properties.

The property options available in theStepmenu or the shortcut (right-click) menu change according
to the currently selected step. For example, if you right-click a step that contains a checkpoint or
output value on a test object, you can view object properties and checkpoint or output value
properties for the current object and checkpoint or output value. If you right-click an action, you can
choose to view action properties or action call properties for the current action.
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Reference

Keyword View User Interface
Relevant for: GUI actions and components

The Keyword View enables you to create and view the steps of your action or component in a
keyword-driven, modular, table format. The Keyword View is comprised of a table-like view, in
which each step is a separate row in the table, and each column represents the different parts of the
steps. The columns displayed vary according to your selection. For details, see "Columns Tab
(Keyword View Options Dialog Box) " on page 954.

The following example shows hierarchical steps in the Login action:

The following example shows the steps of a component:
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To
access

1. Make sure that an action tab or component tab is the active document.

2. Use one of the following:

n For actions or scripted components: If the Editor is displayed, click the
Editor / Keyword View toggle button.

n For keyword components: The Keyword View is displayed by default.

See
also

l "Keyword View Context MenuOptions" on page 949

l "Keyboard Shortcuts in the Keyword View" on page 953
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User interface elements are described below:

UI Elements Description

Item
(actions only)

The item onwhich you want to perform the step. An item can be any of the
following:

l a test object from the object repository

l a utility object

l a function call

l a statement, for example, aDim statement

l a step generated by the Step Generator. For details, see "How to Insert
Steps Using the StepGenerator" on page 978.

This column displays a hierarchical icon-based tree. The highest level of the
tree are actions, and all steps are contained within the relevant branch of the
tree. Steps performed within the same parent object are displayed under that
same object. Function calls, utility objects, and statements are placed in the
tree hierarchy at the same level as the item above them (as a sibling).

Example of Item list

The test objects available in the Item list are the sibling and child test
objects of the previous step's test object, as defined in the object
repository. The example below shows the objects available for the step
following a userName test object.

For task details, see "How to Select an Item for Your Step " on page 926.
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UI Elements Description

Item
(components
only)

The item onwhich you want to perform the step. An item can be any of the
following:

l a test object from the object repository

l a user-defined function (Operation), for example, a function that opens an
application at the start of a business component or checks the value of a
specific property. Available only if user-defined functions were added to a
function library that is associated with the component's application area.
For details, see "Associated Function Libraries" on page 1031 and "User-
Defined Functions and Function Libraries" on page 1029.

l Comment. Free text cell that spans the entire row. After a step is
converted into a Comment step it cannot be restored to another type of
step. You use the Comment option to enter manual steps or to provide
information on adjacent steps. For details, see "Comments in the Keyword
View" on page 922.

Youmust select an option from the Item column before you can add additional
content to a step.

Example of Item list

The test objects available in the Item list are the sibling and child test
objects of the previous step's test object, as defined in the object
repository. The example below shows the objects available for the step
following a userName test object.

For task details, see "How to Select an Item for Your Step " on page 926.
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UI Elements Description

Operation The operation to be performed on the item. This column contains a list of all
available operations (methods, functions, or properties (or sub-procedures for
components)) that can be performed on the item selected in the Item column,
for example, Click andSelect. For task details, see "How to Select an
Operation for Your Step " on page 927.

For actions: TheOperation column displays the default operation.

For components: TheOperation column displays themost commonly used
operation for the item. If the application area used by a component is
associated with at least one function library, the functions from that function
library are accessible from this column. You specify function libraries in the
Function Libraries pane of the Application Area. For details, see "Function
Libraries Pane (Application Area)" on page 2102.
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UI Elements Description

Value The argument values for the selected operation. For actions, this can display
the content of the statement.

TheValue cell is partitioned according to the number of arguments of the
selected option in theOperation column.

If an argument has a predefined list of values, a drop-down list of possible
values is provided, and you cannot manually enter a value in this box. For task
details, see "How to Define Values for Your Step Arguments " on page 928.

l If you click in the Value cell for an operation that accepts parameters, the

parameterization icon is displayed. Click this icon to open the "Value
Configuration Options Dialog Box".

l If you click in the Value cell of a checkpoint step, the checkpoint properties

icon is displayed. Click this icon to open the relevant Checkpoint
Properties dialog box.

For components: An argument value can be a constant, a local parameter,
or a component parameter, depending on the selected option.

l Local parameter. A local parameter is specific to the business component
and can only be accessed by that component. It is intended for use in a
single step or between component steps, for example, as an output
parameter for one step and an input parameter for a later step. For details,
see "How to Define Values for Your Step Arguments " on page 928.

l Component parameter. A component parameter is a parameter that can
be accessed by any component in your ALM project. For details, see
"Parameters Tab (Properties Pane - GUI Testing)" on page 394.

If you click in theValue cell after you specify a local or component parameter
for it, an icon specifying the type of parameter is displayed in the cell:

Indicates a component parameter.

Indicates a local parameter.
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UI Elements Description

Assignment
(actions only)

The assignment of a value to or from a variable. For example, Store in cCols
would store the return value of the current step in a variable called cCols,
which you could then use later in the test.

You can select eitherStore in orGet from, depending on whether you want
to retrieve the value from a variable or store the value in a variable.

l Store in X. Value is equivalent to anX = <step> line in the Editor.

l Get From X. Value is equivalent to a <step> = X line in the Editor. For
details on storing variables, see "Storage Location Options Dialog Box" on
page 991.

Output
(components
only)

The parameter in which output values for the step are stored. For details, see
"Output Value for Your Component Step - Output Column" on page 923.

Example: If you select an output parameter named cCols, the output
value of the current step would be stored in the cCols parameter. You
can then use the value stored in the output parameter later in the
component as an input parameter. As in theValue column, you can use
two types of parameters when specifying an output parameter—a local
parameter or a component parameter.

If you click in theOutput cell after you specify an output parameter for it, an
icon specifying the type of parameter is displayed in the cell:

Indicates a component parameter.

Indicates a local parameter.

Comment For actions: A free text edit box for any information you want to add regarding
the step. These are also displayed as inline comments in the Editor.

For components: A manual step or other free textual notes between steps. A
comment is displayed as an entire row (not in a column). For details, see
"Comments in the Keyword View" on page 922.

Note:

l UFT does not process comments during a run session.

l After you insert a comment, you cannot change it to a step.
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UI Elements Description

Documentation Read-only auto-documentation of what the step does in an easy-to-
understand sentence, for example, Click the "Sign-in" image. orSelect "San
Francisco" in the "toPort" list.

Tip:

l Displaying only this column (and hiding the other columns) is useful if
you want to print or view manual testing instructions. For details, see
"How to Navigate in the Keyword View andOther Tips" on page 937.

l If you created a function library and associated it with a test or with a
component's associated application area, documentation for its
functions can be displayed only if you defined the relevant text in the
function library. For details, see "Add documentation details to the
function - optional" on page 1053 and "User-Defined Functions and
Function Libraries" on page 1029.

Keyword View Context Menu Options

Relevant for: GUI tests and components

To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document pane.

n In the Solution Explorer, select a GUI test or component node or one of
its child nodes.

2. Select View > Keyword View or click theKeyword View toggle button.

Relevant
tasks

"How to Add a Standard Step to Your Test or Component" on page 925

See also l "Keyword View Overview" on page 921

l "Keyword View User Interface" on page 942
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Context menu options for GUI actions and scripted GUI components

Menu
Command Description

Action
Properties
(action level
only)

Opens the "Action Properties Dialog Box" (described on page 900), enabling
you to specify options, parameters, and associated object repositories for a
stored action.

Action Call
Properties
(action level
only)

Opens the "Action Call Properties Dialog Box" (described on page 895),
enabling you to specify the number of run iterations according to the number of
rows in the data table, and to define the values of input parameters and the
storage location of output parameters.

Object
Repository
(action level
only)

Opens the "Object Repository Window" (described on page 1274), which
displays a tree containing all objects in the current action.

Object
Properties

Opens the "Object Properties Dialog Box" (described on page 1271), which
displays the read-only properties of the selected object.

Note: This command is only available when the selected step contains a
test object.

Comment
Properties

Opens the "Comment Properties Dialog Box" (described on page 963), which
enables you to view the properties of the selected comment.

Note: This command is only available when the selected step is a
comment step.

Checkpoint
Properties

Opens the relevant Checkpoint Properties dialog box for a selected object.

Note: This command is only available when the selected step is a
checkpoint step.

Output Value
Properties

Opens the relevant Output Value Properties dialog box for a selected object.

Note: This command is only available when the selected step is an
output value step.

Insert
Standard
Checkpoint

Opens the "Checkpoint Properties Dialog Box" on page 1432 (described on
page 1432), enabling you to create a checkpoint on the selected test object.
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Menu
Command Description

Insert Output
Value

Opens the "Output Value Properties Dialog Box" on page 1498 (described on
page 1498), enabling you insert an output value step on a selected test object.

Insert New
Step

Inserts a new step into your action.

Insert New
Step After
Block

Inserts a new step after a conditional or loop block into your action.

Insert Step >
Step Generator

Opens the "Step Generator Dialog Box" (described on page 983).

Insert Step >
Comment

Inserts a Comment step into your action.

Insert Step >
Report

Opens the Report details dialog, enabling you to add details to be included in
the report of the test.

Conditional
Statement >
If...Then

Inserts an If...Then conditional statement step.

Conditional
Statement >
Elself...Then

Inserts anElself...Then conditional statement step

Conditional
Statement >
Else

Inserts anElse conditional statement step.

Loop
Statement >
While...Wend

Inserts aWhile...Wend loop statement step.

Loop
Statement >
For...Next

Inserts a For...Next loop statement step.

Loop
Statement >
Do...While

Inserts aDo...While loop statement step.

Loop
Statement >
Do...Until

Inserts aDo...Until loop statement step.
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Menu
Command Description

Start
Transaction

Inserts aStartTransaction step into your action, marking the beginning of the
transaction to be timed.

(Relevant only if the test includes transactions to be used by LoadRunner or
Business Availability Center.)

End
Transaction

Inserts anEndTransaction step in the test, marking the end of the
transaction to be timed.

(Relevant only if the test includes transactions to be used by LoadRunner or
Business Availability Center.)

Action > Insert
Call to New

Opens the "Insert Call to New Action Dialog Box (GUI Testing)" (described on
page 913), enabling you to create a new action.

Action > Insert
Call to Copy

Opens the "Select Action Dialog Box " (described on page 915), which inserts
a call to an editable copy of an existing action.

Action > Insert
Call to
Existing

Opens the "Select Action Dialog Box " (described on page 915), which inserts
a call to an existing reusable action.

Insert/Remove
Breakpoint

Sets or clears a breakpoint in your action or component.

Enable/Disable
Breakpoint

Enables or disables the selected breakpoint in your test.

Run from Step Starts a run session from the selected step.

Debug from
Step

Runs from the selected step instead of the start of the test or component.

Run to Step Runs a test or component until the current step.

Optional Step Inserts an optional step into your action or component.

Cut Removes the currently selected line or text from your action or component.

Copy Copies the currently selected step or text.

Paste Pastes the currently copied text.

Delete Deletes the current step or text.

Expand Sub
Tree

Expands all substeps in the current action.

Collapse Sub
Tree

Collapses all substeps in the current action.
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Context menu options for keyword GUI components

Menu Command Description

Insert New Step Inserts a new step into your component.

Insert Comment Inserts a Comment step into your component.

Insert Operation Inserts a new operation (function) step into your component.

Cut Removes the currently selected line or text from your component.

Copy Copies the currently selected step or text.

Paste Pastes the currently copied text.

Delete Deletes the currently step or text.

Keyboard Shortcuts in the Keyword View

Relevant for: GUI actions and components

If you prefer to use your keyboard to edit an action or a component, you can use the following
keyboard shortcuts to navigate within the Keyword View:

l Actions and scripted components:Press SHIFT+INSERT to add a new step after a conditional
or loop block.

l Press INSERT to add a new step below the currently selected step.

l Use the TAB and SHIFT+TAB keys tomove the focus left or right within a single row, unless you
are in a cell that is in edit mode. If so, press ENTER to exit edit mode, and then you can use the
TAB keys.

l When the value cell of a checkpoint step is selected, press CTRL+F11 to open the relevant
Checkpoint Properties dialog box.

l When a cell containing a list is selected, you can:

n Press SHIFT+F4 to open the list for that cell.

n Change the selected item by using the up and down arrow keys. In the Item column, the list
must be open before you can use the arrow keys.

n Type a letter or sequence of letters to move to a value that starts with the typed letters. The
typed sequence is highlighted in white.

l Actions and scripted components:Press F7 to use the StepGenerator to add a new step
below the selected step.
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Columns Tab (Keyword View Options Dialog Box)
Relevant for: GUI actions and components

This tab enables you to specify the columns you want to display in the Keyword View. You can also
specify the order in which the columns are displayed.

The following image shows the options available for an action. Options for a component are similar.

To access In the Keyword View, right-click a column header and select View Options.

Important
Information

l You can use standard SHIFT and CTRL key behaviors to select multiple column
names in theAvailable columns orVisible columns list.

l As an alternative to using this dialog box tab, you can:

n Select which Keyword View columns to display by right-clicking the column
header row in the Keyword View and selecting the columns to display or
hide.

n Select theDocumentation Only item in the displayedmenu. This is useful
if you want to print the documentation column information for use as
instructions for manual testing.

See also l "Keyword View User Interface" on page 942

l "Fonts and Colors Tab (Keyword View Options Dialog Box)" on the next page
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User interface elements are described below:

UI
Elements Description

Available
columns

Columns not currently displayed in the Keyword View.

Visible
columns

Columns currently displayed in the Keyword View.

> Display Selected Columns.Moves the selected columns from theAvailable
columns list to theVisible columns list. Alternatively, you can double-click an
item tomove it to the other list.

>> Display All Columns.Moves all columns from theAvailable columns list to the
Visible columns list.

> Hide Selected Columns.Moves the selected columns from theVisible columns
list to theAvailable columns list. Alternatively, you can double-click an item to
move it to the other list.

>> Hide All Columns.Moves all columns from theVisible columns list to the
Available columns list.

Move Up / Move Down. Adjusts the order in which the selected columns appear in
the Keyword View.

Note: The order of the columns in the Keyword View does not affect the order in
which the cells need to be completed for each step. For example, if you choose
to display theOperation column to the left of the Item column, youmust still
select the item first. Only then is theOperation column list refreshed tomatch
the selection youmade in the Item column.

Fonts and Colors Tab (Keyword View Options Dialog
Box)

Relevant for: GUI actions and components

This tab enables you to specify text and color display options for different elements in the Keyword
View.
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To access 1. In the Keyword View, right-click a column header and select View Options.

2. In the Keyword View Options dialog box, select the Fonts and Colors tab.

See also l "Keyword View User Interface" on page 942

l "Columns Tab (Keyword View Options Dialog Box) " on page 954
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User interface elements are described below:

UI Elements Description

Element You can specify different font and color options for each of these Keyword View
elements. Select one of the following elements to see the current definitions and
modify them:

l Alternate Rows. The background color of every other row. The font and text
color for the alternate rows is the same as the font and text color defined for
theDefault element.

l Comment. The row and text of comment lines. Note that all of the available
formatting options apply to entire comment rows, not to comments within a
regular step row. For comments within a step row, only the specified
Foreground color applies (all other settings are taken from theAlternate
Rows, Default, orSelected Row settings, as appropriate).

l Default. All rows and text in the Keyword View (except for the elements listed
below).

l Selected Row. The row and text currently selected (highlighted).

Font Name Enables you tomodify the font used for text in the selected element. You cannot
change the font forAlternate Rows orSelected Row elements.

Note:When testing in a Unicode environment, youmust select a Unicode-
compatible font. Otherwise, elements in your action or component may not
be correctly displayed in the Keyword View. However, the action or
component will still run in the sameway, regardless of the font you choose.

Size Enables you tomodify the font size used for text in the selected element. You
cannot change the font size forAlternate Rows orSelected Row elements.

Style Enables you tomodify the font style used for text in the selected element. You
can select Regular, Bold, Italic, orUnderline font styles. You cannot change
the font style forAlternate Rows orSelected Row elements.

Foreground Enables you tomodify the text color for the selected element. You cannot change
the foreground color forAlternate Rows.

Background Enables you tomodify the row color for the selected element.

Foreground
for read-
only

Enables you tomodify the text color for rows that are read-only. This option
cannot be changed forAlternate Rows.

Reset all Resets all Fonts and Colors tab options to the default settings.
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Select Test Object Dialog Box
Relevant for: GUI actions and components

This dialog box displays the object repository tree and enables you to:

l Select an object in the object repository tree for your step.

l Select an object from your application for your step. This adds a test object to the local object
repository.

l Select a related object to use in a visual relation identifier. This adds a test object to the same
object repository as the test object you want to identify. For details on visual relation identifiers,
see "Visual Relation Identifiers" on page 1209.

l For actions:Enter a .Object statement for the selected test object in your test.

The following image shows an example of this dialog box when opened from the Keyword View for
an action or from the Visual Relation Identifier dialog box. Similar options are available for
components or when opened from the StepGenerator.
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To access Use one of the following:

l In the Item cell of the Keyword View, click the arrow button to display the Item
list and then select Object from repository.

l In the "Visual Relation Identifier Dialog Box" (described on page 1251), click
theAdd button.

l For actions and scripted components only: In the "Step Generator Dialog
Box" (described on page 983), select Test Objects from theCategory box list
and click theSelect Object button .
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Important
information

l You can select any object in the object repository tree for your new step.
For more information on the object repository, see "Managing Test Objects in
Object Repositories" on page 1198.

l If the object that you want to use in the new step is not in the object repository,
you can select an object in your application by using the pointing hand. This
adds it to the local object repository.

l If you select an object in your application that is not in an associated shared
object repository, a test object is added to the local object repository when you
insert the new step. After you add a new test object to the local object
repository, it is recommended to rename it, if its name does not clearly indicate
its use. For example, youmay want to rename a test object namedEdit (that is
used for entering a username) toUserName. This will enable other users to
select the appropriate test object when adding steps using test objects located
in this shared object repository.

l After you add the required objects to the local object repository, you can use
theObject Repository Merge Tool to update the associated shared object
repository andmake the new test objects available to other actions and
components. For details, see "When toMerge SharedObject Repositories" on
page 1352.

l If you are adding a container test object, it is also recommended to specify its
context, for example, if you are adding a confirmationmessage box from a
Login page, youmay want to name it Login > Confirm. For details, see
"Renaming Test Objects " on page 1206.

l For components:ALM users can select only objects that are stored in the
shared object repositories (in the component's application area).

Relevant
tasks

l "How to Insert Steps Using the StepGenerator" on page 978

l "How to Select an Item for Your Step " on page 926

See also l "Managing Test Objects in Object Repositories" on page 1198

l "Native Properties andOperations" on page 1008

l "Visual Relation Identifier Dialog Box" on page 1251
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

Find Next. Searches from the currently selected node, displaying all objects that
match your criteria. The first object in the list that matches your criteria is
highlighted.

You can click the Find Next button to navigate through all the objects that match
your search criteria. The search continues to the end of the tree, then wraps to the
beginning of the tree, and continues.

Tip: Press F3 to find the next object that matches your search criteria, or
SHIFT+F3 to find the previous match.

<Pointing hand>. Enables you to select an object from your application and add it
to the shared object repository so that you can use it in your action or component
steps. This is useful if the shared object repository does not include the test object
that you need for a particular step.

Click on the required object in your application to add it to the shared object
repository tree. In some environments, as youmove the pointer over your
application, the available test objects are highlighted. For details, see "Tips for
Using the Pointing Hand" on page 1196.

Name The full or partial name of the object to find.

This option is useful if the object repository is very large. If you leave the box
empty, all objects that match the selected object Type are displayed.

Example:Enter p to search for all object names containing the letter p.

Type The type of object for which to search. Specify a type or select <All> to search for
the object in all the object types.

The object types in this list are a generic grouping of objects according to the
general object characteristics. For example, the List type contains list and list view
objects, as well as combo boxes; the Table type contains both tables and grids;
and theMiscellaneous type contains a variety of other objects, such as
WebElement andWinObject.

Example:Suppose you want to add a password object that you know is an
Edit box. You can search all theEdit type objects for one called password, or
even one containing the letter p.

<object
repository
tree>

List of objects in the object repositories associated with the current action or
component. You can select a test object from this tree to insert into a step.
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UI
Elements Description

Insert test
object

Inserts the selected test object in the step.

Note: This option is available only when this dialog box is opened from the
Keyword View for an action or from the Visual Relation Identifier dialog box.

Insert
run-time
object

Inserts anObject statement step for the selected test object. (Relevant for any
object that supports the .Object property.)

Note: This option is available only when this dialog box is opened from the
Keyword View for an action or from the Visual Relation Identifier dialog box.

Insert Comment Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to insert a new comment for a step.

To access In the Keyword View, do one of the following:

l Select Design > Add Comment.

l Right-click any step that does not yet contain a comment and select
Insert Step > Comment (actions) or Insert Comment (keyword
components).
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Important
information for
tests and scripted
components

l If theComment column is not visible, right-click any column header
and select Comment.

l You can add comments directly in the Keyword View by selecting a
step and typing the comment in theComment column.

l You canmodify comments at any time directly in the Keyword View,
or by using the Comment Properties dialog box.

l To add a comment in the Editor, type an apostrophe (') and then type
your comment. You can add a comment at the end of a line or at the
beginning of a separate line.

l If you want to add the same comment to every action that you create,
you can add the comment to an action template. For details, see
"How toManage the Structure of Your GUI Test" on page 888.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<comment text area> The comment text to enter.

Comment Properties Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you tomodify the text of a selected comment.

To access In the Keyword View, right-click any step containing a comment and select
Comment Properties.

Important
information

l If theComment column is not visible, right-click any column header and
select Comment.

l In the Keyword View, you also canmodify the comment text directly in
theComment column.

l In the Editor, you canmanually edit the text to overwrite any existing
comment.
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<comment text area> The comment text to modify.

Insert Report Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to define amessage that UFT sends to your run results.

To access In the Keyword View:

l Select a step and select Edit > Report Step.

l Right-click a step and select Insert Step > Report.

Important Information When you add a report step, aReporter.ReportEvent step is inserted.

See also "Message Statements" on page 975
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User interface elements are described below:

UI
Elements Description

Status The status that will result from this step from theStatus list:

l Passed. Causes this step to pass. Sends the specifiedmessage to the report.

l Failed. Causes this step (and therefore the test itself) to fail. Sends the specified
message to the report.

l Done. Sends amessage to the report without affecting the pass/fail status of the
step.

l Warning. Sends a warning status for the step, but does not cause the test to
stop running, and does not affect its pass/fail status.

Name The name for the step, for example, Password edit box. This name is displayed in
the Run Results tree as the node label for this step.

Details The description of this step. For example, Password edit box does not exist. The
description is displayed in the upper-right pane of the Run Results Viewer.

Image The name of an image to include in the run results with this step. The image is
displayed in the bottom-right pane of the Run Results Viewer. The image can be any
of the supported file types, such as BMP, JPEG, GIF, TIF, or PNG.

Note:

l You cannot specify an image stored in ALM.

l Including large images in the run results may impact performance.

l If an image is specified as a relative path, UFT will first search the Results
folder for the image and then the search paths specified in the Folders pane
of the Options dialog box (Tools > Options > GUI Testing tab > Folders
node).

Password Encoder Tool
Relevant for: GUI actions and components

This tool enables you to encode passwords so that you can use the resulting strings in the following
ways:

For tests:method arguments or data table parameter values (enabling you to place secure values
into the data table)

For components: operation arguments
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For example, yourWeb site may include a form in which the user must supply a password. You
may want to test how your site responds to different passwords, but you also want to ensure the
integrity of the passwords.

To access From theWindowsmenu, select Start > Programs > HP Software >
HP Unified Functional Testing > Tools > Password Encoder.

Note: For details on accessing UFT and UFT tools and files in
Windows 8, see "Accessing UFT inWindows 8Operating Systems"
on page 75.

Important
information for
Business
Process Testing

Use only if you are working with Quality Center.

If you are working with ALM, youmust encode passwords in ALM.
Otherwise, during a run session, encoded strings are treated as plain text.
For details on encoding, see theHP Business Process Testing User Guide.

See also For tests: You can also encrypt strings in Data pane cells using the
Encrypt option in the Datamenu. For details, see "DataMenu (GUI Testing
Data Pane)" on page 243.

User interface elements are described below:

UI
Elements Description

Password The password to encrypt.

Encoded
string

The encrypted string that is generated when you click Generate.

Generate Encrypts the string you entered in thePassword box.

Copy Copies the encrypted password to the Clipboard. You can then paste it as value for
amethod or operation argument, or you can insert it as a secure value in the Data
pane (tests only).
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Troubleshooting and Limitations - Keyword View
Relevant for: GUI actions and components

This section describes troubleshooting and limitations for the Keyword View.

If you use theObject property in a step in the Keyword View, it may take a long time for UFT to
retrieve the object information from the application. This may affect UFT's response time when you
open and select from the various drop-down lists in the step.

Workaround: Use the Editor when working with theObject property.
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Chapter 35: Generated Programming Operations
Relevant for: GUI tests and scripted GUI components

This chapter includes:

Concepts 969

Programming Statements Overview 969

Test Synchronization 973

Message Statements 975

Tasks 978

How to Insert Steps Using the StepGenerator 978

How to GenerateWith Statements for Your Test 978

To generateWith statements for existing actions: 979

Reference 982

Add Synchronization Point Dialog Box 982

StepGenerator Dialog Box 983

Storage Location Options Dialog Box 991
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Concepts

Programming Statements Overview
Relevant for: GUI tests and scripted GUI components

When you design tests, you usually begin by adding steps that represent the operations an end-
user would perform as part of the business process you want to test. Then, to increase the power
and flexibility of your test, you can add steps (programming statements) that contain programming
logic to the basic framework.

Programming statements can contain:

l Test object operations. These aremethods and properties defined by UFT. They can be
operations that a user can perform on an object, operations that can retrieve or set information,
or operations that perform operations triggered by an event.

l Native operations. These aremethods and properties defined within the object you are testing,
and therefore are retrieved from the run-time object in the application.

l VBScript programming commands. These affect the way the test runs, such as Conditional
Statements and Synchronization Points. These are often used to control the logical flow of a
test.

l Comments. Use comments to explain sections of your tests to improve readability and tomake
them easier to update. A comment is an explanatory remark in a program, and does not get
processed when UFT runs. For details, see "Insert Comment Dialog Box" on page 962.

This section also includes:

Step Generator 969

Conditional Statements 970

With Statements 972

Step Generator

Relevant for: GUI tests and scripted GUI components

The StepGenerator enables you to add steps by selecting from a range of context-sensitive options
and entering the required values, so that you do not need tomemorize syntax or to be proficient in
high-level VBScript. You can use the StepGenerator from the Keyword View and also from the
Editor.

In the "Step Generator Dialog Box" (described on page 983) you can define steps that use:
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l Test object operations (tests only).

l Utility object operations.

l Calls to library functions (tests only), VBScript functions, and internal script functions.

For example, you can add a step that checks that an object exists, or that stores the returned value
of amethod as an output value or as part of a conditional statement. You can parameterize any of
the values in your step.

When you insert a new step using the StepGenerator, it is added to your test after the selected
step, and the new step is selected. For details on the hierarchy of steps and objects and the
positioning of new steps, see "Keyword View User Interface" on page 942.

For more details, see "Step Generator Dialog Box" on page 983.

Conditional Statements

Relevant for: GUI tests and scripted GUI components

You can control the flow of your test with conditional statements. Using conditional If...Then...Else
statements, you can incorporate decision-making into your tests.

The If...Then...Else statement is used to evaluate whether a condition is true or false and,
depending on the result, to specify one or more statements to run. Usually the condition is an
expression that uses a comparison operator to compare one value or variable with another. The
following comparison operators are available: less than <, less than or equal to <=, greater than >,
greater than or equal to >=, not equal <>, and equal =.

Your If...Then...Else statement can be nested to as many levels as you need.

The statement has the following syntax:

If condition Then statements [Elseelsestatements] End If

Or, you can use the block form syntax:

If condition Then
[statements]

[ElseIf condition-n Then
[elseifstatements] . . .

[Else
[elsestatements]

End If
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Formore details:

l On inserting conditional statements using the StepGenerator, see "Step Generator Dialog Box"
on page 983.

l Onworking with conditional steps in the Editor, see "Comments, Control-Flow, andOther
VBScript Statements " on page 1006, and the VBScript documentation (select Help >
HP Unified Functional Testing Help > VBScript Reference).

l Onworking with conditional steps in the Keyword View, see "Conditional and Loop Statements
in the Keyword View" on page 923.

Example:
The following example checks whether a valid order number is entered in the Order No. box.

To do this, UFT activates the OpenOrder dialog box (brings it into focus), selects the Order
No. check box, and opens a box in which the user inserts a value—the relevant order number—
and clicks OK. The first conditional statement instructs UFT to verify that the value entered by
the user is greater than zero. If it is not greater than zero, amessage box is displayed, stating
that the value entered is invalid. When the user clicks OK to close themessage box, the run
session ends.

Otherwise, if the value entered is greater than zero, UFT inserts the above value in the Order
No. box.

The next If statement instructs UFT to check whether the order number exists in the
application and to send a report to the Run Results indicating that the step passed or failed. If
the step failed because the order number was invalid, the Flight Reservations error message
opens, and UFT clicks OK to close this message box before ending the run session.

Note: Many of the lines in the example below are comments.

For example:

`Set the focus on (activate) the OpenOrder dialog box
Window("Flight Reservation").Dialog("Open Order").Activate
`Insert a check mark in the Order No. check box
Window("Flight Reservation").Dialog("Open Order").WinCheckBox("Order No.").Set "ON"

Insert an order number in the displayed box and save the value as "OrderNo" for use later in the
script.
If the value is less than or equal to 0, generate amessagebox.
(If the value is illegal and amessage box is generated, end the run session when the user click
s OK.)
OrderNo = InputBox("Enter Order Number")
If OrderNo <= 0 Then
Msgbox "You entered an invalid order number."
ExitAction
End If
`Insert the saved order number value in the Order No. box
Window("Flight Reservation").Dialog("Open Order").WinEdit("OrderNumberEdit").Set OrderNo
`Click OK to close the OpenOrder dialog box
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Window("Flight Reservation").Dialog("Open Order").WinButton("OK").Click
`Check if an error message opens and send a report to the run results
If Window("Flight Reservation").Dialog("Open Order").Dialog("FlightReservations").Exist Then
Reporter.ReportEvent micFail, "Check that the value of the order number is legal", "The order n
umber does not exist."
Window("Flight Reservation").Dialog("Open Order").Dialog("FlightReservations").WinButton("O
K").Click
Else
Reporter.ReportEvent micPass, "Check that the value of the order number is legal", "The order n
umber exists."
End If

With Statements

Relevant for: GUI tests and scripted GUI components

With statements make your script (in the Editor) more concise and easier to read by grouping
consecutive statements with the same parent hierarchy.

In addition, usingWith statements might help your script run faster. When running aWith
statement, UFT identifies the object in the application before running the first statement, but does
not re-identify it before running each statement.

On the other hand, this can affect the running of your test if the object referenced by theWith
statement is refreshed, redrawn, or changed in someway in the application while running theWith
statement. To instruct UFT to re-identify the object in the application before running the next
statement, add a statement that calls theRefreshObject test object operation. For details on the
RefreshObject operation, see theHP UFT Object Model Reference for GUI Testing.

TheWith statement has the following syntax.

With object
statements

End With

Item Description

object An object or a function that returns an object.

statements One ormore statements to be performed on an object.

Example

For example, you could replace this script:

Window("Flight Reservation").WinComboBox("Fly From:").Select "London"
Window("Flight Reservation").WinComboBox("Fly To:").Select "Los Angeles"
Window("Flight Reservation").WinButton("FLIGHT").Click
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Window("Flight Reservation").Dialog("Flights Table").WinList("From").Select "19097 LON "
Window("Flight Reservation").Dialog("Flights Table").WinButton("OK").Click

with the following:

With Window("Flight Reservation")
.WinComboBox("Fly From:").Select "London"
.WinComboBox("Fly To:").Select "Los Angeles"
.WinButton("FLIGHT").Click
With .Dialog("Flights Table")

.WinList("From").Select "19097 LON "

.WinButton("OK").Click
End With 'Dialog("Flights Table")

End With 'Window("Flight Reservation")

You can instruct UFT to automatically generateWith statements when you record a test or to
generateWith statements for any existing action. You can also removeWith statements from an
action.

UsingWith statements in your test has no effect on the run session itself, only on the way your test
appears in the Editor. GeneratingWith statements for your test does not affect the Keyword View
in any way.

For more details, see "How to GenerateWith Statements for Your Test" on page 978.

Test Synchronization
Relevant for: GUI tests and scripted GUI components

When you run a test, your applicationmay not always respond with the same speed. For example,
it might take a few seconds:

l for a progress bar to reach 100%

l for a status message to appear

l for a button to become enabled

l for a window or pop-upmessage to open

You can handle these anticipated timing problems by synchronizing your test to ensure that UFT
waits until your application is ready before performing a certain step.

There are several options that you can use to synchronize your test:

l You can insert a synchronization point, which instructs UFT to pause the test until an object
property achieves the value you specify. When you insert a synchronization point into your
action, aWaitProperty statement is added to the action.

l You can insert Exist orWait statements that instruct UFT to wait until an object exists or to wait
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a specified amount of time before continuing the test.

l You canmodify the default amount of time that UFT waits for aWeb page to load.

l Whenworking with tests, you can increase the default timeout settings for a test to instruct UFT
to allow more time for objects to appear.

This section also includes:

Synchronization Points 974

Exist andWait Statements 974

Timeout Values Modification 975

Synchronization Points

Relevant for: GUI tests and scripted GUI components

If you do not want UFT to perform a step or checkpoint until an object in your application achieves a
certain status, you should insert a synchronization point to instruct UFT to pause the test until the
object property achieves the value you specify (or until a specified timeout is exceeded).

For example, suppose you record a test on a flight reservation application. You insert an order, and
then you want to modify the order. When you click the Insert Order button, a progress bar is
displayed and all other buttons are disabled until the progress bar reaches 100%. Once the progress
bar reaches 100%, you record a click on theUpdate Order button.

Without a synchronization point, UFT may try to click theUpdate Order button too soon during a
test run (if the progress bar takes longer than the test's object synchronization timeout), and the test
will fail.

You can insert a synchronization point that instructs UFT to wait until theUpdate Order button's
enabled property equals 1. For details, see "Add Synchronization Point Dialog Box" on page 982.

Tip: UFTmust be able to identify the specified object to perform a synchronization point. To
instruct UFT to wait for an object to open or appear, use anExist orWait statement. For
details, see "Exist andWait Statements" below.

Exist and Wait Statements

Relevant for: GUI tests and scripted GUI components

You can enterExist and/orWait statements to instruct UFT to wait for a window to open or an
object to appear. Exist statements return a boolean value indicating whether or not an object
currently exists. Wait statements instruct UFT to wait a specified amount of time before proceeding
to the next step. You can combine these statements within a loop to instruct UFT to wait until the
object exists before continuing with the test.
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For example, the following statements instruct UFT to wait up to 20 seconds for the Flights Table
dialog box to open.

blnDone=Window("Flight Reservation").Dialog("Flights Table").Exist
counter=1
While Not blnDone

Wait (2)
blnDone=Window("Flight Reservation").Dialog("Flights Table").Exist
counter=counter+1
If counter=10 then

blnDone=True
End if

Wend

Formore details onWhile, Exist, andWait statements, see theHP UFT Object Model Reference
for GUI Testing.

Timeout Values Modification

Relevant for: GUI tests and scripted GUI components

If you find that, in general, the amount of time UFT waits for objects to appear or for a browser to
navigate to a specified page is insufficient, you can increase the default object synchronization
timeout values for your test and the browser navigation timeout values for your test.

Alternatively, if you insert synchronization points andExist and/orWait statements for the specific
areas in your test where you want UFT to wait a longer time for an event to occur, youmay want to
decrease the default timeouts for the rest of your test.

l Whenworking with tests, to modify themaximum amount of time that UFT waits for an object to
appear, change theObject Synchronization Timeout in the File > Settings > Run pane. For
details, see "Run Pane (Test Settings Dialog Box)" on page 601.

l Tomodify the amount of time that UFT waits for aWeb page to load, change theBrowser
Navigation Timeout in the File > Settings > Web pane. For details, see theHP Unified
Functional Testing Add-ins Guide.

Message Statements
Relevant for: GUI tests and scripted GUI components

You can generatemessages in your test that are displayed in the Run Results Viewer. You can
also choose to display messages on screen while running your test.

This section includes:

l "SendingMessages to the Run Results" on the next page

l "DisplayingMessages During the Run Session" on page 977
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Sending Messages to the Run Results
You can send the following types of messages to the run results:

l Messages specific to a run session. You can add notes to the run results to provide additional
information about the test or component run. For example, you can specify the application
version tested, the operating system used, languages, and so on.

In the Run Results Viewer, this information is displayed in theExecutive Summary page. For
details, see the Result Details Pane (described in theHP RunResults Viewer User Guide).

You add a note by inserting aReporter.ReportNote step in your test or component.

Example:

Reporter.ReportNote "This test was run from 12.34.56.89 using a wireless
connection."

For details, see theUtility Objects section of theHP UFT Object Model Reference for GUI
Testing.

l Messages specific to a step. You can define amessage that is sent to your run results. For
example, suppose you want to check that a password edit box exists in theMercury Tours site.
If the edit box exists, then a password is entered. Otherwise, amessage is sent to the run
results indicating that the object is absent.

You sendmessages to the run results using aReporter.ReportEvent step.

Example:

Reporter.ReportEvent micFail, "Password edit box", "Password edit box does not
exist"

In this example,micFail indicates the status of the report (failed), Password edit box is the report
name, andPassword edit box does not exist is the report message.

List of Supported Statuses:

n micPassed. Causes this step to pass. Sends the specifiedmessage to the report.

n micFailed. Causes this step (and therefore the test itself) to fail. Sends the specified
message to the report.

n micDone. Sends amessage to the report without affecting the pass/fail status of the step.

n micWarning. Sends a warning status for the step, but does not cause the test to stop
running, and does not affect its pass/fail status.
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Displaying Messages During the Run Session
In addition to sendingmessages to the Run Results, you can generatemessages in the following
ways:

l Use theMessageBoxVBScript function in your test to display information during the run
session. The run session pauses until themessage box is closed. For more details, see the
VBScript documentation from theUFTHelpmenu (Help > HP Unified Functional Testing
Help > VBScript Reference).

l Use thePrintUtility statement in your test to display information in the Output pane while still
continuing the run session. For example, the following example iterates all the items in the
Flight Table dialog (in the sample Flight application) and uses thePrintUtility statement to print
the content of each item to the Output pane.

Set FlightsList =Window("Flight Reservation").Dialog("Flights Table").
WinList("From")

For i = 1 to FlightsList.GetItemsCount
Print FlightsList.GetItem(i - 1)

Next

For details on using the Output pane, see "Output Pane User Interface" on page 381.
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Tasks

How to Insert Steps Using the Step Generator
Relevant for: GUI tests and scripted GUI components

This task describes how to insert steps using the StepGenerator.

1. Prerequisites
Select where in your test the new step should be inserted.

2. Open the Step Generator dialog box
Open the StepGenerator from one of the following locations:

n Keyword View

n Editor

n Active Screen

For details, see "Step Generator Dialog Box" on page 983.

3. Define the category, type and operations for the step
First select the category for the step operation (test object, Utility object or function) and the
required object or the function library source (for example, built-in or local script functions). You
can then select the appropriate operation (method, property, or function) and define the
arguments and return values, parameterizing them if required.

4. View the step documentation or syntax
In the StepGenerator, view the step documentation or statement syntax and add your new
step or statement to your test or function library.

5. Results
The StepGenerator inserts a step with the correct syntax into your test. You can continue to
add further steps at the same location without closing the StepGenerator.

How to Generate With Statements for Your Test
Relevant for: GUI tests and scripted GUI components
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This task describes the steps to generate andmanageWith statements in your test.

This task includes the following steps:

l "Instruct UFT to generateWith statements while recording" below

l "GenerateWith statements for existing actions in the Editor" below

l "RemoveWith statements from an action in the Editor" on the next page

Instruct UFT to generate With statements while recording

1. In theGeneral pane of the GUI Testing tab of the Options dialog box (Tools > Options > GUI
Testing tab > General tab), select Automatically generate "With" statements after
recording option. For details, see "General Pane (Options Dialog Box > GUI Testing Tab)" on
page 536.

2. In theGenerate "With" statements for __ or more objects box, enter theminimum number
of consecutive, identical objects for which you want to apply theWith statement. The default
is 2.

For example, if you only want to generate aWith statement when you have three or more
consecutive statements based on the same object, enter 3.

3. Begin recording your test. While recording, statements are recorded normally. When you stop
recording, the statements in all actions recorded during the current recording session are
automatically converted to theWith format.

Generate With statements for existing actions in the Editor
You can instruct UFT to generateWith statements for any action displayed in the Editor, and to
enable the statement completion functionality within existingWith statements.

To generate With statements for existing actions:
1. In theGeneral pane of the GUI Testing tab of the Options dialog box (Tools > Options > GUI

Testing tab > General tab), select theAutomatically generate "With" statements after
recording option. For details, see "General Pane (Options Dialog Box > GUI Testing Tab)" on
page 536.

2. Confirm that the proper number is set for theGenerate "With" statements for __ or more
objects. The default is 2.

3. Display the action for which you want to generateWith statements.
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4. From the Editor, select Edit > Format > Apply "With" to Script. The "With" Generation
Results window opens.

EachWith statement contains only one object.

To confirm the generated results, click OK. TheWith statements are applied to the action.

Tip: If you type aWith statement (as opposed to creating it using the procedure described
above), select Edit > Format > Apply "With" to Script to enable statement completion
within theWith statement.

Remove With statements from an action in the Editor
You can remove all theWith statements in an action displayed in the Editor.
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To remove With statements from an action:

1. Display the action for which you want to removeWith statements.

2. In the Editor, select Edit > Format > Remove "With" Statements. The Remove "With"
Results window opens.

3. To confirm the results, click OK. TheWith statements are replaced with the standard
statement format.
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Reference

Add Synchronization Point Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to insert aWaitProperty statement to synchronize your test.

To access 1. Ensure that a GUI test, action, or component is in focus in the document
pane.

2. Start a recording session.

3. Display the screen or page in your application that contains the object for
which you want to insert a synchronization point.

4. In UFT, select Design > Synchronization Point.

Important
information

l When you insert a synchronization point, the pointer changes to a pointing
hand. For details on using the pointing hand, see "Tips for Using the Pointing
Hand" on page 1196.

l For details on theWaitPropertymethod, see theHP UFT Object Model
Reference for GUI Testing.

See also "Test Synchronization" on page 973

User interface elements are described below:

UI Elements Description

Class The test object class of the selected object.

Test object
name

The name of the selected object.
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UI Elements Description

Property
name

The list of the identification properties associated with the object class. Select
the property you want to use for the synchronization point.

Property
value

Enables you to specify the property value for which UFT should wait before
continuing to the next step in the test.

The property values that the object has at the time that you insert the
synchronization point do not impact the specified synchronization point.

Timeout (in
milliseconds)

The time (in milliseconds) that you want UFT to wait before continuing to the
next step, if the specified property value was not achieved.

View Example

After you insert a synchronization point for the Flight Confirmation button, it may look
something like this:

In the Editor, this is displayed as:

Browser("Welcome: Mercury Tours").Page("Flight Confirmation: Mercury").Sync

Browser("Welcome: Mercury Tours").Page("Flight Confirmation: Mercury").WebElement("Flight
Confirmation #").WaitProperty "visible",

true, 10000

Step Generator Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to add steps that perform operations, using test object methods (for
tests only), Utility object methods, or function calls.
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To access This dialog box can be accessed from the following locations:

l Keyword View

l Editor

l Function Library

l Active Screen

To open the dialog box, do the following:

1. Ensure that a GUI test or action is in focus in the document pane.

2. Select the location to insert the step, and do one of the following:

n Right-click and select Insert Step > Step Generator, or Insert Step >
Step Generator.

n Press F7 (not available for Active Screen).

n Select Design > Step Generator.

Important
information

l Although the StepGenerator shows information regarding the currently
selected step or function, selections that youmake in the StepGenerator add a
new step or function to your test; they do not modify the existing step or
function.

l In the StepGenerator, if you add an operation that returns an object, and the
assignment in the test is missing aSet statement, the run session will fail.

Relevant
tasks

"How to Insert Steps Using the StepGenerator" on page 978

General User Interface Elements

UI Elements Description

Category The type of step to add. The following options are available:

l Test Objects. Enables you to select a test object and operation for the step
(for tests only). For details, see "Test Object Category" on page 988.

l Utility Objects. Enables you to select a Utility object and operation for the
step. For details, see "Utility Object Category" on page 990.

l Functions. Enables you to select a function for the step from the available
library functions (tests only), VBScript functions, and internal script
functions. For details, see "Function Category" on page 991.
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UI Elements Description

Object The list of available objects. The list varies according to the type of object you
select in theCategory list box.

Note: Available when the selectedCategory value is Test Objects or
Utility Objects.

Library The type of functions to display in theOperation list. Possible values:

l All. Displays all functions relevant in the scope from which you opened the
StepGenerator.

l Library Functions. Displays all functions defined in functions libraries
associated with the action's test. (Available only when opening the Step
Generator from an action.)

l Built-in functions. Displays all of the functions that are part of the
VBScript language.

l Local script functions. Displays all of the functions defined in the action
or function library from which you opened the StepGenerator.

Note: Available when the selectedCategory value is Functions.

Operation For objects: The list of operations available for the selected object type in
alphabetical order.

For functions: The list of functions available from the selected library type in
alphabetical order.

Arguments The list of arguments for the operation, if applicable to the selected operation.

Arguments >
Name

The name of the argument for the selected operation.

Arguments >
Type

The type of the argument value for the selected operation.
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UI Elements Description

Arguments >
Value

The value for the argument for the selected operation. Specify the argument
value according to the following rules:

l Mandatory arguments. If the name of the argument is followed by a red
asterisk (*), youmust specify a value for the argument. You cannot insert
the step or view the step documentation if the values have not been defined
for all mandatory arguments.

l Optional arguments. If the name of the argument is not followed by a red
asterisk (*), you can specify a value for the argument or leave the cell
blank. If you do not specify a value, UFT uses the default value for the
argument. (You can view the default value by moving the pointer over the
cell).

l Required arguments. If you specify a value for an optional argument, then
youmust also specify the values for any optional arguments that are listed
before this argument. If you do not specify these values, UFT uses the
default values for all required arguments. You can see the default value for
each argument in a tooltip, by moving the pointer over theValue column.

l Parameterized arguments. You can use a parameter for any argument

value by clicking the parameterization button . For details, see "Value
Configuration Options Dialog Box" on page 1579.

l Predefined constants. If an argument has a predefined list of values, UFT
provides a drop-down list of possible values. If a list of values is provided,
you cannot manually type a value in this box.

Return Value The location for storing the return values of the operation, if applicable. For
details on storing options, see "Storage Location Options Dialog Box" on page
991.
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UI Elements Description

Step
documentation
(Keyword
View)

Summary information on the current step. The following options are available:

l For the Test Object orUtility Object categories, theStep documentation
box describes the operation performed by the step. When the step is
inserted into your test, this description is displayed in theDocumentation
column in the Keyword View.

Note: If any mandatory and required argument values have not been
defined for the operation, theStep documentation box displays a
warningmessage.

l For Functions category, step documentation is available for user-defined
functions, if you provided this information when defining them. For details,
see "How to Create andWork with a User-Defined Function" on page
1048.

Generated step
(Editor /
Function
Library)

The defined statement for the step. If all themandatory and required argument
values have not been defined for the operation, the names of the undefined
arguments are highlighted in bold text. If you attempt to insert the step, an
error message is displayed.

Example:

Insert another
step

Enables you to insert the current step and continue adding steps at the same
location. TheOK button changes to Insert.

Test Object Category
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Important
information

l You can select the object for the new step in the context of the currently
selected step in your test. Alternatively, you can select any object from the
object repository or from your application.

l After you select the operation for your test object, you can define the relevant
argument values.

l If you click theOperation Help button when a native operation is selected, the
HP UFT Object Model Reference for GUI Testing opens for the selected test
object. For details on specific native operations, see the documentation for the
environment or application you are testing.

User interface elements are described below:

UI
Elements Description

Object All the objects in the object repository that are at the same hierarchical level and
location as the currently selected step.

Note: The objects are listed by name in alphabetical order.

Select Object. Enables you to select an object from the object repository or from
your application. For details, see "Select Test Object Dialog Box" on page 958.

Test
object
operations

The UFT operations that can be performed on a test object.

Native
operations

The operations of the object in your application as defined by the object creator.

Note:

l If UFT cannot retrieve native operations for the selected object, theNative
operations option is not available.

l If you select a native operation, the StepGenerator inserts a step using
.Object syntax. For details on using theObject property, see "Native
Properties andOperations" on page 1008.
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Utility Object Category
This option enables you to specify a utility object to insert to your test.

Important
information

For details on Utility objects, see the Utility Objects section of theHP UFT
Object Model Reference for GUI Testing.

User interface elements are described below:

UI
Elements Description

Object The list of Utility objects that are available.

Note: The image above displays the list of Utility objects that are available
when you open the StepGenerator from the Keyword View. When you open the
StepGenerator from the Editor, the list includes a number of additional Utility
objects. If you have one or more add-ins loaded, the list may include additional
Utility objects for those add-ins.
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Function Category

Important
information

For detailed information on a selected built-in VBScript function, seeMicrosoft's
VBScript Reference or theHP UFT Object Model Reference for GUI Testing.

User interface elements are described below:

UI
Elements Description

Library The list of function types. The following options are available:

l All. Enables you to select a function from all the available functions and types.

l Library functions. Enables you to select a function from any function library
associated with your test (for tests only). For details on defining and using
associated function libraries, see "Associated Function Libraries" on page 1031.

l Built-in functions. Enables you to select any standard VBScript function
supported by UFT. For details on working with VBScript, you can open the
VBScript documentation from the UFTHelpmenu (Help > HP Unified
Functional Testing Help > VBScript Reference).

l Local script functions. Enables you to select any local function defined directly
in the current action or function library.

Storage Location Options Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to specify how and where to store a return value for an operation that
you have selected in the StepGenerator dialog box. This dialog box also enables you to specify
how and where to store the value for an output parameter for an action.
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To
access

l In the "Step Generator Dialog Box", make sure theReturn value check box is
selected, click the displayed return value and then the output storage button .

l In the "Action Call Properties Dialog Box" (described on page 895), select an
output parameter in the Parameter Values tab and click the output storage button

in theStore in column.

Relevant
tasks

"How to Create or Modify anOutput Value Step" on page 1494

See also "Default Output Definitions (tests only)" on page 1491

User interface elements are described below:

UI
Elements Description

Variable Stores the value in a run-time variable for the duration of the run session. You can
accept the default name assigned to the variable (if any) or enter a different variable
name.

Output
Type

Stores the value in an output parameter of the specified type.

User Guide
Chapter 35: Generated ProgrammingOperations

HP Unified Functional Testing (12.00) Page 992 of 2274



Default Output Definitions for Action Parameter Values
When you select Output Type or an output action parameter value for a nested action:

l If at least one output action parameter is defined in the action calling the nested action, the
default output type is Test/action parameter and the default output name is the first output
parameter displayed in the "Action Properties Dialog Box" (described on page 900) of the calling
action.

l If no output action parameters are defined in the calling action, the default output type is Data
Table, and UFT creates a new Data pane output name based on the selected value in the Global
sheet of the Data pane.

When you select Output Type for an output action parameter value for a top-level action:

l If at least one output action parameter is defined in the test, the default output type is
Test/action parameter and the default output name is the first output parameter displayed in the
Test Properties dialog box.

l If no output action parameters are defined in the test, the default output type is Data Table, and
UFT creates a new Data pane output name based on the selected value. The value is created in
the Global sheet of the Data pane.
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Chapter 36: Programming in GUI Testing
Documents in the Editor

Relevant for: GUI tests, scripted GUI components, and function libraries

This chapter includes:
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Concepts

Programming in GUI Testing Documents in the Editor -
Overview

Relevant for: GUI actions, scripted GUI components, and function libraries

GUI test actions and scripted GUI components are composed of statements coded in theMicrosoft
VBScript programming language. The Editor provides an alternative to the Keyword View for testers
who are familiar with VBScript. In the Editor, you can view an action or scripted component in
VBScript.

When working with GUI tests, and both scripted and keyword GUI components, you can also
create and work with function libraries in UFT using VBScript. This enables you to increase the
power and flexibility of your tests and components.

If you are familiar with VBScript, you can add and update statements and enhance your tests,
components, and function libraries with programming. This enables you to increase a test or
component's power and flexibility.

This chapter provides a brief introduction to VBScript, and shows you how to enhance your actions,
scripted components, and function libraries using a few simple programming techniques.

Note: For details about using the text and code editor abilities available in the Editor, see
"Editing Text and Code Documents" on page 305.

To learn about working with VBScript, you can view the VBScript documentation available from the
UFTHelpmenu (Help > HP Unified Functional Testing Help > VBScript Reference).

You can add statements that perform operations on objects or retrieve information from your
application. For example, you can add a step that checks that an object exists, or you can retrieve
the return value of an operation.

You can add steps to your action, component, or function library either manually or using the Step
Generator. For details on using the StepGenerator, see "How to Insert Steps Using the Step
Generator" on page 978.

Programmatic Descriptions
Relevant for: GUI actions, scripted GUI components, and function libraries

WhenUFT learns an object in your application, it adds the appropriate test object to the object
repository. After the object exists in the object repository, you can add statements in the Editor to
perform additional operations on that object. To add these statements, you usually enter the name
(not case sensitive) of each of the objects in the object's hierarchy as the object description, and
then add the appropriate operation.

Because each object in the object repository has a unique name, the object name is all you need to
specify. During the run session, UFT finds the object in the object repository based on its name and
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parent objects, and uses the stored test object description for that test object to identify the object
in your application.

You can also instruct UFT to perform operations on objects without referring to the object repository
or to the object's name. To do this, you provide UFT with a list of properties and values that UFT
can use to identify the object or objects on which you want to perform an operation. You can also
describe an Insight test object, by providing a file containing an image of the control as a description
property.

Such a programmatic description can be very useful if you want to perform an operation on an
object that is not stored in the object repository. You can also use programmatic descriptions to
perform the same operation on several objects with certain identical properties, or to perform an
operation on an object whose properties match a description that you determine dynamically during
the run session.

In the Run Results, square brackets around a test object name indicate that the test object
was created dynamically during the run session using a programmatic description or the
ChildObjectsmethod.

Use-case scenario:

Suppose you are testing aWeb site that generates a list of potential employers based on
biographical information you provide, and offers to send your resume to the employer names
you select from the list. You want your test to select all the employers displayed in the list, but
when you design your test, you do not know how many check boxes will be displayed on the
page, and you cannot, of course, know the exact object description of each check box. In this
situation, you can use a programmatic description to instruct UFT to perform aSet "ON"
method for all objects that fit the description: HTML TAG = input, TYPE = check box.

Programmatic Description Types

There are two types of programmatic descriptions:

l Static. You list the set of properties and values that describe the object directly in a VBScript
statement. For details, see "Static Programmatic Descriptions" on the next page.

l Dynamic. You add a collection of properties and values to a Description object, and then enter
the Description object name in the statement. For details, see "Dynamic Programmatic
Descriptions " on page 1000.

Using theStatic type to enter programmatic descriptions directly into your statements may be
easier for basic object description needs. However, in most cases, using theDynamic type
provides more power, efficiency, and flexibility.
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This section also includes:

Static Programmatic Descriptions 997

Dynamic Programmatic Descriptions 1000

Retrieving Child Objects 1002

Programmatic Description Checks 1004

Static Programmatic Descriptions

Relevant for: GUI actions, scripted GUI components, and function libraries

You can describe an object directly in a statement by specifying property:=value pairs describing
the object instead of specifying an object's name.

The general syntax is:

TestObject("PropertyName1:=PropertyValue1", "..." ,
"PropertyNameX:=PropertyValueX")

TestObject. The test object class.

PropertyName:=PropertyValue. The identification property and its value. Each property:=value
pair should be separated by commas and quotationmarks.

To describe an Insight test object, specify the ImgSrc property, with thePropertyValue providing
the file system path or ALM path to an image of the control. (To specify an ALM path to a file located
in the ALM Test Resources module, type: [QualityCenter\Resources] Subject\<folder and file
name>).

The statement below specifies aWebEdit test object in theMercury Tours page with the Name
author and an index of 3. During the run session, UFT finds theWebEdit object with matching
property values and enters the textMark Twain.

Browser("Mercury Tours").Page("Mercury Tours").WebEdit
("Name:=Author", "Index:=3").Set "Mark Twain"

The statement below specifies an InsightObject test object in the Calculator window, with the
image in theC:\AllMyFiles\Button6.bmp file. This file contains an image of the 6 button. During a
run session, UFT finds the area on the calculator that looks like this image, and clicks its center.

Window("Calculator").InsightObject("ImgSrc:=C:\AllMyFiles\Button6.bmp").Click

Formore details, see "Using Programmatic Descriptions for Insight Test Objects" on page 1000.
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Guidelines for Using Static Programmatic Descriptions

Whenworking with static programmatic descriptions, be aware of the following guidelines:

l "Regular Expressions in Programmatic Descriptions" below

l "Variables in Programmatic Descriptions" below

l "Programmatic Descriptions for Parent Test Objects" below

l "Reuse of Static Programmatic Descriptions" on the next page

l "Copying Programmatic Description Data from theObject Spy" on page 1000

l "Using Programmatic Descriptions for Insight Test Objects" on page 1000

Regular Expressions in Programmatic Descriptions
UFT evaluates all property values in programmatic descriptions as regular expressions. Therefore,
if you want to enter a value that contains a special regular expression character (such as *, ?, or +),
use the \ (backslash) character to instruct UFT to treat the special characters as literal characters.
For details on regular expressions related to tests and scripted components, see "Regular
Expressions Overview" on page 318.

Variables in Programmatic Descriptions
You can enter a variable name as the property value if you want to find an object based on property
values you retrieve during a run session. For example:

MyVar="some text string"
Browser("Hello").Page("Hello").Webtable("table").Webedit("name:=" &MyVar)

Programmatic Descriptions for Parent Test Objects
When using programmatic descriptions from a specific point within a test object hierarchy, you
must continue to use programmatic descriptions from that point onward within the same statement.
If you specify a test object by its object repository name after parent objects in the hierarchy have
been specified using programmatic descriptions, UFT cannot identify the object.

Example:

l You can use the following statement, which uses object repository names for the parent
objects and a programmatic description for the object on which the operation is performed:

Browser("Mercury Tours").Page("Mercury Tours").
WebEdit("Name:=Author", "Index:=3").Set "Mark Twain"
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l You can use the following statement since it uses programmatic descriptions throughout
the entire test object hierarchy:

Browser("Title:=Mercury Tours").Page("Title:=Mercury Tours").
WebEdit("Name:=Author", "Index:=3").Set "Mark Twain"

l You can also use the statement below, since it uses programmatic descriptions from a
certain point in the description (starting from the Page object description):

Browser("Mercury Tours").Page("Title:=Mercury Tours").
WebEdit("Name:=Author", "Index:=3").Set "Mark Twain"

l However, you cannot use the following statement, since it uses programmatic descriptions
for the Browser and Page objects but then attempts to use an object repository name for the
WebEdit test object:

Browser("Title:=Mercury Tours").Page("Title:=Mercury Tours").
WebEdit("Author").Set "Mark Twain"

In this case, UFT tries to locate theWebEdit object based on its name, but cannot locate it in
the repository because the parent objects were specified using programmatic descriptions.

For details on working with test objects, see "Managing Test Objects in Object Repositories"
on page 1198.

Reuse of Static Programmatic Descriptions
If you want to use the same static programmatic description several times in one action, scripted
component, or function library, youmay want to assign the object you create to a variable or use a
With statement.

Example

Instead of entering:

Window("Text:=Myfile.txt - Notepad").Move 50,
Window("Text:=Myfile.txt - Notepad").WinEdit("AttachedText:=Find what:").Set "hello"
Window("Text:=Myfile.txt - Notepad").WinButton("Caption:=Find next").Click

You can enter:

Set MyWin =Window("Text:=Myfile.txt - Notepad")
MyWin.Move 50,
MyWin.WinEdit("AttachedText:=Find what:").Set "hello"
MyWin.WinButton("Caption:=Find next").Click
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Alternatively, when working with actions or scripted components, you can use aWith
statement:

With Window("Text:=Myfile.txt - Notepad")
    .Move 50, 50
    .WinEdit("AttachedText:=Find what:").Set "hello"
    .WinButton("Caption:=Find next").Click
End With

For details on theWith statement related to actions and scripted components, see "With
Statement" on page 1026.

Copying Programmatic Description Data from the Object Spy
You can use theCopy Identification Properties to Clipboard option in the "Object Spy Dialog
Box " (described on page 1189) to copy all identification properties and values for a selected object
to theWindows Clipboard. The copied values are formatted in standard programmatic description
syntax with line breaks between each property-value pair. For example:

"Class Name:=Image",
"abs_x:=585",
"abs_y:=573",
"alt:=Specials",
....

You can paste the copied data to any document and then copy selected lines (remove the line
breaks) into a programmatic description. For details on this option, see "Object Spy Dialog Box " on
page 1189.

Using Programmatic Descriptions for Insight Test Objects
When using programmatic descriptions for Insight test objects, consider the following:

l The file containing the image of the control must be a non-compressed image file (JPEG, GIF,
BMP or PNG).

l When running theClickmethod on an Insight test object defined using a programmatic
description, UFT clicks in the center of the control that matches the specified image.

l Make sure that the file specified in the programmatic description is accessible from any
computer that runs the test or component.

l You can also include ordinal identifier properties in the programmatic description.

Dynamic Programmatic Descriptions

Relevant for: GUI actions, scripted GUI components, and function libraries

You can use theDescription object to return aProperties collection object containing a set of
Property objects. A Property object consists of a property name and value. You can then specify
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the returnedProperties collection in place of an object name in a statement. (Each property object
contains a property name and value pair.)

To create theProperties collection, you enter aDescription.Create statement using the following
syntax:

Set MyDescription = Description.Create()

After you have created aProperties object (such as MyDescription in the example above), you can
enter statements to add, edit, remove, and retrieve properties and values to or from theProperties
object during the run session. This enables you to determine which, and how many properties to
include in the object description in a dynamic way during the run session.

After you fill theProperties collection with a set of Property objects (properties and values), you
can specify theProperties object in place of an object name in a statement.

For example, instead of entering:

Window("Error").WinButton("text:=OK", "width:=50").Click

you can enter:

Set MyDescription = Description.Create()
MyDescription("text").Value = "OK"
MyDescription("width").Value = 50
Window("Error").WinButton(MyDescription).Click

Whenworking withProperties objects, you can use variable names for the properties or values to
generate the object description based on properties and values you retrieve during a run session.

You can create several Properties objects if you want to use programmatic descriptions for several
objects.

For details on theDescription andProperties objects and their associatedmethods, see the
HP UFT Object Model Reference for GUI Testing.

Considerations for Description Objects

l By default, the value of all Property objects added to aProperties collection are treated as
regular expressions. Therefore, if you want to enter a value that contains a special regular
expression character (such as *, ?, +), use the \ (backslash) character to instruct UFT to treat
the special characters as literal characters. For details on regular expressions, see "Regular
Expressions Overview" on page 318.

You can set theRegularExpression property to False to specify a value as a literal value for a
specific Property object in the collection. For details, see theUtility Objects section of the
HP UFT Object Model Reference for GUI Testing.

l When using programmatic descriptions from a specific point within a test object hierarchy, you
must continue to use programmatic descriptions from that point onward within the same
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statement. If you specify a test object by its object repository name after other objects in the
hierarchy have been described using programmatic descriptions, UFT cannot identify the object.

For example, you can useBrowser(Desc1).Page(Desc1).Link(desc3), since it uses
programmatic descriptions throughout the entire test object hierarchy.

You can also useBrowser("Index").Page(Desc1).Link(desc3), since it uses programmatic
descriptions from a certain point in the description (starting from the Page object description).

However, you cannot useBrowser(Desc1).Page(Desc1).Link("Example1"), since it uses
programmatic descriptions for the Browser and Page objects but then attempts to use an object
repository name for the Link test object (UFT tries to locate the Link object based on its name,
but cannot locate it in the repository because the parent objects were specified using
programmatic descriptions).

Retrieving Child Objects

Relevant for: GUI actions, scripted GUI components, and function libraries

You can use theChildObjects method to retrieve all objects located inside a specified parent object,
or only those child objects that fit a certain programmatic description. To retrieve this subset of child
objects, you first create a description object, and then you add the set of properties and values that
you want your child object collection tomatch using theDescription object.

Note: Youmust use theDescription object to create the programmatic description for the
ChildObjects description argument. You cannot enter the programmatic description directly
into the argument using the property:=value syntax.

After you build a description in your description object, use the following syntax to retrieve child
objects that match the description:

SetMySubSet=TestObject.ChildObjects(MyDescription)

Example

The statements below instruct UFT to select all of the check boxes on the Itinerary Web page:

Set MyDescription = Description.Create()
MyDescription("html tag").Value = "INPUT"
MyDescription("type").Value = "checkbox"
Set Checkboxes = Browser("Itinerary").Page("Itinerary").ChildObjects(MyDescription)
NoOfChildObjs = Checkboxes.Count
For Counter=0 to NoOfChildObjs-1

Checkboxes(Counter).Set "ON"
Next
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In the Run Results, square brackets around a test object name indicate that the test object was
created dynamically during the run session using theChildObjects method or a programmatic
description.

For details on theChildObjectsmethod, see theHP UFT Object Model Reference for GUI Testing.

Using the Index Property in Programmatic Descriptions
The index property can sometimes be a useful identification property for uniquely identifying an
object. The index identification property identifies an object based on the order in which it appears
within the source code, where the first occurrence is 0.

Index property values are object-specific. Thus, if you use an index value of 3 to describe a
WebEdit test object, UFT searches for the fourthWebEdit object in the page.

If you use an index value of 3 to describe aWebElement object, however, UFT searches for the
fourthWeb object on the page regardless of the type, because theWebElement object applies to all
Web objects.

For example, suppose you have a page with the following objects:

l An image with the nameApple

l An image with the nameUserName

l AWebEdit object with the nameUserName

l An image with the namePassword

l AWebEdit object with the namePassword

The description below refers to the third item in the list above, which is the firstWebEdit object on
the page with the nameUserName:

WebEdit("Name:=UserName", "Index:=0")

The following description, however, refers to the second item in the list above, which is the first
object of any type (WebElement) with the nameUserName:

WebElement("Name:=UserName", "Index:=0")

Note: If there is only one object, using index=0 does not retrieve it. You should not include the
index property in the object description.
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Programmatic Description Checks

Relevant for: GUI actions, scripted GUI components, and function libraries

You can compare the run-time value of a specified object property with the expected value of that
property using either programmatic descriptions or user-defined functions.

Programmatic description checks are useful in cases in which you cannot apply a regular
checkpoint, for example, if the object whose properties you want to check is not stored in an object
repository. You can then write the results of the check to the Run Results report.

For example, suppose you want to check the run-time value of aWeb button. You can use the
GetROProperty orExist operations to retrieve the run-time value of an object or to verify whether
the object exists at that point in the run session.

Example

The following examples illustrate how to use programmatic descriptions to check whether the
ContinueWeb button is disabled during a run session:

Using theGetROProperty operation:

ActualDisabledVal = Browser(micClass:="Browser").Page(micClass:="Page").WebButton
(alt:="Continue").GetROProperty("disabled")

Using theExist operation:

While Not Browser(micClass:="Browser").Page(micClass:="Page").WebButton
(alt:="Continue").Exist(30)

Wend

By addingReport.ReportEvent statements, you can instruct UFT to send the results of a
check to the run results:

If ActualDisabledVal = True Then
Reporter.ReportEvent micPass, "CheckContinueButton = PASS", "The Continue button
is disabled, as expected."
Else
Reporter.ReportEvent micFail, "CheckContinueButton = FAIL", "The Continue button
is enabled, even though it should be disabled."
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You can also create and use user-defined functions to check whether your application is
functioning as expected. The following example illustrates a function that checks whether an
object is disabled and returns True if the object is disabled:

'@Description Checks whether the specified test object is disabled
'@Documentation Check whether the <Test object name> <test object type> is enabled.
Public Function VerifyDisabled (obj)
Dim enable_property
'Get the disabled property from the test object
enable_property = obj.GetROProperty("disabled")
If enable_property = 1 Then ' The value is True (1)—the object is disabled
Reporter.ReportEvent micPass, "VerifyDisabled Succeeded", "The test object is disabled, as ex

pected."
VerifyDisabled = True
Else
Reporter.ReportEvent micFail, "VerifyDisabled Failed", "The test object is enabled, although it

should be disabled."
VerifyDisabled = False
End If
End Function

Note: For details on using theGetROProperty operation, see "Retrieving Native
Properties" on page 1009. For details on usingWhile...Wend statements, see
"While...Wend Statement" on page 1026. For details on specific test objects, operations,
and properties, see theHP UFT Object Model Reference for GUI Testing.

Opening and Closing Applications Programmatically
Relevant for: GUI actions and function libraries

In addition to using the "Record and Run Settings Dialog Box" (for tests) (described on page 865) to
instruct UFT to open a new application when a run session begins, or manually opening the
application you want to test, you can insert statements into your test or component that open and
close the applications you want to test.

You can run any application from a specified location using aSystemUtil.Run statement. You can
add these statements directly in your GUI test action or in a function library.

You can specify an application and pass any supported parameters, or you can specify a file name
and the associated application starts with the specified file open.
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This is especially useful in the following situations:

l For tests: If your test includes more than one application, and you selected theRecord and run
test on any application check box in the "Record and Run Settings Dialog Box" (described on
page 865).

l For components: If you want to provide an operation (function) that opens an application from
within a component.

You can closemost applications using theClosemethod. You can also useSystemUtil statements
to close applications.

For example, you could use the following statements to open a file named type.txt in the default text
application (Notepad), type happy days, save the file using shortcut keys, and then close the
application:

SystemUtil.Run "C:\type.txt", "","",""
Window("Text:=type.txt - Notepad").Type "happy days"
Window("Text:=type.txt - Notepad").Type micAltDwn & "F" &micAltUp
Window("Text:=type.txt - Notepad").Type micLShiftDwn & "S" &micLShiftUp
Window("Text:=type.txt - Notepad").Close

Note:

l When you specify an application to open using the "Record and Run Settings Dialog Box"
(for tests only) (described on page 865), UFT does not add aSystemUtil.Run statement to
your test.

l The InvokeApplicationmethod can open only executable files and is used primarily for
backward compatibility.

For more details, see theHP UFT Object Model Reference for GUI Testing.

Comments, Control-Flow, and Other VBScript Statements
Relevant for: GUI tests and components

UFT enables you to incorporate decision-making into your test or component by adding conditional
statements that control its logical flow. You can add the conditional statements directly in your
action or component, or in the function libraries that they use.

In addition, you can definemessages in your action or component that UFT sends to your run
results.

To improve the readability of your actions and function libraries, you can also add comments to
them.
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For details on how to use these programming concepts in the Keyword View, see "Keyword View"
on page 919.

Note: TheVBScript Reference (available from Help > HP Unified Functional Testing
Help) contains Microsoft VBScript documentation, including VBScript, Script Runtime, and
Windows Script Host.

For details, see:

l "Comments in VBScript" on page 1017

l "Calculations in VBScript" on page 1020

l "For...Next Statement" on page 1024

l "For...Each Statement" on page 1023

l "Do...Loop Statement" on page 1022

l "While...Wend Statement" on page 1026

l "If...Then...Else Statement" on page 1024

l "With Statement" on page 1026

Retrieving and Setting Identification Property Values
Relevant for: GUI tests and components

Identification properties are the set of properties defined by UFT for each object. You can set and
retrieve a test object's identification property values, and you can retrieve the values of
identification properties from a run-time object.

When you run your test or component, UFT creates a temporary version of the test object that is
stored in the test object repository. You can use theGetTOProperty, GetTOProperties, and
SetTOProperty methods in your action, component, or function library to set and retrieve the
identification property values of the test object.

TheGetTOProperty andGetTOProperties methods enable you to retrieve a specific property value
or all the properties and values that UFT uses to identify an object.

TheSetTOProperty method enables you tomodify a property value that UFT uses to identify an
object.

Note: Because UFT refers to the temporary version of the test object during the run session,
any changes youmake using theSetTOProperty method apply only during the course of the
run session, and do not affect the values stored in the test object repository.
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For example, the following statements would set theSubmit button's name value tomy button, and
then retrieve the valuemy button to theButtonName variable:

Browser("QA Home Page").Page("QAHome Page").WebButton("Submit").SetTOProperty "Nam
e", "my button"
ButtonName=Browser("QA Home Page").Page("QAHome Page").WebButton("Submit").GetTOP
roperty("Name")

You use theGetROProperty method to retrieve the current value of an identification property from a
run-time object in your application.

For example, you can retrieve the target value of a link during the run session as follows:

link_href = Browser("HP Technologies").Page("HP Technologies").Link("Jobs").GetROProperty("h
ref")

Tip: If you do not know the identification properties of objects in your application, you can view
them using the Object Spy. For details on the Object Spy, see "Object Spy Dialog Box " on
page 1189.

For a list and description of identification properties supported by each object, and for more details
on theGetROProperty, GetTOProperty, GetTOProperties, andSetTOProperty methods, see the
HP UFT Object Model Reference for GUI Testing.

Native Properties and Operations
Relevant for: GUI tests and components

If the test object operations and identification properties available for a particular test object do not
provide the functionality you need, you can access the native operations and properties of any run-
time object in your application using theObject property.

You can view the native properties and their values, or the identification properties, of the run-time
object associated with an object in your application, in the "Object Spy Dialog Box " (described on
page 1189).

You can use the statement completion feature with object properties to view a list of the available
native operations and properties of an object. For more details on the statement completion option,
see "Statement Completion in the Editor" on page 306.

Tip: If the object is aWeb object, you can also reference its native properties in programmatic
descriptions using the attribute/property notation. For details, see theHP Unified Functional
Testing Add-ins Guide.
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This section also includes:

l "Retrieving Native Properties" below

l "Activating Native Operations " below

Retrieving Native Properties
You can use theObject property to access the native properties of any run-time object. For
example, you can retrieve the current value of the ActiveX calendar's internal Day property as
follows:

Dim MyDay
Set MyDay=Browser("index").Page("Untitled").ActiveX("MSCAL.Calendar.7").Object.Day

Formore details on theObject property, see theHP UFT Object Model Reference for GUI Testing.

Activating Native Operations
You can use theObject property to activate the internal operations of any run-time object. For
example, you can activate the native focusmethod of the edit box as follows:

Dim MyWebEdit

Set MyWebEdit=Browser("Mercury Tours").Page("Mercury Tours").WebEdit("username").Object

MyWebEdit.focus

Formore details on theObject property, see theHP UFT Object Model Reference for GUI Testing.

Running DOS Commands
Relevant for: GUI actions, scripted GUI components, and function libraries

You can run standard DOS commands in your action, scripted component, or function using the
VBScript Windows Scripting Host Shell object (WSCript.shell). For example, you can open a DOS
commandwindow, change the path toC:\, and run theDIR command using the following
statements:

Dim oShell
Set oShell = CreateObject ("WSCript.shell")
oShell.run "cmd /K CD C:\ & Dir"
Set oShell = Nothing

Formore details, see theMicrosoft VBScript Language Reference (select Help > HP Unified
Functional Testing Help > VBScript Reference > VBScript).
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Filtering the GUI Steps Reported in the Run Session
Relevant for: GUI actions, scripted GUI components, and function libraries

You can use theReport.Filtermethod to determine which steps or types of steps are included in
the Run Results. You can completely disable or enable reporting of steps following the statement,
or you can indicate that you only want subsequent failed or failed and warning steps to be included
in the report. You can also use theReport.Filtermethod to retrieve the current report mode.

For details, see "Report Modes" on page 1027.

Using the Windows API in GUI Testing
Relevant for: GUI actions, scripted GUI components, and function libraries

Using theWindows API, you can extend testing abilities and add usability and flexibility to your
tests components. TheWindows operating system provides a large number of functions to help you
control andmanageWindows operations. You can use these functions to obtain additional
functionality.

TheWindows API is documented in theMicrosoft MSDN Web site, which can be found at:
http://msdn.microsoft.com/en-us/library/ee663266

A reference to specific Windows API functions can be found at: http://msdn2.microsoft.com/en-
us/library/Aa383749

For details on how to use theWindows API, see "How to Enhance Your Actions, Scripted
Components, and Function Libraries Using theWindows API" on the next page.
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Tasks

How to Enhance Your Actions, Scripted Components,
and Function Libraries Using the Windows API

Relevant for: GUI actions, scripted GUI components, and function libraries

1. In MSDN, locate the function you want to use.

2. Read its documentation and understand all required parameters and return values.

3. Note the location of theWindows API function. Windows API functions are located inside
Windows DLLs. The name of the .dll in which the requested function is located is usually
identical to the Import Library section in the function's documentation. For example, if the
documentation refers toUser32.lib, the function is located in a .dll namedUser32.dll, typically
located in yourSystem32 library.

4. Use theUFT Extern object to declare an external function. For details, see theHP UFT Object
Model Reference for GUI Testing.

The following example declares a call to a function calledGetForegroundWindow, located in
user32.dll:

extern.declare micHwnd, "GetForegroundWindow", "user32.dll", "GetForegroundWindow"

5. Call the declared function, passing any required arguments, for example:

hwnd = extern.GetForegroundWindow()

In this example, the foreground window's handle is retrieved. This can be useful if the
foreground window is not in the object repository or cannot be determined beforehand (for
example, a window with a dynamic title). Youmay want to use this handle as part of a
programmatic description of the window, for example:

Window("HWND:="&hWnd).Close

In some cases, youmay have to use predefined constant values as function arguments. Since
these constants are not defined in the context of your action, scripted component, or function, you
need to find their numerical value to pass them to the called function. The numerical values of these
constants are usually declared in the function's header file. A reference to header files can also be
found in each function's documentation under the Header section. If you haveMicrosoft Visual
Studio installed on your computer, you can typically find header files underX:\Program
Files\Microsoft Visual Studio\VC98\Include.
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For example, theGetWindow function expects to receive a numerical value that represents the
relationship between the specified window and the window whose handle is to be retrieved. In the
MSDN documentation, you can find the constants: GW_CHILD, GW_ENABLEDPOPUP, GW_
HWNDFIRST, GW_HWNDLAST, GW_HWNDNEXT, GW_HWNDPREV andGW_
HWNDPREV.

If you open theWINUSER.H file, mentioned in theGetWindow documentation, you will find the
following flag values:

/*
* GetWindow() Constants
*/
#define GW_HWNDFIRST 0
#define GW_HWNDLAST 1
#define GW_HWNDNEXT 2
#define GW_HWNDPREV 3
#define GW_OWNER 4
#define GW_CHILD 5
#define GW_ENABLEDPOPUP 6
#define GW_MAX 6

Example

The following example retrieves a specific menu item's value in the Notepad application:

' Constant Values:
const MF_BYPOSITION = 1024
' Windows API Functions Declarations
Extern.Declare micHwnd,"GetMenu","user32.dll","GetMenu",micHwnd
Extern.Declare micInteger,"GetMenuItemCount","user32.dll","GetMenuItemCount",micHwnd
Extern.Declare micHwnd,"GetSubMenu","user32.dll","GetSubMenu",micHwnd,micInteger
Extern.Declare micInteger,"GetMenuString","user32.dll","GetMenuString",micHwnd,micInteger,
micString+micByRef,micInteger,micInteger
' Notepad.exe
hwin =Window("Notepad").GetROProperty ("hwnd")' Get Window's handle
MsgBox hwin
' Use Windows API Functions
men_hwnd = Extern.GetMenu(hwin)' Get window's main menu's handle
MsgBox men_hwnd
item_cnt = Extern.GetMenuItemCount(men_hwnd)
MsgBox item_cnt
hSubm = Extern.GetSubMenu(men_hwnd,0)
MsgBox hSubm
rc = Extern.GetMenuString(hSubm,0,value,64,MF_BYPOSITION)
MsgBox value
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Reference

Checkpoint and Output Statements
Relevant for: GUI actions and scripted GUI components

In UFT, you can create checkpoints and output values on pages, text strings, tables, and other
objects. When you create a checkpoint or output value in the Keyword View, UFT creates a
corresponding line in VBScript in the Editor. It uses theCheckmethod to perform the checkpoint,
and theOutputmethod to perform the output value step.

For example, in the following statement UFT performs a check on the words New York:

Browser("Mercury Tours").Page("Flight Confirmation").Check Checkpoint("New York")

The corresponding step in the Keyword View is displayed as follows:

Note:

l The details about a checkpoint are set in the relevant Checkpoint Properties dialog box. The
details about an output value step are set in the relevant Output Value Properties dialog box.
The statement displayed in the Editor is a reference to the stored information. Therefore,
you cannot insert a checkpoint or output value statement in the Editor manually.

l For details on inserting andmodifying checkpoints, see "Checkpoints Overview" on page
1396. For details on inserting andmodifying output values, see "Output Values Overview"
on page 1488.

Basic VBScript Syntax
Relevant for: GUI actions, scripted GUI components, and function libraries

You use VBScript in UFT to develop actions, scripted components, or function libraries in the Editor
that you can use in your GUI tests and components.

VBScript is an easy-to-learn, yet powerful scripting language. You can use VBScript to develop
scripts to perform both simple and complex object-based tasks, even if you have no previous
programming experience.

This section provides some basic guidelines to help you use VBScript statements to enhance your
action, scripted component, or function library. For more detailed information on using VBScript,
you can view the VBScript documentation from theUFTHelpmenu (Help > HP Unified
Functional Testing Help > VBScript Reference).
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Each VBScript statement has its own specific syntax rules. If you do not follow these rules, errors
will be generated when you run the problematic step.

Additionally, if you try to move to the Keyword View from the Editor, UFT lists any syntax errors
found in the document in the Errors pane. You cannot switch to the Keyword View without fixing or
eliminating the syntax errors. For details, see "Errors Pane User Interface" on page 374.

Tip: You can check the syntax of your documents at any time by selecting
Design > Check Syntax. In the Errors pane, you can view all of the syntax errors in the whole
solution, or only the ones found in a selected test's actions and associated function libraries.

This section also includes:

General VBScript Syntax Rules andGuidelines 1014

Handling VBScript Syntax Errors 1016

Formatting VBScript Text 1016

Comments in VBScript 1017

Parameter Indications in VBScript 1018

Parentheses in VBScript 1019

Calculations in VBScript 1020

Variables in VBScript 1021

Do...Loop Statement 1022

For...Each Statement 1023

For...Next Statement 1024

If...Then...Else Statement 1024

While...Wend Statement 1026

With Statement 1026

General VBScript Syntax Rules and Guidelines

Relevant for: GUI actions, scripted GUI components, and function libraries

Whenworking with actions, scripted components, or function libraries in the Editor, you should
consider the following general VBScript syntax rules and guidelines:

l Case-sensitivity. By default, VBScript is not case sensitive and does not differentiate between
upper-case and lower-case spelling of words, for example, in variables, object and operation
names, or constants.
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For example, the two statements below are identical in VBScript:

Browser("Mercury").Page("Find a Flight:").WebList("toDay").Select "31"
browser("mercury").page("find a flight:").weblist("today").select "31"

l Text strings. When you enter a value as a text string, youmust add quotationmarks before and
after the string. For example, in the above segment of script, the names of theWeb site, Web
page, and edit box are all text strings surrounded by quotationmarks.

Note that the value 31 is also surrounded by quotationmarks because it is a text string that
represents a number and not a numeric value.

In the following example, only the property name (first argument) is a text string and is in
quotationmarks. The second argument (the value of the property) is a variable and therefore
does not have quotationmarks. The third argument (specifying the timeout) is a numeric value,
which also does not need quotationmarks.

Browser("Mercury").Page("Find a Flight:").WaitProperty("items count", Total_Items, 2000)

l Variables. You can specify variables to store strings, integers, arrays and objects. Using
variables helps tomake your script more readable and flexible. For details, see "Variables in
VBScript" on page 1021.

l Parentheses. To achieve the desired result and to avoid errors, it is important that you use
parentheses () correctly in your statements. For details, see "Parentheses in VBScript" on page
1019.

l Indentation. You can indent or outdent your script to reflect the logical structure and nesting of
the statements. For details, see "Formatting VBScript Text" on the next page.

l Comments. You can add comments to your statements using an apostrophe ('), either at the
beginning of a separate line, or at the end of a statement. It is recommended that you add
comments wherever possible, to make your scripts easier to understand andmaintain. For
details, see "Formatting VBScript Text" on the next page, and "Comments in VBScript" on page
1017.

l Spaces. You can add extra blank spaces to your script to improve clarity. These spaces are
ignored by VBScript.

For details on using specific VBScript statements to enhance your tests or components, see
"Comments, Control-Flow, andOther VBScript Statements " on page 1006.
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Handling VBScript Syntax Errors

Relevant for: GUI actions, scripted GUI components, and function libraries

The Errors pane lists the syntax errors found in your document, and enables you to locate each
syntax error so that you can correct it. For details on the Errors pane, see "Errors Pane" on page
364.

You can view a description of each of the VBScript errors in the VBScript Reference. For details,
select Help > HP Unified Functional Testing Help > VBScript Reference > VBScript >
Reference > Errors > VBScript Syntax Errors.

Tip: You can check the syntax of your documents at any time by selecting
Design > Check Syntax. In the Errors pane, you can view all of the syntax errors in the whole
solution, or only the ones found in a selected test's actions and associated function libraries.

For actions and scripted components:When you switch to the Keyword View from the Editor,
UFT verifies the syntax. If a new or updated VBScript statement contains syntax errors, an error
message is displayed in the Keyword View and the syntax error is displayed in the Errors pane.
UFT is unable to display the document in the Keyword View until you have fixed all the syntax
errors.

Tip: TheMicrosoft VBScript Language Reference defines VBScript syntax errors as:
"errors that result when the structure of one of your VBScript statements violates one or more
of the grammatical rules of the VBScript scripting language."

To learn about working with VBScript, you can view the VBScript Reference from the
UFTHelpmenu (Help > HP Unified Functional Testing Help > VBScript Reference).

Formatting VBScript Text

Relevant for: GUI actions, scripted GUI components, and function libraries

Whenworking with actions, scripted components, or function libraries in the Editor, it is important to
follow accepted VBScript practices for comments and indentation.

Comments
Use comments to explain sections of an action, a scripted component, or a function library. This
improves readability andmakes your scripts easier to maintain and update. For details, see
"Comments in VBScript" on the next page.

l Adding Comments. You can add comments to your statements by adding an apostrophe ('),
either at the beginning of a separate line, or at the end of a statement.

Tip: You can comment a selected block of text by choosingEdit > Format > Comment.
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Each line in the block is preceded by an apostrophe.

l Removing Comments. You can remove comments from your statements by deleting the
apostrophe ('), either at the beginning of a separate line, or at the end of a statement.

Tip: You can remove the comments from a selected block or line of text by choosingEdit >
Format > Uncomment.

Indentation
Use indentation to reflect the logical structure and nesting of your statements.

l Indenting Statements. You can indent your statements by selecting the text and choosing
Edit > Format > Indent. If you want to indent multiple lines, you can also select the text and
press the TAB key.

The text is indented according to the Tab spacing selected in theGeneral pane of the Text
Editor tab in the Options dialog box (Tools > Options > Text Editor tab > General node). For
details, see "General Pane (Options Dialog Box > Text Editor Tab)" on page 575.

Note: The Indent selected text when using the Tab key check box must be selected in
the Editor Options dialog box, otherwise pressing the TAB key deletes the selected text.

l Outdenting Statements. You can outdent your statements by selectingEdit > Format >
Outdent or by deleting the space at the beginning of the statements.

For more detailed information on formatting in VBScript, you can view the VBScript documentation
from theUFT Helpmenu (Help > HP Unified Functional Testing Help > VBScript Reference).

Comments in VBScript

Relevant for: GUI actions, scripted GUI components, and function libraries

A comment is a line or part of a line in a script that is preceded by an apostrophe ('). During a run
session, UFT does not process the comments. You can use comments to explain sections of an
action, a scripted component, or a function library, to improve readability, and tomake your scripts
easier to maintain and update.

The following example shows how a comment describes the purpose of the statement below it:

`Sets the word "mercury" into the "username" edit box.
Browser("Mercury Tours").Page("Mercury Tours").WebEdit("username").Set "mercury"

By default, comments are displayed in green inside your VBScript code. You can customize the
appearance of comments in the Fonts and Colors pane of the Text Editor tab in the Options
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dialog box (Tools > Options > Text Editor tab > General node). For details, see "Fonts and
Colors Pane (Options Dialog Box > Text Editor Tab)" on page 577.

Tips:

l You can comment a block of text by selectingEdit > Format > Comment.

l To remove the comment, select Edit > Format > Uncomment.

Note: You can also add a comment line using the VBScript Rem statement. For details,
see theMicrosoft VBScript Language Reference (select Help > HP Unified Functional
Testing Help > VBScript Reference > VBScript).

Parameter Indications in VBScript

Relevant for: GUI actions and scripted GUI components

You can use UFT to enhance your tests by parameterizing values. A parameter is a variable that is
assigned a value from an external data source or generator.

When you create a parameter in the Keyword View, UFT creates a corresponding line in VBScript in
the Editor.

For example, if you define the value of amethod argument as a Data pane parameter, UFT retrieves
the value from the Data pane using the following syntax:

Object_Hierarchy.Method DataTable (parameterID, sheetID)

Item Description

Object_
Hierarchy

The hierarchical definition of the test object, consisting of one or more objects
separated by a dot.

Method The name of themethod that UFT executes on the parameterized object.

DataTable The reserved object representing the data table.

parameterID The name of the column in the data table from which to take the value.

sheetID The name of the sheet in which the value is stored. If the parameter is a global
parameter, dtGlobalSheet is the sheet ID.

Example

Suppose you are creating a test for theMercury Tours site, and you select San Francisco as
your destination. The following statement would be inserted into an action in your test in the
Editor:
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Browser("Welcome: Mercury").Page("Find a Flight:").WebList("toPort").Select "San Francisco"

Now suppose you parameterize the destination value, and you create aDestination column in
the Data pane. The previous statement would bemodified to the following:

Browser("Welcome: Mercury").Page("Find a Flight:").WebList("toPort").Select DataTable("Destin
ation",dtGlobalSheet)

In this example, Select is themethod name, DataTable is the object that represents the data
table, Destination is the Data pane parameter (column name), and dtGlobalSheet indicates the
Global sheet in the Data pane.

In the Keyword View, this step is displayed as follows:

For more details on using and defining parameter values, see "Parameterizing Object Values" on
page 1526.

Parentheses in VBScript

Relevant for: GUI actions, scripted GUI components, and function libraries

When programming in VBScript, it is important that you follow the rules for using or not using
parentheses () in your statements.

Youmust use parentheses aroundmethod arguments if you are calling amethod that returns a
value and you are using the return value.

For example, use parentheses aroundmethod arguments if you are returning a value to a variable, if
you are using themethod in an If statement, or if you are using theCall keyword to call an action or
function. When working with actions, you also need to add parentheses around the name of a
checkpoint if you want to retrieve its return value.

Tip: If you receive anExpected end of statement error message when running a step, it may
indicate that you need to add parentheses around the arguments of the step's method.

Example

Following are several examples showing when to use or not use parentheses.

The following example requires parentheses around themethod arguments for theChildItem
method because it returns a value to a variable:

Set WebEditObj = Browser("Mercury Tours").Page("Method of Payment").WebTable("FirstName").C
hildItem (8, 2, "WebEdit", 0)
WebEditObj.Set "Example"
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The following example requires parentheses around themethod arguments becauseCall is
being used:

Call RunAction("BookFlight", oneIteration)

or

Call MyFunction("Hello World")
...
...

The following example requires parentheses around theWaitPropertymethod arguments
because themethod is used in an If statement:

If Browser("index").Page("index").Link("All kindsof").WaitProperty("attribute/readyState", "complete", 4)

Then
Browser("index").Page("index").Link("All kindsof").Click

End If

The following example requires parentheses around theCheckmethod arguments, since it
returns the value of the checkpoint:

a = Browser("MyBrowser").Page("MyPage").Check (CheckPoint("MyProperty"))

The following example does not require parentheses around theClickmethod arguments
because it does not return a value:

Browser("Mercury Tours").Page("Method of Payment").WebTable("FirstName").Click 3,4

Calculations in VBScript

Relevant for: GUI actions, scripted GUI components, and function libraries

You can write statements that perform simple calculations usingmathematical operators. For
example, you can use amultiplication operator to multiply the values displayed in two text boxes in
yourWeb site. VBScript supports the followingmathematical operators:

Operator Description

+ addition

– subtraction

– negation (a negative number)

* multiplication

/ division

^ exponent
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In the following example, themultiplication operator is used to calculate themaximum luggage
weight of the passengers at 100 pounds each:

'Retrieves the number of passengers from the edit box using the GetROProperty method
passenger = Browser ("Mercury_Tours").Page ("Find_Flights").WebEdit("numPassengers").GetR
OProperty("value")
'Multiplies the number of passengers by 100
weight = passenger * 100
'Inserts the maximum weight into a message box.
msgbox("The maximum weight for the party is "& weight &"pounds.")

Variables in VBScript

Relevant for: GUI actions, scripted GUI components, and function libraries

You can specify variables to store test objects or simple values in your action, scripted component,
or function library. When using a variable for a test object, you can use the variable instead of the
entire object hierarchy in other statements. Using variables in this way makes your statements
easier to read and tomaintain.

To specify a variable to store an object, use theSet statement, with the following syntax:

Set ObjectVar =ObjectHierarchy

In the example below, theSet statement specifies the variableUserEditBox to store the full
Browser.Page.WebEdit object hierarchy for the username edit box. TheSetmethod then enters
the value John into the username edit box, using theUserEditBox variable:

Set UserEditBox = Browser("Mercury Tours").Page("Mercury Tours").WebEdit("username")
UserEditBox.Set "John"

Note: Do not use theSet statement to specify a variable containing a simple value (such as a
string or a number). The example below shows how to define a variable for a simple value:

MyVar = Browser("Mercury Tours").Page("Mercury Tours").WebEdit("username").GetTOProperty(
"type")

You can also use theDim statement to declare variables of other types, including strings, integers,
and arrays. This statement is not mandatory, but you can use it to improve the structure of your
action, scripted component, or function library.

The examples below demonstrate using theDim statement to declare a variable:

In an action or scripted component (using the passengers variable):

Dim passengers
passengers = Browser("Mercury Tours").Page("Find Flights").WebEdit
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("numpassengers").GetROProperty("value")

In a function libraries (using the actual_value variable):

Dim actual_value
' Get the actual property value
actual_value = obj.GetROProperty(PropertyName)

These variables can then be used in different statements within the action, scripted component, or
function library.

Do...Loop Statement

Relevant for: GUI actions, scripted GUI components, and function libraries

TheDo...Loop statement instructs UFT to perform a statement or series of statements while a
condition is true or until a condition becomes true. It has the following syntax:

Do [{while} {until} condition]
statement

Loop

Item Description

condition A condition to be fulfilled.

statement A statement or series of statements to be performed during the loop.

In the following example, UFT calculates the factorial value of the number of passengers using the
Do...Loop:

passengers = Browser("Mercury Tours").Page("Find Flights").
WebEdit("numPassengers").GetROProperty("value")

total = 1
i = 1
Dowhile i <= passengers

total = total * i
i = i + 1

Loop
MsgBox "!" & passengers & "=" & total                        
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For...Each Statement

Relevant for: GUI actions, scripted GUI components, and function libraries

A For...Each loop instructs UFT to perform one or more statements for each element in an array or
an object collection. It has the following syntax:

For Each item In array
statement

Next

Item Description

item A variable representing the element in the array.

array The name of the array.

statement A statement, or series of statements, to be performed during the loop.

The following example uses a For...Each loop to display each of the values in an array:

MyArray = Array("one","two","three","four","five")
For Each element In MyArray
    msgbox element
Next

Note: During a run session, if a For Each statement iterates on theParameterDefinitions
collection, the runmay fail if the collection was retrieved directly before using the For Each
statement. To prevent this, use other VBScript loop statements, such as For orWhile.
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For...Next Statement

Relevant for: GUI actions, scripted GUI components, and function libraries

A For...Next loop instructs UFT to perform one or more statements a specified number of times. It
has the following syntax:

For counter = start to end [Step step]
statement

Next

Item Description

counter The variable used as a counter for the number of iterations.

start The start number of the counter.

end The last number of the counter.

step The number to increment at the end of each loop.
Default = 1.
Optional.

statement A statement, or series of statements, to be performed during the loop.

In the following example, UFT calculates the factorial value of the number of passengers using the
For statement:

passengers = Browser("Mercury Tours").Page("Find Flights").
WebEdit("numPassengers").GetROProperty("value")

total = 1
For i=1 To passengers
    total = total * i
Next
MsgBox "!" & passengers & "=" & total                        

If...Then...Else Statement

Relevant for: GUI actions, scripted GUI components, and function libraries

The If...Then...Else statement instructs UFT to perform a statement or a series of statements
based on specified conditions. If a condition is not fulfilled, the next Elseif condition orElse
statement is examined. It has the following syntax:

If condition Then
statement
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ElseIf condition2 Then
statement

Else
statement

End If

Item Description

condition Condition to be fulfilled.

statement Statement to be perform.

Example

In the following example, if the number of passengers is fewer than four, UFT closes the
browser:

passengers = Browser("Mercury Tours").Page("Find Flights").WebEdit("numpassengers").GetRO
Property("value")
If (passengers < 4) Then

Browser("Mercury Tours").Close
Else

Browser("Mercury Tours").Page("Find Flights").Image("continue").Click 69,5
End If

The following example uses If, ElseIf, andElse statements to check whether a value is equal
to 1, 2, or a different value:

value = 2
If value = 1 Then
msgbox "one"

ElseIf value = 2 Then
msgbox "two"

Else
msgbox "not one or two"

End If
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While...Wend Statement

Relevant for: GUI actions, scripted GUI components, and function libraries

AWhile...Wend statement instructs UFT to perform a statement or series of statements while a
condition is true. It has the following syntax:

While condition
statement

Wend

Item Description

condition A condition to be fulfilled.

statement A statement or series of statements to be executed during the loop.

In the following example, UFT performs a loop using theWhile statement while the number of
passengers is fewer than ten. Within each loop, UFT increments the number of passengers by one:

passengers = Browser("Mercury Tours").Page("Find Flights").WebEdit("numpassengers").GetRO
Property("value")
While passengers < 10

passengers = passengers + 1
Wend
msgbox("The number of passengers in the party is " & passengers)

With Statement

Relevant for: GUI actions and scripted GUI components

With statements make your script more concise and easier to read and write or edit by grouping
consecutive statements with the same parent hierarchy.

In addition, usingWith statements might help your script run faster. When running aWith
statement, UFT identifies the object in the application before running the first statement, but does
not re-identify it before running each statement.

On the other hand, this can affect the running of your test if the object referenced by theWith
statement is refreshed, redrawn, or changed in someway in the application while running theWith
statement. To instruct UFT to re-identify the object in the application before running the next
statement, add a statement that calls theRefreshObject test object operation. For details on the
RefreshObject operation, see theHP UFT Object Model Reference for GUI Testing.

TheWith statement has the following syntax:

With object
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statements
End With

Item Description

object An object or a function that returns an object.

statements One ormore statements to be performed on an object.

Example

You could replace this script:

Window("Flight Reservation").WinComboBox("Fly From:").Select "London"
Window("Flight Reservation").WinComboBox("Fly To:").Select "Los Angeles"
Window("Flight Reservation").WinButton("FLIGHT").Click
Window("Flight Reservation").Dialog("Flights Table").WinList("From").

Select "19097 LON"
Window("Flight Reservation").Dialog("Flights Table").WinButton("OK").Click

with the following:

With Window("Flight Reservation")
.WinComboBox("Fly From:").Select "London"
.WinComboBox("Fly To:").Select "Los Angeles"
.WinButton("FLIGHT").Click
With .Dialog("Flights Table")

.WinList("From").Select "19097 LON"

.WinButton("OK").Click
End With 'Dialog("Flights Table")

End With 'Window("Flight Reservation")

Note that enteringWith statements in the Editor does not affect the Keyword View in any way.

Note: In addition to enteringWith statements manually, you can also instruct UFT to
automatically generateWith statements as you record or to generateWith statements for an
existing test. For more details, see "How to GenerateWith Statements for Your Test" on page
978.

Report Modes
Relevant for: GUI actions, scripted GUI components, and function libraries

For details on using report modes, see "Filtering the GUI Steps Reported in the Run Session" on
page 1010.
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The following report modes are available:

Mode Description

0 or rfEnableAll All events are displayed in the Run Results.
Default.

1 or
rfEnableErrorsAndWarnings

Only events with a warning or fail status are displayed in the
Run Results.

2 or rfEnableErrorsOnly Only events with a fail status are displayed in the Run Results.

3 or rfDisableAll No events are displayed in the Run Results.

l To disable reporting of subsequent steps, enter the following statement:

Reporter.Filter = rfDisableAll

l To re-enable reporting of subsequent steps, enter:

Reporter.Filter = rfEnableAll

l To instruct UFT to include only subsequent failed steps in the Run Results, enter:

Reporter.Filter = rfEnableErrorsOnly

l To instruct UFT to include only subsequent failed or warning steps in the Run Results, enter:

Reporter.Filter = rfEnableErrorsAndWarnings

l To retrieve the current report mode, enter:

MyVar=Reporter.Filter

Formore details, see theHP UFT Object Model Reference for GUI Testing.
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Chapter 37: User-Defined Functions and Function
Libraries

Relevant for GUI tests and components

Note: The terms function, method, and operation are used interchangeably in this chapter.

This chapter includes:

Concepts 1030

Function Library Overview 1030

Associated Function Libraries 1031

User-Defined Functions 1032

User-Defined Function Storage and Access 1034

Registered User-Defined Functions 1035

Loading Function Libraries During a Run Session 1039

Tasks 1041

How to Create andManage Function Libraries 1041

How to Edit a Function Library 1043

How toManage Function Library Associations 1045

How to Create andWork with a User-Defined Function 1048

How to Create and Register a User-Defined Function Using the Function Definition
Generator 1051

Reference 1057

Function Definition Generator Dialog Box 1057

Troubleshooting and Limitations - Function Libraries 1065
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Concepts

Function Library Overview
Relevant for: GUI tests and components

In addition to the test objects, methods, and built-in functions supported by the UFT Test Object
Model, you can define your own function libraries containing VBScript functions, subroutines,
statement, and so on, and then call their functions from your test or use their functions as
operations in your test or component.

A function library is a separate document that contains Visual Basic script. Any text file written in
standard VBScript syntax can be used as a function library.

Your function libraries can contain:

l Function definitions (function signature and code). You can call these functions from other
functions, from actions in your test, or from your component. To call a function from a test or
component, youmust first associate the function library with the test or with the component's
application area.

l VBScript statements. These are statements that are not contained within function definitions
(for example, RegisterUserFunc statements). UFT runs all of these statements when it loads
the function library.

Loading Function Libraries
At the beginning of a run session, UFT loads all of the function libraries associated with your test or
with your component's application area.

In addition, you can use the LoadFunctionLibrary statement to dynamically load a function library
during a run session.

Editing Function Libraries
When you edit function libraries you can do any of the following:

l Open and work on one or several function libraries at the same time, as each function library
opens in a separate document tab.

l UseUFT tomodify and debug any existing function libraries (.vbs, .txt, or .qfl files), even if they
were created using an external editor.

For more details:

n On designing steps in function libraries, see "Programming in GUI Testing Documents in the
Editor" on page 994.

n On editing tools that UFT provides, such as syntax checking and statement completion, see
"UFT File Operations" on page 127.
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n On using VBScript, see "Handling VBScript Syntax Errors" on page 1016 and "Basic
VBScript Syntax" on page 1013.

n On debugging function libraries, see "Debugging Tests and Components" on page 674.

l Choose to open a function library in edit mode or read-only mode:

n Edit mode. Enables you to view andmodify the function library. While the function library is
open on your computer, other users can view the file in read-only mode, but they cannot
modify it.

n Read-only mode. Enables you to view the function library but not modify it. By default, when
you open a function library that is currently open on another computer, it opens in read-only
mode. You can also choose to open a function library in read-only mode if you want to review
it, but you do not want to prevent another user frommodifying it.

l Navigate directly from a function call in your document to its function definition in the source
document. The function definition can be located either in the same document (action or function
library) or in another function library that is associated with your test or component.

If the document containing the function definition is already open, UFT activates the document
(brings it into focus). If the document is closed, UFT opens it in read-only mode. For task details,
see "Navigate to the function's definition - optional" on page 1051.

l Close a function library after you finish editing it, leaving your UFT session open.

l Save the function library to your ALM project or to the file system. By default, UFT saves a
function library with a .qfl extension, unless you specify a different extension, such as .vbs or
.txt.

For tests:You can also save a function library as an attachment to a test in ALM for storage
purposes only. To insert function calls from this function library into a test, youmust first
associate the function library with the test. For details, see "How toManage Function Library
Associations" on page 1045.

For task details, see "How to Create andManage Function Libraries" on page 1041.

Associated Function Libraries
Relevant for: GUI tests and components

After you create your function libraries, you can associate them with your test or application area.
This enables you to insert a call to a public function or subroutine in the associated function library
from that test or any component associated with that application area.

At the beginning of a run session, UFT loads the function libraries associated with the test or
application area, and can then access their functions during the run session. Public functions stored
in function libraries can be called from any associated test or component, whereas private functions
can be called only from within the same function library.
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The order in the list of associated function libraries determines the order in which UFT searches for
a function or subroutine that is called from a step in your test or component. If there are two
functions or subroutines with the same name, UFT uses the first one it finds.

You can:

l Edit the list of associated function libraries for an existing test or application area

l Specify default function libraries for all new tests (tests only)

For details, see "How toManage Function Library Associations" on page 1045.

To use a function library without associating it to your test or application area, you can load the
function library dynamically during a run session using the LoadFunctionLibrary statement. For
details, see theUtility Objects section of theHP UFT Object Model Reference for GUI Testing.

If you dynamically load a function library during a run session, and a later step calls a function that
has the same name as a function in an associated function library, the function in the dynamically
loaded function library is used.

Working with Associated Function Libraries in ALM

Relevant for: GUI tests and components

You can associate a function library with a test, regardless of whether the function library is stored
in the file system or your ALM project. However, if you are planning to use the function library in a
business process test or if you are working with the Resources and Dependencies model, youmust
save it in your ALM project.

When working with ALM and associated function libraries, youmust save the function library in the
Test Resources module in your ALM project before you can associate it with the test or application
area. You can add a new or existing function library to your ALM project.

If you add an existing function library from the file system to an ALM project, you are actually adding
a copy of that file to the project. Therefore, if you later makemodifications to either of these function
libraries (in the file system or in your ALM project), the other function library remains unaffected.

A component accesses the functions that are associated with its application area. Therefore, any
changes youmake to a function library that is stored in your ALM project and associated with an
application areamay affect its associated components. Whenmaking changes to a function library
that is stored in your ALM project and associated with an application area, consider the effect of the
changes on the components that use this application area. In ALM, you can view the list of
components using the application area in the Dependencies tab of the Business Components
module. For details, see "Dependencies Tab (ALMModules) " on page 762"Dependencies Tab
(ALMModules) " on page 762.

User-Defined Functions
Relevant for: GUI tests and components

For tests or scripted components, if you have segments of code that you need to use several times
in your tests, youmay want to create a user-defined function.
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For keyword components, you can create user-defined functions to provide additional functionality.

You create the functions in VBScript. For details on using VBScript, see "Handling VBScript
Syntax Errors" on page 1016 and "Basic VBScript Syntax" on page 1013.

A user-defined function encapsulates an activity (or a group of steps that require programming) into
a keyword (also called an operation). By using user-defined functions, your tests or components are
shorter, and easier to design, read, andmaintain. You or a Subject Matter Expert can then call user-
defined functions from an action or a component by inserting the relevant keywords (or operations)
into that action or component.

For tests:Before you can call a function from an action, youmust add the function definition to the
action or to a function library that is associated with the action's test.

For components:Before you can call a function from a component, youmust add the function
definition to a function library that is associated with the component's application area.

Global Functions
A user-defined function is automatically defined as a global function. You can call global functions
by typing them in the step or selecting them from the lists displayed in the following locations:

l TheOperation box in the StepGenerator, when the Functions category is selected (for function
libraries)

l TheOperation column in the Keyword View, when theOperation item is selected from the Item
list

l The Editor, when using the statement completion feature

Functions That Are Registered to Test Objects

You can also register a user-defined function as amethod for a UFT test object class (type). A
registeredmethod can either override the functionality of an existing test object method for the
duration of a run session, or be registered as a new method for a test object class. You can call the
test object method by typing it in the step or selecting it from the list of operations available for the
test object.

For more details, see "Registered User-Defined Functions" on page 1035 and "How to Create and
Register a User-Defined Function Using the Function Definition Generator" on page 1051.

User-Defined Function Names
When deciding the name for your function, consider the following:

l During run-time, UFT searches the function libraries for the specified function in the order in
which they are listed in the Solution Explorer. This order determines the function library priority.

For tests, UFT searches for the specified function in the action before searching the function
libraries.

If UFT finds more than one function that matches the function name in a specific action or
function library, it uses the last function it finds in that action or function library.
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If UFT finds two functions with the same name in two different function libraries, it uses the
function from the function library that has the higher priority. To avoid confusion, it is
recommended that you verify that within the resources associated with a test or application
area, each function has a unique name.

l When you create a user-defined function, do not give it the same name as a built-in function (for
example, GetLastError,MsgBox, orPrint). Similarly, do not use VBScript registered words (for
example, cStr, F1, ESC) for function names. Built-in functions take priority over user-defined
functions, so if you call a user-defined function that has the same name as a built-in function, the
built-in function is called instead. For a list of built-in functions, see theBuilt-in functions list in
the StepGenerator (Design > Step Generator).

For details on naming conventions for function names, see "Troubleshooting - Naming
Conventions" on page 2269.

User-Defined Function Storage and Access
Relevant for: GUI tests and components

Using UFT, you can define and store your user-defined functions either in a function library (saved
as a .qfl file, by default) or directly in an action within a test.

When you store a public function in a function library and associate the function library with a test or
application area, the test or any component associated with that application area can call the public
functions in that function library. For details, see "Associated Function Libraries" on page 1031.

You can access the functions that are stored in an associated function library from the Step
Generator (for function libraries), theOperation column in the Keyword View, or the Toolbox pane,
or you can enter these functions manually in a function library or an action.

You can also define private functions and store them in a function library. Private functions are
functions that can be called only by other functions within the same function library. This is useful if
you need to reuse segments of code in your public functions.

By implementing user-defined functions in function libraries and associating them with your test or
component (via the component's application area), you and other users can choose functions that
perform complex operations, such as adding if/then statements and loops, or working with utility
objects—without adding the code directly to the test or needing any programming knowledge. In
addition, you save time and resources by implementing and using reusable functions.

For tests:

l When you store a function in an action, it can be called only from within that action—the function
cannot be called from any other action or test. This is useful if you do not want the function to be
available outside of a specific action.

l If the same function name exists locally within your action and within an associated function
library, the function defined in the action in used.
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Registered User-Defined Functions
Relevant for: GUI tests and components

You can register a public user-defined function to a test object to instruct UFT to use your user-
defined function as amethod of a specified test object class for the duration of a test or component
run, or until you unregister themethod.

A registeredmethod applies only to the run session in which you register it. All function registrations
are cleared at the beginning of each run session.

When you register a function to a test object class, you can register the function as a new operation
for the test object class, or you can choose to override the functionality of an existing operation.
You can unregister the function to disable new operations or to return existing operations to their
original UFT behavior.

For tests: If you call an external action that registers amethod (and does not unregister it at the end
of the action), themethod registration remains in effect for the remainder of the test that called the
action.

Availability of Registered User-Defined Functions (for tests)
After you register a function to a test object class, it can be called as amethod of that test object
class, in addition to being available as a global function.

UFT displays the function in the generalOperation list in the StepGenerator and in the list of
operations available for the test object displayed in the following locations:

l TheOperation box in the StepGenerator, when a test object of the relevant class is selected.

l TheOperation column in the Keyword View, when a test object of the relevant class is selected
from the Item list.

l The Editor, when you type the name of a test object of the relevant class and use the statement
completion feature.

When you register a function to a test object class, you can optionally define it as the default
operation for that test object class. This instructs UFT to use the function as the test object
operation by default, in the following situations:

l In theOperation column in the Keyword View, when you choose a test object of the relevant
class in the Item list.

l In theOperation box in the StepGenerator, when you choose a test object of the relevant class
from theObject list.

l In the Editor, when you drag in a test object of the relevant class from the object repository.

Availability of Registered User-Defined Functions (for components)
After you register a function to a test object class, it can be called as amethod of that test object
class, in addition to being available as a global function.
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UFT therefore displays the function in the Keyword View Operation list when a test object of that
class is selected from the Item list, as well as in the generalOperation list in the StepGenerator
(for function libraries).

When you register a function to a test object class, you can optionally define it as the default
operation for that test object class. This instructs UFT to display the function in theOperation
column in the Keyword View, by default, when you or a Subject Matter Expert choose a test object
from the relevant class in the Item list.

This section also includes:

Preparing the User-Defined Function for Registration 1036

Registering User-Defined Functions as Test Object Methods 1036

Unregistering User-Defined Test Object Methods 1037

Running anOverriding User-Defined Test Object Method 1038

Preparing the User-Defined Function for Registration

Relevant for: GUI tests and components

When you run a statement containing a registeredmethod, UFT sends the test object as the first
argument. For this reason, your user-defined functionmust have at least one argument. Your user-
defined function can have any number of arguments, or it can have only the test object argument.

If you register a user-defined function to override an existing test object method, then after the test
object argument, the functionmust have the same number of arguments as themethod it overrides.

Tip: You can use the parent identification property to retrieve the parent of the object
represented by the first argument in your function. For example:
ParentObj = obj.GetROProperty("parent")

Registering User-Defined Functions as Test Object Methods

Relevant for: GUI tests and components

To register a user-defined function as a test object method, you enter aRegisterUserFunc
statement in an action or function library. TheRegisterUserFunc statement specifies the test
object class, the name of your function, and the name of the test object method that should call your
function.

In this statement, you can also instruct UFT to use the function as the default operation for the test
object class.

You can register the same function tomore than one test object class, using the same operation
name for different test object classes, or different names.

After theRegisterUserFunc statement runs, your method becomes a recognizedmethod of the
specified test object class for the remainder of the run session, or until you unregister themethod.
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WhenUFT loads a function library it runs all the statements in the function library. Therefore, if the
function you are registering is defined in a function library, it is recommended to include the
RegisterUserFunc statement in the function library as well so that themethod is immediately
available for use in any test or component using that function library.

For task details, see "Register the function to a test object class - optional " on page 1049.

Unregistering User-Defined Test Object Methods

Relevant for: GUI tests and components

When you register amethod using aRegisterUserFunc statement, your method becomes a
recognizedmethod of the specified test object class for the remainder of the run session, or until
you unregister themethod.

If your method overrides a UFTmethod, unregistering themethod resets themethod to its normal
behavior. Unregistering other methods removes them from the list of methods supported by the test
object class.

For task details, see "Unregister the function - optional" on page 1051.

Additional Information for Tests

Unregisteringmethods is especially important when a reusable action contains registeredmethods
that override UFTmethods. For example, if you do not unregister amethod that uses a function
defined directly within a called action, then the calling test will fail if the registeredmethod is called
again in a later action, because it will not be able to find the function definition.

If you register amethod within a reusable action, you should unregister themethod at the end of the
action (and then re-register it at the beginning of the next action if necessary), so that tests calling
your action are not affected by themethod registration.

If the registered function was defined in a function library, then the calling test may succeed
(assuming the function library is associated with the calling test). However, unexpected results
may be produced as the author of the calling test may not realize that the called action contained a
registered function, and therefore, may use the registeredmethod in later actions, expecting normal
UFT behavior.

Unregistering Functions That Were Registered More Than Once
You can re-register the samemethod to use different user-defined functions without first
unregistering themethod. However, when you do unregister themethod, it resets to its original UFT
functionality (or is cleared completely if it was a new method), and not to the previous registration.

Example:

Suppose you enter the following statements:

RegisterUserFunc "Link", "Click", "MyClick"
RegisterUserFunc "Link", "Click", "MyClick2"
UnRegisterUserFunc "Link", "Click"
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After running theUnRegisterUserFunc statement, theClickmethod stops using the
functionality defined in theMyClick2 function, and returns to the original UFTClick
functionality, and not to the functionality defined in theMyClick function.

Running an Overriding User-Defined Test Object Method

Relevant for: GUI tests and components

You can register a user-defined function to (temporarily) override the functionality of an existing test
object method for a test object class.

When a user-defined function runs instead of the test object method it overrides, if it calls any
overridden test object methods, the standard functionality of thosemethods is used.

When you call the user-defined function directly, if it calls any overridden test object methods, their
overriding user-defined functions are used.

Examples

The following scenarios demonstrate various situations that are affected by this functionality:

A Registered User Function That Calls the Test Object Method It
Overrides
Suppose you want to report the current value of aWeb edit box to the run results before you set
a new value for it. You can override the standard UFT Setmethod with a function that retrieves
the current value of an edit box, reports that value to the run results, and then sets the new
value of the edit box using the standardSetmethod.

The function (and its registering line) would look something like this:

Function MySet (obj, x)
    dim y
    y = obj.GetROProperty("value")
    Reporter.ReportEvent micDone, "previous value", y
    obj.Set (x)
End Function
RegisterUserFunc "WebEdit", "Set", "MySet"

When a test or component step uses theWebEdit.Setmethod, the overridingMySet function
runs, and in turn, calls the original UFTWebEdit Setmethod.

However, when a test or component step uses theMySet function, the function runs and calls
the overriddenWebEdit.Setmethod, running theMySet function oncemore. This time,MySet
calls the original UFTWebEdit Setmethod.

A Registered User Function That Calls a Test Object Method That Is
Overridden by Another Function
Suppose you want to override theVbButton's standardClick method to always perform a
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double click. In addition, you want to override the standard UFTDblClick method with a
function that retrieves the text of the button and reports it to the run results before double-
clicking the button.

The functions (and their registering lines) would look something like this:

Function MyDblClick (obj, x, y, button)
    dim button_name
    button_name = obj.GetROProperty("text")
    Reporter.ReportEvent micDone, "Clicking", button_name
    obj.DblClick x, y, button
End Function
RegisterUserFunc "VbButton", "DblClick", "MyDblClick"
Function MyClick (obj, x, y, button)
    obj.DblClick x, y, button
End Function
RegisterUserFunc "VbButton", "Click", "MyClick"

When a test or component step uses theVbButton.Click method, the overridingMyClick
function runs. In this situation,MyClick will then run the original UFT VbButton DblClick
method.

When a test or component step uses theMyClick function, the function runs and calls the
overriddenVbButton.DblClick method, runningMyDblClick.MyDblClick reports the button
text to the run results and then calls the original UFT VbButtonDblClick method.

To ensure that theMyClick function always runs the overridden behavior forDblClick method,
you could callMyDblClick directly withinMyClick.

Loading Function Libraries During a Run Session
Relevant for: GUI tests and components

If you decide not to associate a function library (any VBScript file) with a test, but do want to be able
to call its functions, subroutines, and so forth, you can do so by loading the function library during
the run session.

Similarly, if you want to call a function that is not stored in an action in your test or in an associated
function library, store it in an independent VBScript file, and load that function library during the run
session.

To load a function library during a run session, insert a LoadFunctionLibrary statement or
ExecuteFile statement in your action, scripted component, or function library. When you run the
test, this statement runs all global code in the specified function library, making all definitions in the
file available for use. For details on these statements, see theUtility Objects section of the
HP UFT Object Model Reference for GUI Testing, available from the Unified Functional Testing
Help.
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The following table describes the differences between using each of these statements:

LoadFunctionLibrary ExecuteFile

In a test:After you run a
LoadFunctionLibrary statement, the
functions in the file are available to your
entire test, until the end of the run
session.

In a component:
LoadFunctionLibraryworks in the
sameway as ExecuteFile. After you
run the statement, the functions in the
file are available only within the scope of
the calling component.

After you run anExecuteFile statement, you can call
the functions in the loaded file only within the scope of
the calling action or component.

LoadFunctionLibrary enables you to
debug the functions in the function
library during run-time.

You cannot debug a file that is called using an
ExecuteFile statement, or any of the functions
contained in the file. In addition, when debugging a
test or component that contains anExecuteFile
statement, the executionmarker may not be correctly
displayed.

If you want functions in a function library (VBScript file) to always be available to your test or
component, associate the function library with your test or application area. For details, see
"Associated Function Libraries" on page 1031.
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Tasks

How to Create and Manage Function Libraries
Relevant for: GUI tests and components

This task describes the different activities you can perform tomanage function libraries in UFT. If a
function is stored in a function library, youmust associate the function library with a test or a
component's application area before you can call the function from the test or component.

This task includes the following steps:

l "Create a function library" below

l "Open a function library" on the next page

l "Edit a function library" on the next page

l "Enable editing for a read only function library " on the next page

l "Debug a function in a function library" on the next page

l "Associate a function library with a test or an application area" on page 1043

l "Load a function library dynamically during a run session" on page 1043

Create a function library
Do one of the following:

l Click theNew button down arrow and select Function Library. The "Open/New
<Document>/<Resource> Dialog Box" (described on page 156) opens, enabling you to specify
the location to save the function library.

Note: A newly created function library is not automatically associated to the current test or
component. Therefore, the new function library is not displayed in the Solution Explorer.

l Create a new function library file from the Application Area (for components only).

This also associates the function library with the application area, displaying it in the Solution
Explorer. For details, see "Function Libraries Pane (Application Area)" on page 2102.

l Create a new function library file from the Test Resources module in ALM. For details, see the
HP Application Lifecycle Management User Guide.

l Create VBScript function libraries outside of UFT in any editor and save them with a .qfl, .vbs,
or .txt extension.
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Open a function library
Do one of the following:

l Click theOpen button down arrow and select Function Library. The "Open/New
<Document>/<Resource> Dialog Box" (described on page 156) opens, enabling you to open a
function library from the file system or from an ALM project.

l If the function library was recently created or opened, select it from theRecent Files list in the
Filemenu.

l If the function library is associated with the open test, component, or application area, you can
also open it as follows:

n In the Solution Explorer, double-click the function library, or right-click the function library and
select Open Function Library.

n In the Toolbox pane, double-click the function library, or right-click the function library and
select Open Resource.

You can choose to open a function library in edit mode or read-only mode. For details, see
"Open/New <Document>/<Resource> Dialog Box" on page 156.

Tip: To open a function library, youmust have read or read-write permissions for the file.

Edit a function library
For details, see "How to Edit a Function Library" on the next page.

Enable editing for a read only function library
Right-click the function library tab in the document pane and select Enable Editing. You can now
edit the function library.

Note:

l You cannot enable editing if the function library is locked by another user or checked in to an
ALM project.

l During a debug session, all documents (such as tests or components and function libraries)
are read-only. To edit a document during a debug session, youmust first stop the debug
session.

Debug a function in a function library

1. Associate the function library with a test or component (for a component, you do this via its
application area).

2. In your test or component, insert a call to a function defined in the function library.
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3. Place a breakpoint at the beginning of the function in the function library.

4. Run the test or component. When the function is called, UFT pauses the run session at the
beginning of the function, enabling you to debug it.

For details, see "Debugging Tests and Components" on page 674.

Note:

n During a debug session, all documents are read-only and cannot be edited. To edit a
document during a debug session, youmust first stop the debug session.

n You cannot debug a file that is called using anExecuteFile statement, or any of the
functions contained in the file. In addition, when debugging a test that contains an
ExecuteFile statement, the executionmarker may not be correctly displayed.

To debug a dynamically loaded function library, use a LoadFunctionLibrary statement
to load it instead of anExecuteFile statement.

Associate a function library with a test or an application area
For details, see "How toManage Function Library Associations" on page 1045.

Load a function library dynamically during a run session
Add a the LoadFunctionLibrary statement to your action, scripted component, or associated
function library. For details, see theUtility Objects section of theHP UFT Object Model Reference
for GUI Testing and "Loading Function Libraries During a Run Session" on page 1039.

Tip: To include the same LoadFunctionLibrary statement in every action you create, you can
add the statement to an action template. For details, see "Create an action template" on page
886.

How to Edit a Function Library
Relevant for: GUI tests and components

This task describes how to edit a function library using the UFT editing features that are available in
the Editor.

Note: This task is part of a higher-level task. For details, see "How to Create andManage
Function Libraries" on page 1041.
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This task includes the following steps:

l "Add steps manually" below

l "Add steps using the StepGenerator (tests and scripted components only)" below

l "Drag and drop a function" below

l "Check the syntax of the code in your function library" below

Add steps manually
Whenwriting the steps in your function library, you can use standard VBScript statements as well
as any UFT reserved objects or test objects, and themethods available for these objects.

UFT applies the same editing settings to your function library as is does to content in the Editor of
an action. For details, see "Editing Text and Code Documents" on page 305.

Statement completion functionality is available for all functions defined in your action or component
and for public functions defined in associated function libraries.

Note: In function libraries, the statement completion feature does not enable you to view test
object names or collections because function libraries are not directly associated with object
repositories.

Add steps using the Step Generator (tests and scripted components only)
The "StepGenerator Dialog Box" (described on page 983) enables you to add steps that contain
reserved objects (the objects that UFT supplies for enhancement purposes, such as utility
objects), VBScript functions (such as MsgBox), utility statements (such asWait), and user-
defined functions that are defined in the same function library.

Drag and drop a function
You can drag and drop a function (or part of it) within the same document, or from one document to
another.

To drag and drop a function from one document to another:

1. Separate the tabbed documents into separate document panes by dragging one document by
its tab. You can then optionally dock the document in another location in UFT.

2. Select the relevant lines and drag and drop them from one document to another.

Check the syntax of the code in your function library
Select Design > Check Syntax. UFT checks the syntax of all the code in all open function libraries
and in function libraries associated with your tests. This may include function definitions and other
VBScript statements.

Tip: For details on using VBScript, see "Basic VBScript Syntax" on page 1013.
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How to Manage Function Library Associations
Relevant for: GUI tests and components

This task describes the different ways that you can associate a function library with a test or
application area or modify existing associations.

Note: This task is part of a higher-level task. For details, see "How to Create andManage
Function Libraries" on page 1041.

This task contains the following steps:

l "View the list of function libraries associated with a test or component" below

l "Associate the currently active function library with a test or an application area" below

l "Associate a function library with a test using the Test Settings dialog box (tests only)" on the
next page

l "Associate a function library with a test using the Solution Explorer pane (tests only)" on page
1047

l "Associate a function library with an application area using the Function Libraries pane
(components only)" on page 1047

l "Modify the priority of an associated function library" on page 1047

l "Remove a function library association" on page 1048

l "Specify default function libraries for all new tests (tests only)" on page 1048

View the list of function libraries associated with a test or component
Do one of the following:

l In the Solution Explorer pane, expand the Function Libraries node within the relevant test or
component's node.

l Select the test or component whose associated function libraries you want to view, and then
select File > Settings > Resources. The Resources pane of the Test/Business Component
dialog box opens.

Associate the currently active function library with a test or an application
area

1. Make sure that the test or application area with which you want to associate the function library
is included in your open solution.

2. Create or open a function library in UFT. For details, see "How to Create andManage Function
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Libraries" on page 1041.

3. Save the function library in the file system (for tests only) or in your ALM project.

4. In UFT, do one of the following:

n right-click the function library document tab and select Associate Library '<Function
Library>' with '<Test/Application Area>'.

n right-click the test or application area name node in the Solution Explorer and select
Associate Function Library.

Associate a function library with a test using the Test Settings dialog box
(tests only)

1. Create or open a test.

Note: You can access or create a test using a relative path. If you enter a relative path,
UFT searches for the test in the folders listed in the Folders pane of the Options dialog box
(Tools > Options > GUI Testing tab > Folders pane). For details, see "Folders Pane
(Options Dialog Box > GUI Testing Tab)" on page 544 and "Relative Paths in UFT for GUI
Testing" on page 130.

2. In the Test Settings dialog box (File > Settings), click theResources node.

3. In theAssociated function libraries list, click theAdd button , UFT displays a browse
button enabling you to browse to a function library in the file system. If you are connected to an
ALM project, UFT also adds [ALM] to the file path, indicating that you can browse to a function
library either in your ALM project or in the file system.

Tip: If you want to add a file from your ALM project but are not connected to ALM, press

and hold the SHIFT key and click theAdd button . UFT adds [ALM], and you can
enter the pathmanually. If you do, make sure there is a space after [ALM]. For example:
[ALM] Subject\Tests

Note that UFT searches ALM project folders only when you are connected to the
corresponding ALM project.

4. Select the function library you want to associate with your test and click Open.
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Associate a function library with a test using the Solution Explorer pane
(tests only)
In the Solution Explorer pane, do one of the following:

l Right click a GUI<test name> node and select Associate Function Library.

l Right-click the Function Libraries node within the relevant test's node in the tree and select
Associate Function Library.

The "Open/New <Document>/<Resource> Dialog Box" (described on page 156) opens.

The function library that you select is associated with the test and displayed as a node under the
Function Libraries node in the tree.

Note: A test node contains the Function Libraries node only if at least one function library is
associated with the test. If the relevant test does not contain a Function Libraries child node,
use one of the other associationmethods described in this task to associate the first function
library.

Associate a function library with an application area using the Function
Libraries pane (components only)

1. In UFT, open your application area and click the Function Libraries button on the
sidebar.

2. In theAssociated function libraries list, click theAdd button . UFT displays a browse
button enabling you to browse to a function library in your ALM project.

3. Select the function library you want to associate with your application area and click Open.

Modify the priority of an associated function library
For tests, do one of the following:

l In the Solution Explorer, expand the Function Libraries node for your test or application area,
right-click the function library you want to prioritize and selectMove up orMove down. For
details, see "Solution Explorer Pane User Interface" on page 478.

l In the list of associated function libraries in the Resources pane of the Test Settings dialog box
(for tests) or the Function Libraries pane (for application areas), select the function library you

want to prioritize and use theUp andDown arrows .

For details, see:

n For tests: "Resources Pane (Test/Business Component Settings Dialog Box) " on page 603

n For components: "Function Libraries Pane (Application Area)" on page 2102.
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Remove a function library association
Do one of the following:

l In the Solution Explorer, expand the Function Libraries node for your test or application area,
right-click the function library and select Remove Function Library from List, or select the
function library and press the DELETE key. For details, see "Solution Explorer Pane User
Interface" on page 478.

l In the list of associated function libraries in the Resources pane of the Test Settings dialog box
(for tests) or the Function Libraries pane (for application areas), select the function library you

want to remove and click theRemove button .

For details, see:

n For tests: "Resources Pane (Test/Business Component Settings Dialog Box) " on page 603.

n For components: "Function Libraries Pane (Application Area)" on page 2102.

l Open an associated function library in UFT. For details, see "How to Create andManage
Function Libraries" on page 1041.

Right-click the function library document tab and select Dissociate Library '<Function
Library>' from '<Test/Application Area>'.

Specify default function libraries for all new tests (tests only)
In the "Resources Pane (Test/Business Component Settings Dialog Box) ", described on page 603,
create the list of associated function libraries that you want to use for every newly created test, and
click theSet as Default button. (This does not affect existing tests.)

How to Create and Work with a User-Defined Function
Relevant for: GUI tests and components

This task describes how to create and work with a user-defined function.

This task includes the following steps:

l "Prerequisites - Open the function library or test " on the next page

l "Create the function" on the next page

l "Register the function to a test object class - optional " on the next page

l "Associate the function library with a test or application area" on page 1050

l "Call the function" on page 1050

l "Navigate to the function's definition - optional" on page 1051

l "Unregister the function - optional" on page 1051
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1. Prerequisites - Open the function library or test
a. For tests:Determine whether you want to store the function in an action or in a function

library.

o If you insert the function in a function library, the function will be accessible to any
associated test.

o If you insert the function directly in an action in the Editor, it can be called only from
within the specific action.

b. Create a new function library or action, open an existing one, or click on the tab of an open
function library or action to bring it into focus.

2. Create the function
You can define functions manually or using the Function Definition Generator, which creates
the basic function definition for you automatically.

Even if you prefer to define functions manually, youmay still want to use the Function
Definition Generator to view the syntax required to add header information, register a function
to a test object class, or set the function as the default method for that test object class. For an
in-depth view of the required syntax, you can define a function using the Function Definition
Generator and experiment with the various options.

For details, see "Function Definition Generator Dialog Box" on page 1057.

When writing the code for your function, consider the issues listed in "Troubleshooting and
Limitations - Function Libraries" on page 1065. For details on using VBScript, see theMicrosoft
VBScript Language Reference (Help > HP Unified Functional Testing Help > VBScript
Reference > VBScript).

Note:

n If you want to register the function to a test object class, define it as a public function,
andmake sure that it expects the test object as the first argument.

n If you want to override an existing test object method, make sure that after the test
object argument, your function accepts the same number of arguments as themethod it
overrides.

3. Register the function to a test object class - optional
You can register your function as a new method for the test object class, or you can register it
using an existingmethod name to (temporarily) override the existing functionality of the
specifiedmethod.

You can perform this stepmanually, or using the "Function Definition Generator Dialog Box"
(described on page 1057):
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n Add aRegisterUserFunc statement in your action or function library. The name of the test
object operation you register cannot contain spaces. In this statement, you can also instruct
UFT to use the function as the default operation for the test object class.

Example:

RegisterUserFunc "WebEdit", "MySet", "MySetFunc", True

After this statement runs (during the run session), theMySet method (operation) is
added to theWebEdit test object class using theMySetFunc user-defined function, and
defined to be the default operation (as specified in the last argument of the statement).

If you or the Subject Matter Expert choose theWebEdit test object from the Item list in
the Keyword View, theMySet operation is selected automatically in theOperation
column. It is also displayed in theOperation list together with other registered and out
of the box operations for theWebEdit test object.

For syntax and other examples, see theUtility Objects > Utility Statements section of the
HP UFT Object Model Reference for GUI Testing, available from the Unified Functional
Testing Help.

n If you use the "Function Definition Generator Dialog Box" (described on page 1057) to create
your function definition, aRegisterUserFunc statement is automatically added immediately
after the definition if you select theRegister to a test object option.

You can add additional RegisterUserFunc statements manually to register the function to
additional test object classes.

Tip: If the function you are registering is defined in a function library, it is recommended
to include theRegisterUserFunc statement in the function library as well so that the
method will be immediately available for use in any test or component using that
function library.

4. Associate the function library with a test or application area
If you inserted the code in a function library, youmust associate the function library with a test
or application area to enable tests and components to access to the user-defined functions. For
details, see "How toManage Function Library Associations" on page 1045.

Alternatively, you can add a LoadFunctionLibrary statement to your test or component to
load the function library during the run session and access its functions. For details, see the
Utility Objects > Utility Statements section of theHP UFT Object Model Reference for GUI
Testing.

5. Call the function
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In your test, component, or function library, do one or both of the following:

n Create steps that call your user-defined function as a global function.

n Run the user-defined function by calling the test object method to which it is registered.

6. Navigate to the function's definition - optional
You can navigate directly from a function call to the function's definition.

a. In the Editor, in an action, click in the step containing the relevant function.

b. Perform one of the following:

o Select Search > Go to > Definition.

o Right-click the step and select Go to Definition from the context menu.

UFT activates the relevant document (if the function definition is located in a function
library) and positions the cursor at the beginning of the function definition.

7. Unregister the function - optional
If you do not want your function to remain registered until the end of the run session, add an
UnRegisterUserFunc statement in your test or function library. For syntax and an example,
see theUtility Objects > Utility Statements section of theHP UFT Object Model Reference
for GUI Testing.

For tests: If you register amethod within a reusable action, you should unregister themethod
at the end of the action (and then re-register it at the beginning of the next action if necessary),
so that tests calling your action are not affected by themethod registration.

How to Create and Register a User-Defined Function
Using the Function Definition Generator

Relevant for: GUI tests and components

This task provides a general description of each step required to create a user-defined function and
register it to a test object class using the "Function Definition Generator Dialog Box" (described on
page 1057). This task also includes examples for some of the steps.

Note: This task is part of a higher-level task. For details, see "How to Create andWork with a
User-Defined Function" on page 1048.

This task includes the following steps:

l "Prerequisite - Open the function library or action" on the next page

l "Open the Function Definition Generator" on the next page
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l "Specify the details for the function definition" below

l "Register the function to a test object class - optional" below

l "Add arguments to the function - optional" on the next page

l "Add documentation details to the function - optional" on the next page

l "Preview the function definition before finalizing it" on page 1054

l "Insert the function in your active document " on page 1055

l "Add the content (code) of the function" on page 1055

l "Results" on page 1055

1. Prerequisite - Open the function library or action
Make sure that the function library or action in which you want to insert the function definition is
the active document. (You can click the function library or action document's tab to bring it into
focus.) This is because the Function Definition Generator inserts the function in the currently
active document after you finish defining it.

2. Open the Function Definition Generator
Select Design > Function Definition Generator. The "Function Definition Generator Dialog
Box" (described on page 1057) opens.

3. Specify the details for the function definition
Specify the function's name, type, and scope in the "Function Definition Area" on page 1059.

Example:

If you want to define a function that verifies the value of a specified property, youmight
name it VerifyProperty and define it as a public function so that it can be called from any
associated test or component. (If you define it as private, the function can be called only
from elsewhere in the same function library. Private functions cannot be registered to a
test object class.)

4. Register the function to a test object class - optional
If you defined a public function and you want to register the function as a test object operation,
do the following in the "Registration Area" (described on page 1061):
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a. Select theRegister to a test object check box.

b. Select the test object from the list of available objects.

Example:

For the sampleVerifyProperty function, youmight want to register it to the Link test
object.

c. Enter the name of a new operation that you want to add to the test object class, or select an
existing operation to specify the operation that you want to override its standard
functionality. The name of themethod cannot contain spaces.

Example:

For the sampleVerifyProperty function, youmight want to define a new
VerifyProperty operation.

d. Optionally, specify that this operation is the default operation for test objects of this type.

Tip: If you choose not to register your function at this time, you canmanually register
it later by adding aRegisterUserFunc statement as described in "Register the
function to a test object class - optional " on page 1049. You can also add additional
RegisterUserFunc statements, to register the function to additional test object
classes.

5. Add arguments to the function - optional
Specify any arguments that are required for your function to run correctly. For details, see
"Arguments Area" on page 1062.

Example:

For theVerifyProperty function, registered to a test object class in the example for the
previous step, youmay want to assign the arguments prop_name (the name of the
property to check) and expected_value (the expected value of the property), in addition to
the first argument, test_object.

6. Add documentation details to the function - optional
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DefineDescription andDocumentation strings for the test object operation. For details, see
"Additional Information Area" on page 1063.

Example:

n For the sampleVerifyProperty function, youmay want to provide the following
description:

Checks whether a property value matches the actual value.

n If you were checking a link to "HP" from a search engine, youmight define the following
documentation using the Function Definition Generator:

`@Documentation Check if the <Test object name> <Test object type> <prop_name> val
ue matches the expected value: <expected_value>.

In the Keyword View, after you create a step that calls theVerifyProperty operation
and choose values for the arguments, the above documentationmight be displayed as
follows:

Check if the "Management Software" link "text" value matches the expected value: "Busin
ess Technology Optimization (BTO) Software".

7. Preview the function definition before finalizing it
As you add information to the Function Definition Generator, thePreview area displays the
emerging function definition. You can review your function andmake any changes, as needed,
in the various areas of the dialog box. For details, see "Bottom Area" on page 1064.

Example:

After defining theVerifyProperty function as described in the previous steps, thePreview
area displays the following code:

‘@Description Checks whether a property matches its expected value
‘@Documentation Check whether the <Test object name> <Test object type> <prop_name>
value matches the expected value: <expected_value>.
Public Function VerifyProperty (test_object, prop_name, expected_value)

‘TODO: add function body here
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End Function
RegisterUserFunc "Link", "VerifyProperty", "VerifyProperty"

8. Insert the function in your active document
a. To generate an additional function definition after inserting this one, select Insert another

function definition. TheOK button changes to Insert.

b. Click OK or Insert. UFT inserts the generated VBScript code in the active document.

9. Add the content (code) of the function
To finalize the function, add content to the function code, as required, replacing the TODO
comment.

When writing the code for your function, consider the issues listed in "Troubleshooting and
Limitations - Function Libraries" on page 1065. For details on using VBScript, see theMicrosoft
VBScript Language Reference (Help > HP Unified Functional Testing Help > VBScript
Reference > VBScript).

Example:

For example, if you want the function to verify whether the expected value of a property
matches the actual property value of a specific test object, youmight add the following to
the body of the function:

Dim actual_value
    ' Get the actual property value
    actual_value = obj.GetROProperty(prop_name)
    ' Compare the actual value to the expected value
    If actual_value = expected_value Then
        Reporter.ReportEvent micPass, "VerifyProperty Succeeded", "The " & prop_name & " ex
pected value: " & expected_value & " matches the actual value"
        VerifyProperty = True
    Else
        Reporter.ReportEvent micFail, "VerifyProperty Failed", "The " & prop_name & " expected
value: " & expected_value & " does not match the actual value: " & actual_value
        VerifyProperty = False
    End If

10. Results
n If you inserted the function in a function library, the function is now accessible to any

associated test or component.

If you inserted the function directly in an action in the Editor, it can be called only from within
the specific action.
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To associate the function library with additional tests or application areas, see "How to
Manage Function Library Associations" on page 1045.

n If you registered the function to a test object, the function is displayed in the list of available
operations for the test object, as well as in the generalOperation list in the StepGenerator
(for function libraries). For details on where you can view the list of operations available for a
test object, see "Registered User-Defined Functions" on page 1035.

You can add additional RegisterUserFunc statements, to register the function to additional
test object classes. For details, see "Register the function to a test object class - optional "
on page 1049.

n If you specified that the function is the default operation for the test object, the function is
used as the test object operation, by default, when you create steps with that test object.
For details, see "Registered User-Defined Functions" on page 1035.

n If you defined a description and aDocumentation string for the test object operation, they
are displayed in the Keyword View and the StepGenerator.
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Reference

Function Definition Generator Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to:

l Generate definitions for new user-defined functions.

l Add header information to the function you create.

l Register the functions to a test object class, if needed.

You fill in the required information and the Function Definition Generator creates the basic function
definition for you. You complete the function by adding its content (code).
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For a task that describes the order of working with this dialog box and provides examples, see
"How to Create and Register a User-Defined Function Using the Function Definition Generator" on
page 1051.

To access Select Design > Function Definition Generator

Important
information

Before you open the dialog box, make sure that the function library or action
(displayed in the Editor) in which you want to insert the function definition is the
active document. (You can click the function library or action document's tab to
bring it into focus.) This is because the Function Definition Generator inserts the
function in the currently active document when you click OK.

Relevant
tasks

l "How to Create and Register a User-Defined Function Using the Function
Definition Generator" on page 1051

l "How to Create andWork with a User-Defined Function" on page 1048
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See also l "User-Defined Functions" on page 1032

l "User-Defined Function Storage and Access" on page 1034

l "Registered User-Defined Functions" on page 1035

This dialog box contains the following key areas:

l "Function Definition Area" below

l "Registration Area" on page 1061

l "Arguments Area" on page 1062

l "Additional Information Area" on page 1063

l "Bottom Area" on page 1064

Function Definition Area

User Guide
Chapter 37: User-Defined Functions and Function Libraries

HP Unified Functional Testing (12.00) Page 1059 of 2274



User interface elements are described below:

UI
Elements Description

Name A name for the new function.

The name should clearly indicate what the operation does so that it can be easily
selected from the StepGenerator or in the Keyword View.

For a list of naming conventions, see "Troubleshooting - Naming Conventions" on
page 2269.

Note:

Do not use any of the built-in function names (for example, GetLastError,
MsgBox, orPrint). For a list of built-in functions, see theBuilt-in functions list
in the StepGenerator (Design > Step Generator).

Try to give each function a name that is unique within the resources associated
with a specific test or application area.

For details, see "User-Defined Function Names" on page 1033.

Type The type of function.

Possible values:

l Function

l Sub (subroutine)

Scope The scope of the function.

Possible values:

l Public. The function can be called by any test associated with this function
library and any component whose application area is associated with this
function library.

l Private. The function can be called only from elsewhere in the same function
library.

Default value:Public

Note:

l Only public functions can be registered to a test object class.

l If you create a user-defined functionmanually and do not define the scope as
Public orPrivate, it is treated as a public function, by default.
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Registration Area

User interface elements are described below:

UI
Elements Description

Register
to a test
object

Indicates whether to register this function as an operation for a UFT test object
class.

All user-defined functions are available as global operations. If you register the
function to a test object class, it can be also be called by test objects of that class,
and is displayed in the list of available operations for such test objects. For details,
see "Registered User-Defined Functions" on page 1035.

Note: If you select this option, then when the Function Definition Generator
creates your function definition, it also automatically adds a
RegisterUserFunc statement with the correct argument values immediately
after the definition.

Test
object

The test object class (type) to which you want to register the function.

Available:WhenRegister to a test object is selected

Operation The operation name to use for this function.

You can select an existing test object operation to override its functionality, or enter
a name for a new operation to add to the test object class.

Do not include spaces in the test object operation name.

Available:WhenRegister to a test object is selected

Register
as default
operation

Indicates whether the function should be the default operation for the test object
class.

This instructs UFT to use the function as the test object operation, by default, when
you create steps for test objects of the specified type. For details, see "Registered
User-Defined Functions" on page 1035.

Note: If you select this option, then when the Function Definition Generator
creates your function definition, it specifies the value True as the fourth
argument of theRegisterUserFunc statement.

Available:WhenRegister to a test object is selected
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Arguments Area

Important
information

When calling a function that is registered to a test object class, UFT passes the
test object as the first argument. Therefore:

l If you select theRegister to a test object check box, the Function Definition
Generator automatically adds the argument, test_object, as the first argument
in this area.

l If you clear theRegister to a test object check box, the default test_object
argument is automatically removed from this area (unless you renamed it).

User interface elements are described below:

UI Elements Description

A toolbar that enables you to add, remove, or re-arrange arguments in the
list. You can add as many arguments as you want to the list.

Caution:

l If you are registering the function to a test object class, do not
remove the test_object argument, change its location in the list, or
modify its Pass Mode.

l If you are registering the function to override an existing test object
method, then after the test object argument, the functionmust have
the same number of arguments as themethod it overrides.

Name The argument name.

The name should clearly indicate the value that needs to be entered for the
argument. For a list of naming conventions, see "Troubleshooting - Naming
Conventions" on page 2269.

Pass Mode Specifies whether the argument is passed to the functionBy value orBy
reference during run-time.
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Additional Information Area

The Function Definition Generator can add header information to your user-defined function
definitions, based on the information you add in this area.

User interface elements are described below:

UI Elements Description

Description The function's description.

If you register the function as a test object operation, the description is
displayed as a tooltip in UFT when the cursor is positioned over the operation
in the StepGenerator, in the Keyword View, and when using the statement
completion feature.

Keep the description text brief and clear.

Documentation A sentence (in the imperative form) that specifies exactly what a step using
your function does.

If you register the function as a test object operation, the text that you add
here is displayed in theStep documentation box of the StepGenerator (tests
only) and in theDocumentation column in the Keyword View. Therefore, the
sentencemust be clear and understandable.

Insert Documentation Element. Displays a list that contains the function's
arguments, and the items test object name and test object type, enabling
you to include these items in theDocumentation text.

If you use the argument or test object items in theDocumentation text, they
are replaced dynamically by the relevant test object names and types or
argument values when you create a step that uses the operation.

Note: The Test object name and Test object type items are available in
the list only if you selected theRegister to a test object check box.
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Bottom Area

User interface elements are described below:

UI Elements Description

Preview Displays the VBScript code that the Function Definition Generator will add to
your active document, based on the information that you enter in the dialog box.

The code is displayed in read-only format and includes:

l An empty function definition

l Header information for the function documentation (if defined)

l A RegisterUserFunc statement (if you selectedRegister to a test object)

The function definition is displayed dynamically, as you enter the information.
You can review your function andmake any changes, as needed, in the various
areas of the dialog box.

Insert
another
function
definition

Specifies whether the dialog box should remain open after you click OK,
enabling you to define an additional function.

If you select this option, theOK button changes to Insert.

OK / Insert Inserts the generated VBScript code in the active document and clears the data
from the dialog box.
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Troubleshooting and Limitations - Function Libraries
Relevant for: GUI tests and components

This section describes troubleshooting and limitations for user-defined functions and function
libraries.

l If you define a VBScript class, it can be called only within the UFT action or function library in
which you defined it.

Workaround:

a. You can use anExecuteFile statement to call a VBScript class defined in an external
function library. However, you cannot debug a file that is called using an ExecuteFile
statement, or any of the functions contained in the file. In addition, when debugging a test or
component that contains an ExecuteFile statement, the executionmarker may not be
correctly displayed.

b. In the function library in which you define the class, create a function that sets an object as
your class, and returns the object. Then you can call this function from anywhere in your test
or component, to assign an object of your class to a variable you define.

Example:

Suppose you want to use the class myClass. In the same function library as you define
myClass, define the following function:

public function myClassGenerator()
set myClassGenerator = new myClass
end function

Now, you can use themyClass class by callingmyClassGenerator, like this:

set myClassObject = myClassGenerator()

myClassGenerator() creates a new myClass object and assigns it tomyClassObject.

l You can use theRegisterUserFunc statement to register a user-defined function that overrides
an existing test object method. You can also register a user-defined function to override a test
object method that was created using a UFT Extensibility SDK. If you override this type of test
object method, the user-defined functionmust not (recursively) call the test object method that it
overrides.

l By default, steps that use user-defined functions are not included in the run results after a run
session. If you want the function to appear in the run results, youmust add aReportEvent
Method statement to the function code. For example, youmay want to provide additional
information or to modify the test, component, or business process test status. For details on the
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Reporter.ReportEvent statement, see the Utility Objects section of theHP UFT Object Model
Reference for GUI Testing.

If a step within your user-defined function calls a standard UFT test object method, this step will
appear in the run results after the run session. However, you can still add a
Reporter.ReportEvent statement to the function code to provide additional information and to
modify the test, component, or business process test status, if required.

l For tests: If you use a partial run or debug option, such as Run from step orDebug from step,
to begin running a test from a point after method registration was performed in a test step (and
not in a function library), UFT does not recognize themethod registration because it occurred
prior to the beginning of the current run session.

l If you delete a function in use from an associated function library, the step using the function will

display the icon. In subsequent run sessions for the test, component, or business process
test, an error will occur when the step using the non-existent function is reached.

l To use anOption Explicit statement in a function library associated with your test or
component, youmust include it in all of the function libraries associated with the test or
component. If you include anOption Explicit statement in only some of the associated function
libraries, UFT ignores all of theOption Explicit statements in all function libraries.

In test actions, you can useOption Explicit statements directly without any restrictions.

l Each function library must have unique variables in its global scope. If you have two associated
function libraries that define the same variable in the global scope using aDim statement or
define two constants with the same name, the second definition causes a syntax error. If you
need to usemore than one variable with the same name in the global scope, include aDim
statement only in the last function library (since function libraries are loaded in the reverse order).

l Function libraries that run in the same run sessionmust not contain different definitions for the
same class. Make sure that each class is defined in only one location.

l If another user modifies a function library that is referenced by a test or component, or if you
modify the function library using an external editor (not UFT), the changes take effect only after
the test or component is reopened.

l Function libraries that contain the Cyrillic ' ' character and are saved in ANSI encodingmay be
interpreted incorrectly in UFT. For example, the ' ' character may be interpreted as a newline
character, causing the run to fail.

Workaround: If this problem occurs, use a text editor to convert the function library by saving it
in Unicode encoding.
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Chapter 38: Integration with API Tests
Relevant for: GUI tests only

This chapter includes:

Concepts 1068

Integrating API Tests and Actions into GUI Tests 1068

Using API Tests in a GUI Test - Use-Case Scenario 1069

Tasks 1073

How to Integrate API Tests and Actions in GUI Tests 1073

Reference 1075

Call to API Test/Action Dialog Box 1075
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Concepts

Integrating API Tests and Actions into GUI Tests
Relevant for: GUI tests only

UFT enables you to test your GUI-less applications (also known as headless applications) while
testing your GUI. For example, you can test standardWeb Services, non-SOAPWeb Services,
such as REST, and so on.

You can include calls from your GUI test to API tests and actions if UFT is using an HP Unified
Functional Testing (also known as UnifiedFunctionalTesting) license.

When you insert a call to an API test or action, the call is displayed under the relevant GUI action in
the canvas and in the action (displayed in the Editor).

If UFT is connected to an ALM project that contains API tests, you can call an API test or action
that is stored in that project. When you run the test, make sure that the UFT client on which you run
the test has access to an HP Unified Functional Testing license.

You insert andmodify calls to API tests using the "Call to API Test/Action Dialog Box" (described
on page 1075). When you insert a call, you can also specify the parameter values that UFT will use
when running the test or action. If a parameter has a default value, you can retain it or modify it as
needed.

For a use case scenario describing this process, see "Using API Tests in a GUI Test - Use-Case
Scenario" on the next page.
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How UFT Runs the Called API Test or Action

When a step containing a call to an API test or action is reached, UFT opens the called test and
runs it. During the run session, the Output pane displays a real-time log of the steps that are being
performed in the API test, as shown in the following example. For details on what is contained in
these steps, see "Output PaneOverview" on page 380.

Note: UFTmust be using an HP Unified Functional Testing (instead of a QuickTest-only)
license to run a call to an API test within a GUI test.

If a Unified Functional Testing license type is not available, the run session behavior is
different depending on whether the test runs from UFT or from ALM.

l When running from UFT: TheGUI test runs until the step calling the API test is reached,
and then fails.

l When running from ALM: If the GUI test contains a call to an API test, UFT does not
open and the test does not run.

After the run session, the results display information about the UFT test including the called API
test or action. You can view these results in the Run Results Viewer. For details, see the section
describing GUI Tests Containing Calls to API Tests (described in theHP RunResults Viewer User
Guide).

Using API Tests in a GUI Test - Use-Case Scenario
Relevant for: GUI tests only

Suppose you want to test that the API (nonGUI, or service) layer of your application performs
correctly with the GUI layer of your application. You want to see that when you perform specific
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steps in the user interface the API (service) processes that accompany the commands given by the
user interface are completed correctly.

This use-case scenario describes an example of how to incorporate tests for the API (service) layer
of your application into a GUI test. For the purposes of this scenario, you will be using a flight
booking application similar to theMercury Tours Flight GUI and Flight API applications provided
with the UFT installation and used in the Tutorial for GUI Testing and Tutorial for API Testing.

Note: For a task related to this scenario, see "How to Integrate API Tests and Actions in GUI
Tests" on page 1073.

Tip: For additional information and user interface details, see "Integrating API Tests and
Actions into GUI Tests" on page 1068 and "Call to API Test/Action Dialog Box" on page 1075.

In your application, you have four different pages, which correspond to the different tasks involved
in booking a flight:

l Logging in to the booking site (Login Page)

l Finding flight options based on customer selections for departure city, arrival city, and flight date
(Flight Finder Page)

l Selecting a flight from the list of flight options (Select Flight Page)

l Booking and confirming a customer's flight selection. (Book Flight Page)

In addition, your application has a number of API processes to help the application process flight
booking requests:

l Finding user login credentials in the database (Login operation)

l Searching for a list of all available flights and displaying the flight list (FindFlights operation)

l Creating a flight order (CreateFlight operation)

l Confirming a flight booking (ConfirmBookFlight operation)

l Updating a flight order (UpdateFlightOrder operation)

l Deleting a flight order (DeleteFlightOrder operation)

l Deleting all flight orders (DeleteAllFlightOrders operation)

You create a separate GUI action for each application page, giving it the same name as the page
name. You also create a separate test for each API process, naming each test with the process
name.

Note: For details on creating API tests, see "How to Create an API Test" on page 1598
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In order to fully test your application, you decide to place an API test after eachGUI test.The API
test checks to see whether the API processes run by that specific application's page (Login,
Flight Finder, Select Flight, orBook Flight) are working correctly.

In your GUI actions, you insert a call to the corresponding API test usingDesign > Call to

Existing API Test/Action or by clicking the Insert Call to Action down arrow and selecting
Call to Existing API Test/Action.

The API test appears is displayed as nested inside the GUI action:

After you insert all the calls to the corresponding API tests, you have a call to an API test inside
each of your GUI test actions as listed in the table below:

GUI Test Action Name
Calls API
test:

Login Page Login

Flight Finder Page FindFlights

Select Flight Page CreateFlight

Book Flight Page ConfirmBookFlig

Note: If you want to pass data from a API test to use in anGUI test, Youmust create a test
output parameter in your API test. For details, see "Add Input/Output Property/Parameter
Dialog Box (API Testing)" on page 1775
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After adding the necessary calls to your API tests, you can run the test. TheGUI test executes
each step the user interface in the flight booking application user interface. For each API test call in
the GUI test, UFT compiles the API test and runs it. UFT displays the API test steps running in the
Output pane.

After the test run is complete, you can check the test results for the GUI test, including calls to
each of the API tests. The Run Results Viewer shows the completion and pass/fail status for each
step.

Using this, you can create composite tests of your application, enabling you to simultaneously test
the GUI and API (service) sides of your application by running a single test.
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Tasks

How to Integrate API Tests and Actions in GUI Tests
Relevant for: GUI tests only

This task describes how to insert a call to an API test or action.

This task includes the following steps:

l "Prerequisites" below

l "Insert or modify a call to an API test" below

l "Use value of the API test parameters in a GUI test" on the next page

1. Prerequisites
A UnifiedFunctionalTesting licensemust be loaded. For details, see "Add-in Manager Dialog
Box" on page 118.

2. Insert or modify a call to an API test
Use the "Call to API Test/Action Dialog Box" on page 1075 (described on page 1075), which
you open as follows:

n To insert a new call, select Design > Call to Existing API Test/Action or click the Insert

Call to New Action toolbar button and select Call to Existing API
Test/Action.

n Tomodify an existing call, right-click the step in the canvas or the Editor and select Edit
Call to API Test/Action.

Note: Do not insert a call to an API test or action that contains a call to a GUI test, as
this can cause unexpected behavior.

UFT inserts a step that calls the API test or action, for example:

RunAPITest "<API test name>"

HP Unified Functional Testing (12.00) Page 1073 of 2274



The call to the API test is displayed in the canvas as a call inside the relevant action of the GUI
test:

3. Use value of the API test parameters in a GUI test
After you add a call to an API test or action, the input and output parameters are available for
use in your GUI test.

The use of parameter values contained in an API test during aGUI test run differs if you are
using input and output parameters:

n If you want to use values for the API test input parameters during aGUI test run, specify
the parameter value in the "Call to API Test/Action Dialog Box". When the API test is run
during the GUI test, UFT uses the values you specified for the appropriate parameters in the
API test.

n If you want to use values for the API test output parameters, youmust assign a variable
name to the output parameter in the "Call to API Test/Action Dialog Box" or assign the API
test output value to a variable or a data table parameter in the GUI test. This variable or data
table parameter is then available to use in other steps of the GUI test.

For details on using parameters in your GUI test or action, see "Parameterizing Object Values"
on page 1526.
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Reference

Call to API Test/Action Dialog Box
Relevant for: GUI tests only

This dialog box enables you to specify the test path, the context (entire test or specific action), and
parameter values for a call to an API test or action.

The following image shows an example of a call to an API test with one argument for which you can
defined a value.
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To access 1. Do one of the following:

n Ensure that a GUI test or action is in focus in the document pane.

n In the Solution Explorer, select a GUI test or action node.

2. Do one of the following:

n New call:Select Design > Call to Existing API Test/Action or click the

Insert Call to New Action toolbar button and select Call to
Existing API Test/Action.

n Existing call:Right-click the step in the canvas or the editor and select
Edit Call to API Test/Action.

Important
information

l If you double click on the call to the test or action in theExternal Tests node in
the Solution Explorer, the test is opened in the document pane and added to
the current solution.

l Do not insert a call to an API test that contains a call to a GUI test, as this can
cause unexpected behavior.

Relevant
tasks

"How to Integrate API Tests and Actions in GUI Tests" on page 1073

See also "Integrating API Tests and Actions into GUI Tests" on page 1068

User interface elements are described below:

UI
Elements Description

Test path The path to the API test to which you are inserting a call. You can insert a test path
in any of the following ways:

l browse to a test path

l select a test path from the drop down list of recently called API tests

l enter a test pathmanually

You can insert a relative or absolute test path.

Call to The API test or action to which you are inserting a call. You can insert a call to:

l the entire test

l a specific action in the test
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UI
Elements Description

<Argument
grid>

The list of arguments in the API test, including both input and output parameters. If
an argument has a default value, that value is displayed in theValue column in the
Keyword View of the action in which the test is called.

You can enter a constant value for each argument, or you can use parameter
values from a data table, random number parameter, environment variable
parameter, or a GUI test or action input parameter.

You insert a parameter value by clicking the parameterization button and
specifying it in the "Value Configuration Options Dialog Box" (described on page
1579).

Note:

l Parameter values are read-only in aValues cell. Tomodify a parameter
value, click theX to clear the cell. Then enter a replacement value.

l XML structures are not relevant for this option because they are not
supported as argument types for API tests and actions.
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Chapter 39: Maintaining and Updating GUI Tests or
Components

Relevant for: GUI tests and components

This chapter includes:

Concepts 1079

Why Tests or Components Fail 1079

Maintenance RunMode 1080

Update RunMode 1081

Tasks 1085

How to UseMaintenance RunMode to Update Your Test or Component When Your
Application Changes 1085

How to Update Test Object Descriptions, Checkpoints, or Output Values, or Active
Screen Captures 1088

Reference 1091

Maintenance RunWizard 1091

Update Options Tab (Update Run Dialog Box) 1107

Troubleshooting and Limitations - MaintenanceMode 1110
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Concepts

Why Tests or Components Fail
Relevant for: GUI tests and components

Tests or components fail when UFT encounters a step it cannot perform or the results of a step
indicate failure. In many cases this is due to the application being tested not functioning properly.
UFT then provides you with run results that assist you in understanding how to fix your application.

Sometimes a test or component fails because the application being tested has changed from when
the test or component was created and the test or component needs to be updated to reflect those
changes. Your object repository may also bemissing some of the objects it needs to run the test.
UFT provides tools that help identify and resolve some of these issues.

Object Changes

WhenUFT runs a step in a test or component, it looks for the object referred to by that step, in the
object repositories associated with that test or component. Using the description of the object in the
repository, UFT attempts to identify that object in the application.

UFT may not be able to identify the object in the application for a number of reasons:

The Object Does Not Exist in the Application
UFT cannot find an object in the application that matches the description of the object in the object
repository. TheMaintenance RunWizard enables you to identify the object that you want your test
or component to use.

The Parent Object Changed
UFT cannot find an object in the application that matches and has the same hierarchy as the object
in the object repository. TheMaintenance RunWizard enables you to identify the object that you
want your test or component to use.

The Object Description Property Values Changed
UFT cannot find an object in the application that is similar to, and has the same description property
values as the object in the object repository. TheMaintenance RunWizard enables you to identify
the object that you want your test or component to use.

The Object Does Not Exist in the Object Repository
UFT looks for the object to which the test or component refers, in the associated object repositories
before attempting to identify that object in the application. If the object in your test or component
cannot be found in any associated object repository, TheMaintenance RunWizard enables you to
identify the object in your application that you want to add to your repository and use in your test or
component.
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Checkpoint Changes

Checkpoints fail when they encounter conditions in the application being tested that are
unexpected. In many cases this is due to the application not functioning properly. UFT provides you
with run results that assist you in understanding how to fix your application.

Sometimes checkpoints fail because the application has changed since the test or component was
created and the checkpoints need to be updated to reflect those changes. Update RunMode
enables you to update the checkpoints in your test or component to reflect changes in the
application.

For example, suppose your application has an edit box whose default value used to be <Enter
value> and you have a checkpoint that checks this value before a new value is entered in the edit
box. If the default value in the application changes to be <Enter name> then your checkpoint will
fail. Update RunMode enables you to update the expected values of your checkpoint to reflect the
change in the application.

Maintenance Run Mode
Relevant for: GUI tests and components

You can useMaintenance RunMode to update the test objects in the object repositories associated
with your test or component when UFT cannot locate one or more objects in your application during
a run session.

When you run a test or component in Maintenance RunMode, theMaintenance RunWizard opens
each time it encounters any of following problems and provides the described solutions:

Problem Solution

The step failed because
the object in your test or
component cannot be
identified in the
application.

TheMaintenance RunWizard helps you identify the object in the
application that you want your test or component to use.

If you point to an object in the application being tested, the
Maintenance RunWizard compares that object to the objects in the
associated object repositories.

Depending on how the property values of the object to which you
point compare to the property values of the objects in the associated
repositories, theMaintenance RunWizard suggests one of several
options for updating your test or component to reflect the changes in
the application.

You can also choose to add a comment to your test or component
before the failed step.
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Problem Solution

The step failed because
the object in your test or
component is missing
from your associated
object repositories.

TheMaintenance RunWizard helps you add themissing object to
the repository.

You can also choose to add a comment to your test or component
before the failed step.

The object in your step
exists in the application,
but can be identified only
through Smart
Identification.

Identifying objects using Smart Identificationmay cause tests or
components to run slower. (For details, see "Smart Identification" on
page 1316.) TheMaintenance RunWizard helps youmodify the
description of the object, so that Smart Identification is not needed.

When theMaintenance RunMode ends, theMaintenance RunWizard provides a summary of the
changes it made to your test or component. The Run Results Viewer also contains aMaintenance
Summary that displays details of the changes made to your test or component, including updated
and added objects, updated and commented steps, and a summary of changes to the object
repository.

Note: Maintenance RunMode does not support complex checkpoint types such as File
checkpoints and XML checkpoints. During theMaintenance Run, these checkpoints run as
they would in a regular run session and will fail if there are differences between expected and
actual values.
(This note applies to output values as well as checkpoints.)

Update Run Mode
Relevant for: GUI tests and components

You can use Update RunMode to update your test object descriptions, checkpoints, output values,
or, for tests and scripted components, Active Screen captures. When you run a test or component
in Update RunMode, UFT runs the test or component to update the set of identification properties
used for test object descriptions, the Active Screen images and values, and/or the expected
checkpoint values.

UFT updates the set of identification properties for each object class in your associated object
repositories according to the properties currently defined in the "Object Identification Dialog Box"
(described on page 1325). If the case-sensitivity designation of a property value has changed since
you learned the object, update runmode also updates that setting. After you save the test or
component, the updated data is used for subsequent runs.

For task details, see "How to Update Test Object Descriptions, Checkpoints, or Output Values, or
Active Screen Captures" on page 1088.

How Test Object Descriptions are Updated when UFT uses Smart
Identification
If you have a test or component that runs successfully, but in which certain objects are identified
using Smart Identification, you can change the set of properties used for object identification and
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then use theUpdate test object descriptions option to update the test object description to use
the set of properties that Smart Identification used to identify the object.

When you run the test or component withUpdate test object descriptions selected, UFT finds
the test object specified in each step based on its current test object description. If UFT cannot find
the test object based on its description, it uses the Smart Identification properties to identify the test
object (if Smart Identification is enabled). After UFT finds the test object, it then updates its
description based on themandatory and assistive properties that you define in the "Object
Identification Dialog Box" (described on page 1325).

How Test Object Descriptions are Updated When they Contain Parameters
or Regular Expressions
Any properties that were used in the previous test object description and are no longer part of the
description for that test object class, as defined in the "Object Identification Dialog Box" (described
on page 1325), are removed from the new description, even if the values were parameterized or
defined as regular expressions.

If the same property appears both in the test object's new and previous descriptions, one of the
following occurs:

l If the property value in the previous description is parameterized or specified as a regular
expression andmatches the new property value, UFT keeps the property's previous
parameterized or regular expression value. For example, if the previous property value was
defined as the regular expression button.*, and the new value is button1, the property value
remains button.*.

l If the property value in the previous description does not match the new property value, but the
object is found using Smart Identification, UFT updates the property value to the new, constant
property value. For example, if the previous property value was button.*, and the new value is
My button, if a Smart Identification definition enabled UFT to find the object,My button becomes
the new property value. In this case, any parameterization or use of regular expressions is
removed from the test object description.

How the Case-Sensitivity of Properties is Updated
Most identification property values are not case-sensitive, meaning that UFT identifies an object in
an application if it matches the test object description, even if the capitalization of the property
values is different. However, UFT does treat some identification property values for specific test
objects as case-sensitive. In some cases, the case-sensitivity of some identification properties
may change from one version of UFT to the next, or as a result of a patch or hotfix installation.

In those cases, when you use Update Run to update test object descriptions, UFT also updates
any case-sensitivity settings that may have changed.

User Guide
Chapter 39: Maintaining and Updating GUI Tests or Components

HP Unified Functional Testing (12.00) Page 1082 of 2274



Below is an example of the run results for a step in which the case-sensitivity of some identification
properties were updated from case-insensitive to case-senstive.:

Example of When to Update Test Object Descriptions

Updating test object descriptions can be especially useful when you want to create or debug
your test or component steps using object property values that are easy to recognize in your
application (such as object labels), but may be language- or operating system-dependent. After
you debug your test or component, you can use theUpdate Run Mode option to change the
object descriptions to usemore universal property values.

Suppose you design a test or component for the English version of part of your application. The
test objects are recognized according to the identification property values in the English
version, some of whichmay be language-dependent. You now want to use the same test or
component for the French version of your application.

To do this, you define properties that are non-language-dependent, so that UFT can use these
properties for object identification. For example, you can identify a link object by its target
property value instead of its text property value. You can then perform an update run on the
English version of this part of your application using these new properties. This modifies the
test object descriptions so that you can later run the test or component successfully on the
French version of your application.

When to Update Checkpoint Properties and Output Property Values
Suppose you defined a text checkpoint as part of your test, and the text in your application has
changed since you created your test. You can update the test to update the checkpoint properties to
reflect the new text.

UFT updates the expected values of your checkpoints to reflect any changes that may have
occurred in your application since you created the test and updates the list of items that can be
retrieved in your output value steps.

Note: Update Run does not support updating complex checkpoint types such as File
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checkpoints and XML checkpoints. During the Update Run, these checkpoints run as they
would in a regular run session and will fail if there are differences between expected and actual
values.
(This note applies to output values as well as checkpoints.)

When to Update Active Screen Images and Values (tests and scripted
components only)
Suppose a dialog box in your application has changed since you recorded your test. You can update
the test to update the dialog box appearance and its properties in the Active Screen.

UFT updates images and property values in the Active Screen to reflect any changes that may
have occurred in your application since you recorded the test or if the Active Screen does not
appear as it should.

You can also use this option to increase or decrease the amount of information saved and displayed
in your Active Screen. Change the Capture Level slider (Tools > Options > GUI Testing tab >
Active Screen node), and run the test in Update RunMode with theUpdate Active Screen
images and values check box selected. UFT updates the amount of information it saves and
displays in the Active Screen, based on the new setting. For more details, see "Active Screen Pane
(Options Dialog Box > GUI Testing Tab)" on page 547.

The Update Runmode does not update Insight test objects. To update an Insight test object, open

the object in the object repository, and click theChange Test Object Image button in the Test
object image area. For more details, see "Change Test Object Image / Add Insight Test Object
Dialog Box" on page 1233.
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Tasks

How to Use Maintenance Run Mode to Update Your Test
or Component When Your Application Changes

Relevant for: GUI tests and components

This task describes how to use theMaintenance RunWizard to help youmaintain your test or
component.

This task includes the following steps:

l "Prerequisites" below

l "Decide how long UFT should wait before determining that an object cannot be found (tests only)
(Optional)" below

l "Run the test or component in Maintenance RunMode" on the next page

l "Export andmerge changes to your shared object repository (Optional) " on the next page

l "Analyze the results of theMaintenance RunMode session in the Run Results Viewer" on the
next page

1. Prerequisites
n Youmust have theMicrosoft Script Debugger installed to run the tests or components in

Maintenance RunMode. If it is not installed, you can use the UFT Additional Installation
Requirements Utility to install it. (Select Start > Programs > HP Software > HP Unified
Functional Testing > Tools > Additional Installation Requirements.)

Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75.

n You can run inMaintenance RunMode only when UFT is set to use theNormal (displays
executionmarker) runmode. It cannot run in Fastmode. For details, see "Test Runs Pane
(Options Dialog Box > GUI Testing Tab)" on page 539.

n You cannot run tests or components in Maintenance RunMode on applications that do not
have a user interface.

2. Decide how long UFT should wait before determining that an object
cannot be found (tests only) (Optional)
TheMaintenance RunWizard opens often when your application has changed and UFT is
unable to identify objects. Youmay want to decrease the amount of time UFT waits for an
object to be displayed before determining that the object cannot be found. You can change the
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object synchronization timeout in the Run pane of the Test Settings dialog box. Ensure that the
timeout specified is sufficient for the objects in your application to load. For more details, see
"Run Pane (Test Settings Dialog Box)" on page 601.

After Maintenance RunMode finishes youmay want to return this setting to its previous value
for regular test runs. (The default setting is 20 seconds.)

3. Run the test or component in Maintenance Run Mode
a. Select Run > Maintenance Run Mode or click the down arrow next to theRun button in

the toolbar and selectMaintenance Run Mode.

b. Specify the results location and the input parameter values (if applicable) for the
Maintenance RunMode session. For details, see "Run Dialog Box" on page 651, and "Run
Dialog Box: Input Parameters Tab (For GUI and API tests and components)" on page 655.

c. Follow the steps in the "Maintenance RunWizard " on page 1091. For details, see
"Maintenance RunWizard " on page 1091 and"Maintenance RunWizardWorkflow" on the
next page.

Tip: As an alternative to using theMaintenance RunWizard, you can update
individual test object descriptions from the object in your application using theUpdate
from Application option in the Object Repository window or Object Repository
Manager. For details, see "Updating Identification Properties from anObject in Your
Application" on page 1206.

4. Export and merge changes to your shared object repository (Optional)
After using theMaintenance RunWizard to update the test or component, youmay want to use
theUpdate from Local Repository option in the Object Repository Manager to merge the
objects from the local repository back to a shared object repository. For details, see "How to
Update a SharedObject Repository From a Local Object Repository" on page 1358.

5. Analyze the results of the Maintenance Run Mode session in the Run
Results Viewer
By default, when the run session ends, the Run Results Viewer opens. For details on viewing
the run session results, see theHP RunResults Viewer User Guide If you cleared theView
results when run session ends check box in theRun Sessions pane of the Options dialog
box (Tools > Options > General tab > Run Sessions node), the Run Results Viewer does
not open at the end of the run session. For details on the Options dialog box, see "Run
Sessions Pane (Options Dialog Box > General Tab)" on page 526
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Maintenance Run Wizard Workflow

Relevant for: GUI tests and components

Note: TheObject Not Found Page does not open when UFT uses Smart Identification to
identify an object in your test. In that case, theMaintenance RunWizard suggests updating the
object properties according to the properties currently defined in the "Object Identification
Dialog Box" (described on page 1325).
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How to Update Test Object Descriptions, Checkpoints, or
Output Values, or Active Screen Captures

Relevant for: GUI tests and components

This task describes how to update your test or component data so that it is accurate for subsequent
runs.

This task includes the following steps:

l "Determine which data types you want to update " below

l "Run in Update RunMode" below

l "Export andmerge changes to your shared object repository (Optional) " below

l "Analyze the results of the Update RunMode in the Run Results Viewer" on the next page

1. Determine which data types you want to update
For details, see "Update RunMode " on page 1081.

2. Run in Update Run Mode
a. Specify the settings for the update run process. For details, see "Update Options Tab

(Update Run Dialog Box)" on page 1107.

b. Enter any required input parameter values in the Input Parameters tab. For details, see
"Run Dialog Box: Input Parameters Tab (For GUI and API tests and components)" on page
655.

When UFT updates tests, it runs through only one iteration of the test and one iteration of
each action in the test, according to the run option selected. For details on actions, see
"Actions in GUI Testing" on page 871.

When a test runs in Update RunMode, it does not update parameterized values, such as
Data pane data and environment variables. For details on parameterized values and
environment variables, see "Parameterizing Object Values" on page 1526. Update Run
Mode does not modify the property values of existing object descriptions in the object
repository. To fix the object property values tomatch your application, useMaintenance
Run Mode. For more details, see "How to UseMaintenance RunMode to Update Your
Test or Component When Your Application Changes " on page 1085.

3. Export and merge changes to your shared object repository (Optional)
WhenUFT updates tests or components, it always saves the updated objects in the local
object repository, even if the objects being updated were originally from a shared object
repository. The next time you run the tests or components, UFT uses the objects from the local
object repository, as the local object repository has a higher priority than any shared object
repositories.
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After using Update RunMode to update the test or component, youmay want to use the
Update from Local Repository option in the Object Repository Manager to merge the objects
from the local repository back to a shared object repository. For details, see "How to Update a
SharedObject Repository From a Local Object Repository" on page 1358.

4. Analyze the results of the Update Run Mode in the Run Results Viewer
The run results for an update run session are always saved in a temporary location.

Test objects that cannot be identified during the update process are not updated. As in any run
session, if an object cannot be found during the update run, the run session fails, and
information on the failure is included in the Run Results. In these situations, youmay want to
useMaintenance Run Mode to resolve these problems.

Because Update Run does not support updating complex checkpoint types such as File
checkpoints and XML checkpoints, then these checkpoints run as they would in a regular run
session and will fail if there are differences between expected and actual values.

By default, when the run session ends, the Run Results Viewer opens. For details on viewing
the run session results, see theHP RunResults Viewer User Guide. If you cleared theView
results when run session ends check box in theRun Sessions pane of the Options dialog
box (Tools > Options > General tab > Run Sessions node), the Run Results Viewer does
not open at the end of the run session. For details on the Options dialog box, see "Run
Sessions Pane (Options Dialog Box > General Tab)" on page 526.

When the update run ends, the Run Results Viewer can show:

n Updated values for checkpoints.

n Updated test object descriptions.

User Guide
Chapter 39: Maintaining and Updating GUI Tests or Components

HP Unified Functional Testing (12.00) Page 1089 of 2274



For example:
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Reference

Maintenance Run Wizard
Relevant for: GUI tests and components

This wizard enables you to update your test or component when your application changes.

To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document pane.

n In the Solution Explorer, select a GUI test or component node.

2. Use one of the following:

n Select Run > Maintenance Run Mode

n Click the down arrow next to theRun button in the toolbar and select
Maintenance Run Mode.

Important
information

See the prerequisite information in "How to UseMaintenance RunMode to
Update Your Test or Component When Your Application Changes " on page 1085.

Relevant
tasks

"How to UseMaintenance RunMode to Update Your Test or Component When
Your Application Changes " on page 1085

Show me To see a demonstration of this functionality, go to the HP Live Network (HPLN)
 page and select theMaintenance Run Modemovie from the list.

Wizard
map

"Maintenance RunWizardWorkflow" on page 1087

See also l "Why Tests or Components Fail" on page 1079

l "Maintenance RunMode" on page 1080

The wizard contains the following pages:

Object Not Found Page (Maintenance RunWizard) 1092

Add Comment Page (Maintenance RunWizard) 1094

ChangeObject Property Values Page (Maintenance RunWizard) 1096

Update Step with Existing Object Page (Maintenance RunWizard) 1099

AddObject to Repository Page (Maintenance RunWizard) 1101

Smart Identification Page (Maintenance RunWizard) 1104

MaintenanceMode Summary Page (Maintenance RunWizard) 1106
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Object Not Found Page (Maintenance Run Wizard)

Relevant for: GUI tests and components

This wizard page enables you to identify theObject that could not be found and theStepUFT was
trying to perform.

TheObject Not Found page opens when an object in your test or component cannot be found in the
application you are testing or in the associated object repositories.

Wizard
map

"Maintenance RunWizardWorkflow" on page 1087
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See also The wizard contains the following additional pages:

l "Add Comment Page (Maintenance RunWizard)" on the next page

l "ChangeObject Property Values Page (Maintenance RunWizard)" on page
1096

l "Update Step with Existing Object Page (Maintenance RunWizard)" on page
1099

l "AddObject to Repository Page (Maintenance RunWizard)" on page 1101

l "Smart Identification Page (Maintenance RunWizard)" on page 1104

l "MaintenanceMode Summary Page (Maintenance RunWizard)" on page 1106

User interface elements are described below:

UI
Elements Description

Point to
the Object

Click thePoint button and point to the object in the application that should be used
in the step. Use this option if you know the application has changed and
identifying a new object for use in the step will resolve the issue, or if the object
does not exist in the associated object repositories.

If the location to which you point is associated with several objects, the "Object
Selection Dialog Box " (described on page 1195) opens. Select the correct object
from the tree and click OK.

The Point to the Object option is disabled when:

l The test or component is open in read-only mode.

l The object is used within a function library function.

l The object's method is defined as a registered user function.

Add a
Comment

Use this option if you want to add a comment to your test as a reminder to fix the
failed step.

The Add a Comment option is disabled when:

l The test or component is open in read-only mode.

l The object is used within a function library function.

l The object's method is defined as a registered user function.
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UI
Elements Description

Suggestion Displayed only if theMaintenance RunWizard cannot find an object in the
application that was not found earlier in theMaintenance RunWizard run as well.
If, when the object was first not found, you chose to replace it with a different
object, theMaintenance RunWizard suggests replacing it with the same object
now.

Use as
default

If, in subsequent steps the same object cannot be found, theMaintenance Run
Wizard automatically replaces the object not found with the object you added to
the object repository. TheMaintenance RunWizard does not open on these
subsequent steps.

Skip Skips the current step in the test or component and continues to run the
Maintenance RunWizard on the remainder of the test or component. This can be
used when the problem is in the application being tested and not in the test or
component.

Before clicking Skip, ensure that the application is ready for the next step in the
test or component.

Retry Retries the current step.

Stop Stops theMaintenance Run and opens the "MaintenanceMode Summary Page
(Maintenance RunWizard)".

Add Comment Page (Maintenance Run Wizard)

Relevant for: GUI tests and components

This wizard page enables you to add a comment to your test or component before the current step.
This can be used when you believe there is a problem in your test or component, but identifying the
object in the application will not solve the problem, or you want to fix the test or component
manually.

The Add Comment page creates a comment in your test or component beginning with the word
TODO along with text you add, as a reminder to fix the step at a later time.
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Wizard
map

"Maintenance RunWizardWorkflow" on page 1087

See also The wizard contains the following additional pages:

l "Object Not Found Page (Maintenance RunWizard)" on page 1092

l "ChangeObject Property Values Page (Maintenance RunWizard)" on the next
page

l "Update Step with Existing Object Page (Maintenance RunWizard)" on page
1099

l "AddObject to Repository Page (Maintenance RunWizard)" on page 1101

l "Smart Identification Page (Maintenance RunWizard)" on page 1104

l "MaintenanceMode Summary Page (Maintenance RunWizard)" on page 1106
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Change Object Property Values Page (Maintenance Run Wizard)

Relevant for: GUI tests and components

This wizard page enables you to update the property values of the object in the associated object
repository to match the property values of the object to which you pointed in the application.

The ChangeObject Property Values page opens when the object to which you pointed is of the
same class as the object in your step, but it has different description property values.

Important
information

If the object to which you point has a different parent object than the one in the
object repository and has different property values, the ChangeObject Property
Values page opens twice. The first time it enables you to update the parent object
of the object in the object repository to match the parent object of the object to
which you pointed. The second time it enables you to update the object in the
object repository to match the object to which you pointed.

Wizard
map

"Maintenance RunWizardWorkflow" on page 1087
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See also The wizard contains the following additional pages:

l "Object Not Found Page (Maintenance RunWizard)" on page 1092

l "Add Comment Page (Maintenance RunWizard)" on page 1094

l "Update Step with Existing Object Page (Maintenance RunWizard)" on page
1099

l "AddObject to Repository Page (Maintenance RunWizard)" on page 1101

l "Smart Identification Page (Maintenance RunWizard)" on page 1104

l "MaintenanceMode Summary Page (Maintenance RunWizard)" on page 1106

Change Object Property Values Page - Central Area
User interface elements of the central area of the ChangeObject Property Values page are
described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Object The object in an associated object repository that is of the same class as the
object to which you pointed in the application.

Object
Properties

A table displaying the changes that will bemade to the property values of the
object in the object repository.

Property The name of the property whose value will be changed.

Original Value The original property value of the object in the object repository.

New Value The new property value for the object in the object repository, based on the
object to which you pointed in the application.
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UI Elements Description

<Recommended
regular
expression>

Depending on the object to which you pointed, the ChangeObject Property
Value pagemay include amessage that a regular expression can be used to
update the property value of the object in the associated object repository.
You canmodify the suggested regular expression in the edit box. For details
on regular expressions, see "Regular Expressions Overview" on page 318.

Note:

l If theMaintenance RunWizard does not determine that a regular
expression is relevant for the new property value, the ChangeObject
Property Value page does not display the suggested regular
expression below the properties table. The Update the <property
name> property to use the regular expression and rerun the step
radio button is also not displayed.

l In a situation wheremore than one property can use a regular
expression, theMaintenance RunWizard suggests a regular
expression only for the first property value.

Change Object Property Values Page - Options
User interface elements are described below:

UI Elements Description

Update the object
property and rerun
the step

Updates the property values of the object in the object repository to
match those of the object to which you pointed in the application, and
reruns the step. The new property values are shown under New Value.

Update the <property
name> property to
use the regular
expression and
rerun the step

Displayed only if the property value can be updated to use a regular
expression. Updates the property value of the object in the object
repository with the regular expression as shown in the edit box, and
reruns the step.

Add the object as a
new object in the
local object
repository, and then
update and rerun the
step

Adds the object to which you pointed, with its current properties, as a
new object in the local object repository. This new object may already
exist in an associated object repository. Depending on whether the
object you want to add already exists in an associated object
repository, one of the following pages opens:

l "Update Step with Existing Object Page (Maintenance RunWizard)"
on the next page

l "AddObject to Repository Page (Maintenance RunWizard)" on
page 1101
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UI Elements Description

Keep the original
object properties,
add a comment, and
continue to the next
step

Keeps the original object properties of the object in the object
repository. Opens the Add Comment page, enabling you to add a
comment before the step, and then continues to the next step.

Reset Returns to the Object Not Found page, where you can point to a
different object in the application or choose a different course of action
for this step.

Update Step with Existing Object Page (Maintenance Run Wizard)

Relevant for: GUI tests and components

This wizard page enables you to update the step in your test to use an object that already exists in
an associated object repository.

The Update Step with Existing Object page opens if the object to which you pointed in the Object
Not Found page exists in an associated object repository and:

l The object to which you pointed is not of the same class as the object in your step, but with
different description property values.

Or

l In the ChangeObject Property Values page you choseAdd the object as a new object in the
local object repository, and then update and rerun the step.
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Wizard map "Maintenance RunWizardWorkflow" on page 1087

See also The wizard contains the following additional pages:

l "Object Not Found Page (Maintenance RunWizard)" on page 1092

l "Add Comment Page (Maintenance RunWizard)" on page 1094

l "ChangeObject Property Values Page (Maintenance RunWizard)" on page
1096

l "AddObject to Repository Page (Maintenance RunWizard)" on the next page

l "Smart Identification Page (Maintenance RunWizard)" on page 1104

l "MaintenanceMode Summary Page (Maintenance RunWizard)" on page
1106
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Update Step with Existing Object Page - Central Area
User interface elements of the central area of the Update Step with Existing Object page are
described below:

UI
Elements Description

Object The object in an associated object repository that is the same as the object to
which you pointed in the application.

Object
Properties

The properties and property values of the object to which you pointed in the test
application.

Original
Step

The failed original step, with the object that could not be found.

New Step The new step as it would appear updated to refer to the object which already
exists in an associated object repository.

Update Step with Existing Object Page - Options
User interface elements are described below:

UI Elements Description

Update the step and
rerun it

Updates the failed step as shown under New Step and reruns the step.

TheMaintenance RunWizard does not remove the original step from
your test or component. The original step is converted into a comment
and the updated step is added below it.

Keep the original
step and continue
to the next step

Keeps the original step and continues to run theMaintenance Run
Wizard on the remainder of the test or component.

Reset Returns to the Object Not Found page, where you can point to a different
object in the application or choose a different course of action for this
step.

Add Object to Repository Page (Maintenance Run Wizard)

Relevant for: GUI tests and components

This wizard page enables you to add the object to which you pointed to the object repository.
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The AddObject to Repository page opens when:

l the object in your step does not exist in any associated repository.

l the object to which you pointed does not exist in any associated object repository and:

n the object to which you pointed is not of the same class as the object in your step, but with
different description property values.

Or

n in the ChangeObject Property Values page you choseAdd the object as a new object in
the local object repository, and then update and rerun the step.

Wizard
map

"Maintenance RunWizardWorkflow" on page 1087
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See also The wizard contains the following additional pages:

l "Object Not Found Page (Maintenance RunWizard)" on page 1092

l "Add Comment Page (Maintenance RunWizard)" on page 1094

l "ChangeObject Property Values Page (Maintenance RunWizard)" on page
1096

l "Update Step with Existing Object Page (Maintenance RunWizard)" on page
1099

l "Smart Identification Page (Maintenance RunWizard)" on the next page

l "MaintenanceMode Summary Page (Maintenance RunWizard)" on page 1106

Add Object to Repository Page - Central Area
User interface elements are described below:

UI Elements Description

Object The object to which you pointed in the test application.

Object
Properties

The properties and property values of the object to which you pointed in the test
application.

Original Step The failed original step, with the object that could not be found.

New Step The new step as it would appear updated to refer to the object being added to
the object repository.

Add Object to Repository Page - Options
User interface elements are described below:

UI Elements Description

Add the object and
then update and rerun
the step

Adds the new object to the object repository, updates the failed step
as shown under New Step and reruns the step.

TheMaintenance RunWizard does not remove the original step from
your test or component. The original step is converted into a
comment and the updated step is added below it.

Keep the original
object and step, and
continue to the next
step

Keeps the original step containing the original object and continues
to run theMaintenance RunWizard on the remainder of the test or
component.

Reset Returns to the Object Not Found page, where you can point to a
different object in the application or choose a different course of
action for this step.
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Smart Identification Page (Maintenance Run Wizard)

Relevant for: GUI tests and components

This wizard page enables you to update the object description according to the properties currently
defined in the "Object Identification Dialog Box" (described on page 1325).

The Smart Identification page opens if UFT used the Smart Identificationmechanism to identify the
object in your test or component. For details on the Smart Identificationmechanism, see "Smart
Identification" on page 1316.

Smart Identificationmay slow down test or component execution, as it is only activated after the
object synchronization timeout has been reached.

Important
information

Your test may use Smart Identification because the set of properties used for
object identification does not uniquely identify all the objects of a particular class.
You can use theUpdate test object descriptions option of Update Run Mode
to change the set of properties used for object identification for all objects in a
specific class. This may bemore useful than using theMaintenance RunWizard
for every object in that class. For more details, see "How Test Object
Descriptions are Updated when UFT uses Smart Identification" on page 1081.
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Wizard
map

"Maintenance RunWizardWorkflow" on page 1087

See also The wizard contains the following additional pages:

l "Object Not Found Page (Maintenance RunWizard)" on page 1092

l "Add Comment Page (Maintenance RunWizard)" on page 1094

l "ChangeObject Property Values Page (Maintenance RunWizard)" on page
1096

l "Update Step with Existing Object Page (Maintenance RunWizard)" on page
1099

l "AddObject to Repository Page (Maintenance RunWizard)" on page 1101

l "MaintenanceMode Summary Page (Maintenance RunWizard)" on the next
page

Smart Identification Page - Central Area
User interface elements are described below:

UI
Elements Description

Object The object in your application that required the use of the Smart Identification
mechanism to be identified.

Step The step in your test in which the object is referenced.

Object
Properties

Property. The list of properties in the old and new object description.

Original Property Value. The original value of the property in theProperty
column. Properties that have no value were not part of the original object
description.

New Property Value. The new value of the property in theProperty column.

Smart Identification Page - Options
User interface elements are described below:

UI Elements Description

Update the
object
description

Updates the object description to use the set of properties currently defined
in the "Object Identification Dialog Box" on page 1325 for the object in your
test. Make sure that the set of properties defined in the Object Identification
dialog box for the object is sufficient to uniquely identify the object.
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UI Elements Description

Keep the original
description and
continue to the
next step

Keeps the original step containing the original object and continues to run
theMaintenance RunWizard on the remainder of the test or component.
The Smart Identification page does not open for this object again during the
run.

Apply this
selection to all
objects using
Smart
Identification in
this run

Uses your radio button selection above for all objects in the test or
component that need the Smart Identificationmechanism to be identified.

Maintenance Mode Summary Page (Maintenance Run Wizard)

Relevant for: GUI tests and components

This wizard page enables you to view a summary of theMaintenanceMode run.

Wizard
map

"Maintenance RunWizardWorkflow" on page 1087
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See also The wizard contains the following additional pages:

l "Object Not Found Page (Maintenance RunWizard)" on page 1092

l "Add Comment Page (Maintenance RunWizard)" on page 1094

l "ChangeObject Property Values Page (Maintenance RunWizard)" on page
1096

l "Update Step with Existing Object Page (Maintenance RunWizard)" on page
1099

l "AddObject to Repository Page (Maintenance RunWizard)" on page 1101

l "Smart Identification Page (Maintenance RunWizard)" on page 1104

TheMaintenanceMode Summary page displays the number of objects that were added to the local
object repository, the number of object properties that were updated, the number of steps that
weremodified, and the number of comments that were added to the test.

Update Options Tab (Update Run Dialog Box)
Relevant for: GUI tests and components

The Update Options tab enables you to specify which aspects of your test or component you want
to update, such as test object descriptions, expected checkpoint values, and/or, for tests and
scripted components, Active Screen images and values. After you save the test or component, the
results of the updated test or component are used for subsequent runs.

This image shows the Update Run dialog box for tests and scripted components. TheUpdate
Active Screen images and values option is not available for keyword components.
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To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document pane.

n In the Solution Explorer, select a GUI test or component node.

2. Use one of the following:

n Select Run > Update Run Mode.

n Click the down arrow next to theRun button in the toolbar and select
Update Run Mode.

Important
information

See "Considerations for the Update Options Tab (Update Run Dialog Box)" on
the next page

Relevant
tasks

"How to Update Test Object Descriptions, Checkpoints, or Output Values, or
Active Screen Captures" on page 1088

See also l "Update RunMode " on page 1081

l "Run Dialog Box: Input Parameters Tab (For GUI and API tests and
components)" on page 655
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User interface elements are described below:

UI Elements Description

Update test object
description

UFT updates the set of properties for each object class in your associated
object repositories according to the properties currently defined in the
"Object Identification Dialog Box" (described on page 1325). You can use
this option tomodify the set of properties used to identify an object of a
certain type.

For details, see "Update RunMode " on page 1081.

Update
checkpoint and
output value
properties

UFT updates the expected values of your checkpoints to reflect any
changes that may have occurred in your application since you created the
test and updates the list of items that can be retrieved in your output value
steps.

For details, see "When to Update Checkpoint Properties andOutput
Property Values" on page 1083.

Update active
screen images
and values (tests
and scripted
components only)

UFT updates images and property values in the Active Screen to reflect
any changes that may have occurred in your application since you
recorded the test or if the Active Screen does not appear as it should.

For details, see "When to Update Active Screen Images and Values (tests
and scripted components only)" on page 1084.

Considerations for the Update Options Tab (Update Run Dialog Box)

l When using theUpdate test object descriptions, if the property set you select in the "Object
Identification Dialog Box" (described on page 1325) for an object class is not ideal for a particular
object, the new object descriptionmay cause future runs to fail. Therefore, it is recommended
that you save a copy of your object repositories (or check them into an ALM project with version
control support, if applicable) before updating them, so that you can return to the previously
saved version, if necessary.

l If checkpoint property values are parameterized or include regular expressions, they are not
updated when using theUpdate checkpoint properties and output property values option.

l If you selected theSave only selected area check box when creating a bitmap checkpoint, the
Update Run Mode option updates only the saved area of the bitmap; it does not update the
original, full size object. To includemore of the object in the checkpoint, create a new
checkpoint. For more details, see "Bitmap Checkpoints Overview" on page 1401.
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Troubleshooting and Limitations - Maintenance Mode
Relevant for: GUI tests and components

This section describes troubleshooting and limitations for MaintenanceMode.

l When running in MaintenanceMode, if a step contains a programmatic description for an object
that is not found in an application, it may take a while for MaintenanceMode to indicate there is a
problem. If you use the option to point to the object, it may take a while for MaintenanceMode to
reopen afterward.

l When theMaintenance RunWizard cannot find an object, and the test object description for that
object does not have any mandatory or assistive properties (it is identified only by its ordinal
identifier, such as a Browser test object), then when you point to the object, the wizard is unable
to fix the problem and displays amessage that the object you pointed to has a test object
description that is similar to the object that UFT could not identify.

Workaround: Use theUpdate from Application option in the Object Repository window (for
objects in the local respiratory) or in the Object Repository Manager (for objects in a shared
object repository) to fix the test object description.

l When yourWindows Display settings are set to use large fonts, the text in theMaintenance Run
Wizard screens may be truncated.

l When theMaintenance RunWizard cannot find an object in the application, and you point to a
different object class to replace it, theMaintenance RunWizard offers to add a step with that
object and the object's default method. However, the wizard does not insert any method
arguments for the step. If the stepmethod has required arguments and you accept the step that
theMaintenance RunWizard proposes without modifying it, the step fails when you run it.

Workaround: Enter valid method arguments for the step.

l When running in MaintenanceMode, UFT may replace test objects with XPath or CSS identifier
property values with new objects from your application.

Workaround: Use theUpdate from Application option in the Object Repository Manager to
update specific test objects with XPath or CSS identifier property values.

l MaintenanceMode cannot fix problems in an object's properties, if the object is used in function
library that is called by a step. If MaintenanceMode detects a problem in an object in a function
library, a message is displayed indicating that the test is read-only and that MaintenanceMode
is disabled.
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Chapter 40: Recovery Scenarios for GUI Testing
Relevant for: GUI tests and components

This chapter includes:

Concepts 1112

Recovery Scenarios Overview 1112

Tasks 1115

How to Create andManage Recovery Scenarios 1115

How toManage Recovery Scenario Associations 1116

Reference 1120

Add Recovery Scenario Dialog Box 1120

Recovery Scenario Manager Dialog Box 1121

Recovery Scenario Properties Dialog Box 1124

Recovery ScenarioWizard 1126

Troubleshooting and Limitations - Recovery Scenarios 1154
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Concepts

Recovery Scenarios Overview
Relevant for: GUI tests and components

Unexpected events, errors, and application crashes during a run session can disrupt your run
session and distort results. This is a problem particularly when tests or components run
unattended—the run pauses until you perform the operation needed to recover. To handle situations
such as these, UFT enables you to create recovery scenarios and associate them with specific
tests or application areas. Recovery scenarios activate specific recovery operations when trigger
events occur.

The Recovery Scenario Manager provides a wizard that guides you through the process of defining
a recovery scenario, which includes a definition of an unexpected event and the operations
necessary to recover the run session. For example, you can instruct UFT to detect aPrinter out of
papermessage and recover the run session by clicking theOK button to close themessage and
continue running.

A recovery scenario consists of the following:

l Trigger Event. The event that interrupts your run session. For example, a window that pops up
on the screen, or a run error.

l Recovery Operations. The operations to perform to enable the run session to continue after the
trigger event interrupts the session. For example, clicking anOK button in a pop-up window, or
restartingMicrosoft Windows.

l Post-Recovery Test Run Option. The instructions on how UFT should proceed after the
recovery operations are performed, and from which step to continue, if at all. Youmay want to
restart the run from the beginning, or skip a step entirely and continue with the next step.

After you create recovery scenarios, you associate them with selected tests or components (via
the application area) so that the appropriate scenarios can run if a trigger event occurs. You can
prioritize the scenarios and set the order in which to apply the scenarios during the run session. You
can also choose to disable specific scenarios, or all scenarios, that are associated with a test or
application area.

You can also define which recovery scenarios will be used as the default scenario for all new tests.

For tests:You can associate, remove, enable, disable, prioritize, and view the properties of the
recovery scenarios associated with a GUI test in the Solution Explorer. For details, see "Solution
Explorer Pane User Interface" on page 478.

For components:You define recovery scenarios for components in the application area. For
details, see "Application Areas" on page 2095.
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This section also includes:

When to Use Recovery Scenarios 1113

Programmatically Controlling the Recovery Mechanism 1114

When to Use Recovery Scenarios

Relevant for: GUI tests and components

Recovery scenarios are intended for use onlywith events that you cannot predict in advance, or for
events that you cannot otherwise synchronize with a specific step in your test or component.

By default, recovery scenario operations are activated only after a step returns an error. This can
potentially occur several steps after the step that originally caused the error. The alternative,
checking for trigger events after every step, may slow performance. For this reason, it is best to
handle predictable errors directly in your test or component.

If you can predict that a certain event may happen at a specific point in your test or component, it is
highly recommended to handle that event directly within your test or component, rather than
depending on a recovery scenario. To do this in a test, add steps such as If statements or optional
steps. To do this in a component, use a user-defined function with conditional steps.

Handling an event directly within your test or component enables you to handle errors more
specifically than recovery scenarios, which by nature are designed to handle amore generic set of
unpredictable events. It also enables you to control the timing of the corrective operation with
minimal resource usage andmaximum performance.

Examples

l If you know that an Overwrite File message box may open when aSave button is clicked
during a run session:

You can handle this event with an If statement that clicks OK if themessage box opens or by
adding an optional step in the test to click OK in themessage box. (For keyword components,
you define this If statement in a user-defined function andmake it available via the associated
application area.)

l You can define a recovery scenario to handle printer errors. Then if a printer error occurs
during a run session, the recovery scenario could instruct UFT to click the default button in
the Printer Error message box.

You would use a recovery scenario in this example because you cannot handle this type of
error directly in your test or component. This is because you cannot know at what point the
network will return the printer error. Even if you try to handle this event by adding an If
statement in a user-defined function or in your test immediately after a step that sends a file to
the printer, your test or component may progress several steps before the network returns the
actual printer error.
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Programmatically Controlling the Recovery Mechanism

Relevant for: GUI tests and components

You can use the Recovery object to control the recovery mechanism programmatically during the
run session. For example, you can enable or disable the entire recovery mechanism or specific
recovery scenarios for certain parts of a run session, retrieve status information about specific
recovery scenarios, and explicitly activate the recovery mechanism at a certain point in the run
session.

By default, UFT checks for recovery triggers when an error is returned during the run session. You
can use the Recovery object's Activatemethod to force UFT to check for triggers after a specific
step in the run session. For example, suppose you know that an object property checkpoint will fail
if certain processes are open when the checkpoint is performed. You want to be sure that the pass
or fail of the checkpoint is not affected by these open processes, whichmay indicate a different
problem with your application.

However, a failed checkpoint does not result in a run error. So by default, the recovery mechanism
would not be activated by the object state. You can define a recovery scenario that looks for and
closes specified open processes when an object's properties have a certain state. This state
shows the object's property values as they would be if the problematic processes were open. You
can instruct UFT to activate the recovery mechanism if the checkpoint fails so that UFT can check
for and close any problematic open processes and then perform the checkpoint again. This ensures
that when the checkpoint is performed the second time it is not affected by the open processes.

For details on the Recovery object and its methods, see theHP UFT Object Model Reference for
GUI Testing.
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Tasks

How to Create and Manage Recovery Scenarios
Relevant for: GUI tests and components

This task describes how to perform different recovery scenario creation andmanagement
operations in the "Recovery Scenario Manager Dialog Box" (described on page "Recovery Scenario
Manager Dialog Box").

This task includes the following:

l "Define a recovery scenario file in which to store the recovery scenarios" below

l "Create a new recovery scenario operation using the Recovery ScenarioWizard" below

l "Manage existing recovery scenarios" on the next page

Define a recovery scenario file in which to store the recovery scenarios
By default, the Recovery Scenario Manager dialog box opens with a new recovery file. You can use
this new file, or you can open an existing recovery file, in one of the following ways:

l Click the arrow next to theOpen button to select a recently-used recovery file from the list.

l Click theOpen button and select an existing recovery file using the "Open/New
<Document>/<Resource> Dialog Box" (described on page 156).

Create a new recovery scenario operation using the Recovery Scenario
Wizard

1. In the "Recovery Scenario Manager Dialog Box" (described on page 1121), click theNew

Scenario button . The Recovery ScenarioWizard opens.

2. Follow the on-screen instructions. The wizard includes the following pages (pages that are in
parentheses open according to the option selected in the previous page):

n "Select Trigger Event Page " on page 1127

n ("Specify Pop-upWindow Conditions Page" on page 1130)

n ("Select Object Page" on page 1131)

n ("Set Object Properties and Values Page" on page 1133)

n ("Select Test Run Error Page" on page 1136)

n ("Select Processes Page" on page 1138)
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n "Recovery Operations Page" on page 1139

n "Recovery Operation Page" on page 1142

n ("Recovery Operation - Click Button or Press Key Page" on page 1143)

n ("Recovery Operation - Close Processes Page" on page 1145)

n ("Recovery Operation - Function Call Screen" on page 1146)

n "Post-Recovery Test RunOptions Page" on page 1148

n "Name and Description Page" on page 1150

n "Completing the Recovery ScenarioWizard Page" on page 1152

Manage existing recovery scenarios

l View properties for your recovery scenarios in the "Recovery Scenario Properties Dialog Box"
(described on page 1124).

l Edit, save, and remove existing recovery scenarios in the Recovery Scenario Manager by using
the toolbar buttons.

How to Manage Recovery Scenario Associations
Relevant for: GUI tests and components

This task describes how to perform different recovery scenario management and association
operations using the Recovery pane in the Test Settings dialog box or an application area's
Additional Settings pane. For a user interface description, see "Recovery Pane (Test/Business
Component Settings Dialog Box / Application Area - Additional Settings Pane)" on page 613.

This task includes the following:

l "Associate a recovery scenario with your test in the Test Settings dialog box" on the next page

l "Associate a recovery scenario with your test in the Solution Explorer" on the next page

l "Associate a recovery scenario with your component or application area" on the next page

l "View read-only recovery scenario properties" on page 1118

l "Prioritize recovery scenarios" on page 1118

l "Remove recovery scenarios from your test or application area" on page 1118

l "Enable/disable specific recovery scenarios" on page 1119

l "Set default recovery scenario settings for all new tests" on page 1119
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Associate a recovery scenario with your test in the Test Settings dialog
box

1. In the "Recovery Pane (Test/Business Component Settings Dialog Box / Application Area -

Additional Settings Pane)" (described on page 613), click theAdd button .

2. In the "Add Recovery Scenario Dialog Box" (described on page 1120), click theBrowse button
and navigate to the recovery scenario file. A list of recovery scenario operations contained in
this file opens in the "Add Recovery Scenario Dialog Box" (described on page 1120).

3. In the list of recovery scenarios, select a recovery scenario and click Add Scenario.

The recovery scenario is displayed in the "Recovery Pane (Test/Business Component
Settings Dialog Box / Application Area - Additional Settings Pane)" (described on page 613)
and is added under the "Recovery Scenarios Node" (described on page 488) found under your
GUI test in the Solution Explorer.

Associate a recovery scenario with your test in the Solution Explorer

1. In the Solution Explorer, do one of the following:

a. Right-click a GUI test node and select Add > Associate Recovery Scenario.

b. Right-click the "Recovery Scenarios Node" and select Associate Recovery Scenario.

2. In the "Add Recovery Scenario Dialog Box" (described on page 1120), click theBrowse button
and navigate to the recovery scenario file. A list of recovery scenario operations contained in
this file opens in the "Add Recovery Scenario Dialog Box".

3. In the list of recovery scenarios, select a recovery scenario and click Add Scenario.

The recovery scenario is added under the "Recovery Scenarios Node" (described on page
488), found under your GUI test in the Solution Explorer.

Associate a recovery scenario with your component or application area

1. In Recovery pane of the Additional Settings pane of your application area, click theAdd button

.

2. In the "Add Recovery Scenario Dialog Box" (described on page 1120), click theBrowse button
and navigate to the recovery scenario file. A list of all recovery scenario operations contained in
this file opens in the Add Recovery Scenario dialog box.

3. In the list of recovery scenarios, select a recovery scenario and click Add Scenario.

The recovery scenario is displayed in the Recovery pane in the Additional Settings pane of
your application area and is associated with the component through its application area or is
associated with the application area.
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View read-only recovery scenario properties
In the Recovery Pane (Test/Component Settings / Application Area Additional Settings)

1. In theScenarios box, select the recovery scenario whose properties you want to view.

2. Do one of the following:

n Click theProperties button .

n Double-click a scenario in theScenarios box.

The "Recovery Scenario Properties Dialog Box" (described on page 1124) opens, displaying
read-only information regarding the settings for the selected scenario.

In the Solution Explorer:

Right-click the name of the recovery scenario whose properties you want to view and select
Recovery Scenario Properties.

The "Recovery Scenario Properties Dialog Box" (described on page 1124) opens, displaying
read-only information regarding the settings for the selected scenario.

Prioritize recovery scenarios
In the Recovery Pane (Test Settings / Application Area Additional Settings)

1. In theScenarios box, select the scenario whose priority you want to change.

2. Click theUp orDown button . The selected scenario's priority changes according to
your selection.

In the Solution Explorer:

Right-click the scenario whose priority you want to change and selectMove Up orMove
Down. The selected scenario's priority changes according to your selection.

Remove recovery scenarios from your test or application area
In the Recovery Pane (Test Settings / Application Area Additional Settings)

1. In theScenarios box, select the scenario you want to remove.

2. Click theRemove button . The selected scenario is no longer associated with the test or
application area.

In the Solution Explorer:

Right-click the scenario you want to remove and select Remove Recovery Scenario from
List. The selected scenario is no longer associated with your test or application area and no
longer appears under the test or application area node in the Solution Explorer.
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Enable/disable specific recovery scenarios
Do one of the following:

l In theScenarios box of the "Recovery Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" (described on page 613), perform one of the
following:

n Select the check box to the left of one or more individual scenarios to enable them.

n Clear the check box to the left of one or more individual scenarios to disable them.

l In the Solution Explorer, right-click the scenario you want to disable and select Disable
Recovery Scenario.

Set default recovery scenario settings for all new tests
Click theSet as Default button in the Recovery pane of the Test Settings dialog box to set the
current list of recovery scenarios to be the default scenarios for all new tests. Any future changes
youmake to the current recovery scenario list only affect the current test, and do not change the
default list that you defined.
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Reference

Add Recovery Scenario Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to associate existing scenarios with your test or your component (via
its application area). This instructs UFT to perform the recovery scenarios during the run session.

To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document pane.

n In the Solution Explorer, select a GUI test or component node.

2. Use one of the following:

n For tests:Select File > Settings > Recovery node, and click the Add

button or right-click a GUI test node in the Solution Explorer and select
Add > Associate Recovery Scenario.

n For components: In theAdditional Settings pane of the application

area, select theRecovery node, and click theAdd button .
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Important
information

If the recovery scenario you need is not available, you can create a new recovery
scenario using the Recovery Scenario Manager (Resources > Recovery
Scenario Manager). You can then associate it with your test or application area
using the Add Recovery Scenario dialog box (described in this topic).

Relevant
tasks

"How to Create andManage Recovery Scenarios" on page 1115

See also l "Recovery Scenario Manager Dialog Box" below

l "Recovery ScenarioWizard" on page 1126

l "Recovery Scenario Properties Dialog Box" on page 1124

User interface elements are described below:

UI
Elements Description

Recovery
file

The recovery file that contains the recovery scenario that you want to associate
with the test or application area. You can click theBrowse button to navigate to the
recovery file you want to select.

Scenarios The recovery scenarios in the recovery file selected in the Recovery file box.

Add
Scenario

Associates the selected recovery scenario with the current test or application area.

Recovery Scenario Manager Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to create and edit recovery files, and create andmanage the recovery
scenarios stored in those files.
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To access 1. Do one of the following:

n Ensure that a GUI test or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node.

2. Select Resources > Recovery Scenario Manager.

Relevant tasks "How to Create andManage Recovery Scenarios" on page 1115

See also l "Recovery ScenarioWizard" on page 1126

l "Recovery Scenario Properties Dialog Box" on page 1124

This dialog box contains the following key elements:

l "General User Interface Elements" on the next page

l "Scenarios Box Icons" on page 1124
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General User Interface Elements

UI
Elements Description

File The name of the selected recovery scenario file.

New Creates a new recovery file.

Open Opens an existing recovery file. You can also click the arrow to select a recovery
file from the list of recently-used recovery files.

Save Saves the current recovery file.

Version
Control

Enables you tomanage version control for your recovery scenarios. (Options are
available only if UFT is connected to a version control-enabled ALM project.)

For details, see "Managing Versions of Assets in ALMOverview" on page 795 and
"Viewing and Comparing Versions of UFT Assets" on page 770.

Scenarios The list of associated recovery scenario files. For details, see "Scenarios Box
Icons" on the next page.

New Scenario. Opens the Recovery ScenarioWizard, in which you define a new
recovery scenario. For details, see "Recovery ScenarioWizard" on page 1126.

Edit. Opens the Recovery ScenarioWizard for the selected recovery scenario, in
which you canmodify the recovery scenario settings. For details, see "Recovery
ScenarioWizard" on page 1126.

Properties. Displays summary properties for the selected recovery scenario in
read-only format. For details, see "Recovery Scenario Properties Dialog Box" on
the next page.

Copy. Copies a recovery scenario from the open recovery file to the Clipboard.
This enables you to paste a recovery scenario into another recovery file.

Paste. Pastes a recovery scenario from the Clipboard into the open recovery file.

Note: If a scenario with the same name already exists in the recovery
scenario file, you can choose whether you want to replace it with the new
scenario you have just copied.

Delete. Deletes a recovery scenario.

Note: If a deleted recovery scenario is associated with a test or component,
UFT ignores it during the run session.

Scenario
description

The description for the currently selected recovery scenario file.
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Scenarios Box Icons

Icon Description

Indicates that the recovery scenario is triggered when a window pops up in an open
application during the run session.

Indicates that the recovery scenario is triggered when the property values of an object in
an applicationmatch specified values.

Indicates that the recovery scenario is triggered when a step in the test or component
does not run successfully.

Indicates that the recovery scenario is triggered when an open application fails during the
run session.

Recovery Scenario Properties Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to view read-only properties for any defined recovery scenario.
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To access l In the "Recovery Scenario Manager Dialog Box" (described on page 1121),

select a scenario and click theProperties button .

l In the "Recovery Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)", double-click a scenario.

l In the Solution Explorer, right-click a recovery scenario and select Recovery
Scenario Properties.

Important
information

Properties are displayed in read-only format. Tomodify any of the properties, use
theEdit button in the Recovery Scenario Manager dialog box.

Relevant
tasks

"How to Create andManage Recovery Scenarios" on page 1115

See also l "Recovery Scenario Manager Dialog Box" on page 1121

l "Recovery ScenarioWizard" on the next page

The Recovery Scenario Properties dialog box displays read-only information about the selected
scenario in the following tabs:

UI Elements Description

General The name and description defined for the recovery scenario, plus the name and
path of the recovery file in which the scenario is saved.

Trigger Event The settings for the trigger event defined for the recovery scenario.

Recovery
Operation

The recovery operations defined for the recovery scenario.

Post-
Recovery
Operation

The post-recovery operation defined for the recovery scenario.
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Recovery Scenario Wizard
Relevant for: GUI tests and components

This wizard enables you to create a recovery scenario to associate with your test or application
area.

To
access

In the "Recovery Scenario Manager Dialog Box" (described on page 1121), click the

New Scenario button .

Relevant
tasks

"How to Create andManage Recovery Scenarios" on page 1115
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Wizard
map

This wizard contains:

Welcome > "Select Trigger Event Page " (page 1127) > ("Specify Pop-upWindow
Conditions Page" (page 1130)) > ("Select Object Page" (page 1131)) > ("Set Object
Properties and Values Page" (page 1133)) > ("Select Test Run Error Page" (page
1136)) > ("Select Processes Page" (page 1138)) > "Recovery Operations Page"
(page 1139) > "Recovery Operation Page" (page 1142) > ("Recovery Operation -
Click Button or Press Key Page" (page 1143)) > ("Recovery Operation - Close
Processes Page" (page 1145)) > ("Recovery Operation - Function Call Screen" (page
1146)) > "Post-Recovery Test RunOptions Page" (page 1148) > "Name and
Description Page" (page 1150) > "Completing the Recovery ScenarioWizard Page"
(page 1152)

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.

See also "Recovery Scenarios Overview" on page 1112

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

<welcome
area>

General information on the different options in the Recovery ScenarioWizard, and
an overview of the stages involved in defining a recovery scenario.

Select Trigger Event Page

Relevant for: GUI tests and components

This page enables you to define the event type that triggers the recovery scenario, and the way in
which UFT recognizes the event.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > Select Trigger Event Page > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery
Operations Page" > "Recovery Operation Page" > ("Recovery Operation - Click
Button or Press Key Page") > ("Recovery Operation - Close Processes Page") >
("Recovery Operation - Function Call Screen") > "Post-Recovery Test Run
Options Page" > "Name and Description Page" > "Completing the Recovery
ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

Important
information

l The set of recovery operations is performed for each occurrence of the trigger
event criteria.

Example: If you define a specific object state, and two objects match this
state, the set of recovery operations is performed two times, once for each
object that matches the specified state.

l The recovery mechanism does not handle triggers that occur in the last step of
a test or component. If you need to recover from an unexpected event or error
that may occur in the last step, you can do this by adding an extra step to the
end of your test or component.
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User interface elements are described below:

UI
Elements Description

Pop-up
window

Detects a pop-up window and identifies it according to the window title and textual
content.

Example:A message box may open during a run session, indicating that the
printer is out of paper. UFT can detect this window and activate a defined
recovery scenario to continue the run session.

Object
state

Detects a specific test object state and identifies it according to its property
values and the property values of all its ancestors. Note that an object is identified
only by its property values, and not by its class.

Example:A specific button in a dialog box may be disabled when a specific
process is open. UFT can detect the object property state of the button that
occurs when this problematic process is open and activate a defined
recovery scenario to close the process and continue the run session.

Test run
error

Detects a run error and identifies it by a failed return value from amethod.

Example:UFTmay not be able to identify amenu item specified in the
method argument, due to the fact that themenu item is not available at a
specific point during the run session. UFT can detect this run error and
activate a defined recovery scenario to continue the run session.

Application
crash

Detects an application crash and identifies it according to a predefined list of
applications.

Example:A secondary applicationmay crash when a certain step is
performed in the run session. You want to be sure that the run session does
not fail because of this crash, whichmay indicate a different problem with
your application. UFT can detect this application crash and activate a defined
recovery scenario to continue the run session.
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Specify Pop-up Window Conditions Page

Relevant for: GUI tests and components

This page enables you to specify how the pop-up window should be identified.

Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > (Specify Pop-up Window Conditions
Page) > ("Select Object Page") > ("Set Object Properties and Values Page") > ("Select
Test Run Error Page") > ("Select Processes Page") > "Recovery Operations Page" >
"Recovery Operation Page" > ("Recovery Operation - Click Button or Press Key
Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation -
Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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User interface elements are described below:

UI
Elements Description

Pointing hand. Instructs UFT to identify only pop-up windows that match the
object property values of the window you select. For details on using the pointing
hand, see "Tips for Using the Pointing Hand" on page 1196.

Window
title

Instructs UFT to identify any pop-up window that contains the relevant title.

Window
text

Instructs UFT to identify any pop-up window that contains the relevant text.

Regular
expression

Enables you to use regular expressions to identify the pop-up window. For details
on regular expressions, see "Regular Expressions Overview" on page 318.

Note: You can click the right arrow to display a list of regular expression
characters that you can select, and to open the Regular Expression Evaluator,
which enables you to test your regular expression. For details, see "Smart
Regular Expression List" on page 361 and "Regular Expression Evaluator" on
page 358.

Select Object Page

Relevant for: GUI tests and components

This page enables you to select the object whose properties you want to specify.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > (Select Object Page) > ("Set Object Properties and Values Page") > ("Select
Test Run Error Page") > ("Select Processes Page") > "Recovery Operations Page" >
"Recovery Operation Page" > ("Recovery Operation - Click Button or Press Key
Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation -
Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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User interface elements are described below:

UI
Elements Description

Pointing hand. Enables you to click the object whose properties you want to
specify. For details on using the pointing hand, see "Tips for Using the Pointing
Hand" on page 1196.

If the location you click is associated with more than one object, the "Object
Selection Dialog Box " (described on page 1195) opens. Select the object whose
properties you want to specify and click OK. The selected object and its parents are
displayed in the Select Object screen.

Note: The hierarchical object selection tree also enables you to select an object
that UFT would not ordinarily learn (a non-parent object), such as aWeb table.

Object
hierarchy

The path to the selected object.

Set Object Properties and Values Page

Relevant for: GUI tests and components

This page enables you to specify the properties and values for the selected object to use in the
recovery scenario.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > (Set Object Properties and Values Page) >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery Operations
Page" > "Recovery Operation Page" > ("Recovery Operation - Click Button or Press
Key Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation
- Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.

User interface elements are described below:

UI
Elements Description

Object
hierarchy
tree

The path to the selected object.

Object
properties

The list of available properties for the selected object.
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UI
Elements Description

Enables you to add or remove object properties from the list of property values to
check.

Note: An object is identified only by its property values, and not by its class.

Edit
property
value

Enables you tomodify the property values used to identify the object.

Regular
expression

Enables you to use regular expressions in the property value. For details on regular
expressions, see "Regular Expressions Overview" on page 318.

Note: You can click the right arrow to display a list of regular expression
characters that you can select, and to open the Regular Expression Evaluator,
which enables you to test your regular expression. For details, see "Smart
Regular Expression List" on page 361 and "Regular Expression Evaluator" on
page 358.
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Select Test Run Error Page

Relevant for: GUI tests and components

This page enables you to select the type of error to use as a trigger event.

Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") > (Select
Test Run Error Page) > ("Select Processes Page") > "Recovery Operations Page" >
"Recovery Operation Page" > ("Recovery Operation - Click Button or Press Key
Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation -
Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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User interface elements are described below:

UI
Elements Description

Error The list of error types to use as trigger events. The following option are available:

l Any error. Any error code that is returned by a test object method.

l Item in list or menu is not unique. Occurs whenmore than one item in the
list, menu, or tree has the name specified in themethod argument.

l Item in list or menu not found. Occurs when UFT cannot identify the list,
menu, or tree item specified in themethod argument. This may be due to the
fact that the item is not currently available or that its name has changed.

l More than one object responds to the physical description. Occurs when
more than one object in your application has the same property values as those
specified in the test object description for the object specified in the step.

l Object is disabled. Occurs when UFT cannot perform the step because the
object specified in the step is currently disabled.

l Object not found. Occurs when no object within the specified parent object
matches the test object description for the object.

l Object not visible. Occurs when UFT cannot perform the step because the
object specified in the step is not currently visible on the screen.

Error
description

The description of the selected error type.
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Select Processes Page

Relevant for: GUI tests and components

This page enables you to select processes that will trigger a recovery scenario if they crash.

Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > (Select Processes Page) > "Recovery Operations
Page" > "Recovery Operation Page" > ("Recovery Operation - Click Button or Press
Key Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation
- Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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User interface elements are described below:

UI
Elements Description

Running
processes

The list of all application processes that are currently running.

To add a process from theRunning processes list, double-click a process in the
Running processes list or select it and click theAdd button. You can select
multiple processes using standardWindows multiple selection techniques (CTRL
and SHIFT keys).

Processes The list of the application processes that will trigger the recovery scenario if they
crash.

Note:

l You can add application processes to theProcesses list by typing them in
theProcesses list or by selecting them from theRunning processes list.

l You canmodify the name of a process by selecting it in theProcesses list
and clicking the process name to edit it.

Add new process. Enables you to add a process directly to theProcesses list by
entering the name of any process you want to add to the list.

Remove process. Enables you to remove a process from theProcesses list.

Recovery Operations Page

Relevant for: GUI tests and components

This page enables you tomanage the collection of recovery operations in the recovery scenario.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > Recovery Operations
Page > "Recovery Operation Page" > ("Recovery Operation - Click Button or Press
Key Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation
- Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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User interface elements are described below:

UI Elements Description

Recovery
operations

The list of selected recovery operations.

To add a recovery scenario to the list, click Next to continue to the "Recovery
Operation Page" (described on page 1142).

Note:

l If you define two or more recovery operations, you can select a recovery
operation and use theMove Up orMove Down buttons to change the
order in which to perform the recovery operations.

l You can also select a recovery operation and click theRemove button to
delete a recovery operation from the recovery scenario.

l If you define aRestart Microsoft Windows recovery operation, it is
always inserted as the last recovery operation, and you cannot change its
position in the list.

Add another
recovery
operation

Displayed only after you have defined at least one recovery operation. The
following options are available:

l Select the check box and click Next to define another recovery operation.

l Clear the check box and click Next to continue to the "Post-Recovery Test
RunOptions Page" (described on page 1148).
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Recovery Operation Page

Relevant for: GUI tests and components

This page enables you to specify the operations UFT performs after it detects the trigger event.

Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery Operations
Page" > Recovery Operation Page > ("Recovery Operation - Click Button or Press
Key Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation
- Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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User interface elements are described below:

UI
Elements Description

Keyboard
or mouse
operation

Simulates a click on a button in a window or a press of a keyboard key.

Close
application
process

Closes specified processes.

Function
call

Calls a VBScript function.

Restart
Microsoft
Windows

Restarts Microsoft Windows.

Note: If you use the this recovery operation, youmust ensure that any test or
application area (and component) associated with this recovery scenario is
saved before you run it. Youmust also configure the computer on which the
test or component is run to automatically log in on restart.

Recovery Operation - Click Button or Press Key Page

Relevant for: GUI tests and components

This page enables you to specify the keyboard or mouse operation that you want UFT to perform
when it detects the trigger event:
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery Operations
Page" > "Recovery Operation Page" > (Recovery Operation - Click Button or Press
Key Page) > ("Recovery Operation - Close Processes Page") > ("Recovery Operation
- Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.

User interface elements are described below:

UI Elements Description

Click
Default
button /
Press the
ENTER key

Clicks the default button or presses the Enter key in the displayed window when
the trigger occurs.
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UI Elements Description

Click
Cancel
button /
Press the
ESCAPE
key

Clicks the Cancel button or presses the Escape key in the displayed window
when the trigger occurs.

Click button
with label

Clicks the button with the specified label in the displayed window when the
trigger occurs. If you select this option, click the pointing hand and then click
anywhere in the trigger window. For details on using the pointing hand, see "Tips
for Using the Pointing Hand" on page 1196.

All button labels in the selected window are displayed in the list box. Select the
required button from the list.

Press key or
key
combination

Presses the specified keyboard key or key combination in the displayed window
when the trigger occurs. If you select this option, click in the edit box and then
press the key or key combination on your keyboard that you want to specify.

Recovery Operation - Close Processes Page

Relevant for: GUI tests and components

This page enables you to select processes to close in the recovery operation.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery Operations
Page" > "Recovery Operation Page" > ("Recovery Operation - Click Button or Press
Key Page") > (Recovery Operation - Close Processes Screen) > ("Recovery
Operation - Function Call Screen") > "Post-Recovery Test RunOptions Page" >
"Name and Description Page" > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.

User interface elements are described below:

UI
Elements Description

Running
processes

The list of all application processes that are currently running.

To add a process from theRunning processes list, double-click a process in the
Running processes list or select it and click theAdd button. You can select
multiple processes using standardWindows multiple selection techniques (CTRL
and SHIFT keys).

Processes
to close

The list of the application processes that will be closed when the trigger is
activated.

Note: You canmodify the name of a process by selecting it in theProcesses
to close list and clicking the process name to edit it.

Add new process. Enables you to add a process directly to theProcesses list by
entering the name of any process you want to add to the list.

Remove process. Enables you to remove a process from theProcesses list.

Recovery Operation - Function Call Screen

Relevant for: GUI tests and components

This page enables you to select a function to call in the recovery operation.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery
Operations Page" > "Recovery Operation Page" > ("Recovery Operation - Click
Button or Press Key Page") > ("Recovery Operation - Close Processes Page") >
(Recovery Operation - Function Call Page) > "Post-Recovery Test Run
Options Page" > "Name and Description Page" > "Completing the Recovery
ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

Important
information

l If more than one scenario uses a function with the same name from different
function libraries, the recovery process may fail. In this case, information
regarding the recovery failure is displayed during the run session.

l For tests:UFT automatically associates the function library you select with
your test. Therefore, you do not need to associate the function library with your
test in the Resources pane of the Test Settings dialog box.

l For components: The function library must be stored in the ALM project.
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User Interface Elements

UI
Elements Description

Function
Library

Displays the selected function library, and enables you to select a recently specified
function library in the box. Alternatively, click theBrowse button to navigate to an
existing function library.

Select
function

Choose an existing function from the function library you selected. Only functions
that match the prototype syntax for the trigger type selected in the "Select Trigger
Event Page " on page 1127 are displayed.

Define
new
function

Create a new function by specifying a unique name for it, and defining the function in
the Function Name box according to the displayed function prototype. The new
function is added to the function library you selected.

Function Prototypes by Trigger Type
Following is the prototype for each trigger type:

Test run error trigger
OnRunStep
(
[in] Object as Object: The object of the current step.
[in] Method as String: Themethod of the current step.
[in] Arguments as Array: The actual method's arguments.
[in] Result as Integer: The actual method's result.
)
Pop-up window and Object state triggers
OnObject
(
[in] Object as Object: The detected object.
)Application crash trigger
OnProcess
(
[in] ProcessName as String: The detected process's Name.
[in] ProcessId as Integer: The detected process' ID.
)

Post-Recovery Test Run Options Page

Relevant for: GUI tests and components

This page enables you to define post-recovery test run options, which specify how to continue the
run session after UFT identifies the event and performs all of the specified recovery operations.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery
Operations Page" > "Recovery Operation Page" > ("Recovery Operation - Click
Button or Press Key Page") > ("Recovery Operation - Close Processes Page") >
("Recovery Operation - Function Call Screen") > Post-Recovery Test Run
Options Page > "Name and Description Page" > "Completing the Recovery
ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in
the previous page. Therefore, not all pages are displayed for every option.

Important
information

If you choseRestart Microsoft Windows as a recovery operation, you can
choose from only the last two test run options.
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User interface elements are described below:

UI
Elements Description

Repeat
current
step and
continue

The current step is the step that UFT was running when the recovery scenario was
triggered. If you are using theOn error activation option for recovery scenarios,
the step that returns the error is often one or more steps later than the step that
caused the trigger event to occur. Therefore, in most cases, repeating the current
step does not cause the trigger event to occur again.

Proceed to
next step

Skips the step that UFT was running when the recovery scenario was triggered.
Keep inmind that skipping a step that performs operations on your applicationmay
cause subsequent steps to fail.

Proceed to
next action
or
component
iteration

Stops performing steps in the current action or component iteration and begins the
next iteration from the beginning (or from the next action or component if no
additional iterations of the current action or component are required).

Proceed to
next test
iteration

Stops performing steps in the current action or component and begins the next
GUI test or business process test iteration from the beginning (or stops the run
session if no additional iterations are required).

Restart
current test
run

Stops performing steps and re-runs the GUI test from the beginning. (Not
applicable to business process tests.)

Stop the
test run

Stops running the test or component.

Name and Description Page

Relevant for: GUI tests and components

This page enables you to specify a name by which to identify your recovery scenario. You can also
add descriptive information regarding the scenario.
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Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery Operations
Page" > "Recovery Operation Page" > ("Recovery Operation - Click Button or Press
Key Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation
- Function Call Screen") > "Post-Recovery Test RunOptions Page" > Name and
Description Page > "Completing the Recovery ScenarioWizard Page"

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.

User interface elements are described below:

UI Elements Description

Recovery file The name of the recovery file.

Scenario name The name of the scenario operation.

Description The textual description of the scenario operation.
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Completing the Recovery Scenario Wizard Page

Relevant for: GUI tests and components

This page enables you to review a summary of the scenario settings you defined.

For tests:You can also specify whether to automatically associate the recovery scenario with the
current test and/or to add it to the default settings for all new tests.

The following image illustrates an example of the Recovery ScenarioWizard summary page. (The
check boxes shown are available only if a test was in focus when you started the wizard.)

Wizard
map

The "Recovery ScenarioWizard" contains:

Welcome > "Select Trigger Event Page " > ("Specify Pop-upWindow Conditions
Page") > ("Select Object Page") > ("Set Object Properties and Values Page") >
("Select Test Run Error Page") > ("Select Processes Page") > "Recovery Operations
Page" > "Recovery Operation Page" > ("Recovery Operation - Click Button or Press
Key Page") > ("Recovery Operation - Close Processes Page") > ("Recovery Operation
- Function Call Screen") > "Post-Recovery Test RunOptions Page" > "Name and
Description Page" > Completing the Recovery Scenario Wizard Screen

Note: Pages that are in parentheses open according to the option selected in the
previous page. Therefore, not all pages are displayed for every option.
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User interface elements are described below:

UI
Elements Description

Scenario
settings

The settings of the defined recovery operation.

For components:You associate a recovery scenario for a component with the
component's application area. You can also define the default recovery scenarios
for all new components associated with a specific application area. For details, see
"Application Areas" on page 2095.

Add
scenario
to current
test
(tests
only)

Associates this recovery scenario with the current test. When you click Finish,
UFT adds the recovery scenario to theScenarios list in the Recovery pane of the
Test Settings dialog box.

Add
scenario
to default
test
settings
(tests
only)

Makes this recovery scenario a default scenario for all new tests. The next time you
create a test, this scenario will be listed in theScenarios list in the Recovery pane
of the Test Settings dialog box.

Note: You can remove scenarios from the default scenarios list. For details,
see "Recovery Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 613.
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Troubleshooting and Limitations - Recovery Scenarios
Relevant for: GUI tests and components

This section describes troubleshooting and limitations for recovery scenarios.

l If you specify multiple function libraries from different locations with the same name in the same
recovery scenario, only the first function library is used.

Workaround:Rename the function libraries so that each function library has a unique name.
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Chapter 41: UFT Automation Scripts
Relevant for: GUI tests and components

This chapter includes:

Concepts 1156

UFT Automation Object Model Overview 1156

When to Use UFT Automation Scripts 1157

Application Object 1158

UFT Automation Object Model Reference 1159

Generated Automation Scripts 1159

Tasks 1161

How to Create a UFT Automation Script 1161

How to Run Automation Scripts on a Remote Computer 1164
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Concepts

UFT Automation Object Model Overview
Relevant for: GUI tests and components

You can use the UFT automation object model to write scripts that automate your UFT operations.
The UFT automation object model provides objects, methods, and properties that enable you to
control UFT from another application.

Using the objects, methods, and properties exposed by the UFT automation object model, you can
write scripts that configure UFT options and run tests or components instead of performing these
operations manually using the UFT interface.

Automation scripts are especially useful for performing the same tasks multiple times or onmultiple
tests or components, or for quickly configuring UFT according to your needs for a particular
environment or application.

What is Automation?
Automation is a Microsoft technology that makes it possible to access software objects inside one
application from other applications. These objects can be created andmanipulated using a scripting
or programming language such as VBScript or VC++. Automation enables you to control the
functionality of an application programmatically.

What is the UFT Automation Object Model?
An object model is a structural representation of software objects (classes) that comprise the
implementation of a system or application. An object model defines a set of classes and interfaces,
together with their properties, methods and events, and their relationships.

The UFT automation object model is a set of objects, methods, and properties that enable you to
control essentially all of the configuration and run functionality provided via the UFT interface.
Although a one-on-one comparison cannot always bemade, most dialog boxes in UFT have a
corresponding automation object, most options in dialog boxes can be set and/or retrieved using the
corresponding object property, andmost menu commands and other operations have corresponding
automationmethods.

You can use the objects, methods, and properties exposed by the UFT automation object model,
along with standard programming elements such as loops and conditional statements to design
your script.

Automation scripts are especially useful for performing the same tasks multiple times or onmultiple
tests or components, or for quickly configuring UFT according to your needs for a particular
environment or application.

Example:

You can create and run an automation script fromMicrosoft Visual Basic that does the
following:
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l Loads the required add-ins for a test or component

l Starts UFT in visible mode

l Opens the test or component

l Configures settings that correspond to those in the:

n Options dialog box

n Test Settings or Business Component Settings dialog box

n Record and Run Settings dialog box (tests only)

l Runs the test or component

l Saves the test or component

You can then add a simple loop to your script so that your single script can perform the
operations described above for multiple tests or components.

You can also create an initialization script that opens UFT with specific configuration settings.
You can then instruct all of your testers to open UFT using this automation script to ensure that
all of your testers are always working with the same configuration.

When to Use UFT Automation Scripts
Relevant for: GUI tests and components

Creating a useful UFT automation script requires planning, design time, and testing. Youmust
always weigh the initial investment with the time and human-resource savings you gain from
automating potentially long or tedious tasks.

Any UFT operation that youmust perform many times in a row ormust perform on a regular basis is
a good candidate for a UFT automation script.

The following are just a few examples of useful UFT automation scripts:

l Initialization scripts. You can write a script that automatically starts UFT and configures the
options and the settings required for testing a specific environment.

l Maintaining your tests and components. You can write a script that iterates over your
collection of tests and components to accomplish a certain goal. For example:

n Updating values. You can write a script that opens each test or component with the proper
add-ins, runs it in update runmode against an updated application, and saves it when you
want to update the values in all of your tests or components to match the updated values in
your application.
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n Applying new options to existing tests and components. When you upgrade toUFT, you
may find that it offers certain options that you want to apply to your existing tests and
components. You can write a script that opens each existing test or component, sets values
for the new options, then saves and closes it.

n Modifying Actions and Action Parameters (tests only). You can retrieve the entire
contents of an action script, and add a required step, such as a call to a new action. You can
also retrieve the set of action parameters for an action and add, remove, or modify the values
of action parameters.

l Calling UFT from other applications. You can design your own applications with options or
controls that run UFT automation scripts. For example, you could create aWeb form or simple
Windows interface from which a product manager could schedule UFT runs, even if themanager
is not familiar with UFT.

Application Object
Relevant for: GUI tests and components

Likemost automation object models, the root object of the UFT automation object model is the
Application object.

TheApplication object represents the application level of UFT. You can use this object to return
other elements of UFT such as the:

l Test object (which represents a test or component document)

l Options object (which represents the Options dialog box)

l Addins collection (which represents a set of add-ins from the Add-in Manager dialog box)

You can also use theApplication object to perform operations like loading add-ins, starting UFT,
opening and saving tests or components, and closing UFT.

Each object returned by theApplication object can return other objects, perform operations related
to the object and retrieve and/or set properties associated with that object.

Every automation script begins with the creation of the UFTApplication object. Creating this
object does not start UFT. It simply provides an object from which you can access all other objects,
methods and properties of the UFT automation object model.

Note: You can also optionally specify a remote UFT computer on which to create the object
(the computer on which to run the script). For details, seeRunning Automation Programs
on a Remote Computer in the Introduction section of theUFT Automation Object Model
Reference in theUFT Help.
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UFT Automation Object Model Reference
Relevant for: GUI tests and components

TheHP UFT Automation Object Model Reference is a Help file that provides detailed descriptions,
syntax information, and examples for the objects, methods, and properties in the UFT automation
object model.

You can open theHP UFT Automation Object Model Reference from:

l UFT program folder (Start > All Programs > HP Software > HP Unified Functional Testing
> Documentation > Unified Functional Testing Automation Reference)

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 75.

l UFT Advanced References Help (Help > HP UFT GUI Testing Advanced References Help
> HP UFT Automation Object Model for GUI Testing)

Generated Automation Scripts
Relevant for: GUI tests and components

The Properties pane of the Test Settings dialog box, the General node of the pane of the
GUITesting tab in the Options dialog box, and the Object Identification dialog box each contain a
Generate Script button. Clicking this button generates an automation script file (.vbs) containing
the current settings from the corresponding dialog box.

You can run the generated script as is to open UFT with the exact dialog box configuration of the
UFT application that generated the script, or you can copy and paste selected lines from the
generated files into your own automation script.

For example, the generated script for the Options dialog box may look something like this:

Dim App 'As Application
Set App = CreateObject("QuickTest.Application")
App.Launch
App.Visible = True
App.Options.DisableVORecognition = False
App.Options.AutoGenerateWith = False
App.Options.WithGenerationLevel = 2
App.Options.TimeToActivateWinAfterPoint = 500
...
...
App.Options.WindowsApps.NonUniqueListItemRecordMode = "ByName"
App.Options.WindowsApps.RecordOwnerDrawnButtonAs = "PushButtons"
App.Folders.RemoveAll
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Formore details on theGenerate Script button and the options available in the Options, Object
Identification, and Test Settings dialog boxes, see "Configuring Object Identification" on page 1310,
"UFT Global Options" on page 522, and "Settings for GUI Tests, GUI Business Components, and
Application Areas" on page 580.
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Tasks

How to Create a UFT Automation Script
Relevant for: GUI tests and components

This task describes when and how to create automation scripts, and includes the following steps:

l "Prerequisites" below

l "Create the Application object" below

l "Reference the type library - optional" on the next page

l "Write your automation script" on page 1163

l "Run your automation script" on page 1164

1. Prerequisites
n Decide whether to use UFT Automation Scripts

Creating a useful UFT automation script requires planning, design time, and testing. You
must always weigh the initial investment with the time and human-resource savings you
gain from automating potentially long or tedious tasks.

Any UFT operation that youmust perform many times in a row ormust perform on a regular
basis is a good candidate for a UFT automation script.

n Choose a language and development environment for designing and running
Automation scripts

You can write your UFT automation scripts in any language and development environment
that supports automation. For example, you can use: VBScript, JavaScript, Visual Basic,
Visual C++, or Visual Studio .NET.

For each language, there are a number of development environments available for designing
and running your automation scripts.

2. Create the Application object
The procedure for creating theApplication object differs slightly from language to language.
Below are some examples for creating the UFTApplication object and starting UFT in visible
mode, using different programming languages. For conceptual details on theApplication
object, see "Application Object" on page 1158.
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Visual Basic

The example below can be used only after setting a reference to the type library. If you are not
working in a development environment that allows referencing type libraries, create the
Application object as described for VBScript below.

Dim qtApp As QuickTest.Application ' Declare the object
Set qtApp = New QuickTest.Application ' Create the object
qtApp.Launch ' Start QuickTest
qtApp.Visible = True ' Make it visible

VBScript

Dim qtApp
Set qtApp = CreateObject("QuickTest.Application")
qtApp.Launch 'Start QuickTest
qtApp.Visible = True ' Make it visible

JavaScript

// Create the application object
var qtApp = new ActiveXObject("QuickTest.Application");
qtApp.Launch(); // Start QuickTest
qtApp.Visible = true; // Make it visible

Visual C++

#import "QTObjectModel.dll" // Import the type library
// Declare the application pointer
QuickTest::_ApplicationPtr spApp;
// Create the application object
spApp.CreateInstance("QuickTest.Application");
spApp->Launch(); // Launch the application
spApp->Visible = VARIANT_TRUE; // Make it visible

3. Reference the type library - optional
Some development environments support referencing a type library. A type library is a binary
file containing the description of the objects, interfaces, and other definitions of an object
model.

If you choose a development environment that supports referencing a type library, you can take
advantage of features likeMicrosoft IntelliSense, automatic statement completion, and status
bar help tips while writing your script. The UFT automation object model supplies a type library
file namedQTObjectModel.dll. This file is stored in <UFT installation folder>\bin.
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If you choose an environment that supports it, be sure to reference the UFT type library before
you begin writing or running your automation script. For example, if you are working in
Microsoft Visual Basic, select Project > Add Reference to open theAdd Reference dialog
box for your project. Then select Unified Functional Testing<Version> Object Library
(where <Version> is the current installed version of the UFT automation type library).

4. Write your automation script
The structure for your script depends on the goals of the script. Youmay perform a few
operations before you start UFT such as retrieving the associated add-ins for a test or
component, loading add-ins, and instructing UFT to open in visible mode.

After you perform these preparatory steps, if UFT is not already open on the computer, you can
open UFT using theApplication.Launchmethod. Most operations in your automation script
are performed after the Launchmethod.

For details on the operations you can perform in an automation program, seeHP UFT
Automation Object Model Reference (Help > HP UFT GUI Testing Advanced References
Help > HP UFT Automation Object Model Reference).

Tip: You can generate automation scripts from UFT that contain the settings for the Test
Settings dialog box, the GUI Testing tab in the Options dialog box, and the Object
Identification dialog box as they are set on your computer. You can then run each
generated script as is to instruct UFT to open on other computers with the exact dialog box
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configuration defined in the generated script, or you can copy and paste selected lines
from the generated files into your own automation script. For details, see "Generated
Automation Scripts " on page 1159.

When you finish performing the necessary operations, or you want to perform operations that
require closing and restarting UFT (such as changing the set of loaded add-ins), use the
Application.Quitmethod.

5. Run your automation script
There are several applications available for running automation scripts. You can also run
automation scripts from the command line usingMicrosoft's Windows Script Host.

For example, you could use the following command line to run your automation script:

WScript.exe /E:VBSCRIPT myScript.vbs

For details on running automation scripts on a remote computer, see "How to Run Automation
Scripts on a Remote Computer " below.

How to Run Automation Scripts on a Remote Computer
Relevant for: GUI tests and components

By default, when you create anApplication object in your automation script, it is created on your
local computer (using your local copy of UFT). You can also run automation scripts on a remote
UFT computer. To do so, youmust:

1. Set DCOM Configuration Properties on the Remote Computer
UFT automation enables UFT to act as a COM automation server. Therefore, to run a UFT
automation script on a remote computer, youmust ensure that the DCOM configuration
properties for that computer give you the proper permissions to launch and configure the UFT
COM server.

The procedure below describes the steps you need to perform on the remote computer to
enable your automation script to run on that computer. Note that the DCOMConfiguration
Property the appearance and names of the dialog boxes and options mentioned heremay vary
depending on the computer's operating system.

To enable automation scripts to access a Unified Functional Testing computer
remotely:

a. On the computer where you want to run the automation script, select Start > Run. The
Run dialog box opens.

b. Enter dcomcnfg and click OK. The Distributed COMConfiguration Properties dialog box
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or the Component Services window opens (depending on your operating system) and
displays the list of COM applications available on the computer.

c. Select QuickTest Professional Automation from the DCOMConfig list and open the
Properties dialog box for the application. (Click theProperties button or right-click and
select Properties, depending on your operating system.)

d. In the QuickTest Professional Automation Properties dialog box, click theSecurity tab.

e. In the launch permissions section, select the custom option and click Edit.

f. Use theAdd andRemove options to select the network users or groups for which you
want to allow or deny permission to launch UFT via an automation script. When you are
finished, click OK to save your settings.

g. Repeat the previous two steps for the configuration permissions section to select the users
or groups who canmodify UFT configuration options via an automation script.

h. In the QuickTest Professional Automation Properties dialog box, click the Identity tab and
select the interactive user option.

i. Click OK to save the QuickTest Professional Automation Properties settings.

j. Click OK to close the Distributed COMConfiguration Properties dialog box or the
Component Services window.

2. Create an Application Object on the Remote Computer
After you set the necessary DCOMConfiguration settings for a remote computer, you can
specify that computer in your automation script.

In VBScript, you do this by specifying the computer name as the optional location argument of
theCreateObject function. The computer name should be the same as the computer name
portion of a share name. For example, to run an automation script on a computer called
MyServer, you could write:

Dim qtApp
Set qtApp = CreateObject("QuickTest.Application", "MyServer")

For details on the syntax for specifying the remote computer in another language you are using,
see the documentation included with your development environment or the general
documentation for the programming language.
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Chapter 42: The Test Object Model
Relevant for: GUI tests and components
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Concepts

Test Object Model - Overview
Relevant for: GUI tests and components

UFT tests your dynamically changing application by learning and identifying test objects and their
expected properties and values. To do this, UFT analyzes each object in your application in much
the sameway that a person would look at a photograph and remember its details.

The following sections introduce the concepts related to the test object model and describe how
UFT uses the information it gathers to test your application.

This section includes:

How UFT Learns Objects 1168

How UFT Identifies Objects During a Run Session 1169

How UFT Learns Objects

Relevant for: GUI tests and components

UFT learns objects just as you would. For example, suppose as part of an experiment, Alex is told
that he will be shown a photograph of a picnic scene for a few seconds during which someone will
point out one item in the picture. Alex is told that he will be expected to identify that item again in
identical or similar pictures one week from today.

Before he is shown the photograph, Alex begins preparing himself for the test by thinking about
which characteristics he wants to learn about the item that the tester indicates. Obviously, he will
automatically note whether it is a person, inanimate object, animal, or plant. Then, if it is a person,
he will try to commit to memory the gender, skin color, and age. If it is an animal, he will try to
remember the type of animal, its color, and so forth.

The tester shows the scene to Alex and points out one of three children sitting on a picnic blanket.
Alex notes that it is a Caucasian girl about 8 years old. In looking at the rest of the picture, however,
he realizes that one of the other children in the picture could also fit that description. In addition to
learning his planned list of characteristics, he also notes that the girl he is supposed to identify has
long, brown hair.

Now that only one person in the picture fits the characteristics he learned, he is fairly sure that he
will be able to identify the girl again, even if the scene the tester shows him next week is slightly
different.

Since he still has a few moments left to look at the picture, he attempts to notice other, more subtle
differences between the child he is supposed to remember and the others in the picture—just in
case.

If the two similar children in the picture appeared to be identical twins, Alex might also take note of
some less permanent feature of the child, such as the child's position on the picnic blanket. That
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would enable him to identify the child if he were shown another picture in which the children were
sitting on the blanket in the same order.

UFT uses a very similar method when it learns objects.

First, it "looks" at the object being learned and stores it as a test object, determining in which test
object class it fits. In the sameway, Alex immediately checked whether the item was a person,
animal, plant, or inanimate object. UFT might classify the test object as a standardWindows dialog
box (Dialog), aWeb button (WebButton), or a Visual Basic scroll bar object (VbScrollBar), for
example.

Then, UFT "considers" the identification properties for the test object. For each test object class,
UFT has a list ofmandatory properties that it always learns; similar to the list of characteristics
that Alex planned to learn before seeing the picture. When UFT learns an object, it always learns
these default property values, and then "looks" at the rest of the objects on the page, dialog box, or
other parent object to check whether this description is enough to uniquely identify the object. If
not, UFT adds assistive properties, one by one, to the description, until it has compiled a unique
description; similar to when Alex added the hair length and color characteristics to his list. If no
assistive properties are available, or if those available are not sufficient to create a unique
description, UFT adds a special ordinal identifier, such as the object's location on the page or in
the source code, to create a unique description, just as Alex would have remembered the child's
position on the picnic blanket if two of the children in the picture had been identical twins.

Insight Image-Based Identification
To learn an object based on its properties, UFT must recognize the technology in which the object
was developed, and retrieve its properties via the object's programmatic interface. When this is not
possible, you can use UFT's Insight option, to learn the object based on its appearance.

When using Insight, UFT stores the object as an InsightObject test object, and captures an image
of the object to use as its main identification property. If the application includes additional similar
objects, and the image is not sufficient to create a unique description of the object, UFT adds an
ordinal identifier, in the sameway as it would when learning an object based on its properties.

How UFT Identifies Objects During a Run Session

Relevant for: GUI tests and components

UFT uses a human-like technique for identifying objects during the run session.

Suppose as a continuation to the experiment (described in "How UFT Applies the Test Object
Model Concept" on page 1171), Alex is now asked to identify the same "item" he initially identified
but in a new, yet similar environment.

The first photograph he is shown is the original photograph. He searches for the sameCaucasian
girl, about eight years old, with long, brown hair that he was asked to remember and immediately
picks her out. In the second photograph, the children are playing on the playground equipment, but
Alex is still able to easily identify the girl using the same criteria.

Similarly, during a run session, UFT searches for a run-time object that exactly matches the
description of the test object it learned previously. It expects to find a perfect match for both the
mandatory and any assistive properties it used to create a unique description while learning the
object. As long as the object in the application does not change significantly, the description learned
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is almost always sufficient for UFT to uniquely identify the object. This is true for most objects, but
your application could include objects that aremore difficult to identify during subsequent run
sessions.

For example, Alex is told he will have to recognize a particular tree out of multiple trees in the photo,
and he knows he is going to have to be able to identify it again in a photo taken from a different
angle. If there isn't enough clearly identifying information about the tree itself, then hemight take
note of where the tree is located relative to some other permanent item, such as a nearby lamp post
or picnic table. Then he will be able to identify the tree again, even if the next picture he sees is from
a different angle (as long as all the required items are still visible in the picture).

This is similar to the visual relation identifier property, which enables UFT to identify test objects
according to their neighboring objects in the application. You use this property to link less stable
test objects to more unique test objects, and as long as those objects in the applicationmaintain
their relative location to your object, UFT should still be able to identify the test object even after
predictable user interface changes in the application.

Consider the final phase of Alex's experiment. In this phase, the tester shows Alex another
photograph of the same family at the same location, but the children are older and there are also
more children playing on the playground. Alex first searches for a girl with the same characteristics
he used to identify the girl in the other pictures (the test object), but none of the Caucasian girls in
the picture have long, brown hair. Luckily, Alex was smart enough to remember some additional
information about the girl's appearance when he first saw the picture the previous week. He is able
to pick her out (the run-time object), even though her hair is now short and dyed blond.

How is he able to do this? First, he considers which features he knows hemust find. Alex knows
that he is still looking for a Caucasian female, and if he were not able to find anyone that matched
this description, he would assume she is not in the photograph.

After he has limited the possibilities to the four Caucasian females in this new photograph, he
thinks about the other characteristics he has been using to identify the girl—her age, hair color, and
hair length. He knows that some time has passed and some of the other characteristics he
remembers may have changed, even though she is still the same person.

Thus, since none of the Caucasian girls have long, dark hair, he ignores these characteristics and
searches for someone with the eyes and nose he remembers. He finds two girls with similar eyes,
but only one of these has the petite nose he remembers from the original picture. Even though these
are less prominent features, he is able to use them to identify the girl.

UFT uses a very similar process of elimination with its Smart Identificationmechanism to identify
an object, even when the learned description is no longer accurate. Even if the values of your
identification properties change, UFT maintains the reusability of your test or component by
identifying the object using Smart Identification. For details on Smart Identification, see
"Configuring Object Identification" on page 1310.

The remainder of this guide assumes familiarity with the concepts presented here, including test
objects, run-time objects, identification properties (includingmandatory and assistive properties),
visual relation identifiers, and Smart Identification. An understanding of these concepts will enable
you to create well-designed, functional tests and components for your application.

For a flowchart illustrating the general object identification process, see "Object Identification
Process Workflow" on page 1188.
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Using Insight to Identify an Object During a Run Session
When using Insight, UFT searches for an object that matches the image stored with the test object.
It also uses the ordinal identifier, if one was stored with the object, or any visual relation identifiers
that you defined. UFT searches for thematching object within the Insight object's parent test
object. You can help focus the search on a smaller area by creating smaller parent objects and
building a hierarchy of Insight test objects in your object repository.

Image comparison can be time consuming, especially if there aremany similar objects within the
same parent. Therefore, steps with Insight objects might take longer to run than steps with UFT
test objects that use object properties for identification.

UFT's imagematching algorithm allows for some variation, enabling UFT to recognize the object
even if it changed slightly. However, the algorithm is not based on object properties, and therefore
does not use the smart identificationmechanism.

How UFT Applies the Test Object Model Concept
Relevant for: GUI tests and components

The test object model is a large set of object types or classes that UFT uses to represent the
objects in your application. Each test object class has a list of identification properties that UFT can
learn about the object, a sub-set of these properties that can uniquely identify objects of that class,
and a set of relevant operations that UFT can perform on the object.

A test object is an object that UFT creates in a test or component to represent the actual object in
your application. UFT stores information on the object that will help it identify and check the object
during the run session.

A run-time object is the actual object in your application on whichmethods are performed during
the run session.

When UFT learns an object in your application, it adds the corresponding test object to an object
repository, which is a storehouse for objects. You can add test objects to an object repository in
several ways. For example, you can use the Navigate and Learn option, add test objects manually,
or perform an operation on your application while recording. For details on object repositories, see
"Managing Test Objects in Object Repositories" on page 1198, "SharedObject Repositories" on
page 1285, and "Test Creation - Keyword-DrivenMethodology" on page 820.

When you add an object to an object repository, UFT:

l Identifies the UFT test object class that represents the learned object and creates the
appropriate test object.

l Reads the current value of the object's properties in your application and stores the list of
identification properties and values with the test object.

l Chooses a unique name for the test object, generally using the value of one of its prominent
properties.
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Example

Suppose you add aSearch button with the following HTML source code:

<INPUT TYPE="submit" NAME="Search" VALUE="Search">

UFT identifies the object as aWebButton test object. In the object repository, UFT creates a
WebButton object with the nameSearch, learns a set of identification properties for the object,
and decides to use the following properties and values to uniquely identify theSearch
WebButton:

If you add an object to an object repository by recording on your application, UFT records the
operation that you performed on the object using the appropriate UFT test object method. For
example, UFT records that you performed aClickmethod on theWebButton.

In an action:UFT displays your step in the Editor like this:

Browser("Search Results: Search").Page("Search Results:
    Search").WebButton("Search").Click

and in the Keyword View like this:

In a component: The hierarchy is not displayed, and the step is displayed like this:

When you run a test or component, UFT identifies each object in your application by its test
object class and its description (the set of identification properties and values used to
uniquely identify the object). The list of test objects and their properties and values are stored in
the object repository. In the above example, UFT would search in the object repository during
the run session for theWebButton object with the nameSearch to look up its description.
Based on the description it finds, UFT would then look for aWebButton object in the
application with the HTML tag INPUT, of type submit, with the valueSearch. When it finds the
object, it performs theClickmethod on it.
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This section also includes:

Test Object Descriptions 1173

UFT Test Object Hierarchy 1174

Properties andOperations for Test Objects and Run-TimeObjects 1175

Test Object Descriptions

Relevant for: GUI tests and components

For each test object class, UFT learns a set of identification properties when it learns an object, and
selects a sub-set of these properties to serve as a unique object description. UFT then uses this
description to identify the object when it runs a test or component.

When the test or component runs, UFT searches for the object that matches the description it
learned. If it cannot find any object that matches the description, or if it finds more than one object
that matches, UFT may use the Smart Identificationmechanism to identify the object.

You can configure themandatory, assistive, and ordinal identifier properties that UFT uses to learn
the descriptions of the objects in your application, and you can enable and configure the Smart
Identificationmechanism. For details, see "Configuring Object Identification" on page 1310.

Example

By default, UFT learns the image type (such as plain image or image button), the html tag, and
theAlt text of eachWeb image it learns.

If these threemandatory property values are not sufficient to uniquely identify the object within
its parent object, UFT adds some assistive properties and/or an ordinal identifier to create a
unique description.

Insight Test Object Descriptions

When using Insight, UFT learns objects based on their appearance instead of retrieving properties
from the objects. For the description property, UFT stores an image of the object, which can be
used later to identify the object. If parts of the object do not always look the same, you can instruct
UFT to ignore those areas when it uses the image to identify the object.

User Guide
Chapter 42: The Test Object Model

HP Unified Functional Testing (12.00) Page 1173 of 2274



If necessary, UFT can also use an ordinal identifier to create a unique description for the object.
Other aspects of object configuration, such as mandatory and assistive properties, and smart
identification, are not relevant for Insight test objects.

After UFT creates a description for an Insight test object, you can add visual relation identifiers to
improve identification of the object. If necessary, you can also add the similarity identification
property to the test object description. This property is a percentage that specifies how similar a
control in the application has to be to the test object image for it to be considered amatch.

UFT Test Object Hierarchy

Relevant for: GUI tests and components

The UFT test object hierarchy comprises one or more levels of test objects. The top level object
may represent a window, dialog box, or browser type object, depending on the environment. The
actual object on which you perform an operationmay be learned as a top level object, a second
level object, for example,Window.WinToolbar, or a third level object, for example,
Browser.Page.WebButton.

In some cases, even though the object in your applicationmay be embedded in several levels of
objects, the hierarchy does not include these objects. For example, if aWebButton object in your
application is actually contained in several nestedWebTable objects, which are all contained within
a Browser and Page, the learned object hierarchy is only Browser.Page.WebButton.

An object that can potentially contain a lower-level object is called a container object. All top-level
objects in the object hierarchy are container objects. If a second-level object contains third-level
objects according to the UFT object hierarchy, then that object is also considered a container
object. For example, in the stepBrowser.Page.Edit.Set "David", Browser and Page are both
container objects.

For details on the UFT object hierarchy for specific environments, see the relevant section in the
HP Unified Functional Testing Add-ins Guide.
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Properties and Operations for Test Objects and Run-Time Objects

Relevant for: GUI tests and components

UFT uses unique terms to differentiate between the properties and operations for test objects and
run-time objects. The table below introduces some of these terms.

UFT Test Objects Run-time Objects From Your Application

Identification properties are UFT-specific
properties that UFT uses to identify objects in
applications, to retrieve and store information
about those objects, or to compare stored values
with the current values of an object in an
application.

The identification properties available for a test
object are determined by its test object class
(and not by the actual properties available for the
object in the application).

Native properties are the properties created
by the object creator for each run-time object.
(Examples of object creators include
Microsoft for Microsoft Internet Explorer
objects and the product developer for ActiveX
objects.)

A test object operation is a method or property
that UFT can perform on an object from a
particular test object class.

Example: UFT can perform theClick
method on aWebButton test object.

Native operations are themethods of the
object in your application as defined by the
object creator.

As you add steps to your test or component, you specify which operation to perform on each test
object. If you record steps, UFT records the relevant operation as it is performed on an object.
During a run session, UFT performs the specified test object operation on the run-time object.

The sections below describe some of the ways in which you can view andmodify properties and
operations for test objects and run-time objects.

For test objects

l You can retrieve or modify identification property values manually while designing your test or
component, or you can useSetTOProperty statements during a run session (via an operation
defined in a function library).

For details, see "Managing Test Objects in Object Repositories" on page 1198, "Retrieving and
Setting Identification Property Values" on page 1007, and theHP UFT Object Model Reference
for GUI Testing.

l You can use regular expressions in function libraries to identify property values based on
conditions or patterns you define.
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For details, see "Regular Expressions Overview" on page 318.

l You can parameterize identification property values with data table parameters so that a
different value is used during each iteration of the test.

For details, see "Parameterizing Object Values" on page 1526.

l You can view ormodify the identification property values that are stored with your test or
component in the Object Properties or Object Repository window.

For details, see "Specifying or Modifying Property Values" on page 1205.

l You can view the current identification property values of any visible object using the Properties
tab of the Object Spy.

For details, see "How to Use theObject Spy to View Object Properties andOperations or Add
anObject to a Repository" on page 1184.

l You can view the syntax of the test object operations of any visible object using the Operations
tab of the Object Spy. For details, see "How to Use theObject Spy to View Object Properties
andOperations or Add anObject to a Repository" on page 1184.

For run-time objects

l You can view the syntax of the native operations of any visible object using the Operations tab
of the Object Spy. For details, see "How to Use theObject Spy to View Object Properties and
Operations or Add anObject to a Repository" on page 1184.

l You can retrieve native property values from the run-time object during the run session by adding
GetROProperty statements. For details, see "Retrieving and Setting Identification Property
Values" on page 1007.

l If the available test object operations and identification properties do not provide the functionality
you need, you can access the internal operations and native properties of the run-time object
using theObject property. You can also use the attribute object property to identify Web objects
in your application according to user-defined properties. For details, see "Native Properties and
Operations" on page 1008 and theHP UFT Object Model Reference for GUI Testing.

l When using Insight test objects, which UFT recognizes in the application based on the object's
appearance, UFT does not use the object's programming interface and therefore native
operations and properties are not relevant.

Identifying Objects Using Insight
Relevant for: GUI tests and components

UFT can use Insight, which is an image-based identification ability, to recognize objects in your
application based on what they look like, instead of using properties that are part of their design.
This can be useful if you are working with an application whose technology is not supported by
UFT, or with an application running on a remote computer.
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When using Insight, UFT stores an image of the object with the Insight test object (along with
ordinal identifiers, if necessary), and uses this image as themain description property to identify the
object in the application. For more details, see "Insight Test Object Descriptions" on page 1173.

You can create InsightObject test objects during recording sessions, or when adding test objects to
an object repository manually. When adding objects to an object repository, you can add an object
directly from the application, or even from a picture of the object displayed on your screen.

Note: Dual monitor support. Insight is supported only on the primary monitor. Therefore, if
you are working with dual monitors, make sure that your application is visible on the primary
monitor when you use UFT for Insight test objects.

For details, see:

l "How to Record a Test or Component Using Insight Recording" on page 860

l "How to Add an Insight Object to the Object Repository" on page 1214

In the object repository, you can edit the object's properties, such as its name and image, and the
default location to click in the control when performing test object methods. You can also define
visual relation identifiers to improve UFT's ability to accurately identify the object.

Insight Test Object Hierarchy
The Insight object is always added to the object repository as a child of the test object that
represents its containing application, such as aWindow or Browser object. (The new object's
parent object is also added if it does not already exist in the object repository.)

You canmanually move the test object in the Object Repository window or the Object Repository
Manager. If you place it under another test object, then UFT searches for the object in the
application only within its parent test object. If youmove the Insight test object to be a top-level
object, then UFT searches for the object anywhere on the screen.

Steps with Insight Test Objects
You create steps using Insight test objects in much the sameway as you would with other types of
test objects.

For details on themethods and properties supported by Insight test objects, see the Insight section
of theHP UFT Object Model Reference for GUI Testing.

In the Editor, the test object image is displayed in the step instead of the test object name. When
you hold the cursor over the image, an enlarged view of the image is displayed. You can double-
click the image to open the object repository with the InsightObject selected.

If you want the Editor to show the test object names instead of the images, clear theShow test
object image in steps option in the Insight pane of the Options dialog box (Tools > Options >
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GUI Testing tab > Insight node). For details, see "Insight Pane (Options Dialog Box > GUI Testing
Tab)" on page 561.

When running steps on Insight objects, UFT can show a visual representation of the steps being
performed on the application. For example, a small circle is displayed for mouse clicks, and a line is
drawn to show the path of a drag operation. You can enable this option in the Insight pane of the
Options dialog box (Tools > Options > GUI Testing tab > Insight node).

During the run session, UFT searches for an object that matches the image stored with the test
object. Image comparison can be time consuming, especially if there aremany similar objects
within the same parent. Therefore, steps with Insight objects might take longer to run than steps
with UFT test objects that use object properties for identification.

Object Repository Types - Overview
Relevant for: GUI actions and components

Objects can be stored in two types of object repositories—a shared object repository and a local
object repository.

A shared object repository stores objects in a file that can be accessed by multiple tests or
components (via their application areas) (in read-only mode). You can use the same shared object
repository for multiple actions or components. You can also usemultiple object repositories for
each action or component.

A local object repository stores objects in a file that is associated with one specific action or
component, so that only that action or component can access the stored objects.

Tests or components always use the object repositories that are specified in the Associated
Repositories tab of the Action Properties dialog box or in the Associate Repositories dialog box of
the application area with which the component is associated. Shared object repositories are read-
only when accessed from tests or components; you edit them using the Object Repository
Manager.

You perform many object repository-related tasks either in the Object Repository window or in the
Object Repository Manager. To view a list of the tasks that you can perform in each, see
"Comparison of Object Repository Window andObject Repository Manager " on page 1186.

Planning where to store objects
When you plan and create tests or components, youmust consider how you want to store their test
objects. You can:

l Store the objects for each action or component in its corresponding local object repository.

l Store the objects in one or more shared object repositories. By storing objects in shared object
repositories and associating these repositories with your actions or component’s application
areas, you enablemultiple actions and components to use the objects. Use a combination of
objects from your local and shared object repositories, according to your needs.
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l Transfer local objects to a shared object repository, if required. This reduces maintenance and
enhances the reusability of your tests and components because it enables you tomaintain the
objects in a single, shared location instead of multiple locations. For details, see "Deciding
Whether to Use Local or SharedObject Repositories " on the next page.

Note: If you want to use a shared object repository from ALM, youmust save the shared object
repository in the Test Resources module in your ALM project before you associate the object
repository using the Associated Repositories tab of the Action Properties dialog box or the
Associate Repositories dialog box.

You can save the shared object repository to your ALM project using the Object Repository
Manager (as long as the Object Repository Manager is connected to your ALM project).

How UFT determines the object to use when an object with the same name
exists in multiple object repositories

l If an object with the same name is located in both the local object repository and in a shared
object repository associated with the same action or component, the local object definition is
used.

l If more than one shared object repository is associated with the same action or component, the
object definition is used from the first occurrence of the object, according to the order in which
the shared object repositories are associated with the action or component.

For details on associating shared object repositories, see:

n For tests:"Associate Repositories Dialog Box" on page 1266

n For components: "Object Repositories Pane (Application Area)" on page 2105

Note for users of previous QuickTest versions
If you open a test stored in the file system that was created using QuickTest 9.0 or earlier, the
object repository associations are changed as follows:

l If the test previously used per-action repositories, the objects in each per-action repository are
transferred to the local object repository of each action in the test.

l If the whole test previously used one shared object repository, the same shared object
repository is associated with each of the actions in the test, and the action’s local object
repositories are empty.

If the test is opened in read-only mode, these changes are not saved.
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Deciding Whether to Use Local or Shared Object
Repositories

Relevant for: GUI actions and components

To choose where to save objects, you need to understand the differences between local and shared
object repositories.

The following table describes when it is preferable to use each type of object repository:

Use this
object
repository
type... In these situations...

local
object
repository

l You are creating single-action tests.

l You are creating simple tests or components, especially under the following
conditions:

n You have only one, or very few, tests or components that correspond to a
given application, interface, or set of objects.

n You do not expect to frequently modify object properties.

n You are new to using UFT. You can record and run tests or components
without creating, choosing, or modifying shared object repositories because
all objects are automatically saved in a local object repository that can be
accessed by its corresponding action or component.

See also: "Local Object Repository - Overview" on the next page
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Use this
object
repository
type... In these situations...

shared
object
repository

l You are creating tests or components using keyword-drivenmethodologies (not
by recording).

l You have several tests or components that test elements of the same
application, interface, or set of objects.

l You often work with multi-action tests and regularly use the Insert Copy of
Action and Insert Call to Action options.

l You expect the object properties in your application to change from time to time
and/or you regularly need to update or modify object properties.

l If you are familiar with testing, it is probably most efficient to save objects in a
shared object repository. In this way, you can use the same shared object
repository for multiple actions or components—if they use the same objects.

Object information that applies tomany actions or components is kept in one
central location. When the objects in your application change, you can update
them in one location for all the actions and components that use this shared
object repository.

See also: "SharedObject Repository - Overview" on the next page

This section also includes:

Local Object Repository - Overview 1181

SharedObject Repository - Overview 1182

Local Object Repository - Overview

Relevant for: GUI actions and components

When you use a local object repository, UFT uses a separate object repository for each action or
component. (You can also use one or more shared object repositories if needed. For details, see
"SharedObject Repositories Overview" on page 1286.) The local object repository is fully editable
from within its action or component.
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Whenworking with a local object repository:

l UFT creates a new (empty) object repository for each action or component.

l WhenUFT learns new objects (either because you add them to the local object repository, or
you record operations on objects in your application), it automatically stores the information
about those objects in the corresponding local object repository (if the test objects do not already
exist in an associated shared object repository).

UFT adds all new objects to the local object repository even if one or more shared object
repositories are already associated with the action or component. (This assumes that a test
object with the same description does not already exist in one of the associated shared object
repositories).

l If a child object is added to a local object repository, and its parents are in a shared object
repository, its parents are automatically added to the local object repository.

l Every time you create a new action or component, UFT creates a new, corresponding local
object repository and adds test objects to the repository as it learn them.

l If UFT learns the same object in your application in two different actions or components, the test
object is stored as a separate test object in each of the local object repositories.

l When you save your test or component, its local object repositories (or repository, respectively)
are automatically saved with the test or component. The local object repository is not accessible
as a separate file (unlike the shared object repository).

Shared Object Repository - Overview

Relevant for: GUI actions and components

When you use shared object repositories, UFT uses the shared object repositories you specify for
the selected action or component's application area. You can use one or more shared object
repositories. (You can also save some objects in a local object repository for each action or
component if you need to access them only from the specific action or component. For details, see
"Local Object Repository - Overview" on the previous page.)

After you begin creating your test or component, you can specify additional shared object
repositories. You can also create new ones and associate them with your action or component.
Before running the test or component, youmust ensure that the object repositories being used
contain all of the test objects used in the test or component steps. Otherwise, the test or
component may fail. For details, see "Adding and Deleting Test Objects in a Local or SharedObject
Repository" on page 1199.

Youmodify a shared object repository using the Object Repository Manager. For details, see
"SharedObject Repositories" on page 1285.
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Whenworking with a shared object repository:

l If UFT learns a test object that already exists in either the shared or local object repository, UFT
uses the existing information and does not add the object to that object repository.

l If a child object is added to a local object repository, and its parents are in a shared object
repository, its parents are automatically moved to the local object repository.

l WhenUFT learns a test object, it adds it to the local object repository (not the shared object
repository)—unless the same test object already exists in an associated shared object
repository. (In this case, UFT uses the existing information in the shared object repository.)

You can export objects from the local object repository to a shared object repository. You can also
export the local object repository and replace it with a shared object repository. This enables you to
make the local objects accessible to other actions or components. For details, see "Exporting Local
Objects to a SharedObject Repository" on page 1260.

You can alsomerge objects from the local object repository directly to a shared object repository
that is associated with the same action or component. This can help reducemaintenance since you
canmaintain the objects in a single shared location, instead of multiple locations. For details, see
"When toMerge SharedObject Repositories" on page 1352.
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Tasks

How to Use the Object Spy to View Object Properties and
Operations or Add an Object to a Repository

Relevant for: GUI tests and components

This task describes how to use the Object Spy to view identification properties, native properties,
test object operations, or native operations, as well as add an object to an object repository.

This task includes the following steps:

l "Prerequisites" below

l "Open theObject Spy dialog box" below

l "Select the details you want to view for the object" below

l "Resize the Object Spy dialog box - Optional" below

l "Use the pointing hand to select the application object on which you want to Spy" below

l "Add selected objects to the object repository - Optional" on the next page

1. Prerequisites
Open your application to the page containing the object on which you want to spy.

2. Open the Object Spy dialog box
For details, see the To Access section of the "Object Spy Dialog Box " (described on page
1189).

3. Select the details you want to view for the object
In the "Object Spy Dialog Box " (described on page 1189), select theProperties orOperations
tab, and then select the radio button to view theNative or Identification properties. For details
about using the run-time object's operations or retrieving the values of its properties, see
"Retrieving and Setting Identification Property Values" on page 1007 and "Native Properties
andOperations" on page 1008.

4. Resize the Object Spy dialog box - Optional
This is useful if the objects on which you want to spy have a deep hierarchy or long property
names and values, as it enables you to view all of the information without scrolling. For details,
see "Object Spy Dialog Box " on page 1189.

5. Use the pointing hand to select the application object on which you
want to Spy

HP Unified Functional Testing (12.00) Page 1184 of 2274



In the Object Spy, click the pointing hand button and thenmouse over or click an object in your
application. In most environments, as youmouse over objects in your application, the Object
Spy highlights the object it identifies and displays the relevant information in the Object Spy,
according to the options you selected in the Object Spy dialog box. For details on using the
pointing hand, see "Tips for Using the Pointing Hand" on page 1196.

When you click an object in your application, the Object Spy captures its information, and you
can:

n Change the selected radio button or tab in the Object Spy to view additional details.

n View properties, values, or operations of other test objects currently displayed in theObject
hierarchy tree, by selecting that test object in the tree.

n Highlight the object in the application, by clicking theHighlight in Application button .

6. Add selected objects to the object repository - Optional
After clicking an object you can add it (or any other object in theObject hierarchy tree) to the

object repository using theAdd to Repository button . For details, see "Object Spy
Dialog Box " on page 1189.

If an object in theObject hierarchy tree already exists in a repository associated with the
active action or component, a repository icon is displayed in the lower-right corner of the
object's icon.
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Reference

Comparison of Object Repository Window and Object
Repository Manager

Relevant for: GUI tests and components

You perform many object repository-related tasks either in the Object Repository window or in the
Object Repository Manager. Some object repository-related tasks can also be performed in both.
The following table lists features and functionality, indicating if they are available in the Object
Repository window or the Object Repository Manager:

Functionality

Object
Repository
window

Object
Repository
Manager

"Adding and Deleting Test Objects in a Local or SharedObject
Repository" on page 1199

"Copying, Pasting, Moving, or Deleting Objects in the Object
Repository "on page 1217

"Highlighting anObject in Your Application" on page 1203

"Locating a Test Object in the Object Repository" on page 1204

"Specifying or Modifying Property Values" on page 1205

"Updating Identification Properties from anObject in Your
Application" on page 1206

"Restoring Default Mandatory Properties for a Test Object" on page
1206

"Renaming Test Objects " on page 1206

"Adding Properties to a Test Object Description" on page 1208

"Defining New Identification Properties" on page 1208

"Removing Properties from a Test Object Description" on page 1224

"Exporting Local Objects to a SharedObject Repository" on page
1260

"Copying Objects to the Local Object Repository" on page 1261

"Managing SharedObject Repositories" on page 1291 (includes
creating, opening, saving, closing, and enabling editing functionality)
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Functionality

Object
Repository
window

Object
Repository
Manager

"Adding a Test Object to anObject Repository" on page 1211

"Adding Test Objects Using the Navigate and Learn Option" on page
1295

"Working with Repository Parameters" on page 1287

"Merging Two SharedObject Repositories" on page 1356

"Importing and Exporting SharedObject Repositories Using XML"
on page 1287
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Object Identification Process Workflow
Relevant for: GUI tests and components

The following flowchart provides a general overview of themain process of UFT object
identification.

Note for Web-based objects:
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l If you definedWeb object identifiers (such as XPath/CSS properties) for these test objects,
they are used before the description properties. If one or more objects are found, UFT
continues to identify the object using the description properties. For details, see the section
onWebObject Identifiers (described in theHP Unified Functional Testing Add-ins Guide).

l Additional UFT-generated properties, such as source index or automatic XPath, may also
affect the object identification process. You enable these properties in the AdvancedWeb
Options tab of the Options dialog box (described in theHP Unified Functional Testing Add-
ins Guide) (Tools > Options > GUI Testing tab > Web > Advanced node).

Object Spy Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to view the native properties and operations of any object in an open
application, as well as the test object hierarchy, identification properties, and operations of the test
object that UFT uses to represent that object.
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You can also check if an object is in a repository associated with your action or component (via its
application area), add the selected object to the local object repository (or a shared object repository
if you are using the Object Spy from theObject Repository Manager), and highlight an object in the
application.
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To
access

1. Do one of the following:

n Ensure that a GUI test or action is in focus in the document pane.

n In the Solution Explorer, select a GUI test or action node.

2. Use one of the following:

n Select Tools > Object Spy.

n Click theObject Spy toolbar button .

n In the Record toolbar, click theObject Spy button during a recording
session.

Available from:

l "UFT MainWindow Overview" (described on page 78)

l "Object Repository Window" (described on page 1274)

l "Object Repository Manager MainWindow" (described on page 1297)

l "Record Toolbar" (described on page 866)

Relevant
tasks

"How to Use theObject Spy to View Object Properties andOperations or Add an
Object to a Repository" on page 1184

See also "Properties andOperations for Test Objects and Run-TimeObjects" on page 1175

User interface elements are described below:

Option Description

Pointing Hand. Turns themouse pointer into a pointing hand. Use the pointing
hand to highlight or click the object whose properties and/or operations you want
to view.

l As youmove the pointing hand over the objects in the application, the objects
are highlighted in the application (in some environments), and their details are
displayed in the Object Spy dialog box.

l To capture information about a particular object and its parent objects in the
Object Spy, click on the object in the application.

See also: "Tips for Using the Pointing Hand" on page 1196.
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Option Description

Keep on Top. Keeps the Object Spy dialog box in view while spying on an object
in your application.

Note:When theKeep on Top button is not pressed, the Object Spy dialog
box may be hidden on your screen behind your application. To view the
Object Spy dialog box, press the left CTRL key and arrange the windows as
needed.

Highlight in Application. Highlights the object in the application that
corresponds to the test object currently selected in the Object Spy.

Add Object to Repository. Adds the test Object selected in the Spy hierarchy
tree to the object repository.

l If the object is successfully added to the object repository, the repository icon
is added to the bottom of the test object icon.

l When theObject Spy dialog box is opened from UFT or the Object Repository
Window, the object is added to the local object repository of the active action
or component.

l When theObject Spy dialog box is opened from theObject Repository
Manager, the object is added to the active object repository. This option is
disabled when there is no open repository.
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Option Description

Copy Identification Properties to Clipboard. Copies all of the properties and
values for the object currently selected in theObject hierarchy tree. You can
paste the copied data from the Clipboard into any document.

Enabled only when the Identification radio button is selected in theProperties
tab.

The copied properties and values are formatted in standard programmatic
description syntax with line breaks between each property-value pair. For
example:

"Class Name:=Image",
"abs_x:=585",
"abs_y:=573",
"alt:=Specials",
....

This option is useful if you want to:

l Compare the properties and values of two objects in your application.

l Copy the relevant strings when creating programmatic descriptions.

For more details on programmatic descriptions, see "Programmatic Descriptions"
on page 995.

Object
hierarchy

Displays the hierarchy of test objects that are related to the object you selected in
your application.

l If an object in the hierarchy already exists in a repository associated with the
active action or component, a repository icon is displayed in the lower-right
corner of the object's icon.

l To view properties, values, or operations for another test object in theObject
hierarchy tree, select that test object in the tree.

l While an object is highlighted in the application, test object classes are
displayed in theObject hierarchy tree, but test object names are not. Test
object names (such as Atlanta to Las Vegas andSpecials in the image shown
above) are displayed only after clicking the object to capture the information in
the Object Spy.
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Option Description

Properties
tab

Select theNative or Identification radio button to display the native properties
and their values, or the test object identification properties and values of the run-
time object associated with the selected test object in theObject hierarchy tree.

l Properties. Displays the identification or native property names for the test
object that is currently selected in theObject hierarchy tree.

l Values. Displays the identification or native property values of the relevant
object in the application.

Operations
tab

Select theNative or Test Object radio button to display the native operations or
test object operations, and their corresponding syntax, for the test object that is
currently selected in the Object Spy test Object hierarchy tree, or the run-time
object associated with it.

Selection The content in this box differs depending on which tab is displayed above it.

Properties tab:Displays the property name or value that was most recently
clicked.

Operations tab:Displays the syntax of themost recently clicked operation.

Tip: To copy the text that is displayed in this box to the Clipboard, highlight
the text and press Ctrl+C or right-click the highlighted text and select Copy.

Description Provides a description of themost recently clicked operation, when available.
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Object Selection Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to specify which object you want UFT to use when you select a
location in your application that is associated with more than one object.

To
access

1. Do one of the following:

n Ensure that a GUI test or action is in focus in the document pane.

n In the Solution Explorer, select a GUI test or action node.

2. Use one of the following:

n After performing an operation that changes the pointer to a pointing hand, if you
point to a location that is associated with more than one object, the Object
Selection dialog box opens.

n For tests:When you right-click a location in the Active Screen to perform an
operation that requires selecting an object, if the location is associated with
more than one object, the Object Selection dialog box opens.

See
also

"Tips for Using the Pointing Hand" on the next page

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

<object
tree>

A tree containing the parent hierarchy of the object you selected. Select the object
that you want UFT to use from the tree and click OK.
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Tips for Using the Pointing Hand
Relevant for: GUI tests and components

Clicking the pointing hand button converts themouse (device) pointer into a pointing hand. You use
the pointing hand to highlight or click an object in your application.

This section provides tips for working with the pointing hand.

l You can hold the left CTRL key to change the pointing hand to a standard pointer. You can then
change the window focus or perform operations in UFT or in your application, such as right-
clicking, using the scroll bars, or moving the pointer over an object to display a context menu.

l If the window containing the object you want to select is partially hidden by another window, hold
the pointing hand over the partially hidden window for a few seconds until it comes to the
foreground. Then point to and click the required object. You can configure the length of time
required to bring a window into the foreground using the General pane of the GUI Testing tab in
the Options dialog box (Tools > Options > GUI Testing tab > General node). For details, see
"General Pane (Options Dialog Box > GUI Testing Tab)" on page 536.

l If the window containing the object you want to select is fully hidden by another window, or if a
dialog box is hidden behind a window, press the left CTRL key and arrange the windows as
needed.

l If the window containing the object you want to select is minimized, you can display it by holding
the left CTRL key, right-clicking the application in theWindows task bar, and choosingRestore
from the context menu.

l If the object you want to select can be displayed only by performing an event (such as right-
clicking or moving the pointer over an object to display a context menu), hold the left CTRL key.
The pointing hand temporarily turns into a standard pointer and you can perform the event. When
the object you want to select is displayed, release the left CTRL key. The pointer becomes a
pointing hand again.

Examples of pointing hand usage

l From theObject Spy, you use the pointing hand to view the object's properties and/or
operations.

l From the Select Object for Step dialog box, you use the pointing hand to add an object to
your test or component. When you click the pointing hand, UFT is hidden, enabling you to
view the entire desktop.
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Troubleshooting and Limitations - Object Spy
Relevant for: GUI tests and components

l Whenworking inWindows XP, usingCTRL+Left mouse button to select Taskbar items is not
supported.

Workaround:UseCTRL + Right mouse button to open the shortcut menu, and then select
Restore to display the selected item.

l TheObject Spy does not support Insight test objects.
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Chapter 43: Managing Test Objects in Object
Repositories

Relevant for: GUI tests an components

This chapter includes:

Concepts 1199

Adding and Deleting Test Objects in a Local or SharedObject Repository 1199

Guidelines for Copying, Pasting, andMoving Objects 1202

Locating Objects 1202

Maintaining Identification Properties 1204

Visual Relation Identifiers 1209

Tasks 1211

How to Add a Test Object to anObject Repository 1211

How to Add an Insight Object to the Object Repository 1214

How to Copy, Paste, Move, or Delete Objects in the Object Repository 1217

How to Locate anObject in anObject Repository 1219

How toMaintain Test Objects in Object Repositories 1220

How to Define a Visual Relation Identifier for a Specific Test Object - Use-Case
Scenario 1225

Reference 1231

Add Properties Dialog Box 1231

Change Test Object Image / Add Insight Test Object Dialog Box 1233

Define New Test Object Dialog Box 1240

Define Object Filter Dialog Box 1242

Find and Replace Dialog Box (Object Repository) 1245

Ordinal Identifier Dialog Box 1247

Select LearnMode Dialog Box 1248

Visual Relation Identifier Dialog Box 1251

Troubleshooting and Limitations - Managing Test Objects 1258
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Concepts

Adding and Deleting Test Objects in a Local or Shared
Object Repository

Available from:

l Object Repository window for the local object repository

l Object Repository Manager for shared object repositories

Relevant for: GUI tests and components

When you create an object repository for your keyword-driven testing infrastructure, you can add
test objects to it in various ways, for example:

l You can use theNavigate and Learn option to add objects to a shared object repository
according to your defined filter.

l You can record an action or component to add each object on which you perform an operation to
the local object repository. (This occurs for objects that do not already exist in an associated
shared object repository.)

l You can add test objects to the local object repository while editing your test or component. For
example, for tests and scripted components, you can add tests objects from the Active Screen.

When you add test objects to an object repository, you can choose to add only a selected test
object, to add all test objects of a certain type (such as all button objects), or to add all test objects
of a specific class (such as allWebButton objects).

For example, youmay find that users need to perform a step on an object that is not in the object
repository. Youmay also find that an additional object was added to the application you are testing
after you built the object repository. You can add the object directly to a shared object repository
using the Object Repository Manager, so that it is available in all actions and components that use
this shared object repository. Alternatively, you can add it to the local object repository of the action
or component.

You can add test objects to a local or shared object repository directly from your application. You
can choose to add a specific test object either with or without its descendants. You can also control
which descendants to add, according to their object and class types, based on selections that you
define in the object filter.

If needed, you canmerge test objects from the local object repository into a shared object
repository. For details, see "Object Repository Merge Tool" on page 1351.

You can also add test objects to a shared object repository while navigating through your
application. For details, see "Navigate and Learn Toolbar" on page 1302.
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This section also includes:

l "Adding Insight Test Objects" below

l "Adding Test Objects to the Local Object Repository from the Active Screen (GUI actions and
scripted components only)" below

l "Defining New Test Objects" on the next page

l "Deleting Objects in the Object Repository" on the next page

Adding Insight Test Objects
Use Insight test objects in UFT if you want UFT to recognize objects based on what they look like,
instead of based on their native properties. For details, see "Identifying Objects Using Insight" on
page 1176.

When you add an Insight test object, UFT stores an image of the object together with the test
object, and later uses this image to identify the object in the application.

When you add an Insight test object, the following learningmodes are available:

l Automatic.When using this mode, you click on the control in the application, and UFT detects
the borders of the control, and takes a snapshot of it. This mode is the faster mode and should
be satisfactory in most cases.

l Manual.When using this mode, you take a snapshot of the control in the application, manually
specifying the borders of the control. You can use this mode in cases where the automatic mode
does not correctly detect the borders of the control. For example, when it selects an area of the
application which is much larger than the control.

In both cases, UFT saves an image of the control (used to identify the control), as well as a
snapshot of the screen containing the control. After UFT takes the snapshot, you can adjust the
image used to identify the test object.

Note: Insight test objects require more disk space than other test objects, because of the test
object images and the snapshots stored with the test objects. To control the amount of space
used, you can limit the size of the snapshot in the "Insight Pane (Options Dialog Box > GUI
Testing Tab)".

In addition, after you add all of the relevant test objects and finishmodifying them to your
satisfaction in the object repository, you can delete all of the snapshots to reduce the amount
of disk space used.

For task details, see "How to Add an Insight Object to the Object Repository" on page 1214.

Adding Test Objects to the Local Object Repository from the Active
Screen (GUI actions and scripted components only)
You can add test objects to the local object repository of the current action by selecting the required
object in the Active Screen.
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To add test objects to the object repository using the Active Screen, the Active Screenmust
contain information for the object you want to add. You can control how much information is
captured in the Active Screen in the Active Screen node of the Options dialog box (Tools >
Options > GUI Testing tab > Active Screen node). For details, see "Active Screen Pane
(Options Dialog Box > GUI Testing Tab)" on page 547.

When you add a test object to the object repository in one of the ways described in this section, the
test object is added to the local object repository and can be used only by the current action or
scripted component. If you want to add the test object to the shared object repository so that it can
be used inmultiple actions or scripted components, add it using the Object Repository Manager
(not from the Active Screen).

Defining New Test Objects
You can define test objects in your object repository that do not yet exist in your application. This
enables you to prepare an object repository and create actions or components for your application
before the application is ready for testing.

For example, youmay already know the names, types, and descriptive properties of some of the
objects in your application, and know only the types of other objects in your application. Before your
application is ready, you can createWebEdit objects forUserName andPassword fields in your
Login page (plus the relevant parent Page and Browser objects). If you know the property values for
these objects, you can also add them. If not, you can add them when your application is ready for
testing.

When youmanually define a new object in the object repository, the object is added to the local
object repository and can be used only by the current action or component. If you want to add the
object to the shared object repository so that it can be used inmultiple actions or components, you
must add it using the Object Repository Manager. For details, see "SharedObject Repositories" on
page 1285.

After you define a new test object, you canmodify the test object description at any time. For
example, youmay need to update the test object description if the properties of the object in your
application do not match the test object description that you defined, or if an object was updated in
your application. For details, see "Updating Identification Properties from anObject in Your
Application" on page 1206.

Deleting Objects in the Object Repository
When you remove a step from your action or component, its corresponding test object remains in
the object repository. You can delete the test object if it is not in use elsewhere.

For example, if you are working with a local object repository, make sure that the test object is not
used in any other steps within that action or component. If you are working with a shared object
repository, confirm that the test object is not used in any other action or component using that
shared object repository. Also, confirm that the test object you are deleting is not used in a visual
relation identifier for another test object.

You delete objects in the local object repository using the Object Repository window, and objects in
the shared object repository using the Object Repository Manager.

Note: If your action or component contains references to an object that you deleted from the
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object repository, your run session will fail.

Guidelines for Copying, Pasting, and Moving Objects
Relevant for: GUI tests and components

When copying, pasting, or moving objects, consider the following guidelines:

l You cannot modify the root node of an object repository.

l If you change the object hierarchy, ensure that the new hierarchy is valid.

l If you paste or move an object to a different hierarchical level, you can choose whether to copy
all objects up to the shared parent object (in themessage displayed when you perform such an
operation).

l In the Object Repository window, when you copy, paste, andmove objects from a shared object
repository associated with an action or a component, the objects are copied, pasted, or moved
to the local object repository of the action or component.

l If youmove an object to its immediate parent, UFT creates a copy of the object (renamedwith
an incremental suffix) and pastes it as a sibling of the original object.

l If you cut or copy an object, and then paste it on its parent object, UFT creates copy of the
object (renamedwith an incremental suffix) and inserts it at the same level as the original object.

l You cannot move an object to any of its descendants.

l You cannot copy or move an object to be a child of a bottom-level object (an object that cannot
contain a child object) in the object hierarchy.

l You cannot copy, paste, or move objects that have unmapped repository parameters from a
shared object repository to the local object repository.

l If you copy, paste, or move an object from a shared object repository to the local object
repository, and the object or one of its parent objects are parameterized using repository
parameters, the repository parameter values are converted when you copy, paste, or move the
object. If the value is a constant value, the property receives the same constant value.

l If you delete a test object that are used in a visual relation identifier for another test object, object
identification for that test object will fail.

Locating Objects

Available from:
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l Object Repository window for the local object repository

l Object Repository Manager for shared object repositories

Relevant for: GUI tests and components

You can search for a specific object in your object repository in several ways. You can search for an
object according to its type. For example, you can search for a specific edit box, or you can point to
an object in your application to automatically highlight that same object in your repository. You can
select an object in your object repository and highlight it in your application to check which object it
is. For local objects (and shared objects in an editable shared object repository when using the
Object Repository Manager), you can also replace specific property values with other property
values. For example, you can replace the property value userNamewith user name.

For task details, see "How to Locate anObject in anObject Repository" on page 1219.

Note:When locating test objects, UFT also takes into account the visual relation identifier
property, if defined for that test object. For details, see "Visual Relation Identifiers" on page
1209.

This section also includes:

l "Finding Objects in anObject Repository" below

l "Highlighting anObject in Your Application" below

l "Locating a Test Object in the Object Repository" on the next page

Finding Objects in an Object Repository
You can use the Find and Replace dialog box to find an object, property, or property value in an
object repository. You can also find and replace specified property values.

You replace property values for objects in the local object repository using the Object Repository
window. You replace property values for objects in shared object repositories using the Object
Repository Manager.

Highlighting an Object in Your Application
You can select a test object in your object repository and highlight it in the application you are
testing. When you choose to highlight a test object, UFT indicates the selected object's location in
your application by temporarily showing a frame around the object and causing it to flash briefly.
The applicationmust be open to the correct context so that the object is visible.

For example, to locate theUser Name edit box in aWeb page, you can open the relevant page in
theWeb browser and then select theUser Name test object in the object repository. When you
select theHighlight in Application option, theUser Name edit box in your browser is framed in
theWeb page and flashes several times. Both the frame and the flashing behavior are temporary.
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Locating a Test Object in the Object Repository
You can select an object in the application you are testing and highlight the test object in the object
repository.

For example, to locate a Find a Flight image in aWeb page, you can select the Locate in
Repository option, and then select the image in yourWeb page using the pointing hand
mechanism. After you select the Find a Flight image object from the selection dialog box and click
OK, the parent hierarchy in the object repository tree expands and the Find a Flight image test
object is highlighted.

Maintaining Identification Properties

Available from:

l Object Repository window for the local object repository

l Object Repository Manager for shared object repositories

Relevant for: GUI tests and components

As applications change, youmay need to change the property values of the steps in your action or
component. Suppose an object in your application is modified. If that object is part of your action or
component, you shouldmodify its values so that UFT can continue to identify it. For example, if a
company Web site contains aContact Us hypertext link, and the text string in this link is changed
toContact My Company, you need to update the object's details in the object repository so that
UFT can continue to identify the link properly (assuming that the text property is included in the test
object's description).

If you are using an Insight object and the text is included in the test object image, youmight need to
update the test object so that UFT can continue to identify it. You canmodify the test object's
image to include the updated text, or you can add a similarity identification property to the test
object description, or lower the property's value, to enable UFT tomatch the test object with the
object in the application despite the differences in the text.

You canmodify identification properties in a number of ways. For an object stored in a local object
repository, you canmodify its properties directly from theObject Repository window. For an object
stored in a shared object repository, you can either open it in the Object Repository Manager and
modify its properties, or you can copy it to the local object repository and thenmodify its properties.

Insight Test Object Properties

You canmaintain the properties of Insight test objects in the sameway as any other type of test
object. However, keep inmind that for Insight test objects, UFT does not retrieve property values
from the application. Therefore, you cannot add any properties from the run-time object to the
description of the test object.
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Themain identification property of an Insight test object is its test object image. Additional
properties that can help create a unique description of the object are:

l "Ordinal Identifiers" (described on page 1209)

l "Visual Relation Identifiers" (described on page 1209)

l Similarity (see "Insight Test Object Descriptions" on page 1173)

This section also includes:

l "Specifying or Modifying Property Values" below

l "Modifying an Insight test object's image" below

l "Updating Identification Properties from anObject in Your Application" on the next page

l "Restoring Default Mandatory Properties for a Test Object" on the next page

l "Renaming Test Objects " on the next page

l "Adding Properties to a Test Object Description" on page 1208

l "Defining New Identification Properties" on page 1208

l "Ordinal Identifiers" on page 1209

Specifying or Modifying Property Values
You can specify or modify values for properties in the test object description. You can specify a
value using a constant value (either a simple value or a constant value that includes regular
expressions) or you can parameterize it. You can also change the set of properties used to identify
that object.

You can also automatically update the description of one or more test objects in your object
repository based on the actual updated object properties in your application. For details, see
"Updating Identification Properties from anObject in Your Application" on the next page.

You can also find and replace specific identification property values. For details, see "Find and
Replace Dialog Box (Object Repository)" on page 1245.

Note: In some cases, the Smart Identificationmechanismmay enable UFT to identify a test
object, even when some of its property values change. However, if you know about property
value changes for a specific test object, you should try to correct the test object definition so
that UFT can identify the test object from its basic object description. For details on the Smart
Identificationmechanism, see "Configuring Object Identification" on page 1310.

Modifying an Insight test object's image
An Insight test object's test object image is its main description property.
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You can update an Insight object's image in the object repository by retaking a snapshot of the
control in the application. Alternatively, you can use the snapshot previously stored with the test
object to adjust the borders of the image used to identify the control.

Updating Identification Properties from an Object in Your Application
You can update a test object in your object repository by selecting the corresponding object in your
application and relearning its properties and property values from the application. When you update
a test object description in this way, all currently defined properties and values are overwritten,
including description properties and values, the ordinal identifier, and Smart Identification
information. An Insight test object's image is not updated.

The updated object description is based on the current definitions in the "Object Identification
Dialog Box" (described on page 1325). Only the object-specific comments, if any, are retained.

This is useful if an object's properties have changed since you added it to the object repository,
since UFTmay not be able to recognize the object unless you update its description.

You can also use this option to update an object that you defined (using theObject > Define New
Test Object option) before the application was completely developed, and as a result some of the
identification properties and values aremissing in the test object description, or are no longer
sufficient to identify the object. For details on theDefine New Test Object option, see "Define
New Test Object Dialog Box" on page 1240.

Note: If you just want to restore the original test object description property set, while retaining
any property values you havemodified, you can use theRestore mandatory property set
option. For details, see "Restoring Default Mandatory Properties for a Test Object" below.

Restoring Default Mandatory Properties for a Test Object
You can restore the default properties for a selected test object. When you restore the default
properties, it restores themandatory property set defined for the selected object class, based on the
settings that were set in the "Object Identification Dialog Box" (described at 1325) at the time the
object was learned. If you added or removed properties to or from the description, those changes
are overwritten. However, if property values were defined or modified for any of themandatory
properties, those values are not modified when you choose this option. In addition, restoring the
default mandatory property set does not change the values for the ordinal identifier or Smart
Identification settings for the test object.

You can use theRestore mandatory property set option to restore the object description property
set to themandatory properties that were defined for that class when your object was learned. If the
mandatory properties in the "Object Identification Dialog Box" are currently different for this test
object class than they were when your object was learned, and you want to use the new definition,
you can use theUpdate From Application option, which relearns the object properties and values
based on the current definitions in the Object Identifications dialog box. For more details, see
"Updating Identification Properties from anObject in Your Application" above.

Renaming Test Objects
When an object changes in your application, or if you are not satisfied with the current name of a
test object for any reason, you can change the name that UFT assigns to the stored object. You can
also provide test objects with meaningful names to assist users in identifying them when using
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them in steps.

For example, suppose you have a graphics application in which all the tools in the toolbar are saved
as WinObjects in the object repository with the names ToolChild1, ToolChild2, ToolChild3, and so
forth. Youmay want to rename all the buttons to their actual labels to make them easier for you to
identify in the test, for example, Color_Picker, Eraser, Airbrush, and so forth.

Renaming a test object does not affect the way UFT recognizes the object in your application, as
the test object name is not included in the test object description.

If you are working with a shared object repository, your change applies to all occurrences of the test
object in all actions and components that use this shared object repository.

If you are working with a local object repository, your change applies to all occurrences of the test
object in the selected action or component. If other actions or components also include operations
on the local test object, you shouldmodify the test object's name in each relevant action or
component.

When youmodify the name of a test object in the local object repository, the name is automatically
updated for all occurrences of the test object in the action or component. When youmodify the
name of a test object in a shared repository, the name is automatically updated in all tests and
components open on the same computer that use the object repository as soon as youmake the
change, even if you have not yet saved the object repository with your changes. If you close the
object repository without saving your changes, the changes are rolled back in any open tests or
components that were open at the time. Changes that are saved are also automatically updated in
any other tests and components that use the object repository, as soon as you open them. To load
and view saved changes in an action, component, or object repository that is currently open on a
different computer, youmust open the object repository or lock it for editing on your computer.

Tip: If you do not want to automatically update test object names in the action or component
for all occurrences of the test object, you can clear theAutomatically update test and
component steps when you rename test objects check box in the General pane of the
Options dialog box (Tools > Options > GUI Testing tab > General node). If you clear this
option, you will need tomanually change the test object names in all steps in which they are
used, otherwise your run session will fail. For details, see "General Pane (Options Dialog
Box > GUI Testing Tab)" on page 536.

Note: If you rename test objects in a shared object repository and save the changes, when you
open another test or component using the same shared object repository, that test or
component updates the test object name in all of its relevant steps. This process may take a
few moments. If you save the changes to the second test or component, the renamed steps
are saved. However, if you close the second test or component without saving, then the next
time you open the same test or component, it will again take a few moments to update the test
object names in its steps.
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Adding Properties to a Test Object Description
You can add to the list of properties that UFT uses to identify an object. For each object class, UFT
has a default property set that it uses for the object description for a particular test object. You can
use the "Add Properties Dialog Box" (described on page 1231) to change the properties that are
included in the test object description.

Note: You can also add any valid identification property to a test object description, even if it
does not appear in the Add Properties dialog box. For details, see "New Property Dialog Box"
on page 1232.

Adding to the list of properties is useful when you want to create and run tests or components on an
object that changes dynamically. An object may change dynamically if it is frequently updated, or if
its property values are set using dynamic content (for example, from a database).

You can also change the properties that identify an object if you want to reference objects using
properties that UFT did not learn automatically when it learned the object. For example, suppose
you are testing aWeb site that contains an archive of newsletters. The archive page includes a
hypertext link to the current newsletter and additional hypertext links to all past newsletters.

The text in the first hypertext link on the page changes as the current newsletter changes, but it
always links to a page called current.html. Suppose you want to create a step in your test or
component in which you always click the first hypertext link in your archive page. Since the news is
always changing, the text in the hypertext link keeps changing. You need tomodify how UFT
identifies this hypertext link so that it can continue to find it.

The default properties for a Link object (hypertext link) are text andHTML tag. The text property is
the text inside the link. The HTML tag property is always A, which indicates a link.

You canmodify the default properties for a hypertext link for the learned object so that UFT can
identify it by its destination page, rather than by the text in the link. You can use the href property to
check the destination page instead of using the text property to check the link by the text in the link.

Note: You can alsomodify the set of properties that UFT learns when it learns objects from a
particular object class using the "Object Identification Dialog Box" (described on page 1325).
Such a change generally affects only those objects that UFT learns after youmake the
change. For details, see "Configuring Object Identification" on page 1310. You can also apply
the changes youmake in the Object Identification dialog box to the descriptions of all objects in
an existing test or component using theUpdate Run Mode option. For details, see "Update
Options Tab (Update Run Dialog Box)" on page 1107.

Defining New Identification Properties
You can add any valid identification property to a test object description, even if it does not appear
in the "Add Properties Dialog Box" (described on page 1231).

For example, suppose you want UFT to use a specific property to identify your object, but that
property is not listed in the Add Properties dialog box. You can open the Add Properties dialog box
and add that property to the list.
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Ordinal Identifiers
An ordinal identifier assigns a numerical value to a test object that indicates its order or location
relative to other objects with an otherwise identical description (objects that have the same values
for all properties). This ordered value provides a backupmechanism that enables UFT to create a
unique description to recognize an object when the defined properties are not sufficient to do so. For
details on ordinal identifiers, see "Ordinal Identifiers" on page 1312.

Note:When visual relation identifiers are used, theOrdinal identifier option is disabled in the
Object Repository Manager or window. For details on visual relation identifiers, see "Visual
Relation Identifiers" below.

Visual Relation Identifiers
Relevant for: GUI tests and components

When testing applications with multiple identical objects, UFT assigns an ordinal identifier to each
test object. This may lead to unreliable object identification. However, it may not (immediately)
result in a failed step. For details, see "Ordinal Identifiers" on page 1312.

To improve object identification, you can create a visual relation identifier, which is a set of
definitions that enable you to identify the object in the application according to the relative location
of its neighboring objects. You can select neighboring objects that will maintain the same relative
location to your object, even if the user interface design changes. This enables you to help UFT
identify similar objects much as a human tester would, and helps createmore stable object
repositories that can withstand predictable changes to the application's user interface.

You define visual relations in the "Visual Relation Identifier Dialog Box" (described on page 1251),
which is accessible from the local or shared object repository, or from the "Object Properties Dialog
Box" (described on page 1271).

How Visual Relation Identifiers Work
Suppose that someone shows you a photograph of identical twins sitting at different desks in a
classroom and asks you to remember the differences between them so that you can identify each
twin successfully when shown different photographs at a later time.

You are told that one differentiating characteristic is that one twin (twin A) always carries a blue
school bag, and that the other twin (twin B) always carries a red school bag. You are then told that
each twin has an assigned desk partner, whichmeans that even if the twins sit at different desks in
other photographs, they always sit next to their assigned partners.

One way to remember which twin is which is by identifying twin A in this manner: Always look for
the blue school bag and the twin's desk partner to locate twin A.

UFT uses visual relation identifiers in a similar manner. It compares the relative locations of the test
objects you defined in the visual relation identifier with themultiple identical objects.

How UFT Uses Visual Relation Identifiers

l During a run session, UFT first attempts to identify the test object using the object's description
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properties. For details, see "How UFT Identifies Objects During a Run Session" on page 1169.

l If UFT finds one or more objects matching the test object's description, it attempts to identify the
object using the visual relation identifier. For details, see "How to Define a Visual Relation
Identifier for a Specific Test Object - Use-Case Scenario" on page 1225.

l After the visual relation identifier is applied, if no objects or more than one object is found, the
visual relation identifier fails, and UFT continues to Smart Identification (when defined for that
test object class). For details, see "Smart Identification" on page 1316.

l After Smart Identification is applied, if no objects or more than one object is found, no ordinal
identifiers are used for that test object.

For general considerations on working with visual relation identifiers, see "Considerations for
Working with Visual Relation Identifiers" on page 1256.

For a workflow of the general object identification process, see "Object Identification Process
Workflow" on page 1188.
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Tasks

How to Add a Test Object to an Object Repository
Relevant for: GUI tests and components

This task describes how to add test objects to local or shared object repositories. This functionality
is available in the Object Repository window for the local object repository, and the Object
Repository Manager for shared object repositories.

This section includes:

l "Add test objects to the object repository using the AddObjects to Local or AddObjects option"
on the next page

l "Add an Insight test object to the object repository using the Add Insight Object or Add Insight
Object to Local button" on the next page

l "Add a test object to the local object repository while adding a step to your test or component" on
the next page

l "Define a new test object" on page 1213

l "Add a test object to the object repository using the Object Spy dialog box" on page 1213

l "Add a test object to the local object repository using the View/AddObject option from the Active
Screen (tests only)" on page 1213

l "Add a test object to the local object repository by inserting a step from the Active Screen (tests
only)" on page 1213

Note:

n You can add a test object to the local object repository only if that test object does not
already exist in a shared object repository that is associated with the action or component.
If a test object already exists in an associated shared object repository, you can add it to
the local object repository using theCopy to Local option. For details, see "Local Copies
of Objects from SharedObject Repositories " on page 1261.

n You cannot addWinMenu objects directly to an object repository using theAdd Objects
to Local button in the Object Repository window or theAdd Objects button in the Object
Repository Manager. If you want to add aWinMenu object to the object repository, you
can use theAdd Objects orAdd Objects to Local button to add its parent object and
then select to add the parent object together with its descendants, or you can record a step
on aWinMenu object and then delete the recorded step.
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Add test objects to the object repository using the Add Objects to Local or
Add Objects option

1. Perform one of the following:

n To add the test object to the local repository, making it available only in the current action or
component:

In the Object Repository window, Select Object > Add Objects to Local or click theAdd

Objects to Local toolbar button .

n To add the test object to a shared repository, making it available for multiple actions or
components:

In the Object Repository Manager, select Object > Add Objects or click theAdd Objects

toolbar button .

UFT and theObject Repository window or Object Repository Manager are hidden, and the
pointer changes into a pointing hand. In some environments, as youmove the pointing hand
over your application, the test objects are highlighted. For details on using the pointing hand,
see "Tips for Using the Pointing Hand" on page 1196.

2. Click the object you want to add to your object repository.

3. If the location you click is associated with more than one object, the "Object Selection Dialog
Box " (described on page 1195) opens. Select the object you want to add to the repository and
click OK.

If the object you select in the Object Selection dialog box is a bottom-level object in the test
object hierarchy, for example, aWebButton object, it is added directly to the object repository.

If the object you select in the Object Selection dialog box is a parent (container) object, such as
a browser or page in aWeb environment, or a dialog box in a standardWindows application,
the "Define Object Filter Dialog Box" (described on page 1242) box opens. The Define Object
Filter dialog box retains the settings that you defined in the previous add object session.

The new object's parent objects are also added, if they do not already exist in the object
repository. Local objects are shown in black in the object repository tree to indicate they are
editable; shared objects are shown in gray and can be edited only in the Object Repository
Manager.

Add an Insight test object to the object repository using the Add Insight
Object or Add Insight Object to Local button
For details, see "How to Add an Insight Object to the Object Repository" on page 1214.

Add a test object to the local object repository while adding a step to your
test or component
You can add a test object to the local object repository by choosing it from your application when
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you add or edit a step in your test or component.

You do this in the "Select Test Object Dialog Box" (described on page 958), which you can open
when selecting an item for a step in the Keyword View or from the StepGenerator.

Define a new test object

1. Select the object under which you want to define the new object, according to the correct
object hierarchy.

2. Click theDefine New Test Object button or select Object > Define New Test Object.
The "Define New Test Object Dialog Box" (described on page 1240) opens.

Add a test object to the object repository using the Object Spy dialog box

1. Click theObject Spy button from UFT or the Object Repository Manager.

2. Click theAdd Object button . Depending on from where you opened theObject Spy dialog
box, the object is added to the local or shared object repository. For details, see "Object Spy
Dialog Box " on page 1189.

Add a test object to the local object repository using the View/Add Object
option from the Active Screen (tests only)

1. If the Active Screen is not displayed, select View > Active Screen.

2. Select a step in your test whose Active Screen contains the object that you want to add to the
object repository.

3. In the Active Screen, right-click the object you want to add and select View/Add Object.

4. If the location you clicked is associated with more than one object, the "Object Selection
Dialog Box " on page 1195 opens. Select the object you want to add to the object repository,
and click OK to close the Object Selection dialog box.

5. The "Object Properties Dialog Box" (described on page 1271) opens and displays the default
identification properties for the object.

Add a test object to the local object repository by inserting a step from the
Active Screen (tests only)

1. If the Active Screen is not displayed, select View > Active Screen.

2. Select a step in your test whose Active Screen contains the object for which you want to add a
step.

3. In the Active Screen, right-click the object for which you want to add a step and select the type
of step you want to insert (checkpoint, output value, Step Generator, and so forth).
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4. If the location you clicked is associated with more than one object, the "Object Selection
Dialog Box " (described on page 1195) opens. Select the object for which you want to add a
step, and click OK.

The appropriate dialog box opens, enabling you to configure your preferences for the step you
want to insert.

5. Set your preferences and select whether to insert the step before or after the step currently
selected in the Keyword View or in the Editor. Click OK to close the dialog box. A new step is
inserted in your test, and the object is added to the local object repository for the current action
(if it was not yet included).

How to Add an Insight Object to the Object Repository
Relevant for: GUI tests and components

This task describes how to add an Insight object to the object repository. You can add the object
directly from the application, or even from a picture of the object displayed on your screen.

This task includes the following steps:

l "Select the Add Insight Object or Add Insight Object to Local command" below

l "Select the learningmode you want to use to add the Insight object - optional " below

l "In the application, select the control for which you want to add an Insight object" on page 1216

l "Results " on page 1216

1. Select the Add Insight Object or Add Insight Object to Local command
Perform one of the following:

n To add the test object to the local object repository, making it available only in the current
action or component:

Open theObject Repository window, select Object > Add Insight Object to Local or

click theAdd Insight Object to Local toolbar button .

n To add the test object to a shared object repository, making it available for multiple actions
and components:

Open theObject Repository Manager, select Object > Add Insight Object or click the

Add Insight Object toolbar button .

2. Select the learning mode you want to use to add the Insight object -
optional
n If the "Select LearnMode Dialog Box" (described on page 1248) opens, click the button for
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themode you want to use.

For details about the different modes, see "Adding Insight Test Objects" on page 1200.

n If you previously selectedDo not show me again on the Select LearnMode dialog box, it
does not open, and the learning session begins using themode you usedmost recently. (To
instruct UFT to display the Select LearnMode dialog box again, select Tools > Options >
GUI Testing tab > Insight node and then select Display Select Learn Mode dialog box.)

UFT and theObject Repository window or Object Repository Manager are hidden, and the
pointer changes according to the learningmode, enabling you to select the control on your
screen:

o Automatic mode. The pointer changes to a pointing hand.

o Manual mode. The pointer changes to a crosshair, with an adjacent circle displaying a
magnified image of the area around the center of the crosshair.

By holding the left CTRL, you can temporarily change the pointing hand or crosshair to a
standard pointer, enabling you to change the window focus or perform operations in UFT
or in your application.
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Formore details on using the pointing hand, see "Tips for Using the Pointing Hand" on
page 1196.

3. In the application, select the control for which you want to add an
Insight object
a. Depending on the learningmode you are using, do one of the following:

o Automatic mode. Click on the control.

o Manual Mode. Use the crosshair to draw a rectangle around the control.

UFT takes a snapshot of the control, automatically detecting the control's borders, or
using the borders that you draw, and the Add Insight Test Object dialog box (described on
page 1233) opens.

b. In the Add Insight Test Object dialog box, you can:

o Adjust the borders of the image saved with the test object in the object repository.

o Take a new snapshot to replace the image entirely.

o Specify areas to exclude from the test object image. UFT will ignore these areas when it
searches for the image on the screen to identify the object.

o Modify the test object's ClickPoint. This is the location to click in the control when
running a test object method on it.

c. Click Save (in the Change Test Object Image Dialog Box).

4. Results
An InsightObject, named InsightObject, is added to the object repository, under the test object
that represents the application or window that contains the control.

n If an object by this name already exists under the same parent, the new object is named
with an incremental suffix.

n If the parent object does not already exist in the object repository, the parent is also added to
the object repository.

In the object repository you can do any of the following, if relevant, to improve the readability
and efficiency of your test or component:

n Rename the test object to a name that describes the control it represents. (Recommended)

n Move the test object within the test object hierarchy: If you place it under another test
object, then UFT searches for the object in the application only within its parent test object.
If youmove the Insight test object to be a top-level object, then UFT searches for the object
anywhere on the screen.
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For details, see "How to Copy, Paste, Move, or Delete Objects in the Object Repository"
below.

n Add a similarity identification property to the test object description. For details about this
property, see the InsightObject Identification Properties section in theHP UFT Object
Model Reference for GUI Testing.

n Modify the ordinal identifier created for the test object. For details, see "Ordinal Identifiers"
on page 1312.

n Define visual relation identifiers for the test object. For details, see "Visual Relation
Identifiers" on page 1209.

Tips:

o Whenworking in the Editor, you can open the object repository by double-clicking an
InsightObject's image. The object repository opens with the InsightObject selected.
(If test object images are not displayed in the Editor, you can display them using the
relevant option in the Tools > Options > GUI Testing tab > Insight pane.)

o Whenworking in the object repository, you can use theHighlight in Application
option to see which controls UFT identifies using the current test object's
description.

When you have finishedmodifying all of the Insight test objects to your satisfaction in the
object repository, you can delete all of the snapshots to reduce the amount of disk space used
(in the Object Repository window or the Object Repository Manager, Tools > Delete Insight
Snapshots). This does not delete the test object images used for object identification.

How to Copy, Paste, Move, or Delete Objects in the
Object Repository

Relevant for: GUI tests and components

The following steps describe how to copy, paste, move, and delete objects in an object repository.
This functionality is available in the Object Repository window for objects in the local object
repository, and the Object Repository Manager for objects in shared object repositories:

l "Move an object to a different location within an object repository" on the next page

l "Copy an object to a different location within an object repository" on the next page

l "Move or copy an object without its child objects" on the next page

l "Cut, copy, and paste objects within an object repository" on the next page

l "Cut, copy, and paste objects between shared object repositories" on the next page

User Guide
Chapter 43: Managing Test Objects in Object Repositories

HP Unified Functional Testing (12.00) Page 1217 of 2274



l "Copy objects from one shared object repository to another" below

l "Move objects from one shared object repository to another" below

l "Delete an object from the object repository" on the next page

l "Add test objects from a local or shared object repository to your test or component " on the next
page

Move an object to a different location within an object repository
Drag the object up or down the tree and drop it at the required location. By default, when you drag an
object, any child objects are alsomoved with it.

Copy an object to a different location within an object repository
Press the CTRL key while dragging the object and drop it at the required location in the tree. By
default, when you drag an object, any child objects are alsomoved with it.

Move or copy an object without its child objects
Drag the object using the right mouse button. When you drop the object at the required location, you
can choose whether to drop it with or without its children. By default, when you drag an object, any
child objects are alsomoved or copied with it.

Cut, copy, and paste objects within an object repository

Use the corresponding toolbar buttons or the options in theEditmenu. When you cut,
copy, and paste objects, the operation is performed also on the child objects of the selected object,
if any.

Cut, copy, and paste objects between shared object repositories

In the Object Repository Manager, use the corresponding toolbar buttons or the
options in theEditmenu. When you cut, copy, and paste objects, the operation is performed also
on the child objects of the selected object, if any.

Copy objects from one shared object repository to another

1. In the Object Repository Manager, open the required shared object repositories and select
Window > Cascade. All open shared object repositories are displayed as separate windows.

2. Drag the object from one window and drop it at the required location in the other window.

Move objects from one shared object repository to another

1. In the Object Repository Manager, open the required shared object repositories and select
Window > Cascade.

2. Press the CTRL key while you drag the object from one window and drop it at the required
location in the other window. Note that moving an object removes it from one shared object
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repository and adds it to the other shared object repository.

You can also copy objects from a shared object repository to the local object repository to
modify them locally. For more details, see "Local Copies of Objects from SharedObject
Repositories " on page 1261.

Delete an object from the object repository

In the repository tree, select the object you want to delete and then click theDelete button .

Add test objects from a local or shared object repository to your test or
component
You can drag and drop test objects from a shared or local object repository to your test or
component. When you drag and drop a test object to your test or component, UFT inserts a step
with the default operation for that test object in your test or component.

For example, if you drag and drop a button object to your test or component, a step is added to your
test or component using the button object, with aClick operation (the default operation for a button
object).

Note: You cannot drag and drop checkpoint or output value objects from theObject Repository
Manager.

For details on adding objects to your test or component, see:

l "Toolbox PaneOverview" on page 506

l "Object Repository Window" on page 1274

How to Locate an Object in an Object Repository
Relevant for: GUI tests and components

The following steps describe how to locate a specific object in your object repository.

l "Find anObject in anObject Repository " below

l "Highlight an Object in Your Application" on the next page

l "Locate anObject from Your Application in the Object Repository" on the next page

Find an Object in an Object Repository

1. Make sure that the relevant object repository is open (in the Object Repository window or
Object Repository Manager).

2. Click the Find & Replace button . The "Find and Replace Dialog Box (Object Repository)
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" (described on page 1245) opens.

Highlight an Object in Your Application

1. Make sure your application is open to the correct window or page.

Tip: If you want to highlight an Insight test object located on the desktop (and not in an
application), make sure that UFT is not hiding part of the object.

2. Select the test object you want to highlight in your object repository.

3. Click theHighlight in Application button .

Locate an Object from Your Application in the Object Repository

1. Make sure your application is open to the correct window or page.

2. Click the Locate in Repository button .

UFT is hidden, and the pointer changes into a pointing hand. In some environments, as you
move the pointing hand over your application, the test objects are highlighted.

3. Use the pointing hand to click the required object in your application. For details on using the
pointing hand, see "Tips for Using the Pointing Hand" on page 1196.

l If the location you clicked is associated with more than one object, the "Object Selection Dialog
Box " (described on page 1195) opens. The selected object is highlighted in the object
repository.

Note:

n If the relevant object repository is not open or the object cannot be found, the object is not
highlighted.

n In the Object Repository Manager, if more than one shared object repository is open, and
UFT cannot locate the selected object in the active object repository, you can choose
whether to look for the object in all of the currently open object repositories.

n Locate in Repository is not supported for Insight test objects.

How to Maintain Test Objects in Object Repositories
Relevant for: GUI tests and components

The following steps describe different options for maintaining andmodifying the test object details
of objects in your repositories.
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l "Specify an identification property value" below

l "Modify an Insight test object's image" on the next page

l "Update identification properties from an object in your application" on the next page

l "Restore themandatory property set" on the next page

l "Rename test objects" on page 1223

l "Add properties to a test object description" on page 1223

l "Define a new identification property" on page 1223

l "Remove properties from a test object description" on page 1224

l "Specify an ordinal identifier" on page 1224

l "Define related objects for a specific test object" on page 1224

Specify an identification property value

1. In the Object Repository window or the Object Repository Manager, select the test object
whose property value you want to specify.

Tip:

n For a test object in the local object repository, you can also right-click the step
containing the test object and select Object Properties, and thenmake the following
property value changes in the "Object Properties Dialog Box" (described on page 1271).

n If you want to view all objects in the action or component, click theView in Repository
button. TheObject Repository window opens and displays all objects stored in the
repository in a repository tree.

n You can also open the object repository for the selected action or component by
choosing Tools > Object Repository Window or by clicking theObject Repository

toolbar button .

2. In the Test object details area, click in the value cell for the required property.

3. Specify the property value in one of the following ways:

n If you want to specify a constant value, enter it in the value cell.

n If you want to parameterize the value or specify a constant value using a regular expression,

click the parameterization button in the value cell . If you specify a constant value using a
regular expression, the icon is displayed next to the value.
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Formore details, see "How to Define Values for Your Step Arguments " on page 928.

If you specified a constant value, it is shown in theValue column of the Test object details
area. If you parameterized the value, the parameter name is shownwith one of the following
icons in theValue column. For details, see "Object Repository Window" on page 1274.

Modify an Insight test object's image

1. In the Object Repository window orManager, select the test object whose image you want to
modify.

Tip: From the Editor, you can open theObject Repository window with the Insight object
selected, by double-clicking the test object's image in a step. (If test object images are not
displayed in the Editor, you can display them using the relevant option in the Tools >
Options > s Testing tab > Insight pane.)

2. In the Test object image area, click theChange Test Object Image button. For details,
see "Change Test Object Image / Add Insight Test Object Dialog Box" on page 1233.

Update identification properties from an object in your application

1. In the object repository tree, select the test object whose description you want to update. (You
cannot use this process to update the test object image of an Insight test object.)

2. Select Object > Update from Application or click theUpdate from Application button .
UFT is hidden, and the pointer changes into a pointing hand. In some environments, as you
move the pointing hand over your application, the test objects are highlighted. For more details
on using the pointing hand, see "Tips for Using the Pointing Hand" on page 1196.

3. Find the object in your application whose properties you want to update in the object repository
and click it. Youmust choose an object of the same object class as the test object you
selected in the object repository tree.

The properties and property values for the selected object are updated in the object repository,
according to the properties and values required to identify the object that were learned by UFT
when you clicked the object in your application. Note that all properties and property values in
the Test object details area are updated, together with the ordinal identifier and Smart
Identification selections. Any object-specific comments that youmay have entered are not
removed.

Restore the mandatory property set

1. In the object repository tree, select the test object whose description you want to restore.

2. In the Test object details area, click theRestore mandatory property set button .

3. Click Yes to confirm the operation. The test object's description properties are restored to the
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mandatory property set for the selected object class at the time that the object was learned.

Rename test objects

1. In the object repository tree of the Object Repository window orManager, select the test object
that you want to rename.

2. In theName box in the Object Properties pane, enter the new name for the test object. Then
click anywhere else to remove the focus from the object. For a list of naming conventions, see
the Test object name section in "Troubleshooting - Naming Conventions" on page 2269. Test
object names are not case-sensitive.

Add properties to a test object description

1. In the object repository tree of the Object Repository window orManager, select the test object
whose description you want to modify.

2. In the Test object details area, click theAdd description properties button .

3. The "Add Properties Dialog Box" (described on page 1231) opens listing the properties that can
be used to identify the object (properties that are not already part of the test object description).

Tip: For a test object in the local object repository, you can also select the required test
object and select Edit > Step Properties > Object Properties, click theAdd

description properties button , and then perform the following steps in the Add
Properties dialog box.

Define a new identification property

1. In the object repository tree of the Object Repository window orManager, select the test object
for which you want to define a new property.

2. In the Test object details area, click theAdd description properties button . The "Add
Properties Dialog Box" (described on page 1231) opens.

Tip: For a test object in the local object repository, you can also select the required test
object, right-click on the object and select Object Properties, click theAdd description

properties button , and then perform the following steps in the Add Properties dialog
box.

3. Click theDefine new property button . The "New Property Dialog Box" (described on
page 1232) opens.
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Remove properties from a test object description

1. In the object repository tree of the Object Repository window orManager, select the test object
whose description you want to modify.

2. In the Test object details area, select one or more properties that you want to remove from the
test object description.

Tip: For an object in the local object repository, you can also select the required test
object, right-click and select Object Properties, and then perform the following steps in
the "Object Properties Dialog Box" (described on page 1271).

3. Click theRemove selected description properties button . The selected properties are
removed from the test object description.

Specify an ordinal identifier

1. In the object repository tree of the Object Repository window orManager, select the test object
whose ordinal identifier you want to specify.

2. In the Test object details area, click in the cell to the right of the Type, Value cell under the
Ordinal identifier row.

Tip: For an object in the local object repository, you can also select the required test
object, right-click and select Object Properties, click in the cell to the right of the Type,
Value cell under theOrdinal identifier row, and then perform the following steps in the
"Object Properties Dialog Box" (described on page 1271).

3. Click theBrowse button. The "Ordinal Identifier Dialog Box" (described on page 1247) opens.

Define related objects for a specific test object

1. In theVisual Relation Identifier Settings row of the Object Repository window or Object
Properties dialog box, click in theValue cell.

2. Click theBrowse button in the cell. The "Visual Relation Identifier Dialog Box" (described on
page 1251) opens.

3. Set the options for the visual relation identifier. For details, see "Visual Relation Identifier
Dialog Box" on page 1251.

Results:

l The visual relation identifier is added to the selected test object, and the text in theValue cell
indicates that a visual relation identifier is defined.

l Any related objects you specified are linked to the test object for which you are using a visual
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relation identifier. You cannot define visual relations for those objects.

l TheOrdinal identifier property is disabled in theObject Details area of the local or shared
object repository, and is not used during the object identification process. However, UFT still
uses this property during the learn process, when comparing existing objects with the objects to
be learned, and therefore the ordinal identifier value should not bemanually changed or removed.

For considerations on working with visual relation identifiers, see "Considerations forWorking with
Visual Relation Identifiers" on page 1256.

For a use-case scenario related to this task, see "How to Define a Visual Relation Identifier for a
Specific Test Object - Use-Case Scenario" below.

How to Define a Visual Relation Identifier for a Specific
Test Object - Use-Case Scenario

Relevant for: GUI tests and components

This scenario describes the process you would follow to define a visual relation identifier for a
specific test object that would otherwise require the use of ordinal identifiers.

Note: For a task related to this scenario, see "How toMaintain Test Objects in Object
Repositories" on page 1220.

This scenario includes the following steps:

l "Background" below

l "Access the Visual Relation Identifier dialog box" on the next page

l "Highlight the objects in the application that match the test object's description" on the next page

l "Define the first related test object using horizontal visual relations" on page 1227

l "Define the second related object using vertical visual relations" on page 1228

l "Define the third related object using distance visual relations" on page 1229

l "Results" on page 1230

1. Background
n The application you are testing contains three identical instances of theCandidate object.
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n WhenUFT learned the objects in the application, it assigned an ordinal identifier to each
Candidate test object.

n For the purpose of this exercise, Object #1 andObject #9make up an object pair, which is
always to the left and right of theCandidate object to identify. You want to instruct UFT to
identify the instance of theCandidate object that is located between theObject #1 and
Object #9 object pair during every run session, even if the sorting order of the object pairs
changes between run sessions.

2. Access the Visual Relation Identifier dialog box
a. In UFT, open the relevant object repository and select theCandidate test object to identify.

b. Verify that you have selected the correct test object by selectingView > Highlight in
Application, andmaking sure that the correct object is highlighted in the application.

c. Open the "Visual Relation Identifier Dialog Box" (described on page 1251).

3. Highlight the objects in the application that match the test object's
description
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In the Visual Relation Identifier dialog box, click thePreview button. This instructs UFT to
highlight all objects that match the test object description (ignoring the ordinal identifiers). The
main UFT window is hidden, and each instance of theCandidate object in the application is
highlighted, including the instance of the test object you want to identify.

You then click thePreview button again to restore the UFT window.

4. Define the first related test object using horizontal visual relations
a. In theRelated Objects area, click theAdd button. The "Select Test Object Dialog Box"

(described on page 958) opens, enabling you to either select a test object from the object
repository, or add an object from the application.

For the purpose of this scenario, the first related test object is Object #1, which is located
to the left of theCandidate object in the application.

b. In theRelation Details area, select the first checkbox and then select Left from the drop-
down list. The description area displays a summary of the visual relation identifier.
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c. To verify that the visual relation is defined correctly, click thePreview button again. The
main UFT window is hidden, and the visual relation identifier displays the objects that
match the test object's description, including the currently defined visual relation. It also
highlights the selected related object, and a visual representation of the defined relation
details. SinceObject #1 is to the left of all threeCandidate buttons, all three buttons are still
highlighted when you use thePreview button.

5. Define the second related object using vertical visual relations
a. In theRelated Objects area, click theAdd button. The "Select Test Object Dialog Box"

(described on page 958) opens, enabling you to select or add another object.

For the purpose of this scenario, the second related test object is Object #5, which is
located above and vertically in line with theCandidate object.

b. In theRelation Details area, select the second check box. From the drop-down list select
Above, and then select the In line (vertically) checkbox. The description area displays a
tooltip of all the selected visual relations.
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c. To verify that the visual relations are defined correctly, click thePreview button again.
SinceObject #5 is above all threeCandidate objects, all three are still highlighted. That
means you still need to select another related object to create a visual relation identifier that
uniquely identifies your object.

6. Define the third related object using distance visual relations
a. In theRelated Objects area, click theAdd button. The "Select Test Object Dialog Box"

(described on page 958) opens, enabling you to select another test object.

For the purpose of this scenario, the third related test object is Object #9, which is the
closest object to the right of theCandidate object.

b. In theRelation Details area, select the third checkbox and then select Closest on the Y-
axis from the drop-down list. The description area displays an updated summary of the
visual relation identifier.
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c. To verify that the visual relations are defined correctly, click thePreview button again. you
can now see that this third related object enables UFT to uniquely identify the correct
object.

7. Results
After you finish defining all of the necessary visual relations:

n The desiredCandidate object is the only object in the application that is identified when you
usePreview.

n UFT can now correctly identify the desiredCandidate object during every run session, even
if the user interface changes, as long as theCandidate object maintains it's relative location
to the three related objects you defined.

n TheOrdinal Identifier property is disabled in the Object Repository Manager or window.
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Reference

Add Properties Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to add properties to the test object description of test objects.

To access From the "Object Repository Manager MainWindow" (described on page 1297) or
"Object Repository Window" (described on page 1274), in the Test object details

area, click theAdd description properties button .

Important
information

l Values for all properties are displayed only if the application that contains the
object is currently open. If the application is closed, only values for properties
that were part of the object description when the object was learned are shown.

l You can resize the Add Properties dialog box to enable you to view long
property values.

l After you add a new property to the object description, you canmodify its
value. For details onmodifying object property values, see "Specifying or
Modifying Property Values" on page 1205.

Relevant
tasks

"How toMaintain Test Objects in Object Repositories" on page 1220

See also "Maintaining Identification Properties" on page 1204
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User interface elements are described below:

UI
Elements Description

Define new property. Opens the "New Property Dialog Box" (described on page
1232).

<Properties
list>

Select one or more properties to add to the test object description and click OK.
You can also double-click a property to add it to the test object description. You
can type the first letters of a property to highlight the first property in the list that
matches the pattern.

New Property Dialog Box

Relevant for: GUI tests and components

This dialog box enables you to define a new identification property for a test object.

To access Click theDefine new property button in the "Add Properties Dialog Box"
(described on page 1231).

Important
information

Youmust enter a valid identification property in the Property value edit box. If you
enter an invalid property and then select it to be part of the object description, your
run session will fail.

Relevant
tasks

"How toMaintain Test Objects in Object Repositories" on page 1220

User interface elements are described below:

UI Elements Description

Property name The property name.

Property value The value for the property.
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Change Test Object Image / Add Insight Test Object
Dialog Box

Relevant for: GUI tests and components

UFT uses the image stored with an Insight test object to identify the relevant control in the
application.

This dialog box enables you to:

l Adjust the borders of the image saved with the test object in the object repository.

l Take a new snapshot to replace the image entirely.

l Specify areas to exclude from the test object image. UFT will ignore these areas when it
searches for the image on the screen to identify the object.

l Modify the test object's ClickPoint. This is the location to click in the control when running a test
object method on it.

You can do this when editing an existing test object, or when adding a new one.

The image below shows the dialog box that opens when you click theChange Test Object Image
button in the Object Repository for an Insight test object that was added to the object repository
during a recording session.
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The dialog box options differ slightly when opened in other circumstances.
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To access Do one of the following:

To change the image for an existing test object:

1. Select an Insight test object in the Object Repository window or Object
Repository Manager.

2. In the Test object image area, click theChange Test Object Image
button.

To fine-tune the image during the process of adding a new test object:

Perform the first steps described in "How to Add an Insight Object to the Object
Repository" on page 1214.

This dialog box opens after you select the control in the application and a
snapshot of it is created (automatically or manually).

Important
Information

The insight mechanism is not sensitive to all differences in color, and does not
support text recognition. Therefore, define the borders of your test object image
around visually distinct borders, templates, shades, icons, or shapes. This is
particularly relevant when capturing images that contain sharp contrasts.

Relevant
tasks

l "How to Add an Insight Object to the Object Repository" on page 1214

l "How to Record a Test or Component Using Insight Recording" on page 860

See also l "Identifying Objects Using Insight" on page 1176

l "Select LearnMode Dialog Box" on page 1248

User Guide
Chapter 43: Managing Test Objects in Object Repositories

HP Unified Functional Testing (12.00) Page 1235 of 2274



User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<snapshot sequence> A series of images of the control, taken during a recording session.
The images are derived from snapshots taken of the entire
application.

l The highlighted image is the one stored with the test object.

l The sequencemay show additional images, taken shortly before
and/or after the stored one.

Note:

l When you select an image, the snapshot display below
displays the corresponding application snapshot. You can
then adjust the image stored with the test object by moving or
resizing the highlighted rectangle in the snapshot display.

l You can configure the size and number of snapshots to
include in the sequence (Select Tools > Options > GUI
Testing tab > Insight node).

l The snapshot sequence is available only when editing a test
object that was created during a recording session.

Next/Previous. Enable you to scroll through the images in the
snapshot sequence and select another image to use.

These buttons appear only when you havemore images in the
snapshot sequence than can fit in the dialog box.
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UI Elements Description

Take/Replace
Snapshot

Enables you tomanually take a snapshot of the control within the
application. (This replaces the snapshot associated with this button,
but not any snapshots in the snapshot sequence.)

When you click this button, UFT is minimized, and themouse pointer
changes to a crosshair, which you can use to draw a rectangle around
the control and take the snapshot.

To help you accurately draw the borders of the control, a magnified
view of themouse location on the screen is displayed in a circle near
the crosshair.

By holding the left CTRL, you can temporarily change the crosshair to
a standard pointer, enabling you to change the window focus or
perform operations in UFT or in your application.

Note:

l Available only when editing an existing test object.

l The button displays the image of the control, as defined by the
rectangle highlighted within the snapshot associated with the
button.

Exclude Areas toolbar Enables you to specify areas to exclude from the test object image or
clear all excluded areas.

l Select area to exclude/Select additional areas to exclude .
When you click this button, themouse pointer changes to a
crosshair, enabling you to draw a rectangle within the test object
image. This does not clear existing excluded areas.

To draw multiple areas to exclude, press and hold theCTRL key
while you draw.

l Clear All. Clears all excluded areas, so that the full test object
image is included.

To clear only one excluded area, hover over the area and press the
DELETE key or click theClear area button that pops up beside
the area.

Note: Make sure that the included area contains enough
significant content to enable object recognition.
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UI Elements Description

Bring the highlighted area into view. Scrolls the snapshot of the
application so that the highlighted rectangle is visible in the center of
the snapshot display.

Zoom Out / Zoom In slider. Enables you to zoom into the
application snapshot to view it at a larger size (up to 200%), and to
zoom back out, up to the original size of the snapshot.

l Zoom in to see the borders of the control more clearly and adjust
the image used for the control.

l Zoom back out to seemore of the context of the application in
which the control is located.

<snapshot display> Displays a snapshot of the application in which the control is located.

This area also contains:

l A highlighted rectangle. Defines the borders of the test object
image stored with in the object repository.

When you hover over this rectangle, it becomes editable and you
can drag or resize it to accurately represent the control.

If you resize this rectangle after selecting areas to exclude, then
any parts of excluded areas that are located outside the new
rectangle are cleared.

l A crosshair. Specifies the location to click in the control. If you
select Custom inSpecify the location to click in the control
below, you canmodify the location of the crosshair by dragging it,
or by editing its coordinates in theX andY boxes.

l Gray rectangles within the test object image (optional).
Excluded areas within the test object image that UFT ignores
when it searches for the image on the screen to identify the test
object.

When you hover over an excluded area, it becomes editable and
you can drag or resize it. If you press theDELETE key or click the
Clear area button that pops up beside the area, the rectangle is
removed, and the area is included in the test object image.

To specify additional excluded areas, or to clear all of the areas at
once, use theExclude Areas toolbar.
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UI Elements Description

Specify the location to
click in the control

The default location to click in the control when performing a test
object method on the control during a run session. (This is also
referred to as the object's ClickPoint.)

If necessary, you can specify a different location when running a
specific test object method by specifying coordinates in the relevant
step.

Possible values:

l Center. Click in the center of the control.

l Custom. Click the control at the specified location.
If you select this option, theX andY fields become available.

Example:Youmay want to specify aCustom location for
controls such as combo boxes, where clicking in the center
would enable the control for typing, and clicking on the side
opens the drop-down list.

Note: If you want the ClickPoint for Insight objects set toCenter
when they are added during a recording session, clear theSave
the clicked coordinates as the test object's ClickPoint option
in the Insight pane of the Options dialog box (Tools > Options >
GUI Testing > Insight). For details, see "Insight Pane (Options
Dialog Box > GUI Testing Tab)" on page 561.

For Insight objects added to the object repository using theAdd
Insight Object orAdd Insight Object to Local button, the
ClickPoint is initially set toCenter.
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UI Elements Description

X, Y The x or y coordinate of the location to click in the control. (Relative to
the top left corner of the highlighted triangle).

Note:

l Available when the location to click in the control is set to
Custom.

l You canmodify these values by typing in theX orY box or by
dragging the crosshairs displayed within the highlighted
rectangle.

l You can specify a location to click that it outside the borders
of the test object image. For example, the test object image
used to identify an edit box or drop down list might be the text
adjacent to the control, but you want the test object
operations (Type, Click) to be carried out on the control itself.

Define New Test Object Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to define test objects in your object repository that do not yet exist in
your application.

.
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To access From the "Object Repository Manager MainWindow" (described on page 1297) or
the "Object Repository Window" (described on page 1274), select Object >
Define New Test Object.

Important
information

l You cannot use this dialog box to define Insight test objects.

l When defining a new test object for windowless controls, youmust create a
new property named acc_name, and include it in the object description.

Note: The acc_name property is not available in the Object Identification
dialog box.

Relevant
tasks

"Adding and Deleting Test Objects in a Local or SharedObject Repository" on
page 1199

See also "Defining New Test Objects" on page 1201
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User interface elements are described below:

UI Elements Description

Environment The list of available environments. The test object classes associated with the
selected environment are displayed in theClass box.

Note:

l The environments included in theEnvironment list correspond to the
loaded add-ins. For details on loading add-ins, see the section on loading
UFT add-ins in theHP Unified Functional Testing Add-ins Guide.

l TheEnvironment list might also include additional environments for
which you or a third party developed support using UFTadd-in
extensibility add-in extensibility.

Class Select the class of the test object you want to define.

Name Enter a name for the new test object. After you enter a name, the Test object
details area is enabled.

Test object
details

Define the properties and values for your test object. The Test object details area
automatically contains themandatory properties defined for the object class in
the "Object Identification Dialog Box" (described on page 1325). You can add or
remove properties as required, and define values for the properties. For details,
see "Maintaining Identification Properties" on page 1204.

Define Object Filter Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to define which objects should be learned while using theNavigate
and Learn option. The object filter contains predefined settings that decide which objects should be
learned. The option you select in the Define Object Filter dialog box is saved and used for each
subsequent learn session.
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To
access

Do one of the following:

l In the Object Repository Manager window, select Object > Navigate and Learn.

l In the Object Repository window, add a test object to the object repository using
theAdd Objects to Local and selecting an object that contains child objects.

l In the Object Repository Manager, add a test object to the object repository using
theAdd Objects and selecting an object that contains child objects.

For details, see "Adding and Deleting Test Objects in a Local or SharedObject
Repository" on page 1199.

Relevant
tasks

"Adding and Deleting Test Objects in a Local or SharedObject Repository" on page
1199

User interface elements are described below:

UI Elements Description

Selected
object only
(no
descendants)

Adds to the object repository the previously selected object's properties and
values, without its descendant objects.

Default
object types

Adds to the object repository the previously selected object's properties and
values, with the properties and values of its descendant objects according to the
object types specified by the default filter. You can see which objects are in the
default filter by selectingSelected object types, clicking theSelect button, and
then clicking theDefault button.

All object
types

Adds to the object repository the previously selected object's properties and
values, together with the properties and values of all of its descendant objects.

Selected
object types

Adds to the object repository the previously selected object's properties and
values, as well as the properties and values of its descendant objects according
to the object types and classes you specify in the object filter. You specify the
objects and classes in the filter by clicking theSelect button and selecting the
required items in the "Select Object Types Dialog Box" (described on page
1244).
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Select Object Types Dialog Box

Relevant for: GUI tests and components

This dialog box enables you to specify a custom object filter for adding test objects to the object
repository (while using theNavigate and Learn option or theAdd Objects option).

To access Click theSelect button in the "Define Object Filter Dialog Box" (described on page
1242).
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Important
information

l When you define an object filter, it is automatically saved for future add object
operations (performed from both theNavigate and Learn option and theAdd
Objects option).

l The object types in this list are a generic grouping of objects according to the
general object characteristics. For example, the List type contains list and list
view objects, as well as combo boxes; the Table type contains both tables and
grids.

l The list shows all objects supported by the installed add-ins and is not specific
to the object you selected. For some add-ins, certain child objects may be
automatically filtered out and not added to the object repository when you
choose to add all descendants of a specific object, even if those object types
are selected in the list. If you want to add an object that is automatically filtered
out, you can add it by selecting it in the "Object Selection Dialog Box "
(described on page 1195). To check whether your add-in automatically filters
out certain objects, see theHP Unified Functional Testing Add-ins Guide.

Relevant
tasks

"Adding and Deleting Test Objects in a Local or SharedObject Repository" on
page 1199

See also "Adding Test Objects to the Local Object Repository from the Active Screen (GUI
actions and scripted components only)" on page 1200

User interface elements are described below:

UI
Elements Description

Default Restores the check box selections to their preset defaults. The preset defaults are
equivalent to choosing theDefault object types option in the "Define Object Filter
Dialog Box" on page 1242

Select
All

Selects all the check boxes.

Clear All Clears all the check boxes.

Find and Replace Dialog Box (Object Repository)
Relevant for: GUI tests and components

This dialog box enables you to find an object, property, or property value in the object repository.
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To access
Click the Find & Replace button  in the "Object Repository Manager Main
Window" on page 1297.

Important
information

l The functionality in this dialog box is available in the Object Repository window
for the local object repository, and the Object Repository Manager for shared
object repositories.

l You can search using any or all of the criteria in the Find and Replace dialog
box.

l The Find and Replace dialog box can find checkpoint and output values only by
searching for the object name.

l You cannot use the Find and Replace dialog box to replace property or object
names. You cannot replace property values in a read-only test or component.

Relevant
tasks

"How to Locate anObject in anObject Repository" on page 1219

See also "Locating Objects" on page 1202
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User interface elements are described below:

UI
Elements Description

Object
name

The name or partial name of the object you want to find.

Object
type

The type of object you want to find, for example, Button.

The object types in this list are a generic grouping of objects according to the general
object characteristics. For example, the List type contains list and list view objects,
as well as combo boxes; the Table type contains both tables and grids.

Object
class

The class of object you want to find, for example,WebButton. The classes available
depend on the selection youmade in theObject type box.

Property
name

The name or partial name of the property you want to find.

Property
value

The property value or partial property value you want to find.

New
property
value

The new property value if you specified a property value and want to replace it with a
different value.

Options l Match case. Select this option if you want the search to distinguish between
upper and lower case letters.

l Match whole word. Select this option if you want the search to find only
complete words that exactly match the single word you entered.

l Direction. The direction you want to search.

Ordinal Identifier Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to define an ordinal identifier for a test object.
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To
access

1. From the "Object Repository Manager MainWindow" (described on page 1297)
or "Object Repository Window" (described on page 1274), in the Test object
details area, click in theValue column of the Type, Value row in theOrdinal
identifier section.

2. Click theBrowse button in that cell.

Relevant
tasks

"How toMaintain Test Objects in Object Repositories" on page 1220

See also "Maintaining Identification Properties" on page 1204

User interface elements are described below:

UI
Elements Description

Identifier
type

l Index. The order in which the object appears within the parent window, frame, or
dialog box relative to other objects with an otherwise identical description.

l Creation Time. (Browser objects only). The order in which the browser was
opened relative to other open browsers with an otherwise identical description.
This identifier type is only available if more than one Browser object was open
when the test object was learned.

l None. Does not specify an ordinal identifier. This is the default value if UFT did
not learn an ordinal identifier.

Identifier
value

The numeric value of the ordinal identifier.

Select Learn Mode Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to specify which learningmode to use when adding an Insight test
object to the object repository.

l When using the automatic mode, you click on the control in the application and UFT
automatically determines the borders of the control.

l When using themanual mode, you draw a rectangle around the control in the application,
specifying the borders of the control.

In both cases, UFT takes a snapshot of the control within the application and the Add Insight Test
Object dialog box (described on page 1233) opens, enabling you to adjust the image that will be
saved with the new test object.

.
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To
access

Do one of the following:

l In the "Object Repository Window" (described on page 1274), click Add Insight

Object to Local

l In the "Object Repository Manager MainWindow" (described on page 1297), click

Add Insight Object

Note: To display the Select LearnMode dialog box if it does not open when you
click these buttons, select Tools > Options > GUITesting tab > Insight node
and then select Display Select Learn Mode dialog box.

Relevant
tasks

"How to Add an Insight Object to the Object Repository" on page 1214

See also l "Adding Insight Test Objects" on page 1200.

l "Change Test Object Image / Add Insight Test Object Dialog Box" on page 1233

User interface elements are described below:

UI
Elements Description

Automatic Hides UFT and theObject Repository window or Object Repository Manager, and
changes the pointer into a pointing hand, enabling you to click on the control that
you want to learn in the application.

User Guide
Chapter 43: Managing Test Objects in Object Repositories

HP Unified Functional Testing (12.00) Page 1249 of 2274



UI
Elements Description

Manual Hides UFT and theObject Repository window or Object Repository Manager, and
changes the pointer into a crosshair that you can use to draw a rectangle around the
control that you want to learn in the application.

To help you accurately draw the borders of the control, a magnified view of the
mouse location on the screen is displayed in a circle near the crosshair.

Do not
show me
again

Instructs UFT not to display this dialog box in the future, when adding Insight
objects to an object repository, but to use the learningmode that you select this
time.

To display the Select LearnMode dialog box again:

Select Tools > Options > GUI Testing tab > Insight node and then select
Display Select Learn Mode dialog box.
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Visual Relation Identifier Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to define related objects for the visual relation identifier of a specific
test object. UFT uses this identifier in addition to the test object description during the run session
to identify the test object.

To access 1. Open the "Object Properties Dialog Box" (described on page 1271) for the
test object you want to identify, or select it in the Object Repository window.

2. In theVisual Relation Identifier Settings row of the Object Repository
window or Object Properties dialog box, click in theValue cell.

3. Click theBrowse button in the text box.

Important
information

"Considerations forWorking with Visual Relation Identifiers" on page 1256

Relevant
tasks

l "How toMaintain Test Objects in Object Repositories" on page 1220

l "How to Define a Visual Relation Identifier for a Specific Test Object - Use-
Case Scenario" on page 1225
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See also l "Visual Relation Identifiers" on page 1209

l "How UFT Identifies Objects During a Run Session" on page 1169

l "How UFT Interprets Horizontal and Vertical Visual Relations" on page 1255

User Interface Elements
User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Test object
to identify

The name of the test object as it appears in the object repository (read-only).

Add. Opens the "Select Test Object Dialog Box" (described on page 958), which
enables you to add a test object to theRelated Objects list, either from the
object repository or directly from the application. Any object you add from the
application is automatically added to the object repository.

Remove. Removes the selected related object from theRelated Objects list.

Note: Removing the related object from the list does not remove the test
object remains from the object repository.
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UI Elements Description

Preview Highlights the visual relation between all related objects and the objects
matching the test object to identify (main UFT window is hidden). While in
Preview mode, the text to the right of the button displays the number of matching
objects. This enables you to test the relation details you are defining without
closing the dialog box or running the steps.

Note:

l During the Preview process, themain UFT window is hidden. Click the
Preview button again to restore the UFT window.

l While thePreview button is pressed, you can change the relation details
and preview the changes without returning to the UFT window.

l If UFT is unable to perform the Preview operation, amessage box opens.
This could be the result of one of the following scenarios:

n One ormore related objects cannot be found in the object repository.

n One ormore related objects are already used in a visual relation
identifier for another test object.

n One ormore related objects cannot be uniquely identified in the object
repository.

Related
Objects

The list of related objects.

Tooltip. The tooltip for each related object displays the full name.

Note: If the related object cannot be found in the object repository, an
indicating icon is displayed next to the name of that related object, and a
tooltip is displayed when you hover the cursor over the icon.

Relation
Details

The details of the visual relation for the selected related object. You can select a
value from one or more of the relation categories.

For details on the available visual relation categories, see "Visual Relation
Categories (Relation Details Area)" on the next page.

<Relation
description>

Textual description of the currently defined visual relations.
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Visual Relation Categories (Relation Details Area)

Category Description

Horizontal Enables you to define related objects according to their horizontal location relative
to the object to identify. The following options are available:

l Left

l Right

l In line (horizontally)

For details on this option, see "How UFT Interprets Horizontal and Vertical Visual
Relations" on the next page.

Vertical Enables you to define related objects according to their vertical location relative to
the object to identify. The following options are available:

l Above

l Below

l In line (vertically)

For details on this option, see "How UFT Interprets Horizontal and Vertical Visual
Relations" on the next page.

Distance
and
hierarchy

Enables you to define related objects according to their distance or hierarchical
location relative to the object to identify. The following options are available:

l Closest on the X-axis

l Closest on the Y-axis

l Closest on both axes

l Contains
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How UFT Interprets Horizontal and Vertical Visual Relations

Relevant for: GUI tests and components

The following diagram illustrates the way UFT interprets horizontal and vertical visual relations. It
also shows the boundaries that are used for determining in line related objects.

How UFT Identifies In Line Related Objects
When you select a related object as a horizontal and/or vertical relation in the Visual Relation
Identifier dialog box, you can also fine-tune that definition by indicating that it is in line with the test
object to identify.

UFT identifies the related object as in line even if the area of the related object surface is only
partially in line with the test object.
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The following example illustrates how UFT identifies related objects that are in line with the test
object to identify.

Considerations for Working with Visual Relation Identifiers

Relevant for: GUI tests and components

Consider the following when working with visual relation identifiers:

l If you define a visual relation identifier for a test object, then that test object's ordinal identifier (if
it exists) is not used during the test object identification process (when running steps,
highlighting objects in the application, etc.). To indicate this, theOrdinal identifier option for
that test object is disabled in the Object Repository window.

l If you add a related object that was not previously in the object repository, then the test object for
the related object is added to that object repository, even if you click Cancel in the Visual
Relation Identifier dialog box.

Workaround: If you do not need that test object, manually delete it from the object repository.

l If you delete a test object (A) that is used in the visual relation identifier for another test object
(B), youmust make sure to remove the deleted test object A from theRelated Object list for
test object B.

l Visual relation identifiers are used only during a run session, or when identifying objects in the
application (for example, from theObject Repository window or the Object Spy). Therefore, even
if you define related objects for a specific test object, if UFT re-learns the object, it uses only the
identification properties that are defined in the "Object Identification Dialog Box" (described on
page 1325) for that test object class, as well as an ordinal identifier (if needed). This may cause
UFT to learn the same object more than once.

Example: If you learned theObject1 test object with an ordinal identifier property value of 1,
and then youmanually remove the ordinal identifier or otherwise significantly modify the
description properties (because you are depending on the visual relation identifiers to fine
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tune the description), then the next time a learn session includes this object, UFT will not
recognizeObject1 as the same object and will learn a new test object with the name
Object1_1.

l UFT uses visual relation identifiers only when one or more objects match the test object's
description properties during the identification process. If no objects in the applicationmatch the
test object's description properties, then the visual relation identifier you defined is ignored, and
UFT continues to Smart Identification (if defined for that test object class).

For details on the complete flow that UFT uses to identify objects, see "Object Identification
Process Workflow" on page 1188.

l A test object cannot be used as a related object to itself.

l The following test objects cannot act as related objects for another test object's visual relation
identifier:

n A test object that has a visual relation identifier.

n A child test object for one of its parent objects.

l You can retrieve or replace the visual relation identifier settings of a specific test object during a
run session using theVisualRelationsCollection object. For details, see the
VisualRelationsCollection object in theHP UFT Object Model Reference for GUI Testing.
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Troubleshooting and Limitations - Managing Test
Objects

Relevant for: GUI tests and components

For troubleshooting and limitations for learning objects, see "Learning objects, running steps, and
recording steps (GUI testing only)" on page 661.
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Chapter 44: Working with Object Repositories
Relevant for: GUI tests and components

This chapter includes:

Concepts 1260

Object Repository Window - Overview 1260

Exporting Local Objects to a SharedObject Repository 1260

Local Copies of Objects from SharedObject Repositories 1261

Repository Parameter ValueMappings 1262

Working with Test Objects During a Run Session 1263

Tasks 1264

How to Export Local Objects to a SharedObject Repository 1264

How to Copy anObject to the Local Object Repository 1265

How toModify Identification Properties During a Run Session 1265

Reference 1266

Associate Repositories Dialog Box 1266

MapRepository Parameters Dialog Box 1268

Object Properties Dialog Box 1271

Object Repository Window 1274

Troubleshooting and Limitations - Object Repositories 1284
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Concepts

Object Repository Window - Overview
Relevant for: GUI tests and components

TheObject Repository window displays a tree of all test objects, and all checkpoint and output
objects in the current action or component, including all local objects and all objects in associated
shared object repositories.

For each object you select in the tree, the Object Repository window displays information on the
object, including its type, the repository in which it is stored, and its object details. Local objects are
editable (black); shared objects are read-only (gray).

You can continue using UFT while the Object Repository window is open, includingmodifying
objects and object repositories. TheObject Repository window reflects changes youmake to it in
real time. For example, if you add objects to the local object repository, or if you associate an
additional object repository with the current action or component, the Object Repository window
immediately displays the updated content.

Note: Youmodify objects in a shared object repository using the Object Repository Manager.
For details, see "SharedObject Repositories" on page 1285.

You can alsomodify an object in a shared object repository by copying it to the local object
repository and thenmodifying the local copy. For details, see "Local Copies of Objects from
SharedObject Repositories " on the next page.

Exporting Local Objects to a Shared Object Repository
Relevant for: GUI tests and components

You can export all of the test objects, checkpoint objects, and output value objects contained in an
action's or component's local object repository to a shared object repository in the file system, or to
an ALM project (if UFT is connected to ALM). This enables you tomake the local objects
accessible to other actions or components.

When you export local objects to a shared object repository, the parameters of any parameterized
objects are converted to repository parameters, using the same name as the source parameter. The
default (mapped) value of each repository parameter is the corresponding source parameter. You
canmodify themapping used within your action or component using the "MapRepository
Parameters Dialog Box" (described on page 1268). For details on repository parameters, see
"Working with Repository Parameters" on page 1287.

Tip: After you export the local objects, you can use theObject Repository Merge Tool to merge
the test objects from the shared object repository containing the exported objects with another
shared object repository. For details, see "Object Repository Merge Tool" on page 1351.
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For actions:You can choose to export only the local objects to a shared object repository, or to
export and replace the local objects. TheExport and Replace Local Objects option exports the
local objects to a shared object repository, associates the new shared object repository with your
action, and then deletes the objects in the local object repository.

For components: TheExport and Replace Local Objects option (File > Export and Replace
Local Objects) is not available.

Local Copies of Objects from Shared Object Repositories

Note: Available from theObject Repository window only.

Relevant for: GUI tests and components

You can create a local copy of any object stored in a shared object repository that is associated
with the action or component currently displayed in the in the object repository tree.

Copying an object to the local repository is useful, for example, if you want to modify an object in
the current action or component, without affecting other actions or components that use the shared
object repository.

When you create a local copy of an object andmodify it in the Object Repository window, the
changes youmake affect only the action or component in which youmake the change. Conversely,
if youmodify the object in the shared object repository using the Object Repository Manager, the
changes youmake are reflected in all actions or components that use the shared object repository.
However, if youmodify an object in a shared object repository, and a copy of the object (with the
same name) exists in the local repository, your changes do not affect the local copy of the object in
your action or component.

During a run session, UFT uses the test object in the local object repository to identify the object in
your application. This is because the local object repository has higher priority than any shared
object repository associated with the action or component.

Considerations for Copying an Object to the Local Object Repository

l When you copy an object to the local object repository, its parent objects are also copied to the
local object repository.

l You cannot copy an object to the local object repository if an object or its parent objects use
unmapped repository parameters. Youmust make sure that all repository parameters are
mapped before copying an object to the local object repository.

l If an object or its parent objects are parameterized using one or more repository parameters, the
repository parameter values are converted when you copy the object to the local object
repository. If the value is a constant value, the property receives the same constant value.

l If you are copyingmultiple objects to the local object repository, during the copy process you
can choose to skip a specific object if it has unmapped repository parameters, or if it has
mapped repository parameters whose values you do not want to convert. You can then continue
copying the next object from your original selection.
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Repository Parameter Value Mappings
Relevant for: GUI tests and components

You use repository parameters to specify that certain property values of an object in a shared
object repository should be parameterized, but that the actual values should be defined in each
action or component associated with the shared object repository. For details on repository
parameters, see "Working with Repository Parameters" on page 1287.

Mapping a repository parameter to a value or to a parameter specifies the property values used to
identify the test object during a run session. You can specify that the property value is taken from a
constant value, or parameterize it using any of the following:

l For tests:

n Data table

n random number

n environment

n test

l For components:

n local parameter

n component parameter

You canmap each repository parameter as required in each test or component that has an
associated object repository containing repository parameters. For example, youmay want to
retrieve the username object's text property value from an environment variable parameter for one
test or component, and from a constant value, Data pane parameter, or local parameter for another.

Before youmap repository parameters, if you havemore than one repository parameter with the
same name in different shared object repositories that are associated with the same action or
component, the repository parameter from the shared object repository with the highest priority (as
defined in the shared object repositories list) is used.

After youmap repository parameters, UFT uses themappings you defined. In addition, changing
the priority or default values has no effect after the parameters aremapped.

When you open a test or component that uses an object repository with an object property value
that is parameterized using a repository parameter with no default value, the Errors pane indicates
that there is a repository parameter that needs mapping. You can thenmap the repository parameter
as needed in the test or component. You can alsomap repository parameters that have default
values, and changemappings for repository parameters that are already mapped.

If you do not map a repository parameter, the default value that was defined with the parameter, if
any, is used during the run session. If the parameter is unmapped, meaning no default value was
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specified for it, the test or component runmay fail if a test object cannot be identified because it has
an unmapped parameter value.

Working with Test Objects During a Run Session
Relevant for: GUI tests and components

The first time UFT encounters an object during a run session, it creates a temporary version of the
test object for that run session. UFT uses the object description to create this temporary version of
the object. For the remainder of the run session, UFT refers to the temporary version of the test
object rather than to the test object in the object repository. TheObject Repository window is read-
only during a run session.

Creating Test Objects During a Run Session

You can use programmatic descriptions to create temporary versions of test objects that represent
objects from your application. You can perform operations on those objects without referring to the
object repository. For example, suppose an edit box was added to a form on yourWeb site. You can
use a programmatic description to add a statement in a user-defined function or in the Editor
(actions only) that enters a value in the new edit box. UFT could then identify the object even
though the object was never added to the object repository. For details on programmatic
descriptions, see "Programmatic Descriptions" on page 995.
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Tasks

How to Export Local Objects to a Shared Object
Repository

Relevant for: GUI tests and components

This task describes how to export local objects to a shared object repository.

This task includes the following steps:

l "Prerequisites " below

l "Select an action (actions only)" below

l "Export the local objects" below

l "Results" below

1. Prerequisites
a. Open the test or component that has the local objects you want to export.

b. Open theObject Repository window by selectingResources > Object Repository or

clicking theObject Repository button .

2. Select an action (actions only)
In the Object Repository window, in theAction box, choose the action whose local objects
you want to export.

3. Export the local objects
Select File > Export Local Objects, or, for actions only, File > Export and Replace Local
Objects. The Save SharedObject Repository window opens. For details, see "Save
<Resource>/Save <Document> As Dialog Box" on page 164.

4. Results
If you choseExport Local Objects, the local objects are exported to the specified shared
object repository (a file with a .tsr extension). Your test or component continues to use the
objects in the local object repository, and the new shared object repository is not associated
with your test.

You can now use the new shared object repository like any other shared object repository.

For actions: If you choseExport and Replace Local Objects, the new shared object
repository (a file with a .tsr extension) is associated with your test, and the objects in the local
object repository are deleted. The objects in the Object Repository window are read-only, as
they are now in a shared object repository. In the Object Properties section of the Object
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Repository window, the repository location indicates the path and filename of the new shared
object repository instead of Local.

How to Copy an Object to the Local Object Repository
Relevant for: GUI tests and components

This task describes how to copy an object from a shared object repository to the local object
repository.

1. Open the test or component that contain the local object repository to which you want to copy
the object.

2. Open theObject Repository window by selectingResources > Object Repository or clicking

theObject Repository button .

3. In the object repository tree of the Object Repository window, select the action or component
associated with the shared object repository containing the object you want to copy.

4. Select the object that you want to copy to the local object repository. (Objects in a shared
object repository are read-only.) You can select multiple objects as long as the selected
objects have the same parent object.

5. Select Object > Copy to Local or right-click the objects and select Copy to Local. The
objects (and parent objects, if any) are copied to the local object repository and aremade
editable.

How to Modify Identification Properties During a Run
Session

Relevant for: GUI tests and components

You canmodify the properties of the temporary version of the object during the run session without
affecting the permanent values in the object repository. To do this, add aSetTOProperty statement
in a user-defined function, or in your action.

Use the following syntax for theSetTOPropertymethod:

Object(description).SetTOPropertyProperty, Value

For details, see theHP UFT Object Model Reference for GUI Testing.

User Guide
Chapter 44: Working with Object Repositories

HP Unified Functional Testing (12.00) Page 1265 of 2274



Reference

Associate Repositories Dialog Box
Relevant for: GUI tests only

This dialog box enables you to associate one or more shared object repositories with one or more
actions in a test. You can view the shared object repositories associated to each of the actions in
the current test, and remove object repository associations from selected actions, or from all
actions in the test.
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To access 1. Open the test to which you want to associate your object repositories.

2. Do one of the following:

n In the UFTmain window, select Resources > Associate Repositories.

n In the Object Repository window, select Tools > Associate
Repositories.

n In the Object Repository window, click theAssociate Repositories

button .

Important
information

l You prioritize the object repositories using the Associated Repositories tab of
the Action Properties dialog box (and not the Associate Repositories dialog
box). For details, see "Associated Repositories Tab (Action Properties Dialog
Box)" on page 906.

l You can associate, remove, prioritize, and view the properties of shared object
repositories in the Solution Explorer. For details, see "Solution Explorer Pane
User Interface" on page 478.

User interface elements are described below:

UI Elements Description

Add Repository. Enables you to browse and add shared repositories to be
associated with actions. The new object repository is displayed at the bottom of
the Repositories list.

Remove Repository. Enables you to remove shared repositories and their
associations from your test.

<Add Action>.Moves the selected action in theAvailable Actions list to the
Associated Actions list. You can also double-click the action name tomove it
to theAssociated Actions list.

Add All Actions.Moves all the actions in theAvailable Actions list to the
Associated Actions list. You can also use the Shift and/or Control keys to
select multiple actions.

Remove Action.Moves the selected action in theAssociated Actions list to
theAvailable Actions list. You can also double-click the action name tomove it
to theAvailable Actions list.

Remove All Actions.Moves all the actions in theAssociated Actions list to
theAvailable Actions list. You can also use the Shift and/or Control keys to
select multiple actions.
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UI Elements Description

Repositories The list of available shared repositories.

Tip: You canmodify the name or path of an associated shared object
repository without changing the current associations, as follows:

l Click a shared object repository and then browse to select a different shared
object repository.

l Click the shared object repository andmodify the name or path directly.

Available
Actions

The list of actions to associate to the selected shared repository.

Associated
Actions

The list of actions currently associated with the selected shared repository.

Map Repository Parameters Dialog Box
Relevant for: GUI tests and components

This dialog box enables you tomap values for the repository parameters that are used in shared
object repositories that are associated with your action or component. This enables you to specify
the property values used to identify the test object during a run session.
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To
access

1. Open the test or component for which you want to map repository parameters.

2. Use one of the following:

n Select Resources > Map Repository Parameters

n In the Errors pane, double-click theRepository Parameters row (Relevant only
if your test or component contains unmapped repository parameters (repository
parameters without a default value)).

See
also

"Repository Parameter ValueMappings" on page 1262
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User interface elements are described below:

UI
Elements Description

Map
parameters
for

Enables you to filter the list of parameters that is displayed. You can choose to
display:

l All unmapped parameters. Displays all of the parameters in your test that
are not mapped to values.

l Entire test. (Tests only) Displays all of the parameters in your test (with
mapped or unmapped values).

l <Action name> or <Component name>. (For example, LogIn) Displays all
of the parameters in the specified action or component (with mapped or
unmapped values).

Name The name of the repository parameter.

Value The parameter's current value, if any. This column shows either the new value
you defined, or the default value that was defined when the parameter was
created. If no default value was defined, then the parameter is currently
unmapped, and the text {No default value} is shown.

You can:

l Enter a new constant value or modify an existing constant value by typing
directly in theValue cell.

Tip: You can also enter a constant value in the "Value Configuration
Options Dialog Box" (described on page 1579) by clicking the

parameterization button .

l Parameterize the value by clicking in theValue cell of the relevant parameter

and then clicking the parameterization button .

You can parameterize the value for actions, using the Data pane (Global sheet
only), random number, environment, or test parameter.

You can parameterize the value for components, using a local or component
parameter.

For details, see "Value Configuration Options Dialog Box" on page 1579.

l Reset a parameter to its default value by clicking in theValue cell of the
relevant parameter and then clicking theReset to Default Value button .
The default value, if any, that was defined in the "Add Repository Parameter
Dialog Box" (described on page 1308) is displayed in the cell.
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UI
Elements Description

Description A textual description of the parameter, if any.

Find in
Repository

Opens theObject Repository window and highlights the first test object in the
object repository tree that uses the selected repository parameter. You can click
this button again to find the next occurrence of the selected parameter, and so
forth.

Object Properties Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to:

l View identification properties and values for objects in your test or component steps, or in the
Active Screen (for actions), as well as other object details.

l Modify the properties and property values used to identify the object (for objects that are stored
in the local object repository). Youmodify the properties and values in the Object Properties
Dialog Box in the sameway as youmodify the test object details in the "Object Repository
Window" (described on page 1274). For details, see "Maintaining Identification Properties" on
page 1204.

Note:

n For Insight objects, you can view properties such as the ordinal identifier and visual
relation identifiers, but not the test object image. To view andmodify the test object
image, click View in Repository to open the Insight test object in the Object Repository
window.

n This dialog box is not available for Insight objects in the Active Screen.

There are slight differences in the Object Properties dialog box, depending on whether the selected
object is currently stored in the local object repository or in an associated shared object repository.
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This section describes options shown in the dialog box for objects in the local object repository. For
objects stored in a shared object repository the information is in read-only format.

To
access

1. Ensure that a GUI action or component is in focus in the document pane.

2. Do use one of the following:

For actions:

n In the action, right-click in the step of the object whose properties you want to
view and chooseObject Properties.

n In the Active Screen, right-click the object whose properties you want to view
and chooseView / Add Object.

For components: In the component, right-click the step of the object whose
properties you want to view and chooseObject Properties.

User interface elements are described below:

UI
Elements Description

Add description properties button.

Remove selected description properties button.
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UI
Elements Description

Name The name that UFT assigns to the object. You can change the name of a object in
the local object repository. For details, see "Renaming Test Objects " on page
1206.

Class The class of the object.

Description
properties

The properties and property values used to identify the object during a run
session.

Tip:

l For details on adding properties to or removing properties from the test
object description, see "Add Properties Dialog Box" on page 1231.

l For details on specifying a property value as a constant or parameterizing
a value, see "Specifying or Modifying Property Values" on page 1205.

Visual
relation
identifier

A set of definitions that enable you to identify the object in the application
according to its neighboring objects in the application. When this option is defined
and enabled, the Ordinal identifier option is disabled. For details, see "Visual
Relation Identifier Dialog Box" on page 1251.

Note: If one or more related objects cannot be found in the object repository,
indicating text is displayed in the cell.

Ordinal
identifier

A numerical value that indicates the object's order or location relative to other
objects with an otherwise identical description (objects that have the same values
for all properties). For details, see "Ordinal Identifier Dialog Box" on page 1247.

Note: If a visual relation identifier is defined for a specific test object, this
option is disabled. For details, see "Considerations forWorking with Visual
Relation Identifiers" on page 1256.
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UI
Elements Description

Additional
details

Contains the following options:

l Enable Smart Identification. Enables you to select True or False to specify
whether UFT should use Smart Identification to identify the test object during
the run session if it is not able to identify the object using the test object
description.

Note: This option is available only if Smart Identification properties are
defined for the test object's class in the "Object Identification Dialog Box"
(described on page 1325). For details, see "Smart Identification" on page
1316.

l Comment. Enables you to add textual information about the test object.

View in
Repository

Opens theObject Repository window and displays the identification properties
and values for the selected object.

Add to
Repository
(actions
only)

Displayed only for an object that is not in the object repository. (Available only
when you open this dialog box from the Active Screen.)

Adds this object to the action's local object repository. After this object is added,
theAdd to Repository button changes toView in Repository.

Object Repository Window
Relevant for: GUI tests and components

This window enables you tomanage identification properties and object repository associations for
your action or component.

You can use theObject Repository window to:

l View the object description of any object in the repository (in local and shared object
repositories).

l Modify local objects and their properties.

l Add test objects to your local object repository.

l Drag and drop test objects to your test or component. When you drag and drop a test object to
your test or component, UFT inserts a step with the default operation for that test object in your
test or component.

For example, if you drag and drop a button object to your test or component, a step is added using
the button object, with aClick operation (the default operation for a button object).

The following image shows theObject Repository window displaying the local object repository of
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an action, with an Image test object selected. The options on this dialog box differ slightly when
displaying a component's object repository, or when selecting other types of objects.
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To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Do one of the following:

n UFT main window:Click theObject Repository button , or choose
Resources > Object Repository

n Solution Explorer pane:Double-click an object repository, or right-click
an object repository and chooseOpen Repository

n GUI Test:Right-click an action in the canvas and chooseObject
Repository

n Toolbox pane:Right-click a test object and chooseOpen Resource

n Record toolbar: Click theObject Repository button during a
recording session.

Important
information

l Local objects are editable (black). Objects from a shared object repository are
read-only format (gray).

l You canmodify checkpoint and output value details for objects saved in the
local object repository.

l You cannot drag and drop checkpoint and output objects from theObject
Repository window to your testing document.

l You can copy an object from a shared object repository to the local object
repository, and thenmodify it.

l Test objects for environments that are not installed/loaded with UFT are
displayed with a questionmark icon.

l TheObject Repository window is read-only during a record or run session.
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Relevant
tasks

Primary tasks:

l "How to Copy, Paste, Move, or Delete Objects in the Object Repository" on
page 1217

l "How to Define a Visual Relation Identifier for a Specific Test Object - Use-
Case Scenario" on page 1225

Related tasks:

l "How to Export Local Objects to a SharedObject Repository" on page 1264

l "How to Copy anObject to the Local Object Repository" on page 1265

See also l For an overview of this window, see "Object Repository Window - Overview"
on page 1260.

l For details on dragging and dropping test objects from other locations,
see "Toolbox PaneOverview" on page 506 and "How toManageObjects in
SharedObject Repositories" on page 1294.

l For details onmodifying the properties of a test object during a run
session, see "Working with Test Objects During a Run Session" on page
1263.

l For details on viewing and modify object properties from other locations,
see "Maintaining Identification Properties" on page 1204.

User interface elements are described in the following sections:

l "Object Repository Window - Edit Toolbar" below

l "Object Repository Window - Filter Toolbar" on page 1279

l "Object Repository Window Options" on page 1280

l "Object Repository Window - Object Details Area" on page 1281

l "Object Repository Window - Test Object Image Area" on page 1282

Object Repository Window - Edit Toolbar

Button Name Description

Compact
View

Compact Viewmode displays only the object repository tree, while
Full Viewmode displays the object repository tree together with the
object details area.

Full View
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Button Name Description

Undo All changes youmake to a local object are automatically updated in all
steps that use the local object as soon as youmake the change. You
can use theEdit > Undo andEdit > Redomenu options orUndo and
Redo toolbar buttons to cancel or repeat your changes. After you save
the current test or component, you cannot undo or redo operations that
were performed before the save operation.

Redo

Cut Cuts the selected object from the object repository tree. For details,
see "How to Copy, Paste, Move, or Delete Objects in the Object
Repository" on page 1217.

Paste Pastes the object in the clipboard into the object repository tree as a
child of the object selected in the tree. Bottom level objects cannot
contain children. For details, see "How to Copy, Paste, Move, or
Delete Objects in the Object Repository" on page 1217.

Copy Copies the selected object from the object repository tree into the
clipboard. For details, see "How to Copy, Paste, Move, or Delete
Objects in the Object Repository" on page 1217.

Delete Deletes the selected object from the object repository tree.

Find &
Replace

Finds and replaces an object in the object repository. For details, see
"Find and Replace Dialog Box (Object Repository)" on page 1245.

Add Objects
to Local

Enables you to add objects to the local object repository. For details,
see "Adding and Deleting Test Objects in a Local or SharedObject
Repository" on page 1199.

Update from
Application

Enables you to update the identification properties from an object in the
application. For details, see "Updating Identification Properties from an
Object in Your Application" on page 1206.

Add Insight
Object to
Local

Enables you to add an Insight object to the local object repository. For
details, see "Adding Insight Test Objects" on page 1200.

Define New
Test Objects

Enables you to define a new test object. For details, see "Define New
Test Object Dialog Box" on page 1240.

Highlight in
Application

Highlights the selected object in the object repository tree, in the
application. For details, see "Highlighting anObject in Your
Application" on page 1203.

Locate in
Repository

Enables you to select an object in the application you are testing and
highlight the test object in the object repository. For details, see
"Locating a Test Object in the Object Repository" on page 1204.
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Button Name Description

Object Spy Enables you to view the native properties and operations of any object
in an open application, as well as the test object hierarchy,
identification properties, and operations of the test object that uses to
represent that object. You can also add an object to the local object
repository and highlight an object in the application. For details, see
"Object Spy Dialog Box " on page 1189.

Associate
Repositories
(actions
only)

Enables you tomanage the shared object repository associations of
your action. For details, see "Associate Repositories Dialog Box" on
page 1266.

Object Repository Window - Filter Toolbar

UI
Element Description

You can use the Filter toolbar to filter the objects shown in the Object Repository
window.

You can choose to show objects that meet one of the following criteria:

l All objects in the current component or in the selected action, including all local
objects and all objects in any shared object repositories associated with the
selected action.

l Only the local objects in the current component or in the selected action.

l Only the objects in a specific shared object repository associated with the current
action or component.

To filter the Object Repository window:

In the Filter toolbar list, select one of the following options:

l All Objects

l Local Objects

l The name of a specific shared object repository associated with the current action
or component

The object repository tree is filtered to display only the objects from the location that
you selected. The title bar of the Object Repository window indicates the current filter.
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Object Repository Window Options
User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Action
(for actions)

Enables you to select the action whose objects you want to view.

Business
Component
(for
components)

Indicates that the current testing document is a business component.

<Object
repository
tree>

Displays all of the test objects, checkpoint objects, and output objects in the
local and shared object repositories associated with in the current component or
in the selected action.

You can filter the objects shown in the object repository tree. For details, see
"Object Repository Window - Filter Toolbar" on the previous page.

Note: If there are test objects in different associated object repositories
with the same name, object class, and parent hierarchy, the object
repository tree shows only the first one it finds based on the priority order
defined. For details, see:

l For actions: "Associated Repositories Tab (Action Properties Dialog
Box)" on page 906

l For components:"Object Repositories Pane (Application Area)" on
page 2105.

Name The name that UFT assigns to the object. You can change the name of a object
in the local object repository. For details, see "Renaming Test Objects " on page
1206.

Class The class of the object.

Repository The location (file name and path) of the object repository in which the object is
located. If the object is located in the local object repository, Local is displayed.

<Object
details area>

Displays and enables you tomodify one of the following:

l The properties and property values used to identify a test object during a run
session

l The properties of a checkpoint or output object.

For details, see the "Object Repository Window - Object Details Area"
(described on page 1281).
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UI Elements Description

Test object
image area

Displays the image used to identify the object and enables you tomodify it.

For details, see the "Object Repository Window - Test Object Image Area"
(described on page 1282).

Object Repository Window - Object Details Area
TheObject details area in the lower right side of the Object Repository window enables you to
view andmodify the properties and property values used to identify an object during a run session or
the properties of a checkpoint or output object.

For test objects:

UI
Elements Description

Description
properties

The properties and property values used to identify the object during a run
session.

Tip:

l For details on adding properties to or removing properties from the test
object description, see "Add Properties Dialog Box" on page 1231.

l For details on specifying a property value as a constant or parameterizing
a value, see "Specifying or Modifying Property Values" on page 1205.
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UI
Elements Description

Visual
relation
identifier

A set of definitions that enable you to identify the object in the application
according to its neighboring objects in the application. When this option is defined
and enabled, the Ordinal identifier option is disabled. For details, see "Visual
Relation Identifier Dialog Box" on page 1251.

Note: If one or more related objects cannot be found in the object repository,
indicating text is displayed in the cell.

Ordinal
identifier

A numerical value that indicates the object's order or location relative to other
objects with an otherwise identical description (objects that have the same values
for all properties). For details, see "Ordinal Identifier Dialog Box" on page 1247.

Note: If a visual relation identifier is defined for a specific test object, this
option is disabled. For details, see "Considerations forWorking with Visual
Relation Identifiers" on page 1256.

Additional
details

Contains the following options:

l Enable Smart Identification. Enables you to select True or False to specify
whether UFT should use Smart Identification to identify the test object during
the run session if it is not able to identify the object using the test object
description.

Note: This option is available only if Smart Identification properties are
defined for the test object's class in the "Object Identification Dialog Box"
(described on page 1325). For details on Smart Identification, see "Smart
Identification" on page 1316.

l Comment. Enables you to add textual information about the test object.

For checkpoints: The object details area contains the same information as the Checkpoint
Properties dialog box. For details, see "Checkpoint Properties Dialog Box" on page 1432.

For output objects: The object details area contains the same information as the Output Value
Properties dialog box. For details, see "Output Value Properties Dialog Box" on page 1498.

Object Repository Window - Test Object Image Area
The Test Object Image area below the test object details area is available only for Insight test
objects.

It displays the image that UFT uses to identify the object in the application. Tomodify the image,

click theChange Test Object Image button in the title bar of this area. The "Change Test
Object Image / Add Insight Test Object Dialog Box"(described on page 1233) opens. In this dialog
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you can change the test object image and also the default location to click in the object when
performingmethods on the object.

s
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Troubleshooting and Limitations - Object Repositories
Relevant for: GUI tests and components

This section describes troubleshooting and limitations for working with object repositories.

l If youmodify the name of a test object in the Object Repository while your test or component
script contains a syntax error, the new name is not updated correctly within your test or
component steps.

Workaround:Clear theAutomatically update test and component steps when you
rename test objects check box (Tools > Options > GUI Testing tab > General node) and
perform the renames in the steps manually (recommended) or solve the syntax error, and then
close and reopen the document in UFT to display the renamed objects in your steps.

l For actions: If you use the Export and Replace Local Objects option for an object repository
that contains action parameters, the created repository parameters aremapped to test
parameters instead of action parameters.

Workaround:Manually adjust themapping in the exported object repository.
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Chapter 45: Shared Object Repositories
Relevant for: GUI tests and components

This chapter includes:

Concepts 1286

SharedObject Repositories Overview 1286

Considerations forWorking with SharedObject Repositories 1289

Tasks 1291

How to Create andManage SharedObject Repositories 1291

How toManageObjects in SharedObject Repositories 1294

Reference 1297

Object Repository Manager MainWindow 1297

Manage Repository Parameters Dialog Box 1306
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Concepts

Shared Object Repositories Overview
Relevant for: GUI tests and components

A shared object repository contains information that enables UFT to identify the objects in your
application. UFT enables you tomaintain the reusability of your tests or components by storing all
the information regarding your test objects in shared object repositories.

You use theObject Repository Manager to create andmaintain shared object repositories. You can
work with shared object repositories saved both in the file system and in an ALM project.

When objects in your application change, the Object Repository Manager provides a single, central
location in which you can update test object information for multiple tests or components.

Advantages of Shared Object Repositories

l You can use the same shared object repository with multiple actions or components, instead of
saving objects directly with an action or a component in a local object repository. This enables
them to be accessed frommultiple actions or components.

l You can usemultiple shared object repositories with each action or component.

l If your shared object repositories are stored in ALM, you can apply version control to them. For
details, see "Version Control in ALM" on page 794.

For details on associating shared object repositories, see:

l For tests:"Add an object repository file to the current solution (GUI testing only)" on page 476

l For components: "Object Repositories Pane (Application Area)" on page 2105

Note: Instead of, or in addition to, shared object repositories, you can choose to store all or
some of the objects in a local object repository for each action or component, using the Object
Repository window. For details on local object repositories, see "Managing Test Objects in
Object Repositories" on page 1198.

This section also includes:

Importing and Exporting SharedObject Repositories Using XML 1287

Working with Repository Parameters 1287

Managing SharedObject Repositories Using Automation 1288
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Importing and Exporting Shared Object Repositories Using XML

Relevant for: GUI tests and components

You can import and export shared object repositories from and to XML files. XML provides a
structured, accessible format that enables you tomake changes to shared object repositories using
the XML editor of your choice and then import them back into UFT.

You can view the required format for the shared object repository in theHP Unified Functional
Testing Object Repository SchemaHelp (Help > HP UFT GUI Testing Advanced References >
Object Repository Schema Reference), or by exporting a saved shared object repository.

You can import and export files from and to the file system or an ALM project (if UFT is connected
to ALM).

For details, see:

l "Import a shared object repository from XML" on page 1294

l "Export a shared object repository to XML" on page 1294

Working with Repository Parameters

Relevant for: GUI tests and components

Repository parameters enable you to specify that certain property values should be parameterized,
but leave the actual parameterization to be defined in each test or component that is associated
with the shared object repository that contains the parameterized identification property values.

Repository parameters are useful when you want to create and run tests and components on an
object that changes dynamically. An object may change dynamically if it is frequently updated in
the application, or if its property values are set using dynamic content, for example, from a
database.

Example

Suppose you have a button whose text property value changes in a localized application
depending on the language of the user interface. You can parameterize the name property
value using a repository parameter, and then in each test or component that uses the shared
object repository you can specify the location from which the property value should be taken.
For example, in one test or component that uses this shared object repository you can specify
that the property value comes from an environment variable or a component parameter,
respectively. In another test or component it can come from the Data pane or a local
parameter, respectively. In a third test or component you can specify it as a constant value.

You define all the repository parameters for a specific shared object repository using the "Manage
Repository Parameters Dialog Box" (described on page 1306).
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Considerations for Working with Repository Parameters

l When you delete a repository parameter that is used in a test object definition, the identification
property value remains mapped to the parameter, even though the parameter no longer exists.
Therefore, before deleting a repository parameter, you shouldmake sure that it is not used in any
test object descriptions, otherwise tests or components that have steps using these test objects
will fail when you run them.

l When you open a test or component that uses a shared object repository with a repository
parameter that has no default value, an indication that there is a repository parameter that needs
mapping is displayed in the Errors pane. You can thenmap the repository parameter as needed
in the test or component. You can alsomap repository parameters that have default values, and
changemappings for repository parameters that are already mapped. For details onmapping
repository parameters, see "Unmapped SharedObject Repository Parameter Values" on page
368.

Managing Shared Object Repositories Using Automation

Relevant for: GUI tests and components

UFT provides anObject Repository automation object model that enables you tomanage UFT
shared object repositories and their contents from outside of UFT. The automation object model
enables you to use a scripting tool to access UFT shared object repositories via automation.

Just as you use the UFT automation object model to automate your UFT operations, you can use
the objects andmethods of the Object Repository automation object model to write scripts that
manage shared object repositories, instead of performing these operations manually using the
Object Repository Manager. For example, you can add, remove, and rename test objects; import
from and export to XML; retrieve and copy test objects; and so forth.

After you retrieve a test object, you canmanipulate it using themethods and properties available for
that test object class. For example, you can use theGetTOProperty andSetTOProperty methods
to retrieve andmodify its properties. For details on available test object methods and properties,
see theHP UFT Object Model Reference for GUI Testing.

Automation programs are especially useful for performing the same tasks multiple times or on
multiple shared object repositories. You can write your automation scripts in any language and
development environment that supports automation. For example, you can use VBScript,
JavaScript, Visual Basic, Visual C++, or Visual Studio .NET. For general information on controlling
UFT using automation, see "UFT Automation Scripts" on page 1155.

Using the Unified Functional Testing Object Repository Automation
Reference
The Unified Functional Testing Object Repository Automation Reference is a Help file that provides
detailed descriptions, syntax information, and examples for the objects andmethods in the UFT
shared object repository automation object model.

The Help topic for each automation object includes a list and description of themethods associated
with that object. Method Help topics include detailed description, syntax, return value type, and
argument value information.
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You can open theUnified Functional Testing Object Repository Automation Reference from the
mainUFT Helpmenu (Help > HP UFT GUI Testing Advanced References > Object
Repository Automation Reference).

Note: The syntax and examples in the Help file are written in VBScript-style. If you are writing
your automation program in another language, the syntax for somemethods may differ slightly
from what you find in the corresponding Help topic. For details on syntax for the language you
are using, see the documentation included with your development environment or to general
documentation for the programming language.

Considerations for Working with Shared Object
Repositories

Relevant for: GUI tests and components

Consider the following when working with shared object repositories:

Opening, Modifying, and Saving Shared Object Repositories

l Enabling editing. If you opened the shared object repository in read-only mode, youmust
enable editing for the shared object repository before you canmodify it. This locks the shared
object repository and prevents it from beingmodified simultaneously by multiple users. For
details on enabling editing, see "How to Create andManage SharedObject Repositories" on
page 1291.

l Unlocking.When you enable editing for a shared object repository, the shared object repository
is locked so that it cannot bemodified by other users. To enable other users tomodify the shared
object repository, youmust first unlock it (by disabling edit mode, or by closing it). If a shared
object repository is already locked by another user, if it is saved in read-only format, or if you do
not have the permissions required to open it, you cannot enable editing for it.

l Applying changes. All changes youmake to a shared object repository are automatically
updated in all tests or components open on the same computer that use the shared object
repository as soon as youmake the change—even if you have not yet saved the shared object
repository with your changes.

If you close the shared object repository without saving your changes, the changes are rolled
back in any open tests or components that were open at the time.

l Updating changes.When you open a test or component on the same computer on which you
modified the shared object repository, the test or component is automatically updated with all
saved changes made in the associated shared object repository. To see saved changes in a test
or component or repository open on a different computer, youmust open the test or component
or shared object repository file or lock it for editing on your computer to load the changes.

l Merging. You canmodify a shared object repository by merging it with another shared object
repository. When youmerge two shared object repositories, a new shared object repository is
created, containing the content of both shared object repositories. If youmerge a shared object
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repository with a local object repository, the shared object repository is updated with the content
of the local object repository. For details, see "Object Repository Merge Tool" on page 1351.

Managing Objects in Shared Object Repositories

l If one or more of the property values of an object in your application differ from the property
values UFT uses to identify the object, your test or component may fail. Therefore, when the
property values of objects in your application change, you shouldmodify the corresponding
identification property values in the corresponding object repository so that you can continue to
use your existing tests or components.

l The following table describes UFT behavior in cases of duplicate objects in shared object
repositories:

If... UFT Uses...

An object with the same name and description is
located in both the local object repository and in
a shared object repository that is associated with
the same action or component.

The local object definition.

An object with the same name and description is
located inmore than one shared object
repository, and these shared object repositories
are all associated with the same action or
component.

The object definition from the first
occurrence of the object, according to the
order in which the shared object
repositories are associated with the action
or component.

General Tips and Guidelines

l If your test or component contains test objects from environments that are not installed/loaded
with UFT, the test objects are displayed with a questionmark in the shared object repository.

l When youmodify a shared object repository, an asterisk (*) is displayed in the title bar until the
object repository is saved.

l You can use theEdit > Undo andEdit > Redo options to cancel or repeat your changes as
necessary. TheUndo andRedo options are related to the active document. When you save a
shared object repository, you cannot undo and redo operations that were performed on that file
before the save operation.

l You perform search operations in the shared object repository the sameway you perform them
in the local object repository. For details, see "Locating Objects" on page 1202.
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Tasks

How to Create and Manage Shared Object Repositories
Relevant for: GUI tests and components

This task describes the different operations you can perform tomanage shared object repositories
using the Object Repository Manager.

This task includes the following steps:

l "Prerequisites and considerations" below

l "Create a new shared object repository" below

l "Open a shared object repository" on the next page

l "Enable editing for a shared object repository" on the next page

l "Save a shared object repository" on the next page

l "Close shared object repositories" on page 1293

l "Associate a shared object repository with actions or components" on page 1293

l "Merge object repositories into shared ones" on page 1293

l "Import a shared object repository from XML" on page 1294

l "Export a shared object repository to XML" on page 1294

Prerequisites and considerations

l If you want to edit a shared object repository stored in the file system, and the shared object
repository was last modified using a version of QuickTest earlier than version 9.0, UFT must
convert it to the current format before you can edit it. If you do not want to convert it, you can
view it in read-only format. After the file is converted and saved, you cannot use it with earlier
versions of QuickTest.

l If you are working with shared object repositories that are stored in an ALM project, youmust
connect to ALM either from UFT or from theObject Repository Manager by choosingALM >

ALM Connection or clicking theALM Connection button . For details, see "ALM
Connection Dialog Box" on page 737.

Create a new shared object repository
Open theObject Repository Manager and create a new shared object repository, as described in
"Object Repository Manager MainWindow" on page 1297.
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Open a shared object repository
Do one of the following:

l In the "Object Repository Manager MainWindow" (described on page 1297), select File > Open
to open theOpen SharedObject Repository dialog (for object repositories stored on the file
system or an ALM project.

Make sure you clear theOpen in read-only mode check box if you want to modify the shared
object repository.

For a user interface description, see "Open/New <Document>/<Resource> Dialog Box" on
page 156.

l You can also open a shared object repository from theRecent Files list in the Filemenu.

l From the Solution Explorer, double-click the name of a shared object repository or right-click and
select Open Repository.

Enable editing for a shared object repository

Select File > Enable Editing or click theEnable Editing button . The shared object
repository becomes editable. For details, see "Object Repository Manager Toolbar Buttons" on
page 1300.

For considerations on enabling editing, see "Considerations forWorking with SharedObject
Repositories" on page 1289.

Save a shared object repository
Save the shared object repository, as described in "Object Repository Manager Toolbar Buttons" on
page 1300. If the file has already been saved, the changes youmade are saved. If the file has not
yet been saved, the Save SharedObject Repository window opens.

For details, see "Save <Resource>/Save <Document> As Dialog Box" on page 164.

For considerations on saving shared object repositories, see "Considerations forWorking with
SharedObject Repositories" on page 1289.

Note about relative and absolute paths:When you specify a path to a resource in the file
system, UFT checks if the path, or a part of the path, exists in the Folders pane of the Options
dialog box (Tools > Options > GUI Testing tab > Folders node). If the path exists, you are
prompted to define the path using only the relative part of the path you entered. If the path does
not exist, you are prompted to add the resource's location path to the Folders pane and define
the path relatively.

For details, see:

l For actions: "Relative Paths in UFT for GUI Testing" on page 130

l For components: "Folders Pane (Options Dialog Box > GUI Testing Tab)" on page 544.
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If you are working with the Resources and Dependencies model with Quality Center 10.00 or
ALM, you should specify an absolute Quality Center or ALM path. For details, see "Relative
Paths and ALM" on page 758.

Close shared object repositories
Do one of the following:

l To close a single shared object repository, select File > Close or click theClose button in the
shared object repository window's title bar. The shared object repository closes and is
automatically unlocked. If youmade changes that are not yet saved, you are prompted to do so
before the file closes.

l To close all open shared object repositories, select File > Close All Windows. All open shared
object repositories close and are automatically unlocked. If youmade changes that are not yet
saved, you are prompted to do so before the files close.

Note: If you close UFT, the Object Repository Manager also closes. If you havemade
changes that are not yet saved, you are prompted to do so before the Object Repository
Manager closes.

Associate a shared object repository with actions or components
You can associate the shared object repository with one or more actions or components (via the
component's application area) from within UFT.

If you want to associate the shared object repository with an application area so that it can be
accessed by components, youmust save it to your ALM project.

For details on associating shared object repositories, see:

l For actions:"Add an object repository file to the current solution (GUI testing only)" on page 476

l For application areas:"Object Repositories Pane (Application Area)" on page 2105.

Merge object repositories into shared ones
Using the Object Repository Merge tool, you canmerge objects from the local object repository of
one or more actions or components to a shared object repository using theUpdate from Local
Repository option in the Object Repository Manager (Tools > Update from Local Repository).

For example, youmay have learned objects locally in a specific action in your test or in a specific
component and want to move them to the shared object repository so they are available to all
actions in different tests that use that shared object repository, and all components that use it.

You can also use the Object Repository Merge Tool to merge two shared object repositories into a
single shared object repository.

For details, see "Object Repository Merge Tool" on page 1351.
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Import a shared object repository from XML
You can import an XML file (created using the required format) as a shared object repository. The
XML file can either be a shared object repository that you exported to XML format using the Object
Repository Manager, or an XML file created using a tool such as UFT Siebel Test Express or a
custom built utility. Youmust adhere to the XML structure and format.

To import from XML:

1. In the Object Repository Manager, select File > Import from XML. The "Open/New
<Document>/<Resource> Dialog Box" (described on page 156) opens.

The XML file is imported and a summary message box opens showing information regarding
the number of test objects, checkpoint and output objects, parameters, andmetadata that were
successfully imported from the specified file.

2. Click OK to close themessage box. The imported XML file is opened as a new shared object
repository. You can now modify it as required and save it as a shared object repository.

Export a shared object repository to XML
You can export the objects in a shared object repository to an XML file. This enables you to edit it
using any XML editor, and also enables you to save it in an accessible, versatile format.

To export to XML:

1. Make sure that the shared object repository whose objects you want to export is the active
window.

2. Make sure that the shared object repository is saved.

3. In the Object Repository Manager, select File > Export to XML. The "Save
<Resource>/Save <Document> As Dialog Box" (described on page 164) opens.

UFT exports the objects in the shared object repository to the specified XML file, and a
summary message box opens showing information regarding the number of test objects,
checkpoint and output objects, parameters, andmetadata that were successfully exported to
the specified file.

4. Click OK to close themessage box. You can now open the XML file and view ormodify it with
any XML editor.

How to Manage Objects in Shared Object Repositories
Relevant for: GUI tests and components

This task describes various operations you can perform tomanage object in shared object
repositories using the Object Repository Manager.

Note: Many of the shared object repository operations you can perform in the Object
Repository Manager are done in a similar way to how youmodify objects stored in a local
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object repository (using the Object Repository window).

For this reason, many of the procedures are described in "Managing Test Objects in Object
Repositories" on page 1198, and are only referenced here. This task contains operations that
you can perform only in the Object Repository Manager.

Althoughmost of the procedures apply equally to the Object Repository Manager and the
Object Repository window, the windows and options may differ slightly.

This task includes the following steps:

l "Prerequisites" below

l "Manage objects in a shared object repository" below

l "Add test objects using the Navigate and Learn option" below

l "Manage repository parameters" on the next page

Prerequisites
Make sure that the shared object repository you want to edit is the active window.

Manage objects in a shared object repository
You can perform the following operations tomanage objects in a shared object repository, as
described in "Managing Test Objects in Object Repositories" on page 1198:

l "How to Add a Test Object to anObject Repository" on page 1211

l "How to Add an Insight Object to the Object Repository" on page 1214

l "How to Copy, Paste, Move, or Delete Objects in the Object Repository" on page 1217

l "How to Locate anObject in anObject Repository" on page 1219

l "How toMaintain Test Objects in Object Repositories" on page 1220

l "How to Copy anObject to the Local Object Repository" on page 1265

Add test objects using the Navigate and Learn option

1. Select Object > Navigate and Learn or press F6. TheNavigate and Learn toolbar opens.
For a user interface description, see "Navigate and Learn Toolbar" on page 1302.

Note: You cannot learn Insight test objects using this option.

2. Click the parent object (for example, Browser, Dialog, Window) you want to add to the shared
object repository to focus it. The Learn button in the toolbar is enabled.
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3. Click the Learn button or focus theNavigate and Learn toolbar and press ENTER. A flashing
highlight surrounds the focused window and the object and its descendants are added to the
shared object repository according to the defined filter.

4. When you finish adding the required objects to the shared object repository, click theClose
button in theNavigate and Learn toolbar or press ESC. TheNavigate and Learn toolbar
closes and theObject Repository Manager is redisplayed, showing the objects you just added
to the shared object repository.

Manage repository parameters
Use the "Manage Repository Parameters Dialog Box" (described on page 1306).
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Reference

Object Repository Manager Main Window
Relevant for: GUI tests and components

This window enables you to openmultiple shared object repositories andmodify them as needed.

The options available when specifying property values for objects in shared object repositories are
different from those available when specifying properties for objects in local repositories.

To access Do one of the following:

l Select Resources > Object Repository Manager.

l In the Solution Explorer, double-click a shared object repository.

Important
information

See "Considerations forWorking with the Object Repository Manager" on
the next page
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Relevant tasks l "How to Create andManage SharedObject Repositories" on page 1291

l "How toManageObjects in SharedObject Repositories" on page 1294

See also l "SharedObject Repositories Overview" on page 1286

l "Considerations forWorking with SharedObject Repositories" on page
1289

l "New Property Dialog Box" on page 1232

l "Ordinal Identifier Dialog Box" on page 1247

Considerations for Working with the Object Repository Manager

l You can open as many shared object repositories as you want.

l Each shared object repository opens in a separate document window. You can then resize,
maximize, or minimize the windows to arrange them as you require to copy, drag, andmove
objects between different shared object repositories, as well as perform operations on a single
object repository.

l While the Object Repository Manager is open, you can continue working with other UFT
windows.

l You cannot add checkpoint or output value objects to a shared object repository via the Object
Repository Manager. They are added to the local object repository as the test object they are
performed on. You can then upload them to the shared object repository, if needed. For details,
see "How to Update a SharedObject Repository From a Local Object Repository" on page
1358.

l When you choose amenu item or click a toolbar button in the Object Repository Manager, the
operation you select is performed on the shared object repository whose window is currently
active (in focus).

l If UFT is connected to an ALM project with version control enabled, you can view andmanage
versions of your shared object repositories, view comparisons of two shared object repository
versions, and view baseline history. For details, see "Version Control in ALM" on page 794 and
"Viewing and Comparing Versions of UFT Assets" on page 770.

l Even when steps containing an object are deleted from your action or component, the objects
remain in the shared object repository.

User interface elements are described in the sections below:

l "Object Repository Document Window" on the next page

l "Object Details Area (Test Objects)" on the next page
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l "Test Object Image Area (Insight Test Objects)" below

l "Object Details Area (Checkpoint Objects)" on the next page

l "Object Details Area (Output Value Objects) " on the next page

l "Object Repository Manager Toolbar Buttons" on the next page

Object Repository Document Window
Each open object repository contains the following user interface elements (unlabeled elements are
shown in angle brackets):

UI Element Description

Title bar Displays the name and file path of the shared object repository currently active (in
focus).

Object
Repository
tree

Located on the left side of the Object Repository window, and contains all objects
in the shared object repository.

Test objects of environments that are not installed with UFT are displayed with a
questionmark icon in the test object tree.

Name Specifies the name that UFT assigns to the selected object. You can change the
object name. For details, see "Renaming Test Objects " on page 1206.

Class Specifies the class of the selected object.

Object Details Area (Test Objects)
Enables you to view the properties and property values used to identify a test object during a run
session.

For details on key functionality of this area, see:

l "Updating Identification Properties from anObject in Your Application" on page 1206

l "Restoring Default Mandatory Properties for a Test Object" on page 1206

l "How toMaintain Test Objects in Object Repositories" on page 1220

l "Renaming Test Objects " on page 1206

l "How to Define a Visual Relation Identifier for a Specific Test Object - Use-Case Scenario" on
page 1225

Test Object Image Area (Insight Test Objects)
The Test Object Image area below the test object details area is available only for Insight test
objects.
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It displays the image that UFT uses to identify the object in the application. Tomodify the image,

click theChange Test Object Image button in the title bar of this area. The Change Test
Object Image dialog box (described on page 1233) opens. In this dialog you can change the test
object image and also the default location to click in the object when performingmethods on the
object.

Object Details Area (Checkpoint Objects)
Enables you to view the properties of a checkpoint object, the sameway as you do in the relevant
checkpoint properties dialog box.

For details on specifying andmodifying values for properties of a checkpoint object, see the
"Checkpoint Properties Dialog Box" on page 1432

Object Details Area (Output Value Objects)
Enables you to view the properties of an output value object, the sameway as you do in the
relevant checkpoint properties dialog box.

For details on specifying andmodifying values for properties of an output object, see the
"Output Value Properties Dialog Box" on page 1498.

Object Repository Manager Toolbar Buttons

Relevant for: GUI actions and components

TheObject Repository Manager toolbar contains the following buttons:

Button Description

New. Enables you to create a new shared object repository. For details, see "Create a
new shared object repository" on page 1291.

Open. Enables you to open a shared object repository from the file system or from
ALM. For details, see "Open a shared object repository" on page 1292.

Save. Enables you to save the active shared object repository to the file system or to
ALM. For details, see "Save a shared object repository" on page 1292.
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Button Description

Enable Editing. Enables you to edit the active shared object repository, by making the
shared object repository editable. For details, see "Enable editing for a shared object
repository" on page 1292.

Undo. Enables you to undo the previous operation performed in the active shared
object repository. You do this in the sameway as in a local object repository. For
details, see "How to Copy, Paste, Move, or Delete Objects in the Object Repository"
on page 1217.

Redo. Enables you to redo the operation that was previously undone in the active
shared object repository. You do this in the sameway as in a local object repository.
For details, see "How to Copy, Paste, Move, or Delete Objects in the Object
Repository" on page 1217.

Cut. Enables you to cut the selected item or object in the active shared object
repository. You do this in the sameway as in a local object repository. For details, see
"How to Copy, Paste, Move, or Delete Objects in the Object Repository" on page 1217.

Copy. Enables you to copy the selected item or object to the Clipboard in the active
shared object repository. You do this in the sameway as in a local object repository.
For details, see "How to Copy, Paste, Move, or Delete Objects in the Object
Repository" on page 1217.

Paste. Enables you to paste the data from the Clipboard to the active shared object
repository. You do this in the sameway as in a local object repository. For details, see
"How to Copy, Paste, Move, or Delete Objects in the Object Repository" on page 1217.

Delete. Enables you to delete the selected item or object in the active shared object
repository. You do this in the sameway as in a local object repository. For details, see
"How to Copy, Paste, Move, or Delete Objects in the Object Repository" on page 1217.

Find and Replace. Enables you to find an object, property, or property value in the
active shared object repository. You can also find and replace specified property
values. You do this in the sameway as in a local object repository. For details, see
"Find and Replace Dialog Box (Object Repository)" on page 1245.

Add Objects. Enables you to add objects to the active shared object repository. You
do this in the sameway as in a local object repository. For details, see "Adding and
Deleting Test Objects in a Local or SharedObject Repository" on page 1199.

Update from Application. Enables you to update identification properties in the active
shared object repository according to the actual properties of the object in your
application. You do this in the sameway as in a local object repository. For details, see
"Updating Identification Properties from anObject in Your Application" on page 1206.

Add Insight Object. Enables you to add an Insight object to the active shared object
repository. You do this in the sameway as in a local object repository. For details, see
"Adding Insight Test Objects" on page 1200.
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Button Description

Define new Test Object. Enables you to define a test object that does not yet exist in
your application and add it to the active shared object repository. You do this in the
sameway as in a local object repository. For details, see "Define New Test Object
Dialog Box" on page 1240.

Highlight in Application. Enables you to select an object in the active shared object
repository and highlight it in your application. You do this in the sameway as in a local
object repository. For details, see "How to Locate anObject in anObject Repository"
on page 1219.

Locate in Repository. Enables you to select an object in your application and highlight
it in the active shared object repository. You do this in the sameway as in a local object
repository. For details, see "Locating a Test Object in the Object Repository" on page
1204.

ALM Connection. Enables you to connect to ALM to work with object repository files
stored in an ALM project. You can connect to ALM from themain UFT window or from
theObject Repository Manager. For details, see "ALM Connection Dialog Box" on page
737.

Object Spy. Opens the "Object Spy Dialog Box " (described on page 1189), enabling
you to view the native properties and operations of any object in an open application, as
well as the test object hierarchy, identification properties, and operations of the test
object that UFT uses to represent that object. For details, see "How to Use theObject
Spy to View Object Properties andOperations or Add anObject to a Repository" on
page 1184.

Manage Repository Parameters. Enables you to add, edit, and delete repository
parameters in the active shared object repository. For details, see "Manage Repository
Parameters Dialog Box" on page 1306.

Navigate and Learn Toolbar

Relevant for: GUI actions and components

This toolbar enables you to addmultiple test objects to a shared object repository while navigating
through your application.

To access In the Object Repository Manager, do one of the following:

l Select Object > Navigate and Learn.

l Press F6.
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Important
information

l Each time you select a window to learn, the selected window and its
descendant objects are added to the active shared object repository according
to a predefined object filter. You can change the object filter definitions at any
time tomeet your requirements. The object filter is used for both theNavigate
and Learn option and theAdd Objects option. The settings you define are
used in both places when UFT learns objects. For details onmodifying the filter
definitions, see "Define Object Filter Dialog Box" on page 1242.

l The Navigate and Learn option is not supported for environments with mixed
hierarchies (object hierarchies that include objects from different
environments), for example, Browser("Homepage").Page
("Welcome").AcxButton("Save") orDialog("Edit").AcxEdit("MyEdit"). To add
objects within mixed hierarchies, use other options, as described in "Adding
and Deleting Test Objects in a Local or SharedObject Repository" on page
1199.

l TheNavigate and Learn option does not learn the following types of objects:

n Minimized windows

n Insight test objects

n Objects in Google Chrome Frame

Relevant
tasks

"How to Create andManage SharedObject Repositories" on page 1291

See also "Object Repository Manager MainWindow" on page 1297

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

Learn Adds the active (in focus) parent object and its descendants to the shared object
repository, according to the defined filter.

Note: This button is disabled if there is no recognized active parent object (for
example, Browser, Dialog,Window).

Keyboard shortcut:ENTER
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UI
Elements Description

Define Object Filter. Opens the "Define Object Filter Dialog Box" (described on
page 1242), enabling you to set filter definitions for objects learned. The current
filter definitions are displayed in the button tooltip (in parentheses after the button
name).

Note: If this is the first time you are adding objects to the shared object
repository, youmay want to change the filter definitions before you continue.

Keyboard shortcut:CTRL+F

<keyboard
shortcuts>

l Help. F1

l Return to Object Repository Manager. ESC

Repository Parameter Dialog Box

Relevant for: GUI tests and components

This dialog box enables you to specify or modify property values for test objects in the shared
object repository. You can specify a value using a constant value (either a simple value or a
constant value that includes regular expressions), or you can parameterize a value using a
repository parameter.

To access In the "Object Repository Manager MainWindow" (described on page 1297), do
the following:

1. Select the test object whose property value you want to specify.

2. In the Test object details area, click in theValue cell for the required
property.
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Important
information

You can also specify or modify values for properties of a checkpoint or output
object, directly in the object details area of the Object Repository Manager. For
details, see "Object Repository Manager MainWindow" on page 1297.

Relevant
tasks

"How toManageObjects in SharedObject Repositories" on page 1294

See also l "Working with Repository Parameters" on page 1287

l "Manage Repository Parameters Dialog Box" on the next page

User interface elements are described below:

UI
Elements Description

Constant The constant value of the object property.

Note: You can also enter a constant value directly in theValue cell of the Test
object details area.

Regular
expression

Enables you to specify a regular expression for the constant value.

For details on regular expressions, see "Regular Expressions Overview" on page
318 and "Regular Expression Characters and UsageOptions" on page 352.

Parameter Enables you to select a repository parameter from the list of defined parameters.

Default
value

The default value for the parameter, where applicable.
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Manage Repository Parameters Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to add, edit, and delete repository parameters for a single shared object
repository.

To access In the "Object Repository Manager MainWindow" (described on page 1297), do
one of the following:

l Select Tools > Manage Repository Parameters.

l Click theManage Repository Parameters button .

Relevant
tasks

"How toManageObjects in SharedObject Repositories" on page 1294

See also l "Working with Repository Parameters" on page 1287.

l "Add Repository Parameter Dialog Box" on page 1308

l "Repository Parameter Dialog Box" on page 1304
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User interface elements are described below:

Option Description

<Repository> Displays the name and path of the shared object repository whose repository
parameters you aremanaging.

Add Repository Parameter. Enables you to add a new repository parameter.
For details, see "Add Repository Parameter Dialog Box" on the next page.

Delete Repository Parameter. Enables you to delete the currently selected
repository parameters.

Parameter
list
(Name,
Default
Value, and
Description)

Displays the list of repository parameters currently defined in this shared object
repository. You canmodify a parameter's default value and description directly
in the parameter list. For considerations, see "Working with Repository
Parameters" on page 1287.

Clear Default Value. Enables you to remove the default value of the
parameter. If you remove the default value, the text {No Default Value} is
displayed in the cell.

Note: If you delete the text manually, it does not remove the default value.
It creates a default value of an empty string. Youmust click theClear
Default Value button if you want to remove the default value.

Find in
Repository

Searches for and highlights the first test object in the shared object repository
tree that uses the selected repository parameter. You can click this button again
to find the next occurrence of the selected parameter, and so on.
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Add Repository Parameter Dialog Box

Relevant for: GUI tests and components

This dialog box enables you to define a new repository parameter. You can specify a default value
for the parameter and ameaningful description to help identify it when it is used in a test or
component step.

To
access

In the "Manage Repository Parameters Dialog Box" (described on page 1306), click

theAdd Repository Parameter button .

Relevant
tasks

"How toManageObjects in SharedObject Repositories" on page 1294

See also l "Working with Repository Parameters" on page 1287

l "Manage Repository Parameters Dialog Box" on page 1306

l "Repository Parameter Dialog Box" on page 1304

User interface elements are described below:

UI
Elements Description

Name A meaningful name for the parameter. For a list of naming conventions, see
"Troubleshooting - Naming Conventions" on page 2269.
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UI
Elements Description

Default
value

The default value to be used for the repository parameter. This value is used if you
do not map the repository parameter to a value or parameter type in a test or
component that uses this shared object repository. If you do not specify a default
value, the repository parameter will appear as unmapped in any tests or
components that use this shared object repository.

Note: If you specify a default value, you can later remove it by clicking in the
Default Value cell of the relevant parameter in the "Manage Repository
Parameters Dialog Box" (described on page 1306) and then clicking theClear
Default Value button. The text {No Default Value} is displayed in the cell.

Description A description of the repository parameter. The description will help you identify the
parameter whenmapping repository parameters in a test or component.
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Chapter 46: Configuring Object Identification
Relevant for: GUI tests and components

This chapter includes:

Concepts 1311

Object Identification Configuration - Overview 1311

Smart Identification 1316

Test Object Mapping for Unidentified or Custom Classes 1321

Tasks 1322

How to Configure Object Identification for a Test Object Class 1322

How toManage Identification Properties of a Test Object Class 1323

How toMap an Unidentified or Custom Class to a StandardWindows Class 1324

Reference 1325

Object Identification Dialog Box 1325

Object Mapping Dialog Box 1330

Smart Identification Properties Dialog Box 1331
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Concepts

Object Identification Configuration - Overview
Relevant for: GUI tests and components

WhenUFT learns an object, it learns a set of properties and values that uniquely describe the object
within the object hierarchy. In most cases, this description is sufficient to enable UFT to identify the
object during the run session.

If you find that the description UFT uses for a certain object class is not themost logical one for the
objects in your application, or if you expect that the values of the properties in the object description
may change frequently, you can configure the way that UFT learns and identifies objects. You can
alsomap user-defined objects to standard test object classes and configure the way UFT learns
objects from your user-defined object classes.

UFT has a predefined set of properties that it learns for each test object. If thesemandatory
property values are not sufficient to uniquely identify a learned object, UFT can add some assistive
properties and/or an ordinal identifier to create a unique description.

Mandatory properties are properties that UFT always learns for a particular test object class.

Assistive properties are properties that UFT learns only if themandatory properties that UFT
learns for a particular object in your application are not sufficient to create a unique description. If
several assistive properties are defined for an object class, then UFT learns one assistive property
at a time, and stops as soon as it creates a unique description for the object. If UFT does learn
assistive properties, those properties are added to the test object description.

Note:

l If the combination of all definedmandatory and assistive properties is not sufficient to
create a unique test object description, UFT also learns the value for the selected ordinal
identifier. For details, see "Ordinal Identifiers" on the next page.

l If a specific test object relies mainly on ordinal identifiers, you can also define visual relation
identifiers for that test object, to help improve identification reliability for that object. For
details, see "Visual Relation Identifiers" on page 1209.

When you run a test or component, UFT searches for the object that matches the description it
learned (without the ordinal identifier). If it cannot find any object that matches the description, or if
more than one object matches the description, UFT uses theSmart Identificationmechanism (if
enabled) to identify the object. In many cases, a Smart Identification definition can help UFT
identify an object, if it is present, even when the learned description fails due to changes in one or
more property values. The test object description is used together with the ordinal identifier only in
cases where the Smart Identificationmechanism does not succeed in narrowing down the object
candidates to a single object.
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You use the "Object Identification Dialog Box" (described on page 1325) to configure the
mandatory, assistive, and ordinal identifier properties that UFT uses to learn descriptions of the
objects in your application, and to enable and configure the Smart Identificationmechanism.

TheObject Identification dialog box also enables you to configure new user-defined classes and
map them to an existing test object class so that UFT can recognize objects from your user-defined
classes when you run your test or component.

Mandatory and Assistive Properties 1312

Ordinal Identifiers 1312

Mandatory and Assistive Properties

Relevant for: GUI tests and components

If you find that the description UFT uses for a certain object class is not themost logical one for the
objects in your application, or if you expect that the values of the properties currently used in the
object descriptionmay change, you canmodify themandatory and assistive properties that UFT
learns when it learns an object of a given class.

During the run session, UFT looks for objects that match all properties in the test object
description—it does not distinguish between properties that were learned as mandatory properties
and those that were learned as assistive properties.

For example, the default mandatory properties for aWeb Image object are the alt, html tag, and
image type properties. There are no default assistive properties defined. Suppose yourWeb site
contains several space holders for different collections of rotating advertisements. You want to
create a test or component that clicks on the images in each one of these space holders.

However, since each advertisement image has a different alt value, one alt value would be added
when you create the test or component, andmost likely another alt value will be captured when you
run the test or component, causing the run to fail. In this case, you could remove the alt property
from theWeb Imagemandatory properties list. Instead, since each advertisement image displayed
in a certain space holder in your site has the same value for the image name property, you could
add the name property to themandatory properties to enable UFT to uniquely identify the object.

Also, suppose that whenever aWeb image is displayedmore than once on a page (for example, a
logo displayed on the top and bottom of a page), theWeb designer adds a special ID property to the
Image tag. Themandatory properties are sufficient to create a unique description for images that
are displayed only once on the page, but you also want UFT to learn the ID property for images that
are displayedmore than once on a page. To do this, you add the ID property as an assistive
property, so that UFT learns the ID property only when it is necessary for creating a unique test
object description.

Ordinal Identifiers

Relevant for: GUI tests and components

In addition to learning themandatory and assistive properties specified in the "Object Identification
Dialog Box" (described on page 1325), UFT can also learn a backup ordinal identifier for each test

User Guide
Chapter 46: Configuring Object Identification

HP Unified Functional Testing (12.00) Page 1312 of 2274



object. The ordinal identifier assigns the object a numerical value that indicates its order relative
to other objects with an otherwise identical description (objects that have the same values for all
properties specified in themandatory and assistive property lists). This ordered value enables UFT
to create a unique description when themandatory and assistive properties are not sufficient to do
so.

The assigned ordinal property value is a relative value and is accurate only in relation to the other
objects displayed when UFT learns an object. Therefore, changes in the layout or composition of
your application page or screen can cause this value to change, even though the object itself has
not changed in any way. For this reason, UFT learns a value for this backup ordinal identifier only
when it cannot create a unique description using all available mandatory and assistive properties.

In addition, even if UFT learns an ordinal identifier, it will use the identifier during the run session
only if:

l The learned description and the Smart Identificationmechanism are not sufficient to identify the
object in your application.

l A visual relation identifier is not defined for the test object. For details, see "Visual Relation
Identifiers" on page 1209.

UFT can use the following types of ordinal identifiers to identify an object:

l Index. Indicates the order in which the object appears in the application code relative to other
objects with an otherwise identical description. For details, see "The Index Ordinal Identifier" on
the next page.

l Location. Indicates the order in which the object appears within the parent window, frame, or
dialog box relative to other objects with an otherwise identical description. For details, see "The
Location Ordinal Identifier" on the next page.

l CreationTime. (Browser object only.) Indicates the order in which the browser was opened
relative to other open browsers with an otherwise identical description. For details, see "The
CreationTimeOrdinal Identifier" on page 1316.

By default, an ordinal identifier type exists for each test object class. Tomodify the default ordinal
identifier, you can select the desired type from theOrdinal identifier box.

Tip:When learning an object, if UFT successfully creates a unique test object description
using themandatory and assistive properties, it does not learn an ordinal identifier value. You
can add an ordinal identifier to an object's identification properties at a later time using the
"Ordinal Identifier Dialog Box", available from theObject Properties or Object Repository
window. For details, see "Managing Test Objects in Object Repositories" on page 1198.
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This section also includes:

l "The Index Ordinal Identifier" below

l "The Location Ordinal Identifier" below

l "The CreationTimeOrdinal Identifier" on page 1316

The Index Ordinal Identifier

Relevant for: GUI tests and components

While learning an object, UFT can assign a value to the test object's Index property to uniquely
identify the object. The value is based on the order in which the object appears within the source
code. The first occurrence is 0.

Index property values are object-specific. Therefore, if you use Index:=3 to describe aWebEdit test
object, UFT searches for the fourthWebEdit object in the page. However, if you use Index:=3 to
describe aWebElement object, UFT searches for the fourthWeb object on the page—regardless of
the type—because theWebElement object applies to all Web objects.

For example, suppose a page contains the following objects:

l An image with the nameApple

l An image with the nameUserName

l AWebEdit object with the nameUserName

l An image with the namePassword

l AWebEdit object with the namePassword

The following statement refers to the third item in the list, as this is the first WebEdit object on the
page with the nameUserName:

WebEdit("Name:=UserName", "Index:=0")

In contrast, the following statement refers to the second item in the list, as that is the first object of
any type (WebElement) with the nameUserName:

WebElement("Name:=UserName", "Index:=0")

The Location Ordinal Identifier

Relevant for: GUI tests and components

While learning an object, UFT can assign a value to the test object's Location property to uniquely
identify the object. The value is based on the order in which the object appears within the window,
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frame, or dialog box, in relation to other objects with identical properties. The first occurrence of the
object is 0. Values are assigned in columns from top to bottom, and left to right.

In the following example, the radio buttons in the dialog box are numbered according to their
Location property:

Location property values are object-specific. Therefore, if you use Location:=3 to describe a
WinButton test object, UFT searches from top to bottom, and left to right for the fourthWinButton
object in the page. However, if you use Location:=3 to describe aWinObject object, UFT searches
from top to bottom, and left to right for the fourth standard object on the page—regardless of the
type—because theWinObject object applies to all standard objects.

For example, suppose a dialog box contains the following objects:

l A button object with the nameOK

l A button object with the nameAdd/Remove

l A check box object with the nameAdd/Remove

l A button object with the nameHelp

l A check box object with the nameCheck spelling

The following statement refers to the third item in the list, as this is the first check box object on the
page with the nameAdd/Remove:

WinCheckBox("Name:=Add/Remove", "Location:=0")

In contrast, the following statement, refers to the second item in the list, as that is the first object of
any type (WinObject) with the nameAdd/Remove:

WinObject("Name:=Add/Remove", "Location:=0")
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The CreationTime Ordinal Identifier

Relevant for: GUI tests and components

While learning a browser object, UFT assigns a value to theCreationTime identification property.
This value indicates the order in which the browser was opened relative to other open browsers.
The first browser that opens receives the valueCreationTime = 0.

During the run session, if UFT is unable to identify a browser object based solely on its test object
description, it examines the order in which the browsers were opened, and then uses the
CreationTime property to identify the correct one.

For example, if UFT learns three browsers that are opened at 9:01 pm, 9:03 pm, and 9:05 pm, UFT
assigns theCreationTime values, as follows: CreationTime = 0 to the 9:01 am browser,
CreationTime = 1 to the 9:03 am browser, andCreationTime = 2 to the 9:06 am browser.

At 10:30 pm, when you run a test or component with these browser objects, suppose the browsers
are opened at 10:31 pm, 10:33 pm, and 10:34 pm. UFT identifies the browsers, as follows: the
10:31 pm browser is identified with theBrowser test object withCreationTime = 0, 10:33 pm
browser is identified with the test object withCreationTime = 1, 10:34 pm browser is identified with
the test object withCreationTime = 2.

If there are several open browsers, the one with the lowest CreationTime is the first one that was
opened and the one with the highest CreationTime is the last one that was opened. For example, if
there are three or more browsers open, the one withCreationTime = 2 is the third browser that was
opened. If seven browsers are opened during a recording session, the browser with
CreationTime = 6 is the last browser opened.

If a step was created on a Browser object with a specific CreationTime value, but during a run
session there is no open browser with that CreationTime value, the step will run on the browser that
has the highest CreationTime value. For example, if a step was created on aBrowser object with
CreationTime = 6, but during the run session there are only two open browsers, with
CreationTime = 0 andCreationTime = 1, then the step runs on the last browser opened, which in
this example is the browser withCreationTime = 1.

Note: It is possible that at a particular time during a session, the availableCreationTime values
may not be sequential. For example, if you open six browsers during a record or run session,
and then during that session, you close the second and fourth browsers (CreationTime values
1 and 3), then at the end of the session, the open browsers will be those withCreationTime
values 0, 2, 4, and 5.

Smart Identification
Relevant for: GUI tests and components

WhenUFT uses the learned description to identify an object, it searches for an object that matches
all of the property values in the description. In most cases, this description is the simplest way to
identify the object, and, unless themain properties of the object change, this method will work.
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If UFT is unable to find any object that matches the learned object description, or if it finds more
than one object that fits the description, then UFT ignores the learned description, and uses the
Smart Identificationmechanism (if defined and enabled) to try to identify the object.

The "Smart Identification Properties Dialog Box" (described on page 1331) enables you to create
andmodify the Smart Identification definition that UFT uses for a selected test object class.
Configuring Smart Identification properties enables you to help UFT identify objects in your
application, even if some of the properties in the object's learned description have changed.

While the Smart Identificationmechanism is more complex, it is more flexible. Therefore, if
configured logically, a Smart Identification definition can probably help UFT identify an object, if it is
present, even when the learned description fails.

The Smart Identificationmechanism uses two types of properties:

l Base Filter Properties. Themost fundamental properties of a particular test object class; those
whose values cannot be changed without changing the essence of the original object. For
example, if aWeb link's tag was changed from <A> to any other value, you could no longer call it
the same object.

l Optional Filter Properties. Other properties that can help identify objects of a particular class.
These properties are unlikely to change on a regular basis, but can be ignored if they are no
longer applicable.

Smart identification is not relevant for Insight test objects.

This section also includes:

When to Use Smart Identification 1317

The Smart Identification Process 1318

Smart Identification Information in the Run Results 1318

How UFT Uses Smart Identification - Use-Case Scenario 1319

When to Use Smart Identification

Relevant for: GUI tests and components

You should enable the Smart Identificationmechanism only for test object classes that have
defined Smart Identification configuration. However, even if you define a Smart Identification
configuration for a test object class, youmay not always want to learn the Smart Identification
property values. If you do not want to learn the Smart Identification properties, clear theEnable
Smart Identification check box.

Even if you choose to learn Smart Identification properties for an object, you can disable use of the
Smart Identificationmechanism for a specific object in the Object Properties or Object Repository
window. For tests, you can also disable use of themechanism for an entire test in the Run pane of
the Test Settings dialog box. For details, see "Managing Test Objects in Object Repositories" on
page 1198, and, for tests, "Run Pane (Test Settings Dialog Box)" on page 601.
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However, if you do not learn Smart Identification properties, you cannot enable the Smart
Identificationmechanism for an object later. For details on learning Smart Identification properties,
see "Smart Identification Properties Dialog Box" on page 1331.

The Smart Identification Process

Relevant for: GUI tests and components

If UFT activates the Smart Identificationmechanism during a run session (because it was unable to
identify an object based on its learned description), it follows the following process to identify the
object:

1. UFT "forgets" the learned test object description and creates a new object candidate list
containing the objects (within the object's parent object) that match all of the properties defined
in the Base Filter Properties list.

2. UFT filters out any object in the object candidate list that does not match the first property
listed in the Optional Filter Properties list. The remaining objects become the new object
candidate list.

3. UFT evaluates the new object candidate list:

n If the new object candidate list still has more than one object, UFT uses the new (smaller)
object candidate list to repeat the filter for the next optional filter property in the list.

n If the new object candidate list is empty, UFT ignores this optional filter property, returns to
the previous object candidate list, and repeats the filter for the next optional filter property in
the list.

n If the object candidate list contains exactly one object, then UFT concludes that it has
identified the object and performs the statement containing the object.

4. UFT continues the filtering process described above until it either identifies one object, or runs
out of optional filter properties to use.

If, after completing the Smart Identification elimination process, UFT still cannot identify the
object, then UFT uses the learned description plus the ordinal identifier to identify the object.

If the combined learned description and ordinal identifier are not sufficient to identify the object,
then UFT pauses the run session and displays a Run Error message.

Smart Identification Information in the Run Results

Relevant for: GUI tests and components

If the learned description does not enable UFT to identify a specified object in a step, and a Smart
Identification definition is defined (and enabled) for the object, then UFT tries to identify the object
using the Smart Identificationmechanism.
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If UFT successfully uses Smart Identification to find an object after no object matches the learned
description, the step is assigned aWarning status in the Run Results, and the result details for the
step indicate that the Smart Identificationmechanism was used.

If the Smart Identificationmechanism cannot successfully identify the object, UFT uses the
learned description plus the ordinal identifier to identify the object. If the object is still not identified,
the test or component fails and a normal failed step is displayed in the results.

For more details, see Smart Identification in the Run Results (described in theHP RunResults
Viewer User Guide).

How UFT Uses Smart Identification - Use-Case Scenario

Relevant for: GUI tests and components

The following example walks you through the object identification process for an object:

Suppose you have the following statement in your test or component:

Browser("Mercury Tours").Page("Mercury Tours").Image("Login").Click 22,17

When you created your test or component, UFT learned the following object description for the
Login image:

However, at some point after you created your test or component, a second login button (for logging
into the VIP section of theWeb site) was added to the page, so theWeb designer changed the
original Login button's alt tag to: basic login.

The default description forWeb Image objects (alt, html tag, image type) works for most images
in your site, but it no longer works for the Login image, because that image's alt property no longer
matches the learned description. Therefore, when you run your test or component, UFT is unable to
identify the Login button based on the learned description. However, UFT succeeds in identifying
the Login button using its Smart Identification definition.

The following explanation describes the process that UFT uses to find the Login object using Smart
Identification:

1. According to the Smart Identification definition you have forWeb image objects, UFT learned
the values of the following properties when it learned the Login image:
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The learned values are as follows:

Base Filter Properties:

Property Value

html tag INPUT

Optional Filter Properties:

Property Value

alt Login

name login

file name login.gif

class <null>

visible 1

2. UFT begins the Smart Identification process by identifying the five objects on theMercury
Tours page that match the base filter properties definition (html tag = INPUT). UFT considers
these to be the object candidates and begins checking the object candidates against the
Optional Filter Properties list.

3. UFT checks the alt property of each of the object candidates, but none have the alt value:
Login, so UFT ignores this property andmoves on to the next one.

4. UFT checks the name property of each of the object candidates, and finds that two of the
objects (both the basic and VIP Login buttons) have the name: login. UFT filters out the other
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three objects from the list, and these two login buttons become the new object candidates.

5. UFT checks the file name property of the two remaining object candidates. Only one of them
has the file name login.gif, so UFT correctly concludes that it has found the Login button and
clicks it.

Test Object Mapping for Unidentified or Custom Classes
Relevant for: GUI tests and components

The "Object Mapping Dialog Box" (described on page 1330) enables you tomap an object of an
unidentified or custom class to a standardWindows class. For example, if your application has a
button that cannot be identified, this button is learned as a generic WinObject.

You can teach UFT to identify your object as if it belonged to a standardWindows button class.
Then, when you click the button while recording, UFT records the operation in the sameway as a
click on a standardWindows button.

When youmap an unidentified or custom object to a standard object, your object is added to the list
of standardWindows test object classes as a user-defined test object class. You can configure the
object identification settings for a user-defined test object class just as you would any other test
object class.

You shouldmap an object that cannot be identified only to a standardWindows class with
comparable behavior. For example, do not map an object that behaves like a button to the Edit
class.
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Tasks

How to Configure Object Identification for a Test Object
Class

Relevant for: GUI tests and components

This task describes steps you can perform to configure the properties that UFT uses to learn and
identify objects. Perform one or more of these steps to configure object identification for a specific
test object class.

Repeat the task for all relevant test object classes.

This task includes the following steps:

l "Prerequisites " below

l "Set the properties that UFT learns for identifying an object in this test object class" below

l "Set the properties that UFT uses for Smart Identification" below

Prerequisites
Determine what you would like to change about how UFT identifies objects of various test object
classes within your application. For details, see "Object Identification Configuration - Overview" on
page 1311.

Set the properties that UFT learns for identifying an object in this test
object class
In the "Object Identification Dialog Box" (described on page 1325), set the properties that are
learned for the test object description:

1. Select the environment.

2. Select the test object class.

3. Set mandatory and assistive properties.

4. Select an ordinal identifier.

Set the properties that UFT uses for Smart Identification

1. In the "Object Identification Dialog Box", select theEnable Smart ID check box. The
Configure button is enabled.

2. Click theConfigure button to open the "Smart Identification Properties Dialog Box" (described
on page 1331).
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3. Set the base and optional properties.

4. Set the order in which the optional properties are used.

5. If you do not want UFT to learn the Smart Identification properties, clear theEnable Smart
Identification check box. The configuration is saved, but not used.

For more details, see "Smart Identification" on page 1316.

How to Manage Identification Properties of a Test Object
Class

Relevant for: GUI tests and components

The following task describes how tomanage the identification properties of a specified test object
class in the "Add/Remove Properties Dialog Box" (described on page 1328) and includes the
following:

l "Add and remove properties to the object identification property lists" below

l "Add identification properties to the test object class" below

Add and remove properties to the object identification property lists
To include a property in theMandatory, Assistive, Base Filter, orOptional Filter Properties
lists, open the "Add/Remove Properties Dialog Box", select the check box next to the property
name you want to add. To remove a property from the list, clear the corresponding check box.

Add identification properties to the test object class
To add a new property to the test object class, open the "Add/Remove Properties Dialog Box" and
click New. TheNew Property dialog box opens. Enter a valid property in the format
attribute/<PropertyName> (forWeb objects) or <PropertyName> (for other environment objects)
and click OK. The new property is added to the available properties list.
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How to Map an Unidentified or Custom Class to a
Standard Windows Class

Relevant for: GUI tests and components

This task describes how tomap an unidentified or custom class to a standardWindows class. This
instructs UFT to identify objects of the specified class in the sameway as it identifies objects of the
Windows class to which it is mapped.

To map an unidentified or custom class to a standard Windows class:

1. Open the "Object Mapping Dialog Box" (described on page 1330) by selectingStandard
Windows in theEnvironment box in the Object Identification dialog box and then clicking the
User-Defined button.

2. Click the pointing hand and then click the object whose class you want to add as a user-
defined test object class. The name of the user-defined object is displayed in theClass name
box.

For details on using the pointing hand, see "Tips for Using the Pointing Hand" on page 1196.

3. In theMap to box, select the standard object class to which you want to map your user-defined
test object class and click Add. The class name andmapping is added to the object mapping
list.

4. Click OK. TheObject Mapping dialog box closes and your object is added to the list of
standardWindows test object classes as a user-defined test object class. Note that your
object has an icon with a redU in the lower-right corner, identifying it as a user-defined class.

5. Configure the object identification settings for your user defined test object class just as you
would any other test object class. For details, see "How to Configure Object Identification for a
Test Object Class" on page 1322.

Caution: If you click the down arrow on theReset Test Object button and select Reset
Environment, whenStandard Windows is selected in theEnvironment box, all of the
user-defined test object classes are deleted.
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Reference

Object Identification Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to set mandatory and assistive properties, to select the ordinal
identifier, and to specify whether you want to enable the Smart Identificationmechanism for each
test object class.

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or component node or one of its
child nodes.

2. Select Tools > Object Identification.
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Important
information

l Only currently loaded environments are listed in theEnvironments box.

l You cannot include the same property in both themandatory and assistive
property lists.

l Any changes youmake in the Object Identification dialog box have no effect on
objects already added to existing object repositories. To update the test
objects in the object repository, run the test or component in Update RunMode
using theUpdate test object descriptions option. For details, see "Update
Options Tab (Update Run Dialog Box)" on page 1107.

l The learned and Smart Identification properties of certain classes cannot be
configured, for example, VbLabel objects. Such classes are therefore not
included in the Test Object classes list for the selected environment.

l Insight test objects are not available in this dialog box.

Relevant
tasks

"How to Configure Object Identification for a Test Object Class" on page 1322

See also "Object Identification Configuration - Overview" on page 1311

User interface elements are described below:

UI Elements Description

Environment The list of environments, according to the loaded add-ins. This list may also
include additional environments for which you or a third party developed support
using UFT Add-in Extensibility.

For details on loading UFT add-ins or on UFT Add-in Extensibility, see the
relevant sections in theHP Unified Functional Testing Add-ins Guide.

Test Object
classes

The list of the test object classes associated with the selected environment.

Note: InStandard Windows, the user-defined classes are displayed at the
bottom of the list.

Mandatory
Properties

The list of properties that UFT always learns as part of the description for test
objects of the selected class.

Assistive
Properties

The list of additional properties that UFT can learn for a test object of the
selected class to create a unique test object description.
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UI Elements Description

Up and Down arrows. Enable you to set the preferred order for theAssistive
Properties list.

When UFT learns an object, and assistive properties are necessary to create a
unique object description, UFT adds the assistive properties to the description
one at a time until it has enough information to create a unique description,
according to the order you set in theAssistive Properties list.

Add/Remove Enables you to add or remove properties for the test object class using the
"Add/Remove Properties Dialog Box"(described on page 1328).

Enable
Smart
Identification

Enables or disables Smart Identification for the selected test object class.

Configure Opens the "Smart Identification Properties Dialog Box" (described on page
1331), which enables you to specify the properties for UFT to learn as Smart
Identification Properties.

Enabled only when theEnable Smart Identification check box is selected.

Ordinal
identifier

The type of ordinal identifier to use when UFT needs to identify an object with an
otherwise identical description. The ordinal identifier enables UFT to assign a
serial order value to each of the otherwise identical objects. For details, see
"Ordinal Identifiers" on page 1312.

User-Defined Enables you tomap an unidentified or custom class to a standardWindows
class by opening the "Object Mapping Dialog Box". For details, see "Object
Mapping Dialog Box" on page 1330.

Note: To enable this option, youmust select theStandard Windows
environment from theEnvironment list.
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UI Elements Description

Reset Test
Object

The down arrow enables you to select one of the following options:

l Reset Test Object. Resets the selected test object to the system default.
(Default selection)

l Reset Environment. Resets the settings for all the test objects in the
current environment to the system default.

l Reset All. Resets the settings for all currently loaded environments to the
system default.

You can restore the default settings for object identification and the Smart
Identification property settings for all loaded environments, for the current
environment only, or for a selected test object, using theReset Test Object
option in the "Object Identification Dialog Box". For details, see "Object
Identification Dialog Box" on page 1325.

Only built-in object properties can be reset. When you reset the settings for the
standardWindows environment, user-defined objects are also deleted. For
details on user-defined objects, see "Test Object Mapping for Unidentified or
Custom Classes" on page 1321.

Generate
Script

Enables you to generate an automation script that sets the current object
identification settings.

When you click theGenerate Script button, a Save As dialog box opens,
enabling you to specify the name and file system location to store the generated
file.

You can use some or all of the script lines from this generated script in an
automation script. This can be useful, for example, if you to set the same object
identification settings onmultiple UFT computers.

For more details, see "UFT Automation Scripts" on page 1155 and theHP UFT
Automation Object Model Reference.

Add/Remove Properties Dialog Box

Relevant for: GUI tests and components

This dialog box enables you to set the properties you want to include in theMandatory, Assistive,
Base Filter, orOptional Filter Properties lists that are used to define the object identification
preferences for a selected test object class. You can also add new property names to the set of
usable properties.
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To access You can access this dialog box by clickingAdd/Remove in the following
dialog boxes:

l "Object Identification Dialog Box" (described on page 1325)

l "Smart Identification Properties Dialog Box" (described on page 1331)

Important
information

l You cannot add the same property to both themandatory and assistive
property lists.

l You cannot add the same property to both the base and optional filter
property lists.

Relevant tasks "How to Configure Object Identification for a Test Object Class" on page
1322

See also l "Object Identification Configuration - Overview" on page 1311

l "Smart Identification" on page 1316

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<Properties> list The list of available identification properties for the selected test object
class. For details, see "Add and remove properties to the object
identification property lists" on page 1323.
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UI Elements Description

New Enables you to add new identification properties to the available properties
list.

Enter a valid property in the format attribute/<PropertyName> (forWeb
objects) or <PropertyName> (for other environment objects).

UFT retrieves the property values from the object's native properties.
Therefore, the name of a new identification property must be identical to the
name of a native property. (In most environments, you can use theObject
Spy to view the list of available native properties.)

If you add a property to a Java test object, see the section on Java Add-in
considerations in theHP Unified Functional Testing Add-ins Guide.

Note: New properties are displayed in the Object Spy but are not
available for checkpoints on objects of the selected class.

For more details, see "Add identification properties to the test object class"
on page 1323.

Object Mapping Dialog Box
Relevant for: GUI tests and components

This dialog box enables you tomap an object of an unidentified or custom class to a standard
Windows test object class.
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To
access

In the "Object Identification Dialog Box" (described on page 1325), select the
Standard Windows environment, and click theUser Defined button.

Relevant
tasks

"How toMap an Unidentified or Custom Class to a StandardWindows Class" on
page 1324

See also "Test Object Mapping for Unidentified or Custom Classes" on page 1321

User interface elements are described below:

UI
Elements Description

Class
name

The name of the user-defined object selected by using thePointing Hand.

Pointing Hand. Enables you to add the object whose class you want to as a user-
defined class by minimizing the UFT window and navigating to the object. The name
of the user-defined object is displayed in theClass name box.

For details on using the pointing hand, see "Tips for Using the Pointing Hand" on
page 1196.

Map to The list of available standardWindows test object classes tomap to the user-
defined object.

Add Enables you to add the selected class name andmapping in the object mapping list
with values set in theClass Name andMap to fields.

Update Enables you to update the selected class name andmapping in the object mapping
list with new values set in theClass Name andMap to fields.

Delete Enables you to delete the selected class name andmapping from the object
mapping list.

Smart Identification Properties Dialog Box
Relevant for: GUI tests and components

The Smart Identification dialog box enables you to configure the Smart Identificationmechanism for
the selected test object class.
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To access In the "Object Identification Dialog Box" (described on page 1325), select an
environment and a test object class, select Enable Smart Identification, and
click Configure.

Important
information

By default, some test object classes already have Smart Identification
configurations and others do not. Those with default configurations also have the
Enable Smart Identification check box selected by default in the "Object
Identification Dialog Box" (described on page 1325).

See also "Smart Identification" on page 1316

User interface elements are described below:

UI Elements Description

Base Filter
Properties

The list of properties that UFT learns as base filter properties for this test object
class. The Smart Identificationmechanism uses these properties to create a list
of possible candidate objects.

Optional
Filter
Properties

The list of properties that UFT learns as optional filter properties for this test
object class. The Smart Identificationmechanism uses these properties in the
specified order to narrow down the object candidate list to one object.

Up and Down arrows. Enable you to set the preferred order for theOptional
Filter Properties list.

When UFT uses Smart Identification, it creates a list of possible candidate
objects according theBase Filter Properties, and then checks the values of
theOptional Filter Properties one by one according to the order you set, until it
narrows down the candidate list to one object.

Add/Remove Opens the "Add/Remove Properties Dialog Box", enabling you tomodify the list
of properties learned for Smart Identification for this test object class. For
details, see "Add/Remove Properties Dialog Box" on page 1328.
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Chapter 47: Object Repository Comparison Tool
Relevant for: GUI tests and components

This chapter includes:

Concepts 1334

Object Repository Comparison Tool Overview 1334

Tasks 1336

How to Compare TwoObject Repositories 1336

Reference 1338

Object Repository Comparison Tool MainWindow 1338

New Comparison Dialog Box 1349
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Concepts

Object Repository Comparison Tool Overview
Relevant for: GUI tests and components

TheObject Repository Comparison Tool enables you to compare two shared object repositories,
and view the differences in their objects, such as different object names, different test object
descriptions, and so on. The tool is accessible from theObject Repository Manager.

Differences between objects in the two object repository files are identified according to default
rules. During the comparison process, the object repository files remain unchanged. For details
about the types of comparisons identified by the Object Repository Comparison Tool, see
"Understanding Object Differences" on page 1347.

After the comparison process, the Comparison Tool provides a graphic presentation of the objects
in the object repositories, which are shown as nodes in a hierarchy. Objects that have differences,
as well as unique objects that are included in one object repository only, can be identified according
to a color configuration that you can specify. Objects that are included in one object repository only
are indicated in the other object repository by the text "Does not exist". You can also view the
properties and values of each object that you select in either object repository.

You can use the information displayed by the Object Repository Comparison Tool whenmanaging
or merging object repositories. For details, see "Object Repository Merge Tool" on page 1351.

This section also includes:

l "When to Use theObject Repository Comparison Tool" below

l "Understanding the Repository Panes" below

When to Use the Object Repository Comparison Tool
In addition to this tool, you can perform merge and comparison operations using the Asset
Comparison Tool and the Object Repository Merge Tool. Consider the following when selecting
which tool to use:

l TheObject Repository Comparison Tool is designed for comparing repositories that are
different, but have a set of overlapping objects. This tool is useful if you want to decide whether
to merge two repositories without performing the actual merge and addressing object conflicts in
the Object Repository Merge Tool. For details, see "How to Compare TwoObject Repositories"
on page 1336 and "Object Repository Merge Tool" on page 1351.

l The Asset Comparison Tool can also compare two repositories, but it is designed for comparing
different versions of the same repository to identify changes between versions. For details, see
"Viewing and Comparing Versions of UFT Assets" on page 770.

Understanding the Repository Panes
The object repository panes of the Object Repository Comparison Tool display the hierarchies of
the objects, and their properties and values, in the object repository files that you are comparing.
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The file path is shown above each object hierarchy.

Tomake it easier to see the status of an object at a glance, the text and background of object
names in the object repositories are displayed using different colors, according to the type of
comparison found.

TheObject Repository Comparison Tool enables you to navigate the two object repositories
independently. You can also resize the various panes to display only some of the objects contained
in the object repositories. When using large object repositories, this can result in the various panes
displaying different areas of the object repository hierarchies, making it difficult to locate and track
specific objects affected by the comparison process. You can synchronize the object repositories
to display the same object in both views.
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Tasks

How to Compare Two Object Repositories
Relevant for: GUI tests and components

This task describes how to compare two object repositories according to predefined settings that
define how comparisons between objects are identified.

This task includes the following steps:

l "Prerequisites" below

l "Select the SharedObject Repositories to compare" below

l "Analyze the initial comparison results" below

l "Analyze the detailed comparison results" on the next page

l "Utilize additional tools to help you perform the comparison - Optional" on the next page

1. Prerequisites
n Determine the shared object repositories you want to compare. Generally, shared object

repositories should contain objects from the same application, andmay have differences in
objects or test object descriptions because the repositories were created at different times
or under different circumstances.

n Make sure that a GUI test or component is currently open.

n Make sure that the Object Repository Manager window is open. For details on working with
the Object Repository Manager, see "Object Repository Manager MainWindow" on page
1297.

n Make sure the color settings are configured tomatch your needs. For details, see "Color
Settings Dialog Box (Object Repository Comparison Tool) " on page 1348.

2. Select the Shared Object Repositories to compare
a. In the Object Repository Manager window, select Tools > Object Repository

Comparison Tool to open theObject Repository Comparison Tool. The "New
Comparison Dialog Box" (described on page 1349) opens.

b. Specify the two object repository files you want to compare.

3. Analyze the initial comparison results
After the comparison is complete, you can view the results summary in the "Comparison
Statistics Dialog Box" (described on page 1346).
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4. Analyze the detailed comparison results
Review and analyze the comparisons between the repositories in the "Object Repository
Comparison Tool MainWindow" (described on page 1346).

5. Utilize additional tools to help you perform the comparison - Optional
n Synchronize the object repositories to display the same object in both views by clicking the

Synchronized Nodes button using the "Menu Commands and Toolbar Buttons" (described
on page 1339).

n Filter the objects and show only the objects that you want to view using the "Filter Dialog
Box (Object Repository Comparison Tool)" (described on page 1342).

n Locate one or more objects in a selected object repository whose name contains a specified
string using the "Find Dialog Box (Object Repository Comparison Tool)" (described on page
1344).

n Adjust the colors of text and background of object names, and empty nodes representing
objects that exist in the other object repository only, using the "Color Settings Dialog Box
(Object Repository Comparison Tool) " (described on page 1348).

User Guide
Chapter 47: Object Repository Comparison Tool

HP Unified Functional Testing (12.00) Page 1337 of 2274



Reference

Object Repository Comparison Tool Main Window
Relevant for: GUI tests and components

This window displays the two repositories selected for comparison and provides tools for analyzing
the comparison.

To access In theObject Repository Manager, select
Tools > Object Repository Comparison Tool.

Important
information

l You cannot work with the Object Repository Manager or the Object Repository
Merge Tool while the Object Repository Comparison Tool is open.

l TheObject Repository Comparison Tool gives precedence tomatching test
object descriptions over thematching of test object names.

Relevant
tasks

"How to Compare TwoObject Repositories" on page 1336
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TheObject Repository Comparison Tool window contains the following key elements:

l "Menu Commands and Toolbar Buttons" below

l "Repository Panes" on the next page

l "Test Object Details Areas" on page 1341

l "Status Bar" on page 1341

Menu Commands and Toolbar Buttons
File Menu

Command
Shortcut
Key Function

New
Comparison

CTRL+N Opens the "New Comparison Dialog Box" (described on page
1349), enabling you to specify two object repositories on which to
perform a new comparison operation.

ALM
Connection

Enables you to connect the Object Repository Comparison Tool to
an ALM project. For details, see "ALM Connection Dialog Box" on
page 737.

Exit Closes the Object Repository Comparison Tool window.

View Menu

Command Function

Statistics Opens the "Comparison Statistics Dialog Box" (described on page 1346), which
summarizes the comparison between the two repositories, including the number
and type of any differences found.

Collapse
All

Collapses the entire hierarchy in both comparison panes.

Tip:WhileSynchronized Nodes is on, double-clicking an expanded node
collapses it in both panes simultaneously.

Expand
All

Expands the entire hierarchy in both comparison panes.

Tip: Double-clicking a collapsed node expands it in both panes
simultaneously.
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NavigateMenu

Command
Shortcut
Key Function

Next
Difference

F4 Finds the next difference between objects in the object repositories.

Previous
Difference

SHIFT
+F4

Finds the previous difference between objects in the object
repositories.

Find CTRL+F Opens the "Find Dialog Box (Object Repository Comparison Tool)"
on page 1344 (described on page 1344).

Find Next F3 Finds the next object in the object repositories according to the
search specifications in the Find dialog box.

Find
Previous

SHIFT
+F3

Finds the previous object in the object repositories according to the
search specifications in the Find dialog box.

Tools Menu

Command Function

Synchronized
Nodes

Enables you to navigate the two object repository panes simultaneously or
independently of one another.

Filter Opens the "Filter Dialog Box (Object Repository Comparison Tool)"
(described on page 1342), enabling you to specify the comparison types that
you want to show.

Color
Settings

Opens the "Color Settings Dialog Box (Object Repository Comparison Tool) "
(described on page 1348), enabling you to specify the text and background
color of the object names and empty nodes displayed in the comparison
panes.

HelpMenu

Command
Shortcut
Key Function

Object Repository Comparison
Tool Help

F1 Opens the Object Repository Comparison
Tool Help.

Repository Panes
The repository panes display a hierarchical view of the objects in the object repositories being
compared. The differences and similarities between objects in the two panes are indicated by
colored text and background colors for each object.
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Differences can also be identified by the icons displayed to the left of the objects in the object
repository panes, as follows:

UI
Elements Description

The number of objects that are unique to the first file.

The number of objects that are unique to the second file.

The number of objects in the first and second file that are not identical, but partially
match.

For details on all comparison types, see "Understanding Object Differences" on page 1347.

The object repository panes provide the following functionality:

l While inSynchronized Nodesmode, when you select an object in one object repository pane,
the corresponding object in the other file hierarchy is located and highlighted. You can press the
CTRL button when you select an object to highlight only the selected object without highlighting
the corresponding object in the other file.

l When you select an object in an object repository pane, its properties and values are displayed
in the respective Test object details area at the bottom of the pane.

l When you position your cursor over an icon to the left of an object in an object repository pane,
the comparison details are displayed as a tooltip, for example, Partial match, orUnique to
second file.

l You can expand or collapse the hierarchy of a parent node by double-clicking the node, or by
clicking the expand (+) or collapse (-) symbol to the left of the node name. You can also expand
or collapse the entire hierarchy in the object repository pane by choosingCollapse All or
Expand All from theViewmenu.

l You can jump directly to the next or previous difference in the object repository hierarchy by
choosingNext Difference orPrevious Difference from theNavigatemenu, by clicking the

Next Difference orPrevious Difference buttons in the toolbar, or by using keyboard
shortcuts. For details about shortcuts, see "Menu Commands and Toolbar Buttons" on page
1339.

l You can drag the edges of the panes to resize them in the Object Repository Comparison Tool
window.

Test Object Details Areas
Shows the properties and values of the object selected in an object repository pane. For details, see
"Understanding the Repository Panes" on page 1334.

Status Bar
Shows the status of the comparison process and details of the comparisons found during the object
repository comparison.

User Guide
Chapter 47: Object Repository Comparison Tool

HP Unified Functional Testing (12.00) Page 1341 of 2274



User interface elements of the status bar are described below (unlabeled elements are shown in
angle brackets):

UI Elements Description

<progress bar> Displays the comparison process status on the left of the status bar. Ready is
displayed when the process is complete.

ALM Connection. Displayed only when UFT is connected to an ALM project.

<filter> Opens the "Filter Dialog Box (Object Repository Comparison Tool)" below.
The icon image indicates the filter status of the repository panes.

Possible values:

l . Indicates that the object repositories are not filtered and all objects
are shown.

l . Indicates a filter is active and that some objects may have been
filtered out of the display.

The number of objects that are unique to the first file.

The number of objects that are unique to the second file.

The number of objects in the first and second file that are not identical, but
partially match.

This section also includes:

Filter Dialog Box (Object Repository Comparison Tool) 1342

Find Dialog Box (Object Repository Comparison Tool) 1344

Comparison Statistics Dialog Box 1346

Color Settings Dialog Box (Object Repository Comparison Tool) 1348

Filter Dialog Box (Object Repository Comparison Tool)

Relevant for: GUI tests and components

This dialog box enables you to filter objects in the repository panes of the "Object Repository
Comparison Tool MainWindow". For details, see page 1338.
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To access In the "Object Repository Comparison Tool MainWindow" on page 1338, do
one of the following:

l Select Tools > Filter.

l Click the Filter button in the toolbar.

Important
information

l To view all the objects in both object repositories, select all of the check
boxes.

l After closing the dialog box, the Filter icon in the status bar indicates the
filter status of the repository panes.

Possible values:

n . Indicates that the object repositories are not filtered and all
objects are shown.

n . Indicates a filter is active and that some objects may have been
filtered out of the display.

Relevant tasks "How to Compare TwoObject Repositories" on page 1336

See also "Understanding the Repository Panes" on page 1334

User interface elements are described below:

UI
Elements Description

Identical
objects

Instructs the Object Repository Comparison tool to display objects that appear in
both object repository files and have no differences in their name or in their
properties.

Unique
objects

Instructs the Object Repository Comparison tool to display objects that appear only
in the first or only in the second object repository file.

Partial
match
objects

Instructs the Object Repository Comparison tool to display objects that are similar
but have name or description differences.
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Find Dialog Box (Object Repository Comparison Tool)

Relevant for: GUI tests and components

This dialog box enables you to find objects in the selected object repository pane according to
predefined search criteria.

To access In the "Object Repository Comparison Tool MainWindow" (described on page
1338), click the object repository pane that contains the required object and do one
of the following:

l Select Navigate > Find.

l Click the Find button in the toolbar.

Important
information

After you set the Find options, you can close the Find dialog box and use toolbar
buttons or shortcut keys to navigate to the next or previous node that matches
your search criteria. For details, see "Menu Commands and Toolbar Buttons" on
page 1339.

Relevant
tasks

"How to Compare TwoObject Repositories" on page 1336

See also "Understanding the Repository Panes" on page 1334

User interface elements are described below:

UI
Elements Description

Object
name
contains

The full or partial name of the object you want to find.
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UI
Elements Description

Criteria The criteria to use to refine your search.

The following criteria are available:

l All objects

l Unique objects

l Partial match objects

l Unique or partial match objects

Match
case

Instructs the Object Repository Comparison tool to distinguish between upper-case
and lower-case characters in the search. WhenMatch case is selected, the
comparison finds only those occurrences with the exact capitalizationmatch to the
text you entered in theObject name contains box.

Match
whole
word

Instructs the Object Repository Comparison tool to search only for whole word
occurrences that match the text you entered in the Find Objects dialog box, and not
as part of larger words.

Direction The direction from the current cursor location in which you want to search. The
following options are available:

l Up

l Down

The Find operation continues to search the entire file after it reaches the beginning
or end of the object repository.

Find
Next

Highlights the next object that matches the specified criteria in the object repository.
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Comparison Statistics Dialog Box

Relevant for: GUI tests and components

This dialog box lists the quantity for each type of comparison identified by the Object Repository
Comparison Tool.

To access In the "Object Repository Comparison Tool MainWindow" on page 1338, do one
of the following:

l Select View > Statistics.

l Click theStatistics button in the toolbar.

Important
information

The icons displayed for each comparison type in the object statistics are the same
as those used in the object repository panes. For details, see "Understanding
Object Differences" on the next page.

Relevant
tasks

"How to Compare TwoObject Repositories" on page 1336

See also "Understanding the Repository Panes" on page 1334
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User interface elements are described below:

UI Elements Description

Object Statistics The number and type of objects meeting each comparison criteria.
Comparison types are described in "Understanding Object
Differences" below.

Open this dialog box
automatically after
comparisons

Indicates whether the Stastics dialog box is automatically displayed
every time theObject Repository Comparison Tool completes a
comparison.

Go to first difference When selected, the Comparison tool highlights the first difference in
the object repositories immediately after you close the Statistics
dialog box.

Understanding Object Differences
The Comparison Tool automatically identifies objects during the comparison process by classifying
them into one of the following types:

l Identical. Objects that are identical in both object repository files.

l Unique to first file, or Unique to second file. Objects that appear in only one of the object
repository files.

l Test objects with identical descriptions and different names. Test objects that appear in
both object repository files that have different names, but the same description properties and
values.

l Test objects with similar descriptions. Test objects that appear in both object repository files
that have similar, but not identical, description properties and values. One of the test objects
always has a subset of the properties set of the other test object. This implies that it is likely to
be a less detailed description of the same test object. For example, a test object namedButton
in the second object repository has the same description properties and values as a test object
namedButton in the first object repository, but also has additional properties and values.

Test objects that do not have any description properties, such as Page or Browser objects, are
compared by name only. If the same test object is contained in both object repositories but with
different names, they will be shown in the object repositories as two separate objects.

Note: Test objects with different visual relation identifier definitions are treated as objects
with different descriptions.

l Checkpoint or output objects with the same name and different content. This option is
relevant for checkpoint and output objects that are not completely identical for all settings.

l Does not exist. Objects that do not exist in one of the repository files, but do exist in the other
file.
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Object differences can also be viewed in the "Object Repository Comparison Tool MainWindow"
on page 1338, according to settings defined in the "Color Settings Dialog Box (Object Repository
Comparison Tool) " (described on page 1348).

Color Settings Dialog Box (Object Repository Comparison Tool)

Relevant for: GUI tests and components

This dialog box enables you to define text and background color settings to help differentiate
between the compared objects.

To access In the "Object Repository Comparison Tool MainWindow" (described on page
1338), do one of the following:

l Select Tools > Color Settings.

l Click theColor Settings button in the toolbar.

Relevant
tasks

"How to Compare TwoObject Repositories" on page 1336

See also "Understanding the Repository Panes" on page 1334
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<comparison types> The list of comparison options on the left side of the dialog box.
Difference types are described in "Understanding Object Differences"
on page 1347.

Test Color Displays the current color used for the object names matching the
corresponding comparison type.

Background Color Displays the current color used for the repository pane rows matching
the corresponding comparison type.

New Comparison Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to select two object repositories to compare.

To access In the "Object Repository Comparison Tool MainWindow" (described on page
1338), do one of the following:

l Select File > New Comparison.

l Click theNew Comparison button in the toolbar.

Note:This dialog box also opens automatically when you initially open the "Object
Repository Comparison Tool MainWindow" on page 1338.
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Important
information

l The object repository files can be located in the file system or ALM. By default,
the boxes display the last files selected for comparison.

l If you want to compare an object repository that was last saved using a version
of QuickTest earlier than version 9.0, youmust first open and save the
repository in the Object Repository Manager to update it to the new format.

l If you want to change the color settings before comparing the object
repositories, click Cancel to close the New Comparison dialog box, change
the settings as described in "How to Compare TwoObject Repositories" on
page 1336, and then perform the comparison.

Relevant
tasks

"How to Compare TwoObject Repositories" on page 1336

User interface elements are described below:

UI
Elements Description

First file The file path for the first object repository.

Second
file

The file path for the second object repository.

Warning icon. Displayed next to the relevant text box if you enter the name of a file
without a .tsr suffix, a file with an incorrect path, or a file that does not exist.

Tip:Position your pointer over the icon to see a tooltip explanation of the error.
Supply an existing .tsr file with the correct path.
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Chapter 48: Object Repository Merge Tool
Relevant for: GUI tests and components

This chapter includes:

Concepts 1352

Object Repository Merge Tool Overview 1352

Object Conflicts 1353

Tasks 1356

How toMerge Two SharedObject Repositories 1356

How to Update a SharedObject Repository From a Local Object Repository 1358

Reference 1361

New Merge Dialog Box 1361

Object Repository Merge Tool MainWindow 1363

Settings Dialog Box (Object Repository Merge Tool) 1374

Object Repository Merge Tool - Multiple MergeWindow 1378

Update from Local Repository Dialog Box 1381
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Concepts

Object Repository Merge Tool Overview
Relevant for: GUI tests and components

UFT enables you tomerge two shared object repositories into a single shared object repository
using the Object Repository Merge Tool.

This tool also enables you tomerge objects from the local object repository of one or more actions
or components into a shared object repository. For example, if UFT learned objects locally in a
specific action in your test or in a component, youmay want to add the objects to the shared object
repository, so that they are available to all actions (even in different tests) or components that use
that object repository.

When to Merge Shared Object Repositories
When you havemultiple shared object repositories that contain test objects from the same area of
your application, it may be useful to combine those test objects into a single object repository for
easier maintenance. You could do this by manually moving or copying objects in the Object
Repository Manager. However, if you have test objects in different object repositories that
represent the same object in your application, and the descriptions for these objects in the different
object repositories are not identical, it may be difficult to recognize and handle these conflicts.

TheObject Repository Merge Tool helps you to solve the above problem by merging two selected
object repositories for you, and providing options for addressing test objects with conflicting
descriptions. Using this tool, youmerge two shared object repositories (called the primary object
repository and the secondary object repository), into a new, third object repository, called the
target object repository. Objects in the primary and secondary object repositories are automatically
compared, and then added to the target object repository according to configurable rules that define
the defaults for how conflicts between objects are resolved.

After themerge process, the Object Repository Merge Tool provides a graphic presentation of the
original objects in the primary and secondary object repositories, which remain unchanged, as well
as the objects in themerged target object repository. Objects that had conflicts are highlighted. The
conflict of each object that you select in the target object repository is described in detail. The
Object Repository Merge Tool provides specific options that enable you to keep the default
resolution for each conflict, or modify conflict resolutions individually, according to your
requirements.

For more details, see "How toMerge Two SharedObject Repositories" on page 1356.

Note: If you want to compare two shared object repositories without merging, you can use the
Object Repository Comparison Tool. For details, see "Object Repository Comparison Tool
Overview" on page 1334.

When to Update a Shared Object Repository from Local Object
Repositories
You can update a shared object repository by merging local object repositories associated with
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specific components (via their application area), or with specific actions from one or more tests, into
the shared object repository. The objects that aremerged from the local object repositories are then
available to any components that use that shared object repository, or to any actions that use that
shared object repository in any tests.

In themerge process, the objects in the local object repository for the selected actions or
components aremoved to the target shared object repository (and then removed from the local
object repository). The action or component steps then use the objects from the updated shared
object repository.

You can view or change how conflicting objects are dealt with during the update process in the
"Settings Dialog Box (Object Repository Merge Tool)" (described on page 1374).

If you choose tomerge local object repositories frommore than one action or component, UFT
performs multiple merges, merging each action's or component's local object repository with the
target object repository one at a time, for all the actions or components in the list. You can view and
modify the results of eachmerge if necessary.

For more details, see "How to Update a SharedObject Repository From a Local Object Repository"
on page 1358.

Object Conflicts
Relevant for: GUI tests and components

Merging two object repositories can result in conflicts arising from similarities between the objects
they contain.

Conflicts between objects in the primary and secondary object repositories are resolved
automatically by the Object Repository Merge Tool, according to the default resolution settings that
you can configure before performing themerge. For details, see "Settings Dialog Box (Object
Repository Merge Tool)" on page 1374.

Conflicts between checkpoint or output value objects with the same name but different content are
always resolved by merging both objects into the new repository and renaming one of them.

TheObject Repository Merge Tool also allows you to change the way themerge was performed for
each individual object that causes a conflict.

Example

An object in the primary object repository could have the same name as an object in the
secondary object repository, but have a different description. Youmay have defined in the
default settings that in this case, the object with themore generic object description, meaning
the object with fewer properties, should be added to the target object repository. However,
when you review the conflicts after the automatic merge, you could decide to handle a specific
conflict differently, for example, by keeping both objects.

Changes that youmake to the default conflict resolution can themselves affect the target object
repository by causing new conflicts. In the above example, keeping both objects would cause a
name conflict. Therefore, the target object repository is updated after each conflict resolution
change and redisplayed.
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TheObject Repository Merge Tool identifies three possible conflict types:

Different Objects with the SameNameConflict 1354

Identical Description Different NameConflict (Test Objects Only) 1354

Similar Description Conflict (Test Objects Only) 1355

Different Objects with the Same Name Conflict

Relevant for: GUI tests and components

An object in the primary object repository and an object in the secondary object repository have the
same name, but completely different content.

You can resolve this conflict type by:

l Keeping the object added from the primary object repository only.

l Keeping the object added from the secondary object repository only.

l Keeping the objects from both object repositories. In this case, the Object Repository Merge
Tool automatically renames the object that is added from the secondary file by adding an
incremental numeric suffix to the name, for example, Edit_1.

l Ignoring the object from the local object repository and keeping the object from the shared object
repository (when updating a shared object repository from a local object repository).

By default, the conflict resolution settings for conflicts of this type are configured so that the target
object repository takes the object from both files. The object that is added from the secondary file is
renamed by adding an incremental numeric suffix to the name, for example, Edit_1. For details on
changing the default settings, see "Settings Dialog Box (Object Repository Merge Tool)" on page
1374.

Note: Test objects with different visual relation identifier definitions are treated as objects with
different descriptions.

Identical Description Different Name Conflict (Test Objects Only)

Relevant for: GUI tests and components

A test object in the primary object repository and a test object in the secondary object repository
have different names, but the same description properties and values.

You can resolve this conflict type by:

l Taking the test object name from the object in the primary object repository.

l Taking the test object name from the object in the secondary object repository.
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l Ignoring the test object from the local object repository and keeping the test object from the
shared object repository (when updating a shared object repository from a local object
repository).

By default, the conflict resolution settings for conflicts of this type are configured so that the target
object repository takes the object name from the primary source file. For details on changing the
default settings, see "Settings Dialog Box (Object Repository Merge Tool)" on page 1374.

Similar Description Conflict (Test Objects Only)

Relevant for: GUI tests and components

A test object in the primary object repository and a test object in the secondary object repository
have the same name, and they have similar, but not identical, description properties and values.
One of the test objects always has a subset of the properties set of the other test object. For
example, a test object namedButton in the secondary object repository has the same description
properties and values as a test object namedButton in the primary object repository, but also has
additional properties and values.

You can resolve this conflict type by:

l Keeping the test object added from the primary object repository only.

l Keeping the test object added from the secondary object repository only.

l Keeping the test objects from both object repositories. In this case, the Object Repository Merge
Tool automatically renames the test object that is added from the secondary file by adding an
incremental numeric suffix to the name, for example, Button_1.

l Ignoring the test object from the local object repository and keeping the test object from the
shared object repository (when updating a shared object repository from a local object
repository).

By default, the conflict resolution settings for conflicts of this type are configured so that the target
object repository takes the test object that has fewer identifying properties than the test object with
which it conflicts. For details on changing the default settings, see "Settings Dialog Box (Object
Repository Merge Tool)" on page 1374.
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Tasks

How to Merge Two Shared Object Repositories
Relevant for: GUI tests and components

This task describes how tomerge two shared object repositories according to predefined settings
that define how conflicts between objects are resolved.

This task includes the following steps:

l "Prerequisites" below

l "Select the shared object repositories tomerge " below

l "Analyze the initial merge results " on the next page

l "Analyze the detailedmerge results " on the next page

l "Utilize additional tools to help you perform the comparison (Optional)" on the next page

l "Adjust object conflict resolutions" on the next page

l "Save the target object repository" on the next page

l "Associate the target object repository with actions or application areas" on page 1358

1. Prerequisites
n Determine the shared object repositories you want to compare. You generally merge two

shared object repositories that contain objects from the same application, and that may
have differences in objects or test object descriptions because the repositories were created
at different times or under different circumstances.

n Make sure that a GUI test or component is in focus.

n Make sure that the Object Repository Manager window is open. For details on working with
the Object Repository Manager, see "Object Repository Manager MainWindow" on page
1297.

n Make sure the resolution and color settings are configured tomatch your needs. For details,
see "Resolution Tab (Settings Dialog Box - Object Repository Merge Tool)" on page 1375
and "Colors Tab (Settings Dialog Box - Object Repository Merge Tool)" on page 1377.

2. Select the shared object repositories to merge
a. In the Object Repository Manager window, select Tools > Object Repository Merge

Tool to open theObject Repository Merge Tool. The "New Merge Dialog Box" (described
on page 1361) opens.
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b. Specify the two object repository files you want to merge.

3. Analyze the initial merge results
After themerge is complete, you can view the results summary in the "Merge Statistics Dialog
Box (Object Repository Merge Tool)" (described on page 1370).

4. Analyze the detailed merge results
Review and analyze themerge between the repositories in the "Object Repository Merge Tool
MainWindow" (described on page 1363).

5. Utilize additional tools to help you perform the comparison (Optional)
n Change the view presented by the Object Repository Merge Tool according to your working

preferences, by dragging the edges of the panes to resize them, or selecting the appropriate
option from theViewmenu, as described in "Object Repository Merge Tool MainWindow"
on page 1363.

n Filter the objects and show only the objects that you want to view by using the "Filter Dialog
Box (Object Repository Merge Tool)" (described on page 1367).

n Locate one or more objects in a selected object repository whose name contains a specified
string using the "Find Dialog Box (Object Repository Merge Tool)" (described on page 1368).

6. Adjust object conflict resolutions
If one or more of themerge resolutions does not match your needs, follow the steps below to
adjust them:

a. In the target object repository, select an object that had a conflict, as indicated by the icon
to the left of the object name. The conflicting objects are highlighted in the source object
repositories.

A description of the conflict and the resolutionmethod used by the Object Repository
Merge Tool is described in the Resolution Options pane. A radio button for each possible
alternative resolutionmethod is displayed. For details on each of the conflict types, see
"Object Conflicts" on page 1353.

b. In the Resolution Options pane, select a radio button to choose an alternative resolution
method. The target object repository is updated according to your selection and
redisplayed.

c. In the Resolution Options pane, click thePrevious Conflict or Next Conflict buttons to
jump directly to the next or previous conflict in the target object repository hierarchy.

7. Save the target object repository
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When the object conflicts are resolved satisfactorily, save the new merged shared object
repository. UFT saves the object repository with a .tsr extension in the specified location and
displays the file name and path above the target object repository in the Object Repository
Merge Tool window.

If you are connected to ALM, you can save your merged shared object repository in the Test
Resources module of your project.

8. Associate the target object repository with actions or application areas
You can now associate the new merged object repository with actions or application areas,
especially ones that were previously associated with the original object repositories, so that
the objects in the object repository can be accessed by the tests or components.

How to Update a Shared Object Repository From a Local
Object Repository

Relevant for: GUI tests and components

This task describes how tomove the objects from local object repositories to a shared object
repository.

This task includes the following steps:

l "Prerequisites" below

l "Select the shared object repository and the local repositories that you want to merge into it" on
the next page

l "Analyze the initial merge results" on the next page

l "Analyze the detailedmerge results" on the next page

l "Utilize additional tools to help you perform the comparison (Optional)" on the next page

l "Adjust object conflict resolutions" on the next page

l "Save the target object repository" on page 1360

1. Prerequisites
n Make sure that the shared object repository you want to update from the local object

repositories is already associated with the repository actions or components.

n Make sure the tests or components containing the local object repositories are not part of an
open solution.

n Make sure that a GUI test or component is in focus.

n Make sure that the Object Repository Manager window is open. For details on working with
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the Object Repository Manager, see "Object Repository Manager MainWindow" on page
1297.

n Make sure the resolution and color settings are configured tomatch your needs. For details,
see "Resolution Tab (Settings Dialog Box - Object Repository Merge Tool)" on page 1375
and "Colors Tab (Settings Dialog Box - Object Repository Merge Tool)" on page 1377.

2. Select the shared object repository and the local repositories that you
want to merge into it
a. In the Object Repository Manager, open the shared object repository into which you want

to merge the local repositories. If the object repository opened in read-only mode, select
File > Enable Editing.

b. Select Tools > Update from Local Repository to open the "Update from Local
Repository Dialog Box" (described on page 1381).

c. In the "Update from Local Repository Dialog Box", select the tests or components that
contain the local object repositories you want to merge, and click Update All.

3. Analyze the initial merge results
View the initial merge results in the "Merge Statistics Dialog Box (Object Repository Merge
Tool)" on page 1370.

4. Analyze the detailed merge results
Review and analyze the detailedmerge results in the "Object Repository Merge Tool - Multiple
MergeWindow" on page 1378.

5. Utilize additional tools to help you perform the comparison (Optional)
n Change the view presented by the Object Repository Merge Tool according to your working

preferences, by dragging the edges of the panes to resize them, or selecting the appropriate
option from theViewmenu, as described in "Object Repository Merge Tool - Multiple Merge
Window" on page 1378.

n Filter the objects and show only the objects that you want to view by using the "Filter Dialog
Box (Object Repository Merge Tool)" (described on page 1367).

n Locate one or more objects in a selected object repository whose name contains a specified
string using the "Find Dialog Box (Object Repository Merge Tool)" (described on page 1368).

6. Adjust object conflict resolutions
If one or more of themerge resolutions does not match your needs, follow the steps below to
adjust them:

a. In the target object repository, select an object that had a conflict, as indicated by the icon
to the left of the object name. The conflicting object is highlighted in the local object
repository.
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A description of the conflict and the resolutionmethod used by the Object Repository
Merge Tool is described in the Resolution Options pane. A radio button for each possible
alternative resolutionmethod is displayed. For details on each of the conflict types, see
"Object Conflicts" on page 1353.

b. In the Resolution Options pane, select a radio button to choose an alternative resolution
method. The target object repository is updated according to your selection and
redisplayed.

c. In the Resolution Options pane, click thePrevious Conflict or Next Conflict buttons to
jump directly to the next or previous conflict in the target object repository hierarchy.

7. Save the target object repository
When the object conflicts are resolved satisfactorily, save the new merged shared object
repository. UFT saves the object repository with a .tsr extension in the specified location and
displays the file name and path above the target object repository in the Object Repository
Merge Tool window.

If you are connected to ALM, you can save your merged shared object repository in the Test
Resources module of your project.

Note: The objects that aremerged into the shared object repository are removed from the
local object repositories. The steps in the actions or components then use the objects from
the updated shared object repository.
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Reference

New Merge Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to select two object repositories tomerge.

To access In the "Object Repository Merge Tool MainWindow" (described on page 1363), do
one of the following:

l Select File > New Merge.

l Click theNew Merge button in the toolbar.

Note: This dialog box also opens automatically when you initially open the
"Object Repository Merge Tool MainWindow" on page 1363.

Important
information

l An object repository that is currently open by another user is locked. If you try
to merge a locked file, a warningmessage displays, but you can still perform
themerge because themerge process does not modify the source files. Note
that changes made to the locked file by the other user may not be included in
themerged object repository.

l If this dialog box opens automatically, but you want to change the configured
settings beforemerging the object repositories, click Cancel to close the New
Merge dialog box, change the settings as described in "Settings Dialog Box
(Object Repository Merge Tool)" on page 1374, and then open this dialog box
again to perform themerge.

l To improve efficiency of themerge process, select as your primary object
repository the object repository in which you have invested themost effort,
meaning the object repository with more objects, object properties, and values.

Relevant
tasks

"How toMerge Two SharedObject Repositories" on page 1356
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User interface elements are described below:

UI
Elements Description

Primary
file

The file system or ALM path for the first object repository.

Secondary
file

The file system or ALM path for the second object repository.

Warning icon. Displayed next to the relevant text box if you enter the name of a
file without a .tsr suffix, a file with an incorrect path, or a file that does not exist.

Tip: Position your pointer over the icon to see a tooltip explanation of the error.
Supply an existing .tsr file with the correct path.
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Object Repository Merge Tool Main Window
Relevant for: GUI tests and components

This window displays the two repositories selected for merging and the target repository containing
themerged content. This window also provides tools for analyzing themerge and resolving
conflicts.

To access In theObject Repository Manager, select
Tools > Object Repository Merge Tool.

Important
information

l You cannot work with the Object Repository Manager or the Object Repository
Comparison Tool while the Object Repository Merge Tool is open.

l Test objects that do not have description properties, such as Page or Browser
objects, are compared by name only. If the same object is contained in both
the source object repositories but with different names, they will bemerged
into the target object repository as two separate objects.

Relevant
tasks

"How toMerge Two SharedObject Repositories" on page 1356
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TheObject Repository Merge Tool main window contains the following key elements:

l "Menu Bar and Toolbar" below

l "Target Repository Pane" below

l "Primary and Secondary Repository Panes" on the next page

l "Resolution Options Pane" on the next page

l "Status Bar" on page 1366

Menu Bar and Toolbar
Displays menus with Object Repository Merge Tool commands. These commands are described in
"Object Repository Merge Tool Menu Commands and Toolbar Buttons" on page 1371.

Target Repository Pane
The target object repository pane displays a hierarchy of the objects, as well as their respective
properties and values, that weremerged from the primary and secondary object repositories. In the
column to the left of the object hierarchy, the pane displays the source file of each object (1 is
displayed for the primary file and 2 for the secondary file), and an icon representing the type of
conflict, if any.

When you save the target object repository, the file path is displayed above the object hierarchy.

Note: Tomake it easier to see the status of an object at a glance, the text colors of the object
names in the target object repository can be set according to their source and whether they
caused a conflict. For details, see "Colors Tab (Settings Dialog Box - Object Repository Merge
Tool)" on page 1377.

Merging two object repositories can result in a target object repository containing a large number of
objects. Tomake navigation and the location of specific objects easier in the target object
repository pane, the Object Repository Merge Tool enables you to filter the objects in the pane and
show only the objects that had conflicts that were resolved during themerge.

The target object repository pane provides the following functionality:

l When you select an object in the target object repository, the corresponding object in the primary
and/or secondary source file hierarchy is located and indicated by a check mark.

l When you select an object in the target object repository, its properties and values are displayed
in theObject Properties - Target File area at the bottom of the target object repository pane
(View > Target Repository Object Properties).

l If themerge results in a conflict, an icon is displayed to the left of the conflicting object in the
target object repository. You can see a tooltip description of the conflict type by positioning your
pointer over the icon.

l When you right-click an object, a context-sensitivemenu opens. You can expand an option or
collapse the entire hierarchy in the target object repository, or, when applicable, you can change
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the conflict resolutionmethod and result.

l You can expand or collapse the hierarchy of the node by double-clicking a node. You can also
expand or collapse the entire hierarchy in the target object repository by choosingCollapse All
or Expand All from theViewmenu.

l You can jump directly to the next or previous conflict in the target object repository hierarchy by
choosingNext Conflict orPrevious Conflict from theNavigatemenu, or by clicking theNext

Conflict orPrevious Conflict buttons in the toolbar or Resolution Options pane.

l You can locate one or more objects in the target object repository by using the "Find Dialog Box
(Object Repository Merge Tool)" (described on page 1368).

l You can show or hide the target object repository object properties by choosingView > Target
Repository Object Properties.

Primary and Secondary Repository Panes
The primary and secondary object repository panes display the hierarchies of the objects, and their
properties and values, in the original source object repositories that you chose tomerge. The file
path is shown above each object hierarchy.

The panes provide the following functionality:

l You can expand or collapse the hierarchy of a selected item by double-clicking the item.

l You can view the properties and values of an object in the Test object details area by selecting
it in the relevant pane.

l You can show or hide the panes by selecting or clearingPrimary Repository or Secondary
Repository in theViewmenu.

Resolution Options Pane
The Resolution Options pane provides information about any conflict encountered during themerge
for the object selected in the target object repository. The pane also provides options that enable
you to keep or change the conflict resolutionmethod that was applied using the default resolution
options.

The Resolution Options pane provides the following functionality:

l When you select a conflicting object in the target object repository, the pane displays a textual
description of the conflict and the resolutionmethod used by the Object Repository Merge Tool.
A choice of alternative resolutionmethods is offered.

l You can select a radio button to choose an alternative resolutionmethod for the conflict. Every
time youmake a change, the target object repository is automatically updated and is
redisplayed.

l You can jump directly to the next or previous conflict in the target object repository hierarchy by
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clicking thePrevious Conflict or Next Conflict buttons.

l For a local object repository merge, you can click the Ignore Object button to exclude a specific
local object repository object from themerge process. The object remains in the local object
repository when themerge is complete.

l You can show or hide the pane by selecting or clearingResolution Options in theViewmenu.

Status Bar
The status bar shows the following UI elements (unlabeled elements are shown in angle brackets):

UI
Elements Description

Conflict
number

The conflict number (if any) of the object selected in the target object repository
pane.

<progress
bar>

Displayed during themerge process. Ready is displayed when themerge is
complete.

Filter. Displays the filter status of the target object repository pane. Possible
states:

l ON. Indicated that a filter is currently in use.

l OFF. indicates that the object repositories are not filtered and all objects are
shown.

Note: Note:Click the Filter icon to open the "Filter Dialog Box (Object
Repository Merge Tool)" on the next page.

ALM Connection. Displayed when UFT is connected to an ALM project.

Similar Description Conflict. For details on object conflicts, see "Object
Conflicts" on page 1353.

Same Name Different Description Conflict. For details on object conflicts, see
"Object Conflicts" on page 1353.

Same Description Different Name Conflict. For details on object conflicts, see
"Object Conflicts" on page 1353.

This section also includes:

l "Filter Dialog Box (Object Repository Merge Tool)" on the next page

l "Find Dialog Box (Object Repository Merge Tool)" on page 1368
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l "Merge Statistics Dialog Box (Object Repository Merge Tool)" on page 1370

l "Object Repository Merge Tool Menu Commands and Toolbar Buttons" on page 1371

Filter Dialog Box (Object Repository Merge Tool)

Relevant for: GUI tests and components

This dialog box enables you to filter the target repository pane in the "Object Repository Merge Tool
MainWindow" (described on page 1363).

To access In the "Object Repository Merge Tool MainWindow" on page 1363 , do one of the
following:

l Select Tools > Filter.

l Click the Filter button in the toolbar.

Important
information

The filter only affects which objects are displayed in the target object repository
pane. It does not affect which objects are included in the target object repository.

Relevant
tasks

"How toMerge Two SharedObject Repositories" on page 1356

User interface elements are described below:

UI Elements Description

Show all objects Instructs the Object Repository Merge Tool to display all objects in the
target object repository

Show only
conflicting objects

Instructs the Object Repository Merge Tool to display only objects in the
target object repository that have conflicts.
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Find Dialog Box (Object Repository Merge Tool)

Relevant for: GUI actions and components

This dialog box enables you to find objects in the target object repository pane according to
predefined search criteria. The located object is also highlighted in the relevant primary and/or
secondary object repositories.

To access In the "Object Repository Merge Tool MainWindow" (described on page 1363), do
one of the following:

l Select Navigate > Find.

l Click the Find button in the toolbar.

Important
information

After you set the Find options, you can close the Find dialog box and usemenu
commands or toolbar buttons to navigate to the next or previous node that
matches your search criteria. For details, see "Object Repository Merge Tool
Menu Commands and Toolbar Buttons" on page 1371.

Relevant
tasks

l "How toMerge Two SharedObject Repositories" on page 1356

l "How to Update a SharedObject Repository From a Local Object Repository"
on page 1358

See also "Object Conflicts" on page 1353

User interface elements are described below:

UI
Elements Description

Object
name
contains

The full or partial name of the object you want to find.
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UI
Elements Description

Criteria The criteria to use to refine your search.

The following criteria are available:

l All objects

l Objects from one source

l Objects with conflicts

l Objects with conflicts or from one source

Match
case

Instructs the Object Repository Merge Tool to distinguish between upper-case and
lower-case characters in the search. WhenMatch case is selected, UFT finds only
those occurrences with the exact capitalizationmatch to the text you entered in the
Object name contains box.

Match
whole
word

Instructs the Object Repository Merge Tool to search only for whole word
occurrences that match the text you entered in the Find Objects dialog box, and not
as part of larger words.

Direction The direction from the current cursor location in which you want to search. The
following options are available:

l Up

l Down

The Find operation continues to search the entire file after it reaches the beginning
or end of the object repository.

Find
Next

Highlights the next object that matches the specified criteria in the target object
repository.
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Merge Statistics Dialog Box (Object Repository Merge Tool)

Relevant for: GUI tests and components

This dialog box displays the result of themerge, and the number and type of any conflicts that were
resolved during themerge.

To access In the "Object Repository Merge Tool MainWindow" on page 1363 , do one of the
following:

l Select View > Statistics.

l Click theStatistics button in the toolbar.

Important
information

l The Statistics dialog box shown after performing an Update from Local
Repository merge differs slightly from the dialog box shown above.

Relevant
tasks

l "How toMerge Two SharedObject Repositories" on page 1356

l "How to Update a SharedObject Repository From a Local Object Repository"
on page 1358
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User interface elements are described below:

UI
Elements Description

Conflicts
Found

The number and type of any conflicts between the objects added to the target object
repository. Conflict types are described in "Object Conflicts" on page 1353.

Merge
Summary

The number of objects merged from each object repository during themerge.

Go to
first
conflict

When selected, the Object Repository Merge Tool highlights the first conflict in the
target object repository immediately after you close the Statistics dialog box.

Object Repository Merge Tool Menu Commands and Toolbar
Buttons

Relevant for: GUI tests and components

The tables below describe commands available for:

l The "Object Repository Merge Tool MainWindow" (described on page 1363), for merging two
shared object repositories.

l The "Object Repository Merge Tool - Multiple MergeWindow" (described on page 1378), for
updating objects from local object repositories.

File Menu

Command
Shortcut
Key Function

New Merge
(shared object
repositories
merge only)

CTRL+N Enables you to specify two object repositories with which to
perform a new merge operation.

Save
(shared object
repositories
merge only)

CTRL+S Saves themerged shared object repository.

Save As
(shared object
repositories
merge only)

Opens the Save SharedObject Repository window, enabling
you to specify a name, file type, and storage location for the
merged shared object repository.
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Command
Shortcut
Key Function

Save and
Merge Next
(update from
local repository
only)

Whenmergingmultiple local object repositories, saves the
current merge andmerges the next local object repository.

Revert to
Original
Merged Files
(update from
local repository
only)

Cancels any manual conflict resolution adjustments and returns
the target object repository to the original state at the time of the
merge.

ALM
Connection

Enables you to connect UFT to an ALM project. For details, see
"ALM Connection Dialog Box" on page 737.

Exit Closes the Object Repository - Merge Tool window. If you did
not yet save themerged repository, you are prompted to save it.

View Menu

Command Function

Primary
Repository

Displays the "Primary and Secondary Repository Panes" on page 1365 pane,
containing a hierarchical view of the objects from the first source object
repository that you chose tomerge. Also displays the details for each object
selected in this pane. For details, see "Primary and Secondary Repository
Panes" on page 1365 and "New Merge Dialog Box" on page 1361.

Secondary
Repository
(shared
object
repositories
merge only)

Displays the "Primary and Secondary Repository Panes" on page 1365 pane,
containing a hierarchical view of the objects from the second source object
repository that you chose tomerge. Also displays the details for each object
selected in this pane. For details, see "Primary and Secondary Repository
Panes" on page 1365 and "New Merge Dialog Box" on page 1361.

Target
Repository
Object
Properties

Displays the Object Properties - Target File pane, which displays the details for
each test object selected in the target repository pane. For details, see "Target
Repository Pane" on page 1364.

Resolution
Options

Displays the Resolution Options pane, which provides information about any
conflict that occurred during themerge. For details, see"Resolution Options
Pane" on page 1365 and"Object Conflicts" on page 1353.
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Command Function

Restore
Default
Layout

Restores the view that you saved using theSet as Default Layout option
(described below). This is useful if you resize a pane, or show or hide specific
panes and then want to restore your saved view. For details, see "Object
Repository Merge Tool Menu Commands and Toolbar Buttons" on page 1371.

Set as
Default
Layout

Enables you to save the current view so that each time you open theObject
Repository - Merge Too, this view is displayed. If you later modify this view by
resizing panes, or showing or hiding them, you can restore your default view
using theRestore Default Layout option (described above). For details, see
"Object Repository Merge Tool Menu Commands and Toolbar Buttons" on page
1371.

Statistics Opens the "Merge Statistics Dialog Box (Object Repository Merge Tool)"
(described on page 1370), which describes how the files weremerged, and the
number and type of any conflicts that were resolved during themerge.

Collapse
All

Collapses the entire hierarchy in the Target Object Repository pane.

Tip: You can collapse a single node by double-clicking it.

Expand
All

Expands the entire hierarchy in the Target Object Repository pane.

Tip: You can expand a single node by double-clicking it.

Navigate Menu

Command
Shortcut
Key Function

Next
Conflict

F4 Navigates to the next conflicting object in themerged object
repository.

Previous
Conflict

SHIFT
+F4

Navigates to the previous conflicting object in themerged object
repository.

Find CTRL+F Opens the "Find Dialog Box (Object Repository Merge Tool)"
(described on page 1368).

Find Next F3 Navigates to the next object in themerged object repository
according to the search specifications in the "Find Dialog Box (Object
Repository Merge Tool)" (described on page 1368).

Find
Previous

SHIFT
+F3

Navigates to the previous object in themerged object repository
according to the search specifications in the Find dialog box.
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Tools Menu

Command Function

Settings Opens the "Settings Dialog Box (Object Repository Merge Tool)" (described on
page 1374), enabling you to:

l Configure how theObject Repository Merge Tool deals with conflicting
objects during amerge

l Specify the text color of the object names displayed in the target object
repository

Filter Opens the "Filter Dialog Box (Object Repository Merge Tool)" (described on page
1367), enabling you to show all of the objects in the Target Repository pane, or to
show only the objects that had conflicts that were resolved during themerge.

Help Menu

Command
Shortcut
Key Function

Object Repository Merge Tool
Help

F1 Opens the Object Repository Merge Tool
Help.

Settings Dialog Box (Object Repository Merge Tool)
Relevant for: GUI tests and components

TheObject Repository Merge Tool uses predefined settings whenmerging object repositories or
when updating a shared object repository from local object repositories.

You can change these settings at any time. After you change the settings, all new merges are
performed according to the new settings.

The Settings dialog box contains the following tabs:

l Resolution Tab (described on page 1375). Enables you to configure how theObject Repository
Merge Tool deals with conflicting objects in the primary and secondary object repositories (or
local and shared object repositories when updating a shared object repository from local object
repositories).

l Colors Tab (described on page 1377). Enables you to specify the text color of the object names
that are displayed in the target object repository.

Tip: If the New Merge dialog box opens when you open theObject Repository Merge Tool,
and you want to change the settings beforemerging two object repositories, click Cancel to
close the New Merge dialog box, change the settings as described in the next sections, and
then open this dialog box again to perform themerge.
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Resolution Tab (Settings Dialog Box - Object Repository Merge
Tool)

Relevant for: GUI tests and components

This tab enables you to configure how theObject Repository Merge Tool automatically deals with
conflicting objects during themerge process or when performing anUpdate from Local
Repository operation.

To access In the "Object Repository Merge Tool MainWindow" on page 1363 , do one of the
following:

l Select Tools > Settings, and select theResolution tab.

l Click theSettings button in the toolbar, and select theResolution tab.
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Important
information

l The resolution settings are relevant only for test objects. Conflicts between
checkpoint or output value objects with the same name but different content
are always resolved by merging both objects into the new repository and
renaming one of them.

l When updating a shared object repository from a local object repository, the
object repositories are referred to as the Local and Shared object repository.

l If youmake any change to the resolution settings while amerged object
repository is open, you are asked whether you want to merge the open files
again with the new settings. If you click No, the new settings will apply only to
futuremerges.

Relevant
tasks

l "How toMerge Two SharedObject Repositories" on page 1356

l "How to Update a SharedObject Repository From a Local Object Repository"
on page 1358

See also l "Object Conflicts" on page 1353

l "Colors Tab (Settings Dialog Box - Object Repository Merge Tool)" on the next
page

User interface elements are described below:

UI
Elements Description

Take test
object
description
that is

Specifies how to resolve conflicts in which two test objects have the same name,
but their descriptions differ. You can specify that the target object repository takes
the test object description that is more generic or less generic, as follows:

l More generic. Instructs the Object Repository Merge Tool to take the test
object that has fewer identifying properties than the test object with which it
conflicts, or uses regular expressions in its property values. This is the default
setting.

l Less generic. Instructs the Object Repository Merge Tool to take the test
object that has all the identifying properties of the test object with which it
conflicts, plus additional identifying properties.

User Guide
Chapter 48: Object Repository Merge Tool

HP Unified Functional Testing (12.00) Page 1376 of 2274



UI
Elements Description

Take test
object
name from

Specifies how to resolve conflicts where two test objects have the same or similar
descriptions, but their names differ. You can select the source from which the
target test object repository takes the object name, as follows:

l Primary repository file. The target object repository takes the test object
name from the test object in the primary object repository. This is the default
setting. (When updating a shared object repository from a local object
repository, this option is for the Local object repository.)

l Secondary repository file. The target object repository takes the test object
name from the test object in the secondary object repository. (When updating a
shared object repository from a local object repository, this option is for the
Shared object repository.)

l Same file as the object description. The target object repository takes the
object name from the object in the same object repository from which it took the
object description.

Colors Tab (Settings Dialog Box - Object Repository Merge Tool)

Relevant for: GUI tests and components

This tab enables you to specify the color in which object names are displayed in the target object
repository according to their source, and whether they caused a conflict.
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To access In the "Object Repository Merge Tool MainWindow" (described on page 1363), do
one of the following:

l Select Tools > Settings, and select theColors tab.

l Click theSettings button in the toolbar, and select theColors tab.

Important
information

When performing anUpdate from Local Repository operation, the options in the
Colors tab of the"Settings Dialog Box (Object Repository Merge Tool)" (described
on page 1374) also apply to objects added from the local (primary) and shared
(secondary) object repositories.

Relevant
tasks

"How toMerge Two SharedObject Repositories" on page 1356

"How to Update a SharedObject Repository From a Local Object Repository" on
page 1358

See also l "Object Conflicts" on page 1353

l "Resolution Tab (Settings Dialog Box - Object Repository Merge Tool)" on
page 1375

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<object criteria> The list of object criteria on the left side of the dialog box.

Text Color Displays the current color used for the object names that match the
corresponding object criteria.

Object Repository Merge Tool - Multiple Merge Window
Relevant for: GUI tests and components

This window displays merge results of the selected local object repositories into the target shared
object repository. The local object repositories aremerged one by one into the shared object
repository.

The active local object repository is treated as the primary object repository, and the shared object
repository is treated as the target object repository.
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To access In the "Object Repository Manager MainWindow" (described on page 1297),
select Tools > Update from Local Repository.
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Important
information

l If you specifiedmore than one action or component in the "Update from Local
Repository Dialog Box" (described on page 1381), UFT performs multiple
merges, merging each local object repository with the target object repository
one at a time.

l The image above shows themerge results of the first merge (the first local
object repository beingmerged into the shared object repository).

l The number of eachmerge set in amultiple merge is displayed in the title bar,
for example, [Set 2 of 3].

l When you click Save and Merge Next, the current merge is saved and cannot
bemodified without performing another merge.

l The Ignore Object button is visible in theMerge Tool window only for a local
object repository merge, and is only enabled when an object in the local object
repository is selected.

l If you are performingmultiple merges, click theSave and Merge Next
button in the Object Repository Merge Tool toolbar to perform the next merge
(the next local object repository beingmerged into the shared object
repository).

Relevant
tasks

"How to Update a SharedObject Repository From a Local Object Repository" on
page 1358

TheObject Repository Merge Tool - Multiple Merge window contains the following key elements:

l "Menu Bar and Toolbar" below

l "Target Repository Pane" below

l "Primary Repository Pane" on the next page

l "Resolution Options Pane" on the next page

l "Status Bar " on the next page

Menu Bar and Toolbar
Displays menus of Object Repository Merge Tool commands. These commands are described in
"Object Repository Merge Tool Menu Commands and Toolbar Buttons" on page 1371.

Target Repository Pane
Displays the objects that were added from the local object repositories to the shared object
repository.
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At the left of each object in the target object hierarchy is an icon that indicates the source of the
objects:

UI Elements Description

Indicates that the object was added from the local object repository.

Indicates that the object already existed in the shared object repository.

Primary Repository Pane
Displays the objects in the local object repository that you are currently merging. For details, see
"Update from Local Repository Dialog Box" below.

Resolution Options Pane
Provides source, conflict, and resolution details about the objects in the target object repository
pane, and enables you tomodify how a selected conflict is resolved. For details, see "Resolution
Options Pane" on page 1365.

In the Resolution Options pane, you can select from one of the following options:

l Keep a specific object from the shared object repository and delete the conflicting object from
the local object repository.

l Keep a specific object from the local object repository and delete the conflicting object from the
shared object repository.

l Keep conflicting objects from both the shared object repository and the local object repository.

l Ignore Object. Exclude a specific local repository object from themerge process so that it is
not included in the shared object repository. The object is removed from the shared object
repository and grayed in the local object repository tree. It remains in the local object repository
when themerge is complete.

Caution: The Ignore Object operation cannot be reversed. To include the object again in
themerge process, youmust repeat themerge by clickingRevert to Original Merged

Files in the toolbar.

Status Bar
Provides source, conflict, and resolution details about the object selected in the target object
repository pane, the filter status, and an icon legend. For details, see "Status Bar" on page 1366.

Update from Local Repository Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to select components and tests containing actions, whose local object
repositories you want to merge into a shared object repository.
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To access In the "Object Repository Manager MainWindow" (described on page 1297),
select Tools > Update from Local Repository.

Important
information

l You can select multiple tests and components.

l If you are currently connected to an ALM project, you can select tests and
components from the file system or from ALM.

l For actions:You can add only tests containing actions that are associated
with the shared object repository you are updating and whose local object
repositories contain objects.

l For components: You can add components only if you are currently
connected to the ALM project in which they are stored. The components must
be associated (via their application area) with the shared object repository you
are updating and their local object repositories must contain objects.

l Before eachmerge, UFT checks whether the local object repository is in use
by another user. If so, the local object repository is locked and the objects for
the selected action or component cannot bemoved to the target shared object
repository. A warningmessage is displayed. Themerge can be performed
when the local object repository is no longer in use by the other user.

Relevant
tasks

"How to Update a SharedObject Repository From a Local Object Repository" on
page 1358
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<selected
tests,
actions, and
components>

The list of actions (within the selected tests) and components that contain local
object repositories to include in themerge.

Add Tests or Components. Enables you to browse to a test or component

and add it to the list. Click the down arrow to browse for tests or for
components. (You can browse for components only when connected to ALM).

For actions: If you select a test that contains multiple actions, only the actions
that are associated with the shared object repository you are updating and
whose local object repositories contain objects are added to the list.

Update All Instructs the Object Repository Merge Tool to automatically merge the local
object repositories with the shared object repository according to the
preconfigured settings and opens the Object Repository Merge Tool. You can
thenmodify any conflict resolutions if necessary. For details, see "Object
Repository Merge Tool MainWindow" on page 1363.

Note: If the list contains multiple actions or components, merges are
performed one after the other, and you can review the shared object
repository andmodify any conflict resolutions after eachmerge. For
details, see "Object Repository Merge Tool - Multiple MergeWindow" on
page 1378.
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Chapter 49: Virtual Objects
Relevant for: GUI tests and scripted GUI components

This chapter includes:

Concepts 1385

Virtual Objects - Overview 1385

How Virtual Objects are Defined and Recognized 1385

Tasks 1387

How to Define Virtual Objects for Unsupported Objects in Your Test or Scripted
Component 1387

Reference 1388

Virtual Object Manager Dialog Box 1388

Virtual Object Wizard 1389
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Concepts

Virtual Objects - Overview
Relevant for: GUI tests and scripted GUI components

Your applicationmay contain objects that behave like standard objects but are not recognized by
UFT. You can define these objects as virtual objects andmap them to standard classes, such as a
button or a check box. UFT emulates the user's action on the virtual object during the run session.
In the run results, the virtual object is displayed as though it is a standard class object.

For example, suppose you want to test aWeb page containing a bitmap that the user clicks. The
bitmap contains several different hyperlink areas, and each area opens a different destination page.
When you create the test or scripted component, theWeb site matches the coordinates of the click
on the bitmap and opens the destination page.

To enable UFT to click at the required coordinates during a run session, you can define a virtual
object for an area of the bitmap, which includes those coordinates, andmap it to the button class.
When you run the test or scripted component, UFT clicks the bitmap in the area defined as a virtual
object so that theWeb site opens the correct destination page.

Virtual object collections are groups of virtual objects that are stored in the Virtual Object Manager
under a descriptive name. For details, see "Virtual Object Manager Dialog Box" on page 1388.

The virtual object collections displayed in the Virtual Object Manager are stored on your computer
and not with the tests or scripted components that contain virtual object steps. This means that if
you use a virtual object in a step, the object is recognized during the run session only if it is run on a
computer containing the appropriate virtual object definition. To copy your virtual object collection
definitions to another computer, copy the contents of your <UFT installation
folder>\dat\VoTemplate folder (or individual .vot collection files within this folder) to the same
folder on the destination computer.

Note: UFT does not support virtual objects for analog or low-level recording. For details on low-
level recording, see "Creating Tests or Components" on page 2247.

How Virtual Objects are Defined and Recognized
Relevant for: GUI tests and scripted GUI components

UFT identifies a virtual object according to its boundaries. Marking an object's boundaries specifies
its size and position on aWeb page or application window. When you assign a test object as the
parent of your virtual object, you specify that the coordinates of the virtual object boundaries are
relative to that parent object. When you record a test or scripted component, UFT recognizes the
virtual object within the parent object and adds it as a test object in the object repository so that
UFT can identify the object during the run session. UFT also recognizes the virtual object as a test
object when you add it manually to the object repository.

To perform an operation in the Active Screen on amarked virtual object, youmust first record it, so
that its properties are saved in the test object description in the object repository. If you perform an
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operation in the Active Screen on a virtual object that has not yet been recorded, UFT treats it as a
standard object.

You can use virtual objects only when recording and running a test or scripted component. You
cannot insert any type of checkpoint on a virtual object, or use the Object Spy to view its properties.

You can enable and disable recognition of virtual objects during recording, in theGeneral pane of
the GUI Testing tab in the Options dialog box (Tools > Options > GUI Testing tab > General
node). For details, see "General Pane (Options Dialog Box > GUI Testing Tab)" on page 536.

During a run session, make sure that the application window is the same size and in the same
location as it was during recording, otherwise the coordinates of the virtual object relative to its
parent object may be different, and this may affect the success of the run session.
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Tasks

How to Define Virtual Objects for Unsupported Objects in
Your Test or Scripted Component

Relevant for: GUI tests and scripted GUI components

This task describes how to define virtual objects for objects that are not normally recognized by
UFT.

This task includes the following steps:

l "Display the object containing the area you want to define as a virtual object" below

l "Use the Virtual Object wizard to define your virtual object" below

1. Display the object containing the area you want to define as a virtual
object
With UFT open (but not in recordmode), open your application and display the object
containing the area you want to define as a virtual object.

You can define virtual objects only for objects on which UFT records Click orDblClick
methods. Otherwise, the virtual object is ignored. For example, if you define a virtual object
over theWinList object, the Select operation is recorded, and the virtual object is ignored. UFT
does not support virtual objects for analog or low-level recording. For details on low-level
recording, see "Frequently AskedQuestions for GUI Testing" on page 2246.

2. Use the Virtual Object wizard to define your virtual object
Open the Virtual Object wizard (Tools > Virtual Object > New Virtual Object). The Virtual
Object wizard includes the following pages:

n "Map to a Standard Class Page (Virtual Object Wizard)", described on page 1390

n "Mark Virtual Object Page (Virtual Object Wizard)", described on page 1391

n "Object Configuration Page (Virtual Object Wizard)", described on page 1392

n "Save Virtual Object Page (Virtual Object Wizard)", described on page 1393

HP Unified Functional Testing (12.00) Page 1387 of 2274



Reference

Virtual Object Manager Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to view andmanage the virtual object collections defined on your
computer. From the Virtual Object Manager, you can define and delete virtual objects and
collections.

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the
document pane.

n In the Solution Explorer, select a GUI test or action node.

2. Select Tools > Virtual Object > Virtual Object Manager.

Important
information

"How Virtual Objects are Defined and Recognized" on page 1385

Relevant tasks "How to Define Virtual Objects for Unsupported Objects in Your Test or
Scripted Component" on the previous page
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User interface elements are described below:

UI
Elements Description

Available
virtual
object
collections

Displays the virtual object collections defined on your computer and the virtual
objects contained in each collection. Click the + and - signs next to a collection to
view or hide the virtual objects defined in that collection.

New Opens the Virtual Object Wizard, which guides you through the process of
defining a new virtual object for a new or existing collection.

Delete Deletes the selected virtual object or virtual object collection.

Virtual Object Wizard
Relevant for: GUI tests and scripted GUI components

This wizard enables you to define a virtual object by:

l Mapping it to a standard class

l Marking its boundaries

l Assigning it a parent object

l Specifying its name and grouping objects into collections

To access 1. Do one of the following:

n Ensure that a GUI test, action, or component is in focus in the document
pane.

n In the Solution Explorer, select a GUI test or action node.

2. Use one of the following:

n Select Tools > Virtual Object > New Virtual Object.

n Select Tools > Virtual Object > Virtual Object Manager. From the
Virtual Object Manager, click New.

Important
information

"How Virtual Objects are Defined and Recognized" on page 1385

Relevant
tasks

"How to Define Virtual Objects for Unsupported Objects in Your Test or Scripted
Component" on page 1387

Wizard
map

This wizard contains:

Welcome > Map to a Standard Class (page 1390) > Mark Virtual Object (page
1391) > Object Configuration (page 1392) > Save Virtual Object (page 1393)

User Guide
Chapter 49: Virtual Objects

HP Unified Functional Testing (12.00) Page 1389 of 2274



Map to a Standard Class Page (Virtual Object Wizard)

Relevant for: GUI tests and scripted GUI components

This wizard page enables you to configure a standard class for the virtual object.

Wizard
map

"Virtual Object Wizard" contains:

Welcome (page 1389) >Map to a Standard Class > Mark Virtual Object (page 1389)
> Object Configuration (page 1392) > Save Virtual Object (page 1393)

User interface elements are described below:

UI Elements Description

Class Specify a standard object class from the list.

l For the list class, specify the number of rows in the virtual object.

l For the table class, select the number of rows and columns.
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Mark Virtual Object Page (Virtual Object Wizard)

Relevant for: GUI tests and scripted GUI components

This wizard page enables you to configure the size and location of the virtual object.

Important
information

l Make sure that the virtual object does not overlap any other virtual object, as
this may prevent UFT from identifying the virtual object during a run session.

l To record and run tests or scripted components properly, youmust ensure that
the application window is the same size and in the same position as it was
when you defined the virtual object.

Wizard
map

"Virtual Object Wizard" contains:

Welcome (page 1389) > Map to a Standard Class (page 1390) >Mark Virtual
Object > Object Configuration (page 1392) > Save Virtual Object (page 1393)
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Object Configuration Page (Virtual Object Wizard)

Relevant for: GUI tests and scripted GUI components

This wizard page enables you to configure an object as a parent of the virtual object.

Wizard
map

"Virtual Object Wizard" contains:

Welcome (page 1389) > Map to a Standard Class (page 1390) > Mark Virtual Object
(page 1391) > Object Configuration > Save Virtual Object (page 1393

User interface elements are described below:

UI Elements Description

Select the
parent of the
virtual object

Enables you to select an object in the tree as the parent object. The
coordinates of the virtual object outline are relative to the parent object.

Selected
parent

Indicates the name of the object selected as the parent object (read-only).
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UI Elements Description

Identify object
using

l Entire parent hierarchy. Select this radio button to identify the virtual
object in one occurrence only. UFT identifies the virtual object only if it has
the exact parent hierarchy.

For example, if the virtual object is defined usingBrowser("A").Page
("B").Image("C"), UFT does not recognize it if the hierarchy changes to
Browser("X").Page("B").Image("C").

l Parent only. Select this radio button to identify all occurrences of the virtual
object. UFT identifies the virtual object using its direct parent only,
regardless of the entire parent hierarchy.

For example, if the virtual object was defined usingBrowser("A").Page
("B").Image("C"), UFT recognizes the virtual object even if the hierarchy
changes toBrowser("X").Page("Y").Image("C").

Save Virtual Object Page (Virtual Object Wizard)

Relevant for: GUI tests and scripted GUI components

This wizard page enables you to configure a name and a collection for the virtual object. It also
enables you to begin defining another virtual object.

Wizard
map

"Virtual Object Wizard" contains:

Welcome (page 13891389> Map to a Standard Class (page 1390 > Mark Virtual Object
(page 1391) > Object Configuration (page 1392) > Save Virtual Object

User Guide
Chapter 49: Virtual Objects

HP Unified Functional Testing (12.00) Page 1393 of 2274



User interface elements are described below:

UI Elements Description

Name The name of your new virtual object.

Collection name The name of the collection in which your new virtual object is
stored.

Define virtual object collections in the "Virtual Object Manager
Dialog Box" (described on page 1388).

Do you want to define
another virtual object?

l Select Yes to enable the Next button and start the wizard
again from the start.

l Select No to enable the Finish button and close the wizard.

User Guide
Chapter 49: Virtual Objects

HP Unified Functional Testing (12.00) Page 1394 of 2274



Chapter 50: Checkpoints in GUI Testing
Relevant for: GUI tests and components

This chapter includes:

Concepts 1396

Checkpoints Overview 1396

Checkpoint Types 1397

Tasks 1419

How to Insert a Checkpoint in a GUI Test or Component 1419

How to Include and Ignore Areas WhenComparing a Bitmap - Use-Case Scenario 1426

How to Configure Text Recognition Settings 1429

Reference 1432

Checkpoint Properties Dialog Box 1432

Add Existing Checkpoint Dialog Box 1460

Advanced File Content Checkpoint Properties Dialog Box 1461

Advanced Settings Dialog Box (Bitmap Checkpoints Dialog Box) 1463

Configure Text Selection Dialog Box 1466

Define/Modify Row Range Dialog Box 1467

Edit XML as Text Dialog Box 1469

Filter Link Check Dialog Box 1470

Filter Image Check Dialog Box 1472

Parameterization / Properties Dialog Box (Checkpoints) 1473

Parameter Options Dialog Box (Local and Component Input Parameters for
Checkpoints) 1475

Schema Validation Dialog Box 1476

Connect to Database Using ODBC Page (DatabaseQuery Wizard) 1480

XMLSource Selection - Checkpoint / Output Value Properties Dialog Box 1482

Troubleshooting and Limitations - Using Checkpoints 1485

HP Unified Functional Testing (12.00) Page 1395 of 2274



Concepts

Checkpoints Overview
Relevant for: GUI tests and components

UFT enables you to add checks to your test or component. A checkpoint is a verification that
compares the current value for specified properties or current state of other characteristics of an
object with the expected value or characteristics. This helps you to identify whether your
application is functioning correctly. For example, you can perform standard checkpoints to check
that the actual object property values conform to the expected values, and you can perform bitmap
checkpoints to check that the visible parts of your application are displayed correctly.

When you add a checkpoint, UFT inserts a checkpoint step to the current row in the Keyword View,
and for tests and scripted components, also adds aCheck CheckPoint statement in the Editor. By
default, UFT names the checkpoint using the name of the test object on which the checkpoint was
created. You can choose to specify a different name for the checkpoint or accept the default name.

When you run the test or component, UFT compares the expected results of the checkpoint to the
current results. If the results do not match, the checkpoint fails. You can view the results of the
checkpoint in the Run Results Viewer.

This section also includes: 

Adding Existing Checkpoints to a Test 1396

Simple and AdvancedMode 1397

Adding Existing Checkpoints to a Test

Relevant for: GUI tests and scripted GUI components only

UFT enables you to reuse existing checkpoints. When you create checkpoints, consider which
checkpoints can be reused inmultiple locations in your test or in multiple tests. For example:

l Checkpoints that check generic content or the state of your applicationmay be useful in multiple
locations.

l Checkpoints that check the content of a specific area of your application are generally useful in
only one particular place in your test.

The following examples illustrate situations in which inserting an existing checkpoint may be
useful:

l If each page of your application contains your organization's logo, you can reuse a bitmap
checkpoint to verify each occurrence in the application.

l If your application contains multiple edit boxes, you can reuse a checkpoint to confirm the
enabled status of these edit boxes throughout your test.
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Simple and Advanced Mode

Relevant for: Keyword GUI components only

UFT provides twomodes of checkpoints that you can insert using the relevant Checkpoint
Properties dialog box—Simple Mode andAdvanced Mode. SimpleMode enables you to check a
basic set of properties and values. This type of checkpoint is visible and editable in both UFT and
ALM. For details on the Checkpoint Properties dialog box, see "Checkpoint Properties Dialog Box"
on page 1432.

In UFT, you can also view or edit advanced checkpoint properties that are not visible to users in
ALM. You do this by inserting a checkpoint using AdvancedMode. If a checkpoint contains
advanced properties, and an ALM user views its properties in ALM, a disclaimer opens indicating
that some properties are checked but are not shown.

Checkpoint Types
Relevant for: GUI tests and components

You can insert the following checkpoint types to check objects in an application:

Checkpoint
Type Description

Standard
Checkpoint

Checks property values of an object in your application. For example, you can
check that a radio button is activated after it is selected or you can check the
value of an edit box.

Standard checkpoints are supported for all add-in environments (see "Supported
Checkpoints" on page 2225).

For details on standard checkpoints, see "Standard Checkpoints Overview" on
page 1400.

Image
Checkpoint
(tests and
scripted
components
only)

Checks the value of an image in your application. For example, you can check
that a selected image's source file is correct.

You create an image checkpoint by inserting a standard checkpoint on an image
object.

Image checkpoints are supported for theWeb add-in environment (see
"Supported Checkpoints" on page 2225).

For details on image checkpoints, see "Standard Checkpoints Overview" on
page 1400.
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Checkpoint
Type Description

Accessibility
Checkpoint
(tests and
scripted
components
only)

Identifies areas of yourWeb site that may not conform to theWorldWideWeb
Consortium (W3C)WebContent Accessibility Guidelines. For example,
guideline 1.1 of theW3C WebContent Accessibility Guidelines requires you to
provide a text equivalent for every non-text element. You can add anAlt property
check to check whether objects that require theAlt property under this guideline,
do in fact have this tag.

Accessibility checkpoints are supported for theWeb add-in environment (see
"Supported Checkpoints" on page 2225).

For details on accessibility checkpoints, see "Accessibility
Checkpoints Overview" on page 1400.

Bitmap
Checkpoint

Checks an area of your application as a bitmap. For example, suppose you have
aWeb site that can display amap of a city the user specifies. Themap has
control keys for zooming. Using the bitmap checkpoint, you can check that the
map zooms in correctly.

You can also check that a specific bitmap exists in your application. For
example, you can check that your company logo is displayed anywhere on your
Web page.

You can create a bitmap checkpoint for any area in your application.

Bitmap checkpoints are supported for all add-in environments. For details, see
"Supported Checkpoints" on page 2225.

For details on bitmap checkpoints, see "Bitmap Checkpoints Overview" on page
1401.

Database
Checkpoint
(tests and
scripted
components
only)

Checks the contents of a database accessed by your application. For example,
you can use a database checkpoint to check the contents of a database
containing flight information for yourWeb site.

Database checkpoints are supported for all add-in environments (see "Supported
Checkpoints" on page 2225).

For details on database checkpoints, see "Database Checkpoints Overview" on
page 1405.

File Content
Checkpoint
(tests only)

Checks the text in a dynamically generated (or accessed) file. For example,
suppose your application generates a .pdf. You can check that the correct text is
displayed on specific lines in on specific pages in that .pdf.

File content checkpoints are supported for all add-in environments (see
"Supported Checkpoints" on page 2225).

For details on file content checkpoints, see "File Content Checkpoints
Overview" on page 1406.
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Checkpoint
Type Description

Page
Checkpoint
(tests and
scripted
components
only)

Checks the characteristics of aWeb page. For example, you can check how
long aWeb page takes to load or whether aWeb page contains broken links.

You create a page checkpoint by inserting a standard checkpoint on a page
object.

Page checkpoints are supported for theWeb add-in environment (see
"Supported Checkpoints" on page 2225).

For details on page checkpoints, see "Page Checkpoints Overview" on page
1407.

Table
Checkpoint
(tests and
scripted
components
only)

Checks information within a table. For example, suppose your application
contains a table listing all available flights from New York to San Francisco. You
can add a table checkpoint to check that the time of the first flight in the table is
correct.

You create a table checkpoint by inserting a standard checkpoint on a table
object. For details on table checkpoints, see "Table Checkpoints Overview" on
page 1407.

Table checkpoints are supported for all add-in environments that have a *Table
test object. Table checkpoints are also supported for some list view objects,
such asWinListView andVbListView, as well as other list view objects in add-in
environments. For details, see "Supported Checkpoints" on page 2225.

Text
Checkpoint
(tests and
scripted
components
only)

Checks that a text string is displayed in the appropriate place in an application.
For example, suppose aWeb page displays the sentence Flight departing from
New York to San Francisco. You can create a text checkpoint that checks that
the words "New York" are displayed between "Flight departing from" and "to San
Francisco".

Text checkpoints are supported for most add-in environments (see "Supported
Checkpoints" on page 2225).

For details on text checkpoints, see "Checking Text Overview " on page 1408.
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Checkpoint
Type Description

Text Area
Checkpoint
(tests and
scripted
components
only)

Checks that a text string is displayed within a defined area in aWindows-based
application, according to specified criteria. For example, suppose your Visual
Basic application has a button that says View Doc <Num>, where <Num> is
replaced by the four digit code entered in a form elsewhere in the application.
You can create a text area checkpoint to confirm that the number displayed on
the button is the same as the number entered in the form.

Text area checkpoints are supported for all Windows-based environments, such
as StandardWindows, Visual Basic, and ActiveX add-in environments (see
"Supported Checkpoints" on page 2225). Text area checkpoints are also
supported for some other add-in environments, such as Java.

For details on text area checkpoints, see "Checking Text Overview " on page
1408.

XML
Checkpoint
(tests and
scripted
components
only)

Checks the data content of .xml documents in ,xml files or .xml documents in
Web pages and frames. For details on XML checkpoints, see "XMLCheckpoints
Overview" on page 1416

The XML Checkpoint (Web Page/Frame) option is supported for theWeb add-
in environment. TheXML Checkpoint option is supported for all add-in
environments (see "Supported Checkpoints" on page 2225).

Standard Checkpoints Overview

Relevant for: GUI tests and components

You can check the object property values in your application using standard checkpoints. Standard
checkpoints compare the expected values of object properties to the object's current values during
a run session. You can create standard checkpoints for all supported testing environments (as long
as the appropriate add-ins are loaded).

You can check that a specified object in your application has the property values you expect, by
adding a standard checkpoint step to your test or component while recording or editing it. To set the
options for a standard checkpoint, you use the "Checkpoint Properties Dialog Box" (described on
page 1432).

For tests and scripted components:You can also use standard checkpoints to perform checks
on images, tables, Web page properties, and other objects within your application.

Accessibility Checkpoints Overview

Relevant for: GUI tests and scripted GUI components

You can add accessibility checkpoints to help you quickly identify areas of yourWeb site that may
not conform to theW3C WebContent Accessibility Guidelines.
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The Section 508 criteria forWeb-based technology and information systems are based on access
guidelines developed by theWeb Accessibility Initiative of theWorldWideWebConsortium
(W3C).

You can add automatic accessibility checkpoints to each page in your test, or you can add
individual accessibility checkpoints to individual pages or frames.

Accessibility checkpoints are not supported for keyword components.

Automatic Accessibility Checkpoints
You can instruct UFT to create automatic accessibility checkpoints for every page in all tests. For
details, see "How to Insert a Checkpoint in a GUI Test or Component" on page 1419.

Individual Accessibility Checkpoints
If you do not select to add accessibility checkpoints automatically while recording, you can add an
accessibility checkpoint while recording or editing your test.

For details, see:

l "How to Insert a Checkpoint in a GUI Test or Component" on page 1419

l "Checkpoint Properties Dialog Box" on page 1432

Bitmap Checkpoints Overview

Relevant for: GUI tests and components

UFT enables you to check that the visible parts of your application are displayed correctly by
comparing bitmaps of objects in your application to bitmaps captured previously and stored with the
test or component.

You can create bitmap checkpoints for all supported testing environments (as long as the
appropriate add-ins are loaded).

Bitmap checkpoints enable you to do the following:

l Compare an entire object or areas within an object. For example, suppose you have aWeb
site that can display amap of a city that the user specifies. Themap has control keys for
zooming. You can zoom in on amap, and then insert a bitmap checkpoint on the zoomed-in map
to check that themap zooms in correctly.

l Locate a specified image within an object. For example, suppose you want to check that
your company logo is displayed on yourWeb page. You can either select the logo in the actual
Web page, or load a bitmap file containing the logo from your computer.

For details on defining checkpoint settings, see "Checkpoint Properties Dialog Box" on page 1432.

How UFT Compares Bitmaps
When you create a bitmap checkpoint, UFT captures the visible part of the specified object as a
bitmap and inserts a checkpoint in the test or component. (UFT does not capture any part that is
scrolled off the screen, or hidden by another object, for example.)

User Guide
Chapter 50: Checkpoints in GUI Testing

HP Unified Functional Testing (12.00) Page 1401 of 2274



You can specify areas of the object to ignore or include in the checkpoint. For example, if yourWeb
page includes a dynamic counter that may cause the checkpoint to fail, you can instruct UFT to
ignore it during the run session by excluding the area in which it is located from the comparison.

When you run the test or component, UFT captures a bitmap of the actual object in the application
and compares this runtime bitmap (or the selected areas within it) with the bitmap stored in the
checkpoint. You can fine-tune this comparison by defining tolerance settings in the checkpoint. For
details, see "Fine-Tuning the Bitmap Comparison" on the next page.

If there are differences, UFT saves the runtime bitmap and displays it next to the expected bitmap
in the details pane of the Run Results Viewer. In the Run Results Viewer you can also view a
bitmap that reflects the difference between the two bitmaps, to assist you in identifying the nature
of the discrepancy.

How UFT Locates Bitmaps
When you create a bitmap checkpoint, you select a bitmap that you want UFT to locate during a run
session. You can either select an area within the bitmap captured from your application, or load a
bitmap file from the file system and store it in the checkpoint.UFT then inserts the checkpoint in the
test or component.

When you run the test or component, UFT searches for the specified bitmap within the runtime
bitmap captured from the application. You can fine-tune this search by defining similarity criteria in
the checkpoint. For details, see "Fine-Tuning the Bitmap Comparison" on the next page.

If the specified bitmap is not found, the checkpoint fails, and UFT displays the specified bitmap
next to the actual (runtime) bitmap in the Details pane of the Run Results Viewer.

The Run Results Viewer also displays the coordinates of the nearest candidate bitmap within the
actual bitmap, along with the similarity percentage used to find the candidate.

When to Use the Option to Locate a Bitmap Within the Runtime Bitmap
Suppose your application includes a specific bitmap that you want to make sure exists when you
run your steps. The bitmap you want to check may not always be located in the same place in your
application.

If you attempt to compare the expected bitmap with the runtime bitmap, and the location of the
expected bitmap changes, then the checkpoint may fail. Therefore, you can define the specific
bitmap that you want to locate, and UFT searches for that bitmap anywhere in the object on which
you define the checkpoint, relative to the top-left corner of the object.

How UFT Displays Bitmap Checkpoint Results
By default, UFT only displays expected, actual, and difference bitmaps in the Run Results Viewer
for checkpoints that fail. If a bitmap checkpoint is configured such that the checkpoint can pass
even if the expected and actual bitmaps are not identical, you can configure the run results to
display the captured actual, expected and difference bitmaps for bitmap checkpoints that pass, too.
For details, see "Screen Capture Pane (Options Dialog Box > GUI Testing Tab)" on page 557.

The results of bitmap checkpoints may be affected by factors such as operating system, screen
resolution, and color settings.

For details on run results of a checkpoint, see the section on Bitmap Checkpoint Results in the
HP RunResults Viewer User Guide.
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Fine-Tuning the Bitmap Comparison

Relevant for: GUI tests and components

When running a bitmap checkpoint, UFT compares the area that you are checking in the application
with the bitmap stored in the checkpoint, pixel by pixel. By default, if any pixels are different, the
checkpoint fails. The advanced settings in the Bitmap Checkpoint Properties dialog box (described
on page 1432) provides various options for fine-tuning the bitmap comparison:

l When comparing bitmaps, you can adjust the comparison to enable the checkpoint to pass even
if the bitmaps are not identical by setting theRGB tolerance andPixel tolerance options
described below.

l When locating a specified bitmap within the runtime bitmap, you can use similarity to enable
the checkpoint to pass, even if the exact bitmap is not found in your application. For details on
similarity, see "Image Similarity".

l You can also use a custom comparers to carry out a bitmap checkpoint. A custom comparer is
a COM object that you or a third party can develop to run the bitmap comparison in the
checkpoint, according to amore specific algorithm. For details on using theComparer option,
see "Custom Comparers".

RGB Tolerance

Note: This functionality is available only when comparing expected bitmaps with runtime
bitmaps. It is not available when locating a specified bitmap within the runtime bitmap.

The RGB (Red, Green, Blue) tolerance determines the percent by which the RGB values of the
pixels in the runtime bitmap can differ from those of the expected bitmap and allow the checkpoint
to pass. (The RGB tolerance option is limited to bitmaps with a color depth of 24 bits.)

For example, a bitmap checkpoint on identical bitmaps could fail if different display drivers are used
when you create your checkpoint and when you run your test. Suppose one display driver displays
the color white as RGB (255, 255, 255) and another driver displays the color white as RGB (231,
231, 231). The difference between these two values is about 9.4%. By setting theRGB tolerance
to 10%, your checkpoint will pass when running your test with either of these drivers.

Note: UFT applies the RGB tolerance settings when comparing each pixel in the expected and
runtime bitmaps. The Red, Green, and Blue values for each pixel are compared separately. If
any of the values differs more than the tolerance allows, the pixel fails the comparison.

Pixel Tolerance

Note: This functionality is available only when comparing expected bitmaps with runtime
bitmaps. It is not available when locating a specified bitmap within the runtime bitmap.

The pixel tolerance determines the number or percentage of pixels in the runtime bitmap that can
differ from those in the expected bitmap and allow the checkpoint to pass.
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For example, suppose the expected bitmap has 4000 pixels. If you define the pixel tolerance to be
50 and select thePixels radio button, up to 50 pixels in the runtime bitmap can be different from
those in the expected bitmap and the checkpoint passes. If you define the pixel tolerance to be 5
and select thePercent radio button, up to 200 pixels (5 percent of 4000) in the runtime bitmap can
be different from those in the expected bitmap and the checkpoint passes.

Using Both RGB and Pixel Tolerances

Note: This functionality is available only when comparing expected bitmaps with runtime
bitmaps. It is not available when locating a specified bitmap within the runtime bitmap.

If you define both RGB and pixel tolerances, the RGB tolerance is calculated first. The pixel
tolerance then defines themaximum number of pixels that can fail the RGB criteria and allow the
checkpoint to pass.

For example, suppose you define an RGB tolerance of 10 percent and a pixel tolerance of 5 percent,
for a bitmap that has 4000 pixels.

For the checkpoint to pass, each pixel in the runtime bitmapmust have RGB values that are no
greater than or no less than 10 percent of the RGB values of the expected bitmap. If that criterion
fails, UFT checks that the number of pixels that failed are less than 200. If that criterion passes, the
checkpoint passes.

Image Similarity

Note: This functionality is available only when locating a specified bitmap within the runtime
bitmap. It is not available when comparing expected bitmaps with runtime bitmaps.

Image similarity settings can enable a checkpoint to pass, even if the exact bitmap is not found in
your application. UFT attempts to locate the specified bitmap in the runtime bitmap of the object in
your application during the run session. If UFT locates an exact match to the specified bitmap, then
the checkpoint passes.

If an exact match cannot be found and you specified less than 100% in theSimilarity option in the
advanced settings of the "Checkpoint Properties Dialog Box" (described on page 1432), UFT
adjusts the comparison according to the similarity level. If the possible candidate has a similarity
that is equal to or greater than the percentage that you defined, the checkpoint passes.

Custom Comparers
A custom comparer is a COM object that you or a third party can develop to run the bitmap
comparison in the checkpoint according to amore specific algorithm. If you use a custom comparer
to perform the bitmap checkpoint, UFT sends the comparer two bitmaps to compare: A screen
capture of the object, created with the checkpoint and saved as the expected bitmap, and a screen
capture of the object as it appears in the application during the run session. The comparer then
compares these two bitmaps according to the specifications in its algorithm. If you use a custom
comparer, you cannot use the "Checkpoint Properties Dialog Box" (described on page 1432) to
specify tolerance or similarity settings, or areas of the object to compare or ignore.
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If one or more custom comparers are installed and registered on the UFT computer, the "Advanced
Settings Dialog Box (Bitmap Checkpoints Dialog Box)" (described on page 1463) includes a
Comparer option.

TheComparer option enables you to select the UFT default comparer or a custom comparer that
performs the bitmap comparison according to your testing requirements. For an example of when it
can be useful to create a custom comparer, see "Custom Comparer for Images Whose Location
Changes in the Application - Use-Case Scenario" on page 2199. For details on developing or
installing custom comparers, see "Developing Custom Comparers for Bitmap Checkpoints (GUI
Testing)" on page 2198.

If you select a custom comparer, some of the options in the Bitmap Checkpoint Properties
Advanced Settings dialog box are different. For details, see "Advanced Settings Dialog Box
(Bitmap Checkpoints Dialog Box)" on page 1463.

Database Checkpoints Overview

Relevant for: GUI tests and scripted GUI components

You can use database checkpoints to check databases accessed by your application, and to detect
defects. To do this, you define a query on your database. Then you create a database checkpoint
that checks the results of the query.

You can define a database query in the following ways:

l UsingMicrosoft Query. You can install Microsoft Query from the custom installation of Microsoft
Office.

l By manually defining an SQL statement.

You create a database checkpoint based on the results of the query (result set) you defined on a
database. You can create a check on a database to check the contents of the entire result set, or a
part of it. UFT captures the current data from the database, saves this information as expected
data, and inserts a database checkpoint step.

This checkpoint is displayed in the Editor as aDbTable.Check CheckPoint statement and as a
step in the Keyword View.

When you create a new database checkpoint, all cells contain a blue check mark, indicating they
are selected for verification. You can select to check the entire results set, specific rows, specific
columns, or specific cells. UFT checks only cells containing a check mark.

You can also specify the way UFT identifies the selected cells. For example, suppose you want to
check the data that is displayed in the first row and second column in the "Checkpoint Properties
Dialog Box" (described on page 1432). However, you know that each time you run your test or
scripted component, it is possible that the rows may be in a different order, depending on the sorting
that was performed in a previous step. Therefore, rather than finding the data based on row and
column numbers, youmay want UFT to identify the cell based on the column name and the row
containing a known value in a key column.
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During the run session, the database checkpoint compares the current data in the database to the
expected data defined in the "Checkpoint Properties Dialog Box" on page 1432 If the expected data
and the current results do not match, the database checkpoint fails.

Note:

l You canmodify the expected data of a database checkpoint before a run session. You can
alsomake changes to the query in an existing database checkpoint. This can be useful if
youmove the database to a new location on the network.

l You can view the results of the checkpoint in the Run Results Viewer. For details, see the
section on database checkpoint results in theHP RunResults Viewer User Guide.

l For details on creating database checkpoints, see "How to Insert a Checkpoint in a
GUI Test or Component" on page 1419.

File Content Checkpoints Overview

Relevant for: GUI tests and scripted GUI components

You can use file content checkpoints to compare the textual content of a file that is generated
during a run session with the textual content of a source file. This enables you to verify that the
generated file contains the expected results. For example, youmay want to verified that a PDF file
generated during a run session displays the local corporate address at the top of every page.

You can perform a checkpoint on text in one line, multiple lines, or the entire document, as needed.
You can also specify what to ignore. For example, if you expect certain lines or areas in the file to
change, you can exclude them from the checkpoint.

When you select a source document to compare, UFT converts a copy of this document to a text
file and displays the content in the file content editor area of the "Checkpoint Properties Dialog Box"
(described on page 1432) enabling you to configure your checkpoint. You can use parameters and
regular expressions to augment your checkpoint, as needed.

You can perform a file content checkpoint for any of the following file types:

l HTML l Microsoft Word l Text

l PDF l RTF

If a file content checkpoint step fails during a run session, the Captured Data pane in the Run
Results Viewer displays a side-by-side comparison of the generated document and the source
document, enabling you to visually compare the differences between the documents, including
lines or sections that were added or removed. For details, see the section on the section describing
File Content Checkpoint Results (described in theHP RunResults Viewer User Guide).
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Table Checkpoints Overview

Relevant for: GUI tests and scripted GUI components

You can use table checkpoints to check the content of tables displayed in your application. For
example, you can check that a specified value is displayed in a certain cell. For some
environments, you can also check the property values of the table object. For example, you can
check that a table has the expected number of rows and columns.

During a run session, the table checkpoint compares the actual data to the expected data, as
defined in the checkpoint. If the results match, the checkpoint passes. You can view the results of
the checkpoint in the Run Results Viewer. For details, see the section on table checkpoint results
in theHP RunResults Viewer User Guide.

Different environments support different checkpoints. For details on supported checkpoints, see
"Supported Checkpoints" on page 2225.

Row Range Selection
The tables in your applicationmay be very large. A table checkpoint on a large table may take a long
time to create and a long time to run. You can choose to include all rows in your table checkpoint or
you can specify a smaller row range.

For someUFT add-ins, when creating a new table checkpoint object, you can specify the range of
rows you want to include using the "Define/Modify Row Range Dialog Box" on page 1467.

Page Checkpoints Overview

Relevant for: GUI tests and scripted GUI components

You can use page checkpoints to check statistical information about yourWeb pages. These
checkpoints check the links and the sources of the images on aWeb page. You can also instruct
page checkpoints to include a check for broken links.

The following types of page checkpoints are available:

Individual Page Checkpoints
You canmanually add a page checkpoint to check the links and image sources on a selectedWeb
page during a recording or editing session.

For task details, see "How to Insert a Checkpoint in a GUI Test or Component" on page 1419.

For user interface details, see "Checkpoint Properties Dialog Box" on page 1432.

Automatic Page Checkpoints
You can instruct UFT to create automatic page checkpoints for every page during a recording
session by selecting theCreate a checkpoint for each Web page while recording check box in
theWeb > Advanced pane of the Options dialog box (Tools > Options > GUI Testing tab > Web
> Advanced node). By default, the automatic page checkpoint includes the checks that you select
from among the available options in theWeb > Advanced pane.
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You can also instruct UFT not to perform automatic page checkpoints during run sessions by
selecting the Ignore automatic checkpoints while running tests check box in theWeb >
Advanced pane of the Options dialog box (Tools > Options > GUI Testing tab > Web >
Advanced node).

For details, see the chapter on theWeb > Advanced pane in the GUI Testing tab of the Options
dialog box in theHP Unified Functional Testing Add-ins Guide.

Checking Text Overview

Relevant for: GUI tests and scripted GUI components

You can check that a specified text string is displayed by adding one of the following checkpoints.

l Standard Checkpoint. Enables you to check the text property of an object. You can use
standard checkpoints to check text inWindows-based and other types of applications (including
Web-based applications). For details on standard checkpoints, see "How to Insert a Checkpoint
in a GUI Test or Component" on page 1419.

l Text Area Checkpoint. Enables you to check that a text string appears within a defined area in
aWindows application, according to specified criteria. When checking text displayed in a
Windows-based application, it is often advisable to define a text area larger than the actual text
you want UFT to check. You then use the "Checkpoint Properties Dialog Box" (described on
page 1432) to configure the relative position of the Checked Text within the captured area.
During a run session, UFT checks for the selected text within the defined area, according to the
settings you configured.

l Text Checkpoint. Enables you to check that the text is displayed in a screen, window, orWeb
page, according to specified criteria. For example, suppose you want to check the third
occurrence of a particular text string in a page. To check for this string, you can specify which
text precedes and/or follows it and to which occurrence of the specified text string you are
referring.

By default, when checking text, UFT tries to retrieve the text directly from the object. If UFT cannot
retrieve the text in this manner (for example, because the text is part of a picture), it tries to retrieve
the text using anOCR (optical character recognition) mechanism. TheOCR mechanism translates
images of handwritten or typewritten text into machine-editable text.

Note: TheOCR text mechanism is not supported for objects in the Active Screen.

For task details, see "How to Insert a Checkpoint in a GUI Test or Component" on page 1419.

Text Recognition Overview

Relevant for: GUI tests and components

Whenworking with tests and scripted components, you can use the text and text area checkpoint
or output value commands to verify or retrieve text in your objects.
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Whenworking with tests, keyword or scripted components, and function libraries, you can insert
steps to capture the text from objects in your application using the <testobject>.GetVisibleText,
the testobject.GetTextLocation test object methods, the TextUtil.GetText or
TextUtil.GetTextLocation reserved object methods, or the testobject.GetText (for Terminal
Emulator objects).

When you use one of these options, UFT identifies text in your application using either aWindows
API-basedmechanism (not supported for Vista operating systems and higher, or any 64-bit
operating systems) or anOCR (optical character recognition) mechanism.

By default, UFT tries to retrieve the text directly from the object using aWindows API-based
mechanism. If UFT cannot capture the text this way (for example, because the text is part of a
picture), it tries to capture the text using anOCR (optical character recognition) mechanism.

When UFT uses the OCR mechanism, a number of factors can affect the text it retrieves.
Depending on the characteristics of the text you want to retrieve, you can adjust several OCR
configuration options to optimize the way the text is captured.

You use the "Text Recognition Pane (Options Dialog Box > GUI Testing Tab)" (described on page
542) to specify the preferred text recognitionmechanism andOCR-specific settings.

Guidelines for Text Recognition

Relevant for: GUI tests and components

l TheWindows API text recognitionmechanism is provided as is (not supported for Vista
operating systems and higher, or 64-bit operating systems). If it does not work as you expect,
change the option to useOCR.

However, although UFT uses amarket-leading OCR mechanism and the accuracy is usually
very high, keep inmind that as with all OCR technologies, these engines are non-deterministic
in the way they are built and interpret text and therefore accuracy of recognition for some text
patterns may be better than others. TheOCR mechanism does not guarantee 100% accuracy.

Additionally, text-capturing steps may behave differently in different run sessions depending on
the operating system version you are using, the installed service packs, other installed toolkits,
the APIs used in your application, and so on.

l When using the OCR mechanism, the larger the text, the better the text recognition.

l TheOCR mechanism is not supported for objects in the Active Screen.

l Whenworking with text area checkpoints or specifying the text area inmethods such as
GetTextLocation, try to keep the dimensions of the selected text area as small as possible, as
this helps prevent additional unwanted characters in recognized text.

At the same time, consider the potential movement (change of coordinates) of the object within
the window. For example, the screen resolution is often different on different computers, and this
can affect the coordinates of the object in the application. Also, during the design and
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development stages of an application, an object may bemoved tomake room for other objects
or for aesthetic purposes.

Consider that the operating system, installed service packs, installed toolkits, and so on, can all
affect the size and location of an object in an application. Make sure that the dimensions of the
selected text area are large enough for different system configurations.

The dimensions of the selected text area need to be large enough to take these issues into
account.

l Single text block mode andmultiple text block mode sometimes result in different captured text.

If you are not sure which text block mode to use, use the default multiple block mode. If the
results are not what you expect, then try using the single text block mode.

For an example of when to use different text block modes, see "Checking Text in an Image -
Use-Case Scenario" on page 1414.

Tip: If you want to use the text recognitionmechanism for a large area containing different
fonts and backgrounds, it is recommended to create several steps to capture the text for
each single text block instead of creating one step to capture amultiple text block.

l Windows provides various themes. When working with text recognition, try to apply themes in
the following order:

n Windows Vista theme (for best results)

n Windows XP theme

n Windows Classic theme

For example, this may be useful if the default OCR settings result in additional unexpected
characters in the captured text.

l OnWindows Vista operating systems and higher (includingWindows 8), only the OCR
mechanism is applied for text recognition. This can affect text recognition features (such as text
checkpoints and output values, GetVisibleText andGetTextLocation test object methods, and
TextUtil.GetText and TextUtil.GetTextLocation reserved object methods).

l If the text recognitionmechanism retrieves unwanted text information (such as hidden text and
shadowed text that appears as multiple copies of the same string) when using themultiple text
block mode, use the single text block mode option. To do this, in the Text Recognition pane of
the Options dialog box (Tools > Options > GUI Testing tab > Text Recognition node), select
Single text block mode. For details, see "Text Recognition Pane (Options Dialog Box > GUI
Testing Tab)" on page 542.

l If your text recognition options are set to use theWindows API mechanism, then, when running
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a step that uses text recognition, theWindows API may cause a "blinking effect" in your
application as it captures the text. If your test or component contains consecutive steps that
utilize the text recognitionmechanism, the "blinking effect" in one stepmay cause the
subsequent text recognition step (or other step that relies on the appearance of the application,
such as a bitmap checkpoint) to fail.

To address this, you can insert aWait statement prior to each such step. This enables you to
delay the performance of the next text recognition step until theWindows API capture of the
previous step is complete.

l It is highly recommended to check text from your application window by inserting a standard
checkpoint for the object containing the desired text, using its text (or similar) property.

l By default, when UFT captures text for a text/text area checkpoint or output value step using the
GetText, GetTextLocation, orGetVisibleTextmethods, it tries to retrieve the text directly from
the object using aWindows API-basedmechanism. If UFT cannot capture the text this way (for
example, because the text is part of a picture), it tries to capture the text using anOCR (optical
character recognition) mechanism. For details about changing this behavior, see theCan
QuickTest Professional Text Recognition behavior bemodifiedKnowledge base article (number
KM202721).

l For tests: If you are creating text area checkpoints, see the Important Information section in
"Checkpoint Properties Dialog Box" on page 1432 for additional guidelines.

Text Recognition and Development Environments

Relevant for: GUI tests and components

The following table lists the development environments supported by UFT (via its add-ins) and
specifies what is supported for text recognition.

Development
Environment Text Recognition Supported

Text Recognition Not
Supported

ActiveX Full text recognition support N/A

Delphi Full text recognition support N/A

Java l Text checkpoints

l Text output values

l Text area checkpoints

l Text area output values

l GetTextLocation
method

l GetVisibleText
method
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Development
Environment Text Recognition Supported

Text Recognition Not
Supported

.NET WebForms l Text checkpoints for Page object only

l Text output values for Page object only

l Text checkpoints for all
other objects

l Text output values for
all other objects

l Text area checkpoints
for all objects

l Text area output values
for all objects

l GetTextLocation
method

l GetVisibleText
method

.NET WinForms Full text recognition support N/A

Oracle N/A No text recognition
support

PeopleSoft l Text checkpoints for PSFrame object
only

l Text output values for PSFrame object
only

l Text checkpoints for all
other objects

l Text output values for
all other objects

l Text area checkpoints
for all objects

l Text area output values
for all objects

l GetTextLocation
method

l GetVisibleText
method

PowerBuilder Full text recognition support N/A

SAP Gui for
Windows

N/A No text recognition
support
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Development
Environment Text Recognition Supported

Text Recognition Not
Supported

SAP Web l Text checkpoints

l Text output values

l Text area checkpoints

l Text area output values

l GetTextLocation
method

l GetVisibleText
method

Siebel N/A No text recognition
support

Silverlight Full support except as listed in theNot
Supported column.

l GetTextLocation
method

Standard
Windows

Full text recognition support N/A

Stingray Full text recognition support N/A

Terminal
Emulators

Text output values for TeScreen and
TeTextScreen objects only

l Other text checkpoints

l Other text output
values

l Text area checkpoints

l Text area output values

l GetTextLocation
method

l GetVisibleText
method

VisualAge Full text recognition support N/A

Visual Basic Full text recognition support N/A
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Development
Environment Text Recognition Supported

Text Recognition Not
Supported

Web l Text checkpoints for Page object only

l Text output values for Page object only

l Text checkpoints for all
other objects

l Text output values for
all other objects

l Text area checkpoints
for all objects

l Text area output values
for all objects

l GetTextLocation
method

l GetVisibleText
method

WPF Full support except as listed in theNot
Supported column.

l GetTextLocation
method

Checking Text in an Image - Use-Case Scenario

Relevant for: GUI tests and scripted GUI components

Ben andGeorge are quality assurance engineers who are experienced UFT users. George is also
familiar with text recognition and has a basic understanding of how text recognitionmechanisms
work.

Ben often uses bitmap checkpoints to check the appearance of various icons or pictures in the user
interface he is testing.

For one of his projects, Ben also needed to verify the text in the graphics, so he decided to use text
checkpoints.

Ben decided to begin the verification process by inserting a text checkpoint to check that the text
Welcome ! was displayed correctly in the following graphic.

Before inserting the text checkpoint, Ben opened the Text Recognition pane and configured the text
recognition settings. Ben set the text recognitionmechanism toUse Only OCR because the text
was part of a graphic. Ben also knew that single text block mode usually works best, so he selected
theSingle text block mode option.
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Ben then inserted a text checkpoint on the entire area shown above and received the following
results in the Text Checkpoint Properties dialog box:

Ben noticed that there were extra characters in theCheckpoint Summary area of the text
checkpoint, but he did not know why.

Ben asked his colleague, George, for help. George explained to him that the text recognition
mechanism sometimes adds extra characters to the text checkpoint when it does not recognize the
text correctly.

George also pointed out that the area Ben defined for the text checkpoint consisted of multiple text
blocks because the text was not uniform in font size, color, or background. The title area consisted
of white characters on a blue-gray background, while the remaining text was smaller and consisted
of blue text on a white background.

Ben remembered that he had selected theSingle text block mode option in the Text Recognition
pane (Tools > Options > GUI Testing tab > Text Recognition node) and understood that if he
wanted to use single text block mode, he would have to create a text checkpoint only on the
Welcome ! area of the graphic, and not on the entire graphic. Ben tried this, and the OCR
mechanism correctly identified the text, as shown below:
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Benwas pleased with the results, but he wanted to explore other possibilities, so he inserted
another text checkpoint—this time on the entire graphic. He selected theMultiple text block
mode option in the Text Recognition pane, which resulted in the following:

Ben was pleased that the OCR mechanism correctly recognized all of the text in the graphic. But he
needed to check only the title,Welcome !, so he finalized this checkpoint by marking all of the text
afterWelcome ! as Text After.

Even though both checkpoints passed, Ben needed only one text checkpoint. He decided to keep
the first checkpoint (that usedSingle text block mode), and he deleted the second one. He
selected theSingle text block mode option in the Text Recognition pane to help ensure that the
checkpoint would pass in future run sessions.

XML Checkpoints Overview

Relevant for: GUI tests and scripted GUI components

You can use XML checkpoints to check the contents of individual XML data files or documents that
are part of yourWeb application.

XML (Extensible Markup Language) is ameta-markup language for text documents that is endorsed
as a standard by theW3C (WorldWideWebConsortium). XMLmakes the complex data structures
portable between different computer environments/operating systems and programming languages,
facilitating the sharing of data.

XML files contain text with simple tags that describe the data within an XML document. These tags
describe the data content, but not the presentation of the data. Applications that display an XML
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document or file use either CSS (Cascading Style Sheets) or XSL-FO (XSL Formatting Objects) to
present the data.

You can perform checkpoints on XML documents contained inWeb pages or frames, on XML files,
and on test objects that support XML (such asWebXML test objects). An XML checkpoint is a
verification point that compares a current value for a specified XML element, attribute and/or value
with its expected value. When you insert a checkpoint, UFT adds a checkpoint step in the Keyword
View and adds aCheck CheckPoint statement in the Editor. During a run session, UFT compares
the expected results of the checkpoint to the current results. If the results do not match, the
checkpoint fails.

After a run session, you can view summary results of the XML checkpoint in the Run Results
Viewer. You can also view detailed results by opening the XMLCheckpoint Results window,
described in theHP RunResults Viewer User Guide.

A few common uses of XML checkpoints are described below:

l An XML file can be a static data file that is accessed to retrieve commonly used data for which a
quick response time is needed—for example, country names, zip codes, or area codes.
Although this data can change over time, it is normally quite static. You can use an XML file
checkpoint to validate that the data has not changed from one application release to another.

l An XML file can consist of elements with attributes and values (character data). There is a
parent and child relationship between the elements, and elements can have attributes
associated with them. If any part of this hierarchy (including data) changes, your application's
ability to process the XML file may be affected. Using an XML checkpoint, you can check the
content of an element to make sure that its tags, attributes, and values have not changed.

l XML files are often an intermediary that retrieves dynamically changing data from one system.
The data is then accessed by another system using Document Type Definitions (DTD), enabling
the accessing system to read and display the information in the file. You can use an XML
checkpoint and parameterize the captured data values if you want to check an XML document or
file whose data changes in a predictable way.

l XML documents and files often need a well-defined structure to be portable across platforms and
development systems. One way to accomplish this is by developing an XML schema, which
describes the structure of the XML elements and data types. You can use schema validation to
check that each item of content in an XML file adheres to the schema description of the element
in which the content is to be placed.

Note: XML checkpoints are compatible with namespace standards. A change in namespace
between expected and actual values results in a failed checkpoint.

For details on XML standards, see: http://www.w3.org/XML/

For details on namespace standards, see: http://www.w3.org/TR/1999/REC-xml-names-
19990114/
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XML Checkpoint Types

Relevant for: GUI tests and scripted GUI components

You can create the following types of XML checkpoints:

l XML Web Page/Frame Checkpoint. Checks an XML document within aWeb page or frame.

l XML File Checkpoint. Checks a specified XML file.

Using XML Objects and Methods to Enhance Your Test or Scripted
Component

Relevant for: GUI tests and scripted GUI components

UFT provides several scriptingmethods that you can use with XML data. You can use these
scriptingmethods to retrieve data and return new XML objects from existing XML data. You do this
by using the XMLUtil, orWebXML objects to return XML data and then using the supported
XMLData objects andmethods tomanipulate the returned data.

Tip: All XMLData objects andmethods are compatible with namespace and XPath standards.

For details on XML standards, see: http://www.w3.org/XML/

For details on namespace standards, see: http://www.w3.org/TR/1999/REC-xml-names-
19990114/

For details on XPath standards, see: http://www.w3.org/TR/1999/REC-xpath-19991116

For details on programming in the Editor, see "Programming in GUI Testing Documents in the
Editor" on page 994. For details on XML objects andmethods, see theSupplemental Objects
section of theHP UFT Object Model Reference for GUI Testing.
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Tasks

How to Insert a Checkpoint in a GUI Test or Component
Relevant for: GUI tests and components

This task describes how to insert a checkpoint step while recording or editing your test or
component. You can also add an existing checkpoint to a test or scripted component. It is generally
more convenient to define checkpoints after creating the initial test or component.

For details on supported checkpoints per add-in environment, see "GUI Checkpoints andOutput
Values Per Add-in" on page 2224

This task describes both the general process for inserting a new checkpoint step to your test or
component and the prerequisites and considerations for the different types of components.

This task includes the following steps:

l "Important information before inserting the checkpoint" on the next page

l "Define automatic page checkpoints - optional" on page 1421

l "Set global accessibility checkpoint preferences" on page 1421

l "Insert a checkpoint step while recording your test or component" on page 1422

l "Insert a checkpoint step while editing your test or component" on page 1422

l "Use programming to insert checkpoints in a test or scripted component" on page 1424

l "Set options for the checkpoint" on page 1424

l "Move checkpoint objects from the local object repository to a shared object repository -
optional" on page 1426
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Important information before inserting the checkpoint

Object
visibility in
application

l During an editing session, make sure the object is visible in your application
before inserting a standard checkpoint.

l For bitmap checkpoints: During a run session, bitmap checkpoints can
capture only the visible part of an object. Therefore, confirm that the object to
capture is always fully visible on the screen before a bitmap checkpoint step is
performed. One way to do this is to insert aMakeVisible statement (for
relevant environments) prior to your bitmap checkpoint step. For details on the
MakeVisiblemethod, see theHP UFT Object Model Reference for GUI
Testing.

l For file content checkpoints: The source file must be located on the file
system.

Availability l Recording sessions

l Editing sessions

l Active Screen (not supported for file content checkpoints or XML checkpoints)
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Important
Information

l Checkpoints can be viewed in the followingmodes:

n Simple Mode: Displays only the basic properties and expected values of
the checkpoint.

n Advanced Mode: Displays all supported properties and expected values of
the checkpoint.

l In ALM, you cannot create, edit, or rename checkpoints for keyword GUI
components.

l You cannot create image, table, or (Web) page checkpoints in a keyword GUI
component. These special checkpoint types are only available for tests and
scripted GUI components. However, if you select aWeb page or any table
object when creating a standard checkpoint for your component, you can
check their object properties like any other object.

l For bitmap checkpoints: If you want to create a bitmap checkpoint that
contains multiple objects, you should select the highest level object that
includes all the objects to include in the bitmap checkpoint.

l For text or text area checkpoints:

n Before you create a text or text area checkpoint for aWindows-based
application, make sure you configure the required capture settings in the
Text Recognition pane (Tools > Options > GUI Testing tab > Text
Recognition node. For details, see "Text Recognition Pane (Options
Dialog Box > GUI Testing Tab)" on page 542.

n You can also check the text property of an object inWindows-based and
other types of applications (includingWeb-based applications) by using a
standard checkpoint.

l For XML checkpoints:You can insert XML checkpoints to verify Web pages
and frames and to directly access and verify specific XML files in your system.

Define automatic page checkpoints - optional
In theWeb > Advanced pane of the Options dialog box (Tools > Options > GUI Testing tab >
Web > Advanced node), do one or more of the following:

l To instruct UFT to create automatic page checkpoints for every page during every recording
session, select theCreate a checkpoint for each Web page while recording check box.

l To instruct UFT not to perform automatic page checkpoints during run sessions, select the
Ignore checkpoints while running tests check box.

Set global accessibility checkpoint preferences
In theWeb Advanced pane of the Options dialog box (Tools > Options > GUI Testing tab > Web
> Advanced node), do one or more of the following:
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l Define the checks to include in the checkpoints. All accessibility checkpoints in your test use
the options that are selected in the AdvancedWebOptions dialog box at the time of the run
session. You can also view these options in the Accessibility Checkpoint Properties dialog box.

l (Optional) To instruct UFT to insert an accessibility checkpoint for each page as you record,
select theAdd Automatic accessibility checkpoint to each Web page while recording
check box. This creates an accessibility checkpoint for each page as you record.

Insert a checkpoint step while recording your test or component

1. Start a recording session before inserting a checkpoint.

2. Insert a checkpoint by doing one of the following:

n In the Record toolbar, click the Insert Checkpoint or Output Value button and select the
type of checkpoint from the drop-down list.

n Select Design > Checkpoint and choose the relevant type of checkpoint.

n Click the Insert Checkpoint or Output Value button in the toolbar and select the
type of checkpoint from the drop-down list.

3. UFT is hidden, and the pointer changes to a pointing hand. In your application, click the object
that you want to check.

Note: If the object in your application is associated with more than one location, the
Object Selection dialog box opens. This dialog box enables you to select an object to
check from the object tree. The objects in the tree are displayed with hierarchical order,
based on the location you clicked in the Active Screen or application.

Insert a checkpoint step while editing your test or component

1. Youmay need to open the application and display the relevant object before inserting a
checkpoint. This depends on the environment and the object type you are checking. For
details, see the prerequisite information for your specific checkpoint type.

2. Select the step where you want to add the checkpoint and do one of the following:

n Select Design > Checkpoint, and then select the relevant checkpoint option.

n Select Design > Checkpoint > Existing Checkpoint.

n Right-click any object in the Active screen and select the relevant checkpoint. You can
create checkpoints for any object in the Active Screen even if the object is not part of any
step in the Keyword View.
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If you use the Active Screen to insert a checkpoint, ensure that the Active Screen contains
sufficient data for the object you want to check. For details, see the section on the "Active
Screen Pane (Options Dialog Box > GUI Testing Tab)" on page 547.

Note: If the object in your application is associated with more than one location, the
Object Select Dialog Box opens. This dialog box enables you to select an object to
check from the object tree. The objects in the tree are displayed in hierarchical order,
based on the location you clicked in the Active Screen or application.

Notes:

l For table checkpoints:When inserting a table checkpoint, for certain objects in certain
environments, before the Table Checkpoint Properties dialog box opens, the Define/Modify
Row Range Dialog Box opens. In this dialog, select the row range to check.

l For text or text area checkpoints:

n To create the checkpoint, you first highlight a text string in the Active Screen then right-
click the string, and select Insert Text Checkpoint.

n When you create a text area checkpoint, you first define the area containing the text you
want UFT to check.

When you select the Text Area Checkpoint option, themouse turns into a crosshairs
pointer. Click and drag the crosshairs point to define this area. Release themouse button
after outlining the area required.

Tip: Hold down the left mouse button and use the arrow keys tomake precise
adjustments to the defined area.

l For file content checkpoints:When inserting a file content checkpoint, the File Content
Checkpoint Properties dialog box displays by default the option to select only All
Supported Files. When this is selected, only files with the expected extensions are
displayed (for example, .htm or .pdf files). You can also select a file that uses a non-
standard extension by selectingAll Files in the Files of type box and then selecting the
relevant file.

l For database checkpoints:

When inserting a database checkpoint, the DatabaseQuery Wizard opens.

a. In the DatabaseQuery Wizard, define the query for your checkpoint usingMicrosoft
Query or by manually entering a database connection and SQL statement.

b. If you selectedMicrosoft Query as your data source, Microsoft Query opens, enabling
you to define a query. When you are done, in the Finish page of the Query Wizard, use
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one of the following:

o Exit and return to HP Unified Functional Testing. Exits Microsoft Query.

o View data or edit query in Microsoft Query. View or edit the query prior to exiting
Microsoft Query.

c. If you selectedSpecify SQL statement manually, the Specify SQL statement page
opens, enabling you to specify the connection string and the SQL statement.

Use programming to insert checkpoints in a test or scripted component

l If you want to retrieve the return value of a checkpoint (a boolean value that indicates whether
the checkpoint passed or failed), youmust add parentheses around the checkpoint argument in
the statement in the Editor. For example:

a = Browser("MyBrowser").Page("MyPage").Check (CheckPoint("MyProperty"))

l You can also use theCheckPropertymethod and theCheckItemPropertymethod to check
specific property or item property values. For details, see theHP UFT Object Model Reference
for GUI Testing.

Set options for the checkpoint
In the "Checkpoint Properties Dialog Box", specify the settings for the checkpoint object.

For table checkpoints:

Define the cell selection for the table object in the Grid area of Table Checkpoint Properties
dialog box, as follows:

To: Do this:

Add a single cell to or remove it
from the check

Double-click the cell

Add an entire row to or remove it
from the check

Double-click the row header

Add an entire column to or
remove it from the check

Double-click the column header.

Add all cells to or remove all cells
from the check

Double-click the column header.
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Add a range of cells to the check Select the cells to add to the check and click theAdd

to Check
button

Remove a range of cells from
the check

Select the cells to remove from the check and click the

Remove from Check
button

For database checkpoints:

Define the cell selection for the database object in the Grid area of Database Checkpoint
Properties dialog box, as follows:

To: Do this:

Add a single cell to or remove it
from the check

Double-click the cell

Add an entire row to or remove it
from the check

Double-click the row header

Add an entire column to or
remove it from the check

Double-click the column header.

Add all cells to or remove all cells
from the check

Double-click the column header.

Add a range of cells to the check Select the cells to add to the check and click theAdd

to Check
button

Remove a range of cells from
the check

Select the cells to remove from the check and click the

Remove from Check
button

Tomodify the SQL query definition, in the Keyword View or Editor, right-click the database
object that you want to modify and select Object Properties.

For file content checkpoints:

In the File Content Checkpoint Properties dialog box, scroll to each line you want to compare
and select it.

As you hover over a line, a checkbox and a regular expression icon are displayed in the sidebar
to the left of that line.

l Click the check box to select (or clear) the line for verification.

l Click the Treat Line as Regular Expression/Plain Text button to add (or remove)
 backslashes prior to all special characters in that line. You can thenmodify any regular
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expressions, as needed.

Note:

n If the source file contains multiple ages, the File Content Editor is divided into
separate pages. You can then expand or collapse the pages, select or clear entire
pages for verification and so on.

n Pages with more than 19MB of content may take a long time to parse.

Move checkpoint objects from the local object repository to a shared
object repository - optional
After you insert a checkpoint step, the checkpoint object is added to the local object repository. If
you are using shared object repositories, you canmove the new checkpoint object to your shared
object repository.

How to Include and Ignore Areas When Comparing a
Bitmap - Use-Case Scenario

Relevant for: GUI tests and components

Suppose you want to compare an expected bitmap with an actual bitmap of the object in your
application, but there are areas of this runtime bitmap that might be affected by dynamic values and
parameters. If you include these areas in the checkpoint, running the steps with different values
may cause the checkpoint to fail.

This use-case scenario describes the process you would follow to define which areas to ignore and
include in a bitmap checkpoint that compares an expected bitmap with a runtime bitmap.

Note: For a task related to this scenario, see "How to Insert a Checkpoint in a GUI Test or
Component" on page 1419.

1. In UFT, start a recording session and open theWindows Calculator application (for example,
Start > Programs > Accessories > Calculator).

2. Record steps that multiply 7 by 5 and display the result.

3. Select Design > Checkpoint menu, or click the Insert Checkpoint or Output Value button

in the toolbar, and then select Bitmap Checkpoint. UFT is hidden, and the pointer
changes to a pointing hand.

User Guide
Chapter 50: Checkpoints in GUI Testing

HP Unified Functional Testing (12.00) Page 1426 of 2274



4. Select the Calculator application. If the "Object Selection Dialog Box " (described on page
1195) opens, select the top-level object and click OK. The "Checkpoint Properties Dialog Box"
(described on page 1432) opens.

Note: (For tests and scripted components) For the purpose of this use-case scenario, you
insert the bitmap checkpoint while recording your steps. However, the options are relevant
also when inserting a bitmap checkpoint from the Active Screen.

5. In the Bitmap Checkpoint Properties dialog box, select theCompare selection with runtime
bitmap radio button. For the purpose of this scenario, we will compare a bitmap of the entire
Calculator application.

6. Because the value in the number linemay change, depending on parameters that are used
during the run session, we want to ignore the number line when comparing the expected bitmap
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with the runtime bitmap.

To do this, click theMark Rectangle to Ignore button in the toolbar, and then select the
entire number line. Modify the size and position of your selection as needed. When you are
finished, double-click to finalize the selection.

The following example shows the bitmap display area when the number line is selected to be
ignored:

7. (Optional) If you need tomodify your ignored selection after you finalize it, you can do so by

clicking theMark Rectangle to Include button in the toolbar, and then selecting the areas
that you want to clear. Any areas that you clear from the ignored selection are included in the
comparison.
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The following example shows the bitmap display area after a part of the ignored selection is
selected for clearing (double-click the area to finalize):

8. (Optional) If you want additional areas to be ignored, click theMark Rectangle to Ignore

button , select the relevant areas, and double-click to finalize.

9. Click OK to close the Bitmap Checkpoint Properties dialog box and insert the bitmap
checkpoint. When you run your steps, the bitmap checkpoint ignores the area that you
selected, and the checkpoint passes even if the value in the number line changes.

How to Configure Text Recognition Settings
Relevant for: GUI tests and components

This task describes a suggested workflow for configuring text recognition settings.
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This task includes the following steps:

l "Prerequisites" below

l "Analyze the characteristics of the text" below

l "Set the appropriate options in the Text Recognition Pane " below

l "Check the text recognition settings" below

l "Adjust the settings as necessary" on the next page

l "Results" on the next page

1. Prerequisites
In your application, display the text you want to capture.

2. Analyze the characteristics of the text
Determine whether you can capture the text using a text (or text-like) property instead of using
a text recognitionmechanism.

If it must use text-recognition, analyze whether theWindows API or OCR mechanisms are
more likely to meet your needs.

For details, see "Text Recognition Overview" on page 1408 and "Guidelines for Text
Recognition" on page 1409.

3. Set the appropriate options in the Text Recognition Pane
For details, see "Text Recognition Pane (Options Dialog Box > GUI Testing Tab)" on page 542.

4. Check the text recognition settings
a. Create or open a test or component.

b. Do any of the following:

o Insert a text checkpoint or output value step (tests and scripted components only)

o Insert a step that uses one of the following test object methods:

o testobject.GetVisibleText

o testobject.GetTextLocation

o testobject.GetText (for Terminal Emulator objects)
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o Insert a step that uses one of the following reserved object methods (tests and scripted
components only):

o TextUtil.GetText

o TextUtil.GetTextLocation

c. Run the step to verify that text recognition works as expected.

For details, see "How to Insert a Checkpoint in a GUI Test or Component" on page 1419,
"How to Create or Modify anOutput Value Step" on page 1494, and theHP UFT Object
Model Reference for GUI Testing.

5. Adjust the settings as necessary
If the captured text is not as expected, analyze the problems and adjust the Text Recognition
options to fine tune the way UFT captures your text.

For details, see "Text Recognition Pane (Options Dialog Box > GUI Testing Tab)" on page 542
and "Guidelines for Text Recognition" on page 1409.

6. Results
You can now use text recognition to capture text from your application.
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Reference

Checkpoint Properties Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to edit your checkpoint properties for a selected checkpoint object.

The example below gives the basic structure for the various Checkpoint Properties dialog boxes.
Certain elements may differ between checkpoint types.
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To access 1. Ensure that a GUI action or component is in focus in the document pane.

2. Do one of the following:

n Insert a new checkpoint step and select an object from your application.

n Click in the Value cell of an existing checkpoint step, and click the

checkpoint properties icon .

n In an action or a scripted component:Right-click an existing
checkpoint step and select Checkpoint Properties.

n In the local or shared object repository, click an existing checkpoint object.
TheCheckpoint details are displayed on the right side of the object
repository window, in theObject Details area.

Important
information

The advanced properties of standard checkpoint objects cannot be viewed or
edited in ALM. Therefore, if one or more advanced properties are selected in a
standard checkpoint object, and an ALM user views its properties in ALM, the
dialog box displays text indicating that some properties are not shown.

This dialog box has the following areas:

l "Object Details Area" below

l "Properties Grid Area" on the next page

l "Configure Value Area" on the next page

l "Statement Location and Checkpoint Timeout Area" on page 1435

Object Details Area

UI Element Description

Name The name that UFT assigns to the checkpoint object. By default, the name is the
same as the name of the object on which the checkpoint step is being performed.
You can specify a different name for the checkpoint object or accept the default
name.

Class The type of object (read-only).

Note for keyword components: The class of the object is not displayed in
ALM.
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UI Element Description

Find in Repository. Displays the checkpoint object in its object repository. This
option is only available when editing an existing checkpoint step.

Note for keyword components: This option only available in advanced
mode.

(only
available for
Keyword
components

Advanced Mode/Simple Mode. Toggles the dialog box between Advanced
Mode and SimpleMode.

For details on Simple and Advancedmode, see "Simple and AdvancedMode" on
page 1397.

Properties Grid Area

The Properties grid area displays the properties to check in the object.

For standard checkpoints see "Properties Grid Area (Checkpoint Properties Dialog Box) -
Standard, Page, and Image Checkpoints" on the next page.

For bitmap checkpoints, see "BitmapOptions Section (Checkpoint Properties Dialog Box) -
Bitmap Checkpoints" on page 1438.

For table checkpoints see "Properties Grid Area (Checkpoint Properties Dialog Box) - Table
Checkpoints" on page 1446.

For text or text area checkpoints, see "Checkpoint Summary Area (Checkpoint Properties Dialog
Box) - Text/Text Area Checkpoints" on page 1451.

For file content checkpoints, see "File Content Editor (Checkpoint Properties Dialog Box) - File
Content Checkpoints" on page 1442.

For database checkpoints, see "Properties Grid Area (Checkpoint Properties Dialog Box) -
Database Checkpoints" on page 1441.

For page checkpoints, see "Properties Grid Area (Checkpoint Properties Dialog Box) - Standard,
Page, and Image Checkpoints" on the next page.

For accessibility checkpoints, see "Current Settings Area (Checkpoint Properties Dialog Box) -
Accessibility Checkpoints" on page 1438.

ForXML checkpoints, see "XML Tree/Options Area (Checkpoint Properties Dialog Box) -
XML Checkpoints" on page 1457.

Configure Value Area

The Configure Value area displays the options to configure the value of the object to be checked.

For a standard checkpoint, see "Configure Value Area (Checkpoint Properties Dialog Box) -
Standard/Image Checkpoints" on page 1436.

For a bitmap, file content, accessibility, orXML checkpoint, this area is not applicable.
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For a table or database checkpoint, see "Configure Value Area (Checkpoint Properties Dialog
Box) - Table/Database Checkpoints" on page 1448.

For a text or text area checkpoint, see "Checkpoint Options Area (Checkpoint Properties Dialog
Box) - Text/Text Area Checkpoints" on page 1452.

For a page checkpoint, see "Configure Value Area (Checkpoint Properties Dialog Box) - Page
Checkpoints" on page 1455.

Statement Location and Checkpoint Timeout Area

Note: If you are working with a keyword GUI component, this option is available only in
AdvancedMode.

User interface elements are described below:

UI Element Description

Checkpoint
timeout

Specifies the time interval (in seconds) during which UFT attempts to perform the
checkpoint successfully. UFT continues to perform the checkpoint until it passes
or until the timeout occurs. If the checkpoint does not pass before the timeout
occurs, the checkpoint fails.

Example:Suppose it takes some time for an object to achieve an expected
state. Increasing the checkpoint timeout value in this case can help ensure
that the object has sufficient time to achieve that state, enabling the
checkpoint to pass (if the datamatches) before themaximum timeout is
reached.

If you specify a checkpoint timeout other than 0, and the checkpoint fails, the Run
Results Viewer displays information on the checkpoint timeout.

Note: Themaximum allowed timeout for a checkpoint is 99999 seconds.

Insert
statement

Specifies whether to insert the checkpoint step before or after the currently
selected step. The default value is Before current step.

Note: Available only when inserting a new checkpoint step during an editing
session. During a recording session, the checkpoint step is always inserted
as the next step.

Properties Grid Area (Checkpoint Properties Dialog Box) - Standard,
Page, and Image Checkpoints

Relevant for: GUI tests and components
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Specific properties may vary depending on the type of object you are checking.

User interface elements are described below:

UI
Elements Description

Check
box

For each object class, UFT recommends default property checks. You can accept
the default checks or modify them accordingly.

To check a property, select the corresponding check box.

To exclude a property check, clear the corresponding check box.

Type l . Indicates that the value of the property is currently a constant.

l . Indicates that the value of the property is currently a test or action parameter
(tests only).

l . Indicates that the value of the property is currently a Data Table parameter.
(tests and scripted components only)

l . Indicates that the value of the property is currently an environment variable
parameter. (tests and scripted components only)

l . Indicates that the value of the property is currently a random number
parameter. (tests and scripted components only)

l . Indicates that the value of the property is currently a parameter. (keyword
components only)

Property The name of the property.

Value The expected value of the property. For details onmodifying property values, see
"Configure Value Area" on page 1434.

For keyword components:See also: "Parameterization / Properties Dialog Box
(Checkpoints)" on page 1473.

Configure Value Area (Checkpoint Properties Dialog Box) -
Standard/Image Checkpoints

Relevant for: GUI tests and components
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This area enables you to configure object property values or the values of the operation arguments
defined for the step.

User interface elements are described below:

UI
Elements Description

Constant A manually defined value that remains unchanged for the duration of the run. In
certain contexts, you can define a constant value using a regular expression.

If the entire value cannot be displayed in theConstant box, it is shown as
[complex value]. For example, the value of a list's all items property is amulti-
line value, where each line contains the value of an item in the list.

Parameter A value that is defined or generated externally and is retrieved during a run
session. For example, a parameter valuemay be defined in an external file or
generated by UFT.

TheParameter box displays:

l The current parameter definition for a value that is already parameterized

l The default parameter definition for a value that is not yet parameterized.

Constant Value Options/Parameter Options. Opens the Constant Value
Options or Parameter Options dialog boxes to edit the value for a constant value,
or select a different parameter type or modify the parameter settings for a
parameter value.

Note:When editing a constant value, you can define string or complex value
as a regular expression.

Compare
image
content
(for image
checkpoints
only)

Enables you to compare the expected image source file with the actual image
source file. If the expected and actual images are different, UFT displays them
both in the Run Results. If the images are identical, only one graphic is displayed.
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Current Settings Area (Checkpoint Properties Dialog Box) -
Accessibility Checkpoints

Relevant for: GUI tests and scripted GUI components

For an accessibility checkpoint, the Checkpoint Properties dialog box displays a series of possible
properties to check in the selected object.

User interface elements are described below:

UI
Element Description

Current
settings

(Read-only) The list of the checks to perform.

Note: Youmodify the settings for accessibility checkpoints in theWeb >
Advanced pane of the Options dialog box (Tools > Options > GUI Testing tab
> Web > Advanced node). For details, see the section on Accessibility
Checkpoint Options in Tests in theHP Unified Functional Testing Add-ins Guide.

Bitmap Options Section (Checkpoint Properties Dialog Box) -
Bitmap Checkpoints

Relevant for: GUI tests and scripted GUI components

The BitmapOptions area of the Bitmap Checkpoint Properties dialog box enables you to set the
area of the bitmap to check as well as recognition criteria for the bitmap images to check.
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Important Information

l In this area, you define the following:

n The type of comparison that you want UFT to perform when it runs a bitmap checkpoint
step.

o After selecting amode, click Advanced settings under the bitmap display area to open
the "Advanced Settings Dialog Box (Bitmap Checkpoints Dialog Box)" on page 1463
and define settings to fine-tune the comparison, or choose a custom comparer to run
the comparison.

o If a custom comparer is selected in the "Advanced Settings Dialog Box (Bitmap
Checkpoints Dialog Box)" on page 1463, you cannot change the type of comparison
selected in this area. To enable the selection of a different checkpoint mode. first
open the Advanced Settings dialog box and select UFT Default from theComparer
Type list.

o For keyword components only: The Checkpoint Mode area and theAdvanced
settings option are available only in AdvancedMode.

n The bitmap that UFT compares with or locates in your application during a run session.

The options available in this area depend on the checkpoint mode you selected.

o If you selected Locate selection within runtime bitmap, the bitmap to locate is
surrounded by a highlighted rectangle. By default, the whole bitmap is selected. You
can resize, move, or re-draw the rectangle to specify the area that you want the
checkpoint to locate.

o If you selectedCompare selection with runtime bitmap, you canmanually select
areas of the bitmap to include or ignore in the bitmap comparison.
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o By default, the whole bitmap is included in the comparison. If you want to select
smaller areas to compare, make sure to click Ignore Entire Bitmap first, to clear
this default.

o Set the toolbar buttons to specify the shape of your selection, and whether to
include or ignore it. Then click and drag the cursor to mark the areas you want to
select. Finalize a selection by double-clicking in it, or clicking once outside of it.
Right-click to cancel a selection before it is finalized.

o You can definemultiple areas to compare or ignore.

o If one selection overlaps another, the current selection overrides the previous one,
in the overlapping areas. Therefore, for example, if you want to adjust an area that
you selected to ignore, you can clear parts of the selection by selecting to include
them.

o For tests and scripted components: If you define the checkpoint to compare
only specific areas of the bitmap, the selected areas are also highlighted in the
actual and expected bitmaps displayed in the Run Results Viewer.\

o For keyword components:Available only in AdvancedMode.

User interface elements are described below:

UI Element Description

Compare
selection with
runtime
bitmap

Instructs UFT to compare the bitmap that you define with the bitmap of the
actual object in your application during the run session.

l Use the toolbar and editor to select areas to ignore or compare.

l Click Advanced settings to open the "Advanced Settings Dialog Box
(Bitmap Checkpoints Dialog Box)" on page 1463 and set Tolerance
settings to fine-tune the comparison.

Locate
selection
within runtime
bitmap

Instructs UFT to check whether the specified bitmap is found anywhere within
the bitmap of the actual object in your application during the run session.

l In the bitmap editor area (in the Properties grid area of the dialog box),
select the area that you want to locate. (By default, the whole bitmap is
selected.)

l Click Advanced settings to open the "Advanced Settings Dialog Box
(Bitmap Checkpoints Dialog Box)" on page 1463 and set Similarity
settings to fine-tune the comparison.
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UI Element Description

Locate image
within runtime
bitmap (load
image file)

Instructs UFT to check whether the specified image is found anywhere within
the bitmap of the actual object in your application during the run session.

l Click Select a bitmap file to load and browse to a .bmp file containing the
image to use for the checkpoint. UFT creates a copy of the selected file
and stores it within the checkpoint. For keyword components, the copied
file is saved with the checkpoint in ALM.

Note: If the file you want to load is stored in a network folder, youmust
map the network folder on your computer before navigating to the file.

l Click Advanced settings to open the "Advanced Settings Dialog Box
(Bitmap Checkpoints Dialog Box)" on page 1463 and set Similarity
settings to fine-tune the comparison.

<bitmap
selection
area>

The area of the selected bitmap to check. Use the toolbar controls to
customize the area to check.

Properties Grid Area (Checkpoint Properties Dialog Box) - Database
Checkpoints

Relevant for: GUI tests and components

For a database checkpoint, the properties grid area displays a grid with the content of the database
object.
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Important
information

l The column header names are captured from the database you selected for
your checkpoint.

l Double-clicking on the grid toggles the settings for all selected cells. Therefore,
if you double-click a row header, a column header, or the top left corner of the
grid, any cells that were previously included in the check are removed from it,
and any cells that were not previously included in the check are added to it.

l Whenmore than one cell is selected, the options in the Expected Data tab are
disabled.

User interface elements are described below:

<grid
area>

The grid area displays the captured/expected values of all the cells in the table. Only
the ones with blue check marks are used (checked) by the checkpoint. You can check
the entire table, specific rows, specific columns, or specific cells.

Change Modifies the row range. For details, see "Define/Modify Row Range Dialog Box" on
page 1467.

Add/Remove from check. Add or remove the selected cells from the check.

File Content Editor (Checkpoint Properties Dialog Box) - File
Content Checkpoints

Relevant for: GUI tests and scripted GUI components

Whenworking with a file content checkpoint, the Properties Grid area displays a File Content Editor
which enables you to specify the text to check in a document that is generated or accessed during a
run session.
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User interface elements are described below:

UI Element Description

Comparison
file path

The file path of the generated document that you want to compare during the run
session.

You can enter a pathmanually or click theSelect Comparison File button to
navigate to the required file. The path can be relative or absolute (unless you use
a regular expression). The file must be located in the file system.

When you initially specify a file to compare, the textual content from that file is
displayed in the file content editor of the dialog box as the expected value of the
checkpoint. If you later change this path, the content in the file content editor is
not affected.

Note: The document must not be password-protected, otherwise, UFT will
not be able to access it during a run session.

You can use the following when specifying the document path:

l Configure Verification Value (Parameter/Regular Expression).
Opens the "Value Configuration Options Dialog Box" (described on
page1579). You use this dialog box to define the file path as a constant or
parameter value, with or without a regular expression.

For example, suppose your application is being released inmultiple
languages, and you want to compare a different source file for each language.
You can specify a data table parameter to instruct UFT to use a different file
for each iteration.

Displayed only when you hover over theComparison file path text box.

Note: If you specify a parameter value for the comparison file path and
multiple files that match the value exist in the specified location, UFT
performs the checkpoint on the latest generated file (according to its
creation time).

If you use a regular expression, youmust specify amapped drive, for
example: C:\\Program Files\\HP\\Unified Functional Testing\\Tests\\.*\.txt

l Select Comparison File. Enables you to navigate to the file you want to
compare.
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UI Element Description

Select/Clear Line for Verification. This toggle button enables you to select or
clear a line to compare with the generated file during a run session.

When you select a line, UFT highlights it and selects the check box to the left of
the line.

(Also available from the context menu)

Treat Line as Regular Expression/Plain Text. This toggle button enables you
to instruct UFT to look for and handle regular expressions in the line.

Note: The line does not need to be selected for comparison to insert a
regular expression (or to modify the text in general).

(Also available from the context menu)

Add Parameter to Line. Opens the "Value Configuration Options Dialog Box"
(described on page 1579). You use this dialog box to define a parameter as a
constant or parameter value.

For example, suppose you inserted a parameter in the "Comparison file path" box
because you want to compare a different file during each iteration. You can
specify a data table parameter to instruct UFT to use a different value for each
iteration.

(Also available from the context menu)

Open Regular Expression Evaluator. Opens the "Value Configuration Options
Dialog Box" (described on page 1579). You use this dialog box to create and test
a regular expression enabling you to determine whether it suits your needs.

(Also available from the context menu)

User Guide
Chapter 50: Checkpoints in GUI Testing

HP Unified Functional Testing (12.00) Page 1444 of 2274



UI Element Description

Preview Comparison. Opens a comparison window showing the differences
between the source file in the file system and the currently displayed file in the
file content editor.

Usage examples:

l Suppose youmodified the text in the file content editor by adding parameters
and deleting some text and lines, youmay want to compare the current
content to the text in the original file to make sure that your checkpoint is still
applicable.

l Suppose the original file in the file system was modified. You can compare
the content in that file with the content of the text in the file content editor.

Tip: If the text in the source file is very different from the text in the file
content editor, youmay want to recreate the checkpoint.

Note:

l If you select Checkpoint Properties in the "Advanced File Content
Checkpoint Properties Dialog Box"(described on page 1461), these
properties are ignored during a preview comparison. (Comparison
Settings, however, are included in the preview comparison.)

l This view is similar to the comparison available in the Captured Data
pane in the Run Results Viewer for failed file content checkpoint steps.
For details, see the section on File Content Checkpoint Results
(described in theHP RunResults Viewer User Guide).

-- Search for. Text box in which you can optionally enter text for which to search.
As you type, all instances of the specified text are highlighted. Press ENTER to
jump to the first instance if it is not visible in the file content editor.

You can use the following buttons to navigate between each instance of the
specified text:

Find Next. Jumps to the next instance of the specified text in the file
content editor.

Find Previous. Jumps to the previous instance of the specified text in the
file content editor. (Enabled only after you click Find Next.)

Advanced Opens the "Advanced File Content Checkpoint Properties Dialog Box". This
dialog box enables you to set additional comparison settings and checkpoint
properties.
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UI Element Description

Page The page from the source file being compared.

Pages are displayed only when the content from the source file exceeds one
page.

You can:

l View the number of pages in the file being compared.

l Expand or contract a specific page to view or hide the content on that page.

l Select the adjacent check box to select all of the lines on a page.

l Clear the adjacent check box to clear the selection of all of the lines on a
particular page.

Properties Grid Area (Checkpoint Properties Dialog Box) - Table
Checkpoints

Relevant for: GUI tests and scripted GUI components

For a table checkpoint, the Properties Grid area displays two tabs:

l "Table Content Tab" below

l "Properties tab" on the next page

Table Content Tab

In the Table Content, the dialog box displays a grid with the content of the selected Table object.
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User interface elements are described below:

<grid
area>

The grid area displays the captured/expected values of all the cells in the table. Only
the ones with blue check marks are used (checked) by the checkpoint. You can
instruct UFT to check the entire table, specific rows, specific columns, or specific
cells.

Note: UFTchecks only cells containing a check mark.

Change Enables you to define or modify the row range to check by opening the "Define/Modify
Row Range Dialog Box" on page 1467.

Add/Remove from check. Add or remove the selected cells from the check.

Properties tab

In the Properties tab, the dialog box displays the properties of the Table object (without the table
content).

User interface elements are described below:

UI
Elements Description

Check
box

For each object class, UFT recommends default property checks. You can accept
the default checks or modify them accordingly.

To check a property, select the corresponding check box.

To exclude a property check, clear the corresponding check box.
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UI
Elements Description

Type l . Indicates that the value of the property is currently a constant.

l . Indicates that the value of the property is currently a test or action parameter
(tests only).

l . Indicates that the value of the property is currently a Data Table parameter.
(tests and scripted components only)

l . Indicates that the value of the property is currently an environment variable
parameter. (tests and scripted components only)

l . Indicates that the value of the property is currently a random number
parameter. (tests and scripted components only)

l . Indicates that the value of the property is currently a parameter. (keyword
components only)

Property The name of the property.

Value The expected value of the property. For details onmodifying property values, see
"Configure Value Area" on page 1434.

For keyword components:See also: "Parameterization / Properties Dialog Box
(Checkpoints)" on page 1473.

Configure Value Area (Checkpoint Properties Dialog Box) -
Table/Database Checkpoints

Relevant for: GUI tests and scripted GUI components

For a table checkpoint (in the Table Content Tab) and a database checkpoint, this area displays
three tabs:

l "Expected Data Tab" on the next page

l "Settings Tab" on the next page

l "Cell Identification Tab" on page 1450

Note: For a table checkpoint, the Properties tab also displays the Configure Value area, For
details, see "Configure Value Area (Checkpoint Properties Dialog Box) - Standard/Image
Checkpoints" on page 1436.
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Expected Data Tab

Important
information

Whenmore than one cell is selected (highlighted) in the grid area, the options in
the Expected Data tab are disabled.

User interface elements are described below:

UI
Elements Description

Selected
cell

Indicates the table name and the row and column numbers of the selected cell.

Configure
value

Enables you to set the expected value of the cell as a constant or parameter. For
details onmodifying values, see "Configure Value Area (Checkpoint Properties
Dialog Box) - Standard/Image Checkpoints" on page 1436.

Constant Value Options/Parameter Options. Opens the Constant Value Options
or Parameter Options dialog boxes to edit the value for a constant value, or select a
different parameter type or modify the parameter settings for a parameter value.

Note:When editing a constant value, you can define string or complex value
as a regular expression.

Settings Tab

Important
information

l The settings in this tab apply to all cells marked for verification.

l The default setting is to treat cell values as strings and to check for the
exact text, while ignoring spaces.

User interface elements are described below:

Option Description

Verification
type

Specifies how cell contents are compared:

l String Content. (Default) Evaluates the content of the cell as a string. For
example, 2 and 2.00 are not recognized as the same string.

l Numeric Content. Evaluates the content of the cell according to numeric
values. For example, 2 and 2.00 are recognized as the same number.

l Numeric Range. Compares the content of the cell against a numeric range,
where theminimum andmaximum values are any real number that you
specify. This comparison differs from string and numeric content verification in
that the table data is compared against the range that you defined and not
against a specific expected value.
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Option Description

Exact
match

(Default) Checks that the exact text, and no other text, is displayed in the cell.
Clear this check box if you want to check that a value is displayed in a cell as part
of the contents of the cell.

Available only whenString Content is selected as theVerification type.

Ignore
space

(Default) Ignores spaces in the captured content when performing the check. The
presence or absence of spaces does not affect the outcome of the check.

Available only whenString Content is selected as theVerification type.

Match case Conducts a case sensitive search.

Available only whenString Content is selected as theVerification type.

Min / Max Specifies the numeric range against which the content of the cell is compared.
The range values can be any real number.

Available only whenNumeric Range is selected as theVerification type.

Cell Identification Tab

Important information The settings in this tab apply to all cells marked for verification.

User interface elements are described below:

Identify
columns

Specifies the location of the column (in your actual table) containing the cell(s) to
which you want to compare the expected data.

l By position. (Default) Locates cells according to the column position. A shift
in the position of the columns within the table results in amismatch.

l By column name. Locates cells according to the column name. A shift in the
position of the columns within the table does not result in amismatch. (Enabled
only when the table contains more than one column.)
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Identify
rows

Specifies the location of the row (in your actual table) containing the cell(s) to
which you want to compare the expected data.

l By row number. (Default) Locates cells according to the row position. A shift
in the position of any of the rows within the table results in amismatch.

l By selected key column(s). Locates the row(s) containing the cells to be
checked by matching the value of the cell whose columnwas previously
selected as a key column. A shift in the position of the row(s) does not result
in amismatch. If more than one row is identified, UFT checks the first
matching row. You can usemore than one key column to uniquely identify any
row.

Note: A key symbol is displayed in the header of selected key columns.

Use value
match
criteria to
identify
data in the
key
column

Instructs UFT to use the verification type settings from the Settings tab as the
criteria for identifying data in the key column.

Enabled only when you select to identify rows By selected key column(s).

Checkpoint Summary Area (Checkpoint Properties Dialog Box) -
Text/Text Area Checkpoints

Relevant for: GUI tests and components

For a text or text area checkpoint, the Properties Grid area displays a summary of the text to check.
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User interface elements are described below:

UI Element Description

Checkpoint
Summary

Summarizes the selected text for the checkpoint. It displays the text you selected
when creating the checkpoint, plus the text before and after it. UFT automatically
displays the checked text in red, and the text before and after the checked text in
blue.

For text checkpoints inWeb-based environments, it displays the text you selected
when creating the checkpoint, plus some text before and after it. For text and text
area checkpoints inWindows-based environments, it displays the text you
selected when creating the checkpoint.

Note: InWindows-based environments, if there is more than one line of text
selected, the Checkpoint Summary area displays [complex value] instead of
the selected text string. You can click Configure to view andmanipulate the
actual selected text for the checkpoint.

Configure Opens the "Configure Text Selection Dialog Box" (described on page 1466),
where you can specify the checked text, the text before (if any), and the text after
(if any).

Reset Resets the text selection to the previous configuration.

Checkpoint Options Area (Checkpoint Properties Dialog Box) -
Text/Text Area Checkpoints

Relevant for: GUI tests and scripted GUI components

Whenworking with a Text or Text Area checkpoint, the Configure Value area displays three
different sets of options, depending on if you are editing the text to check, the text before the
checked text, or the text after the checked text:

l "Checked Text Option" on the next page

l "Text Before Option" on the next page

l "Text After Option" on page 1454
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Checked Text Option
User interface elements are described below:

UI
Element Description

Constant (Default) Sets the expected value of the checked text as a constant. For details on
modifying values, see "Configure Value Area " on page 1575.

Tip: TheConstant box displays the checked text. You can change the
checked text by typing in theConstant box or by using the "Configure Text
Selection Dialog Box" (described on page 1466).

Parameter Sets the expected value of the checked text as a parameter. For details on
modifying values, see "Configure Value Area " on page 1575.

Match
case

Conducts a case-sensitive check.

Exact
match

Checks for the exact expected text. For example, if you create a checkpoint with
the following description, Check that New York is displayed between Flight
departing from and to San Francisco, and select Exact match, if the actual text is
New York City, the checkpoint fails. If you do not select Exact match, the
checkpoint passes because the expected text is contained within the actual text.

Ignore
spaces

Ignores spaces in the captured text when performing the check. The presence or
absence of spaces does not affect the outcome of the check.

Text not
displayed

Checks that the text string is not displayed. For example, if you create a checkpoint
with the following description, Check that New York is displayed between Flight
departing from and to San Francisco, and select Text not displayed, UFT checks
that the text New York is not displayed.

Text Before Option
User interface elements are described below:

UI Element Description

Use the text
before

Checks the text before the checked text. To ignore this text, clear this check
box.
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UI Element Description

Text to
check is
displayed
after
occurrence _
of

Checks that the checked text is displayed after the specified text.

If the identical text string you specify is displayedmore than once on the page,
you can specify the occurrence of the string to which you are referring.

If you accept the default text that UFT recommends, the number in the dialog
box will be correct. If youmodify the text, confirm that the occurrence number is
accurate.

If you choose a non-unique text string, change the occurrence number
appropriately. For example, if you want to check that the words Mercury Tours
are displayed after the fourth occurrence of the word the, enter 4 in the Text to
check is displayed after occurrence box.

Constant (Default) Sets the expected value of the text before the checked text as a
constant. For details onmodifying values, see "Configure Value Area " on page
1575.

If youmodify the text, whenever possible, use a string that is unique within the
object so that the occurrence number is 1.

Tip: TheConstant box displays the text before the checked text. You can
change the text by typing in theConstant box or by using the "Configure
Text Selection Dialog Box" on page 1466.

Parameter Sets the expected value of the text before the checked text as a parameter. For
details onmodifying values, see "Configure Value Area " on page 1575.

Text After Option
User interface elements are described below:

UI Element Description

Use the
text after

Checks the text after the checked text. To ignore this text, clear this check box.
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UI Element Description

Text to
check is
displayed
before
occurrence
_ of

Checks that the checked text is displayed before the specified text. If the identical
text string you specify is displayedmore than once on the page, you can specify to
which occurrence of the string you are referring.

Note: UFT starts counting occurrences of the specified Text After value from
the beginning of the text string you selected to output, and includes any
occurrences within the output value string itself.

If you accept the default text that UFT recommends, the number in the dialog box
will be correct. If youmodify the text, confirm that the occurrence number is also
accurate.

If you choose a non-unique text string, change the occurrence number
appropriately. For example, if you want to check that the words Mercury Tours are
displayed before the fourth occurrence of the word the (where occurrences are
counted only at the end of the text defined in the Text Before option area), enter 4
in the Text to check is displayed before occurrence box.

Constant (Default) Sets the expected value of the text after the checked text as a constant.
For details onmodifying values, see "Configure Value Area " on page 1575.

If youmodify the text, whenever possible, use a string that is unique within the
object so that the occurrence number is 1.

Tip: TheConstant box displays the text after the checked text. You can
change the text by typing in theConstant box or by using the "Configure Text
Selection Dialog Box" on page 1466.

Parameter Sets the expected value of the text after the checked text as a parameter. For
details onmodifying values, see "Configure Value Area " on page 1575.

Configure Value Area (Checkpoint Properties Dialog Box) - Page
Checkpoints

Relevant for: GUI tests and scripted GUI components

Whenworking with a Page checkpoint, the Configure Value area displays three separate sections:

l "Configure Value Area" below

l "HTML Verification Area" on the next page

l "All Objects in Page Area" on the next page

Configure Value Area
For details on the user interface elements in this area, see "Configure Value Area " on page 1575.
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HTML Verification Area

Important: You can select these options only when creating a Page checkpoint while
recording.

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Element Description

HTML source Checks that the source in theWeb page being testedmatches the
expected HTML code (the source code of the page at the time that the test
or scripted component is recorded). Available only when creating a page
checkpoint while recording.

Edit HTML Source
(enabled only
when the HTML
Source check box
is selected)

Opens the HTMLSource dialog box, which displays the expected HTML
code. Edit the expected HTML source code and click OK. Note that you
can also use regular expressions when editing the expected HTML source
code if you click the regular expression check box at the bottom of the
page.

HTML tags Checks that the HTML tags in theWeb page being testedmatch the
expected HTML tags (the HTML tags on the page at the time that the test
or scripted component is recorded).

Edit HTML Tags
(enabled only
when the HTML
Tags check box is
selected)

Opens the dialog box that displays the expected HTML tags. Edit the
expected HTML tags and click OK. Note that you can also use regular
expressions when editing the HTML tags if you click the regular
expression check box at the bottom of the page.

All Objects in Page Area
User interface elements are described below:

UI Element Description

Links Checks the functionality of the links in the page according to your selections in
the "Filter Link Check Dialog Box".

Filter Link
Check
(enabled only
when the
Links check
box is
selected)

Opens the "Filter Link Check Dialog Box", which enables you to specify which
hypertext links to check in the page.

Images Checks that the images are displayed on the page according to your selections
in the "Filter Link Check Dialog Box".
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UI Element Description

Filter Image
Check
(enabled only
when the
Images check
box is
selected)

Opens the "Filter Link Check Dialog Box" (described on page 1470), which
enables you to specify which image sources to check in the page.

Broken links Instructs UFT to check for broken links.

Note: If you want to check only links that are targeted to your current
host, select theBroken links - checks only links to current host
option in theWeb pane of the Options dialog box (Tools > Options > GUI
Testing tab > Web > General node. For details, see the section on
settingWeb testing options in theHP Unified Functional Testing Add-ins
Guide.

XML Tree/Options Area (Checkpoint Properties Dialog Box) -
XML Checkpoints

Relevant for: GUI tests and scripted GUI components

For an XML checkpoint, this area displays the XML hierarchy of the selected test object and the
elements, attributes, and values to check.

This area includes the following sections:

l "XML Tree" below

l "Options Area" on page 1459

XML Tree
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Important
information

l The XML tree displays the hierarchical relationship between each element and
value in the XML tree, enabling you to select the specific elements, attributes
and values you want to check. Each element is displayed with a icon. Each
value is displayed with a icon.

l Select the check box next to an element or value node to include that item in
the checkpoint. Select an element or value node in the XML tree to display,
edit, or parameterize its expected attributes and values in the options area of
the XMLCheckpoint Properties dialog box. For details, see the section on the
Options area, below.

User interface elements are described below:

UI
Element Description

Add Child. Adds a child node below the selected node in the tree.

Insert Sibling. Adds a sibling node at the same level as the selected node in the tree.

Add Value. Enables you to assign a constant or parameterized value to the selected
element.

Delete. Deletes the selected node. Note that you cannot delete the root node of the
checkpoint.

Import XML. Enables you to browse to an existing XML file and import it. The new
file replaces the selected node and its current sub-tree.

Export XML. Enables you to save the content of the checkpoint tree to an .xml file.
This option is enabled only when the root node of the tree is selected.

Edit XML as Text. Opens the "Edit XML as Text Dialog Box" (described on page
1469), enabling you tomodify the XML text of the selected node and its subnodes in a
text editor.

Select All. Selects all element and value nodes in the XML tree as well as all element
attributes.

Clear All. Clears all element and value nodes in the XML tree as well as all element
attributes.

Duplicate. Adds a new node, identical to the selected one, as a sibling node at the
same level as the selected node in the XML tree.

Available:Only from the context menu (right-click menu).

<XML
tree>

A hierarchy of all XML elements in the selected XML test object.
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Options Area

User interface elements are described below:

UI Element Description

Attribute The list of attributes for the selected element or value node in the XML tree.

Value The list of values for the selected element or value node in the XML tree.

Check
number of
attributes

Checks the number of attributes that are attached to the element.

Check
number of
child
element
occurrences
in block

Displays the number of child elements associated with the selected parent
element. If you select this option, UFT verifies that the number of child elements
in your XML tree (with the specified name, if applicable) corresponds to the
number that appears in theCheck number of child element occurrences in
block field.

You can specify the child element name for the Number of child element
occurrences check. If you select a child element name, UFT verifies that the
number of child elements with that name corresponds to the number that you
specify in theNumber of child element occurrences in block field.

Select Any Child (default) to check the total number of child elements
associated with the selected parent element.

Schema
Validation

Confirms that the XML in your application or file adheres to the structure defined
in a specific XML schema or schemas. You can validate the structure of the XML
you are checking using one or more external schema files or using schemas
embedded within your XML document. For details, see "Schema Validation
Dialog Box" on page 1476.
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Add Existing Checkpoint Dialog Box
Relevant for: GUI tests and scripted GUI components only

This dialog box enables you to add an existing checkpoint to your test while editing.

To access 1. Ensure that a GUI action or component is the active document in the
document pane.

2. Select Design > Checkpoint > Existing Checkpoint.

Important
information

l This option is available only if at least one of the object repositories associated
with the current action (including the local object repository) contains at least
one checkpoint.

l If a test object step is highlighted in the Keyword View or the cursor is located
in a step in the Editor, the Add Existing Checkpoint dialog box opens with the
TestObjects tree hidden. The test object displayed in the Test object box is
the object from the highlighted step in the Keyword View or the specific object
where the cursor is located in the Editor.

See also "Adding Existing Checkpoints to a Test" on page 1396
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Test object The name of the test object for which you are adding a checkpoint.

Test Objects
tree

All objects in the current action.

Show/Hide Test
Objects

Shows or hides the Test Objects tree.

Display only
checkpoints
relevant to the
selected test
object

When selected, UFT determines which checkpoints from the current action's
object repositories are relevant for the selected object (based on the
checkpoint type and the properties selected in the checkpoint) and displays
only those checkpoints in theCheckpoints list.

When using this option, open your application and display the selected object
to enable UFT to accurately determine all of the checkpoints that can apply
to that object.

Checkpoints Lists the checkpoints available for insertion.

If theDisplay only checkpoints relevant to the selected test object
option is cleared, this list includes all checkpoints from all object repositories
associated with the current action.

If theDisplay only checkpoints relevant to the selected test object
option is selected, this list displays only the relevant checkpoints as
described above.

<checkpoint
details area>

Displays the settings of the selected checkpoint in read-only format.

Configure value The value for the selected checkpoint in read-only mode. For details, see
"Value Configuration and Parameterization" on page 1570.

Advanced File Content Checkpoint Properties Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to configure how the checkpoint is performed.
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To access In the "Checkpoint Properties Dialog Box" (described on page 1432), select
Advanced in the toolbar.

Important
information

When a file content checkpoint step runs, it locates the checkpoint text within the
line by comparing all of the text on that line. The options in this dialog box instruct
UFT how to treat the text on every line in the file in which one or more checkpoints
are specified for a single checkpoint object. (You can createmultiple checkpoints
in a single file—all within a single checkpoint object.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

See also "Checkpoint Properties Dialog Box" on page 1432

User interface elements are described below:

UI Element Description

Ignore spaces Ignores extraneous spaces on the same line as the checked text when
comparing the expected content with the actual content. This is useful
when theremight potentially be one or more spaces in the text preceding
or following the checked text, and you do not want the checkpoint to fail
because of this.

Note: This setting does not affectmissing spaces, which are treated
as non-matching text.

Default: Cleared
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UI Element Description

Match case Conducts a case-sensitive check of all the text on the same line as the
checked text when comparing the expected content with the actual
content.

Default: Selected

Verify page count Compares the number of pages in the checkpoint object with the number
of pages in the file generated or accessed during the run session.

When this option is selected, the checkpoint fails if the page count
comparison is not identical.

Note: This setting is ignored during a preview comparison.

Default:Cleared

Fail checkpoint for
additional/missing
lines

Compares the number of lines in the checkpoint object with the number of
lines in the file generated or accessed during the run session.

When this option is selected, the checkpoint fails if one or more lines was
added or removed in the file being compared.

Note: This setting is ignored during a preview comparison.

Default:Cleared

Advanced Settings Dialog Box (Bitmap Checkpoints
Dialog Box)

Relevant for: GUI tests and components

This dialog box enables you to define advanced settings for a bitmap checkpoint, in order to fine-
tune the comparison that UFT performs when running the checkpoint.

The following image shows an example of the Advanced Settings dialog box when theCompare
selection with runtime bitmap option is selected in the Bitmap Checkpoint Properties dialog box,
and no custom comparers are installed and registered on the computer.
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The following image shows an example of the Advanced Settings dialog box when a custom
comparer is selected in the Comparer Type list. (TheComparer options are enabled because a
custom comparer is installed and registered on the UFT computer, and

To access In the "Checkpoint Properties Dialog Box" (described on page 1432), click
Advanced settings beneath the bitmap display area (available for keyword
components only in AdvancedMode).
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Important
information

The options enabled in this dialog box differ, depending on whether you are
comparing an expected bitmap with a runtime bitmap or locating a specified
bitmap within the runtime bitmap.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

See also l "Checkpoint Properties Dialog Box" on page 1432

l "Fine-Tuning the Bitmap Comparison" on page 1403

User interface elements are described below:

UI Element Description

Tolerance
Relevant only when theCompare selection with runtime bitmap option is selected.

RGB tolerance Enables you to define the percent by which the RGB values of the pixels in
the runtime bitmap can differ from those of the expected bitmap and allow the
checkpoint to pass. Available only for bitmaps with a color depth of 24 bits.

Pixel tolerance Enables you to define the number or percentage of pixels in the runtime
bitmap that can differ from those in the expected bitmap and allow the
checkpoint to pass.

Select either thePercent orPixels radio button, and set the relevant value. If
you switch between thePercent andPixels radio buttons after entering the
tolerance value, the value is recalculated based on your selection. (100% is
the total number of pixels in the expected bitmap or selected area.)

Similarity
Relevant only when the Locate selection within runtime bitmap or Locate image within
runtime bitmap (load image file) option is selected.

At least Enables you to determine the amount of differences in pixels between the
specified bitmap that you are locating and the runtime bitmap that can occur
and still allow the checkpoint to pass.

If used, then UFTmay locate possible candidates for the specified bitmap
that you are attempting to locate, and display the possible candidates in the
Run Results Viewer, in addition to the results of the checkpoint.

Comparer
Relevant only:

l When theCompare selection with runtime bitmap option is selected.

l If one or more custom comparers are installed and registered on the UFT computer. For
details, see "Fine-Tuning the Bitmap Comparison" on page 1403.
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UI Element Description

Type Enables you to select the comparer for UFT to use to run the checkpoint. You
can select the UFT default comparer or a custom comparer.

A custom comparer is a COM object that you or a third party develop to run
the bitmap comparison in the checkpoint according to amore specific
algorithm.

Input Enables you to provide input (in string format) to the custom comparer, for
any configuration options it supports. By default, this box displays a
configuration string provided by the custom comparer (if available).

Example:Youmight be able to specify tolerance levels, an acceptable
deviation in size or location of the bitmap, and so on.

Relevant only if a custom comparer is selected from the Comparer Type list.

Details Opens help information provided by the custom comparer (if available). This
help can include instructions for providing configuration input to the comparer,
information about the algorithm that the custom comparer uses to compare
the bitmaps, an explanation about when to use this custom comparer, and so
on.

Available only if a custom comparer is selected from the Comparer Type list,
and documentation is provided for this comparer.

Configure Text Selection Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to specify the checked text, the text before, and the text after, for a text
checkpoint.
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To access In the Checkpoint Summary Area of the Checkpoint Properties dialog box, click
theConfigure button in theCheckpoint Summary area.

Important
information

l UFT displays the checked text in red and the text before and after it in black
(as indicated in the Legend displayed in the dialog box).

l To remove text from the current text selection configuration, highlight only the
text you want included as the before or after text and click the appropriate
button. Any text that is not selected as Checked Text, Text Before, or Text
After is displayed in gray. The gray text is not displayed the next time the
Configure Text Selection dialog box is opened.

Example: In the sample image above, suppose you wanted to check only the
word information, and you wanted UFT to look for this text between Find
detailed and about your destination, then:

l Highlight the word information, and click Checked Text. The word
information remains red, and the other text turns black.

l Highlight the words Find detailed and click Text Before. The words Find
detailed remain black, and all text preceding it turns gray. This gray text
will be removed from the text configuration when you click OK.

l The words about your destination are already marked in black as the text
after, so there is no need tomodify this configuration.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

Tomodify which text is checked and how that text is found, based on the text before and after it,
highlight the text you want to set for one of these items and then click the appropriate button:

UI
Elements Description

Checked
Text

Sets the highlighted text as the checked text. UFT displays this text in red and the
remainder in black.

Text
Before

Sets the highlighted text as the text before the checked text.

Text After Sets the highlighted text as the text after the checked text.

Define/Modify Row Range Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to define or modify the number of rows included in an existing table or
database checkpoint.
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The following image shows this dialog box as it appears for a table checkpoint in definemode.
Depending on themode of the dialog box, the actual title bar of the imagemay differ. This dialog box
may also differ when viewed for a table output value object.

To access In the Table Checkpoint Properties dialog box or Table Output Value Properties
dialog box, click theChange button.

Important
information

This dialog box is also available for certain list view objects. This enables you to
define a table checkpoint on specific rows within a list view object.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

See also l "Checkpoint Properties Dialog Box" on page 1432

l "Considerations for Modifying Row Ranges" on the next page

l "How to Create or Modify anOutput Value Step" on page 1494

User interface elements are described below:

UI
Elements Description

All rows Includes all rows in the checkpoint or output value.

Note: Capturing all of the data for large table or list view objects may take
some time.

Visible
Rows

Includes only the rows that are currently visible in your application in the
checkpoint or output value.

Available only for some environments or object types.

Another
range

Includes the rows you specify in the checkpoint or output value.

You can specify any row range between 1 and the number of rows listed in the
dialog box.
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Considerations for Modifying Row Ranges

l If your modified row range includes new rows, UFT captures the current values of the new rows
from the open application.

l If your modified row range includes some or all of the rows that were already included in the
checkpoint, the expected values of those cells are not changed. This enables you tomodify the
row range without losing parameterization, regular expressions, or other changes youmay have
made to the expected cell values in your checkpoint.

Therefore, you cannot use theModify Row Range dialog box to update the expected values of
an existing table checkpoint. To update the expected values of your checkpoint, use theUpdate
Run Mode option. For details, see "Update Options Tab (Update Run Dialog Box)" on page
1107.

l If your modified row range excludes some or all of the rows that were previously included in your
checkpoint, those rows (and any modifications youmade to the expected values) are deleted
from the checkpoint.

Edit XML as Text Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to edit XML content from the XML tree in a text editor.
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To access Click the Edit XML as Text button in the XML tree area of the XML
Checkpoint Properties Dialog Box described on page 1432.

Important
information

l This dialog box is usedmainly for constructing an entire XML segment from a
string or for fixing syntax problems that prevent the dialog box from displaying
the XML tree correctly. It is also useful when you want to use copy-paste
functionality to edit the tree.

l When you click OK in the Edit XML as Text dialog box, the sub-tree of the
node you previously selected in the XML tree (or the entire tree if no node was
selected or if the root node was selected) is completely replaced by the XML
content from the Edit XML as Text dialog box.

l You cannot modify the name of the root element displayed in the Edit XML as
Text dialog box.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

Filter Link Check Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to instruct UFT to filter the hypertext links to check in a page
checkpoint.
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To access In the All Objects in Page Area area of the Page Checkpoint Properties Dialog
Box (described on page 1432), click the Filter Link Check button.

Important
information

If you select the Links check box in the Page Checkpoints Properties dialog box,
all of the links on the page are automatically selected by default.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

See also "Filter Image Check Dialog Box" on the next page

User interface elements are described below:

UI
Element Description

Check
box

Each link on the page has a corresponding check box.

To check a link, select the corresponding check box (by default all links are
selected).

To exclude a link from the page checkpoint, clear the corresponding check box.

Type The icon indicates that the target URL is currently a constant.

The icon indicates that the value of the property is currently a DataTable
parameter.

The icon indicates that the value of the property is currently an environment
variable parameter.

The icon indicates that the value of the property is currently a random number
parameter.

Link
name

The text in the hypertext link.

Link URL The target URL.

Configure
Value
area

Enables you to you define the expected value of the target URL to which the
hypertext links as aConstant orParameter. For details on the user interface
elements in this area, see "Configure Value Area" on page 1455.
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Filter Image Check Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to instruct UFT to filter which image sources to check in a to check in a
page checkpoint.

To access In the Configure Value Area area of the Page Checkpoint Properties Dialog Box
(described on page 1432), click the Filter Image Check button.

Important
information

If you select the Images check box in the Page Checkpoints Properties dialog
box, then by default all the images on the page are selected.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

See also "Filter Link Check Dialog Box" on page 1470
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User interface elements are described below:

UI
Element Description

Check
box

Each image source on the page has a corresponding check box.

To check an image source, select the corresponding check box (by default all image
sources are selected).

To exclude an image source from the page checkpoint, clear the corresponding
check box.

Type The icon indicates that the target URL is currently a constant.

The icon indicates that the value of the property is currently a DataTable
parameter.

The icon indicates that the value of the property is currently an environment
variable parameter.

The icon indicates that the value of the property is currently a random number
parameter.

Image
name

The name of the image.

Image
source

The image source file and path.

Configure
Value
area

Enables you to you define the path of the image source file as aConstant or
Parameter. For details on the user interface elements in this area, see "Configure
Value Area" on page 1455.

Parameterization / Properties Dialog Box (Checkpoints)
Relevant for: Keyword GUI components only

This dialog box enables you to set the checkpoint property value as aConstant or aParameter.

The following image shows this dialog box when aConstant property value is selected.
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To access In the "Checkpoint Properties Dialog Box" on page 1432 (simplemode) (described
on page 1432), click the browse button for a property.

Important
information

This dialog box opens only from SimpleMode. (In AdvancedMode, the options in
this dialog box are available in theConfigure value area of the Checkpoint
Properties dialog box.)

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

See also "Checkpoint Properties Dialog Box" on page 1432

For a description of user interface elements, see "Configure Value Area " on page 1575.
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Parameter Options Dialog Box (Local and Component
Input Parameters for Checkpoints)

Relevant for: GUI components

This dialog box enables you to set the parameter value for a checkpoint property value.

To
access

l In the "Checkpoint Properties Dialog Box" on page 1432 (described on page

1432), click theParameter Options button .

l In the "Parameterization / Properties Dialog Box (Checkpoints)" (described on
page 1473), select theParameter radio button. If a parameter is already defined,

youmust then click theParameter Options button to open this dialog box.

Relevant
tasks

l "How to Insert a Checkpoint in a GUI Test or Component" on page 1419

l "How to Parameterize Input Values (Keyword Components)" on page 1573

See also l "Checkpoint Properties Dialog Box" on page 1432

l "Value Configuration Options Dialog Box" on page 1579

For a description of user interface elements, see "Configure Value Area " on page 1575.
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Schema Validation Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to specify an XML schema against which you want to validate the
hierarchy of the XML in your application or file.

To access In the "Checkpoint Properties Dialog Box" (described on page 1432), select the
Activate Schema Validation button.
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Important
information

l If you are validating an XML file using a schema defined in the XML file, the
schema can be defined with an absolute or relative path. When you specify a
relative path, UFT searches for the schema in the folders listed in the Folders
pane of the Options dialog box (Tools > Options > GUI Testing tab >
Folders node). For details, see "Folders Pane (Options Dialog Box > GUI
Testing Tab)" on page 544.

l If you are validating an XML document located on theWebwith a schema file
located on your file system, you cannot use UNC format (for example,
\\ComputerName\Path\To\Schema) to specify the schema file location.
Instead, map the schema file location to a network drive.

l If there is a schemawith a namespace defined in your XML document, the
namespace of the external schemamust be identical to the one defined in your
document. Using an external XML schema file to validate an XML document
may cause an unexpected result if the XML document has an XML schema
declaration, and the namespace in the external schema file and the schema
defined in the document are not identical.

l When you perform a schema validation, UFT validates all of the elements in
the XML document, even if certain XML elements are not associated with a
schema file. Any XML elements that are not associated with a schema file
cause the schema validation to fail.

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

User interface elements are described below:

UI Elements Description

Validate against the
schema defined in the
XML document

Instructs UFT to use the schema or schemas defined within your
XML document to validate the hierarchy of the XML in yourWeb
page/frame, XML file, or XML test object.

Validate against the
schemas specified
below

Instructs UFT to use one or more external XML schema files to
validate the hierarchy of your XML. Any schemas defined within your
XML document are also checked.

Note: If you select this option:

l TheValidate against the schema defined in the XML
document option is automatically selected and is disabled.

l TheAdd Schema, Remove Schema, andModify Schema
buttons are enabled.

Add Schema. Enables you to add an external schema file to the list.
For details, see "Add SchemaDialog Box" on the next page.
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UI Elements Description

Remove Schema. Enables you to remove the selected external
schema file from the list.

Modify Schema. Enables you tomodify the details of the selected
external schema file in the list. For details, see "Edit SchemaDialog
Box" on the next page.

Add Schema Dialog Box

Relevant for: GUI tests and scripted GUI components

This dialog box enables you to specify the path or URL of an external schema file and its
namespace. If there is a schemawith a namespace defined in your XML document, the namespace
of the external schemamust be identical to the one defined in your document.

To access In the "Schema Validation Dialog Box" (described on page 1476), select theAdd
Schema button

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

User interface elements are described below:

UI
Elements Description

Schema
path or
URL

The path or URL of your XML schema file. Alternatively, click the browse button to
navigate to the XML schema you want to use to validate the XML in yourWeb
page/frame, XML file, or XML test object. You can specify schema files either
from your file system or from ALM. For each external file you add, youmust
specify its path or URL and namespace
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UI
Elements Description

Schema
namespace

(If applicable.) The namespace of your schema file. UFT checks that the
namespacematches the schema file as part of the validation process. If the
schema file has a namespace and you do not specify it, or if the namespace you
specify is different to the one specified in the schema file, the validation fails.

Click OK to add the selected schema to the list in the Schema Validation dialog
box. Click theAdd Schema button again if you want to add another schema.

Edit Schema Dialog Box

Relevant for: GUI tests and scripted GUI components

This dialog box displays the path and namespace of the schema file you selected in the list. You
canmodify the path or URL of the selected schema file, and its namespace.

To access In the "Schema Validation Dialog Box" (described on page 1476), select the
Modify Schema button

Relevant
tasks

"How to Insert a Checkpoint in a GUI Test or Component" on page 1419

User interface elements are described below:

UI
Elements Description

Schema
path or
URL

The path or URL of your XML schema file. Alternatively, click the browse button to
navigate to the XML schema you want to use to validate the XML in yourWeb
page/frame, XML file, or XML test object. You can specify schema files either
from your file system or from ALM. For each external file you add, youmust
specify its path or URL and namespace
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UI
Elements Description

Schema
namespace

(If applicable.) The namespace of your schema file. UFT checks that the
namespacematches the schema file as part of the validation process. If the
schema file has a namespace and you do not specify it, or if the namespace you
specify is different to the one specified in the schema file, the validation fails.

Click OK to add the selected schema to the list in the Schema Validation dialog
box. Click theEdit Schema button again if you want to edit another schema.

Connect to Database Using ODBC Page (Database Query
Wizard)

Relevant for: GUI tests and scripted GUI components

This wizard enables you to define the query for your checkpoint usingMicrosoft Query or by
manually entering a database connection and SQL statement.

To access 1. Ensure that a GUI action or component is in focus in the document pane.

2. Select Design > Checkpoint > Database Checkpoint .

Relevant tasks "How to Insert a Checkpoint in a GUI Test or Component" on page 1419

Wizard map This wizard contains:

Connect to Database Using ODBC > Specify SQL Statement(page 1481)

See also "Specify SQL Statement Page (DatabaseQuery Wizard)" on the next page
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User interface elements are described below:

UI Elements Description

Create query
using
Microsoft
Query

Opens Microsoft Query, enabling you to create a new query. After you finish
defining your query, you return to UFT. This option is available only if you have
Microsoft Query installed on your computer.

Specify SQL
statement
manually

Opens theSpecify SQL statement page in the wizard, which enables you to
specify the connection string and an SQL statement.

Maximum
number of
rows

When selected, enables you to limit the number of rows and enter the
maximum number of database rows to check. You can specify amaximum of
32,000 rows.

Show me
how to use
Microsoft
Query

Displays an instruction page when you click Next before openingMicrosoft
Query. Available only whenCreate query using Microsoft Query is selected.

Specify SQL Statement Page (Database Query Wizard)

Relevant for: GUI tests and scripted GUI components

This page enables you tomanually specify the database connection string and the SQL statement.

To access Select Design > Checkpoint > Database Checkpoint.
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Important
information

It takes several seconds to capture the database query and restore the
UFT window.

Relevant tasks "How to Insert a Checkpoint in a GUI Test or Component" on page 1419

Wizard map This wizard contains:

Connect to Database Using ODBC (page 1480) > Specify SQL
Statement

See also "Connect to Database Using ODBC Page (DatabaseQuery Wizard)" on
page 1480

User interface elements are described below:

UI
Elements Description

Connection
string

The connection string.

Create Opens theODBC Select Data Source dialog box. You can select a .dsn file in the
ODBC Select Data Source dialog box or create a new .dsn file to have the
DatabaseQuery Wizard insert the connection string in the box for you.

SQL
statement

The details of the SQL statement.

XML Source Selection - Checkpoint / Output Value
Properties Dialog Box

Relevant for: GUI tests and scripted GUI components

This dialog box enables you to specify the XML file or test object for which you want to insert an
XML checkpoint/output value step.

The following image shows an example of the XMLSource Selection - Checkpoint Properties dialog
box.
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The following image shows an example of the XMLSource Selection - Output Value Properties
dialog box.

To access 1. Ensure that a GUI action or component is in focus in the document pane.

2. Use one of the following:

n For checkpoints:Select Design > Checkpoint > XML Checkpoint
(From Resource)

n For output values:Select Design > Output Value > XML Output
Value (From Resource)

Relevant
tasks

l "How to Insert a Checkpoint in a GUI Test or Component" on page 1419

l "How to Create or Modify anOutput Value Step" on page 1494

User interface elements are described below:

UI
Elements Description

Create
checkpoint
step from
XML file
/ Create
output
value step
from XML
file

Specifies the file for which you want to insert a checkpoint/output value. In the
box, you can:

l Enter the URL or the file path of the XML file.

l Click the browse button to open theOpen XML File dialog box and navigate to
the XML file. You can specify an XML file either from your file system or from
ALM.

Note: If you enter a relative path, ALM searches for the XML file in the
folders listed in the Folders pane of the Options dialog box (Tools >
Options > GUI Testing tab > Folders pane). After ALM locates the file, it
saves it as an absolute path and uses the absolute path during the run
session. For details, see "Folders Pane (Options Dialog Box > GUI Testing
Tab)" on page 544.
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UI
Elements Description

Create
checkpoint
step for
test object
/ Create
output
value step
for test
object

l Specifies an XML checkpoint/output value for a test object. From the list, select
the test object.

l You can select an existingWebXML or XMLFile test object type as long as the
actual XML object is currently available (in an open browser or in the file
system, as relevant).

Note: Selecting aWebXML or XMLFile test object is identical to using the
XML Checkpoint (From Application) orCreate new checkpoint from
file options, but may be faster than browsing to these objects and can be
inserted while recording or editing. However, to use this option, the XML
sourcemust be available when you select the test object (theWeb page
must be open or the file must exist in the same location as when the test
object was defined).

Tip: To select an object that is not displayed in the list, you can click Object
from Repository . Then select a test object from the object repository on
which to create a new checkpoint. The selected object must support XML
(such as aWebXML test object). For details on selecting objects, see "Select
Test Object Dialog Box" on page 958.
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Troubleshooting and Limitations - Using Checkpoints
Relevant for: GUI tests and components

The following sections describe troubleshooting and limitations for working with checkpoints in a
GUI test or component:

Accessibility checkpoints
In ALM, you can view a comparison of accessibility checkpoints in the Asset Comparison Tool only
if both UFT and the UFT Add-in for ALM are installed on the ALM computer.

Bitmap checkpoints
Bitmap checkpoints on objects containing text may fail if you create them using a Remote Desktop
Connection and then run them locally, or if you create them locally and then run the checkpoint
steps using a Remote Desktop Connection. In the run results, the image displayed when you click
View Difference in the bitmap checkpoint results shows some text shapes.

Workaround:Enable the Font smoothing option in the Remote Desktop Connection application.

Database checkpoints

l The format of captured values varies depending on the specific system settings. For example,
date and time values may be set to different formats.

Workaround: If you are running the test or scripted component on a different system than the
one you used to record the test, confirm that the systems use the same format settings.

l When you create a database checkpoint on onemachine and try to run it on different machine,
you should have the sameODBC driver installed on bothmachines.

File content checkpoints
File content checkpoints for htm/html files generated dynamically by third-party Javascript code are
not supported.

Text/text area checkpoints
Text and text area checkpoints are not supported if the text in the selected area is in a non-English
language.

XML checkpoints

l When executing an XML checkpoint on an XML file that contains > as a value, an error message
may occur.

l When you add a new value node to an XML node, in some cases the new valuemay not be
displayed.

Workaround:Close the Edit XML as Text dialog box and reopen it to display the new value
node correctly.
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l When inserting an XML file checkpoint on a file that cannot be loaded, or a file that is formatted
incorrectly, youmay receive an error message.

l Creating and running XML checkpoints for large XML documents may take a few minutes.
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Chapter 51: Output Values in GUI Testing
Relevant for: GUI tests and components

This chapter includes:

Concepts 1488

Output Values Overview 1488

Tasks 1494

How to Create or Modify anOutput Value Step 1494

Reference 1498

Output Value Properties Dialog Box 1498

Add Existing Output Value Dialog Box 1515

Advanced File Content Output Value Properties Dialog Box 1518

Output Options Dialog Box 1519

Parameterization / Properties Dialog Box (Output Values) 1525
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Concepts

Output Values Overview
Relevant for: GUI tests and components

Your test or component can retrieve values and store them in output value objects. You can then
use these values as input at a later stage in a run session.

An output value step is a step in which one or more values are captured at a specific point in your
test or component and stored for the duration of the run session. The values can later be used as
input at a different point in the run session.

You can output the property values of any object. You can also output values from text strings,
table cells, databases, and .xml documents.

When you create output value steps, you can determine where the values are stored during the run
session and how they can be used. During the run session, UFT retrieves each value at the
specified point and stores it in the specified location. When the value is needed later in the run
session, UFT retrieves it from this location and uses it as required.

Output values are stored only for the duration of the run session. When the run session is repeated,
the output values are reset.

Note: After the run session, you can view the output values retrieved during the session as
part of the session results. For details, see the section on Parameterized Values in the Run
Results (described in theHP RunResults Viewer User Guide).

For details about using output values for each add-in environment installed with UFT, see
"Supported Output Values" on page 2228.

This section also includes:

Output Value Categories 1489

Output Types and Settings 1491

Viewing and Editing Output Values 1492

Storing Output Values 1492
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Output Value Categories

Relevant for: GUI tests and components

You can create the following categories of output values:

l "Standard Output Values" below

l "File Content Output Values (tests and scripted components only)" below

l "Table Output Values (tests and scripted components only)" on the next page

l "Text and Text AreaOutput Values (tests and scripted components only)" on the next page

l "DatabaseOutput Values (tests and scripted components only)" on the next page

l "XMLOutput Values (tests and scripted components only)" on the next page

l "Existing Output Values (tests and scripted components only)" on page 1491

Standard Output Values
You can use standard output values to output the property values of most objects. For example,
you can use standard output values to output text strings by specifying the text property of the
object as an output value in a keyword component. In aWeb-based application, the number of links
on aWeb pagemay vary based on the selections a user makes on a form on the previous page.
You could create an output value in your test or scripted component to store the number of links on
the page.

Note for tests and scripted components:

l You can also use standard output values to output the contents of table cells.

l You can use standard output values to output text strings by specifying the text property of
the object as an output value.

For task details, see "How to Create or Modify anOutput Value Step" on page 1494.

File Content Output Values (tests and scripted components only)
You can use file content output values to output the contents from any of the following file types:

l HTML l Microsoft Word l Text

l PDF l RTF

You can create output values from the entire contents of a file, or from a part of it. During the run
session, UFT retrieves the current data from the file and outputs the values according to the
settings that you specified.
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For task details, see "How to Create or Modify anOutput Value Step" on page 1494.

Table Output Values (tests and scripted components only)
Table output values are a subset of standard output values, described above. You can use table
output values to output the contents of table cells. For some types of tables, you can specify a row
range from which to choose the table cells. During the run session, UFT retrieves the current data
from the specified table cells according to the settings that you specified and outputs the values to
the Data pane.

For task details, see "How to Create or Modify anOutput Value Step" on page 1494.

Text and Text Area Output Values (tests and scripted components only)
You can use text output values to output text strings displayed in an application. When creating a
text output value, you can output a part of the object's text. You can also specify the text before and
after the output text.

You can use text area output values to output text strings displayed within a defined area of a
screen in aWindows-based application.

For example, suppose that you want to store the text of any error message that appears after a
specific step in theWeb application you are testing. Inside the If statement, you check whether a
window exists with a known title bar value, for exampleError. If it exists, you output the text in this
window (assuming that the window size is the same for all possible error messages).

Note: You can create a text area output value only while recording onWindows-based
applications.

For task details, see "How to Create or Modify anOutput Value Step" on page 1494.

Database Output Values (tests and scripted components only)
You can use database output values to output the value of the contents of database cells, based on
the results of a query (result set) that you define on a database. You can create output values from
the entire contents of the result set, or from a part of it. During the run session, UFT retrieves the
current data from the database and outputs the values according to the settings that you specified.

For task details, see "How to Create or Modify anOutput Value Step" on page 1494.

XML Output Values (tests and scripted components only)
You can use XML output values to capture and output the values of XML elements and attributes in
XML documents.

For example, suppose that an XML document in aWeb page contains a price list for new cars. You
can output the price of a particular car by selecting the appropriate XML element value to output.

After the run session has finished, you can also view the captured data by opening the XMLOutput
Value Results window from the Run Results Viewer. For details, see the XMLOutput Value
Results Window (described in theHP RunResults Viewer User Guide).

For task details, see "How to Create or Modify anOutput Value Step" on page 1494.
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Existing Output Values (tests and scripted components only)
When you insert an existing output value in your test or scripted component, consider which output
values should be used inmultiple locations in your test or component. Each time an output value
step is performed, the value contained in the output value is overwritten with the new output value.
You should insert an existing output value only if the stored value will no longer be needed later in
the run session when the output value object is used again.

For details, see "Add Existing Output Value Dialog Box" on page 1515.

Output Types and Settings

Relevant for: GUI tests and components

In the "Output Options Dialog Box " (described on page 1519) you can set the output type and
settings for each value, to determine where it is stored and how it can be used during the run
session. When the output value step is reached, UFT retrieves each value selected for output and
stores it in the specified location for use later in the run session.

For details relevant to keyword components, see "Output Value Properties Dialog Box" on page
1498.

When you create a new output value step, UFT assigns a default definition to each value selected
for output. For details, see the Default Output Definitions (tests only) below.

You can change the current output definition for the selected value by selecting a different output
type and/or changing the output settings in the "Output Options Dialog Box "(described on page
1519).

Default Output Definitions (tests only)
When you initially select a value for output, UFT generates a default output definition for the value.

When you output a value for a step, the following occurs:

l If at least one output parameter is defined in the action, the default output type is Test/action
parameter and the default output name is the first output parameter displayed in the
"Parameters Tab (Action Properties Dialog Box)" (described on page 903).

l If no output parameters are defined in the action, the default output type is DataTable, and UFT
creates a new DataTable output name based on the selected value.

The output value is created in the Global sheet of the Data pane.

For details on creating output parameters for actions, see "How to Display andModify Action-
Related Information" on page 886.

For details on Data pane sheets, see "Data Pane" on page 221.
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Viewing and Editing Output Values

Relevant for: GUI tests and components

In the Keyword View, an output value step is displayed as follows:

l TheOperation column displays Output.

l TheValue column displays CheckPoint followed by the name assigned to the output value.

In the Editor, an output value statement is displayed with the following syntax:

Object.Output CheckPoint(Name)

You can view or edit the output value or its details in the relevant Output Value Properties dialog
box, by right-clicking the step and choosingOutput Value Properties. Alternatively, you can click

the step in theValue column in the Keyword View and then click theOutput Properties button .

For details on the options available in the various Output Value Properties dialog boxes, see
"Output Value Properties Dialog Box" on page 1498.

Storing Output Values

Relevant for: GUI tests and scripted GUI components

When you define an output value, you can specify where and how each value is stored during the
run session.

You can output a value to:

l "Test and Action Parameters (tests only)" below

l "Run-time Data Table"

l "Environment Variables"

Test and Action Parameters (tests only)
You can output a value to an action parameter, so that values from one part of a run session can be
used later in the run session, or be passed back to the application that ran (called) the test.

For example, suppose you are testing a shopping application that calculates your purchases and
automatically debits your account with the amount that you purchased. You want to test that the
application correctly debits the purchase amount from the account each time that the action is run
with a different list of items to purchase. You could output the total amount spent to an action
parameter value, and then use that value later in your run session in the action that debits the
account.

For details on action parameters, see "Action Parameters" on page 877.
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Run-time Data Table
The option to output a value to the run-time data table is especially useful with a data-driven test,
action, or scripted component that runs several times. In each repetition, or iteration, UFT retrieves
the current value and stores it in the appropriate row in the run-time data table.

Example

Suppose you are testing a flight reservation application and you design a test to create a new
reservation and then view the reservation details. Every time you run the test, the application
generates a unique order number for the new reservation. To view the reservation, the
application requires the user to input the same order number. You do not know the order
number before you run the test.

To solve this problem, you output a value to the Data pane for the unique order number
generated when creating a new reservation. Then, in the View Reservation screen, you use the
column containing the stored value to insert the output value into the order number input field.

When you run the test, UFT retrieves the unique order number generated by the site for the new
reservation and enters this output value in the run-time data table. When the test reaches the
order number input field required to view the reservation, UFT inserts the unique order number
stored in the run-time data table into the order number field.

Environment Variables
When you output a value to an internal user-defined environment variable, you can use the
environment variable input parameter at a later stage in the run session.

Example

Suppose you are testing an application that prompts the user to input an account number on a
Welcome page and then displays the user's name. You can use a text output value to capture
the value of the displayed name and store it in an environment variable.

You can then retrieve the value in the environment variable to enter the user's name in other
places in the application. For example, in anOrder Checkbook Web page, which for security
reasons requires users to enter the name to appear on the checks, you could use the value to
insert the user's name into theName edit box.

Note:

l Output values are stored only for the duration of the run session, and are not saved with the
test or component. If you select to output a value to an existing parameter, a data table
column, or an environment variable, the existing value is overwritten when the output value
step runs. When the run session ends, the original value is restored.

l You can output values only to internal user-defined environment variables and not to
external or built-in environment variables, which are read-only.
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Tasks

How to Create or Modify an Output Value Step
Relevant for: GUI tests and components

This task describes how to insert an output value step while recording or editing your test or
component. You can also add an existing output value to a test or scripted component. It is
generally more convenient to define output values after creating the initial test or component.

For details on supported output values per add-in environment, see "GUI Checkpoints andOutput
Values Per Add-in" on page 2224

This task describes both the general process for inserting a new output value step to your test or
component and the prerequisites and considerations for the different types of output values.

This task includes the following steps:

l "Important information before inserting the output value step" below

l "Insert a new standard output value step while recording your test or component" on the next
page

l "Insert a new output value step using the Active Screen while editing (tests and scripted
components only)" on page 1496

l "Insert an existing output value step while editing (tests and scripted components only)" on page
1497

l "Set the options for the output value object" on page 1497

Important information before inserting the output value step

Object
visibility in
application

l During an editing session, make sure the object is visible in your application
before inserting an output value step on it.

l For file content output values: The source file must be located on the file
system.

Availability l Recording sessions

l Editing sessions

l Active Screen

Active
Screen

Make sure that the Active Screen contains sufficient data for the object for which
you want to define an output value. For details, see "Active Screen Pane (Options
Dialog Box > GUI Testing Tab)" on page 547.

HP Unified Functional Testing (12.00) Page 1494 of 2274



Important
Information

l Output valuescan be viewed in the followingmodes:

n Simple Mode: Displays only the basic properties and expected values of
the output value.

n Advanced Mode: Displays all supported properties and expected values of
the output value.

l For text/text area checkpoints:

n Before you create a text or text area output value for aWindows-based
application, make sure you configure the required capture settings in the
Text Recognition pane of the Options dialog box (Tools > Options > GUI
Testing tab > Text Recognition node). For details, see "Text Recognition
Pane (Options Dialog Box > GUI Testing Tab)" on page 542.

n When you use text-area selection to capture text displayed in aWindows
application, it is often advisable to define a text area larger than the actual
text you want UFT to use as an output value. During the run session, UFT
outputs the selected text, within the defined area, according to the settings
you configured.

n Because text may change its position during run sessions, make sure that
the area defined is large enough so that the output text is always within its
boundaries. For details, see "Text Recognition Overview" on page 1408.

Insert a new standard output value step while recording your test or
component

1. Start a recording session.

2. Do one of the following:

n Select Design > Output Value > Standard Output Value.

n In the record toolbar, click Insert Checkpoint or Output Value down arrow and
select Standard Output Value.

The pointer changes into a pointing hand. For details on using the pointing hand, see "Tips
for Using the Pointing Hand" on page 1196.

If necessary, select the object or object sections you want to include in the output value. The
specific dialog that opens differs depends on the type of output value selected:

n For table checkpoints, see "Define/Modify Row Range Dialog Box".

n For database checkpoints, see "Connect to Database Using ODBC Page (Database
Query Wizard)" on page 1480.
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n For XML checkpoints, see "XML Source Selection - Checkpoint / Output Value Properties
Dialog Box".

Insert a new output value step using the Active Screen while editing (tests and scripted
components only)

1. Do one of the following:

n Select View > Active Screen, click a step whose Active Screen contains the object for
which you want to specify an output value, and right-click the object for which you want to
specify an output value and select Insert Output Value.

n Right-click the step and select Insert Output Value.

If the location you clicked is associated with more than one object, the "Object Selection
Dialog Box " (described on page 1195) opens.

If necessary, select the object or object sections you want to include in the output value.
The specific dialog that opens differs depends on the type of output value selected:

o For table checkpoints, see "Define/Modify Row Range Dialog Box".

o For database checkpoints, see "Connect to Database Using ODBC Page (Database
Query Wizard)" on page 1480.

o For XML checkpoints, see "XML Source Selection - Checkpoint / Output Value
Properties Dialog Box".

Note if you are creating a text/text area output value:

n To output text value while editing, you first highlight a text string in the Active Screen
then right-click the string, and select Insert Text Output Value.

n When you output a text area value, you first define the area containing the text you want
UFT to check. When you select Text AreaOutput Value, themouse turns into a
crosshairs pointer. Click and drag the crosshairs pointer to define this area. Release the
mouse button after outlining the area required. For more details, see the section on text
area output values in "Output Value Categories" on page 1489, and the important
details in "Output Value Properties Dialog Box" on page 1498.

Tip: Hold down the left mouse button and use the arrow keys tomake precise
adjustments to the defined area.
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Insert an existing output value step while editing (tests and scripted
components only)

1. Select the step after which you want to insert the output value.

2. Select Design > Output Value > Existing Output Value. The Add Existing Output Value
Dialog Box opens, enabling you to select the test object from which you want to output values.

Set the options for the output value object

For tests and scripted components:Set the options for the output value, including the values to
add to the output value step. For details, see "Output Value Properties Dialog Box" on the next
page.

For keyword components:Specify the settings in the "Output Value Properties Dialog Box" on
the next page (described on page 1498).
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Reference

Output Value Properties Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to define andmodify properties for a selected output value.

The example below gives the basic structure for the various Output Value Properties dialog boxes.
Certain elements may differ between output value types.
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To access 1. Ensure that a GUI action or component is in focus in the document pane.

2. Use one of the following:

n Insert a new output value step and select an object from your application.

n During a recording session, click the Insert Checkpoint or Output Value
down arrow and select the relevant type.

n Right-click an existing output value step and select Output Value
Properties.

n In the local or shared object repository, click an existing output value
object. The output value details are displayed on the right side of the object
repository window, in theObject Details area.

Important
information

l If you insert an output value on aWeb page, the PageOutput Value Properties
dialog box opens. This dialog box is identical to the Output Value Properties
dialog box, except that it contains two additional areas, HTML verification
andAll objects in page. These options are relevant only for checkpoints and
are disabled when defining output values.

l You cannot view or edit the advanced properties of output value objects when
working in ALM. Therefore, if one or more advanced properties are selected in
an output value object, and an ALM user views its properties in ALM, the dialog
box displays text indicating that some properties are not shown.

Relevant
tasks

"How to Create or Modify anOutput Value Step" on page 1494

This dialog box has the following areas:

l "Object Details Area" below

l "Properties Grid Area" on the next page

l "Statement Location Area" on page 1501

Object Details Area

UI Element Description

Name The name that UFT assigns to the output value object. By default, the name is
the same as the name of the object on which the output value step is performed.
You can specify a different name for the output value object or accept the default
name.
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UI Element Description

Class The type of object (read-only).

Note: The class of the object is not displayed in ALM when working with a
keyword component.

Find in Repository. Displays the output value object in its existing repository.

For tests and scripted components, this option is only available when editing
an existing output value step. It is not available when creating a new output
value step.

For keyword components, this option is only available in AdvancedMode.

(available
only for
keyword
components)

Advanced Mode/Simple Mode. Toggles the dialog box between Advanced
Mode and SimpleMode. AdvancedMode expands the dialog box and enables
you to view or edit advanced properties.

Properties Grid Area

The Properties grid area displays the properties to output from the object.

For standard output values, see "Properties Grid Area (Output Value Properties Dialog Box) -
Standard Output Values" on the next page.

For table output values, see "Properties Grid Area (Output Value Properties Dialog Box) - Table
Output Values" on page 1507.

For text or text area output values, see "Output Value Summary Area (Output Value Properties
Dialog Box) - Text/Text AreaOutput Values" on page 1509.

For file content output values, see "File andOutput Value Details Area (Output Value Properties
Dialog Box) - File Content Output Values" on page 1504.

For database output values, see "Properties Grid Area (Output Value Properties Dialog Box) -
DatabaseOutput Values" on page 1503.

For XML output values, see "XML Tree/Options Area (Output Value Properties Dialog Box) - XML
Output Values" on page 1512.

Configure Value Area

For standard, table, or database output values, see "Configure Value Area (Output
Value Properties Dialog Box) - Standard, Table, and Database Checkpoints" on page 1502.

For text/text area output values, see "Output Value Summary Area (Output Value Properties Dialog
Box) - Text/Text AreaOutput Values" on page 1509.

For file content orXML output values, this area is not applicable.
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Statement Location Area
The following image shows the statement location area when inserting a new output value step
during an editing session. When inserting a new output value step during a recording session, the
Insert statement option is not available.

User interface elements are described below:

UI
Elements Description

Insert
statement

Specifies whether to insert the output value step before or after the currently
selected step. The default value is Before current step.

Note: Available only when inserting a new output value step during an editing
session. During a recording session, the output value step is always inserted
as the next step.

Properties Grid Area (Output Value Properties Dialog Box) -
Standard Output Values

Relevant for: GUI tests and components

This area of the Output Properties dialog box enables you to set the values to output for the output
value step.

User interface elements are described below:

UI
Elements Description

Check
box

Enables you to select one or more property for the object, and specify the output
options for each property value you select.
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UI
Elements Description

Type l . Indicates that the value of the property is currently a constant.

l . Indicates that the value of the property is currently a test or action parameter
(tests only)

l . Indicates that the value of the property is currently a DataTable parameter
(tests and scripted components only)

l . Indicates that the value of the property is currently an environment variable
parameter (tests and scripted components only)

l . Indicates that the value of the property is currently a random number
parameter (tests and scripted components only)

l . Indicates that the value of the property is currently a parameter (keyword
components only)

Property The name of the property.

Value The expected value of the property.

For details onmodifying the value of a property in tests and scripted components,
see "Configure Value Area " on page 1575.

Configure Value Area (Output Value Properties Dialog Box) -
Standard, Table, and Database Checkpoints

Relevant for: GUI tests and components

The Configure Value area enables you to set the value to use as an output.

The example below shows the Configure Value area (called the Parameter data tab) when a table
output value is selected.
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Important information (for keyword
components only)

l This area is available only in AdvancedMode.

l In SimpleMode, when you click theBrowse
button for a selected property in the
Properties grid, the "Parameterization /
Properties Dialog Box (Output Values)" opens,
in which the output definition for the selected
property value is displayed.

User interface elements are described below:

UI Elements Description

Selected Cell
(table and database
checkpoints only)

The name of the object and location of the cell to output.

Selected Cell The name of the object and location of the cell to output.

Modify Opens theOutput Options dialog box, enabling you to change the
output type and/or settings for the selected value.

For details, see "Output Options Dialog Box " on page 1519.

Properties Grid Area (Output Value Properties Dialog Box) -
Database Output Values

Relevant for: GUI tests and scripted GUI components

For database output values, the Properties Grid area displays a grid containing the database values
of the object for which you are creating an output value.
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Important
information

l Double-clicking on the grid toggles the settings for all selected cells. Therefore,
if you double-click a row header, a column header, or the top left corner of the
grid, any cells that were previously included in the output are removed from it,
and any cells that were not previously included in the output are added to it.

l You can change the columnwidths and row heights of the grid by dragging the
column and row header dividers.

l If row range selection is supported, the row range you specify when creating
the output value is displayed above the grid.

See also "Define/Modify Row Range Dialog Box" on page 1467

User interface elements are described below:

UI
Element Description

<grid
area>

The grid area displays the captured\expected values of all the cells in the table. Only
the ones with blue checkmarks are outputted. You can instruct UFT to output the
entire table, specific rows, specific columns, or specific cells.

Note: UFTchecks only cells containing a check mark.

Change Enables you to define or modify the row range to output by opening the "Define/Modify
Row Range Dialog Box" on page 1467.

Add/Remove Output. Add or remove the selected cells from the output.

File and Output Value Details Area (Output Value Properties Dialog
Box) - File Content Output Values

Relevant for: GUI tests and scripted GUI components

Whenworking with a file content output value, the Properties Grid area displays a File Content
Editor which enables you to specify the text to output in a document that is generated or accessed
during a run session.
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User interface elements are described below:

User Guide
Chapter 51: Output Values in GUI Testing

HP Unified Functional Testing (12.00) Page 1505 of 2274



UI Element Description

Generated
file

The file path of the generated document from which you want to output text
during the run session.

You can enter a pathmanually or click theSelect Comparison File button to
navigate to the required file. The path can be relative or absolute (unless you use
a regular expression). The file must be located in the file system.

When you initially specify a file to compare, the textual content from that file is
displayed in the file content editor of the dialog box as the expected value of the
checkpoint. If you later change this path, the content in the file content editor is
not affected.

Note: The document must not be password-protected, otherwise, UFT will
not be able to access it during a run session.

You can use the following when specifying the document path:

l Configure Verification Value (Parameter/Regular Expression).
Opens the "Value Configuration Options Dialog Box" (described on
page1579). You use this dialog box to define the file path as a constant or
parameter value, with or without a regular expression.

For example, suppose your application is being released inmultiple
languages, and you want to compare a different source file for each language.
You can specify a data table parameter to instruct UFT to use a different file
for each iteration.

Displayed only when you hover over theComparison file path text box.

Note: If you specify a parameter value for the comparison file path and
multiple files that match the value exist in the specified location, UFT
performs the checkpoint on the latest generated file (according to its
creation time).

If you use a regular expression, youmust specify amapped drive, for
example: C:\\Program Files\\HP\\Unified Functional Testing\\Tests\\.*\.txt

l Select Comparison File. Enables you to navigate to the file you want to
compare.

Select/Clear Line for Verification. This toggle button enables you to select or
clear a line to output in the generated file during a run session.
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UI Element Description

Add Parameter to Line. Opens the "Value Configuration Options Dialog Box".
You use this dialog box to define a parameter as a constant or parameter value.

For example, suppose you inserted a parameter in the "Generated file" box
because you want to compare a different file during each iteration. You can
specify a data table parameter to instruct UFT to use a different value for each
iteration.

Open Regular Expression Evaluator. Opens the "Value Configuration Options
Dialog Box". You use this dialog box to create and test a regular expression
enabling you to determine whether it suits your needs.

-- Search for. Text box in which you can optionally enter text for which to search.
As you type, all instances of the specified text are highlighted. Press ENTER to
jump to the first instance if it is not visible in the file content editor.

You can use the following buttons to navigate between each instance of the
specified text:

Find Next. Jumps to the next instance of the specified text in the file
content editor.

Find Previous. Jumps to the previous instance of the specified text in the
file content editor. (Enabled only after you click Find Next.)

Advanced Opens the "Advanced File Content Checkpoint Properties Dialog Box". This
dialog box enables you to set additional comparison settings and checkpoint
properties.

Page The page from the source file being compared.

Pages are displayed only when the content from the source file exceeds one
page.

You can:

l View the number of pages in the file being compared.

l Expand or contract a specific page to view or hide the content on that page.

l Select the adjacent check box to select all of the lines on a page.

l Clear the adjacent check box to clear the selection of all of the lines on a
particular page.

Properties Grid Area (Output Value Properties Dialog Box) - Table
Output Values

Relevant for: GUI tests and scripted GUI components
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For a table output value, the Properties Grid area displays two tabs:

l "Grid Area" below

l "Properties Grid Area" on the next page

Grid Area
The following image shows theGrid area when row range selection is enabled.

Important
information

l The column header names are captured from the table you selected for your
output value.

l Double-clicking on the grid toggles the settings for all selected cells. Therefore,
if you double-click a row header, a column header, or the top left corner of the
grid, any cells that were previously included in the output are removed from it,
and any cells that were not previously included in the output are added to it.

l If row range selection is supported, the row range you specify when creating
the output value is displayed above the grid.

User interface elements are described below:

UI
Element Description

<grid
area>

The grid area displays the captured\expected values of all the cells in the table. Only
the ones with blue checkmarks are outputted. You can instruct UFT to output the
entire table, specific rows, specific columns, or specific cells.

Note: UFT checks only cells containing a check mark.

Change Enables you to define or modify the row range to output by opening the "Define/Modify
Row Range Dialog Box" on page 1467.

Add/Remove Output. Add or remove the selected cells from the output.
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Properties Grid Area
The Properties grid displays the table object's default properties, including the properties, their
values, and their types. It is identical to the Properties Grid area of the Output Value Properties
dialog box.

For user interface description, see "Properties Grid Area (Output Value Properties Dialog Box) -
Standard Output Values" on page 1501.

Output Value Summary Area (Output Value Properties Dialog Box) -
Text/Text Area Output Values

Relevant for: GUI tests and scripted GUI components

For a text or text area output value, the Properties Grid area displays a summary of the text to
check.
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User interface elements are described below:

UI
Element Description

Output
Value
Summary

Summarizes the selected text for the output value. It displays the text you selected
when creating the output value, plus the text before and after it. UFT automatically
displays the output text in red, and the text before and after the output text in blue.

For text output values inWeb-based environments, it displays the text you selected
when creating the output value, plus some text before and after it. For text and text
area output values inWindows-based environments, it displays the text you
selected when creating the output value.

Note:

l InWindows-based environments, if there is more than one line of text
selected, the Output Value Summary area displays [complex value]
instead of the selected text string. You can then click Configure to view and
manipulate the actual selected text for the output value.

l For a text area output value, the output value string contains all the text in
the selected area. Therefore, although the Text Output Value Properties and
Text AreaOutput Value Properties dialog boxes are identical, when you
create a text area output value, the Text Before and Text After values are
not captured.

Output Text Options Area (Output Value Properties Dialog Box) -
Text/Text Area Output Values

Relevant for: GUI tests and scripted GUI components

TheOutput Text Options area displays different options depending on whether you are checking the
specific text to output, or the text before/after the output text:

l "Output Text Options Area " on the next page

l "Text Before / Text After Options" on the next page
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Output Text Options Area

User interface elements are described below:

UI
Element Description

<Text
Area
list>

The current output value settings for the selected text. When you create a new output
value, the default output definition is displayed for the value. For details, see "Default
Output Definitions (tests only)" on page 1491.

Modify Enables you to set parameterization and other preferences for each of the string
elements in your output value, by opening the "Output Options Dialog Box "
(described on page 1519).

Text Before / Text After Options

User interface elements are described below:

UI Element Description

Use the
text before
/
Use the
text after

When selected, the current Text Before / Text After value is displayed in the
Constant box.

When cleared, UFT retrieves the value of the first occurrence of the defined output
string, regardless of the text displayed before it (if you chose Text Before) or after
it (if you chose Text After).

Note:When this check box is cleared, the options below it are not available.
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UI Element Description

Text to
capture is
displayed
before
occurrence
/

Text to
capture is
displayed
after
occurrence

Specifies the exact occurrence of the value specified in theConstant or
Parameter box, if the value is displayedmore than once in the object or area.

If you accept the default text that UFT recommends, the number in this box is
correct. For example, if the selected output string is displayed before the first
occurrence of the string First (as shown in the dialog box above). When Text After
is selected, the number 1 is displayed in the Text to capture is displayed before
occurrence box.

If youmodify the recommended value, youmust confirm that the occurrence
number is accurate. If you choose text that is not unique in the defined object or
area, change the occurrence number appropriately. For example, if you want to
output the text displayed after the third occurrence of the stringMercury Tours,
select Text Before and enter 3 in the Text to capture is displayed after
occurrence box.

Note: UFTstarts counting occurrences of the specified Text After value from
the beginning of the text string you selected to output, and includes any
occurrences within the output value string itself.

Constant Sets the Text Before or Text After value as a constant. A constant is a value that
is defined directly within the test. It remains set for the duration of the test.

When you are creating a text output value with Text Before selected, the
Constant box displays the captured Text Before value. When you are creating a
text output value with Text After selected, theConstant box displays the
captured Text After value. You can change the value by typing in the text box.

When you are creating a text area output value, the Text Before and Text After
values are not captured. You can enter the text by typing or copying it into the
Constant box.

Tip: It is recommended to specify a text string that is unique within the object
or area whenever possible, to ensure that the occurrence number is 1.

Parameter Sets the Text Before or Text After value as a parameter. For details on specifying
parameter values, see "How to Configure Constant and Parameter Values" on
page 1572.

XML Tree/Options Area (Output Value Properties Dialog Box) - XML
Output Values

Relevant for: GUI tests and scripted GUI components

For XML output values, the Output Value Properties dialog box displays an XML tree and options
section to enable you to select the XML elements to output:
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l "XML Tree" below

l "Options Area" on the next page

XML Tree

Important
information

l The XML tree displays the hierarchical relationship between each element and
value in the XML tree, enabling you to select the element and/or attribute
values that you want to output. Each element node is displayed with a icon.
Each value node is displayed with a icon.

l When you create an XML output value for an operation return value, only a
generic XML tree is created and shown in the XMLOutput Properties dialog
box. Before you can select which element or attribute values you want to
output, youmust populate the XML tree with the actual elements, attributes,
and values.

l Select the check box for an element or value node in the XML tree to indicate
that you want to output a value for that node.

l Select an element node in the XML tree to display or set output options for its
attributes and values on the right of the XMLOutput Properties dialog box.

The following commands are available according to the node you select in the tree:

Command Icon Description

Add Child Adds a child node below the selected node in the tree.

Insert
Sibling

Adds a sibling node at the same level as the selected node in the tree.

Add Value Enables you to assign a constant or parameterized value to the selected
element.
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Command Icon Description

Delete Deletes the selected node. Note that you cannot delete the root node of the
output value step.

Import
XML

Enables you to browse to and select a file structure from an existing XML
file. The new file overrides the selected node's current sub-tree.

Export
XML

Enables you to save the file structure of the selected node to an XML file.

Edit XML
as Text

Opens the "Edit XML as Text Dialog Box", enabling you tomodify the XML
text of the selected node and it's subnodes in a test editor.

Duplicate Adds a new node, identical to the selected one, as a sibling node at the
same level as the selected node in the XML tree.

Note: This command is available only from the context menu (right-
click menu).

Options Area

User interface elements are described below:

UI Element Description

Attribute The list of attributes for the selected element or value node in the XML tree.

Value The list of values for the selected element or value node in the XML tree.

Note: Click theConfigure the value button to display the "Output
Options Dialog Box ", which enables you to select or define the parameter in
which you want to store the retrieved value. For details on the options
available for each parameter type, see "Parameter Options Dialog Box" on
page 1556.
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Add Existing Output Value Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to select the test object to which you want to add an existing output
value.

The following image shows an example of the Output Value Properties dialog box when the
TestObjects tree is shown.

To access 1. Ensure that a GUI action or component is in focus in the document pane.

2. Insert a new output value step and select theExisting Output Value option.

Important
information

This option is available only if at least one of the object repositories associated
with the current action (including the local object repository) contains at least one
output object.

Relevant
tasks

"How to Create or Modify anOutput Value Step" on page 1494

See also "Output Options Dialog Box " on page 1519
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Object Details Area

User interface elements are described below:

UI Element Description

Test object The test object for which you are adding an output value (read-only).

TestObjects Tree Area

User interface elements are described below:

Option Description

TestObjects tree The objects stored in the object repositories associated with the
current action.

Show/Hide Test
Objects

Shows or hides the TestObjects tree.
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Properties Grid Area
The following image shows the Properties Grid area when only part of the properties are selected.
Specific properties may vary depending on the type of object for which you are defining output
values.

User interface elements are described below:

UI Element Description

Display only
output values
relevant to the
selected test
object

Instructs UFT to determine which output value objects from the current
action's object repositories are relevant for the selected object (based on the
output value type and the properties selected to output in the output value
object) and display only those output value objects in the Output Values list.

Note:When using this option, it is recommended to open your application
and display the selected object so that UFT can accurately determine all
of the output values that can apply to that object.

Output values The output values available for insertion.

If theDisplay only output values relevant to the selected test object
option is cleared, this list includes all output value objects from all object
repositories associated with the current action.

If theDisplay only output values relevant to the selected test object
option is selected, this list displays only the relevant output value objects as
described above.

Check box Enables you to select one or more property for the object, and specify the
output options for each property value you select.
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UI Element Description

Type The icon indicates that the value of the property is currently a constant.

The icon indicates that the value of the property is currently a test or action
parameter.

The icon indicates that the value of the property is currently a DataTable
parameter.

The icon indicates that the value of the property is currently an environment
variable parameter.

The icon indicates that the value of the property is currently a random
number parameter.

Property The name of the property.

Value The expected value of the property.

Configure Value Area
The following image shows the Configure Value area when the Data pane is used to store the
output value.

User interface elements are described below:

UI Element Description

Configure
value area

The output definition for the selected property, in read-only mode.

Modify Opens the "Output Options Dialog Box " (described on page 1519), enabling you to
change the output type and/or settings for the selected value.

Advanced File Content Output Value Properties Dialog
Box

Relevant for: GUI tests and scripted GUI components

This dialog box enables you to configure how the output value step is performed.
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To access In the "Output Value Properties Dialog Box" (described on page 1498), select
Advanced in the toolbar.

Important
information

WhenUFT performs a file content output value step, it locates the output value
text within the line by comparing all of the text on that line. The options in this
dialog box instruct UFT how to treat the text on every line in the file in which an
output value is specified. (You can createmultiple output values in a single file.)

Relevant
tasks

"How to Create or Modify anOutput Value Step" on page 1494

See also "Output Value Properties Dialog Box" on page 1498

User interface elements are described below:

UI
Element Description

Ignore
spaces

Ignores extraneous spaces on the same line as the output text when comparing the
expected content with the actual content. This is useful when theremight potentially
be one or more spaces in the text preceding or following the checked text, and you do
not want the checkpoint to fail because of this.

Note: This setting is not relevant for missing spaces.

Default:Cleared

Match
case

Conducts a case-sensitive check of all the text on the same line as the output value
text when comparing the expected content with the actual content.

Default:Selected

Output Options Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to define the output type for the specified property. The available output
types depend on whether the output value is for a test, a scripted component, or a keyword
component.
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To access l For tests and scripted components: In the Configure Value area of
any Output Value Properties dialog box, click theModify button.

l For keyword components, use one of the following:.

n In theOutput cell of a component step, click the output value

button  .

n Press CTRL + F11.

Important
information

l You can only output a value to an action parameter if the parameter
has been defined as an output parameter for the calling action.

l If at least one output parameter is defined in the action, UFT may
display Test/action parameter as the default output type. Otherwise,
DataTable may be displayed as the default output type.

l If at least one output component parameter is defined in the
component, the default output type is Component parameter and the
default output name is the first output parameter displayed in the
Parameters pane of the Business Component Settings dialog box.

l After you define an output parameter for a component, you can use its
value as an input value in a later step in the component (local and
component parameters), or in a later component in the business
process test (component parameters only).

l If you click in theOutput cell in a component step after you specify an
output parameter for the component, an icon specifying the type of
parameter is displayed in the cell:

n Indicates a component parameter.

n Indicates a local parameter.

See also l "Output Value Properties Dialog Box" on page 1498

You can choose from the following output types:

l "Test/Action Parameter Option" on the next page

l "Data Table Option" on the next page

l "Environment Variable Option" on page 1524

l "Component Parameter Option" on page 1524
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Test/Action Parameter Option

UI Elements Description

Test/action
parameter
Output type

Enables you to output a value to an action parameter, so that the values can be
used later in the run session, or the values can be passed back to the external
application that ran (called) the test.

For details on outputting a value to a test or action parameter, see "Storing
Output Values".

For details on creating and using parameters, see "Parameterizing Object
Values" on page 1526.

Parameter The name of the parameter in which to store the output value. The read-only list
of available parameters contains the names and full descriptions of the currently
defined output parameters for the action.

Tip: You can resize the display, as needed, and, if the list of parameters is
long, you can scroll through the list.

Data Table Option

UI
Elements Description

Data
Table
Output
type

Enables you to output values to the run-time data table. This enables you to store
and retrieve values during a data-driven test (or action) that runs several times. In
each repetition, or iteration, UFT stores the value in a different row within the Data
pane.

Name The name of the column in the Data pane in which to store the value. UFT suggests
a default name for the output. You can select an existing output name from the list,
or create a new output name by using the default output name or entering a valid
descriptive name.

Location
in Data
Table

Specifies whether to add the DataTable parameter (column name) in the global or
current action sheet in the data table.

For details on the use of data in the global and current action sheets, see "Action and
Test Iterations Using the Data Pane" on page 874.

For details on actions, see "Actions in GUI Testing" on page 871.

For details on outputting values to the Data pane, see "Run-time Data Table".
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Environment Variable Option

UI Elements Description

Environment
Output type

Enables you to specify the internal user-defined environment variable in which to
store the selected value for the duration of the run session.

Name The name of the internal user-defined environment variable in which to store the
value. The list contains all currently defined internal user-defined environment
variables with the corresponding type. You can select an existing variable from
the list, or you can create a new internal environment variable by modifying the
displayed name or by entering a new, descriptive name.

Note: If you select an existing variable from the list, UFT prompts you to
choose whether to overwrite its current value with the new value when the
output value step runs. If you choose not to overwrite the current value of
the selected variable, a new environment variable is created with the original
variable name and an identifying suffix.

Type The environment variable type. Because it is not possible to output values to
external or built-in environment variables, the type is always User-defined -
 internal.

For details on environment variables, see "Environment Variable Parameters" on
page 1536.

Component Parameter Option

UI
Elements Description

Output
Types

The type of output parameter. Possible values:

l Component parameter

l Local parameter

Parameter The component parameter in which to store the output value. (Displayed only if
Component parameter is Output Type.)

The names and full descriptions of the available component parameters are
displayed as read-only. You can resize the display, as needed, and, if the list of
parameters is long, you can scroll through the list.

Name The name of the parameter. (Displayed only if Local parameter is theOutput
Type)

Enter ameaningful name for the parameter or choose one from the list. If no local
parameter is defined, then the default parameter name, p_Local, is displayed.

Description A brief description for the parameter. (Displayed only if Local parameter is
Output Type.)
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Parameterization / Properties Dialog Box (Output Values)
Relevant for: Keyword GUI components

This dialog box displays output property value as aConstant or aParameter, in read-only mode.

To access In the Output Value Properties dialog box (Simplemode), click theBrowse button
for a property .

Important
information

l This option is available only in Simplemode. When in Advancedmode, the
options in this dialog box are available in theConfigure value area of the
Output Value Properties dialog box.

l You edit the output definition for output values in the Output Options dialog
box. For details, see "Component Parameter Option" on the previous page.

Relevant
tasks

"How to Create or Modify anOutput Value Step" on page 1494

See also l "Output Value Properties Dialog Box" on page 1498

l "Output Values Overview" on page 1488

For a description of user interface elements, see "Configure Value Area (Checkpoint Properties
Dialog Box) - Standard/Image Checkpoints" on page 1436.
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Chapter 52: Parameterizing Object Values
Relevant for: GUI tests and scripted GUI components

This chapter includes:

Concepts 1527

Parameterizing Values Overview 1527

Test and Action Input Parameters 1528

Data Table Parameters 1533

Environment Variable Parameters 1536

When to ChooseGlobal or Action Data Table Parameters 1538

Automatically Parameterizing Steps 1539

Data Driver 1543

Example of a Parameterized Test 1543

Tasks 1549

How to Parameterize Values for Operations or Local Objects 1549

How to Parameterize a Checkpoint Property Value 1550

How to Use User-Defined External Environment Variables 1551

How to Create an External Environment Variables File 1552

Reference 1554

Default Parameter Values 1554

Built-in Environment Variables 1554

Parameter Options Dialog Box 1556

Edit Complex Value Dialog Box 1563

Data Driver Dialog Box 1564

Data DriverWizard - Select Parameterization Type Page 1565

Data DriverWizard - Parameterize the Selected Step Page 1567
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Concepts

Parameterizing Values Overview
Relevant for: GUI tests only

You can enhance your test by parameterizing the values that it uses. A parameter is a variable that
is assigned a value from an external data source or generator.

You can parameterize values of:

l Checkpoints.

l Object properties for a selected step.

l Operation arguments defined for a selected step.

l One ormore properties of an object stored in the local object or the "Object Repository Window"
(described on page 1274). For details on parameterizing a property value for an object in a shared
object repository, see "SharedObject Repositories" on page 1285.

Example

Your applicationmay include a form with an edit box into which the user types the user name.
Youmay want to test whether your application reads this information and displays it correctly
in a dialog box. You can insert a text checkpoint that uses the built-in environment variable for
the logged-in user name, to check whether the displayed information is correct.

Note:When you parameterize the value of an object property for a local object, you are
modifying the test object description in the local object repository. Therefore, all
occurrences of the specified object within the action are parameterized. For details on the
local object repository, see "Managing Test Objects in Object Repositories" on page 1198.

You can parameterize the values in steps or the values of action parameters using one of the
following parameter types:

l Test/action parameters. Test parameters enable you to use values passed from your test.
Action parameters enable you to pass values from other actions in your test. For details, see
"Test and Action Input Parameters" on the next page.

l DataTable parameters. Enable you to create a data-driven test (or action) that runs several
times using the data you supply. In each repetition, or iteration, UFT uses a different value from
the Data pane. For details, see "Data Table Parameters" on page 1533.

l Environment variable parameters. Enable you to use variable values from other sources
during the run session. Thesemay be values you supply, or values that UFT generates for you
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based on conditions and options you choose. For details, see "Environment Variable
Parameters" on page 1536.

l Random number parameters. Enable you to insert random numbers as values in your test. For
example, to check how your application handles small and large ticket orders, you can instruct
UFT to generate a random number and insert it in a number of tickets edit box.

Tip:

n If you want to parameterize all the operation arguments in your test or in one or more
actions of a test, consider using the Automatically parameterize steps option. For details,
see "Automatically Parameterizing Steps" on page 1539.

n If you want to parameterize the same value in several steps in your test, consider using the
Data Driver rather than adding parameters manually. For details, see "Data Driver" on
page 1543.

n When you use the StepGenerator to add new steps, you can parameterize the values for
the operation you select. For details, see "How to Insert Steps Using the StepGenerator"
on page 978.

n You can also parameterize identification property values of test objects in the object
repository using repository parameters. For details, see "Working with Repository
Parameters" on page 1287.

Test and Action Input Parameters
Relevant for: GUI tests only

You can parameterize a value in a step using a test or action input parameter. To use a value within
a specific action, youmust pass the value down through the action hierarchy of your test to the
required action. You can then use that parameter value to parameterize a step in your test.

You can parameterize a value using a test or action parameter only if the parameter has been
defined for the test or action. For details on defining parameters, see "Parameters Tab (Properties
Pane - GUI Testing)" on page 394, "Parameters Tab (Action Properties Dialog Box)" on page 903,
and "Action Call Properties Dialog Box" on page 895.

Example

Suppose that Action3 is a nested action of Action1 (a top-level action), and you want to
parameterize a value in Action3 using a value that is passed into your test from the external
application that runs (calls) the test.

You can pass the value from the test level to Action1, then to Action3, and then parameterize
the required value using this action input parameter value (that was passed through from the
external application).
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Alternatively, you can pass an output action parameter value from an action step to a later
sibling action at the same hierarchical level. For example, suppose that Action2, Action3, and
Action4 are sibling actions at the same hierarchical level, and that these are all nested actions
of Action1.

You can parameterize a call to Action4 based on an output value retrieved from Action2 or
Action3. You can then use these parameters in your action step.

For details, see "Considerations for Setting Action Parameters" on the next page.

This section also includes:

l "How to Parameterize a Value" below

l "Using Action Parameters in Steps in the Editor" below

l "Considerations for Setting Action Parameters" on the next page

How to Parameterize a Value
You parameterize values by selecting input parameters in the Parameter Options or "Value
Configuration Options Dialog Box" (described on page 1579). The parameter options that are
available in these dialog boxes depend on where you are currently located in your test, and whether
test or action parameters are defined.

Alternatively, you can enter the parameter name in the Editor using theParameter utility object. For
details, see "Using Action Parameters in Steps in the Editor" below.

For details, see "How to Parameterize Values for Operations or Local Objects" on page 1549 and
"How to Parameterize a Checkpoint Property Value" on page 1550.

Tip: You can also create test or action parameter output values that retrieve values during the
run session and store them for use at another point in the run session. You can then use these
output values to parameterize a step in your test. For details, see "Storing Output Values" on
page 1492.

For details, see "Parameter Options Dialog Box" on page 1556.

Using Action Parameters in Steps in the Editor
Instead of selecting input (or output) parameters from the appropriate dialog boxes while
parameterizing steps or inserting output value steps, you can enter input and output parameters as
values in the Editor using theParameter utility object in the format: Parameter("ParameterName")
for the current action, orParameter("ActionName", "ParameterName") to use the output parameter
from a previous action as an input parameter in the current action.

Example:

Suppose you have test steps that enter information in a form to display a list of purchase orders
in a table, and then return the total value of the orders displayed in the table.
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You can define input parameters, calledSoldToCode and MaterialCode, for the codes
entered in theSold to andMaterials edit boxes of the form so that the Orders table that is
opened is controlled by the input parameter values passed when the test is called.

You can define an output parameter, for example TotalValue, to store the returned value. The
output value (TotalValue) can then be returned to the application that called the test.

The example described abovemight look something like this (parameters are in bold font):

Browser("Mercury").Page("List Of Sales").WebEdit("Sold to").Set Parameter("SoldToCode")

Browser("Mercury").Page("List Of Sales").WebEdit("Materials").Set Parameter("MaterialCode")

Browser("Mercury").Page("List Of Sales").WebButton("Enter").Click

NumTableRows = Browser("Mercury").Page("List Of Sales").WebTable("Orders").RowCount

Parameter("TotalValue") = Browser("Mercury").Page("List Of Sales").WebTable("Orders").GetCell
Data(NumTableRows,"Total")

Considerations for Setting Action Parameters

l Input action parameter values can be used only within the steps of the current action. You can
use an action input value from another action (or from the test) only if you pass the value from
action to action down the test hierarchy to the action in which you want to use it.
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l In subsequent steps of a calling action, you can use any type of action output value as a
variable, if the value was retrieved from the called action. For example, if ActionA calls ActionB
and specifies MyBVar as the variable in which to store ActionB's output parameter, then steps in
ActionA after the call toActionB can use theMyBVar as a value (just as you would use any
other variable). For example:

Test -> Action1 -> Action2 -> Action3 -> (Action3) Step 1

l Output action parameter values can be retrieved from a previous action at the same hierarchical
level, from a parent action, or from the current action. You can use an action output value from
one action within the step of another action if:

n You pass the value from action to action up the test hierarchy to the action in which you want
to use it. For example:
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(Action3) Step 1-> Action3 -> Action2 -> Action1 -> Test -> Action4

In this example, any step in Action 1, Action 2, or Action 3 can potentially use the output
value from (Action3) Step 1, even though the example shows that the output value is used by
steps in Action4.
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n You pass the value from a previous action to the sibling action in which you want to use it. For
example:

(Action2) Step 1 -> Action2 -> Action3 -> (Action3) Step 1

In this example, any step in Action 2 or Action 3 can potentially use the output value from
(Action2) Step 1, even though the example shows that the output value is used by (Action3)
Step 1.

l You can link action parameters with test parameters using the Parameter Values tab in the
Action Call Properties dialog box (described on page 897).

Data Table Parameters
Relevant for: GUI tests and scripted GUI components

You can supply the list of possible values for a parameter by creating a data table parameter. Data
table parameters enable you to create a data-driven test, or action that runs several times using
the data you supply. In each repetition, or iteration, UFT uses a different value from the Data pane
(taken from the subsequent row in the Data pane).

When you create a new data table parameter, a new column is added at the end of the Data pane
and the current value you parameterized is placed in the first row. If you parameterize a value and
select an existing data table parameter, the values in the column for the selected parameter are
retained and are not overwritten by the current value of the parameter.

Note: If you parameterize a value that is defined as a variant value, then when UFT retrieves
the value from the Data pane, it retrieves it as a string. This occurs even if you enter a numeric
value in the Data pane. For example, if you parameterize the argument of a step such as:
WpfWindow("MyWindow").WpfComboBox("cb").Select 1
and you enter the value 1 in the Data pane, then when the step runs, it retrieves the value as a
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string: "1", and the step fails.

A data table comprises:

l Columns. Each column in the table represents the list of values for a single data table
parameter.

l Column headers. The data table parameter names.

l Rows. Each row in the table represents a set of values that UFT submits for all the parameters
during a single iteration of the test. When you run your test, UFT runs one iteration of the test for
each row of data in the Data pane. For example, a test with ten rows in the Global sheet of the
Data pane runs ten times.

l Sheets. The Data pane contains two types of sheets—Global and action-specific. For details,
see "Data Table Sheets for GUI Testing" on page 225.

For details on entering values in the Data pane, see "Data Pane" on page 221.

Tip: You can also create data table output values, which retrieve values during the run session
and insert them into a column in the Data pane. You can then use these columns as data table
parameters in your test. For details, see "Output Values Overview" on page 1488.

Example 1

Suppose your application includes a feature that enables users to search for contact
information from amembership database. When the user enters amember's name, the
member's contact information is displayed, together with a button labelledView
<MemName>'s Picture, where <MemName> is the name of themember. You can
parameterize the name property of the button using a list of values so that during each iteration
of the run session, UFT can identify the different picture buttons.

Example 2

Consider theMercury Tours sampleWeb site, which enables you to book flight requests. To
book a flight, you supply the flight itinerary and click theContinue button. The site returns the
available flights for the requested itinerary.

Although you could conduct the test by accessing theWeb site and submitting numerous
queries, this is a slow, laborious, and inefficient solution. By using data table parameters, you
can run the test for multiple queries in succession.

When you parameterize your test, you first create steps that access theWeb site and check
for the available flights for one requested itinerary.

User Guide
Chapter 52: Parameterizing Object Values

HP Unified Functional Testing (12.00) Page 1534 of 2274



You then substitute the existing itinerary with a data table parameter and add your own sets of
data to the relevant sheet of the Data pane, one for each itinerary.

In this example, UFT submits a separate query for each itinerary when you run the test.
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Environment Variable Parameters
Relevant for: GUI tests and scripted GUI components

UFT can insert a value from the Environment variable list, which is a list of variables and
corresponding values that can be accessed from your test or component. Throughout the run
session, the value of an environment variable remains the same, regardless of the number of
iterations, unless you change the value of the variable programmatically in your test.

Example

You can instruct UFT to read all the values for filling in aWeb form from an external file, or you
can use one of UFT's built-in environment variables to insert current information about the
computer running the test or scripted component.

Tip: Environment parameters are especially useful for localization testing, when you want to
test an application where the user interface strings change according to the selected language.
Environment parameters can be used for testing the same application on different browsers.
You can also vary the input values for each language by selecting a different data table file
each time you run the test. For details, see "Data Pane" on page 221.

There are several types of environment variables:

User-Defined Internal Environment Variables (tests only)
User-defined internal environment variables are defined within the test. These variables are saved
with the test and are accessible only within the test in which they were defined.

You can create or modify internal, user-defined environment variables for your test in the:

l Environment pane of the Test Settings dialog box, as described in "Environment Pane (Test
Settings Dialog Box)" on page 608.

l Parameter Options dialog box, as described in "Parameter Options Dialog Box" on page 1556.

Tip: You can also create environment output values, which retrieve values during the test run
and output them to internal environment variable parameters for use in your test. For details,
see "Output Values Overview" on page 1488.

User-Defined External Environment Variables (tests only)
User-defined external environment variables are predefined in the active external environment
variables file. You can create as many files as you want and select an appropriate file for each test,
or change files for each test run. External environment variable values are designated as read-only
within the test.

External environment variable files are comprised of a list of variable-value pairs in .xml format. You
select the active external environment variable file for a test in the Environment pane of the Test
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Settings dialog box (see "Environment Pane (Test Settings Dialog Box)" on page 608). Then you
can use the variables from the file as parameters.

You can set up your environment variable XML files manually, or you can define the variables as
internal environment variables in the Environment pane of the Test Settings dialog box and use the
Export button to create the .xml file with the correct structure.

For details on creating and using user-defined external environment variable files see, "How to Use
User-Defined External Environment Variables" on page 1551.

Note:

l You can also store environment variable files in ALM. For details, see "Environment
Variable Files and ALM (tests only)" below.

l You can create several external variable files with the same variable names and different
values and then run the test several times, using a different file each time. This is especially
useful for localization testing.

Built-in Environment Variables
Variables that represent information about the test or scripted component and the computer on
which they are run, such as Test path andOperating system. These variables are accessible from
all tests and scripted components, and are designated as read-only. For details, see "Environment
Pane (Test Settings Dialog Box)" on page 608.

ALM provides a set of built-in variables that enable you to use current information about the test or
scripted component and the UFT computer running your test. These can include the test or
component name and path, the operating system type and version, and the local host name.

For example, youmay want to perform different checks in your test or component based on the
operating system being used by the computer that is running the test. To do this, you could include
the OSVersion built-in environment variable in an If statement.

You can also select built-in environment variables when parameterizing values. For details, see
"Parameter Options Dialog Box" on page 1556.

Note: UFT also has a set of predefined environment variables that you can use to set the
values of the Record and Run Settings dialog options. You should not use the names of these
variables for any other purpose. For details, see the sections on how to define record and run
settings forWindows-based andWeb-based applications in theHP Unified Functional Testing
Add-ins Guide.

Environment Variable Files and ALM (tests only)
Whenworking with ALM and environment variable files, youmust save the environment variable
file in the Test Resources module in your ALM project before you specify the file in the Environment
pane of the Test Settings dialog box.
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You can add a new or an existing environment variable file to your ALM project. Adding an existing
file from the file system to an ALM project creates a copy of the file in ALM. Therefore, changes
made to the ALM environment variable file do not affect the file system file and vice versa.

When to Choose Global or Action Data Table Parameters
Relevant for: GUI tests only

When you parameterize a step in a test using the Data pane, youmust decide whether you want to
make it a global data table parameter or a local data table parameter.

You use local data table parameters when you want the data to be used only for a single action. You
use global data table parameters when you want the data to be available to other actions, and when
you want subsequent iterations to use different data for a particular parameter (each time the test
repeats or each time the action repeats within the test).

If you havemultiple rows in the Global data sheet, the entire test runs multiple times. If you have
multiple rows in a local data sheet, the corresponding action runs multiple times before running the
next action in the test. If you havemultiple rows in both Global and local data sheets, each single
test iteration runs all iterations of each action before running the next iteration of the test.

l Global data table parameters take data from theGlobal sheet in the Data pane. TheGlobal
sheet contains the data that replaces global parameters in each iteration of the test.

By default, the test runs one iteration for each row in the Global sheet of the Data pane. You can
also set the test to run only one iteration. You can also set the test to run iterations on specified
rows within the Global sheet of the Data pane.

You can use the parameters defined in the Global data sheet in any action.

For details on setting global iteration preferences, see "Run Pane (Test Settings Dialog Box)" on
page 601.

Tip: By outputting values to the global Data pane sheet from one action and using them as
input parameters in another action, you can pass values from one action to another. For
details, see "Output Values Overview" on page 1488.

l Local data table parameters take data from the action's sheet in the Data pane. The data in the
action's sheet replaces the action's data table parameters in each iteration of the action. By
default, actions run only one iteration.

You can also set a particular call of the action to run iterations for all rows in the action's sheet or
to run iterations on specified rows within the action's sheet. When you set your action properties
to run iterations on all rows, UFT inserts the next value from the action's data sheet into the
corresponding action parameter during each action iteration, while the values of the global
parameters stay constant. For details on setting action iteration preferences, see "Run Tab
(Action Call Properties Dialog Box)" on page 895.
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After running a parameterized test, you can view the actual values taken from the Data pane in the
run results run-time data table. For details, see the section on the Run Results Viewer Data Pane
(described in theHP RunResults Viewer User Guide).

Automatically Parameterizing Steps
Relevant for: GUI tests only

You can instruct UFT to automatically parameterize the steps in your test actions at the end of a
recording session.

This enables you to create actions that can be used for a variety of different purposes or scenarios
by referencing different sets of data.

To activate this option, select theAutomatically parameterize steps option in theGeneral node
of the GUI Testing tab of the Options dialog box (Tools > Options > GUI Testing tab > General
node). You can set the option to useGlobal Data Table Parameters or Test Parameters. For
details, see "General Pane (Options Dialog Box > GUI Testing Tab)" on page 536.

When you stop a recording session while this option is selected, UFT replaces the constant values
in the test object operation arguments of your steps with either Data pane parameters or action
parameters, based on your selection of global Data pane parameters or test parameters in the
Options dialog box.

UFT performs this automatic parameterization for all relevant steps in any action in your test, in
which you recorded one or more steps during that recording session.

l When you select to useGlobal Data Table Parameters, the generated parameters are added
to the Global sheet of the Data pane.

If you work with ALM, you canmap these parameters to the column names of a data resource
and then use different configurations in your test sets. For details on ALM configurations and
mapping data table parameters to ALM data resources, see "Data Awareness in ALM" on page
715.

l When you select to use Test Parameters, UFT parameterizes the step with a newly created
action parameter. It also creates a corresponding test parameter.

For details on how UFT creates these parameters, which types of operation arguments are included
and excluded from the parameterization, and other important criteria to consider, see "Guidelines
and Considerations for Automatically Parameterizing Steps" on the next page.

This section also includes:

Guidelines and Considerations for Automatically Parameterizing Steps 1540
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Guidelines and Considerations for Automatically Parameterizing
Steps

Relevant for: GUI tests only

Before you begin a recording session with theAutomatically parameterize steps option
activated, make sure you are aware of the following guidelines and considerations:

General Guidelines

l The automatic parameterization process runs on all relevant steps in all local actions in which
you recorded one or more steps during the recording session. It also parameterizes the action
that is displayed when you stop the recording session, even if you did not record any steps in
that action.

n All relevant steps in any relevant action are parameterized, whether or not those steps were
added in the current recording session. Therefore, you can perform automatic
parameterization on an existing action by starting and stopping a recording session without
adding any steps.

n Automatic parameterization is not performed on external actions that are called from your
test, nor for actions called using the LoadAndRunAction statement.

l In general, simple, constant (string, number, boolean) test object and utility object operation
arguments are parameterized. Therefore, if the following are contained in amethod argument,
they are not parameterized:

n arguments that are already parameterized

n variables

n enumeration constants, such asmicLeftbtn

n expressions, such as: x = 3

n Assignments of values, such as:Window("Notepad").WinMenu("Menu").ExpandMenu =
True

n mathematical or other concatenation operations, such as "HelloWorld" & micCtrl & "S"

n VBScript statements, such as msgbox "hello"

n VBScript language statements such as For, If, Do, While

n steps inside called functions from function libraries or in functions or sub-routines defined
directly within the action
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l In addition to the above general rule, operation arguments in the following scenarios are also not
parameterized:

n SAPGuiTable.Input, SAPGuiGrid.Input, orSAPGuiAPOGrid.Input steps (inserted using
theAuto-parameterize table and grid controls option). For details, see the auto-
parameterize table topic in the SAP section of theHP Unified Functional Testing Add-ins
Guide.

n Nativemethods and properties accessed by theObject property.

n Steps for test objects that are stored in variables. For example, the "text" constant is not
parameterized in:

Set MyEditBox = Browser("x").Page("x").WebEdit("myedit")
MyEditBox.Set "text"

n Steps containing programmatic descriptions, such as:

Browser("x").Page("x").WebEdit(MyDescription).Set "text"

or

Browser("x").Page("x").WebEdit("prop:=value", "prop2:=value2).Set "text".)

n User-defined functions that are registered to test objects using aRegisterUserFunc
statement.

However, built-in UFT test object operations that were overridden using aRegisterUserFunc
statement are parameterized.

n Operation arguments of type variant, when the value is a number.

For example, in the following statement, the variant argument of the Select method is not para
meterized, because it is a number.

WpfWindow("MyWindow").WpfComboBox("cb").Select 1

However, in the following statement, the variant argument of the Select method is
parameterized, because it is a string.

WpfWindow("MyWindow").WpfComboBox("cb").Select "item1"

n Whenworking with Siebel applications, only operation arguments of Sbl* test objects, which
represent standard interactivity (SI) objects are parameterized. The operation arguments of
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Sieb* test objects, which represent Siebel High Interactivity (HI) API test objects, are not
parameterized. For details on these types of objects, see theSiebel section of the
HP Unified Functional Testing Add-ins Guide.

l The name of the parameter that UFT creates for eachmethod argument is in the format
TestObjectName_ArgumentName.

n If a parameter with this name already exists for the relevant parameter type, UFT appends an
underscore and a number to the end of the new parameter to create a unique name.

n If the test object name contains characters that are not valid for parameter names or if it
contains multi-byte characters, then the test object class is used instead of the test object
name.

l The automatic parameterization option is relevant only for tests. UFT does not automatically
parameterize steps after you record steps in a component.

l If you select theAutomatically generate With statements after recording option in addition
to theAutomatically parameterize steps option, then when you stop a recording session, UFT
converts the steps toWith statements and then parameterizes the operation arguments within
them.

Guidelines for Automatic Parameterization of Data Table Parameters

l When you useGlobal Data Table Parameters for the automatic parameterization option, the
arguments are parameterized using Global Data Table parameters. The constant value that the
parameter replaces is stored in the created column in the Global data sheet.

If the Global data sheet already contains more than one row, the value is entered in all rows of
the created Data Table column.

l Data pane sheets can contain 256 columns. At the end of a recording session, UFT
parameterizes the relevant operation arguments until it reaches the 256th column. If UFT
reaches themaximum number of data table parameters, it stops parameterizing at that point and
amessage informs you that not all relevant steps were parameterized.

l If the test uses an external data table, and the data table file is read-only, locked by another user,
or checked in to ALM version control, the automatic parameterization is not performed and a
message is displayed when you finish your recording session.

Guidelines for Automatic Parameterization of Test Parameters

l When you use Test Parameters for the automatic parameterization option:

n Each relevant method argument is converted to a new action parameter.

n A corresponding test parameter is also created.

n The constant value that the parameter replaces is stored as the default value for the action
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parameter (in the Action Properties dialog box) as well as for the test parameter (in the
Parameters pane of the Test Settings dialog box).

For top-level actions, UFT also promotes (parameterizes) the action parameter value (in the
"Action Call Properties Dialog Box" (described on page 895)) to use the corresponding test
parameter for you.

For nested actions, UFT creates an action parameter and a corresponding test parameter.
However, the action parameter value (in the "Action Call Properties Dialog Box") is not
promoted (parameterized) to use a parent action parameter. It is set to use the constant value
that it replaced.

When working with nested actions, if you want to use the created test parameter in order to
provide the actual values from an external application that calls your test, such as from SAP
eCATT, youmust manually create corresponding action parameters for all actions that call
your action, and then pass (promote) the action parameter values up to each parent action
and then to the test parameter level. For details on passing values between action and test
parameters, see "How to Use Action Parameters - Use-Case Scenario" on page 893.

Data Driver
Relevant for: GUI tests only

The Data Driver enables you to quickly parameterize several (or all) property values for test objects,
checkpoints, and/or method arguments containing the same constant value within a given action.

You can choose to replace all occurrences of a selected constant value with a parameter, in the
sameway that you can use a Find and Replace All operation instead of a step-by-step Find and
Replace process.

UFT can also show you each occurrence of the constant so that you can decide whether or not to
parameterize the value.

Note:

l When findingmultiple occurrences of a selected value, UFT conducts a search that is case
sensitive and searches only for exact matches. (It does not find values that include the
selected value as part of a longer string.)

l You cannot use the Data Driver to parameterize the values of arguments for user-defined
methods or VBScript functions.

Example of a Parameterized Test
Relevant for: GUI tests only

The following example shows how to parameterize a stepmethod and a checkpoint using data table
parameters.
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When you test your application, youmay want to check how it performs the same operations with
multiple sets of data. For example, if you are testing theMercury Tours sampleWeb site, youmay
want to check that the correct departure and the arrival cities are selected before you book a
particular flight.

Suppose that you want to check that the flights are booked correctly for a variety of different
locations. Rather than create a separate test with a separate checkpoint for each location, you can
parameterize the location information. For each iteration of the test, UFT then checks the flight
information for the different locations.

The following is a sample test of a flight booking procedure. The departure city is Frankfurt and the
arrival city is Acapulco.

This example includes:

Step 1: Parameterize a Step 1545

Step 2: Parameterize a Checkpoint 1545

Step 3: Enter Data in the Data Pane 1548

Step 4: View the Parameterized Test 1548
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Step 1: Parameterize a Step

Relevant for: GUI tests only

Parameterize themethod argument of the fromPort step:

In the Keyword View, click in theValue cell of the step and then click the parameterization icon .
In the "Value Configuration Options Dialog Box" (described on page 1579), select theParameter
radio button. In theName box, rename p_item to Location.

Click OK. The Location column is added to the Data pane.

For details on parameterizing a step, see "How to Parameterize Values for Operations or Local
Objects" on page 1549.

Step 2: Parameterize a Checkpoint

Relevant for: GUI tests only

Add a parameterized text checkpoint to check that the correct locations were selected before you
book a flight. To do this:
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Select theSelect a Flight step. In the Active Screen, highlight the text Frankfurt to Acapulco, right-
click and insert a text checkpoint:

In the Text / Text Area Checkpoint Properties Dialog Box (described on page 1498), select
Parameter to parameterize the selected text. Select theParameter radio button and click the

Parameter Options button .
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In the Parameter Options dialog box, rename the data table parameter toCheck_Locations_Text.
Click OK in the Parameter Options dialog box and in the Text Checkpoint Properties dialog box. A
Check_Locations_Text column is added to the Data pane.

For details on parameterizing a checkpoint, see "How to Parameterize a Checkpoint Property
Value" on page 1550.
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Step 3: Enter Data in the Data Pane

Relevant for: GUI tests only

Complete the Data pane, for example:

For details on Data pane, see "Data Pane" on page 221.

Step 4: View the Parameterized Test

Relevant for: GUI tests only

The following example shows the test after parameterizing the step and creating a parameterized
text checkpoint.

The parameterized value for the fromPort step is clearly shown as a data table parameter. To see
the parameterization setting for the checkpoint, click in theValue column for theSelect a Flight
step.
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Tasks

How to Parameterize Values for Operations or Local
Objects

Relevant for: GUI tests and scripted GUI components

This task describes different ways to parameterize the values for operations in a step or objects in
the local object repository.

This task includes:

l "Parameterize a value for an operation using the parameterization icon" below

l "Use the Data Driver to parameterize some or all of the occurrences of a constant value in your
test (tests only)" on the next page

l "Enter input and output parameters as values in the Editor (tests only)" on the next page

Parameterize a value for an operation using the parameterization icon

1. To parameterize a value for an operation using the parameterization icon, in the Keyword View
click in theValue column of the required step.

n To parameterize property values for local objects, do one of the following:

o Right-click a step and select Object Properties. The "Object Properties Dialog Box"
(described on page 1271) opens.

o Open the "Object Repository Window" (described on page 1274) and select the object.

2. Click the parameterization icon .

n To parameterize a value for an operation, in the Keyword View, click the parameterization

icon for the value that you want to parameterize.

n To parameterize property values for local objects, in the Object Repository click in the
Value cell for the property that you want to parameterize, and click the parameterization

icon .

n The Value Configuration Options dialog box opens, showing the currently defined value.

3. Parameterize the value using the "Value Configuration Options Dialog Box" (described on page
1579).
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Use the Data Driver to parameterize some or all of the occurrences of a
constant value in your test (tests only)
For details, see "Data Driver Dialog Box" on page 1564.

Enter input and output parameters as values in the Editor (tests only)
You can enter input and output parameters as values in the Editor using the Parameter utility object.
For details, see "Using Action Parameters in Steps in the Editor" on page 1529.

How to Parameterize a Checkpoint Property Value
Relevant for: GUI tests and scripted GUI components

This task describes how to parameterize the values for properties in checkpoints. You can
parameterize the values for properties in checkpoints in one of the following ways:

l "Parameterize a value for a property in a checkpoint using the Checkpoint Properties dialog box"
below

l "Use the Data Driver to parameterize some or all of the occurrences of a constant value in your
test (tests only)" below

l "Enter input and output parameters as values in the Editor (tests only)" below

Parameterize a value for a property in a checkpoint using the Checkpoint
Properties dialog box

1. Open the dialog box for the checkpoint properties.

Open the dialog box for the checkpoint properties in one of the following ways:

n Right-click the checkpoint and select Checkpoint Properties.

n Open the "Object Repository Window" (described on page 1274) and select the checkpoint.

2. Use the options in the Configure Value area to parameterize the value.

a. Select the property whose value you want to parameterize from the table of properties.

b. In theConfigure value area, select Parameter.

c. Click theParameter Options button . The "Parameter Options Dialog Box" on page
1556 opens:

Use the Data Driver to parameterize some or all of the occurrences of a
constant value in your test (tests only)
For details, see "Data Driver Dialog Box" on page 1564.

Enter input and output parameters as values in the Editor (tests only)
You can enter input and output parameters as values in the Editor using the Parameter utility object.
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For details, see "Using Action Parameters in Steps in the Editor" on page 1529.

How to Use User-Defined External Environment Variables
Relevant for: GUI tests only

This task describes how to create an external variable file and use it in your test.

This task includes the following steps:

l "Create an external environment variables file" below

l "(ALM users only) Upload the environment resource file to your ALM project" below

l "Use environment variables in your test" below

l "Results" on the next page

1. Create an external environment variables file
You can create an external environment variable file using the Test Settings dialog box or
manually. For details, see "Create an external environment variable file manually" on the next
page.

2. (ALM users only) Upload the environment resource file to your ALM
project
a. In the ALM Test Resources module, create a new environment variable resource and then

upload the .xml environment variable file you want to use with your test. For details, see
theHP Application Lifecycle Management User Guide.

b. In UFT, connect to the ALM project. For details, see "ALM Connection Dialog Box" on
page 737.

3. Use environment variables in your test
a. Open the Environment pane in the Test Settings dialog box (File > Settings >

Environment node). For details, see "Environment Pane (Test Settings Dialog Box)" on
page 608.

b. Select User-defined from theVariable type list.

c. Select the Load variables and values from external file (reloaded each run session)
check box.

d. Use the browse button to the right of the File edit box, or enter the full path of the external
environment variables file you want to use with your test. If your test is stored in ALM, you
must select an file that is stored with your ALM project.

The variables defined in the selected file are displayed in the list of user-defined
environment variables.
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4. Results
You can now select the variables in the active file as external user-defined environment
parameters in your test. For details, see "Parameter Options Dialog Box" on page 1556.

How to Create an External Environment Variables File
Relevant for: GUI tests only

Note: This task is part of a higher-level task. For details, see "How to Use User-Defined
External Environment Variables" on the previous page.

You create an external environment variables file in one of the following ways:

l "Create an external environment variable file using the Test Settings dialog box" below

l "Create an external environment variable file manually" below

Create an external environment variable file using the Test Settings dialog
box

1. Define the variables in the Environment pane of the Test Settings dialog box (File > Settings
> Environment node).

2. Click Export to export the user-defined environment variables to an .xml file.

For details, see "Environment Pane (Test Settings Dialog Box)" on page 608.

Create an external environment variable file manually

1. Create an .xml file using the editor of your choice.

You can use the UFT environment variable file schema in:<Unified Functional Testing
installation folder>\help\
QTEnvironment.xsd or follow the formatting instructions below.

2. Enter <Environment> on the first line.

3. Enter each variable name-value pair in between <Variable> elements using the following
format:

<Variable>
    <Name>This is the first variable's name</Name>
    <Value>This is the first variable's value</Value>
    <Description> This text is optional and can be used to add comments.
    It is shown only in the XML and not in UFT</Description>
</Variable>
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4. Enter </Environment> on the last line.

Example

<Environment>
    <Variable>
        <Name>Address1</Name>
        <Value>25 Yellow Road</Value>
    </Variable>
    <Variable>
        <Name>Address2</Name>
        <Value>Greenville</Value>
    </Variable>
    <Variable>
        <Name>Name</Name>
        <Value>John Brown</Value>
    </Variable>
    <Variable>
        <Name>Telephone</Name>
        <Value>1-123-12345678</Value>
    </Variable>
</Environment>

5. Save the file in a location that is accessible from the UFT computer. The file must be in .xml
format with an .xml file extension.
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Reference

Default Parameter Values
Relevant for: GUI tests only

When you select a value that has not yet been parameterized, UFT generates a default parameter
definition for the value. The following table describes how the default parameter settings are
determined:

When
parameterizing Condition

Default
parameter
type Default parameter name

A value for a
step or a
checkpoint in an
action

At least one input
action parameter is
defined in the current
action

Action
parameter

The first input parameter displayed in
the "Parameter Values Tab (Action Call
Properties Dialog Box)" (described on
page 897)

An input action
parameter value
for a nested
action

At least one input
action parameter is
defined for the action
calling the nested
action

Action
parameter

The first input parameter displayed in
the "Parameter Values Tab (Action Call
Properties Dialog Box)" (described on
page 897) of the calling action

An input action
parameter value
for a top-level
action call

At least one input
parameter is defined
for the test

Test
parameter

The first input parameter displayed in
the "Parameter Values Tab (Action Call
Properties Dialog Box)" (described on
page 897)

If the relevant condition described above is not true, the default parameter type is Data Pane. If you
accept the default parameter details, UFT creates a new data table parameter with a name based
on the selected value. data table parameters are created in the Global sheet.

For details on Data pane sheets, see "Data Pane" on page 221.

Built-in Environment Variables
Relevant for: GUI tests and scripted GUI components

The following built-in environment variables are available:

Name Description

ActionIteration
(GUI tests only)

The action iteration currently running.

ActionName The action name.
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Name Description

ControllerHostName The name of the controller's computer. This variable is relevant only
when running as aGUI Vuser from the LoadRunner controller.

GroupName The name of the group in the running scenario. This variable is
relevant only when running as aGUI Vuser from the LoadRunner
controller.

LocalHostName The local host name.

OS The operating system.

OSVersion The operating system version.

ProductDir The folder path where the product is installed.

ProductName The product name.

ProductVer The product version.

ResultDir The path of the folder in which the current run results are located.

Note: You cannot use theResultDir environment variable
when running a test from Business Availability Center,
LoadRunner, or the Silent Test Runner in UFT.

ScenarioId The identification number of the scenario. This variable is relevant
only when running as aGUI Vuser from the LoadRunner controller.

SystemTempDir The system temporary folder.

TestDir The path of the folder in which the test or scripted component is
located.

TestIteration
(GUI tests only)

The test or iteration currently running.

TestName The name of the test or scripted component.

UpdatingActiveScreen Indicates whether the Active Screen images and values are being
updated during the update run process. For details, see "Update
Options Tab (Update Run Dialog Box)" on page 1107.

UpdatingCheckpoints Indicates whether checkpoints are being updated during the update
run process. For details, see "Update Options Tab (Update Run
Dialog Box)" on page 1107.

UpdatingTODescriptions Indicates whether the set of properties used to identify test objects
are being updated during the update run process. For details, see
"Update Options Tab (Update Run Dialog Box)" on page 1107.
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Name Description

UserName TheWindows login user name.

VuserId The Vuser identification under load. This variable is relevant only
when running as aGUI VUser from the LoadRunner controller.

For more details, see the section on built-in environment variables in "Environment Variable
Parameters" on page 1536.

Parameter Options Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to define settings for a test/action parameter, a data table parameter,
an environment parameter, or a random number parameter.

The example below shows the Parameter Options dialog box for a test/action parameter.

The example below shows the Parameter Options dialog box for a data table parameter.
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The example below shows the Parameter Options dialog box for a test/action parameter.

The example below shows the Parameter Options dialog box for a random number parameter.
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To access 1. Ensure that a GUI action is in focus in the document pane.

2. Use one of the following:

n For argument values: In the Keyword View, click theConfigure the

value button  .

n For object property values: In the "Object Repository Window"
(described on page 1274), select the object property value you want to

parameterize and click theConfigure the value button  .

n For checkpoints: In theConfigure value area of theCheckpoint
Properties dialog box, select theParameter radio button and click the

Parameter Options button  .

n For output value storage locations: In the "Object Repository Window"
(described on page 1274), select the output object property value you want
to parameterize and click theModify button in theConfigure value area.

Note: This dialog appears when using a scripted component only for
checkpoints.
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Important
information

l You can also use test or action parameter variables using parameterization
objects andmethods in the Editor. For details, see theHP UFT Object Model
Reference for GUI Testing.

l You cannot select Use Data Table formula if Regular expression is
selected.

l The value of an environment variable remains the same throughout the test
run, regardless of the number of iterations, unless you change the value of the
variable programmatically in your script.

l Random number parameters are not appropriate for non-numeric values, such
as text or hypertext links.

l If you select an existing parameter in your test, when youmodify the settings
in this dialog box, all instances of that parameter are affected.

Relevant
tasks

l "How to Parameterize Values for Operations or Local Objects" on page 1549

l "How to Parameterize a Checkpoint Property Value" on page 1550

l "How to Use User-Defined External Environment Variables" on page 1551

See also l "Parameterizing Object Values" on page 1526

l "Test and Action Input Parameters" on page 1528

l "Formulas in Data Tables for GUI Testing" on page 228

l "Environment Variable Parameters" on page 1536

User interface elements are described below:

When working with a Test/action parameter

UI Element Description

Parameter
types

The type of parameter you want to use for the value.

You can choose from Test/action parameter, Data Table parameter,
Environment, orRandom Number.

Parent action
parameter/Test
parameter
(test and action
parameters
only)

Select this radio button if you want the parameter to take its value from an
input parameter. The available radio button option depends on where you are
defining the parameter:

l Parent action parameter. Available for nested actions and all steps.

l Test parameter. Available for top-level actions only.
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UI Element Description

Parameter Specifies the name of the input parameter. The read-only list of available
parameters contains the names and full descriptions of the currently defined
input parameters for the action.

Output from
previous
action call(s)
(test and action
parameters
only)

Select this radio button if you want the parameter to take its value from an
output parameter. You can select from the output parameters of any previous
action in the same hierarchical level as the current action, for which output
parameters are defined.

l Action. Specifies the previous action from which you can choose an output
parameter. You can choose any action in the list.

l Parameter. Specifies the name of the output parameter. The read-only list
of available parameters contains the names and full descriptions of the
currently defined output parameters from the previous action(s).

When working with a Data Table parameter

UI
Elements Description

Parameter
types

The type of parameter you want to use for the value. Make sure that Data Table is
selected.

Name The name of the parameter to use. The following options are available:

l To use an existing parameter, select it from the list.

l To create a new parameter, either use the default parameter name or enter a
descriptive name for the parameter.

Location
in Data
Table

l Global sheet. You store data in the Global tab when you want it to be available
to all actions in your test and you want the data to control the number of test
iterations.

l Current action sheet (local). You store data in the action's tab when you want
to use the data in data table parameters for that action only and you want the
data to control the number of action iterations.

For details, see "When to ChooseGlobal or Action Data Table Parameters " on
page 1538.

Regular
expression

Enables you to set the value of the parameter as a regular expression.

Note: This option is available only when parameterizing checkpoint and object
property values.
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UI
Elements Description

Use Data
Table
formula

Enables you to use formulas predefined in the Data Table. For details on setting
formulas, see "Formulas in Data Tables for GUI Testing" on page 228.

For checkpoints, UFT inserts two columns in the Data pane. The first column
contains a formula that checks the validity of the output in the second column.
UFT uses the data in the output column to compute the formula, and inserts a
value of TRUE or FALSE in the table cell of the formula column.

When working with an Environment parameter

UI
Elements Description

Parameter
types

The type of parameter you want to use for the value. Make sure that Environment
is selected.

Name The name of the parameter. For an internal user-defined environment variable
parameter, you can create a new parameter by using the default parameter name
or entering a new, descriptive name. Alternatively, you can select an existing
internal user-defined environment variable parameter from the list.

Note:

l If you edit the name displayed in theName box for an existing parameter,
you create a new internal user-defined environment variable parameter.
The original environment variable parameter is not modified. For details on
modifying existing environment variable parameters, see "Environment
Pane (Test Settings Dialog Box)" on page 608.

l If you are parameterizing an argument that receives a predefined constant
or number, only the environment variable parameters whose value is of
type integer are shown in theName list.

Value Specifies the value of the parameter. You can enter the value for a new user-
defined internal parameter, or modify the value for an existing user-defined internal
parameter. External and built-in environment variable parameter values cannot be
modified in this dialog box.

If the entire value of a selected environment variable parameter cannot be
displayed in theValue box, it is shown as [complex value]. For example, the
value of a list's all items property is amulti-line value, where each line contains
the value of an item in the list.

You can view or edit a complex value by clicking the View/Edit Complex Value

button . For details, see "Edit Complex Value Dialog Box " on page 1563.
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UI
Elements Description

Type The type of environment variable parameter (read-only):

l internal user-defined

l external user-defined

l built-in

Regular
expression

The value of the parameter as a regular expression. This option is available only
when parameterizing a checkpoint or object property text string value, and the
selected environment variable parameter type is internal user-defined. For
details on regular expressions, see "Regular Expressions Overview" on page 318.

When working with a Random Number parameter

UI
Elements Description

Parameter
types

The type of parameter you want to use for the value. Make sure that Random
Number is selected.

Numeric
range

The range from which the random number is generated. You canmodify the range
by entering different values in the From and To boxes.

Default range: 0 to 100

Minimum From value: 0

Maximum To value: 2147483647

Name The name of your parameter. Assigning a name to a random parameter enables you
to use the same parameter several times in your test. You can select an existing
named parameter or create a new named parameter by entering a new, descriptive
name.

Generate
new
random
number

The generation timing for a named random parameter. This box is enabled when you
select theName check box. You can select one of the following options:

l For each action iteration. Generates a new number for each action iteration.

l For each test iteration. Generates a new number for each global iteration.

l Once per entire test run. Generates a new number the first time the parameter
is used. The same number is used for the parameter throughout the run session.
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Edit Complex Value Dialog Box
Relevant for: GUI tests only

This dialog box enables you to edit a parameter value that cannot be displayed in the Parameter
Options dialog box.

To access TheParameters Options dialog box displays the value of the parameter in the
Value box. If the value cannot be entirely displayed in theValue box (such as a

list), click theView/Edit Complex Value button to open theEdit Complex
Value dialog box.

Important
information

l Internal user-defined environment variable parameter. You can edit the
value.

l External or built-in environment variable parameter. You can view the
value but you cannot modify it in this dialog box.

Relevant
tasks

"How to Use User-Defined External Environment Variables" on page 1551

See also "Environment Variable Parameters" on page 1536
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Data Driver Dialog Box
Relevant for: GUI tests only

This dialog box displays a list of all the default constants for an action. For each constant value you
add to the list, it displays the number of times the constant valuEWe appears in the action.

To access 1. Do one of the following:

n Ensure that a GUI action is in focus in the document pane.

n In the Solution Explorer, select a GUI test node or one of its child
nodes.

2. Select Tools > Data Driver.

Relevant tasks l "How to Parameterize Values for Operations or Local Objects" on page
1549

l "How to Parameterize a Checkpoint Property Value" on page 1550

See also "Data Driver" on page 1543
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<constants
list>

The list of default constant values as well as any constants you added during the
current Data Driver session. The list also displays the number of times the
constant value occurs in the action, and the number of occurrences that are set
to be parametrized.

Add Value Opens the Add Constant dialog box, which enables you to add a valid constant
to the Constants list.

Any object property or checkpoint value that exists in your action is a valid
constant value.

If you chose not to wait for the constants to load you can use this option to add
the constant values that you want to parameterize to the Data Driver.

Parameterize Opens the Data DriverWizard, which enables you to parameterize all
occurrences of the selected value. You can set the parameterization for each
occurrence step-by-step, or you can parameterize all occurrences in a single
operation.

Data Driver Wizard - Select Parameterization Type Page
Relevant for: GUI tests only

This wizard enables you to select the parameterizationmethod, and set parameterization options if
you select theParameterize allmethod.
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To
access

1. Do one of the following:

n Ensure that a GUI test or action is in focus in the document pane.

n In the Solution Explorer, select a GUI test node or one of its child nodes.

2. Select Tools > Data Driver and select theParameterize button in the Data
Driver dialog box.

Relevant
tasks

l "How to Parameterize Values for Operations or Local Objects" on page 1549

l "How to Parameterize a Checkpoint Property Value" on page 1550

Wizard
map

This wizard contains:

Data Driver Wizard - Select Parameterization Type Page > "Data DriverWizard -
Parameterize the Selected Step Page"(page 1567)
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User interface elements are described below:

UI Elements Description

Step-by-step
parameterization

Enables you to view the current values of each step containing the selected
value. For each step, you can choose whether or not to parameterize the
value, and if so, which parameterization options you want to use.

TheNext button is enabled when you select this option.

Parameterize all Enables you to parameterize all occurrences of the selected value
throughout the action.

When you select this option theConfigure value area is enabled.

The Finish button is enabled when you select this option.

Configure value Enables you to set the parameterization options you want to apply to all
occurrences of the selected value.

Select your parameterization preferences the sameway that you would for
an individual step. For details on setting parameterization options, see
"Configure Value Area " on page 1575.

Next Opens the "Data DriverWizard - Parameterize the Selected Step Page".

(Enabled only whenStep-by-step parameterization is selected.)

Skip Disabled for this page.

Finish Saves your parameterization options and closes the Data DriverWizard.
The "Data Driver Dialog Box" displays the number of occurrences of the
selected value to parameterize.

Note: Your parameterization settings are not applied until you click OK
on the Data Driver main page.

Data Driver Wizard - Parameterize the Selected Step Page
Relevant for: GUI tests only

This wizard page displays the steps in the current action and enables you to set your
parameterization preferences for the selected step.
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Wizard map The Data DriverWizard contains:

"Data DriverWizard - Select Parameterization Type Page" (page 1565)
 > Data Driver Wizard - Parameterize the Selected Step Page

See also "Data Driver" on page 1543

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Step to parameterize Displays the steps in the current action. Highlights the first step with
an object property or checkpoint value containing the constant value
selected in the "Data Driver Dialog Box".

<Step information> The top right part of the dialog box displays information about the
selected object property or checkpoint in the "Step to parameterize"
area.
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UI Elements Description

<Properties/arguments
information> (for
objects and
checkpoints only)

The Properties area displays the property to parameterize within the
context of the other properties or arguments that apply to the selected
step.

Note: You can parameterize only the selected value. The other
values are displayed for informative purposes only.

Configure value area The default parameterization settings are selected for the value. To

modify the settings click theParameter Options button to set
the parameterization options you want to apply to this step.

You select your parameterization preferences the sameway that you
would for an individual step. For details, see "Configure Value Area "
on page 1575.

Next Saves your parameterization preferences for the selected step, and
opens the Parameterize the Selected Step page for the next
occurrence of the selected value. If there are no remaining
occurrences of the value, clickingNext opens the Finished page.

Skip The value of the selected step remains a constant (not
parameterized), and the Parameterize the Selected Step page for the
next occurrence of the selected value opens. If there are no remaining
occurrences of the value, clickingSkip opens the Finished page.

Finish Applies the parameterization settings of the current step to this step
and all remaining steps containing the selected value. The Data
DriverWizard closes and the Data Driver main page shows how
many occurrences you selected to parameterize and how many
remain as constants.
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Chapter 53: Value Configuration and
Parameterization

Relevant for: GUI tests and components

This chapter includes:

Concepts 1571

Value Configuration Overview 1571

Working with Local and Component Parameters 1571

Tasks 1572

How to Configure Constant and Parameter Values 1572

How to Parameterize Input Values (Keyword Components) 1573

Reference 1575

Configure Value Area 1575

Constant Value Options Dialog Box 1577

Value Configuration Options Dialog Box 1579

Using Property Patterns to Identify Objects 1582
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Concepts

Value Configuration Overview
Relevant for: GUI tests and scripted GUI components

UFT enables you to configure the values for properties and other items by defining a value as a
constant or a parameter. You can also use regular expressions for some values to increase the
flexibility and adaptability of your tests. For details on regular expressions, see "Regular
Expressions Overview" on page 318.

Some dialog boxes, such as the Checkpoint Properties dialog boxes, include aConfigure value
area, in which you can define the value for a selected item as a constant or a parameter. In other
contexts, such as the Keyword View, StepGenerator, andObject Repository window, you can
select a value directly and parameterize it or define it as a constant.

l Constant. A manually defined value that remains unchanged for the duration of the test. In
certain contexts, you can define a constant value using a regular expression.

l Parameter. A value that is defined or generated externally and is retrieved during a run session.
For example, a parameter valuemay be defined in an external file or generated by UFT.

When you define a value as a parameter, you can also specify other settings according to the
parameter type. For details on using parameters in your tests, see "Parameterizing Object Values"
on page 1526.

Working with Local and Component Parameters
Relevant for: Keyword GUI components

You can define input parameters that pass values into your keyword component, and output
parameters that pass values from your component to external sources or from one step to another
step. You can then use these parameters to parameterize input and output values in steps.

You can define two types of parameters—local parameters and component parameters.

Local parameter. Variable values defined within a component for use within the same component.

Local input parameter values can be received and used by a later parameterized step in the same
component. You define local input parameters in the Keyword View using the "Value Configuration
Options Dialog Box" (described on page 1579) and the "Parameters Tab (Properties Pane - GUI
Testing)" (described on page 1475).

Local output parameters can be returned by an operation or component step for use within the same
component. Local output parameter values can be viewed in the business process run results. You
define local output parameters using the Output Options dialog box.

You cannot delete local parameters, but you can cancel the input or output to them.

Component parameter. Variable values defined within a component for use in the same
component or later components in the business process test.
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Component input parameter values can be received and used as the values for specific,
parameterized steps in the component.

Component output parameter values can be returned as input parameters in components that are
used later in the test. These values can also be viewed in the business process run results.

You define component input and output parameters in the Parameters pane of the Component
Settings dialog box, or in the ALM Business Components module. For details, see "Parameters Tab
(Properties Pane - GUI Testing)" on page 394 or theHP Business Process Testing User Guide.

Tip: Additionally, if you are working with a business process test or flow, you can define
parameters in the Properties pane. For details, see "Parameters Tab (Properties Pane - BPT)"
on page 444.

After you define a parameter you can use it to parameterize a value. Alternatively, you can apply a
constant value to the parameter by typing it directly in theValue cell.

For instructions on how to parameterize input values, see "How to Parameterize Input Values
(Keyword Components)" on the next page.

For instructions on how to parameterize output values, see "How to Create or Modify anOutput
Value Step" on page 1494.

Tasks

How to Configure Constant and Parameter Values
Relevant for: GUI tests and components

This task describes how to define a value as a constant or a parameter:

l In theValue area (available from the Keyword View, StepGenerator, Object Repository

window, and so on), click the parameterization button for a selected value to open the "Value
Configuration Options Dialog Box" (described on page 1579). For example:
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l Above theConfigurevalue area of a dialog box, select a property or argument, for example:

Then, in theConfigure value area, select theConstant orParameter radio button and click the

Constant Value Options orParameter Options button . For details, see "Configure Value
Area " on page 1575.

For additional details, see:

n For tests and scripted components: "Parameter Options Dialog Box" on page 1556

n For keyword components: "Parameter Options Dialog Box (Local and Component Input
Parameters for Checkpoints)" on page 1475.

How to Parameterize Input Values (Keyword
Components)

Relevant for: Keyword GUI components

This task describes how to parameterize input values for a step using a local parameter or a
component parameter.

This task includes the following steps:

l "Open the Value Configuration Options dialog box or Parameter Options dialog box" on the next
page

l "Select the type of parameter and define its details" on the next page

l "Results" on page 1575
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Open the Value Configuration Options dialog box or Parameter Options
dialog box
For details, see:

l "Value Configuration Options Dialog Box" on page 1579

l "Parameter Options Dialog Box (Local and Component Input Parameters for Checkpoints)" on
page 1475

Select the type of parameter and define its details

1. In theParameter box, select one of the following:

n Component parameter. Select the component parameter you want to use for the
parameterized value. The names and full descriptions of the available component
parameters are displayed as read-only. You can resize the display, as needed, and, if the list
of parameters is long, you can scroll through the list.

n Local parameter. The details for the local parameter type are displayed.

2. Specify the property details for the local parameter:

n Name. Enter ameaningful name (case-sensitive) for the parameter or choose one from the
list.
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n Value. Enter an input value for the parameter. For details, see "Parameters Tab (Properties
Pane - GUI Testing)" on page 394.

n Description. Enter a brief description for the parameter.

Tip:

You can cancel the parameterization of a value by selecting theConstant option in the
"Value Configuration Options Dialog Box" (described on page 1579) and entering a
constant value. The Constant box offers the same editing options as the Value cell in

which you clicked the parameterization button to open this dialog box.

If you click in theValue cell after you define a component parameter for it, the 
icon is displayed in each part of the cell for which a component parameter is defined.

If you click in theValue cell after you define a local parameter for it, the  icon is
displayed in each part of the cell for which a local parameter is defined.

Results
The local or component parameter is displayed in theValue cell of your step. When the component
runs, it will use the value specified in the parameter for the step.

Reference

Configure Value Area
Relevant for: GUI tests and components

This area enables you to configure object property values or the values of the operation arguments
defined for the step.

The following examples illustrate various value definitions:

Single-line constant
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Complex constant (tests only)

Parameter

To
access

This area is available in many dialog boxes, for example, the various Checkpoint
Properties andOutput Value dialog boxes, the various Parameter Options dialog boxes,
the "Parameterization / Properties Dialog Box (Checkpoints)" (described on page 1473)
(for components), the Data DriverWizard, and so on.

User interface elements are described below:

UI
Elements Description

Constant A manually defined value that remains unchanged for the duration of the run. In
certain contexts, you can define a constant value using a regular expression.

This is the default option.

If the entire value cannot be displayed in theConstant box, it is shown as
[complex value]. For example, the value of a list's all items property is amulti-line
value, where each line contains the value of an item in the list.

You can edit a value directly in theConstant box or by clicking theConstant Value

Options button . This also enables you to define a string value or complex
value as a regular expression.
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UI
Elements Description

Parameter A value that is defined or generated externally and is retrieved during a run session.
For example, a parameter valuemay be defined in an external file or generated by
UFT.

TheParameter box displays:

l The current parameter definition for a value that is already parameterized

l The default parameter definition for a value that is not yet parameterized.

For more details on default parameter definitions, see:

n For tests and scripted components: "Default Parameter Values" on page
1554

n For keyword components: "Value Configuration Options Dialog Box" on page
1579.

You can click theParameter Options button to open the Parameter Options
dialog box that enables you to select a different parameter type or modify the
parameter settings for the value. For details, see "Parameter Options Dialog Box"
on page 1556 (if you are working in a test or scripted component) or "Value
Configuration Options Dialog Box" on page 1579 (if you are working in a scripted
component).

For more details on using parameters in GUI tests, see "Parameterizing Object
Values" on page 1526.

Constant Value Options Dialog Box
Relevant for: GUI tests and scripted GUI components

This dialog box enables you to edit the value of a constant.
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For a complex value (a value that cannot be displayed entirely in theConstant box in the
Configure value area of a dialog box), the Constant Value Options dialog box expands to show the
entire contents of the value.

To access Click theConstant Value Options button in theConfigure value area of
a dialog box.

See also "Value Configuration Options Dialog Box" on the next page

User interface elements are described below:

UI
Elements Description

Value The value for the constant.

Regular
expression

Sets the defined value as a regular expression. If you select this option, an arrow is
enabled to the right of theValue text box, enabling you to insert regular expression
characters and to test your regular expression tomake sure that it suits your
needs.

l For general details on regular expressions, see "Regular Expressions
Overview" on page 318.

l For details on defining a regular expression, see "Regular Expression
Characters and UsageOptions" on page 352.

l For details on inserting regular expression characters directly from a list,
see "Smart Regular Expression List" on page 361.

l For details on testing your regular expression, see "Regular Expression User
Interface" on page 352.
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Value Configuration Options Dialog Box
Relevant for: GUI tests and components

This dialog box enables you to define a selected value as a constant or a parameter. In some
situations, you can also define the constant or parameter using a regular expression.

The following examples illustrate the Value Configuration Options dialog box with and without the
Regular expression check box (relevant for tests and scripted components). The parameter
options shown in this dialog box change according to the parameter type selected in theParameter
box.
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The following examples illustrate the Value Configuration Options dialog box (for keyword
components) when eitherConstant or Parameter value type is selected. The options shown in this
dialog box change according to the value type.

To access 1. Ensure that a GUI action or component is in focus in the document pane.

2. In the Keyword View, click the parameterization button for a selected
value.

Important
information

Relevant for keyword components: If at least one input component parameter
is defined in the component, the default input type is Component parameter and
the default input name is the first output parameter displayed in the Parameters
pane of the Business Component Settings dialog box.

User interface elements are described below:

UI Elements Description

Constant A manually defined value that remains unchanged for the duration of the run.

You can edit the value directly in theConstant box. This box offers the same
editing options as theValue cell in which you clicked the parameterization

button to open this dialog box. For details, see "How to Define Values for
Your Step Arguments " on page 928.
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UI Elements Description

Regular
expression
(tests and
scripted
components)

Enables you to specify a constant value using a regular expression.

This option is available only for string value types in some situations, for
example, when parameterizing an object identification property value. This
option is not available for method arguments or for keyword components.

To use a regular expression:Enter a regular expression in theConstant box
and select theRegular expression check box.

For more details, see "Regular Expressions Overview" on page 318, "Smart
Regular Expression List" on page 361, and "Regular Expression Evaluator" on
page 358.

Parameter A value that is defined or generated externally and is retrieved during a run
session. The parameter section displays:

l The current parameter type and details for the value if a value is already
parameterized.

l The default parameter type and details for the value if a value is not yet
parameterized. You can change the default definition by selecting a different
parameter type or modifying the parameter settings for the value. For details,
see:

n For tests and scripted components: "Default Parameter Values" on
page 1554

n For keyword components: "Working with Local and Component
Parameters" on page 1571.

Options for tests and scripted components include:

The options in theParameter section change according to the parameter type
you select and are very similar to the options in the Parameter Options dialog
box. For details, see "Parameter Options Dialog Box" on page 1556

Formore details on using parameters in your tests or scripted component, see
"Parameterizing Object Values" on page 1526.

Parameter
(Cont.)

Options for keyword components include:

l Component parameter. Variable values defined within a component for use
in the same component or later components in a business process test.

l Local parameter. Variable values defined within a component for use
exclusively within the same component.

For details about component parameters and local parameters, see "Working
with Local and Component Parameters" on page 1571, "How to Parameterize
Input Values (Keyword Components)" on page 1573, and "Parameters Tab
(Properties Pane - GUI Testing)" on page 394.
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Using Property Patterns to Identify Objects
If certain object property values in yourWeb site or application are generated dynamically for all
objects of a given type, you can create a property pattern configuration file that instructs UFT to
automatically record the object property string as a regular expression.

Note: The property pattern configuration file applies only to constant identification properties
of type string. It does not convert the expected values of checkpoints (including automatic
checkpoints) to regular expressions.

For example, suppose aWeb site displays a number of thumbnail photographs and clipart images
as the results of a search, with links to page containing a larger version of each image. The name
property for each image is generated dynamically, so the name of the image is different each time
you run your test, but you want to identify the image using the name property. Photograph names
start with pic followed by a generatedmulti-digit code, followed by an underscore and a descriptive
name of the image. Clipart images start with img followed by a similar pattern. For example, on a
given test run, one image namemight be: pic198362839_tree, and another image on the pagemight
be named img2984730_apple.

You can create a property pattern definition for the name property of the Image object, so that the
name property for all images is recorded with a regular expression that learns the property value as
the first three literal characters, followed by any number of digits, and then all remaining literal
characters. After recording, the name property value in the Object Properties dialog is
automatically displayed with the appropriate regular expression:
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Youmust perform the following three steps to use the property pattern option:

l activate the property pattern option in the registry

l create a property pattern configuration file

l select a configuration file

Note: Themodified registry and the property pattern configuration file must be set up on the
computer on which you want to record objects using property patterns. However, once the
test is recorded, you can run the test on any UFT computer.

Activating and Disabling the Property Pattern Option

If you want to use a property pattern configuration file, youmust first activate the
UsePropertyPattern option in the registry. If you no longer want to use the property pattern
configuration file, youmust disable theUsePropertyPattern option.

To activate or disable the UsePropertyPattern option:

1. Select Run from theStartmenu. The Run dialog box opens.

2. Type regedit and click OK. The Registry Editor opens.

3. Double-click theUsePropertyPattern option from: HKEY_CURRENT_
USER\Software\Mercury Interactive\QuickTest QuickTest
Professional\MicTest\AdditionalObjects\PropertyPatternObj\Settings. The Edit DWORD
Value dialog box opens.

4. To activate the Property Pattern option, enter 1 in theValue Data box.

To disable the property pattern option, enter 0 in theValue Data box.

Creating the Property Pattern Configuration File

The property pattern configuration file is an XML file. The file must be saved with an *.xml
extension. You can save the file in any folder.

The format of the Property Pattern configuration file is described below. Text in bold should be
typed literally. Text in italics should be replaced with the appropriate information as described in the
table below the format description.

You can create your property pattern configuration file in any text editor, but you should open the file
in an application with an XML parser (such as Microsoft Internet Explorer) to confirm that the syntax
is correct.

<XML>

<Object Name="ObjectClass">

<Property Name="PropertyName">
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<Pattern ToFind="SearchExpression"

ToReplace="ReplaceExpression">

</Pattern>

...

</Object>

...

</XML>

Element Description

<XML>..</XML> The XML element begins and ends the XML file.

<Object>..</Object> The Object element defines the UFT test object class for which
you want to define a pattern. Each element defines one object.
You can create as many <Object>..</Object> elements as
necessary.

Name The Name attribute specifies the name of the test object class.

ObjectClass The name of the UFT test object class for which you want to
define a pattern, or "Any Object".

Entering "Any Object" as the object class enables you to
define patterns that UFT applies to any object you record with
a property value matching the defined pattern if, and only if,
no other object-specific pattern in the configuration file
applies. In other words, a pattern defined for a specific object
class overrides the definitions in the "Any Object" section of
the file.

<Property>..</Property> The Property element defines the UFT identification property
for which you want to define a pattern. Each Property element
defines one object property. You can create as many
<Property>..</Property>

elements as necessary for each object.

Name The Name attribute specifies the name of the identification
property.

PropertyName The name of the UFT identification property for which you
want to define a pattern.
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Element Description

<Pattern>..</Pattern> The Pattern element defines the property pattern to find, and
the regular expression with which it is replaced. Each element
defines one pattern to find and replace. You can create as
many <Pattern>..</Pattern>

elements as necessary for each object property.

ToFind The ToFind attribute specifies the expression to find.

SearchExpression The expression to find. Use parentheses to divide the
expression into parts.

For example, if you want to find values containing 3
characters followed by several digits, followed by an
underscore and several characters, enter: (\w{3})(\d*)(_\w*).

Use standard regular expression syntax to define your search
expression.

ToReplace The ToReplace attribute defines the regular expression that
replaces all occurrences of the pattern specified in the ToFind
attribute.

ReplaceExpression The expression that replaces the text of the specified pattern.
If you want to retain a part of the text that was found, specify
the part using $#, where # is the number of the part.

For example, "$1.*" means—replace the text found with the
contents found for the first part of the SearchExpression
followed by ".*".

So, if the text pic12345_animal was found using the
SearchExpression—(\w{3})(\d*)(_\w*), then the
ReplaceExpression—"$1\d*$3" would replace the text with the
regular expression—pic\d*_animal.

Sample Property Pattern Configuration File

The following configuration file defines property patterns for Image objects as well as for "Any
Object".

<XML>

<Object Name="Any Object">

<Property Name="Name">

<Pattern ToFind="(\w{5}-\w{2})(-\w{6}-)(\d*)"

ToReplace=".*$3"></Pattern>

<Pattern ToFind="(\w{5}-)(\d*)"
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ToReplace=".*$2">

</Pattern>

</Property>

</Object>

<Object Name="Image">

<Property Name="Alt">

<Pattern ToFind="(\w{5}\.)(\w{4})(\d*)"

ToReplace=".*$3"></Pattern>

<Pattern ToFind="(\w{5}-)(\d*)"

ToReplace=".*$2">

</Pattern>

</Property>

</Object>

</XML>

Assume the image below was part of yourWeb site:

<IMG html id = 1 alt=Jenny.Foxx567 name=jfoxx height=29 src2.gif" width=65>

The property pattern configuration file above replaces the Alt property of the image to the following
regular expression:

Jenny\..*567

Selecting the Property Pattern Configuration File

After you have created a property pattern configuration file, youmust select the file in the
PropertyPatternsFile option in the registry.

To select the Property Pattern file:

1. Select Run from theStartmenu. The Run dialog box opens.

2. Type regedit and click OK. The Registry Editor opens.

3. Double-click theUsePropertyPattern option from: HKEY_CURRENT_
USER\Software\Mercury Interactive\QuickTest
QuickTest Professional\MicTest\AdditionalObjects\PropertyPatternObj\Settings. The Edit
DWORD Value dialog box opens.

4. Enter 1 and click OK.
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5. Double-click thePropertyPatternFile option from: HKEY_CURRENT_
USER\Software\Mercury Interactive\QuickTest
QuickTestProfessional\MicTest\AdditionalObjects\PropertyPatternObj\Settings. The Edit
String dialog box opens.

6. Enter the full path for your property pattern configuration file and click OK.

Normalizing Property Values Before Applying Property Patterns

If the object property value to which you need to apply a property patternmay contain a special
character, and you want those characters to be treated literally, you can use theNormalizeValue
attribute of the optional Settings element in your property pattern .xml file to instruct UFT to insert
a backslash before all special characters in the property value before applying the property pattern.

For example, if an image source file might be named: pic$198362839_tree$.gif, and you want to
replace this value with pic\$\d*_tree\$\.gif, you can can set theNormalizeValue attribute to "1".
This way, the dollar signs and dot (.) before the extension are automatically prefixed with
backslashes before the rest of the property pattern file converts the digits in the filenamewith the
\d*.

To add theNormalizeValue attribute to your property pattern file, add the Settings element to the
top of your .xml file:

<XML>

<Settings NormalizeValue= "1"/>

<Object Name=.....
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Chapter 54: API Test Creation Overview
Relevant for: API testing only

This chapter includes:
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UFT API Testing Overview 1590
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Automated Testing Tool Integration 1596

Tasks 1598
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Concepts

UFT API Testing Overview
Relevant for: API testing only

API Testing is how UFT enables you to test your non-GUI applications to see how your
application's API processes performs. Using UFT API testing, you create a test that represents the
activities that your application performs (even using actual and output data from your application),
and use checkpoints to assess the success or failure of the test.

You design an API test by dragging activities from the Toolbox pane onto the canvas. The Toolbox
pane includes a collection of standard activities and technology-specific activities such as HTTP,
Java, JMS, IBM WebSphereMQ, and SAP. You can add additional activities to the Toolbox pane
by importingWSDLs andWADLs, creating REST Services, or using services from the file system
or ALM. You can also create new custom activities using the built-in Activity Wizard as described in
"API Testing Extensibility" on page 2022.

This section includes:

Testing Application Processes with API Testing 1590

Extensibility in API Testing - Overview 1592

Testing Application Processes with API Testing

Relevant for: API testing only

To test your application's processes and services, you create test steps modeled on API activities
and check the results to determine whether your application is performing as expected..

For example, if yourWeb-based application requires you to log in to the application, you can create
test steps to check that the application responds correctly to a HTTP Request, that the application
connects to the database containing user data, and so on. You can test these processes by using
the activities provided with UFT, or you can import Web Services and REST Services to create
activities that represent your application’s services

You create a basic test by dragging an activity from the Toolbox pane to the canvas, assigning the
activity input and output data or parameters, and then setting checkpoints to verify the response.

For more details, see "How to Create an API Test" on page 1598.

UFT provides a number of standard activities that test common application processes, including:

l Flow Control activities, such asWait, Break, andConditional steps. These activities enable
you to customize your test to match any special application workflows.

l String Manipulation activities, such as Concatenate Strings andReplace String.
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l File system activities, which enable you to test your application's interaction with the file
system.

l Database activities, which enable you to test your application's ability to connect and
communicate with a database.

l FTP activities, which enable you to test your application's ability to perform FTP-related
procedures.

l Network activities, such as HTTP Request andSOAP Request, which enable you to test your
application's connection with a network or web-based server.

l JSON andXML activities, which enable you to test your application's ability to convert XML and
JSON data to text and vice versa.

l Math andDate/Time activities, which enable you to perform math operations or perform tasks
using the system date and time.

l OtherMiscellaneous activities, includingCustom Code activities, Run andEnd program
activities, and aReport activity.

In addition, there are various activities directed at testing application processes using specific
technologies, including:

l A Call Java Class activity, which enables you to test Java-based processes that run in your
application

l JMS (JavaMessage Service) activities, which enable you to test your application's ability to
communicate, publish, browse, receive, and check messages from a JMS queue.

l IBM WebSphere MQ activities, which enable you to test your application's ability to
communicate with, publish, browse, receive, and check messages from the IBM WebSphere
MQ queue or topic.

l SAP activities, which enable you to test your application's ability to communicate with an
SAP server using IDOCS and RFCs.

l Load Testing activities, which enable you to add steps for your test to be run as a load test in
HP LoadRunner.

l HP Automated Testing Tools activities, which enable you to call a GUI test or action, API test
or action, or Virtual User Generator script from UFT, QuickTest Professional, Service Test, or
LoadRunner to use as part of your test.

For details on these activities, see "Standard Activities" on page 1611.

User Guide
Chapter 54: API Test Creation Overview

HP Unified Functional Testing (12.00) Page 1591 of 2274



If you need additional functionality beyond the standard activities, you can import or create custom
activities, including:

l Web Service activities imported from aWSDL file. For details, see "How to Import aWSDL-
BasedWeb Service" on page 1744.

l Web Application activities imported from aWADL file. For details, see "How to Import aWeb
Application Service" on page 1754,

l REST Service activities created in UFT using the Add REST Service dialog box. For details,
see "How to a Create a REST Service" on page 1746.

Any of these activities can be dragged to the canvas and used in a test flow.

Extensibility in API Testing - Overview

Relevant for: API testing only

For greater control over test steps, you can use custom code activities that seamlessly integrate
with UFT. Using customized code, you can also customize the behavior of existing activities using
event handlers. For details on creating and using custom code with your test, see "Writing Event
Handlers for API Test Steps" on page 1935.

If the existing test activities are not suitable to test your application, you can also create custom
test activities with the UFT Activity Wizard (Start > All Programs > HP Software > HP Unified
Functional Testing > Tools > Activity Wizard). The Activity Wizard enables you to specify the
activity type and properties. It then exports the activity to the Toolbox pane for use in future testing
sessions.

For details on adding new activities and custom code, see "API Testing Extensibility" on page
2022.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 75.

API Test Creation Methodology
Relevant for: API testing only

Using the UFT's test creationmethodology, you can create tests for your applications earlier in the
application development process. This test designmethodology separates the test step design
from the test step infrastructure design. As a result, you can develop test steps earlier andmaintain
these steps with only minor updates, even when the application or testing needs change
significantly.This process is also especially useful because it offers a clear division of test design
tasks. A few peoplemaintain the resource framework while other users design andmaintain test
steps. Additionally, after the basic infrastructure is in place, both types of users can do their jobs
simultaneously.

The information in the sections listed below provides an overview of themain steps involved in
creating an API test. For a task description of this process, see "How to Create an API Test" on
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page 1598. For a use-case scenario description of this process, see "How to Create an API Test -
Use-Case Scenario" on page 1603.

Analyzing Your Application 1593

Configuring UFT According to Your Testing Needs 1594

Building and Enhancing Your API Tests 1595

Running and Troubleshooting Your API Tests 1596

Analyzing Your Application

Relevant for: API testing only

The first step in creating a test is to analyze your application to determine your testing needs.

What technologies do you want to test?
From the perspective of UFT, your application consists of numerous business processes that run
functions created to perform certain tasks. UFT provides support for these business processes
using standard activities. Furthermore, UFT enables you to import Web Services activities, WADL
activities, and user-created activities as well as create your REST Services activities.

Inside UFT, you can use the standard activities or import your own custom activities by importing
yourWSDL orWADL files or creating your REST servicemethods using the REST Service
designer. These activities are displayed in the Toolbox pane, enabling you to select from awide
range of potential activities to use in your test. If you need to create additional activities, you can
use the Activity Wizard to represent your application's activities and then import them into UFT.

What information do you need to know to test the business processes in
your application?
For each of your application processes, you will need to know the properties of these processes,
including the input and output properties passed from the application, any input or output
parameters, and server information (forWeb-based steps). If you are working with network-based
orWeb-based activities, (such as WSDL, REST, andWADL), you need to know the
URL properties for your application, as well as additional information such as proxies and security
certificates required

These properties are entered into the Properties pane for each test step, enabling UFT to effectively
test the functionality of the application using the application's actual properties and parameters.

For details on the Properties pane and the various tabs used for test activities, see "Properties
Pane User Interface (API Testing) " on page 402.
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What actions do you need to create?
If you find that the application processes are consistently using a series of repeated activities, you
can create test actions that contain the repeated steps. After you create the action, instead of
entering the repeated steps and entering their properties multiple times when creating your test, the
test can call the action and run the test steps contained in the action.

Example

Your application that enables customers to book a flight online contains various business
processes, including logging on to the application, selecting a flight, and creating a customer
order. As part of these processes, your application has to check the application database for
the information and return this data to the application's user interface. For each of the
application processes, you could create an action that contains a database connection step, a
step to retrieve the necessary data, and a step to return the data to the application. Each time
you test a different application process, you can call this action as a precursor to the other test
steps.

By creating actions for repeated test steps, you alsomake your test designmore efficient.

You can also call an action from an external test, thereby making these test steps reusable across
multiple tests.

Tip: As you plan your tests and actions, keep inmind that short tests and actions that check
specific application processes are often better than long tests that perform several tasks, as
they are easier to reuse andmaintain over time.

Configuring UFT According to Your Testing Needs

Relevant for: API testing only

Before creating your tests, you need to configure UFT to suit your needs. This involves one or more
of the following:

Defining your global testing preferences
You need to specify configuration settings that affect how you create and run tests in general --
these settings are not test-specific.

Global testing preferences in the Options dialog box (Tools > Options). For details, see "UFT
Global Options" on page 522.

Configuring test-specific preferences and properties
You can also set a number of test-specific properties:

l General test properties: Using the General tab of the Properties pane, you set the global
general test properties. For details, see "General Tab (Properties Pane - API Testing)" on page
413.
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l User profiles: You can create user profiles for each test to enablemultiple users to define
different variable values for the same test. For details see, "How to Define API Test Properties
or User/System Variables" on page 141.

l Test specific properties/parameters:You can set custom input and output property
parameters that can be used by any test step by selecting theStart orEnd of the test.

Configuring the UFT IDE to suit your testing preferences
You can open, close, andmove any of the UFT panes to suit your needs when creating tests. This
enables you to easily access any needed panes, such as the canvas, the Solution Explorer pane,
the Toolbox, Properties pane, or the Data pane easily. For details, see "UFTWindow Layout" on
page 182.

Building and Enhancing Your API Tests

Relevant for: API testing only

Before creating your test steps, youmay need to import yourWeb Service (WSDL) andWeb
Applicationmethods or create your REST Servicemethods. For details, see "Local Activities" on
page 1733.

After creating a test, youmodify it by dragging activities from the Toolbox pane to the canvas and
modifying the step properties in the Properties pane. You can also use a variety of options to further
enhance your tests:

Checkpoints
Formany test activities, you can define checkpoints. In an API test, a checkpoint is set as a
property of a test step. Using checkpoint properties enables you to determine whether or not your
application is functioning correctly.

For details on the different checkpoints properties available for test activities, see "Standard
Activities" on page 1611.

Parameterization
When you test your application, youmay want to check how it performs the same processes with
different data. You can do this by replacing fixed values from an external data source during your
run session. This is called parameterizing your test. You can supply data from an Excel data table,
a local data table, a database, or an XML file. For more details, see "Data Usage in API Tests" on
page 1800. In addition, you can data drive all the steps in your test, using Excel or XML data
sources.

Linking Steps
You can retrieve values from your test steps and use them as input or output properties/parameters
for other test steps. This enables you to use data or values retrieved from application processes (in
much the samemanner your application does) in other parts of your test. You can also create
custom link expressions combining values from a data source, other test steps, or test variables.
For details, see "Linking Property Values to a Data Source" on page 1803.
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Actions
You can add actions to your test to combine steps that are runmultiple times in the course of a test.
By combining these repeated steps in a single action and calling the action later in a test, youmake
test creationmore efficient.

Custom Code
You can add custom code activities using C# code to be run as a test step. You can also add event
handlers to any of your test steps, enabling you to customize the behavior of the test step before,
during, and after running the step, as well as coding special checkpoint events for each test step.
Each event handler or custom code has autocomplete options available to help you write your code.

When creating custom code, youmay do the following:

l Determine whether you need to create additional event handlers for a particular test step or
create a new user-defined code document

l Determine what functions are needed

l Add custom code documents to your test. For details, see the "Add Reference Dialog Box" on
page 485.

l Debug your custom code. For details, see "How to Debug Your Test, Component, Function
Library, or User Code File" on page 683.

For details on using custom code, see "Writing Event Handlers for API Test Steps" on page 1935.

Running and Troubleshooting Your API Tests

Relevant for: API testing only

When your tests are complete and ready to run, you run them, view the run results, and
troubleshoot your tests, as needed.

After your test, view the run results. Expand the nodes in the Run Results Viewer to see where
steps succeeded and failed and to try to understand why. For details, see theHP RunResults
Viewer User Guide.

For details on running your tests, see "Running Tests and Components" on page 634

For details on debugging your tests, see "Debugging Tests and Components" on page 674.

Automated Testing Tool Integration
Relevant for: API testing only

UFT API testing integrates with the following other HP products:

l HP Application Lifecycle Management (ALM). You can save tests, business component,
and test resources on ALM, enablingmultiple users to store and access a shared repository of
tests and test resources. You can also use ALM's defect tracking abilities to record andmanage
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application defects when running your tests. For details on UFT-API testing integration with
ALM, see "ALM Integration" on page 707. For details about ALM, see theHP Application
Lifecycle Management User Guide.

l HP Service Test Management. Service Test Management integrates with ALM and UFT API
Testing to enable you to better use and organize yourWeb services. For more details, see the
Service Test Management User Guide.

l HP Service Virtualization. In order to mimic services that your applicationmay use, UFT
integrates with HP Service Virtualization. After creating your servicemodels in Service
Virtualization, you then run them in tandem with a UFT API test. For more details on using
Service Virtualization in UFT, see "Running Tests with Virtualized Services - Overview" on page
665. For more details on HP Service Virtualization, see theService Virtualization User Guide.

l In addition, by usingHP Automated Testing Tools activities you can integrate with additional
HP functional testing products by creating test steps that call a UFT GUI test or action, UFT
API test or action, or a LoadRunner script. These tests or scripts are created in the original
application and call from within your UFT API test flow.

For task details, see "How to Call External Tests or Actions" on page 1639.
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Tasks

How to Create an API Test
Relevant for: API testing only

This task describes the workflow andmethodology to follow when you create and build a test.

This task includes the following steps:

l "Prerequisite - Analyze your application" below

l "Prerequisite - Configure UFT according to your testing needs" below

l "Prerequisite - Prepare the service references (optional)" on the next page

l "Build your test structure" on the next page

l "Enhance your test steps" on page 1600

l "Results" on page 1602

Prerequisite - Analyze your application
Before creating a test, you need to analyze your application and determine your testing needs. You
need to:

l Determine the functionality you want to test. To do this, you consider the various activities
that the application performs. What business processes run?What activities aremost relevant
for the business processes that you want to test?

l Identify any processes that run repeatedly. Plan to create actions in your test for such
processes.

As you plan, try to keep the number of steps that you plan to include in each action to a
minimum. Creating small, modular actions helps make your tests easier to read, follow, and
maintain.

Prerequisite - Configure UFT according to your testing needs
This can include:

l Setting up your global testing preferences.

For details, see "UFT Global Options" on page 522.

l Setting up test-specific preferences, including global properties, test input and output
properties and parameters, or user profiles and variables.

For details, see "How to Define API Test Properties or User/System Variables" on page 141.
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l Configuring your run session preferences. For details, see "Run Sessions Pane (Options
Dialog Box > General Tab)" on page 526.

Prerequisite - Prepare the service references (optional)

l Import or build the set of resources to be used by your tests, including:

n Importing WSDL or WADL files, which define themethods used for aWeb service orWeb
application.

For details, see "How to Import aWSDL-BasedWeb Service" on page 1744 or "How to
Import aWeb Application Service" on page 1754.

n Creating REST service resources and methods if your application is based upon REST
services.

For details, see "How to a Create a REST Service" on page 1746.

n Importing .NET assemblies referenced by your test.

For details, see "How to Import and Create a .NET Assembly API Test Step" on page 1760.

n Adding any additional reference files that will be referenced by your test.

For details, see "Add Reference Dialog Box" on page 485.

Note: Skip this step when you will be using only the built-in operations. These activities are
available in the Toolbox pane under the Standard Activities section.

Build your test structure
To build your basic test structure, do the following:

1. Create additional test flow steps- optional

Expand the Toolbox pane nodes and drag Flow Control activities onto the canvas:

n Loop. Enables you to add another loop (the Test Flow loop is always part of a test, and
cannot be removed). You specify the loop behavior in the loop's input properties.

n Condition. Enables you to define conditional branches.

n Sleep. Indicates a time delay in milliseconds.

2. Add activities to the test to create test steps

Expand the nodes of the Toolbox pane and drag activities into the Text Flow or a Loop box
within the canvas to create test steps. If you added aCondition step, drag activities into the
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condition branches. For a list of the available activities, see the "Standard Activity Types" on
page 1650.

3. Provide the step properties

Enter the input, output, and checkpoint properties (as needed) for each activity. For details on
the input, output, and checkpoint properties available for each activity, see "Standard
Activities" on page 1611.

Note: If you have a number of activities/steps that are repeated often in your test,
consider creating an action and adding the steps to this action. After creating the action,
you can call the action each time you need to repeat these steps in your test instead of
adding the activities and setting the activity's properties repeatedly.

Enhance your test steps
To enhance your test steps, do any of the following:

l Define data sources for the test

For details, see "How to Assign Data to API Test/Component Steps" on page 1819 or "How to
Data Drive an API Test Step" on page 1827.

l Create a Custom Code activity

a. Select theCustom Code activity from theMiscellaneous category and drag it into a loop.

b. Click the Input/Checkpoints tab in the Properties pane.

c. Click Add Properties and create the required input and output properties.

d. Open theEvents tab in the Properties pane.

e. Double-click theHandler column of theExecuteEvent row. UFT opens a new tab
TestUserCode.cs.

f. Locate the Todo section and enter your custom code. Follow the sample code in the
comments and use autocompletion to write your code.

g. Click File > Save All to save the custom code and the test.

For details and examples, see "Writing Event Handlers for API Test Steps" on page 1935.

l Add input attachments to the test - optional

ForWeb Service activities that support input attachments, add an input attachment.
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a. Select theWeb Service call step in the canvas and open theAttachments  tab in the
Properties pane.

b. In the upper pane, select an attachment Type: DIME orMIME.

c. Click in theAttachments row and click theAdd button to add an array element.

d. Select a file as theOrigin of the attachment using theBrowse button .

e. Select aContent Type. Specify aContent ID or keep the default value, Auto.

l Add/validate an output attachment- optional

a. Select theWeb Service call step in the canvas and open theAttachments view in the
Properties pane.

b. Click in theAttachments row in the Checkpoints pane, and click Add to add an array
element (it may be necessary to expand the column).

c. Select the check box adjacent to each item that you want to validate. Specify values for the
elements being validated: Content Type and/orContent ID.

d. To validate content, click theCalculate the file checksum button icon in theContent
row. UFT calculates the specified file's checksum using theMD5Hash function.

For user interface details, see "Attachments Tab (Properties Pane - API Testing)" on page
403. You can also check for received attachments in the test's folder, stored as files with a
.bin extension.

l Add an event handler - optional

For any activities, you can define default event handlers for checkpoints, and before and after
step executions.

To add an event handler for a step:

a. Select a step in the canvas and open the Events tab in the Properties pane.

b. In the row containing the event execution point you want (before, after,etc.), select Create a
default handler.

c. Edit the code in the TestUserCode.cs tab. Locate the Todo section and add your custom
code. Follow the sample code in the comments and use statement completion to create an
expression.
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d. To access the properties of an activity, cast it before the activity name. For example:

ConcatenateStringsActivity cat = args.Activity as ConcatenateStringsActivity;
args.Checkpoint.Assert.Equals(cat.Prefix+cat.Suffix, cat.Result);

e. Click File > Save All to save the TestUserCode.cs file and the test.

For details and examples, see "Writing Event Handlers for API Test Steps" on page 1935.

Tip: To ignore an event handler for a step, select a handler and press DELETE to clear
the field in the Events tab. To completely remove the event handler, youmust also
delete the codemanually in the TestUserCode.cs tab.

Results
After you create your test, you can perform different types of runs to achieve different goals. You
can:

l Run your test to check your application.

The test starts running from the Start step in the canvas and stops at the end of the test. While
running, UFT performs each step in your test, including any checkpoints.

If you parameterized the test using data from a data source stored in the Data pane, UFT
repeats the test (or test flow loop, if needed) using the data as defined in the Input tab for the
Test Flow or test flow steps.

l Run your test to debug it.

Note: Before running a debugging session, make sure to enable debugging capabilities by
selecting theRun test in debugging mode option in the "General Pane (Options Dialog
Box > API Testing Tab)" (described on page 565).

For general details on debugging, see "Debugging Tests and Components" on page 674. For
details on the available debugging panes, see "Debug Panes" on page 271.

l Run an individual step.

Select the step in the canvas and chooseRun Step from the context menu to run the step with
its property values. Note the results in theRun Step Results pane, in the lower section of the
main window. If something needs to bemodified, do so at this point. For details, see "Run Step
Results Pane" on page 454.

Note: The Run Step command, for steps whose properties are assigned an XML data
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source, does not retrieve the latest data shown in the user interface.

Workaround: Save the test before activating the Run Step command.

How to Create an API Test - Use-Case Scenario
Relevant for: API testing only

Creating a test is comprised of several stages. This section walks you through the stages you
might perform when preparing a test for the Flight API application.

This scenario consists of the following steps:

l "Analyze the Flight API application" below

l "Create or import your test resources" on page 1605

l "Create your test steps" on page 1606

l "Enhance your test steps" on page 1609

l "Run the test" on page 1610

1. Analyze the Flight API application
When analyzing the application to determine what application processes youmay want to test,
you can consider the existing business processes that run in the application.

The business processes that should be tested for the Flight API application include:

n Connecting to the user database and confirming login information

n Retrieving the list of flights

n Retrieving a flight order based on user input

n Creating a flight order

n Updating a flight order

n Deleting a flight order

n Deleting all flight orders

n Logging a user out of the application

Although the first and last items above have not yet been implemented in the Flight API
application that you want to test, it is important to take them into account in the planning stage.
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Now that you have determined the primary application processes, you should analyze each
one to determine the breakdown of these application processes into smaller, testable parts.

A logical breakdown of the above business processes could be:

n Connecting to the user database and confirming login information

o Sending a request to connect to the database

o Receiving confirmation or failure of database connection

o Checking the customer login details database based on user input

o Returning authentication results (permission or rejection) for user input

o Return results to application user interface

n Retrieving a list of flights

o Connecting to the flight information database

o Receiving confirmation or failure of database connection

o Searching the flight information database for all available flights

o Returning the search results

n Retrieving a flight order based on user input

o Connecting to the flight information database

o Receiving confirmation or failure of the database connection

o Searching the flight information database using the user-specified criteria

o Returning the search results

n Creating a flight order

o Connecting to the flight database for the specific flight based on user input

o Receiving confirmation or failure of the database connection

o Reserving a place on the selected flight in the database

o Returning the order confirmation

n Updating a flight order
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o Connecting to the flight database and finding the selected flight based on user input

o Receiving confirmation or failure of the database connection

o Retrieving the flight order details

o Updating the flight information in the database based on user input

o Returning the flight order update confirmation

n Deleting a flight order

o Connecting to the flight database and finding the selected flight based on user input

o Receiving confirmation or failure of the database connection

o Retrieving the flight order details

o Deleting the flight order from the database

o Returning confirmation of the flight order deletion

By comparing the sub-steps in each of the business processes, you can see what specific
steps you need to design in your test. In addition, you can also see the steps that are repeated
and can be combined in a reusable action that can be called in different parts of your test.

2. Create or import your test resources
Some of your application processes for the Flight API application require custom activities not
included in the standard collection of API activities provided in the Toolbox pane. For these
activities, youmust import or create the activities into your tests.

At this stage we can import the followingWeb services methods:

n CreateFlightOrder

n GetFlights

n GetFlightOrders

n UpdateFlightOrder

n DeleteFlightOrder

n DeleteAllFlightOrders

For details on how to import Web Servicemethods, see "How to Import aWSDL-BasedWeb
Service" on page 1744.
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You can also create the following REST Service resources andmethods:

n Flights Get

n Flight Get

n FlightOrders Get

n FlightOrders ReserveOrder

n FlightOrder Get

n FlightOrder Update

n FlightOrder Delete

n FlightOrder DeleteAll

For details on how to create REST Servicemethods, see "How to a Create a REST Service"
on page 1746.

3. Create your test steps
Now that you have planned and prepared all of the required resources for your test, you are
ready to create test steps that represent the steps a real application would perform on the Flight
API application.
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The activities that are available for your test steps are stored in the Toolbox pane. This
includes custommethods that were imported or created for your test:
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To create test steps, you select activities from the Toolbox pane and either drag them to the
canvas or double-click them to add them to the canvas:
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You then set input, output, or checkpoint property values for the activities to mimic your
application:

If you have steps that appearedmultiple times, you can create an action which combines the
repeated steps and call this action instead of the repeated steps.

For task details on creating test steps, see "How to Create an API Test" on page 1598.

4. Enhance your test steps
Once you have put the appropriate steps for the Flight API application in the canvas, you can
add additional enhancements for these test steps:

n You can set checkpoint properties for a test step, providing the expected output values for
each of themethods.

n You can link the test steps to a data source, such as an Excel file containing different values
for the step input properties. This enables you see how the test steps run with different input
values.

n You can link one step to another. For example, you can link the GetFlights Web Service
method to the CreateFlightOrder method to pass the flight information between the two
methods.
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n You can add additional event handlers to enhance the step function before the test step
runs, during the running of the test step, and after the step's execution.

5. Run the test
After you add your test steps, and provide the input, output, or checkpoint property values, you
run your test and observe the results. Expand the Run Results tree and observe the results and
response for each of the test steps.

If you want to test each individual step after entering its properties, you can right-click the step
name in the canvas and select Run Step. UFT runs only that step and displays the step results
in the Run Step Results pane.
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Concepts

Activity Overview
Relevant for: API testing only

You create a test by double-clicking or dragging activities from the Toolbox pane into a canvas. The
Toolbox pane provides a collection of built-in standard activities for functional testing in areas such
as file and stringmanipulation, andmessaging through HTTP, FTP, and JMS.

The activities are divided into several categories:

l Standard Activities. This category includes the built-in activities, such as String
Manipulation, Database, Network, File System. For a complete list of the standard activities,
see "Standard Activity Types" on page 1650.

l Local Activities. This category includes the activities that are stored as part of the test or
business component. These can be imported services such as Web or REST service
operations, and .NET assemblies. For details, see "Local Activities" on page 1733.

l File System Activities. This category includes activities that reside in the file system on either
local or network drives. These are Local activities that youmoved into the file system repository
that can be shared between tests.

l ALM Activities. This category includes the activities that reside in the ALM repository. These
are Local activities that youmoved into the ALM repository that can be shared between tests.
This category only appears when a connection to an ALM server is open.

You can also create new custom activities, using the extensibility API provided with the product.
These will be stored under the Standard Activities. For details, see "API Testing Extensibility" on
page 2022.

For general information about the API interface and creating tests, see "API Test Creation
Overview" on page 1589.

Checkpoint Validation for Test Steps
Relevant for: API testing only

In functional testing, it is necessary to check the results of test steps to confirm that the activity
performed its expected functionality. The response can contain several properties, each containing
several data items. TheCheckpoints section is a central point for defining the expected values of
the properties.
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Before replaying a test, you set the expected output property values. You can enter the values
manually, link them to a data source, or load values that were captured during a prior replay. This is
useful when you havemany argument values—instead of manually entering values, you
automatically load them.

To include a checkpoint in the test, you select its check box. If you loaded replay values, you can
select only those properties that you loaded.

ForWSDL-basedWeb Services and SOAP Requests, UFT includes two built-in checkpoints for
the purpose of validation. One checkpoint validates the XML structure and the other checks its
compliance withWS-I.

Additional checkpoint settings let you trim the string, ignore case inconsistencies, and indicate
whether to stop on failed checkpoints.

For details, see the "Parameters/Checkpoints Tab (Properties Pane - API Testing)" on page 417.

After the test run, the Run Results Viewer displays the checkpoint status in its own sub-node. For
details, see theHP RunResults Viewer User Guide.

This section also includes

XPath Checkpoints 1613

XPath Checkpoints

Relevant for: API testing only

For steps with XML output properties, such asWeb Service andSOAP Request, String to XML,
and so forth, you can validate the test results against XPath expressions.

You can specify a fully qualified XPath expression, or you can instruct UFT to ignore the
namespaces and prefixes during the test run. By ignoring the namespaces, you can use a simpler
expression.

User Guide
Chapter 55: Standard Activities

HP Unified Functional Testing (12.00) Page 1613 of 2274



In the following example, to retrieve the contents of the second node, B, you would need to write an
expression that also indicates the namespace, such as //*[local-name(.)='Node' and namespace-uri
(.)='ns2'].

<Root>
   <Body>
        <Node xmlns="ns1">A </Node>
        <Node xmlns="ns2">B </Node>
   </Body>
</Root>

Whenworking with simple XPath expressions, you can further simplify the XPath expression by
selecting Ignore namespaces. In the above example, the expression //Node[2] is sufficient to
evaluate the valueB in the second node.

You can type in the XPath expressions manually, or use the shortcut menu to retrieve the simplified
or fully qualified XPath.

UFT also enables you to evaluate XMLwith namespace prefixes. For example, if the XML contains
the prefix definition xmlns:T="ns1", you can specify the prefix in the XPath expression:
//T:NodeName. To evaluate namespace prefixes, disable the Ignore namespaces option.

XPath checkpoints can only be used when the XPath query returns a scalar value—not XML.

For task details, see "How to Set XPath Checkpoints for Test Steps" on page 1617.
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Tasks

How to Set Array Checkpoints for Test Steps
Relevant for: API testing only

This task describes how tomanually set checkpoints for elements of an array. For details about
setting regular checkpoints, see "How to Run an API Test" on page 643.

For details about data driving array checkpoints, see "How to Data Drive Array Checkpoints" on
page 1828.

This task includes the following steps:

l "Enable active content on your computer" below

l "Add a step with an array output" below

l "Select an array validationmethod" below

l "Add array elements" on the next page

l "Provide values" on the next page

l "Validate the element count - optional" on the next page

l "Set the number of iterations and run the test" on the next page

l "Open the Checkpoint report" on page 1617

1. Enable active content on your computer
The RunResults Viewer shows array checkpoint results in an expandable tree. To enable this
view, modify your browser settings as follows:

a. In Internet Explorer, select Tools > Options.

b. Select theAdvanced tab.

c. Enable the optionAllow active content to run in files on My Computer in theSecurity
section.

d. Click OK and close the browser.

2. Add a step with an array output
Add a test step with output properties in the form of an array.

3. Select an array validation method
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Expand the drop down adjacent to the name of the parent array node. Select one of the
following:

n Fixed. Checks that each of the returned array elements matches its corresponding array
element in theCheckpoints pane. Each array is marked by an index number, as it checks
the arrays by their index.

n All. Checks that all of the returned array elements match the array element in the
Checkpoints pane. In this mode, arrays are not marked by an index number. For example, if
a property in the first array is marked >= 2 and the same property in another array element is
set to <=10, the test run will check that all returned values are between 2 and 10.

n Contains. Checks that at least one of the returned array elements matches the value of the
property in theCheckpoints pane. In this mode, arrays are not marked by an index number.

4. Add array elements
Use the plus button in the row of the parent node to add the desired number of array
elements.

5. Provide values
Select theValidate box for each value that you want to validate and provide values for those
properties.

6. Validate the element count - optional
Click in the parent row of the array and enter a desired count number in theExpected Value
column and the evaluation expression, such as =, >, and so forth. During the test run, the
validation will check the number of returned array elements against this value.

7. Set the number of iterations and run the test
Click in the Test Flow or Loop box and open the Properties pane. Set the test flow properties,
such as the number of iterations or loop type. Click theRun button and provide a results
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location. For details, see "How to Run an API Test" on page 643.

8. Open the Checkpoint report
In the Run Result Viewer, expand the test results tree in the left pane. Select a Checkpoint
node. In theCaptured Data pane, click View Report in the Details column. In the report that
opens, expand the checkpoint node for each of the iterations to view its actual and expected
value.

How to Set XPath Checkpoints for Test Steps
Relevant for: API testing only

This task describes how to validate your test results against XPath expressions. For conceptual
information, see "XPath Checkpoints" on page 1613.

This task includes the following steps:

l "Add a step with XML output" below

l "Set the namespace setting" below

l "Copy the XPath" on the next page

l "Add an XPath checkpoint" on the next page

l "Provide the XPath expression" on the next page

l "Set up the validation" on the next page

l "Run the test" on the next page

1. Add a step with XML output

Add a test step with XML output, such as String to XML. Open the Input/Checkpoints tab
. Paste a source string into theValue column or use the Link to data source button to link to
a value.

2. Set the namespace setting
Click theXPath tab, and indicate whether or not to ignore namespaces. By default, the Ignore
namespaces option is enabled. If you plan to validate against a fully qualified expression, or if
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you need to specify a namespace prefix, disable the option. For details, see "<XPath
checkpoint options>(available for steps with XML output properties)" on page 424.

3. Copy the XPath
Copy an XPath expression to the clipboard. If you intend to enter the XPath expression
manually, skip this step.

n To retrieve a simple XPath, click in theValue column, and select Copy XPath from the
shortcut menu.

n To retrieve a complete qualified XPath, click in theValue column, and select Copy Fully
Qualified XPath from the shortcut menu.

4. Add an XPath checkpoint
Click theXPath tab in the Checkpoints section. Click theAdd button to add a new XPath
checkpoint.

5. Provide the XPath expression
Type or paste the expression into theXPath Checkpoints column. You can also use the Link
to data source button to link to a value.

6. Set up the validation
Select the check box in theValidate column, select a comparison operator, and provide an
expected value.

7. Run the test
Run the test and check the results.

How to Use Flow Control Activities
Relevant for: API testing only

This task describes how to use Flow Control activities in an API test.

This task includes the following steps:
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l "Add a conditional step" below

l "Add a loop" on the next page

l "Add steps to pause and restart the test" on page 1622

l "Add a wait step" on page 1622

Add a conditional step
Conditional steps enable you to specify alternate test paths depending on the outcome of a
previous step. This is the equivalent of an If...Else function in an application's code.

1. In the Toolbox pane, expand the Flow Control activities node and drag aCondition step to
the canvas.

The canvas displays a branched test step, withYes andNo branches, as see in the example
below:

2. Set the trigger for each branch of the step.

You can the trigger for theYes orNo branches in the following ways:

n Specify a condition for the output of a test step.

i. In theCondition tab in the Properties pane, select theUse condition option. The
condition properties are displayed.

ii. In theVariable field, click the Link to data source button .

iii. In the Select Link Source dialog box, link to the output of a previous step. For details on
linking properties to other steps, see "Link your test step to another step" on page
1820.

Note: Youmust link theVariable field to a previous step to set the value tomeet
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to trigger the condition.

iv. Specify the expectedValue and theOperator (equal to, greater than or less than, etc.)
for the step selected in theVariable field.

n Use an event handler.

i. In theCondition tab in the Properties pane, select theUse event option.

ii. In theEvents tab , in theCondition row, click the drop down arrow and select
Create a default handler. The TestUserCode.cs file opens in the document pane.

iii. In the IfElse9_OnCondition section of the TestUserCode.cs file, replace the TODO
section with your event handler.

3. Drag activities to theYes andNo branches of the Condition step to create the steps to run
based on the results of the condition.

Add a loop
Loops enable you to run the steps contained in a the loopmultiple times.

1. In the Toolbox pane, expand the Flow Control activities node and drag a Loop step to the
canvas.

2. In the Input tab of the Properties pane, select the Loop type and define the loop properties.

Select one of the following loop types:

n 'For' Loop

This loop runs the included steps the specified number of times. Set the number of iterations
to run the loop.
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Note: If the number of iterations is defined elsewhere (the result of a previous step or a
data table), link to the property by clicking the Link to data source button in the
Value cell for theNumber of Iterations property.

n 'Do While' Loop

This loop runs indefinitely until a specific condition is met. When the condition is met, the
test advances to the steps following the loop.

You can set the loop run properties in the following ways:

o Specify a condition.

o In theCondition tab in the Properties pane, select theUse condition option.
The condition properties are displayed

o In theVariable field, click the Link to data source button .

o In the Select Link Source dialog box, link to the output of a previous step.

Note: Youmust link theVariable field to a previous step to set the value to
meet to trigger the condition.

o Specify theValue and theOperator (equal to, greater than or less than, etc.) for the
value of the step selected in the Variable field.

o Use an event handler.

o In theCondition tab in the Properties pane, select theUse event option.

o In theEvents tab , in the Condition row, click the drop down arrow and select
Create a default handler. The TestUserCode.cs file opens in the document pane.

o In the Loop_OnCondition section of the TestUserCode.cs file, replace the TODO
section with your event handler.

n 'For Each' Loop

This loop runs one time for each item in a selected collection (usually an array). To link this
loop to a collection from a different step, click the Link to data source button and select
the collection in the Select Link Source dialog box.

3. Drag activities inside the loop.

4. Associate data sources with the loop.
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You can assign a specific data source to use with the current loop. The data from this data
source is then available for all steps included in the loop. For details, see "Add a data source to
the Test Flow or test loop" on page 1826.

Add steps to pause and restart the test
You can add any of the following steps to your test to pause and restart the test:

l Break. This step stops the test. You insert aContinue step to resume the test.

l Continue. This step resumes the test after aBreak step stops it.

l Sleep. This step temporarily pauses the test for a specified number of milliseconds. Enter the
number of milliseconds to wait in the Input/Checkpoints tab for the step.

Add a wait step
Wait steps aremandatory when your application uses an asynchronous service call. After the call
to the service, you insert theWait step. While the test is waiting for the response from the service
call, the test waits the amount of time specified in this step.

1. In the Toolbox pane, expand the Flow Control activities node and drag aWait step to the
canvas.

2. In the Input/Checkpoints tab in the Properties pane, Set the step properties:

n Timeout: the number of milliseconds to pause the test.

n Start timeout from step: the step for which UFT is waiting for a response.

n Action on Timeout: what happens when the end of the timeout is reached and the step's
response is not received.

n Completion events: the events that signify completion of the timeout.

How to Use Date and Time Activities
Relevant for: API testing only

The following describes various tasks that you can perform with the Date/Time activities, such as
incrementing a date or finding a differential.

This task includes:

l "Increment a date and time" on the next page

l "Find the difference between two date/time expressions" on the next page

l "Format a date or time" on page 1624
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Increment a date and time

1. Drag the Increment Date/Time activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Original Date/Time. Click the arrow in theValue column to open the
calendar. Click Today or select another date. You can also link to the output of another step
using the Link to a data source button.

4. To set a time unit such as hour, minute, seconds, or milliseconds, edit the expression in the
Original Date/Time row. For milliseconds, add a colon followed by a three digit millisecond
value, for example, 2011-01-01T01:30:00:040.

5. Set the Input property—Unit. Select a unit by which to increment:Milliseconds, Seconds,
Minutes, Hours, Days,Months, orYears.

6. Set the Input property—Amount. Use the scroller to set the amount of units to increment.

7. Select theResult check box in theCheckpoints pane to verify the response. Use the calendar
to select the expected date. If you need to set an expected value for a time unit, modify the
time units manually.

Find the difference between two date/time expressions

1. Drag theDate/Time Difference activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property— Date/Time A. Click the arrow in theValue column to open the
calendar. Click Today or select another date.

4. To set a time unit such as hour, minute, seconds, or milliseconds, edit the expression in the
Date/Time A row. For milliseconds, add a colon followed by a three digit millisecond value, for
example, 2011-01-01T01:30:00:040.

5. Set the Input property—Date/Time B. Click the arrow in theValue column to open the
calendar. Select a date for the second expression.

To set a time unit such as hour, minute, seconds, or milliseconds, follow the instructions in the
above step.

6. Set the Input property—Unit. Select the unit by which you want to measure the difference:
Milliseconds, Seconds,Minutes, Hours, Days,Months, orYears.

7. To verify the response, select theDifference check box in theCheckpoints pane. Use the
scroller to specify the expected difference.
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Format a date or time

1. Drag the Format Date/Time activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the property Input Date/Time, the term to which you want to apply formatting. Click the
arrow in theValue column to open the calendar. Click the date displayed at the top of the
calendar window to use the current date, or select another date.

4. If you provide a date/time in a string (non-date) format, select a format in the Input Date/Time
Format row. Otherwise, leave this row empty.

5. Set the Format input property. Select a format from the drop down or type in a custom format
for the output expression. If your expression contains milliseconds, use an expression with a
time format and add a colon followed by fff, for example, dd/MM/yyyy hh:mm:ss:fff.

6. Select theResult check box in theCheckpoints pane to verify the response's format. Type
the expected expression. If you need to set an expected value for a time unit, modify the time
units manually.

How to Execute Database Commands or Retrieve Data
Relevant for: API testing only

The following describes how to use database activities. For details about the database activities,
see "Database Activities" on page 1669.

This task includes:

l "Open a connection" below

l "Add a Select Data step" on the next page

l "Add an Execute Command step" on the next page

l "Add database transaction activities" on the next page

l "Add a Close Connection step" on page 1626

Open a connection
This step is mandatory for all of the following steps.

1. Drag theDatabase > Open Connection activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Select the Input property—Connection string.

4. Click theConnection Builder button in the right side of theValue column . The
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Connection Builder dialog box opens. For details, see "Connection Builder Dialog Box" on page
1720.

5. Paste in an existing string into the text area or click the Connection Builder button to open
Microsoft's Data Link Properties dialog box. Provide the required information and click OK. For
details, click the dialog box's Help button.

Note: The database connectionmust be anOLE DB type.

6. If you want to validate the connection, set the checkpoint properties -Results andResults
message.

Add a Select Data step

1. Drag theDatabase > Select Data activity onto the canvas, below anOpen connection step.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Connection. Click the Link to a data source button by the right side
of theValue column . In the Select Link Source dialog box, select an earlierOpen
connection step in the left pane. In the right pane, select the step's result.

4. Set the Input property—Query string. Click theBrowse button in the right side of theValue
column to open theQuery Builder. Paste in a query or use the Query Designer. For details,
see the "Query Builder Dialog Box" on page 1722.

5. Optionally, set the Timeout, themaximum time allowed for the database response. To allow
an unlimited amount of time, enter 0.

Add an Execute Command step

1. Drag theDatabase > Execute Command activity onto the canvas, below theOpen
Connection step.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Connection. Click the Link to a data source button by the right side
of theValue column . In the Select Link Source dialog box, select an earlierOpen
connection step in the left pane. In the right pane, select the step's result.

4. Set the Input property—Command. Click the arrow to open an edit box, Paste in a command
and click OK.

5. Optionally, set the Timeout, themaximum time allowed for the database response.

Add database transaction activities
You can optionally add transaction activities to your test.
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1. Drag theDatabase > Begin Transaction activity to the canvas after anOpen Connection
step and before the steps to be included in the transaction.

2. Drag aDatabase > Commit Transaction activity to the canvas after the database steps that
make up the transaction.

3. Drag aDatabase > Rollback Transaction activity to the canvas after the database steps that
make up the transaction.

Tip: A common use is to insert aCondition step to check a value after the database
commands. Set one branch withCommit Transaction and the other branch toRollback
Transaction. For details, see "Flow Control (API Testing only)" on page 210.

Add a Close Connection step

1. Drag theDatabase > Close Connection activity on to the canvas, after all of the database
steps.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Set the Input property—Connection. Click the Link to a data source button in the right side
of theValue column . In the Select Link Source dialog box, select theAvailable steps
option. In the left pane, select the earlier step, Open Connection, In the right pane, select the
Connection node.

How to Send a Multipart HTTP Request
Relevant for: API testing only

The following describes how to send an HTTP request that uses multiple parts. For details about
the properties, see the "Multipart Tab (Properties Pane - API Testing)" on page 426.

This task includes:

l "Add an HTTP Step" below

l "Set the General properties" below

l "Set the properties for the first part" on the next page

l "Set the properties for the next parts" on the next page

1. Add an HTTP Step
Drag theNetwork > HTTP activity onto the canvas.

2. Set the General properties
Open theGeneral tab
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in the Properties pane. Set the properties as described in the "General Tab (Properties
Pane - API Testing)" on page 413.

3. Set the properties for the first part

Open the Input/Checkpoints tab in the Properties pane. Set the properties for the first part
as described in the "Network Activities" on page 1684.

4. Set the properties for the next parts

a. Open theMultipart tab in the Properties pane.

b. Select theEnable Multipart option.

c. Set themultipart type and global header information.

d. Add elements to theParts array corresponding to the number of parts.

e. Set the properties for the parts as described in the "Multipart Tab (Properties Pane - API
Testing)" on page 426.

f. If you want to validate a response, select the box in theValidate column and provide the
expected values.

How to Create a Call to a Java Class
Relevant for: API testing only

The Call Java Class activity lets you to add Java steps to your test script. This feature enables you
to incorporate existing Java code into your test.

This task describes how to create the Java call and includes the following steps:

l "Set the global Java settings - optional" on the next page

l "Implement the Java interface" on the next page

l "Compile the Java source code" on the next page

l "Package your custom step - optional" on the next page

l "Set up the Java environment - optional" on the next page

l "Add a Call Java Class activity" on page 1629

l "Open the Java Class Setting dialog box" on page 1629

l "Set the Java Call properties" on page 1629

l "Provide Input property values" on page 1629
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1. Set the global Java settings - optional
To set global VM (Virtual Machine) settings, select the Start or End steps in the canvas, and

open the Test Settings view in the Properties pane. For details, see the "Test Settings Tab
(Properties Pane - API Testing)" on page 429.

2. Implement the Java interface
Change to the <installation_folder>\addins\ServiceTest\
JavaCall\Java Interface\src\hp\st\ext\java folder and create an implementation for the java
interface. For an example, see the sample subfolder.

This interface includes the essential information for the Java call, such as input properties,
output properties, and a point of entry. The followingmethods are included:

n getInputProperties. Returns amapping of the input property names and their Java class.

n getOutputProperties. Returns amapping of the output property names and their Java
class.

n Execute. A method that receives themapping of the input property names and their actual
values i.e. their object instance. In this method, you process input properties and delegate
them to your own Java artifacts. Afterward you process the output properties and send their
mappings and their actual values as themethod's output.

3. Compile the Java source code
Compile the java files located in the <installation_folder>\
addins\ServiceTest\JavaCall\Java Interface\src\hp\
st\ext\java folder.

Tip: To determine which JDK to use for, check the version of Java JRE installed with
UFT. Open the <installation_folder>/
jre/bin folder and right-click the java.exe file. Select Properties and open theVersion tab.

4. Package your custom step - optional
Package your java classes into a .jar file. This is optional, since you can also provide a
package root for the class.

5. Set up the Java environment - optional

a. Click in a Start or End step and click the Test Settings  tab in the Properties pane. Set
the Java test settings for the VM and JMS. For details, see the "Test Settings Tab
(Properties Pane - API Testing)" on page 429.

b. Expand the JMS node in the Toolbox pane and drag a JMS activity onto the canvas.

c. Set the step's properties. Click on the step in the canvas, and select the Input/Checkpoints
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tab in the Properties pane. Enter a value for Queue, Subscription, Topic name, and any
other relevant property.

d. For Send activities, specify amessage.

e. For Receive activities, select the output properties you want to validate in the
Checkpoints pane and specify their values.

For more details, see "JMS Activities" on page 1691.

6. Add a Call Java Class activity
Expand the Java node in the Toolbox pane, and drag theCall Java Class activity onto the
canvas.

7. Open the Java Class Setting dialog box

Select the Java step in the canvas, and click the Input/Checkpoints tab in the Properties
pane. Click the Java Class button to open the "Java Class Dialog Box" (described on page
1727.

If you need to embed the jar in the script, youmust select the check box before browsing for
and selecting the class file.

8. Set the Java Call properties
In the Java Class dialog box:

a. Provide a classpath. If you packaged your Java step, click theBrowse button adjacent to
the Jar field and point to a .jar file. Alternatively, click theBrowse button adjacent to the
Package root field and point to a package root folder. To embed the jar and save it with the
test, select Embed Jar in Test. Due to a technological limitation, if you intend to specify a
class file, youmust select theEmbed Jar in Test option before you browse for the class
file.

b. Click theBrowse button adjacent to theClass file field to locate the class within the .jar
file or the folder. Make sure it is a class that implements theServiceTestCall interface.

c. To provide additional classpaths, click the Jar or Folder buttons in theAdditional
Classpaths section and browse to a .jar file or classpath folder. Click Add to move the
contents into the list.

d. Click OK to save the Java Call settings.

For user interface details, see the "Java Class Dialog Box" on page 1727.

9. Provide Input property values

In the Properties pane's Input/Checkpoints tab , provide values for the step's input
properties.
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How to Retrieve Messages from a JMS Queue
Relevant for: API testing only

This task describes how to send, receive and browse JMS messages on a JMS queue.

This task includes the following steps:

l "Define the global JMS settings" below

l "Prepare amessage to send to the queue" below

l "Add a SendMessage step to your test" below

l "Add a SendMessage with security and attachments - optional" on the next page

l "Add a ReceiveMessage step to your test - optional" on the next page

l "Browse themessage queue - optional" on the next page

l "Set checkpoints- optional" on page 1632

l "Run the test and view the run results" on page 1633

1. Define the global JMS settings
Define global JMS settings such as the JNDI details according to the specifications of your
JMS messaging server. Select theStart orEnd step in the canvas and open the Test Settings

view in the Properties pane. For details, see the "Test Settings Tab (Properties Pane - API
Testing)" on page 429.

2. Prepare a message to send to the queue
Prepare themessage you want to send to the queue in one of the following ways:

n Prepare an expression and type it into theMessage property area.

n Use other activities to generate the string, for exampleConcatenate String, Trim String,
and so forth.

3. Add a Send Message step to your test
a. In the Toolbox pane, expand theStandard Activities > JMS node. Drag aSend Message

to JMS Queue or aSend and Receive Message from JMS Queue activity onto the
canvas.

b. Select the step and click the Properties pane's Input/Checkpoints tab. Set the send-
related input properties:
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o Send queue name

o Message

o JMS send properties

c. If you used another step to generate themessage text, link its output to theMessage
property.

4. Add a Send Message with security and attachments - optional
To send aWeb servicemessage via JMS with attachments and security setting, such as
tokens and signatures:

a. Drag in or select theWeb service step in the canvas and disable its Send Request to
Service option in the Properties pane. For details, see "HTTP Request Activity" on page
1684 and "SOAP Request Activity" on page 1688.

b. Set the security options for the service. For details, see "How to Set Security for aWeb
Service on the Port Level" on page 1885.

c. Include any attachments. For details, see "Attachments Tab (Properties Pane - API
Testing)" on page 403.

d. Drag in a SendMessage to JMS Queue activity onto the canvas.

e. In the Properties pane's Input/Checkpoints tab, select the link icon for theMessage
property. The Select Link Source dialog box opens. For details, see the "Select Link
Source Dialog Box (API Testing)" on page 1840.

f. In the Select Link Source dialog box, select theWeb service step in the left pane. In the
Output property section, double-click on theRaw Request property. This attaches the
security and attachment data to themessage.

g. Define any other JMS properties as you normally would. For property details, see "JMS
Activities" on page 1691.

5. Add a Receive Message step to your test - optional
a. To retrieve amessage from the queue, drag aReceive Message from JMS Queue

activity onto the canvas. If you added aSend and Receive Message to JMS Queue
activity in the previous step, you can skip this step.

b. Select theReceive Message from JMS Queue step and open the Properties pane's
Input/Checkpoints tab. Set the receive-related input properties: Receive queue name and
JMS receive message selector. For property details, see "JMS Activities" on page 1691.

6. Browse the message queue - optional
a. To browse themessages in the queue without consuming them, drag aBrowse JMS
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Queue Messages activity onto the canvas, outside of the Test Flow. Make sure that a
Send (and Receive) Message from JMS Queue step precedes theBrowse JMS Queue
Messages step.

b. Click the Properties pane's Input/Checkpoints tab, and select theBrowse JMS Queue
Messages step. Set the browse-related input properties:

o Queue name. Provide a queue name or link to the queue name from an earlier step. For
IBMWebsphere's MQ, if you specify a queue name that does not exist, a new queue
will be created during the test run.

o JMS receive message selector. The selector lets you filter themessages list. For
details about these properties, see "JMS Activities" on page 1691.

7. Set checkpoints- optional
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a. Select theBrowse JMS Queue Messages step and click in the Properties pane's
Checkpoints section.

b. Select the properties you want to validate and provide values.

c. Use theBrowse JMS queue messages output properties to validate themessages on the
queue. For example, you can check the value of a specific property or check the number of
messages on the queue.

8. Run the test and view the run results
Run the test. In the Run Results Viewer, expand the checkpoint nodes and verify that the
actual values match the expected values. Click the link in the report to display the JMS queue
messages in a separate browser. Compare thesemessages with those shown in the queue on
the JMS application server's console.

How to Receive Messages Through JMS Topics
Relevant for: API testing only

This task describes how to work with subscriptions to JMS topics.

This task includes the following steps:

l "Set the global JMS settings" on the next page

l "Subscribe to a topic" on the next page

l "Publish amessage to the topic" on the next page

l "IncludeWeb service security and attachments - optional" on the next page

l "Receive themessage through the topic" on the next page
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1. Set the global JMS settings
Set global JMS settings such as the JNDI details according to the specifications of your JMS
messaging server. Click in the canvas outside of the Test Flow, and open the Test Settings

tab in the Properties pane. For details, see the "Test Settings Tab (Properties Pane - API
Testing)" on page 429.

2. Subscribe to a topic
Add aSubscribe to JMS Topic step and provide values for its input properties as described in
"JMS Activities" on page 1691.

3. Publish a message to the topic
Add aPublish Message to JMS Topic step and provide values for its input properties.

4. Include Web service security and attachments - optional
To publish aWeb servicemessage via JMS with attachments and security setting, such as
tokens and signatures:

a. Drag in or select theWeb service step in the canvas and disable its Send Request to
Service option in the Properties pane. For details, see "HTTP Request Activity" on page
1684 and "SOAP Request Activity" on page 1688.

b. Set the security options for the service. For details, see "How to Set Security for aWeb
Service on the Port Level" on page 1885.

c. Include any attachments. For details, see "Attachments Tab (Properties Pane - API
Testing)" on page 403.

d. Drag aPublish Message to JMS Topic step onto the canvas.

e. In the Properties pane's Input/Checkpoints tab, select the link icon for theMessage
property. The Select Link Source dialog box opens. For details, see the "Select Link
Source Dialog Box (API Testing)" on page 1840.

f. In the Select Link Source dialog box, select theWeb service step in the left pane. In the
Output property section, double-click on theRaw Request property. This attaches the
security and attachment data to themessage.

g. Define any other JMS properties as you normally would. For property details, see "JMS
Activities" on page 1691.

5. Receive the message through the topic
Drag aReceive Message from JMS Topic activity onto the canvas. Use the topic and
subscription name that you defined in the previous steps.
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How to Retrieve Messages from an MQ Queue
Relevant for: API testing only

This task describes how to work with Put andGet on an IBMWebsphereMQ queue.

This task includes the following steps:

l "Prerequisite" below

l "Connect to theMQQueueManager" below

l "Put amessage on the queue" below

l "Browse themessage queue - optional" below

l "Get amessage from the queue" on the next page

l "Commit or Backout the actions - optional" on the next page

l "Disconnect from theMQQueueManager" on the next page

l "Define event handlers - optional" on the next page

l "Set checkpoints - optional" on the next page

1. Prerequisite
Youmust have theMQ client installed on all machines upon which you want to run the test.

2. Connect to the MQQueue Manager
A connection stepmust precede all steps that use the specified QueueManager. Drag an IBM
Websphere MQ > Connect to MQ Queue Manager step onto the canvas and provide the
connection details in the Properties pane's Input/Checkpoints tab. For details see "Put
Message toMQQueue Activity" on page 1704.

3. Put a message on the queue
Drag aPut Message to MQ Queue step onto the canvas, below the connection step. The
canvas automatically links theMQManager property to themost recent Connect to MQ
Queue Manager step. Set input values as described in "Put Message toMQQueue Activity"
on page 1704.

4. Browse the message queue - optional
To browse themessages in the queue without consuming them:

a. Drag aBrowse Messages in MQ Queue activity onto the canvas.

b. Select the step in the canvas and open the Properties pane's Input/Checkpoints tab.
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c. Set the browse-related properties. For details, see "BrowseMessages inMQQueue
Activity" on page 1702.

5. Get a message from the queue
Drag aGet Message from MQ Queue step onto the canvas, below the connection step. Set
the input values as described in "Get Message fromMQQueue Activity" on page 1705.

6. Commit or Backout the actions - optional
To commit the actions performed until a certain point, drag aCommit MQ Pending Messages
activity onto the canvas. To roll back changes drag aBackout MQ Pending Messages
activity onto the canvas at the relevant location.

7. Disconnect from the MQQueue Manager
A disconnection stepmust follow all steps that use the specified QueueManager. Drag a
Disconnect from MQ Queue Manager step onto the canvas, and provide the connection
details in the Properties pane's Input/Checkpoints tab.

8. Define event handlers - optional
To customize or automate the actions against theMQ server, use theMQ event handlers.
Click the Events button in the Properties pane and double-click the appropriate event—a
standard event or one of theMQ-specific events, such as BeforeMQGetMessage or
AfterMQGetMessage. Customize the code in the TestUserCode.cs tab. For details, see
"Writing Event Handlers for API Test Steps" on page 1935 and the "Events Tab (Properties
Pane - API Testing)" on page 409.

9. Set checkpoints - optional
To validate the response data, select the step and click within the Properties pane's
Checkpoints section. Indicate the properties you want to validate and provide values. Run the
test and view the run results.

How to Receive Messages Through MQ Topics
Relevant for: API testing only

This task describes how to retrievemessages published toMQ topics.

This task includes the following steps:

l "Prerequisite" on the next page

l "Connect to theMQQueueManager" on the next page

l "Subscribe to a topic" on the next page

l "Publish amessage to the topic" on the next page
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l "Receive themessage through the topic" below

l "Unsubscribe from a topic" below

l "Disconnect from theMQQueuemanager" below

l "Define event handlers - optional" below

1. Prerequisite
Youmust have theMQ client installed on all machines upon which you want to run the test.

2. Connect to the MQQueue Manager
A connection stepmust precede all steps that use the specified QueueManager. Drag a
Connect to MQ Queue Manager step onto the canvas, and provide the connection details in
the Properties pane's Input/Checkpoints tab. For details see "Connect to MQQueueManager
Activity" on page 1700.

3. Subscribe to a topic
Add aSubscribe to MQ Topic step. The canvas automatically links theMQManager property
to themost recent Connect to MQ Queue Manager step. Provide values for its input
properties as described in "Subscribe toMQTopic Activity" on page 1709.

4. Publish a message to the topic
Add aPublish Message to MQ Topic step and provide values for its input properties as
described in "PublishMessage toMQTopic Activity" on page 1711.

5. Receive the message through the topic
Drag aReceive Message from MQ Topic activity onto the canvas. Use the topic and
subscription name that you set in the previous steps.

6. Unsubscribe from a topic
Add anUnsubscribe from MQ Topic step and provide values for its input properties as
described in "Unsubscribe fromMQTopic Activity" on page 1710.

7. Disconnect from the MQQueue manager
A disconnection stepmust follow all steps that use the specified QueueManager. Drag a
Disconnect from MQ Queue Manager activity onto the canvas. The canvas automatically
links to themost recent opened connection.

8. Define event handlers - optional
To customize or automate the actions against theMQ server, use theMQ event handlers.
Click theEvents button in the Properties pane and double-click the appropriate event—a
standard event or one of theMQ-specific ones. Customize the code in the TestUserCode.cs
tab. For details, see "Writing Event Handlers for API Test Steps" on page 1935 and the
"Events Tab (Properties Pane - API Testing)" on page 409.
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How to Create an SAP API Test Step
Relevant for: API testing only

This task describes how to create a test step for an SAP IDoc or RFC.

This task includes the following steps:

l "Prerequisite" below

l "Define an SAP Connection" below

l "Open the Import from SAP dialog box" below

l "Select a connection" below

l "Provide credentials - optional" below

l "Search for an IDoc or RFC" on the next page

l "Add the IDoc or RFC to the Toolbox pane" on the next page

l "Create a test/action step" on the next page

1. Prerequisite
Youmust have the SAP .NET Connector installed on your machine. The installation is
available on the SAP Help portal, at http://help.sap.com/saphelp_
NW04/helpdata/en/e9/23c80d66d08c4c8c044a3ea11ca90f/content.htm.

2. Define an SAP Connection
Select Tools > Options > API Testing tab > SAP Connections node. In the SAP
Connections pane, define one or more SAP connections. For details, see "SAP Connections
Pane (Options Dialog Box > API Testing Tab)" on page 568.

3. Open the Import from SAP dialog box
Select Tools > Import from SAP. For user interface details, see "Import from SAP/Update
Dialog Box" on page 1729.

4. Select a connection
Select one of the connections that you defined in the SAP Connections pane of the Options
dialog box.

5. Provide credentials - optional
Accept the default credentials (as entered in the SAP Connections pane in the Options dialog
box) or click Override connection to provide different information.
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6. Search for an IDoc or RFC
Select IDoc orRFC and specify a search string using an asterisk (*) as a wildcard. Click
Search.

7. Add the IDoc or RFC to the Toolbox pane
Check the returned items and click Import Selected to add them to theSAP category in the
Toolbox pane.

8. Create a test/action step
Expand the Local Activities > SAP > <Connection Name> > IDOCs/ RFCs node in the
Toolbox pane, and drag an SAP activity to the canvas. Provide values for theGeneral and
Input/Checkpoints properties.

How to Call External Tests or Actions
Relevant for: API testing only

This task describes how to incorporate tests from other HP applications. You can call any of the
following types of tests:

l Unified Functional Testing tests (both GUI and API tests)

l QuickTest Professional tests

l Service Test tests

l VuGen (Virtual User Generator ) scripts from HP LoadRunner

For details on integration between UFT API Testing and other HP products, see "Automated
Testing Tool Integration" on page 1596.

This task includes the following steps:

l "Prerequisites" on the next page

l "Call an API Test or Action or Service Test test" on the next page

l "Call a GUI Test or QuickTest action or test" on page 1641

l "Add a LoadRunner script activity" on page 1642
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1. Prerequisites
Make sure you have installed the application whose test/script you want to call on the same
computer with UFT or have access to the directory containing the tests or scripts.

Notes:

n If you are calling a test last modified in a version of Service Test prior to your present
version, make sure the test was modified with Service Test 11.10 or higher or UFT.

n To call a test created in QuickTest Professional, ensure that the test was created with
QuickTest 11.00. The first time you run the step, youmay need to wait several seconds
for UFT to invoke and load the test.

n If you are calling a test created in HP LoadRunner, ensure that you created or opened
the test in LoadRunner version 11.00 or later.

2. Call an API Test or Action or Service Test test
a. Make sure the action or test you want to call has been saved and run successfully at least

once.

b. In theStandard Activities section of the Toolbox pane, expand theHP Automated
Testing Tools node.

c. Drag theCall API Action or Test activity onto the canvas.

d. In the Input/Output Properties tab in the Properties pane, click theSelect Action or
Test button.

e. In the "Select Action or Test Dialog Box", select a test last modified with Service Test
11.10 or higher, or with UFT.

Note: To refresh this test or action call when you are editing the test, click theRefresh
button in the Input/Output Properties tab in the Properties pane..

f. In the Input/Output Properties tab, edit the property values as needed.

Note:

o The property list remains empty until you select a test.

o If the test you are calling has no input or output parameters, the Input/Output
Properties tab will be empty.

g. Add other relevant steps to your test. You can link input properties of subsequent step to
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the output properties of the step containing the called API test or action..

h. If the value of the input parameter for step containing the API test/action call must be a
string (such when the result of a previous step was XML), add anXML to String activity
before the step containing the call to the action or test.

i. Optional - To specify a custom directory for the results, in the General tab of the Properties,
click theBrowse button in theResults directory row in theGeneral view tab.

j. Save and run the test.

3. Call a GUI Test or QuickTest action or test
a. Make sure the action or test you want to call has been saved and run successfully at least

once.

b. In theStandard Activities section of the Toolbox pane, expand theHP Automated
Testing Tools node.

c. Drag theCall GUI Action or Test activity onto the canvas.

Note: This activity is only available when working with an HP Unified Functional
Testing license.

Tip: Do not insert a call to a QuickTest or GUI action or test that contains a call to an
API Test action or test, as this can cause unexpected behavior.

d. In the Input/Output Properties tab in the Properties pane, click theSelect Action or
Test button. In the "Select Action or Test Dialog Box" (described on page 1797, select an
action or a test.

e. In the "Select Action or Test Dialog Box", select an action or a test created in QuickTest
11.00 or UFT.

Note: If you want to use data from aGUI test in your API test, the GUI test or action
that is calledmust have test or action parameters saved with the test or action.

Tip: If the QuickTest or GUI action or test changed at its source, you can reload it. In
the Input/Output Properties tab, click Refresh.
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f. In the Input/Output Properties tab, edit the property values as needed. If you want to use
parameters from the called GUI test, in the Input/Checkpoints tab, click the Link to data
source button in subsequent test steps. In the Select Link Source dialog box, link the
selected property to a GUI test or action parameter.

Note:

o The property list remains empty until you select a test.

o If the test you are calling has no input or output parameters, the Input/Output
Properties tab will be empty.

g. Add other relevant steps to your test.

h. Save and run the test.

4. Add a LoadRunner script activity
a. Make sure the action or test you want to call has been saved and run successfully at least

once.

b. In theStandard Activities section of the Toolbox pane, expand theHP Automated
Testing Tools node.

c. Drag theCall Virtual User Generator Script activity onto the canvas.

d. Open theGeneral tab in the Properties pane, and click the script selection button .

e. Navigate to the directory where your VuGen script file (.usr) is saved.

f. Add other relevant steps to your test.

g. Save and run the test.

How to Prepare and Run a Load Test
Relevant for: API testing only

This task describes how to prepare a test for load testing in LoadRunner. For an explanation about
load testing, see "Load Testing Activities" on page 1698.

This task includes the following steps:

l "Prerequisite" on the next page

l "Create a load test" on the next page

l "Add test steps" on the next page
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l "Prepare for load testing - optional" below

l "Assign data to the test - optional" on the next page

l "Set the data retrieval properties - optional" on the next page

l "Set the run configuration to Release" on the next page

l "Run in Load Testingmode to validate the test" on the next page

l "Incorporate the test into LoadRunner" on the next page

1. Prerequisite
Make sure that HP LoadRunner or a standalone version of VuGen (HP Virtual User Generator)
is installed. Without this installation, the Load Testing template will not be available.

2. Create a load test
In the "New <Document> Dialog Box" on page 152 (described on page 152), in theSelect type
section, chooseAPI Load Test.

If you have a test that was created with the standard API testing template, select Design >
Operation > Enable Test for Load Testing or click theEnable Test for Load Testing

button .

3. Add test steps
Drag activities from the Toolbox pane onto the canvas to add steps to the test.

4. Prepare for load testing - optional
Tomeasure the performance of a group of steps, define a transaction.

a. Mark the beginning of a transaction.

o Drag theStart Transaction activity from the Toolbox pane's Load Testing category,
onto the canvas. Place it before the first step of the group of steps that you want to
measure.

o Click the Input/Checkpoints tab in the Properties pane. Enter a Transaction name.
This namewill be used in LoadRunner Analysis.

b. Mark the end of a transaction.

o Drag theEnd Transaction activity to the end of the group of steps you want to
measure.

o In the Properties pane's Input/Checkpoints tab, type a transaction name. The name
must be one that was already used for a priorStart Transaction step.
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o In the End Transaction's Input properties, select aStatus for reporting: PASS, FAIL,
AUTO, orSTOP.

Note: The End Transaction status is only the LoadRunner transaction's status—
not the status of step in UFT. For example, if you assign a Failed status to the
transaction, UFT can still issue aPassed status for the test step.

c. Set the think time.

o If you want to emulate think time, drag the Load Testing >Think Time activity
between the relevant steps.

o In the Properties pane's Input/Checkpoints tab, click in theDuration (sec) row and
specify a think time in seconds.

5. Assign data to the test - optional
Import or create data tables for the input properties. For details, see "How to Assign Data to
API Test/Component Steps" on page 1819.

6. Set the data retrieval properties - optional
If you have data in the Data Pane, set the data retrieval properties. Click the Link to a data
source button . For details, see the "Data Retrieval Options for Load Test Enabled Tests"
on page 1845.

7. Set the run configuration to Release
In the General pane of the API Testing tab in the Options dialog (Tools > Options > API
Testing tab > General node), in theRun Sessions options, select Release. TheRelease
mode conserves resources, thus enhancing the load testing capabilities.

8. Run in Load Testing mode to validate the test
Expand the toolbarRun button and select Run Test in Load Testing Mode. This run is only
for debugging purposes, to verify that the test is functional.

Note:When you run a test in Load Testingmode, the Output pane does not contain data
and the Run Results Viewer does not open. To view the results, select Run to run the test
in functional mode.

9. Incorporate the test into LoadRunner
Add the test to the LoadRunner Controller console to include it in a load test.
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How to Validate an XML file
Relevant for: API testing only

This task describes how to validate the code in an XML string. The Validate XML activity evaluates
an XML string and checks its compliance with an XSD schema.

Since theValidate XML activity reads a string, you need to specify the actual XML string—not just
a file name. If the string is short, you can copy it into theValue column directly. For more complex
XML content, you can read the XML file using aRead from File activity.

This task includes the following steps:

l "Provide the XML code to validate" below

l "Add a Validate XML activity" below

l "Connect the steps - if using Read from File" below

l "Specify an XSD file" on the next page

l "Set a checkpoint - optional " on the next page

l "Run the test" on the next page

1. Provide the XML code to validate
To provide the XML code, you can paste an XML directly into theValue column, or read the
contents from the file using theRead from File activity.

To enter XML code directly, copy the XML string from the source document and paste it into
theValue column.

To read the XML from a file:

a. Drag the File System > Read from File activity onto the canvas.

b. Click the Input/Checkpoints tab in the Properties pane. Browse to the XML file you want to
validate.

2. Add a Validate XML activity
Drag theXML > Validate XML activity onto the canvas. If you used aRead from File step,
drag this activity beneath the step.

3. Connect the steps - if using Read from File
If you used aRead from File step to obtain the XML, follow these steps. Otherwise, skip to
step 4.
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a. Click the Input/Checkpoints tab in the Properties pane. Click in theValue column of the
XML String property and click the Link to a data source button .

b. In the Select Link Source dialog box, select theAvailable steps option. In the right pane,
select theRead from File step's output property, Content, and click OK.

4. Specify an XSD file
a. Select theValidate XML step in the canvas. Click the Input/Checkpoints tab in the

Properties pane, Browse to anXSD file.

b. To import the XSD file into the test's folder, set theXSD file to test folder option to true.
This is useful if you plan on saving the test on ALM. Setting this option will make the XSD
file available to anyone who loads the test.

5. Set a checkpoint - optional
If you want to verify the results:

a. In the Input/Checkpoints tab in the Properties pane, click in the Checkpoints section.

b. Select theValid check box. Set the value to true to verify that the XML code complies with
the XSD. Set the value to false to confirm that the XML code did not comply with the XSD.

c. To check for a specific error, set theValid value to false, and specify the expected error in
theError row. You can link to a data source containing the expected value.

6. Run the test
Run the test. TheOutput tab and RunResults Viewer will display the results and indicate
whether the XML is in compliance with the XSD and details about the errors.

How to Transform an XML File
Relevant for: API testing only

This task describes how to transform an .xml file to a different structure based on an .xslt file.

Since the Transform XML activity reads a string, you need to specify the actual XML string—not
just a file name. If the string is short, you can copy it into theValue column directly. For more
complex XML content, you can read the XML file using aRead from File activity.

This task includes the following steps:

l "Provide the XML code to transform" on the next page

l "Add a Transform XML activity" on the next page

l "Connect the steps - if using Read from File" on the next page

l "Specify an XSLT file" on the next page
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l "Set a checkpoint - optional " below

l "Run the test" below

1. Provide the XML code to transform
To provide the XML code, you can paste an XML directly into theValue column, or read the
contents from the file using theRead from File activity.

To enter XML code directly, copy the XML string from the source document and paste it into
theValue column.

To read the XML from a file:

a. Drag the File System > Read from File activity onto the canvas.

b. Click the Input/Checkpoints tab in the Properties pane. Browse to the .xml file you want to
transform.

2. Add a Transform XML activity
Drag theXML > Transform XML activity onto the canvas. If you used aRead from File step,
drag this activity beneath the step.

3. Connect the steps - if using Read from File
If you used aRead from File step to obtain the XML, follow these steps. Otherwise, skip to
the next step.

a. Click the Input/Checkpoints tab in the Properties pane. Click in theValue column of the
XML String property and click the Link to a data source button .

b. In the Select Link Source dialog box, select theAvailable steps option. In the right pane,
select theRead from File step's output property, Content, and click OK.

4. Specify an XSLT file
a. Select the Transform XML step in the canvas. Click the Input/Checkpoints tab in the

Properties pane. Browse to an .xslt file.

b. To import the .xslt file into the test's folder, set theXSLT file to test folder option to true.
This is useful if you plan on saving the test on ALM. Setting this option will make the .xslt
file available to anyone who loads the test.

5. Set a checkpoint - optional
If you want to verify the results, select the Transformed XML check box in theCheckpoints
section and specify the expected result. You can link to a data source containing the expected
value.

6. Run the test
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Run the test. TheOutput tab and the Run Results Viewer will indicate whether the transform
operation succeeded.

How to Compare XML Strings
Relevant for: API testing only

This task describes how to compare two XML strings and view the differences.

This task includes the following steps:

l "Add an Compare XMLs step to the canvas" below

l "Enter the original XML string" below

l "Enter the new XML string" below

l "Set the ignore options - optional" below

l "Save the settings - optional" below

l "Set a checkpoint - optional" on the next page

l "View the results" on the next page

1. Add an Compare XMLs step to the canvas
Drag theXML > Compare XMLs activity onto the canvas.

2. Enter the original XML string
Copy the original XML string onto the clipboard.

Click the Input/Checkpoints tab in the Properties pane. Click the down arrow in theValue
column of theXML string 1 property and paste the original XML string into the box.

3. Enter the new XML string
Copy themodified XML onto the clipboard and paste it into theXML string 2 row.

4. Set the ignore options - optional
a. To ignore any differences in the order of the elements, set Ignore element order to true.

b. To ignore any differences in namespaces, set Ignore namespaces to true.

c. To ignore differences in a specific node, expand the Ignore XPaths array and add one or
more array elements with the XPath expression you want to ignore.

5. Save the settings - optional
To save all of your ignore settings for future use, click theSave options button.

User Guide
Chapter 55: Standard Activities

HP Unified Functional Testing (12.00) Page 1648 of 2274



6. Set a checkpoint - optional
To set a checkpoint which indicates whether or not there was a change, click theValidate
check box in the Checkpoints area.

n To verify that there was a change, set Are Equal to false.

n To verify that there was no change, set Are Equal to true.

7. View the results
a. Run the test. In the Run Results Viewer, expand the results.

b. Select theCompare XMLs node in the results tree in the left pane.

c. In theCaptured Data pane, click theReport File link. The report shows both XML strings.
The report's legend indicates the nature of the change: added, removed, changed, and so
forth.

d. Scroll down in theCaptured Data pane for the XMLComparison Results table. This table
lists the changes, showing the old and new element and attribute names with their values.
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References

Standard Activity Types
Relevant for: API testing only

This section describes the Standard activity groups:

Flow Control Activities 1651

Miscellaneous Activities 1654

StringManipulation Activities 1657

System Activities 1659

Math Activities 1660

Date and Time Activities 1660

File System Activities 1663

Database Activities 1669

FTP Activities 1674

Network Activities 1684

JSON Activities 1690

Java Activities 1691

JMS Activities 1691

Load Testing Activities 1698

IBMWebSphereMQActivities 1699

HP Automated Testing Tools Activities 1714

SAP Activities 1714

XMLActivities 1717

HP Unified Functional Testing (12.00) Page 1650 of 2274



Flow Control Activities

Relevant for: API testing only

The following activities allow you to control the flow of the test using loops, conditions, breaks, and
delays:

l Condition. Enables you to use a branchingmechanism to determine alternate test flows based
on the value of a property. For details, see "Condition Activity" below.

l Loop. A loop framewhose properties can be set independently of the Test Flow. The loop types
are For loop, Do While loop, and For Each loop. For details, see "Loop Activity" on the next
page.

l Break. Halts the test execution.

l Continue. Resumes the test execution after a break.

l Sleep. Pauses the test execution for a specified amount of time.

l Wait. Waits a specified amount of time for a trigger event before releasing a step for execution.
For details, see "Wait Activity" on page 1653.

Condition Activity

Relevant for: API testing only

This activity enables you to branch your test flow depending on a conditional outcome.

The following properties are available for this activity:

Property Description
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Use
condition

Instructs UFT to use a conditional outcome to proceed with the test flow.

If the current state of the applicationmatches the defined condition, then the
condition proceeds with the test steps defined in theYes branch. If the current state
of the application does not match the defined condition, the test proceeds with the
steps in theNo branch.

You define the following settings for the condition activity:

l Variable: the process for which you want to determine the value

l Operator: the basis for comparison for the variable. You can select one of the
following:

n =

n !=

n >

n >=

n <

n <=

l Value: the expected value for the variable

You can link the variable and value to data sources or other test steps. For details,
see "How to Assign Data to API Test/Component Steps" on page 1819.

Use
event Instructs UFT to use the event handler specified in theEvents tab to determine

on which conditional branch to continue to run the test.

Note: You can create custom properties to use in the event handler in by

clicking theAdd button .

Loop Activity

Relevant for: API testing only

This activity enables you to use additional test flow loops independently of the test flow. This also
enables you to set individual data flow patterns for each loop independently of themain Test Flow
data usage properties.
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The following iteration settings are available for the Test Flow or other custom loops:

Property Description

Do While
Loop -
Use
condition

Repeats the loop as long as the specified condition is met:

l Variable. The variable to evaluate. Use the Select Link Source button to
enter a data source expression.

l Operator. A comparison operator relevant to the variable such as =, !=,
Contains, Starts andRegex.

l Value. The value with which to compare the result.

Do While
Loop -
Use event

Performs iterations until the event returns True. This mode is useful for complex
conditions that can be defined in an event handler. When you select this option, the
Input Properties grid opens.

l Click to define properties.

l Click to open theEvents view. Click Create a default handler in the
Handler column.

l Modify or add code to the event handler method that defines your condition.

For Each
Loop

Performs an iteration for each element in the associated array or collection of
objects. Data is selected using theSelect Link Source button .

Note:When you delete data from a data table, it continues to run an iteration
for that row, with empty values. To remove an entire row of a data, click the
row and select Delete from the shortcut menu (only with Excel installations).

For Loop Performs the Test Flow or custom loop the number of times that you specify in the
Number of Iterations box.

Wait Activity

Relevant for: API testing only

This activity enables you to temporarily pause the test flow for a specified amount of time.

When running asynchronous service calls as part of your test, theWait activity waits a specified
amount of time for a trigger event before releasing the associated step. This activity is used in
conjunction with theHTTP Receiver steps andWeb Service calls imported as server response
steps. For details, see "Asynchronous Service Calls" on page 1927.
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The following properties are available:

Property Description

Timeout The timeout in milliseconds. Negative values indicate that there is no
timeout.

Start timeout after
step

The time after step execution from when to beginmeasuring the timeout
interval.

Action on timeout The action to take when the timeout is reached without the completion
events: Fail orContinue.

Completion event
names

A list of the completion events that were configured in prior receiver steps.

Miscellaneous Activities

Relevant for: API testing only

This activity group includes the following activities:

l Custom Code. Enables you to program a step to execute your own activity. Use theAdd
button to define new input or output properties.

l Set Test Variable. Defines a global variable for your test.

Note: This adds an additional test variable to the built-in variables included in every test.

l Run Program. Invokes an application on the current machine. For details, see "Run Program
Activity" below.

l End Program. Closes an application that is running. For details, see "End Program Activity" on
the next page.

l Report Message. Sends a custommessage to the Run Results and/or the Output pane. For
details, see "Report Message Activity" on page 1656.

Run Program Activity

Relevant for API testing only

This activity enables you to run a program from your computer as part of the test.
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The following properties are available for this activity:

Input Properties

Property Description

Target The name of the program to run.

Tip: You can click theBrowse for file button to navigate to the file.

Command line
arguments

The arguments to enter in theWindows command line to run the program
selected for the Target property.

Working
directory

The file system location of the program defined in the Target property.

Note: If you do not remember the exact path to the Target program, click
theBrowse for file button to find the correct directory.

Run as user The user with which to run the program specified in the Target property.

Password The password of the user specified in theRun as user property.

Domain The password to use when starting the application.

Timeout The amount of time (in milliseconds) to wait for the application to exit.

Checkpoint Properties

Property Description

Exit code The value returned by the program specified in the Target property when the
program closed.

Tip: You can choose an operator to expand the possible values if the output of
the program varies. Select the appropriate operator from the dropdownmenu.

Process
terminated

Specifies whether the program completed its run correctly or timed out. Select the
appropriate value from the drop-downmenu in theValue column.

End Program Activity

Relevant for API testing only

This activity enables you to stop and close a program that is running as part of your test. You should
use this step in conjunction with aRun Program activity.
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The following properties are available for this activity:

Input Properties
When entering the input properties, you can choose between ending the program by specifying the
path to the program, by specifying the window to close, or by specifying the process ID of the
program.

Note: You can only choose one of the options to close the program.

Property Description

Executable
path

The path to file to close.

Note: You can click theBrowse for file button to navigate the file.

Window
Title

Enables you to specify a specific program window to close.

In order to close the window, youmust define the following properties:

l Title: The window title of the program to close

l Use RegEx: Instructs UFT to treat the window title as a regular expression.
Select true or false from the drop-down list to enable or disable this attribute.

Process ID TheWindows process ID of the program to close.

Checkpoint Properties

Property Description

Exit Code The value provided by the program upon its completion.

Report Message Activity

Relevant for: API testing only

This activity enables you to send amessage to the Output pane during a test run or to the run
results.

The following properties are available for this activity:

Property Description
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Status The status to report in themessage.

By default, UFT includes statuses of Done, Pass, and Fail. To define other
statuses, click the Link to data source button in theValue cell.

Note: This status is different from the run status of the step displayed for
each test step in the Result Details pane in the Run Results Viewer.

Message Themessage to report. You canmanually enter themessage or link this message
to a data source or other test steps. For details on linking this property value, see
"How to Assign Data to API Test/Component Steps" on page 1819.

Destination The place to report themessage. You can report this message in the run results
only or in the run results and the Output pane (displayed during test runs).

Themessage generated during the test run of this step, including theStatus andMessage property
values, is displayed in theCaptured Data pane in the Run Results Viewer. For details on the
Captured Data pane, see the section on the Captured Data Pane in theHP RunResults Viewer
User Guide.

String Manipulation Activities

Relevant for: API testing only

This activity group provides access to the following string related activities:

l Concatenate Strings. Joins two strings.

l Replace String. Replaces part of a string with an alternate string. You can provide an array of
replacement strings for use with iterations. For details, see "Replace String Activity" below.

l Substring. Extracts the characters between two specified locations of a string. For details, see
"Substring Activity" on the next page.

l Trim String. Removes whitespace characters from the beginning or end of a string. For details,
see "Trim String Activity" on page 1659.

Replace String Activity

Relevant for: API testing only

This activity enables you to replace a specified string with another string.

The following properties are available for this activity:

Input Properties

Property Description
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Source
string

The name of the string to replace.

Search
and
replace
array

The array containing the strings to find and replace. Youmust provide the values for
the following:

l Search string: The string to replace.

l Replace String: The string which replaces the string found in theSearch String
property.

Tip: If you need to replacemultiple parts of the source string, add an additional
array by clicking theAdd button in theSearch and Replace (array) property
row.

Case-
sensitive

Indicates that UFT should search for theSearch String property by locating the
matching case for the string specified in the Search String value cell. Select True or
False from the drop-down list to set this property.

Checkpoint Properties

Property Description

Result The expected result for the search and replace operation.

Note: Make sure to include spaces where needed in both theSearch and
Replace strings as well as theResult output string or the checkpoint will fail.

Substring Activity

Relevant for: API testing only

This activity enables you to extract a section of a specified string for use elsewhere in your test.

The following properties are available for this activity:

Input Properties

Property Description

Source
string

The string from which you are extracting a section.

Substring
start

The character position (numerically) in the string defined in theSource string
property to begin extracting.

Substring
length

The number of characters to extract from the string specified in theSource
string property.
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Checkpoint Properties

Property Description

Result The expected string that is extracted.

Trim String Activity

Relevant for: API testing only

This activity enables you to trim extra whitespaces from a selected string.

The following properties are available for this activity:

Input Properties

Property Description

Source
string

The string from which to trim.

Trim
start

Enables you to trim the whitespace from the beginning of the string. Choose True or
False from the drop-down list to enable or disable trimming.

Trim
end

Enables you to trim the whitespace from the end of the string. Choose True or False
from the drop-down list to enable or disable trimming.

Checkpoint Properties

Property Description

Result The result of the trim operation.

Note: Make sure to include spaces where needed in both theSearch and
Replace strings as well as theResult output string or the checkpoint will fail.

System Activities

Relevant for: API testing only

This activity group provides access to the following operating system activities:

l Set OS Environment Variable. Sets the value of an operating system variable.

l Get OS Environment Variable. Retrieves the value of an operating system variable.
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Math Activities

Relevant for: API testing only

This activity group performs the followingmath related activities:

l Add. Adds two numbers.

l Subtract. Subtracts one number from another.

l Multiply.Multiplies two numbers.

l Divide. Divides one number by another.

Date and Time Activities

Relevant for: API testing only

This activity group performs the following date and time related activities:

l Increment Date. Adds date or time units to a date/time string. For details, see "Increment Date
Activity" below.

l Date/Time Difference. Calculates the difference between two date/time strings. For details,
see "Date/Time Difference Activity" on the next page.

l Format Date/Time. Formats a date/time string. For details, see "Format Date/Time Activity" on
page 1662.

Increment Date Activity

Relevant for: API testing only

This activity enables you to change a date and time by ameasured amount.

The following properties are available for this activity:

Input Properties

Property Description

Original
Date/Time

The source date and time tomodify.

Tip: You canmanually enter the date and time or choose a date and time
from the drop-down calendar.
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Original
Date/Time
Format

The format of the date and time provided in the Original Date/Time property.
Choose one of the formats from the drop-down list.

Note: You only need to enter this information when you provide a string
expression for theOriginal Date/Time property.

Units The unit to add to the date and time specified in theOriginal Date/Time property.

Note: You can only increment one unit at a time in a test step. If you need to
increment multiple date and time units, add additional Increment Date
activities to your test.

Units The number of units (as specified in theUnits property value) to add to the
Original Date/Time property.

Checkpoint Properties

Property Description

Result The new date and time after the addition is made.

Note: Make sure to enter the date and time with exactly the same format as
specified in theOriginal Date/Time Format property.

Date/Time Difference Activity

Relevant for: API testing only

This activity enables you compare different dates and times.

The following properties are available for this activity:

Input Properties

Property Description

Date/Time
(A,B)

The date and times to compare.

Tip: You canmanually enter the date and time or choose a date and time from
the drop-down calendar.
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Date/Time
Format
(A,B)

The format of the date and time provided in theDate/Time property. Choose one of
the formats from the drop-down list.

Note: You only need to enter this information when you provide a string
expression for theDate/Time property.

Units The unit to compare between the date and times specified in theDate/Time
properties.

Note: You can only increment one unit at a time in a test step. If you need to
increment multiple date and time units, add additional Increment Date
activities to your test.

Checkpoint Properties

Property Description

Result The numeric difference between the compared dates specified in theDate/Time
properties.

Format Date/Time Activity

Relevant for: API testing only

This activity enables you to format a selected date and time with a given date and time format.

The following properties are available for this activity:

Input Properties

Property Description

Input
Date/Time

The date and time to format.

Tip: You canmanually enter the date and time or choose a date and time
from the drop-down calendar.

Input
Date/Time
Format

The format of the date and time specified in the Input Date/Time property.

Note: You only need to enter this information when you provide a string
expression for the Input Date/Time property.

Format The format to which to change the date and time specified in the Input
Date/Time property.
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Checkpoint Properties

Property Description

Result The date and time after the new format is applied.

Note: Make sure to enter the date and time with exactly the same format as
specified in the Format property.

File System Activities

Relevant for: API testing only

This activity group provides access to the following file system related activities:

l File Exists. Searches for a specific file, or group of files, if you use a wildcard expression. It
returns true if the file exists.

l Folder Exists. Searches for a specific folder. It returns true if the folder exists.

l File Copy. Copies a file to a new destination. For details, see "File Copy Activity" below.

l File Move.Moves a file to another destination. For details, see "File Move Activity" on the next
page.

l File Create. Creates a new file. For details, see "Create File Activity" on page 1665.

l File Delete. Deletes a file.

l File Rename. Renames a file. For details, see "File Rename Activity" on page 1665.

l Write to File.Writes to an existing or For details, see "Write to File Activity" on page 1666.new
file.

l Read from File. Retrieves text from a file. For details, see "Read From File Activity" on page
1667.

l Get Folder Contents. Gets the contents of a folder—file names, folder names, or both. For
details, see "Get Folder Contents Activity" on page 1668.

File Copy Activity

Relevant for: API testing only

This activity enables you to copy a selected file to another specified location.
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The following properties are available for this activity:

Input Properties

Property Description

File
source
path

The path of the file to copy.

Tip: You can click theBrowse for file button to navigate to the file.

Target
folder

The folder into which to copy the file specified in the File source path property.

Tip: If you do not remember the exact path in which you want to copy the file,
you can click theBrowse for folder button to find the directory.

Target
file name

The name of the file after it is copied.

Overwrite Instructs UFT to overwrite or not overwrite an already existing file of the same
name. Select True or False from the drop-down list to enable or disable the setting.

Checkpoint Properties

Property Description

Result Indicates whether the file copy succeeded or failed.

File Move Activity

Relevant for: API testing only

This activity enables you tomove a file to a selected location.

The following properties are available for this activity:

Input Properties

Property Description

File
source
path

The path of the file to copy.

Tip: You can click theBrowse for file button to navigate to the file.

Target
folder

The folder into which to copy the file specified in the File source path property.

Tip: If you do not remember the exact path in which you want to copy the file,
you can click theBrowse for folder button to find the directory.

User Guide
Chapter 55: Standard Activities

HP Unified Functional Testing (12.00) Page 1664 of 2274



Target
file name

The name of the file after it is copied.

Overwrite Instructs UFT to overwrite or not overwrite an already existing file of the same
name. Select True or False from the drop-down list to enable or disable the setting.

Checkpoint Properties

Property Description

Result Indicates whether the file copy succeeded or failed.

Create File Activity

Relevant for: API testing only

This activity enables you to create a new file.

Note: This activity creates a new file but does not put content into the file. If you need to also
add content to the file, use aWrite to File activity in conjunction with this activity.

The following properties are available for this activity:

Input Properties

Property Description

Target
folder

The folder into which to copy the file specified in the File source path property.

Tip: If you do not remember the exact path in which you want to copy the file,
you can click theBrowse for folder button to find the directory.

Target
file name

The name of the file after it is copied.

Overwrite Instructs UFT to overwrite or not overwrite an already existing file of the same
name. Select True or False from the drop-down list to enable or disable the setting.

Checkpoint Properties

Property Description

Result Indicates whether the file copy succeeded or failed.

File Rename Activity

Relevant for: API testing only

This activity enables you to rename a selected file.
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The following properties are available for this activity:

Input Properties

Property Description

File
source
path

The path of the file to copy.

Tip: You can click theBrowse for file button to navigate to the file.

Target
file name

The name of the file after it is copied.

Overwrite Instructs UFT to overwrite or not overwrite an already existing file of the same
name. Select True or False from the drop-down list to enable or disable the setting.

Checkpoint Properties

Property Description

Result Indicates whether the file copy succeeded or failed.

Write to File Activity

Relevant for: API testing only

This activity enables you to add content to a new or existing file.

You can use this activity in conjunction with theCreate File activity to add content to a created file.

The following properties are available for this activity:

Input Properties

Property Description

Content The information to add to the file specified in the File path property.

If you have a lot of content to add to the file, click the down arrow to display the
extended

File path The directory containing the file, including the file name.

Mode Themanner of editing the specified file. You can select one of the following:

l Append to existing file: Adds content to a file that already exists.

l Create new file:Creates a new file with the name specified in the File path
property and with the content indicated in theContent property.
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Encoding Themanner of encoding the content added in the file. Select one of the following
modes of encoding:

l ASCII

l UTF-7

l UTF-8

l UTF-32

l Unicode

Append
new line

Instructs UFT to add a new line for your content to the file selected (if you are writing
to an existing file). Select True or False to enable or disable the setting.

Checkpoint Properties

Property Description

Result Indicates whether the file copy succeeded or failed.

Read From File Activity

Relevant for: API testing only

This activity enables you to check and read the content in a specific file.

The following properties are available for this activity:

Input Properties

Property Description

File path The directory containing the file, including the file name.

Encoding Themanner of encoding the content added in the file. Select one of the following
modes of encoding:

l ASCII

l UTF-7

l UTF-8

l UTF-32

l Unicode
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Checkpoint Properties

Property Description

Content The content read from the file.

Get Folder Contents Activity

Relevant for: API testing only

This activity enables you to check the contents of a specified folder.

The following properties are available for this activity:

Input Properties

Property Description

Folder
source
path

The folder in which to search.

Search
pattern

The criteria by which to search the folder's content. By default, UFT searches for
any file having an extension (indicated by the *.* criteria.

Content
type

The type of content for which to search. You can choose to search only files, only
folders, or both files and folders.

Sort by Sorts the folder content results. You can sort by a number of criteria:

l Name

l Creation Time (of the file/folder)

l Date Modified (of the file/folder)

l None

Sort type Displays the results in ascending or descending order.

Include
subfolders

Searches the subfolders included in the folder specified in the Folder source path
property.

Checkpoint Properties
The checkpoint properties for this activity are displayed as an array, To add an array (or multiple
arrays if needed), click theAdd Array button .

Property Description

Name The name of a file expected to be found.
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Path The directory of the expected result.

Full path The full path to the directory of the expected result.

Content type The expected content of the search.

Creation time The creation time of the expected result.

Date modified Themodification date of the expected result.

Database Activities

Relevant for: API testing only

This activity group performs the following database related activities:

l Open Connection. Opens a connection to a database using the specified connection string. For
details, see "Open Connection/Close Connection Activity" below.

l Close Connection. Closes an open database connection. For details, see "Open
Connection/Close Connection Activity" below.

l Select Data. Executes a SELECT type SQL statement that retrieves data. For details, see
"Select Data Activity" on the next page.

l Execute Command. Executes an SQL statement that does not retrieve data from the
database, such as UPDATE, DELETE, and so forth. For details, see "Execute Command
Activity" on page 1672.

l Begin Transaction. Begins a database transaction. For details, see "Begin Transaction
Activity" on page 1673.

l Commit Transaction. Commits a database transaction. For details, see "Commit
Transaction/Rollback Transaction Activity" on page 1674.

l Rollback Transaction. Rolls back a database transaction from a pending state. For details, see
"Commit Transaction/Rollback Transaction Activity" on page 1674.

Open Connection/Close Connection Activity

Relevant for: API testing only

This activity enables you to open or close a connection to a database. You should use both of these
activities together.

TheOpen Connection activity is required before other database connection activities.
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The following properties are available for these activities:

Input Properties

Property Description

Connection String
(for Open Connection
activities only)

AnOLE DB database connection string. You can provide a value in one
of the following ways:

l Type it in manually.

l Open theConnection Builder . For details, see the
"Connection Builder Dialog Box" on page 1720.

l Use the Link to a data source button to create a link to the
string.

Connection
(for Close Connection
activities)

A link to the output of anOpen Connection step. Use the Link to a
data source button to create a link.

Checkpoint Properties

Property Description

Result Indicates whether the connection is active (true) or closed (false).

Result
Message

A message indicating success or an informational message from the
database.

Select Data Activity

Relevant for: API testing only

This activity enables you to specify the data from a database user source.

Youmust put anOpen Connection step in your test before this activity.

The following properties are available for this activity:

Input Properties

Property Description

Connection A link to the output of a previously opened connection string. Use the Link to a
data source button to create the link.
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Property Description

Query
string

An SQLSELECT statement. You can provide a string in one of the following
ways:

l Type it in manually.

l Open theQuery Builder . For details, see the "Query Builder Dialog Box"
on page 1722.

l Use the Link to a data source button to create a link to the string.

Timeout Themaximum time to allow for executing the database command. A value of zero
indicates no time limit.

Default: 30 seconds

Checkpoint Properties

Property Description

Count The number of rows returned by the command.

Result Indicates whether the operation has been successfully completed: true or false.

Result
table

An array of returned rows. The row elements are column names. You can set an
expected value for each column of each row:

l The columns changed due to parameterization.

l A columnwas removed since the original query.

l You don't have access to database when designing the test.

Note: In order to see the table column, you need to generate the output at least
once. You can do this by selecting theGenerate output option in the Query
Builder, or by clicking theGenerate Output button in theCheckpoints pane.

Tip: Use theManage Columns button to remove or replace columns when:
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Database Property Options

Option Description

Generate
Output

Retrieves table data from the database and constructs an array with the current table
structure.

If you enabledGenerate output in the Query Builder, you do not need to generate
the output again. For details, see "Query Builder Dialog Box" on page 1722.

Manage
Columns

If the table structure changed since you generated the output, theManage Columns
dialog box lets youmanage the columns. This is commonwhen columns names
were a parameter, or if a columnwas deleted from the table.

Execute Command Activity

Relevant for: API testing only

This activity enables you to execute a command for your database data.

Youmust put anOpen Connection step in your test before this activity.

The following properties are available for this activity:

Input Properties

Property Description

Connection A link to the output of a previously opened connection string. Use the Link to a
data source button to create the link.

Command An SQL statement that does not retrieve data, such as UPDATE or DELETE. You
can provide a string in one of the following ways:

l Type it in manually in the drop-down edit box.

l Use the Link to a data source button to create a link to the string.

Timeout Themaximum time to allow for executing the database command. A value of zero
indicates no time limit.

Default: 30 seconds

Checkpoint Properties

Property Description

Affected
rows

The number of rows affected by the command.

Result Indicates whether the command executed successfully: true or false.
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Property Description

Result
Message

Success or upon failure, amessage issued by the database indicating the
nature of the failure.

Begin Transaction Activity

Relevant for: API testing only

This activity enables you to start a database transaction.

Youmust put anOpen Connection step in your test before this activity.

The following properties are available for this activity:

Input Properties

Property Description

Connection A link to the output of a previously opened connection string. Use the Link to a
data source button to create the link.

Isolation
level

The isolation level of the transaction:

l Default

l Chaos

l ReadCommitted

l ReadUncommitted

l Repeatable Read

l Serializable

l Snapshot.

For details, see http://msdn.microsoft.com/en-
us/library/system.data.isolationlevel.aspx.

Checkpoint Properties

Property Description

Result Indicates whether the connection is active (true) or closed (false).

Result
Message

A message indicating success or an informational message from the
database.
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Commit Transaction/Rollback Transaction Activity

Relevant for: API testing only

This activity enables you to commit the results of a transaction to your database or roll back a
selected transaction.

Youmust put aBegin Transaction step before this activity.

The following properties are available for this activity:

Input Properties

Property Description

Transaction A link to an open transaction. Use the Link to a data source button to create
a link to the output of aBegin Transaction step.

Checkpoint Properties

Property Description

Result Indicates whether the connection is active (true) or closed (false).

Result
Message

A message indicating success or an informational message from the
database.

FTP Activities

Relevant for: API testing only

This activity group provides activities that allow you to perform FTP operations, such as FTP
Upload and FTP Download.

l FTP Download. Downloads a file or directory from an FTP server. For details, see
"FTP Download Activity" on the next page.

l FTP Upload. Uploads a file or directory to an FTP server. For details, see "FTP Upload
Activity" on page 1676.

l FTP Rename. Renames an existing file or directory on an FTP server. For details, see
"FTP Rename Activity" on page 1678.

l FTP File Delete. Deletes a file on an FTP server. For details, see "FTP File Delete Activity" on
page 1679.

l FTP File Get Size. Gets the size of a file on an FTP server. For details, see "FTP File Get Size
Activity" on page 1680.
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l FTP Directory Delete. Deletes a empty directory on an FTP server. For details, see
"FTP Download Activity" below.

l FTP Directory Create. Creates a new directory on an FTP server. For details, see
"FTP Directory Create Activity" on page 1681.

l FTP Directory Get Content. Lists the content of a directory on an FTP server. For details, see
"FTP Directory Get Content Activity" on page 1683.

FTP Download Activity

Relevant for: API testing only

This activity enables you to download an FTP file from a specified directory.

The following properties are available for this activity:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 1923.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Input Properties

Property Description
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URL The URL location of the file to download.

User ID The user name to access the FTP server.

Password The password to access the FTP server.

Local
Path

The location to which to download the file.

Overwrite Enables UFT to overwrite or not overwrite an existing file by the same name.
Choose True to overwrite a file of the same name or False to make another copy.

Transfer
mode

Themethod of file transfer: ASCII or binary.

Checkpoint Properties

Property Description

Result An indicator if the step succeeded. Select True to add a checkpoint confirming the
successful completion, or False to confirm an unsuccessful attempt to download the
selected file.

FTP Upload Activity

Relevant for: API testing only

This activity enables you to upload a file to specified FTP directory.

The following properties are available for this activity:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.
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Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 1923.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Input Properties

Property Description

Directory
file path

The URL and directory in which to upload the file.

User ID The user name to access the FTP server.

Password The password to access the FTP server.

Local
Path

The location from which to upload the file.

Overwrite Enables UFT to overwrite or not overwrite an existing file by the same name.
Choose True to overwrite a file of the same name or False to make another copy.

Transfer
mode

Themethod of file transfer: ASCII or binary.

Checkpoint Properties

Property Description

Result An indicator if the step succeeded. Select True to add a checkpoint confirming the
successful completion, or False to confirm an unsuccessful attempt to download the
selected file.
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FTP Rename Activity

Relevant for: API testing only

This activity enables you to rename a specified file in an FTP directory.

The following properties are available for this activity:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 1923.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Input Properties

Property Description

URL The URL location of the file to rename.

User ID The user name to access the FTP server.

Password The password to access the FTP server.

New file name The name of the file after renaming.
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Checkpoint Properties

Property Description

Result An indicator if the step succeeded. Select True to add a checkpoint confirming the
successful completion, or False to confirm an unsuccessful attempt to download the
selected file.

FTP File Delete Activity

Relevant for: API testing only

This activity enables you to delete a selected file from an FTP directory.

The following properties are available for this activity:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 1923.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Input Properties

Property Description

URL The URL location of the file to delete.
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User ID The user name to access the FTP server.

Password The password to access the FTP server.

Checkpoint Properties

Property Description

Result An indicator if the step succeeded. Select True to add a checkpoint confirming the
successful completion, or False to confirm an unsuccessful attempt to download the
selected file.

FTP File Get Size Activity

Relevant for: API testing only

This activity enables you to check the size of a file on a specified FTP directory.

The following properties are available for this activity:

Input Properties

Property Description

URL The URL location of the file to check.

User ID The user name to access the FTP server.

Password The password to access the FTP server.

Checkpoint Properties

Property Description

Result An indicator if the step succeeded. Select True to add a checkpoint confirming the
successful completion, or False to confirm an unsuccessful attempt to download the
selected file.

File size The expected size of the file.

FTP Directory Delete Activity

Relevant for: API testing only

This activity enables you to delete a selected FTP directory.

The following properties are available for this activity:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.
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Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 1923.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Input Properties

Property Description

URL The URL location of the file to download.

User ID The user name to access the FTP server.

Password The password to access the FTP server.

Checkpoint Properties

Property Description

Result An indicator if the step succeeded. Select True to add a checkpoint confirming the
successful completion, or False to confirm an unsuccessful attempt to download the
selected file.

FTP Directory Create Activity

Relevant for: API testing only

This activity enables you to create an FTP directory.
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The following properties are available for this activity:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 1923.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Input Properties

Property Description

URL The URL location of the directory to create.

User ID The user name to access the FTP server.

Password The password to access the FTP server.

Directory Path The FTP location in which to create the new directory.

Checkpoint Properties

Property Description

Result An indicator if the step succeeded. Select True to add a checkpoint confirming the
successful completion, or False to confirm an unsuccessful attempt to download the
selected file.
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FTP Directory Get Content Activity

Relevant for: API testing only

This activity enables you retrieve the content from a specified FTP directory.

The following properties are available for this activity:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Enable
SSL

Indicates whether to establish a secure FTP connection: true or false.

Proxy The proxy server information: Server, Username andPassword.

Timeout The FTP request timeout in milliseconds.

Client
certificate

l . Browse Certificates. Opens the Select Certificate dialog box. To see the
icon, click in the top level row of theClient certificate section, in theValue
column. For details, see the "Select Certificate Dialog Box" on page 1923.

l A Choice element indicating the source of the client certificate for secure FTP
connections:

n Use file system certificate: The expanded node provides the full path of the
certificate file.

n Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Input Properties

Property Description

URL The URL location of the directory to check.

User ID The user name to access the FTP server.

Password The password to access the FTP server.

Checkpoint Properties

Property Description
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Result
(array)

An array of possible property values for the content in the directory. Possible
values include:

l Name

l Type

l Flags

l Owner

l Group

l Size

l Date Created

Network Activities

Relevant for: API testing only

This activity group provides activities that enable you to send and receive HTTP and SOAP
requests.

This activity group contains the following activities:

l HTTP Request. This activity enables you to send an HTTP request over the network. For
details, see "HTTP Request Activity" below.

l HTTP Receiver. This activity enables you to receive an HTTP response from a server. For
details, see "HTTP Receiver Activity" on page 1687.

l SOAP Request. This activity enables you to send a SOAP request over the network. For
details, see "SOAP Request Activity" on page 1688.

HTTP Request Activity

Relevant for: API testing only

This activity enables you to add an HTTP request to a network-based service to your test.

The following properties are available for these activities:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Note: These properties are also relevant forWeb Service request steps.
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Property Description

Proxy The settings for the proxy server hosting the service contract: Server (URL
and port when required), Username, andPassword.

Authentication The user credentials settings for obtaining a service contract: Username and
Password.

Connection
type

The type of connection: Keep-Alive orClose.

Default:Keep-Alive

Timeout The HTTP timeout in milliseconds.

Client
certificate

A Choice element indicating the source of the client certificate:

l Use file system certificate: The expanded node provides the full path of
the certificate file.

l Use Windows store certificate: The expanded node lists the following
properties Store location, Store name, X509 find type, andX509 find
value.

l Password. The certificate's password.

Note: To use a certificate, make sure to theUse Client Certificate
property to true.

Use Client
Certificate

Enables the use of a client certificate.

Default: false

Maximum
automatic
redirections

The number of times to attempt accessing a page, including redirection.

Default: 3

Allow
redirections

Indicates whether to allow the step to redirect to another URL.

Default: true

Reuse cookies Enables the reusing of cookies for the current step. Default: false.

Input Properties

Property Description

URL The URL to which tomake the HTTP Request.
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HTTP Method Themethod by which to send the request. You can select one of the following:

l GET

l POST

l PUT

l DELETE

l TRACE

l OPTIONS

l HEAD

HTTP Version The HTTP version to use in the request. Choose from version 1.0 or version
1.1.

Request
Headers

The request header to send with the HTTP request.

This property is displayed as an array. Youmust provide the following details
for the request:

l Name

l Value

Note: To sendmultiple request headers, click theAdd Array Element
button in theRequestHeaders row.

Checkpoint Properties

Property Description

HTTP Version The HTTP version of the response to the HTTP request.

Status code The expected code of the response.

Status description The expected description of the response.

Response body as UTF-8 string The expected response in UTF-8 form.

Response body as Base64 string The expected response in Base64 form.
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HTTP Receiver Activity

Relevant for: API testing only

TheHTTP Receiver activity receives an HTTP message from a server. This activity is used with
asynchronous messaging. For details, see "Asynchronous Service Calls" on page 1927.

Receiver activities are activities that act as receiver for a server response. This category includes
the built-inHTTP Receiver activity andWeb Service operations that were imported as a server
response. For more details, see the "Select WSDLDialog Box" on page 1764 or "Select WSDL
Dialog Box" on page 1764.

All receiver activities are composite activities. This means that they serve as a wrapper for all
activities inside the container whose responses are sent to the HTTP Receiver step—not the Test
Flow.

For example, if an HTTP Receiver step contains the FTP Download andRead from File steps,
these internal steps send their response to the HTTP Receiver step—not to the Test Flow loop.

The following properties are available for these activities:

General Properties
To view theGeneral properties, click theGeneral view button in the Properties pane.

Property Description

Listen on port The port upon which to listen for the server request.
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Property Description

Completion event name The name of the event associated with a followingWait step,
allowing the step to receive the server request.

Use SSL Secures the connection with SSL: true or false.

SSL Certificate Information about the SSL certificate:

l Subject. The certificate's subject string.

l Store location. The location of the certificate—LocalMachine or
Windows store.

l Store name. The name of the store hosting the certificate.

l Thumbprint. The certificate's thumbprint or hash code.

Save response body
with this extension

Saves the response body for messages with the specified
extension.

Output Properties
You can link to theHTTP Receiver output property, its response body, through the Select Link
Source dialog box. For details, see "Select Link Source Dialog Box (API Testing)" on page 1840.

Property Description

Response body as a UFT-8 string The body of the HTTP response in UFT-8 format.

SOAP Request Activity

Relevant for: API testing only

TheSOAP Request activity sends amanual SOAP request to the server, usually in XML format.
You can import a schema and load XML for this activity.

The following properties are available for these activities:

General Properties
To view theGeneral properties, click theGeneral button in the Properties pane.

Note: These properties are also relevant for REST Servicemethod steps.

Property Description

Transport The type of transport for the SOAP request: HTTP or JMS.
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Property Description

Transport
> HTTP

Use the HTTP transport method for this call with the following properties:

l Endpoint Address. The endpoint location of the service as derived from the
WSDL

l SoapAction. An expression indicating the SOAP action

Example:HP.SOAQ.SampleApp/IHPFlights_Service/DeleteFlightOrder.

l ContentType. The type of content: For example text/xml; charset=utf-8.

l Timeout. Themaximum time inmilliseconds to wait for the response. Enter -1
to disable the timeout and wait for the response as long as required.

Transport
> JMS

Use the JMS transport method for this call with the following properties:

l Send queue name. The name of the queue from which to send themessage.

l Receive queue name. The name of the queue from which to receive the
message.

l JMS send properties. JMS properties with the key/value form. You can use the
key tomodify JMS header or message properties.

l JMS receive message selector. An SQL expression to filter the received
message. For more information on the syntax for defining selectors, see the
Message Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

For example, a key JMSCorrelationID, with a value of 4566636, receives only
messages whose correlation ID is 4566636.

IsOneWay Indicates whether the service is a one way service: true or false. A one way service
only sends a request. A non-one way service sends a request and receives a
response.

The input and checkpoint properties for the SOAP Request activity are dependent on the file you
load containing your Request and Response information.
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JSON Activities

Relevant for: API testing only

This activity group contains activities related to JSON files:

l JSON to String. Converts a JSON file to a text string. For details, see "JSON to String
Activity" below.

l String to JSON. Converts a string to a JSON structure. For details, see "String to JSON
Activity" below.

This JSON to String andString to JSON activities are useful when you need to access the output
in a specific format—either as string or JSON.

For example, suppose your test contains aWeb Service call whose output is JSON. However, you
need to use the output as an input for the next step, such as an API test step, which requires a
textual string—not JSON.

You can use the JSON to String activity to create a string that is compatible with the API test
step.

After the API test step, you can use aString to JSON activity to convert the output to JSON,
making it available for linking and checkpoints.

String to JSON Activity

Relevant for: API testing only

This activity enables you to convert a selected string to JSON format.

The following properties are available for this activity:

Input Properties

Property Description

Source string The string to convert into JSON text.

The checkpoints are dependent upon the JSON text contained in the file you load in the
checkpoints section.

JSON to String Activity

Relevant for: API testing only

This activity enables you to take JSON text and convert it into a string.

The following properties are available for this activity:
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The input properties are dependent upon the JSON text contained in the file you load in the
checkpoints section.

Checkpoint Properties

Property Description

Source string The string to convert into JSON text.

Java Activities

Relevant for: API testing only

This activity group contains theCall Java Class activity. It enables you to set up and configure a
call to a Java class.

The input and checkpoint properties for this activity are dependent on the information in your Java
class file.

JMS Activities

Relevant for: API testing only

The JMS transport method is a J2EE standard for sendingmessages—either text or Java objects—
between Java clients. UFT supports the sending of text messages between Java clients. There are
two scenarios for communication:

l Peer-to-Peer. Also known as Point-to-Point. JMS implements point-to-point messaging by
defining amessage queue as the target for amessage. Multiple senders sendmessages to a
message queue, and the receiver gets themessage from the queue.

l Publish-Subscribe. Eachmessage is sent from one publisher to many subscribers through a
designated topic. The subscribers only receivemessages sent after they have subscribed.

To interpret Topic andQueue names, UFT calls a lookupmethod on a JNDI context, defined in the
Properties pane's Test Settings. For details, see the "Parameters/Checkpoints Tab (Properties
Pane - API Testing)" on page 417.

For task details, see "How to RetrieveMessages from a JMS Queue" on page 1630 or "How to
ReceiveMessages Through JMS Topics" on page 1633.

This activity group provides steps that handle JMS messages, and contains the following activities:

l Publish Message to JMS Topic. Publishes amessage tomultiple subscribers using a JMS
topic. For details, see "PublishMessage to JMS Topic Activity" on the next page.

l Receive Message from JMS Queue. Receives amessage from a JMS queue. For details, see
"SendMessage to JMS Queue Activity" on page 1695.

l Receive Message from JMS Topic. Receives publishedmessages to a specific JMS topic for
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a subscription. Place this step afterSubscribe to JMS Topic. For details, see "Receive
Message from JMS Topic Activity" on page 1694.

l Send Message to JMS Queue. Sends amessage to a JMS queue. For details, see "Send
Message to JMS Queue Activity" on page 1695.

l Send and Receive Message from JMS Queue. Sends amessage to a specified queue and
receives amessage from a specified queue. For details, see "Send/ReceiveMessages from
JMS Queue Activity" on page 1695.

l Subscribe to JMS Topic. Creates a subscription for a JMS topic. Use this step before any
Receive Message from Topic steps for the subscription. For details, see "Subscribe to
JMS Topic Activity" on page 1697.

l Browse JMS Queue Messages. Retrieves messages from the JMS queue without consuming
them. For details, see "Browse JMS Queue Activity" on page 1697.

Publish Message to JMS Topic Activity

Relevant for: API testing only

This activity enables you to publish amessage to a specified JMS topic.

The following properties are available for these activities:

Input Properties

Property Description

Topic name The name of the queue from which to receive themessage.

Message Themessage to publish.

JMS send
properties

JMS properties with the key/value form. You can use the key tomodify JMS
header or message properties.

Checkpoint Properties

Property Description

Result A boolean variable indicating whether the step succeeded.

Receive Message from JMS Queue Activity

Relevant for: API testing only

This activity enables you receive amessage from a selected JMS Queue.
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The following properties are available for this activity:

Input Properties

Property Description

JMS
receive
message
selector

An SQL expression to filter the receivedmessage. For details on the syntax for
defining selectors, see theMessage Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

For example, a key JMSCorrelationID, with a value of 4566636, receives only
messages whose correlation ID is 4566636.

Receive
queue
name

The name of the queue from which to receive themessage. If the value is empty, it
uses a temporary queue.

Checkpoint Properties

Property Description

JMSMessageID A unique ID for themessage.

JMSTimeStamp The time and date of themessage.

JMSCorrelationID Themessage's correlation ID.

Tip: Use in conjunction with the JMS receivemessage selector.

JMSReplyTo The contents of theReply To field.

JMSDestination Themessage's destination.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSType A string describing the JMS type.

JMSExpiration Themessage's expiration date.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number
of properties, or click theAdd button to add elements.

Message body Themessage content.
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Receive Message from JMS Topic Activity

Relevant for: API testing only

This activity enables you to receive amessage from a selected JMS topic.

The following properties are available for this activity:

Input Properties

Property Description

Topic name The name of the topic from which to receive themessage.

Subscription
name

The name of the subscription. Use the same subscriber name value from the
previously-calledSubscribe to JMS Topic step.

Checkpoint Properties

Property Description

JMSMessageID A unique ID for themessage.

JMSTimeStamp The time and date of themessage.

JMSCorrelationID Themessage's correlation ID.

Tip: Use in conjunction with the JMS receivemessage selector.

JMSReplyTo The contents of theReply To field.

JMSDestination Themessage's destination.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSType A string describing the JMS type.

JMSExpiration Themessage's expiration date.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number
of properties, or click theAdd button to add elements.

Message body Themessage content.
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Send Message to JMS Queue Activity

Relevant for: API testing only

This activity enables you to send amessage to a selected JMS queue.

The following properties are available for this activity:

Input Properties

Property Description

Send queue
name

The name of the queue from which to send themessage.

Message Themessage to send.

JMS send
properties

JMS properties with the key/value form. You can use the key tomodify JMS
header or message properties.

Checkpoint Properties

Property Description

Result A boolean variable indicating whether the step succeeded.

Send/Receive Messages from JMS Queue Activity

Relevant for: API testing only

This activity enables you to send or receivemessages from a selected JMS queue activity.

The following properties are available for this activity:

Input Properties

Property Description

Send
queue
name

The name of the queue to which to send themessage.

Receive
queue
name

The name of the queue from which to receive themessage. If the value is empty, it
uses a temporary queue.

Message Themessage to send.

JMS send
properties

JMS properties with the key/value form. You can use the key tomodify JMS
header or message properties.
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Property Description

Send
queue
name

The name of the queue to which to send themessage.

JMS
receive
message
selector

An SQL expression to filter the receivedmessage. For details on the syntax for
defining selectors, see theMessage Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

For example, a key JMSCorrelationID, with a value of 4566636, receives only
messages whose correlation ID is 4566636.

Tip: To automatically generate a selector, use theAutomatically generate
selector option in the Properties pane's Test Settings tab. This selector uses
a correlation ID that corresponds to the request's message ID.

Checkpoint Properties

Property Description

JMSMessageID A unique ID for themessage.

JMSTimeStamp The time and date of themessage.

JMSCorrelationID Themessage's correlation ID.

Tip: Use in conjunction with the JMS receivemessage selector.

JMSReplyTo The contents of theReply To field.

JMSDestination Themessage's destination.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSType A string describing the JMS type.

JMSExpiration Themessage's expiration date.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number
of properties, or click theAdd button to add elements.

Message body Themessage content.
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Subscribe to JMS Topic Activity

Relevant for: API testing only

This activity enables you to subscribe to a selected JMS topic.

The following properties are available for this activity:

Input Properties

Property Description

Topic name The name of the topic from which to receive themessage.

Subscription
name

The name of the subscription. To retrievemessages on the subscription created
by this step, insert aReceive Message from Topic step using the same
Subscription name value.

JMS receive
message
selector

An SQL expression to filter the receivedmessage. For details on the syntax for
defining selectors, see theMessage Properties section in
http://docs.oracle.com/javaee/1.3/api/javax/jms/Message.html.

Checkpoint Properties

Property Description

Result A boolean variable indicating whether the step succeeded.

Browse JMS Queue Activity

Relevant for: API testing only

This activity enables you to browse a selected JMS queue.

The following properties are available for this activity:

Input Properties

Property Description

Queue
name

The name of the queue upon which to browse for a collection of messages. This
field is mandatory.

Note:When using IBM ActiveMQ, youmust use the format
dynamicQueues/<queue_name>. If the specified queue does not exist, it will
be created dynamically.

Messages
selector

An optional SQL expression to filter the receivedmessages. For details on the
syntax for defining selectors, see theMessage Properties section in
http://www.oracle.com/technetwork/java/jms-101-spec-150080.pdf.
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Checkpoint Properties

Property Description

JMSMessageID A unique ID for themessage.

JMSTimeStamp The time and date of themessage.

JMSCorrelationID Themessage's correlation ID.

Tip: Use in conjunction with the JMS receivemessage selector.

JMSReplyTo The contents of theReply To field.

JMSDestination Themessage's destination.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSType A string describing the JMS type.

JMSExpiration Themessage's expiration date.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number
of properties, or click theAdd button to add elements.

Message body Themessage content.

Load Testing Activities

Relevant for: API testing only

Load testing enable you tomeasure the performance of your application or service with a defined
user load.

When you have a full LoadRunner installation on the samemachine, UFT provides a custom
template, API Load Test.

For tests created with the standardAPI Test template, UFT provides a conversion utility which
converts the script into a LoadRunner compatible script, with a .usr extension.

Note: Tests created in UFT and converted into LoadRunner scripts, cannot be edited in
LoadRunner's Virtual User Generator (VuGen). To edit a test, modify it in UFT.
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Whenworking with data tables, you can use the standard data retrieval methods that are available
in LoadRunner. For details, see "Data Retrieval Options for Load Test Enabled Tests" on page
1845.

For task details, see "How to Prepare and Run a Load Test" on page 1642.

This activity group contains the following activities that allow you prepare the test for load testing:

l Start Transaction.Marks the beginning of a LoadRunner transaction.

l End Transaction.Marks the end of a LoadRunner transaction.

l Think Time. Emulates a time delay, in seconds, between steps.

For details, see "Prepare for load testing - optional" on page 1643.

IBM WebSphere MQ Activities

Relevant for: API testing only

This activity group enables you to perform actions on an IBMWebsphereMQ application server.

The activities in this group are:

l Connect to MQ Queue Manager. Connects to a specific MQQueueManager andmaintains an
open connection with the server. For details, see "Connect to MQQueueManager Activity" on
the next page.

l Disconnect from MQ Queue Manager. Disconnects from the specific MQQueueManager
and closes the connection with theMQ server. For details, see "Disconnect fromMQQueue
Manager Activity" on page 1701.

l Commit MQ Pending Messages. Commits the last changes made for all messages since the
last point of synchronization. For details, see "Commit/Backout PendingMQMessages
Activity" on page 1702.

l Backout MQ Pending Messages. Performs a Backout operation from the last point of
synchronization. All PUTmessages will be cancelled andGETmessages will be reinstated to
the queue. For details, see "Commit/Backout PendingMQMessages Activity" on page 1702.

l Browse Messages in MQ Queue. Browses themessages on theMQQueue via the Queue
Manager. For details, see "BrowseMessages inMQQueue Activity" on page 1702.

l Put Message to MQ Queue. Puts amessage on theMQ queue via the QueueManager. For
details, see "Put Message toMQQueue Activity" on page 1704.

l Get Message from MQ Queue. Gets themost recent message from theMQ queue via the
QueueManager. For details, see "Get Message fromMQQueue Activity" on page 1705.

l Put and Get Message from MQ Queue. Puts amessage on theMQ queue and then gets a
message from theMQ queue via the QueueManager. For details, see "Put andGet Message
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fromMQQueue" on page 1707.

l Subscribe to MQ Topic. Creates a subscription for anMQ topic. From this point on, a
subscriber can receivemessages from a specified topic. For details, see "Subscribe toMQ
Topic Activity" on page 1709.

l Unsubscribe to MQ Topic. Cancels a subscription for the specifiedMQ topic. For details, see
"Unsubscribe fromMQTopic Activity" on page 1710.

l Publish Message to MQ Topic. Publishes amessage to subscribers using anMQ topic. For
details, see "PublishMessage toMQTopic Activity" on page 1711.

l Receive Message from MQ Topic. Receives messages for the active subscription, that were
published to a specific MQ topic. For details, see "ReceiveMessage fromMQ Topic Activity" on
page 1712.

UFT enables you to set the data format of themessage for both queues and topics. TheString
format indicates Unicode and non- Unicode strings without a prefix. TheUTF format represents a
UTF string with a 2-byte prefix.

For task details, see "How to RetrieveMessages from anMQQueue" on page 1635 or "How to
ReceiveMessages ThroughMQTopics" on page 1636.

Connect to MQQueue Manager Activity

Relevant for: API testing only

This activity enables you to connect to the IBMWebsphereMQ QueueManager.

The properties available for this activity include:

Input Properties

Property Description

Host
name

The name or IP address of the QueueManager's host machine.

Port The port through which to connect, by default 1414.

Channel The channel through which to connect. For most configurations, use
SYSTEM.DEF.SVRCONN.

Queue
manager
name

An property indicating the name of the QueueManager.

User ID An optional identification property for connecting to the host machine.

Password An optional password for connecting to the host machine.
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Property Description

Host
name

The name or IP address of the QueueManager's host machine.

Port The port through which to connect, by default 1414.

SSL Enables or disables SSL. When you enable SSL, you can set values for the
following properties:

l SSLCipherSpec. The SSLCipher Specification, SSLCIPH. This specification
indicates which data encryption algorithm and key size to use, such as DES_
SHA_EXPORT orRC2_MD5_EXPORT.

l SSLKeyRepository. The path of the SSL key repository on the client machine.

Checkpoint Properties

Property Description

MQManager An automatically generated connection expression.

Note:

l Although this does not appear in theCheckpoints grid, it is visible as an
output property in the Select Link Source dialog box. For details, see the
"Select Link Source Dialog Box (API Testing)" on page 1840.

l When you add steps, they automatically use the connection expression
from themost recent connection step.

Result A boolean variable indicating whether the step succeeded.

Disconnect from MQQueue Manager Activity

Relevant for: API testing only

This activity enables you to disconnect from the IBM WebsphereMQQueueManager.

The properties available for this activity include:

Input Properties

Property Description

MQManager A connection expression linked to aConnect to MQ Queue Manager step.

Note:When you add aDisconnect to MQ Queue Manager step, it
automatically creates a link to themost recent connection step.
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Checkpoint Properties

Property Description

Result A boolean variable indicating whether the step succeeded.

Commit/Backout Pending MQMessages Activity

Relevant for: API testing only

This activity enables you to commit or roll back pendingmessages from aMQQueue.

Youmust put aConnect to MQ Queue Manager step before this step.

The properties available for this activity include:

Input Properties

Property Description

MQManager A connection expression linked to aConnect to MQ Queue Manager step.

Note:When you add this step, it automatically creates a link to themost
recent connection step.

Checkpoint Properties

Property Description

Result A boolean variable indicating whether the step succeeded.

Browse Messages in MQQueue Activity

Relevant for: API testing only

This activity enables you to browse all themessages in a selectedMQQueue.

Youmust put aConnect to MQ Queue Manager step before this step.
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The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Queue
name

The name of theMQ queue to browse.

Queue
Access
Options

A tree with several built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Message
Get Options

A tree with several built-in MQGet options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Wait
interval

Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Message
data format

The format of themessage being retrieved: String orUTF.

Match
Conditions

An array of match conditions in a key/value format. Select a key from the drop
down box in the Key's Value column and provide a value.MQMO_NONE does
not require a value.

Checkpoint Properties

Property Description

JMSMessageID A unique ID for themessage.

JMSTimeStamp The time and date of themessage.

JMSCorrelationID Themessage's correlation ID.

Tip: Use in conjunction with the JMS receivemessage selector.
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Property Description

JMSMessageID A unique ID for themessage.

JMSReplyTo The contents of theReply To field.

JMSDestination Themessage's destination.

JMSDeliveryMode Themessage's delivery mode. Use the scroller to select a value.

JMSRedelivered Indicates whether themessage was redelivered. False by default.

JMSType A string describing the JMS type.

JMSExpiration Themessage's expiration date.

JMSPriority Themessage's priority in comparison to other messages. Use the scroller
to select a value.

JMS properties An array of message properties in the structure of keys and values.

Tip: Use theNumber of elements drop -down to specify the number
of properties, or click theAdd button to add elements.

Message body Themessage content.

Put Message to MQQueue Activity

Relevant for: API testing only

This activity enables you to add amessage to a selectedMQQueue.

Youmust put aConnect to MQ Queue Manager step before this step.

The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Put queue
name

The name of theMQ queue on which to put themessage.

Queue
Access
Options

A drop down of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

User Guide
Chapter 55: Standard Activities

HP Unified Functional Testing (12.00) Page 1704 of 2274



Property Description

Message
Put Options

A drop down of built-in message put options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Priority The priority of themessage rated from 0 through 9 (highest). A message with a
higher priority will be taken from the queue beforemessages with a lower priority.

Correlation
ID

The correlation ID of themessage.

Message
format

The format of themessage being sent: String orUTF.

Character
Set

The character set code to use when sending amessage.

Note: This property is only relevant when themessage format is set to
String.

Message
body

The body of themessage to put on the queue.

Message
Properties

An array of Put message properties in aKey/Value format.

Checkpoint Properties

Property Description

MessageId A message identifier of themessage being sent.

PutTime The date and time themessage was put.

UserId The sender's user ID.

Get Message from MQQueue Activity

Relevant for: API testing only

This activity enables you to receive amessage from a selectedMQ Queue.

Youmust put aConnect to MQ Queue Manager step before this step.
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The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Get Queue
Name

The name of theMQ queue from which to get themessage.

Queue
Access
Options

A drop down of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Message
Get Options

A collection of built-in Message get options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Wait
interval

Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Message
data format

The format of themessage being retrieved: String orUTF.

Match
Condition

An array of match conditions in a key/value format. Select a key from the drop
down box in the Key's Value column and provide a value.MQMO_NONE does
not require a value.

Checkpoint Properties

Property Description

MessageId Themessage identifier of the retrievedmessage.

CorrelationId The correlation identifier of the retrievedmessage.

GroupId An identifier of themessage group to which the physical message belongs.

MsgSeqNumber The sequence number of a logical message within a group.
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Property Description

MessageId Themessage identifier of the retrievedmessage.

PutTime The date and time the PUT action was executed for themessage.

Priority The priority of themessage rated from 0 through 9 (highest). A message with
a higher priority will be taken from the queue beforemessages with a lower
priority.

UserId The User ID of the user who submitted themessage.

MessageBody A string representing the UTF content of the retrievedmessage.

Put and Get Message from MQQueue

Relevant for: API testing only

This activity enables you to add and receive amessage from a selectedMQQueue.

Youmust put aConnect to MQ Queue Manager step before this step.

The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Auto Match
Correlation
ID

Correlates the sent and receivedmessages by automatically adding amatch
condition. This condition indicates that theCorrelation ID of the received
message should equal theMessage ID of the sent message.

Put Queue
Name

The name of theMQ queue upon which to put themessage.

Put Queue
Access
Options

A collection of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Message
Put Options

A collection of built-in message put options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Put priority The priority of themessage to be submitted.
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Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Put
correlation
ID

A correlation identifier for themessage to be submitted.

Put
Message
Format

The format of themessage: being sent: String orUTF.

Character
Set

Message
Body

A string representing the UTF content of the submittedmessage.

Message
properties

An array of Put message properties in a key/value format.

Get Queue
Name

The name of theMQ queue from which to get themessage.

Get Queue
Access
Options

A collection of built-in MQ queue access options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Message
Get Options

A collection of built-in options that control the Get operation.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Wait
interval

Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Get
Message
Format

The format of the receivedmessage: String orUTF.
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Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Match
Condition

An array of Get Messagematch conditions n a key/value format. Select a key
from the drop down box in the Key's Value column and provide a value.MQMO_
NONE does not require a value.

Checkpoint Properties

Property Description

MessageId Themessage identifier of the retrievedmessage.

CorrelationId The correlation identifier of the retrievedmessage.

GroupId An identifier of themessage group to which the physical message belongs.

MsgSeqNumber The sequence number of a logical message within a group.

PutTime The date and time the PUT action was executed for themessage.

Priority The priority of themessage rated from 0 through 9 (highest). A message with
a higher priority will be taken from the queue beforemessages with a lower
priority.

UserId The User ID of the user who submitted themessage.

MessageBody A string representing the UTF content of the retrievedmessage.

Subscribe to MQ Topic Activity

Relevant for: API testing only

This activity enables you to subscribe to a selectedMQQueue topic.

Youmust put aConnect to MQ Queue Manager step before this step.

The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Topic name The name of theMQ topic from which subscribers can access themessage.

Subscription
name

An automatically generated subscription name.
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Property Description

Topic
Access
Options

A collection of built-in MQ topic access options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Checkpoint Properties

Property Description

Result The Subscription name enteredmanually or generated automatically.

Notes:

l Although this does not appear in theCheckpoints grid, it is visible as an
output property in the "Select Link Source Dialog Box (API Testing)".

l This property can be used as an input value for the subscription name in the
Unsubscribe from MQ Topic andReceive Message from MQ Topic
steps.

Unsubscribe from MQ Topic Activity

Relevant for: API testing only

This activity enables you to unsubscribe from a previous subscription to anMQQueue topic.

Youmust put aConnect to MQ Queue Manager step before this step.

The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Subscription
name

The subscription from which to unsubscribe. This can be a literal string or an
expression linked to the output of aSubscribe to MQ Topic step.

Checkpoint Properties

Property Description

Result A boolean variable indicating whether the step succeeded.
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Publish Message to MQ Topic Activity

Relevant for: API testing only

This activity enables you to publish amessage to a selectedMQQueue topic.

Youmust put aConnect to MQ Queue Manager step before this step.

The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Topic
Name

The name of the topic on which to publish themessage.

Topic
Access
Options

A drop down of the built-in options that control the opening of the topic.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Message
Put Options

A drop down of built-in options that control the Put operation, such as MQPMO_
SYNCPOINT.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.

Priority The priority of themessage rated from 0 through 9 (highest). A message with a
higher priority will be taken from the queue beforemessages with a lower priority.

Correlation
ID

The UserId of the user who submitted themessage.

Message
Format

The format of themessage being published: String orUTF.

Character
Set

The character set to use when sending this message.

Note: This property is only relevant when theMessage Format is set to
String.

Message
body

Themessage to publish.
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Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Topic
Name

The name of the topic on which to publish themessage.

Message
Properties

An array of message properties in aKey/Value format.

Checkpoint Properties

Property Description

MessageId A message identifier of the submittedmessage.

PutTime The date and time themessage was put.

UserId The UserId of the user who submitted themessage.

Receive Message from MQ Topic Activity

Relevant for: API testing only

This activity enables you to receive amessage from a selectedMQ Queue topic.

Youmust put aConnect to MQ Queue Manager step before this step.

The following properties are available for this activity:

Input Properties

Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Subscription
Name

The subscription through which to receive topic messages. This can be a literal
string or an expression linked to the output of aSubscribe to MQ Topic step.

Message Get
Options

A drop down of built-in message get options.

Note: To access additional options, use an event handler. For details, see
"Writing Event Handlers for API Test Steps" on page 1935.
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Property Description

MQManager A connection expression linked to themost recent Connect to MQ Queue
Manager step.

Subscription
Name

The subscription through which to receive topic messages. This can be a literal
string or an expression linked to the output of aSubscribe to MQ Topic step.

Wait interval Themaximum time inmilliseconds to wait for themessage to arrive, using the
following values:

l -1: Unlimited wait time

l 0: No wait

l A positive number: The time to wait in milliseconds.

Message
Format

The format of themessage being retrieved: String orUTF.

Match
Condition

An array of match conditions n a key/value format. Select a key from the drop
down box in the Key's Value column and provide a value.MQMO_NONE does
not require a value.

Checkpoint Properties

Property Description

MessageId Themessage identifier of the retrievedmessage.

CorrellationId The correlation identifier of the retrievedmessage.

GroupId An identifier of themessage group to which the physical message belongs.

MsgSeqNumber The sequence number of a logical message within a group.

PutTime The date and time themessage was put.

Priority The priority of themessage rated from 0 through 9 (highest). A message with
a higher priority will be taken from the queue beforemessages with a lower
priority.

UserId The User ID of the user who submitted themessage.

MessageBody A string representing the UTF content of the retrievedmessage.
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HP Automated Testing Tools Activities

Relevant for: API testing only

This activity group contains activities that allow you implement unified testing plan. For task
details, see "How to Call External Tests or Actions" on page 1639.

l Call API Action or Test. Calls an API or Service Test test or action when the current Test
Flow or loop reaches this step.

l Call GUI Action or Test. Calls a GUI test or action when the current Test Flow or loop reaches
this step. Do not insert a call to a GUI Test action or test that contains a call to a API Test action
or test, as this can cause unexpected behavior.

l Call Virtual User Generator script. Runs a LoadRunner Virtual User Generator (VuGen)
script.

General Properties
The following general properties are available for these activities:

Property Activity Description

Test path Call API Action or
Test

Call GUI Action or
Test

Action name Call API Action or
Test

Call GUI Action or
Test

The name of the action being called. This field is
read-only. To select an action, click theSelect
Action or Test button in the Input/Checkpoints
tab.

Description All An editable field describing the call.

Result
Directory

Call API Action or
Test

The location in which to store the run results. This
field is editable.

Script path Call Virtual User
Generator Script

The path of the Virtual User Generator-LoadRunner
script. This field is read-only. To select a script, click
theSelect Virtual User Generator Script button in
the Input/Checkpoint view.

SAP Activities

Relevant for: API testing only

This activity group contains the activity related to SAP IDoc status.
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l Get IDOC Status. Retrieves the status of an IDoc.

This section describes the built-in SAP activity. For information about imported SAP activities
representing RFCs and IDocs, see "How to Create an SAP API Test Step" on page 1638.

General Properties
To view these properties, click theGeneral tab in the Properties pane.

Property Description

Timeout Themaximum time allowed for the function to respond inmilliseconds.

Default:100000

ConnectionInfo The SAP Connection information for the selected step:

l Server. The name or IP address of the server.

l System number. The server's System Number.

l Client. The client for this SAP connection.

l Username. The username for this SAP connection.

l Password. The password for this SAP connection.

Function name The name of the RFC (for RFCs only).

Expect
Exception

Indicates whether or not to expect an exception when running the function:
true or false (for RFCs only).

IDocController IDoc Controller properties (for IDocs only):

l Message Type, Basic Type, andExtension.

l Sender:Port, Partner number, andPartner type.

l Receiver:Port, Partner number, andPartner type.

Transaction Indicates whether or not the RFC is part of a transaction or not: true or false
(for RFCs only).

Input Properties

Property Description

IDoc Number The IDoc number for the IDoc whose status you want to retrieve.
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Checkpoint Properties
The checkpoint name corresponds to the SAP property ID.

Property Description

MANDT The client.

DOCNUM The IDoc number.

LOGDAT The date of the status information.

LOGTIM The time of the status information.

COUNTR The IDoc status counter.

CREDAT The creation date of the status record.

CRETIM The creation time of the status record.

STATUS The status of the IDoc.

UNAME The user name.

REPID The program name.

ROUTID The name of the subroutine or functionmodule.

STACOD The status code.

STATXT The status code textual representation.

SEGNUM The SAP segment number.

SEGFLD The field name in the SAP segment.

STAPA1,2,3,4 Status parameters 1, 2, 3, and 4.

STATYP The systemmessage type: A, W, E. S, or I.

STAMQU The status message qualifier.

STAMID The status message ID.

STAMNO The status message number.

TID The transaction ID.

APPL_LOG The application log.
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XML Activities

Relevant for: API testing only

This activity group contains activities related to XML files:

l Transform XML. Converts an XML file to another structure based on the specified XSLT. For
details, see "Transform XMLActivity" below.

l Compare XML. Performs a comparison between two XML strings. For details, see "Compare
XMLActivity" on the next page.

l XML to String. Converts an XML file to a text string. For details, see "XML to String Activity" on
page 1719.

l String to XML. Converts a string to XML structure. For details, see "String to XML Activity" on
page 1719.

l Validate XML. Validates an XML file against an XSD schema. For details, see "Validate XML
Activity" on page 1719.

TheXML to String andString to XML activities are useful when you need to access the output in
a specific format—either as string or XML.

For example, suppose your test contains aWeb Service call whose output is XML. However, you
need to use the output as an input for the next step, which requires a textual string—not XML.

You can use theXML to String activity to create a string that is compatible with the API test step.

After the test step, you can use aString to XML activity to convert the output back to XML,
making it available for linking, and checkpoints.

For task information, see:

l "How to Validate an XML file" on page 1645

l "How to Transform an XML File" on page 1646

l "How to Compare XMLStrings" on page 1648

Transform XML Activity

Relevant for: API testing only

This activity enables you to transform a selected XML string.

The following properties are available for this activity:

Input Properties

Property Description
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XML String The XML to transform.

Import XSLT to test
folder

Copies the file containing the transformed XML (the .xslt file) to the
test folder.

XSLT folder The full path of the folder in which to place the file containing the
transformed XML,

Checkpoint Properties

Property Description

Transformed XML The expected XML string after its transformation.

Compare XML Activity

Relevant for: API testing only

This activity enables you to compare two selected XML strings.

The following properties are available for this activity:

Input Properties

Property Description

XML String
1

The first XML string to compare.

XML String
2

The second XML string to compare

Ignore
element
order

Instructs UFT to ignore the order of XML elements when doing the comparison.
Select True to ignore the elements or False to notice the element order during the
comparison.

Ignore
namespaces

Instructs UFT to ignore the XML namespaces of XML elements in the strings.
Select True to ignore the namespaces or False to consider the namespaces
during the comparison.

Ignore
XPaths

A list of all the XPaths that UFT ignores during the comparison. Click theAdd
Array button to add XPath elements to ignore.

You can add as many XPath elements as needed.

Checkpoint Properties

Property Description

Are
Equal

Checks if the values of theXML String 1 andXML String 2 properties are equal.
Select True if the strings are expected to be equal, or False if they are expected to be
different.
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XML to String Activity

Relevant for: API testing only

This activity enables you to convert a selected XML string into a regular text string.

The following properties are available for this activity:

Input Properties

Property Description

Source string The source XML to convert into a string

The available checkpoint properties depend on the XML loaded in the Checkpoints section.

String to XML Activity

Relevant for : API testing only

This activity enables you to convert a selected text string into XML.

The following properties are available for this activity:

The available input properties depend on the XML loaded in the Input section.

Checkpoint Properties

Property Description

Source string The expected XML after the conversion.

Validate XML Activity

Relevant for: API testing only

This activity enables you to validate a selected XML string against a specified XML schema.

The following properties are available for this activity:

Input Properties

Property Description

XML string The XML string to validate

Import XSD to
test folder

Instructs UFT to import the file (the .xsd file) containing the transformed
XML to the folder containing your test.

XSD file The .xsd file against which the validatation is performed.
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Checkpoint Properties

Property Description

Valid Indicates whether the XML string specified in theXML string property is valid
according to the validation performed against the file specified in theXSD file
property.

Errors The expected error in the validation.

Activity-Specific Dialog Boxes
Relevant for: API testing only

Several activities provide separate dialog boxes to assist you in creating and assigning Input
property data.

This section includes:

Connection Builder Dialog Box 1720

Query Builder Dialog Box 1722

Query Designer Dialog Box 1724

Java Class Dialog Box 1727

Import from SAP/Update Dialog Box 1729

Connection Builder Dialog Box

Relevant for: API testing only

This dialog box helps you create a database connection expression for theDatabase > Open
Connection activity.
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To access Do the following:

1. Drag aDatabase > Open Connection activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Select the Input property—Connection string.

4. Click theConnection Builder button in the right side of theValue
column.

Relevant tasks "How to Execute Database Commands or Retrieve Data" on page 1624

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Connection type The type of database connection: OleDB orODBC.

Edit Connection String.

l For OleDB. Opens theMicrosoft Data Link Properties dialog
box to help you create a new string or edit an existing one.

l For ODBC. Opens the Select Data Source Name dialog box.
For details, see "Select Data Source NameDialog Box" on
page 262.
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UI Elements Description

<connection string area> An editable area for pasting in existing strings, or for editing the
connection string selected in the drop down list.

Connection string A drop down list of previously defined connection strings.

Password The password required to connect to the database. The password
is displayed in encrypted form.

Insert. Inserts a parameter representing the password at the
location of the cursor in the Connection String area.

Test Connection Checks the database connection using the string shown in the text
area. If it succeeds to connect to the database, the status
message beneath this button changes from Disconnected to
Connected.

After you test a connection, it remains open until after the test is
complete or when you close it manually using aClose
Connection step.

Connected/Disconnected The current connection status.

Query Builder Dialog Box

Relevant for: API testing only

This dialog box helps you create an SQL statement for theQuery string property of theDatabase
> Select Data activity.
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To access Do the following:

1. Drag aDatabase > Select Data activity onto the canvas.

2. Click the Input/Checkpoints tab in the Properties pane.

3. Select the Input property—Query string.

4. Click theQuery Builder button in the right side of theValue column.

Relevant tasks "How to Execute Database Commands or Retrieve Data" on page 1624

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

Query Designer. Opens theQuery Designer dialog box.

Query
string

A drop-down list of previously defined query strings.

<query
string
area>

An editable area for pasting in existing strings, or for editing the query string selected
in the drop-down list.
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UI
Elements Description

Test
Query

Tests the query against the database to which you are connected.

<query
status>

The displayed query's status. The possible values are:

l Query not executed

l Query executed successfully

l Query completed with errors

Generate
output

Automatically retrieves table information from the database when you click OK, and
sets the structure of the output in the Properties pane's Checkpoints area.

Query Designer Dialog Box

Relevant for: API testing only

This dialog box helps you design an SQL statement for:

l theQuery string property of theDatabase > Select Data activity.

l creating a new database data source in the Data Pane.
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To
access

In the Input/Checkpoints tab, for aSelect Data step:

1. Select the Input property—Query string.

2. Click theBuild an SQL query string button in the right side of theValue
column to open the "Query Builder Dialog Box".

3. Click theQuery Designer button .

In the Data Pane, when defining a new Database type data source using the "Add
New Database Data SourceWizard" on page 258:

1. In the Add New Database Data Source wizard, proceed to the second screen,
Set SQL Statement.

2. Click theQuery Designer button to the right of theSQL statement box.

Relevant
tasks

l "How to Execute Database Commands or Retrieve Data" on page 1624

l "Add a database data source" on page 235

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Table/View A drop-down list of the tables and views in the database. The tables and views
are distinguishable by different icons.

Note: The number of items shown in the list is limited to 1000. You can also
enter text in the field to display a list of relevant data sources.

Reset Query. Resets the query to its original state and discards all changes.

Group by Adds aGroupBy column to the grid, allowing you to select a groupingmethod
such as: Sum, Avg,Min,Max, Count, and so forth. It adds GROUP BY to the
SQL statement. If you select aGroupBy criteria, it also adds it to the SQL
expression.

Distinct Adds a DISTINCT term to the SQL statement, instructing the query to retrieve
only distinct record sets.
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UI Elements Description

<table/view
columns
grid>

A list of the columns in the selected table or view.

The grid contains the following columns:

l Column. The name of the column in the table or view.

l Alias. An alias name for the column, if applicable.

l Output.When enabled, it includes the column in the SELECT statement.

l Sort. Enables you to sort the results in ascending or descending order.

l Sort Order.Whenworking with multiple sorted columns, this indicates the
sorting order beginning with 1.

l Filter. Enables you to filter the results of the query, by adding aWHERE
<column_name> = <filter text> to the SQL statement.

<SQL
statement
preview
pane>
(bottom left)

A preview of the SQL statement generated by your selections.

<returned
rows pane>
(bottom
right)

The rows returned by the query.

Tip: If you enableAuto Execute, these rows display the current query
results.

Auto Execute Automatically executes the SQL statement in thePreview pane whenever you
make a change in the upper panes of the dialog box.

Tip: If you notice that the query takes a long time to execute, you can

disable this option and click theExecute query button tomanually
run it.

Execute query. Executes the query shown in thePreview pane. Use this when
Auto Execute is disabled.

Tip: If theReturned rows pane is grayed out, this indicates that the results
are not current.
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Java Class Dialog Box

Relevant for: API testing only

This dialog box enables you to configure the settings for a call to a Java class.

To access Do the following:

1. Add aCall Java Class step to the canvas.

2. In the Properties pane, click the Input/Checkpoints tab .

3. Click the Java Class button.

Relevant tasks "How to Create a Call to a Java Class" on page 1627

User interface elements are described below:

UI
Elements Description

Jar The Jar (Java Archive) file to use in the Java call.

Embed
Jar in Test

Copies the Jar file to the test's EmbeddedJavaResources folder. This allows the
test to be ported to other machines. (Due to a limitation, youmust select this check
box before you browse for the class file.)
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UI
Elements Description

Package
root

The root folder containing the classes to be called by the step.

Class file The Java class to associate with theCall Java Class step. When you click
Browse, it shows the classes in the specified .jar file.

UFT supports the following Java classes:

l Byte

l Short

l Int

l Long

l Float

l Double

l Boolean

l Date

l String

Note: TheChar class is not supported.

Additional
classpaths

Additional classpaths to associate with theCall Java Class step.

l Jar. Opens theSelect Jar File dialog box.

l Folder. Opens theBrowse for Folder dialog box to select a folder containing
the .class file.

l Add. Adds the contents of theAdditional Classpath box to the additional
classpath list.

l Remove. Removes the selected entry from the list.

System
classpath

The paths you defined in the Test Settings for system classpaths.

Tomodify this setting, click on theStart orEnd step and open the Properties
pane's General view. Modify the Test Setting's JVM > Classpath node.
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Import from SAP/Update Dialog Box

Relevant for: API testing only

This dialog box enables you to import an SAP IDoc or RFC into the Toolbox pane or update an
existing one from a new location.
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To
access

To import a new RFC or IDoc:

1. Define an SAP Connection. For details, see "SAP Connections Pane (Options
Dialog Box > API Testing Tab)" on page 568.

2. Select Tools > Import from SAP.

To update an RFC or IDoc from a different location:

1. Select the RFC or IDoc in the Toolbox pane.

2. Select Update from from the right-click menu.

Relevant
tasks

"How to Create an SAP API Test Step" on page 1638

Some user interface elements are only available when you select a specific node or if you import a
new RFC or IDoc. The user elements are:

UI
Elements Description

SAP
Connection

A drop down containing the names of the SAP connections defined in the "SAP
Connections Pane (Options Dialog Box > API Testing Tab)" on page 568 (read-
only).

Credentials The credentials to use for accessing the server:

l Default credentials for connection. Use the client and credentials defined
for the connection.

l Override connection.Manually provide client and credential information for
this import.

Search for The type of document to search for: IDOC orRFC.

Matching Thematching condition. Use an asterisk, *, as a wildcard.

Search Begins the search based on thematching conditions.

Results The IDOCs or RFCs that matched the condition.

Import
Selected

Imports the RFCs or IDocs indicated with a check mark into the Local Activities
> SAP section of the toolbox.

Update Updates the selected RFC or IDoc.
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Troubleshooting and Limitations - Activities
Relevant for: API testing only

This section describes troubleshooting and limitations for working with activities.

System Activities

l End Program. You cannot specifyWindow Title as an input method for a windowless
process, even if you are using a wildcard expression.

l End Program. If you are running on a 64-bit machine, theEnd Program activity will not be able
to terminate 64-bit applications. However, it can terminate other 32-bit applications.

Java Activities

l Call Java Class. Supports only Java primitive types.

l Call Java Class. Once you select a Java file for the call, the Java Class button is disabled. As
a result, you cannot replace or update the Java file.

Workaround:Remove the step containing theCall Java Class step and add a new one using
the new Java file.

l Call Java Class. Java code loaded by the JVM (Java Virtual Machine) cannot bemodified or
updated when the JVM is running.

Network Activities

l HTTP Request/Receiver. Nested transactions are not support ed.

Workaround: Add a new loop activity within an existing transaction. Add the new transactions
steps to the newly created loop. Make sure to set the loop iteration to 1.

l HTTP Request/SOAP Request. XML file that use XSL, are not supported.

l SOAP Request. Switching between Text andGrid views, may cause the grid to display an
element added below the Body's Any node, under the Header's Any node.

Workaround: Open the Text view to view the correct XML..

l SOAP Request. By default, UFT validates the request received in a SOAP Request step using
the SOAP 1.1 schema. If you expect your response to use the SOAP 1.2 schema, the validation
will fail.

Workaround: Import the SOAP 1.2 schema for your SOAP Request step's response body. This
schema is available with the UFT installation at <UFT installation
folder>\Addins\ServiceTest\WSImportTechnology\envelop1.2.xsd.
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Database Activities

l Nested transactions are not supported in database transaction activities.

Workaround: Add a new loop activity within an existing transaction. Add the new transactions
steps to the newly created loop. Make sure to set the loop iteration to 1.

l Databases which are supported by ODBC, but not by OLEDB, cannot be accessed by UFT.

FTP Activities

l FTP:Whenworking with FTP activities that specify paths, you need to enter the full path.

l FTP Download:When downloading from Linux servers, you cannot download an empty folder.

Load Testing Activities

l Related datamapping in a load-enabled test is not supported for the LoadRunner parameter
advance policy of Each Occurrence.

l Tests created as Business Process Testing (BPT) components, cannot be used in load testing.

l If your tests use IBM's MQ client, make sure to install theMQ client on all machines running
these tests.

l You cannot run tests containing actions or calls to other tests on a remote load generator. This
limitation does not apply when running the test on a local load generator.

l The data assignment method, Use a unique value for each Virtual User when load testing
is not supported in all environments.

IBMWebsphere MQ Activities

l Get Message from MQ Queue. TheMQGMO_MARK_SKIP_BACKOUT option is not
supported.

l Put Message to MQ Queue, Publish Message to MQ Topic. Themessage body should not
exceed 64K bytes. If it exceeds this size, the execution issues aMQRC_CONVERTED_
STRING_TOO_BIG status. This is a limitation of IBMMQ.

l MQ Steps. Automatic linking of IBMWebsphereMQ steps to themost recent Connect to MQ
Queue Manager connection, is supported only when the steps are on the same level in the
container, or if the connection step is in a parent container. If the connection step is in a leaf
container and the step using the connection is in a parent container or in another leaf, UFT does
not create an automatic link.

Workaround:Manually link to aMQManager property using the Select Link Source dialog box.

XPath Activity Checkpoints
XPath aggregate functions are not supported.
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Chapter 56: Local Activities
Relevant for: API testing only

This chapter includes:

Concepts 1734

Local Activity Overview 1734

Activity Sharing 1737

Negative Testing of Web Services 1738

Passing REST Service Properties 1738

Exposing REST Service Properties 1742

Tasks 1744

How to Import aWSDL-BasedWeb Service 1744

How to a Create a REST Service 1746

How to Send a JSON Request to a REST Service 1752

How to Receive a JSON Response from aREST Service 1753

How to Import aWeb Application Service 1754

How to Import a Network Capture File 1758

How to Import and Create a .NET Assembly API Test Step 1760

How to Perform Activity Sharing 1761

References 1764

Select WSDLDialog Box 1764

Import/UpdateWSDL from URL or UDDI Dialog Box 1766

Select Service from UDDI Dialog Box 1767

Web Services Properties Dialog Box 1769

REST Services Properties Dialog Box 1770

Add/Edit REST Service Dialog Box 1772

Import .NET Assembly Dialog Box 1774

Add Input/Output Property/Parameter Dialog Box (API Testing) 1775

Import Network Capture Dialog Box 1781

Troubleshooting and Limitations - Local Activities 1783
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Concepts

Local Activity Overview
Relevant for: API testing only

In addition to theStandard activities, you can create or import other services and activities. These
activities, displayed under the Toolbox pane's Local Activities node, areWeb Service, REST
Service, Web Application Services, .NET assembly operations, SAP IDocs/RFCs whose
contract/document or DLL you import.

You generate your own Local activities by defining or importing contract or document files. UFT
supports a number of different types of Local activities: Web Services, REST Services, Web
Application Services, NET Assemblies, and SAP. In addition, UFT also enables you to create
activities based on a network traffic capture. After you import or define at least one entry per type,
the Toolbox pane displays its type under the Local activities node.

This section includes:

l "Web Service Activities " below

l "REST Service Activities" on the next page

l "Web-Application Services" on the next page

l "Network Capture Activities" on page 1736

l ".NET Assembly Activities" on page 1736

l "SAP Activities" on page 1737

Web Service Activities
You typically begin creating a test by importing aWSDL file. This file provides a structure for the
test, since it describes the service in terms of its elements, argument values, and properties. For
details on importing aWSDL, see "How to Import aWSDL-BasedWeb Service" on page 1744.

If your service changed during development, you can use the Update tool for synchronizing the
service. For details, "Updating Services and Assemblies" on page 1853.

TheWSDL import supports both Document/Literal and RPC typeWeb services.

InDocument/LiteralWeb services, the client sends standard XML documents to the server. The
server application is responsible for mapping the server objects (properties, method calls, and so
forth) and the values in XML documents. The data is serialized according to a given schema, so it
can be validated against the schema. For Document/Literal typeWeb services, the Properties pane
displays the input and output properties in a grid, allowing you to assign values for each property
independently.

InRPC typeWeb services, theWSDL file and SOAP body contain the complete operation name,
its input and output properties, and their values. There is no schema for this type of service and it is
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not supported by theWS-I conformance standard. The Properties pane does not display the input
and output properties for RPC type services.

If your service document is unique and cannot be imported in the normal way, you can use the
SOAP Request activity to send amanual SOAP request to the server.

TheWS-I validation tool lets you validate imported services by checking their conformance with the
WS-I standard. For details, see "Validate theWSDL file - optional" on page 1745.

After you import aWeb service, the tree hierarchy displays its components in several levels:

l Level 1. Service name

l Level 2. Port number

l Level 3. Operation name

For details about importing aWeb service, see "How to Import aWSDL-BasedWeb Service" on
page 1744.

REST Service Activities
You can define REST services, their resources, andmethods. You define themetadatamanually
by modeling the service and defining your own resources andmethods. The services, resources,
andmethods are then stored as a prototype activity within your test.

After you define a REST service and its resources andmethods, UFT creates a hierarchy of
Service, Resource, andMethod, based on your definition of the REST service.

UFT provides a designer window for creating and configuring REST servicemethod activities. You
drag the RESTmethods onto the canvas, just as you would with other Toolbox pane activities.

After creating RESTmethods, you can reuse them inmultiple steps. For details, see "How to a
Create a REST Service" on page 1746.

UFT also enables you to update REST service definitions and resolve service definition conflicts
through the "Resolve RESTMethod Steps Wizard" on page 1871.

In addition, you can also define properties and parameters for your REST service at all levels of the
hierarchy. You can then pass these properties or parameters from the service and resource levels
to the resource and method levels. For details, see "Passing REST Service Properties" on page
1738.

Web-Application Services
WebApplication services provide a description of a HTTP-basedWeb application in an XML
format. This description is contained in aWeb Application Description Language (WADL) file. The
WADL file describes the resources provided by a service and themethods used to access the
service.

Like aWeb Service, you import aWeb application service into UFT. The resources andmethods
are then displayed in a hierarchy like a REST service, in a Service, Resource, andMethod
hierarchy.
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The URL for aWeb application is defined in the XML of theWADL file. You can, however, define
other HTTP properties and add input and output parameters for an activity's methods.

Like REST services, you can define parameters and their values at all levels of theWeb Application
hierarchy. You can then pass these parameter values to lower levels of the hierarchy.

The importedWeb Application servicemethods serve as a prototype for test steps. You canmodify
the parameter values of amethod after dragging amethod to the canvas.

Network Capture Activities
Network capture activities enable you to create test steps by recording network traffic. Importing a
network capture file provides you with another way to create test steps measuring the network
activity of your application orWeb service. Instead of using the standard Network activities to
design steps for your application's network processes, you can perform a network capture and use
the captured information as a basis for your test.

Using a network capture program, you capture the network traffic for your application orWeb
service. The network capture program then saves the file containing the network traffic. You then
import this file into UFT.

UFT takes the TCP network stream and creates test steps based on the request and response
information for each TCP stream in the network traffic capture.

Based on the request and response information, UFT creates a test activity differently:

l If the TCP stream request and response is compatible with or matches an already existingWeb
service, UFT creates aWeb Service step.

l If the TCP stream request has a SOAP request structure, UFT creates aSOAP Request step.

l If the TCP stream is not similar to an existingWeb servicemethod or a SOAP request
transaction, UFT creates aHTTP Request step.

These activities are not stored in the Toolbox pane. If you need to reuse the steps in your test, you
can reimport the network capture file or cut and paste the existing steps into your test.

For task details, see "How to Import a Network Capture File" on page 1758.

.NET Assembly Activities
The .NET importer lets you create activities for testing APIs in the form of .NET assemblies. You
can interface with the types defined in the assembly.

You begin by importing the .NET assembly into your test. The Toolbox pane displays the assembly
as an activity. You drag the .NET activity on to the canvas as you would with any other activity.

You can define input and output properties and link them to other steps within your script. For
example, you can design a test that retrieves an object through the .NET assembly. This object can
be an input property for aWeb service step.

When you import a .NET assembly, it saves a local copy of the assembly with the test. This makes
the test portable and allows you to copy it to another machine. If the assembly calls other
assemblies, the test may not run until you copy the additional assemblies to the new machine.
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For task details, see "How to Import and Create a .NET Assembly API Test Step" on page 1760.

For user interface details, see "Import .NET Assembly Dialog Box" on page 1774.

SAP Activities
The SAP importer lets you create SAP activities in the Toolbox pane, by importing SAP
Intermediate Documents (IDoc) and Remote Function Calls (RFC).

These activities can be useful for testing the SAP server response in several common scenarios:

l Sending an IDoc to an SAP server, and confirming that the IDoc was sent

l Checking an IDoc's status on the SAP server

l Calling an RFC in SAP and ensure that it returned the expected results

These activities can be also be useful when upgrading a system to verify that the integration
patterns are still functional, such as Aggregator, Enricher, Router, Translation, Bridge, Splitter, and
so forth.

First you define one or more SAP Connections in the SAP Connections pane in the Options dialog
box (Tools > Options > API Testing tab > SAP Connections node). For details, see "SAP
Connections Pane (Options Dialog Box > API Testing Tab)" on page 568.

Once the connection is established, you can search for an IDoc or RFC and import them as
activities into the Toolbox.

Once they are in the Toolbox, you can add them to a test or action and assign property values as
with all other steps.

For task details, see "How to Create an SAP API Test Step" on page 1638.

For user interface details, see "Import from SAP/Update Dialog Box" on page 1729.

Activity Sharing
Relevant for: API testing only

The activity sharing feature enables you to save locally stored services to a repository, so that they
will be available for other tests.

You can specify a repository on the file system or in ALM. The next time you create a test, you can
access the service's activities from the repository instead of reimporting or recreating them.

If the resource (WSDL or REST service) becomes unavailable, the canvas displays alerts on the
steps that use the resource. If you run the test when its resource is not available from its original
source, it uses a copy of the test stored in its cache. By clicking the alert, you can reload the steps
when the resource becomes available again.

The Toolbox pane detects version updates for activities stored in a repository. When it detects a
discrepancy between the step and the Toolbox pane activity, it displays an alert for the step. By
clicking the alert, you can automatically update the resource from its source.
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Negative Testing of Web Services
Relevant for: API testing only

When performing a functional test for yourWeb Service, you should approach the testing in a
variety of ways. Themost common type of testing is calledPositive Testing—checking that the
service does what it was designed to do.

In addition, you should perform Negative Testing, to confirm that the application did not perform a
task that it was not designed to perform. In those cases, you need to verify that the application
issued an appropriate error—a SOAP Fault.

To illustrate this, consider a form accepting input data—you apply positive testing to check that
yourWeb Service has properly accepted the name and other input data. You apply negative testing
tomake sure that the application detects an invalid character, for example a letter character in a
telephone number.

When your service sends requests to the server, the server responds in one of the following ways:

l SOAP Result. A SOAP response to the request.

l SOAP Fault. A response indicating that the SOAP request was invalid. Negative Testing
applies only to SOAP faults.

l HTTP Error. AnHTTP error, such as Page Not Found, unrelated toWeb Services.

UFT can check for a standard SOAP result or a SOAP fault response. For example, if yourWeb
Service attempts to access aWeb page that cannot be found, it will issue a 404 HTTP error. Using
negative testing you indicate that you expect a SOAP fault. In this case, the test run will fail if the
service accesses a validWeb page.

The Properties pane lets you provide values for the SOAP fault header and body. You can enter
faultcode, faultstring, and faultactor values as well as custom properties usingAny type
parameters. Using the Checkpoint mechanism, you can validate these values and view the results
in the Run Results Viewer.

For details on setting up the SOAP fault values, see "SOAP Fault Tab (Properties Pane - API
Testing)" on page 428.

Passing REST Service Properties
Relevant for: API testing only

When creating or editing a REST service, youmay want to define the value of a URL property or a
custom input or output property at the service or resource level in order to make this property or
parameter available for all resources andmethods included in the service or resource. For example,
if your REST service resources andmethods are all referencing the sameURL prefix during run
time, you can define the value of URL property at the service level of the REST service and pass
the URL property value to all its resources andmethods.
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You can also define custom input and output property names and values at all levels of the
hierarchy and pass these input and output properties and their values through the REST service
hierarchy. For details on creating custom input and output properties, see "Define custom
properties - optional" on page 1748.

After a URL property value is defined at a higher level, you can define other (relative) additions to
the URL property value for any of the resources andmethods below it. These adjusted relative URL
values are then concatenated to the URL property value that was received from higher levels of the
hierarchy and the adjusted values are passed to all levels below it. For example, if you add a URL
property value at the service level, you can append relative URL paths for a selected resource or
method. The URL property value passed from the service level is then concatenated with the
relative URL property value added at the resource or method levels.

Note: You cannot modify URL property values passed down from a higher level of the REST
service hierarchy. You can only add to them with a relative URL value.
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After you add additional relative URL property values at lower levels of the hierarchy, such as at the
resource or method level, youmust assure that the full URL is a proper URL. For example, if you
define the URL property value at the resource level with http://, the relative URL property value
appended at themethod level should not also use a http:// prefix.

Example

You define a URL property value for the REST service at the service (top)
 level: http://flights.api.com. This value is then passed to any resources andmethods within
this REST service.

You also create a resource for this service, called Flight Reservation. You define the relative
URL value as /reserve. This relative URL property value is then concatenated with the
URL property value passed from the service level to create a URL for the
resource: http://flights.api.com/reserve. This URL property value can also pass to any
methods created for the resource.

You then create amethod for the Flight Reservation resource, calledGetFlights and define the
relative URL property value for this method as /getflights. This value is then further
concatenated with the URL passed from the resource tomake a complete URL for themethod:
http://flights.api.com/reserve/getflights.
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The example below shows the URL property value passed from the service level
(http://api.flights.com) and the relative URL property value defined at the resource level (/reserve),
with the relative URL property value for themethod (/getflights) also defined. These URL parts are
then concatenated in theURL property field to make the complete URL for themethod.

These properties and custom input or output properties then serve as a prototype template for the
REST service, and you can edit the URL property values or custom input and output property
values after dragging themethod activities in the canvas.

Note: The relative URL is not displayed on the REST method when it is included in a test in the
canvas. Only the full, concatenated URL for themethod displayed in the Add REST Service
dialog box is displayed in the Properties pane for the selectedmethod.
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Exposing REST Service Properties
Relevant for: API testing only

Whenworking with REST servicemethods saved in API tests created in UFT 11.51 or earlier or
Service Test 11.51 or earlier, the Properties pane enables you to expose input and output HTTP
properties. Exposing HTTP properties means that youmake them available at the RESTmethod
wrapper level instead of just the inner HTTP level. You can expose properties that are available
from theGeneral, Input/ Checkpoint, HTTP, andMultipart views.

Note: You can only expose properties if you are working withAPI tests created inUFT 11.51 or
earlier or Service Test 11.51 or earlier.

The following example shows the shortcut menu item, Expose as an input property. This option
prompts you to provide a name for the property as it should appear in the REST wrapper level.

The property, HTTP method, will be available in the RESTmethod wrapper. To see the exposed
property, select the RESTmethod wrapper in the canvas —not the inner HTTP Request.

Note:

l When exposing a property with incoming links, the links are redirected to the newly created
property.
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l When exposing a complex property, the new property will be created as aString type.

For user interface details, see "New Exposed Property Dialog Box" on page 1850.
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Tasks

How to Import a WSDL-Based Web Service
Relevant for: API testing only

This task describes how to import aWSDL file into your test.

This task includes the following steps:

l "Prerequisites" below

l "Open the Import WSDL dialog box" below

l "Select a source " below

l "Set connection settings for URL/UDDI imports - optional" on the next page

l "Mark theWSDL as a server response - optional" on the next page

l "Complete the import" on the next page

l "Validate theWSDL file - optional" on the next page

l "Configure SOAP Fault information - optional" on page 1746

1. Prerequisites
If you intend to import aWSDL stored on ALM, the ALM project to which you are connecting
must have the Service Test Management extension enabled. For details, see the "ALM
Connection Dialog Box" on page 737.

2. Open the Import WSDL dialog box
n To import aWSDL from the file system or ALM, click > Import WSDL

from File or ALM Application Component. For details, see the "Select WSDLDialog
Box" on page 1764.

n To import aWSDL from aWeb site or UDDI repository, click > Import
WSDL from URL or UDDI.

o For a URL, select Import from: URL

o For a UDDI, select Import from: UDDI

For details, see the "Import/UpdateWSDL from URL or UDDI Dialog Box" on page 1766.

3. Select a source
n For File System orALM Application Components imports, click the appropriate button in
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the left pane. Navigate to theWSDL in the file system or the ALM repository.

n For aURL import, click theBrowse button adjacent to theAddress field. This opens a
browser window. Navigate to theWSDL and close the browser. This automatically places
the URL in theAddress field.

n For aUDDI import, click theBrowse button adjacent to theAddress field. This opens the
Select Service from UDDI dialog box. Specify a UDDI address and select the service to
import. For details, see the "Select Service from UDDI Dialog Box" on page 1767.

4. Set connection settings for URL/UDDI imports - optional
For URL or UDDI imports, if yourWSDLmust be accessed through a secure server or proxy
machine, click Advanced Settings to expand the dialog box. Enter the authentication
information or the proxy server details.

5. Mark the WSDL as a server response - optional
You canmark the importedWSDL as a server responsemethod. This is useful when working
with asynchronous Web services. Click Advanced Settings to expand the dialog box and
select the Import as server option. For details about working with asynchronous services, see
"Asynchronous Services" on page 1928.

6. Complete the import
Click OK. If the import succeeds, the Toolbox displays the service, its ports, and operations
under theWeb Services node. The Toolbox pane differentiates betweenDocument/Literal and
RPC encoded services with different icons.

7. Validate the WSDL file - optional
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To check theWSDL's compliance with theWS-I standard, right-click the service and select
Validate WS-I Compliance from the shortcut menu. TheOutput window shows theWS-I
validation results. These validations apply only toDocument/Literal type services, but not
RPC.

8. Configure SOAP Fault information - optional
To apply negative testing to aWeb service:

a. Open theSOAP Fault tab .

b. Select Fault is expected.

c. Provide SOAP Fault checkpoint values for the negative testing:

o Towork In theXML layout: Expand the SOAP nodes and defineAny elements for the
SOAP Header and Body. If relevant, provide values for faultcode, faultstring, or
faultactor.

o Towork withXPath expressions: Click theXPath tab and use the Add button to add
new XPath entries. Copy the XPATH entry into the cell.

For details, see the "SOAP Fault Tab (Properties Pane - API Testing)" on page 428.

How to a Create a REST Service
Relevant for: API testing only

This task describes how to set up a REST service with its resources andmethods. You define the
request body and properties in order to create a prototypemethod that could be reused by multiple
test steps.

This task includes the following steps:

l "Prerequisite " on the next page

l "Open the REST service designer" on the next page

l "Name the REST service" on the next page

l "Add a resource" on the next page

l "Add amethod" on the next page

l "Set the General properties" on the next page

l "Set the URL property values" on page 1748

l "Define themethod's HTTP properties" on page 1748
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l "Define custom properties - optional" on the next page

l "Enter the request body directly - optional" on the next page

l "Link the body request to a data source - optional" on page 1749

l "Test themethod" on page 1750

l "Add themethod to the toolbox" on page 1750

l "Use the REST activity" on page 1751

l "Expose input and output properties - optional (for API tests created in previous versions)" on
page 1751

l "Edit the prototype service" on page 1751

l "Resolve conflicts between the prototype and the test step - optional" on page 1752

l "Share the service - optional" on page 1752

1. Prerequisite
Study the structure of the REST Service body and determine which resources andmethods
you need to define.

2. Open the REST service designer

Click theAdd REST Service toolbar button . The Add REST Service dialog box opens.
For details, see the "Add/Edit REST Service Dialog Box" on page 1772.

3. Name the REST service
Click on theNew Service node and provide ameaningful name for the service in the left pane.

4. Add a resource

Click theAdd Resource toolbar button to add a resource to the REST service. Click on
theREST Resource node and provide ameaningful name for the resource.

5. Add a method

Click theAdd Method toolbar button to add amethod. Click on theMethod node and
provide ameaningful name for themethod.

6. Set the General properties

a. In the right pane's Properties list, open theGeneral tab.

b. Enter values for the properties. For details, see the "General Tab (Properties Pane - API
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Testing)" on page 413.

7. Set the URL property values
a. In the REST Service editor, select a REST service, resource, or method.

b. In the General tab, enter the URL property value:

o If you are entering a URL property value for a REST service, enter the URL prefix in the
URL property row, beginning with a http://

o If you are entering a URL property value for a REST resource or method, enter the URL
property value in the Relative URL property row.

Note: If you enter a URL property value for the service or resource of your REST
service, the URL property values are passed to all resources or methods included in
the service or resource. For details, see "Passing REST Service Properties" on page
1738

8. Define the method's HTTP properties
a. Select a REST servicemethod.

b. In the REST service editor's right pane,click theHTTP Input/Checkpoints tab.

c. For eachmethod, modify theHTTP method andHTTP version.

d. Use the plus sign in theRequestHeaders parent node to add name and value pairs for
the request header array.

For details, see the "Parameters/Checkpoints Tab (Properties Pane - API Testing)" on
page 417.

9. Define custom properties - optional
Formethods that require input, such as PUT orPOST, you can add custom input properties.
For methods that provide an output such as GET, you add the required output properties. To
create these properties:

a. In the right pane's Properties list, click theCustom Input/Checkpoints tab .

b. Expand the plus button and select Add Input/Output Property.

c. Provide a name, data type, and description (optional) for each property.

d. Enter the property values in theValue column.

10. Enter the request body directly - optional
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This step describes how to enter the request body directly. (For details on linking to a data
source, see the next step.)

a. Return to the design document for the REST service and copy the Request body onto the
clipboard.

b. In the right pane of the Add REST Service window, open theHTTP tab. Make sure the
Body type in the drop down is set to Text, and click within theBody section. Press
CTRL+V to paste the contents of the request into the pane. Make sure that there are no
extra spaces before or after the body text.

c. Modify the element values within the XML body as required.

11. Link the body request to a data source - optional
This step describes how to enter the Request body through a data source. (For details on
entering the Request body directly, see the previous step.)

a. Return to the design document for the REST service and copy the request body to the
clipboard.

b. In the right pane of the Add REST Service dialog box, open theHTTP tab . Make sure the
Body type in the drop down is set to Text, and click within theBody section.

c. Click the Link Body button to the right of the pane, to open the Select Link Source
dialog box. For details, see "Select Link Source Dialog Box (API Testing)" on page 1840.

d. In the Select Link Source dialog box, click Custom Expression to expand the dialog box.
Paste the clipboard contents, the Request body, into theExpression area.
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e. In theExpression area, highlight the value of the element you want to link. In the upper
pane, double-click on the custom property you defined earlier in the properties list. The
property is now linked to a value.

f. Themodified expression appears in theExpression area. In the following example the
custom Class property is linked toClass element in the REST document.

<Class>{Step.InputProperties.RestMethod.Class}</Class>

g. Click OK. UFT places the data in theBody area.

12. Test the method

Click the RunMethod button on the toolbar to test themethod with its property values.
Note the results in the lower section of the window. If something needs to bemodified, do so at
this point.

13. Add the method to the toolbox
Click OK in the Design REST Service dialog box. UFT adds the REST service along with its
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resources andmethods to the Toolbox pane, under the Local Activities category.

14. Use the REST activity
You have now created a prototype for a RESTmethod, complete with input parameters and
HTTP information. You can now drag the activity, whose primary properties are already
defined, onto the canvas. A wizard helps you resolve any conflicts between the original
prototype and a test step. For details, see "How to Resolve Conflicts in a REST Service Test
Step" on page 1860.

15. Expose input and output properties - optional (for API tests created in
previous versions)
You can forward built-in HTTP properties to the RESTmethod wrapper. This is useful for
making specific HTTP properties available at the wrapper level.

Note: If you created a REST method in UFT 11.52 or Service Test 11.52 or later, all REST
properties are incorporated into the REST activity step itself without a wrapper.

a. Double-click a RESTmethod from the Toolbox pane to add it to the canvas. Expand the
method to show theHTTP Request frame.

b. Click in theHTTP Request frame. Select a property in the Properties pane and select
Expose as Input Property orExpose as Output Property from the right-click menu.

c. Provide a name for the property in the New Exposed Property dialog box.

d. Click the RESTmethod wrapper in the canvas, and view the newly exposed property in the
Properties pane's Custom Input/Checkpoints tab .

For details, see "Exposing REST Service Properties" on page 1742.

16. Edit the prototype service
To edit a REST servicemethod's properties, select it in the Toolbox pane and chooseEdit
Service from the right-click menu. For details, see the "Add/Edit REST Service Dialog Box" on
page 1772.
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17. Resolve conflicts between the prototype and the test step - optional
If you created a test step using a template RESTmethod and then changed the template
method, the canvas adds an alert icon adjacent to the affected steps. Click the alert icon to
open the Resolve RESTMethod wizard to resolve any conflicts. For details, see the "Resolve
RESTMethod Steps Wizard" on page 1871.

18. Share the service - optional
To add a REST service to the test repository, to make it available for other tests, share it.
Select the parent service node in the Toolbox and chooseMove to from the right-click menu.
For details, see "How to Perform Activity Sharing" on page 1761.

For an example of creating a REST Service with data driving and data tables, see theHP
Tutorial for UFT - API Testing.

How to Send a JSON Request to a REST Service
Relevant for: API testing only

This task describes how to send a JSON request for a REST service.

This task includes the following steps:

l "Set the HTTP properties" below

l "Prepare to load the request body" below

l "Load the request body" on the next page

l "Modify the JSON body - optional" on the next page

l "Data drive or link to fields - optional" on the next page

Note: The following tasks show how to send a single JSON request. To create a reusable
model, create a prototype. For details, see "How to a Create a REST Service" on page 1746.

1. Set the HTTP properties

Note: If you are working with an API test created in UFT 11.51 or earlier or Service Test
11.51 or earlier, youmust expand the REST activity's wrapper and enter these properties
in the HTTP Request step found inside the REST activity wrapper.

In the Properties pane's Input/Checkpoints tab , set the destinationURL and theHTTP
method, usually POST orPUT.

2. Prepare to load the request body
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Open the Properties pane's HTTP view . Select aBody type JSON.

3. Load the request body
Click the Load JSON button and locate the .json file. Click OK.

4. Modify the JSON body - optional
If you intend to dynamically assign values to the JSON body from a data source, you need to
add escape characters. Open the Text view of the JSON body and add the escape character, \,
for each occurrence of a square or curly bracket ({, }, [, and ]). Do not use an escape character
for link expressions enclosed by curly brackets. For example:

\{"results":
\[
\{"name": "John", "id": 873829904, location: "NY"\},
\{"name": "Linda", "id": 726371109, location: "LA"\},
\{"name": "Mike", "id": 711029345, location: "NY"\},
\]
\}

When no links are used, this is not required.

5. Data drive or link to fields - optional
To data drive or link to specific JSON fields, highlight the value in the body text, click the Link
Body button , and select a data source. For details, see "Select Link Source Dialog Box
(API Testing)" on page 1840.

How to Receive a JSON Response from a REST Service
Relevant for: API testing only

This task describes how to receive a JSON response from aREST service. All HTTP Request
activities are capable of receiving JSON responses.

This task includes the following steps:

l "Add a request header - optional" on the next page

l "Add checkpoints - optional" on the next page

Note: The following tasks show how to receive a single JSON request. To create a reusable
model, create a prototype. For details, see "How to a Create a REST Service" on page 1746.
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1. Add a request header - optional

Note: If you are working with an API test created in UFT 11.51 or earlier or Service Test
11.51 or earlier, youmust expand the REST activity's wrapper and enter these properties
in the HTTP Request step found inside the REST activity wrapper.

If your server requires you to specify JSON during content negotiation, you need to set the
request header. In the Properties pane's Input/Checkpoints tab , click the plus sign to add a
RequestHeader array element. Add a custom request header namedAccept with the value
application/json.

2. Add checkpoints - optional
If you require checkpoints to validate the response:

a. Open the Properties pane's HTTP tab . Click in the lower section of the tab, in the
checkpoint area.

b. To validate against regular expressions, set theBody type to Text. Add regular
expressions for each value that you want to validate.

c. To validate against a JSON response, set theBody type set to JSON. Click Load JSON
and locate the .json file with the expected values.

How to Import a Web Application Service
Relevant for: API testing only

This task describes how to import aWeb Application service (WADL) into your test.

This task includes the following steps

l "Prerequisite " on the next page

l "Import theWADL document" on the next page

l "Edit the service's properties - optional" on page 1757

l "Use theWADL service's methods" on page 1757

l "Share the service - optional" on page 1757
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1. Prerequisite
Before importing, study the structure of yourWADL document, as specific elements from the
document are imported into theWADL hierarchy inside UFT.

<?xml version="1.0" encoding="utf-8" ?>
<application xmlns="http://wadl.dev.java.net/2009/02">
<resources base="http://example.com/api">
<resource path="books">
<method name="GET"/>
<resource path="{bookId}">
<param required="true" style="template" name="bookId"/>
<method name="GET"/>
<method name="DELETE"/>
<resource path="reviews">
<method name="GET">
<request>
<param name="page" required="false" default="1" style="query"/>
<param name="size" required="false" default="20" style="query"/>
</request>
</method>

<resource path="{index}">
<method name="GET" id="get index"/>
<param name="index" style="template"/>

</resource>
</resource>
</resource>
</resource>
<resource path="readers">
<method name="GET"/>
</resource>
</resources>
</application>

For details onWADL elements, see http://www.w3.org/Submission/wadl/.

2. Import the WADL document
In the toolbar, click on theAdd REST Service button and select Import WADL or select
Tools > Add REST Service > Import WADL. In the ChooseWADL file dialog box, navigate
to the directory in which theWADL is saved, and select theWADL file.

Note: You can import only WADLs saved on the file system.
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TheWADL service is imported to the Local Activities node of your test with its resources and
methods. TheWADL service, resource, andmethod hierarchy is created based on the XML
description provided in theWADL file, described below:

XML Element UFT WADL Activity Hierarchy Element

doc xml:lang="en"
title="RestService"

WADL service name

resource path="<resource
name>"

WADL resource

Note: If multiple resources have the same name,
UFT numbers the resources sequentially to
differentiate between resources.

method name="<method
name>"

WADL method

n UFT assigns theWADL hierarchy name using the
following criteria:

n If a method name has an "id" attribute, the name is
taken from the value of the "id" attribute.

n If a method name does not a have an "id" attribute, then
the name is defined as the value of the "method name".
For example, if the "method name" is defined as
<"method name="GET"/>, UFT defines themethod
name in theWADL hierarchy as GET Method.

Themethod name always contains the HTTP method
as part of its value. This method (GET, POST, PUT,
DELETE, TRACE, OPTIONS, or HEAD is also used
as the HTTP method in the HTTP tab of the
WADL service. For details on the HTTP tab, see
"HTTP Tab (Properties Pane - API Testing)" on page
414

Note: If there aremultiple methods of the same
name using the default values, then themethods
are defined with increasing sequential numbers.
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param name="<parameter
name>"

WADL resource or method parameters. These
parameters are displayed until the Custom
Input/Checkpoints tab in the Edit REST Service dialog
and in Input/Checkpoints tab for methods on the canvas.

If a "param name = <name>" string also contains a
"default=<value>" string, the value defined in the XML is
displayed with the parameter.

resources
base="http://example.com/api"

WADL Service URL. This is displayed on the HTTP tab
for the service.

The URL is also passed to all resources andmethods
included in the service. For details, see "Passing REST
Service Properties" on page 1738.

Note: You cannot change the URL property for an
individual resource or method.

3. Edit the service's properties - optional
To edit theWADL service properties, right-click the service name in the Toolbox and select
Edit Service.

In the Edit REST Service dialog box, you can define general properties, parameters, HTTP
properties, and HTTP request and response information for the service, resources, and
individual methods. For details, see "How to a Create a REST Service" on page 1746.

For user interface details, see "Add/Edit REST Service Dialog Box" on page 1772.

4. Use the WADL service's methods
After importing aWADL, you have created a prototype for the service, with methods,
HTTP properties, and parameters. Drag amethod to the canvas to use it in your test.

Note: You can edit all method properties after dragging the activity to the canvas.

Caution: If youmodify the service's properties after dragging amethod to the canvas, the
properties of your service will differ from the service's prototype (as defined in the
Toolbox). The Resolve REST Steps Wizard is not available to resolve differences for
WADL servicemethods.

5. Share the service - optional
To add aWADL service to the test repository, to make it available for other tests, share it.
Select the parent service node in the Toolbox and chooseMove to from the right-click menu.
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For details, see "How to Perform Activity Sharing" on page 1761.

How to Import a Network Capture File
Relevant for: API testing

This task describes how to import a network capture file to your test to create test steps.

This task includes the following steps:

l "Create a capture file" below

l "Prerequisite - study the structure of your network capture file" below

l "Import the network capture file" on the next page

l "Edit the step properties - optional " on the next page

l "Run the step - optional" on the next page

1. Create a capture file
Use a network capture program (also known as a sniffer) to create a capture file containing a
log of network activity for your application orWeb service.

Note: It is strongly recommended that you capture network traffic only on your application
orWeb service during the network capture session to prevent the creation of invalid or
unneeded activities in your test. Many network capture tools capture all network traffic on
the computer where they are installed, including network traffic unrelated to your
application orWeb service.

2. Prerequisite - study the structure of your network capture file
The structure of your file depends on the type of file you import. UFT supports .libpcap/pcap
and .har network capture files.

n For .pcap files: UFT creates test steps based on the TCP network traffic. You can see the
input and checkpoint values by viewing the TCP request and response information for a
TCP stream.

Note: Youmust use a network capture program to view the network capture traffic for
your .pcap file.

n For .har files: Using a text editor, you can view the Request and Response information in
the JSON hierarchy of the file.
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Note: UFT creates a test activity based on its recognition of the TCP stream in the
following ways:

n If UFT recognizes the TCP stream as being compatible with or matching an already
existingWeb Servicemethod, UFT creates aWeb Service step.

n If UFT recognizes the TCP stream response as a SOAP network transaction, it creates
aSOAP Request step.

n If UFT does not recognize the TCP stream as being similar to an existingWeb Service
step or a SOAP request network transaction, it creates anHTTP Request step.

3. Import the network capture file
a. In UFT, with an API test open or selected, select Tools > Import Network Capture File.

The "Import Network Capture Dialog Box" (described on page 1781) opens.

b. In the Import Network Capture Dialog Box, select the file containing your network capture
data.

Note: UFT supports only .pcap and .har network capture files.

c. View the file details in the Info Pane of the Import Network Capture Dialog Box. If there are
errors in your file, return to your network capture tool and fix the errors.

d. If you want UFT to create checkpoints for your test steps based on the response sections
of the network capture file, select theCreate checkpoints from response option.

e. Click Import. If your network capture file contains many transactions, UFT displays the
progress of your import.

Note: To stop an import, click Cancel in the import progress window. All test steps
created prior to your cancellation are removed from the test.

UFT creates Web Service test steps, SOAP Request test steps, or HTTP Request test
steps for each of the transactions contained in your network capture file.

4. Edit the step properties - optional
In the Properties pane, select the properties you want to edit and enter the values as needed.
For details on populating property values, see "How to Assign Data to API Test/Component
Steps" on page 1819.

5. Run the step - optional
To verify that the step runs correctly after the import and step creation, right-click the step in
the canvas and select Run Step.

User Guide
Chapter 56: Local Activities

HP Unified Functional Testing (12.00) Page 1759 of 2274



You can view the step results and the request and response information for the test step in the
Run Step Results pane.

How to Import and Create a .NET Assembly API Test Step
Relevant for: API testing only

This task describes how to create a test step for verifying the functionality of a .NET assembly.

This task includes the following steps:

l "Prerequisite " below

l "Open the Import .NET Assembly dialog box" below

l "Select a GAC assembly - optional" below

l "Import a .NET assembly" below

l "Add a .NET assembly step" on the next page

l "Add properties - optional" on the next page

l "Customize the code - optional" on the next page

1. Prerequisite
Prepare a .dll assembly file and store it in a location accessible from your machine.

2. Open the Import .NET Assembly dialog box

Click the Import .NET Assembly button on the toolbar. For user interface details, see
"Import .NET Assembly Dialog Box" on page 1774.

3. Select a GAC assembly - optional
Each computer where the common language runtime is installed has amachine-wide code
cache called the GAC (Global Assembly Cache). TheGAC stores assemblies specifically
designated to be shared by several applications on the computer.

In theGAC tab, select one or more GAC assemblies and click Select to add them to the
Selected References list.

4. Import a .NET assembly
Click the .NET Assembly Browser tab. Locate the assembly .dll or .exe file. Select the file
and click Select to add it to theSelected References list. Click OK to add the .NET
assemblies to the Toolbox pane.
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Tip: After importing the .NET assembly, you should save the test. Not saving the test
leads to unexpected behavior with the autocomplete functionality when adding an event
handler to a .NET assembly test step.

5. Add a .NET assembly step
Expand the .NET Assemblies category in the Toolbox pane and drag a .NET activity onto the
canvas.

6. Add properties - optional
a. In the Properties pane's Input/Output tab, click theAdd Input/Output Property button

to define new input and output properties.

b. In theAdd Input/Output Property dialog box, specify a property name and data type.

o To add a simple type property, select a type from the drop down.

o To add an advanced type, click Advanced and select a type. All .NET types and .dll
files referenced by the test, and all types from the imported assemblies, are available.
To filter the types, enter a keyword into the Type field.

c. Click OK to add the property. Repeat this for all of the required input and output properties.

7. Customize the code - optional

In the Properties pane, open theEvents tab . Double-click in the ExecuteEvent's Handler
column. The TestUserCode.cs tab opens.

Edit the Todo area. You can access input and output properties that you defined earlier, using
autocompletion.

The comments indicate the syntax to use for accessing the properties. For example:

/// Use this.CodeActivity4 to access the CodeActivity4
/// Activity's context, including input and output properties.
public void CodeActivity4_OnExecuteEvent(object sender, STActivityBaseEventArgs args)
{
this.CodeActivity4.Input.Property1...
...
}

How to Perform Activity Sharing
Relevant for: API testing only

This task describes how to save activities to a repository, update them, and view their properties.
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This task includes the following steps:

l "Connect to ALM" below

l "Set up the repository paths" below

l "Import aWSDL or create a REST service" below

l "Move the activity to a repository" below

l "View the service properties - optional" below

l "Refresh the activity - optional" on the next page

l "Update the activity - optional" on the next page

l "Add the activity to a new test - optional" on the next page

1. Connect to ALM
If you want to work with a repository on ALM, connect to the desired ALM server. For details,
see the "ALM Connection Dialog Box" on page 737.

2. Set up the repository paths
a. Select Tools > Options > API Testing tab > General node.

b. In the Activity Repositories section, click theBrowse button and navigate to the location in
the file system or in ALM.

c. Click OK.

3. Import a WSDL or create a REST service
Import aWSDL file or create a REST servicemethod. The Toolbox pane shows the services in
the Local Activities node. By default, the test stores these activities in its
EmbeddedJavaResources subfolder.

4. Move the activity to a repository
Right-click the service node, and selectMove to > File System Activities orALM
Activities. This moves the service from Local Activities to File System Activities orALM
Activities in the Toolbox pane. The service is also removed from the test's
EmbeddedJavaResources subfolder and placed in the repository folder. The next time you
create a test, these activities will be accessible from the File System Activities orALM
Activities nodes.

5. View the service properties - optional
Right-click the service's parent node, and select Properties. The Properties window shows
the service's significant properties. For details see "Web Services Properties Dialog Box" on
page 1769.
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6. Refresh the activity - optional
To reload theWSDL from its stored location, right-click the service node, and select Refresh

. This is useful in cases when theWSDL is stored in a shared location andmay have been
updated by another user.

7. Update the activity - optional
To reimport theWSDL from its original location, for example to revert back to the original
version, right-click the service node and select Update WSDL, or click theUpdate WSDL

button in the Toolbox pane .

8. Add the activity to a new test - optional
Open a new test. Expand the File System Activities orALM Activities node, select the
desired service or method, and drag it onto the canvas.

You can also remove shared activities from the toolbox and re-add them. For details, see
"Toolbox Pane User Interface (API Testing) " on page 514.
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References

Select WSDL Dialog Box
Relevant for: API testing only

This dialog box enables you to import WSDLs from a file system or Service Test Management, the
ALM extension for working with application components.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Select Import WSDL > Import WSDL from File or ALM Application
Component.

Relevant
tasks

"How to Import aWSDL-BasedWeb Service" on page 1744

HP Unified Functional Testing (12.00) Page 1764 of 2274



The following elements are included:

UI Elements Description

File System Displays WSDLs in the file system.

ALM
Application
Components

Displays WSDLs in the ALM repository.

Note: Available only if there is an open connection to ALM with the
Service Test Management extension.

Import as
Server
Response

Imports theWSDL as a server response. Its methods will be server
responses—not requests. This is useful for asynchronous typeWeb
services.

File name The contract name:

l File System. The file name of theWSDL.

l ALM Application Components. The name of the application component
or service.

Files of type The document type:WSDL extension orAll files.
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Import/Update WSDL from URL or UDDI Dialog Box
Relevant for: API testing only

This dialog box enables you to import WSDLs using a URL or UDDI or update an existingWSDL
from a new location.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the Solution Explorer, select an API test or component.

2. Select Import WSDL > Import WSDL from URL or UDDI.

Relevant tasks "How to Import aWSDL-BasedWeb Service" on page 1744
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The following elements are included:

UI Elements Description

Browse.

l ForURL imports: Opens a browser to allow you to navigate to a URL.

l ForUDDI Imports: Opens the "Select Service from UDDI Dialog Box".

Address The URL or UDDI path of theWSDL.

Advanced
Settings

Expands the dialog box to show the authentication and proxy settings.

Use
authentication
settings

The authentication settings by which to access theWSDL: Username and
Password.

Use proxy
settings

The authentication settings for the proxy server hosting theWSDL: Server,
Port, Username, andPassword.

Import as
Server
Response

Imports theWSDL as a server response. Its methods will be server
responses—not requests. This is useful for asynchronous typeWeb services.

Select Service from UDDI Dialog Box
Relevant for: API testing only

This dialog box enables you to select and import WSDLs from aUDDI (Universal Description,
Discovery, and Integration) server.
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To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the Solution Explorer, select an API test or component.

2. Select Import WSDL > Import WSDL from URL or UDDI.

3. Select Import from: UDDI.

4. Click the button.

Relevant tasks "How to Import aWSDL-BasedWeb Service" on page 1744

See also "Import/UpdateWSDL from URL or UDDI Dialog Box" on page 1766

The following elements are included (unlabeled UI elements are shown in angle brackets):

UI
Elements Description

UDDI
Address

The name or IP address of the UDDI server inquiry API.

Example: http://mysite.com:8080/uddi/inquiry

Version The UDDI version.

<list of
services>

A list of the services that match the filter criteria. The grid shows the following
information:

l Service Name

l Description

l Service Contract

l Service ID

Service
Name

A string in theWSDL name by which to filter the list.

Search Retrieves the list of services that match the string in theService name field. If no
string is specified, it retrieves all available services.
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Web Services Properties Dialog Box
Relevant for: API testing only

This dialog box displays the properties of importedWeb services.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Import aWSDL. Select Import WSDL > Import WSDL from URL or
UDDI.

3. Select the parent node of theWSDL in the Toolbox pane.

4. Select Properties from the context menu.

Relevant tasks "How to Import aWSDL-BasedWeb Service" on page 1744

The following elements are included:

UI
Elements Description

Name The name of theWeb service as defined in theWSDL file.
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UI
Elements Description

Location The current location of theWSDL. If it was updated from a location other than the
original, it will indicate the new location.

Working
Folder

A folder containing a local, working copy of theWSDL. ForWeb services moved to
the shared repository, this is a temporary folder.

Version TheWSDL version.

Creation
Date

The date and time in which theWSDLwas first imported.

Update
Date

The date and time of the latest update. If no updates were done, this value is the
same as theCreation Date.

Import
Type

The way in which theWSDLwas imported: Regular orAs Server. For details about
importing theWSDL as a server response, see the "Select WSDLDialog Box" on
page 1764.

REST Services Properties Dialog Box
Relevant for: API testing only

This dialog box displays the properties of REST services.
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To
access

1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Create a REST Service or import aWeb Application service. For details, see
"Add/Edit REST Service Dialog Box" on the next page.

3. Select the parent node of the service in the Toolbox pane.

4. Select Properties from the context menu.

Relevant
tasks

"How to a Create a REST Service" on page 1746

The following elements are included:

UI
Elements Description

Name The name of the REST service as defined in the REST Service Designer.

Location The current location of the REST service files.

Working
Folder

The folder containing a local, working copy of the test. By default, this is <Test_
Folder>\EmbeddedResources\
NewService.

Version The current version of the REST service.

Creation
Date

The date and time in which the service was created.

Update
Date

The date and time of the latest change and refresh. If no updates were done, this
value is the same as theCreation Date.

User Guide
Chapter 56: Local Activities

HP Unified Functional Testing (12.00) Page 1771 of 2274



Add/Edit REST Service Dialog Box
Relevant for: API testing only

This dialog box enables you to define a new REST service.

To
access

1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Do one of the following:

n Click theAdd REST Service button on the toolbar and select
REST Service Editor or Import WADL.

n Select a REST Service orWeb Application service node in the Toolbox pane,
and chooseEdit Service from the right-click menu.

Relevant
tasks

"How to a Create a REST Service" on page 1746
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Some user interface elements are available only when you select a specific node. The user
elements are (unlabeled elements are shown in angle brackets):

UI Elements Description

Expand All. Expands all of the nodes of the parent REST service.

Collapse All. Collapses all of the children nodes of the parent REST
service.

Add Method. Adds amethod to the selected REST service node.

Add Resource. Adds a resource to the selected REST service or resource.

Delete. Deletes the selected REST service, resource, or method.

Rename. Renames the selected REST service, resource, or method.

Run Method. Runs the selectedmethod and shows the results in the lower
part of the pane.

Note: Available only when you select amethod.

<properties
pane>

The properties of the REST servicemethods. For details, see the "Properties
Pane" on page 385.

<REST
Services tree>

Displays a list of the REST services that match the filter condition.

<results pane> The results of theRunMethod command. This section also shows the
property values and the response.

Filter box Filters the display by the entered text.
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Import .NET Assembly Dialog Box
Relevant for: API testing only

This dialog box enables you to import .NET assemblies in order to use them as activities from the
Toolbox pane.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Click the Import .NET Assembly button on the toolbar.

Important
Information

After importing the .NET assembly, you should save the test. Not saving the test
leads to unexpected behavior with the autocomplete functionality when adding an
event handler to a .NET assembly test step.

Relevant
tasks

"How to Import and Create a .NET Assembly API Test Step" on page 1760
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The following elements are included:

UI Elements Description

GAC tab Displays a list of the GAC (Global Assembly Cache) assemblies.

Choose specific assembly version. Shows all versions of the GAC
assemblies as separate entries. This enables you to add a specific version of a
GAC assembly.

.NET
Assembly
Browser tab

Enables you to browse for an assembly to import.

Select Adds the selected assemblies to theSelected References list.

Selected
References

A list of the GAC assemblies that you selected. The grid shows the following
information:

l Reference Name. The name of the reference as it will appear in the Toolbox
pane.

l Type. GAC or Assembly

l Location. ForGAC types, the class; ForAssembly types, the full path of the
DLL.

Remove Removes the selected assemblies from theSelected References list.

Add Input/Output Property/Parameter Dialog Box (API
Testing)

Relevant for: API testing only

This dialog box enables you to define custom input or output properties for the current step or input
or output parameters for a test.

l For adding a property for a Custom Code or .NET Assembly step, see "Add Property for Custom
Code or .NET Assembly Activities" on the next page.

l For adding a test property, see "Add Input/Output Parameter for Test Settings" on page 1777.

l For adding a property for a REST activity step, see "Add Input/Output Property for REST
Service Steps" on page 1779
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Add Property for Custom Code or .NET Assembly Activities

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the Solution Explorer, select an API test or component.

2. Add a Custom Code or .NET Assembly activity to the canvas.

3. Select the Properties pane's Input/Checkpoints tab.

4. Click theAdd button and select one of the following:

n Add Input Property

n Add Output Property

Relevant tasks l "How to Import and Create a .NET Assembly API Test Step" on page 1760

l "Create a Custom Code activity" on page 1600

l "How to Define API Test Properties or User/System Variables" on page
141

The following elements are included (unlabeled elements are shown in angle brackets):
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UI
Elements Description

Name A name for the property.

Type ForSimple types, a drop down list of simple data types, such as String, Integer,
and so forth.

Filter ForAdvanced types, a textual expression by which to filter the displayed
assemblies. For example, to show only those assemblies that begin with the
system prefix, enter system.

Simple Shows the simple data types, such as String, Integer, and so forth.

Advanced Shows an extensive list of types, including all .NET types and DLLs referenced
by the test, and all types from the imported assemblies.

<list of
properties>

A list of the types, including .NET types, types from DLLs referenced by the test,
and all types of the imported assemblies.

Description A description of the property.

Add Input/Output Parameter for Test Settings
The image below shows the dialog used to add an input parameter. This example also shows the
options available when adding a test parameter to a test stored on an ALM server with Lab
Management.
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To access 1. Create or open an API test or action.

2. Select theStart orEnd steps in the canvas.

3. Click the Properties pane's Test Input/Output Parameters tab.

4. Click theAdd button and select one of the following:

n Add Input Parameter

n Add Output Parameter (not relevant for ALM AUT Parameters)

Relevant tasks "How to Run a Test Using Server-Side Execution" on page 727.

See also l "Running Tests in Server-Side Execution" on page 713

l "Select AUT Parameter Dialog Box" on page 742

The following elements are included:

UI
Elements Description

Name A name for the parameter. A default name for the parameter is provided.

Type A drop down list of simple data types, such as String, Integer, and so forth.

Note: For parameters linked to ALM AUT parameters, the type will always be
String.

Default
Value

A default value for the parameter, used during the run session if no other value is
provided for the parameter.

Note: For ALM AUT parameters, you can set this value by selectingCopy
default value (override) in the "Select AUT Parameter Dialog Box"
(described on page 742).

ALM AUT
Parameter

The path to an ALM AUT Parameter from the Lab Resources > AUT
Environmentmodule in ALM LabManagement.

You cannot edit the text in this box. Use theSelect ALM application
parameters to enter an AUT parameter.

Note: Available only if UFT is connected to an ALM server that has the Lab
Management module, and a test stored on that server is selected in the
solution explorer.
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UI
Elements Description

Select ALM application parameters. Opens the Select AUT Parameter dialog
box for selecting a parameter from an AUT environment defined in the Lab
Resources > AUT Environmentmodule. For details, see "Select AUT
Parameter Dialog Box" on page 742.

Note: Available only if UFT is connected to an ALM server that has the Lab
Management module, and a test stored on that server is selected in the
solution explorer.

Remove link to ALM application parameters. Removes the linking of the
selected parameter from ALM. This parameter will now be an ordinary test
parameter.

Note: Available only if UFT is connected to an ALM server that has the Lab
Management module, and a test stored on that server is selected in the
solution explorer.

Description A description of the parameter.

Add Input/Output Property for REST Service Steps
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To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the Solution Explorer, select an API test or component.

2. Open the Add REST Service Dialog box .

3. Create a RESTmethod, service, or resource.

4. Click theCustom Input/Checkpoints tab in the right pane .

5. Click theAdd button and select one of the following:

n Add Input Property

n Add Output Property (for RESTmethods only)

Relevant tasks "How to a Create a REST Service" on page 1746.

See also "Add/Edit REST Service Dialog Box" on page 1772

The following elements are included:

UI Elements Description

Name A name for the property.

Type A drop down list of simple data types, such as String, Integer, and so forth.

Description A description of the property.
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Import Network Capture Dialog Box
Relevant for: API testing only

This dialog box enables you to import the contents of a network capture file. After you import the file
to your test, UFT creates test steps for the transactions included in your file.

To access 1. Create, open, or select an API test.

2. Select Tools > Import Network Capture File.

Important
Information

l Only .pcap and .har network capture files are supported.

l If your file contains errors, you cannot import the file and the Import button is
disabled.

l Steps created by importing a network capture file are not stored in the Toolbox
pane. If you need to add the steps to your test again, you need to import the
network capture file again.

Relevant
tasks

"How to Import a Network Capture File" on page 1758

See also "Network Capture Activities" on page 1736
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The following elements are included (unlabeled elements are shown in angle brackets):

UI Elements Description

Network Capture
file

The path to the file to import.

Note: You can only select network capture files stored on the file
system.

Browse. Enables you to navigate to the file to import.

Info Pane Displays details about the selected file, including number of network
transactions contained in the file or errors in the file.

Note: Themaximum number of transactions allowed is 100.

Create
checkpoints from
response

Creates checkpoint values for your test steps based on the information
detailed in the response of the .pcap or .har file.

You view the response of your file differently based on whether your
network capture file is a .pcap or a .har file.:

l For .pcap files:Open the file in a network capture program and view the
response information contained in a TCP stream.

l For .har files:Open the file in a text editor and navigate to the response
section of the desired HTTP transaction.
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Troubleshooting and Limitations - Local Activities
Relevant for: API testing only

This section describes troubleshooting and limitations for working withWeb and REST services.

This section includes the following:

l "Web Services" below

l "REST Services" on the next page

l "Web Applications (WADL)" on the next page

l "Network Capture Activities" on page 1785

l ".NET Assemblies" on page 1785

Web Services

l You cannot import WSDL files with names that are restricted by theWindows operating system.
This list includes: CON, PRN, AUX, NUL, COM1, COM2, COM3, COM4, COM5, COM6,
COM7, COM8, COM9, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, and LPT9.

Workaround:Rename theWSDL file before the import.

l The followingWSDLs are not supported:

n WSDL version 2.0

n WSDLs containing a <appInfo> element.

n RPC EncodedWSDLs configured as Asynchronous Web services.

n WSDLs authenticated by HTTP digest on Apache servers.

l When openingmany tests in the same solution using one or more of the sameWeb services,
UFT may develop amemory leak.

Workaround: Move theWeb service to the file system or ALM repository. To do this, import a
Web service and then, in the Toolbox pane, right-click theWeb Service activity and select
Move to > File System Activities orALM Activities.

l For aWeb service imported as a server response:

n RPC typeWSDLs cannot be imported as a server response. If you attempt to update a
service from anRPC encodedWSDL, it will create a duplicate entry.
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n If you end theUFT.exe process during the listening stage, after the binding was added, the
binding will not be removed from the system.

Workaround:Remove the bindingmanually using a utility such as httpcfg.exe or netsh.exe.

n Whenworking with SSL, certificates from a file are not supported. If youmove the test to
another machine, the certificate will not be saved with the test.

Workaround:Add the certificate to the local machine store before the listener starts, and
remove it at the end of the listening process.

REST Services

l Importing a schema to a REST, HTTP, or SOAP checkpoint may remove the links of the input
properties.

l XPath checkpoints are not supported for HTTP and REST activities.

l If you link between input and output properties in the sameRESTmethod and then delete the
input property without removing the link, the link expression still remains in the output property. If
you save the test in this state, youmay be unable to reopen it.

Workaround:Delete the link explicitly either before or immediately after deleting its source
property.

l When defining a RESTmethod prototype in the Add/Edit REST Service dialog box - in order to
use the Trim, Ignore, orStop test options, select the check box in theValidate column, in the
Checkpoints pane.

l When running a RESTmethod using theRun Step command, checkpoints of dynamic property
values in themethod linked to other property values (input or output) are ignored.

Web Applications (WADL)
The following elements are not supported when importing yourWADL. UFT does not import these
elements into theWADL hierarchy inside your test:

l Grammars element

l Resource_type element

l Link element

Note: Any child elements of these elements are also ignored by UFT and not added to your
WADL inside the test.

In addition, if you use the href attribute to link to other elements, youmust refer to an element in the
sameWADL file. Linking betweenWADL files is not supported.

For more details onWADL elements, see http://www.w3.org/Submission/wadl/
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Network Capture Activities
Steps added to your test from a network capture file do not include:

l Security settings forWeb service calls and SOAP requests

l Web authentication information for any type of step

l Cookies data for HTTP request

l Attachments sent as part of theWeb Service call

.NET Assemblies
Importing or adding references to 64-bit .NET assemblies is not supported.
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Chapter 57: Reusable Actions in Service Test
Relevant for: API testing only

This chapter includes:

Concepts 1787

Actions in API Testing - Overview 1787

Action Placement 1788

Calls to Existing Actions 1788

Combining Steps into Actions 1790

Actions Using the Data Table 1791

Considerations forWorking with Actions 1791

Tasks 1793

How to Use Actions in an API Test 1793

Reference 1796

Insert Call to New Action Dialog Box (API Tests) 1796

Select Action or Test Dialog Box 1797

Rename Action Dialog Box 1798

Actions Context Menu 1798
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Concepts

Actions in API Testing - Overview
Relevant for: API testing only

Actions are sequences of operations that you perform within the context of a test, consisting of
either one or multiple steps. Calls to actions placed in your test enable you to test a specific area or
function of your application. In this way, your test can check the user interface and the application
functionality, such as opening a flight reservation system using based on aWeb Service.

Actions also allow you call a repeated activity, such as logging in to aWeb site multiple times.
Each time the action is called, the test calls the action steps, its properties, and its data. Instead of
recreating the process and entering its data each time you call the action, the call to an action refers
to the original action instead of having to define a new action.

An action contains its own test coding, including all of the steps in that action and all necessary
objects for its execution.

When you insert a call to an action into your test, the test adds the action to the Solution Explorer.
As a result, you can reuse the actionmultiple times within a test or call it from another test.

Actions can also be saved as business components to be used for BPT.

When to Use Actions
Actions are useful when you need to repeat a specific activity multiple times. For example, if you
are testing yourWeb service which requires a login, you can insert a call to a log-in actionmultiple
times instead of inserting a new log-in step each time it is needed.

Actions also enable you to parameterize repeated steps within your test. For example, if you want
to test yourWeb service for multiple users, you can call an action connected to a data source with
user information for multiple users. The call to an action gives you the ability to provide data for a
specific step or feature to ensure it works for multiple scenarios or users. Thus, you can not only
test the functionality of the processes of your application, but you can also test that the individual
elements within that process work correctly.

Actions also enable you tomodify a specific element within an application without affecting the
test. When the call to action is inserted in the test of a larger process, if the application element
changes, the entire test does not. The action properties are updated to reflect the change in the
application element. However, the application process test steps do not need to bemodified.

Calling Actions from Other Tests
You can call both actions defined within your current test or defined in other tests. When you call an
action from another test, by default its data is read-only. Using the Property View, you can enable
the action's data for editing. For details, see "How to Use Actions in an API Test" on page 1793.

Nesting and Repeating Actions
You can nest additional actions within existing ones. This allows you to create specialized actions
and call them at the desired point within your test.
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You can also set the loop properties for individual actions, independent of the loop properties in the
main Test Flow. You click in the action's flow, and specify the loop properties in the Property View.

Example

Suppose you want to test aWeb service which enables customers to book a flight and
purchase tickets. This requires you to test several processes and features: request aWeb
service, log in, choose flights, process customer information, output a complete reservation,
and log out. Testing this service also requires you to test both application processes and user
interface elements. Furthermore, youmight want to test the capability of a user, such as a
travel agent to use the service tomakemultiple reservations.

Your test might look similar to this model:

Action Placement
Relevant for: API testing only

UFT provides reusable actions that can be calledmultiple times within a test or by other tests.
These actions make it easier to maintain your tests, because when an object or procedure in your
application changes, themodified element is updated in all calls to the action.

Note: This is different from GUI Test (formerly QuickTest Professional) actions, which allow
you to indicate whether the action should be reusable or not.

Calls to Existing Actions
Relevant for: API testing only

When you plan a test or multiple tests, youmay realize that each test requires identical, repeated
activities, such as logging in. Instead of inserting these steps three times in separate places or
tests (and adding checkpoints, parameters, and data) separately, you can create an action one time
and store it with the test. You then populate the action with activities from the Toolbox. After you
are satisfied with the action you have created, you can also call it from other tests.
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If you call an action from an external test that has data assigned to its properties, you can indicate
whether you want the data from action's data sheet to be imported as a local, editable copy, or
whether you want to use the (read-only) data from the original action.

Tomodify the steps of an action from an external test, youmust open the test in which the action is
stored andmake your modifications there. Themodifications apply to all tests that call that action.

For more details, see "How to Use Actions in an API Test" on page 1793.

Example

Suppose you want to create the following three tests for flight reservation--booking a flight,
modifying a reservation, and deleting a reservation. While planning your tests, you realize that
for each test, you need to log in and log out of the site.

Test 1 would contain three actions (Logging In, Booking a Flight, and Logging Out). Test 2
would contain three actions (Logging In, Modifying a Booking, and Logging Out). Test 1 would
contain three actions (Logging In, Cancelling a Booking, and Logging Out). The Logging In and
Logging Out actions are defined in the same test, and called as external actions by all three
tests.
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Combining Steps into Actions
Relevant for: API testing only

Multiple steps can be combined together to constitute an action. For example, when designing a
test to check yourWeb service for booking flights, youmay find that certain actions and processes
are repeatedmultiple times. You can select these steps on the canvas and group them in an action.
You can also select multiple steps using the standardWindows multiple selectionmethods, with
theSHIFT andCTRL keys.

After selecting the steps you copy/cut and paste them into the action's tab. Your test can then call
the action, and apply loop behavior to the action as a single unit.

For more details, see "How to Use Actions in an API Test" on page 1793.
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Actions Using the Data Table
Relevant for: API testing only

You can use the Data pane tables to provide property values for your actions. Each action uses its
own data sources—not the test's data source.

Tip: If you want to use the same data for the test and in a specific action, youmust define the
data source path twice, once for the test and once for the action. See "Using Data in Your API
Test or Component Steps" on page 1801.

By default, data from actions called from other tests, are not visible in your current test. You can
expose the data by enabling theAllow other tools to override the data option in the action’s test.
As a result, you can view the data in the Data Pane. It is marked with an icon  indicating that
this is data from an action.

AnUpdate option allows you to reload the action's data in your test when it changes in its original
location. This only applies to data that you did not make editable. For details, see "How to Use
Actions in an API Test" on page 1793.

Note: You can switch data from read-only to editable or vice versa. However, when changing
from editable to read-only, any changes made to the data are lost.

If an action is called repeatedly in the test, only one set of the action's data is displayed in the Data
Pane. If youmake changes to the data at the action's original location and it is not marked as
editable, then the changes are applied to all calls to this action.

For details on how UFT handles data in a test, see "Using Data in Your API Test or Component
Steps" on page 1801.

Considerations for Working with Actions
Relevant for: API testing only

Inserting Actions
You should consider using actions if:

l You intend to use an identical or virtually identical procedure or action in more than one test.

l Youwant to edit the data in a specific call to an action that you call multiple times within your
test.

Naming Actions
Youmay want to rename the actions in your test with descriptive names to help you identify them.
It is also a good idea to add detailed action descriptions. This facilitates inserting actions from one
test to another. You can rename an action by right-clicking on the action in the Solution Explorer and
selectingRename.
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When renaming an action, make sure to use the following naming conventions:

l Cannot begin or end with a space

l Cannot exceed 1,023 characters

l Cannot contain the following characters: \ / : * ? " < > | % ' ! { }
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Tasks

How to Use Actions in an API Test
Relevant for: API testing only

This task describes the different operations you can perform to use actions in your test.

This task includes the following steps:

l "Insert a call to a new action" below

l "Call an existing action or a test" below

l "Set action properties" on the next page

l "Copy or move steps" on the next page

l "Remove a call to an action" on the next page

l "Delete an action" on the next page

l "Enable an action's data for editing when called by another test" on page 1795

l "Override data from an action called by another test" on page 1795

Insert a call to a new action

1. Select Design > Call to New Action.

2. Specify the action name and description. Click OK to add the call to the action to the canvas.

3. In the Solution Explorer, double-click the action to open its canvas.

4. Add steps to the action. Drag activities from the Toolbox onto the canvas.

Note: You can insert a call to another action, from an existing action call.

Call an existing action or a test

1. Drag anHP Automated Testing Tools > Call API Action or Test orCall GUI Action or
Test activity onto the canvas.

2. Open the Properties pane (CTRL+ALT+P).

3. In the Input/Checkpoints tab, click theSelect Action or Test button.

4. Select the desired test and action. Click OK.
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Set action properties
To set an action call's properties, youmust set the values for each of the steps separately.

1. Select an activity within the action whose properties you want to set.

2. In the Properties tab, provide values or data drive the properties. For details, see the
"Properties Pane Tabs" on page 403.

3. The property values that you set will be the default values used when you add a call.

Note: If you reload the service using theRefresh button, the new versionmay add or
remove properties. Properties that remain unchanged, will retain the default values.

Copy or move steps
Copying or moving steps is ideal if you want to copy or move existing steps into another location in
the Test Flow or to an action.

1. Make sure the actions into which you want to copy or move the steps, are open. To open an
action, double-click on it in the Solution Explorer or select Open from the action's context
menu in the test.

2. Select one or more steps that you want to copy or move. To select multiple steps, do one of the
following:

n Drag themouse pointer around the steps. A transparent rectangle is be drawn over the
selected area.

n Press SHIFTwhile selecting the beginning and ending steps to be grouped. All steps
between the endpoints are grouped.

3. Select Copy orCut from the context menu.

4. Place the cursor in the desired location. Select Paste from the right-click menu.

Remove a call to an action
In the test canvas, select the call to the action and press DELETE or right-click and select Delete

Delete an action
In the Solution Explorer, right-click the action and select Delete. The action is removed from the
Solution Explorer and all calls to the action are removed. Edited data from the removed step is
moved to themain node of the Data Pane as described in "Actions Using the Data Table" on page
1791.
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Enable an action's data for editing when called by another test
To view or override an external action's data, youmust expose it in its original location. This only
applies to Excel type data sources, and only available for tests—not business components.

1. Define data for the action that you will be calling. Assign the datamanually or use data driving.
For details, see "How to Assign Data to API Test/Component Steps" on page 1819.

2. In the Data Pane, select the data source's node.

3. Open the Properties pane (CTRL+ALT + P) and select theAllow other tools to override the
data option. The Data pane creates a local copy of the data which can be edited.

Override data from an action called by another test

1. Make sure the action that you want to call has its data exposed. For details, see the above
step.

2. Open the test in which you want to add the call to the action.

3. In theHP Automated Testing Tools node, drag aCall API Action or Test or aCall GUI
Action or Test activity onto the canvas.

4. In the Properties pane Input/Checkpoints tab, click theSelect Action or Test button.

5. In the Select Action or Test dialog box, browse for the test and select the desired action. Click
OK.

6.  Open the Properties pane and select theUse a local, editable copy option.

7. Edit the data tables in the Data pane.
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Reference

Insert Call to New Action Dialog Box (API Tests)
Relevant for: API testing only

For GUI tests, see "Insert Call to New Action Dialog Box (GUI Testing)" on page 913.

This dialog box enables you to create a new action for your test.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the Solution Explorer, select an API test or component.

2. Do one of the following:

n Design > Call to New Action

n Click the Insert Call to New Action button 

Relevant tasks "Insert a call to a new action" on page 1793

User interface elements are described below:

UI Element Description

Name A name for the action as it will appear in the Solution Explorer and canvas.

Description A detailed description of the action.
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Select Action or Test Dialog Box
Relevant for: API testing only

This dialog box enables you to add a call to a copy of an action, or a call to an existing action within
your test.

To
access

1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Drag anHP Automated Testing Tools > Call API Action or TestorCall
GUI Action or Test activity onto the canvas.

3. Open the Properties pane.

4. Click theSelect Action or Test button.

Relevant
tasks

"Call an existing action or a test" on page 1793

User interface elements are described below:

UI Element Description

Test The name of the test from which you are calling the action.
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UI Element Description

Browse. This allows you to browse your test library to find a test.

Action A drop down list of the actions available for the selected test. You can view a list
of the available actions in the Solution Explorer.

Description The original description given to the action (read-only).

Rename Action Dialog Box
Relevant for: API testing only

This dialog box enables you to rename an action.

To access Right-click on an API action name in the Solution Explorer.

Relevant tasks "How to Use Actions in an API Test" on page 1793

See also "Naming Actions" on page 1791

User interface elements are described below:

UI Element Description

New Name A new name for the action.

Actions Context Menu
Relevant for: API testing only

The context menu for action steps is described below:

UI
Element Description

Cut Cuts the action from the current flow, and places it on the clipboard.
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UI
Element Description

Copy Copies the selected action to the clipboard.

Delete Removes the selected action from the current flow.

Open Opens a tab for the selected action. This allows you to add steps and set properties
for the action.

Note: For external actions, stored in other tests, a message window asks if you
want to add the external test to your solution. This creates a local copy of the
action allowing you tomodify its data.
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Chapter 58: Data Usage in API Tests
Relevant for: API testing only

For details about the GUI testing Data Table Explorer pane, see "Data Pane" on page 221.

This chapter includes:

Concepts 1801

Using Data in Your API Test or Component Steps 1801

NavigatingWithin a Data Source 1813

Parent/Child Data Source Relations 1814

Data Assignment in Arrays 1815

Data Keywords 1817

Tasks 1819

How to Assign Data to API Test/Component Steps 1819

How to Assign Data to API Test Steps - Tutorial 1822

How to Set the Data Source Navigation Properties 1825

How to Data Drive an API Test Step 1827

How to Data Drive Array Checkpoints 1828

How to Parameterize XMLData 1831

Reference 1834

Data Driving Dialog Box 1834

Data Link/RelationMessage Box 1837

Attach Data Source to Loop Dialog Box 1839

Select Link Source Dialog Box (API Testing) 1840

Data Navigation Dialog Box 1846

Define New/Edit Data Relation Dialog Box 1849

New Exposed Property Dialog Box 1850

Troubleshooting and Limitations - Using Data in API Tests and Components 1852
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Concepts

Using Data in Your API Test or Component Steps
Relevant for: API testing only

When you create test steps, you assign input and checkpoint property values for the test steps.
Sometimes you enter the property values manually. Other times you link these property values to
data.

In UFT, you can link property values to data in a number of ways:

l Link to a data source. You can connect your test steps to an Excel file, an XML data source, a
database, or a locally-created data table. These data sources are associated with your test in
the Data pane. UFT then pulls the property values from the values specified in the Data pane.
This enables you to run the test step using different sets of property values, thereby testing how
your test steps (and by extension, your application) performs with varying data values.

For more details on linking your test steps to a data source, see "Linking Property Values to a
Data Source" on page 1803. For details on associating a data source with your test using the
Data pane, see "How to Add Data Sources to an API Test" on page 233.

l Link to another test step: In some cases, your application passes a value betweenmultiple
processes in the course of its normal operation. Therefore, in your test, you can link the output of
one step to the input of another step. This mimics the way that your application passes values
between application processes, and allows your test to more accurately assess the
application's performance.

For details, see "Linking Property Values to a Data Source" on page 1803.

l Link to multiple sources. You can also link your property values tomultiple sources by
creating a custom expression that combines manual property value input, values from a data
source, and input frommultiple test steps. As a result, if an application process receives its
input from both a data source and the previous step, your test can reflect the same
property/parameter input.

For more details, see "Linking Property Values toMultiple Sources of Data" on page 1809.

l Link to a test variable value. In addition to linking to a data source value or another test step,
you can provide the property values by linking to a test variable value or a user-defined variable.
This enables you to use other custom values for properties in your test.

For task details on using data with test steps, see "How to Assign Data to API Test/Component
Steps" on page 1819.

In addition, if you would like to use data for all the properties in your test, you can data-drive all the
properties of a selected step. Data-driving is themechanism by which UFT automatically creates
data expressions that refer to data in a new, editable table. For details, see the "Data Driving Dialog
Box" on page 1834.
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Populating Property Values Manually

Relevant for: API testing only

When you enter property values for your test step, the basic way to do this is to providemanual
values for each property.

In the "Parameters/Checkpoints Tab (Properties Pane - API Testing)", you can view and edit the
values of each input and checkpoint property, both for simple properties and arrays.

For test steps that use XML and JSON (such as Web Service calls and XML/JSON activities), you
can alsomanually edit the values in the XML/JSON text mode.
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Any changes youmake are then reflected in the Input/Checkpoints property grid:

In addition, you canmanually populate the checkpoint values by loading values that were obtained
from an earlier run using the Load from Replaymechanism.

Linking Property Values to a Data Source

Relevant for: API testing only

You can link the test input and checkpoint property values to a data source. In this way, you can
test how a particular test runs with varying input and checkpoint properties.

Note: Before you can link your property values to a data source, youmust import the data
source into your test in the Data pane. For details, see "Data PaneOverview" on page 222.

You can link your test steps tomultiple types of data:

l Excel files

l XML files

l Database values

l Local table values
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The image below shows an example of connecting a test step to an Excel data source using the
Select Link Dialog Box:
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Once you have linked the step to a specific value in the data source, the Value column for the
property name in the Properties pane reflects this link:

When the test runs, the property values are provided from the associated source.

For task details on how to link property values to a data source, see "Link your test step to a data
source" on page 1819. For details on the Select Link Source dialog box, see "Select Link Source
Dialog Box (API Testing)" on page 1840.

Creating a Query to Retrieve Database Tables

Relevant for: API testing only

If you choose to create a data source from a database, UFT lets you retrieve data from both OleDB
andODBC databases. A wizard guides you through connecting to a database and creating an SQL
query statement. After you complete the wizard, the Data pane displays the database's data tables.

The connection builder assists you in creating a string for your connection. For details, see
"Connection Builder Dialog Box" on page 1720.
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Once you are connected to the database, you can use UFT's Query Designer to create a custom
SQL statement, based on the tables and views in your database.

For details on how to use the Query Designer, see the "Query Designer Dialog Box" on page 1724.

To learnmore about using the wizard, see "Add a database data source" on page 235.

Linking Property Values to Other Test Steps

Relevant for: API testing only

In some instances, your application passes data from one application process to another. Thus, the
input value that one process is calling is reliant upon the output value of another process.

Therefore, when testing the behavior and performance of your application in a test, youmust be
able tomimic this passing of data. UFT enables you to do this through linking the property values of
one step to the property values of another step.
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Linking step property values is much the same as linking a step's property values to a data source.
You use the Select Link Source dialog box and select the optionAvailable Steps.
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After you link the steps together, the canvas indicates the connection between the test steps:

For task details, see "Link your test step to another step" on page 1820.

For details on the Select Link dialog box, see "Select Link Source Dialog Box (API Testing)" on
page 1840.

Outgoing Links

Relevant for: API testing only

When you link a property to another step's property, UFT indicates this with aOutgoing Links
button in the property's value column in the Properties pane's Input/Checkpoints tab.

By clicking on the button, you can view a list of the properties that link to this output property. This
is especially helpful when linking other steps to an output property multiple times to enable you to
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view the flow of data throughout your test. Likewise, this helps you ensure that the test steps match
the flow of properties/parameters as they do in your application.

When you click theOutgoing Links button, UFT opens a list of the target properties that link to this
value. Using theGo to button, you can navigate directly to the linked property. This selects the
target step on the canvas and the target property in the Properties pane.

Linking Property Values to Multiple Sources of Data

Relevant for: API testing only

If the input of a particular application process in your application is linked to both a data source and
the result of a previous application process, you can create property value expressions in UFT that
reflect this process.

You do this by linking the property value of a test step tomultiple sources of data and then creating
custom expressions for the property value using a combination of the linkingmethods.
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Using the Select Link Source dialog box, you create these custom expressions in any combination:

The custom expression is then added as the property value for your test step and runs accordingly
when you run your test.

For task details, see "Link your test step tomultiple sources" on page 1821.

For details on the Select Link dialog box, see "Select Link Source Dialog Box (API Testing)" on
page 1840.
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Data Driving

Relevant for: API testing only

Data-driving is themechanism by which UFT automatically creates data expressions for
properties. When you data drive a step, UFT adds data expressions to the step's value fields.

These expressions refer to data in a new editable Excel table or XML structure, depending on the
type of provider you specified during the data driving.

You can customize data-driving in the following ways:

l Specify the type of data source to create—Excel or XML.

l Indicate which properties to data drive:

n For standard input and output (checkpoint) properties: Input, Checkpoints, or both.

n For XSD files, loaded for the HTTP or SOAP Request steps: Request Body, Response
Body, or both.

n For additional types such as HTTP multipart and SOAP Fault properties, see the "Data
Driving Dialog Box" on page 1834.

l Whether to use the same or two different data sources, when data driving two sections, such as
Input and Checkpoint properties (Enabled only for Excel data sources).

l Whether or not to set the target step's loop, as a "For Each" type, based on the generated data
source.
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For Excel type tables, you canmanually add to and edit the data in the Data pane.

For XML data sources, you canmanually edit the XML root.

For task details, see "How to Data Drive an API Test Step" on page 1827.

For user interface details, see "Data Driving Dialog Box" on page 1834.
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Navigating Within a Data Source
Relevant for: API testing only

Sometimes, when you are running your test, your data is stored inmultiple sources and called by
many different step properties in the test. In these cases, you can instruct UFT how to use the data
sources, including where in the data source to begin calling data values, how tomove through the
data source, and where to stop using values from the data source. You specify these settings for
each of the data sources associated with your test in the "Data Navigation Dialog Box" (described
on page 1846)

This is useful to test your application's performance with constantly varying sets of data. In
addition, this enables you tomaintain your data source while still using it in a test. For example, if
you are adding new data to a data source that is being used in a test, but the new data is not
complete, you can instruct UFT to begin at the row containing the old data and stop before calling
the new data values currently under construction.
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The Data Navigation settings you create work with the loop settings for the Test Flow or selected
test loop:

l If the loop is configured as a ForEach type, and you assign a specific data source as the loop's
collection, then the Data Navigation settings affect the number of iterations of the loop. Because
you specify the number of rows to use from the selected data source, the test runs the same
number of iterations as the number of rows specified.

For details on the different loop types, see "Flow Control Activities" on page 1651.

l For data sources that are not designated as the loop collection but whose values are called by
steps within the loop, the Data Navigation policy affects the data differently. It indicates the
order in which the values are called from the data source and assigned to steps within the loop.
For example, if you specify in the Data Navigation dialog box to begin in the second row of your
Excel data source, UFT populates the property value with the values from the second row (and
so forth, as specified in the Data Navigation dialog box).

For task details, see "How to Set the Data Source Navigation Properties" on page 1825

Parent/Child Data Source Relations
Relevant for: API testing only

If your test uses multiple data sources to provide data for your test step properties, you can create a
hierarchy of relations between data sources that describes how to use the data sources in your test.
You use data relations when you use one specific data source as the primary data source for your
test but require other data sources to populate property values within the same test.

When you use data relations, you assign the primary data source to the Test Flow or selected test
loop. Then, using the Define New Data Relation dialog box, you specify any necessary child data
sources andmap the columns of the parent data source to the columns of the child data source.

When the test runs, UFT substitutes the child data as specified.

For task details, see "Create a new child relation" on page 1826.
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For details on the Define New Data Relation dialog box, see the "Define New/Edit Data Relation
Dialog Box" on page 1849.

Data Assignment in Arrays
Relevant for: API testing only

When your step has properties that are arrays, you can assign them data as a fixed-size array or
through data relations:

Fixed-Size Array Assignment
In the fixed-sizemethod, you assign each element of a fixed-size array to any column in a data
table. You can assign each array element to a different data table column.

The following example shows three array elements assigned to different columns of a data table.

Data Relation Based Assignment
When you have one or more data relations defined, as described in "Create a new child relation" on
page 1826, UFT assigns data from a single column. You link the first element of the array to a
column in a data source.

In order for UFT to assign data based on a data relation, the following conditions must be present:

l The data source in the link is defined in a data relation.

l The parent data source is attached to the loop containing the step.

l Only the first element of the array is mapped to the child data source. If youmap another array
element to a different column, simple based assignment will be used.
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The following example shows a single array element linked to a child data source. In this example,
all elements of the array will take values from the same column, using the data-relation based
assignment.

The link to the first element indicates the column from which the values for all of the array elements
will be taken.

If you create a simple link to data, and the data source is already designated as a child in a data
relation, the behavior will be relation-based.

Data-driven array elements will always be assigned using the data relation based assignment,
using the column assigned to the first element.

Assignment Types

For relation-based data assignment, the drop down list adjacent to the name of the parent array
node provides the following options for checkpoint validation:

l Fixed. Checks that each of the returned array elements matches the corresponding array
element in the data table in the Data Pane. Each array is marked by an index number, as it
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checks the arrays by their index.

l All. Checks that all of the returned array elements match the array element in the Data Pane. In
this mode, arrays are not marked by an index number. For example, if a property in the first array
is marked >= 2 and the same property in another array element is set to <=10, the test run will
check that all returned values are between 2 and 10.

l Contains. Checks that at least one of the returned array elements matches the value of the
property in the Checkpoints pane. In this mode, arrays are not marked by an index number.

l Fixed. Checks that each of the returned array elements matches the corresponding array
element in the data table in the Data Pane. Each array is marked by an index number, as it
checks the arrays by their index.

l All. Checks that all of the returned array elements match the array element in the Data Pane. In
this mode, arrays are not marked by an index number. For example, if a property in the first array
is marked >= 2 and the same property in another array element is set to <=10, the test run will
check that all returned values are between 2 and 10.

l Contains. Checks that at least one of the returned array elements matches the value of the
property in the Checkpoints pane. In this mode, arrays are not marked by an index number.

Data Keywords
Relevant for: API testing only

You can use keywords to customize the test run and validation. For example, SKIP omits a
property in the request or in the validation.

UFT provides keywords for both input properties and checkpoints. You can set keywords in the
following ways:

l Select the property and choose Insert Keyword from the right-click menu.

l Link to a data source containing the keyword.

l Type to keyword into theExpected Value column (checkpoints only).

For themanual options, make sure to use the required format by enclosing the keyword with hash
(#) signs. Keywords are not case-sensitive.

Input Keywords
The following keywords are supported for input properties:

Keyword Description

#SKIP# Omits this element from the XML of the request. This is useful for elements of SOAP
requests, for whichminOccurs = 0
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Keyword Description

#NIL# Adds a nil=true attribute to the property's XML in the request.

Example: <name John Doe nil="true"></name>

If the XML element is not nillable, this is reported to the log.

Checkpoint Keywords
The following keywords are supported for checkpoints:

Keyword Description

#EXISTS# Verifies that the element is present in the XML response. In this evaluation, the
actual value is ignored—it only checks for the presence of a value. This is useful for
SOAP response elements, for whichminOccurs = 0.

#NOT_
FOUND#

Verifies that the element is not present in the XML response. In this evaluation, the
value is ignored. This is useful for SOAP response elements, for whichminOccurs
= 0.

#SKIP# Informs the run engine to ignore this value when evaluating checkpoints.

To check if an element has a nil="true" attribute in its response, select or clear its NIL icon in the
user interface.
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Tasks

How to Assign Data to API Test/Component Steps
Relevant for: API testing only

This task describes the different ways to link test step properties (both for input properties and
checkpoint properties) to data sources :

l "Manually enter the data for your test step properties" below

l "Link your test step to a data source" below

l "Link your test step to another step" on the next page

l "Link your test step tomultiple sources" on page 1821

l "Link your test steps to a test or user-defined variable" on page 1822

l "How to Assign Data to API Test/Component Steps" above

Manually enter the data for your test step properties

1. In the canvas, select the test step for which you want to assign property values.

2. In the Properties pane, open the Input/Checkpoints tab .

3. In theValue cell for the property, enter the value.

Note: If you are working with a step that uses XML or JSON input, you can also enter the
property values using the Text view in the Input section. Click the Revert button to undo
your changes in the XML view.

Tips:

n If the property value is a string, enter it exactly as you expect it appear (including
spaces and special characters.)

n If you want to use the values from the previous test run, click the Load from Replay
button.

Link your test step to a data source

1. In the Data pane, associate a data source with your test. For details, see "How to Add Data
Sources to an API Test" on page 233.
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2. In the canvas, select the test step for which you want to assign property values.

3. In the Properties pane, open the Input/Checkpoints tab .

4. In theValue cell for the property, click the Link to data source button . The "Select Link
Source Dialog Box (API Testing)" (described on page 1840) opens.

5. In the Select Link Source dialog box, select theData source column option. A list of all data
sources is displayed.

6. Select the data source containing your property's data value. A list of all available data
columns is displayed.

7. In the data columns list, select the corresponding column name for your test step property and
click OK.

The property name in the Input/Checkpoints tab is now displayed with the associated data
source name and data source value.

Note:

n You can only link properties to data sources only if the data source is attached in a loop,
such as Test Flow or custom loops.

n Linking a leaf node to a complex XML node is supported only for string type data.

Link your test step to another step

1. In the canvas, select the step for which you want to link a property value.

2. In the Properties pane, open the Input/Checkpoints tab .

3. In theValue cell for the property, click the Link to data source button . The "Select Link
Source Dialog Box (API Testing)" (described on page 1840) opens.

4. In the Select Link Source dialog box, select theAvailable steps option. A list of all steps
preceding the selected step is displayed.

5. In the list of available steps, select the step you want to link to the selected property value.
A list of available properties is displayed in the right pane.

6. In the right pane, open the tab containing the property to which to link.

Note: If you are linking to the output of a previous step, open the Input/Checkpoints tab
.

7. Select the property to which to link and click OK.
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The property value is displayed in theValue column of the input property namewith an
expression representing the output of the linked step. The canvas also displays an arrow
connecting he step property values.

Note: The Properties pane displays a down arrow next to any property that is set to be
used as output data for another step. Click the icon to display a list of all steps linked to
the selected property. For details, see "Outgoing Links" on page 1808.

Link your test step to multiple sources

1. If necessary, add a data source. For details on adding data sources, see "How to Add Data
Sources to an API Test" on page 233.

2. In the canvas, select the step for which you want to link a property value.

3. In the Properties pane, open the Input/Checkpoints tab .

4. In theValue cell for the property, click the Link to data source button . The "Select Link
Source Dialog Box (API Testing)" (described on page 1840) opens.

5. In the Select Link Source dialog box, click theCustom Expression button to expand the
expression area.

6. Create your expression, with any combination of methods. Click Add after linking to each
source to add the value to your custom expression: 

n Manually enter the expression

n Link to data source values, as described in "Link your test step to a data source"

Note: You canmake a custom expression that includes multiple links to data sources.

n Link to another step's property, as described in "Link your test step to another step"

Caution: If you are entering a custom string, make sure to add the string exactly as you
want it to appear, including spaces and special characters.

You can use thesemethods in any order and in any manner as needed to create your
expression.

7. When you are finished entering all values, click OK.

The custom expression is displayed in theValue column for the property name in the
Input/Checkpoints tab exactly as you entered it in the expression area.
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Link your test steps to a test or user-defined variable

1. In the canvas, select the step you want to link to a test or user-defined variable.

2. In the Properties pane, open the Input/Checkpoints tab .

3. In theValue cell for the property you want to link to a variable value, click the Link to data
source button . The "Select Link Source Dialog Box (API Testing)" (described on page
1840) opens.

4. In the Select Link Source dialog box, select the Test variables option. The list of available
variables is displayed.

5. In the list of available variables, select the variable for the link and click OK.

The value for the selected property is displayed as the expression of the test variable.

How to Assign Data to API Test Steps - Tutorial
Relevant for: API testing only

This tutorial teaches you how to assign data to your test steps. The test steps are based upon the
sample Flight API application provided with UFT.

Note: For the task related to this scenario, see "How to Assign Data to API Test/Component
Steps" on page 1819.

This tutorial includes the following steps:

l "Prerequisite - import theWeb Servicemethods for the sample application" below

l "Associate a data source with your test" on the next page

l "Create your test steps" on the next page

l "Manually enter the input properties for the GetFlights step" on the next page

l "Link the CreateFlightOrder input properties to the data source" on page 1824

l "Link the Report step input properties to the CreateFlightOrder step" on page 1824

l "View the run results" on page 1825

1. Prerequisite - import the Web Service methods for the sample
application
For this scenario, you use theGetFlights andCreateFlightsmethods from the sample Flight
API application.
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To import the service, do the following:

a. Open the Flight API application from theStartmenu.

For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing UFT
inWindows 8Operating Systems" on page 75.

b. Type help to display the service details.

c. Copy the URL for theWeb Service of the Flight API Application.

d. Import theWeb Service into UFT. For details, see "How to Import aWSDL-BasedWeb
Service" on page 1744.

2. Associate a data source with your test
Add the sample application Excel data source to your test. This file (SampleAppData.xlsx) is
found in the <UFT installation>\samples\flight_service directory.

a. In the Data pane, click theNew Data Source button and select Excel.

b. In the "New/Change Excel Data Source Dialog Box" (described on page 255), navigate to
sample application Excel file. Click OK to add the Excel file to the test.

The data source is displayed in theData pane.

3. Create your test steps
From the Toolbox pane, drag the following steps to the canvas in order:

n GetFlights (found in the Local Activities > Web Services node)

n CreateFlightOrder (found in the Local Activities > Web Services node)

n Report Message (found in theMiscellaneous node)

4. Manually enter the input properties for the GetFlights step
To provide property values for theGetFlights step, use the first method for providing data by
manually entering the property values.

To provide the property values, do the following:

a. In the canvas, make sure that theGetFlights step is selected.

b. In the Properties pane, open the Input/Checkpoints tab .
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c. In the Input/Checkpoints tab, manually select the following values from the property value
drop-down lists:

o DepartureCity:Denver

o Arrival City: Los Angeles

5. Link the CreateFlightOrder input properties to the data source
When theGetFlightsmethod runs in the Flight API application, it automatically creates a
number of output properties, including the airline number, price, a flight number, and so on.

In this step, you link the input property values of theCreateFlightOrder step both to the output
of theGetFlights step and to the sample Excel file you associated with your test.

a. In the canvas, select theCreateFlightOrder step.

b. In the Properties pane, open the Input/Checkpoints tab .

c. In the Input/Checkpoints tab, in theValue cell for the FlightNumber input property, select
the Link to data source button .

d. In the "Select Link Source Dialog Box (API Testing)" (described on page 1840), link the
FlightNumber property to theGetFlights step output property of the same name. When
prompted if you would like to link the selected property as part of a loop, select No.

For details on linking to another test step property, see "Link your test step to another step"
on page 1820.

Note: By default, the FlightNumber property is not visible. Expand the
GetFlightsResult node and click theAdd button to expand all the output
properties.

e. In the Input/Checkpoints tab, link the remaining input properties to the relevant columns in
the Excel data source.

Note: Make sure to clear the NIL property on any property values.

6. Link the Report step input properties to the CreateFlightOrder step
For the final step of this tutorial, you will create a custom expression tomimic the Flight API
application's passing of flight data to a flight bookingWeb site page. For this, create the
custommessage that the results display.

a. In the canvas, select theReport Message step.

b. In the Properties pane, open the Input/Checkpoints tab .
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c. In the Input/Checkpoints tab, in theValue cell of theMessage property, select the Link to
data source button .

d. In the "Select Link Source Dialog Box (API Testing)", click theCustom Expression
button to display the expression area.

e. In the expression area, enter the text "Your flight order number is (with an extra space at
the end).

f. In the "Select Link Source Dialog Box (API Testing)", select the Available step option.

g. In the list of available steps (left pane), select theCreateFlightOrder step.

h. In CreateFlightOrder properties list in the right pane, in theOutput Properties section,
expand theCreateFlightOrderResult node.

i. In the output properties list, select theOrderNumber property.

j. Click Add to add this to the custom expression.

k. Click OK in the Select Link Source dialog box to add this expression.

l. The expression Your flight order number is
{Step.OutputProperties.StServiceCallActivity4.Body.CreateFlightOrderResponse.Create
FlightOrderResult.OrderNumber} appears in the Value column of theMessage property

7. View the run results
Run the test. When the Run Results Viewer opens, expand the nodes in the Run Results tree
and check the results of your steps in the Captured Data pane.

In the Response section of the Captured Data pane for the CreateFlight step and in the result
summary for the Report Message step, you should see the data values passed between steps.

How to Set the Data Source Navigation Properties
Relevant for: API testing only

This task describes how to set the navigation preferences for data stored in tables. You can set
different navigation properties for each data source. For details, see "NavigatingWithin a Data
Source" on page 1813.

This task includes the following steps:

l "Add a data source to the Test Flow or test loop" on the next page

l "Specify the navigation properties for the data source" on the next page

l "Create a new child relation" on the next page
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Add a data source to the Test Flow or test loop

1. Associate the necessary data sources with your test. For details, see "How to Add Data
Sources to an API Test" on page 233.

2. In the canvas, select the Test Flow or another test loop.

3. In the Properties pane, select theData Sources tab . The list of all currently associated
data sources is displayed.

4. In the Data Sources tab, click Add. The "Attach Data Source to Loop Dialog Box " (described
on page 1839) opens.

5. In the Attach Data Source to Loop dialog box, select the data source to add to the loop and
click OK.

The selected data source is now added to the loop and you can use it to link property values.

Specify the navigation properties for the data source

1. In the canvas, select the Test Flow or other test loop.

2. In the Properties pane, open theData Sources tab . The list of data sources associated
with the current loop is displayed.

3. In the Data Sources tab, click Edit. The "Data Navigation Dialog Box" (described on page
1846) opens.

4. In the Data Navigation dialog box, specify theStart andEnd rows.

5. Indicate the direction in which tomove when retrieving data from the table, Forward or
Backward, and the number of rows by which to advance for each iteration. Alternatively, you
can indicate tomove to a random row.

6. Specify the action to do when reaching the last row-Wrap around orKeep using that row.
Click OK.

For details on the Data Navigation dialog box, see "Data Navigation Dialog Box" on page 1846.

Create a new child relation
This step enables you to specify parent-child data source relations betweenmultiple data sources.
You can use parent-child relations forExcel, Local Table, andDatabase type data sources.

1. Add at least two or more Excel, Local Table, or Database data sources.

Note: This can also be a single Excel file with two worksheets.

2. In the Data pane, select the data source that you want to designate as a parent.
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3. In the Properties, open the "Data Source Properties Tab (Properties Pane - API Testing)"
(described on page 406).

4. Click theAdd button. The "Define New/Edit Data Relation Dialog Box" (described on page
1849) opens.

5. Specify the details of the new relation:

n The data source to use as the child data source

n The primary key - the data column in the parent data source

n The foreign key - the data column in the child data source. This column is used in place of
the primary key column in the parent data source when running the test.

Click OK after specifying the data source details. The data relation is displayed in the Data
Source Properties tab for the parent data source.

How to Data Drive an API Test Step
Relevant for: API testing only

This task describes how to data drive a test step. Data driving is UFT's mechanism for
automatically creating data expressions for step properties.

For further details, see "Data Driving" on page 1811.

This task includes the following steps:

l "Prerequisite" below

l "Open the Input Properties tab" below

l "Include the data " below

l "Data drive the test step" on the next page

l "Enter the data source values" on the next page

1. Prerequisite
Create a step in the canvas. For details, see "Add activities to the test to create test steps" on
page 1599.

2. Open the Input Properties tab

Display the step's properties grid. In the Properties pane,open the Input/Checkpoints tab .

3. Include the data
To include optional properties in the data driving, toggle the triangle icon adjacent to the
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property. A filled-in triangle indicates an included property.

4. Data drive the test step

a. In the Input/Checkpoints tab, click theData Drive button. The "Data Driving Dialog
Box" (described on page 1834) opens.

b. In the Data Driving dialog box, choose a Data provider: Excel orXML.

c. Select the properties upon which you want to apply data driving: input properties,
checkpoints, or both.

d. If you specified anExcel provider and data-driving for both input properties and
checkpoints, specify whether to place the data for both sections in the same Excel
worksheet or different ones.

e. Indicate whether you want toConfigure '<loop name>' as a For Each loop using the
new data source. This option repeats the steps in the loop frame according to the number
of data rows in the Excel or XML data source. If you disable this option, you canmanually
set the number of iterations via the loop properties. This setting overrides the general loop
properties. For details, see "Loop Activity" on page 1652.

f. Click OK.

g. UFT prompts you to confirm the action. Click OK.

UFT populates the value columnwith data expressions. The expressions are preceded by
informational icons, indicating read-only status or unmatching data types.

Note: If your properties are within an array, youmust create at least one array element
to allow data driving. To add an array element, select the array's parent node and click
theAdd button . If you do not add at least one element, then the array will not be
data driven.

For user interface details, see the "Data Driving Dialog Box" on page 1834.

5. Enter the data source values
In the Data pane, edit the contents of the newly created data tables or XML source.

How to Data Drive Array Checkpoints
Relevant for: API testing only

This task describes how to set checkpoints for elements of an array through data driving. For
details about setting regular checkpoints, see "How to Run an API Test" on page 643.
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This task includes the following steps:

l "Enable active content on your computer" below

l "Add a step with an array output" below

l "Add an array element" below

l "Data Drive the array" below

l "Set the evaluation expression" below

l "Provide data for the array" on the next page

l "Select an array validationmethod" on the next page

l "Set the number of iterations - optional" on the next page

l "Run the test" on the next page

l "Open the Checkpoint report" on the next page

1. Enable active content on your computer
The RunResults Viewer shows array checkpoint results in an expandable tree. To enable this
view, configure your browser to allow active content as described in "How to Set Array
Checkpoints for Test Steps" on page 1615.

2. Add a step with an array output
Add a test step with output properties in the form of an array.

3. Add an array element
a. Open the Properties pane and click in theCheckpoints area.

b. Use the plus button . in the row of the parent node, to add an array element.

c. Provide property values. These values are transferred to the Data pane during data driving.
If you do not provide data, include the array element by selecting the triangle icon in the
parent node.

4. Data Drive the array

a. Select the array's parent node and click theData Drive button .

b. In the "Data Driving Dialog Box" (described on page 1834), select Only Input,
Checkpoints orBoth Input and Checkpoints as aData Driven Section option.

c. Click OK. The data drivingmechanism informs you that it succeeded.

5. Set the evaluation expression
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In the Properties pane, adjacent to the data driving expression, select an evaluation operator,
such as =, <, and so forth.

6. Provide data for the array
a. Once you data drive an array, you do not set property values from theCheckpoints pane.

Instead, you edit the table in the Data pane. In the Data pane, which opens automatically,
click the node in the left pane, corresponding to the array element that is to be validated.

b. Enter the iteration number to which to checkpoint should be applied in theMainDetails
column of the <array_name> andMainDetails tables. A "1" indicates the first iteration. If
you have several columns with "1" as the iteration number, the checkpoints will be
validated against all of those values.

7. Select an array validation method
Select the step in the canvas and view the Properties pane. Expand the drop down adjacent to
the name of the parent array node. Select one of the following:

n Fixed. Checks that each of the returned array elements matches the corresponding array
element in the data table in the Data pane. Each array is marked by an index number, as it
checks the arrays by their index.

n All. Checks that all of the returned array elements match the array element in the Data
pane. In this mode, arrays are not marked by an index number. For example, if a property in
the first array is marked >= 2 and the same property in another array element is set to <=10,
the test run will check that all returned values are between 2 and 10.

n Contains. Checks that at least one of the returned array elements matches the value of the
property in theCheckpoints pane. In this mode, arrays are not marked by an index number.

8. Set the number of iterations - optional
If you selected theConfigure Test Flow as a ForEach loop using the new data source
option in the "Data Driving Dialog Box" (described on page 1834), you can skip this step. If
not, click in the Test Flow or Loop box and open the Properties pane. Set the test flow
properties, such as the number of iterations or loop type.

9. Run the test
Click theRun button and provide a results location. For details, see "How to Run an API Test"
on page 643.

10. Open the Checkpoint report
In the Run Results Viewer, expand the test results tree in the left pane. Select a Checkpoint
node. In theCaptured Data pane, click View Report in the Details column. In the report that
opens, expand the checkpoint node for each of the iterations to view its actual and expected
value.
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How to Parameterize XML Data
Relevant for: API testing only

This task describes how to parameterize XML data. Suppose you pasted or loaded an XML file as
the request body for your step. Using the parameterization capabilities, you can replace a constant
value with a data source expression.

1. Prerequisites
Create a test step that uses XML text in the request body. This applies to Network and XML
type activities. If you intend to parameterize the data with a data source, import or create the
data source. For details, see "How to Add Data Sources to an API Test" on page 233.

2. Add the XML body text

a. Using the Properties pane, open theHTTP tab .

b. Click the Load File button and load an XML file or paste XML code directly into theBody
area.

3. Select the text to parameterize
a. In theHTTP tab, select Text from theBody type drop-down list.

b. In the Body area, select the text value that you want to replace and select Link to Data
Source from the right-click menu.

4. Select a link source
In the Select Link Source dialog box, select a data source type, such as Available steps or
Data source column. Select the node that you want to use for parameterization. Click Add.

User Guide
Chapter 58: Data Usage in API Tests

HP Unified Functional Testing (12.00) Page 1831 of 2274



Note that the expression changed.

5. Verify the value in the Properties pane
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In the Properties pane, check the Body area, and verify that the constant value was replaced
with the data source expression.
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Reference

Data Driving Dialog Box
Relevant for: API testing only

Enables you to populate the input property and checkpoint values for a step, with data expressions.

To access 1. Select a step within the canvas.

2. In the Properties pane, open the Input/Checkpoints tab .

3. Click in the Properties pane's toolbar.

Relevant tasks "How to Data Drive an API Test Step" on page 1827

See also "New/Change Excel Data Source Dialog Box" on page 255

The following elements are included:

UI Elements Description

Data Provider The source type of the data: Excel orXML.
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UI Elements Description

Data Driven
Section - for
Input/Checkpoint
properties

The type of properties upon which to apply the data driving. These options
are available when data driving standard input and output checkpoints
properties.

l Input. All input properties listed in the grid.

l Checkpoints. All checkpoints listed in the grid. For array type
properties, youmust create at least one array element in order to data
drive the array.

l Both Input and Checkpoints. All properties.

Note: Activities that do not have output parameters, such as Report
Message andSystem type activities, will only show the Input option.

Data Driven
Section - for
Request/Response

The schema to data drive. These options are available when data driving
XSD schema files for anHTTP, SOAP Request, orREST step.

l Request Body. All input properties associated with the request body.

l Response Body. All output properties associated with the response
body. For array type properties, youmust create at least one array
element in order to enable data driving.

l Both Request Body and Response Body. All entities in both
schemas.

Note: These options are only available after importing a schema into
the Input and/orCheckpoints sections.

Data Driven
Section - for
SOAP Fault
properties

Fault Properties. The SOAP Fault properties to data drive. This option is
available when invoking data driving in the Properties pane's SOAP Fault
view.

Note: These options are only available forWeb Service and SOAP
Request steps.
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UI Elements Description

Data Driven
Section - for
Multipart
properties

Themultipart properties to data drive. These options are available for an
HTTP step with amultipart message.

l Request MultipartInfo. Only Request multipart properties.

l Response MultipartInfo. Only Responsemultipart properties.

l Both Request MultipartInfo and Response MultipartInfo. All
multipart properties.

Use the same data
source for both
sections

Uses the same data source for the Input/Checkpoint properties or
Request/Response body. When selected, UFT creates a single Excel
worksheet with columns for both the Input andOutput properties. For
example, for the sample application's CreateFlightOrder step, UFT
creates a single worksheet with columns for the Input properties: Class,
CustomerName, DepartureDate, FlightNumber, NumberofTickets, and
theOutput properties: OrderNumber, and TotalPrice.

Note: This option is available only when selecting theBoth option,
for an Excel Data Provider type.

Configure 'Test
Flow/Loop' as a
ForEach loop
using the new data
source

Runs the steps in the Test Flow or Loop using a For Each type loop, with
the values from the newly created data source. The number of iterations is
determined by the number of rows in the data source—it performs one
iteration for each row. This setting is applied to the innermost loop
containing the data-driven step.

Note: This option overrides the configuration that youmay have set
for the Test Flow/Loop settings. For details, see "Loop Activity" on
page 1652.
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Data Link/Relation Message Box
Relevant for: API testing only

This message box lists the elements that were not found in the new Excel file, when you changed
the data source's existing Excel file.
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To
access

Do the following:

1. Save the test.

2. In the Data Pane, select themain node of an existing Excel data source.

3. In the Properties pane, select Change Excel File.

4. In the "New/Change Excel Data Source Dialog Box""New/Change Excel Data
Source Dialog Box"(described on page 255), specify a new Excel file.

5. Click OK to permanently remove all of the listed items and save the test.

Note: This dialog box only opens if the new Excel file has renamed ormissing
worksheets or columns, which affect data links or data relations.

Relevant
tasks

l "Add an Excel data source" on page 234

l "How to Assign Data to API Test/Component Steps" on page 1819

See also l "New/Change Excel Data Source Dialog Box" on page 255

l "NavigatingWithin a Data Source" on page 1813

l "Parent/Child Data Source Relations" on page 1814

User interface elements are described below:

UI Elements Description

More
Details/Less
Details

Expands or collapses theDetails section to show or hide data links or data
relations that will be removed when you click OK.

Data Links
table

A table of all of the affected data links. The table displays the step name, the
affected property of the step, and the specific data link.

Data
Relations
table

A table of all of the affected data relations. The table lists the name of the
Primary Data Source, the name of theChild Data Source, the affected column
in the primary data source (Primary Key) and the affected column in the child
data source (Foreign Key).

Copy
details to
clipboard

Copies the details to the clipboard, in a comma separated format.
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Attach Data Source to Loop Dialog Box
Relevant for: API testing only

This dialog box enables you to add a data source to the current loop.

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the solution explorer, select an API test or component.

2. Associate a data source or multiple data sources with your test in the Data
pane

3. In the canvas, select the Test Flow or another test loop.

4. In the Properties pane, open theData Sources tab .

5. Click theAdd button.
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Important l Youmust first define data in the Data pane before you generate a list of data
sources.

l When you link any step in the loop to the data, it automatically adds a data
source to the loop.

For details, see "How to Assign Data to API Test/Component Steps" on page
1819.

Relevant
tasks

"How to Set the Data Source Navigation Properties" on page 1825

See also "Data Navigation Dialog Box" on page 1846

User interface elements are described below:

UI Element Description

Select a data source A list of the available data sources.

Select Link Source Dialog Box (API Testing)
Relevant for: API testing only

This dialog box enables you to select a data source for the step's properties.
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To access Click the Link to data source button
in theValue column of the

property for which you want to select a
data source.

Important information l To see the icon, move the cursor to
the right of the property value area.

l A step property not contained
within a loop, cannot be linked to a
data source. For example, the For
Loop's Number of Iterations
property, cannot be linked to a data
source, since it is not contained
within the Test Flow loop.
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Relevant tasks "How to Assign Data to API
Test/Component Steps" on page 1819

See also l "How to Add Data Sources to an
API Test" on page 233

l "How to Set the Data Source
Navigation Properties" on page
1825

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements
Relevant
for Description

Link from: All types The source for the property value:

l Available steps. A property value from another step.

l Data source column. A value from a data source—Excel,
XML, local table, or database.

l Test variables. A value of an test variable—either a user-
defined variable or a system variable.

Select a step Available
steps

A tree hierarchy of the steps whose properties are available as
data for the current step. This list could include:

l Previous steps.

l An input value of the current step, when selecting data for a
property in theCheckpoints section.

l For loop type steps, previous steps or other steps within loop.

Select a
property

Available
steps

The step's linkable properties. The displayed sections depend on
the step type. For most step types, the Checkpoints section is
displayed.

Select data l Available
steps

l Data
source
column

l For table-based data sources such as Excel, local tables and
database: a list of the columns in the data table.

l For XML data sources: a hierarchy of the data source's
nodes.

Matching
data types
only

Data source
column

Hides all columns (or schema rows for XML data sources) whose
data types do not match the properties of the step whose value
you want to set.
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UI Elements
Relevant
for Description

Attach the
data source
to the loop

Data source
column

A drop down list of the loops in the test containing the step. The
data source is only associated with the selected loop.

Default: Innermost loop containing the step.

<user
variable
grid>

Test
variables

A list of the user-defined test variables and their values in the
current profile.
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UI Elements
Relevant
for Description

<system
variable
grid>

Test
variables

A list of the system environment variables and their values:

l IsLoadTest

l TestDir

l TestName

l LocalHostName

l OS

l OSVersion

l ProductDir

l ProductName

l ProductVer

l UserName

l CurrentDate

l QcUrl

l QcUserName

l QcPassword

l QcDomain

l QcProject

The following variables are available when running the test on a
remote agent:

l CurrentRunID

l CurrentTestSet

l CurrentTestSetID

l CurrentTestInstanceID

Custom
Expression

All types Expands the dialog box to allow you tomanually edit the link and
create a custom expression. This is useful for creating an
expression that uses multiple sources.
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Data Retrieval Options for Load Test Enabled Tests
For Load Test Enabled tests, the Select Link Source dialog box provides additional controls for the
Input properties, when choosing theData source column option.

User interface elements are described below:

UI Elements Description

Use a unique value
for each Virtual User
when load testing

Assigns a unique value to each Virtual User, from the data table, with
the following properties:

l Data source parameter. The parameter to use as a source of
values for the selected input property.

l Update value on. The frequency by which LoadRunner will update
the values: Each Iteration, Each Occurrence (of the parameter),
orOnce.

l When out of values.The action to do when reaching the end of the
data table:

n Abort Vuser. End the test run for the Virtual User.

n Continue Cyclic. Return to the top of the data table and use the
data in a cyclic manner.

n Continue with Last. Use the last value retrieved from the data
table for all subsequent occurrences.

Allocate Virtual User
values in the
Controller

Allocates a specific amount of values from the data table for the Virtual
User:

l Automatically allocate block size. Automatically allocates a
block size from the data based on the number of iterations and
Virtual Users (only for Update value onEach Iteration).

l Allocate <amount> values for each Virtual User. Allocates a
specific number of values for each Virtual User.

Note: Allocation is only possible when choosing Update value on
Each Occurrence orEach Iteration..
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Data Navigation Dialog Box
Relevant for: API testing only

This dialog box enables you to set the data navigation properties for your test loop. You can set the
direction in which to use the data, from where to begin, and the condition for selecting data.
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To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. In the Properties pane, link a property to a data source .

3. In the canvas, select the Test Flow or another test loop.

4. In the Properties pane, Open theData Sources tab .

5. Select a data source in the list and click Edit.

Relevant tasks "How to Set the Data Source Navigation Properties" on page 1825

See also "NavigatingWithin a Data Source" on page 1813

User interface elements are described below:

UI Elements Description

Start The location from where to begin taking data from the data source.

l Start at. The row of data from which to begin: First row, Last row,
Specific row, Random row, or First row matching.

l Row. The row number from which to begin (only available when selecting
Specific row).

l Condition. The condition the data row must meet in order to start the
looping (only available when selecting the First row matching option):

n Column. One of the data source's columns.

n Comparison operator. =, !=, >, >=, <, <=, Starts, Ends, Contains, or
Regex (depending on the row's data type).

n Value. The value to bematched in order to use this row of data.

Move The direction and amount of rows by which to advance within the data.

l Move by. The number of rows to advance (not relevant forDirection >
To a random row).

l Direction. The direction in which tomove: Forward, Backward, or To a
random row.
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UI Elements Description

End When to stop the looping through the data: First row, Last row, Specific
row, or First row matching.

l Row. The row number in which to end (only available when selecting
Specific row).

l Condition. The condition the data row must meet in order to end the
looping (only available when selecting the First row matching option):

n Column. One of the data source's columns.

n Comparison operator. =, !=,>, >=, <, <=, Starts, Ends, Contains, or
Regex (depending on row's data type).

n Value. The value to bematched in order to use this row of data.

Note: This setting stops the looping only when the loop type is set to
'For Each' (see "Loop Activity" on page 1652) and the current data
source whose navigation settings you are editing, is the same data
source that is linked to the loop.

Tip: This setting is only relevant when theMove direction is set to
Forward orBackward. For the To a random row option, each row is
visited once in random order. The navigation ends after all of the rows
were visited.

Upon reaching
the last row -
Action:(Move
Forward)

The action to take when reaching the last row of data.

l Keep using that row. Keep using the last row of data for all subsequent
loops.

l Wrap around. Start again from the first row of data.

Upon reaching
the first row -
Action:(Move
Backward)

The action to take when reaching the first row of data.

l Keep using that row. Keep using the first row of data for all subsequent
loops.

l Wrap around. Start again from the last row of data.

User Guide
Chapter 58: Data Usage in API Tests

HP Unified Functional Testing (12.00) Page 1848 of 2274



Define New/Edit Data Relation Dialog Box
Relevant for: API testing only

This dialog box enables you to define or edit a new data relation for a data source. The following is
an example of the Define New Data Relation dialog box:

To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. Make sure you have at least one data source in the Data pane.

3. In the Data pane, select a data source.

4. In the Properties pane, open theData Source Properties tab .

5. Click Add orEdit.

Relevant tasks "Create a new child relation" on page 1826

User interface elements are described below:

UI Elements Description

Parent data
source

The name of the parent data source, selected in the Properties pane (read-
only).
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UI Elements Description

Child data
source

The sheet or table to use for the child data source.

Primary key The column in the parent data source.

Foreign key The column in the child data source to use in place of the primary key
column.

New Exposed Property Dialog Box
Relevant for: API testing only

Note: This dialog box is relevant only if you are working withAPI tests created in UFT 11.51 or
earlier or Service Test 11.51 or earlier.

This dialog box enables you to expose an internal HTTP property andmake it available to other
steps, from the wrapper. This is primarily useful for REST service steps with inner HTTP
Requests.

)
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To access Do one of the following:

From within the Add/Edit REST Service dialog box:

l Define a REST servicemethod.

l In the right pane, click theCustom Input/Checkpoints tab.

l Click within a property row.

l Select Expose as Input Property orExpose as Output Property from the
right-click menu.

From within the canvas:

l Add a RESTmethod to the canvas. Expand it and select its innerHTTP step.

l Open the Properties pane and click within a property row.

l Select Expose as Input Property orExpose as Output Property from the
right-click menu.

Relevant
tasks

"How to a Create a REST Service" on page 1746

See also "Add/Edit REST Service Dialog Box" on page 1772

The following elements are included:

UI
Elements Description

Name A name for the exposed property.

Type A drop down list of simple data types, such as String, Integer, and so forth. This
field is read-only as it is determined by the exposed property's type.

Description A description of the property.
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Troubleshooting and Limitations - Using Data in API
Tests and Components

Relevant for: API testing only

This section describes troubleshooting and limitations for working with data.

General

l If a specified data source is or becomes inaccessible, the test will not fail. The Errors pane and
report, however, indicate that there was an error in retrieving the data.

l Keywords such as #SKIP#, and so forth, are not supported in the Input property grid.

Workaround: Link to a data source that contains the keyword.

l When adding a referenced Excel data source, if the file requires special credentials (for example,
a location on another domain or a drive requiring authentication), youmust verify that the
operating system will allow access to the file.

l Data sources with parent-child relationships, should not be accessed together in the same loop,
unless the child data source is used for data-driving array elements. Accessing parent-child data
sources in the same loop, may corrupt the test.

l Linking to file names is not supported forHTTP Request andHTTP Receiver activities that use
the File typemessage body.

l For data sources with child relations: If you change the name the Key column in the child sheet,
the Define New/Edit Data Relation dialog box does not reflect the new column name in the drop
down lists.

Data Driving

l Data driving for JSON requests or responses, is only supported for Excel.

l Data driving for an Excel data source is only effective for the first 254 properties of a step. If a
step has more than 254 properties, they will not be data-driven.

l Data driving for an Excel data source is only supported for property values consisting of 255
characters or less. If a property value has more than 255 characters, the data drivingmechanism
offers to truncate the string.

l When data driving a test step that has an array with two or more nested levels, the data driving
engine only copies the first element of each array to the Excel data tables.

l Keyword data driving to an XML data source is not supported.
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Chapter 59: Updating Services and Assemblies
Relevant for: API testing only

This chapter includes:

Concepts 1854

UpdatingWeb Services 1854

REST Service Conflicts 1855

Updating SAP RFCs or IDocs 1855

Tasks 1857

How to Update aWeb Service 1857

How to Update a .NET Assembly 1859

How to Resolve Conflicts in a REST Service Test Step 1860

How to Update an SAP RFC or IDoc 1861

Reference 1863

Update Port Security Wizard 1863

Update Step/Activity Wizard 1866

Resolve RESTMethod Steps Wizard 1871

Troubleshooting and Limitations - Updating 1876
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Concepts

Updating Web Services
Relevant for: API testing only

You can updateWeb services that exist in the Toolbox pane, from their original locations or from
alternate locations.

When you update a service, UFT first compares the service and port names. If the port names
match, UFT transfers all of the data from the updated service, including new security information. If
the new version of the service contains a port that was not present in the original service, it adds it
to the Toolbox pane, as an additional port for the service.

If the port paths (<service name:port name> combination) do not match, and security was set for on
the port level, UFT opens theUpdate Port Security Wizard. For details, see the "Update Port
Security Wizard" on page 1863.

If HTTP transport information such as the endpoint was changed, UFT will update this
automatically, as long as the port path is the same.

In the next step of the update, UFT compares the operations and properties of the current test
steps. UFT tries tomatch up the properties that were assigned values between the original service
and the updated version.

If the operation names do not match, the Update Step wizard enables you tomap the new operation
name to the original name.

If the operation names match, but the property names do not, the Update Step wizard enables you
tomap the new property names to the original ones. Matching properties are ones that have the
same XPaths and types.

The wizard screenmarks resolved properties in green and unresolved properties in red.

If you originally imported a service from ALM through Service Test Management, youmust update
the service in ALM—youwill not be able to update the service through UFT.
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When you update an RPC Web service, as long as the operation names match, the properties are
marked as resolved. If the operation names cannot be resolved, UFT opens the wizard. If there is
no operation available to map to the original, the wizard suggests that you delete the affected step.

For task details, see "How to Update aWeb Service" on page 1857.

You can also update the data assigned to properties. When working with an Excel data source, you
can update the data in the Data pane. For details, see "New/Change Excel Data Source Dialog
Box" on page 255.

REST Service Conflicts
Relevant for: API testing only

Using REST services that you added to the Toolbox pane, you can create tests with minimal
configurations. For details, see "How to a Create a REST Service" on page 1746.

If youmodify a REST step's properties after incorporating it into your test, it will no longer match the
method in the Toolbox. Youmay want to keep the change, or youmay want to remove the conflicts
so that your step will match themethod defined in the toolbox.

Youmay encounter conflicts in the following areas:

l Adding or removing an input or output property

l Renaming an input or output property

l A change in the REST service URL

l A change in the HTTP request/response body type or schema

l Internal links between a REST property and its inner HTTP elements (if you are working with an
API test created inUFT 11.51 or earlier or Service Test 11.51 or earlier

l HTTP methods

The Resolve RESTMethod Steps wizard enables you to view the conflicts and decide what to do
with the conflicts in your test step—keep, remove, or map them. The wizard lets you resolve
property-related conflicts. Other conflicts, such as discrepancies in the URL values, the HTTP
body, and so forth, are resolved automatically.

For wizard details, see the "Resolve RESTMethod Steps Wizard" on page 1871.

For task details, see "How to Resolve Conflicts in a REST Service Test Step" on page 1860.

Updating SAP RFCs or IDocs
Relevant for: API testing only

You can update SAP RFCs and IDocs from their original location or from another connection or
location.
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TheUpdate option automatically updates the item from its original location. UFT loads the
information for the RFC/IDoc with the same names, from the original connection.

TheUpdate from option lets you specify different connection information, or a name of a different
RFC/IDoc on the same server.

If UFT detects an inconsistency between the original and updated RFC/IDoc names or their
properties, it enables the Update Step wizard. This wizard lets youmap the original and new items.
For details, see "How to Update an SAP RFC or IDoc" on page 1861.
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Tasks

How to Update a Web Service
Relevant for: API testing only

This task describes how to update aWSDL-BasedWeb Service that was already imported and
incorporated into a test.

This task includes the following steps:

l "Prerequisites" below

l "Update the service " below

l "Run the Update Port Security wizard - optional" below

l "Run the Update Step wizard" on the next page

1. Prerequisites
If you want to update theWSDL from ALM, make sure you have an open connection to the
ALM server. For details, see the "ALM Connection Dialog Box" on page 737.

2. Update the service
n To update a service from its original location, select its main node in the Toolbox pane.

ChooseUpdate WSDL from the context menu.

n To update the service from a different location, or if theUpdate WSDL option is not
available:

i. Select the service's main node in the Toolbox pane.

ii. ChooseUpdate WSDL from > URL or UDDI orUpdate WSDL from > File or
ALM Application Component from the right-click menu.

iii. Navigate to theWSDL and click OK.

iv. Accept any warning or informational pop-ups.

Note: TheUpdate WSDL optionmay not be available if the user credentials changed or if
the service was imported using Service Test or an earlier version of UFT.

3. Run the Update Port Security wizard - optional
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If UFT detects a change in the port path (<service name:port name> combination) theUpdate
Port SecurityWizard opens. The wizard only opens if you configured security settings for the
original service. Follow the steps of the wizard to resolve all of the Service/Port conflicts. For
details, see "Update Port Security Wizard" on page 1863.

Note:

n The wizard imports all of the services defined in theWSDL, even those deleted
manually before the update. To remove them from the Toolbox pane, delete them again
manually, after the update.

n If youmanually remove a service with conflicts from the Toolbox pane, you will no
longer be able to resolve the conflicts using the wizard.

4. Run the Update Step wizard
If a test step became invalid because an operation name changed or properties with values
were changed, then the canvas marks the step with a warningmarker.

For details about the wizard, see the "Update Step/Activity Wizard" on page 1866.

a. Click the warningmarker to display themessage The step must be resolved. Resolve
step. Click on themessage text. TheUpdate Step Wizard window opens.

Note that the step's properties become read-only, until you resolve them with the help of
the wizard.

b. In theSelect Operation page, click in theNew Operation pane and select the operation
that corresponds to the one in theOriginal Operation pane. Click Next. Properties for
which conflicts were detected are highlighted in red.

c. In theUpdate Input Properties page, in theOriginal Properties pane, select a property
for which there is a conflict, highlighted in red. In the right pane, New Properties, select a
property to map.
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Click Map. The wizard adds themapping to the list in the bottom pane. Repeat this for all
properties that you want to map. Click Next.

d. In theUpdate Output Properties page, select a property for which there is a conflict,
highlighted in red. In theNew Properties pane select the property to which you want to
map. Click Map. The wizard adds themapping to the list of mappings in the bottom pane.
Repeat this for all properties that you want to map. Click Next.

e. Click Finish to save your changes and close the wizard.

How to Update a .NET Assembly
Relevant for: API testing only

This task describes how to update a .NET assembly with a newer version. The updating of .NET
assembly is similar to the importing of an assembly described in "How to Import and Create a .NET
Assembly API Test Step" on page 1760.

This task includes the following steps:

l "Select the assembly to update" below

l "Open the Import .NET Assembly dialog box" below

l "Import a .NET assembly" below

l "Handle warnings - optional" below

l "Modify custom code - optional" on the next page

1. Select the assembly to update
In the Toolbox pane, expand the .NET Assemblies node and select the assembly you want to
update.

2. Open the Import .NET Assembly dialog box
Click the Import .NET Assembly button on the toolbar. For user interface details, see "Import
.NET Assembly Dialog Box" on page 1774.

3. Import a .NET assembly
Click the .NET Assembly Browser tab. Click Browse and locate the .dll or .exe file. Click
Open in the Open dialog box to add it to theSelected References list. Click OK to begin the
update.

4. Handle warnings - optional
If the updated .NET assembly is missing types that are in use by existing activities, you will
need tomodify the step properties. The canvas displays warning icons adjacent to the steps
whose properties use themissing type.
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5. Modify custom code - optional
If you wrote custom code in an event handler, youmay need tomodify the step properties. If
the updated .NET assembly is missing types that are used by the custom code, make sure to
modify the code to use only the types that are available.

How to Resolve Conflicts in a REST Service Test Step
Relevant for: API testing only

This task describes how to update a RESTmethod step that was changed.

This task includes the following steps:

l "Prerequisites" below

l "Modify the step as required" below

l "Open the wizard" below

l "Run the wizard" below

1. Prerequisites
Create one or more prototypemethods for REST services. Drag them onto the canvas to
create RESTmethod steps. For details, see "How to a Create a REST Service" on page 1746.

2. Modify the step as required
Modify the REST service step as required: add or remove properties, change property values,
and so forth. If there are conflicts, the canvas will display warning icons next to the relevant
steps.

3. Open the wizard
n To resolve conflicts for the selected step, click the warning icon in the top right corner of the

RESTmethod step in the canvas. Select This step should be resolved. Resolve step.
The Resolve RESTMethod Steps wizard opens.

n To resolve conflicts for all steps created with the prototype, right-click themethod in the
Toolbox pane and select Apply Changes to all Steps.

4. Run the wizard
a. Select the steps that you want to resolve (only relevant when opening the wizard through

the Toolbox pane).

The left pane, Before Changes, shows the step's properties before they were resolved.
The right pane, After Changes, shows the step's properties after they were resolved.
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b. Proceed with the wizard, resolving or keeping the detected differences.

For details about the wizard, see the "Resolve RESTMethod Steps Wizard" on page 1871.

How to Update an SAP RFC or IDoc
Relevant for: API testing only

This task describes how to update an SAP RFC or IDoc from its original or from a different location.

This task includes the following steps:

l "Update the RFC/IDoc from its original location" below

l "Update the RFC/IDoc from a different location" below

l "Run the Update Step wizard" below

Update the RFC/IDoc from its original location
To update an item from its original location, drill down to the actual RFC or IDoc in the Toolbox
pane. This assumes that the location and name of the RFC or IDoc did not change. ChooseUpdate
from the context menu.

Update the RFC/IDoc from a different location
To update an RFC or IDoc from a different server, or from the same server but a different RFC or
IDoc:

1. Select the RFC or IDoc in the Toolbox pane and chooseUpdate from from the context menu.
The Update <Item_Name> dialog box opens.

2. To change the connection or server information, select Override connection and specify the
details. Alternatively, you can change the default connection information in the "SAP
Connections Pane (Options Dialog Box > API Testing Tab)" described on page 568.

3. To select a different RFC or IDoc, search for it and select it in the bottom pane. For details, see
the "Import from SAP/Update Dialog Box" on page 1729.

4. Click Update. Accept any warning or informational pop-ups.

Run the Update Step wizard
If a test step contains conflicts because an RFC or IDoc name or property changed, then the
canvas marks the step with a warningmarker.

1. Click the warningmarker to display themessage The step must be resolved. Resolve step.
Click on themessage text. TheUpdate Step Wizard window opens.

Note that the step's properties become read-only, until you resolve them with the help of the
wizard.
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2. In the wizard's Select Activity page, click in theNew item area and select the operation that
corresponds to the one in theOriginal item pane. Click Next. Properties for which conflicts
were detected are highlighted in red.

3. If there are conflicted input properties, theUpdate Input Properties page opens. In the
Original Properties pane, select a property for which there is a conflict, highlighted in red. In
the right pane, New Properties, select a property to map. Click Map. The wizard adds the
mapping to the list in the bottom pane. Repeat this for all properties that you want to map. Click
Next.

4. If there are conflicted output properties, theUpdate Output Properties page opens. Select a
property for which there is a conflict, highlighted in red. In theNew Properties pane select the
property to which you want to map. Click Map. The wizard adds themapping to the list of
mappings in the bottom pane. Repeat this for all properties that you want to map. Click Next.

5. Click Finish to save your changes and close the wizard.

For details about the wizard, see the "Update Step/Activity Wizard" on page 1866.
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Reference

Update Port Security Wizard
Relevant for: API testing only

This wizard enables you to update ports that became invalid as a result of an update action. The
steps became invalid because the port path (<service name:port name> combination) changed.
The wizard enables you tomap old port names to new ones.

To
access

1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Import aWSDL using the Import WSDL toolbar button.

3. In the Toolbox pane, click on one of the service's ports and select Security
Settings from the right-click menu.

4. In the Security Settings for Port dialog box, configure the port's security.

5. Select the service's parent node in the Toolbox pane and select Update (or
Update from) from the right-click menu.

Note: This wizard only opens if there is a discrepancy between the service or
port names, and if the port's security settings were configured.

Relevant
tasks

"How to Update aWeb Service" on page 1857

Wizard
map

This wizard contains:

"Map Services and Ports Page" > "Finish Page"

See also "UpdatingWeb Services" on page 1854

Map Services and Ports Page

Relevant for: API testing only

This wizard page enables you tomap a port or service from the new WSDL, with the original
WSDL's service name and port. This page is repeated for each of the services for which there is a
conflict.
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Important
information

General information about this wizard is available here: "Update
Step/Activity Wizard" on page 1866.

Wizard map This wizard contains:

Map Services and Ports Page > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

Shows the service/port in theAvailable Services and Ports pane, that is mapped
to the service/port selected in theOriginal Service and Ports pane.

Shows the service/port in theOriginal Service and Ports pane, that is mapped to
the service/port selected in theAvailable Services and Ports pane.

Maps the selected service/port in theOriginal Service and Ports pane, to a
service/port in theAvailable Services and Ports pane. After youmap a
service/port, the grid displays it in green.

Note: This button is enabled only if you select a red or black service/port in
theOriginal Service and Ports pane, and a service/port in theAvailable
Services and Ports pane.

Removes themapping of the selected service/port in theOriginal Service and
Ports pane, from a service/port in theAvailable Services and Ports pane.

Note: This button is only enabled if you select themapped service/port in both
panes. To find themapped service/port, use theShow Match buttons.

<mapped
property
list>

A list of all themapped services and ports—the ones mapped automatically by
UFT and the ones mappedmanually.

Tip: Click on a set of services and ports to highlight them in the upper panes.

Available
Services
and Ports

A tree hierarchy of all of the available services and ports. The services and ports
displayed in green text did not change in the update.
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UI
Elements Description

Original
Service
and Ports

A tree hierarchy of the first service or port for which a conflict was found. As you
click Next, the wizard proceeds to the next conflict. The wizard displays the
services and ports in the following colors:

Green. A service or port that did not change in the update or that was resolved
throughmapping.

Red. A services or port that changed during the update and requires mapping.

Black. A service or port that was resolved automatically during the update, but you
chose to unmap it.

Finish Page

Relevant for: API testing only

This wizard page indicates whether you successfully resolved the conflicts between your original
services and ports and those from the updated service.

Important
information

General information about this wizard is available here: "Update Port
Security Wizard" on page 1863.

Wizard map This wizard contains:

"Map Services and Ports Page" > Finish Page

User interface elements are described below:

UI Elements Description

Ignores
unresolved
services/ports

Ignores unresolved conflicts. If you intend to remove the unresolved
services, you can enable this option.

Tip: To return to the wizard screens to resolve all of the services or
ports, click Back.

Finish Closes the wizard and applies your changes to the test.

Note: Enabled when you successfully map all unresolved services
and ports, or when you choose to ignore unresolved conflicts.
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Update Step/Activity Wizard
Relevant for: API testing only

This wizard enables you to update test steps that became invalid as a result of anUpdate from
action. The steps became invalid because the step/activity was removed or changed, or property
names weremodified. The wizard enables you tomap old operations/activities and properties to
new ones.

To
access

1. Do one of the following:

n Ensure that an API test or component is in focus in the document pane.

n In the Solution Explorer, select an API test or component.

2. Use the Toolsmenu to import aWeb service or an SAP RFC or IDoc.

3. Drag an operation/activity from the Toolbox pane onto the canvas and set input
values.

4. Select the parent node and select Update orUpdate from in the shortcut
menu. Accept any warning popupmessages.

5. Click on the alert adjacent to the step .

6. Click on the text The step must be resolved. Resolve step.

Note: The wizard will open only when there is a change in property names that
were assigned values.

Relevant
tasks

"How to Update aWeb Service" on page 1857

Wizard
map

This wizard contains:

"Select Operation/Activity Page" > "Update Input Properties Page" > "Update
Output Properties Page" > "Finish Page"

See also "UpdatingWeb Services" on page 1854

Select Operation/Activity Page

Relevant for: API testing only

This wizard page enables you tomap an operation/activity from the new service/RFC or IDoc, with
the original one. TheNext button proceeds to the next conflict.
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Important
information

l General information about this wizard is available here: "Update Step/Activity
Wizard" on the previous page.

l The wizardmay indicate that it could not find any compatible operations in the
updated contract. This may be a result of different SOAP versions.

Wizard
map

This wizard contains:

Select Operation/Activity Page > "Update Input Properties Page" > "Update
Output Properties Page" > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

<search box> For Web services:Enables you to filter the operations list. For example to
display only those operations containing the termGet, typeGet into the text
field.

New
operation/item
pane

For Web services:A tree hierarchy of the new service, its ports, and its
operations.

For SAP IDocs and RFCs:An expansion of the new item in the toolbox
showing the SAP Connection name, item type (RFC or IDoc), and item name.

Original
operation/item

For Web services:A tree hierarchy of the operation in the selected test step.

For SAP RFCs and IDocs: The original RFC or IDoc.

Apply to all
steps of this
type

Converts all test steps using the original operation/item, to steps using the new
operation/item name. If you do not select this option, you will need to resolve
the same conflict in other test steps, one-by-one.

Note: This option is only enabled when you havemultiple steps in the
canvas that use the original operation/activity.

Update Input Properties Page

Relevant for: API testing only

This wizard page enables you tomap new input properties with the original input properties.

Important
information

General information about this wizard is available here: "Update Step/Activity
Wizard" on the previous page.

Wizard map This wizard contains:

"Select Operation/Activity Page" > Update Input Properties Page > "Update
Output Properties Page" > "Finish Page"
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Shows the property in theNew Properties pane, that is mapped to the
property selected in theOriginal Properties pane.

Shows the property in theOriginal Properties pane, that is mapped to the
property selected in theNew Properties pane.

Maps the selected property in theOriginal Properties pane, to a property in
theNew Properties pane. After youmap a property, the grid displays it in
green.

Tip: This button is enabled only if you select a red or black property in the
Original Properties pane, and a property in theNew Properties pane.

Note:Whenmapping to an operation from anotherWSDL, the new
WSDLmust have the same SOAP version as the original.

Removes themapping of the selected property in theOriginal Properties
pane, from a property in theNew Properties pane.

Note: This button is enabled only if you select themapped properties in
both panes. To find themapped properties, use theShow Match buttons.

Original
Properties

A tree hierarchy of all of the original step's input properties. The text color
indicates the status:

Green. Properties that did not change in the update or that were already
mapped.

Red. Properties that changed during the update and require mapping.

Black. Properties that were resolved automatically during the update, but you
chose to unmap them.

New
Properties

A tree hierarchy of all of the new operation's input properties. The properties
displayed in green text, are properties that did not change in the update.

Show only
unmapped
properties

Hides all non-red properties. The red properties are the ones that UFT was
unable to resolve automatically during the update, and that you did not
previously resolve.

<mapped
property list>

A list of all themapped properties—the ones mapped automatically by UFT
and the ones mappedmanually.

Tip: Click on a set of properties to highlight them in the upper panes.
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Update Output Properties Page

Relevant for: API testing only

This wizard page enables you tomap new output properties with the original output properties. If the
step has no output properties, the wizard skips this step.

Important
information

General information about this wizard is available here: "Update Step/Activity
Wizard" on page 1866.

Wizard map This wizard contains:

"Select Operation/Activity Page" > "Update Input Properties Page" > Update
Output Properties Page > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets):

UI Elements Description

Shows the property in theNew Properties pane, that is mapped to the
property selected in theOriginal Properties pane.

Shows the property in theOriginal Properties pane, that is mapped to the
property selected in theNew Properties pane.

<mapped
property list>

A list of all themapped properties—the ones mapped automatically by UFT
and the ones mappedmanually.

Tip: Click on a set of properties to highlight them in the upper panes.

Map Maps the selected property in theOriginal Properties pane, to a property in
theNew Properties pane. After youmap a property, the grid displays it in
green.

Note: This button is enabled only if you select a red or black property in
theOriginal Properties pane, and a property in theNew Properties
pane.

New Properties A tree hierarchy of all of the new operation's output properties. The properties
displayed in green text, are properties that did not change in the update.
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UI Elements Description

Original
Properties

A tree hierarchy of all of the original step's output properties. The text color
indicates the status:

l Green. Properties that did not change in the update or that were already
mapped.

l Red. Properties that changed during the update and require mapping.

l Black. Properties that were resolved automatically during the update, but
you chose to unmap them.

Show only
unmapped
properties

Hides all non-red properties. The red properties are the ones that UFT was
unable to resolve automatically during the update.

Unmap Removes themapping of the selected property in theOriginal Properties
pane, from a property in theNew Properties pane.

Note: This button is enabled only if you select themapped properties in
both panes. To find themapped properties, use theShow Match
buttons.

Finish Page

Relevant for: API testing only

This wizard page indicates whether you successfully resolved the conflicts between your original
properties and the new ones.

Important
information

General information about this wizard is available here: "Update Step/Activity
Wizard" on page 1866.

Wizard map This wizard contains:

"Select Operation/Activity Page" > "Update Input Properties Page" > "Update
Output Properties Page" > Finish Page

User interface elements are described below:

UI Elements Description

Ignore
unresolved
properties

Ignores all unresolved input and output properties. If you intend to remove the
step with the unresolved properties from your step, you can enable this option.

Tip: To return to the wizard screens to resolve all of the properties, click
Back.
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UI Elements Description

Finish Closes the wizard and applies your changes to the test.

Note: Enabled when you successfully map all unresolved properties, or
when you choose to ignore unresolved properties.

Resolve REST Method Steps Wizard
Relevant for: API testing only

This wizard enables you to resolve differences between REST service steps and the prototype
method upon which they were based. The wizard detects changes such as added, removed, or
renamed properties and helps you resolve them. For details about the conflict types, see "REST
Service Conflicts" on page 1855.

To
access

Do one of the following:

l Ensure that an API test or component is in focus in the document pane.

l In the Solution Explorer, select an API test or component.

As a prerequisite:

1. Create a prototype for a REST servicemethod. For details, see "How to a
Create a REST Service" on page 1746.

2. Drag one or more REST servicemethods from the Toolbox pane to the canvas.

3. Select a RESTmethod in the Toolbox pane and chooseEdit Service from the
right-click menu. In the Edit REST Service dialog box, modify themethod's
properties and/or values.

To start the wizard:

l For the selected step only:Click on the alert in the bottom right corner of the
RESTmethod step and click the text The step should be resolved. Resolve
step.

l For all steps using the prototype method: In the Toolbox pane, right-click the
method and select Apply Changes to all Steps.

Relevant
tasks

"How to Resolve Conflicts in a REST Service Test Step" on page 1860

Wizard
map

This wizard contains:

"Select Steps Page" > "Resolve Conflicts Page" > "Finish Page"

User Guide
Chapter 59: Updating Services and Assemblies

HP Unified Functional Testing (12.00) Page 1871 of 2274



The wizard's global interface elements are described below:

UI
Elements Description

Cancel Closes the wizard, discarding all resolutions that youmade until this point.

Finish Does the following:

l Performs the automatic resolutions for remaining test steps whose conflicts were
not resolvedmanually.

l Ignores all remaining conflicting properties, by applying theKeep action to all of
them.

l Advances to the wizard's Finish page.

Next Proceeds to the conflicts of the next step. The wizard displays a separateResolve
Conflicts page for each step.

Select Steps Page

Relevant for: API testing only

When you start the wizard from the Toolbox pane, it enables you to resolve conflicts for all steps
that use the selectedmethod. This wizard page enables you to include or exclude specific steps in
which to apply the resolutions.

Important
information

l General information about this wizard is available here: "Resolve REST
Method Steps Wizard" on the previous page.

l The ability to select the steps to resolve, is only available when you open the
wizard from the Toolbox pane—not from the alert on the canvas.

l The wizard only checks those REST steps that are based on the prototype
selected in the Toolbox pane.

Wizard
map

This wizard contains:

Select Steps Page > "Resolve Conflicts Page" > "Finish Page"

User interface elements are described below (unlabeled UI elements are shown in angle brackets):

UI
Elements Description

<test
tree>

A tree hierarchy of the test steps.

The following steps of the wizard will only affect the selected steps.
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UI
Elements Description

Check
All

Selects all test steps in which a conflict was detected.

Uncheck
All

Clears the check box for all test steps in which a conflict was detected, excluding
them from the wizard.

Resolve Conflicts Page

Relevant for: API testing only

This wizard page enables you tomap new input/output properties with the original input/output
properties.

Important
information

l General information about this wizard is available here: "Resolve REST
Method Steps Wizard" on page 1871.

l The wizard repeats this page for each of themethods selected in the
previous step.

Wizard map This wizard contains:

"Select Steps Page" > Resolve Conflicts Page > "Finish Page"

User interface elements are described below (unlabeled elements are shown in angle brackets).
TheKeep, Remove, andMap buttons relate to both the Input andOutput properties.

UI Elements Description

<conflict
resolutions>

A list of all the resolved conflicts—the type of conflict, and the resolution.

The text color indicates the conflict status:

l Green. Conflicts that were resolved automatically or resolved by aKeep,
Map, orRemove action.

l Red. Conflicts that were not yet resolved or removed.
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UI Elements Description

Input
Properties /
Output
Properties

A list of all of the step's input/output properties.

l Before changes. A list of the step's original properties

l After changes. A list of the step's properties after the conflicts were
resolved.

The text color indicates the property status:

l Green. Properties that were resolved automatically or resolved by aKeep,
Map, orRemove action.

l Red. Properties for which a conflict was found, and not yet resolved.

l Black. Properties for which no conflict was found.

Keep Accepts the conflict for use within the test. The resulting test step's
properties do not correspond to the prototype.

Map Assigns the value of the selected property in theBefore changes pane, to
the property in theAfter changes pane After youmap a property, the grid
displays it in green.

Note: This button is enabled only if you select a red or green property in
theBefore changes pane, and a black or green property in theAfter
changes pane.

Remove Removes the selected conflicting property from the current test step.

Finish Page

Relevant for: API testing only

This wizard page indicates whether you successfully resolved the conflicts between the prototype
and the test steps.

Important
information

General information about this wizard is available here: "Resolve REST
Method Steps Wizard" on page 1871.

Wizard map This wizard contains:

"Select Steps Page" > "Resolve Conflicts Page" > Finish Page
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User interface elements are described below:

UI
Elements Description

Finish Closes the wizard and applies the resolutions to the test step.

Note: If you click the Finish button before resolving the conflicts, the wizard
applies aKeep action to all conflicts, and performs an automatic resolution for
non-property related conflicts.
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Troubleshooting and Limitations - Updating
Relevant for: API testing only

This section describes troubleshooting and limitations for updating services and assemblies.

REST Services

l When comparing a REST step to its prototype - a difference in the request/response body
contents is not considered a conflict. Therefore, when resolving a REST step whose contents
do not match the body contents of the prototype, the body contents will not be affected.
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Chapter 60: Web Service Security
Relevant for: API testing only

This chapter includes:

Concepts 1878

Setting Security Overview 1878

Security Scenarios Overview 1878

Advanced Security Settings 1884

Tasks 1885

How to Set Security for aWeb Service on the Port Level 1885

How to Set Security for a Specific Step 1886

How to Set Security for a StandardWeb Service 1887

How to Customize Security forWCF TypeWeb Services 1889

How to Set CommonWeb Services Security Scenario Properties 1893

How to Test Web Services that useWS-Security or SSL 1897

How to Set up Advanced Standards Testing 1898

Reference 1900

Security Settings for Port <Port_Name> Dialog Box 1900

Advanced Settings Dialog Box 1916

Select Certificate Dialog Box 1923

Troubleshooting and Limitations - Web Service Security 1926
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Concepts

Setting Security Overview
Relevant for: API testing only

When buildingWeb Service applications, there is a challenge in building scalable applications that
are secure. You can secureWeb Services by having themessage sent over a secure transport,
such as Secure Sockets Layer (SSL), or by applying security at themessage level, also known as
WS-Security.

For testing a secured service, answering the following questions will help you define your security
scenario.

l Is there transport security, such as SSL?What is the HTTPS URL?

l Is basic authentication required?

l Is mutual authentication required?

l What type of security is required in the SOAP header?

Security Levels
UFT lets you set the security for a service on two levels—port or operation. If you define a
security for a port, all of its methods use these settings, by default. When working in the canvas,
you can override the default port security for a given test step and customize the security for a
particular operation.

For task details, see "How to Set Security for a Specific Step" on page 1886.

Security Scenarios Overview
Relevant for: API testing only

UFT provides several built-in scenarios for configuring security inWeb Service calls.

A security scenario represents a typical security implementation for aWeb Service. It contains
information such as authentication, encoding, proxy, certificates, and so forth.

A defaultWeb Service scenario can be used for most Web services. It enables you to configure
both transport andmessage-level security. UFT support for message-level security lets you
manually configure the security elements such as tokens, message signatures, and encryption. For
details, see "Web Service Scenario Overview" on the next page.

WCF scenarios enables you to configure security for HTTP or custom bindings and work with
advanced specifications, such asWS-SecureConversation.

You use the default Web Service scenario for:
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l SimpleWeb Services where no advanced standards are required.

l Web services using HTTP transport level security.

l Web services usingmessage level security (WS-Security) for SOAP 1.1

You use aWCF scenario for:

l WCF Services that utilize advanced security andWS-Specifications.

l Web services usingmessage level security (WS-Security) for SOAP 1.2

Such services can be written in various platforms such as WCF (Windows Communication
Foundation), Metro (WSIT), and Axis2. UFT also supports proprietary standards and transports.

For details on the built-in security scenarios see one of following sections:

l "Web Service Scenario Overview" below

l "WCF Service (CustomBinding) Scenario Overview" on page 1881

l "WCF Service (Federation) Scenario Overview " on page 1882

l "WCF Services (WSHttpBinding) Scenario Overview " on page 1883

Web Service Scenario Overview

Relevant for: API testing only

The default Web Service scenario is based on theWS-Security specification. This scenario lets
you place security credentials in the actual SOAP message.

When a SOAP message sender sends a request, the security credentials, known as tokens, are
placed in the SOAP message. When theWeb server receives the SOAP request, it does not need
to send additional requests to verify the integrity of the sender. The server verifies that the
credentials are authentic before letting theWeb Service execute the application. By not having to
go back to the source of the credentials, the application's scalability improves significantly.

To further secureWeb Services, it is common to use digital signatures or encryption for the SOAP
messages. Digitally signing a SOAP message verifies that themessage has not been altered
during transmission. Encrypting a SOAP message helps secure aWeb Service by making it
difficult for anyone other than the intended recipient to read the contents of themessage.

The Security Settings dialog box provides the following tabs for theWeb Service scenario: HTTP,
WS-Security, andWS-Addressing. TheHTTP tab lets you configure the transport security, the
WS-Security tab handles themessage-level security, and theWS-Addressing tab sets the
addressing version.

You can use the following types of security:
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Transport Level Security
The transport level security includes the authentication and proxy server information. You can also
specify Keep Alive preferences and connection timeout. For user interface details, see "Result Tab
(Properties Pane - API Testing)" on page 427.

Message Level Security
TheWS-Security tab lets you set themessage level security through tokens, signatures and
encryption.

To support WS-Security, UFT enables you to create security tokens for your script. You can create
multiple tokens and set their properties. After creating a token, you use it to sign or encrypt a SOAP
message.

TheWeb Services security mechanism associates security tokens with messages. This
mechanism supports several security token formats to accommodate a variety of authentication
requirements. For example, a client might need to provide a proof of identity or a security certificate.

The available tokens are: UserName, X509 Certificate, Kerberos, Kerberos2, andSAML.

l UserName. TheUser Name token contains user identification information for the purpose of
authentication: User Name and Password. You can also specify Password Options, indicating
how to send the password to the server for authentication: Text, None, orHash. and indicate
whether to include a timestamp.

l X509 Certificate. This token is based on an X.509 certificate. To obtain a certificate, you can
either purchase it from a certificate authority, such as VeriSign, Inc. or set up your own
certificate service to issue a certificate. Most Windows servers support the public key
infrastructure (PKI), which enables you to create certificates. You can then have it signed by a
certificate authority or use an unsigned certificate.

l Kerberos /Kerberos2. (ForWindows 2003 or XP SP1 and later) The Kerberos protocol is used
tomutually authenticate users and services on an open and unsecured network. Using shared
secret keys, it encrypts and signs user credentials. A third party, known as a KDC (Kerberos
Key Distribution Center), authenticates the credentials. After authentication, the user may
request a service ticket to access one or more services on the network. The ticket includes the
encrypted, authenticated identity of the user. The tickets are obtained using the current user's
credentials.

The primary difference between the Kerberos and Kerberos2 tokens, is that Kerberos2 uses the
Security Support Provider Interface (SSPI), so it does not require elevated privileges to
impersonate the client's identity. In addition, the Kerberos2 security token can be used to secure
SOAP messages sent to aWeb Service running in aWeb farm.

l SAML Token. SAML is an XML standard for exchanging security-related information, called
assertions, between business partners over the Internet. The assertions can include attribute
statements, authentication, decision statements, and authorization decision statements.

SAML uses brokered authentication with a security token issued by STS (Security Token
Service). The STS is trusted by the client and theWeb Service to provide interoperable security
tokens. SAML tokens are important forWeb Service security because they provide cross-
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platform interoperability and ameans of exchanging information between clients and services
that do not reside within a single security domain.

Message Signatures and Encrypted Data
When you add a security token to a SOAP message, it is added to the SOAP message in the form
of an XML element in theWS-Security SOAP header.

Themessage, however, is exposed and therefore requires additional security. This is especially
true when the credentials, including the password, are sent in plain text as it is with role-based
security.

The twomethods used to secure the data aremessage signatures andmessage encryption:

l Message Signatures.Message Signatures are used by the recipients to verify that messages
were not altered since their signing. The signature is in the form of XMLwithin the SOAP
message. The recipient checks the signature tomake sure it is valid.

l Message Encryption. Although the XMLmessage signature offers amechanism for verifying
that themessage has not been altered since it was signed, it does not encrypt the SOAP
message—themessage is still plain text in XML format. To secure themessage in order that it
should not be exposed, you encrypt it, making it difficult for an intruder to view and obtain a
user's password.

For task details, see "How to Set Security for a Specific Step" on page 1886.

For user interface details, see "Security Settings for Port <Port_Name> Dialog Box" on page 1900.

WCF Service (CustomBinding) Scenario Overview

Relevant for: API testing only

TheWCF Service (CustomBinding) scenario enables the highest degree of customization. Since
it is based upon theWCFCustomBinding standard, it enables you to test most WCF services,
along with services on other platforms such as Java-based services that use theWS - <spec_
name> specifications.

Use theWCF Service (CustomBinding) scenario to configure a scenario that does not comply with
any of the predefined security scenarios. You can customize the transport and encoding settings:

l Transport. HTTP, HTTPS, TCP, orNamedPipe

l Encoding. Text,MTOM, orWCF Binary

You can also provide additional security information:

l Authentication mode. The type of authentication, such as None, AnonymousForCertificate,
and so forth. The options are available from the drop down list.

l Bootstrap policy. For theSecureConversation authenticationmode, you can specify a
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bootstrap policy.

l Net Security. The network security for TCP andNamedPipe type transports. Typical values are
None,Windows stream security, orSSL stream security available from the field's drop down
list. For services with HTTP transport, you should set the value toNone. To enable SSL for
HTTP, select HTTPS transport.

For task details, see "How to Customize Security forWCF TypeWeb Services" on page 1889.

For user interface details, see "WCF Service (Federation) Scenario (Security Settings for Port
<Port_Name> Dialog Box)" on page 1911.

Note: ForWSE3 security configurations, use theWCF Service(CustomBinding) Scenario. For
details, see "How to Customize Security forWCF TypeWeb Services" on page 1889.

WCF Service (Federation) Scenario Overview

Relevant for: API testing only

In theWCF Service (Federation) scenario, the client authenticates against the STS (Security
Token Service) to obtain a token. The client uses the token to authenticate against the application
server.

Therefore, two bindings are needed, one against the STS and another against the application
server.

You define the bindings in two stages:

l Provide security details for the application server's security scenario in the following areas:

n Server. The transport and encodingmethods.

n Security. The authenticationmode, such as IssuedToken, SecureConversation, and so
forth.

n Identity. Information about the server certificate and expected DNS.

n STS. Settings related to the STS, such as the endpoint address and binding.

l Define an STS binding in theReferenced binding field.

For task details, see "How to Customize Security forWCF TypeWeb Services" on page 1889.

For user interface details, see "WCF Service (Federation) Scenario (Security Settings for Port
<Port_Name> Dialog Box)" on page 1911.
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WCF Services (WSHttpBinding) Scenario Overview

Relevant for: API testing only

Note: TheWCFService (WSHttpBinding) scenario only supports the testing of WCF
services which utilizewsHttpBinding and incorporate some level of security. To test WCF
services that usewsHttpBinding but have no security, use theWCFService
(CustomBinding) scenario.

In theWCFService (WSHttpBinding) scenario, you can select from several types of
authentication: None, Windows, Certificate, or Username (message protection).

No Authentication (Anonymous)
In this scenario, the client uses the server's certificate to encrypt amessage; there is no client
authentication. Use this scenario to test Web Services where the:

l Client uses the server's X.509 certificate for encryption.

l Client is not authenticated.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.

Windows Authentication
This scenario uses Windows Authentication. If you are testing aWCF service that has not been
customized and uses the default configuration, use this type of scenario.

Use this scenario to test Web Services where the:

l Client and server useWindows authentication.

l Security is based on Kerberos or SPNEGO negotiations.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.

Certificate Authentication
In thisWCF WSHttpBinding scenario, the client uses the server's X.509 certificate to encrypt the
message and its own certificate for a signature.

Use this scenario to test Web Services where the:

l Client uses the server's X.509 certificate for encryption.

l Client uses its own X.509 certificate for signatures.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.

Username Authentication (Message Protection)
In theWCF WSHttpBinding scenario, the client uses the server's X.509 certificate to encrypt the
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message, and sends a user name and password to authenticate itself.

Use this scenario to test Web Services where the:

l Client uses the server's X.509 certificate for encryption.

l Client is authenticated with a username and password.

l Communicationmay utilize advanced standards such as secure conversation or MTOM.

For all of the authentication types, you can apply advanced settings as described in "Advanced
Security Settings" below.

For user interface details, see "WCF Service (WSHttpBinding) Scenario (Security Settings for Port
<Port_Name>) Dialog Box)" on page 1913.

Advanced Security Settings
Relevant for: API testing only

This scenario's settings let you customize For aWCFService scenario, you can add additional
advanced security settings, includingEncoding, Advanced Standards, Security, orHTTP and
Proxy. Not all settings are relevant for each of the scenarios.

For details, see the "Advanced Settings Dialog Box" on page 1916.
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Tasks

How to Set Security for a Web Service on the Port Level
Relevant for: API testing only

This task describes how to configure security settings for aWeb service on the port level. You can
override this by modifying the settings for a specific test step. For details, see "How to Set Security
for a Specific Step" on the next page.

This task includes the following steps:

l "Prerequisites" below

l "Open the Security Setting dialog box" below

l "Load existing settings - optional" below

l "Create a new security scenario" below

l "Save the settings - optional " on the next page

1. Prerequisites
Import at least oneWeb service.

2. Open the Security Setting dialog box
Right-click aWeb service's port node in the Toolbox pane and select Security Settings.

3. Load existing settings - optional
a. In the Security Settings dialog box, To load an existing set of UFT security settings, click

Import the .stss (Service Test Security Scenario) file.

b. Navigate to a .stss (Service Test Security Scenario) file and load it into your test. The
settings in the Security Settings dialog shouldmatch the settings saved in the security
settings file.

4. Create a new security scenario
Use the Security Settings dialog box to create a new security scenario or modify a loaded one:

a. In the Service Details dropdown, select a scenario type.

b. Configure the security settings for the selected scenario. For details, see the "Security
Settings for Port <Port_Name> Dialog Box" on page 1900.

c. ForWeb Service type scenarios, add tokens, signatures, and encryption. For details, see
"Web Service Scenario (Security Settings for Port <Port_Name> Dialog Box)" on page
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1902.

d. ForWCF security scenarios, add the security information. For details on these settings,
see "WCF Service (Custom Binding) Scenario (Security Settings for Port <Port_Name>
Dialog Box" on page 1909, "WCF Service (Federation) Scenario (Security Settings for Port
<Port_Name> Dialog Box)" on page 1911, or "WCF Service (WSHttpBinding) Scenario
(Security Settings for Port <Port_Name>) Dialog Box)" on page 1913.

5. Save the settings - optional
Click Save to save the settings to an .stss file.

How to Set Security for a Specific Step
Relevant for: API testing only

This task describes how to set security properties for an individual test step.

This task includes the following steps:

l "Add a step to which security can be applied" below

l "Open the Security Setting tab" below

l "Enable the step's security details" below

l "Specify a scenario type" below

l "Configure the security settings" below

1. Add a step to which security can be applied
Drag aWeb Service operation or SOAP Request activity onto the canvas.

2. Open the Security Setting tab

Open theSecurity Settings tab in the Properties pane.

3. Enable the step's security details
Clear theUse the port's security settings option.

4. Specify a scenario type
Select a scenario from theService Details dropdown list.

5. Configure the security settings
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Configure the security settings for the selected scenario. For task details, see one of the
following sections:

n "How to Set Security for a StandardWeb Service" below

n "How to Customize Security forWCF TypeWeb Services" on page 1889

To see the request and response before and afterWSE2 (non-WCF) security is applied, view
theOutput pane after the test run.

How to Set Security for a Standard Web Service
Relevant for: API testing only

This task describes how to configure security settings for a standardWeb Service. This mode lets
you define the HTTP transport information and security elements such as tokens.

For details about standardWeb service security, see "Web Service Scenario Overview" on page
1879.

This task includes the following steps:

l "Open the Security Settings dialog box or tab" below

l "Create aWeb Service scenario" below

l "Configure the HTTP settings" on the next page

l "Define security elements (optional)" on the next page

l "Configure theWS-Addressing (optional)" on the next page

1. Open the Security Settings dialog box or tab
n To set security on a port level, right-click aWeb Service port in the Toolbox and choose

Security Settings.

n To set security for a specific Web Service step already on the canvas, select the step and
open theSecurity Settings tab in the Properties pane. Clear the use the port's security
settings option.

n For a SOAP Request step, click theSecurity Settings tab in the Properties pane.

For details on the available settings, see the "Security Settings for Port <Port_Name> Dialog
Box" on page 1900.

2. Create a Web Service scenario
In the Security Settings dialog box, selectWeb Service from theService Details dropdown
list (default).
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3. Configure the HTTP settings
In themain window of the Security Settings dialog box, select theHTTP tab, and set the
transport and proxy information. For details on the transport and proxy settings, see the "HTTP
tab" on page 1903.

4. Define security elements (optional)
In themain window of the Security Settings dialog box, click theWS-Security tab. Add
tokens, message signatures, and encryption.

n To add a token, click theSecurity Tokens button and select a token type. In the lower
pane, provide the token details.

For details on the different types of tokens, see "Message Level Security" on page 1880.

Note:When adding a SAML token, if you have the complete SAML token string, you
can paste it directly into theAssertionIDReference field. If you do not have the
complete token string and you want to configure the tokenmanually, make sure that the
first row in the schema contains theAssertion property—not the
AssertionIDReference. You can change this using the grid's drop downmenu.

n To add amessage signature, click theAdd Message Signature button and select a
token in theSigning token dropdown list. In the lower pane, provide the other required
information.

Note: Youmust add a token before adding amessage signature.

n To add amessage encryption (youmust first add at least one token), click theAdd

Message Encryption button and select the token for the encryption from the
Encryption token box. Provide any other required information or accept the defaults.

Note: Youmust add a token before addingmessage encryption.

n Organize the security elements in their order of priority. Use theUp andDown
arrows to set the priorities. The basic order is tokens, followed by message signatures, and
then encryption. In addition, your servicemay also require a specific order for the tokens.

n Indicate whether or not to include a timestampwhen sending the token, signature, or
encryption to the server by selecting or clearing theExclude Timestamp option.

For details on the available options for tokens, message signatures, andmessage encryption,
see "WS-Security tab" on page 1904.

5. Configure the WS-Addressing (optional)
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a. In themain pane of the Security settings dialog box, click theWS-Addressing tab.

b. In theWS-Addressing tab, select the relevant version orNone if WS-Addressing is not
used.

c. In theReply to field, provide an alternate destination.

For user interface details see the "Security Settings for Port <Port_Name> Dialog Box" on
page 1900.

How to Customize Security for WCF Type Web Services
Relevant for: API testing only

This section describes how to customize the security settings forWeb services usingWCF.

Note: This task is part of a higher-level task. For details, see "How to Set Security for aWeb
Service on the Port Level" on page 1885 or "How to Set Security for a Specific Step" on page
1886.

This section describes:

l "Prerequisite - create aWCF scenario" below

l "Configure the settings for aWeb Service usingWSHTTPBinding" on the next page

l "Configure the settings for aWeb Service using CustomBinding" on the next page

l "Configure the settings for aWCF FederationWeb service" on the next page

l "Configure the settings for aWCF service using netTcp or namedPipe transport" on page 1891

l "Configure the settings for aWeb service usingWSE3 security configuration with a server
certificate" on page 1891

l "Configure the settings forWCF service usingmutual certificate authentication" on page 1892

l "Configure the settings for aWCF scenario using binding with TCP transport to require an X.509
client certificate" on page 1893

Prerequisite - create a WCF scenario

l For port level security, right-click a service's port in the Toolbox pane and select Security
Settings.

l For step level security, open theSecurity Settings tab in the Properties pane. Clear theUse
the port's security settings option.

Select the type ofWCF Servicefrom theService Details dropdown list.
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Configure the settings for a Web Service using WSHTTPBinding
WSHttpBinding is one of themost popular bindings inWCF. In order to use this binding, select the
WCFService (WSHttpBinding) scenario from theService Details dropdown list.

1. In the Client authentication type dropdown list, choose a client credential type to use in your
binding—Windows, Certificate, orUsername. This value corresponds to the
MessageClientCredentialType property of theWCF's WSHttpBinding parameter.

Windows authentication is themost common value for aWCF services. If you are using the
WCF default settings for your service, use this option.

2. Define the security settings for your authentication type. The available options differ per
authentication type.

Note: For some scenarios you should indicate whether to use theWCF proprietary
negotiationmechanism to get the service credentials.

3. Click Advanced to control the usage of a secure session. For details on the available
Advanced security properties, see "Advanced Settings Dialog Box" on page 1916.

Configure the settings for a Web Service using CustomBinding

1. In the Security Settings dialog box, select theWCFService (Custom Binding) scenario.

2. In themain pane of the Security Settings dialog box, set theWeb service security options,
including:

n Transport type

n Encoding

n Authentication mode for theWeb service

n Net security type

n The identities for the custom bindings and authentication certificate

n The client user information for the "user" who would access theWeb service

Configure the settings for aWCF FederationWeb service

1. In the Security Settings dialog box, select theWCFService Federation scenario from the
Service Details dropdown list.

2. Provide the service and security transport details, including:

n Transport type

n Encoding
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n Authentication mode for theWeb service

n Bootstrap policy for theWeb service

n The identities for the custom bindings and authentication certificate

n STS (Security Token Service) settings

Note: Youmust to define the communication properties for both the STS and the application
server

Configure the settings for a WCF service using netTcp or namedPipe
transport

1. In the Security Settings dialog box,select theWCFService (Custom Binding) scenario from
theService Details dropdown list.

2. Configure the transport to TCP orNamedPipe.

3. Set the other security settings as described in "Configure the settings for aWeb Service using
CustomBinding" on the previous page.

Configure the settings for a Web service using WSE3 security
configuration with a server certificate

1. Create a new test and import theWSDL containing theW3E3 service.

2. Drag amethod from theWeb service to the canvas.

3. Select theSecurity tab in the Properties pane or right-click theWeb service node in the
Toolbox and select Security Settings.

4. In the Security Settings dialog box, select theWCFService (Custom Binding) scenario.

5. In themain pane of the Security Settings dialog box, set the Transport toHTTP, and the
Encoding to Text.

6. In the Identities section, enter a username and password.

7. Click theBrowse button adjacent to the Server Certificate field and specify theStore
Location, Store Name andSearch text (optional). Click Find, select the certificate, and click
Select.

8. Provide theExpected DNS.
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9. Click theAdvanced button and configure the following settings in the Advanced Settings
dialog box:

a. In theEncoding tab: Set theWS-Addressing version appropriately

b. In theSecurity tab, set the following options:

o Enable secure session:Enabled

o Negotiate service credentials:Enabled

o Protection level:Encrypt and Sign

o Message protection order:Sign Before Encrypt

o Message security version:
WSSecurity11WSTrustFebruary2005WSSecureConversationFebruary2005 (first entry)

o Require Derived keys:Enabled

For all other fields, use the default settings.

Configure the settings for WCF service using mutual certificate
authentication
The following procedure describes how to set up a security scenario for mutual certificates and how
to comply with aWSE3 security configuration.

1. In the Security Settings dialog box, select theWCFService (CustomBinding) scenario from
theScenario Details dropdown list.

2. Set the Transport toHTTP, and theEncoding to Text.

3. Set the authenticationmode toMutualCertificate.

4. In the Identities section, select the server and client certificates. For details, see "Select
Certificate Dialog Box" on page 1923.

5. Provide theExpected DNS.

6. Click the Advanced button and configure the following settings in the Advanced Settings dialog
box:

a. Encoding tab—WS-Addressing:WSA 04/08 (for aWSE3 security configuration).

b. Security tab—Require Derived keys: Disabled

For all other fields, use the default settings.

User Guide
Chapter 60: Web Service Security

HP Unified Functional Testing (12.00) Page 1892 of 2274



Configure the settings for a WCF scenario using binding with TCP
transport to require an X.509 client certificate
The following procedure describes how to configure aWCF custom scenario to require an X.509
client certificate in nettcp.

1. In the Security Settings dialog box, select theWCFService (Custom Binding) scenario from
theService Details dropdown list.

2. Set the Transport to TCP and theNet Security toSSL stream security.

3. In the Properties pane, open the Events tab .

4. IIn the events list, select theBeforeApplyProtocolSettings event. Click in theHandler column
and select Create a default handler from the drop-down.

5. In the TestUserCode.cs file, locate the TODO section of the code and add the following
definitions.

var wcf = (HP.ST.Ext.CommunicationChannels.Models.WcfChannelBinding)args[1];
var ssl =
(HP.ST.Ext.CommunicationChannels.Models.WcfSslStreamSecurityChannel)wcf.

     Protocols.Channels[1];
ssl.RequireClientCertificate = true;

For all other fields, use the default settings.

6. Save the test and run it.

How to Set Common Web Services Security Scenario
Properties

Relevant for: API testing only

This section illustrates how to set several common security scenarios properties. The examples
apply when using the default Web Service security scenario.

You can set security for all operations in aWeb service port or for a specific step in your test.

Note: This task is part of a higher-level task. For details, see "How to Set Security for aWeb
Service on the Port Level" on page 1885 or "How to Set Security for a Specific Step" on page
1886.

This task includes the following:

l "Authenticating with a Username Token" on the next page

l "Signing with an X.509 Certificate" on the next page
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l "Encrypting with a Certificate" on the next page

l "Authenticating with a Username Token and Encrypting with an X.509 Certificate" on page 1896

l "Encrypting and Signing aMessage" on page 1896

Authenticating with a Username Token
To send amessage level username/password token (a UserName token):

1. In the Security Settings dialog box, select theWeb Service scenario from theService Details
dropdown list.

2. In themain part of the Security Settings dialog box, click theWS-Security tab.

3. In theWS-Security tab, click theAdd Token button and add aUsername token.

4. In the lower pane, customize the token details, such as username and password.

Signing with an X.509 Certificate

1. In the Security Settings dialog box, select theWeb Service scenario from theService Details
dropdown list.

2. In themain part of the Security Settings dialog box, click theWS-Security tab.

3. In theWS-Security tab, click theAdd Token button and select X509 Certificate from the
dropdown list

4. In the lower pane, enter the token name.

5. Click theBrowse button to navigate to your certificate file. The certificate must be installed in
theWindows certificate store.

6. Select aReference type. Since this token is used for a signature, themost common type is
BinarySecurityToken.

7. Click theAdd Message Signature button .

8. In theSigning Token dropdown list, select the token you entered in the previous steps.

9. To sign a specific element with the certificate, scroll down to theXPath field and provide an
XPath expression.

You cannot use an XPath expression to sign a timestamp or token that is under the security
element of a SOAP request.

n To sign aSOAP Body, Timestamp, orWS-Addressing, select the check box in the
Predefined parts area.
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n To sign tokens within the security element, select a token in the Token (optional) field, in
theWhat to sign area.

Note: The certificate needs to be installed in theWindows certificate store. In the example
above, you need to set the actual store name, store location, and subject name of your
certificate.

Encrypting with a Certificate
To encrypt amessage using the service's X.509 certificate:

1. In the Security Settings dialog box, select theWeb Service scenario from theService Details
dropdown list,

2. In themain part of the Security Settings dialog box, select theWS-Security tab.

3. In theWS-Security tab, click theAdd Token button and select X509 Certificate token
from theSecurity Token drop down list.

4. Enter token name.

5. Since this token is used for encryption, useReference as theReference type.

6. Click theAdd Message Encryption button . In the drop down list, select the token you
created in the previous steps.
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7. Scroll down to theXPath field. Enter an XPath expression to the elements to encrypt, for
example: // *[local-name(.)='Body'].

Authenticating with a Username Token and Encrypting with an X.509
Certificate
The following section describes how to send aUsername token to the service and encrypt it with
the server's X.509 certificate:

1. In the Security Settings dialog box, select theWeb Service scenario from theService Details
dropdown list.

2. In themain part of the Security Settings dialog box, select theWS-Security stab.

3. In theWS-Security tab, click theAdd Token button and select Username Token from
theSecurity Token drop down list.

4. In the lower pane, Provide the token details for the Username token.

5. Click theAdd Token button again and select X509 Certificate Token from theSecurity
Token drop down list.

6. In the lower pane, enter the token details to reference the server's public certificate. Since this
token is used for encryption, useReference as theReference type.

7. Click theAdd Message Encryption button . In the drop down list, select the X.509 token
you created in the previous steps.

8. To encrypt a specific message, scroll down to theXPath field. Enter an XPath expression, for
example:, // *[local-name(.)='Body'].

Encrypting and Signing a Message
This example shows how to sign amessage using a private key and then encrypt it using the
service's public key.

1. In the Security Settings dialog box, select theWeb Service scenario from theService Details
list.

2. In themain part of the Security Settings dialog box, select theWS-Security tab.

3. In theWS-Security tab, click theAdd Token button and select X509 Certificate Token
from theSecurity Token drop down list.

4. Enter the token details to reference your private certificate. Select BinarySecurityToken as a
Reference type, since this token is used for a signature.

5. Click theAdd Token button again and select X509 Certificate Token from theSecurity
Token drop down list to add another X.509 token.
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6. Enter the token details to reference your private certificate. Select Reference as aReference
type, since this token is used for a encryption.

7. Click theAdd Message Signature button . In the drop down list, select the first X.509
token you created.

8. Click theAdd Message Encryption button . In the drop down list, select the second token
you created.

How to Test Web Services that use WS-Security or SSL
Relevant for: API testing only

This section provides step for setting up web services that useWS-Security or SSL protocols.

Note: This task is part of a higher-level task. For details, see "How to Set Security for aWeb
Service on the Port Level" on page 1885 or "How to Set Security for a Specific Step" on page
1886.

This section includes:

l "How do I test aWeb Service that uses SSL?" below

l "How do I test aWeb Service that requires Windows authentication at the HTTP level?" below

l "How do I test aWeb Service that uses WS-Security?" on the next page

l "How do I configure the low-level details of my WS-Security tokens?" on the next page

How do I test a Web Service that uses SSL?
Testing a secure site does not require any special configuration. If your service URL begins with
https, SSL is automatically used.

If in addition to SSL you are also usingmessage-level security (for example for a username) then
youmust configure the security for themessage separately.

You can use the basic Web Services security scenario and specify themessage-level security
such as tokens and signatures. You can also use theWCFService (Custom Binding) scenario, or
theWCFService(WSHttpBinding) scenario with the transport credentials.

How do I test a Web Service that requires Windows authentication at the
HTTP level?

1. Select theWeb Service scenario from theScenario Details list.

2. Set the service security settings as described in "How to Set Security for a StandardWeb
Service" on page 1887.
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How do I test a Web Service that uses WS-Security?
Use theWeb Services security scenario and open theWS-Security tab. Add themessage-level
security such as tokens, signatures, and encryption. For details, see "How to Set Security for a
StandardWeb Service" on page 1887.

How do I configure the low-level details of my WS-Security tokens?
In most cases, you can configure the low-level details as described in "Advanced Settings Dialog
Box" on page 1916.

How to Set up Advanced Standards Testing
Relevant for: API testing only

This section provides guidelines for using UFT in advanced standards testing.

This section includes:

l "How do I test aWeb Service that uses MTOM?" below

l "How do I change theWS-Addressing version of a service?" below

l "How do I enable support for a service or activity that uses 256-bit SSL encoding?" on the next
page

How do I test a Web Service that uses MTOM?

1. Select theWCFService (Custom Binding) scenario from theService Details list.

2. Configure theEncoding toMTOM.

If your service requires advanced settings, click theAdvanced button. For details on the
available options, see the "Advanced Settings Dialog Box" on page 1916.

For more details about the scenario, see "How to Customize Security forWCF TypeWeb
Services" on page 1889.

How do I change the WS-Addressing version of a service?

1. Select theWeb Service scenario from theService Details list.

Note: If your service uses WCF, use the appropriate scenario and configure the
addressing version from the Advanced Settings dialog box's Encoding tab. For details,
see the "Advanced Settings Dialog Box" on page 1916.

2. Click theWS-Addressing tab and select a version.

User Guide
Chapter 60: Web Service Security

HP Unified Functional Testing (12.00) Page 1898 of 2274



How do I enable support for a service or activity that uses 256-bit SSL
encoding?
Change the SSL cipher order inWindows Vista so that AES256 precedes AES128 in the cipher list.

Tip: Check with an IT professional before performing the following actions.

To change the cipher order:

1. Type gpedit.msc at a command prompt to open your group policy editor.

2. ChooseComputer Configuration > Administrative Templates > Network > SSL
Configuration Settings.

3. Open the only item—SSL Cipher Suite Order.

4. Select Enabled.

5. The first item in the list is TLS_RSA_WITH_AES_128_CBC_SHA

The second item is TLS_RSA_WITH_AES_256_CBC_SHA

6. Change the first 128 to 256. Thenmove the cursor forward and change the 256 to 128.

7. Move the cursor through the list and change the cipher priorities as in the above step.

8. Close the group policy editor and reboot.
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Reference

Security Settings for Port <Port_Name> Dialog Box
Relevant for: API testing only

Using the Security Settings dialog box, you can configure security settings for all operations in a
Web service port. To set the security for a specific step within your test, use theSecurity Settings
tab in the Properties pane. For details, see "Result Tab (Properties Pane - API Testing)" on page
427.
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To access 1. Do one of the following:

n Ensure that an API test or component is in focus in the document
pane.

n In the solution explorer, select an API test or component.

2. Import aWeb Service.

3. Select aWeb Services port node in the Toolbox pane and select
Security Settings from the context menu.

Important
information

l For details about choosing a security scenario type, see "Security
Scenarios Overview" on page 1878.

l For examples, see "How to Set CommonWeb Services Security Scenario
Properties" on page 1893.

Relevant tasks "How to Set Security for a Specific Step" on page 1886
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User interface elements are described below:

UI
Elements Description

Service
Details

The type of Web service.

You can choose from the following types of services:

l Web Service (standard)

l WCF CustomBinding

l WCF Federation

l WCF WSHttpBinding

<Service
security
settings>

The settings for the selected service. The available options depending on the type
of service selected.

l For standardWeb services, see "Web Service Scenario (Security Settings for
Port <Port_Name> Dialog Box)" below

l ForWCF CustomBinding services, see "WCF Service (Custom Binding)
Scenario (Security Settings for Port <Port_Name> Dialog Box" on page 1909

l ForWCF Federation services, see "WCF Service (Federation) Scenario
(Security Settings for Port <Port_Name> Dialog Box)" on page 1911

l ForWCFWSHttpBinding services, see "WCF Service (WSHttpBinding)
Scenario (Security Settings for Port <Port_Name>) Dialog Box)" on page 1913

Advanced Opens the Advanced Settings dialog box. For details, see the "Advanced Settings
Dialog Box" on page 1916.

Note: Available only forWCF typeWeb services.

Import Loads security settings from a previously saved .stss file.

Save Saves the security scenario settings to an .stss (Service Test Security Scenario)
file, for use in other tests. If you are connected to ALM, it saves the file together
with the test.

Web Service Scenario (Security Settings for Port <Port_Name>
Dialog Box)

Relevant for: API testing only

When you select the standardWeb Service, you set multiple different options in the following tabs:
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l "HTTP tab" below

l "WS-Security tab" on the next page

l "WS-Addressing tab" on page 1908

HTTP tab

This tab enables you to set the HTTP transport level settings such as user credentials for sending a
message with basic authentication, proxy settings, message-level settings, encryption, and so
forth.

The user interface elements are described below.

UI Elements Description

User name
Password

The credentials for HTTP authentication such as basic authentication, digest,
or NTLM.

Example

l User name:myDomain\myUser

l Password:myPassword
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UI Elements Description

Client
certificate

The client credentials required for client certificate authentication when using
two-way SSL scenarios.

TheBrowse button opens the "Select Certificate Dialog Box" on page 1923.

Proxy URL The URL and port of the proxy server through which themessagemust pass.

Example:http://myProxy:8888/.

To use the default, select Use default proxy.

Proxy user
name
Proxy
password

The credentials for the proxy server through which themessagemust pass.

Keep alive Keeps the connection persistent.

Connection
timeout

The time threshold in which to connect through the proxy server or with
authentication.

Manage
cookies

Enables the writing of cookie information.

WS-Security tab

The tab enables you to addmessage level security using tokens, message signatures, and
encryption.
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The user interface elements are described below. (Unlabeled elements are shown in angle
brackets).

UI Elements Description

Security Tokens. Adds a security token to yourWeb service. You can
select one of the following types of tokens:

l User Name,

l X509

l Kerberos,

l Kerberos2

l SAML

Add Message Signature. Adds a signature to themessage. This requires
a token.

Add Message Encryption. Adds encryption to themessage. This requires
a token.

<security element
list>

A list of the tokens, message signatures, and encryptions.

<Encryption
details pane>

The details of the encryption token.

l Encrypting token. The token to use for encryption, usually an X.509
type. You can select from a list of all previously created tokens.

l Encrypting type. Indicates whether to encrypt the whole destination
Element or only its Content.

l Key algorithm. The algorithm to use for the encryption of the session
key: RSA15 orRSAOAEP.

l Session algorithm. The algorithm to use for the encryption of the
SOAP message. You can select from a list of common values.

l What to encrypt

n XPath (optional). An XPath that indicates the parts of themessage
to encrypt. If left blank, only the SOAP body is encrypted.

n Token (optional). The name of the encrypted token. A drop down
box provides a list of all added tokens. With most services, this field
should be left empty.
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UI Elements Description

<Signature
details pane>

The details of the digital signature used to secure the token.

l Signing token. The token to use for signing, usually an X.509 type.
Select from the list of all added tokens.

l Canonicalization algorithm. A URL for the algorithm to use for
canonicalization. A drop down list provides common algorithms. If you
are unsure which value to use, keep the default.

l Transform algorithm. A URL for the Transform algorithm to apply to
themessage signature. A drop down list provides common algorithms.
If you are unsure which value to use, keep the default.

l Inclusive namespaces list. A list of comma-separated prefixes to be
treated as inclusive (optional).

l What to sign. The SOAP elements to sign: SOAP Body, Timestamp,
andWS-Addressing.

l XPath (optional). An XPath that specifies which parts in themessage
to sign. If left blank, the elements selected in theSignature options
field are signed. For example, //*[local-name(.)='Body'].

l Token (optional). The target token you want to sign. Select from the
drop down list of all added tokens. With most services, this field should
be left empty.

<Token details
pane> - for
Kerberos tokens

Token details forKerberos tokens:

l Token name. A meaningful name for the token.

l Host. The host name of the server against which you want to
authenticate. In most cases, it is the host portion of the service URL.

l Domain. TheWindows domain of the server against which you want to
authenticate.
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UI Elements Description

<Token details
pane> - for
Username tokens

Token details forUsername tokens.

l Token name. A meaningful name for the token (you can use the default
value).

l Include nonce. Includes a nonce in the token.

l User name, Password

l Password type: Text, Hash, orNone.

l Timestamp format: Full, Created, orNone.

<Token details
pane> - for X509
Certificate tokens

l Token name. A meaningful name for the token.

l Certificate. The path of the server certificate file. TheBrowse button
opens the "Select Certificate Dialog Box" on page 1923.

l Reference type. Instructs UFT how to reference the security token:
BinarySecurity Token orReference.

When the certificate is used for encryption, for example, a service
certificate, useReference. When using it for a signature (for example, a
certificate with your private key) select BinarySecurity Token.

<Token details
pane> -for SAML
tokens

l <SAML token assertions>.

n Grid view, an expandable node listing the assertions in the SAML
schema. If you expand the list, you can set the attribute values. A
drop down list lets you select a specific assertion.

n Text view, an XML reference to the token.

n Revert. Discards all changes made in Text view.

l Load from file. Enables you to browse to a SAML certificate.

l Certificate. The path of the certificate file. TheBrowse button opens
the "Select Certificate Dialog Box" on page 1923.

l Certificate reference type. Instructs UFT how to reference the
certificate: X509, Data, orRSA.

Exclude
Timestamp

Removes the timestamp from the SOAP header before sending the
security element to the server.
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WS-Addressing tab

TheWS-Addressing tab indicates whetherWS-Addressing is used by the service, and if so, its
version number. You can also specify the IP address of the server to which you want the response
to be sent.
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WCF Service (Custom Binding) Scenario (Security Settings for Port
<Port_Name> Dialog Box

Relevant for: API testing only

Use this scenario to test WCF services which require security or transport configurations. For
general details, see "WCF Service (CustomBinding) Scenario Overview" on page 1881.
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User interface elements are described below (unlabeled elements are shown in angle brackets):

UI
Elements Description

Transport Transport type. The transport types include:

l HTTP

l HTTPS

l TCP

l NamedPipe

l AutoSecuredHTTP

Encoding Encoding.You can choose from the following encoding types:

l Text

l MTOM

l WCF Binary

Security l Authentication mode. A drop down list of possible modes of authentication,
such as AnonymousForCertificate,MutualCertificate, and so forth.

l Bootstrap Policy. A drop down list of possible bootstrap policies forSecure
Conversation authentication., such as SspiNegotiated,
UserNameOverTransport, and so forth.

Net
Security

The type of stream security: None, Windows stream security, orSSL stream
security.

Reliable
Messaging

Enables Reliable Messaging inOrdered orNon-ordered format.

Identities The identity information for the bindings and certificate:

l Username andPassword

l Server /Client certificate. A certificate that provides identity information for
the server or client. Use theBrowse button to open the "Select Certificate
Dialog Box".

l Expected DNS, SPN, andUPN. The expected identity of the server in terms of
its DNS, SPN, or UPN. This can be localhost, an IP address, or a server name.
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UI
Elements Description

Client
Windows
Identity

The identity information for the client windows:

l Current User. The identity of the user logged onto themachine.

l Custom User. A user with the following credentials: Username, Password,
and Domain.

Advanced Opens the Advanced Settings dialog box. For details, see "Advanced Settings
Dialog Box" on page 1916.

WCF Service (Federation) Scenario (Security Settings for Port
<Port_Name> Dialog Box)

Relevant for: API testing only

In theWCF Service (Federation) scenario, the client authenticates against the STS (Security
Token Service) to obtain a token. The client uses the token to authenticate against the application
server.
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User interface elements are described below (unlabeled elements are shown in angle brackets). For
details, see "WCF Service (Federation) Scenario Overview " on page 1882.

UI Elements Description

Server l Transport. The transport type: HTTP orHTTPS.

l Encoding. The server's encoding policy: Text orMTOM.

Security l Authentication mode. A drop down list of possible modes of
authentication, such as AnonymousForCertificate,MutualCertificate, and
so forth.

l Bootstrap Policy. A drop down list of possible bootstrap policies for
Secure Conversation authentication., such as SspiNegotiated,
UserNameOverTransport, and so forth.

Identities The identity information for the bindings and certificate:

l Server certificate. A certificate that provides identity information for the
server. Use theBrowse button to open the "Select Certificate Dialog
Box".

l Expected DNS. The expected identity of the server in terms of its DNS.
This can be localhost, an IP address, or a server name.

STS (Security
Token Service)
Details

Information about the STS:

l Endpoint address. The endpoint address of the STS. This can be
localhost, an IP address, or a server name.

l Binding. The scenario which references the binding that contacts the
STS.

Advanced Opens the Advanced Settings dialog box. For details, see "Advanced
Settings Dialog Box" on page 1916.
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WCF Service (WSHttpBinding) Scenario (Security Settings for Port
<Port_Name>) Dialog Box)

Relevant for: API testing only

In theWCFService (WSHttpBinding) scenario, you can select from several types of
authentication: None, Windows, Certificate, or Username (message protection). For details, see
"WCF Services (WSHttpBinding) Scenario Overview " on page 1883.

User interface elements are described below (unlabeled elements are shown in angle brackets) by
the client authentication types:

UI Elements Description

Client
authentication
type

Authentication type:

l None,

l Windows

l Certificate

l Username (message protection)

For details, see below.
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UI Elements Description

Advanced Opens the Advanced Settings dialog box. For details, see "Advanced
Settings Dialog Box" on page 1916.

Client Authentication Types:

l "Client Authentication Type—None" below

l "Client Authentication Type—Windows" below

l "Client Authentication Type—Certificate" on the next page

l "Client Authentication Type—Username (message protection)" on the next page

Client Authentication Type — None

UI
Elements Description

Expected
server DNS

The expected identity of the server in terms of its DNS. This can be localhost, an
IP address, or a server name. It can also be the common name by which the
certificate was issued.

Negotiate
server
credentials

Negotiates theWeb Service's certificate with the server.

You can also provide the server's DNS information.

Specify
service
certificate

The location of the service's certificate. If you select this option, theNegotiate
service credentials option is not relevant.

For details, see the "Select Certificate Dialog Box" on page 1923.

Enable
secure
session

Enables a secure session using no client authentication.

Client Authentication Type —Windows

UI Elements Description

Client Windows
identity

The identity information for the client windows:

l Current User. The identity of the user logged onto themachine

l Custom User. A user with the following credentials: Username,
Password, and Domain

Enable secure
session

Enables a secure session usingWindows type authentication.
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UI Elements Description

Expected server
identity

The expected server identity method: SPN orUPN.

Client Authentication Type — Certificate

UI
Elements Description

Client
certificate

The location of the client certificate. TheBrowse button opens the "Select
Certificate Dialog Box".

Enable
secure
session

Enables a secure session usingCertificate type authentication.

Expected
server DNS

The expected identity of the server in terms of its DNS. This can be localhost, an
IP address, or a server name. It can also be the common name by which the
certificate was issued.

Negotiate
server
credentials

Negotiates theWeb Service's certificate with the server.

You can also provide the server's DNS information.

Specify
service
certificate

The location of the service's certificate. If you select this option, theNegotiate
server credentials option is disabled.

For details, see the "Select Certificate Dialog Box" on page 1923.

Client Authentication Type — Username (message protection)

UI
Elements Description

Enable
secure
session

Enables a secure session usingUsername type authentication.

Expected
server DNS

The expected identity of the server in terms of its DNS. This can be localhost, an
IP address, or a server name. It can also be the common name by which the
certificate was issued.

Negotiate
server
credentials

Negotiates theWeb Service's certificate with the server.

You can also provide the server's DNS information.

Specify
service
certificate

The location of the service's certificate. If you select this option, theNegotiate
server credentials option is disabled.

For details, see the "Select Certificate Dialog Box" on page 1923.
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UI
Elements Description

Username,
Password

The authentication credentials of the client.

Advanced Settings Dialog Box
Relevant for: API testing only

This dialog box enables you to customize the security settings for your test.
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To access Do the following:

1. Open the "Security Settings for Port <Port_Name> Dialog Box".

2. Select aWCF Service scenario type from theService Details list.

3. Click Advanced.

Relevant tasks l "How to Set Security for aWeb Service on the Port Level" on page 1885

l "How to Set Security for a Specific Step" on page 1886

l "How to Customize Security forWCF TypeWeb Services" on page 1889

This dialog box includes the following tabs:

l "Encoding Tab (Advanced Settings Dialog Box)" below

l "Advanced Standards Tab (Advanced Settings Dialog Box)" on the next page

l "Security Tab (Advanced Settings Dialog Box)" on page 1919

l "HTTP and Proxy Tab (Advanced Settings Dialog Box)" on page 1921

Encoding Tab (Advanced Settings Dialog Box)

Relevant for: API testing only

This tab lets enables you to select the type of encoding to use for theWeb service's messages.

User interface elements are described below:

UI Elements Description

Encoding The encoding type to use for themessages. You can select any of the
following types of encoding:

l Text

l MTOM

l WCF Binary

WS-Addressing
version

The version of WS-Addressing for the selected encoding. You can select
from the following versions:

l None

l WSA 1.0

l WSA 04/08
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Advanced Standards Tab (Advanced Settings Dialog Box)

Relevant for: API testing only

This tab enables you to configure advancedWS- standards, such as Reliable Messaging and the
Via address option.

You can configure the following options:

UI
Elements Description

Reliable
messaging

Enables reliable messaging for services that implement theWS-
ReliableMessaging specification.

You can use any of the following types of encoding:

l Text

l MTOM

l WCF Binary

Reliable
messaging
ordered

Indicates whether the reliable messaging session should be ordered.

Reliable
messaging
version

The version to apply to themessages:WSReliableMessagingFebruary2005 or
WSReliableMessaging11.

Specify via
address

Sends amessage to an intermediate service that submits it to the actual server.
This may also apply when you send themessage to a debugging proxy. This
corresponds to theWCF clientVia behavior.

This is useful to separate the physical address to which themessage is actually
sent, from the logical address for which themessage is intended.

Via
address

The logical address to which to send themessage. It may be the physical of the
final server or any name. It appears in the SOAP message as follows:

<wsa:Action>http://myLogicalAddress<wsa:Action>

The logical address is retrieved from the user interface. By default, it is the address
specified in theWSDL. You can override this address using this field.
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Security Tab (Advanced Settings Dialog Box)

Relevant for: API testing only

The AdvancedSecurity settings correspond toWS-Security specifications. You can use the
following settings:

UI Element Description

Enable secure
session

Establish a security context using theWS-SecureConversation standard.

Negotiate
service
credentials

Allow WCF proprietary negotiations to negotiate the service's security.

Default
algorithm suite

The algorithm to use for symmetric/asymmetric encryption.

The algorithm drop down list gets its values from the
SecurityAlgorithmSuite configuration inWCF.

Default:Basic256

Protection
level

Indicates whether the SOAP Body be encrypted/signed. The possible values
are: None, Sign, andEncrypt And Sign (default).

Default:Encrypt And Sign

Message
protection
order

The order for signing and encrypting. Choose from:

l Sign Before Encrypt

l Sign Before Encrypt-And Encrypt Signature

l Encrypt Before Sign

Message
security
version

TheWS-Security security version. You can also indicate whether toRequire
derived keys for themessage.

Require
derived keys

Indicates whether to require derived keys.
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UI Element Description

Security
header layout

The layout for themessage header:

l Strict

l Lax

l Lax Timestamp First

l Lax Timestamp Last

Key entropy
mode

The entropy mode for the security key. The possible values are: Client
Entropy, Security Entropy, andCombined Entropy.

Default:Combined Entropy

Require
security
context
cancellation

Indicates whether to require the cancellation of the security context. If you
disable this option, stateful security tokens will be used in theWS-
SecureConversation session, if they are enabled.

Include
timestamp

Includes a timestamp in the header.

Allow
serialized
signing token
on reply

Enables the reply to send a serialized signing token.

Require
signature
confirmation

Instructs the server to send a signature confirmation in the response.

X509 inclusion
mode

When to include the X.509 certificate:

l Always to Recipient

l Never

l Once

l Always To Initiator

Note: This and the next three options only apply when using an X.509
certificate.
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UI Element Description

X509 reference
style

How to reference the certificate:

l Internal

l External

X509 require
derived keys

Indicates whether X.509 certificates should require derived keys.

X509 key
identifier
clause type

The type of clause used to identify the X.509 key.

l Any

l Thumbprint

l Issuer Serial

l Subject Key Identifier

l Raw Data Key Identifier

HTTP and Proxy Tab (Advanced Settings Dialog Box)

Relevant for: API testing only

This tab lets you set the HTTP transfer and Proxy information for your test.

The following options are available:

UI Element Description

Transfer mode The transfer method for requests/responses. The possible values
include:

l Buffered

l Streamed

l Streamed Request

l Streamed Response

Max response size (KB) Themaximum size of the response before being concatenated.

Default: 65 KB

Send Timeout The time to wait (in seconds) for response on the transfer.

Allow cookies Indicates whether to enable or disable cookies.
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UI Element Description

Transfer mode The transfer method for requests/responses. The possible values
include:

l Buffered

l Streamed

l Streamed Request

l Streamed Response

Keep-Alive enabled Indicates whether to enable or disable keep-alive connections.

Authentication scheme The HTTP authenticationmethod:

l None

l Digest

l Negotiate

l NTLM

l Integrated Windows Authentication

l Basic

l Anonymous

Realm The realm of the authentication scheme in the form of a URL.

Require client certificate Indicates whether to require a certificate for SSL transport.

Use default web proxy Indicates whether to usemachine's default proxy settings.

Bypass proxy on local Indicates whether to ignore the proxy when the service is on the
local machine.

Proxy address The URL of the proxy server.

Proxy authentication
scheme

HTTP authenticationmethod on the proxy server:

l Digest

l Negotiate

l NTLM

l Basic

l Anonymous
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Select Certificate Dialog Box
Relevant for: API testing only

This dialog box enables you to search and locate a certificate from a file orWindows store.

To access Do the following:

1. Open the "Security Settings for Port <Port_Name> Dialog Box".

2. Select aWCF Service scenario type from theService Details list.

3. Click theBrowse button adjacent to theServer Certificate box.

Relevant tasks "How to Customize Security forWCF TypeWeb Services" on page 1889

The available options differ depending on whether you are selecting your certificate from a file or
from theWindows store:

Select Certificate from File

User interface elements are described below:

UI Elements Description

Browse. Enables you to locate the certificate file with a .cer or .pfx
extension.

File The complete path of the certificate file.

Password
(optional)

The password required to access the certificate.
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Select Certificate fromWindows Store

User interface elements are described below:

UI Elements Description

Store
location

The store location, for exampleCurrent User.

Store name The store name, for example, AuthRoot.

Search text The text to match in the certificate name. If left blank, the Find action retrieves
all available certificates.
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UI Elements Description

<certificate
list>

A list of the certificates in theWindows store sorted by Subject, Issuer,
Private, Store Location, andStore Name.

Password
(optional)

The password required to access the certificate.
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Troubleshooting and Limitations - Web Service
Security

Relevant for: API testing only

This section describes troubleshooting and limitations for working withWeb services security.

l Authentication and proxy security are not supported forWeb Services imported from aUDDI.

l ForWeb Service configured withWCF settings: Configuring different security settings for
operations residing on the same port is not supported.

l ForWeb Service configured withWCF settings, some of the user event handlers (such as the
AfterProcessRequestSecurity, BeforeProcessResponseSecurity, OnSendRequest, and
OnReceiveResponse events) will not be invoked.

l When testingWeb Services that require message-level security, theWeb Service security
scenario only supports SOAP version 1.1. For SOAP 1.2 use aWCF type scenario.

l When using a SAML security token forWeb services security, user-provided content may
contain creation and expiration timestamps. To extend the life of the test, we recommend that
you hard-code an expiration date in the distant future. In this is not possible, change the
timestamp by implementing theOnBeforeApplyProtocolSettings event.

l When using a SAML security token forWeb services security, if you edit the values in Grid
mode, they may not be updated in UFT.

Workaround: To update the values, switch to Textmode and save the test.

l WebService steps are not supported when using a SAML token with a certificate from the file
system.

Workaround: Install the certificate to theWindows store and select the certificate from the
store.

l Whenworking with Federation type scenarios that use STS (Security Token Service), you
cannot change the SOAP version.

l If you are using SOAP version 1.2:

n You can choose only UserName or X509 tokens when configuring themessage level
security.

n When configuring the canonicalization algorithm and the transform algorithm for themessage
signature, you cannot use the following format: http://docs.oasis-
open.org/wss/2004/01/oasis-200401-wss-soap-message-security-1.0#STR-Transform.
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Chapter 61: Asynchronous Service Calls
Relevant for: API testing only

This chapter includes:

Concepts 1928

Asynchronous Services 1928

Tasks 1931

How to Create an API Test for an Asynchronous Web Service 1931

Troubleshooting and Limitations - Asynchronous Testing 1934
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Concepts

Asynchronous Services
Relevant for: API testing only

You can use UFT to emulate asynchronous services. Asynchronous services can beWeb
Services, REST services, HTTP requests, JMS/MQ-based services, and so forth.

In synchronous messaging, the replay engine blocks step execution until the server responds. The
client sends a request and receives a response immediately, using the same connection. During
the waiting time, the replay engine is blocked and does not perform any other activity. If the timeout
was reached without a response from the server, the client returns an error.

In asynchronous mode, the replay engine executes the step without waiting for server's response
from previous requests.

Wait Steps

When sending asynchronous calls with HTTP or HTTPS, you use aWait step to instruct the test to
wait for the response of earlier asynchronous requests before continuing with its execution.

You do not have to place theWait step directly after the Receive step. The test can proceed with
other steps, but theWait step will instruct the test to wait for a response before ending the test, or
before continuing to execute any steps that follow theWait step.

Checkpoints

When sending a request to a server, you use checkpoints to verify theOutput property values.

When getting a request from a server, as in most of the asynchronous patterns, you use
checkpoints to verify the Input properties.

UFT provides a solution for the following asynchronous patterns:

l "WS-Addressing" below

l "HTTP Receiver" on the next page

l "Web Service Publish Subscribe" on the next page

l "Web Service Solicit Response" on the next page

l "Dual WSDL Files" on page 1930

WS-Addressing
WS-Addressing is a specification that enables Web services to communicate addressing
information. You can instruct the server to respond to any location, and not necessarily to the

HP Unified Functional Testing (12.00) Page 1928 of 2274



machine that issued the request. To do this, you use theWS-Addressing replyTo attribute.

In this implementation, UFT pauses the test and uses a listener mechanism to verify that the
response arrived at the specified address. After the listener acknowledges that the server
responded to the address or if it reaches the timeout, the test resumes. Upon the completion of the
test, you can validate the response with the standard API testing checkpoints.

For user interface details, see the "Asynchronous Tab (Properties Pane - API Testing)" on page
403.

HTTP Receiver
In theHTTP Receiver pattern, the server sends an HTTP request to the client, reversing the
typical roles of the client and server.

This is useful, for example, if you want to test a service which publishes information over HTTP to a
client. You define a receiver, which waits for a request from the server, sent over HTTP.

After a trigger, the receiver captures the request. The trigger can be an HTTP client request, a call
to aWeb service, an email, or any other event that will trigger the server. If there are inner steps, the
receiver waits for them to finish and only then is the receiver activity considered complete.

Using the API testing interface, you can insert the necessary logic and validate the checkpoints in
the captured request.

The response from the receiver should wait for the inner steps to complete and link to them.

The completion event name fired for the receiver should only be fired AFTER the inner steps are
done.

For details about the properties, see the "HTTP Receiver Activity" on page 1687.

Web Service Publish Subscribe
In theWeb Service Publish Subscribe pattern, the server sends an HTTP request to the client,
reversing the typical roles of the client and server. it is similar to the HTTP Receiver, except that
the request is sent to the client through aWeb Service call instead of exclusively via HTTP.

Using UFT, you test the publishing of messages to the client. You set up a receiver, which waits for
a server request, sent from the server as aWeb service call.

After a trigger, the receiver captures the request. The trigger can be an HTTP client request, a call
to aWeb service, an email, or any other event that will trigger the server.

Using the API testing interface, you can validate the response with standard API testing
checkpoints.

Web Service Solicit Response
TheWeb Service Solicit Response pattern is a variation of theWeb Service Publish
Subscribe pattern. It enables you test a a service which publishes information through aWeb
Service to a client.

In this pattern, however, the client is expected to send a response to the server request. The
response can be a simple acknowledgment or a full SOAP message.
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You set up a receiver activity, which waits for a server request. This server request is sent from the
server as aWeb service call. The receiver then sends a client response back to the server.

After the trigger, the receiver captures the request. The trigger can be an HTTP client request, a call
to aWeb service, an email, or any other event that will trigger the server.

Using the API testing interface, you can validate the response with standard API testing
checkpoints.

Dual WSDL Files
The Dual WSDL technique is a standard request-response pattern. In this pattern, however, the
client request is defined by oneWSDL, and the server response is defined by anotherWSDL.

You implement this scenario in two stages:

l Import the Request WSDL file, using the Import WSDL from import command.

l Import the ResponseWSDL file, using the Import WSDL from import command, enabling the
Import as Server Response option. For details, see the "Import/UpdateWSDL from URL or
UDDI Dialog Box" on page 1766 or "Select WSDLDialog Box" on page 1764.

For task details, see "How to Create an API Test for an Asynchronous Web Service" on the next
page.
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Tasks

How to Create an API Test for an Asynchronous Web
Service

Relevant for: API testing only

This task describes how to create an API test for testing an asynchronous Web service.

For an overview of the asynchronous patterns supported by UFT, see "Asynchronous Services" on
page 1928.

The following section describes the following tasks:

l "Create a test forWS-Addressing" below

l "Create a test for HTTP Receiver" below

l "Create a test for aWeb service publish subscribe pattern" on the next page

l "Create a test for Dual WSDL Files" on page 1933

Create a test for WS-Addressing
To useWS-Addressing for aWeb Service call:

1. Import aWeb Service using Import WSDL > Import WSDL from URL or UDDI and drag an
operation onto the canvas. For details, see "How to Import aWSDL-BasedWeb Service" on
page 1744.

2. Open the Asynchronous tab in the Properties pane and select This is an asynchronous
call box.

3. Specify a value for the Listen for response on property. This is the port to which you expect
the server to respond.

4. Open the Security tab in the Properties pane. Select theWS Addressing tab.

5. Select aWS-AddressingVersion and provide and a URL and port (same port as defined for the
Listen for response on property) in theReply to box, to indicate the destination of the server
response.

6. Run the test and perform checkpoint validations as you would with any step.

For more details, see the "Asynchronous Tab (Properties Pane - API Testing)" on page 403.

Create a test for HTTP Receiver
To create a test for an HTTP Receiver in which the client receives the response:
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1. Drag aNetwork > HTTP Receiver step onto the canvas.

a. Make sure you are logged in as an administrator. Administrator privileges are required to
runHTTP Receiver steps.

b. In theGeneral tab , specify theGeneral properties. For details, see the
"HTTP Receiver Activity" on page 1687.

c. In the HTTP Receiver tab , set theHTTP Receiver properties. For details, see the
"HTTP Receiver Tab (Properties Pane - API Testing)" on page 416.

d. Set a filter for the HTTP message . For details, see "Filter Settings Tab (Properties
Pane - API Testing)" on page 412.

2. Drag a Flow Control > Wait step onto the canvas. Specify timeout information and one or
more completion events. You can link to the completion event from a priorHTTP Receiver
step.

3. If required, drag additional activities from the Toolbox pane into theHTTP Receiver flow.

4. Run the test and apply the trigger for the server. For details, see the "HTTP Receiver" on page
1929.

Tip: If your test needs to listen tomore than onemessage, receiver steps (such as HTTP
Receiver orWeb Service calls set up as receivers) can be data driven and placed inside a
loop. The placement of theWait step—inside or outside of the loop—depends on whether
the send order matters:

n If themessages to be sent to the receiver are expected in a specific order, youmust
place theWait step inside the receiver step's frame. All steps that are contained within
the receiver can be data driven using this loop.

n If however, themessages are expected in a random order, place theWait step outside
the receiver step. Steps that are contained within the receiver should not be data driven
using the same loop as the receiver step and should not link to other steps outside the
receiver.

Create a test for a Web service publish subscribe pattern
To create a test to check that messages are properly published to the client:

1. Import aWSDL as a server by enabling the Import as server option. For details, see "How to
Import aWSDL-BasedWeb Service" on page 1744. This Web Service should have a receiver
type pattern. Drag an operation onto the canvas.

2. Set the input or output properties . For details, see the "Parameters/Checkpoints Tab
(Properties Pane - API Testing)" on page 417.
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3. Drag a Flow Control > Wait step onto the canvas. Specify timeout information and one or
more completion events. You can link to the completion event from a priorHTTP Receiver
step.

4. Run the test and activate the trigger for the server. For details, see "Web Service Publish
Subscribe" on page 1929.

Create a test for Dual WSDL Files
To create a test for a dual WSDL pattern, using oneWSDL for the request and another for the
response:

1. Import the request WSDL file using the standard import command, Import WSDL from. The
imported operations can send client requests and receive server responses.

2. Import the responseWSDL file as a server by enabling the Import as Server Response
option in the "Select WSDLDialog Box" or the "Import/UpdateWSDL from URL or UDDI
Dialog Box" (for URL and UDDI imports, click Advanced Settings to show the option). The
imported operations first receive server requests and then send client responses.

3. Drag aWeb service operation with the request onto the canvas.

4. Drag aWeb service operation with the response onto the canvas, after the request step.

For details, see "Dual WSDL Files" on page 1930.
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Troubleshooting and Limitations - Asynchronous
Testing

Relevant for: API testing only

This section describes troubleshooting and limitations for creating asynchronous tests.

For aWeb service imported as a server response:

l When enabling the SSL option, UFT temporarily binds the SSL certificate to the specified port on
a system, http.sys, level. If you end theUFT.exe process from the Task Manager during the
listening stage after the binding was added, the binding will not be automatically removed from
the system.

Workaround:Remove the bindingmanually using a utility such as httpcfg.exe or netsh.exe.

l Whenworking with SSL, certificates from a file are not supported. If youmove the test to
another machine, the certificate will not be available.

Workaround:Add the certificate to the local machine store before running the test. If desired,
remove it after you finish working with the test.

HP Unified Functional Testing (12.00) Page 1934 of 2274
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Relevant for: API testing only
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Concepts

Event Based Coding - Overview
Relevant for: API testing only

When testing your application's API, you can use event handlers to change or extend how you test
your application's process. An event handler is a specific occurrence of a defined code process
triggered at a specific point in the overall test flow.

When you run a test of your application's API (or run the application itself), each business process
is executed as defined in your application's code. These business processes are represented in
your test by the test steps you create. However, events (when running the application's code) and
event handlers (when running the test) are used at specific places in the application execution or the
test run. For example, if you are testing an application using aWeb service, the core part of your
test is theWeb service call processes in which data is sent to and from theWeb service. Events
and event handlers can be added before, after, and at other points in the test flow, such as a special
event handler that runs after the application compiles theWeb service call response, sets security
for theWeb service response data, or adds attachments to theWeb service call response.

Event handlers are designed to be run at a specific point in the application/test workflow. As a
result, the objects, methods, and properties available in a given event handler are limited to the
context of where the event occurs in the application or test workflow. For example, when you are
working in an event handler that occurs before an application process/test step, you cannot access
the process's/test step's output properties, as these properties are in a part of the application/test
that has not yet run.
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Example

You have an application based on aWeb service, in which the following steps occur:

1. The application generates theWeb service request.

2. The application sets the security for theWeb service call request.

3. The application adds the attachments for theWeb service request.

4. The application sends the request to theWeb service.

5. The application receives the responses from theWeb service.

6. The application reads the response and the attachments from the response.

Using event handlers, you can code an event handler in your test for any of these steps. For
example, if you want to set the request properties of one step based on the response properties
of a previous step, you can create code in an event handler calledBeforeExecuteStep, and
enter the property values you would like your test to use. When writing the code for this event
handler, the available properties/methods for your code are limited to the objects contained in
the context of the step's flow (the output/response properties available in the previous step and
the input/request properties of the current step) and the event handler (which takes place
immediately after the step).

You could also add another event handler that builds the attachment data into an XML
document to attach to theWeb service request. Likewise, you could add numerous other event
handlers that supplement the core processes that your application performs.

However, if you use an event handler out of the context in which it is designed, the
properties/methods of the step with which the event should run are not accessible. Thus, if you
try to code an event handler for one of the response steps above after a step involved inmaking
theWeb service request (such as generating theWeb service request), the properties of the
response step - while accessible - are null in the response context, and your test run gets an
exception when running this particular event handler code.

For details about how UFT uses event handlers, see "Writing Code for API Test Events -
Overview" on the next page.
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Writing Code for API Test Events - Overview
Relevant for: API testing only

Each step has predetermined event handlers which are run at specific points in the test execution.
Within these event handlers, you can add additional code (above and beyond the test step's regular
execution flow) which enables you to define properties, parameters, or variables and additional
processes that help to facilitate your test flow. For most test steps, there are three standard event
handlers which run before the test step, after the test step, and as a checkpoint for the test step.
ForWeb service and SOAP request steps, there are additional event handlers that mimic the
process of aWeb service call. For details on the event handler structure, see "API Event Coding -
Event Structure Overview" on page 1978.

Examples

Case 1
Before entering customer information into a flight booking service, your applicationmust
connect to a database located locally on your computer (whichmimics the application
connecting to a local database). However, using the existing UI framework of the UFT API
test, you cannot connect to the database. Using an event handler designed to run before the
test step, you can write code that accesses your database and imports the information to your
test to be entered into the flight booking service.

Case 2
After receiving a response from yourWeb service (in XML format), you need to extract certain
information from the response file to use as the input for another test step. You can write an
event handler to run after the test step which can read and extract the information from this
XML file.

Event handlers should be used to extend the behavior of existing test steps, instead of providing all
the property/parameter values for test steps. It is not recommended to use custom code to set the
property/parameter values of your steps and execute the steps, but instead to use the grid in the
Input/Properties tab in the Properties pane to set these values.

Note: This functionality is in contrast to themanner GUI testing uses coding. GUI tests and
components enable you to write the entire test or action flow using code. However, an API
event handler or custom code activity is only a portion of the larger test flow.

It is recommended to have experience and/or knowledge in writing code before attempting to write
event handlers for your tests. All API test events use the C# language and syntax, even if your
application uses a different language. For details on C#, see theMicrosoft C# Reference.

Note: Any add-ins you choose in the Add-in Manager when opening UFT do not affect API
tests or event/custom coding.
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Writing Events for API Tests - Use-case Scenarios
Relevant for: API testing only

The following scenarios describe use-cases on how to use event coding in the context of a test of a
realistic application. Each of the scenarios describes the general context in which the application is
used, the workflow of the application, and a test created for the application. The steps in the test
include possible input and output properties for each step, and also describe how event coding can
be used to enhance various test steps.

You can view a use-case scenario for the following types of applications:

l "Web Service application" below

l "REST Service application" on page 1942

l "Standard application" on page 1945

Web Service application

Scenario
A hotel has an application that deals with customer room charges and prints receipts for customers.
The application takes the customer’s room number, compiles customer charges of the customer
into a bill, charges the customer’s credit card, and prints a receipt. This receipt must display the
customer’s name, including any special characters in their name. However, the printer for the
receipt can only print English characters.

The billing application is based upon aWeb service which works on a cloud-based application and
database.

Application Flow
The billing application has the following workflow:

1. The billing application accesses the hotel booking application where customer information is
stored. The hotel billing application retrieves the customer's name, credit card number, and
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total charges.

2. The billing application sends the information for the bill to the receipt printer.

3. The receipt is printed.

Test Setup
You create the following test for the application, including a number of events:

1. GetBillingInformation step

This step accesses the hotel booking application in order to retrieve the customer data,
including the customer name, total charges, and customer credit card number.

Properties:
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Input Properties Web service address for the hotel booking application.

Output Properties n Customer Name

n Customer credit card number

These properties are contained in a description element in theWeb
service response.

n Price

Checkpoints Checkpoint to check whether the connection to the hotel booking
application succeeded.

2. PrintReceipt step

This step takes the customer information (from the description element of the
GetBillingInformation step) and prints a receipt for the customer.

Properties:

Input Properties Description. This property is linked to the data source imported in the
first step.

Price. The total price to charge to the customer.

Output Properties Response file containing the receipt from the

Checkpoints None

Events:

For this step, youmust create an event handler for theBeforeExecuteStepEvent event. This
event handler searches the description element for non-English characters and replaces them
with the correct characters:

/// <summary>
/// Handler for the StServiceCallActivity10 Activity’s BeforeExecuteStepEvent event.
/// </summary>
/// <param name=\"sender\">The activity object that raised the BeforeExecuteStepEvent

event.</param>
/// <param name=\"args\">The event arguments passed to the activity.</param>
/// Use this.StServiceCallActivity10 to access the StServiceCallActivity10 Activity's conte

xt, including input and output properties.
public void StServiceCallActivity10_OnBeforeExecuteStepEvent(object sender, STActivi

tyBaseEventArgs args)
{
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//Get the description text
XmlNamespaceManager nsmgr = new XmlNamespaceManager(this.StServiceCallAct

ivity10.InputEnvelope.NameTable);
nsmgr.AddNamespace("a", @"http://schemas.datacontract.org/2004/07/CustomerBil

lingService");
var OriginalText = this.StServiceCallActivity10.InputEnvelope.SelectSingleNode("//a:

Description", nsmgr).InnerText;

//In case there are non-English characters in the description, convert them to English
ones

var ConvertedText = ConvertSpecialCharactersToEnglishCharacters(OriginalText);

//Update the description with the converted text
this.StServiceCallActivity10.InputEnvelope.SelectSingleNode("//a:Description", nsmg

r).InnerText = ConvertedText;
}

REST Service application

Scenario

Note: This scenario is based on the Flights API application included with the UFT installation.

You have a flight booking application built using REST services. Your flight application retrieves the
flights from the service, creates a flight order, and then reserves the customer order. The service
then creates a flight order and total price, which is forwarded to the customer.

Application Flow
The billing application has the following workflow:

1. The flight application accesses the flights database through an HTTP connection, stored
externally.

2. The flight application retrieves the flights matching the specified parameters. You can search
for flights using any of the following criteria:

n Airlines

n Arrival City

n Arrival Time at destination

n Departure City

n Departure Time from departure point
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3. The flight application finds a specific flight, using the output from the flight retrieval, creates a
flight order, and reserves the customer's place on the flight.

4. The flight application provides the customer with a flight order number and a price.

Test Setup
You create the following test for the application, including a number of events:

1. Get step

In this step, the flight application accesses the flights database, and retrieves the flights that
match the customer preferences.
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Properties:

Input Properties n Airlines.

n ArrivalCity

n ArrivalTime

n DepartureCity

n DepartureTime

n FlightNumber

Output Properties n Class

n DepartureDate

n FlightNumber

Note: The output properties are defined by importing a
ResponseXML file, which details the required response
parameters.

Checkpoints None

2. ReserveOrder step

In this step, the flight application creates a flight order based on the specified output from the
Get step, and reserves the customer's place on the flight.

As part of this step, the test needs to add a checkpoint ensuring that the flight numbermeets
standards of being greater than 999 and less than 100000.
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Properties:

Input Properties n Class. This property is linked to theClass output property of theGet
step.

n CustomerName

n DepartureDate. This property is linked to theDepartureDate output
parameter from theGet step.

n FlightNumber. This property is linked to the FlightNumber output
property from theGet step.

n NumberofTickets

Output Properties n OrderNumber

n TotalPrice

Checkpoints A checkpoint ensuring that the flight numbermeets specified
parameters. This checkpoint is added with an event handler.

Events:

For this test step, you add two additional events:

n A CodeCheckpointEvent event. For this event, the code checks that the flight number is
greater than 999 and less than 100000. In the event handler, you also add code to stop the
test if the checkpoint fails.

n AnAfterExecuteStepEvent event. In this event, you add code to save the response XML
document as an attachment for the customer to receive.

Standard application

Scenario
You have an application which delivers a response received from aWeb-based application. The
application creates a file in which to save the response's data, and then extracts the relevant data
and adds it to the created file.

Application Flow
The application has the following workflow:

1. The application receives the response from theWeb-based application.

2. The application creates the file for the response data.
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3. The application extracts the necessary content from the response, and adds this to the created
file.

Test Setup
To test the application, you create the following test:

1. A Web service step.

This step details the response expected from theWeb-based application.

2. A File Cretate step.

This step creates a file in the specified directory in which the extracted data will be written.
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Properties:

Input Properties n Folder Path This property is linked to theClass output property of
theGet step.

n File Name

Both of these properties are enteredmanually in the test.

Output Properties None

Checkpoints None

3. AWrite To File step.

In this step, you extract the data from theWeb service response, and then add the data to the
file created in theCreateFile step.

Properties:

Input Properties n File Path. This property is linked to the Folder Path property of the
CreateFile step. However, since you can only link to output
properties using the API testing UI, youmust add an event handler
to link the properties.

n Content. The content comes from the response of theWeb service.
As this content is created dynamically during the test run, youmust
use an event handler to access the content.

Output Properties None

Checkpoints None

Events:

For this step, you need 2 events:

n A BeforeExecuteStepEvent event: This event links the File Path property of the current step
to the Folder Path property from theCreateFile step. The code passes the value specified
for the folder path to this test step so that theWriteToFile operation writes in the same folder
and file that you created.

n AnAfterExecuteStepEvent event: In this event, you access the response XML from the
Web service, and use the code to extract the binary data from theWeb service response.
Then, you add the binary data as the content for theWriteToFile operation, in the folder and
file specified in theBeforeExecuteStepEvent event.
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Tasks

How to Open a Window for Writing Custom Code
Relevant for: API testing only

When creating or editing a test, you can use event handlers to test non-standard behavior of your
application's API. For non-custom code activities, the default event handlers include events for
checkpoints, before step execution, and after step execution.

This task includes the following steps:

l "Open the Events tab" below

l "Select an event" on the next page

l "Edit the code" on the next page

l "Save the changes" on the next page

1. Open the Events tab
a. In the canvas, select an activity.

b. In the Properties pane, open theEvents tab .
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Note: You can also open the Events tab by double-clicking aCustom Code activity in
the canvas.

2. Select an event
In the Handler column, double-click the row for the event to which you want to provide code.

The TestUserCode.cs file opens as a separate tab.

3. Edit the code
In the TestUserCode.cs tab, locate the TODO section for your event handler and add your
custom code.

Note: Changes youmake in the canvas are not reflected in the event handler code
Intellisense/autocomplete options until you save the document.

4. Save the changes
Click File > Save All to save the custom code and the test.
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How to Manipulate Web Service Call/HTTP Request/SOAP
Request Step Input/Output Properties

Relevant for: API testing only

Using code, you can access and set the properties of your HTTP/SOAP Request orWeb Service
steps.

This task includes the following activities:

l "Access and set property values for input properties" below

l "Add checkpoint property values" on the next page

l "Specify a SOAP Fault and SOAP Fault values" on page 1952

l "Assign a specific request file to a test step" on page 1953

l "Assign a specific request file to aWeb service step in the OnSendRequest event" on page
1953

l "Set asynchronous Web service call properties" on page 1954

l "Add an input attachment to aWeb service call" on page 1955

l "Access an attachment from aWeb service call response" on page 1957

l "Add a HTTP Header forWeb Service Calls" on page 1958

l "HTTP Headers for REST Service Calls" on page 1959

Access and set property values for input properties

1. In the canvas, select aWeb service or SOAP Request step.

2. If you are using a SOAP Request step, load the XML containing the body of your
SOAP request:

a. In the Properties pane, open theXML Body tab .

b. In the XMLBody tab, click the Load XML button and navigate to your request file.

3. In the Properties pane, open theEvents tab .

4. In the Events tab, create an event handler for theAfterGenerateRequest event. The
TestUserCode.cs file opens.
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5. In the TODO section of the TestUserCode.cs file, add the property value, using the following
syntax:

this.StServiceCallActivity<activity #>.InputEnvelope.SelectSingleNode(XPath to property).In
nerText = "<value>";

For details on the Input Envelope object, see "InputEnvelopeObject" on page 1998. For details
on the SelectSingleNodemethod, see "SelectSingleNodeMethod" on page 2018.

Example

The following example assigns the value of the DepartureCity input property for a flight booking
web service from an Excel data source:

string newDepatureCityValue = GetDataSource("SampleAppData!Input").GetValue(this.Loop2.C
urrentIterationNumber-1, "DepartureCity").ToString();
string departureCityXpath = "/*[local-name(.)='Envelope'][1]/*[local-name(.)='Body'][1]/*[local-na
me(.)='GetFlights'][1]/*[local-name(.)='DepartureCity'][1]";
this.StServiceCallActivity4.InputEnvelope.SelectSingleNode(departureCityXpath).InnerText = ne
wDepatureCityValue;

Add checkpoint property values
You can use code to add checkpoint values in aWeb service or SOAP request step. This can be
very useful if the response on which the checkpoints is based is dynamically created.

Note: You cannot change the value of already existing checkpoints set in theWeb service call.

1. Create an event handler for theCodeCheckpointEvent, as described in "Set the value of a
checkpoint" on page 1970.

2. Following the line containing your code for enabling the checkpoint
(args.Checkpoint.RunUICheckpoints = true), enter the value of your checkpoint, using the
following syntax:

args.Checkpoint.Assert.Equals(<actual value>,<expected value>);

In the <actual value> and <expected value> parameters, you access the checkpoint properties
through the step's output envelope. To access the output parameters, use the same syntax as
described in "Access and set property values for input properties" on the previous page.
However, youmust change the InputEnvelope toOutputEnvelope to access the correct
properties.
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Example

In the following example, the checkpoint value for the DepartureCity value in a flight booking
Web service is set:

string departureCityActualValueXpath = "/*[local-name(.)='Envelope'][1]/*[local-name(.)='Body'][1
]/*[local-name(.)='GetFlightsResponse'][1]/*[local-name(.)='GetFlightsResult'][1]/*[local-name(.)
='Flight'][1]/*[local-name(.)='DepartureCity'][1]";
string ActualValue = this.StServiceCallActivity4.OutputEnvelope.SelectSingleNode(departureCit
yActualValueXpath).InnerText;

string departureCityExpectedValueXpath = "/*[local-name(.)='Envelope'][1]/*[local-name(.)='Bod
y'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='DepartureCity'][1]";
string ExpectedValue = this.StServiceCallActivity4.InputEnvelope.SelectSingleNode(departureCi
tyExpectedValueXpath).InnerText;

args.Checkpoint.Assert.Equals(ActualValue, ExpectedValue);

Specify a SOAP Fault and SOAP Fault values
Using code, you can set yourWeb service call or SOAP Request to expect a SOAP fault, as well
as to specify the expected fault properties.

1. In the canvas, select aWeb service or SOAP Request step.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler for theAfterGenerateRequest event. The
TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, specify the expected fault, using the
following syntax:

this.<activity>.FaultExpected = true;

5. In the Events tab, create an event handler for theCodeCheckpointEvent event.

6. In the TODO section of the TestUserCode.cs file, in theCodeCheckpointEvent section,
specify the expected fault information, using the following syntax:

string xpath = "<path to fault property>";
string actualValue = this.StServiceCallActivity<activity #>.OutputEnvelope.SelectSingleNod
e(xpath).InnerText;
string expectedValue = "soap:Server";
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args.Checkpoint.Assert.Equals(actualValue,expectedValue);

Note: For the specified string names in the syntax above, you can use your own names.

Example

string xpath = "/*[local-name(.)='Envelope'][1]/*[local-name(.)='Body'][1]/*[local-name(.)='Fault'][1
]/*[local-name(.)='faultcode'][1]";
string actualValue = this.StServiceCallActivity4.OutputEnvelope.SelectSingleNode(xpath).InnerT
ext;
string expectedValue = "soap:Server";
args.Checkpoint.Assert.Equals(actualValue,expectedValue);

Assign a specific request file to a test step

1. In the canvas, select aWeb service or SOAP Request step.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler for theAfterGenerateRequest event. The
TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, specify the expected fault, using the
following syntax:

this.<activity>.InputEnvelope.LoadXml(@"<path to response file>");

Note: You can also load the response from a previous step instead of from a file. In this
case, you need to access theOutputEnvelope from a previous step in place of the
@"<path to response file>" string. For details on accessing an output property from a step,
see "Set the value of a checkpoint" on page 1970.

Assign a specific request file to a Web service step in the OnSendRequest
event

1. In the canvas, select aWeb service or SOAP Request step.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler for theOnSendRequest event. The
TestUserCode.cs file opens.
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4. In the TODO section of the TestUserCode.cs file, specify the expected fault, using the
following syntax:

System.Xml.XmlDocument envelope = new XmlDocument();
envelope.LoadXml(System.Text.Encoding.UTF8.GetString(args.Message));

string xpath = "<fully qualified XPath to Property>";
envelope.SelectSingleNode(xpath).InnerText = "<value to enter>";

args.Message = System.Text.Encoding.UTF8.GetBytes(envelope.OuterXml);

Example

// Load request envelope into XML document
System.Xml.XmlDocument envelope = new XmlDocument();
envelope.LoadXml(System.Text.Encoding.UTF8.GetString(args.Message));

// Find and change the required node
string xpath = "/*[local-name(.)='Envelope'][1]/*[local-name(.)='Body'][1]/*[local-name(.)='EchoAr
r'][1]/*[local-name(.)='arr'][1]/*[local-name(.)='int'][1]";
envelope.SelectSingleNode(xpath).InnerText = "10";

// Save changed envelope back
args.Message = System.Text.Encoding.UTF8.GetBytes(envelope.OuterXml);

Set asynchronous Web service call properties

1. In the canvas, select aWeb service or SOAP Request step.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler forAfterGenerateRequest event. The
TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, specify the asynchronous call, using the
following syntax:

<activity name>.IsAsync = true;

5. Below the code for the IsAsync, specify the port on which to listen for theWeb service or
SOAP Request response, using the following syntax:

this.<activity>.ListenOnPort = <port number>;
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Example

StServiceCallActivity8.IsAsync = true;
this.StServiceCallActivity8.ListenOnPort = 8822;

Add an input attachment to a Web service call
You can use code to send an attachment with aWeb service call. This is very useful when the
attachment is generated dynamically, and you cannot add this attachment using the API testing
interface during test design.

Note: If you are loading an attachment from outside your test, skip to step 5.

1. Add a custom code step to the canvas.

2. In the Properties pane, open the Input/Output Properties tab .

3. In the Input/Output Properties, click Add and select Add Input Parameter. In the Add Input
Parameter dialog box, give the parameter ameaningful name.

4. Link the parameter to the desired attachment. For details, see "How to Assign Data to API
Test/Component Steps" on page 1819.

5. In the canvas, select aWeb service or SOAP Request step.

6. In the Properties pane, open theEvents tab .

7. In the Events tab, create theAfterGenerateRequest event. The TestUserCode.cs file opens.

8. In the TODO section of the TestUserCode.cs file, specify the attachment to add, using the
following syntax:

string attachmentsInfo =
@"<InputAttachments>

<Type> <attachment type> </Type>
<Attachments>

<Origin> <path to file> </Origin>
<OriginType> File </OriginType>
<ContentType> <type of content> </ContentType>
<ContentID>Auto</ContentID>

</Attachments>
</InputAttachments>";

this.StServiceCallActivity<activity #>.InputAttachments = new XmlDocument();
this.StServiceCallActivity<activity #>.InputAttachments.LoadXml(attachmentsInfo);
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Youmust define the attachment properties before the code that adds the attachment, as seen
in the@<InputAttachments> of the code. These properties are then displayed for the test step
in the Attachments tab in the Properties pane. For details on the necessary property values for
attachments, see "Attachments Tab (Properties Pane - API Testing)" on page 403.

Note: You can definemultiple attachments between the opening <InputAttachments> tag
and the closing </InputAttachments> tag, using the syntax displayed above (between the
<Attachments> and </Attachments> tags.

9. Optional - to override an attachment already defined in the Attachments tab in the Properties
pane, you can use the following syntax:

string <string name> = "<fully qualified XPath to attachment defined in the Attachments ta
b>";
this.StServiceCallActivity<activity #>.InputAttachments.SelectSingleNode(<string name>).I
nnerText =@"<path to file>";

Note: This does not update the attachment's properties, but simply overwrites the
attachment file.
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Examples:

l The following example adds two text file attachments to your test:

string attachmentsInfo =
@"<InputAttachments>

<Type>DIME</Type>
<Attachments>

<Origin>C:\somefile1.txt</Origin>
<OriginType>File</OriginType>
<ContentType>text/plain</ContentType>
<ContentID>Auto</ContentID>

</Attachments>
<Attachments>

<Origin>C:\somefile2.txt</Origin>
<OriginType>File</OriginType>
<ContentType>text/plain</ContentType>
<ContentID>Auto</ContentID>

</Attachments>
</InputAttachments>";

this.StServiceCallActivity5.InputAttachments = new XmlDocument();
this.StServiceCallActivity5.InputAttachments.LoadXml(attachmentsInfo);

l The following example replaces an existing attachment with a text file:

string firstAttachmentOriginXpath = "/*[local-name(.)='InputAttachments'][1]/*[local-name(.)='
Attachments'][1]/*[local-name(.)='Origin'][1]";
this.StServiceCallActivity5.InputAttachments.SelectSingleNode(firstAttachmentOriginXpath).
InnerText =@"c:\somefile.txt";

Access an attachment from a Web service call response
By default, UFT saves attachments from aWeb server response in the run results folder contained
within the test's folder. However, you can also access these attachments using an event handler:

1. In the canvas, select theWeb service or SOAP Request step for which you want to save the
Web service call.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler for theAfterExecuteStepEvent event. The
TestUserCode.cs file opens.
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4. In the TODO section of the TestUserCode.cs file, access the attachment information, using
the following syntax:

string <string name> = System.IO.Path.Combine(this.StServiceCallActivity<activity #>.Cont
ext.ReportDirectory,"Attachments");
string[] <name> = System.IO.Directory.GetFiles(<string name>);

This event handler returns an array which contains the full paths to the attachments returned
with theWeb service response.

Example

string responseAttachmentsFolder = System.IO.Path.Combine(this.StServiceCallActivity4.Conte
xt.ReportDirectory,"Attachments");
string[] responseAttachments = System.IO.Directory.GetFiles(responseAttachmentsFolder);

Add a HTTP Header for Web Service Calls
When you are editing yourWeb service call or SOAP Request steps, you can use an event to add
an HTTP header. This is useful if the source for this information is created dynamically during a test
run.

1. In the canvas, select aWeb service or SOAP Request step.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler for theBeforeApplyProtocolSettings event. The
TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, add the header element, using the following
syntax:

this.StServiceCallActivity4.HttpRequestHeaders.Add("<header key>", "< key value>");

Note: You can also set the HTTP headers values by expanding theRequestHeader node in
the Properties pane's Input/Checkpoints tab. You then link to a data source from theName and
Value rows. For details, see "Select Link Source Dialog Box (API Testing)" on page 1840.

If youmodify the headers using code in an event handler, it will override the values in the
Properties pane during the test run.
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HTTP Headers for REST Service Calls
To dynamically add an HTTP header to a REST service or to a REST service’s inner HTTP
Request step (when working with API tests created in UFT 11.51 or earlier or Service Test 11.51 or
earlier):

1. In the canvas, select a REST method step.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler for theBeforeExecuteStepEvent event. The
TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, allocate the desired length for the array:

(args.Activity as HTTPActivity).RequestHeaders =
new HP.ST.Shared.Utilities.Pair<string, string>[<# of headers>];

(args.Activity as HTTPActivity).RequestHeaders = new HP.ST.Shared.Utilities.Pair<string, s
tring>[2];

5. Below the allocation code, provide the each array element with the <HeaderName> and
<HeaderValue> for each array element:

(args.Activity as HTTPActivity).RequestHeaders[0] = new HP.ST.Shared.Utilities.Pair<strin
g, string>("<header name>", "<header value>")

Note: Youwill need to provide a separate line for each of the headers, as specified in your
allocation statement.

Example

(args.Activity as HTTPActivity).RequestHeaders = new HP.ST.Shared.Utilities.Pair<string, strin
g>[2];
(args.Activity as HTTPActivity).RequestHeaders[0] = new HP.ST.Shared.Utilities.Pair<string, stri
ng>"HeaderName1", "Value1");
(args.Activity as HTTPActivity).RequestHeaders[1] = new HP.ST.Shared.Utilities.Pair<string, stri
ng>("HeaderName2", "Value2");

How to Stop an API Test Run from an Event
Relevant for: API testing only
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Using custom code, you can stop a test run. This is useful if a condition in your test fails, and you
do not want to continue the test run.

To stop the test run, do the following:

1. In the canvas, select the step on which you want to stop the test run (if necessary).

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. T he TestUserCode.cs file opens. The event you
select depends on the test property you want to ensure is correct and where that property
occurs in the test flow.

Tip: To differentiate this event from other default events, enter a descriptive name like
stopTestScript in the event name field.

4. In the TODO section of the TestUserCode.cs file, enter an if statement for the current activity.

For details on if statements in C#, see http://msdn.microsoft.com/en-us/library/5011f09h
(v=vs.90).aspx.

5. Below the if statement in the TestUserCode.cs file, enter the value you want to report using the
following syntax:

this.Context.ReplayApiClient.Stop();

If the condition entered in your event is not met, UFT immediately stops the test run, and does not
display test results. If the condition is met, the test run continues.

Example

The following example stops a test run on a SOAP Response step. This code is set on the
OnReceiveResponse event, given the name stopTestScript. It stops the test run if the
SOAP response returns a fault:

String node_xpath = "/*local-name(.)='Envelope'][1]/*local-name(.)='Body'][1]";
if(this.StServiceCallActivity10.OutputEnvelope.SelectSingleNode(node_xpath).FirstChild.Name
=="soapenv:Fault")

this.Context.ReplayApiClient.Stop();

How to Manipulate Data Programmatically
Relevant for: API testing only

Using code, you can retrieve or set test step property/parameter values, import or export
property/parameter values, or data-drive the property/parameter values of your test steps.
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This task includes the following steps:

l "Prerequisite" below

l "Retrieve a value from a data source" below

l "Set a property value from a data source" on the next page

l "Import a data source file to your test" on page 1963

l "Export the property values to a file" on page 1964

l "Data drive test step property/parameter values" on page 1964

Prerequisite
Add at least one data source to your test and save the test.

Retrieve a value from a data source
In order to get a value from a data source, youmust use theGetDataSource andGetValue
methods:

1. Select the step for which you want to retrieve a data source value.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, call the data source value you want to
retrieve using the following syntax:

GetDataSource("<data source name>".GetValue(<row index>, "<column name>");

Note:When entering the parameters for theGetValue function, your row index is based on
0.

5. (Optional) If you want to retrieve the value corresponding to the value in the current iteration,
you replace the <row index> with theCurrentIterationNumber property, using the following
syntax:

GetDataSource(<data source name>.GetValue(<this.Loop<#>.CurrentIterationNumber, "<c
olumn name>");

Notes:
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n When running a data-driven test, UFT runs one iteration for each row in the data source.
Therefore, the loop number you enter corresponds to the row of the data source, unless
you specify a different starting row in the Data Source navigation policies.

n TheCurrentIterationNumber is one-based, meaning that the number entered for the
current loopmust be 1 or higher.

Examples

l This example retrieves a value from the first row of an Excel data source, converts it to a
string, and then assigns it as the property value for GetFlights test step Flight Number
property:

this.GetFlights4.FlightNumber =
GetDataSource("GetFlights4_Input!MainDetails").GetValue(0, "Flight_Number").ToString(
);

l This example also retrieves a value from an Excel data source, but from the current
iteration's row in the Excel sheet. The event then assigns the retrieved value to the
GetFlights test step's FlightNumber property.

this.GetFlights4.FlightNumber =
GetDataSource("GetFlights4_Input!MainDetails").
GetValue(this.Loop4.CurrentIterationNumber, "Flight_Number").ToString();

Set a property value from a data source
You can use theSetValuemethod to insert a property value in a data source. This enables you to
populate a data source with manually-entered values or values taken from another source.

1. Select the step for which you want to set a data source value.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, call the data source value you want to enter
using the following syntax:

GetDataSource("<data source name>").SetValue(<row index>, "<column name>", "<value to
enter>");
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Example

The following example writes values to the Flight_Number and Tickets_Ordered columns of an
Excel data source attached to a test:

GetDataSource("CreateFlightOrder4_Input!MainDetails").SetValue(0, "Flight_Number", "Y2
2");
GetDataSource("CreateFlightOrder4_Input!MainDetails").SetValue(0, "Tickets_Ordered", "2")
;

Import a data source file to your test
You can import data to your test using the Import and ImportFromExcelFile (if you are importing an
Excel file) methods. This enables you to add data in runtime and populate your property values with
this data.

1. Select the step to which you want to import data values

2. .In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, call the data source value you want to enter
using the following syntax:

ExcelFileImportInputArgs <name> = new ExcelFileImportInputArgs(@"<path to data sourc
e>", "<data source name>", <boolean whether there is a header>);
GetDataSource("<data source name>").Import(<name>);

or

GetDataSource("<data source name>").ImportFromExcelFile(@"<path to data source>", "<d
ata source name>", <boolean whether there is a header>);

Example

The following example imports an Excel Data source:

ExcelFileImportInputArgs a = new ExcelFileImportInputArgs(@"C:\DemoExcel.xls", "MainDetail
s", true);
GetDataSource("CreateFlightOrder4_Input!MainDetails").Import(a);

GetDataSource("CreateFlightOrder4_Input!MainDetails").ImportFromExcelFile(@"C:\DemoEx
cel.xls", "MainDetails", true);
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Export the property values to a file
You can also export the data from a test step to an external file using theExport and
ExportToExcelFilemethods. This enables you to export values to a file that other test steps can
access to provide values for their properties/parameters in runtime.

1. Select the step for which you want to export its data values

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, call the data source value you want to enter
using the following syntax:

ExcelFileExportInputArgs <name> = new ExcelFileExportInputArgs(@"<path to file>");
GetDataSource("<data source name>").Export(<name>);

or

GetDataSource("<data source name>").ExporttoExcelFile(@"<path to file>");

Example

The following example takes the values from the input properties for a CreateFlightOrder step
and writes these to an Excel file:

ExcelFileExportInputArgs a = new ExcelFileExportInputArgs(@"C:\ExportedExcel.xls");
GetDataSource("CreateFlightOrder4_Input!MainDetails").Export(a);

GetDataSource("CreateFlightOrder4_Input!MainDetails").ExportToExcelFile(@"C:\Exported
Excel.xls");

Data drive test step property/parameter values
You can also data drive test step property/parameter values using code. This is useful in custom
scenarios where you cannot link to your data source with the user interface options or you need to
link to a data source created in the test runtime.

1. Link the Test Flow/test loop with the data source. For details, see "Add a data source to the
Test Flow or test loop" on page 1826.

2. Set the Data Navigation policy for the data source. For details, see "How to Set the Data
Source Navigation Properties" on page 1825.

3. In the canvas, select the step to data drive.

4. In the Properties pane, open theEvents tab .
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5. In the Events tab, create an event handler. The TestUserCode.cs file opens.

Tip: If you are populating values for the currently selected test step, use the
BeforeExecuteEvent step. This ensures that the properties/parameters aremapped to the
appropriate data source values before the step is run.

6. Connect your property value to the data source using the following syntax:

n For test step properties are not based on an array:

var <variable name> = GetDataSource("<data source>").GetValue(<row index>, "<column
name>").ToString();
<activity name>.<property name> = <variable name>;

n For test step properties based on an array:

var <variable name> = GetDataSource("<data source>").GetValue(<row index>, "<column
name>").ToString();
<activity name>.InputEnvelope.SelectSingleNode("<fully qualified xpath to property value
>").InnerText = <variable name>;

Notes:

n You can retrieve the XPath to a property name stored in an array by right-clicking the
Property name in the Input/Checkpoints tab and selectingCopy Fully Qualified
XPath.

n If you want to set the value of an output value or checkpoint stored in an array, change
the InputEnvelope toOutputEnvelope in the syntax displayed above.

n If you are runningmultiple iterations using data-driving, you can use the
this.Loop<#>.CurrentIterationValue property as the row index. However, since the
CurrentIterationProperty is one-based, but the row-index is zero-based, add a -1 to the
CurrentIterationProperty to ensure that your last iteration does not fail.
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Example

The following example sets theDepartureCity andArrivalCity values for a flight bookingWeb
service from an Excel data source called "WebServiceData."

var GetFlights_Input_Departure_City = GetDataSource("WebServiceData!Input").GetValue(this.
Loop2.CurrentIterationNumber-1, "DepartureCity").ToString();
StServiceCallActivity4.InputEnvelope.SelectSingleNode("/*[local-name(.)='Envelope'][1]/*[local-n
ame(.)='Body'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='DepartureCity'][1]").InnerText
= GetFlights_Input_Departure_City;
var GetFlights_Input_Arrival_City = GetDataSource("WebServiceData!Input").GetValue(this.Loo
p2.CurrentIterationNumber-1, "ArrivalCity").ToString();
StServiceCallActivity4.InputEnvelope.SelectSingleNode("/*[local-name(.)='Envelope'][1]/*[local-n
ame(.)='Body'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='ArrivalCity'][1]").InnerText = G
etFlights_Input_Arrival_City;

How to Access and Set the Value of Step Input, Output,
or Checkpoint Properties

Relevant for: API testing only

You can set the values of input, output, or checkpoint properties through event handlers and custom
code.

This task includes the following activities:

l "Access an step property" below

l "Access a step's parent activity" on page 1968

l "Set the value of a step's properties" on page 1968

l "Access the value of a step's property in runtime" on page 1969

l "Enable or ignore selected checkpoints - optional" on page 1970

l "Set the value of a checkpoint" on page 1970

Access an step property

1. From the Toolbox pane, drag the activity for which you want to access properties or add a
custom code activity or event handler to an existing activity. Make sure that the custom code
activity is after the activity for which you want to define properties.

2. In the canvas, select the step.

3. In the Properties pane, open theEvents tab .
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4. In the Events tab, create an event handler. A TestUserCode.cs file opens in the document
pane.

5. In the TODO section of the TestUserCode.cs file, use the this object to access the properties
of the activity for which you want to set properties, using the following syntax:

this.<activity name>.Input.<property name>

Note: Formore details on the this object, see http://msdn.microsoft.com/en-
us/library/dk1507sz.aspx.

6. Enter the step name for which you want to set properties followed by a . character.

7. Enter the property name of the activity to set properties, followed by a . character. In this
example, you set thePrefix andSuffix properties for theConcatenateStringsActivity step.
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Access a step's parent activity
TheParent property of a step refers to the loop, condition, or parent activity that encloses a test
step.

1. To access the activity's parent, use the this object as described in the "Access an step
property" on page 1966 step,

2. Instead of entering the step's properties, enter theParent property for the step.

3. If you want to get the parent loop for an activity, enter theGetParentLoopmethod, using the
following syntax:

this.<activity name>.GetParentLoop();

Example

This example retrieves the parent activity and converts it into a string.

string ParentName = this.ConcatenateStringsActivity5.Parent.Name

Set the value of a step's properties

1. In the canvas, select the step for which you want to set property values.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, enter the parameter value for the
parameters/properties, using this syntax:

this.<activity name>.Input.<parameter name> = <parameter value>;

or

this.<activity name>.Output.<parameter name> = <parameter value>;

You cannot set checkpoint values using the this.<activity name> object. Youmust use the
args.Checkpoint object instead.

Important: Make sure that the value is the same type as the type entered when you
created the parameter, i.e. a string parameter must have a string value.

When your test runs, UFT passes the value as specified in your custom code step to the other
activity.
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Example

This example sets the value of the Prefix and Suffix value for a Concatenate Strings activity:

CodeActivity6.Input.a = "Hello";
CodeActivity6.Input.b = "World";
this.ConcatenateStringsActivity4.Prefix = CodeActivity6.Input.a;
this.ConcatenateStringsActivity4.Suffix = CodeActivity6.Input.b;

Access the value of a step's property in runtime
You can also report the runtime value of a test step's property or parameter in the Output pane
during a test run. This is useful if you want to watch the value of a particular operation or object
during the test run, without having to stop and debug the test.

To do this, you can use aUserLogger object:

1. Add an event handler for theOnAfterExecuteStep event to the step for which you want to
watch a property/parameter value.

2. Use theUserLogger object to report the value to the compilation log in the Output pane, using
the following syntax:

Context.UserLogger.Info(<activity name>.<property name>);

Note: Using theContext object in an event handler or custom code enables you to get the
contextual value for the property/parameter (i.e., the runtime value), instead of the entered
value (what you enter in the Properties pane, for example).

When the compilation log is displayed in the Output pane, you will see a line with the
property/parameter value displayed as part of the compilation log. Note that the Output pane does
not list the property/parameter namewith the value, so youmust search within the step where you
placed the code to find this value, as seen in the example below:
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Example

This example retrieves the value of thePrefix property of aConcatenateStrings activity:

Context.UserLogger.Info(ConcatenateStringsActivity4.Prefix);

Enable or ignore selected checkpoints - optional
You can instruct UFT to ignore the checkpoints for any test step. This is useful if you need to
switch between enabling and ignoring checkpoints on different test runs.

You use theCheckpoint object to access the checkpoint's properties:

1. In the canvas, select the step for which you want to enable or ignore the checkpoints.

2. In the Properties pane, select theEvents tab .

3. In the Events tab, create an event handler for theOnCodeCheckpointEvent event. The
TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, enable or ignore a checkpoint for an event
using the following syntax:

args.Checkpoint.RunUICheckpoints = true (to enable a checkpoint)

or

args.Checkpoint.RunUICheckpoints = false (to disable a checkpoint)

For more details on the args object, see http://msdn.microsoft.com/en-us/library/aa884376
(v=ax.50).aspx.

Set the value of a checkpoint
In addition to enabling or ignoring a checkpoint, you can also set the value (expected or not
expected) of a checkpoint. This can be useful both to validate that your application works as
expected but also does not allow unexpected behaviors.

1. Enable a checkpoint for the step, as described in "Enable or ignore selected checkpoints -
optional" above.

2. Following the line containing your code for enabling the checkpoint
(args.Checkpoint.RunUICheckpoints = true), enter the value of your checkpoint, using the
following syntax:

args.Checkpoint.Assert.Equals("<actual value>", "<expected value>");

User Guide
Chapter 62: Writing Event Handlers for API Test Steps

HP Unified Functional Testing (12.00) Page 1970 of 2274

http://msdn.microsoft.com/en-us/library/aa884376(v=ax.50).aspx


Formore details on the args object, see http://msdn.microsoft.com/en-us/library/aa884376
(v=ax.50).aspx. For details on the supportedmethods for the args object in UFT, see "Assert
Object" on page 1989.

Examples

l The following example sets the value of a checkpoint for aConcatenateStrings step:

args.Checkpoint.Assert.Equals(this.ConcatenateStringsActivity4.Prefix+this.
ConcatenateStringsActivity4.Suffix, this.ConcatenateStringsActivity4.Result);

l This example checks if the text value (alphabetical order for a string) of the prefix is less
than the suffix. To ensure that the checkpoint succeeds, enter a prefix value that is greater
than the suffix, for example a prefix of aa and a suffix of bb.

args.Checkpoint.Assert.Less("Concatenate test", this.
ConcatenateStringsActivity4.Prefix, this.ConcatenateStringsActivity4.Suffix,
       "The prefix is less than the suffix");

How to Report Test Run-Time Information
Relevant for: API testing only

Using custom events, you can report the run-time values or information of a given step, property, or
parameter. You can choose either to report this to the Output pane or the Run Results Viewer.
Viewing this information provides a simpler alternative to watching a object/property/parameter
value while debugging.

To send run-time information, you can use theReport function or theUserLogger object.

This task includes the following activities:

l "Report a custommessage to the run results" below

l "Report run-time values to the Output pane" on page 1973

Report a custommessage to the run results
Using theReport function, you can send a custommessage to the Run Results Viewer.

1. Select the step for which you want to report information.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.
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4. In the TODO section of the TestUserCode.cs file, enter the value you want to report using the
following syntax:

this.<activity name>.Report("<report information title>", "<reported data>");

or

<activity name>.Report("<report information title>", "<reported data>");

Tip: If you use theContext object after the <Activity Name> property. you report the run-
time value of the selected object, property, or parameter.

TheReportmethod displays a custommessage in the Captured Data pane of the run results.In this
example, aConcatenateStrings test step implemented the following code in an event handler:

args.Activity.Report("TestID","APR-12-2010_CYCLE_1");

Examples

The following example reports the value used for thePrefix property of aConcatenateStrings
activity:

this.ConcatenateStringsActivity4.Report("Run-time Prefix Value", this.ConcatenateStringsActivit
y4.Prefix)
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Report run-time values to the Output pane
Using aUserLogger object, you can view the run-time value of a particular property, parameter, or
object. This value is reported in theUserLogger build log displayed in the Output pane during test
compilation.

UserLogger statements are useful in place of debugging. By viewing the run-time value of the
selected property, parameter, or object, you can see the actual value without having to use the
more complex debugging features.

1. Select the step for which you want to report information.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, enter the value you want to report using the
following syntax:

Context.UserLogger.<user logger info level>("<object/property/parameter>");

IMPORTANT: It is mandatory to use theContext object before theUserLogger object, as
theContext object isolates the actual run-time context of the property, parameter, or
object whose value you want to see.

You can then see the value you selected in the Output pane:
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Examples

The following example reports the run-time value of theCustomerName property (whose value
comes from a data source attached to the test) in a flight bookingWeb service. In this example
the value to be reported was set with theDataSourceValue variable.

var DataSourceValue = GetDataSource("WebServiceData!Input").GetValue(0, "CustomerNam
e");
Context.UserLogger.Info(DataSourceValue);

How to Retrieve and Set Test or User Variables
Relevant for: API testing only

You can use special code in test step events to retrieve or set the value of environment and user
variables.

This task includes the following steps:

l "Prerequisite - create user variables." below

l "Optional - set the test profile" below

l "Retrieve a variable value" on the next page

l "Set a variable value" on the next page

Prerequisite - create user variables.
See "Define user variables" on page 142 for details on creating user variables.

Note: Youmay also want to createmultiple test profiles to vary the value of the variables for
different users or different test runs. For details on creating and editing user profiles, see
"Define user variable profiles " on page 143

Optional - set the test profile
If you are usingmultiple test profiles, youmust set the test profile you want to use before running
test:

1. In the canvas, select either theStart orEnd steps.

2. In the Properties pane, open the Test Variables tab .

3. In the Test Variables tab, choose the profile name from theActive Profile drop-down list.

If you have entered default values for any test or user variables, the values for this profile are used
in the test run.
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Retrieve a variable value
You can use code to retrieve the value of a user variable during run-time. This is useful to show you
the value of the variable without having to start a debugging session.

1. In the canvas, select the step during which you want to retrieve a variable value.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, call the data source value you want to
retrieve using the following syntax:

this.<activity name>.Context.TestProfile.GetVariableValue("<variable name>"); (if you
want to use a specific value from a specific profile)

or

this.<activity name>.Context.EnvironmentProfile.GetVariableValue("<variable name>");

Example

this.ConcatenateStringsActivity4.Context.TestProfile.GetVariableValue("Prefix");
this.ConcatenateStringsActivity4.Report("Prefix Variable Value", this.ConcatenateStringsActivity
4.Context.TestProfile.GetVariableValue("Prefix"));

Set a variable value

1. In the canvas, select the step during which you want to retrieve a variable value.

2. In the Properties pane, open theEvents tab .

3. In the Events tab, create an event handler. The TestUserCode.cs file opens.

4. In the TODO section of the TestUserCode.cs file, call the data source value you want to
retrieve using the following syntax:

this.<activity name>.Context.TestProfile.SetVariableValue("<variable name>","<variable
value>"); (if you want to enter a value for a specific test profile)

or

this.<activity name>.Context.EnvironmentProfile.SetVariableValue("<variable
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name>","<variable value>");

Examples

l The following example retrieves the value of the TestName test variable:

string testName = this.StServiceCallActivity4.Context.TestProfile.GetVariableValue("Tes
tName");

l The following example sets the value of the environment variable beforeExecuteStepevent
used to verify that theBeforeExecuteStepEvent event ran in the test step for the activity
activity.

activity.Context.EnvironmentProfile.SetVariableValue("beforeExecuteStepEvent","true");

How to Encrypt and Decrypt Passwords
Relevant for: API testing only

Password fields expect an encrypted string - if you provide an unencrypted string, the
authentication will fail.

TheEncryptionMngrmethod lets you encrypt and decrypt strings within your events.

This task includes the following steps:

l "Encrypt the password" below

l "Decrypt the password - optional" below

1. Encrypt the password
Use the activity's context's EncryptionMngrmethod, and select Encrypt from the
autocompletion drop-down. The following example encrypts a password.

string plainText = "myPassword";
string encryptedText = this.StServiceCallActivity4.Context.EncryptionMngr.Encrypt(plainTex
t);

2. Decrypt the password - optional
Use theDecryptmethod from the autocompletion drop-down.
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The following example decrypts a password and validates it against the original string.

string decryptedText = this.StServiceCallActivity4.Context.EncryptionMngr.Decrypt(encrypte
dText);
bool equalText = decryptedText.Equals(plainText);
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Reference

API Event Coding - Event Structure Overview
Relevant for: API testing only

When adding event handlers for your API tests, you can choose from a number of different event
handlers. Each of these event handlers runs at a different place in the test step's execution, and
likewise can access different properties of the current activity.

For most of the API activities included in UFT, you can choose from the standard event
handlers: BeforeExecuteStepEvent, AfterExecuteStepEvent, orCodeCheckpointEvent. The
function of these is the same regardless of which test step they are used with or the unique
properties for each test step.

ForWeb service and SOAP Request activities, you can access additional event handlers that
enable you to add specific functionalities to theWeb service call or SOAP request.

The following sections detail the possible events you can use when adding event handlers:

API Event Coding - Standard Event Structure 1979

API Event Coding -Web Service Event Structure 1983
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API Event Coding - Standard Event Structure

Relevant for: API testing only

For themajority of the activities supported for an API test in UFT, you can only use the standard
event handlers:

l BeforeExecuteStepEvent

l AfterExecuteStepEvent

l CodeCheckpointEvent

The following diagram shows how each event works within the individual test step run:

Because of this design, each activity has a different purpose and has access to different properties
of the individual test step:

l "BeforeExecuteStepEvent" below

l "AfterExecuteStepEvent" on the next page

l "CodeCheckpointEvent" on page 1981

BeforeExecuteStepEvent
Purpose:Set conditions and properties of the step required tomake the step run or to handle output
from a previous step required in the current step

Accessible Properties:

l Input properties/parameters from the current activity

l User/test variables from the current test

l Output properties from a previous test step or a parent activity

Example

/// <summary>
/// Handler for the ConcatenateStringsActivity4 Activity’s BeforeExecuteStepEvent event.
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/// </summary>
/// <param name=\"sender\">The activity object that raised the BeforeExecuteStepEvent event

.</param>
/// <param name=\"args\">The event arguments passed to the activity.</param>
/// Use this.ConcatenateStringsActivity4 to access the ConcatenateStringsActivity4 Activity's c

ontext, including input and output properties.
public void ConcatenateStringsActivity4_OnBeforeExecuteStepEvent(object sender, STActivit

yBaseEventArgs args)
{

ExcelFileImportInputArgs a = new ExcelFileImportInputArgs(@"C:\Users\user\Documents\Un
ified Functional Testing\API Test Resources\ConcatenateStrings.xlsx", "Sheet1", true);

GetDataSource("ConcatenateStrings!Sheet1").ImportFromExcelFile(@"C:\Users\user\Docu
ments\Unified Functional Testing\API Test Resources\ConcatenateStrings.xlsx", "Sheet1", true);

ConcatenateStringsActivity4.Prefix = GetDataSource("ConcatenateStrings!Sheet1").GetValu
e(0, "Prefix").ToString();

ConcatenateStringsActivity4.Suffix = GetDataSource("ConcatenateStrings!Sheet1").GetValu
e(0, "Suffix").ToString();

this.Context.UserLogger.Info (ConcatenateStringsActivity4.Prefix);
this.Context.UserLogger.Info (ConcatenateStringsActivity4.Suffix);

}

AfterExecuteStepEvent
Purpose:Set output properties for the current step or handle the output of the step (to export, save,
etc.)

Accessible Properties:

l Output properties/parameters from the current activity

l User/test variables from the current test

l Any output from the current test step

Example:

/// <summary>
/// Handler for the FileWriteActivity7 Activity’s AfterExecuteStepEvent event.
/// </summary>
/// <param name=\"sender\">The activity object that raised the AfterExecuteStepEvent event.<

/param>
/// <param name=\"args\">The event arguments passed to the activity.</param>
/// Use this.FileWriteActivity7 to access the FileWriteActivity7 Activity's context, including input

and output properties.
public void FileWriteActivity7_OnAfterExecuteStepEvent(object sender, STActivityBaseEvent

Args args)
{
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///Event code is here
String WriteToFileContent = this.StServiceCallActivity5.OutputEnvelope.SelectNodes("/*[loca

l-name(.)='Envelope'][1]/*[local-name(.)='Body'][1]/*[local-name(.)='CreateFlightOrder'][1]").ToSt
ring();

this.FileWriteActivity7.Content =WriteToFileContent;

CodeCheckpointEvent
Purpose: To set checkpoint properties and values for the current step

Accessible Properties:

l Input and output values for the current step

l User test/variables from the current test.

l All input and output from the current test step

Example:

/// <summary>
/// Handler for the CodeActivity15 Activity?s CodeCheckPointEvent (General execute event f

or executing code checkpoints) event.
/// </summary>
/// <param name="sender">The activity object that raised the CodeCheckPointEvent event.<

/param>
/// <param name="args">The event arguments passed to the activity.</param>
/// Use args to access the CodeActivity15 Activity's context, including any input and output ar

guments.
/// <example></example>
public void CodeActivity15_OnCodeCheckPointEvent(object sender, CheckpointEventArgs a

rgs)
{
///Event code starts here

string attachPath = CodeActivity15.Input.attachmentPath;
string attachmentContent = File.ReadAllText(attachPath);
string currDate = DateTime.Now.ToString();

currDate = currDate.Substring( 0,currDate.IndexOf(":") ) ;
//args.Checkpoint.Assert.Equals( attachmentContent.Contains(" Current Time = "+currDat

eTime+" file was attached$") ,true);
//bool status= attachmentContent.Contains(" Current Time = "+currDate);
bool status = attachmentContent.Contains( CodeActivity16.Output.currentDateTime );
bool status1 = attachmentContent.Contains("file was attached$");
if (status && status1)
{
args.Checkpoint.Report( attachmentContent," Current Time = "+currDate+" file was atta

ched$","contain", StatusEnum.Succeed );
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}
else
args.Checkpoint.Report( attachmentContent," Current Time = "+currDate+" file was attac

hed$","contain", StatusEnum.Fail );
}
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API Event Coding - Web Service Event Structure

Relevant for: API testing only

Whenworking with aWeb service call step or a SOAP Request step, there are a number of
additional events available that correspond with the unique run structure of aWeb service call:

l BeforeExecuteStepEvent

l AfterExecuteStepEvent

l CodeCheckpointEvent

l AfterGenerateRequest

l AfterProcessRequestSecurity

l AfterProcessRequestAttachments

l OnSendRequest

l OnReceiveResponse

l BeforeProcessResponseAttachments

l BeforeProcessResponseSecurity

l BeforeSaveResponse

l BeforeApplyProtocolSettings
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The following diagram shows how each event works within the individual test step run:

However, due to the flow and timing of the various events, you should only create event handlers
for specific events:

l "BeforeExecuteStepEvent" below

l "AfterExecuteStepEvent" on the next page

l "CodeCheckpointEvent" on the next page

l "AfterGenerateRequest" on the next page

l "AfterProcessRequestSecurity (WCF services only)" on page 1986

l "OnReceiveResponse" on page 1986

l "BeforeProcessResponseSecurity (WCF Security Scenarios only)" on page 1986

l "BeforeSaveResponse" on page 1986

BeforeExecuteStepEvent
Purpose:Set conditions and properties of the step required tomake the step run or to handle output
from a previous step required in the current step
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Accessible Properties:

l Input properties/parameters from the current activity

l User/test variables from the current test

l Output properties from a previous test step or a parent activity

AfterExecuteStepEvent
Purpose:Set conditions and properties of the step required tomake the step run or to handle output
from a previous step required in the current step

Accessible Properties:

l Input properties/parameters from the current activity

l User/test variables from the current test

l Output properties from a previous test step or a parent activity

l Response data from the current step

l Response attachments from the current step

CodeCheckpointEvent
Purpose:Set conditions and properties of the step required tomake the step run or to handle output
from a previous step required in the current step

Accessible Properties:

l Input properties/parameters from the current activity

l User/test variables from the current test

l Output properties from a previous test step or a parent activity

l SOAP Fault properties

AfterGenerateRequest
Purpose:Set conditions and properties of the step required tomake the step run or to handle output
from a previous step required in the current step
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Accessible Properties:

l Input properties from the current step

l The input envelope from the current step

l The input attachments from the current step

l Asynchronous properties from the current step

AfterProcessRequestSecurity (WCF services only)
Purpose:Update the request envelope information forWeb services using aWCF security
scenario withWSE defined. For details on theWCF security scenarios, see "Security Scenarios
Overview" on page 1878.

Use the args.Message property to access the response envelope

Accessible Properties:

l Input envelope information for the current test.

OnReceiveResponse
Purpose:Access the output envelope for the current test forWeb services using aWeb Service
security scenario withWSE defined. For details on theWCF security scenarios, see "Security
Scenarios Overview" on page 1878.

Use the arg.Message property to access the response envelope

Accessible Properties:

l The response envelope information for the current step. When this runs, theWeb service call
step returns a byte array containing the response envelope. Youmust add event handler code
also to use the byte array data.

Use the arg.Message property to access the response envelope

BeforeProcessResponseSecurity (WCF Security Scenarios only)
Purpose:Access the output envelope for the current step forWeb services using aWCF security
scenario withWSE defined. For details on theWCF security scenarios, see "Security Scenarios
Overview" on page 1878.

Use the arg.Message property to access the response.

Accessible Properties:

l The response envelope information for the current step.

BeforeSaveResponse
Purpose:Access the current step's response.
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Accessible Properties:

l The response for the current step. Use the arg.Message property to access the response.
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API Test Event Coding Common Objects
Relevant for: API testing only

Whenwriting custom code for events in your API test step events, you can use the following
objects:

Activity Object 1989

Assert Object 1989

Checkpoint Object 1991

Context Object 1992

CurrentIterationNumber Object 1993

EncryptionMngr Object 1994

EnvironmentProfile Object 1995

InputAttachment Object 1995

InputEnvelopeObject 1998

OutputAttachment Object 1998

OutputEnvelopeObject 2001

Parent Object 2002

TestProfile Object 2003

UserLogger Object 2004
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Activity Object

Relevant for: API testing only

Description

Accesses the current activity's properties and arguments.

Syntax

args.Activity.<supported object/method>

Supported Methods

l Comment object

l Context object

l EnableReporting object

l GetParentLoopmethod

l GetRootLoopmethod

l Name object

l Parent object

l Reportmethod

l StepEndedAt object

l StepId object (read-only)

Assert Object

Relevant for: API testing only

Description

Qualifies the preceding object.

Note: This object should be used only in theCodeCheckpointEvent event.
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Syntax

<object>.Assert.<supported operator method("<expected value>");

Supported Methods

l Equals

l Greater

l GreaterorEqual

l Less

l LessorEqual

l NotEquals

Example

args.Checkpoint.Assert.Equals(this.ConcatenateStringsActivity4.Prefix+this.ConcatenateStrings
Activity4.Suffix,this.ConcatenateStringsActivity4.Result);
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Checkpoint Object

Relevant for: API testing only

Description

Accesses the current activity's checkpoint properties.

Note: This object is only accessible when using theOnCodeCheckpointEvent event.

Syntax

args.Checkpoint.<supported object/method>

Note: Youmust use the args object before theCheckpoint object to access the selected
activity's checkpoint properties.

Supported Objects and Methods

l Assert object

l RunUIcheckpoints object

l Reportmethod

Examples

args.Checkpoint.RunUICheckpoints = true;

if (args.Checkpoint.Assert.Equals(this.ConcatenateStringsActivity4.Result))
this.ConcatenateStringsActivity4.Report(ConcatenateStringsActivity4.Result, "Passed");

else
this.ConcatenateStringsActivity4.Report(ConcatenateStringsActivity4.Result, "Failed");

User Guide
Chapter 62: Writing Event Handlers for API Test Steps

HP Unified Functional Testing (12.00) Page 1991 of 2274



Context Object

Relevant for: API testing only

Description

Accesses the run-time context of the preceding object.

Note: You should add another object following this object to specify the specific context of the
selected activity you want to access (i.e., follow this object with aCheckpoint object to isolate
checkpoint properties for the activity.

Syntax

this.<activity name>.Context.<object>

Supported Methods

None

Example

Context.UserLogger.Info(ConcatenateStringsActivity4.Prefix);
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CurrentIterationNumber Object

Relevant for: API testing only

Description

Gets the current iteration number.

Syntax

this.<parent activity>.CurrentIterationNumber

Supported Methods

None

Example

var GetFlights_Input_Arrival_City = GetDataSource("WebServiceData!Input").GetValue(this.Loo
p2.CurrentIterationNumber-1, "ArrivalCity").ToString();
StServiceCallActivity4.InputEnvelope.SelectSingleNode("/*[local-name(.)='Envelope'][1]/*[local-n
ame(.)='Body'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='ArrivalCity'][1]").InnerText = G
etFlights_Input_Arrival_City;
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EncryptionMngr Object

Relevant for: API testing only

Description

Accesses UFT API testing's encryptionmechanism to enable you to encrypt or decrypt strings
(such as passwords).

Syntax

this.<activity>.Context.EncryptionMngr.<supported method>

Supported Methods

l Decrypt

l Encrypt

Example

string plainText = "myPassword";
string encryptedText = this.StServiceCallActivity4.Context.EncryptionMngr.Encrypt(plainText);
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EnvironmentProfile Object

Relevant for: API testing only

Description

Accesses the environmental variables for a test.

Note: If you are using test profiles for a test, you should use the TestProfile object instead.

Syntax

this.<activity>.Context.EnvironmentProfile.<supported method>

Supported Methods

l GetType

l GetVariablesNames

l GetVariableValue

l SetVariableValue

l ToString

Example

this.ConcatenateStringsActivity4.Context.EnvironmentProfile.GetVariablesNames().ToString();

InputAttachment Object

Relevant for: API testing only

Description

Accesses the properties of the test step's input attachments.

Syntax

this.<activity>.Context.InputAttachments.<supported object or method>
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Supported Methods

l Attributes object

l BaseURL object

l ChildNodes object

l CreateAttributemethod

l CreateCDataSectionmethod

l CreateCommentmethod

l CreateElementmethod

l CreateEntityReferencemethod

l CreateNodemethod

l CreateWhitespacemethod

l CreateXMLDeclarationmethod

l DocumentElement object

l DocumentType object

l FirstChild object

l GetElementsbyIdmethod

l GetElementsbyTagNamemethod

l GetEnumeratormethod

l GetNamespaceOfPrefix method

l HasChildNodes object

l ImportNodemethod

l InnerText object

l InnerXML object

l InsertAftermethod

l InsertBeforemethod
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l IsReadOnly object

l LastChild object

l Loadmethod

l LoadXMLmethod

l LocalName object

l Name object

l NamespaceURL object

l NameTable object

l NextSibling object

l NodeType object

l OwnerDocument object

l ParentNode object

l Prefix object

l PrependChildmethod

l PreserveWhitespace object

l PreviousSibling object

l ReadNodemethod

l RemoveAllmethod

l RemoveChildmethod

l ReplaceChildmethod

l SchemaInfo object

l Schemas object

l SelectNodes method

l SelectSingleNodemethod

l Supports method

l Validatemethod
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l Value object

l WriteContentTomethod

l WriteTomethod

Example

this.StServiceCallActivity8.InputAttachments.Load(@"<my file path>");

InputEnvelope Object

Relevant for: API testing only

Description

Accesses the input property envelope forWeb Service, HTTP Request, and SOAP Request
activities.

Syntax

this.<activity>.InputEnvelope.<supported object/method>

Supported Objects and Methods

This object is a standard object of theXMLDocument class. All supported objects andmethods for
theXMLDocument class can be used with this object.

Example

var GetFlights_Input_Arrival_City = GetDataSource("WebServiceData!Input").GetValue(this.Loo
p2.CurrentIterationNumber-1, "ArrivalCity").ToString();
StServiceCallActivity4.InputEnvelope.SelectSingleNode("/*[local-name(.)='Envelope'][1]/*[local-n
ame(.)='Body'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='ArrivalCity'][1]").InnerText = G
etFlights_Input_Arrival_City;

OutputAttachment Object

Relevant for: API testing only

Description

Accesses the properties of the test steps output attachments.
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Syntax

this.<activity>.Context.OutputAttachments.<supported object or method>

Supported Methods

l Attributes object

l BaseURL object

l ChildNodes object

l CreateAttributemethod

l CreateCDataSectionmethod

l CreateCommentmethod

l CreateElementmethod

l CreateEntityReferencemethod

l CreateNodemethod

l CreateWhitespacemethod

l CreateXMLDeclarationmethod

l DocumentElement object

l DocumentType object

l FirstChild object

l GetElementsbyIdmethod

l GetElementsbyTagNamemethod

l GetEnumeratormethod

l GetNamespaceOfPrefix method

l HasChildNodes object

l ImportNodemethod

l InnerText object

l InnerXML object
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l InsertAftermethod

l InsertBeforemethod

l IsReadOnly object

l LastChild object

l Loadmethod

l LoadXMLmethod

l LocalName object

l Name object

l NamespaceURL object

l NameTable object

l NextSibling object

l NodeType object

l OwnerDocument object

l ParentNode object

l Prefix object

l PrependChildmethod

l PreserveWhitespace object

l PreviousSibling object

l ReadNodemethod

l RemoveAllmethod

l RemoveChildmethod

l ReplaceChildmethod

l SchemaInfo object

l Schemas object

l SelectNodes method

l SelectSingleNodemethod
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l Supports method

l Validatemethod

l Value object

l WriteContentTomethod

l WriteTomethod

Example

this.StServiceCallActivity8.OutputAttachments.Load(@"<my file path>");

OutputEnvelope Object

Relevant for: API testing only

Description

Accesses the output envelope information forWeb Service, HTTP Request, and SOAP Request
activities.

Syntax

this.<activity>.OutputEnvelope.<supported object/method>

Supported Methods

This object is a standard object of theXMLDocument class. All supported objects andmethods for
theXMLDocument class can be used with this object.

Example

var GetFlights_Input_Arrival_City = GetDataSource("WebServiceData!Input").GetValue(this.Loo
p2.CurrentIterationNumber-1, "ArrivalCity").ToString();
StServiceCallActivity4.OutputEnvelope.SelectSingleNode("/*[local-name(.)='Envelope'][1]/*[loca
l-name(.)='Body'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='ArrivalCity'][1]").InnerText =
GetFlights_Input_Arrival_City;
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Parent Object

Relevant for: API testing only

Description

Accesses the parent activity for a selected activity.

Syntax

this.<activity>.Parent.<supported method>

this.<activity>.Context.Parent.<supported method>

Note: Using the Context object here enables you to access the run-time context of the
selected activity and parent activity.

Supported Methods

l Activities object

l Comment object

l Context object

l EnableReporting object

l GetParentLoop

l GetRootLoop

l Name object

l Reportmethod

l StepEndedAt object

l StepId object

Example

string ParentName = this.ConcatenateStringsActivity5.Parent.Name
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TestProfile Object

Relevant for: API testing only

Description

Accesses the values of the environment and user variables for the currently active test profile as
specified in the Properties pane.

Syntax

this.<activity>.Context.TestProfile.<supported method>

Supported Methods

l GetType

l GetVariableNames

l GetVariableValue

l SetVariableValue

Example

this.ConcatenateStringsActivity4.Context.TestProfile.GetVariableValue("Prefix");
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UserLogger Object

Relevant for: API testing only

Description

Reports the specified conditions of the preceding object to the UserLogger build log in the Output
pane.

Syntax

this.<activity>.Context.UserLogger.<user logger detail supported method>

Supported Methods

l Info

l InfoFormat

l Debug

l DebugFormat

l Error

l ErrorFormat

l Fatal

l FatalFormat

l Warn

l WarnFormat

For details on the supportedmethods, see http://www.codeproject.com/Articles/140911/log4net-
Tutorial.

Example

var Variablenames = this.ConcatenateStringsActivity4.Context.EnvironmentProfile.GetVariables
Names();
Context.UserLogger.Info(Variablenames);
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API Test Event Coding Common Methods
Relevant for: API testing only

Whenwriting custom code for your API test activities, there are a number of methods that you can
use:

Export Method 2006

ExportToExcelFile Method 2007

GetDataSourceMethod 2008

GetValueMethod 2009

GetVariableNames Method 2011

GetVariableValueMethod 2012

Import Method 2013

ImportFromExcelFile Method 2015

InfoMethod 2016

Report Method 2017

SelectSingleNodeMethod 2018

SetValue Method 2019

SetVariableValueMethod 2020

Note: TheQuery function implemented in versions 11.20 and earlier is not supported in version
11.50 and later. Tomodify runtime data through an event handler, replace all occurrences of the
Query function withGetDataSource, using the arguments described in this section..
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Export Method

Relevant for: API testing only

Description

Exports the specified Excel data source from your test to an external file.

Class

DataSource

Syntax

ExcelFileExportInputArgs <name> = new ExcelFileImportInputArgs(@"<path to data source>");
GetDataSource("<data source name>").Export (name);

Note: Youmust cast the data source in the first line of the syntax in order to use theExport
method. If you do not want to cast the data source, use theExportToExcelFilemethod.

Parameters

Parameter Description

Name Name assigned to the data source.

Path to data source TheWindows path to the file for the data source.

Return Type

An Excel file with the specified data in the specified directory.

Example

ExcelFileExportInputArgs a = new ExcelFileExportInputArgs(@"C:\Users\brojerem\Documents\U
nified Functional Testing\API Test Resources\File.xls");
GetDataSource("ConcatenateStrings!Sheet1").Export(a);
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ExportToExcelFile Method

Relevant for: API testing only

Description

Exports the specified Excel data source from your test to an external file.

Class

DataSource

Syntax

GetDataSource("<data source>).ExportToExcelFile(@"<path to file>");

Parameters

Parameter Description

Path to data source TheWindows path to the file for the data source.

Return Type

An Excel file in the specified directory.

Example

GetDataSource("ConcatenateStrings!Sheet1").ExportToExcelFile(@"C:\Users\brojerem\Docum
ents\Unified Functional Testing\API Test Resources\File.xls");
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GetDataSource Method

Relevant for: API testing only

Description

Accesses the specified data source.

Note: This method is typically used when setting a value for a property, parameter, or variable.
It is also used in conjunction with other methods which enable you to use the data from the
data source, such as GetValue orSetValue.

Class

Test Entities

Syntax

property value =GetDataSource("<Data source name>").

Parameters

Parameter Description

Data
source
name

The name of the data source, exactly as it appears in the Data pane.

Note: You can right-click the data source in the Data pane and select Copy to
ensure that you use the correct name in your code.

Return Type

No explicit return object - method only accesses the data source.

Example

var DataSourceValue = GetDataSource("WebServiceData!Input").GetValue(0, "CustomerNam
e");
Context.UserLogger.Info(DataSourceValue);
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GetValue Method

Relevant for: API testing only

Description

Retrieves a specified value from the selected data source.

Note: This method is amethod of the data source. In order to use this method to get a data
source value, youmust retrieve a data source using theGetDataSourcemethod

Class

DataSource

Syntax

GetDataSource(<data source name>).GetValue(<row index>, "<column name>");

Parameters

Parameter Description

Row index Required. The row from which to take the value.

Note: The row index is zero-based, meaning if you want to pull from the first
row of the table, youmust set the row index value to 0.

Column
name

Required. The name of the column from which to take the value.

Return Type

Data value (format depends based on the data source type)

Example

var TableDataSourceValue = GetDataSource("WebService Customer Table").GetValue(0, "Custo
merName");

var GetFlights_Input_Departure_City = GetDataSource("WebServiceData!Input").GetValue
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(this.Loop2.CurrentIterationNumber-1, "DepartureCity").ToString();
StServiceCallActivity4.InputEnvelope.SelectSingleNode("/*[local-name(.)='Envelope'][1]/*[local-n
ame(.)='Body'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='DepartureCity'][1]").InnerText
= GetFlights_Input_Departure_City;
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GetVariableNames Method

Relevant for: API testing only

Description

Retrieves the names of all variable values in the current test.

Class

TestProfile

Syntax

this.<activity>.Context.TestProfile.GetVariableNames();

this.<activity>.Context.EnvironmentProfile.GetVariableNames();

Parameters

None

Return Type

A list of all environment/test variables in the current test or test profile.

Example

this.ConcatenateStringsActivity4.Context.EnvironmentProfile.GetVariablesNames().ToString();
var Variablenames = this.ConcatenateStringsActivity4.Context.EnvironmentProfile.GetVariables
Names();
Context.UserLogger.Info(Variablenames);
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GetVariableValue Method

Relevant for: API testing only

Description

Retrieves the value of a selected test or environment variable.

Class

TestProfile

Syntax

this.<activity>.Context.TestProfile.GetVariableValue("<variable name>");

this.<activity>.Context.EnvironmentProfile.GetVariableValue("<variable name>");

Parameters

Parameter Description

Variable name A string for the name of the variable. You can find this
value in the Test Variables tab in the Properties pane.

Return Type

No explicit return - the variable value is set for the test run.

Examples

this.ConcatenateStringsActivity4.Context.TestProfile.GetVariableValue("Prefix");
this.ConcatenateStringsActivity4.Report("Prefix Variable Value", this.ConcatenateStringsActivity
4.Context.TestProfile.GetVariableValue("Prefix"));

this.ConcatenateStringsActivity4.Context.EnvironmentProfile.GetVariableValue("Prefix");
this.ConcatenateStringsActivity4.Report("Prefix Variable Value 2", this.ConcatenateStringsActivit
y4.Context.EnvironmentProfile.GetVariableValue("Prefix"));
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Import Method

Relevant for: API testing only

Description

Imports the specified Excel data source into your test.

Class

DataSource

Syntax

ExcelFileImportInputArgs <name> = new ExcelFileImportInputArgs(@"<path to data source>", "<data
source name in the test>", "header row");
GetDataSource("<data source name>").Import (name);

Note: Youmust cast the data source in the first line of the syntax in order to use the Import
method. If you do not want to cast the data source, use the ImportfromExcelFilemethod
instead.

Parameters

Parameter Description

Name Name assigned to the data source.

Path to data source TheWindows path to the file for the data source.

Data source name in the test The name the test gives the data source after importing.

Header row A boolean value if the data source has a header row.

Possible values are "true" or "false".

Return Type

An Excel data source added to your test.

Example

ExcelFileImportInputArgs a = new ExcelFileImportInputArgs
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(@"C:\Users\user\Documents\Unified Functional Testing\API Test Resources\ConcatenateStrin
gs.xlsx", "Sheet1", true);

GetDataSource("ConcatenateStrings!Sheet1").Import(a);
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ImportFromExcelFile Method

Relevant for: API testing only

Description

Imports the selected Excel file to your test.

Class

DataSource

Syntax

GetDataSource("<data source name>").ImportFromExcelFile(@"<path to Excel file>", "<test data so
urce name>", header row>);

Parameters

Parameter Description

Name Name assigned to the data source.

Path to data source TheWindows path to the file for the data source.

Data source name in the test The name the test gives the data source after importing.

Header row A boolean value if the data source has a header row.

Possible values are "true" or "false".

Return Type

Adds an Excel data source to your test.

Example

GetDataSource("ConcatenateStrings!Sheet1").ImportFromExcelFile(@"C:\Users\user\Documen
ts\Unified Functional Testing\API Test Resources\ConcatenateStrings.xlsx", "Sheet1", true);
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Info Method

Relevant for: API testing only

Description

Reports the selected information to the UserLogger build log in the Output pane.

Note: You can also use other common .NET logging options. For details, see
http://www.codeproject.com/Articles/140911/log4net-Tutorial.

Class

ILog

Syntax

this.<activity>.Context.UserLogger.Info(message)

Note: This methodmust always be used with aUserLogger object.

Parameters

Parameter Description

Message A string or value to report. You can use other code strings in this parameter to report
the run-time value of any object, property, parameter, or variable in run-time.

Return Type

A message displayed in the UserLogger build log in the output pane.

Example

this.ConcatenateStringsActivity4.Context.EnvironmentProfile.GetVariablesNames().ToString();
var Variablenames = this.ConcatenateStringsActivity4.Context.EnvironmentProfile.GetVariables
Names();
Context.UserLogger.Info(Variablenames);
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Report Method

Relevant for: API testing only

Description

Reports a custom attribute in the Captured Data pane of the run results.

Class

Action

Syntax

this.<activity>.Report("report attribute string", "<attribute value>");

Parameters

Parameter Description

Report attribute string A string for the custom field to enter into the run results.

Attribute value The value for the attribute to report.

Return Type

A custom field in the run results.

Example

var ActivityArguments = args.Activity.StepId.ToString();
this.ConcatenateStringsActivity4.Report("Overall report", ActivityArguments);
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SelectSingleNode Method

Relevant for: API testing only

Description

Selects a single node from an array containing input/output properties.

Class

This method is not part of a UFT API testing class, but is invoked by the InputEnvelope object.

Syntax

<activity>.InputEnvelope.SelectSingleNode("<fully qualified Xpath>").<supported object/method>

Parameters

Parameter Description

Fully
qualified
XPath

The XPath to the property node in the array. Right-click the property/parameter
name in the Input/Checkpoints tab in the Properties pane and select Copy
Fully Qualified XPathto retrieve this information.

Return Type

No explicit return - enables the test to access the property or parameter.

Example

var GetFlights_Input_Departure_City = GetDataSource("WebServiceData!Input").GetValue(this.
Loop2.CurrentIterationNumber-1, "DepartureCity").ToString();
StServiceCallActivity4.InputEnvelope.SelectSingleNode("/*[local-name(.)='Envelope'][1]/*[local-n
ame(.)='Body'][1]/*[local-name(.)='GetFlights'][1]/*[local-name(.)='DepartureCity'][1]").InnerText
= GetFlights_Input_Departure_City;
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SetValue Method

Relevant for: API testing only

Description

Sets the value of a specified item in the data source.

Notes:

l This methodmust be used with theGetDataSourcemethod.

l This method cannot be used for XML data sources.

Class

DataSource

Syntax

GetDataSource(<data source name>).SetValue(<row index>, "<column name>");

Parameters

Parameter Description

Row index Required. The row from which to take the value.

Note: The row index is zero-based, meaning if you want to pull from the first
row of the table, youmust set the row index value to 0.

Column
name

Required. The name of the column from which to take the value.

Return Type

No explicit return object. Sets a value in the specified data source.

Example

GetDataSource("ConcActivity Strings").SetValue(1, "Suffix", "done.");
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SetVariableValue Method

Relevant for: API testing only

Description

Sets the value of a selected test or environment variable.

Class

TestProfile

Syntax

this.<activity>.Context.TestProfile.SetVariableValue("<variable name>" , "<variable value>");

this.<activity>.Context.EnvironmentProfile.SetVariableValue("<variable name>" , "<variable valu
e>");

Parameters

Parameter Description

Variable
name

A string for the name of the variable. You can find this value in the Test Variables
tab in the Properties pane.

Variable
value

The value for the variable. The format differs on the expected use of the variable.

Return Type

No explicit return - the variable value is set for use in the test run.

Example

var activity = ((HP.ST.Ext.WebServicesActivities.StServiceCallActivity)(args.Activity));
activity.Report( "codeCheckPointEvent" , "code CheckPoint event" );
args.Checkpoint.Report("CheckPoint","CheckPoint","=" , HP.ST.Fwk.RunTimeFWK.CheckpointF
WK.StatusEnum.Succeed );
activity.Context.EnvironmentProfile.SetVariableValue( "codeCheckpointEvent","true");
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Troubleshooting and Limitations - Event Coding
Relevant for: API testing only

This section describes troubleshooting and limitations for working with UFT events.

l The Loop.CurrentIterationObject is deprecated and will always return null.

l When calling a test or action, you cannot access the data associated with the called test or
action using runtime API coding, even if overriding the data was enabled (through theAllow
other tools to override the data option).

l Whenworking on non-English operating systems, youmust install a localized version of .NET
framework to obtain localized compilation errors.

l By default, onmachines running 64-bit Windows, the ActiveX object, HP.ST.Test, is only
registered in 32-bit mode - not 64-bit.

Workaround:Register the assembly manually using the following command line code:

cd "<UFT installation folder>\bin" %windir%\
Microsoft.NET\Framework64\v4.0.30319\
RegAsm.exe HP.ST.Fwk.SOAReplayAPI.dll /codebase
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Chapter 63: API Testing Extensibility
Relevant for: API testing only

The HP UFT installation includes the capabilities to create custom activities for the Toolbox pane.
After defining a custom activity, you can drag it onto the canvas as you would with any other built-in
activity.

This chapter includes:

Concepts 2023

Creating New Activities - Overview 2023

Custom Activity Files 2023

Tasks 2036

How to Use theWizard to Create a Custom Activity - C# 2036

How to Use theWizard to Create an Activity - Java 2038

How toManually Create a Custom Activity in C# 2040

How to Create a Runtime File 2044

Reference 2049

Activity Wizard 2049

Troubleshooting and Limitations - Extensibility (API Testing) 2061
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Concepts

Creating New Activities - Overview
Relevant for: API testing only

UFT enables you to create custom API testing activities to extend the capabilities of the product.

Once you create a new activity through this mechanism, it will be available in the Toolbox pane for
all future tests.

For most custom activities, you can use the Activity Wizard. For C# users, the wizard creates a
Visual Studio project into which you can add your ownC# code. Java users can edit .java files
which will be compiled into .class files. You then deploy the new activity into UFT. For details, see
"Activity Wizard" on page 2049 and "How to Use theWizard to Create a Custom Activity - C#" on
page 2036.

Advanced users can build custom activities manually, without the wizard. For details, see "How to
Manually Create a Custom Activity in C#" on page 2040.

Custom Activity Files
Relevant for: API testing only

This section describes the structure and content of the files required tomanually define a new
activity in UFT. The following information is not relevant if you are using the Activity wizard.

To create a custom activity, you need to define the following files on all machines upon which you
intend to run the test.

l "Runtime Files"

l "Signature Files"

l "Addin Files"

TheRuntime file is the DLL that UFT invokes to run the activity. For details, see "Runtime Files"
on the next page.

TheSignature file is an XML file that defines the input and output properties, events, and the
runtime class that executes the activity. For details, see "Signature Files" on page 2025.

TheAddin file is an XML file that references all of the activity component data. For details, see
"Addin Files" on page 2032.

In addition, you can also define resource files to store text strings used by your activity. For details,
see "Resource Files " on page 2035.

The product's installation includes a sample project in theExtensibilitySamples folder. Use this
sample as a basis for a new activity.
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All of the custom files—Signature, Addin, and Runtime—should be stored in the <Installation_
folder>\addins\CustomerAddins\<addin_name> folder. This enables UFT to load them during
startup.

For more details, see "How toManually Create a Custom Activity in C#" on page 2040.

Note: This is a preliminary version of the SDK (Software Development Kit). It enables you to
extend the capabilities of the product. However, this SDK is subject to change in a future
release, and these changes might require you to update any code that uses this preliminary
version. Although HP endeavors to keep these changes to aminimum, we cannot guarantee
that extensions created using the preliminary version of the SDK will continue to work without
modification when upgrading to a new version of HP UFT.

Runtime Files

Relevant for: API testing only

In addition to the signature and addin files, youmust provide a DLL to run when executing the
activity. You create a solution and customize the code as required. You can use the sample
ReportMessageActivitySample.sln located in the product's ExtensibilitySamples folder as a basis
for your project.

UseMicrosoft's IntelliSense to determine themethod's arguments and syntax.

Here are some guidelines that youmust follow:

l As shown in the sample, youmust usemethods that are included in theSTActivityBase class.

public class ReportMessageActivitySample : STActivityBase

l STExecutionResult is the return value of theExecuteStepmethod. It receives one or two
parameters: STExecutionStatus Status and optionally, string msg. STExecutionStatus is an
enum type that can be set to the following values: ActivityFailure, ActivityStopTest,
ApplicationUnderTestFailure, Equals, ReferenceEquals, Success, TestStopped. In the
following example it receives theSuccess value.

return new STExecutionResult(STExecutionStatus.Success);

l Place your executable code within theExecuteStep function.

protected override STExecutionResult ExecuteStep()
{ ...

Note: Youmust compile the DLL with a Target Framework of Framework 4.0, available in
Microsoft Visual Studio 10.
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For task details and an example, see "How to Create a Runtime File" on page 2044.

Signature Files

Relevant for: API testing only

The signature file describes the activity to UFT. It typically has aResource element followed by
the following sections: GeneralProperties, InputProperties, OutputProperties, Tabs, and
Events. The signature file must have an .xml extension.

This following sections describe the elements of the signature file:

Resource Element 2025

Section Element 2026

Property Definitions 2030

Resource Element

Relevant for: API testing only

TheResource element has the following attributes:

Attribute Description

type The type of entity, in this caseActivity.

id A unique string that identifies the activity. You can reference this ID when
writing event handler code. For details, see the section on API coding.

version The version of the current addinmechanism. For example, 1.0.0

group The parent group under which the activity will appear in the Toolbox pane, for
exampleString Manipulation. To add it to an existing group, specify a group
name as it appears in the Toolbox pane. If the group does not exist, it adds a
new group.

shortname The short name of the activity as shown in the Toolbox pane's hint area
(above the description).

description The description of the activity as shown in the Toolbox pane's hint area.

assembly The DLL file to call when running the activity, stored in the same folder as the
signature and addin files.

className The class implemented by the activity.

Note: The class must inherit from the STActivityBase class.
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Attribute Description

image An image file for the icon representing the activity. Store the image in the
same folder as the signature file.

visible A boolean value indicating whether to display the activity is displayed in the
Toolbox pane.

xmlns The namespace that defines the schema for the signature file,
http://hp.vtd.schemas/signature/v1.0. Keep the default value.

xmlns:xsi The schema instance used for the signature file. Keep the default value,
http://www.w3.org/2001/XMLSchema-instance.

xmlns:Location The URL of the signature file's schema, Signature.xsd, referenced by the
namespace. This value has two parts: the namespace and the file path.

l Namespace. http://hp.vtd.schemas/signature/v1.0

l File path. <Installation_Folder>/dat/schemas/Signature.xsd

Keep the default value.

The following example shows theResource section from the signature file of the sample activity,
ReportMessageActivitySample. The location of the sample is: <Installation_
Folder>\ExtensibilitySamples\ReportMessageActivitySample

<Resource
type="Activity"
id="ReportMessageActivitySample"
version="1.0.0"
group="Miscellaneous"
shortName="ReportMessageActivitySample"
description="The ReportMessageActivitySample allows you to send a custom message to the re
port and/or log. "
assembly="ReportMessageActivitySample.dll"
className="ReportMessageActivitySample.ReportMessageActivitySample"
image="toolbox_ReportMessageActivitySample.png"
visible="true"
xmlns="http://hp.st.schemas/signature/v1.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://hp.st.schemas/signature/v1.0 ../../../dat/schemas/Signature.xsd"
>

Section Element

Relevant for: API testing only

The Section definitions apply to all sections in the Signature file, such as GeneralProperties,
InputProperties, andOutputProperties. The following table describes the primary Section
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element attributes.

Attribute Description

name The internal name of the section.

To use a sub-element, it is recommended that you set the value to the
name of the sub-element. For example name="Tab" or name="Alerts".

source If set to true, it displays the source of the section.

dest destination. If set to true, it displays the destination path of the section.

checkpoint If set to true, displays the checkpoint check box in theValidate column.

isSharedMetadata When true, enables the section to share its meta data with other sections.

propertiesType The type of the properties in the section, for example, "XML".

showXmlControls When true, displays the XML controls such as Text and XPath tabs in the
section.

displayName The name of the section as it will appear in the Properties pane.

The following table describes the sub-elements of Section:

Element Description

Tab The tabs to appear in the Properties pane using the following attributes. For details,
see below.

l name. The internal name of the tab. Some of the built-in ones areGeneral,
InputOutput, Events, Attachments, andSOAPFault.

l id. The id of the tab referred to be the API. The id usually uses the namewith an
added suffix, "Tab". For example, GeneralTab, InputOutputTab, andEventsTab.

l CanBeInToolbox. If true, shows the tab on the Toolbox pane's toolbar.

l CanBeInPropertySheet. If true, shows the tab in the Properties pane.

l CanBeInDataLinkDialog. If true, shows the tab in the "Select Link Source Dialog
Box (API Testing)" (described on page 1840).

Note: To use the default tabs: General, Input/Checkpoints, andEvents, you do
not need to include this element. If you want to omit one of the tabs or add extra
ones, then you need to include the Tabs sub-element and specify the desired
tabs.

For details about the tabs, see "Properties Pane" on page 385.
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Element Description

Alert Enables you to apply alerts to the properties in the section using the following
attributes:

l constraint. The reason to show the alert, for example, NullValueConstraint.

l target. The Xpath of the property to which to apply the constraint.

l section. The internal name of the section containing the properties.

l type. The type of alert, such as error orwarning

The value of the element, is the alert message. For example:

<Section name="Alerts" isSharedMetaData="true">
<Alert constraint="NullValueConstraint"
         target="/Url[1]"
         section="InputProperties"
         type="error">The 'URL' must not be empty</Alert>
</Section>
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Element Description

Events In theEvents sub-element, you can customize the events that will be available for the
activity. This sub-element uses the following attributes

l name. The internal name of the event. Use one of the built-in names or define a
custom one.

n CodeCheckpointEvent. Enables you to create an event handler to run when
the test is verifying checkpoints.

n BeforeExecuteStepEvent. Enables you to create an event handler to run
before executing the activity.

n AfterExecuteStepEvent. Enables you to create an event to run after executing
the activity.

n <custom event>. A custom event that you define.

l description. A textual description of the event.

l eventArgs. The source of the arguments for the event. The standard argument for
BeforeExecuteStepEvent andAfterExecuteStepEvent event is
STActivityBaseEventArgs. The built-in value for theCodeCheckpointEvent is
CheckpointEventArgs.

Web Service steps provide additional built-in events. For details, see "UpdatingWeb
Services" on page 1854.

Note: To access the default events: CodeCheckpoint, BeforeExecute, and
AfterExecute, you need to include only theEvents tab in the Tab sub-element,
but you do not need to use theEvents sub-element. If you want to omit one of the
events or add custom events, then you need to include this sub-element and
specify the desired events.
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Property Definitions

Relevant for: API testing only

The property definitions in the signature file, apply to all sections that use properties. The built-in
sections that use properties are:

l GeneralProperties. Defines the properties in theGeneral view of the Properties pane, for
exampleStep ID andName.

l InputProperties. Defines the input properties located in the Input pane of the of the Properties
pane's Input/Checkpoints tab.

l OutputProperties. Defines the output properties located in theCheckpoints pane of the of the
Properties pane's Input/Checkpoints tab.

This section includes:

l "Elements and Sub-Elements" below

l "Element Attributes" on the next page

l "Simple Elements with Enumeration" on page 2032

l "Complex Array Elements" on page 2032

Elements and Sub-Elements
The elements and attributes are defined in the standard XML schema file,
http://www.w3.org/2001/XMLSchema, or the built-in types.xsd schema, located in the
<Installation_Folder>/dat/schema folder. The following table describes the elements and sub-
elements that can be used in these sections. The level number indicates the level of the element or
sub-element in the hierarchy.

Element Description

xs:schema The schema namespaces for the properties, as described by the xml:ns
attribute.

Keep the default values, http://hp.vtd.schemas/types/v1.0 and
http://www.w3.org/2001/XMLSchema.

xs:import The namespace to import using the namespace and schemaLocation
attributes.

Keep the default values, http://hp.vtd.schemas/types/v1.0 and
../../../dat/schemas/types.xsd.

xs:element The element to define, using the attributes described in the table below.
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Element Description

xs:simpleType A tag indicating the beginning of definitions of a simple type property.

Note: You only need to enclose a simple type element with this tag, if
you want to do enumeration with a drop-down list. For example, the
following definition does not require an xs:simpleType tag.

<xs:element name="ClientCertificate" type="types:Certificate"
types:displayName="Client certificate" />

xs:complexType A tag indicating the beginning of definitions for a node of multiple properties.

xs:sequence A tag indicating the beginning of a list of properties in a complex type
property.

xs:restriction A tag restricting the value of the enumeration values of a property, using the
base attribute. To restrict String type values, use base="xs:string".

xs:enumeration A tag indicating the beginning of list of values in the drop-down list for a
property, using the value attribute.

xs:annotation An annotation for the element Use an xs:documentation sub-element to
compose text that will appear below the properties grid in the Properties
pane.

Element Attributes
The following table describes the primary attributes of the xs:element. For attributes in the standard
XML schema, use an xs: prefix in the value, for example standard types use type=xs:string or
type=xs:int.

For types defined in the Types.xsd schema, use a types: prefix in the attribute name. For example
types:displayName.

Attribute Description

name The internal name of the property or grid in the Properties pane. This is the
name referenced by other calls and by the event handlers code. This is
not the name displayed in the Properties pane's Name column.

type The type of property. Some common values are:

xs:string, xs:int, xs:boolean,Multipart, Header, Part. For a value defined
in the Types schema, use the types: prefix. For example
type="types:filePath".

minOccurs Theminimum number of array elements for which the user must provide.
For none, specify "0".
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Attribute Description

maxOccurs Themaximum number of array elements the user may provide. To allow
an unlimited amount, specify "unbounded"

types:visible When true, enables the parameter to be visible even before being
expanded by the Add Array Element command.

types:argType The type of the property: "XML" or "Object".

types:displayName The property name as it will appear in the Properties pane.

Simple Elements with Enumeration
The followingReportMessageActivitySample example defines an input parameter, Status, with
an enumeration attribute. This code creates a drop-down list of values in the Properties pane's input
property grid.

<xs:element name="Status" default="Done" types:displayName="Status">
<xs:simpleType>
<xs:restriction base="xs:string">
<xs:enumeration value="Done"/>
<xs:enumeration value="Pass"/>
<xs:enumeration value="Fail"/>
</xs:restriction>
</xs:simpleType>

</xs:element>

Complex Array Elements
The following sample defines a complex property, with aKey andValue pair of values.

<xs:complexType name="NameValueType">
<xs:sequence>
<xs:element name="Key" type="xs:string"/>
<xs:element name="Value" type="xs:string"/>

</xs:sequence>
</xs:complexType>

Addin Files

Relevant for: API testing only

The addin file provides the references for the activity you are defining. The file is in XML format and
contains information such as activity names, dependencies, and runtime DLLs.

The addin file should be located in the installation directory under the
addins\CustomerAddins\<addin_name> folder, together with the signature file. The addin file must
have an .addin extension.
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Each addin file should contain the following sections:

l "Addin Section" below

l "Manifest Section" below

l "Runtime Section" on the next page

Addin Section
The Addin's attributes describe the activity to UFT.

Element Description Attributes

<Addin> Basic details
about the addin.

l name. the name of the addin.

l author. the creator of the activity.

l copyright. the full path of a text file with the copyright
information.

l description. a textual description of the activity.

l version. The addin file version, set to 1.0.

Path Details about the
location of the
activity.

l name. The logical path scanned by the framework, to
identify addins. The physical location of this folder is
addins\CustomerAddins\
<addin_name>.

Activity
(sub-
element of
Path)

See attribute
descriptions.

l id. An identifying string corresponding to the ID in the
signature file.

l displayName. The activity's display name in the
Toolbox pane.

l signatureFile. The name of the XML signature file.

Manifest Section
TheManifest section contains a unique logical name for the addin and provides a list of
dependencies.

Element Description Attributes

Identity Basic details about the
addin.

l name. The activity name corresponding to the ID in
the signature file. When referring to this addin as a
dependency, use this name.
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Element Description Attributes

Dependency The activity upon
which the current
activity is dependent

l addin. The identity name of the dependent activity,
from the name attribute in theManifest section of its
addin file.

l requirePreload. A boolean value indicating whether
to preload the dependent addin before loading the
current one.

Runtime Section
The runtime section contains information about the addin's runtime file.

Element Description Attributes

Import An assembly to
import when
running the
activity.

l assembly. The name of an assembly. Use the DLL name
without the DLL extension.

Note: To import an addin from another activity, precede the
addin namewith a colon. For example,
:HP.ST.Fwk.DesignerModel imports the DesignerModel
addin.

The following example shows theReportMessageActivitySample.addin file. For multiple
activities, use uniqueAddin files.

<?xml version="1.0" encoding="utf-8"?>
<AddIn name = "HPReport Message Activity Sample"
    author = "John Doe"
    copyright = "C:\Copyrights\copyright.txt"
    description = "Extensibility Sample - Report Message Activity"
    version="1.0">
<Manifest>
<!--<Must be unique -->
<Identity name = "ReportMessageActivitySample"/>
</Manifest>
<Runtime>
<Import assembly=":HP.ST.Fwk.DesignerModel"/>
</Runtime>
<Path name = "/ST/Activities">
<!--Misc Activities -->
<Activity id = "ReportMessageActivitySample"

displayName = "ReportMessageSample"
signatureFile = "ReportMessageActivitySample.xml"
assembly="ReportMessageActivitySample.dll"/>

</Path>
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</AddIn>

Resource Files

Relevant for: API testing only

You can use resource files to retrieve values for elements and attributes. The fromResource
function lets you name the resource containing the values.

In the following example, the signature file retrieves the shortName and description from a
resource file.

<Resource
type="Activity"
id="ReportMessageActivitySample"
version="1.0.0"
group="Miscellaneous"
shortName="fromResource(conc_str_short_name)"
description="fromResource(conc_str_description)"

The resources are defined in a standardMicrosoft ResX Schema version 2.0 Resource fie.

<data name="conc_str_description" xml:space="preserve">
<value>Reports an activity's run status to the log</value>
</data>
<data name="conc_str_short_name" xml:space="preserve">
<value>Report Message</value>
</data>

The resource referencemust be a compiled file with a .resources extension, compiled from the
ResX source file and stored in the same folder as the signature file.

You can generate the compiled file as a post-build operation using the resgen utility. For example:

resgen STBasicActivity.resx STBasicActivity.resources.

For step-by-step instructions on how to create a custom activity, see "Prerequisite - create a
runtime file" on page 2041.
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Tasks

How to Use the Wizard to Create a Custom Activity - C#
Relevant for: API testing only

This task describes how to create a new activity, using C#, and deploying it in UFT.

This task includes the following steps:

l "Run the Activity Wizard" below

l "Open the folder" below

l "Add execution code" below

l "Add Logger code - optional" on the next page

l "Add a Report statement - optional" on the next page

l "Compile the project into a DLL" on the next page

l "Deploy the activity" on the next page

l "Add a test step" on the next page

1. Run the Activity Wizard
Open the Activity Wizard from the product's start menu (Start > All Programs >
HP Software > HP Unified Functional Testing> Tools > Activity Wizard).

In the wizard's General Properties pane, select theC# as the Language.

Define the relevant properties and proceed to the last screen of the wizard. For details, see the
"Activity Wizard" on page 2049.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75.

2. Open the folder
On the final screen of the wizard, click Open Folder to open the <Activity Name> folder,
corresponding to the activity name you specified in the wizard. Navigate to the following
subfolderSourceCode and locate the <Activity Name>.cs file.

3. Add execution code
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Add your execution code to theExecuteStep function inside the .cs file.

protected override STExecutionResult ExecuteStep()
{
try
{ 
//**************************
// Execution code goes here //**************************
...

4. Add Logger code - optional
Add information for the log using the LogInfo, LogDebug, or LogError statements. For
example:

protected override STExecutionResult ExecuteStep()
{
try
{ 
    LogInfo("Log Message 1");
    LogDebug("Log Message 2");
    LogError("Log Message 3");
...

5. Add a Report statement - optional
Add aReport statement. For example:

protected override STExecutionResult ExecuteStep()
{
try
{ 
        DetailsReport = DetailsReport.Replace("\\n", "<BR>");
        this.Report("Message", DetailsReport);    ;
...

6. Compile the project into a DLL
Build the project andmake sure the current <Activity Name> .dll file is in the new activity folder
that you specified in the wizard.

7. Deploy the activity
In the final wizard screen, click Deploy in UFT. Click Finish to close the wizard. Restart
UFT.

8. Add a test step
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n Open a new test and add the new custom activity (by default under theMiscellaneous
category) into the Test Flow.

n Provide values for the properties you defined for the activity in the wizard.

n Run the test and observe the Output log and RunResults Viewer.

n Enable checkpoints to verify the results and rerun the test.

How to Use the Wizard to Create an Activity - Java
Relevant for: API testing only

This task describes how to create a new activity using Java code, and deploy it in UFT.

This task includes the following steps:

l "Prerequisite" below

l "Run the Activity Wizard" below

l "Open the folder" on the next page

l "Edit the code" on the next page

l "Add Logger code - optional" on the next page

l "Add a Report statement - optional" on the next page

l "Compile the Java into a class" on page 2040

l "Deploy the activity" on page 2040

l "Add a test step" on page 2040

1. Prerequisite
Make sure you have a JAVA_HOME environment variable defined on your machine indicating
the parent JDK folder.

2. Run the Activity Wizard
Open the Activity Wizard from the product's start menu (Start > All Programs >
HP Software > HP Unified Functional Testing > Tools >Activity Wizard).

In the wizard's General Properties pane, select the Java as the Language.
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Define the relevant properties and proceed to the last screen of the wizard. For details, see the
"Activity Wizard" on page 2049.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75.

3. Open the folder
On the final screen of the wizard, click Open Folder to open the <Activity Name> folder,
corresponding to the activity name you specified in the wizard. Navigate to the following
subfolder <Activity Name>\hp\st\ext\java and locate theMyLogic.java file.

4. Edit the code
Edit theExecuteLogic function inside theMyLogic.java file. Make sure to keep theProperties
definition.

public Properties Props = new Properties();
public ExecutionResult ExecuteLogic()
{
    try{
    //**************************
    // Execution code goes here
    //**************************
    return ExecutionResult.Success;
    }
...

5. Add Logger code - optional
Add information for the log using the Logger.LogInfo, Logger.LogDebug, or
Logger.LogError statements. For example:

    try{
    ...
        Logger.LogInfo("Log Message 1");
        Logger.LogDebug("Log Message 2");
        Logger.LogError("Log Message 3");
    ...
    return ExecutionResult.Success;
    }

6. Add a Report statement - optional
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Add a Report statement, Reporter.Report, using key value combinations. For example:

    try{
    ...
        Reporter.Report{"Name","John");
    ...
    return ExecutionResult.Success;
    }

7. Compile the Java into a class
a. In your design IDE, add theServiceTestCall.jar file to the build path.

b. In UFT, run theCompileJavaFiles batch file in the <Activity
Name>\hp\custom\java\activity folder to compile all java files into a class. This utility only
compiles the files in its folder.

8. Deploy the activity
In the final wizard screen, click Deploy in UFT. Click Finish to close the wizard. Restart
UFT.

9. Add a test step
n Open a new test and add the new custom activity (by default under theMiscellaneous

category) into the Test Flow.

n Provide property values in the Properties pane.

n Run the test and observe the Output log and RunResults Viewer.

n Enable checkpoints to verify the results and rerun the test.

How to Manually Create a Custom Activity in C#
Relevant for: API testing only

This task describes how to create a new activity and implement it into UFT.

To run a test with the custom activity on another machine, you need to copy all of the custom files
to its <Installation_Folder>\addins\
CustomerAddins\<addin_name> folder.

This task includes the following steps:

l "Prerequisite - create a runtime file" on the next page

l "Create a signature file" on the next page
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l "Create an addin file" on the next page

l "Provide a graphic for your activity - optional" on page 2043

l "Check the implementation" on page 2043

1. Prerequisite - create a runtime file
Create a C# project that implements your activity's actions in the
addins\CustomerAddins\<addin_name> folder. For task details, see "How to Create a
Runtime File" on page 2044.

2. Create a signature file
a. Create a new signature file with an .xml extension. in the addins\CustomerAddins\<addin_

name> folder, together with the runtime file. Use the sample project in the <installation
folder>\ExtensibilitySamples folder as a basis for your custom signature file.

b. Customize theResource section or copy the code provided below, modifying the bolded
text for your needs. For details about each of the elements, see "Resource Element " on
page 2025.

<Resource
type="Activity"
id="ReportMessageActivitySample"
version="1.0.0"
group="Miscellaneous"
shortName="ReportMessageActivitySample"
description="ReportMessageActivitySample allows you to send a custommessa
ge to the report and/or log. "
assembly="ReportMessageActivitySample.dll"
className="ReportMessageActivitySample.ReportMessageActivitySample"
image="toolbox_ReportMessageActivitySample.png"
visible="true"
xmlns="http://hp.st.schemas/signature/v1.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://hp.st.schemas/signature/v1.0 ../../../dat/schemas/Signatur
e.xsd"
>

c. Add the required sections, such as GeneralProperties, InputProperties, Tabs, Events and
so forth. For a list of the built-in sections and their attributes, see the "Section Element" on
page 2026.
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d. Add properties to the relevant sections. For details and examples, see "Property
Definitions" on page 2030.

o GeneralProperties. Properties displayed in the Properties pane's General tab. In most
cases you can use the section as it appears in the sample file, without any
modifications. By default, it will provide theStep ID andName properties.

o InputProperties. Properties displayed in the Properties pane's Input/Checkpoints
tab, in the Input pane.

o OutputProperties. Properties displayed in the Properties pane's Input/Checkpoints
tab, in theCheckpoints pane.

e. Specify any external resource files as described in "Resource Files " on page 2035.

f. Close the file with the </Resource> tag.

</Resource>

Formore details about the structure of the signature file, see "Signature Files" on page
2025.

3. Create an addin file
a. Create a new file with an .addin extension in the <installation

directory>\addins\CustomerAddins\
<addin_name> folder, together with the signature file.

b. Use the sample addin file in the <installation folder>\ExtensibilitySamples folder as a
basis, or copy the code provided below, modifying the bolded text for your needs. For
details, see "Addin Files" on page 2032.

<?xml version="1.0" encoding="utf-8"?>
<AddIn name = "HP Report Message Activity Sample"

author = "John Doe"
copyright = "prj:///doc/copyright.txt"
description = "Extensibility Sample - Report Message Activity"
version="1.0">

<Manifest>
<!--<Must be unique -->
<Identity name = "ReportMessageActivitySample"/>
</Manifest>
<Runtime>
<Import assembly=":HP.ST.Fwk.DesignerModel"/>
</Runtime>
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<Path name = "/ST/Activities">
<!--Misc Activities -->
<Activity id = "ReportMessageActivitySample"

    displayName = "ReportMessageSample"
signatureFile = "ReportMessageActivitySample.xml"

    assembly="ReportMessageActivitySample.dll"/>
</Path>
</AddIn>

c. Create a uniqueAddin file for each activity—do not definemultiple activities in a single
Addin file. For details, see "Addin Files" on page 2032.

d. Define post-build tasks such as resgen, as described in "Resource Files " on page 2035.

e. Compile the project and copy the DLL to the <Installation_
Folder>\addins\CustomerAddins\<addin_name> folder.

For additional details, see "Runtime Files" on page 2024.

4. Provide a graphic for your activity - optional
a. Copy an icon image for your activity into the <Installation_

Folder>\addins\CustomerAddins\<addin_name> folder. This file shouldmeet the following
requirements:

o a .png extension

o sized at 16 x 16 pixels

o 8-bit color depth

b. Specify the name of the image file in the signature file's "Resource Element ".

5. Check the implementation
a. Reopen the application and drag the new activity into the Test Flow. Verify that the activity

and its properties appear as expected.

b. Provide property values.

c. Run the test and observe the Output log and RunResults Viewer.

d. Enable checkpoints to verify the results and rerun the test.
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How to Create a Runtime File
Relevant for: API testing only

This section contains the following topics:

l "Add Using statements" below

l "Specify the namespace and class" below

l "Set the internal logging" on the next page

l "Initialize the properties" on the next page

l "Retrieve the property values" on the next page

l "Define events" on page 2046

l "Execute the step" on page 2047

l "Set the status" on page 2047

l "Compile the runtime file" on page 2048

Note: Youmust compile the DLL with a Target Framework of Framework 4.0.

1. Add Using statements
Provide themandatory using statements. In your solution, youmust also add a reference to
the .dll files. The .dll files are located in the products installation's /bin folder. Youmust always
add a reference toHP.ST.Fwk.RunTimeFWK.dll. If you are using internal logging, youmust
also add a reference to log4net.dll.

The following example shows theUsing statements in the sample .cs file.

using HP.ST.Fwk.RunTimeFWK;
// If you need to implement Internal Logging
using log4net;

2. Specify the namespace and class
Define the namespace and provide the activity's runtime code. The class you define for your
custom activity must inherit from theSTActivityBase class. For example:

namespace ReportMessageActivitySample
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{
[Serializable]
public class ReportMessageActivitySample : STActivityBase
{

3. Set the internal logging
Use the built-in logger manager to instruct the activity to create an internal log during runtime.
This example gets the property values of the input properties and sends the output to either the
Run Results Viewer only or to the Run Results Viewer andOutput window. For example:

/// <summary> /// Internal log
/// </summary>
private static readonly ILog log =

LogManager.GetLogger(typeof(ReportMessageActivitySample));
const string runResults = "Run Results";
const string runResultsAndOutputWindow = "Run Results and Output Window";

For details about other logging options, see "Assert Object" on page 1989.

4. Initialize the properties
Initialize the custom Input andOutput properties that you define in the signature file. The
following example initializes the three input properties: Status,Message, andDestination. For
example:

/// <summary>
/// Initializes properties.
/// </summary>
/// <param name="ctx">The runtime context</param>
public ReportMessageActivitySample(ISTRunTimeContext ctx, string name)
: base(ctx, name)
{
this.Status = String.Empty;
this.Message = String.Empty;
this.Destination = String.Empty;
}

5. Retrieve the property values
This section retrieves or sets the input property values. For example:

/// <summary>
/// Gets or sets the status of the message to report.
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/// </summary>
public string Status { get; set; }
/// <summary>
/// Gets or sets the details of the message to report.
/// </summary>
public string Message { get; set; }
/// <summary>
/// Gets or sets the destination where the message should be reported to.
/// </summary>
public string Destination { get; set; }

If you have array type properties that are not described by a schema, for example, key/value
pairs, youmust initialize all themembers of the array explicitly, and indicate the actual number
of elements.

The following example initializes 40 elements for theMyArrayName property. It contains 40
key and value pairs.

this. MyArrayName = new MyPair[40];
for (int i=0; i<40; i++)
{
this. MyArrayName [i] = new MyPair();
}
public MyPair[] MyArrayName;
public class MyPair
{
string Key;
string Value;
}

For arrays defined by a schema orWSDL, you can use the standard "Select Link Source
Dialog Box (API Testing)" (described on page 1840) and link directly to the array element.

6. Define events
Define one or more custom events, that you will invoke later. For example:

public event EventHandler CustomerEvent;
private void InvokeCustomerEvent(EventArgs MyArg)
{
EventHandler handler = this.CustomerEvent;
if (handler != null)
{
handler(this, MyArg);
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}
}

7. Execute the step
Execute the step and send the runtime information to the log. Use theSTExecutionResult
data type and its ExecuteStep function defined in theSTActivityBase class. For example:

protected override STExecutionResult ExecuteStep()
{
string DetailsReport;
if (this.Destination == runResultsAndOutputWindow)
{
LogInfo("\n" + this.Message.Replace("\\n", "\n"));
}
/// <summary>
/// Reports message to test results and output window.
/// </summary>
// The line-breaks replacements allow the printing of multiple lines in the report

DetailsReport = this.Message;
DetailsReport = DetailsReport.Replace("\\n", "<BR>");
DetailsReport = DetailsReport.Replace("\n", "<BR>");
this.Report("Message", DetailsReport);

If you defined a custom event, invoke it after the call toExecuteStep.

...
protected override STExecutionResult ExecuteStep()
{
InvokeCustomerEvent();
}

8. Set the status
Set the Status of the test run. TheReportMessageActivitySample.cs sample file uses
enumeration to set the status, based on theSTExecutionResult value. For example:

switch (this.Status)
{
case "Done":
this.Report(ReportKeywords.StatusKeywordTag, ReportKeywords.DoneValueTag);
return new STExecutionResult(STExecutionStatus.Success);
case "Pass":
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this.Report(ReportKeywords.StatusKeywordTag, ReportKeywords.SuccessValueTag);
return new STExecutionResult(STExecutionStatus.Success);
case "Fail":
this.Report(ReportKeywords.StatusKeywordTag, ReportKeywords.FailureValueTag);
return new STExecutionResult(STExecutionStatus.Success);
default:
return new STExecutionResult(STExecutionStatus.Success);
}

9. Compile the runtime file
After you customize the code, you compile the .dll. The .dll name should be the same as the
name of the addin file. For example, the runtime file, ReportMessageActivitySample.dll
corresponds to theReportMessageActivitySample.addin file.

After you create the runtime file in your development environment, you reference the .dll from
the signature file, and the signature file from the addin file.
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Reference

Activity Wizard
Relevant for: API testing only

This wizard enables you to create new custom activities in the Toolbox pane.

To
access

Start > All > Programs > HP Software > HP Unified Functional Testing > Tools
> Activity Wizard

Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set Properties
Page " > "Confirm Page " > "Progress Page " > "Finish Page "

See
also

l "Creating New Activities - Overview " on page 2023

l "How toManually Create a Custom Activity in C#" on page 2040

l "How to Use theWizard to Create a Custom Activity - C#" on page 2036

General Properties Page

Relevant for: API testing only

This wizard page enables you to set the General type properties for the activity.
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Important
information

General information about this wizard is available here: "Activity Wizard" on the
previous page.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI
Elements Description

Reset Values. Resets all of the values to their original defaults and discards all
changes that youmade.
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UI
Elements Description

Open Wizard Project. Opens a Visual Studio activity project that you created
earlier.

Category The category under which to deploy the activity. A drop down list contains all of
the built-in or previously created categories.

Clicking on New opens the Add New Category dialog box.

Description A meaningful description that will appear in the Toolbox pane's hint area when
you select the activity.

Display
Icon

An icon image for the activity for the Toolbox pane and canvas. Click Import to
upload a new image file for the icon. The icon size should be 16 x 16 pixels.

Display
Name

The name of the activity as it will appear in the canvas and Toolbox pane.

Language The language in which to generate the code: C# or Java.

Note:When you select Java, the wizard creates a Java file to which you can
add the logic for your activity, and references to other required files. In
addition, a Visual Studio project is created tomanage the integration between
the API Test and your Java activity.

Project
Location

The location in which to save the project.

Unique
Activity ID

A unique ID for the new activity. This ID can be used to reference the activity.
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Project Properties Page

Relevant for: API testing only

This wizard page enables you to set the properties for the activity project.

Important
information

General information about this wizard is available here: "Activity Wizard" on page
2049.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "
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User interface elements are described below:

UI Elements Description

Activity Class
Name

A class name for the activity that will be generated.

Project Name The name of the project.

Edit advanced
properties

Enables themanual editing of additional project properties.

Project Namespace The namespace to create for the project.

Project File Name The name of the project file. By default, this is theProject Namewith a
.csproj extension.

Solution File Name The name of the solution file. By default, this is theProject Namewith
an .sln extension.

Class FIle Name The name of the class file. By default, this is theProject Namewith a
.cs extension.

Class Partial FIle
Name

The name of the class file. By default, this is theProject Namewith a
.cs extension.

Assembly Name The name of the assembly file. This namewill be associated with the .dll
extension.
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Set Properties Page

Relevant for: API testing only

This wizard page lets you to define Input andOutput properties for the activity and add new General
properties.

Important
information

General information about this wizard is available here: "Activity Wizard" on page
2049.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "
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User interface elements are described below (unlabeled UI elements are shown in angle brackets):

UI
Elements Description

Open in Separate Window. Opens a list of the properties in a separate window.

Add Property. Opens the Add New Property dialog box. For details, see "Add New
Property" on the next page.

Remove Property. Deletes the selected property from the activity.

Clone Property.Makes a copy of the selected property.

Show Properties Tree. Shows the properties in a tree hierarchy, by category—
General, Input, andOutput.

Show Properties List. Hides the property tree hierarchy and shows all of the
properties in a single grid.

Add/Remove Columns. Opens the Add/Remove Columns dialog box enabling you
to indicate which columns will be displayed in the Set Properties wizard page.

Show Properties Pane. Opens the Properties pane in a dockable window. You can
edit all of the property values— even ones that are not displayed in the wizard
screen columns.

Hide Properties Pane. Closes the Properties pane.

<property
list>

A grid representation of the activities properties.

Tip:

l To show different or additional columns in the grid, click theAdd/Remove
Columns button and select the desired columns.

l To change the order of the columns in the display, drag to column title to the
desired location.
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Add New Property

Relevant for: API testing only

The Add New Property dialog box lets you create new properties for the activity.

To access Do the following:

1. Open the Activity Wizard. For details, see "Activity Wizard" on page 2049.

2. Advance to theSet Properties page.

3. Click theAdd Property button in the toolbar .

User interface elements are described below:

Tree
Elements Description

Section The section in which to add the property: Input, Output (Checkpoint), or
General.

Type The data type of the property, such as String, Int, and so forth.

Name The name of the property as it will be called within the test and by event handlers.

Display
Name

The name of the property as it will be displayed in the property list.

Description An optional description of the property, that will appear in the hint area when you
select the property in the Properties pane.
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Confirm Page

Relevant for: API testing only

This wizard page shows you a summary of your settings before generating the activity.

Important
information

General information about this wizard is available here: "Activity Wizard" on page
2049.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI Elements Description

<summary text> A message indicating that the wizard is ready to begin the generation.
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Progress Page

Relevant for: API testing only

This wizard page shows you the generation progress.

Important
information

General information about this wizard is available here: "Activity Wizard" on page
2049.

Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "
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User interface elements are described below:

UI Elements Description

<progress information> A log indicating progress of the generation.

Finish Page

Relevant for: API testing only

This wizard page enables you to view the generation log, open the solution and its folder, and
deploy the activity.

Important
information

General information about this wizard is available here: "Activity Wizard" on page
2049.
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Wizard
map

This wizard contains:

Welcome > "General Properties Page" > "Project Properties Page" > "Set
Properties Page " > "Confirm Page " > "Progress Page " > "Finish Page "

User interface elements are described below:

UI Elements Description

View Report Opens a log of the generation process. The log file is located in the
%temp%\ ActivityWizard\Reports folder. Its title contains the
generation date,WizardLog_#datetime#.log.

Open Folder Opens the folder in which the activity files were generated. This
folder is the Output directory you specified in the wizard.

For example, you can open this folder to locate the java files to
which you can add your custom code. The default subfolder is
hp\st\ext\java.

Open Solution Opens the activity's solution file in Visual Studio 2010. Use this
option to edit and compile the source code.

Deploy in UFT Deploys the activity in UFT by adding it to the Toolbox pane.

Close the Activity
Wizard after selecting
one of the above options

Closes the wizard screen automatically after selecting theView
Report, Open Folder, Open Solution, orDeploy in UFT options.
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Troubleshooting and Limitations - Extensibility (API
Testing)

Relevant for: API testing only

This section describes troubleshooting and limitations for creating and using custom activities.

l Youmust have Visual Studio 2012 installed on the samemachine as UFT to create custom
activities using the Activity Wizard.

l The following error may occur if you place the signature file beneath a sub-folder of the addin
folder.

ServiceTest was unable to drag and drop the activity: Type 'http://hp.vtd.schemas/types/v1.0:
GeneralPropertiesType' is not declared.

Workaround:Modify the relative path of the Types schema. For example:

.schemaLocation="../../dat/schemas/Types.xsd".

l If youmodify the activity structure in the signature file, you will be unable to open tests using
that activity. Tomodify an activity structure, create a new activity with the new structure,
replace all of the test steps using the old activity, and then remove the old activity
implementation.

l Custom Java activities created in versions of UFT prior to 12.00 will fail when you run your test.

Workaround:

a. Remove theServiceTestCall.java interface from the project in which you created the
custom Java activity..

b. Change the project package name to something other than hp.st.ext.java.

c. Add theServiceTestCall.jar file to your classpath. This file is located in <UFT installation
path>
\Addins\ServiceTest\JavaCall\Java Interface\bin.

d. Recompile your Java project.
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Chapter 64: Business Process Testing in UFT
Relevant for: business process tests and flows

This chapter includes:

Concepts 2064

Business Process Testing Overview 2064

Business Process Test and Flow Overview 2064

Business Process Testing in UFT - Overview 2065

Business Process TestingMethodologies 2065

Tasks 2071

How to Create, Maintain, and Run Business Process Testing Tests and Flows in UFT 2071

Reference 2074

Business Process Testing in UFT User Interface 2074

Comparing BPT in UFT to BPT in ALM 2077

Troubleshooting and Limitations - Business Process Testing in UFT 2079
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Concepts

Business Process Testing Overview
Relevant for: business process testing

Business Process Testing provides you with a customizable, component-based testing framework
that supports:

Component reuse and modularization
Component reuse andmodularization keep costs low by speeding up test creation, maintenance,
and execution.

Creation of tests for both simple and complex applications
An application under test can be a simple, HTML-based web application or a complex business
process involving packaged applications and back-end services and databases.

Collaboration between various personas
The testing framework is flexible enough tomeet the needs of various personas, such as manual
testers, automation engineers, and subject matters experts.

Business Process Testing helps you document your components and tests, including screenshots
illustrating how they should be used, and so on. This makes it easy for people with different roles
and skill sets to share others assets.

Management of parts of a test
Managing parts of a test includes component documentation, test run results, version control,
reporting, and history. Additionally, using ALM, you can generate documents containing information
about the tests, flow, and components in a given project.

In Business Process Testing, you arrange components, including keyword GUI components,
scripted GUI components, or manual components in a business process test or business process
flow to test different scenarios. Business Process Testing enables you to arrange components to
suit your needs.

Note: Business Process Testing is available with ALM Edition andQuality Center Enterprise
Edition. For more information about the HP Business Process Testing editions and their
functionality, see theHP Application Lifecycle Management User Guide. To find out what
edition of HP Business Process Testing you are using, ask your ALM site administrator.

Business Process Test and Flow Overview
Relevant for: business process testing

Whenworking with Business Process Testing in UFT, you can use both business process tests
and business process flows to organize your testing.
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While tests and flows are fundamentally the same as they both contain a specified order of
business components, there are differences:

l A business process test is a scenario comprising a sequence of business components or flows,
designed to test a specific scenario in an application.

l A flow is a type of test that comprises a logical set of business components, in a fixed
sequence, that performs a specific task. Flows share the same functionality as business
process tests (for example, iterations, parameters, and results) in addition to functionality unique
to flows (validation, debugmode). When designing flows, they can be considered as "compound
components."

In addition, flows cannot contain other flows.

You can use a flow inmultiple business process tests. When youmodify a flow or any of its
components, all business process tests containing that flow reflect that modification.

However, fundamentally, when you perform a run of your tests and flows, youmust run them as
part of a business process test.

Business Process Testing in UFT - Overview
Relevant for: business process tests and flows

In UFT, you can create and edit business process tests and flows with the native UFT Toolbox,
Data, and Properties panes.

To work with BPT from within UFT, youmust first connect to an ALM project with BPT support.

In UFT, you can create and edit keyword GUI components, scripted GUI components, and API
components. For details about keyword and scripted GUI components, see "Business
Components" on page 2080. API components aremuch like API tests, described in "API Testing
Design" on page 1588. Some exceptions and limitations for working with API components are
described in "Working with API components" on page 2079.

In addition, business components use application areas to store settings and resources that may be
required by multiple components, such as shared object repositories and function libraries.
Components are automatically linked to all of the resources and settings defined in the associated
application area. For more details about application areas, see "Application Areas" on page 2095.

For a task on how to create and edit your business process tests in UFT, see "How to Create,
Maintain, and Run Business Process Testing Tests and Flows in UFT" on page 2071.

Business process tests and flows can also includemanual testing components. For details about
manual testing, as well as details about using BPT in ALM, see theHP Business Process Testing
User Guide in the ALM documentation set.

Business Process Testing Methodologies
Relevant for: business process tests and flows
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BPT is flexible and does not require any one particular model for incorporating business processes
into your testing environment. The actual workflow in an organizationmay differ for different
projects, or at different stages of the application development life cycle.

The chapters in this guide are structured according to the bottom-upmethodology.

Bottom-up Methodology
Defining low-level components first and then designing business process tests based on the
defined components is called a bottom-upmethodology. This methodology is particularly useful:

l For regression testing

l When the business processes in the organization are clearly defined.

l When users are new to BPT.

The bottom-upmethodology is based on the following design phases:
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Phase Description

Component
Specification

l Develop a component tree with components.

l Create the component shell by adding basic details.

l Create component content by addingmanual and/or automated
implementations. Component content can contain:

n Manual implementation for manual components

n Automation, for automated components

n Bothmanual implementation and automation

Data Handling Design the data that each business process test, flow, or component uses
when run.

Test Planning Build test plans and design business process tests and flows.

Test Execution Create a subset of the business process tests in your project and run them.

Top-down Methodology
The top-downmethodology advocates the creation of business process testing entities according
to the following hierarchy:

l Business process tests, which contain flows and/or business components

l Flows, which contain business components

l Business components, which contain manual and/or automated steps
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The top-downmethodology is based on the following design phases:

Design Phase Description

High-level
design

Includes the high-level design, creation of a structure for business process
tests, and determining the test configurations for testing different use-cases
that will be needed.

When designing at the high-level, facilitate automation:

l By designing with modularity in mind. Design tests to use smaller,
reusable components that automated tests can call multiple times.

l By designing tests with reusable components, whichmakes maintaining
tests easier.
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Mid-level
design

Includes the:

l Creation of flows (sets of business components in a logical order that can
be run). Flows are considered "compound components."

l Creation of business components (reusable units that perform specific
tasks in a business process). Only the shell of the component is created
during this phase.

l Specification of criteria for more granular test coverage (requirements) as
necessary.

l Linking to other testing documents.

l Adding business components to business process tests and flows.

Low-level
implementation

Includes the low-level implementation of business component content by:

l Creating component steps (the content of the business component),
including automated steps when necessary

l Grouping components

l Setting up iterations (for business process tests, flows, groups, and
components)

l Parameterizing

Agile Methodology
This approach is based on using BPT to provide testing in sprints, as developers code features for
the application under test. Components and tests are created and updated in parallel with
development.

Example

If the application under test is implemented in Java, components might be grouped by the
classes that represent certain groups of UI elements, such as toolbar buttons. Each time a
button is added to the toolbar, the component representing that class is updated.

This approach encourages:

l Automation. Because sprints are short, it is important to automate as much as possible.

l Component reuse. Component reuse can be designed in the sameway that the developers
implement modularly for reuse.

The following presents the Agile Development-centric approach.
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Tasks

How to Create, Maintain, and Run Business Process
Testing Tests and Flows in UFT

Relevant for: business process tests and flows

This task describes how to create, maintain, and run business process tests and flows in UFT.

This task includes the following steps:

l "Create a new business process test or flow or open an existing one" below

l "View and update test or flow properties" on the next page

l "Add content to business process tests and flows" on the next page

l "Use parameters in your test" on the next page

l "Iterate components and flows" on the next page

l "Group components and flows" on the next page

l "Debug and run your test" on page 2073

Create a new business process test or flow or open an existing one
"How to Create andManage Documents" on page 136 describes how to create andmanage
business process tests and flows, as well as other UFT documents.

Note: Make sure when opening UFT to edit a business process test that you select the same
add-ins in the "Add-in Manager Dialog Box" (described on page 118)as the test objects
contained in your component object repositories.

Additionally, youmust save business process tests and flows on an ALM server, in a pre-defined
test subject. For details about test subjects, see theHP Business Process Testing User Guide.

Note:When you open a test or flow in UFT, it is automatically locked, and other users cannot
modify it in UFT or ALM. When you close the test, it is automatically unlocked.

If you open a test that is already locked by another user, the test opens as read-only. You can
also open a test as read-only by selecting theOpen in read-only mode option in theOpen
test dialog box. If changes aremade to the test or flow by another user while you have it open

(as read-only), click Refresh in the BPT toolbar to update your test or flow with the latest
data.
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View and update test or flow properties

1. In the Solution Explorer, make sure that a test or flow is selected, andmake sure that the
Properties pane (described on page 438) is displayed.

Note: If you have a component or flow selected in the document pane, the Properties pane
displays details about the selected component or flow instead of the test or flow selected
in the Solution Explorer.

2. In the Properties paneGeneral Properties tab (described on page 439), view basic information
about the selected test or flow.

Add content to business process tests and flows

1. Open the Toolbox pane and navigate to the component or flow you want to add and double-
click it or and drag and drop to add the component or flow to your flow or test.

2. In the document pane:

n Order the items in your test or flow as needed by dragging and dropping the individual

components or using the arrow buttons in the BPT toolbar.

n To edit a specific component or flow, right-click the component name and select Go to

Component/Flow . The component or flow opens as a new tab in the document pane,
and the component or flow is added to the solution.

n To remove a component or flow from your test or flow, select it and click Delete from Test

.

For more details about the BPT toolbar, see "Toolbar Controls" on page 2075.

Use parameters in your test
For details, see "How to Use Data in a Business Process Test" on page 2124

Default values for component or flow parameters are used during the run session, if no other value
is supplied.

Iterate components and flows
By default, each component or flow you add to your test has a single iteration. For details on
defining iterations and parameter values for the iterations, see "Add iterations for a component or
flow" on page 2126 and "Set data values for each iteration" on page 2126.

Group components and flows
In some cases, it may be helpful to manage several business components or flows together as a
group.
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In the document pane, select the components or flows you want to group, and click Group . To

ungroup, select the group and click Ungroup .

Note:When iterating groups, all items to be included in the groupmust have the same number
of iterations, or an error message is displayed when you group the items.

Debug and run your test

l To debug a test or component, insert breakpoints in specific components or flows in your
test, and then run your test. The run session stops at each breakpoint. For details, see "How to
Use Breakpoints " on page 687.

Note: If you run a BPT test from the ALM Test Planmodule or from UFT, UFT stops the
test at all breakpoints in bothDebug andNormalmodes. However, before running the BPT
test, youmust open the business components with the breakpoints and add them to the
solution in UFT.

l To run your test, do one of the following:

n Click theRun button or select Run > Run to select the test or flow to run from any of the
open documents in Run dialog box.

n Select Run > Run Now to run the test or flow in focus in the document pane.

Note:

n Before running a test, youmust enable theAllow other HP products to run tests and
components option in the Test Runs pane (Tools > Options > GUI Testing tab > Test
Runs node)

n For improved performance when running business process tests or flows, UFT creates
and runs a hosting test, named Test Runtime. The Test Runtime test is recreated each
time the test or flow runs, and is not saved with the run.

During the test run, click Pause orStop in the toolbar to pause or stop the run session.

By default, when the run session ends, the Run Results Viewer opens and the test results are
displayed. For details about analyzing the run results, see theHP RunResults Viewer User Guide.

User Guide
Chapter 64: Business Process Testing in UFT

HP Unified Functional Testing (12.00) Page 2073 of 2274



Reference

Business Process Testing in UFT User Interface
Relevant for: business process tests and flows

Business process tests and flows are displayed in the document pane in a grid. Selecting a specific
component, flow, or group in the document pane causes information to change in the Properties and
Data panes. For general information about the document pane, see "Document PaneOverview" on
page 303.

To access "Create a new business process test or flow or open an existing one"
on page 2071.

The business process test or flow opens as a tab in the document
pane.

Important
information

l "Business Process Testing Overview" on page 2064

l "Business Process Test and Flow Overview" on page 2064

l "Business Process Testing in UFT - Overview" on page 2065

Relevant tasks "How to Create, Maintain, and Run Business Process Testing Tests
and Flows in UFT" on page 2071
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User interface elements are described below:

l "User Interface Elements (Grid Columns)" below

l "Toolbar Controls" below

l "Context menu items" on the next page

User Interface Elements (Grid Columns)

UI Element Description

Name The name of the component or flow.

Snapshot. Indicates whether a snapshot exists for this component.

Status The ALM workflow status for the components and flows in the test.

I/O
Parameters

The number of parameters defined for the selected component or flow, as defined
in the "Parameters Tab (Properties Pane - BPT)" on page 444.

Iterations The number of iterations defined in the pane for the selected component or flow.

Run
Conditions

The attributes that must match for the component to run, as defined in the
"Properties Tab (Properties Pane - BPT)" on page 447.

Note: You canmodify these attributes only when editing a flow. This value is
blank for components contained in a test.

On Failure The action for UFT to take if a specific business component in the flow fails, as
defined in the "Properties Tab (Properties Pane - BPT)" on page 447.

Valid values include:

l Exit. The business process test run ends if the selected business component
fails.

l Continue. (Default) The business process test will run the next business
component or flow if the selected component fails.

Toolbar Controls
The following toolbar buttons are included in the BPT toolbar above the document pane.

Button Description

Move up/down. Enables you to change the order of entities in the business process
test or flow by moving a selected component, group, or flow up or down.
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Button Description

Delete from Test. Removes the selected business component, group, or flow from the
business process test or flow.

Caution: If you are deleting the last component in a group, the entire group is
deleted.

Go to Component/Flow. Opens the selected component or flow in the document
pane.

The component or flow is also added to the solution and listed in the Solution Explorer.

Group. Creates a group that includes the selected business components and/or flows.

The components and flows must be contiguous. A component or flow can belong to one
group only.

A group node is created above the grouped items and is identified by the group icon. By
default, the group is namedGroup, followed by a unique number.

Tip:

l You can add other business components or flows to an existing group by
dragging and dropping a component or flow from the Toolbox pane to the
relevant position in the group.

l You can change the order of themembers of the group by dragging and
dropping.

Ungroup. Ungroups components and/or flows.

To completely remove a group, including its members, select the group and click

Delete from Test .

To remove a business component or flow from a group, select the component or flow,
drag it up or down out of the group, and drop it at the required location.

Refresh. Refreshes a currently open read-only test with any updated information.

Context menu items
The following table describes the context menu items available from the document pane, when
editing a business process test or flow.
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Button Description

Move up/down. Enables you to change the order of entities in the business process
test or flow by moving a selected component, group, or flow up or down.

Delete from Test. Removes the selected business component, group, or flow from the
business process test or flow.

Go to Component/Flow. Opens the selected component or flow in the document
pane.

The component or flow is also added to the solution and listed in the Solution Explorer.

Group. Creates a group that includes the selected business components and/or flows.

Ungroup. Ungroups components and/or flows.

Comparing BPT in UFT to BPT in ALM
Relevant for: business process tests and flows

Business process tests and flows are displayed in the UFT document pane, in a display similar to
the ALM Test Script tab. The following table describes where to find the BPT functionality you are
familiar with from working in ALM, when you are working in UFT.

For details about using BPT in ALM, see theHP Business Process Testing User Guide.

Function ALM UFT

Create or open test or flow Test Plan > New or Details
button

"Open/New
<Document>/<Resource>
Dialog Box" on page 156

Check in and check out tests
and flows

Version Control user interface "VersionManagement
Commands" on page 802

View test properties Test Plan > Test Details
dialog box > Details tab

"General Properties Tab
(Properties Pane - BPT)" on
page 439

View, add, or modify test
parameters

Test Plan > Parameters tab "Test Parameters Tab
(Properties Pane - BPT)" on
page 440

Add component or flow to test
or flow

Test Plan > Test Script tab >
Select Components and
Flows pane

"Toolbox Pane User Interface
(BPT in UFT)" on page 518
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Function ALM UFT

Reorder, group, or open
components or flows in tests

View run conditions or failure
settings for components or
flows

Test Plan > Test Script tab "Business Process Testing in
UFT User Interface" on page
2074

Edit run conditions for
components in flows

Test Plan > Test Script tab >
Run Conditions button

"Properties Tab (Properties
Pane - BPT)" on page 447

Edit failure settings for
components in flows

Test Plan > Test Script tab >
On Failure link in grid

"Properties Tab (Properties
Pane - BPT)" on page 447

Add or modify component
parameters

Business Components >
Parameters tab

"Parameters Tab (Properties
Pane - BPT)" on page 444

Link parameters Test Plan > I/O Parameters
link in grid > Link I/O column >
Select Output Parameter
dialog box

"Select Link Source Dialog
Box (BPT)" on page 2128

Promote parameters Test Plan > Test Script tab >
Select Components and
Flows pane > QuickAdd
button > AddWhile Setting
Promote Options

"Parameters Tab (Properties
Pane - BPT)" on page 444

"Data Pane User Interface
(BPT in UFT)" on page 265

"BPT Testing Tab (Options
Dialog Box)" on page 570

View andmodify BPT
comments for a specific
component instance

Test Plan > Test Script tab >
Comments tab

"Component Details Tab
(Properties Pane - BPT)" on
page 451

Add andmodify iterations and
iteration data for components,
flows, and groups

Test Plan > Test Script tab >
Iterations link in grid

"Data Pane User Interface
(BPT in UFT)" on page 265

Run or debug test Test Plan > Test Script tab >
Run or Debug Test button

"Run Dialog Box" on page 651
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Troubleshooting and Limitations - Business Process
Testing in UFT

Relevant for: business process tests and flows

This section includes:

l "General functionality" below

l "Working with API components" below

General functionality
To create BPT tests and flows in UFT, youmust work with ALM 11.52 or later.

Working with API components
You can create andmanage API components in much the sameway as you would API tests, as
described in "API Testing Design" on page 1588. The following exceptions apply when working with
API components:

l You cannot use Load Test activities in a component. If you save a load-enabled test as a
business component, it will no longer be load-enabled.

l You cannot use Automated Testing Tool activities in a component.

l Encoded password type properties are not supported. If the component has a property of type
password (or encrypted in ALM 11.00 and later), the value will be treated as an ordinary string,
without encoding or decoding.

l Multiple User Variable profiles are not supported. Remove all but one of the profiles.

Note: Other general differences between test and components also apply to API components,
such as "Troubleshooting - Naming Conventions" on page 2269
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Chapter 65: Business Components
Relevant for: GUI components only

Note: Unless otherwise specified, references toApplication Lifecycle Management orALM
in this guide apply to all currently supported versions of ALM andQuality Center. Note that
some features and options may not be supported in the specific edition of ALM or Quality
Center that you are using.

For a list of the supported versions of ALM or Quality Center, see theHP Unified Functional
Testing Product Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD. Themost up-to-date product availability matrix is available from the
HP Software Product Manuals site, at http://h20230.www2.hp.com/selfsolve/manuals
(requires an HP Passport).

For details on ALM or Quality Center editions, see theHP Application Lifecycle Management
User Guide or theHP Quality Center User Guide.

This chapter includes:

Concepts 2081

Business Components - Overview 2081

Keyword GUI Components Overview 2084

Scripted GUI Components Overview 2085

Tasks 2088

How to Create andManageGUI Business Components 2088

How to Convert a Keyword GUI Component to a Scripted GUI Component 2090

Reference 2092

Change Application Area Dialog Box 2092

Troubleshooting and Limitations - Business Components 2094
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Concepts

Business Components - Overview
Relevant for: business process tests and flows

You can create, define, modify, andmanage business components in UFT or ALM. Business
components provide the basis for BPT and are incorporated into business process tests and flows.

A business component is a reusable unit that:

l Performs a specific task in a business process

l Describes the condition or state of the application before and after that task

You can use a component in multiple business process tests and flows. When youmodify a
component or its content, all business process tests or flows containing that component reflect that
modification. You can also use run conditions to enable components to run selectively, based on
earlier stages within the test or flow.

Business Component Examples

Business
Component
Name Task

Application State
Before Application State After

Login Banker logs
into banking
application

<none> The application is launched and the
main home page is displayed.

SearchLoan Banker
searches for
an existing
loan

The banker is logged
in and themain home
page is displayed.

The application displays themain
loan details page, or a page
indicating that the loan was not
found.

Business components are comprised of: 

l A Shell (general information such as component name, status).

l Content (steps or scripts). Low-level, detailed information, such as the component's manual
steps and/or automation. The contents provide detailed instructions for performing business
process tasks in the application. Component content can bemanual, automated, or both—
depending on whether you create amanual implementation and/or automation for the
component.

n For details on automated components, see "Keyword GUI Components Overview" on page
2084 and "Scripted GUI Components Overview" on page 2085.

HP Unified Functional Testing (12.00) Page 2081 of 2274



Example of Content

Step Description Expected Result

1 Open the application. The application is launched and the login page is
displayed.

2 Enter a user name. The cursor advances to the password field.

3 Enter a password. The password is displayed as asterisks.

4 Click Submit on theWeb
page.

The application's main page is displayed.

API components aremuch like API tests, described in "API Testing Design" on page 1588.
Some exceptions and limitations for working with API components are described in "Working
with API components" on page 2079.

n For details about manual testing in BPT, see theHP Business Process Testing User Guide in
the ALM documentation set.

This section also includes:

Business Component Categories 2082

Business Component Categories

Relevant for: business process tests and flows

Because BPT is a component-based testing framework, components are largely responsible for
driving the actual application testing. This component framework encourages component design
and reuse, so themethod you use to categorize your components has a large impact on the ability
of your framework tomanage your testing abilities successfully.

You can use one or more of the followingmethods to categorize components .

l "Logical Components" on the next page

l "Application Object Components" on the next page

l "Generic Components" on the next page
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Logical Components
A logical component represents the use of a part of the screen with one or more controls, or a set of
API calls which combine to perform some application logic. This category is based on a specific
context in the application under text.

Examples

l A Login component represents the login process, based on a login window that allows you
to enter a user name and password, and then click a Login button.

l A Search component represents search for an entity in the application under test. You can
enter a string for which to search, indicate capitalization and/or whole word options, and
click aSearch button.

Application Object Components
An application object component might represent an object on the screen or a call to a single API.

This category is usually independent of the context within the application under test, and can be
used inmany situations. You decide the level of granularity that most encourages reuse.

Examples

l A Button component represents the button object.

l A Grid component represents a grid object in a pane or window.

l A Pane component represents a pane in a window or screen.

l An Interrogate component represents the interrogation of the application under test's
backend database.

Generic Components
A generic component performs actions outside of the context of the application under test. It can be
reused in tests of different applications.

Example

l A Launch component represents the launching of a browser.
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Flows can be thought of as complex components or small business component tests. Flows
comprise a set of components in a fixed sequence to perform a specific task. A flow can be part of a
test just like any other component, but when the flow runs, BPT executes the components that the
flow contains.

Keyword GUI Components Overview
Relevant for: Keyword GUI components only

You can use the Keyword View to create, view, andmodify a keyword component in UFT.

In the Keyword View, keyword components are divided into steps in amodular, keyword-driven,
table format. Each step is a row that comprises individual parts that you can easily modify. You
create andmodify steps selecting items and operations and entering additional information, as
required.

Each step in a keyword component is automatically documented as you complete it. This enables
you to view a description of the step in understandable sentences. In addition, if you added a
function library to the application area associated with the keyword component, when you define a
step by selecting a user-defined operation (function), the documentation that you added in the
function library is displayed for the step. For details, see "How to Create andWork with a User-
Defined Function" on page 1048.

Note: ALM users can access components from the ALM Business Components module. For
details, see theHP Business Process Testing User Guide.

Keyword GUI Component Resources

l Each keyword component is based on a specific application area, which is stored in the ALM
project in which you intend to save the component.

l Each application area specifies the settings and resources for the keyword component,
including the location of shared object repositories, function libraries, recovery scenarios, and
other information.

l Theremay be one or more application areas from which to choose. You select the application
area that is best suited for your keyword component. For details, see "Application Areas" on
page 2095.

This section also includes:

l "Tips andGuidelines for Selecting Application Areas for Your Component" on the next page
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Tips and Guidelines for Selecting Application Areas for Your
Component

Relevant for: Keyword GUI components only

l When you create a GUI component in UFT, youmust select the application area to which you
want to associate the component. Theremay be one or more application areas available from
which to choose. You should select the one that is best suited for the component.

l If changes aremade to your application or to the resource files and settings associated with the
application area, the application areamay become unsuitable, and youmay need to associate a
different application area with a specific component. For example, the object repository could
have beenmodified or removed from the application area.

l As your application develops, it may include additional or different objects that are not contained
in the currently associated object repository. This could cause the component or business
process test to run incorrectly or to fail.

l If another application area contains the required resource files and settings, you should
associate that application area with the component.

l Each time you open a component, UFT verifies that the resources specified for the component
are available. If a component or application area has resources that cannot be found, such as a
missing shared object repository, UFT indicates this in the Errors pane. For details, see "Errors
Pane" on page 364.

Scripted GUI Components Overview
Relevant for: Scripted GUI components only

Scripted components aremaintainable, reusable scripts that perform a specific task.

Using scripted components enables you to utilize the full power of both the Keyword View and the
Editor, as well as other UFT tools and options to create, view, modify, and debug scripted
components. For example, you can:

l Use the StepGenerator to guide you through the process of addingmethods and functions to
your scripted component.

l Use the Editor to enhance the scripted component flow by manually entering standard VBScript
statements and other programming statements using test objects andmethods.

l Incorporate user-defined functions in your scripted component steps, parameterize selected
items, and add checkpoints and output values.
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This section also includes:

l "Use Scripted GUI Components for Complex Functionality" below

l "Similarities Between Scripted GUI Components and Tests" below

l "Similarities Between Scripted and Keyword GUI Components" on the next page

l "Differences Between Scripted and Keyword GUI Components" on the next page

l "Converting Keyword GUI Components to Scripted GUI Components" on the next page

Use Scripted GUI Components for Complex Functionality
You can create scripted components that contain more complex functionality, such as loops or
conditional statements. You can then include these scripted components in business process tests
to check that the application behaves as expected.

Note: For details about viewing components in tests and flows in UFT, see "Business Process
Testing in UFT User Interface" on page 2074.

In the Component Steps tab of the ALM Business Components module, ALM users can view
and work only with themanual steps defined for a scripted component (if any). They cannot
view ormodify the automated steps unless they open the scripted component in UFT by
clicking the Launch button in the Automation tab (provided that UFT is installed on the ALM
client). For more details, see theHP Business Process Testing User Guide.

Similarities Between Scripted GUI Components and Tests
Scripted components containedmuch of the same functionality as actions and tests. For example,
you can:

l Work with programmatic statements in the Editor (see "Programming in GUI Testing
Documents in the Editor" on page 994).

l Use standard and bitmap checkpoints and standard output values.

l View the hierarchical Keyword View display.

l Create and work with virtual objects.

l Use the Active Screen to view a snapshot of your application as it appeared when you
performed a certain step during a recording session, and to parameterize object values and
insert checkpoints, methods, and output values for any object in the page, even if your
application is not available or you do not have a step in your test corresponding to the selected
object.

l Use random and environment parameters.

l Set applications to open at the start of a record or run session.

l Use the analog and low-level recordingmodes.
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Similarities Between Scripted and Keyword GUI Components
Both scripted and keyword components are:

l Associated with a specific application area. Therefore, all of the resources must be stored in the
ALM project and not in the file system.

l Standalonemodular units that can be incorporated into a business process test.

l Linear within a business process test (not hierarchical).

l Not nested, meaning they cannot call another component.

Differences Between Scripted and Keyword GUI Components
Scripted components cannot bemodified in ALM.

Converting Keyword GUI Components to Scripted GUI Components
You can convert keyword components to scripted components, when required. However, because
scripted components can bemodified only in UFT (and not in ALM), the automated steps cannot be
viewed in ALM.

The conversion process is not reversible, meaning you cannot convert the scripted component
back to a keyword component.
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Tasks

How to Create and Manage GUI Business Components
Relevant for: GUI components only

This task describes the different operations you can perform tomanage business components, and
contains general considerations and guidelines.

This task includes:

l "Prerequisites" below

l "Guidelines for users of earlier QuickTest versions" below

l "Create a new business component" on the next page

l "Open a business component" on the next page

l "Save a business component" on page 2090

l "Associate a different application area with your component" on page 2090

l "Delete a component" on page 2090

Prerequisites

l Youmust connect UFT to an ALM project, which is where components and application area
resources and settings are stored. Connecting your ALM project enables UFT to create or open
the component. This also enables the component to access all of the resources defined in the
application area on which the component is based. For details, see "ALM Connection Dialog
Box" on page 737.

l Make sure you have the required ALM permissions before working with components and
application areas. For details on setting user group permissions in the Business Components
module, see theHP Business Process Testing User Guide and theHP Application Lifecycle
Management Administrator Guide.

l Components that are currently open in ALM or another UFT session are locked and can be
opened only in read-only format. To work with these components, they must be closed
everywhere else. Additionally, if the resources used by a component are locked, these resource
files open in read-only mode. For details on working with locked resources , see "Opening and
Saving Tests with Locked Resources" on page 134.

Guidelines for users of earlier QuickTest versions

l Tomodify a component last modified using a version of QuickTest earlier than 9.5, youmust
upgrade the component to the QuickTest 11.00 format using the QuickTest Asset Upgrade Tool
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for ALM (found on your QuickTest 11.00 installation DVD).

After upgrading the version of the component, open the upgraded component in UFT. Before it is
upgraded, though, you can view it in read-only format, and you can run it. (To work with a
component last modified using QuickTest version 8.x, it must first be upgraded to QuickTest
version 9.x.) All components last modified in versions of QuickTest later than 9.5 can be opened
in UFT without conversion.

l After you save a converted component, it cannot be used with earlier versions of QuickTest.

Create a new business component

1. Select File > New > Business Component.

In the "New <Document> Dialog Box" (described on page 152), select a folder in the Business
Components module in ALM in which to store your component and give your component a
name.

2. In theApplication Area field of the "New <Document> Dialog Box", click theBrowse button
to select a suitable application area from within theALM Test Resourcesmodule. After
choosing your application area, click OK.

3. A new business components opens in the Keyword View (for keyword components) or in the
Editor (for scripted components).

Although the component does not yet contain content, it does contain all of the required
settings and resources that were defined in the application area on which it is based. You can
view these settings in read-only format by choosing File > Settings. If you later need to
change these settings, you can do so in the associated application area.

4. Optional - You can now add steps and comments to your business components.

For details relevant for keyword components, see "How to Add a Standard Step to Your Test
or Component" on page 925 and "Comments in the Keyword View" on page 922.

For details, relevant for scripted components, see "How to Enhance Your Actions, Scripted
Components, and Function Libraries Using theWindows API" on page 1011 and
"Programming in GUI Testing Documents in the Editor - Overview " on page 995.

Open a business component
Do one of the following:

l Select the component in the Open Business Component dialog box, which you open by
selecting File > Open > Business Component. For details, see "Open/New
<Document>/<Resource> Dialog Box" on page 156.

l Select the component from the list of Recent files in the Filemenu.
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Save a business component

l To save amodified component, select File > Save. The component is saved with the changes.

l To save a new component or to save an existing component with a new name, select File >
Save As.

The business component is saved to the component tree in the ALM project (Business
Components module).

Note: (for scripted GUI components: When working with scripted components, the data
sheet name in the Data pane is identical to the scripted component name. Therefore, if you
save a scripted component with a new name using File > Save As, the data sheet is
automatically renamed. If you have a step that references the data sheet by name, the step
will fail during the run session because it references the former data sheet name. If you
save a scripted component with a new name, youmust find any references to the former
data sheet name in the Editor and replace them with the new data sheet name.

Associate a different application area with your component
Do one of the following:

l Select File > Change Application Area.

l Right-click on a component node and select Change Application Area.

In the "Change Application Area Dialog Box" (described on page 2092), you select a different
application area and click OK to change the application area associated with a component.

Delete a component
You delete a component in ALM, regardless of whether it was created in UFT or in ALM. For details,
see theHP Business Process Testing User Guide.

How to Convert a Keyword GUI Component to a Scripted
GUI Component

Relevant for: GUI components only

This task describes how to convert a single keyword component to a scripted component.

Caution: This replaces the existing keyword component with a scripted component, and
cannot be undone.
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This task includes the following steps:

l "Prerequisites" below

l "Convert the keyword GUI component to a scripted GUI component" below

l "Results" below

1. Prerequisites
n Youmust connect UFT to an ALM project. For details, see "ALM Connection Dialog Box" on

page 737.

n The keyword component must be editable (meaning it must not read-only mode or locked by
another user). For example, if your are working with version control, youmust check out the
component.

2. Convert the keyword GUI component to a scripted GUI component
a. Open the keyword component you want to convert.

b. Select File > Convert to Scripted Component. When prompted, click OK to proceed
with the conversion.

3. Results
After the conversion is complete, the scripted component opens automatically.

User Guide
Chapter 65: Business Components

HP Unified Functional Testing (12.00) Page 2091 of 2274



Reference

Change Application Area Dialog Box
Relevant for: Keyword GUI components only

This dialog box enables you to associate an existing component with another application area.

To access 1. Open a business component or select the component node in the Solution
Explorer.

2. Do one of the following:

n Select File > Change Application Area.

n Right-click the node of a component and select Change Application
Area.

Important
information

This dialog opens to the ALM Resources module in your ALM project. All
available application areas contained in this module are displayed.

Relevant
tasks

"How to Create andManageGUI Business Components" on page 2088

See also "Keyword GUI Components Overview" on page 2084
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User interface elements are described in the "Open/New <Document>/<Resource> Dialog Box" on
page 156.
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Troubleshooting and Limitations - Business
Components

Relevant for: GUI components only

This section describes troubleshooting and limitations for business components.

l For troubleshooting and limitations for learning objects, and recording and running steps, see
"Learning objects, running steps, and recording steps (GUI testing only)" on page 661.

l Start Menu / Quick Launch Panel. OnWindows Vista, Windows 7, Windows Server 2008,
Windows Server 2008 R2, Window 8 ,orWindows Server 2012, if you begin a recording session
after installing UFT (or upgrading from QuickTest) without restarting your computer, UFT cannot
record operations on theWindows Startmenu orQuick Launch Panel.

Workaround:Restart your computer and start a new recording session.

l Start menu. UFT does not record launchingWindows Help from theStart Menu.

l Start Menu. UFT does not record the selection of Startmenu items that are customized as
menus, such as My Computer, Control Panel, orRecent Documents.

Workaround:Customize theStartmenu items as links so that UFT can record operations on
them or record the activation of these items another way (and not through theStart menu).

l Renaming a UFT component from ALMmay cause the test or component to behave
unexpectedly.

Workaround: To rename a test or component, open it in UFT and rename it using theSave As
option. If the test or component has already been renamed from ALM, use the rename option
again to restore the old name, and then use theSave As option in UFT. Renaming a UFT test
parameter from UFT will cause any run-time parameter values already set for this parameter in
ALM to be lost.

l Multilingual Support. Names and paths of components, application areas, and resources (for
example, function libraries, object repositories, and recovery scenarios) are not Unicode
compliant and therefore should be specified either in English or in the language of the operating
system.

l Business component scripts that were created in QTP 11.00, and contain theActionName
environment variable, return different values for theActionName variable value when run in
UFT.

For example, anActionName variable that returned theBC1 value as the component name in
QTP 11 returns theBC1[BC1] value in UFT.

Workaround:Update your scripts as needed to use the new environment variable value.
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Chapter 66: Application Areas
Relevant for: GUI components only

Note: Unless otherwise specified, references toApplication Lifecycle Management orALM
in this guide apply to all currently supported versions of ALM andQuality Center. Note that
some features and options may not be supported in the specific edition of ALM or Quality
Center that you are using.

For a list of the supported versions of ALM or Quality Center, see theHP Unified Functional
Testing Product Availability Matrix, available from the UFT Help or the root folder of the Unified
Functional Testing DVD. Themost up-to-date product availability matrix is available from the
HP Software Product Manuals site, at http://h20230.www2.hp.com/selfsolve/manuals
(requires an HP Passport).

For details on ALM or Quality Center editions, see theHP Application Lifecycle Management
User Guide or theHP Quality Center User Guide.

This chapter includes:

Concepts 2096

Application Areas - Overview 2096

Tasks 2097

How to Create andManage Application Areas 2097

Reference 2101

Application Area User Interface 2101

Function Libraries Pane (Application Area) 2102

Object Repositories Pane (Application Area) 2105

Keywords Pane (Application Area) 2107

Additional Settings Pane (Application Area) 2109

Troubleshooting and Limitations - Application Areas 2112
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Concepts

Application Areas - Overview
Relevant for: GUI components only

When you create a set of components to test a particular area of your application, you generally
need to work with many of the same test objects, keywords, testing preferences, and other testing
resources, such as function libraries and recovery scenarios. You define these files and settings in
an application area, which provides a single point of maintenance for all elements associated with
the testing of a specific part of your application.

An application area is a collection of settings and resources that are required to create the content
of a business component. Resources may include shared object repositories containing the test
objects in the application being tested, function libraries containing user-defined operations that can
be performed on that application, and so forth. Components are automatically linked to all of the
resources and settings defined in the associated application area.

For example, to be able to select test objects when implementing steps for a component, the test
objects must be stored in a shared object repository associated with the component's application
area. Associating function libraries with your application area enables you to access the functions
defined in these function libraries as keywords.

You can create as many application areas as needed. For example, youmay decide to create an
application area for eachWeb page, module, window, or dialog box in your application.
Alternatively, for a small application, one application areamay be all that is needed.

Each component can have only one associated application area.

Application Area Settings and Associated Resources
Application area settings and any changes youmake to these settings are automatically applied to
any business component with which the application area is associated.

The resources associated with your application areas are the resources that are available to the
components associated with your application area.

If resources are referenced in component steps, and you later modify the resources associated with
its application area, your component may not run correctly. For example, if a component uses test
objects from theMyRepository.tsr shared object repository, and you remove this object repository
from the application area, the component will not be able to access the required test objects
because the object repository is no longer included in the application area.
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Tasks

How to Create and Manage Application Areas
Relevant for: GUI components only

This task includes the following steps:

l "Prerequisites " below

l "Make sure all required resources are stored in ALM" below

l "Create the application area" on the next page

l "Configure application area settings" on the next page

l "Maintain the application area" on page 2099

1. Prerequisites
a. Make sure you have permissions in ALM for modifying components, adding steps,

modifying steps, and deleting steps. (If you do not have all of these permissions, you can
open application areas only in read-only format.) For details on setting permissions for the
Business Components module, see theHP Business Process Testing User Guide.

b. Evaluate the purpose of your application area and determine the resources required for the
business components that will use it. For example:

o What test objects will they need?

o What user-defined functions can you add to ensure that all required operations are
available?

o Which keyword operations do you want to make available for each test object type?

2. Make sure all required resources are stored in ALM
To create an application area, youmust associate the required function library, shared object
repository, and recovery scenario resources with it.

Some of the required resources may already exist.

If necessary, create new resources and store them in the Test Resourcesmodule in ALM.

a. Verify the existence of or create required function library resources. For details, see "How
to Create andManage Function Libraries" on page 1041.

Note: BPT provides a set of predefined function libraries that you can use. Some of
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these are associated with all new application areas by default. These files are located
in the Test Resourcesmodule of your ALM project underResources/BPT
Resources.

b. Verify the existence of or create required shared object repository resources. For details,
see "How to Create andManage SharedObject Repositories" on page 1291 and "How to
ManageObjects in SharedObject Repositories" on page 1294.

c. Verify the existence of or create required recovery scenario resources. For details, see
"How to Create andManage Recovery Scenarios" on page 1115.

3. Create the application area
a. Connect to the ALM project in which you want to save the application area. For details, see

"ALM Connection Dialog Box" on page 737.

b. Select File > Add > New Application Area. The New Application Area dialog box opens,
enabling you to specify the location for the new application area within the ALM Test
Resourcesmodule. (In Quality Center 10.00, application areas are always stored in the
BPT Resources\Application Areas folder.)

Specify a unique and descriptive name.

After you click Save, the new application area is added to the open solution and then
opened in the document pane. The application area displays several panes in which you
specify the settings and resource files that you want business components associated
with the application area to use.

Note: If you do not want to add the application area to the open solution, select File >
New > Application Area. If you do this, the open solution is closed, any open
documents included in the solution are closed as well, and the new application area is
opened in a new untitled solution.

4. Configure application area settings
a. In the Properties pane, provide a full description of the application area, as described in

"General Properties Tab (Properties Pane for Application Areas)" on page 391.

b. Specify associations to the required UFT add-ins, as described in "General Properties Tab
(Properties Pane for Application Areas)" on page 391.

When a business process test runs, the add-ins associated with the application area for the
first component in the test are loaded in UFT. Therefore, if this application area is likely to
be associated with components that may be first in a business process test, ensure that
you include all add-ins that any of the components in the test may need. However, to
ensure expected functionality and optimum performance, do not include add-ins that are
not necessary.
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c. If necessary, associate function libraries or shared object repositories. Click the
<application area name> node in the Solution Explorer and select Associate Function
Library orAssociate Object Repository, as needed. For more details and association
methods, see "Function Libraries Pane (Application Area)" on page 2102

d. If necessary, associate recovery scenarios and define their settings as described in
"Recovery Pane (Test/Business Component Settings Dialog Box / Application Area -
Additional Settings Pane)" on page 613.

Note: In general, you should create all necessary resources for your application area
before you begin creating the application area itself. If you realize the need for another
resource while you are in the process of creating the application area, it is possible to
create new, empty resource files directly from the application area and associate them
with your application area (and then create the content for those files at a later time).

For details, see "Function Libraries Pane (Application Area)" on page 2102, "Object
Repositories Pane (Application Area)" on page 2105, and "Recovery Pane
(Test/Business Component Settings Dialog Box / Application Area - Additional
Settings Pane)" on page 613.

e. Specify which keywords will be available for use when creating component steps, as
described in "Keywords Pane (Application Area)" on page 2107.

f. Specify theWindows-based applications on which components associated with the
application area can record and run, as described in "Applications Pane (Business
Component Settings Dialog Box / Application Area - Additional Settings Pane)" on page
597.

g. If relevant, define additional setting for your application area in the Additional Settings
pane, such as add-in specific settings, log tracking, and local systemmonitors. For details,
see "Application Area User Interface" on page 2101.

h. Save your changes .

5. Maintain the application area
After you create an application area, you can use the options described below tomaintain it:

n Open an existing application area for viewing or modification. For details, see "Application
Area User Interface" on page 2101.

n In ALM, you can view all components that are dependent on a particular application area. To
view this list, display theDependencies tab for your Application Area (located in the Test
Resourcesmodule). For details on ALM dependencies, see theHP Application Lifecycle
Management User Guide.
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n If an application area is no longer needed, you can delete it. Before you delete an application
area, make sure that:

o The application area is not associated with any component.

o The application area is not currently open on any computer.

You delete an application area from the Test Resources module in ALM, regardless of
whether it was created in UFT or in ALM. For details, see theHP Business Process
Testing User Guide.
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Reference

Application Area User Interface
Relevant for: GUI components only

In the application area, you define and view application area settings and associate required
resource files.

Note: Some basic application area settings are defined in the "General Properties Tab
(Properties Pane for Application Areas)".

To
access

In UFT:

1. Connect to your ALM project.

2. Create a new application area or open an existing one (File > New/Open/Add >
Application Area, or double-click the application area in the Solution Explorer).

Note: You can also access this dialog box from ALM.

Relevant
tasks

"How to Create andManage Application Areas" on page 2097
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See also l "Application Areas - Overview" on page 2096

l "General Properties Tab (Properties Pane for Application Areas)" on page 391

User interface elements are described below:

UI
Elements Description

Function Libraries. Displays the Function Libraries pane, which enables you to
associate function libraries with your application area and to prioritize them. It also
enables you to create andmodify associated function libraries. For details, see
"Function Libraries Pane (Application Area)" below.

Object Repositories. Displays the Object Repositories pane, which enables you to
associate shared object repositories with your application area and to prioritize them.
It also enables you to create andmodify associated object repositories. For details,
see "Object Repositories Pane (Application Area)" on page 2105.

Keywords. Displays the Keywords pane, which enables you to determine which
built-in and user-defined keywords (operations) are available when creating
components. For details, see "Keywords Pane (Application Area)" on page 2107.

Additional Settings. Displays the Additional Settings pane, which enables you to
define settings that affect all of the components associated with this application
area.

You can specify theWindows-based applications with which a component can
work, recovery scenarios that a component can use, and different tracking and
monitoring options. For details, see "Additional Settings Pane (Application Area)" on
page 2109.

Note: The Business Components Settings dialog box is very similar to this
pane, but displays most of the settings in read-only mode.

Function Libraries Pane (Application Area)
Relevant for: GUI components only

This pane enables you to associate VBScript function library files (of types .qfl, .vbs, or .txt) with
your application area. You associate function libraries with your application areas to provide
additional functionality in the form of user-defined keywords (functions) that can be used when
creating business components. You can also create new function library files directly from this
pane.
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To access In the application area sidebar, click Function Libraries.

Important
information

l All associated function libraries must be saved in your ALM project.

l To rename a function library, you can click it twice, or select it and press F2.

l UFT provides you with sample function libraries containing predefined
functions. By default, these files are associated with all new application areas.
The default function libraries are located in the Test Resourcesmodule of your
ALM project underResources/BPT Resources. For details on creating user-
defined functions in function libraries, see "User-Defined Functions and
Function Libraries" on page 1029.

Relevant
tasks

"How to Create andManage Function Libraries" on page 1041

See also "Application Area User Interface" on page 2101
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User interface elements are described below:

UI Element Description

Associated
function
libraries

The list of function libraries currently associated with your application area. You
can associate additional function libraries, andmodify, delete, and prioritize these
files. You can add existing function libraries or create new ones, as long as the
function libraries are stored in your ALM project.

Note:

l You can double-click a function library in this list, or right-click it and select
Open to open the function library in a separate document tab.

l You can right-click a function library in this list and select Remove to
remove its association with the application area.

l If an associated function library cannot be found, for example, if it was
removed from the ALM project, UFT indicates this by displaying the
Missing Function Library icon to the left of the function library in the
list. To handle themissing function library, right-click it and select Locate
to browse to the required function library, orRemove to remove the
association to themissing function library.

Enables you to create a new, blank function library, save it to your ALM project,
and add it to the list.

By default, new function libraries are created as .qfl files if no suffix is specified.
You can also specify a .txt or .vbs file extension.

Opens the selected function library for viewing or editing in the document pane.
You can also double-click a file in the list to open it. To save your changes, close
the file and click Yeswhen prompted.

Function libraries that are currently in use by another UFT or ALM user are locked
and can be opened only in read-only mode. For details, see "User-Defined
Functions and Function Libraries" on page 1029.

Enables you to browse to your ALM project and select an existing function library
to associate with the application area. For details, see "How to Create and
Manage Application Areas" on page 2097.

If the function library you select contains syntax errors, a message box informs
you that components using this function library may fail because of these syntax
errors.

Removes the selected function library from the application area.

Moves the selected function library up in the list, giving it a higher priority during
the component run session.
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UI Element Description

Moves the selected function library down in the list, giving it a lower priority during
the component run session.

Object Repositories Pane (Application Area)
Relevant for: GUI components only

This pane displays the list of shared object repositories currently associated with your application
area and enables you to associate additional object repositories, and tomodify, delete, and
prioritize these files. You can also create new shared object repositories directly from this pane.

To access In the application area sidebar, click Object Repositories.

Relevant tasks l "How to Create andManage SharedObject Repositories" on page 1291

l "How toManageObjects in SharedObject Repositories" on page 1294

See also l "Application Area User Interface" on page 2101

l "SharedObject Repositories" on page 1285

l "Renaming Test Objects " on page 1206
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User interface elements are described below:

UI Element Description

Associate
object
repositories

The list of object repositories that are currently associated with your application
area. You can add existing object repositories or create new ones, as long as the
object repositories are stored in your ALM project.

All business components associated with an application area that refers to these
shared object repositories will then access these shared object repository files.

Note:

l You can double-click a shared object repository in this list, or right-click it
and select Open to open it in the Object Repository Manager.

l You can right-click a shared object repository and select Remove to
remove its association with the application area.

l If a shared object repository cannot be found, its name and path are
displayed in the Errors pane when you open the application area. To
handle themissing shared object repository, right-click it in the list of
associated object repositories and select Locate to browse to the required
shared object repository, orRemove to remove the association to the
shared object repository.

Enables you to create a new object repository, save it to ALM, and then add it to
the list. For details, see "How to Create andManage Application Areas" on page
2097.

Opens the selected object repository for viewing or editing in the Object
Repository Manager. You can also double-click an object repository in the list to
open it. Object repositories that are currently locked are opened in read-only
format. For more information on theObject Repository Manager, see "Shared
Object Repositories" on page 1285.

Enables you to browse to the Test Plan tree or Resources module of your ALM
project and select an existing object repository to associate with the application
area. For details, see "How to Create andManage Application Areas" on page
2097.

Removes the selected object repository from the application area.

Moves the selected object repository up in the list, giving it a higher priority during
the component run session.

Moves the selected object repository down in the list, giving it a lower priority
during the component run session.
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Keywords Pane (Application Area)
Relevant for: Keyword GUI components only

This pane enables you tomanage keywords and select which of them should be available to as test
object operations when creating keyword components. Only selected built-in keywords are
available by default. However, all user-defined keywords (functions) are available.

To access In the application area sidebar, click Keywords.

Important
information

l All of the built-in methods and properties, plus all of the functions in user-
defined function libraries, are displayed as keywords in the Keywords pane. In
addition, the Keywords pane displays methods and properties of any test
object classes that you or a third party developed using UFT Add-in
Extensibility.

l The Keywords pane is not relevant for scripted components.

l You can also filter and sort columns. For details, see "Filtering and Sorting
Options" on the next page.

See also "Application Area User Interface" on page 2101
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User interface elements are described below:

Column Description

Environment The name of the add-in for which the keyword is provided, for example,Web or
Visual Basic. The keywords available for all currently loaded add-ins are
displayed in the pane. (Including keywords and add-ins that you or a third party
developed using UFT Add-in Extensibility.)

l Keywords in user-defined functions that are registered to a test object are
displayed under the environment and object class to which they are
registered.

l Keywords in user-defined functions that are not registered to a test object,
plus built-in VBScript functions, are all displayed under theGlobal
environment.

Class The object class, for example, Image orWinbutton.

Keyword The displayed operation name, for example, Click orVerifyProperty.

Type Indicates whether the operation is Built-in (provided by UFT) orUser-Defined
(contained in a function library).

Available Indicates whether the keyword is available for use in business component steps.
You can select or clear each check box as required.

Properties Textual description of what the keyword does, and the name and path of its
function library (for user-defined keywords). The location of a built-in keyword is
defined as Internal.

Filter. Displays a list of the unique items contained in the selected column. You
can filter the data in the column to display only those keywords with which you
want to work. You can filter the data in a single column only, or filter additional
columns to further reduce the number of displayed items.

For example, youmay want to view only Web Add-in keywords that are currently
not available. You would filter theEnvironment column to display only
keywords from theWeb Add-in, and then filter theAvailable column to display
only keywords whose check box is cleared (select Unchecked from the
Available column filter list).

For details, see "Filtering and Sorting Options" below.

Filtering and Sorting Options

l Click an item in the list. You can use theCTRL key to select multiple items from a filter list. The
Keywords pane refreshes to show the data for keywords with that item name only.

You can then click the arrow in another column header and select an item in that list. The filtered
data is filtered again to show only the keywords that match all selected filter criteria.
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l In the Filter For box at the bottom of the filter list, you can enter a filter pattern that includes
wildcards such as ?, *, and #. Press ENTER to filter the data according to the pattern. You can
use ? to represent any single character, * to represent zero or more occurrences of any
character, and # to represent any digit. You can also use | to specify items that match only one
of the options in the pattern. For example, Verify*|Check* shows all keywords that start with
Verify orCheck.

l You can apply multiple filters simultaneously. For example, if you want to view keywords for
only the StandardWindows and ActiveX environments, and you want to display only built-in
keywords (as opposed to user-defined keywords), you can apply three filters: one filter for
StandardWindows; another filter forActiveX; and a third filter for the type, Built-in.

l Click the to the left of the filter criteria to clear the filter and show all keywords.

l You can rearrange the order that columns are displayed in the Keywords pane by dragging a
column header to a new location. Red arrows are displayed when the column is dragged to an
available location.

l If the data in a column is partially hidden because the column is too narrow, you can resize the
column using themouse. Drag a column header divider to adjust the width.

l You can arrange the data in a column into ascending or descending alphabetical order by clicking
the column header. TheAvailable column is sorted according to selected and cleared check
boxes.

l The sort direction is indicated by an arrow in the column header. Click the column header again
to sort the data in the other direction.

Additional Settings Pane (Application Area)
Relevant for: GUI components only

This pane enables you to define settings that affect all of the components associated with this
application area.

Note: The Business Components Settings dialog box is very similar to this pane, but displays
most of the settings in read-only mode.
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To access In the application area sidebar, click Additional Settings.

Important
information

This panemay also contain additional panes corresponding to any UFT add-ins
that are loaded, for example, Web, or Java. For details on nodes related to add-
ins, see theHP Unified Functional Testing Add-ins Guide.

See also l "Application Area User Interface" on page 2101

l "Applications Pane (Business Component Settings Dialog Box / Application
Area - Additional Settings Pane)" on page 597

l "Recovery Pane (Test/Business Component Settings Dialog Box / Application
Area - Additional Settings Pane)" on page 613

l "Log Tracking" on page 586

l "Local SystemMonitor Pane (Test/Business Component Settings Dialog Box /
Application Area - Additional Settings Pane)" on page 623

The Additional Settings pane contains a number of sub-panes that enable you to define the
following settings:

Pane Enables you to define:

Applications TheWindows-based applications with which a component associated with your
application area can work.
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Pane Enables you to define:

Recovery Recovery scenarios that specify how a component associated with the
application area recovers from unexpected events and errors during a run
session.

Log
Tracking

Run-time preferences for tracking logmessages generated by the log framework
that monitors events occurring in your application.

Local
System
Monitors

Preferences for tracking system counters during a run session.
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Troubleshooting and Limitations - Application Areas
Relevant for: GUI components only

This section describes troubleshooting and limitations for application areas.

l Renaming a UFT test or component from ALMmay cause the test or component to behave
unexpectedly.

Workaround: To rename a test or component, open it in UFT and rename it using the Save As
option. If the test or component has already been renamed from ALM, use the rename option
again to restore the old name, and then use theSave As option in UFT.

l Renaming a UFT test parameter from UFT will cause any run-time parameter values already set
for this parameter in ALM to be lost. For a list of naming conventions, see "Troubleshooting -
 Naming Conventions" on page 2269.
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Chapter 67: Using Data in Business Process Testing
Relevant for: business process testing

This chapter includes:

Concepts 2114

Using Data in Business Process Tests - Overview 2114

Business Process Testing Parameter Categories 2117

Linking Parameters in Business Process Tests 2119

Promoting Parameters in a Business Process Test 2123

Tasks 2124

How to Use Data in a Business Process Test 2124

Reference 2128

Select Link Source Dialog Box (BPT) 2128

Troubleshooting and Limitations - Using Data with BPT in UFT 2130
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Concepts

Using Data in Business Process Tests - Overview
Relevant for: business process testing

You can affect the behavior and results of a business process test by using parameters to define
the values that components and flows receive and return. This process is known as
parameterization.

Note: You can also use parameters for individual steps inside a component. For details, see
"Parameterizing Object Values" on page 1526.

Parameterization enables you to perform operations on the application you are testing with multiple
sets of data. Each time you run a business process test, you can supply different values for the
parameters in the test (or its components and flows).

For task details, see "How to Use Data in a Business Process Test" on page 2124.

This section includes:

l "Parameter Types" below

l "Parameter Linkage" on the next page

l "Parameter Promotion" on page 2116

l "Parameters and Iterations" on page 2116

Parameter Types

Business Process Testing provides several types of parameters, such as

l Component/Test/Flow parameters. Component parameters provide data for components.
Similarly, flow parameters provide data at the flow level and test parameters provide data at the
test level.

l Input/Output parameters. Input parameters are data that are used by an entity (component, flow,
or test) in order for the entity to perform its function. For example, in order for a component to
simulate a login operation, it must receive the login name and password as input parameters.
Output parameters are data that are outputted or generated by an entity (component or flow),
such as an invoice number.

Example

To test the business process of a banker logging into an online banking application, youmight
structure a business process test from components that:
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l Log into the application (Login)

l Select a customer loan (SelectLoan)

l View transactions for the loan (ViewLoan)

l Log out (Logout)

You can set up the steps in each of these business components to receive data from the
business process test that runs the components (for example, the loans that a customer has).
You can also parameterize any element of data, whichmay have different values each time the
business component is run. For example, the banker may choose a different customer and
customer loan to view each time he or she logs in.

Here are parameters that youmight create for this scenario, listed by category:

Category Parameters

Input parameters
for a component

l LoginName, entered as input by the banker when logging in

l AccountNo, entered by the banker, perhaps from awritten inquiry.

These parameters are created as input parameters for an individual
component, and then you can use them for any step inside the
component.

Output
parameters for a
component

l SessionNo, a number for the login session, outputted by the
business component when the banker successfully logs in

l SelectedAccountNo, outputted by the business component after the
banker selects a loan from a list

Test Parameters CustomerLoans, a comma-delimited list of all loans for a particular
customer, accessed from the test level.

Parameter Linkage

For component parameters within a business process test or flow to be accessible to other
components, the parameters must be linked. You link output parameters from one component to
input parameters in another component.

Tip: You can also link flow parameters.

For task details, see "Link parameters" on page 2125.

Example

A banking application contains business processes for:
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l Selecting a customer loan (SelectLoan)

l Viewing transactions for the loan (ViewLoan)

You can structure your business process test so that it contains a component for selecting the
loan (calledSelectLoan), and component for viewing the loan's transactions (calledViewLoan).
For theViewLoan component to know which loan to view, it receives an input parameter (called
ViewLoanID) from the output parameter (calledSelectedLoanID of theSelectLoan component.

Parameter Promotion
Promoting parameters enables in the components in other flows or components and flows in other
tests to access a parameter value. Promoting a parameter from the component level wides the
scope of a parameter so that more entities can use its value when a business process test runs. By
promoting a parameter from the component or flow level, youmake it into a flow or test parameter
and then any component included in the flow or test can access the promoted parameter.

You can promote component parameters to the flow or test level at the same time as you add a
component to a flow or test. Similarly, you can promote flow parameters to the test level at the
same time that you add a flow to a test.

For task details, see "Promote parameters" on page 2125.

Example

Using the same banking application, you decide that once a loan ID is selected by a banker
using the application, all components testing the application included in a specific flow or test
should have access to the loan ID parameter (calledSelectedLoanID).

Tomake theSelectedLoanID output parameter available to all components in a flow, you
promote it from the component or flow to the flow or test level. Once promoted, any business
components in the same business process test can use theSelectedLoanID parameter as an
input parameter. These components would then have access to theSelectedLoanID parameter
without needing to directly link input and output parameters

Parameters and Iterations

Setting parameter values per test iteration enables you to iterate specific components in a business
process test, specific components in a flow, or entire business process tests--thereby creating
data-driven tests.

l Defining iterations enables you to automatically run business components, flows, and tests
multiple times, each time using different parameter values. For details, see "Running Iterations
in a Business Process Test" on page 2132.

l You can run business process tests for different use-cases of the application you are testing.
Examples of use-cases include running the test on different operating systems, running the
same test for different browser versions, or running the same test with different languages or
character sets.
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Note: In ALM, you can associate each of these use-cases with a test configuration. For
details, see theHP Application Lifecycle Management User Guide.

Example

Youmust test that the banking application business processes for approving loans works as
expected for different scenarios:

l Loans pre-approved during the last marketing campaign are automatically approved

l Loans under a certain amount follow the standard business process for approving loans

l Loans over a certain amount must be flagged for additional approvals

To ensure these business processes work correctly, you can iterate a loan approval
component contained in your test (namedApproveLoan). In each of the iterations of this
component, you provide different values for the component parameters set up for the loan
amount (called LoanAmount) and for the date of themarketing campaign (called
PromotionCode).

Business Process Testing Parameter Categories
Relevant for: business process testing

Within a BPT test, you can have different types of parameters:

Parameter
Categories Parameter and Description
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Input /
Output

Input parameters enable you to define data used by a component or flow that is
provided from an external source. When creating components, tests, and flows,
you define how the values are supplied for input parameters.

An input parameter can receive:

l A predefined default value, if no other value is supplied by the test or flow.

l An output parameter value returned by a component or flow earlier in the flow
or test.

l A parameter value that is supplied at the test or flow level, when the test or
flow is run.

Output parameters allow data values retrieved from a component step or flow
(the source) to be passed as input parameters to a subsequent component or
flow (the target) in the test run.

Note: You cannot set a default value for an output parameter.

You can link Input and output parameters to make data available between
components or flows within the same business process test.

Component,
Flow, and
Test

Component parameters are parameters defined with a component, and
available for use for all steps included in the component. You can have both
component input parameters and component output parameters.

These parameters are available to:

l All subsequent steps in the same component

l Subsequent components in a flow or test, provided that:

n The component parameter is defined as an output parameter in the current
test or flow, and as an input parameter in the subsequent component in the
current test or flow.

n The output parameter in the current test or flow is linked to the input
parameter of the subsequent component in the current test or flow.

Flow parameters are parameters defined within a flow. These parameters are
available to all components included in a flow. Like component parameters, flow
parameters can be input or output parameters.

Test parameters are parameters identified within a business process test.
These parameters are available to all components and flows in the test. Test
parameters can only be input parameters.
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Local
parameters

Local parameter values are defined within an individual business component
and you can access them only in the component in which they were created.
Local parameters are intended for use in a single step or between component
steps, for example, as an output value for one step and input parameter for a later
step.

This type of parameter is used when working with keyword GUI components.

Linking Parameters in Business Process Tests
Relevant for: business process testing

Parameter linkage enables you to pass data between business components and flows. Thus, if you
have a value that you need for another component in one business component, you can pass the
value between the components by linking their parameters. This tests the ability of your application
to pass a value from one API to another in the course of the application's work.

You can also pass a test or flow parameter to an individual component parameter.

Once a parameter is linked, it is available to any step contained in the component with the
parameter.

Example

A business component,(namedCreateLoan) has an output parameter that contains a
generated loan ID. A subsequent business component, (namedSearchLoan), can verify the
loan if it has access to theCreateLoan loan ID value. This access is provided by linking the
CreateLoan component output parameter toSearchLoan component input parameter.

The component or flow in which the output parameter is defined is the source. The component or
flow that links to that output parameter is the target. In the example above, CreateLoan is the
source component andSearchLoan is the target component.

For task details, see "Link parameters" on page 2125.

This section also includes:

Linking Parameters When Running Iterations in a Business Process Test 2119

Linking Parameters in a Business Process Test - Examples 2120

Linking Parameters When Running Iterations in a Business Process
Test

Relevant for: business process testing

As part of data driving a business process test, you can set components (or groups of components)
 to runmultiple times in different iterations. For details on iterations, see "Running Iterations in a
Business Process Test" on page 2132.
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Iterations of a source component can result in multiple parameter output values. In these cases, the
value provided by each iteration is passed as input to the corresponding iteration of the target.

Linking can occur successfully only when UFT can determine the target iteration for each source
iteration. One of the following conditions must exist:

l Condition 1. The source has one iteration and the target has one or more iterations (a “1–to–
n”relationship). For an example, see "Linking Parameters when using Iterations ("1-to-
n" Relationship)" on page 2122.

l Condition 2. The source and the target have the same number of iterations (an “n–to–n"
relationship). For an example, see "Linking Parameters when using Iterations ("n-to-n"
Relationship)" on page 2122.

Note:When a source or target is amember of a group, the number of iterations is that of the
group.

If the component iterations are not represented by a “1–to–n” or “n–to–n” relationship, a warning
message is displayed.

Considerations

l When you use the output parameter of a previous component as the value for an input parameter
of a subsequent component, the link between the output and input parameter applies to all
component iterations of the input parameter.

l When iterations of a source component in a business process test result in multiple output
parameter values, the value that is provided by a given iteration run is passed as input to the
corresponding iteration of the target component.

l Moving a business component, group, or flow can cause a parameter reference conflict, such as
when a target component is moved to a position preceding the source component. If the
resulting warningmessage is ignored, the conflicting link to the source parameter is deleted.
This causes the iteration to fail, and youmust redo the link between the parameters.

l Iteration errors cause a business process test or flow that contains the relevant components to
fail. These errors are reported as part of the test results.

Linking Parameters in a Business Process Test - Examples

Relevant for: business process testing

When linking component parameters as part of a business process test, there are a number of
possible scenarios:

This topic includes the following examples:

l "Linking Input andOutput Parameters" on the next page

l "Linking Parameters when using Iterations ("1-to-n" Relationship)" on page 2122
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l "Linking Parameters when using Iterations ("n-to-n" Relationship)" on the next page

For these examples, you create components corresponding to the different processes of your
application for processing a customer loan request:

l A component that tests the application's ability to receive the request, and generate a unique
loan ID for the request (calledCreateLoan). This

l A component that searches the existing loans to verify if the loan already exists (called
SearchLoan).

l A component that tests the loan request approval process (calledApproveLoan).

Each of the components has a number of input parameters (in black), and output parameters (in
green).

Linking Input and Output Parameters
When you create a business process test, you arrange the components in order to test the entire
loan approval process workflow from receiving the request through approving the request.

In this example, the value of the LoanID output parameter is passed from theCreateLoan
component to theSearchLoan component as the value of the LoanID input parameter for the
component. The value is also passed to theApproveLoan component as the value for the LoanID
input parameter.
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Linking Parameters when using Iterations ("1-to-n" Relationship)

In this instance (using the example above), theCreateLoan component (containing the
LoanID output parameter) has one iteration, and theSearchLoan andApproveLoan components
have one or more iterations. This is called a "1-to-n" relationship.

In this scenario, the value of the LoanID output parameter is used for each iteration of the
SearchLoan orApproveLoan component:

Linking Parameters when using Iterations ("n-to-n" Relationship)

In this scenario, theCreateLoan component (containing the LoanID output parameter) has the same
number of iterations as theSearchLoan andApproveLoan components. This is called an "n-to-
n" relationship.

For this scenario, the different values for the LoanID output parameter in each of the iterations are
used in the respective iterations of theSearchLoan orApproveLoan components:
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Promoting Parameters in a Business Process Test
Relevant for: business process testing

When editing a business process test, you can promote component parameters to the flow or test
level at the same time as you add a component to a flow or test. Similarly, you can promote flow
parameters to the test level at the same time as you add a flow to a test. This enables you to use a
parameter for all components or flows included in a given flow or test.

Example

You create a business process test with components namedCreateLoan, VerifyLoan, and
ApproveLoan. Each of these three components contains a parameter called LoanID:

Using parameter promotion, you can promote the LoanID parameter to theProcessLoans flow
level, thereby making it available as a parameter for theCreateLoan, SearchLoan, and
ApproveLoan components. Likewise, if you need tomake the LoanID parameter available to the
CancelLoans flow, you can promote it to the test level.

For task information, see "Promote parameters" on page 2125.
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Tasks

How to Use Data in a Business Process Test
Relevant for: business process testing

This task provides general information for how to work with parameters, and iterations in business
process tests.

This task is part of a higher-level task. For details, see "How to Create, Maintain, and Run
Business Process Testing Tests and Flows in UFT" on page 2071.

This task includes the following steps:

l "Design data" below

l "Create parameters and set default values" below

l "Link parameters" on the next page

l "Promote parameters" on the next page

l "Add iterations for a component or flow" on page 2126

l "Set data values for each iteration" on page 2126

Design data

Consider the following before using parameters:

l Determine which parameters are dependent on other parameters so that you can link them. For
details, see "Link parameters" on the next page.

l Determine which parameters should be available at the component, flow, and test levels. For
details, see "Promoting Parameters in a Business Process Test" on the previous page.

l You can also use different use-case scenarios by creating iterations for a given component,
flow, or test and providing values for the parameter in each iteration. Design how may times
each component, flow, and business process test should run, and with what values. For
conceptual details, see "Running Iterations in a Business Process Test" on page 2132.

Create parameters and set default values

1. Prerequisite: Ensure that you add the component or flow to your open solution and check it out
of the version control database (if your components/flows are saved in a version-controlled
ALM project.)

2. In the Solution Explorer, select the test, flow, or component to which you want to add a
parameter.
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3. In the Properties pane, open the Test Parameters orParameters tab .

4. In the Test Parameters/Parameters, tab, click theAdd button and specify the type of
parameter to add (either input or output).

5. In the Add Input Parameter/AddOutput Parameter dialog box, enter the parameter details. You
can enter a default value or leave the field blank.

If you enter a default value, you can use the default value in the event a value is not supplied for
the test run, or you can use the default value as an example for the type of value that can be
provided (for example, a phone number example could be ###-##-####).

Note: After you add a component parameter, this parameter is available to use in any step
contained in a component. For details on parameterizing component steps, see
"Parameterizing Object Values" on page 1526.

Link parameters

1. Prerequisite: Ensure that you add the component or flow to your open solution and check it out
of the version control database (if your components/flows are saved in a version-controlled
ALM project.)

2. In the document pane, select a business process test or flow.

3. In the business process test or flow tab, select a flow or component.

4. In the Properties pane, open the Test Parameters orParameters tab.

5. Select the parameter you want to link.

6. In the Value cell of the parameter, click the Link button. The Select Link Source dialog box
opens.

7. In the left pane of the Select Link Source dialog box, select the test or flow from which you
want to use a parameter.

8. In the right pane of the Select link Source dialog box, select the parameter to which to link.

The parameter name is displayed with a link icon in the value column indicating the link.

Tip: You can also automatically link component parameters if they share the same name as a
test or flow parameter. In the BPT Testing tab of the Options dialog box (Tools > Options
> BPT Testing tab), select theAlways link to existing test parameters option.

Promote parameters

1. Open the BPT Testing tab (Tools > Options > BPT Testing tab).
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2. In theBPT Testing tab, select thePromote component parameters option. Any parameters
in components or flows added after this option is selected are promoted to test or flow
parameters.

Tip: If you do not want to automatically promote parameters for a selected component or
flow, clear this option before adding the flow or component.

3. If you do not automatically promote parameters using the options in the BPT Testing pane of
the Options dialog box, you can click thePromote Parameters button in the Parameters
tab of the Properties pane.

The selected parameter is promoted to the next level and the parameter value is linked to the
value of the newly created parameter.

Add iterations for a component or flow

Before you can set parameter values for each iteration of a component or flow, youmust add
iterations to the test for each component you want to run in iterations:

1. In the document pane, select the component or component group for which to add iterations.

2. If necessary, open the Data pane.

3. In the Data pane, click theAdd button and select one of the following to add an
iteration:

n Add New Iteration: Adds a new iteration without any values for the component/group
parameters.

n Copy Iteration. Copies the values for the component/group parameters from the previously
entered iteration.

n Create Iteration with Default Values. Adds a new iteration with the default values entered
for the parameter in the Test Parameters/Parameters tab in the Properties pane.

The new iteration and parameter values (if selected) are added as an additional row in the Data
pane.

Set data values for each iteration

1. In the document pane, select a flow, component, or group.

2. If necessary, open the Data pane.

3. In the Data pane, click in theValue cell for the parameter name. All parameters for the selected
flow, component, or group are displayed in separate columns with the parameter name as
column headers.

User Guide
Chapter 67: Using Data in Business Process Testing

HP Unified Functional Testing (12.00) Page 2126 of 2274



Note: Make sure that you have also selected the correct row for the parameter - each
separate row is its own iteration.

4. Enter the parameter value for the selected parameter.

The entered parameter value is used for each iteration.
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Reference

Select Link Source Dialog Box (BPT)
Relevant for: business process tests and flows

This dialog box enables you to link parameter values to other parameters in your business process
test or flow, and is accessible from the BPT Properties pane Parameters tab or the BPT Data pane.

To access 1. Make sure that you have a business process test or flow open in the
document pane, with a specific component or flow selected.

2. Do one of the following:

n In the Properties pane Parameters tab, hover over theValue column for
the parameter you want to link, and then click the Link button.

n In the Data pane, click in the cell for the parameter value you want to link,
and click the Link button.
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Important
information

In theSelect a step: column, select the test, flow, or component that contains the
source parameter, and then in theSelect a parameter: column, select the
parameter you want to link to.

l To link to test parameters, select the test node in theSelect a step: column.

l To link to component or flow parameters, expand the tree in theSelect a step:
column and select the component or flow node that contains your parameter.
This is only available when linking from the Parameters tab of the Properties
pane.

Relevant
tasks

"How to Use Data in a Business Process Test" on page 2124

See Also "Using Data in Business Process Tests - Overview" on page 2114

"Business Process Testing Parameter Categories" on page 2117

"Linking Parameters in Business Process Tests" on page 2119

User interface elements are described below:

UI
Element Description

Select a
step:

Displays the current test structure available.

When linking from the Data pane, this list will include tests only, as you can only
link to test parameters from the Data pane.

When linking from the Parameters tab in the Properties pane, this column also lists
any flows or components under the relevant test, and you can link to parameters
stored in those components or flows as well.

Select a
parameter:

Lists the available parameters in the selected component or flow.
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Troubleshooting and Limitations - Using Data with
BPT  in UFT

Relevant for: business process testing

l When referencing data table sheets from a business process test, you should use the data table
sheet names, not the SheetIDs.

l To import a data sheet to a business component, you should use the following
syntax: datatable.ImportSheet "<path to data sheet>",<row index>,Environment("ActionName")
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Chapter 68: Running Business Process Tests
Relevant for: business process testing

This chapter includes:

Concepts 2132

Running Iterations in a Business Process Test 2132

RunConditions Overview 2136

Tasks 2138

How to Set Run Conditions for a Business Process Test 2138

HP Unified Functional Testing (12.00) Page 2131 of 2274



Concepts

Running Iterations in a Business Process Test
Relevant for: business process testing

When deciding how to run your business process test, you can vary the number of times a selected
flow, component group, or individual component runs in the course of the test run. This enables you
to run flows or components with different sets of data.

You can configure how many times, and with which data:

l A business component runs in a test

l A flow runs in a test

l A component group runs in a test

Examples

l You can create iterations for a flow that searches for different loans in a test for a banking
application by supplying different loan IDs for a loan ID parameter.

l You can create iterations for a test that prepares loans with different interest rates to see
which rate is most affordable for the customer.

You define the number of iterations to add in the Data pane. Then, for each iteration, you supply
data for the parameter values. You can keep the default value, use the same value as a previous
iteration, or vary the values between iterations.

Example

You create a business process test with components named Login, CreateLoan, and Logout.
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In this scenario:

l The entire business process test is iterated three times.

l You can use different values for the parameters BankURL, Username, andPassword in each
test iteration.

l Within each of the three test iterations, theCreateLoan component is iterated twice. This means
that theCreateLoan component iterates a total of six times.

l Different values for theCustomerName, CustomerPhone, CustomerAddress, and theAmount
input parameters are used for each iteration of theCreateLoan component. Six different input
parameters can be supplied in total.

l TheCreateLoan component provides an output value for the LoanID parameter for each iteration
(six output values provided in total).

For task details, see "Set data values for each iteration" on page 2126.

Running Iterations of Component Groups in a Business Process
Test

Relevant for: business process testing

Sometimes, it may be helpful to run a group of components together for multiple iterations.
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Component groups contained in your test flow are identified by a group node listed above its
member components. This group node contains the group icon and displays the number of
iterations for the components included in the group.

You cannot run any of the components included in the group for a different number of iterations than
the number of iterations defined for the group.

Example

You create a business process test with the following business components: C1, C2, C3, and
C4. You set the iterations for the components as follows:

l Component C1 - two iterations

l Component C2 - three iterations

l Component C3 - three iterations

l Component C4 - one iteration

These components run differently, depending on whether you group the components or not:

Without Grouping
If you do not group any of the components, the business process test runs each component in
sequence: C1 for its iterations, C2 for each of iterations, and so forth:
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With Grouping

Instead of running all the iterations of component C1, then all the iterations of component C2,
and so forth, grouping the components together changes themanner in which the business
process test is run.

In this scenario, you group components C2 andC3 together as a group, and set the group to
run for three iterations. Thus, the business process test runs in the following order:

l The first iteration of component C1

l The second iteration of component C1

l The first iteration of component C2

l The first iteration of component C3

l The second iteration of component C2

l The second iteration of component C3

l The third iteration of component C2

l The third iteration of component C3

l The single iteration of component C4

This process is illustrated graphically in the example below:
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Run Conditions Overview
Relevant for: business process testing

You can use run conditions to insert condition statements into your flows. A run condition checks
the current value of a component parameter before running the component in a flow. Based on the
parameter value and the run condition definition, UFT determines whether to:

l Run the component

l Skip to the next component

l End the component run and set the component status to fail
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When you run business process tests containing flows with run conditions, the test run results
display the results of run conditions in the test, and lists the components that did not run because a
run condition was not met. If a run condition is not met, the test results also provide details about
the condition that was not met to help you understand why the component run failed or did not run.

Note: If you set run conditions, and later add or remove a component or change the component
order within a flow, the parameters may no longer be relevant and the run conditionmay not
work. For example, if Component B uses an output parameter value from Component A, and
you change the order of the components so that Component B precedes Component A, then
Component B cannot receive the output parameter value from Component A and the invalid run
condition is ignored.
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Tasks

How to Set Run Conditions for a Business Process Test
Relevant for: business process testing

The following steps describe how to set run conditions for the flows in a business process test or
flow.

Note: This task is part of a higher-level task. For details, see "How to Create, Maintain, and
Run Business Process Testing Tests and Flows in UFT" on page 2071.

This task includes the following steps:

l "Prerequisites" below

l "Select the flow or component to set run conditions" below

l "Set On Failure settings for a flow or component" below

l "Set run conditions for a component" on the next page

l "Test the run conditions" on the next page

1. Prerequisites
Ensure that the component for which you are setting run conditions has parameters or that the
flow containing the component has a parameter.

2. Select the flow or component to set run conditions
a. Do one of the following:

o If you are setting run conditions for a flow, in the document pane, select the test
containing the flow.

o If you are setting run conditions for a component, in the document pane, select the
business process test or business process flow containing the component.

b. In the document pane, select the flow or component to set run conditions.

3. Set On Failure settings for a flow or component
If you are editing a test, you can set On Failure options for all the flows or components
included in the test:

a. In the Solution Explorer or document pane, select the business process test you are
editing.
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b. In the document pane, select the flow or component for which to set On Failure settings.

c. In the Properties pane, open theProperties tab .

d. In the Properties tab, set the options for the selected flow or component:

o Continue. Continues the test regardless whether the test passes or fails.

o Exits. Immediately stops the test and exists the test run.

4. Set run conditions for a component
When you are editing a business process flow, you can set additional run options for the
components included in the flow:

a. In the Solution Explorer or the document pane, select the business process flow on which
you are working.

b. In the document pane, select the component to which you want to add run conditions.

c. In theProperties tab in the Properties pane, select theUse run condition option.

d. In themiddle section of the Properties tab, set the condition options:

o Run if: Indicates what type of parameter (flow or component parameter) and the name
of parameter for which a conditionmust bemet

o Is: the operator for the parameter value

o Else: Instructs UFT what to do with the test run if the condition is not met.

5. Test the run conditions
Run the test to ensure that the run conditions were performed correctly.

Note: If a run condition is not valid, the run condition link is displayed in red. This can
happen, for example, if a reference parameter was deleted, a parameter value was
encrypted, and so on. Delete the run condition and define a new one.
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Appendix A: Where's My UI?
(Changes from Previous Versions)

Relevant for: GUI tests and components and API testing

This chapter describes changes that have beenmade to the user interface betweenQuickTest
Professional 11.00 or Service Test 11.20 and UFT:

Pane Changes 2142

Menu CommandChanges 2144

Toolbar Changes 2158

QuickTest 11.00 Options Dialog Box Changes 2164

QuickTest Editor Options Dialog Box Changes 2167
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Pane Changes
Relevant for: GUI testing and API testing

The table below lists the panes whose names in UFT are different from QuickTest 11.00 orService
Test 11.20. The functionality of the pane remains similar.

Previous Pane
Name

UFT Pane
Name Additional Information

Available Keywords
(QuickTest only)

Toolbox For details on theGUI testing (QuickTest) pane, see
"Toolbox Pane User Interface (GUI Testing)" on page
510.

Data Table
(QuickTest only)

Data For details on theGUI testing (QuickTest) Data pane,
see "Data PaneOverview" on page 222.

Data Explorer
(Service Test only)

Data For details on theAPI testing (UFT) Data pane, see
"Data Pane User Interface (API Testing)" on page 252.

Debug Viewer
(QuickTest only)

Debug AvailableDebug panes include:

l Breakpoints

l Call Stack

l Watch

l Local Variables

l Console

For details, see " Debug Panes Overview" on page
272.

General (in
Application Area)
(QuickTest only)

Properties For details, see "General Properties Tab (Properties
Pane for Application Areas)" on page 391.

Information
(QuickTest only)

Errors The Information andMissing Resources panes have
beenmerged into a single Errors pane.

For details, see "Errors PaneOverview " on page 365.Missing Resources
(QuickTest only)

Property Sheet
(Service Test only)

Properties For details on the Properties pane, see "Properties
Pane" on page 385.
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Previous Pane
Name

UFT Pane
Name Additional Information

Resources
(QuickTest only)

Solution
Explorer

For details on theSolution Explorer pane, see
"Solution Explorer PaneOverview" on page 471.

Tests
(Service Test only)

Solution
Explorer

Test Flow
(QuickTest only)

Canvas The canvas replaces the flow pane and provides all its
functionality.

For details, see "The Canvas" on page 209.

To Do
(QuickTest only)

Tasks For details on the Tasks pane, see "Tasks Pane
Overview" on page 498.

Toolbox Palette
(Service Test only)

Toolbox For details on theAPI testing (UFT) pane, see
"Toolbox PaneOverview" on page 506.
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Menu Command Changes
Relevant for: GUI testing and API testing

Some of themenu commands from Service Test 11.20 andQuickTest 11.20 are relocated in UFT,
to improve product usability. Use this section to locate the commands that moved.

This section discusses the followingmenu changes:

File Menu Changes 2144

Edit Menu Changes 2146

View MenuChanges 2148

Insert Menu Changes (QuickTest only) 2150

Test Menu Changes (Service Test only) 2151

AutomationMenu Changes (QuickTest only) 2152

Build Menu Changes (Service Test only) 2153

DebugMenu Changes 2154

Resources Menu Changes (QuickTest only) 2155

Tools Menu Changes (QuickTest only) 2155

Window MenuChanges (QuickTest only) 2156

HelpMenu Changes 2156

File Menu Changes
Relevant for: GUI testing and API testing

The following table lists commands from theQuickTest 11.00 or Service Test 11.20 File menu and
their location in UFT.

Service Test 11.20/
QuickTest 11.00
Menu Option UFT Option Additional Information

File > New > Scripted
Component
(QuickTest only)

File > New >
Business
Component

You can choose all types of business
components, including scripted components,
through this menu command in the "New
<Document> Dialog Box".

For details, see the "New <Document> Dialog
Box" on page 152.
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Service Test 11.20/
QuickTest 11.00
Menu Option UFT Option Additional Information

File > Open >
Business/Scripted
Component
(QuickTest only)

File > Open >
Business
Component

You can choose all types of business components
through this menu command in the "Open/New
<Document>/<Resource> Dialog Box".

For details, see the "Open/New
<Document>/<Resource> Dialog Box" on page
156.

File > Close All
Function Libraries|
(QuickTest only)

Document
pane context
menu

Right-click any document tab in the document
pane and select Close All Documents.

File > ALM/QC
Connection

ALM > (menu
option)

All menu command tomanage an ALM connection
have beenmoved to a stand-aloneALMmenu.

Note: The ALM Connection is also available

by pressing theALM Connection button
in the toolbar.

ALM/QC Version
Control > Check Out

ALM/QC Version
Control > Undo Check
Out

ALM/QC Version
Control > Check In

ALM/QC Version
Control > Version
History

ALM/QC Version
Control > Baseline
History

File > Enable Editing
(GUI testing only)

Function
library context
menu

Right-click the tab of a read-only function library in
the document pane and select Enable Editing.

File > Settings
for application areas
(GUI testing only)

In Application
Area,
Additional
Settings
panes

Process Guidance
Management

This command is not relevant for UFT.
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Service Test 11.20/
QuickTest 11.00
Menu Option UFT Option Additional Information

Associate Function
Library <Function
Library name> with Test
<Test Name>

Document
pane context
menu

Right-click a function library tab in the document
pane and select Associate Function Library
with <Document name>

Edit Menu Changes
Relevant for: GUI testing and API testing

The following table lists commands from theQuickTest 11.00 orService Test 11.20Edit menu and
their location in UFT.

GUI testing (QuickTest) changes

QuickTest 11.00
Menu Option UFT Option Additional Information

Edit > Copy
Documentation to
Clipboard

Keyword View
context menu

Right-click on a column header in the Keyword
View and select Copy Documentation to
Clipboard.

Edit > Action > Split
Action

This command is not relevant for UFT.

Edit > Action >
Rename Action

Canvas or
Keyword View
context menu

Right-click an action in the canvas or the Action
node in the Keyword View to access all action
commands.

Edit > Action > Delete
Action

Edit > Action >
Action Properties

Edit > Action >
Action Call Properties
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QuickTest 11.00
Menu Option UFT Option Additional Information

Edit > Step Properties
> Comment
Properties

Keyword View
context menu

Right-click the appropriate step in the Keyword
View to access the item's properties.

Edit > Step Properties
> Object Properties

Edit > Step Properties
> Checkpoint
Properties

Edit > Step Properties
> Output Value
Properties

Edit > Step Properties
> Report Properties

This option is not available in UFT. Edit the step
itself in the Editor or Keyword View.

Edit > Find Search > Find or
Search >
ReplaceEdit > Replace

Edit > Go To Search > Go To This menu option also enables you to domultiple
types of Go To searches.

Edit > Bookmarks Search >
Bookmarks

All bookmarks aremanaged in the Bookmarks
pane. For details, see "Bookmarks Overview" on
page 204.

Edit > Advanced >
Comment Block

Edit > Format
submenu

Thesemenu commands remain in theEditmenu,
but are now combined under the Format
submenu.

Edit > Advanced >
Uncomment Block

Edit > Advanced >
Indent

Edit > Advanced >
Outdent

Advanced > Go To >
Function Definition

Editor context
menu

Right-click a step in the Editor and select Go to
Function Definition.
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QuickTest 11.00
Menu Option UFT Option Additional Information

Advanced > Complete
Word

Edit > Format
submenu

Thesemenu commands remain on theEdit, but
are now combined under the Format submenu.

Advanced >
Argument Info

Advanced > Apply
"with" to Script

Advanced > Remove
"With" Statements

Optional Step This command is not relevant for UFT.

API testing (Service Test) changes

Service Test 11.20
Menu Option UFT Option Additional Information

Select All This command is not relevant for UFT.

Find and Replace Search > Find
Search > Replace

Settings > Show
Run Test dialog box

This command is not relevant for UFT.

Settings > Show
Results after Run

Tools > Options >
General tab > Run
Sessions node

Select theView results when run
session ends option to enable this
command.

Settings > Use
Relative Paths in
UFT Steps

Tools > Options > API
Testing tab > General
node

Select theUse relative paths to call
assets option to enable this command.

Settings > Activity
Repositories

Tools > Options > API
Testing tab > General
node

Choose the Activity Repositories path in
theActivity Repositories area of General
pane.

View Menu Changes
Relevant for: GUI testing and API testing

The following table lists commands from the QuickTest 11.00 orService Test 11.20View menu
and their location in UFT.
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GUI testing (QuickTest) changes

QuickTest 11.00
Menu Option UFT Option Additional Information

View >
Available
Keyword

View >
Toolbox

View > Data
Table

View > Data

View > Debug
Viewer

View >
Debug

This menu command displays a list of debug panes from
which to choose.

View > Process
Guidance

This command is not relevant for UFT.

View >
Resources

View >
Solution
Explorer

View > Test
Flow

This command is not relevant for UFT. The test canvas
provides the functionality that was provided by the Test Flow
pane.

View > To Do View > Tasks

View >
Keyword View

View >
Keyword
View/Editor

This menu command switches between the Keyword View
and Editor.

Note: You can also change between the Keyword View
and the Editor by using the toolbar button.

View > Expert
View

View >
Toolbars

This menu command is not available in UFT.

For details on the toolbar changes in UFT, see "Toolbar
Changes" on page 2158.

Window Theme This command is not relevant for UFT.

API testing (Service Test) changes

Service Test 11.20
Menu Option UFT Option Additional Information

Tests View > Solution
Explorer

Data Window View > Data
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Service Test 11.20
Menu Option UFT Option Additional Information

Property Sheet View > Properties

Window Theme >
(suboptions)

This command is not relevant for
UFT.

Insert Menu Changes (QuickTest only)
Relevant for: GUI tests and components

The following table lists commands from theQuickTest 11.00 Insert menu and their location in
UFT.

QuickTest 11.00
Menu Option UFT Option Additional Information

Insert >
Checkpoint >
(suboptions)

Design >
Checkpoint
submenu

All the checkpoints available in QuickTest 11.00 are
available under this menu command.

Insert > Output
Value >
(suboptions)

Design > Output
Value submenu

All the output values available in QuickTest 11.00 are
available under this menu command.

Insert > Step
Generator

Design submenu TheStep Generator command is also available from
the context menu for the Keyword View and Editor.
Right-click in either view and select Insert Step > Step
Generator.Insert >

Function
Definition
Generator

Insert >
Synchronization
Point

Design >
Synchronization
Point

Insert > New
Step

Keyword View
context menu

Right-click a step in the Keyword View and select Insert
New Step.

New Step After
Block

Keyword View
context menu

Right-click a step in the Keyword View and select Insert
New Step After Block.

Operation This command is not relevant for UFT

Comment Design > Add
Comment

Also available by right-clicking a step in the Keyword
View and selecting Insert Step > Comment.

Report Keyword View
context menu

Right-click a step in the Keyword View and select Insert
Step > Report.
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QuickTest 11.00
Menu Option UFT Option Additional Information

Conditional
Statement

Edit > Code
Snippet
submenu

This menu command provides choices of multiple types
of conditional and loop statements to insert in a test or
component.

Loop Statement

Call to New
Action

Design > Call to
submenu

Also available by right-clicking an action in the canvas
and selecting the relevant commandor a step in the
Keyword View/Editor and selectingAction and
selecting the relevant command.Call to Copy of

Action

Call to Existing
Action

Call to Service
Test test

Start
Transaction

Design > Start
Transaction

Also available by right-clicking a step in the Editor and
selecting Insert Step > Start Transaction orEnd
Transaction.

End Transaction Design > End
Transaction

Test Menu Changes (Service Test only)
Relevant for: API testing only

The Testmenu items from Service Test 11.20 are incorporated into other menus in UFT.

Service Test 11.20
Menu Option UFT Option Additional Information

Test > Add
Reference

Design > Add
Reference

Test > Enable
Test for Load
Testing

Design > Enable
Test for Load
Testing

Only available when HP LoadRunner is installed
on themachine.

Test > Open
Containing
Folder

Context menu in
document pane

Right-click on a test tab in the document pane and
select Open Containing Folder in Explorer.

Test > View Test
Results

View > Last Run
Results
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Automation Menu Changes (QuickTest only)
Relevant for: GUI tests and components

TheAutomationmenu from QuickTest 11.00 is incorporated into theRun andRecordmenus in
UFT.

QuickTest 11.00
Menu Option

UFT
Option Additional Information

Automation >
Web Service
Testing Wizard

Tools >
Web
Service
Testing
Wizard

TheWeb Services Add-in is supported for backwards
compatibility only is not enabled by default. New tests and
components can use HP's API testing solution forWeb service
testing purposes.

To enableWeb Services Add-in for legacy tests, contact
HP Software Support.

Automation >
Record

Record >
Record

Automation >
Run

Run >
Run

Automation >
Stop

Record >
Stop (if
recording)
Run >
Stop (if in a
run
session)

Automation >
Run Current
Action

Run
submenu

Automation >
Run
Maintenance
Mode

Automation >
Update Run
Mode

Automation >
Analog
Recording

Record >
Analog
Recording
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QuickTest 11.00
Menu Option

UFT
Option Additional Information

Automation >
Low Level
Recording

Record >
Low-Level
Recording

Automation >
Record and
Run Settings

Record >
Record
And Run
Settings

Automation >
Process
Guidance List

This command is not relevant for UFT.

Automation >
Results

View >
Last Run
Results

Build Menu Changes (Service Test only)
Relevant for: API testing only

TheBuildmenu from Service Test 11.20 is incorporated into theRunmenu in UFT.

Service
Test 11.20
Menu Option UFT Option Additional Information

Build Solution Run > Compile submenu

Rebuild
Solution

Clean Solution

Build <test
name>

Rebuild <test
name>

Clean <test
name>

Abort Build
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Service
Test 11.20
Menu Option UFT Option Additional Information

Set
Configuration
> Debug

Tools > Options > API
Testing tab > General node

Select the appropriate option from the drop-
downmenu forCompile as option.

Set
Configuration
> Release

Debug Menu Changes
Relevant for: GUI testing and API testing

TheDebugmenu from QuickTest 11.00 orService Test 11.20 is incorporated into theRunmenu in
UFT.

GUI testing (QuickTest) changes

QuickTest 11.00
Menu Option UFT Option Additional Information

Pause Run
submenu

These commands have all moved into theRun
menu.

Step Into

Step Over

Step Out

Run to Step

Debug from Step

Add to Watch

Insert/Remove Breakpoint

Enable/Disable Breakpoint

Clear All Breakpoints

Enable/Disable All
Breakpoints
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API testing (Service Test) changes

Service Test 11.20
Menu Option UFT Menu Option

Run Test Run submenu

Stop Process

Break

Continue Debugging

Step Over

Step Into

Step Out

Toggle Breakpoint

Resources Menu Changes (QuickTest only)
Relevant for: GUI tests and components

TheAssociated Function Libraries command from theQuickTest 11.00Resources menu is not
available in UFT.

To view the list of function libraries associated with a test or component, use the "Solution Explorer
Pane" (described on page 470), or the "Resources Pane (Test/Business Component Settings
Dialog Box) " (described on page 603).

Tools Menu Changes (QuickTest only)
Relevant for: GUI tests and components

The following table lists commands from theQuickTest 11.00 Tools menu and their location in
UFT.

QuickTest 11.00
Menu Option UFT Option Additional Information

View Options Tools >
Options >
Text Editor
tab

Most of the options available in the QuickTest 11.00 View
Options are incorporated into the Text Editor tab of the
Options dialog box in UFT. For details, see "QuickTest
Editor Options Dialog Box Changes" on page 2167.

Check Syntax Design >
Check Syntax
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QuickTest 11.00
Menu Option UFT Option Additional Information

Web Event
Recording
Configuration

Record >
Web Event
Recording
Configuration

Customize Not available in UFT.

Window Menu Changes (QuickTest only)
Relevant for: GUI tests and components

The followingWindowmenu commands from QuickTest 11.00 are changed in UFT.

QuickTest 11.00
Menu Option UFT Option Additional Information

Cascade Thesemenu commands are not available in UFT.

Instead, the functionality of these commands is incorporated
into the pane layout. For details, see "UFTWindow Layout
Customization - Overview" on page 183.

Tile
Horizontally

Tile Vertically.

Close All
Function
Libraries

Window >
Close All
Documents

<windows list> This menu command is not available in UFT.

Instead you can select from the various document tabs
available in the document pane.

Help Menu Changes
Relevant for: GUI testing and API testing

The followingHelp menu options from QuickTest 11.00 orService Test 11.20 are changed in UFT.

GUI testing (QuickTest) changes

QuickTest 11.00
Menu Option UFT Option Additional Information

QuickTest Professional Tutorial Help > UFT Help > Tutorial
for GUI Testing

Send Feedback and Win This command is not
relevant for UFT.
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QuickTest 11.00
Menu Option UFT Option Additional Information

HP QuickTest Professional
Software Web Page

Help > Useful Links >
Product Page

API testing (Service Test) changes

Service Test 11.20
Menu Option UFT Menu Option Additional Information

Index Not available in UFT.

Search

Contents

User Guide Help > HP UFT Help

HP Service Test Web Site Help > Useful Links > Product Page
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Toolbar Changes
Relevant for: GUI testing and API testing

For GUI testing: UFT has a single toolbar, as opposed to themultiple functional toolbars in
QuickTest 11.00. The toolbar displays different buttons, depending on the open document or the
operations you perform. The functionality of any buttons no longer available in the toolbar is
incorporated into menu commands or shortcut (right-click) menu commands.

The sections describe the locations of toolbar buttons or toolbar icons from QuickTest 11.00
orService Test 11.20 that changed.

This section includes:

l "QuickTest Toolbar Buttons" below

l "Service Test Toolbar Buttons" on page 2162

QuickTest Toolbar Buttons
Relevant for: GUI tests and components

The following table shows the new icons for QuickTest 11.00 toolbar buttons, as well as themenu
options you can use for buttons that are no longer available.

Standard Toolbar Buttons

QuickTest 11.00
toolbar button UFT Location

New Test Toolbar button:
New

Open Test Toolbar button:
Open

Save Test with
Resources

Menu command: File > Save (Other) > Save with Resources

Print Not available in UFT.

Cut Menu commands:
Edit submenu

Copy

Paste

Enable Editing Function library context menu: Right-click the tab of a read-only function
library in the document pane and select Enable Editing.
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QuickTest 11.00
toolbar button UFT Location

Settings Menu command:
File > Settings

ALM/QC
Connection

Toolbar button:
ALM Connection

Automation Toolbar Buttons

QuickTest 11.00
toolbar button UFT Location

Web Service
Testing Wizard

Menu command: Tools > Web Service TestingWizard

Note: TheWeb Services Add-in is supported for backwards
compatibility only is not enabled by default. New tests and
components can use HP's API testing solution forWeb service
testing purposes.

To enableWeb Services Add-in for legacy tests, contact HP Software
Support.

Analog
Recording

On Recording mode dropdown in Record toolbar:
Analog Recording

Low Level
Recording

On Recording mode dropdown in Record toolbar:
Low-Level

Standard
Windows
Recording

On Recording mode dropdown in Record toolbar
StandardWindows Recording

Insert Emulator
Synchronization
Step

Menu command:
Design > Emulator Synchronization

Insert Emulator
WaitString Step

Menu command:
Design > EmulatorWaitString

Object
Repository

Toolbar button:
Object Repository
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Debug Toolbar Buttons

QuickTest 11.00 toolbar button UFT Location

Pause Buttons on Run/Debug Toolbar:

l Pause

l Step Into

l StepOver

l StepOut

Step Into

Step Over

Step Out

Insert/Remove Breakpoint Menu commands:

l Run > Insert/Remove Breakpoint

l Run > Clear All Breakpoints

l Run > Enable/Disable Breakpoints

Clear All Breakpoints

Enable/Disable All Breakpoints

Edit Toolbar Buttons

QuickTest 11.00 toolbar button UFT Location

Undo Menu command:
Edit > Undo

Redo Menu command:
Edit > Redo

Comment Block Menu command:
Edit > Format > Comment

Uncomment Block Menu command:
Edit > Format > Uncomment

Find Menu command:
Search > Find

Replace Menu command:
Search > Replace

Insert Toolbar Buttons

QuickTest 11.00 toolbar button UFT Location

Split Action This command is not relevant for UFT.

Step Generator Menu command:
Design > StepGenerator
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QuickTest 11.00 toolbar button UFT Location

Start Transaction Menu command:
Design > Start Transaction

End Transaction Menu command:
Design > End Transaction

Tools Toolbar Buttons

QuickTest 11.00 toolbar button UFT Location

Options Menu command:
Tools > Options

Check Syntax Menu command:
Design > Check Syntax

Object Spy Toolbar button:
Object Spy

View Toolbar Buttons

QuickTest 11.00
toolbar button UFT Location

Test Flow When you open a test in UFT, the test opens in the canvas, which
displays the test's flow. This replaces the Test Flow pane.

Available
Keywords

Toolbar button:
Toolbox

Resources Toolbar button:
Solution Explorer

Data Table Toolbar button:
Data

Active Screen Menu command:
View > Active Screen

Process
Guidance

This option is not available in UFT.

To Do Menu command:
View > Tasks
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Action Toolbar

QuickTest 11.00
toolbar button UFT Location Additional Information

<action name> l Action node in
the Solution
Explorer

l Action on test
canvas

Back l Test node in
the Solution
Explorer

l Test canvas
tab

Select the test name node in the Solution Explorer or the
test canvas tab to return to the test flow.

Show l Action node in
the Solution
Explorer

l Action on test
canvas

Double-click the action node in the Solution Explorer or
test canvas to open or display the selected action.

Service Test Toolbar Buttons
Relevant for: API testing only

The following table shows the new icons for Service Test 11.20 toolbar buttons, as well as the
menu options you can use for buttons that are no longer available.

Service Test
11.20
toolbar
button UFT Location Additional Information

Open Test Toolbar button:
Open

This toolbar button also provides a
drop-down list of document types to
open.

Add New
Test

Toolbar button:
Add

This toolbar button also provides a
drop-down list of document types (both
new and existing to add to a solution).

ALM/QC
Connection

Toolbar button:
ALM Connection
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Enable Test
for Load
Testing

Menu command:
Design > Enable
Test for Load
Testing

Only available when HP LoadRunner is
installed on themachine.

Default
Zoom

Button on canvas

Zoom In Button on canvas

Zoom Out Button on canvas
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QuickTest 11.00 Options Dialog Box Changes
Relevant for: GUI tests and components

The UFT Options dialog box (Tools > Options) incorporates options from QuickTest 11.00 as well
as various new options. The UFT Options dialog box includes tabs for global testing options as well
as separate GUI Testing and API Testing tabs. This section lists QuickTest 11.00 options whose
location has changed. For details on the Options dialog, see "UFT Global Options" on page 522.

General Pane
The following table lists theGeneral pane options that changed from QuickTest 11.00.

QuickTest 11.00 Options String UFT Path

Display Add-in Manager on startup Tools > Options > General tab >
Startup Options node

Display Start Page on startup Tools > Options > General tab >
Startup Options node

Display warning if associated add-ins are not
loaded

Tools > Options > General tab >
Startup Options node

Disable recognition of virtual objects while
recording

Tools > Options > GUI Testing tab
> General node

Automatically update test and component steps
when you rename test objects.

Tools > Options > GUI Testing tab
> General node

Display the Keyword View for tests and scripted
components

This option is not available in UFT.

The Keyword view is always
available.

Automatically parameterize steps using... Tools > Options > GUI Testing tab
> General node

Automatically generate "With" statements after
recording

Tools > Options > GUI Testing tab
> General node

When pointing at a window, activate it after <>
tenths of a second

Tools > Options > GUI Testing tab
> General node

Restore Layout View > Reset Window Layout

Generate script Tools > Options > GUI Testing tab
> General node

Run Pane
The following table lists theRun pane options that changed from QuickTest 11.00.
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QuickTest 11.00 Options String UFT Path

Run mode Tools > Options > GUI Testing tab > Test
Runs node

Submit a defect to ALM/QC for each failed
step

Tools > Options > GUI Testing tab > Test
Runs node

View results when run session ends Tools > Options > General tab > Run
Sessions node

Allow other HP products to run tests and
components

Tools > Options > GUI Testing tab > Test
Runs node

Stop command shortcut key This option is not available in UFT.

The shortcut key to stop a run is always F4.

Other Options Dialog Panes
The following panes from theQuickTest 11.00 Options dialog have changed locations in UFT:

l Folders pane

l Active Screen pane

l Screen Capture pane

l Windows Applications pane

l Solution Manager pane

l Java pane

l Terminal Emulator pane

l Web pane

l SAP pane

l Stingray pane

These panes are found in GUI Testing tab (Tools > Options > GUITesting tab).

The options available in these panes have remained in QuickTest 11.00 have remained.

Note: >Some of these panes are displayed only when you load the appropriate add-ins in the
"Add-in Manager Dialog Box" (described on page 118) and open a test or component.

Web Services Pane
TheWeb Services pane from QuickTest 11.00 is not available in UFT.
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TheWeb Services Add-in is supported for backwards compatibility only is not enabled by default.
New tests and components can use HP's API testing solution forWeb service testing purposes.

To enableWeb Services Add-in for legacy tests, contact HP Software Support.
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QuickTest Editor Options Dialog Box Changes
Relevant for: GUI tests and components

The UFT Options dialog box also includes the options from theQuickTest 11.00 View Options
dialog box. For details on the Options dialog, see "UFT Global Options" on page 522.

The following sections describe the new locations of the QuickTest 11.00 Editor Options dialog:

General Tab

QuickTest 11.00
Editor Options
String UFT Path

Show line
numbers

Tools > Options > Text Editor tab > General node

Auto-indent This option is not available in UFT. However, the functionality is
incorporated into the Tab spacing functionality (Tools > Options > Text
Editor tab > General node).

Indent selected
text when
pressing TAB
key

This option is not available in UFT. The Editor is designed to always use the
TAB key to indent selected text, if multiple rows are selected.

Statement
completion

This option is not available in UFT. The statement completion feature is
always enabled.

Draw box
around current
line

This option is not available in UFT.

Dynamic
surround

This option is not available in UFT.

Show all
characters

Tools > Options > Text Editor tab > General node

Auto-expand
VBScript syntax

This option is not available in UFT. VBScript syntax automatic completion
is always available.

Use tab
character

The functionality of this option is included when you select theShow tabs
options in the Text Editor pane of the Options dialog box (Tools > Options
> Text Editor tab > General node).

Fonts and Colors Pane
The Fonts and Colors pane options from QuickTest 11.00 have remained in UFT. These options
are found at Tools > Options > Text Editor tab > Font and Colors node.
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For details on this pane, see "Fonts and Colors Pane (Options Dialog Box > Text Editor Tab)" on
page 577.

Key Binding Pane
TheKey Binding pane options from QuickTest 11.00 are not available in UFT.
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Appendix B: UFT Terminology Quick Reference
Relevant for: GUI tests and components and API testing

This chapter lists the relevant testing areas for commonUFT elements, as well as references for
more details.

Testing type Includes these testing documents:

GUI tests l GUI tests

l actions

l function libraries

GUI components l keyword GUI components

l scripted GUI components

l application areas

l function libraries

API testing l API tests

l API components

l user code files

Term (A-Z) Relevant for: For details, see:

.NET assembly API testing ".NET Assembly Activities" on page 1736

accessibility
checkpoints

l GUI tests

l scripted
GUI
components

"Accessibility Checkpoints Overview" on page 1400

actions l GUI tests

l API testing

l For GUI testing: "Actions in GUI Testing -
Overview" on page 872

l For API testing: "Actions in API Testing - Overview"
on page 1787
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Term (A-Z) Relevant for: For details, see:

active screen l GUI tests

l scripted
GUI
components

l "Active ScreenOverview" on page 194

l "Active Screen Pane User Interface" on page 200

activity API testing "Activity Overview" on page 1612

activity repository API testing "How to Perform Activity Sharing" on page 1761

add-ins l GUI tests

l GUI
components

HP Unified Functional Testing Add-ins Guide

ALM project l GUI tests

l GUI
components

l API testing

"ALM Integration Overview" on page 709

application area GUI
components

l "Application Areas - Overview" on page 2096

l "Application Area User Interface" on page 2101

array properties API testing "Array Control Buttons" on page 438

automation l GUI tests

l GUI
components

"UFT Automation Object Model Overview" on page 1156

bitmap
checkpoints

l GUI tests

l scripted
GUI
components

"Bitmap Checkpoints Overview" on page 1401

bookmarks l GUI tests

l scripted
GUI
components

l function
libraries

l API testing

l "Bookmarks Overview" on page 204

l "Bookmarks Pane User Interface" on page 206
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Term (A-Z) Relevant for: For details, see:

breakpoints l GUI tests

l scripted
GUI
components

l function
libraries

l API testing

l "Breakpoints " on page 681

l " Breakpoints Pane" on page 277

business process
test

l GUI
components

l API testing

"Business Process Testing in UFT - Overview" on page
2065

canvas l GUI tests

l API testing

"The Canvas" on page 209

checkpoint l GUI tests

l GUI
components

l API testing

l For GUI testing: "Checkpoints Overview" on page
1396

l For API testing: "Checkpoint Validation for Test
Steps" on page 1612

checkpoint
validation

API testing "Checkpoint Validation for Test Steps" on page 1612

classes API testing "How to Search for References or Classes in
Documents in the Editor (API Testing Only)" on page 325

code completion l GUI tests

l scripted
GUI
components

l function
libraries

l API testing

"Automatic Code Completion" on page 316

code object l GUI tests

l GUI
components

l API testing
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Term (A-Z) Relevant for: For details, see:

code snippets l GUI tests

l scripted
GUI
components

l "Automatic Code Completion" on page 316

l "How to Use Code Snippets and Templates" on page
322

code templates l GUI tests

l scripted
GUI
components

l function
libraries

l API testing

l "How to Use Code Snippets and Templates" on page
322

l "Code Templates Pane (Options Dialog Box > Coding
Tab)" on page 573

compile API testing "Output PaneOverview" on page 380

conditional
statement

l GUI tests

l scripted
GUI
components

"Comments, Control-Flow, andOther VBScript
Statements " on page 1006

conditional steps API testing` "Flow Control Activities" on page 1651

data driving l GUI tests

l API testing

l For GUI testing: "Data Driver" on page 1543

l For API testing: "How to Data Drive an API Test
Step" on page 1827

data table l GUI tests

l scripted
GUI
components

l API testing

l For GUI testing: "Data PaneOverview" on page 222

l For API testing: "Using Data in Your API Test or
Component Steps" on page 1801

data table
parameters

GUI tests "Data Table Parameters" on page 1533

data table
property

API testing l "Linking Property Values to a Data Source" on page
1803

l "How to Assign Data to API Test/Component Steps"
on page 1819
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Term (A-Z) Relevant for: For details, see:

database
checkpoints

l GUI tests

l scripted
GUI
components

"Database Checkpoints Overview" on page 1405

database query API testing "Creating aQuery to Retrieve Database Tables" on page
1805

Editor l GUI tests

l scripted
GUI
components

l function
libraries

l API testing

l "Editing Text and Code Documents" on page 305

l "Editor User Interface" on page 334

environment
variables

l GUI tests

l GUI
components

"Environment Variables" on page 1493

event handler API testing "Writing Code for API Test Events - Overview" on page
1938

file content
checkpoints

l GUI tests

l scripted
GUI
components

"File Content Checkpoints Overview" on page 1406

function library l GUI tests

l GUI
components

"Function Library Overview" on page 1030

global data sheet l GUI tests

l scripted
GUI
components

"Global Sheet" on page 226

IBM Websphere
MQ

API testing "IBMWebSphereMQActivities" on page 1699

input/output
properties

API testing "Properties PaneOverview" on page 386
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Term (A-Z) Relevant for: For details, see:

Insight objects l GUI tests

l GUI
components

"Identifying Objects Using Insight" on page 1176

JMS transport API testing "JMS Activities" on page 1691

JSON API testing l "How to Send a JSON Request to a REST Service"
on page 1752

l "How to Receive a JSON Response from aREST
Service" on page 1753

Keyword View l GUI tests

l GUI
components

l "Keyword View Overview" on page 921

l "Keyword View User Interface" on page 942

load testing API testing "Load Testing Activities" on page 1698

log tracking l GUI tests

l GUI
components

l "Log Tracking" on page 586

l "Log Tracking Pane (Test/Business Component
Settings Dialog Box / Application Area - Additional
Settings Pane)" on page 617

loop statement l GUI tests

l scripted
GUI
components

"Comments, Control-Flow, andOther VBScript
Statements " on page 1006

maintenance run
mode

l GUI tests

l GUI
components

"Maintenance RunMode" on page 1080

missing
resources

l GUI tests

l GUI
components

l API testing

"Errors PaneOverview " on page 365

multipart HTTP
requests

API testing "How to Send aMultipart HTTP Request" on page 1626

negative testing API testing "Negative Testing of Web Services" on page 1738
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Term (A-Z) Relevant for: For details, see:

object repository l GUI tests

l GUI
components

"Object Repository Window - Overview" on page 1260

object spy l GUI tests

l GUI
components

"Object Spy Dialog Box " on page 1189

optional steps l GUI tests

l scripted
GUI
components

"Optional Steps" on page 637

output value l GUI tests

l scripted
GUI
components

"Output Values Overview" on page 1488

parameter (both
input and output)

l GUI tests

l GUI
components

l "Parameterizing Values Overview " on page 1527

l "Output Values Overview" on page 1488

property l GUI tests

l GUI
components

l API testing

For GUI testing: "Properties Pane User Interface (GUI
Testing)" on page 387

For API testing: "Properties Pane User Interface (API
Testing) " on page 402

recording l GUI tests

l GUI
components

"Recording GUI Tests and Components - Overview" on
page 843

recovery scenario l GUI tests

l GUI
components

"Recovery Scenarios Overview" on page 1112

references API testing "Add Reference Dialog Box" on page 485
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Term (A-Z) Relevant for: For details, see:

regular
expression

l GUI tests

l scripted
GUI
components

"Regular Expressions Overview" on page 318

repository
parameters

l GUI tests

l GUI
components

"SharedObject Repositories Overview" on page 1286

resources l GUI tests

l GUI
components

"Resources Pane (Test/Business Component Settings
Dialog Box) " on page 603

REST Service API testing l "REST Service Activities" on page 1735

l "How to a Create a REST Service" on page 1746

run results l GUI tests

l GUI
components

l API testing

HP RunResults Viewer User Guide

run session l GUI tests

l GUI
components

l API testing

l For GUI testing: "Running GUI Tests and
Components - Overview " on page 635

l For API testing: "Running API Tests - Overview " on
page 636

run-time object l GUI tests

l GUI
components

"How UFT Applies the Test Object Model Concept" on
page 1171

SOAP API testing "Web Service Scenario Overview" on page 1879

solution l GUI tests

l GUI
components

l API testing

"Solutions in UFT Overview" on page 471

User Guide
Appendix B: UFT Terminology Quick Reference

HP Unified Functional Testing (12.00) Page 2176 of 2274



Term (A-Z) Relevant for: For details, see:

statement
completion

l GUI tests

l scripted
GUI
components

l function
libraries

l API testing

"Statement Completion in the Editor" on page 306

step generator l GUI tests

l scripted
GUI
components

"Step Generator Dialog Box" on page 983

syntax errors l GUI tests

l GUI
components

l API testing

"Errors PaneOverview " on page 365

system monitor l GUI tests

l GUI
components

l "Local SystemMonitor" on page 585

l "Local SystemMonitor Pane (Test/Business
Component Settings Dialog Box / Application Area -
Additional Settings Pane)" on page 623

Test Batch
Runner

l GUI tests

l API testing

"Test Batch Runner Overview" on page 637

test loops API testing "Flow Control Activities" on page 1651

test object l GUI tests

l GUI
components

"Test Object Model - Overview" on page 1168

test variables API testing "How to Define API Test Properties or User/System
Variables" on page 141

text checkpoint

text area
checkpoints

l GUI tests

l scripted
GUI
components

"Checking Text Overview " on page 1408
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Term (A-Z) Relevant for: For details, see:

text recognition l GUI tests

l GUI
components

l "Text Recognition Overview" on page 1408

l "Text Recognition Pane (Options Dialog Box > GUI
Testing Tab)" on page 542

TODO comments l GUI tests

l scripted
GUI
components

l function
libraries

l API testing

l "Tasks PaneOverview" on page 498

l "Tasks Pane User Interface" on page 501

Toolbox l GUI actions

l GUI
components

function
libraries

l API testing

Business
process
tests and
flows

"Toolbox Pane" on page 505

Update Run Mode l GUI tests

l GUI
components

"Update RunMode " on page 1081

Update
Service/Assembly

API testing "UpdatingWeb Services" on page 1854

user code files API testing "Writing Code for API Test Events - Overview" on page
1938

Userlogger API testing "UserLogger Object" on page 2004

virtual object l GUI tests

l scripted
GUI
components

"Virtual Objects - Overview" on page 1385
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Term (A-Z) Relevant for: For details, see:

virtualized
services

API testing "Running Tests with Virtualized Services - Overview" on
page 665

Web services API testing "Web Service Activities " on page 1734

WSDL API testing l "Web Service Activities " on page 1734

l "How to Import aWSDL-BasedWeb Service" on
page 1744

XML checkpoints l GUI tests

l GUI
components

"XMLCheckpoints Overview" on page 1416

XPath
Checkpoints

API testing "XPath Checkpoints" on page 1613
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Appendix C: UFT Installation Utilities
Relevant for: GUI tests and components

This chapter describes the Additional Installation Requirements utility that enables you to configure
additional settings in Unified Functional Testing, launch the LicenseWizard during installation, and
install any prerequisite software for working with Unified Functional Testing.

This chapter includes:

Additional Installation Requirements Utility 2181
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Additional Installation Requirements Utility
Relevant for: GUI tests and components

Several prerequisites for working with UFTmust be installed and configured after UFT is installed.
In addition, to take advantage of UFT debugging and remote access features, certain Internet
Explorer and DCOM settings need to be configured.

The Additional Installation Requirements screen displays any prerequisite software that must be
installed or configured to work with UFT, according to the options selected when UFT is installed or
the installation is modified.

The Additional Installation Requirements utility enables you to configure the required settings
automatically, and to run the License InstallationWizard andMicrosoft Debugger installation during
the UFT installation.

l Select an option name in the Additional Installation Requirements dialog box to display a
description of the feature.

l Select the check box of one or more required options and click Run.

You can run the Additional Installation Requirements utility at any time by choosingStart > All
Programs > HP Software > HP Unified Functional Testing > Tools > Additional Installation
Requirements. In addition to the options to configure Internet Explorer and DCOM settings, and to
run the LicenseWizard, the dialog box displays any prerequisite software that is still required to be
installed to work with UFT.

Note: For details on accessing UFT and UFT tools and files inWindows 8, see "Accessing
UFT inWindows 8Operating Systems" on page 75.

Other Additional Installation Prerequisites
Additional installation requirements listed in the Additional Installation Requirements dialog box can
include the following, according to the options selected when UFT is installed or the installation is
modified:

l Microsoft Script Debugger. Provides the debugging environment that UFT uses during test
runs. This item is displayed only when not currently installed.

l Terminal Emulator Wizard. Provides a wizard that enables you to configure terminal emulator
identifying settings. This item is displayed only when the Terminal Emulator (TE) Add-in is
installed.

l Stingray Wizard. Provides a wizard that enables you configure UFT to work with your Stingray
application. This item is displayed only when the Stingray Add-in is installed.

Note: TheWeb Services Add-in is supported for backwards compatibility only and is not
enabled by default. New tests and components can use HP's API testing solution for web
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service testing purposes. To enable theWeb Services Add-in for previously created tests,
contact HP Software support.

In addition, the Additional Installation Requirements utility enables you to perform the following:

l Configure Internet Explorer settings. Select this check box to automatically configure the
Internet Explorer options that enable UFT to use theMicrosoft Script Debugger application
during test runs.

You can configure these options manually before running UFT. In Internet Explorer, select Tools
> Internet Options > Advanced. Then select Disable script debugging andEnable third-
party browser extensions.

l Configure DCOM settings for ALM Integration. Select this check box to automatically
change DCOM permissions and security settings and open a firewall port on your UFT
computer. These changes are only required if you want to run UFT tests remotely from ALM, and
are running UFT onWindows 7. If you need to set these options manually, see the topic on
Modifying DCOM Permissions Manually to Enable Remote Execution in theHP Unified
Functional Testing Installation Guide. You can also automatically configure DCOM later by
running the Additional Installation Requirements tool (Start > All Programs > HP Software >
HP Unified Functional Testing > Tools > Additional Installation Requirements) or
running the Remote Agent (<installation directory>\bin\AQTRmtAgent.exe).

l Configure DCOM settings for Automation Scripts. Select this check box to automatically
change DCOM permissions and security settings to enable another computer to remotely
control UFT using automation scripts.

Caution: Selecting this option enables remote users to control UFT on this machine,
exposing the UFT computer to security risks.

For information on how to configure this optionmanually, see the topic onModifying DCOM
Permissions Manually to Enable Remote Execution in theHP Unified Functional Testing
Installation Guide.

l Run License Installation Wizard. Select this check box to run the Unified Functional Testing
LicenseWizard. If you want to run UFT using the demo license for up to 30 days, do not select
this check box.

Note: This option is not automatically selected when upgrading from
QuickTest Professional version 9.5 or later because license data is retained. If you did not
install a license before the upgrade, select this check box to run the Unified Functional
Testing LicenseWizard.
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Appendix D: Understanding Unified Functional
Testing Licenses

Relevant for: GUI testing and API testing

This chapter provides a description of the Unified Functional Testing License Installation wizard
and the License Validation Utility.

This chapter includes:

Understanding the Unified Functional Testing License InstallationWizard 2184

Unified Functional Testing License Installation - License Type Screen 2184

Unified Functional Testing License Installation -Welcome Screen 2185

Unified Functional Testing License Installation - License Key Screen 2186

Unified Functional Testing License Installation - Install Summary Screen 2187

Unified Functional Testing License Installation - Finish Screen for Seat Licenses 2187

Unified Functional Testing License Installation - Concurrent License Server Screen 2188

Unified Functional Testing License Installation - Finish Screen for Concurrent Licenses 2189

Validating UFT Licenses 2190

License Information 2192

Validation Checks 2193

Copying Your License Validation Result to the Clipboard 2193

Setting the LSHOST or LSFORCEHOST Variable 2194

Troubleshooting and Limitations - UFT Licenses 2197
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Understanding the Unified Functional Testing License
Installation Wizard

Relevant for: GUI testing and API testing

The Unified Functional Testing License Installation wizard enables you to install a concurrent or
seat license for UFT, or change from one license type to the other. After you select the type of
license to install, you follow the steps of the wizard.

This section provides an overview of the Unified Functional Testing License InstallationWizard
screens. For more details about the Unified Functional Testing installation and the way the UFT
licensemechanism works, see theHP Unified Functional Testing Installation Guide.

This section describes the following:

Unified Functional Testing License Installation - License Type Screen 2184

Unified Functional Testing License Installation -Welcome Screen 2185

Unified Functional Testing License Installation - License Key Screen 2186

Unified Functional Testing License Installation - Install Summary Screen 2187

Unified Functional Testing License Installation - Finish Screen for Seat Licenses 2187

Unified Functional Testing License Installation - Concurrent License Server Screen 2188

Unified Functional Testing License Installation - Finish Screen for Concurrent Licenses 2189

Unified Functional Testing License Installation - License
Type Screen

Relevant for: GUI testing and API testing

In the License Type screen, you select the type of license with which you want to work. On server
operating systems this screen is not displayed and the "Unified Functional Testing License
Installation -Welcome Screen" is displayed automatically.

HP Unified Functional Testing (12.00) Page 2184 of 2274



The License Type screen contains the following options:

License
Type Description

Seat
license

A permanent license that is specific to the computer on which it is installed. When
you first install UFT, this license includes a 30-day demo period during which you
must contact HP to obtain a permanent seat license key. After you receive the
seat license key, you can activate it to work with UFT permanently.

For details, see "Unified Functional Testing License Installation -Welcome
Screen" below

Concurrent
license

A concurrent license regulates the number of UFT concurrent users. You can work
with a concurrent license only if a concurrent license server is installed on your
local network, and that license server has at least one available license that is not
currently in use.

For details, see "Unified Functional Testing License Installation - Concurrent
License Server Screen " on page 2188.

Unified Functional Testing License Installation -
Welcome Screen

Relevant for: GUI testing and API testing

After selecting the license type (as described in "Unified Functional Testing License Installation -
License Type Screen" on the previous page), theWelcome screen opens. TheWelcome screen
contains the following information:

Information Description

https://h30580.www3.hp.com/
poeticWeb/session/hppHome.htm

A link to the HP Licensing for Software Portal page. Click
this link to request a license key.

Information area The information you need to provide when requesting a seat
license.

l Product name. The name of the product and the version
number, for example, Unified Functional Testing.

l Locking code. A number used to uniquely identify the
computer. A locking code from one computer cannot be
used on another computer.

l Order number. The order number printed on the
Entitlement Certificate that was shipped with your LTU
or ELTU package.
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Requesting a License Key via the HP Licensing for Software Portal

The HP Software Licensing Portal assists you in requesting a license key.

For details on the various areas of the portal, see the links under theResources section on the left
side of theWeb page, such as the tutorial or the how-to demos.

Request your license key as described in the HP Software License Activation Quick Start Guide,
available from theResources area of the HP Software Licensing Portal.

Unified Functional Testing License Installation - License
Key Screen

Relevant for: GUI testing and API testing

After receiving your license key (described in "Unified Functional Testing License Installation -
Welcome Screen" on the previous page), you use the License Key screen to enter the license key
you received from HP. The license key is included in the .dat file attached to the email containing
your Permanent Password Certificate.

To install the license key:

1. Open the .dat file attached to the email containing your Permanent Password Certificate using
any text editor. The license key is also included in the Permanent Password Certificate.

2. Copy the license key (with or without the # character) from the .dat file to the clipboard.

3. Paste the key into the License Installation - License Key screen by clicking thePaste From

Clipboard button .

After you click Next, the "Unified Functional Testing License Installation - Install Summary Screen"
on the next page (described on page 2187) opens.

Notes:

l The license key is valid only for the computer with the locking code that you entered in the
license request form.

l A computer with multiple bootable partitions may generate a different locking code for each
partition. If a different locking code is generated for a partition, you will need to request a
unique license key for it.
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Unified Functional Testing License Installation - Install
Summary Screen

Relevant for: GUI testing and API testing

After installing your license (as described in "Unified Functional Testing License Installation -
License Key Screen" on the previous page), the Install Summary screen displays information about
the license you are about to install. The Install Summary screen contains the following information:

Information Description

License Name The name of the license you are installing, for example, Unified Functional
Testing.

License Type The type of license you are installing, for example, Seat License.

Expiration
Date

The time period for which the license is valid.

After the installation ends, the "Unified Functional Testing License Installation - Finish Screen for
Seat Licenses" (described on page 2187) opens.

Unified Functional Testing License Installation - Finish
Screen for Seat Licenses

Relevant for: GUI testing and API testing

The Finish screen displays information about the success of the seat license installation. If the
license installation is successful, a success message is displayed. If the license could not be
installed successfully, a message is displayed describing why. For example, if a seat license was
previously installed on your computer, and you try to install a seat license again using the same
license key, the license installation will not succeed.

The Finish screen also contains the Install another license check box. If you select this check
box and click Next, the license wizard opens the License Type screen, enabling you to install
another license.
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Unified Functional Testing License Installation -
Concurrent License Server Screen

Relevant for: GUI testing and API testing

After selectingConcurrent License in the "Unified Functional Testing License Installation -
License Type Screen" on page 2184, you can specify the concurrent license server to which you
want to connect. The Concurrent License Server screen has the following options:

Option Description

Concurrent
License
Server edit
box

Enables you to specify the concurrent license server to which you want to
connect. Note that the server must be accessible from the network. You can enter
the server's:

l host name, for example,MyServer orMyServer.com

l IP address, for example, 191.191.19.1    

Note:

l If you do not specify a concurrent license server, UFT will try to locate one
for you the next time you open UFT.

l If you want to specify the name of a concurrent license server that is
currently unavailable, but will be available later, you can enter the name of
the concurrent license server in the edit box. Even though the Concurrent
License Server screen informs you that the specified server is not
available for connection, the next time you open UFT, UFT will try to
locate the server you specified.

Check
Connection
button

Instructs UFT to check that the concurrent license server you specified is
accessible from the network.

Note: If you do not click theCheck Connection button, UFT checks the
connection for you when you click Next.
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Note:

When you specify one server name:

l The LSFORCEHOST environment variable is created with the server name you specified,
instructing UFT to search for available licenses only in the server you specified.

l If you already have an LSHOST environment variable defined, it is replaced with the new
LSFORCEHOST environment variable.

When you specify multiple server names or no server name:

l The LSHOST environment variable is created with all of the servers you specified (or none),
instructing UFT to search for available licenses first in the server you specified. If no
available licenses are found in the specified servers, it tries to locate a server elsewhere on
the network.

l If you already have an LSFORCEHOST environment variable defined, it will take
precedence over the new LSHOST variable. To enable the LSHOST variable, youmust
manually delete the LSFORCEHOST environment variable.

For more details, see "Setting the LSHOST or LSFORCEHOST Variable" on page 2194.

You can specify a different concurrent license server at any time by rerunning this wizard (Help >
License Wizard), or by modifying the LSHOST or LSFORCEHOST environment variable. For
details, see theHP Unified Functional Testing Installation Guide.

After the installation ends, the "Unified Functional Testing License Installation - Finish Screen for
Concurrent Licenses" opens.

Unified Functional Testing License Installation - Finish
Screen for Concurrent Licenses

Relevant for: GUI testing and API testing

The Finish screen displays information about the success of the concurrent license installation. If
the license is successful, a success message is displayed. UFT also displays an informative
message, if needed. For example, if UFT could not locate a concurrent license server on your
network, amessage informs you of this.

If you already have an LSFORCEHOST environment variable defined, it will take precedence over
the new LSHOST variable. To enable the LSHOST variable, youmust manually delete the
LSFORCEHOST environment variable.

For more details, see "Setting the LSHOST or LSFORCEHOST Variable" on page 2194.
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Validating UFT Licenses
Relevant for: GUI testing and API testing

The License Validation Utility decodes and validates UFT license strings. This enables you to view
and copy license information and license validation information for troubleshooting purposes.

The License Validation Utility performs the following operations:

l Decodes the license string and retrieves important information regarding the license. For details,
see "License Information" on page 2192.

l Validates the license according to a predefined set of checks. For details, see "Validation
Checks" on page 2193.

If required, you can copy the decoding and validation results to the clipboard. For details, see
"Copying Your License Validation Result to the Clipboard" on page 2193.

To decode and validate a license:

1. Select Start > All Programs > HP Software > HP Unified Functional Testing > Tools >
License Validation Utility.
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Note: For details on accessing UFT and UFT tools and files inWindows 8, see
"Accessing UFT inWindows 8Operating Systems" on page 75.

2. In the License Key box, enter the license code you want to decode and validate. You can find
the license code already installed on a UFT computer in the lservrc file. This file is usually
located in%APPDATA%\HP\Functional Testing\License.

Tip: Ensure that a # character is inserted at the end of the license code, or an error will be
reported in the License validation results area. The # indicates the end of the license
code, and any string after the # character is ignored by the License Validation Utility.

3. Click Validate. The license string is decoded.

License information is displayed in the License information area. For details, see "License
Information" on the next page.
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The result of the validation is displayed in the License validation results area. For details,
see "Validation Checks" on the next page.

4. If required, click Copy to copy the information to the clipboard. The copied information includes
the current computer locking code, the license string that was decoded, and the decoding and
validation results. For details, see "Copying Your License Validation Result to the Clipboard"
on the next page.

5. Click Close to close the utility.

License Information
Relevant for: GUI testing and API testing

The result of the decoding operation includes the following information about the license.

Note: Some information provided by the operation is intended for Software Support only and is
not described here.

l Feature Name. The UFT feature name specified when the license was created.

l Feature Version. The license version specified when the license was created. This is not the
UFT version number.

l Seat/Concurrent. The license type. This can be either aSeat license that is specific to the
computer on which it is installed, or aConcurrent license, which references a current license
server that can be used by multiple UFT users.

l Trial/Normal. The license type. It can be either a Trial license, which is a demo license that has
a limited period of use, or aNormal license.

l Trial Days Count. Applicable only for trial licenses. Specifies the number of days until the trial
period is over.

l Locking Code. The locking code specified when the license was created. This code uniquely
identifies the computer on which UFT is installed.

l Clock Tamper. Indicates whether a license can be issued, based on whether any date changes
have beenmade to the computer on which UFT is installed.

l Commuter License. Indicates whether commuter licenses are supported. A commuter license
enables you to work with UFT when you are not connected to the UFT concurrent license
server. Commuter licenses are available only with concurrent licenses. For details, see the
HP Unified Functional Testing Installation Guide.
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Validation Checks
Relevant for: GUI testing and API testing

The validation checks performed by the License Validation Utility include the following:

1. Does the UFT feature namematch one of the existing features?

2. Does the license versionmatch one of the existing versions?

3. Does the locking codematch the locking code of the computer on which UFT is installed?

4. Has the trial period specified in the license string ended?

5. If the license is a concurrent license, does it support commuter licenses?

Copying Your License Validation Result to the Clipboard
Relevant for: GUI testing and API testing

In some cases, youmay need a copy of the information provided by this utility. For example, you
may need to forward this information to Software Support.

When the validation operation is complete, click theCopy button to copy the information to the
clipboard. Then paste the information as required.
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Setting the LSHOST or LSFORCEHOST Variable
Relevant for: GUI testing and API testing

In addition to using the LicenseWizard to specify the concurrent license server to which you want
UFT to connect, you can also specify a concurrent license server usingWindows Environment
variables. For example, you can use the LSHOST variable to set the preferred concurrent license
server for a UFT client. If the specified concurrent license server cannot be found in the local
subnet, then a search is conducted on the entire network. Alternatively, you can use the
LSFORCEHOST variable to restrict UFT to a specific concurrent license server.

Note: If you activated a concurrent license using the License InstallationWizard and specified
a single server name, the LSFORCEHOST user variable is already defined with the concurrent
license server you specified, and cannot be replaced with the LSHOST variable by running the
License InstallationWizard again.

To set the LSHOST or LSFORCEHOST variables:

1. Open the Environment Variables dialog box. (Select Control Panel > System > Advanced
system settings > Environmental Variables button (forWindows 7 or Vista users) or
Control Panel > System > Advanced tab > Environmental Variables button (forWindows
XP users). The Environment Variables dialog box opens.)
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Note: If the concurrent license server is already defined using an LSHOST or
LSFORCEHOST system variable, you do not need to define it using the user variable.

2. UnderUser variables for <user name>, click New. The New User Variable dialog box
opens.

3. In theVariable Name box, type LSHOST or LSFORCEHOST.

4. In theVariable Value box, type the full name of the concurrent license server. Alternatively,
you can enter the IP address of the host computer.

Note:

n The LSHOST and LSHOSTFORCE environment variable values are limited to
64 characters.

n Formultiple host names (for example, where there are HP Functional Testing
Concurrent License Servers running on one network), use a semicolon (;) to separate
the host names or IP addresses in theVariable Value box.
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5. Click OK to close the New User Variable dialog box.

6. Click OK to close the Environment Variables dialog box.

7. Click OK to close the System Properties dialog box.

To delete the LSFORCEHOST variable:

1. In the User variables list of theWindows Environment Variables dialog box, select the
LSFORCEHOST variable.

2. Click Delete, and restart UFT for the changes to take effect.
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Troubleshooting and Limitations - UFT Licenses
Relevant for: GUI testing and API testing

This section describes troubleshooting and limitations for UFT licenses.

l As documented in theHP Unified Functional Testing Installation Guide, seat licenses are not
supported on server operating systems. In some cases, the license installation wizardmay not
disable the option to select Seat license on the operating system. If you do select it, the license
key installation will fail.

l When you connect to a Vista orWindows XP 64-bit operating system using a Remote Desktop
Connection, you cannot select to install a seat license or modify the UFT license type from
Concurrent toSeat.

Workaround: Open UFT on the physical computer to change the license type, or connect to the
computer using a console that does not create a session when it accesses the remote
computer.

l The HP Functional Testing Concurrent License Server does not support the use of Network
Address Translation (NAT).

l You cannot install UFT with a demo license over a QuickTest Professional installation whose
demo license has expired and for which a regular license was never installed.

l If the LSHOST variable was set to a server on another domain, the server utility lsmon.exe
might behave unexpectedly.

l The concurrent license does not include a demo license and does not work without an HP
Functional Testing Concurrent License Server and an installed license key.

l You cannot change the license type from seat to concurrent or vice versa when logged into the
machine without administrator privileges.

Workaround: To change the license type, log into themachine as a user with administrator
privileges.

l If version 6.0.0.8169 of Pdm.dll is found on your computer, the setup program will recognize this
during the UFT installation and will instruct you to download the corrected DLL from the
Microsoft site. For more details, see http://support.microsoft.com/kb/q293623/.

l Installing UFT on a network drive is not supported.

l Whenworking with a terminal server (for example, Windows 2003 server), youmust connect to
UFT using a concurrent license. Seat and demo licenses are not supported on terminal servers.

Workaround: Install a concurrent license server on the terminal server and then connect to it, or
connect to a concurrent license server that is installed on a different computer.
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Chapter E: Developing Custom Comparers for
Bitmap Checkpoints (GUI Testing)

Relevant for: GUI tests and components

This appendix is intended for COM programmers who want to customize the algorithm used to
compare bitmaps in bitmap checkpoints.

This chapter includes:

Concepts 2199

About Developing Custom Comparers for Bitmap Checkpoints 2199

Custom Comparer for Images Whose Location Changes in the Application - Use-Case
Scenario 2199

Custom Bitmap Comparer Development 2200

Tasks 2202

How to Develop a Custom Comparer 2202

How to Implement the Bitmap Comparer Interfaces 2204

How to Install Your Custom Comparer and Register it to UFT 2206

How to Use the Bitmap Checkpoint Custom Comparer Samples 2209

How to Develop a Custom Comparer - Tutorial 2211

Reference 2220

The Bitmap Checkpoint Comparer Interfaces 2220
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Concepts

About Developing Custom Comparers for Bitmap
Checkpoints

Relevant for: GUI tests and components

A custom comparer is a COM object that you develop to run the bitmap comparison in a bitmap
checkpoint according to a specific algorithm. This enables you to create bitmap checkpoints that
perform the comparison according to your needs.

By default, a bitmap checkpoint in UFT compares the actual and expected bitmaps pixel by pixel
and fails if there are any differences. UFT provides various bitmap checkpoint configuration options
that enable you to refine the bitmap comparison andmake it more flexible. For example, you can
define tolerance levels, or you can instruct UFT not to compare complete images, but rather
compare selected areas within them, or to locate a specific image within an object in your
application. For more details, see "Bitmap Checkpoints Overview" on page 1401.

If you need to further customize the way bitmaps are compared in checkpoints, you can develop
custom comparers and install and register them on the UFT computer. A UFT user can then choose
to use a custom comparer to perform the comparison in a bitmap checkpoint (on a per checkpoint
basis).

The COM object that you developmust implement interfaces that UFT provides in a type library,
and register to the component category that UFT defines for bitmap comparers. The type library
(BitmapComparer.tlb) and the category ID (defined inComponentCategory.h) are available in <UFT
installation folder>\dat\BitmapCPCustomization.

When a UFT user creates or edits a bitmap checkpoint, UFT displays any registered custom
comparers in the advanced settings in the Bitmap Checkpoint Properties dialog box (in addition to
the UFT default comparer). The user can then select a comparer according to the testing
requirements of the specific application or bitmap being tested. For more details about using
custom comparers in UFT, see "Custom Comparers" on page 1404.

You can find an example of a situation where developing a custom comparer enhanced the use of
bitmap checkpoints, in "Custom Comparer for Images Whose Location Changes in the Application
- Use-Case Scenario" below.

Custom Comparer for Images Whose Location Changes
in the Application - Use-Case Scenario

Relevant for: GUI tests and components

Ben is a quality assurance engineer who is experienced in using UFT, and often uses bitmap
checkpoints to test the appearance of different icons or pictures in the user interface he is testing.
He does not have a programming background.

Joanne is a software engineer who is experienced in image processing and is familiar with COM
programming.
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When Ben began testing the user interface of a furniture purchasing application, he created a
bitmap checkpoint to test that the pictures of the items on sale were displayed properly. In the
checkpoint, he captured an image of the pane in the application that contained the pictures he
wanted to test. Ben found that the bitmap checkpoint often failed, even though the graphic images
displayed in the application during the run seemed identical to the ones he had captured when
creating the checkpoint.

Ben reviewed the actual, expected, and difference bitmaps displayed in the run results. He also
took a closer look at the application's user interface. The application contained three panes. The left
pane displayed general information, themiddle pane displayed the pictures of the items on sale, and
the right pane displayed the corresponding list of items and relevant details. Ben found that
depending on the information displayed in the left pane, the images in themiddle pane sometimes
shifted slightly one way or the other within the pane. While the images themselves were still
identical, their changed location was causing the bitmap checkpoint to fail.

Ben did not want to use pixel tolerance to address this issue because he wanted the checkpoint to
fail when the pixels within the images themselves were not identical.

When Benmentioned his problem to a co-worker, she suggested that developing a custom
comparer for his bitmap checkpoints could solve the problem, and referred him to Joanne. Joanne
developed a custom comparer that would accept as input the number of pixels that the images
should be allowed to shift without failing the checkpoint. The bitmap comparison that Joanne
designed would pass the checkpoint only if the images were identical and they had all shifted by the
same number of pixels. This way, Ben knew that his checkpoint would still catch incorrect images
and cases where the application's interface looked bad because the images were no longer aligned.

Ben installed and registered the custom comparer on his UFT computer, and then selected the new
custom comparer for his bitmap checkpoint. After some experimenting, he found the optimal
number of pixels to enter in the configuration string, so that significant changes in the application's
interface were detected, but insignificant shifting of the images did not cause the checkpoint to fail.

After Ben successfully used this custom comparer for a while, his company decided to install and
register it on all of the UFT computers. The custom comparer would now be available to everyone in
the quality assurance team to use for similar situations.

Custom Bitmap Comparer Development
Relevant for: GUI tests and components

To develop a custom comparer, you create a COM object that implements the UFT bitmap
checkpoint comparer interfaces (described on page 2220) to perform the following:

l Accept input from UFT and perform the bitmap comparison.

l Provide comparison results to UFT.

l (Optionally) Provide information that UFT can display in the advanced settings in the Bitmap
Checkpoint Properties dialog box when a user creates or edits a bitmap checkpoint.

Custom comparers run within the UFT context. Youmust therefore exercise care when developing
your custom comparer, as its behavior and performance will affect the behavior and performance of
UFT.
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For UFT to recognize the custom comparer, it must be registered to the component category that
UFT defines for bitmap comparers. Depending on how you implement your custom comparer, you
can design the comparer to register itself when it is installed, or you can provide an additional
program that needs to be run at the time of installation. For details, see "How to Install Your Custom
Comparer and Register it to UFT" on page 2206.

Perform the tutorial in "How to Develop a Custom Comparer - Tutorial" on page 2211 to learn how to
create and use a custom comparer. You can then create your own custom comparers in much the
sameway. For task details, see "How to Develop a Custom Comparer" on the next page.

In addition to the tutorial, UFT provides source files that implement a sample custom comparer in
different languages. The source files are provided in C++ and in Visual Basic. Both projects
generate a similar custom comparer.

You can study the samples to help you learn about developing custom comparers for UFT bitmap
checkpoints, or use them as a reference or template when you develop your own custom
comparers. For details, see "How to Use the Bitmap Checkpoint Custom Comparer Samples" on
page 2209.
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Tasks

How to Develop a Custom Comparer
Relevant for: GUI tests and components

This task describes the process for developing a custom bitmap comparer.

Tip: To practice performing this task, see "How to Develop a Custom Comparer - Tutorial" on
page 2211.

This task includes the following steps:

l "Prerequisites" on page 2209

l "Develop the custom comparer COM object" below

l "Prepare the custom comparer installation - optional " below

l "Install the custom comparer" on the next page

l "Test the custom comparer" on the next page

1. Prerequisites
n Knowledge of image processing

n Experience in developing COM objects

2. Develop the custom comparer COM object
a. Create the custom comparer COM object. You can use any language and development

environment that supports creating COM objects.

Note: Depending on the language that you use for development, youmight be able to
specify the custom comparer namewhen you create the COM object. Otherwise the
name can be specified on the UFT computer after registering the object. For details,
see "Set the Custom Comparer Name - Optional" on page 2208.

b. Program your COM object to implement the custom comparer interfaces. For details, see
"How to Implement the Bitmap Comparer Interfaces" on page 2204.

3. Prepare the custom comparer installation - optional
Your custom comparer might need to be installed onmore than one computer. You can create a
program that automatically performs the steps necessary to install and register the comparer
and its documentation on those computers.
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For details on the steps that such a program needs to perform, see "How to Install Your
Custom Comparer and Register it to UFT" on page 2206.

For example, when you design your custom comparer installation, youmust ensure that when
it is installed on the UFT computer, it is also registered to the component category for UFT
bitmap comparers. This can be achieved in different ways, such as:

n If you develop your custom comparer in C++ usingMicrosoft Visual Studio, you canmodify
theDllRegisterServer andDllUnregisterServermethods to handle this registration. These
methods are called when you run a .dll using the regsvr32.exe program. You can see an
example of this type of implementation in "How to Develop a Custom Comparer - Tutorial"
on page 2211.

n If you develop your custom comparer in an environment that does not enable you tomodify
the registrationmethods, you can add an additional program that handles this registration
and instruct users who install the custom comparer to run this program as well. You can see
an example of this type of implementation in the Visual Basic sample custom comparer that
UFT provides. For more details, see "How to Use the Bitmap Checkpoint Custom
Comparer Samples" on page 2209.

4. Install the custom comparer
On the computer where you want to use the custom comparer, do one of the following:

n Run the installation program that automatically installs and registers the comparer.

n Manually install and register the custom comparer. For details, see "How to Install Your
Custom Comparer and Register it to UFT" on page 2206.

5. Test the custom comparer
Create bitmap checkpoint steps in a test or component in UFT. In the Bitmap Checkpoint
Properties dialog box, click Advanced settings, select your custom comparer, and use it to
perform bitmap checkpoints and check that they perform correctly.

Tip: By default, UFT displays expected, actual, and difference bitmaps in the Run
Results only for checkpoints that fail. When you test your custom comparer on UFT, you
might want to see the expected, actual, and difference bitmaps in the run results even for
bitmap checkpoints that pass. To configure this, select Tools > Options > GUI Testing
tab > Screen Capture node in UFT and set theSave still image captures to results
option toAlways. For more details on using this option, see "Screen Capture Pane
(Options Dialog Box > GUI Testing Tab)" on page 557.
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How to Implement the Bitmap Comparer Interfaces
Relevant for: GUI tests and components

This task describes how to implement the bitmap comparer interfaces so that your custom
comparer COM object performs the following:

l Accepts bitmaps and compares them

l Provides comparison results to UFT

l Provides information for the advanced settings in the Bitmap Checkpoint Properties dialog box

Note: This task is part of a higher-level task. For details, see "How to Develop a Custom
Comparer" on page 2202.

This task includes the following steps:

l "Prerequisite - Reference the type library" below

l "Implement the CompareBitmaps method to accept input and compare bitmaps" below

l "Implement the CompareBitmaps method to return the comparison results to UFT" on the next
page

l "Implement IBitmapCompareConfiguration to provide information for the Bitmap Checkpoint
Properties dialog box" on the next page

Prerequisite - Reference the type library
In the COM object that you develop, reference the type library that UFT provides (located in <UFT
installation folder>\dat\BitmapCPCustomization\BitmapComparer.tlb)

Implement the CompareBitmaps method to accept input and compare
bitmaps
UFT calls the "The CompareBitmaps Method" on page 2220method in the IVerifyBitmap
interface (described on page 2220) to pass the expected and actual bitmaps to the custom
comparer for comparison.

Method syntax:

HRESULT CompareBitmaps ([in] IPictureDisp* pExpected,
[in] IPictureDisp* pActual,
[in] BSTR bstrConfiguration,
[out] BSTR* pbstrLog,
[out] IPictureDisp** ppDiff,
[out, retval] VARIANT_BOOL* pbMatch);
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Implement the "The CompareBitmaps Method" on page 2220method to perform the following:

l Accept and compare two bitmaps according to a predefined algorithm that you define based on
the testing requirements.

l Accept a text string that can contain configuration information provided by the UFT user (in the
Bitmap Checkpoint Properties dialog box, Advanced settings), and use it in the comparison. For
example, the string could contain tolerance specifications, acceptable deviations in size or
location of the image, or any other information that you want to affect the comparison.

The string can have any format you choose (XML, comma separated, INI file style, and so on).
Make sure that the documentation you provide for the custom comparer describes the format. The
configuration input that the UFT user enters in the advanced settings in the advanced settings in
the Bitmap Checkpoint Properties dialog box must conform to this format.

Implement the CompareBitmaps method to return the comparison results
to UFT
UFT displays the results of bitmap checkpoints in the Run Results Viewer.

When you implement the "The CompareBitmaps Method" on page 2220method in the
IVerifyBitmap interface (described on page 2220) to compare the bitmaps, youmust also return the
following information:

l Whether the bitmaps match and the checkpoint should pass.

l A text string that UFT displays in the run results.

The purpose of this string is to provide information about the comparison to the UFT user, but
while you develop and test your comparer, you can use this string for debugging purposes as
well.

l A bitmap that visually represents the difference between the actual and expected bitmaps.

The purpose of this bitmap is to help the UFT user understand why the checkpoint failed. The
custom comparer can create this bitmap using any visualization approach you choose. For
example, the default UFT comparer creates a black-and-white bitmap containing a black pixel
for every pixel that is different in the two images.

Implement IBitmapCompareConfiguration to provide information for the
Bitmap Checkpoint Properties dialog box
When aUFT user selects a custom comparer in the advanced settings of the Bitmap Checkpoint
Properties dialog box, UFT displays an input text box, and, optionally, a link to documentation
provided for the custom comparer. For details, see "Custom Comparers" on page 1404.

To support these options, you can implement the IBitmapCompareConfiguration interface
(described on page 2222) to provide the necessary information for the dialog box.

l Implement the "The GetDefaultConfigurationString Method" on page 2222method to return
the default configuration string for your custom comparer.
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Method syntax:

HRESULT GetDefaultConfigurationString ([out, retval] BSTR* pbstrConfiguration);

UFT displays this string in the Input box in the advanced settings in the Bitmap Checkpoint
Properties dialog box.

The format of this stringmust be the same as the format of the configuration string that the
comparer expects as input.

l Implement theGetHelpFilenamemethod to return a path to the documentation about your
custom comparer. A UFT user can then access the documentation from the advanced settings
in the Bitmap Checkpoint Properties dialog box.

Method syntax:

HRESULT GetHelpFilename ([out, retval] BSTR* pbstrFilename);

The documentation can be in any format that you choose. UFT opens the documentation using
the program associated with the provided file type on the user's computer. Therefore, you should
provide the documentation in a format for which you expect the UFT user to have the necessary
program.

The documentation should provide the UFT user with the following information:

n The type of comparison the custom comparer performs (to enable the user to determine when
to use it to run a bitmap checkpoint).

n The required format for the configuration string and the possible values it can contain.

n An explanation of the comparison result information that is displayed in the run results (text
string and difference bitmap).

How to Install Your Custom Comparer and Register it to
UFT

Relevant for: GUI tests and components

The custom comparer must be installed and registered on any computer that runs a test or
component with a bitmap checkpoint using the custom comparer.

This task describes how to install the custom comparer on a UFT computer and register it to UFT.

l When you develop a custom comparer, you can create a program that automatically performs
the steps in this task. If you choose not to create an installation program, review these steps and
make sure to provide your users with all of the required files and information.
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l When you install a custom comparer that you did not develop, youmay need additional
information from the developer to perform the steps in this task. Alternatively, youmay receive
an installation program from the developer that performs this task automatically.

Note: This task is part of a higher-level task. For details, see "How to Develop a Custom
Comparer" on page 2202.

This task includes the following steps:

l "Prerequisites" below

l "Install the custom comparer COM object on the UFT computer" below

l "Register the custom comparer to the component category for UFT bitmap comparers " below

l "Place the custom comparer documentation in the correct location" on the next page

l "Set the Custom Comparer Name - Optional" on the next page

l "Results" on the next page

Prerequisites

1. More than one custom comparer can be installed and registered on the sameUFT computer.

However, before installing and registering a new version of a specific custom comparer,
unregister the existing comparer.

2. A custom comparer .dll is created using a specific development environment version. Make
sure that the computer on which this .dll runs has the corresponding runtime environment
installed.

Install the custom comparer COM object on the UFT computer
For example, you can do this by double-clicking the .dll or running the .dll using the regsvr32.exe
program.

Register the custom comparer to the component category for UFT bitmap
comparers
Register the component category ID for UFT bitmap comparers, CATID_QTPBitmapComparers,
as a registry key under the COM object's HKEY_CLASSES_
ROOT\CLSID\<Object's CLSID>\Implemented Categories key.

Note:WhenUFT is installed, it adds this component category ID as a registry key under the
HKEY_CLASSES_ROOT\Component Categories key. The component category ID is
defined in <UFT installation folder>\dat\BitmapCPCustomization\
ComponentCategory.h.
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Place the custom comparer documentation in the correct location
The Bitmap Checkpoint Properties dialog box in UFT can display documentation about the custom
comparer, if such documentation is provided.

Place the custom comparer documentation in the location specified in the custom comparer
object's GetHelpFilenamemethod.

Set the Custom Comparer Name - Optional
UFT displays the name of the custom comparer in the advanced settings in the Bitmap Checkpoint
Properties dialog box and in the Run Results Viewer. The name that UFT uses is the value (in the
registry) of the default property of the custom comparer ProgID key under theHKEY_CLASSES_
ROOT key. For example, in the image below, the name of the custom comparer is Sample
Custom Comparer.

l In some environments you set the namewhile developing the object. For example if the custom
comparer is developed in C++ usingMicrosoft Visual Studio, this name can be specified during
development in the Type box in the ATL Simple Object Wizard.

l In other environments, you can set or customize the name as part of the installation or
registration process on each computer. For example, if the custom comparer is developed in
Visual Basic, this registry value is automatically set to the COM object's ProgID. If you want to
modify the custom comparer name, you can edit it manually in the registry after the comparer is
installed, or design the program that performs the installation and registration to edit this value as
well.

Results
In the advanced settings in the Bitmap Checkpoint Properties dialog box, UFT displays the
comparer you installed and registered, along with all of the available custom comparers, and the
UFT default comparer. You can then select the appropriate comparer to use for each bitmap
checkpoint.
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How to Use the Bitmap Checkpoint Custom Comparer
Samples

Relevant for: GUI tests and components

This task describes how to generate the sample custom comparer, and then register it and work
with it.

This task includes the following steps:

l "Prerequisites" below

l "Generate the sample comparer" below

l "Install the custom comparer on a UFT computer" below

l "Register the custom comparer to the component category for UFT bitmap comparers" below

l "Study the custom comparer functionality" on the next page

1. Prerequisites
Decide whether you want to use the sample C++ project or the Visual Basic one.

The samples are located under <UFT installation folder>\samples\BitmapCPSample.

2. Generate the sample comparer
a. To open the sample project, do one of the following:

o To open the C++ project, useMicrosoft Visual Studio 2003 or later.

o To open the Visual Basic project, useMicrosoft Visual Studio 6.0.

b. Compile the custom comparer, to build the .dll.

Note: If you are usingMicrosoft Visual Studio 2010 to compile the C++ project, make
the followingmodification before compiling: Open the stdafx.h file in
<UFT installation folder>\samples\BitmapCPSample\CPPCustomComparer, locate
the line #define _WIN32_WINNT 0x0400 and change it to #define _WIN32_WINNT
0x0501.

3. Install the custom comparer on a UFT computer
Run the custom comparer using the regsvr32.exe program to install it on the computer.

4. Register the custom comparer to the component category for UFT
bitmap comparers
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n If you are using the C++ sample project:

The C++ sample sources implement registering the custom comparer to UFT in the
DllRegisterServer andDllUnregisterServermethods. Therefore, if you used the C++
project to create the .dll, running the .dll (in the previous step) will also register the custom
comparer.

Note: The name displayed for the custom comparer in UFT will beCustom QTP
Bitmap Comparer.

n If you are using the Visual Basic sample project:

The Visual Basic sample project does not implement this registration. Therefore, the Visual
Basic sample also includes an additional tool that youmust run after installing the custom
comparer, to register the custom comparer to the component category for UFT bitmap
comparers. For more details, see "How to Install Your Custom Comparer and Register it to
UFT" on page 2206.

You can run the Visual Basic Comparer Registration Tool from
<UFT installation folder>\samples\BitmapCPSample\VBCustomComparer\RegisterCateg
ory.exe.

In the dialog box that opens, enter the ProgID of the custom comparer and click Register.

Note: The name displayed for the custom comparer in UFT will be its ProgId—
VBCustomComparer.BitmapComparer. For details onmodifying this name, see
"Set the Custom Comparer Name - Optional" on page 2208.

5. Study the custom comparer functionality
Create bitmap checkpoint steps in a test or component in UFT. In the advanced settings in the
Bitmap Checkpoint Properties dialog box, you can select the sample custom comparer and
use it to perform bitmap checkpoints.

a. Note the customized information that is displayed in the dialog box when you select the
custom comparer.
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o The default configuration string that the sample comparer returns (and UFT displays in
the Bitmap Checkpoint Properties dialog box) is MaxSurfAreaDiff=140000.

o The documentation provided with this sample comparer (and opened from the Bitmap
Checkpoint Properties dialog box) is theSampleComparerDetails.txt text file located in
<UFT installation folder>\samples\BitmapCPSample\
CPPCustomComparer.

b. Run bitmap checkpoints to test the behavior of the sample comparer. For example, you
can run checkpoints on theWindows Calculator application, alternately setting the
Calculator view toStandard orScientific, to obtain different size bitmaps for the same
object.

The sample custom comparer does not compare the content of the actual and expected
bitmaps. It compares the total number of pixels they contain. For configuration input, this
comparer expects a string that defines theMaxSurfAreaDiff parameter. The comparer fails
the checkpoint if the difference in total number of pixels is greater than the number defined
forMaxSurfAreaDiff.

c. View the results of your checkpoint in the run results.

This sample bitmap custom comparer returns the actual bitmap as the difference bitmap. In
addition, it provides a text string that specifies the difference in total number of pixels. UFT
displays this string in the run results.

How to Develop a Custom Comparer - Tutorial
Relevant for: GUI tests and components

This tutorial walks you step-by-step through the process of creating a custom comparer in C++
usingMicrosoft Visual Studio. The custom comparer you create is similar to the sample custom
comparer provided with UFT. You can create your own custom comparers in a similar way. For
details about the sample custom comparer, see "How to Use the Bitmap Checkpoint Custom
Comparer Samples" on page 2209.

Note: For a task related to this tutorial, see "How to Develop a Custom Comparer" on page
2202.

By following the instructions in this section, you create a COM object that:

l Implements theCompareBitmapsmethod to receive two bitmaps to compare and a
configuration string, compare the (size of) the two bitmaps, and return the necessary results.

l Implements theGetDefaultConfigurationStringmethod and theGetHelpFilenamemethod, to
return the information that UFT displays in the advanced settings in the Bitmap Checkpoint
Properties dialog box.

l Registers to the component category for UFT bitmap comparers.
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When the design of your custom comparer is complete, you can install and register it and use it in
UFT to run a bitmap checkpoint.

Note: Depending on the version of Microsoft Visual Studio that you use to perform the tutorial,
the command names may be different.

This tutorial includes the following steps:

l "Create a new ATL project—SampleCPPCustomComparer" below

l "Create a new class—CBitmapComparer" below

l "Define that the CBitmapComparer class implements the bitmap checkpoint comparer
interfaces" on the next page

l "Move the function bodies for the bitmap checkpoint comparer interfacemethods from
BitmapComparer.h to BitmapComparer.cpp" on the next page

l "Implement the bitmap checkpoint comparer interfacemethods to customize the bitmap
checkpoint as required" on page 2215

l "Design your custom comparer to register to the component category for UFT bitmap
comparers" on page 2217

l "Compile your DLL and run it using the regsvr32.exe program" on page 2218

l "Test your custom comparer by using it for bitmap checkpoints in UFT" on page 2218

1. Create a new ATL project—SampleCPPCustomComparer
a. In Microsoft Visual Studio, select New > Project. The New Project dialog box opens.

b. Select theATL Project template, enterSampleCPPCustomComparer in theName box for
the project, and click OK. The New ATL Project wizard opens.

c. InApplication Settings, make sure that theAttributed option is not selected, and click
Finish.

2. Create a new class—CBitmapComparer
a. In the class view, select theSampleCPPCustomComparer project, right-click, and

select Add > Class. The Add Class dialog box opens.

b. Select ATL Simple Object and click Add. The ATL Simple Object Wizard opens.

c. In theShort name box, enterBitmapComparer. The wizard uses this name to create the
names of the class, the interface, and the files that it creates.

d. In the Type box, enterSample Custom Comparer. This is the custom comparer name that
UFT will display in the advanced settings in the Bitmap Checkpoint Properties dialog box
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and in the run results. For details, see "Set the Custom Comparer Name - Optional" on
page 2208.

e. Click Finish. The wizard creates the necessary files for the class that you added, including
.cpp and .h files with implementation of CBitmapComparer class.

3. Define that the CBitmapComparer class implements the bitmap
checkpoint comparer interfaces
a. In the class view, select CBitmapComparer, right-click, and select Add > Implement

Interface. The Implement Interface wizard opens.

b. In the Implement interface from option, select File. Browse to or enter the location of the
UFT bitmap checkpoint comparer type library. The type library is located in: <UFT
installation folder>\dat\BitmapCPCustomization\
BitmapComparer.tlb.

The wizard displays the interfaces available in the selected type library,
IBitmapCompareConfiguration and IVerifyBitmap.

c. Add both interfaces to the list of interfaces to implement, and click Finish.

In theBitmapComparer.h file, the wizard adds the declarations, classes, andmethod stubs
that are necessary to implement the interfaces. In subsequent steps you will need to add
implementation to thesemethod stubs.

Note: In Microsoft Visual Studio 2005, the wizard generates the signature for the
CompareBitmapsmethod in the IVerifyBitmap interface incorrectly. To enable your
project to compile correctly, manually change the type of the last argument (pbMatch)
from BOOL* toVARIANT_BOOL*.

4. Move the function bodies for the bitmap checkpoint comparer interface
methods from BitmapComparer.h to BitmapComparer.cpp
a. Open theBitmapComparer.h andBitmapComparer.cpp files.

b. InBitmapComparer.h, create declarations for the bitmap checkpoint comparer interface
methods (based on the function bodies that the wizard created): CompareBitmaps,
GetDefaultConfigurationString, andGetHelpFilename.

c. Move the function bodies that the wizard created for the bitmap checkpoint comparer
interfacemethods from theBitmapComparer.h file to theBitmapComparer.cpp file.
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At the end of this step, BitmapComparer.cpp andBitmapComparer.h should contain the
following code:

// BitmapComparer.cpp : Implementation of CBitmapComparer
#include "stdafx.h"
#include "BitmapComparer.h"
// CBitmapComparer
// IBitmapCompareConfiguration Methods
STDMETHODIMPCBitmapComparer::GetDefaultConfigurationString

(BSTR * pbstrConfiguration)
{

return E_NOTIMPL;
}
STDMETHODIMPCBitmapComparer::GetHelpFilename(BSTR * pbstrFilename)
{

return E_NOTIMPL;
}
// IVerifyBitmap Methods
STDMETHODIMPCBitmapComparer::CompareBitmaps

(IPictureDisp * pExpected, IPictureDisp * pActual,
                        BSTR bstrConfiguration, BSTR * pbstrLog,
                        IPictureDisp * * ppDiff, VARIANT_BOOL * pbMatch)
{

return E_NOTIMPL;
}

// BitmapComparer.h : Declaration of the CBitmapComparer
#pragma once
#include "resource.h" // main symbols
#include "SampleCPPCustomComparer.h"
// CBitmapComparer
class ATL_NO_VTABLECBitmapComparer :
        public CComObjectRootEx<CComSingleThreadModel>,
        public CComCoClass<CBitmapComparer, &CLSID_BitmapComparer>,
        public IDispatchImpl<IBitmapComparer, &IID_IBitmapComparer,
                    &LIBID_SampleCustomComparerLib, /*wMajor =*/ 1, /*wMinor =*/ 0>,
        public IDispatchImpl<IBitmapCompareConfiguration,
                    &__uuidof(IBitmapCompareConfiguration),
                    &LIBID_BitmapComparerLib, /* wMajor = */ 1, /*wMinor =*/ 0>,
        public IDispatchImpl<IVerifyBitmap, &__uuidof(IVerifyBitmap),
                    &LIBID_BitmapComparerLib, /* wMajor = */ 1, /*wMinor =*/ 0>
{
    public:
        CBitmapComparer()

{
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        }
        DECLARE_REGISTRY_RESOURCEID(IDR_BITMAPCOMPARER)
        BEGIN_COM_MAP(CBitmapComparer)
            COM_INTERFACE_ENTRY(IBitmapComparer)
            COM_INTERFACE_ENTRY2(IDispatch, IBitmapCompareConfiguration)
            COM_INTERFACE_ENTRY(IBitmapCompareConfiguration)
            COM_INTERFACE_ENTRY(IVerifyBitmap)
        END_COM_MAP()
        DECLARE_PROTECT_FINAL_CONSTRUCT()
        HRESULT FinalConstruct()

{
            return S_OK;
        }
        void FinalRelease() {}
        // IBitmapCompareConfiguration Methods
public:
        STDMETHOD(GetDefaultConfigurationString)(BSTR * pbstrConfiguration);
        STDMETHOD(GetHelpFilename)(BSTR * pbstrFilename);
        // IVerifyBitmap Methods
public:
        STDMETHOD(CompareBitmaps)(IPictureDisp * pExpected,

IPictureDisp * pActual, BSTR bstrConfiguration, BSTR * pbstrLog,
                    IPictureDisp * * ppDiff, VARIANT_BOOL * pbMatch);
};
OBJECT_ENTRY_AUTO(__uuidof(BitmapComparer), CBitmapComparer)

5. Implement the bitmap checkpoint comparer interface methods to
customize the bitmap checkpoint as required
In this tutorial, you implement a custom comparer similar to the sample custom comparer
provided with UFT. For details about the sample custom comparer, see "How to Use the
Bitmap Checkpoint Custom Comparer Samples" on page 2209.

When you create your own custom comparers, this is the step during which you design the
custom comparer logic. You define the configuration input that it can receive, the algorithm that
it uses to compare the bitmaps, and the output that it provides.

In theBitmapComparer.cpp file, add #include <atlstr.h>, and implement the bitmap checkpoint
comparer interfacemethods as follows:

n TheGetDefaultConfigurationStringmethod:

STDMETHODIMPCBitmapComparer::GetDefaultConfigurationString
(BSTR * pbstrConfiguration)

{
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        CComBSTR bsConfig("MaxSurfAreaDiff=140000");
        *pbstrConfiguration = bsConfig.Detach();
        return S_OK;
}

n TheGetHelpFilenamemethod:

STDMETHODIMPCBitmapComparer::GetHelpFilename(BSTR * pbstrFilename)

{
        CComBSTR bsFilename ("..\\samples\\BitmapCPSample\\

CPPCustomComparer\\SampleComparerDetails.txt");
        *pbstrFilename = bsFilename.Detach();
        return S_OK;
}

Note:When theGetHelpFilenamemethod returns a relative path, UFT searches for
this path relative to <UFT installation folder>\bin. The implementation above instructs
UFT to use the documentation file provided with the CPP sample custom comparer.

n TheCompareBitmapsmethod:

STDMETHODIMPCBitmapComparer::CompareBitmaps
(IPictureDisp * pExpected, IPictureDisp * pActual,

                                    BSTR bstrConfiguration, BSTR * pbstrLog,
                                    IPictureDisp * * ppDiff, VARIANT_BOOL * pbMatch)
{
        HRESULT hr = S_OK;
        if (!pExpected || !pActual)
            return S_FALSE;
        CComQIPtr<IPicture> picExp(pExpected);
        CComQIPtr<IPicture> picAct(pActual);
        // Try to get HBITMAP from IPicture
        HBITMAPHbmpExp, HbmpAct;
        hr = picExp->get_Handle((OLE_HANDLE*)&HbmpExp);
        if (FAILED(hr))
            return hr;
        hr = picAct->get_Handle((OLE_HANDLE*)&HbmpAct);
        if (FAILED(hr))
            return hr;
        BITMAP ExpBmp = {0};
        if( !GetObject(HbmpExp, sizeof(ExpBmp), &ExpBmp) )
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            return E_FAIL;
        BITMAP ActBmp = {0};
        if( !GetObject(HbmpAct, sizeof(ActBmp), &ActBmp) )
            return E_FAIL;
        CString s, tol;
        tol = bstrConfiguration;
        int EPos = tol.ReverseFind('=);
        tol = tol.Right(tol.GetLength() - EPos - 1);
        int maxSurfaceAreaDiff = _ttoi(tol);
        // Set output parameters
        CComPtr<IPictureDisp> Diff(pActual);
        *ppDiff = Diff;
        int DiffPixelsNumber = abs (ExpBmp.bmHeight * ExpBmp.bmWidth - ActBmp.bmHei
ght * ActBmp.bmWidth);
        *pbMatch = DiffPixelsNumber <=maxSurfaceAreaDiff;
        s.Format(_T("The number of different pixels is: %d."), DiffPixelsNumber);
        CComBSTR bs (s);
        *pbstrLog = bs.Detach();
        return hr;
}

6. Design your custom comparer to register to the component category
for UFT bitmap comparers
For UFT to recognize the COM object that you create as a custom comparer, youmust register
it to the component category for UFT bitmap comparers. The component category ID is defined
in <UFT installation folder>\dat\BitmapCPCustomization\
ComponentCategory.h.

You can implement this registration in theDllRegisterServer andDllUnregisterServer
methods in theSampleCPPCustomComparer.cpp file that the wizard created as part of your
project. Thesemethods are called when you run a DLL using the regsvr32.exe program.

a. Add the <UFT installation folder>\dat\
BitmapCPCustomization folder to your project's include path.

b. Open theSampleCPPCustomComparer.cpp file and add the following line: #include
"ComponentCategory.h"

c. In theSampleCPPCustomComparer.cpp file, modify theDllRegisterServer and
DllUnregisterServermethods created by the wizard, to contain the following code:

STDAPI DllRegisterServer(void)
{

// registers object, typelib and all interfaces in typelib
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HRESULT hr = _AtlModule.DllRegisterServer();
        CComPtr<ICatRegister> spReg;
        hr = spReg.CoCreateInstance

(CLSID_StdComponentCategoriesMgr, 0, CLSCTX_INPROC);
        if (FAILED(hr))
            return hr;
        // register comparer to the UFT bitmap comparers category
        CATID catid = CATID_QTPBitmapComparers;
        hr = spReg->RegisterClassImplCategories(CLSID_BitmapComparer, 1, &catid);
        return hr;
}

STDAPI DllUnregisterServer(void)
{
        HRESULT hr = _AtlModule.DllUnregisterServer();
        CComPtr<ICatRegister> spReg;
        hr = spReg.CoCreateInstance

(CLSID_StdComponentCategoriesMgr, 0, CLSCTX_INPROC);
        if (FAILED(hr))
            return hr;
        // unregister comparer from the UFT bitmap comparers category
        CATID catid = CATID_QTPBitmapComparers;
        hr = spReg->UnRegisterClassImplCategories(CLSID_BitmapComparer, 1, &catid);
        return hr;
}

Note the second section in thesemethods, that handles registration to the component
category for UFT bitmap comparers—CATID_QTPBitmapComparers.

7. Compile your DLL and run it using the regsvr32.exe program
Your custom comparer can now be used in UFT for bitmap checkpoints.

8. Test your custom comparer by using it for bitmap checkpoints in UFT
For details on how to work with bitmap checkpoints, see "Bitmap Checkpoints Overview" on
page 1401.

a. Open UFT and create a bitmap checkpoint on theWindows Calculator application
(Standard view).

The advanced settings in the Bitmap Checkpoint Properties dialog box include the
Comparer option, in which you can select the default UFT comparer or your sample
custom comparer.

b. Change the Calculator view toScientific. The size of the calculator object is now larger.
Run the checkpoint using the default UFT comparer. The checkpoint fails.
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c. Edit the checkpoint in the Bitmap Checkpoint Properties dialog box:

o Make sure theCompare selection with runtime bitmap checkpoint mode is
selected.

o Click Advanced settings to open the Advanced Settings dialog box, and select
Sample Custom Comparer in the Comparer Type box.

In the Input box, you can see the default configuration string returned by the
GetDefaultConfigurationStringmethod:MaxSurfAreaDiff=140000

In the Input box, you can see the default configuration string returned by the
GetDefaultConfigurationStringmethod:MaxSurfAreaDiff=140000

If you click Details, the text file containing documentation for the sample custom
comparer opens.

The comparer you designed in this exercise checks how different the expected and actual
bitmaps are in size, and fails the checkpoint if the difference is greater than the number of
pixels defined in the configuration string.

If you run the checkpoint using defaultMaxSurfAreaDiff value, the checkpoint passes,
because the difference in the total size of the calculator object when it is set to different
views is less than 140000 pixels (the difference is approximately 80000 pixels). If you set
MaxSurfAreaDiff to 70000, the checkpoint fails.

View the run results to see the text string and difference bitmap that your custom comparer
provides to UFT after the comparison.
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Reference

The Bitmap Checkpoint Comparer Interfaces
Relevant for: GUI tests and components

Your custom comparer must implement the interfaces described in this section. UFT calls these
interfaces' methods when creating or running a bitmap checkpoint that uses your custom comparer.

This section includes:

The IVerifyBitmap Interface 2220

The IBitmapCompareConfiguration Interface 2222

The IVerifyBitmap Interface

Relevant for: GUI tests and components

This interface contains theCompareBitmaps method that you need to implement to perform the
bitmap comparison for the checkpoint.

The CompareBitmaps Method
TheCompareBitmapsmethod receives the actual and expected bitmaps that need to be
compared for the bitmap checkpoint, and a string that can contain configuration input for the custom
comparer.

Themethodmust compare the bitmaps according to the comparison algorithm for which this
custom comparer is designed, and return the results to UFT.

The results include:

l An indication whether the bitmaps match and the checkpoint should pass.

l A text string that contains information about the results of the bitmap comparison.

l A bitmap that reflects the differences between the actual and expected bitmaps.

UFT displays the results that this method returns in the Run Results Viewer. For details, see the
section on Bitmap Checkpoint Results (described in theHP RunResults Viewer User Guide).

Method syntax:

HRESULT CompareBitmaps ([in] IPictureDisp* pExpected,
[in] IPictureDisp* pActual,
[in] BSTR bstrConfiguration,
[out] BSTR* pbstrLog,
[out] IPictureDisp** ppDiff,
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[out, retval] VARIANT_BOOL* pbMatch);

Method Parameters:

l pExpected. A picture object (input).

The expected bitmap stored in the checkpoint.

l pActual. A picture object (input).

The actual bitmap captured from the application being tested.

l bstrConfiguration. A text string (input).

A string that contains configuration input for the custom comparer. This is the string displayed in
the Input box in the advanced settings in the Bitmap Checkpoint Properties dialog box.

The string can be the default configuration string that the custom comparer provides to UFT in
theGetDefaultConfigurationStringmethod described below, or an input string entered by the
UFT user.

The bstrConfiguration string can have any format you choose (XML, comma separated, ini file
style, and so on). Make sure that the default configuration string returned by the
GetDefaultConfigurationStringmethodmatches the format expected in the
CompareBitmapsmethod. Additionally, make sure that the documentation you provide for your
custom comparer explains the format that the UFT user must use when editing this string in the
Input box.

l pbstrLog. A text string (output).

A string that contains information about the results of the bitmap comparison. UFT displays this
string in the Run Results Viewer.

l ppDiff. A picture object (output).

A bitmap (created by the custom comparer) that reflects the difference between the actual and
expected bitmaps. UFT displays this bitmap in the Run Results Viewer along with the actual
and expected bitmaps.

l pbMatch. A boolean value (output).

A value that indicates whether the bitmaps match and the checkpoint should pass.

Possible values:

n VARIANT_TRUE. Actual and expected bitmaps match, checkpoint passes.

n VARIANT_FALSE. Actual and expected bitmaps do not match, checkpoint fails.
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Return Value

The HRESULT that this method returns indicates whether the comparison ran successfully (and
not whether the bitmaps match).

The IBitmapCompareConfiguration Interface

Relevant for: GUI tests and components

This interface contains themethods that you need to implement to support the custom comparer
options that UFT displays in the advanced settings in the Bitmap Checkpoint Properties dialog box.
For details, see "Checkpoint Properties Dialog Box" on page 1432.

The GetDefaultConfigurationString Method
TheGetDefaultConfigurationStringmethodmust return the default configuration string for your
custom comparer. For details on configuration strings, see "Implement the CompareBitmaps
method to accept input and compare bitmaps" on page 2204.

UFT displays this string in the Input box in the advanced settings in the Bitmap Checkpoint
Properties dialog box when a user creating a new bitmap checkpoint selects your custom
comparer.

If the UFT user does not modify the input string in the dialog box, the string provided by
GetDefaultConfigurationString is passed to the custom comparer's CompareBitmapsmethod.
Youmust thereforemake sure that the default configuration stringmatches the format that your
custom comparer expects to receive in theCompareBitmapsmethod.

Method syntax:

HRESULT GetDefaultConfigurationString ([out, retval] BSTR* pbstrConfiguration);

The GetHelpFilename Method
TheGetHelpFilenamemethodmust return a path to the documentation that contains information
about your custom comparer for UFT users.

UFT displays the documentation when a user selects your custom comparer in the advanced
settings in the Bitmap Checkpoint Properties dialog box and clicks Details. Make sure that when
your custom comparer is installed, the documentation that you provide is installed in the location
specified by theGetHelpFilenamemethod.

The path can be one of the following:

l A full path to a file.

l A relative path to a file (UFT searches for this path relative to <UFT installation folder>\bin).

l A URL.

If you do not provide documentation for your custom comparer, this method should return the
HRESULT E_NOTIMPL. For details on the type of information you should provide, see "Implement
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IBitmapCompareConfiguration to provide information for the Bitmap Checkpoint Properties dialog
box" on page 2205.

Method syntax:

HRESULT GetHelpFilename ([out, retval] BSTR* pbstrFilename);
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Chapter F: GUI Checkpoints and Output Values
Per Add-in

Relevant for: GUI tests and components

The tables in this chapter show the categories of checkpoints and output values that are supported
by UFT for each add-in.

For details about using checkpoints and output values in a specific add-in, see the relevant add-in
section.

This chapter includes:

Supported Checkpoints 2225

Supported Output Values 2228
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Supported Checkpoints
Relevant for: GUI tests and components

The following table shows the categories of checkpoints that are supported by UFT for each add-in.

Table Legend

l S: Supported

l NS: Not Supported

l NA: Not Applicable

Note: Only standard and bitmap checkpoints are supported for keyword components.

For additional information, see "Footnotes" on page 2227.
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Footnotes

1 Text checkpoints are supported only for Page, Frame, and ViewLink objects.

2When you insert a checkpoint on a PowerBuilder DataWindow control, UFT treats it as a table
and opens the Table Checkpoint Properties dialog box.

3 For NETWeb Forms, text checkpoints forWbfTreeView, WbfToolbar, andWbfTabStrip objects
are not supported.

4 The text area checkpoint mechanism for Java Applet objects is disabled by default. You can
enable it in the Advanced JavaOptions dialog box.

5 This is supported only when UFT records HTML elements using theWeb infrastructure, but not
when it records using the SAPGui Scripting Interface (as selected in the SAP pane of the Options
dialog box).

6 This is supported only when UFT is configured to use the OCR (optical character recognition)
mechanism.

7 XML checkpoints are not supported on Internet Explorer 9 or later running in standardmode, on
Google Chrome, onMozilla Firefox, or on Apple Safari because theWebXML test object is not
supported for these browsers.

Note: For additional information about using text recognition in checkpoints, see "Guidelines
for Text Recognition" on page 1409.
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Supported Output Values
Relevant for: GUI tests and components

The following table shows the categories of output values that are supported by UFT for each add-
in.

Table Legend

l S: Supported

l NS: Not Supported

l NA: Not Applicable

Note: Only standard and bitmap output values are supported for keyword components.

For additional information, see "Footnotes" on page 2230.
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Footnotes

1 Text output values are supported only for Page, Frame, and ViewLink objects.

2When you insert an output value step on a PowerBuilder DataWindow control, UFT treats it as a
table and opens the Table Output Value Properties dialog box.

3 The text area output mechanism for Java Applet objects is disabled by default. You can enable it
in the Advanced JavaOptions dialog box.

4 This is supported only when UFT records HTML elements using theWeb infrastructure, but not
when it records using the SAPGui Scripting Interface (as selected in the SAP pane of the Options
dialog box).

5 This is supported only when UFT is configured to use the OCR (optical character recognition)
mechanism.

6 XML output values are not supported on Internet Explorer 9 or later running in standardmode, on
Google Chrome, or onMozilla Firefox, because theWebXML test object is not supported for these
browsers.

7 You can create text output values (tests only) only for TeScreen and TeTextScreen objects.

8 In the terminal emulator window you can add text checkpoints or output values (tests only) and
standard checkpoints and output values for the status bar and the dialog boxes that open from the
menu options. UFT recognizes these as standardWindows objects.
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Appendix G: Using Performance Testing and
Business Service Management Products with UFT
GUI Tests

Relevant for: GUI tests only

This chapter includes:

Concepts 2232

HP Performance Testing and Business ServiceManagement Products Overview 2232

Designing Tests for HP Performance Testing Products 2234

Running GUI Tests from HP Performance Testing Products 2234

Designing GUI Tests for HP Business Process Monitor 2235

Running GUI Tests from HP Business Process Monitor 2236

Measuring Transactions 2237

Silent Test Runner 2239

Tasks 2241

How to Insert and RunGUI Tests in Performance Center and LoadRunner 2241

Reference 2242

End Transaction Dialog Box 2242

Start Transaction Dialog Box 2243

Silent Test Runner Dialog Box 2244
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Concepts

HP Performance Testing and Business Service
Management Products Overview

Relevant for: GUI tests only

UFT enables you to create complex tests that examine the full spectrum of your application's
functionality to confirm that every element of your application works as expected in all situations.

After you use UFT to create and run a suite of tests that test the functional capabilities of your
application, youmay want to test how much load your application can handle or to monitor your
application as it runs.

l HP performance testing products (LoadRunner and Performance Center) test the
performance and reliability of an entire system under controlled and peak load conditions. To
generate load, these performance testing products run hundreds or thousands of virtual users.
These virtual users provide consistent, repeatable, andmeasurable load to exercise your
application just as real users would.

l HP Business Service Management (formerly HP Business Availability Center) enables
real-timemonitoring of the end user experience. Business Process Monitor runs synthetic users
to perform typical activities on themonitored application.

If you have already created and perfected a test in UFT that is a good representation of your user’s
actions, youmay be able to use your test as the basis for performance testing and application
management activities.

You can useSilent Test Runner to check in advance that a test will run correctly from
LoadRunner, Performance Center, and Business Process Monitor.

Features for Use with Performance Testing and Business Service
Management
UFT offers several features that are designed specifically for integration with LoadRunner,
Performance Center, and Business Process Monitor.

Note: These products are designed to run tests using virtual or synthetic users representing
many users simultaneously performing standard user operations. Some features may not be
available when integrating these products with UFT.

You can use theServices object and its associatedmethods to insert statements that are
specifically relevant to Performance Testing and Business ServiceManagement. These include:

AddWastedTime EndTransaction SetTransaction

EndDistributedTransaction LogMessage SetTransactionStatus
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GetEnvironmentAttribute Rendezvous ThinkTime

StartDistributedTransaction StartTransaction UserDataPointUserDataPoint

For details on thesemethods, see theServices section of theHP UFT Object Model Reference for
GUI Testing and your HP performance testing or Business ServiceManagement documentation.

For details on transactions, see "Measuring Transactions" on page 2237.

For details on insertingStartTransaction andEndTransaction statements using the UFTmenu
options, see "Start Transaction Dialog Box" on page 2243 and "End Transaction Dialog Box" on
page 2242.

Advantages of Running Tests in LoadRunner
Themain advantages of running tests in LoadRunner are:

l To check how your application's functionality is affected by heavy load

l Tomeasure the response time that a typical user experiences on the client side while your
application is under load (end-to-end response time)

For example, you can add tests to specific points in a LoadRunner scenario to confirm that the
application's functionality is not affected by the extra load at those sensitive points.

Another advantage of using a virtual GUI user (GUI Vuser) script as part of your LoadRunner
scenario is that the GUI Vuser script runs on your screen during the scenario, enabling you to watch
the actual steps executed by the Vuser in real time.

Designing Tests for Use HP Performance Testing and HP Business
Service Management Products
If you plan to use the same test in both UFT and LoadRunner, Performance Center, and/or
Business Process Monitor, you should take into account the different options supported in each
product as you design your test. For details, see:

l "Designing Tests for HP Performance Testing Products" on the next page

l "Designing GUI Tests for HP Business Process Monitor" on page 2235

Running Tests from HP Performance Testing and HP Business Service
Management Products
The runmechanisms used in all HP Performance Testing and HP Business ServiceManagement
products are the same. This means that you can create tests that are compatible with LoadRunner,
Performance Center, and Business Process Monitor, enabling you to take advantage of tests or
test segments that have already been designed and debugged in UFT.

For example, you can add tests to specific points in a performance test to confirm that the
application's functionality is not affected by the extra load at those sensitive points. You can also
run tests on Business Process Monitor to simulate end user experience and ensure that your
application is running correctly and in a timely manner.
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If you plan to use the same test in both UFT and LoadRunner, Performance Center, and/or
Business Process Monitor, you should take into account the different options supported in each
product before you run your test. For details, see:

l "Running GUI Tests from HP Performance Testing Products " below

l "Running GUI Tests from HP Business Process Monitor" on page 2236

Designing Tests for HP Performance Testing Products
Relevant for: GUI tests only

Consider the following guidelines when designing tests for use with performance testing products:

l The tests you use with LoadRunner and Performance Center should be simple, designed to
pinpoint specific operations, and should avoid using external actions and references to other
external files (including resources stored in ALM). Also, when working with action iterations,
correspondingStartTransaction andEndTransaction statements must be contained within the
same action.

l Every test must contain at least one transaction to provide useful information in the performance
test. LoadRunner and Performance Center use only the data that is included within a
transaction, and ignore any data in a test outside of a transaction.

l Do not include references to external actions or other external resources (including resources
stored in ALM), such as an external data table file, environment variable file, shared object
repositories, function libraries, and so forth. This is because LoadRunner or Performance Center
may not have access to the external action or resource.

(However, if the resource can be found on the network, UFT will use it. For example, you can try
defining external resources via an absolute path, or by adding them as supplementary files and
transferring them to LoadGenerator in the GUI test folder.)

l Make sure that the last step(s) in the test closes the application being tested, as well as any
child processes that are running. This enables the next iteration of the test to open the
application again.

For details on working with LoadRunner or Performance Center, see your HP performance testing
documentation.

Running GUI Tests from HP Performance Testing
Products

Relevant for: GUI tests only

Consider the following guidelines when running tests from HP Performance Testing Products:
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l You can run only oneGUI Vuser concurrently per computer. (A GUI Vuser is a Vuser that runs a
GUI test.)

l Ensure that UFT is closed on the UFT computer before running a test in Performance Center or
LoadRunner.

l The settings in the LoadRunner or Performance Center Run-time Settings dialog box are not
relevant for tests.

l You cannot use theResultDir environment variable when running a performance test.

l Transaction breakdown is not supported for tests (scripts) created with UFT.

l UFT cannot run on a computer that is:

n Logged off or locked. In these cases, consider running UFT on a terminal server.

n Already running a test. Make sure that the test is finished before starting to run another test.

Tip: You can simulate how the test will run from a performance testing product by using
Silent Test Runner. For details, see "Silent Test Runner" on page 2239.

Designing GUI Tests for HP Business Process Monitor
Relevant for: GUI tests only

Note: As of Business ServiceManagement 9.0, profiles are no longer used. Instead, Business
Process Monitor uses Business Transaction Flows, which are included in the parent
application's run unit and can be run as part of that unit or independently, as needed.

Consider the following guidelines when designing tests for use with Business Process Monitor:

l The tests you use with Business Process Monitor should be simple, designed to pinpoint
specific operations, and should avoid using external actions and references to other external
files (including resources stored in ALM). Also, when working with action iterations,
correspondingStartTransaction andEndTransaction statements must be contained within the
same action.

l Every test must contain at least one transaction to provide useful information in Business
Process Monitor. Business Process Monitor uses only the data that is included within a
transaction, and ignores any data in a test outside of a transaction.

l Business Process Monitor does not support running tests that require access to external
resources, including resources stored in ALM (such as a shared object repository, function
library, external data table, external actions, and so forth). Tests that require external resources
may fail to run on Business Process Monitor. (However, if the resource can be found on the
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network, UFT will use it.)

l Make sure that the last steps in the test close the application being tested, as well as any child
processes that are running. This cleanup step enables the next test run to open the application
again.

l Whenmeasuring a distributed transaction over two different Business Process Monitor profiles
or Business Transaction Flows (depending on the version), the profile with the
StartDistributedTransaction statement must be run before the profile with the associated
EndDistributedTransaction.

l Whenmeasuring distributed transactions, make sure that you relate the tests to a single
Business Process Monitor instance. Business Process Monitor searches for the end transaction
name in all instances, andmay close the wrong distributed transaction if it is included inmore
than one instance.

l Whenmeasuring a distributed transaction over two Business Process Monitor profiles, make
sure that the timeout value you specify is large enough so that the profile or Business
Transaction Flow (depending on the version) that contains theStartDistributedTransaction
step and all the profiles that run before the profile that contains theEndDistributedTransaction
step, will finish running in a time that is less than the value of the specified timeout.

Running GUI Tests from HP Business Process Monitor
Relevant for: GUI tests only

Consider the following guidelines when running tests from HP Business Process Monitor:

l Before you try to run a test in Business Process Monitor, check which versions of UFT are
supported by your version of Business Process Monitor. For details, see the Business Process
Monitor documentation.

l To run a test in Business Process Monitor, UFT must be installed and closed on the Business
Process Monitor computer

l Business Process Monitor can run only one test at a time. Make sure that the previous UFT run
session is finished before starting to run another test.

l Transaction breakdown is not supported for tests created with UFT.

l Tests must be zipped before uploading them to Business ServiceManagement Admin.

If youmake changes to your local copy of a test after uploading it to Business Service
Management, upload the zipped test again to enable Business Process Monitor to run the test
with your changes.

l UFT cannot run tests on a computer that is logged off, locked, or running UFT as a non-
interactive service.
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l You should start Business Process Monitor by running themagentproc.exe program when
running tests from Business Process Monitor.

l You cannot use theResultDir environment variable when running a test in Business Process
Monitor.

For details on working with Business ServiceManagement, see the relevant documentation—
specifically the sections describing UFT scripts in the Business Process Monitor Administration
guide and the End User Management guide.

Tip: You can simulate how the test will run from Business Process Monitor by using Silent
Test Runner. For details, see "Silent Test Runner" on page 2239.

Measuring Transactions
Relevant for: GUI tests only

You canmeasure how long it takes to run a section of your test by defining transactions. A
transaction represents the process in your application that you are interested in measuring. Your
test must include transactions to be used by LoadRunner, Performance Center, or the Business
Process Monitor. These products use only the data that is included within a transaction, and ignore
any data in a test outside of a transaction.

You define transactions within your test by enclosing the appropriate sections of the test with start
and end transaction statements. For example, you can define a transaction that measures how
long it takes to reserve a seat on a flight and for the confirmation to be displayed on the client's
terminal.

During the run session, theStartTransaction step signals the beginning of the timemeasurement.
The timemeasurement continues until theEndTransaction step is reached. The test results for the
EndTransaction step include the transaction's name, end status, total duration, and wasted time.

During a run session, UFT runs background processes that add to the time it takes to run a test.
Wasted time is the time within the total duration that was added as a result of UFT running the
transaction. If the application ran the transaction without UFT, the total duration would equal the
total durationminus the wasted time.

Note: If you start a transaction while there is already open transaction with the same name, the
previous transaction is ended with Fail status and then the new transaction is started.

There is no limit to the number of transactions that can be added to a test.

Tip:

User Guide
Appendix G: Using Performance Testing and Business ServiceManagement Products with UFT GUI

HP Unified Functional Testing (12.00) Page 2237 of 2274



You can:

l Insert a transaction within a transaction.

l Insert a variety of transaction-related statements using the StepGenerator or Editor. For
details, see theServices section of theHP UFT Object Model Reference for GUI Testing.

l EnterStart Transaction andEnd Transaction steps using UFT. For details, see "Start
Transaction Dialog Box" on page 2243 and "End Transaction Dialog Box" on page 2242.

For details on the statements you can use in transactions, see theHP UFT Object Model
Reference for GUI Testing.

Example of a test with a transaction

Part of a sample test with a transaction is shown below, as it is displayed in the Keyword View:

The same part of the test is displayed in the Editor as follows:

Services.StartTransaction "ReserveSeat"
Browser("Welcome: Mercury Tours").Page("Find a Flight: Mercury"). WebList("fromPort").Select
"London"
Browser("Welcome: Mercury Tours").Page("Find a Flight: Mercury"). WebList("toPort").Select "F
rankfurt"
Browser("Welcome: Mercury Tours").Page("Find a Flight: Mercury"). WebList("toDay").Select "1
2"
Browser("Welcome: Mercury Tours").Page("Find a Flight: Mercury"). WebRadioGroup("servClas
s").Select "Business"
Browser("Welcome: Mercury Tours").Page("Find a Flight: Mercury"). WebList("airline").Select "Bl
ue Skies Airlines"
Browser("Welcome: Mercury Tours").Page("Find a Flight: Mercury"). Image("findFlights").Click 6
5,12
Browser("Welcome: Mercury Tours").Page("Select a Flight: Mercury"). WebRadioGroup("outFlig
ht").Select "Blue Skies Airlines"
Browser("Welcome: Mercury Tours").Page("Select a Flight: Mercury"). WebRadioGroup("inFligh
t").Select "Blue Skies Airlines"
Browser("Welcome: Mercury Tours").Page("Select a Flight: Mercury"). Image
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("reserveFlights").Click 46,8
Services.EndTransaction "ReserveSeat"

Silent Test Runner
Relevant for: GUI tests only

Silent Test Runner enables you to simulate the way a test runs from LoadRunner, Performance
Center, and Business ServiceManagement. When you run a test using Silent Test Runner, it runs
without opening the UFT user interface, and the test runs at the same speed as when it is run from
LoadRunner, Performance Center, or Business ServiceManagement At the end of the test run, you
can view information about the test run and transaction times. For details, see "Test Run
Information for Silent Runs" below.

You can also use Silent Test Runner to verify that your test is compatible with LoadRunner,
Performance Center, and Business ServiceManagement. A test will fail when run using Silent Test
Runner if it uses a feature that is not supported by these products. For details on features that are
not supported, see "Designing Tests for HP Performance Testing Products" on page 2234,
"Running GUI Tests from HP Performance Testing Products " on page 2234, "Designing GUI Tests
for HP Business Process Monitor" on page 2235, and "Running GUI Tests from HP Business
Process Monitor" on page 2236.

Test Run Information for Silent Runs

Silent Test Runner provides test run information in log files. Each test generates a test run log, and
any test with transactions generates an additional transaction summary.

Viewing the Test Run Log
The test run log is saved as output.txt in the <Unified Functional Testing>\Tests\<test name>
folder. A log file is saved for each test run with Silent Test Runner and is overwritten when you rerun
the test. To open the log file, click Test Run Log.

The log file displays information about the test run. For example, information is shown about each
iteration, action call, step transaction, failed step, and so forth. Each line displays amessage or
error ID. For details onmessage and error codes in the log file, see your Performance Center or
Business ServiceManagement documentation.
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Viewing the Transaction Summary
The transaction summary is saved as transactions.txt in the <Unified Functional
Testing>\Tests\<test name> folder. A transaction summary is saved for each test that includes
transactions and is overwritten when you rerun the test. To open the log file, click Transaction
Summary. The transaction summary displays a line for each transaction in the test. For each
transaction, the status is displayed together with the total duration time and any wasted time (in
seconds). The transactionmeasurements in Silent Test Runner are exactly the same as if the test
was run from LoadRunner, Performance Center, or Business ServiceManagement.

Note:

l A transaction summary is available only for a test that contains transactions ending with an
EndTransaction statement. If a transaction started but did not end because of test failure,
it is not included in the transaction summary.

l Distributed transactions (transactions that start in one test and end in another) are not
reported in the transaction summary but are included in the test run log.

l Any transaction information included in the transaction summary is also included in the test
run log.
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Tasks

How to Insert and Run GUI Tests in Performance Center
and LoadRunner

Relevant for: GUI tests only

The following are various tasks that you can perform when working with HP Performance Center
and LoadRunner.

To insert a test in a LoadRunner scenario
In the Controller Open Test dialog box, browse to the test folder and select QuickTest Tests orGUI
Scripts (for tests created in the SAP environment) in the Files of type box. This enables you to
view the tests in the folder.

To use a UFT test in Performance Center
Create a zipped version of the test, and upload it to the Performance Center User Site Vuser
Scripts Page.

To run multiple GUI Vusers on the same application
Open a terminal server session for eachGUI Vuser. For details, refer to the HP performance testing
documentation.

For details on working with LoadRunner or Performance Center, see your HP performance testing
documentation.

HP Unified Functional Testing (12.00) Page 2241 of 2274



Reference

End Transaction Dialog Box
Relevant for: GUI tests only

This dialog box enables you to insert a step that signals the end of the timemeasurement for a
transaction.

To access 1. Open the existing test into which you want to insert a load transaction step.

2. Select the Design > End Transaction.

Important
information

l Theremay be cases in which you want to instruct UFT to perform all the steps
in a transaction, even though an error occurs during the run session.

To do this:

In the Run pane of the Test Settings dialog box (File > Settings > Run node),
select proceed to next step from theWhen error occurs during run
session list.

l You can also create recovery scenarios or other error handling steps to
address these cases. For details, see "Recovery Scenarios for GUI Testing"
on page 1111.

See also l "Measuring Transactions" on page 2237

l "Start Transaction Dialog Box" on the next page
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User interface elements are described below:

UI Elements Description

Name The name of the transaction you want to end.

The list contains the name of all transactions that start prior to the selected step
in the current action.

Insert
Statement

Indicates where theEndTransaction step will be inserted in relation to the
selected step.

Select Before current step orAfter current step.

Start Transaction Dialog Box
Relevant for: GUI tests only

This dialog box enables you to insert a step that signals the beginning of the timemeasurement for
a transaction.

To access 1. Open the existing test into which you want to insert a load transaction step.

2. Select the Design > Start Transactionmenu command.

See also l "Measuring Transactions" on page 2237

l "End Transaction Dialog Box" on the previous page
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User interface elements are described below:

UI
Elements Description

Name The name of the transaction you want to measure.

Note: You cannot include spaces in a transaction name.

Insert
Statement

Indicates where theStartTransaction step will be inserted in relation to the
selected step. You can select Before current step orAfter current step.

Silent Test Runner Dialog Box
Relevant for: GUI tests only

This dialog box enables you to simulate the way a UFT test runs from LoadRunner and Business
ServiceManagement and to verify that your UFT test is compatible with LoadRunner and Business
ServiceManagement.

To access Select theStart > Programs > HP Software > HP Unified Functional Testing
> Tools > Silent Test Runnermenu command.

Note: For details on accessing UFT and UFT tools and files inWindows 8,
see "Accessing UFT inWindows 8Operating Systems" on page 75.

Important
information

l You can invoke only one instance of Silent Test Runner and you can specify
only one test to run.

l You cannot use theResultDir environment variable when running a test from
Silent Test Runner.
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See also l "Silent Test Runner" on page 2239

l "Test Run Information for Silent Runs" on page 2239

User interface elements are described below:

UI
Elements Description

Test The full file system path of the test you want to run.

Note: To specify a network path, youmust map the network drive.

Run Test Runs the test specified in the Test box.

When you click this button, the test runs without opening the UFT user interface.
The text Running test... is displayed next to theRun Test button while the test
is running.

When the test run finishes, the text Running test... is replaced with the text Test
run completed. If Silent Test Runner was unable to run your test, the text Test
could not be run is displayed.

Note: After you start a test run, you cannot stop the test run from Silent Test
Runner. Even if you close Silent Test Runner, the test continues to run. To
end the run, end themdrv.exe process manually.

Test Run
Log

Displays themost recent run log for the selected test. Each time you run a test
with Silent Test Runner, the previous log file is overwritten with the current run
results.

(Enabled only when the selected test has run with the Silent Test Runner at least
once.)

For details, see "Viewing the Test Run Log" on page 2239.

Transaction
Summary

Displays the summary of the transactions in the test.

(Enabled only when the selected test contains at least one transaction and the
test has run with the Silent Test Runner at least once.)

For details, see "Viewing the Transaction Summary" on page 2240.
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Appendix H: Frequently Asked Questions for GUI
Testing

Relevant for: GUI tests and components

This chapter answers some of the questions that are askedmost frequently by advanced users of
UFT. The questions and answers are divided into the following sections:

This chapter includes:

Creating Tests or Components 2247

Programming in the Editor andWorking with Function Libraries 2248

Working with Dynamic Content 2250

AdvancedWeb Issues 2252

StandardWindows Environment 2255

Test and Component Maintenance 2256

Testing Localized Applications 2258

Improving GUI Testing Performance 2258
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Creating Tests or Components
Relevant for: GUI tests and components

This section includes answers to the following questions:

l "How can I record on objects or environments not supported by UFT?" below

l "How can I launch an application from a test or component?" on the next page

l "How does UFT capture user processes inWeb pages?" on the next page

l "Can I insert calls toWinRunner tests and functions from UFT?" on the next page

How can I record on objects or environments not supported by UFT?
You can do this in a number of ways:

l Install and load any of the add-ins that are available for UFT. UFT supports many developmental
environments including Java, Oracle, .NET, SAP Solutions, Siebel, PeopleSoft, and terminal
emulators.

l You canmap objects of an unidentified or custom class to standardWindows classes. For
details on object mapping, see "Test Object Mapping for Unidentified or Custom Classes" on
page 1321.

l You can use the Insight recordingmode. For details, see "Insight Recording" on page 849.

l UFT provides add-in extensibility that you can use to extend UFT built-in support for various
objects. This enables you to direct UFT to recognize an object as belonging to a specific test
object class, and to specify the behavior of the test object. You can also extend the list of
available test object classes that UFT recognizes. This enables you to create tests or
components that fully support the specific behavior of your custom objects.

l For tests and scripted components:

n You can define virtual objects for objects that behave like test objects, and then record in the
normal recordingmode. For details on defining virtual objects, see "Virtual Objects" on page
1384.

n You can record your clicks and keyboard input based on coordinates in the low-level or analog
recordingmodes. For details on low-level and analog recording, see "RecordingModes" on
page 845.
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How can I launch an application from a test or component?
To launch an application from within a test or scripted component:

Add aSystemUtil step, such as:

SystemUtil.Run "D:\My Music\Breathe.mp3","","D:\My Music\Details","open"

ForWindows-based applications, you should also ensure that in theWindows Applications tab of
the Record and Run Settings dialog box, you configure UFT to record and run on applications
opened by UFT.

To launch an application from within a keyword component:

Select Operation from the Item column, select OpenApp from theOperation column, and then
enter the full path in theValue column, for example:

%ProgramFiles%\HP\Unified Functional Testing\samples\flight\app\flight4a.exe

How does UFT capture user processes in Web pages?
UFT hooks theMicrosoft Internet Explorer browser. As the user navigates theWeb-based
application, UFT records the user operations. (For details onmodifying which user operations are
recorded, see the section on configuringWeb event recording in theHP Unified Functional Testing
Add-ins Guide.) UFT can then run the test or component by running the steps as they originally
occurred.

Can I insert calls to WinRunner tests and functions from UFT?
The Insert > Call to WinRunner > Test and Insert > Call to WinRunner > Function
commands are no longer available. You can continue to run existing UFT business process tests
that contain calls toWinRunner tests or components and functions, and you can view run results in
the Run Results Viewer.

Note: Hewlett-Packard (HP) has discontinued HP WinRunner (WR) 7.5, 7.6, 8.0, 8.2, 9.2 (all
editions) and has announced an End-of-Support timeline for these products. For details, see:
http://support.openview.hp.com/encore/wr.jsp?jumpid=reg_R1002_USEN

Programming in the Editor and Working with Function
Libraries

Relevant for: GUI tests and components

This section includes answers to the following questions:

l "Can I store functions and subroutines in a function library?" on the next page

l "How can I enter information during a run session?" on the next page
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l "For tests: I have aMicrosoft Access database that contains data I would like to use inmy test.
How do I do this?" below

l "How do I customize the Run Results?" on the next page

Can I store functions and subroutines in a function library?
You can create one or more VBScript function libraries containing your functions. You can then call
the functions from any test, or use them in any component, by associating them with the test or
with the component's application area. You can use the UFT function library editor to create and
debug your function libraries.

You can also register your functions as methods for UFT test objects. Your registeredmethods can
override the functionality of an existing test object method for the duration of a run session, or you
can register a new method for a test object class.

For more details, see "User-Defined Functions and Function Libraries" on page 1029, and, for
components, "Application Areas" on page 2095.

For tests:You can define functions within an individual action, making them available for use inside
the action. If you save the action as a reusable action, it functions are available in the actions that
call it as well. However, you can help improve UFT performance by storing your functions in
function libraries instead of in reusable actions.

How can I enter information during a run session?
The VBScript InputBox function enables you to display a dialog box that prompts the user for input,
and then continues running the test or component. You can use the value that was entered by the
user later in the run session. For details on the InputBox function, see theVBScript Reference.

For components:You can insert the VBScript InputBox function into an associated function
library to create a user-defined VBScript InputBox function.

For tests: The following example shows the InputBox function used to prompt the user for a
password:

Browser("Mercury Tours").Page("Mercury Tours").WebEdit("username").Set "administrator"
Passwd = InputBox ("Enter password", "User Input")
Browser("Mercury Tours").Page("Mercury Tours").WebEdit("password").Set Passwd

For tests: I have a Microsoft Access database that contains data I would
like to use in my test. How do I do this?
The Editor enables you to access databases using ADO andODBC. Below is a sample test that
searches for books written by an author in the "Authors" table of the database.

Dim MyDB
Dim MyEng
Set MyEng = CreateObject("DAO.DBEngine.35")
Dim Td
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Dim rs
' Specify the database to use.
Set MyDB =MyEng.OpenDatabase("BIBLIO.MDB")
' Read and use the name of the first 10 authors.
Set Td =MyDB.TableDefs("Authors")
Set rs = Td.OpenRecordset
rs.MoveFirst
For i = 1 To 10
    Browser("Book Club").Page("Search Books").WebEdit("Author Name").Set rs("Author")
    Browser("Book Club").Page("Search Books").WebButton("Search").Click
Next

How do I customize the Run Results?
You can add information to the run results by using theReportEventmethod. This adds a step to
the run results containing a free-text message and a step status that can potentially affect the
status of the run session. The step can also include an image, such as a logo, if you specify an
image file path.

For example:

Reporter.ReportEvent 1, "Custom Step", "The user-defined step failed"

Formore details, see theHP UFT Object Model Reference for GUI Testing.

The results of each UFT run session are saved in a single .xml file (called results.xml). You can
modify this file, as needed. You can use theHP RunResults SchemaReference (Help > HP UFT
GUI Testing Advanced References Help > HP Run Results Schema Reference) to help you
customize your run results.

Working with Dynamic Content
Relevant for: GUI tests and components

This section includes answers to the following questions:

l "How can I create and run tests or components on objects that change dynamically from viewing
to viewing?" below

l "How can I check that an object or child object exists (or does not exist)?" on the next page

l "How does UFT record on dynamically generated URLs andWeb pages?" on the next page

l "How does UFT handle tabs in browsers?" on page 2252

How can I create and run tests or components on objects that change
dynamically from viewing to viewing?
Sometimes the content of objects in an application changes due to dynamic content. You can
create dynamic descriptions of these objects so that UFT will recognize them when it runs the test
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or component using regular expressions, theDescription object, repository parameters, or
SetTOProperty steps.

How can I check that an object or child object exists (or does not exist)?
Some objects are created in an application only after you perform an operation. For example, a link
in one window sometimes creates another window. The newly created window may be an
independent object, or a child of the original window.

Before you perform operations on an object created during a run session, youmay want to verify
that the object already exists.

If you have a test object that corresponds to the object in the application, you can use theExist
property to check whether the object exists in the application. TheExist property looks for an object
in the application that matches the test object's description. For example:

If Window("Main").ActiveX("Slider").Exist Then
. . .

Alternatively, you can use theChildObjectsmethod to retrieve all child objects (or the subset of
child objects that match a certain description) on the Desktop or within any other parent object.

Example

Set oDesc = Description.Create
oDesc("Class Name").Value = "Window"
Set coll = Desktop.ChildObjects(oDesc)
For i = 0 to coll.count -1
        msgbox coll(i).GetROProperty("text")
Next

Note:

l After you use theChildObjectsmethod to retrieve an object, UFT accesses the object
directly in the application and does not save a description for the object. Therefore, you
must use the object immediately after retrieving it, before anything in the application
changes.

l TheExist property searches for objects based on their description, and is therefore not
relevant for objects retrieved by theChildObjectsmethod. (TheExist property always
returns true when called for such objects).

For more details on theExist property andChildObjectsmethod, see theHP UFT Object Model
Reference for GUI Testing.

How does UFT record on dynamically generated URLs and Web pages?
UFT actually clicks links as they are displayed on the page. Therefore, UFT records how to find a
particular object, such as a link on the page, rather than the object itself. For example, if the link to a
dynamically generated URL is an image, then UFT records the "IMG" HTML tag, and the name of
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the image. This enables UFT to find this image in the future and click on it.

How does UFT handle tabs in browsers?
UFT provides several methods that you can use with theBrowser test object to manage tabs in
yourWeb browser.

OpenNewTab opens a new tab in the current Web browser.

IsSiblingTab indicates whether a specified tab is a sibling of the current tab object in the same
browser window.

Close closes the current tab if more than one tab exists, and closes the browser window if the
browser contains only one tab.

CloseAllTabs closes all tabs in a browser and closes the browser window.

For more details on theseBrowser-relatedmethods, see theWeb section of theHP UFT Object
Model Reference for GUI Testing.

Advanced Web Issues
Relevant for: GUI tests and components

This section includes answers to the following questions:

l "How does UFT handle cookies? " below

l "Where can I find aWeb page's cookie?" on the next page

l "How does UFT handle session IDs? " on the next page

l "How does UFT handle server redirections? " on the next page

l "How does UFT handlemeta tags? " on the next page

l "Does UFT work with .asp and .jsp?" on the next page

l "How does UFT support AJAX?" on the next page

l "Does UFT work with COM?" on the next page

l "Does UFT work with XML?" on the next page

l "How can I access HTML tags directly?" on page 2254

l "Where can I find information on the Internet Explorer Document Object Model?" on page 2254

l "How can I send keyboard key commands (such as shortcut commands) to objects that do not
support the Typemethod?" on page 2254

How does UFT handle cookies?
Server-side connections, such as CGI scripts, can use cookies both to store and retrieve
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information on the client side of the connection.

UFT stores cookies in thememory for each user, and the browser handles them as it normally
would.

Where can I find a Web page's cookie?
The cookie used by the Internet Explorer browser can be accessed through the browser's
Document Object Model (DOM) using the .Object property (for components, you do this in a user-
defined function). In the following example the cookie collection is returned the from the browser:

Browser("Flight reservations").Page("Flight reservations").Object.Cookie

How does UFT handle session IDs?
The server, not the browser, handles session IDs, usually by a cookie or by embedding the session
ID in all links. This does not affect UFT.

How does UFT handle server redirections?
When the server redirects the client, the client generally does not notice the redirection, and
misdirections generally do not occur. In most cases, the client is redirected to another script on the
server. This additional script produces the HTML code for the subsequent page to be viewed. This
has no effect on UFT or the browser.

How does UFT handle meta tags?
Meta tags do not affect how the page is displayed. Generally, they contain information only about
who created the page, how often it is updated, what the page is about, and which keywords
represent the page's content. Therefore, UFT has no problem handlingmeta tags.

Does UFT work with .asp and .jsp?
Dynamically createdWeb pages utilizing Active Server Page technology have an .asp extension.
Dynamically createdWeb pages utilizing Java Server Page technology have a .jsp extension.
These technologies are completely server-side and have no bearing on UFT.

How does UFT support AJAX?
You can use UFTWeb Add-in Extensibility to add your own support for customWeb controls. The
Web Add-in Extensibility SDK installs a sample toolkit support set that provides partial support for
some ASP .NET AJAX controls. You can use this sample to learn how to create your own support
for your AJAX controls. For more details, see theHP UFTWeb Add-in Extensibility Developer
Guide.

Does UFT work with COM?
UFT complies with the COM standard.

UFT supports COM objects embedded inWeb pages (which are currently accessible only using
Microsoft Internet Explorer), and you can drive COM objects in VBScript.

Does UFT work with XML?
XML is eXtensible Markup Language, a pared-down version of SGML forWeb documents, that
enables Web designers to create their own customized tags. UFT supports XML and recognizes
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XML tags as objects.

For tests and scripted components:You can also create XML checkpoints to check the content
of XML documents inWeb pages, frames or files. UFT also supports XML output and schema
validation.

For more details, see "XMLCheckpoints Overview" on page 1416, and theXMLUtil object in the
Utility Objects section of theHP UFT Object Model Reference for GUI Testing.

How can I access HTML tags directly?
UFT provides direct access to the Internet Explorer's Document Object Model (DOM) through
which you can access the HTML tags directly. Access to the DOM is performed using the .Object
notation.

The function below demonstrates how to iterate over all the tags in an Internet Explorer page. The
function then outputs the inner-text of the tags (the text contained between the tags) to the Run
Results using theReporter object.

' Use the on error option because not all the elements have inner-text.
On Error Resume Next
Set Doc = Browser("CNN Interactive").Page("CNN Interactive").Object
' Loop through all the objects in the page.
For Each Element In Doc.all
    TagName = Element.TagName ' Get the tag name.
    InnerText = Element.innerText ' Get the inner text.
    ' Write the information to the run results.
    Reporter.ReportEvent 0, TagName, InnerText
Next

Where can I find information on the Internet Explorer Document Object
Model?
For details on the Internet Explorer DOM, browse to the followingWeb sites:

Document object:
http://msdn.microsoft.com/en-us/library/ms531073.aspx

Other DHTML objects:
http://msdn.microsoft.com/en-us/library/ms533054.aspx

General DHTML reference:
http://msdn.microsoft.com/en-us/library/ms533050.aspx

How can I send keyboard key commands (such as shortcut commands) to
objects that do not support the Type method?
For objects that do not support the Typemethod, use theWindows ScriptingSendKeysmethod.
For more details, see theMicrosoft VBScript Language Reference (chooseHelp > HP Unified
Functional Testing Help > VBScript Reference > Windows Script Host).
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Standard Windows Environment
Relevant for: GUI tests and components

This section includes the answers to the following questions:

l "How can I record on nonstandardmenus?" below

l "For tests: How can I terminate an application that is not responding?" below

l "For tests: Can I copy and paste to and from the Clipboard during a run session?" below

How can I record on nonstandard menus?
You canmodify how UFT behaves when it records menus. The options that control this behavior
are located in theWindows Applications > AdvancedOptions pane. (Tools > Options > GUI
Testing tab > Windows Applications node > Advanced node).

For more details, see theHP Unified Functional Testing Add-ins Guide.

For tests: How can I terminate an application that is not responding?
You can terminate any standard application while running a test in UFT by adding one of the
following steps to the test:

l SystemUtil.CloseProcessByName "<app.exe>"

l SystemUtil.CloseProcessByWndTitle "<Some Title>"

For tests: Can I copy and paste to and from the Clipboard during a run
session?
You can use the Clipboard object to copy, cut, and paste text during a UFT run session.

The Clipboard object supports the samemethods as the Clipboard object available in Visual Basic,
such as:

l Clear

l GetData

l GetText

l SetData

l SetText

For details on thesemethods, see http://msdn.microsoft.com/en-us/library/ms172962.aspx.

Below is an example of Clipboard object usage:

Set MyClipboard = CreateObject("Mercury.Clipboard")
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MyClipboard.Clear
MyClipboard.SetText "TEST"
MsgBox MyClipboard.GetText

Test and Component Maintenance
Relevant for: GUI tests and components

This section includes answers to the following questions:

l "How do I maintain my test or component whenmy application changes?" below

l "For tests and scripted components: Can I increase or decrease Active Screen information after
I finish recording a test?" on the next page

l "For tests: How can I remove run results files from old tests?" on the next page

How do I maintain my test or component when my application changes?
The way tomaintain a test or component when your application changes depends on how much
your application changes. This is one of themain reasons you should create a small group of tests
or components, rather than one large test or component for your entire application.

For tests:You can also use UFT actions to designmoremodular and efficient tests. Divide your
test into several actions, based on functionality. When your application changes, you canmodify a
specific action, without changing the rest of the test. Whenever possible, insert calls to reusable
actions rather than creating identical pieces of script in several tests. This way, changes to your
original reusable action are automatically applied to all tests calling that action. For more details,
see "Actions in GUI Testing" on page 871.

If you havemany tests, components, and actions that contain the same test objects, it is
recommended to work with shared object repositories so that you can update object information in a
centralized location.

You can use theUpdate Run Mode option to update changed information for checkpoints or the
Active Screen, or to change the set of identification properties used to identify the objects in your
application. For details, see "Update Options Tab (Update Run Dialog Box)" on page 1107.

If there is a discrepancy between the identification property values saved in the object repository
and the object property values in the application, you can use theMaintenance Run Mode to help
correct this. When you run a test or component in Maintenance RunMode, UFT runs your test or
component, and then guides you through the process of updating your steps and object repository
each time it encounters a step it cannot perform due to an object repository discrepancy. For more
details, see "Maintenance RunMode" on page 1080.
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For tests and scripted components: Can I increase or decrease Active
Screen information after I finish recording a test?
If you find that the information saved in the Active Screen after recording is not sufficient, or if you
no longer need Active Screen information, and you want to decrease the size of your test or
component, there are several methods of changing the amount of Active Screen information saved.

l To decrease the disk space used by your test or component, you can delete Active Screen
information by selectingSave As, and clearing theSave Active Screen files check box. For
details, see "Save <Resource>/Save <Document> As Dialog Box" on page 164.

l If you chose not to save all information in the Active Screen when testing aWindows
application, you can use one of several methods to increase the information stored in the Active
Screen.

Confirm that the Active Screen capture preference in theActive Screen pane of the Options
dialog box (Tools > Options > GUI Testing tab > Active Screen node) is set to capture the
amount of information you need and then:

n Perform anUpdate Run Mode operation to save the required amount of information in the
Active Screen for all existing steps. For details on theUpdate Run Mode options, see
"Update Options Tab (Update Run Dialog Box)" on page 1107.

n Re-record the steps containing the objects you want to add to the Active Screen.

To re-record the step, select the step after which you want to record your step, position your
application tomatch the selected location in your test or component, and then begin
recording. Alternatively, place a breakpoint in your test at the step before which you want to
add a step and run your test or component to the breakpoint. This brings your application to
the point from which to record the step. For details on setting breakpoints, see "Breakpoints "
on page 681.

For more details on changing the amount of information saved in the Active Screen forWindows
applications, see "Active Screen Pane (Options Dialog Box > GUI Testing Tab)" on page 547.

For tests: How can I remove run results files from old tests?
You can use the Run Results Deletion Tool to view a list of all of the run results in a specific
location in your file system or in your ALM project. You can then delete any run results that you no
longer require.

The Run Results Deletion Tool enables you to sort the run results by name, date, size, and so forth,
so that you canmore easily identify the results you want to delete.

To open this utility, chooseStart > All Programs > HP Software > HP Unified Functional
Testing > Tools > Run Results Deletion Tool.
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Testing Localized Applications
Relevant for: GUI tests only

I am testing localized versions of a single application, each with localized
user interface strings. How do I create efficient tests in UFT?
You can parameterize these user interface strings using parameters from the global Environment
variable list. This is a list of variables and corresponding values that can be accessed from any test.
For details, see "Parameterizing Object Values" on page 1526.

I am testing localized versions of a single application. How can I efficiently
input different data in my tests, depending on the language of the
application?
If you are running a single iteration of your test, or if you want values to remain constant for all
iterations of an action or test, use environment variables, and then change the active environment
variable file for each test run.

If you are runningmultiple iterations of your test or action, and you want the input data to change in
each iteration, you can create an external data table for each localized version of your application.
When you change the localized version of the application you are testing, you simply switch the
data table file for your test in the Resources pane of the Test Settings dialog box. For details on
working with data tables, see "Data Pane" on page 221. For details on selecting the data table file
for your test, see "Resources Pane (Test/Business Component Settings Dialog Box) " on page
603.

Improving GUI Testing Performance
Relevant for: GUI tests and components

This section includes the answers to the following questions:

l "How can I improve the working speed of UFT when working with GUI testing?" below

l "How can I decrease the disk space used by UFT for GUI tests and components? " on page
2260

l "For tests: Is there a recommended length for tests?" on page 2261

How can I improve the working speed of UFT when working with GUI
testing?
You can improve the working speed of UFT by doing any of the following:

l In the Add-in Manager, load only the add-ins you need for a specific UFT session when UFT
starts. This will improve performance while learning objects and during run sessions. For details
on loading add-ins, see theHP Unified Functional Testing Add-ins Guide.

l Run your tests or components in "fast mode." From the Test Runs pane in the Options dialog
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box (Tools > Options > GUI Testing tab > Test Runs node), select the Fast option. This
instructs UFT to run your test or component without displaying the execution arrow for each
step, enabling the test or component to run faster. For details on the Test Runs pane of the
Options dialog box, see "Test Runs Pane (Options Dialog Box > GUI Testing Tab)" on page 539.

l Decide if and when you want to capture and save images and/or movies of the application for the
run results. You can reduce disk space and improve test run time by saving screen captures and
movie segments only in certain situations, such as when errors occur, or by not saving them at
all. To do this, use theSave still image captures to results andSave movie to results
options in theScreen Capture pane in the Options dialog box (Tools > Options > GUI Testing
tab > Screen Capture node). For details, see "Screen Capture Pane (Options Dialog Box > GUI
Testing Tab)" on page 557.

l If you are using Insight test objects, adjust the number and size of snapshots saved with the test
objects. For details, see "Insight Pane (Options Dialog Box > GUI Testing Tab)" on page 561.

In the object repository, you can delete all of the snapshots stored with the Insight test objects
after you finalize the test object images and verify that they enable correct object identification in
all relevant scenarios. (In the Object Repository window or the Object Repository Manager,
Tools > Delete Insight Snapshots.)

l Save the run results report to a temporary folder to overwrite the results from the previous run
session every time you run a test or component. For more details, see "Run Dialog Box" on page
651.

l For components: Try to use the same application area for all components in a business
process test, as this improves performance.

l For tests:Minimize the number of actions in a test. Ideally, a test should not contain more than
a few dozen actions.

l For tests:Store your functions in function libraries instead of as reusable actions.

l For tests:Use the Results Deletion Tool to remove unwanted or obsolete run results from your
system, according to specific criteria that you define. This enables you to free up valuable disk
space. For details, see the section on the Run Results Deletion Tool (described in theHP Run
Results Viewer User Guide).

l For tests and scripted components: If you are not using the Active Screen while editing your
test, hide the Active Screen while editing your test to improve editing response time by right-
clicking the Active Screen pane and selectingHide. For details, see "UFT at a Glance" on page
77.
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l For tests and scripted components:Decide if and how much information you want to capture
and save in the Active Screen. Themore information you capture, the easier it is to add steps to
your test or component using themany Active Screen options, but more captured information
also leads to slower recording and editing times. You can choose from the following Active
Screen options to improve performance:

n If you are testingWindows applications, you can choose to save all Active Screen
information in every step, save information only in certain steps, or to disable Active Screen
captures entirely. You set this preference in theActive Screen pane of the Options dialog
box. For details, see "Active Screen Pane (Options Dialog Box > GUI Testing Tab)" on page
547.

n If you are testingWeb applications, you can disable screen capture of all steps in the Active
Screen. From theActive Screen pane of the Options dialog box, click Custom Level to open
the Custom Active Screen Capture Settings dialog box.

Select theDisable Active Screen Capture option. This will improve recording time. For
details on the Active Screen pane of the Options dialog box (Tools > Options > GUI
Testing tab > Active Screen node), see "Active Screen Pane (Options Dialog Box > GUI
Testing Tab)" on page 547.

n When you save a new test or component, or when you save a test or component with a new
name usingSave As, you can choose not to save the captured Active Screen files with the
test or component by clearing theSave Active Screen files option in the Save or Save As
dialog box. This is especially useful when you have finished designing your test or component
and you plan to use your it only for run sessions. Tests and components without Active
Screen files openmore quickly and use significantly less disk space.

For details on the Active Screen pane of the Options dialog box, see "Active Screen Pane
(Options Dialog Box > GUI Testing Tab)" on page 547.

Tip: (For tests and scripted components) If you need to recover Active Screen files after
you save a test or component without Active Screen files, re-record the necessary steps or
use theUpdate Run Mode option to recapture screens for all steps. For details, see
"Update Options Tab (Update Run Dialog Box)" on page 1107.

How can I decrease the disk space used by UFT for GUI tests and
components?
You can decrease the disk space used by UFT by doing any of the following:

l Decide if and when you want to capture and save images and/or movies of the application for the
run results. You can reduce disk space and improve test run time by saving screen captures and
movie segments only in certain situations, such as when errors occur, or by not saving them at
all. To do this, use theSave still image captures to results andSave movie to results
options in theScreen Capture pane in the Options dialog box (Tools > Options > GUI Testing
tab > Screen Capture node). For details, see "Screen Capture Pane (Options Dialog Box > GUI
Testing Tab)" on page 557.

User Guide
Appendix H: Frequently AskedQuestions for GUI Testing

HP Unified Functional Testing (12.00) Page 2260 of 2274



l If you are using Insight test objects, adjust the number and size of snapshots saved with the test
objects. For details, see "Insight Pane (Options Dialog Box > GUI Testing Tab)" on page 561.
These settings can also affect UFT performance when recording and running Insight steps.

In the object repository, you can delete all of the snapshots stored with the Insight test objects
after you finalize the test object images and verify that they enable correct object identification in
all relevant scenarios.

l For tests and scripted components: Decide if and how much information you want to capture
and save in the Active Screen. Themore information you capture, the easier it is to add steps to
your test using themany Active Screen options, but more captured information also leads to
slower recording and editing times. You can choose from the following Active Screen options to
improve performance:

n If you are testingWindows applications, you can choose to Save all Active Screen
information in every step, save information only in certain steps, or to disable Active Screen
captures entirely. You set this preference in theActive Screen pane of the Options dialog
box. For details, see "Active Screen Pane (Options Dialog Box > GUI Testing Tab)" on page
547.

n If you are testingWeb applications, you can disable screen capture of all steps in the Active
Screen. From the Active Screen pane, click Custom Level to open the Custom Active
Screen Capture Settings dialog box. Select theDisable Active Screen Capture option. This
will improve recording time. For details on the Active Screen pane of the Options dialog box,
see "Screen Capture Pane (Options Dialog Box > GUI Testing Tab)" on page 557.

n When you save a new test, or when you save a test with a new name using Save As, you can
choose not to save the captured Active Screen files with the test by clearing theSave Active
Screen files option in the Save or Save As dialog box. This is especially useful when you
have finished designing your test and you plan to use your test only for test runs. Tests
without Active Screen files use significantly less disk space.

Tip: (For tests and scripted components) If you need to recover Active Screen files after
you save a test without Active Screen files, re-record the necessary steps or use the
Update Run Mode option to recapture screens for all steps in your test. For details, see
"Update Options Tab (Update Run Dialog Box)" on page 1107.

For tests: Is there a recommended length for tests?
Although there is no formal limit regarding test length, it is recommended that you divide your tests
into actions and that you use reusable actions in tests, whenever possible. An action should
contain nomore than a few hundreds steps and, ideally, nomore than a few dozen. For details, see
"Actions in GUI Testing" on page 871.

Note: See also "Improving the working speed (performance) of UFT" on page 2264
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Appendix I: UFT Troubleshooting and Limitations
Relevant for: GUI tests and components and API testing

This chapter includes:

Troubleshooting and Limitations - UFT ProgramManagement 2263

Troubleshooting and Limitations - Multilingual Applications in GUI Testing 2266

Troubleshooting and Limitations - Operating Systems in GUI Testing 2268

Troubleshooting - Naming Conventions 2269
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Troubleshooting and Limitations - UFT Program
Management

Relevant for: GUI tests and components and API testing

This section describes troubleshooting and limitations for UFT tools and programmanagement, and
covers the following topics:

l "Tools in the HP UFT program group" below

l "Characters do not display correctly" on the next page

l "Improving the working speed (performance) of UFT" on the next page

l "Improving the working speed (performance) of UFT" on the next page

Tools in the HP UFT program group
You cannot use some of the tools from theHP UFT > Tools program group when the UAC (User
Account Control) option in is set to ON. (Relevant for Microsoft Windows Vista, Windows 7,
Windows Server 2008, andWindows Server 2008 R2.)

Workaround: Temporarily turn off the UAC option while using these tools, by doing the following:

For Microsoft Windows Vista and Windows Server 2008:

1. Log in as an administrator.

2. From the Control Panel, select User Accounts > Change Security Settings, and clear the
Use User Account Control (UAC) to help protect your computer check box.

3. Restart the computer to enable this setting to take effect.

4. After working with the desired tool, return to theChange Security Settings screen, and select
theUse User Account Control (UAC) to help protect your computer check box to turn on
UAC again. Restart your computer if necessary.

For Microsoft Windows 7 and Windows Server 2008 R2:

1. Log in as an administrator.

2. From the Control Panel, select User Accounts > User Accounts > Change User Account
Settings.

3. In the User Account Control Settings window, move the slider toNever notify.

4. Restart the computer to enable this setting to take effect.

5. After working with the desired tool, return to the User Account Control Settings window, and
restore the slider to its previous position to turn the UAC option on again.
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For Microsoft Windows 8:

1. Log in as an administrator.

2. From the Control Panel, select User Accounts and Family Safety > User Accounts >
Change User Account Control Settings.

3. In the User Account Control Settings window, move the slider toNever notify.

4. In the Control Panel, select System and Security > Administrative Tools > Local Security
Policy.

5. In the Local Security Policy window, in the left pane, select Local Policies.

6. In the Local Policies tree, select Security Options.

7. In the right pane, select theUser Account Control: Run all administrators in Admin
Approval mode option.

8. Select Action > Properties from themenu bar.

9. In the dialog that opens, select Disabled.

10. Restart the computer for your changes to take effect.

11. After working with the desired tool, return to the User Account Control Settings window, and
restore the slider to its previous position to turn the UAC option on again.

12. Restart the computer for your changes to take effect.

Characters do not display correctly
UFT does not fully support UTF-16 surrogate pairs and combining characters. The Run Results
Viewer and some user interface elements in UFT do not display these characters correctly.

UFT and DEP (Data Execution Prevention)
OnWindows 7 64-bit andWindows Server 2008 R2 operating systems, UFT behaves
unexpectedly when the DEP (Data Execution Prevention) flag is set toAlways On.

Workaround:Switch off the DEP, or modify its settings to beON only for important operating
system processes.

Improving the working speed (performance) of UFT

l If you receive a "running low on UFT resources" error message in theWindows system tray, see
"Windows Notification AreaMessages" on the next page.

l See also "Improving GUI Testing Performance" on page 2258.
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Windows Notification Area Messages
Relevant for: GUI tests and components and API testing

UFT sometimes generates systemmessages in theWindows notification area.

l UFT resources are running low. Close any UFT documents that you do not need or remove
assets from the solution. If this problem continues, restart UFT.

This message displays when UFT consumes toomuchmemory.

To reduce UFTmemory usage and improve performance, you can try one or more of the
following:

n Include fewer items in your solution.

n Open fewer UFT documents simultaneously.

n Create shorter tests. You can do this by dividing your test into smaller tests, with each test
covering fewer scenarios or use cases.

n Verify that the UFT installationmeets all of theminimum system requirements as specified in
theHP Unified Functional Testing Readme.

In addition, to alleviate thememory shortage, close other unneeded applications that are running
on your computer.

If the problem continues, restart UFT.
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Troubleshooting and Limitations - Multilingual
Applications in GUI Testing

Relevant for: GUI tests and components

This section includes general limitations about multilingual issues in UFT:

l Some user interface items are not localized, for example:

n Tooltips in the Properties Pane

n Tooltips and context menu in the editor of the File Content Checkpoint dialog box

n Compilation information in the Output pane for an API Test

n Context menu for the search box in the toolbar of the File Content Checkpoint Properties
dialog box

n Error messages when importing aWSDLWeb service

n The default value string for a Date parameter in the Add Input Parameter dialog box for an API
test

n Warning or error messages in the Test Batch Runner, for example, when saving files using
theSave As command

n Strings displayed when adding a date-type input parameter in the Properties pane of an API
test

n Some of the UFT user interface related to XML operations

n XMLValidation results in the Run Results Viewer

Workaround: Install the relevant user interface language .NET Framework Language Pack.
You can download it from theMicrosoft download center: http://www.microsoft.com/en-
us/download/default.aspx

l The image displayed when selectingView Sample Snapshot in the UFT Asset Comparison
tool is not localized

l UFTmay behave unexpectedly when usingmulti-byte string inputs if it is installed on a VMware
operating system.

Workaround:Set the hardware acceleration of the display driver toNone. If this does not work,
uninstall the VMware display adapter.
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l Manually editing scripts in the Editor using the Korean language onWindows XP orWindows
2003 operating systems may cause UFT tomalfunction.

Workaround:Select Control Panel > Regional and Language Options > Languages tab >
Details > Advanced tab and select the Turn off advanced text services check box.

Youmay need to restart your computer after setting this option.

l Theremay be cases during a run session when UFT loses the focus of the application you are
testing when working in a Korean, Chinese, or Japanese operating system. This may result in a
loss of data during the run session.

Workaround:Run anActivatemethod on the application's window to ensure focus on the
window before performing the next step. For example:

Window("Notepad").Activate

l When using Chinese IME to recordmultiline objects:

n Somemouse operations on the IME are recorded and are not executed during the run
session.

Workaround:Avoid performingmouse operations on the IME window while recording.

n Selecting a character from the IME Candidate window is not supported.

l Running the Typemethod on computers with Japanese, Korean, or Chinese operating systems
may not work as expected.

Workaround:Add an English input locale to the computer (using theRegional Options or
Regional and Language Options in your Control Panel).

Additional product-area specific limitations are described in the chapters that describe the relevant
functionality.
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Troubleshooting and Limitations - Operating Systems
in GUI Testing

Relevant for: GUI tests and components

Some operating systems have specific characteristics that affect the normal behavior of UFT
functionality. These issues are described in the chapters that describe that functionality. The table
below groups these issues by operating system so that you can find all issues that are specific to
the operating system you use.

Operating System Affected Functionality

Windows 7 Recording tests and components

Using UFT tools from theWindows Start menu

Exporting run results (in theHP RunResults
Viewer User Guide)

Opening and saving tests

DEP (Data Execution Prevention) - 64-bit only

Windows 8 Accessing inWindows 8Operating Systems

Windows Server 2008 R2 Recording tests and components

Exporting data tables

Exporting run results (in theHP RunResults
Viewer User Guide)

Using UFT tools from theWindows Start menu

DEP (Data Execution Prevention) - see
HP Unified Functional Testing Installation Guide
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Troubleshooting - Naming Conventions
Relevant for: GUI tests and components and API testing

The following table lists the restrictions to consider when naming items in UFT:

Item Naming Convention

Action
(for tests)

l Must be unique in the test.

l Cannot begin or end with a space.

l Cannot contain the following characters: \ / : * ? " < > | % ' ! { }

Action parameter
(for tests)

l Case-sensitive.

l Must begin with a letter

l Cannot contain spaces.

l Cannot contain the following characters: ! @ # $ % ^ & * ( ) + = [ ] \
{ } | ; ' : " , . / < >

Application area
(for components)

l Cannot exceed 220 characters (including the path).

l Cannot contain, begin, or end with spaces.

l Cannot contain the following characters: \ / : " ? < > | * ! { } ' % ; ,

l Cannot contain multibyte punctuation symbols and other multibyte
special characters, such as multibyte questionmarks, multibyte
spaces, andmultibyte brackets.

Checkpoint l Cannot begin or end with a space.

l Cannot contain " (double quotationmark).

l Cannot contain the following character combinations:

n :=

n @@
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Item Naming Convention

Component
(for components)

l Cannot exceed 220 characters (including the path).

l Cannot contain, begin, or end with spaces.

l Cannot contain the following characters: \ / : " ? < > | * ! { } ' % ;

l Cannot contain multibyte punctuation symbols and other multibyte
special characters, such as multibyte questionmarks, multibyte
spaces, andmultibyte brackets.

Data Table file
(for tests and
scripted
components)

ALM: cannot contain the following characters: ! % * { } \ | ' : " / < > ? ; ,

Data Table >
Parameter name
(column header)

(for tests and
scripted
components)

l Must be unique in the sheet.

l Must begin with a letter or underscore.

l Can only contain the following:

n Letters (excluding special characters, machine-dependent
characters, or platform-dependent characters)

n Numbers

n Periods

n Underscores

Environment
variable
(parameter)

l Must begin with a letter.

l Can only contain the following:

n Letters

n Numbers

n Underscores

Environment
variables file

File system:Cannot contain the following characters: ! % * { } \ | ' : " / <
> ? ;

ALM:Cannot contain the following characters: ! % * { } \ | ' : " / < > ? ; ,
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Item Naming Convention

Function library
file

File system:Cannot contain the following characters: ! % * { } \ | ' : " / <
> ? ;

ALM:

l Cannot contain the following characters: ! % * { } \ | ' : " / < > ? ; ,

l Cannot contain non-English characters

Function /
Function argument

l Cannot contain non-English letters or characters.

l Function names cannot be the same as a VBScript registered
keyword.

l Must begin with a letter.

l Cannot contain spaces or any of the following characters: ! @ # $ % ^
& * ( ) + = [ ] \ { } | ; ' : "" , / < > ?

Object repository
file

File system:Cannot contain the following characters: ! % * { } \ | ' : " / <
> ? ;

ALM:Cannot contain the following characters: ! % * { } \ | ' : " / < > ? ; ,

Output value l Cannot begin or end with a space.

l Cannot contain " (double quotationmark).

l Cannot contain the following character combinations:

n :=

n @@

ALM file or folder
name

l Cannot exceed 90 characters (including the path).

l Cannot begin or end with a space.

l Cannot contain the following characters: \ : * ? " < > | % ' ;

l Cannot contain multibyte punctuation symbols and other multibyte
special characters, such as multibyte questionmarks, multibyte
spaces, andmultibyte brackets.

Recovery Scenario File system:Cannot contain the following characters: ! % * { } \ | ' : " / <
> ? ;

ALM:Cannot contain the following characters: ! % * { } \ | ' : " / < > ? ; ,
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Item Naming Convention

Test name
(for tests)

l Cannot exceed 220 characters (including the path).

Note:When you create a test and store it in the file system, UFT
creates a folder with the name you specify, and also a file with the
same name inside that folder. The name of this file, including its
path, cannot exceed 220 characters.

l Cannot begin or end with a space.

l Cannot contain the following characters: \ / : * ? " < > | % ' ;

l Cannot contain multibyte punctuation symbols and other multibyte
special characters, such as multibyte questionmarks, multibyte
spaces, andmultibyte brackets.

Test resources
(when saving a
test with
resources)

The path name (resource name and file path together) cannot exceed 256
characters.

Test object class
(extensibility only)

l Cannot contain non-English letters or characters.

l Cannot contain spaces or any of the following characters: ! @ # $ % ^
& * ( ) + = - [ ] \ { } | ; ' : "" , / < > ?

Test object name l must be unique within the same class and hierarchy in the object
repository

l Cannot begin or end with a space.

l Cannot contain " (double quotationmark).

l Cannot contain the following character combinations:

n :=

n @@

Test object
identification
properties

l Cannot contain non-English letters or characters.

l Cannot contain spaces or any of the following characters: ! @ # $ % ^
& * ( ) + = [ ] \ { } | ; ' : "" , / < > ?

Test object
method /
Test object
method argument

l Cannot contain non-English letters or characters.

l Cannot contain spaces or any of the following characters: ! @ # $ % ^
& * ( ) + = [ ] \ { } | ; ' : "" , / < > ?
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We appreciate your feedback!
If you have comments about this document, you can contact the documentation team by email. If
an email client is configured on this system, click the link above and an email window opens with
the following information in the subject line:

Feedback on User Guide (Unified Functional Testing 12.00)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client,
and send your feedback to sw-doc@hp.com.
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